ZuluGaz

Добро пожаловать

Благодарим вас за использование наших продуктов!

Настоящее руководство предназначено для инженерно-технического персонала, выполняющего расчеты систем газоснабжения с использованием программы ZuluGaz.

Пользуясь данным руководством пользователь может самостоятельно освоить систему, в конце многих разделов приведены практические примеры, которые полезно проработать для усвоения материала. Помимо этого на сайте можно ознакомится с видео уроками, которые так же будут полезны для быстрого и успешного освоения системы (Страница видео уроков).

Руководство по работе с геоинформационной системой содержит более подробнее описание многих основных функций: Руководство пользователя ZuluGIS

Данная версия справочной системы от 25-06-2025


Введение

Назначение документа

Настоящее руководство предназначено для инженерно-технического персонала, выполняющего расчеты систем газоснабжения с использованием программы ZuluGaz 2021. При написании данного справочного руководства предполагалось, что пользователь знает о форматах хранения графической информации в ЭВМ, а также владеет понятием реляционная база данных. В руководстве подробно описываются основные функции ZuluGaz, а также основные расчетные зависимости.

В связи с тем, что ZuluGaz постоянно совершенствуется, данное описание может быть неполным или в отдельных пунктах расходиться с тем, что пользователь видит на экране. В этом случае рекомендуем Вам просматривать справку по выбранной команде непосредственно в системе, для этого надо нажать кнопку Справка выбранного диалога или в меню ? выбрать пункт Справка.


Общие сведения о программе

Наименование и обозначение программы − программно-расчетный комплекс для систем газоснабжения ZuluGaz.

Средством разработки ZuluGIS является Microsoft Visual C++™.

Программно-расчетный комплекс ZuluGaz предназначен для расчета стационарного режима работы тупиковой и кольцевой газовой сети с одним или несколькими ГРС, ГРП.

Расчет газопроводов низкого, среднего и высокого давления может производиться как для одного вида газа, так и для смеси газов с использованием двух методик:

  • С учетом температуры газа принятой для нормальных условий в соответствии с СП 42-101-2003;

  • С учетом температуры газа, отличающейся от нормальных условий.

В результате расчетов определяется потокораспределение в газовой сети, давление и плотность газа во всех узловых точках, нарушение режима работы потребителей.

Расчеты работают в тесной интеграции с геоинформационной системой и выполнены в виде модуля расширения геоинформационной системы ZuluGIS. Сеть весьма просто и быстро заноситься в ZuluGIS с помощью мышки или по координатам. При этом сразу формируется расчетная модель. Остается лишь задать расчетные параметры объектов и нажать кнопку выполнения расчета.


Описание основных характеристик и особенностей

Система обладает широкими возможностями

  • Проводить технологические расчеты инженерных коммуникаций;

  • создавать и использовать библиотеку графических образов элементов систем газоснабжения и режимов их функционирования;

  • создавать расчетные схемы инженерных коммуникаций с автоматическим формированием топологии сети и соответствующих баз данных;

  • создавать входные и выходные формы представления информации;

  • изменять топологию сетей и режимы работы ее элементов;

  • решать различные топологические задачи.

Ограничение области применения

  • Только для расчета наружных газопроводных сетей: согласно СП 42-101-2003 и СТО ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2-1-2013, которые описывают расчеты распределительных газопроводных сетей с давлением до 1,2 МПа и до 2.5 МПа соответственно.

  • ограничивается стандартным набором элементов системы газоснабжения.


Взаимодействие с другими программами

Объектная модель ZuluGIS открыта для расширения приложениями пользователя через механизм COM. ZuluGIS предоставляет возможность использовать и расширять свою функциональность двумя способами - это написание модулей расширения системы (plug-ins) или использование ActiveX компонентов в своих готовых приложениях.

Создание модулей расширения системы (plug-ins)

ZuluGIS позволяет расширять свою функциональность путем подключения к системе дополнительных модулей - plug-ins. Модули расширения создаются в виде ActiveX DLL c использованием любой среды разработки, позволяющей их создавать (Visual C++™, Visual Basic™, Delphi™, C++ Builder™ и т.д.).

Модуль пользователя через механизм COM получает:

  • доступ к объектам и событиям системы;

  • возможность отрисовки своей информации в окнах системы;

  • возможность внедрять в систему свои меню, кнопки, разделы в строке состояния и т.д.

ZuluNetTools

ZuluNetTools - библиотека ActiveX компонентов. Предоставляет возможность разработчикам программного обеспечения включать в свои приложения гидравлические расчеты тепловых, водопроводных, паровых и газовых сетей, реализованные в расчетных модулях ZuluThermo , ZuluHydro , ZuluSteam и ZuluGaz , в средах разработки приложений, поддерживающих модель COM (Microsoft Visual C++, Microsoft Visual Basic, Borland Delphi, Borland C++Builder и т.д.)

Основные возможности

  • программное задание топологической модели инженерной сети;

  • программное задание исходных данных для расчетов;

  • подключение инженерных сетей в формате ZuluGIS;

  • запуск расчетов тепловых сетей ZuluThermo;

  • запуск расчетов водопроводных сетей ZuluHydro;

  • запуск расчетов паровых сетей ZuluSteam;

  • запуск расчетов газовых сетей ZuluGaz;

  • программное чтение результатов расчетов и кодов ошибок;

  • вывод протокола расчетов и списка ошибок;

  • построение графиков падения давления.

Более подробная информация доступна на сайте разработчиков https://www.politerm.com/products/devtools/zulunettools/.

Экспорт и импорт

ZuluGaz на основе ГИС позволяет экспортировать информацию в следующие обменные форматы:

  • DXF;

  • MIF/MID;

  • BMP;

  • Shape SHP;

  • MS Excel (xls);

  • Html.

А также импортировать информацию из форматов:

  • DXF;

  • MIF/MID;

  • Shape SHP;

  • Metafile WMF;

  • GPS eXchange format GPX;

  • OziExplorer PLT;

  • KML, KMZ.

Более подробную информацию о импорте и экспорте можно прочитать в справочной системе по ZuluGIS (https://www.politerm.com/zuludoc/export_import.htm).


Сведения о технических средствах и операционных системах

Поддерживаемые операционные системы:

  • Windows 10, Windows 7, Windows 8, Windows 8.1, Windows Vista Service Pack 2, Windows XP Service Pack 3.

  • Windows Server 2008 Service Pack 2, Windows Server 2008R2 SP1, Windows Server 2012, Windows Server 2012R2, Windows Server 2016.

Требования к оборудованию:

  • Процессор: 1.6 ГГц и выше.

  • Память: 2 ГБ и выше.

  • Диск: 1,5 Гб свободного места на жестком диске

  • Видеоадаптер: для ОС Windows с поддержкой разрешения 1024 x 768 и полноцветного режима True Color (рекомендуется видеокарта, совместимая с DirectX 9 и выше)


Возможности системы

Программный комплекс ZuluGaz позволяет рассчитывать газопроводную сеть большого объема и любой сложности. Основой программного комплекса ZuluGaz является географическая информационная система ZuluGIS. ГИС позволяет создать карту города (населенного пункта) и нанести на неё любые инженерные коммуникации. Состав газовой смеси может задаваться пользователем и это может быть не только природный газ, но и обычный воздух.

Состав расчетов

  • Поверочный расчет газовой сети среднего, высокого или низкого давления.

  • Конструкторский расчет газовой сети.

  • Построение графика падения давления в газовой сети.

  • Экспорт продольного профиля в DXF.

  • Построение ортогональной технологической схемы.

  • Коммутационные задачи.

Поверочный расчет газопроводной сети

Целью поверочного расчета является определение расчетных расходов газа на участках газовой сети, давления во всех узловых точках и нарушения режима работы потребителей.

Созданная математическая имитационная модель системы газоснабжения, служащая для решения поверочной задачи, позволяет анализировать гидравлический режим работы системы, а также прогнозировать его изменения в случае каких-либо переключений. Расчеты могут проводиться при различных исходных данных, в том числе при отключении отдельных участков газовой сети.

Расчет систем газоснабжения может производиться с использованием следующих методик (можно выбрать в настройках расчета):

  • При нормальных условиях работы по методическим рекомендациям СП 42-101-2003.

  • По СП 42-101-2003 c учетом температуры газа, отличающейся от нормальных условий.

  • По методике СТО ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2-1-2013 ПРОЦЕССЫ «Процесс работы с данными. Определение пропускной способности, расчет свободных мощностей газопроводов».

Конструкторский расчет газопроводной сети

Целью конструкторского расчета газопроводной сети является определение диаметров трубопроводов обеспечивающих пропуск расчетных расходов газа при обеспечении заданных напоров на потребителях.

Под расчетным режимом работы сети понимают такие возможные сочетания отбора газа, при которых имеют место наибольшие нагрузки для отдельных сооружений системы, в частности газопроводной сети.

Расчету подлежат тупиковые и кольцевые газопроводные сети, работающие от одного или от нескольких источников. Возможен расчёт сети с учетом существующих диаметров.

График падения давления

Целью построения графика падения давления по заданному направлению является наглядная иллюстрация результатов гидравлического расчета газовой сети.

Для построения графика выбирается направление, указываемое флажками и цветом линии, и запускается задача построения графика.

На экран выводятся окно с графиком падения давления газа в трубопроводе:

Пример графика падения давления

Рисунок 1. Пример графика падения давления

Цвет и стиль линий падения давления задается пользователем.

В таблице под графиком выводятся для каждого узла сети наименование, геодезическая отметка, высота потребителя, напоры в трубопроводах, потери напора по участкам сети и другие. Количество выводимой под графиком информации настраивается пользователем.

Экспорт продольного профиля в DXF

Продольный профиль газовой сети можно экспортировать в DXF формат (для дальнейшего оформления в Компас, AutoCAD и других САПР).

Профиль строится на основании высотной информации, а таблица профиля заполняется автоматически - на основании данных из базы данных и изображения объектов на карте. Информация о геодезических отметках объектов сети указывается пользователем или может быть автоматически считана со слоя рельефа.

На продольном профиле могут отображаться дополнительные объекты газовой сети: характерные точки, пикеты и пересечения с другими коммуникациями. Эти объекты изображаются пользователем "поверх" газовой сети, а при построении профиля привязываются в заданном радиусе.

[Примечание] Примечание

Пикеты могут быть автоматически расставлены с заданным шагом вдоль указанного пользователем маршрута.

Внешний вид профиля: вертикальный и горизонтальные масштабы, формат листа, ширина колодцев, вес линий и высота текста настраиваются пользователем при экспорте.

Фрагмент продольного профиля в DXF

Рисунок 2. Фрагмент продольного профиля в DXF

Технологическая схема

ZuluGaz 2021 позволяет создать технологическую ортогональную схему, по принципам описанным в ГОСТ Р 70107-2022 " Системы газораспределительные. Сети газораспределения. Общие требования к графическому отображению объектов сетей газораспределения".

Построение технологической схемы происходит на основе существующего слоя газовой сети, с наследованием ID (Sys) и атрибутов исходной газовой сети (базами данных). Схема создается без системы координат (план-схема локальный датум). Пользователь указывает для какой газовой сети (от какого регулирующего устройства) будет происходить экспорт газовой сети.

В результате преобразования и экспорта в новом слое объекты технологической схемы автоматически располагаются, соблюдая принцип ортогональности, то есть с углом поворота, кратным 90°. При этом ориентация осей газопроводов по сторонам света может не соответствовать фактическому, так как для технологических схем сетей газораспределения привязка к плану населенного пункта не требуется.

Исходный слой газовой сети

Рисунок 3. Исходный слой газовой сети

Результат преобразования представлен на картинке далее. Слой был преобразован с сохранением исходных топологических связей, баз данных и данных.

Результат экспорта слоя в ортогональную технологическую схему

Рисунок 4. Результат экспорта слоя в ортогональную технологическую схему

Коммутационные задачи

Коммутационные задачи предназначены для решения следующих задач:

  1. Анализ переключений

    Целью анализа переключений является поиск ближайшей запорной арматуры, позволяющей отключить (изолировать), указанный пользователем объект (участок, потребитель и т.д.) от сети. В результате:

    • выводится перечень запорных устройств;

    • формируется список объектов, попавших под отключения, с последующей возможностью их печати, экспорта в таблицу Microsoft Excel;

    • на карте в виде тематической раскраски отображаются отключенные объекты сети и здания;

    • определяются итоговые значения: расход газа на продувку, заполнение и настройку газового оборудования.

  2. Поиск в слое подложке:

    Целью является поиск в слое подложке (обычно слой здания) объектов, местоположение которых совпадает с местоположением потребителей в слое сети. В результате здания, содержащие потребителя выводятся в отчёт, а также выделяются на карте цветом, в зависимости от состояния потребителя (включен\отключен).

Объекты выбранного слоя подложки будут раскрашены в зависимости от состояния потребителя изображенного на этом объекте, например, здания будут окрашены под выключенными потребителями:

Отображение отключений на тематической раскраске

Рисунок 5. Отображение отключений на тематической раскраске


Ограничение использования и лицензия

Все наши программные продукты имеют ознакомительный режим. Демо-версия позволяет ознакомиться основными функциями и возможностями программного обеспечения. Она представляют из себя полную версию продукта с небольшими количественными ограничениями.

[Предупреждение] Предупреждение

Демонстрационная версия программного обеспечения не может использоваться для решения коммерческих задач. Использование программного обеспечения в коммерческих целях возможно только при получении лицензии.

Лицензирование программных продуктов осуществляется с использованием ключа аппаратной защиты Hasp. Без доступа к ключу все продукты работают в демонстрационном режиме.

Лицензия определяет возможное количество одновременных выполняемых расчетов.

Расчёты ZuluGaz имеют собственные ограничения демонстрационного режима. Полный список ограничений доступен на официальном сайте.

Задача | Ограничение
Поверочный расчет | Суммарное количество потребителей и обобщенных потребителей в рассчитываемой подсети не должно превышать 10.
Конструкторский расчет
Аварийный выброс
Остаточный запас
Расчет резерва сети | Количество участков не должно превышать 10
График падения давления | Количество узлов в выбранном пути не должно превышать 15.
Технологическая схема | Количество узлов в выбранной сети (подсети) не должно превышать 50.
Коммутационные задачи (отчёт) | Полный результат анализа сети выводится при количестве элементов сети не большем 100.
Экспорт продольного профиля в AutoCAD/DXF | Количество объектов не должно превышать 10.


Элементы модели газопроводной сети

Введение

Данный раздел посвящен описанию объектов, необходимых для построения математической модели газопроводной сети.

Математическая модель сети для проведения гидравлических расчетов представляет собой граф, где дугами являются участки газопровода, а узлами точечные объекты инженерной сети: регулирующие устройства, задвижки, колодцы, потребители.

После создания слоя газопроводной сети автоматически появляется структура этого слоя, то есть набор объектов сети с подключенными к ним базами данных (как создать слой газопроводной сети можно узнать в разделе «Создание слоя газопроводной сети»). Причем все символы можно отредактировать и даже создать новые. Пример настройки объектов газопровода устанавливается вместе системой, запустить его можно через меню Пуск: ZuluGIS 2021/Газоснабжение/Пример структуры газовой сети.

Следует понимать, что расчетный модуль ZuluGaz может использовать при расчете только ту информацию, которая предусмотрена разработчиками. Поэтому каждому объекту в структуре слоя должен соответствовать определенный ID - идентификатор типа (порядковый номер каждого объекта в структуре слоя, с помощью которого программа распознает объекты), а также определенный графический тип (объект может иметь символьный, линейный или площадной графический тип).

Далее описаны элементы математической модели газопроводной сети.


Регулирующее устройство

Условное обозначение:

ГРС

ГРП
ШРП

Графический тип объекта - символьный, относится к объектам инженерных сетей и классифицируется как узел.

[Внимание] Внимание

При нанесении регулирующего устройства важно учитывать, следующие правила:

  1. из регулятора должен выходить только один участок;

  2. направление участка должно выходить из регулятора.

Неправильное и правильное изображение регулирующего устройства

Рисунок 6. Неправильное и правильное изображение регулирующего устройства

Уникальный номер (ID) в структуре слоя газопроводной сети – ID 6.


Потребитель

Потребитель - это узловой объект сети, характеризуется расходом газа и минимальным (максимальным) давлением на входе.

Условное обозначение потребителя:

включен

Потребитель может быть задан несколькими способами:

  1. Сосредоточенный потребитель

    В качестве расхода указывается Максимальный расчетный часовой расход газа Qhd, м3/ч.

  2. Жилой дом

    Согласно СП 42-101-2003 для отдельных жилых домов и общественных зданий расчетный часовой расход газа Qhd, м3/ч, следует определять по сумме номинальных расходов газа газовыми приборами с учетом коэффициента одновременности.

[Подсказка] Подсказка

Подробнее о типах потребителя можно узнать в разделе «Расход в зависимости от типа потребителя».

Помимо сосредоточенных потребителей, возможно задать путевые расходы на участках газовой сети. Путевой расход включает в себя мелких потребителей и ответвления. Расчет будет выполняться даже если заданы только путевые расходы. Если и путевых расходов не указано, везде будет одинаковое давление.

Графический тип объекта - символьный, относится к объектам инженерных сетей и классифицируется как потребитель.

Уникальный номер (ID) в структуре слоя газопроводной сети – ID 3.


Колодец на газопроводе

Колодец - это узловой объект сети, характеризуется геодезической отметкой. Служит для соединения участков газовой сети. Может иметь различные варианты отображения (режимы), например, разветвление, врезка, смена вида прокладки.

Условное обозначение:

колодец на газопроводе

Графический тип объекта - символьный, относится к объектам инженерных сетей и классифицируется как узел.

Уникальный номер (ID) в структуре слоя газопроводной сети – ID 4.


Участок

Участок — это линейный объект газовой сети.

Условное обозначение участка в зависимости от режима работы:

[Внимание] Внимание

Для типового объекта Участок вы можете добавлять новые режимы работы, но только парами: то есть Включен-Отключен, Включен (магистраль)-Отключен (магистраль) и так далее. Подробнее смотрите раздел «Правила добавления режимов».

Включен

Отключен

Расчетный участок газопровода – это линейный объект (участок), в пределах которого нет изменения расхода газа, давления, диаметра, вида прокладки.

[Подсказка] Подсказка

Для выполнения расчётов на участке возможно указать путевой расход газа.

Для задания опусков, подъемов, переходов служит отдельный символьный элемент «Вертикальный участок».

[Примечание] Примечание

Участок как тип инженерной сети может выступать в качестве отсекающего устройства. То есть, его можно использовать для отключения объектов.

Графический тип объекта - линейный, относится к объектам инженерных сетей и классифицируется как участок, отсекающий.

Уникальный номер (ID) в структуре слоя газопроводной сети – ID 2.


Начало и конец участка

Участок обязательно должен начинаться и заканчиваться одним из типовых узлов (объектом сети).

Условия завершения участка:

  • разветвление − меняется расход;

  • изменение диаметра − меняется сопротивление;

  • установка на участке какого-либо оборудования.

Кроме того, пользователь может разбить трубопровод на разные участки в любом месте по своему желанию даже там, где гидравлические свойства трубопровода не меняются. Например, трубопровод может быть разделен на участки узлом, разграничивающим балансовую принадлежность.


Направление

На изображенных участках появляется стрелка, указывающая направление, заданное при его вводе (рисовании) от начального узла к конечному. Направление движения газа в трубопроводе можно узнать, только после выполнения гидравлического расчета.

[Примечание] Примечание

Отображение направления движения может быть отключено, для его включения следует:

  1. Выбрать команду главного меню Карта|Настройка слоя.

  2. В открывшемся окне Загруженные слои выбрать слой сети.

  3. Включить опцию Показ направлений.

Как изменить направление участка можно узнать в разделе «Смена направления участка газопроводной сети».


Задвижка

Задвижка – это символьный объект газопроводной сети, являющийся отсекающим устройством.

Условное обозначение запорно-регулирующего устройства:

открыта

Графический тип объекта- символьный, относится к объектам инженерных сетей и классифицируется как отсекающее устройство.

Уникальный номер (ID) в структуре слоя газопроводной сети – ID 7.


Вертикальный участок

Вертикальный участок — это символьный объект газопроводной сети, являющийся вертикальным участком, для задания опусков, подъемов, переходов. Вертикальный участок изображается как узловой объект.

Условное обозначение вертикального участка:

вертикальный участок

В качестве исходных данных указывается геодезические отметки начала и конца участка. Данный объект использует по-умолчанию базу данных Участок. «Участок»

Если слой был создан в версиях ниже 7.0, то тип вертикальный участок в структуре слоя отсутствует. Добавить его в структуру слоя можно самостоятельно, для этого необходимо выполнить несколько шагов: «Добавление вертикального участка»

Уникальный номер (ID) в структуре слоя газопроводной сети – ID 8.


Добавление вертикального участка

Шаг 1. Добавить элемент вертикальный участок в структуру слоя:

  1. Войти в структуру слоя газовой сети.

  2. Создать новый тип объектов, с произвольным названием, например Вертикальный. Графический тип символьный/ объект инженерной сети/ отсекающее устройство или узел .«Создание нового типа объектов»

    [Внимание] Внимание

    Если элемент будет создан как узел, он не будет иметь состояние отключен, соответственно если как отсекающее устройство, то будет.

  3. Подключить к типовому объекту Вертикальный базу данных по участкам.

    Создание типа Вертикальный

    Рисунок 7. Создание типа Вертикальный

  4. Создать необходимое количество режимов. Для каждого режима разработать соответствующий символ, настроить его масштаб и параметры отображения «Пример создания режима для уже существующего типа «Узел»».

    Создание режима Включен

    Рисунок 8. Создание режима Включен

Шаг 2. Подготовить базу данных по участкам:

Вертикальный участок имеет тот же самый набор полей, что и горизонтальный, но дополнительно характеризуется геодезической отметкой начала и конца участка. Данный поля потребуется добавить в структуру таблицы, подключенной к участкам.

  1. Открыть окно информации (i) по участку газовой сети.

  2. Щелчком правой кнопки мыши вызвать контекстное меню и выбрать пункт Добавить поле. Указать имя поля, к примеру "Zgeo", пользовательское название "Геодезическая отметка начала" и тип поля Вещественное. Аналогичным способом добавить поле "Геодезическая отметка конца".

    [Внимание] Внимание

    При необходимости окно представления информации можно настроить в структуре слоя. https://www.politerm.com/zuludoc80/webhelp/index.html#zb_query_create.htm .

    Добавление поля Геодезическая отметка начала

    Рисунок 9. Добавление поля Геодезическая отметка начала

Шаг 3. Подключить тип Вертикальный участок в настойках расчетного модуля ZuluGaz:

Осталось установить связь между объектами и таблицами слоя пользователя с объектами и таблицами расчетного модуля (расчетная модель)

  1. Открыть окно настроек данных расчетной модели ZuluGaz. Для этого, выберите меню Задачи|ZuluGaz, в открывшемся диалоге выберите слой газопроводной сети. Нажмите кнопку Настройки и выберите вкладку Данные.

  2. Встаньте на позицию Вертикальный участок и нажмите кнопку Добавить объект, укажите типовой объект вертикальный участок.

    Подключение типа Вертикальный

    Рисунок 10. Подключение типа Вертикальный

  3. Установите соответствия между всеми объектами расчетной модели и таблицами слоя. Для этого необходимо встать на тип Вертикальный и нажать кнопку Поля.

    Соответствие полей слоя и расчетной модели

    Рисунок 11. Соответствие полей слоя и расчетной модели

    [Внимание] Внимание

    Подробное описание данного этапа «Настройка объектов слоя и данных».


Обратный клапан

Обратный клапан — это символьный объект газовой сети, пропускающий газ по трубопроводу только в одном направлении и автоматически закрывающийся при перемене направления потока.

Условное обозначение обратного клапана:

обратный клапан

Изображение на схеме

В обратный клапан должен входить один участок и выходить один участок. Направление участков задает состояние обратного клапана, в котором он открыт.

Исходные данные

В качестве исходных данных указывается геодезическая отметка. Данный объект использует по-умолчанию базу данных Обратный клапан.

Как добавить тип, если его нету в слое

Если слой был создан в версиях ниже 10.0.0.8438 (дата релиза — 06.02.2023) , то тип Обратный клапан в структуре слоя отсутствует. Добавить его в структуру слоя можно самостоятельно, для этого можно:

  1. Создать новый слой газовой сети (после обновления в нём будет нужный тип).

  2. В ваш слой импортировать тип из структуры слоя.

  3. Настроить модель и поля нового объекта для расчетов. Подробное описание данного этапа «Настройка объектов слоя и данных».

Графический тип объекта — символьный, относится к объектам инженерных сетей и классифицируется как узел.

Уникальный номер (ID) в структуре слоя газовой сети – ID 9.


Создание и моделирование газопроводной сети

Введение

В данном разделе рассказывается о том как создается, изображается и редактируется математическая модель газопроводной сети. О том как менять её структуру (добавить новые режимы работы, меняется их внешний вид и размеры) можно узнать в разделе Структура слоя).

В основе математической модели для расчетов сетей лежит граф. Как известно, граф состоит из узлов, соединенных дугами. В любой сети можно выделить свой набор узловых элементов. Так в газоснабжении - это ГРС, ГРП, колодцы, потребители, запорная арматура. Дугами графа являются участки сети - трубопроводы. Участок обязательно должен начинаться в каком-то узле и заканчиваться узлом.

Начиная рисовать участок сети, нужно будет обязательно либо привязать начало участка к одному из существующих узлов, либо выбрать узел, из набора узлов, в котором этот участок будет начинаться. Точно так же, заканчивая ввод участка, нужно либо привязать его конец к одному из существующих узлов, либо установить новый узел, в котором участок будет закончен. При перемещении какого-либо узла (изменении его координаты), вместе с ним переместятся начала и концы участков, связанных с этим узлом. То есть изменение положения узлов в пространстве не приведет к изменению топологии графа, сеть не «развалится».

С точки зрения математической модели совершенно неважно, будут ли координаты узлов и точек перелома участков введены по координатам с геодезической точностью, обрисованы по какой-то подложке или просто изображены схематично. Важно, что нужные пары узлов соединены дугами, и в результате «рисования» сети мы автоматически получаем и кодировку математического графа сети. Если рисунок выполнен правильно, то и граф сети ошибок содержать не будет.

Для нанесения газопроводной сети необходимо использовать слой системы ZuluGIS определенной структуры, к объектам которого подключены таблицы с необходимыми для расчетов полями (смотрите раздел «Создание слоя газопроводной сети»). Наносить схему газопроводной сети можно либо на заранее подготовленную подоснову, либо на чистую карту (подробно о подготовке топоосновы можно узнать в справке по ZuluGIS). Для проверки правильности нанесения схемы газопроводной сети можно произвести проверку ее связности и определить все ли узлы и участки связаны между собой. Проверку можно производить как для полностью нанесенной сети, так и для готовых ее частей (смотрите раздел «Контроль ошибок при вводе»).


Создание слоя газопроводной сети

[Примечание] Примечание

Видеоурок по созданию слоя газопроводной сети можно посмотреть пройдя по ссылке: https://www.politerm.com/videos/network/layer_create_set/.

[Примечание] Примечание

В процессе работы пользователь самостоятельно будет «дорабатывать» созданный слой сети. Например добавлять новые режимы, настраивать внешний вид объектов, добавлять дополнительные поля в базы данных, добавлять новые объекты в справочники, и др.

Именно поэтому рекомендуется разработать «эталонный» слой с оптимальным наполнением, то есть заранее продумать и настроить: структуру слоя (типы, режимы, символы, размеры), настроить базу данных (поля в базах, настройки запросов), настроить расчетные сортаменты и т.д. по необходимости).

И в дальнейшем при создании нового слоя пользоваться не нижеприведенным способом через меню Задачи/ZuluGaz/Сервис/Создать слой, а путем копирования структуры «эталонного» слоя (подробней смотрите http://politerm.com.ru/docs.htm).

Для того чтобы создать слой газопроводной сети надо:

  1. Выбрать команду главного меню Слой | Создать инженерную сеть | Газоснабжение.

  2. В появившемся окне выбрать диск и каталог, где будут храниться файлы моделируемой газопроводной сети.

    Диалог сохранения слоя

    Рисунок 12. Диалог сохранения слоя

    [Примечание] Примечание

    Имя слоя НЕОБХОДИМО ЗАДАВАТЬ ЛАТИНСКИМИ буквами, слой ОБЯЗАТЕЛЬНО должен создаваться в отдельной папке. Также важно, чтобы в пути до файлов слоя НЕ БЫЛО РУССКИХ БУКВ, допускается использование только латинских. Данное ограничение связано с тем, что при работе с локальными таблицами система ZuluGIS использует программные средства, для которых не желательно наличие в имени папки русских символов.

  3. В строке Имя файла ввести имя файла латинскими символами (например Network_gaz) и нажать кнопку Сохранить (Рисунок 13, «Окно создания файла газопроводной сети»). Если будет выбрано имя файла уже существующего слоя, то в результате создания нового слоя существующий слой будет уничтожен, и вместо него создастся новый.

    Окно создания файла газопроводной сети

    Рисунок 13. Окно создания файла газопроводной сети

  4. В окне Новая Газ, в строке Название слоя ввести пользовательское имя слоя русскими символами, например Газопроводная сеть.

    Диалог создания слоя газопроводной сети

    Рисунок 14. Диалог создания слоя газопроводной сети

    [Примечание] Примечание

    Если не ставить флажок добавить в карту, тогда слой газопроводной сети будет создан только на диске и для дальнейшей работы его нужно загрузить в карту.

  5. Выбрать систему координат, с помощью кнопки Система координат. При работе с картой, выполненной в план-схеме (локальный датум), этот пункт следует пропустить.

  6. Указать способ хранения таблиц, например SQLite, MS Access или другие.

  7. После того как все окна диалога (Рисунок 14, «Диалог создания слоя газопроводной сети») заполнены, нажать кнопку ОК.


Файлы слоя газопроводных сетей

После создания слоя в папке газопроводной сети сформировались файлы графической и семантической базы данных, созданные с именем заданным в окне Имя слоя (Рисунок 13, «Окно создания файла газопроводной сети»), например, Network_gaz. Имена таблиц и описателей баз данных образованы из имени слоя (Network_gaz) и, например, названия объекта сети (potrebit), к которому они относятся (например, Network_gaz_potrebit).

Таблица 1. Файлы слоя газопроводных сетей

Network_gaz.b00 Network_water.b01 Network_gaz.b02 Network_gaz.b03 Network_gaz.b04 Network_gaz.b05 Network_gaz.b08 Network_gaz.zsx Network_water.zx | Файлы графической базы данных ZuluGIS.
Network_gaz_BACK.zb | Описатель базы данных по узлу.
Network_gaz_potrebit.zb | Описатель базы данных по потребителю.
Network_gaz_REGUL.zb | Описатель базы данных по регулирующим устройствам.
Network_gaz_uch.zb | Описатель базы данных участкам.
Network_gaz_ZAPOR.zb | Описатель базы данных задвижкам.


Последовательность действий

Для моделирования газопроводной сети требуется проделать определенную последовательность действий:

  1. Создать слой газопроводной сети.

    Для нанесения газопроводной сети на карту необходимо предварительно создать слой газопроводной сети. Подробнее об этом можно узнать в разделе «Создание слоя газопроводной сети».

  2. Настроить структуру слоя: внешний вид, размеры символов.

    Пользователь может изменить графическое отображение любого из объектов (размер, внешний вид), а также добавить к сформированной структуре новые объекты, например «Внезапное сужение (расширение)», «Граница балансовой принадлежности» и т.д. Подробнее о настройке структуры слоя можно узнать в разделе Структура слоя.

  3. Нанести газопроводную сеть на карту.

    После создания слоя газопроводной сети, модель можно изображать на карте. О том, как изображать и редактировать объекты газопроводной сети, смотрите соответствующие разделы Ввод объектов сети и Редактирование сети.

  4. Проверить связность.

    Для проверки правильности создания математической модели газопроводной сети необходимо произвести проверку связности всех объектов сети между собой. Проверку можно производить как для полностью нанесенной сети, так и для ее частей. Подробнее о проверке связности можно узнать в разделе «Контроль ошибок при вводе».


Загрузка слоя в карту

Если при создании слоя не была установлена галочка добавить в карту, то слой сети созданный в определенной директории, следует добавить в карту вручную, для этого необходимо:

  1. Выбрать команду главного меню Карта|Добавить слой, либо нажать на панели инструментов кнопку [image] . На экране появится диалог выбора слоя:

    Диалог выбора слоя

    Рисунок 15. Диалог выбора слоя

  2. Зайти в нужную директорию и выделить слой газопроводной сети:

    Диалог выбора слоя

    Рисунок 16. Диалог выбора слоя

  3. Нажать кнопку Открыть или дважды щелкнуть по выбранному слою. Он будет добавлен в текущую карту.


Структура слоя

При создании слоя газопроводной сети, он создаётся с заранее определенной стандартной структурой: символами, базами данных, типовыми объектами газопроводной сети и режимами их работы. Редактирование структуры слоя позволяет настроить внешний вид объектов газопроводной сети или добавить новые режимы работы для уже существующих объектов. Любое редактирование структуры слоя происходит через редактор структуры слоя.

Редактор структуры слоя позволяет:

  • создать, удалить или отредактировать символ (смотрите раздел «Символы»);

  • импортировать символ из другого слоя (смотрите раздел «Импорт символов из библиотеки других слоев»);

  • создать новые типовые объекты (смотрите раздел «Создание нового типа объектов»);

  • создавать новые режимы для объектов газопроводной сети (смотрите раздел «Создание нового режима объекта»);

  • поменять размеры символов газопроводной сети (смотрите раздел «Изменение размеров символов газопроводной сети»);

  • поменять внешний вид символов газопроводной сети (смотрите раздел «Изменение внешнего вида символов газопроводной сети»);

  • импортировать типы и режимы из других слоев (смотрите раздел «Импорт типов и режимов»);

  • распечатать список объектов, входящих в структуру слоя (смотрите раздел «Печать объектов, входящих в структуру слоя»).


Общие сведения о структуре слоя

Чтобы открыть редактор структуры слоя надо:

  1. Отключить редактирование слоя - [image] ), если оно было включено.

  2. Выбрать команду главного меню Слой|Структура слоя или нажать на панели инструментов кнопку [image] . На экране появится диалог выбора слоя:

    Диалог выбора слоя

    Рисунок 17. Диалог выбора слоя

  3. Войти в нужную папку, выделить слой газопроводной сети и нажать кнопку Открыть.

    Рисунок 18. Выбор слоя

На экране появится окно структуры слоя, изображенное на рисунке ниже. Диалоговое окно разделено на две части, в зависимости от того, какой пункт выделен с левой стороны, справа будут происходить соответствующие изменения, то есть будет отображаться информация, относящаяся к выбранному пункту.

Окно структуры слоя

Рисунок 19. Окно структуры слоя

Сохранение изменений и выход

Для сохранения изменений структуры слоя следует нажать кнопку Сохранить или выбрать пункт меню Файл|Сохранить.

Чтобы выйти из редактора структуры слоя нужно нажать кнопку Выход или выбрать пункт меню Файл|Закрыть. Если изменения не были сохранены, система предложит это сделать автоматически.


Символы

При выделении в окне Структура слоя пункта Символы выводится библиотека символов данного слоя, показанная на рисунке ниже. Для изображения символьного объекта в слое, этот символ должен быть обязательно добавлен в библиотеку символов данного слоя.

Окно библиотеки символов

Рисунок 20. Окно библиотеки символов

Закладка Символы снабжена следующими командными кнопками:

  • Новый... - открывает редактор символа для создания нового символа. После создания символ добавляется в список символов слоя.

  • Изменить... - открывает редактор символа для символа, выбранного в списке. Так же редактор символов можно вызвать двойным щелчком левой кнопки мыши по символу, который надо изменить.

  • Удалить - удаляет из библиотеки символов символ, отмеченный в списке. Если удаляемый символ используется одним из режимов структуры слоя или одним из объектов, удаление этого символа будет запрещено.

  • Операции:

    • Импорт - открывает диалог импорта символов, позволяющий импортировать символы из библиотек других слоев. После завершения импорта импортированные символы пополнят список символов данного слоя (подробней смотрите «Импорт символов из библиотеки других слоев»).

    • Удалить свободные - удаляет из библиотеки символов все символы, не используемые ни одним из объектов. Это позволяет очистить библиотеку от лишних символов.


Создание нового символа в библиотеке символов

Для того чтобы создать новый символ надо:

  1. Выбрать пункт Символы.

  2. Нажать кнопку [image] Новый..., появится редактор символов.

[Примечание] Примечание

Подробнее о работе в редакторе можно узнать в справочном пособии по работе с ZuluGIS в разделе Работа с векторными слоями|Редактор структуры слоя|Редактор символов (http://politerm.com/zuludoc/struct_symbols.htm#_struct_symbol_edit).


Редактирование символа в библиотеке символов

Для редактирования символа следует:

  1. Щелчком левой кнопки мыши по символу выделить символ для редактирования.

  2. Нажать кнопку [image] Изменить... или дважды щелкнуть по символу. При этом открывается редактор символов для редактирования.

[Примечание] Примечание

Подробнее о работе в редакторе можно узнать в справочном пособии по работе с ZuluGIS в разделе Работа с векторными слоями|Редактор структуры слоя|Редактор символов (http://politerm.com/zuludoc/struct_symbols.htm#_struct_symbol_edit).


Удаление символа из библиотеки

Чтобы удалить символ из библиотеки нужно:

  1. Щелчком мыши выбрать символ.

  2. Нажать кнопку [image] Удалить или кнопку Delete на клавиатуре.

  3. Нажать кнопку Сохранить.


Импорт символов из библиотеки других слоев

Символы можно импортировать из одного слоя в другой, то есть если символы уже были созданы для другого слоя, то их можно скопировать в библиотеку нашего слоя, для этого надо:

  1. В диалоговом окне Структура слоя ( [image] ) в дереве выбрать пункт Символы.

  2. Нажать кнопку [image] Операции и в открывшемся списке выбрать Импорт...:

    Рисунок 21. Импорт символов

  3. В открывшемся окне указать слой-источник, то есть слой, из которого вы хотите импортировать символы и нажать кнопку Открыть:

    Диалог выбора слоя

    Рисунок 22. Диалог выбора слоя

  4. Все символы выбранного слоя появятся в верхнем списке символов, как показано на рисунке ниже. В нижнем списке отображаются выбранные символы для импорта. Если вы случайно выбрали не тот слой-источник, нужно нажать на кнопку Выбор слоя, чтобы указать новый.

    Окно импорта символов

    Рисунок 23. Окно импорта символов

  5. Щелчком мыши выбрать символ в верхнем списке.

  6. Нажать кнопку Добавить или сделать двойной щелчок левой кнопкой мыши по символу. Выделенный символ появится в нижнем списке. Таким же образом добавить необходимые символы.

    Окно импорта символов

    Рисунок 24. Окно импорта символов

  7. Нажать кнопку Импортировать . Символы из нижнего списка, будут добавлены в библиотеку.

  8. В окне Структура слоя нажать кнопку Сохранить.

Описание кнопок диалога Импорт символов представлено далее:

  • Выбор слоя - кнопка выбора текущего слоя-источника. После выбора слоя символы из его библиотеки заполняют верхний список диалога.

  • Добавить все - добавляет все символы из верхнего списка в нижний список.

  • Добавить - добавляет текущий символ верхнего списка в нижний список. То же самое произойдет при двойном щелчке мыши на символ из верхнего списка.

  • Исключить - исключает текущий символ из нижнего списка.

  • Исключить все - очищает нижний список.

  • Импортировать - добавляет все символы из нижнего списка в библиотеку символов слоя.

  • Закрыть - закрывает диалог без импорта.


Базы данных

При выделении в окне Структура слоя пункта Базы данных выводится список всех подключенных к слою баз данных.

Вкладка «Базы данных»

Рисунок 25. Вкладка «Базы данных»

Закладка Базы данных снабжена следующими командными кнопками:

Кнопка | Описание
Создать | Позволяет создать новую базу данных. При нажатии на эту кнопку появится окно Новая база данных, в строке Название базы данных надо вписать название вашей новой базы.
Добавить | Позволяет добавить уже готовую базу данных в структуру слоя. После нажатия открывается стандартное окно выбора файла, в котором надо указать какую базу данных вы хотите добавить и нажать кнопку Открыть.
Конструктор | Данная кнопка будет активна только в том случае, если в списке выделена база данных. Она открывает диалоговое окно Редактор баз данных, в котором имеется возможность отредактировать выделенную в списке базу данных.
Удалить | Удаляет из списка выделенную базу данных. Удаление произойдет только в том случае, если эта база данных не используется ни одним из типов структуры слоя.
[Примечание] Примечание

Подробнее о создании и редактировании баз данных можно узнать в справочном пособии по работе с ZuluGIS в разделе Семантические базы данных (http://politerm.com/zuludoc/zb_overview.htm).


Типы объектов

  • «Подключенная к типу база данных»

  • «Создание нового типа объектов»

  • «Удаление типа»

  • «Редактирование параметров уже существующего типа»

Для моделирования газопроводной сети используются типовые объекты. Создание типов и режимов, а также их редактирование происходит в диалоговом окне Структура слоя ( [image] ).

Тип объекта определяет, какую функцию данный типовой объект должен выполнять, например Потребитель – потребителем газа. К типовым объектам может привязываться семантическая база данных.

Каждый типовой объект, в свою очередь, может иметь несколько режимов, которые задают различные способы работы (отображения) типового объекта. Например, тип объекта - задвижка, режимы работы – открыта и закрыта. Подробнее о режимах можно узнать в разделе «Режимы объектов»).

Дерево типов и режимов находится в структуре слоя газопроводной сети. При выделении левой кнопкой мыши типа объекта (например, потребитель), в дереве типов и режимов справа откроется вкладка, в которой отобразятся свойства выделенного типа:

Вкладка «Тип объекта»

Рисунок 26. Вкладка «Тип объекта»

На открывшейся вкладке диалога расположены следующие разделы:

  • Название− в данной строке отображается название типа, оно же одновременно отображается в дереве типов.

  • ID− отображается ID выделенного типа, то есть уникальный номер, который за данным типом закреплен. У каждого типа свой номер.

  • Графический тип − типовые объекты могут быть символьными, линейными, площадными и текстовыми. Символьный тип имеет дополнительный признак объект инженерных сетей, наличие которого позволяет конкретизировать какие функции (источник, потребитель, простой узел или запорной устройство) этот тип выполняет.

    Линейный тип имеет два дополнительных признака:

    • участок − наличие этого признака позволит системе относиться к объектам такого типа как к участкам инженерной сети, то есть при вводе потребует наличия на своих концах объектов символьного типа;

    • отсекающий − при установленном флажке, участок будет рассматриваться как отсекающее устройство, т. е. отключение на схеме можно будет производить участком.


Подключенная к типу база данных

Каждый типовой объект слоя использует свою семантическую базу данных. Например, на рисунке, представленном ниже, в дереве типов и режимов выделен тип Участок, и видно, что в разделе База данных указана используемая этим типом база - Участок.

Выбор базы данных

Рисунок 27. Выбор базы данных


Просмотр подключений к типу базы

Для просмотра подключенной к типу базы данных надо:

  1. Щелчком установить курсор на нужный тип объекта, например Насосная станция. В строке База данных отобразиться название используемой базы данных:

Рисунок 28. Вкладка «Тип»


Замена используемой типовым объектом базы данных

Для того, чтобы заменить базу данных у типового объекта надо:

  1. Щелчком установить курсор на нужный тип объекта.

  2. В строке База данных сделать щелчок, после чего появится список:

    Выбор базы данных

    Рисунок 29. Выбор базы данных

  3. Выбрать нужную базу (база данных должна быть заранее создана) из списка. В открывающемся списке будут содержаться только базы данных слоя (те базы, которые видны при выборе пункта Базы данных ).

  4. Нажать кнопку Сохранить на панели инструментов для сохранения изменений.

[Примечание] Примечание

Следует учитывать то, что различные типы объектов используют различные базы данных. В то же время, различные режимы работы одного и того объекта, используют одну и ту же базу данных. Например, режимы работы объектов типа Регулирующее устройство (ГРС, ГРП, ШРП) используют одну базу данных Регулирующее устройство.


Создание нового типа объектов

[Примечание] Примечание

В слое газопроводных сетей можно создавать новые режимы работы для объектов, включенных в математическую модель газопроводной сети.

Для создания нового типа объекта надо:

  1. На панели инструментов окна Структура слоя нажать кнопку Новый…, затем Новый тип или выбрать пункт меню Правка|Новый тип....

    Создание нового типа

    Рисунок 30. Создание нового типа

  2. В строке Название открывшейся закладки ввести пользовательское название типа, которое одновременно отобразится и в появившейся строке дерева типов. Например, Контрольно-измерительный пункт:

    Название нового типа

    Рисунок 31. Название нового типа

  3. Выбрать графический тип создаваемого объекта (если это объект инженерной сети, то необходимо определить какие функции он выполняет в сети: источник, потребитель, отсекающее устройство или узел). Смотровая камера относится к типу узел.

  4. Если надо, чтобы созданный тип использовал предварительно созданную базу данных, сделать щелчок левой кнопкой мыши по строке База данных и в выпадающем списке выбрать нужную базу. Если база данных этому типу не нужна, этот пункт можно не выполнять.

  5. Далее для созданного типа следует создать режимы его работы (отображения), подробнее об этом можно узнать в разделе «Режимы объектов».

  6. Нажать кнопку Сохранить.


Удаление типа

Для удаления существующего типа следует:

  1. Установить курсор в дереве типов на удаляемый тип.

  2. Нажать кнопку Удалить на панели инструментов.

  3. Нажать кнопку Сохранить.

[Примечание] Примечание

Тип можно удалить только тогда, когда он не имеет режимов.


Редактирование параметров уже существующего типа

Для редактирования параметров существующего типа надо:

  1. Щелкнуть на строку с именем этого типа в дереве типов, в правой части окна откроется вкладка, относящаяся к выделенному типу.

  2. Провести необходимые изменения.

  3. Нажать кнопку Сохранить.


Режимы объектов

  • «Создание нового режима объекта»

  • «Изменение размеров символов газопроводной сети»

  • «Изменение внешнего вида символов газопроводной сети»

  • «Удаление режима»

  • «Пример создания режима для уже существующего типа «Узел»»

Любой типовой объект, для его отображения на карте, должен иметь хотя бы один режим работы. Для стандартных объектов, включенных в математическую модель газопроводной сети, режимы их работы созданы по-умолчанию.

Настройка отображения типовых объектов и режимом их работы:

Вкладка «Режим символьного объекта»

Рисунок 32. Вкладка «Режим символьного объекта»

Вкладка режима имеет следующие элементы управления:

  • Кнопки Изменить и Новый - позволяют изменять существующее и создавать новое отображение выбранного режима в редакторе символов.

    [Примечание] Примечание

    Подробнее о работе в редакторе можно узнать в справочном пособии по работе с ZuluGIS в разделе Работа с векторными слоями|Редактор структуры слоя|Редактор символов (http://politerm.com/zuludoc/struct_symbols.htm#_struct_symbol_edit).

  • Размер - окно, в которое вводится масштабирующий коэффициент для регулирования размеров символов на карте. Поскольку размеры символов из библиотеки символов задаются в относительных единицах (пикселях), то заранее неизвестно, какого размера они будут на той или иной карте, так как слой может создаваться для масштабов области, города, квартала, помещения. Чем больше значение коэффициента, тем крупнее будут выглядеть символы на карте (при одном и том же масштабе карты).

  • Флажок Масштабировать включает режим масштабирования символа, т. е. изменение размеров символа при изменении масштаба карты.

  • Флажок Не увеличивать больше указанного размера - не позволяет увеличивать символ, когда масштаб карты становится меньше указанного в строке Размер.

  • Флажок Ориентировать при вводе участков - если этот флажок отмечен, то объекты наносятся по направлению ввода участков.

  • Флажок Ориентация в верхней полуокружности - при установке данного флажка объекты при нанесении будут принимать ориентацию в верхней полуокружности вводимого участка. Параметр действует только при установленном флажке Ориентировать при вводе участков.

  • Флажок Поворачивать на 90 град - поворачивает объект на 90 градусов относительно того, как он изображен в редакторе символов.

При задании режима для линейного типа, необходимо задать стиль вывода на экран, толщину на экране и толщину при печати:

Режим линейного объекта

Рисунок 33. Режим линейного объекта


Создание нового режима объекта

  • «Состояние объектов сети»

  • «Правила добавления режимов»

  • «Последовательность действий по добавлению режима»

При необходимости можно добавить дополнительные режимы работы для стандартных типовых объектов.

Важно понимать, что не стоит без необходимости добавлять в сеть новые режимы. Новые режимы имеет смысл добавлять только в том случае, если надо визуально выделить объекты одного типа друг от друга. Например, если на карте необходимо чтобы участки квартальной сети отличались по цвету от магистральной, то тогда в тип Участок надо добавить два новых режима, при чем добавляя их надо соблюдать определенные правила!

[Предупреждение] Предупреждение

При создании нового режима следует учесть:

Для типовых объектов в окне Состояние выбирается проводимость для решения топологических задач. Однако для инженерных расчетов следует добавлять объекты в определенной последовательности и по определенным правилам!


Состояние объектов сети

Для типовых объектов, имеющих графический тип Линейный/участок/отсекающий в окне Состояние выбирается свойства объекта для решения топологических задач. Типовому объекту инженерных сетей можно указать следующее свойство Проводимости:

  • Включен – проводимость во всех направлениях;

  • Отключен − нет проводимости;

  • Прямая проводимость – существует проводимость от входящих по направлению участков к выходящим;

  • Обратная проводимость − существует проводимость от выходящих по направлению участков к входящим.

Для типовых объектов, имеющих графический тип Символьный/Объект инженерных сетей/отсекающее устройство в окне Состояние выбирается свойства объекта для решения топологических задач. Можно указать следующее свойство Проводимости:

  • Включен – проводимость во всех направлениях;

  • Отключен − нет проводимости;

  • Прямая проводимость – существует проводимость от входящих по направлению участков к выходящим;

  • Обратная проводимость − существует проводимость от выходящих по направлению участков к входящим;

  • Размыкатель - объект будет являться размыкателем;

  • Не работает - объект будет вести себя как простой узел.

Свойство проводимости объекта (участка, задвижки) используется только при решении топологических задач.


Правила добавления режимов


Колодец

В тип Колодец можно добавлять столько режимов, сколько необходимо, в любом порядке, так как у него нет понятия отключен.


Участки

В тип Участок режимы можно добавлять только парами, то есть Включен, Отключен. Как бы Вы не назвали добавленный режим система воспримет нечетные по счету режимы включенными, а четные - отключенными. Кроме этого для вновь созданных режимов работы объекта, следует указать в окне Состояние его проводимость, тогда режим будет добавлен правильно.

Режимы участков воспринимаются программой следующим образом:

Номера режимов | Состояние
1, 3, 5 и т.д. | Включен
2, 4, 6 и т.д. | Отключен


Потребители

Потребители задаются парами режимов, которые воспринимаются программой следующим образом: нечетный номер режима соответствует включенному состоянию, четный номер режима – отключенному.

[Предупреждение] Предупреждение

Перед созданием режимов следует проверить включена ли опция Потребители с четными режимами отключены.

Номера режимов | Состояние
1, 3, 5 и т.д. | Включен
2, 4, 6 и т.д. | Отключен

В случае отключения участка сети, все потребители, попавшие под отключение изменят режим работы на отключенный (перейдут в режим с номером на единицу больше), при обновлении состоянии сети.


Задвижки

Задвижки задаются парами режимов, которые воспринимаются программой следующим образом: нечетный номер режима соответствует открытому состоянию, четный номер режима – закрытому.

Номера режимов | Состояние
1, 3, 5 и т.д. | Открыта
2, 4, 6 и т.д. | Закрыта

Кроме этого для вновь созданных режимов работы объекта, следует указать в окне Состояние его проводимость, тогда режим будет добавлен правильно.


Последовательность действий по добавлению режима

Для создания нового режима надо:

  1. В дереве Типы и режимы щелчком левой кнопкой мыши выделите тип, для которого создается новый режим, например Узел:

    Создание нового режима

    Рисунок 34. Создание нового режима

  2. Нажать кнопку Новый… и в открывающемся списке выбрать пункт Новый…|режим или пункт меню Правка| Новый режим.... На экране появится следующее окно:

    Параметры нового режима

    Рисунок 35. Параметры нового режима

  3. В строке название введите название режима, например Граница балансовой принадлежности.

  4. Если режим задается для символьного типа, то из открывающегося списка символов нужно выбрать тот символ, которым будет отображаться режим.

    Если символ, соответствующий требуемому режиму отображения отсутствует, символ следует создать в редакторе символов - кнопка Новый (подробнее смотрите справку по ZuluGIS раздел Создание и редактирование графического символа объекта. Редактор символов http://politerm.com/forums/index.php). Если существующий символ по каким-то критериям не подходит для отображения режима, его можно отредактировать нажатием кнопки Изменить (подробнее смотрите http://politerm.com/forums/index.php).

    Если режим задается для объекта инженерных сетей (участок или задвижка), которые могут являться отсекающими устройствами, тогда необходимо в окне Состояние выбрать соответствующую для данного режима проводимость.

    Для символьного объекта также надо задать:

    • размер, он задается в строке размер (подробнее смотрите справку по ZuluGIS раздел Изменение размеров символов http://politerm.com/zuludoc/struct_symbols.htm#_struct_symbol_size);

    • состояние (Включен/Отключен), состояние задается только в том случае, если тип является объектом инженерных сетей: источником, или потребителем;

    • при желании установить опцию Масштабировать, в этом случае включается режим масштабирования символа, т. е. изменение размеров символа при изменении масштаба карты;

    • при желании установить опцию Не увеличивать больше указанного размера, она не позволяет увеличивать символ, когда масштаб карты становится меньше указанного в строке размер;

    • при желании установить опцию Ориентировать при вводе участков, в этом случае объекты будут наноситься по направлению ввода участков;

    • при желании установить опцию Поворачивать на 90 град., она поворачивает объект на 90 градусов относительно того, как он изображен в редакторе символов.

    Для линейного графического типа объекта так же надо задать:

    • цвет, он выбирается из открывающейся палитры;

    • из списка стиль выбрать, стиль линии, если необходимого стиля нет в наличии, то его можно создать (смотрите справку по ZuluGIS раздел Создание и редактирование стиля линейных объектов http://politerm.com.ru/zuludoc/struct_linestyle.htm#_struct_linestyle_edit);

    • указать толщину на экране (толщина указывается в пикселях);

    • указать толщину при печати (толщина указывается в миллиметрах).

    Создание нового режима

    Рисунок 36. Создание нового режима

  5. Для сохранения изменений структуры слоя нажать кнопку Сохранить.


Изменение размеров символов газопроводной сети

Размеры символов задаются в относительных единицах, поэтому заранее неизвестно, какого размера они будут на той или иной карте, так как слой может создаваться для масштабов области, города, квартала, помещения. Для регулирования размеров символов на карте вводится масштабирующий отображение символов коэффициент, который задается в строке Размер . Чем больше значение коэффициента, тем крупнее будут выглядеть символы на карте (при одном и том же масштабе карты).

Для изменения размера символа газопроводной сети следует:

  1. В окне Структура слоя ( [image] ) в дереве Типы и режимы щелчком левой кнопкой мыши выделить режим, для редактирования, например Запорные устройства/Открыто.

  2. В строке Размер изменить значение:

    Изменение размера символа газопроводной сети

    Рисунок 37. Изменение размера символа газопроводной сети

  3. Нажать кнопку Сохранить. Изменения сразу отобразятся на карте.


Изменение внешнего вида символов газопроводной сети

Для изменения внешнего вида объекта газопроводной сети следует:

  1. В окне Структура слоя ( [image] ) в дереве Типы и режимы щелчком левой кнопкой мыши выделить режим, для редактирования, например Потребитель:

    Изменение внешнего вида объекта газопроводной сети

    Рисунок 38. Изменение внешнего вида объекта газопроводной сети

  2. Нажать кнопку Изменить. На экране появится редактор символов:

    Окно редактора символов

    Рисунок 39. Окно редактора символов

  3. В редакторе символов нарисовать новое изображение объекта.

  4. Нажать кнопку Сохранить и закрыть редактор.

  5. При необходимости в строке Размер задать необходимый размер.

  6. Для сохранения структуры слоя нажать кнопку Сохранить.

[Примечание] Примечание

Подробнее о работе в редакторе символов можно узнать в справке по ZuluGIS раздел Создание и редактирование графического символа объекта. Редактор символов (http://politerm.com.ru/zuludoc/struct_symbols.htm#_struct_symbol_edit).


Удаление режима

  1. Выделить удаляемый режим левой кнопкой мыши.

  2. Нажать на панели инструментов кнопку Удалить.

[Примечание] Примечание

Режим можно удалить только тогда, когда он не занят объектами, то есть ни в одном слое нет объектов этого режима.


Пример создания режима для уже существующего типа «Узел»

Предположим нам надо добавить новый объект, который будет называться Граница балансовой принадлежности. Для его добавления следует:

  1. Выделить левой кнопкой мыши в дереве тип Узел, нажать на панели инструментов диалога кнопку [image] Новый... и в открывающемся списке указать Новый режим или выбрать пункт меню Правка|Новый режим.....

  2. В появившейся закладке Режим в строке Название ввести название создаваемого режима: Граница балансовой принадлежности.

  3. Нажать кнопку Новый, после чего откроется окно Редактор символов, в котором надо создать новый символ для нашего режима. Для этого на панели Редактор символов следует нажать кнопку [image] − ввод многоугольника.

  4. На панели форматирования задать параметры создаваемого объекта (для контура [image] : цвет, узор, толщина, цвет и стиль линии).

  5. В рабочем поле окна редактора нарисовать символ.

  6. В строке Название ввести пользовательское название символа (Граница балансовой принадлежности).

  7. При необходимости изменить точку привязки (центр) символа.

    Создание нового режима

    Рисунок 40. Создание нового режима

  8. Нажать кнопку Сохранить ( [image] ) и закрыть окно редактора. Созданный режим отобразятся в дереве типов и режимов окна Структура слоя.

  9. Установить в строке размер: 50.

    Граница балансовой принадлежности

    Рисунок 41. Граница балансовой принадлежности

  10. Сохранить структуру слоя - кнопка Сохранить [image] .


Перемещение режима в структуре слоя

Вы можете переместить режим в структуре слоя — вверх или вниз в дереве типов и режимов. Перемещение режима приводит к изменению его порядкового номера (номер режима).

Для перемещения режима в структуре слоя:

  1. Выделите необходимый режим в дереве типов и режимов.

  2. Для перемещения режима вверх по дереву используйте сочетание клавиш CTRL + ↑ (стрелка вверх).

    Для перемещения режима вниз по дереву используйте сочетание клавиш CTRL + ↓ (стрелка вниз).

  3. Для сохранения изменений нажмите кнопку Сохранить.

Перемещение режима в структуре слоя

Рисунок 42. Перемещение режима в структуре слоя


Импорт типов и режимов

В системе имеется возможность импортировать из других слоев структуры отдельных типов с относящимися к этим типам режимами, символами и структурами баз данных.

Для импорта типов надо:

  1. В дереве редактора структуры слоя выделить пункт Типы и режимы, нажать кнопку Импортировать типы:

    Рисунок 43. Импорт типов

  2. В появившемся диалоге Импорт типов выбрать слой, из которого будут импортироваться типы, для этого надо воспользоваться кнопкой ....

  3. В списке типов выбранного слоя отметить типы для импорта, и завершить импорт нажатием кнопки Импорт.

    Выбор типов для импорта

    Рисунок 44. Выбор типов для импорта

[Примечание] Примечание

При копировании структур табличных баз данных на данный момент реализовано создание таблиц только в формате Paradox.


Печать объектов, входящих в структуру слоя

Для печати объектов входящих в структуру слоя надо:

  1. Выбрать в меню Файл пункт Печать..., после чего на экране появится окно отчета по структуре слоя. В открывшемся окне можно задать настройки для отчета.

    Печать структуры слоя

    Рисунок 45. Печать структуры слоя

  2. Написать имя заголовка, указать параметры шрифта в закладке Заголовок.

    Отчет по структуре слоя

    Рисунок 46. Отчет по структуре слоя

  3. В закладке Стили задать стили для печати, выбрать параметры шрифта, и отметить галочками те элементы, которые надо включить в отчет (типы, режимы, базы).

  4. Во вкладке Размеры установить размеры для объектов.

  5. Настроить параметры страниц для печати, в закладке Страница.

  6. Нажать кнопку Просмотр, для предварительного просмотра отчета. Если все настройки устраивают, то нажать кнопку Печать. Для отмены нажать кнопку Отмена.


Ввод объектов сети

Наносить схему газопроводной сети можно либо на заранее подготовленную подоснову, либо на чистую карту. При нанесении схемы на можно использовать вспомогательные функции:

  • привязка к объектам, сетка редактора;

  • ортогональный ввод;

  • ввод точек по координатам.

[Примечание] Примечание

Подробное описание данных функций смотрите в руководстве пользователя ZuluGIS http://politerm.com/zuludoc/edit_input_polyline.htm.

Для занесения сети на карту нужно, чтобы бы слой газопроводной сети был создан и загружен в карту.

  • «Создание слоя газопроводной сети»

  • «Загрузка слоя в карту»

После нанесения сети или для готовых ее участков можно провести операции контроля ошибок ввода. Подробнее о проверке ошибок ввода «Контроль ошибок при вводе».


Включение режима редактирования слоя

Перед нанесением схемы сети необходимо сначала включить режим редактирования слоя. В этом режиме происходит ввод и редактирование объектов.

Режим редактирования можно включить несколькими способами:

Первый способ:

  1. Выбрать пункт главного меню Карта|Редактор слоя или нажать кнопку [image] на панели инструментов.

  2. Если карта содержит только один слой, то этот слой сразу станет редактируемым. Если же в карте несколько слоев, то на экране появится список слоев карты, в котором нужно левой кнопкой мыши выбрать слой и нажать кнопку ОК.

    Выбор слоя для редактирования

    Рисунок 47. Выбор слоя для редактирования

Второй способ:

Нажать кнопку с карандашиком, которая расположена с правой стороны от имени слоя в окошке активного слоя: .

Кнопка примет утопленное состояние: .

После включения редактора слоя в строке состояния внизу экрана отобразится имя редактируемого слоя: .


Последовательность действий при вводе

Для изображения сети можно пользоваться двумя способами:

  • Если известны координаты узловых объектов, таких как колодцы, потребители и т.д., то можно сначала расставить эти объекты на карте и затем соединить их участками («Ввод узловых объектов сети»).

  • Изображать сеть с помощью объекта Участок. Тогда при вводе участка редактор сам будет запрашивать узловые объекты в начале и в конце участка, а поскольку часто начало нового участка является концом предыдущего, то начальный узел нового участка уже существует, и за него нужно только зацепится, то есть, продолжая ввод участка, нажать на узле левой клавишей мыши («Ввод газопроводной сети с помощью участка»).

[Примечание] Примечание

Используя для рисования режим Участка, требуется гораздо меньше действий из-за того, что не приходиться постоянно выбирать объект для ввода. Используя один лишь режим участка, изображаются все элементы сети.

Далее приведены примеры изображения газопроводной сети этими двумя способами. Например, нужно ввести фрагмент сети ГРС->Колодец->Задвижка ->Потребитель.


Ввод узловых объектов сети

Если использовать первый способ, то последовательность действий должна быть следующей:

  1. Включить режим редактирования слоя [image] .

  2. Нажать кнопку выбор типа [image] и в открывшемся списке выбрать режим регулирующего устройства ГРС:

    Выбор режима регулирующего устройства

    Рисунок 48. Выбор режима регулирующего устройства

  3. Сделать щелчок левой кнопкой мыши в том месте карты, где будет установлен ГРС.

    Рисунок 49. Ввод ГРС

  4. Нажать кнопку выбор типа [image] и в выпадающем списке выбрать режим узла Колодец на газопроводе.

  5. Сделать щелчок левой кнопкой мыши в том месте карты, где будет колодец:

    Рисунок 50. Ввод колодца

  6. Далее нажать кнопку выбор типа [image] и в открывающемся списке выбрать режим задвижки Открыта.

  7. Сделать щелчок левой кнопкой мыши в том месте карты, где будет изображена задвижка:

    Рисунок 51. Ввод задвижки

  8. Нажать кнопку выбор типа [image] и в открывшемся списке выбрать режим потребителя Включен.

  9. Сделать щелчок левой кнопкой мыши в том месте карты, где будет потребитель.

    Рисунок 52. Ввод потребителя

  10. Нажать кнопку выбор типа [image] и в открывающемся списке выбрать режим участка Включен.

  11. Щелкнуть левой кнопкой мыши в центр источника, «зацепившись» за него.

  12. Сделать двойной щелчок по колодцу для соединения его с источником.

  13. Аналогичным образом соединить оставшиеся элементы:

    Ввод оставшихся элементов

    Рисунок 53. Ввод оставшихся элементов

[Предупреждение] Предупреждение

Устанавливать таким образом объекты на уже нарисованные участки сети нельзя. Их следует вставлять объекты только в режиме Узлы [image] .


Ввод газопроводной сети с помощью участка

Геометрически участок представляет собой ломаную линию. Любая ломаная имеет как минимум две вершины − начало и конец участка. Вершины ломаной между началом и концом участка называются точки перелома, с помощью которых обозначают повороты участка, компенсаторы. На участке может быть неограниченное количество точек перелома. При рисовании участка возможно использовать все вспомогательные функции, что и при изображении простой ломаной линии (смотрите подробнее в руководстве по ZuluGIS http://politerm.com/zuludoc/edit_input_polyline.htm). Ниже на первом рисунке изображен участок без точек перелома, а на втором участок, имеющий четыре точки перелома:

Изображения участка сети

Рисунок 54. Изображения участка сети

Участок должен обязательно начинаться и заканчиваться узловым объектом. Например, оба участка на рисунке выше начинаются колодцем и заканчиваются потребителем.

Для ввода участка газопроводной сети надо выполнить следующие действия:

  1. Нажать на панели инструментов кнопку выбор типа [image] , выбрать для ввода нужный режим (включен\отключен) объекта Участок.

    Выбор объекта для ввода

    Рисунок 55. Выбор объекта для ввода

    [Примечание] Примечание

    При необходимости вновь вводить ранее выбранный режим работы участка достаточно нажать на панели инструментов [image] (если она еще не нажата). Кнопка примет утопленное положение, и редактор перейдет в режим ввода линейных объектов.

  2. В начале участка обязательно должен присутствовать символьный объект. Если начальный объект участка уже установлен на карте, то участок надо к нему присоединить. Для этого нужно подвести курсор мыши к центру объекта и нажать левую клавишу мыши. При этом, если присоединение к узлу прошло успешно, то первая точка участка будет зафиксирована, и можно продолжить ввод остальных точек участка. Для того, чтобы легче было присоединиться к узловому объекту можно удерживать клавишу Ctrl.

    [Примечание] Примечание

    Никакого всплывающего окна при этом появляться не должно. Всплывающее окно означает что:

    • привязки к объекту не произошло;

    • попытка привязаться туда, где нет узлового объекта.

    Для закрытия открывшегося окна следует сделать щелчок левой кнопкой мыши по карте или нажать клавишу Esc. В этих случаях надо повторить попытку привязаться к объекту, либо внедрить объект на существующий участок.

    Если начального символьного объекта участка еще нет, то участок можно начинать в произвольной точке. Для этого нужно подвести курсор мыши в точку карты, соответствующую будущему началу участка, и нажать левую клавишу мыши. После этого редактор попросит указать тип начального узла. На экране появится список типов и режимов узловых объектов редактируемого слоя. Из этого списка нужно выбрать узел, в котором будет начинаться участок (например, ГРС или колодец на газопроводе.) Таким образом, начиная участок в произвольной точке, мы попутно добавляем в сеть и новый узел.

  3. После того как задана начальная точка участка, можно продолжить его ввод, последовательно задавая точки поворота. Для этого надо подвести курсор мыши к точке на карте, соответствующей очередной точке поворота, и зафиксировать ее нажатием левой клавиши мыши. После того как точки поворота введены, или при отсутствии их у данного участка, можно завершать ввод трубопровода.

  4. В конце участка обязательно должен быть узловой объект. Если конечный объект уже имеется на карте, то надо подвести курсор к центру такого объекта и дважды щелкнуть левой клавишей мыши (чтобы проще было зацепиться за точку объекта удерживайте клавишу Ctrl). Никакого всплывающего окна при этом, не должно появиться. Если захват узла прошел успешно, то ввод участка будет завершен.

    Если конечного символьного объекта участка еще нет, то участок можно закончить в произвольной точке. Для этого нужно подвести курсор мыши в точку карты, соответствующую будущему концу участка, и дважды щелкнуть левой клавишей мыши. После этого редактор попросит указать тип конечного узла. На экране появится список объектов слоя с учетом их возможных режимов работы. Из этого списка нужно выбрать объект, в котором будет заканчиваться участок (например, потребитель). Таким образом, завершая участок в произвольной точке, мы попутно добавляем в сеть и новый узел.

    [Важно] Важно

    Во время завершающего ввод двойного щелчка левой клавишей мыши, важно, чтобы сама мышь между щелчками оставалась неподвижной, то есть щелчки надо сделать быстро. В противном случае будет установлена точка перелома участка. Также можно сделать щелчок правой кнопкой мыши и выбрать из меню Завершить объект, для завершения объекта в последней точке перелома.

    [Примечание] Примечание

    При вводе участков сети, так же как и при вводе простой ломаной доступны такие функции как ввод с использованием геометрических построений или ввод участка с клавиатуры (подробней смотрите Ввод ломаной).

    Так же при вводе участка удобно пользоваться клавишей Shift. Если при вводе участка ее нажать и удерживать, то участок будет вводится так, что заканчивающийся на нем последний отрезок будет образовывать с предыдущим отрезком углы 90, 180 или 270 градусов.


Ввод точек перелома (поворота) участка

Для ввода точек перелома участка во время изображения участка надо:

  1. Подвести курсор к месту на карте, где будет установлена точка перелома (например, поворот).

  2. Сделать щелчок левой кнопкой мыши, точка перелома будет установлена. Затем можно дальше продолжать ввод участка:

    Изображение точек перелома

    Рисунок 56. Изображение точек перелома


Отмена введенных точек

Если во время нанесения участка на карту последняя из введенных точек была введена ошибочно то ее можно отменить, для этого надо:

  • нажать клавишу Esc;

    или

  • сделать щелчок правой кнопкой и мыши выбрать в открывшемся контекстном меню пункт Отменить последнюю точку Esc.

Повторяя эти действия, можно шаг за шагом отменить несколько последних введенных точек, или вообще все точки, включая начало участка.


Ввод за пределами экрана

Если местоположение очередной вводимой точки выходит за пределы окна карты на экране, то изображение нужно передвинуть так, чтобы место установки точки попало в окно карты. Переместить изображение, не выходя из режима ввода участка, можно нескольким способами:

  • Использовав кнопки вертикальной и горизонтальной полосы прокрутки карты;

    или

  • При установке предыдущей точки перелома, то есть нажатии левой клавиши мыши, не отпускать эту клавишу, и в таком состоянии переместить мышь за пределы окна карты в сторону где должна быть установлена очередная точка. При этом изображение карты начнет прокручиваться в заданном направлении. Прокрутив карту на нужное расстояние, завершите прокрутку, отпустив левую клавишу мыши и продолжайте ввод участка;

    или

  • Если у мыши имеется средняя клавиша (или средняя клавиша с колесиком), то можно перемещать карту мышкой, удерживая среднюю клавишу в нажатом состоянии, при этом курсор мыши изменит свой вид и будет выглядеть как рука [image] . Для завершения перемещения нужно среднюю клавишу отпустить.


Отмена ввода объектов

Если участок был завершен и, оказалось, что он введен ошибочно, то последний введенный участок можно отменить нажатием кнопки [image] . Повторяя эту операцию можно отменить несколько последних действий редактора.

Если отмена последних действий редактора была ошибочна, то их можно восстановить нажатиями кнопки [image] .

[Примечание] Примечание

При выключении режима редактирования слоя ( [image] ) использование данных кнопок становится невозможным.


Контроль ошибок при вводе

После того, как сеть нанесена на карту необходимо проверить правильность ее нанесения, то есть надо произвести проверку ее связности, для того, чтобы определить все ли узлы и участки связаны между собой. Проверку можно производить как для полностью нанесенной сети, так и для готовых ее частей.

Для проверки надо:

  1. Сделать активным слой газопроводной сети.

  2. На панели навигации нажать кнопку Поиск пути [image] .

  3. Левой клавишей мыши установить флажок на любом объекте сети (кроме участков).

  4. Нажать правую клавишу мыши и в появившемся контекстном меню выбрать пункт Найти связанные. Все найденные объекты сети, в соответствии с выбранным пунктом меню поиска, окрасятся в красный цвет.

    Поиск связанных объектов

    Рисунок 57. Поиск связанных объектов

  5. Для отмены результатов поиска нажать кнопку Отмена пути [image] .

Можно найти все связанные объекты сети по направлению от узла, на котором был установлен флажок, или против направления, для этого в меню выбрать пункт Найти связанные по направлению или Найти связанные против направления соответственно.

Следует учитывать, что направление участка определяется при его вводе, то есть направление участка будет от начальной точки ввода к конечной точке. Также можно Найти несвязанные объекты. Для поиска колец газопроводной сети выбрать в меню пункт Найти кольца. Все найденные объекты сети, в соответствии с выбранным пунктом меню поиска, окрасятся в красный цвет.


Редактирование сети

В данном разделе рассмотрены варианты редактирования (удалить, переместить, изменить режим работы объектов), которые могут применяться непосредственно к объектам газопроводной сети. Об остальных операциях редактирования можно узнать в справке по ZuluGIS.

Внешний вид любого введенного или еще не введенного объекта газопроводной сети может быть изменен. Изображения объектов сети меняются в окне редактора структуры слоя (подробней смотрите «Изменение внешнего вида символов газопроводной сети»). Все изменения относятся сразу ко всем объектам в слое газопроводной сети.

[Примечание] Примечание

Для того чтобы отредактировать сеть необходимо, чтобы был включен режим редактирования слоя ( [image] ). Как включить режим редактирования слоя смотрите раздел «Включение режима редактирования слоя».


Редактирование объектов

В режиме редактирования объектов выполняются операции, относящиеся к объекту (узлу или участку сети) целиком:

  • «Перемещение объекта»;

  • «Поворот символьного объекта»;

  • «Дублирование объекта»;

  • «Смена типа или режима объекта»;

  • «Смена направления участка газопроводной сети»;

  • «Удаление объекта»;

  • «Разбиение участка узловым объектом (Ввод объекта на существующую сеть)»;

  • «Объединение последовательно соединенных участков (удаление объекта с нанесенной сети)».


Перемещение объекта

Переместить объект можно двумя способами: с сохранением топологических связей или с отрывом объекта от сети. В первом случае изменяется только местоположение объекта, а связность объектов сети не нарушается, то есть топология сети не изменяется. Во втором случае нарушается связь перемещаемого объекта с сетью, поэтому такое перемещение объекта, как правило, используется как промежуточная операция.

[Примечание] Примечание

Описанные ниже способы перемещения подходят как для одиночных объектов, так и для группы объектов. Если требуется переместить группу объектов, то ее надо заранее выделить, как это сделать подробно описано в справке по ZuluGIS в разделе Ввод и редактирование объектов слоя/Редактирование группы объектов/Выделение группы объектов (http://politerm.com/zuludoc/edit_group_select.htm).

Для перемещения объекта с сохранением связей надо:

  1. Войти в режим редактирования объектов, для этого нажать на панели инструментов кнопку [image] .

  2. Установить курсор на перемещаемый объект (символ или участок) (a).

  3. Нажать левую клавишу мыши и, не отпуская ее, начать перемещение (b).

    Перемещение объекта с сохранением связи

    Рисунок 58. Перемещение объекта с сохранением связи

  4. Переместить объект в новое положение.

  5. Отпустить левую клавишу мыши, для завершения перемещения (c).

В результате видно, что объект переместился с сохранением топологической связи.

Для перемещения объекта с отрывом от сети надо:

  1. Войти в режим редактирования объектов, для этого нажать на панели инструментов кнопку [image] .

  2. Установить курсор на перемещаемый объект (символ или участок).

  3. Нажать и не отпускать клавишу Shift.

  4. Нажать левую клавишу мыши и, не отпуская ее, начать перемещение (b). После начала перемещения клавишу Shift можно отпустить.

    Перемещение объекта с отрывом от сети

    Рисунок 59. Перемещение объекта с отрывом от сети

  5. Переместить объект в новое положение.

  6. Отпустить левую клавишу мыши, для завершения перемещения (c).

[Примечание] Примечание

Эта операция используется как промежуточная (например, для внедрения другого объекта вместо убранного.

В результате объект был перемещен, при этом топологическая связь участков с этим объектом разорвалась.


Поворот символьного объекта

Поворот символа не изменяет местоположение объекта ни топологию сети. Просто иногда возникает необходимость повернуть символ, под определенным углом для улучшения наглядности и читаемости изображения сети.

Для поворота символа нужно:

  1. Войти в режим выделения объектов, нажав на панели инструментов кнопку [image] .

  2. С помощью левой кнопки мыши выделить символьный объект, который надо повернуть. Символ выделится прямоугольной областью с небольшим кружком в одном из ее углов (b).

    Поворот узлового объекта

    Рисунок 60. Поворот узлового объекта

  3. Подвести курсор мыши к кружку, нажать левую клавишу мыши.

  4. Для произвольного поворота текста повернуть текст на необходимый угол, и затем сделать щелчок левой кнопкой мыши, при повороте новое положение текста показывает прозрачная рамка (c).

    Для поворота на заданный угол, параллельно или перпендикулярно какой либо линии сделать щелчок правой кнопкой мыши и в появившемся контекстном меню выбрать соответствующий пункт:

    Рисунок 61. Контекстное меню

    При выборе пункта Задать угол далее надо в появившемся окне ввести нужное значение угла и подтвердить поворот нажатием кнопки ОК.

    При выборе пункта Повернуть параллельно линии или Повернуть перпендикулярно линии надо указать системе параллельно или перпендикулярно какой линии необходимо сделать поворот. Если линия находится в активном слое, то к ней подвести курсор и сделать щелчок левой кнопкой мыши, если она находится в неактивном слое, то дополнительно еще необходимо нажать и удерживать на клавиатуре кнопку Ctrl.

Для прерывания процесса вращения, нажмите правую клавишу мыши и выберите пункт Отменить.


Дублирование объекта

Дублирование объекта является одним из способов создания нового объекта. В качестве исходного отмечается один из существующих объектов слоя, и на указанном месте создается новый объект с тем же типом, режимом и той же формы, что и исходный. Действия при дублировании объекта почти полностью совпадают с перемещением объекта с отрывом от сети.

[Примечание] Примечание

Описанные ниже способ дублирования подходит как для одиночных объектов, так и для группы объектов.

При дублировании объекта создается новый элемент, с новым ID. Для копирования табличных данных можно настроить Правила, в настройках слоя https://www.politerm.com/zuludoc/index.html#layer_setup_rules.html

Для дублирования объекта нужно:

  1. Выбрать стрелку Объект, нажав кнопку [image] на панели инструментов.

  2. Установить курсор на исходный объект.

  3. Для отрыва объекта от сети, нужно не отпуская левую кнопку мыши нажать клавишу Shift.

  4. Удерживая левую клавишу мыши начать перемещение объекта.

  5. Переместить объект в новое положение. Не отпуская кнопку мыши, нажать клавишу Ctrl, рядом с курсором появится [image] .

  6. Отпустить левую кнопку мыши. После этого клавишу Ctrl можно отпустить. Исходный объект будет продублирован в новое место.

    Рисунок 62. Дублирование объекта


Смена типа или режима объекта

В процессе работы может возникнуть необходимость изменить один объект сети на другой, или изменить режим его работы. Например, сменить режим участка на Отключен.

Для смены типа/режима объекта нужно:

  1. Войти в режим выделения объектов, нажав на панели инструментов кнопку [image] .

  2. Установить курсор на объект и сделать двойной щелчок левой клавишей мыши. На экране появится диалог Смена режима:

    Смена режима для узлового объекта

    Рисунок 63. Смена режима для узлового объекта

  3. В верхней части окна в разделе Тип выбрать тип объекта. Например, Задвижка.

  4. В нижней части окна в разделе Режим выбрать режим для объекта. Например, Закрыта.

  5. Нажать кнопку OK для сохранения изменений и выхода. Для отказа от изменений нажать кнопку Отмена.

[Примечание] Примечание

Опция Сменить направление появляется только если изменяемый объект - участок. Выбор данной опции и нажатие кнопки ОК изменяет направление ввода участка на противоположное, то есть изменяет направление стрелки.


Смена направления участка газопроводной сети

Для смены направления участка следует:

  1. Войти в режим выделения объектов, нажав на панели инструментов кнопку [image] .

  2. Установить курсор на участок, на котором надо сменить направление. Если необходимо сменить направление сразу у нескольких участков, то выделить их.

  3. Далее есть два варианта действия:

    • Сделать щелчок правой кнопкой мыши и в появившемся контекстном меню выбрать пункт Изменить направления участков.

      Рисунок 64. Контекстное меню

      ИЛИ

    • Сделать двойной щелчок левой клавишей мыши на одном участке или на любом участке из выделенной группы. На экране появится диалог Смена режима:

      Смена режима для линейного объекта

      Рисунок 65. Смена режима для линейного объекта

      Установить опцию Сменить направление и нажать кнопку OK. Для отказа от изменений нажать кнопку Отмена.


Удаление объекта

Для удаления объекта нужно:

  1. Войти в режим выделения объектов, нажав на панели инструментов кнопку [image] .

  2. Отметить удаляемый объект или группу объектов. Отмеченный объект изменит цвет.

  3. Нажать клавишу Del на клавиатуре или кнопку [image] панели инструментов. Также можно сделать щелчок правой кнопкой мыши и в контекстном меню выбрать пункт Удалить.

Выделенный объект удалится.


Разбиение участка узловым объектом (Ввод объекта на существующую сеть)

Данная операция касается типового линейного объекта слоя, являющегося типом Участок. В результате операции участок будет разделен на два участка, а между ними будет внедрен типовой символьный объект. Имеется несколько вариантов выполнения такой операции:

  • разделение участка в режиме ввода символа;

  • разделение участка введенным ранее символьным объектом

  • разделение участка символьным объектом в режиме ввода участка;

  • разделение участка узловым объектом в режиме Узлы.

[Примечание] Примечание

Для операций внедрения и удаления узловых объектов в ZuluGIS имеется возможность настроить правила Редактора.

Разделение участка в режиме ввода символа

Чтобы разделить участок символьным объектом в режиме ввода узлового символьного объекта:

  1. Включите редактирования слоя сети, в котором находится объект ( [image] ).

  2. Нажмите кнопку [image] и в открывшемся списке выберите тот символьный объект, который необходимо ввести, например разветвление.

  3. Подведите курсор к предполагаемому месту внедрения символьного объекта и удерживая клавиши CTRL+ALT [image] сделайте щелчок левой кнопкой мыши.

    Разделение участка в режиме ввода символа

    Рисунок 66. Разделение участка в режиме ввода символа

    Объект добавится в указанное место, а участок будет разделён.

Разделение участка введенным ранее символьным объектом

Если узловой объект уже ранее введен, то его можно переместить и одновременно внедрить в участок тем самым разделив его на два участка, для этого:

  1. Включите редактирования слоя сети.

  2. Выберите режим Узлы - кнопка [image] .

  3. Подведите курсор к символьному объекту, нажмите левую клавишу мыши.

  4. Не отпуская левую клавишу мыши нажмите и удерживайте на клавиатуре клавишу ALT, курсор примет вид - [image] .

  5. Переместите объект на участок.

    Разделение участка уже нанесенным символьным объектом

    Рисунок 67. Разделение участка уже нанесенным символьным объектом

    Объект внедрится в указанное место участка и участок будет разделён.

Разделение участка символьным объектом в режиме ввода участка

Вводя инженерную сеть в режиме ввода Участка, можно быстро внедрить узловой объект на существующую сеть и затем продолжить введение сети, для этого:

  1. Включите редактирования слоя сети.

  2. Нажмите кнопку [image] и в открывшемся списке выберите участок.

  3. Подведите курсор к предполагаемому месту внедрения объекта на уже существующем участке.

  4. Удерживая клавиши CTRL+ALT [image] щёлкните левой кнопкой мыши. В появившемся списке выберите объект для внедрения. Далее продолжайте вводить сеть.

    Разделение участка символьным объектом в режиме ввода участка

    Рисунок 68. Разделение участка символьным объектом в режиме ввода участка

    Выбранный из списка объект добавится в указанное место, а участок будет разделён.

Разделение участка узловым объектом в режиме Узлы

Для ввода объекта на существующий участок:

  1. Включите режим редактирования слоя в котором находится объект ( [image] ).

  2. Выберите режим работы Узлы, нажав кнопку [image] на панели инструментов.

  3. Отметьте точку вставки на участке, для этого подведите указатель мыши к предполагаемой точке разбиения и нажмите левую кнопку мыши. Место на отрезке отобразится кружком, в точке перелома- квадратиком (Рисунок 69, «Вставка объекта на существующую сеть», b).

  4. Нажмите кнопку [image] на панели инструментов или щёлкните правой кнопкой мыши и выберите в меню пункт [image] Вставить символьный объект. Откроется всплывающее окошко объектов редактируемого слоя.

  5. Из списка объектов выберите нужный и нажмите левую кнопку мыши. Выбранный объект будет изображен на схеме. (Рисунок 69, «Вставка объекта на существующую сеть», с).

    Вставка объекта на существующую сеть

    Рисунок 69. Вставка объекта на существующую сеть


Объединение последовательно соединенных участков (удаление объекта с нанесенной сети)

Если на сети установлен объект, который связан только с двумя участками, то его можно удалить, таким образом, что два связанных с ним участка объединятся в один, а на месте удаленного узла будет точка перелома объединенного участка.

В отличие от простого удаления объекта (через Del) при котором нарушается связанность, в этом случае, несмотря на изменение топологии (сеть уменьшается на один узел и одно ребро), связность сети не нарушается, так как происходит объединение участков.

Для объединения участков с общим узлом нужно:

  1. Выбрать режим Узлы, нажав на панели инструментов кнопку [image] .

  2. Отметить удаляемый узел. Подвести курсор к узловому объекту и нажать левую клавишу мыши (b).

    Удаление объекта с нанесенной сети

    Рисунок 70. Удаление объекта с нанесенной сети

  3. Нажать на панели инструментов кнопку [image] или щёлкнуть правой кнопкой мыши и в контекстно меню выбрать Исключить символьный объект (c).

[Примечание] Примечание

Если число связей отмеченного узла отлично от двух (то есть в этом узле сходиться три участка), или объект является конечным или начальным для участка, то удаление объекта не произойдет.


Редактирование элементов объекта

Под редактированием элементов объекта подразумеваются операции с участием отдельных элементов участков, таких как отрезки и точки перелома:

  • «Перемещение узла»;

  • «Перемещение отрезка»;

  • «Добавление точки перелома»;

  • «Удаление точки перелома»;

  • «Перепривязка участка».


Перемещение узла

Любой уже нанесенный на карту узел можно переместить. Для того, чтобы перенести узел надо:

  1. Войти в режим редактирования узлов, для этого на панели инструментов нажать кнопку Узлы - [image] .

  2. Подвести курсор к узлу и нажать левую клавишу мыши (b).

    Рисунок 71. Перемещение узла

  3. Не отпуская клавишу переместить узел на нужное место (с).

  4. Отпустить клавишу мыши для окончания перемещения узла (d).

    Точно таким же образом можно перенести любой символьный объект, только при выполнении пункта 2 надо обязательно попасть в точку привязки объекта (как правило − это центр объекта).

[Примечание] Примечание

Перемещение узлов (узловых объектов) так же модно сделать с помощью геометрических преобразований (смотрите справку по ZuluGIS Работа с объектами слоя http://politerm.com/zuludoc/edit_elem_move_node.htm).


Перемещение отрезка

Любой нанесенный отрезок, участок сети можно перенести с одного места на другое. Для переноса отрезка надо:

  1. Выбрать стрелку Узлы, нажав кнопку [image] на панели инструментов.

  2. Для переноса отрезка вместе со связанными с ним объектами подвести курсор к отрезку и нажать левую клавишу мыши, не отпуская клавишу переместить отрезок на нужное место (b).

  3. Отпустить клавишу мыши для окончания перемещения отрезка (c).

Рисунок 72. Перемещение отрезка


Добавление точки перелома

В любой уже нанесенный участок сети можно добавить новые точки перелома. Для создания точки перелома надо:

  1. На панели инструментов выбрать режим Узлы, нажав кнопку [image] .

  2. Подвести курсор к предполагаемой точке перелома и, удерживая клавишу Ctrl, нажать левую клавишу мыши.

    ИЛИ

    С помощью левой кнопки мыши выделить место предполагаемого перелома, после чего нажать на панели инструментов кнопку [image] .

    ИЛИ

    С помощью левой кнопки мыши выделить место предполагаемого перелома, сделать щелчок правой кнопкой мыши и в появившемся контекстном меню выбрать Добавить точку перелома.

    На участке появится точка перелома.


Удаление точки перелома

Ошибочно введенный или лишний узел на участке можно удалить, либо указывая удаляемую точку на карте, либо указывая ее в панели свойств. Для удаления точки перелома первым способом нужно:

  1. На панели инструментов выбрать Узлы, нажав кнопку [image] .

  2. Отметить удаляемый узел, для этого подвести курсор к удаляемому узлу и нажать левую клавишу мыши. Отмеченный узел будет выделен квадратом черного цвета (b).

  3. Нажать на панели инструментов кнопку [image] или клавишу Delete на клавиатуре, либо щелкнуть правой кнопкой мыши и в контекстном меню выбрать Удалить точку перелома. Точка перелома будет удалена и участок автоматически выпрямится (c).

Удаление точки перелома

Рисунок 73. Удаление точки перелома

Возможен второй способ удаления точки перелома:

  1. Нажать на панели инструментов кнопку Панель свойств - [image] . В правой части экрана появится окно Свойства.

  2. На панели инструментов выбрать Узлы, нажав кнопку [image] .

  3. Подвести курсор к участку, на котором находится удаляемая точка, и нажать левую клавишу мыши, в окне свойств отобразятся параметры участка: координаты начальной, конечной и промежуточных точек, длина и азимут промежуточных отрезков.

  4. Перемещаясь в окне свойств, точки соответствующие строке, на которой находится курсор, будут выделяться черным квадратом.

  5. Поставить курсор на строку, характеризующую удаляемую точку и нажать на клавиатуре комбинацию клавиш Ctrl+Delete (а);

  6. Выделенная точка и строка, соответствующая ей удалится, а отрезок выпрямится (b).

Удаление точки перелома из панели Свойства

Рисунок 74. Удаление точки перелома из панели Свойства


Перепривязка участка

Для перепривязки участка от одного объекта к другому необходимо:

  1. На панели инструментов выбрать Узлы, нажав кнопку [image] .

  2. С помощью левой кнопки мыши выделить перепривязываемый участок. На отмеченном участке будет отмечены точки перелома (a).

  3. Подвести курсор к узлу участка, который необходимо «оторвать» от сети и удерживая клавишу Shift на клавиатуре нажать левую клавишу мыши.

    [Примечание] Примечание

    Клавиша Shift в данном случае используется для того, чтобы «оторвать» участок от объекта.

    Рисунок 75. Перепривязка участка

  4. Удерживая левую клавишу мыши и Shift отвести участок в сторону (b). Таким образом, участок будет отцеплен от объекта.

  5. Щелчком левой кнопкой мыши «ухватиться» за конечную точку участка. Не отпуская клавишу мыши и удерживая клавишу Ctrl на клавиатуре подвести конец участка к узлу привязки, при этом вид курсора изменится на следующий [image] (c).

  6. Отпустить клавишу мыши для окончания перепривязки участка (d).

[Примечание] Примечание

Клавиша Ctrl в данном случае используется для того, чтобы участок «прицепился» к объекту.


Исходные данные для выполнения инженерных расчетов

Введение

Прежде чем приступить к любому инженерному расчету, необходимо занести исходные данные. В зависимости от вида проводимого расчета, потребуется занести дополнительные данные к уже введенным, например, для конструкторского расчета.

[Примечание] Примечание

Независимо от того, какой расчет требуется проводить, для всех объектов газопроводной сети (кроме участков) необходимо задать значение Zgeo, Геодезическая отметка, м. Если геодезические отметки неизвестны, то можно принять местность плоской, задав на всех объектах геодезическую отметку равную нулю. Геодезическая отметка также может быть считана со слоя рельефа, подробнее об этом «Автоматическое занесение геодезических отметок объектов сети со слоя рельефа».

Рекомендации по занесению исходных данных

  • Рекомендуется сначала внести исходные данные для узловых объектов сети, таких как ГРС, колодцы, потребители и т. д., а затем уже по участкам трубопроводов газопроводной сети.

  • Для всех объектов сети, кроме участков трубопроводов, рекомендуется заполнить поле Name, Наименование объекта (узла), так как информация из данного поля дает наглядность при построении пьезометрических графиков и их распечатке.

  • Наименования начал и концов участков трубопроводов сети можно записать автоматически, при наличии наименований объектов сети, подробнее «Автоматическое занесение начала и конца участков».

  • При изображении сети на карте (в масштабе) можно считать длину участков с карты, подробнее «Автоматическое занесение длины с карты».

[Примечание] Примечание

При занесении исходных данных по объектам также можно воспользоваться сводными таблицами, Таблицы баз данных элементов газопроводной сети.


Основные исходные данные для выполнения поверочного расчета

  • «Регулирующее устройство (ГРС, ГРП, ШРП)»

  • «Потребитель»

  • «Узел (колодец на газопроводе)»

  • «Участок газопроводной сети»

  • «Задвижка»


Регулирующее устройство (ГРС, ГРП, ШРП)

Для выполнения поверочного расчета надо занести следующую информацию по регулирующему устройству:

  1. H_geo, Геодезическая отметка, м – задается отметка оси трубы, она может автоматически быть считана со слоя рельефа («Автоматическое занесение геодезических отметок объектов сети со слоя рельефа»).

  2. Preg, Давление на выходе, кПа - задается давление на выходе регулирующего устройства.

  3. Pmin, Минимальное давление, кПА – пользователем указывается минимальное давление на входе на регулирующем устройстве. В поверочном расчете значение данного поля должно быть больше или равно, чем значение поля Давление на выходе (Preg). Для поверочного расчета вы можете оставить поле пустым и включить опцию Pmin равно давлению на выходе.

  4. Gmax_norm, Максимальный расход при нормальных условиях, м3/ч – указывается пользователем значение максимального расхода для источнике газоснабжения. Используется для поверочного расчета, конструкторского расчета и резерва пропускной способности.

    При превышении максимального расхода, указанного на источнике, будет выводится предупреждающее сообщение (Расход на узле превышает максимальный ....).

    Вы можете включить ограничение (регулирование) — для этого укажите 1 в поле Ограничитель по максимальному расходу.

    Данное поле доступно, начиная с версии 10.0.0.8207 (дата релиза — 24.06.2022). После обновления вы можете его добавить самостоятельно и настроить, подробнее.

  5. RegulG, Ограничитель по максимальному расходу — задаётся пользователем:

    0 (или ПУСТО) — нет ограничения по расходу.

    1 — включено ограничение максимального расхода на данном регулирующем устройстве.

    [Предупреждение] Предупреждение

    Ограничитель можно использовать только, если в сети есть несколько регулирующих устройств. Сразу на всех регулирующих устройствах ограничитель использовать нельзя — должен быть хотя бы один "неограниченный" источник.

    В случае, когда с "неограниченного" источника расход будет превышать расчетный — давление на выходе будет снижаться.

    Данное поле доступно, начиная с версии 10.0.0.8207 (дата релиза — 24.06.2022). После обновления вы можете его добавить самостоятельно и настроить, подробнее.

Сводная таблица данных по регулирующему устройству приведена в разделе «Регулирующее устройство».


Потребитель

Для выполнения поверочного расчета надо занести следующую информацию по потребителям:

  1. H_geo, Геодезическая отметка, м – задается отметка оси трубы, она может автоматически быть считана со слоя рельефа («Автоматическое занесение геодезических отметок объектов сети со слоя рельефа»).

  2. Gnorm, Расчетный расход, м3/час - задается пользователем по проектным данным (значение используется в расчете если потребитель задан как Сосредоточенный).

  3. Knom, Коэффициент изменения расхода - при желании может быть задан пользователем коэффициент, который позволит уменьшить или увеличить расход, задается в долях от единицы.

  4. Pmin, Минимальное давление, кПа - задается пользователем по проектным данным.

  5. Pmax, Максимальное давление, кПа - задается пользователем по проектным данным.

  6. Type, Тип потребителя - выбирается из списка тип потребителя:

    • Сосредоточенный потребитель - данный тип потребителя используется по умолчанию, при выборе данного типа потребителя в расчете будет использоваться значение Расчетного расхода (подробней «Расход в зависимости от типа потребителя»).

    • Жилой дом - при выборе данного типа потребителя в расчете будет использоваться указанное далее газовое оборудование, а расчетный расход будет проигнорирован (подробней «Расход в зависимости от типа потребителя»).

  7. Плита 4-конфорочная (количество) - в том случае, если потребитель был задан как Жилой дом, в данном поле необходимо указать количество плит 4-конфорочных.

  8. Плита 4-конфорочная (номинальный расход) - в том случае, если было указано количество 4-конфорочных плит, то в данном поле необходимо указать номинальный расход каждой плиты.

  9. Плита 2-конфорочная (количество) - в том случае, если потребитель был задан как Жилой дом, в данном поле необходимо указать количество 2-конфорочных плит.

  10. Плита 2-конфорочная (номинальный расход) - в том случае, если было указано количество 2-конфорочных плит, то в данном поле необходимо указать номинальный расход каждой плиты.

  11. Плита 4-конфорочная и проточный нагреватель (количество) - в том случае, если потребитель был задан как Жилой дом, в данном поле необходимо указать количество 4-конфорочных плит и поточных нагревателей.

  12. Плита 4-конфорочная и проточный нагреватель (номинальный расход) - в том случае, если было указано количество 4-конфорочных плит и проточных нагревателей, то в данном поле необходимо указать номинальный расход плиты и нагревателя.

  13. Плита 2-конфорочная и проточный нагреватель (количество) - в том случае, если потребитель был задан как Жилой дом, в данном поле необходимо указать количество 2-конфорочных плит и поточных нагревателей.

  14. Плита 2-конфорочная и проточный нагреватель (номинальный расход) - в том случае, если было указано количество 2-конфорочных плит и проточных нагревателей, то в данном поле необходимо указать номинальный расход плиты и нагревателя.

  15. Емкостной нагреватель, котел или печь (количество) - в том случае, если потребитель был задан как Жилой дом, в данном поле необходимо указать количество емкостных нагревателей.

  16. Емкостной нагреватель, котел или печь (номинальный расход) - в том случае, если было указано количество 2-конфорочных плит и проточных нагревателей, то в данном поле необходимо указать номинальный расход емкостного нагревателя.

Сводная таблица данных по потребителю приведена в разделе «Потребитель».


Узел (колодец на газопроводе)

  1. Zgeo, Геодезическая отметка, м – задается пользователем по проектным данным отметка оси трубы, проходящей в данном узле. Она может автоматически быть считана со слоя рельефа («Автоматическое занесение геодезических отметок объектов сети со слоя рельефа»).

Сводная таблица данных по узлу приведена в разделе «Узел сети (колодцы, разветвления)».


Участок газопроводной сети

Для выполнения поверочного расчета надо занести следующую информацию по участкам сети:

  1. len, Длина, м - задается длина участка трубопровода в плане с учетом длины всех ответвлений. Поле Длина можно заполнить автоматически для всех участков сети ( «Автоматическое занесение длины с карты»).

  2. diam, Диаметр внутренний, м - задается в метрах внутренний диаметр трубопровода, например 0.1.

  3. ke, Шероховатость, мм - задается коэффициент шероховатости трубопровода, например 0.5, 1, 2 мм.

  4. kz, Коэффициент местных потерь давления - задается пользователем коэффициент местных потерь давления, который увеличивает расчетную длину участка, позволяя моделировать общие потери давления с учетом местных сопротивлений, таких как колена, тройники, запорная арматура, компенсаторы и другие элементы.

    Если не указано поле Sum_Km (Сумма коэффициентов местных сопротивлений), то значение коэффициента местных потерь давления должно быть больше 1. Например, если вы введете 1.1 или 1.2, то расчетная длина участка трубопровода будет увеличена на 10% или 20%, соответственно.

    Если же поле Sum_Km (Сумма коэффициентов местных сопротивлений) уже заполнено, то коэффициент местных потерь давления следует задавать равным 1.

  5. Sum_Km, Сумма коэффициентов местных сопротивлений – указывается пользователем сумма коэффициентов местных сопротивлений ζ (всех кранов, тройников, запорной арматуры и т.д., на этом участке), на основании справочной литературы.

    Данное поле можно оставить пустым, а общие потери давления с учетом местных сопротивлений, моделировать с помощью увеличения расчетной длины газопровода — для этого используйте поле kz, Коэффициент местных потерь давления.

  6. Gw, Путевой расход - указывается пользователем путевой расход — суммарное потребление всех узловых расходов на расчетном участке; включает в себя расход всех мелких потребителей и ответвлений, не изображенные на схеме.

    Если все потребители в сети изображены на схеме и заданы как потребители с расчетным расходом, то значение путевого расхода следует задавать равным 0.

Сводная таблица данных по участкам сети приведена в разделе «Участок».


Задвижка

Для выполнения расчетов надо занести следующую информацию:

  1. Zgeo, Геодезическая отметка, м – задается отметка оси (верха) трубы, данной задвижки. Она может автоматически быть считана со слоя рельефа («Автоматическое занесение геодезических отметок объектов сети со слоя рельефа»).

Сводная таблица данных по запорной арматуре приведена в разделе «Задвижка».


Обратный клапан

  1. Zgeo, Геодезическая отметка, м – задается геодезическая отметка оси (верха) трубы, выходящей из обратного клапана. Она может автоматически быть задана со слоя рельефа (смотрите «Автоматическое занесение геодезических отметок объектов сети со слоя рельефа»).

[Примечание] Примечание

В обратный клапан должен входить один участок и выходить один участок.

Направление участков задает состояние обратного клапана, в котором он открыт.

Сводная таблица данных по элементу Обратный клапан приведена в разделе «Обратный клапан».


Исходные данные для выполнения конструкторского расчета

Для проведения конструкторского расчета понадобится ввести дополнительно следующую информацию.

Для всех объектов кроме участков необходимо задать значение (если еще не задано) Zgeo, Геодезическая отметка, м. Если геодезические отметки неизвестны, то можно принять местность плоской, задав на всех объектах геодезическую отметку равную нулю. Геодезическая отметка также может быть считана со слоя рельефа, подробнее об этом «Автоматическое занесение геодезических отметок объектов сети со слоя рельефа».

Помимо геодезической отметки понадобится задать дополнительные данные по следующим объектам:

  • «Регулирующее устройство (ГРС, ГРП, ШРП)»

  • «По потребителям»

  • «По участкам»


Регулирующее устройство (ГРС, ГРП, ШРП)

  1. Pmin, Минимально давление, кПа - задается пользователем минимальное давление (по проекту или для текущего расчета) на регулирующем устройстве.

  2. Gnorm, Расчетный расход, м3/час - задается пользователем по проектным данным расчетный расход газа.

  3. Kg, Снижение нагрузки, % - задается пользователем.

  4. Gmax_norm, Максимальный расход при нормальных условиях, м3/ч – указывается пользователем значение максимального расхода для источнике газоснабжения. Используется для поверочного расчета, конструкторского расчета и резерва пропускной способности.

    При превышении максимального расхода, указанного на источнике, будет выводится предупреждающее сообщение (Расход на узле превышает максимальный ....).

    Вы можете включить ограничение (регулирование) — для этого укажите 1 в поле Ограничитель по максимальному расходу.

    Данное поле доступно, начиная с версии 10.0.0.8207 (дата релиза — 24.06.2022). После обновления вы можете его добавить самостоятельно и настроить, подробнее.

  5. RegulG, Ограничитель по максимальному расходу — задаётся пользователем:

    0 (или ПУСТО) — нет ограничения по расходу.

    1 — включено ограничение максимального расхода на данном регулирующем устройстве.

    [Предупреждение] Предупреждение

    Ограничитель можно использовать только, если в сети есть несколько регулирующих устройств. Сразу на всех регулирующих устройствах ограничитель использовать нельзя — должен быть хотя бы один "неограниченный" источник.

    В случае, когда с "неограниченного" источника расход будет превышать расчетный — давление на выходе будет снижаться.

    Данное поле доступно, начиная с версии 10.0.0.8207 (дата релиза — 24.06.2022). После обновления вы можете его добавить самостоятельно и настроить, подробнее.


По потребителям

  1. Pmin, Минимальное давление, кПа - задается пользователем по проектным данным.

  2. Pmax, Максимальное давление, кПа - задается пользователем по проектным данным.

  3. Kg, Снижение нагрузки, % - задается пользователем.


По участкам

  1. L, Длина участка, м - задается длина участка трубопровода в плане с учетом длины всех ответвлений. Поле Длина участка можно заполнить автоматически для всех участков сети («Автоматическое занесение длины с карты»).

  2. kz, Коэффициент местных потерь давления - задается пользователем коэффициент местных потерь давления, который увеличивает расчетную длину участка, позволяя моделировать общие потери давления с учетом местных сопротивлений, таких как колена, тройники, запорная арматура, компенсаторы и другие элементы.

    Если не указано поле Sum_Km (Сумма коэффициентов местных сопротивлений), то значение коэффициента местных потерь давления должно быть больше 1. Например, если вы введете 1.1 или 1.2, то расчетная длина участка трубопровода будет увеличена на 10% или 20%, соответственно.

    Если же поле Sum_Km (Сумма коэффициентов местных сопротивлений) уже заполнено, то коэффициент местных потерь давления следует задавать равным 1.

  3. Sum_Km, Сумма коэффициентов местных сопротивлений – указывается пользователем сумма коэффициентов местных сопротивлений ζ (всех кранов, тройников, запорной арматуры и т.д., на этом участке), на основании справочной литературы.

    Данное поле можно оставить пустым, а общие потери давления с учетом местных сопротивлений, моделировать с помощью увеличения расчетной длины газопровода — для этого используйте поле kz, Коэффициент местных потерь давления.

  4. Gw, Путевой расход - указывается пользователем путевой расход — суммарное потребление всех узловых расходов на расчетном участке; включает в себя расход всех мелких потребителей и ответвлений, не изображенные на схеме.

    Если все потребители в сети изображены на схеме и заданы как потребители с расчетным расходом, то значение путевого расхода следует задавать равным 0.

  5. sortament, Сортамент - в данное поле необходимо внести материал для трубопровода. Материал выбирается из справочника, для открытия которого надо поставить курсор на поле Сортамент и нажать на кнопку .... В появившемся справочнике из верхнего списка надо выбрать материал и проверить сортамент труб указанный в нижней части окна. Подробней о справочнике по трубам можно узнать в разделе «Справочник по трубам (Сортамент)».

  6. Proklad, Вид прокладки - выбирается из открывающегося списка, который открывается нажатием на кнопку [image] .

  7. diam_con_status, Статус при подборе диаметра - указывается или выбирается из списка:

    0 (ПУСТО) — значение по-умолчанию. В результате конструкторского расчета для участка будет подобран диаметр.

    1 — если в данном поле будет установлена 1, то на данном участке диаметр в результате расчета НЕ будет подбираться, а будет использоваться диаметр, указанный в поле Диаметр внутренний, м.


Настройка объектов слоя, данных и размерности полей

В случае если слой сети газоснабжения создавался в программном обеспечении ZuluGIS без учета объектов и соответствующих баз данных, необходимых для выполнения гидравлического расчета, то перед расчетами обязательно следует произвести его настройку (смотрите «Настройка объектов слоя и данных»).

Также настройка слоя позволяет настроить размерность полей, используемых в качестве исходных данных и результатов расчета (смотрите «Настройка единиц измерения»).

Настройка объектов слоя и данных

Настройка объектов слоя позволяет установить связь между объектами и таблицами слоя пользователя (старая модель) с объектами и таблицами расчетного модуля (расчетная модель). К каждому объекту расчетного модуля могут быть привязаны несколько объектов слоя пользователя, например, к объекту Узел можно привязать два объекта слоя пользователя Узел и Задвижка.

[Подсказка] Подсказка

Во время выполнения настройки данных объектов слоя, возможно потребуется добавить поля в базу данных.

Для настройки данных объектов слоя:

  1. Выберите меню Задачи|ZuluGaz, либо нажмите на панели инструментов кнопку [image] . Откроется панель расчетов.

  2. Нажмите кнопку Слой..., в открывшемся диалоге выберите слой газопроводной сети и нажмите кнопку ОК чтобы подтвердить выбор и закрыть диалог.

  3. Далее нажмите кнопку Настройки, откроется диалог настройки расчетов для выбранного слоя.

    Рисунок 76. Панель расчетов

  4. В диалоге Настройки гидравлического расчета выберите вкладку Данные.

  5. Далее необходимо в соответствии с принятой в программном обеспечении ZuluGaz расчетной моделью газовой сети переназначить ранее созданные объекты и соответствующие им данные. Каждому объекту расчетной модели ZuluGaz:

    • Пункт регулирования;

    • Участок;

    • Узел;

    • Потребитель.

    Для этого отметьте тип объекта, для которого будут добавляться элементы сети.

  6. Нажмите кнопку Добавить объект или выполните двойной щелчок по нужному типу:

    Рисунок 77. Вкладка Данные

  7. В появившемся окне установите соответствие между объектом «новой» и объектом «старой» модели сети, путем установки флажка рядом с объектом, например, Регулирующее устройство:

    Рисунок 78. Вкладка Данные

    Аналогичным образом для каждого объекта расчетной модели ZuluGaz, который будет принимать участие в расчете необходимо указать соответствующие объекты старой модели сети путем их добавления.

После приведения в соответствие объектов «новой» и «старой» модели подобную операцию необходимо проделать и с данными по этим объектам.

Установка соответствия между данными производится следующим образом:

  1. Отметьте тип объекта, для которого будет проводиться настройка полей.

  2. Нажмите кнопку Поля или выполните двойной щелчок по нужному режиму:

    Диалог Настройки гидравлического расчета

    Рисунок 79. Диалог Настройки гидравлического расчета

  3. В появившемся окне выберите имя поля, которое надо переопределить:

    Настройка полей объектов

    Рисунок 80. Настройка полей объектов

  4. Нажмите кнопку ... или кнопку Задать.

  5. В появившемся окне будет представлена структура информация базы данных старой модели соответствующая данному объекту:

    Рисунок 81. Задание поля

  6. Выберите поле, соответствующее новой структуре и нажмите кнопку ОК. В результате этой операции в новой базе данных в колонке Имя поля появится значение Name.

  7. Аналогичным образом следует переназначьте остальные ранее созданные объекты и соответствующие им данные.

Настройка единиц измерения

[Предупреждение] Предупреждение

Смена единиц измерения в расчетной модели не пересчитывает текущие значения и не изменяет настройки продольного профиля. Смена единиц просто указывает расчету в каких единицах задано или должно быть записано число.

Система имеет возможность изменить единицы измерения не для всех полей базы, а только для некоторых, программно предусмотренных полей.

У регулирующих устройств могут быть изменена размерность следующих полей:

  • Давление, Давление на входе, Минимальное давление:

    • кПа (по умолчанию);

    • МПа;

    • мм вод. ст.

У участка могут быть изменена размерность следующих полей:

  • Диаметр, Расчетный внутренний диаметр, Расчетный наружный диаметр:

    • м (по умолчанию);

    • мм.

  • Давление в начале, Давление в конце, Потеря давления, Гидростатическое давление:

    • кПа (по умолчанию);

    • МПа;

    • мм вод. ст.

У узла могут быть изменена размерность следующих полей:

  • Фактическое давление:

    • кПа (по умолчанию);

    • МПа;

    • мм вод. ст.

У потребителя могут быть изменена размерность следующих полей:

  • Минимальное давление, Максимальное давление, Фактическое давление:

    • кПа (по умолчанию);

    • МПа;

    • мм вод. ст.

Для настройки единиц измерения:

  1. Выберите меню Задачи|ZuluGaz, либо нажмите на панели инструментов кнопку [image] . Откроется панель расчетов.

  2. Нажмите кнопку Слой..., в открывшемся диалоге выберите слой газопроводной сети и нажмите кнопку ОК чтобы подтвердить выбор и закрыть диалог.

  3. Далее нажмите кнопку Настройки, откроется диалог настройки расчетов для выбранного слоя.

    Рисунок 82. Панель расчетов

  4. В диалоге Настройки гидравлического расчета выберите вкладку Данные.

  5. Отметьте объект, для которого будут настраиваться единицы измерения, например, Регулирующее устройство.

    Диалог Настройки гидравлического расчета

    Рисунок 83. Диалог Настройки гидравлического расчета

  6. Нажмите кнопку Поля. Откроется окно настройки полей и единиц измерения.

  7. В столбце Размерность выберите нужные единицы измерения для необходимых полей.

    Диалог Настройки гидравлического расчета

    Рисунок 84. Диалог Настройки гидравлического расчета

  8. Аналогичным образом настройте другие объекты.

  9. Нажмите ОК для сохранения изменений.


Настройки расчетов и вкладка Сервис

Перед выполнением любого расчета обязательно необходимо проверить настройки расчетов, так как их изменение может существенно повлиять на результаты.

[Предупреждение] Предупреждение

Для каждого слоя газопроводной сети указываются свои собственные параметры расчета, которые сохраняются системой автоматически.

Для открытия диалога настройки расчетов выполните следующие действия:

  1. Выберите меню Задачи|ZuluGaz, либо нажмите на панели инструментов кнопку [image] . Откроется панель расчетов.

  2. Нажмите кнопку Слой..., в открывшемся диалоге выберите слой газопроводной сети и нажмите кнопку ОК чтобы подтвердить выбор и закрыть диалог.

    Рисунок 85. Панель расчетов

  3. Далее нажмите кнопку Настройки, откроется диалог настройки расчетов для выбранного слоя.

Настройка различных параметров расчетов подробно описывается в последующих подразделах:

  • «Настройка расчета»

  • «Состав газа»

  • «Настройка раскраски»

  • «Настройка данных»

  • «Настройка вида панели расчетов»

  • «Настройка HASP»

  • «Вкладка Сервис»


Настройка расчета

Вкладка Настройки расчета позволяет задать следующие параметры:

  • выбрать метод расчета («Метод расчета»);

  • установить параметры проведения расчета и ведения протокола расчета («Настройка проведения расчета и ведения протокола расчета»).

Диалог настройки расчета. Вкладка «Настройки расчета»

Рисунок 86. Диалог настройки расчета. Вкладка «Настройки расчета»

Метод расчета

Гидравлический расчет газовой сети возможно производить по различным методикам:

  • по своду правил СП 42.101-2003 с учетом нормальных условий при температуре газа 0 °С;

  • с учетом температуры газа отличной от нормальных условий;

    В случае выбора гидравлического расчета газопровода С учетом температуры газа необходимо указать в окне значение этой температуры, например, 10 °С.

  • СТО ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2-1-2013.

    В случае выбора метода СТО ГП ГР 12.2.2-1-2013 для сетей высокого и среднего давления надо установить опцию Учитывать сжатие, для сетей низкого давления считается что газ среда несжимаемая.

Выбор метода осуществляется путем установки маркера (точки) напротив соответствующего пункта.

Настройка проведения расчета и ведения протокола расчета

В блоке настроек Протокол содержаться настройки проведения расчета, а также ведения протокола (сообщения и предупреждения в окне Сообщения).

Настройки проведения расчета:

  • При нехватке давления на входе регулятора брать Pout = Pin — при проведении поверочного расчёта, в случае недостаточного давления на входе в регулятор (ГРС, ГРП, ШРП и т. д.) , можно учитывать или не учитывать пониженное давление на входе в регулирующее устройство. Подробнее смотрите Поверочный расчет газопроводной сети.

  • Очищать поля объектов, не связанных с источниками — при установке данной опции, у объектов не участвовавших в расчетах, данные во всех полях результатов будут очищены;

  • Автоматически изменять направление участков — если установлена данная опция, то при завершении гидравлического расчета будет автоматически изменено направление участков в соответствии с направлением движения газа по трубопроводу.

  • Записывать в поля "Источники" имена регуляторов — при включении данной опции в результате расчета в поля Sist, Источники вместо номеров регуляторов, будут записываться наименования из поля Name.

Настройки ведения протокола:

  • Выводить сообщения по участкам без узлов — при установке данной опции при расчете не будут выводить предупреждения об участках не имеющих связи с объектом в начальном или конечном узле;

  • Выводить сообщения о нехватке давления на потребителе — если опция установлена, то сообщения о нехватке давления по результатам расчета будут выведены в окно Сообщения;

  • Выводить сообщения о нехватке давления на регуляторе — в окно Сообщения будут выводится сообщения о нехватке давления на регуляторах (в том числе внутри ГРС, ГРП и ШРП). Смотрите также Возможные ошибки расчетов

  • Выводить сообщения о превышении максимального давления — если опция установлена, то сообщения о превышении максимального давления будут выведены в окно Сообщения;

  • Переключатель Единицы измерения давления в сообщениях позволяет выбрать как будут выводиться (кПа или МПа) ошибки и предупреждения в окне Сообщения.


Состав газа

Состав газа задается в соответствующей вкладке Состав газа:

Диалог настройки расчетов. Вкладка «Состав газа»

Рисунок 87. Диалог настройки расчетов. Вкладка «Состав газа»

По умолчанию в процентном содержании компонентов в смеси газа указан 100 % метан, при необходимости данное соотношение можно изменить. Количество компонентов в смеси не должно превышать 100%.


Настройка раскраски

Параметры отображения тематической раскраски участков трубопроводов после проведения расчетов задаются во вкладке Раскраска диалога настройки расчетов. Подробнее о тематической раскраске можно узнать в разделе «Раскраска с помощью встроенных фильтров».

Диалог настройки расчетов. Вкладка «Раскраска»

Рисунок 88. Диалог настройки расчетов. Вкладка «Раскраска»


Настройка данных

Диалог настройки расчетов. Вкладка «Данные»

Рисунок 89. Диалог настройки расчетов. Вкладка «Данные»

  • В левой части окна отображается список, где можно настроить объекты, участвующие в расчете, а также задать размерность полей.

  • Потребители с четными режимами отключены — при включении данной опции потребители с чётными режимами (в структуре слоя) будут отключенными. Если отключена — все режимы потребителей считаются включенными.

    [Примечание] Примечание

    Подробнее о правилах добавления режимов: «Правила добавления режимов»

  • С помощью опции Задавать расчетные расходы пользователь может выбрать, какой расход газа указан у потребителя в качестве исходных данных (поле Gnorm, Расчетный расход):

    • При нормальных условиях.

    • При стандартных условиях.

    Подробнее о стандартных и нормальных условиях смотрите раздел: «Нормальные и стандартные условия».

  • Pmin на входе регулятора по умолчанию равно давлению на выходе — при включении данной опции: если у Регулирующих устройств значение поля Pmin (Минимальное давление) не задано (пусто), то по умолчанию оно будет равно значению поля Preg (Давление на выходе).

    Если не включать опцию, то минимальное давление на входе обязательно должно быть больше или равно давлению на выходе.

    [Примечание] Примечание

    В конструкторском расчете опция не действует и обязательно указывается Минимальное давление Pmin.


Настройка вида панели расчетов

На вкладке Вид вы можете настроить сортировку источников на панели расчётов: по какому полю сортировать и в каком порядке — по возрастанию или убыванию:

Сортировка источников на панели расчета

Рисунок 90. Сортировка источников на панели расчета

Настройка вида панели расчетов выполняется во вкладке Вид в настройках расчета:

  • Чтобы выбрать поле для сортировки нажмите кнопку ... и в открывшемся окне выберите нужное поле из списка.

  • Выбрать метод сортировки можно в списке Сортировка (см. рисунок ниже).

Диалог настройки расчета. Вкладка «Вид».

Рисунок 91. Диалог настройки расчета. Вкладка «Вид».


Настройка HASP

Настройка опроса сетевого ключа HASP выполняется во вкладке HASP диалога настройки расчетов. Функция включается/выключается установкой/снятием флажка Производить опрос сетевого ключа.

[Предупреждение] Предупреждение

Флажок обязательно должен быть установлен при использовании сетевого ключа, в противном случае расчет производиться не будет. При использовании локального ключа, данный флажок обязательно должен быть снят.

Диалог настройки расчета. Вкладка «Hasp».

Рисунок 92. Диалог настройки расчета. Вкладка «Hasp».


Вкладка Сервис

Вкладка Сервис панели гидравлических расчетов представлена на рисунке ниже:

Диалог настройки расчета. Вкладка Сервис

Рисунок 93. Диалог настройки расчета. Вкладка Сервис

На данной вкладке расположены следующие кнопки:

  • Длины участков с карты — кнопка позволяет считать длины участков с карты. Подробнее можно узнать в разделе «Автоматическое занесение длины с карты».

  • Отметки высот с карты — кнопка позволяет считать геодезические отметки со слоя рельефа. Подробнее можно узнать в разделе «Автоматическое занесение геодезических отметок объектов сети со слоя рельефа».

  • Начала и концы участков — кнопка позволяет считать наименования начала и конца участков. Подробнее можно узнать в разделе «Автоматическое занесение начала и конца участков».

  • Создать новую сеть — кнопка создания нового слоя газопроводной сети. Подробней о создании сети можно узнать в разделе «Создание слоя газопроводной сети».


Поверочный расчет газопроводной сети

Цель расчета

Целью поверочного расчета является определение расчетных расходов газа на участках газовой сети, давления во всех узловых точках и нарушения режима работы потребителей.

Созданная математическая имитационная модель системы газоснабжения, служащая для решения поверочной задачи, позволяет анализировать гидравлический режим работы системы, а также прогнозировать его изменения в случае каких-либо переключений. Расчеты могут проводиться при различных исходных данных, в том числе при отключении отдельных участков газовой сети. Состав газовой смеси может задаваться пользователем и это может быть не только природный газ, но и обычный воздух.

Поверочный гидравлический расчет системы газоснабжения возможен:

  • По всей системе целиком — от источника верхнего уровня, например ГРС до конечного потребителя газовой сети.

    [Предупреждение] Предупреждение

    Каждый источник многоступенчатой газораспределительной системы рассчитывается с заданными на нём параметрами Давления на выходе Preg. В поверочном расчете значение Давления на входе (Pin) на регуляторе используется только для проверки. Если в результате расчета Давление на входе меньше, чем Давление на выходе (Pin < Preg) — то будут отображаться предупреждающие сообщения: Предупреждение Z604: ID=XX Давление на входе регулятора ниже давления на выходе на ХХ.Х кПа.

    Дополнительно на регулирующем устройстве указывается Минимальное давление на входе (Pmin). Значение данного поля должно быть больше или равно, чем значение поля Давление на выходе (Pmin < Preg), иначе будет выведено соответствующее предупреждение Предупреждение Z602: ID=XX Давление на потребителе ниже минимального на XX.X кПа.

    Для поверочного расчета вы можете включить опцию Pmin равно давлению на выходе и оставить поле Pmin пустым.

  • От отдельного источника на любом уровне газовой сети (ГРС, ГРП или ШРП).

  • От указанного узла или участка — используется для упрощения процесса расчета при использовании очень больших и распределённых газопроводных сетей.

Только для расчета наружных газопроводных сетей: согласно СП 42-101-2003 или СТО ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2-1-2013, которые описывают расчеты распределительных газопроводных сетей с давлением до 1,2 МПа и до 2.5 МПа.

Расчет систем газоснабжения может производиться с использованием следующих методик (можно выбрать в настройках расчета):

  • При нормальных условиях работы по методическим рекомендациям СП 42-101-2003.

  • По СП 42-101-2003 c учетом температуры газа, отличающейся от нормальных условий.

  • По методике СТО ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2-1-2013 ПРОЦЕССЫ «Процесс работы с данными. Определение пропускной способности, расчет свободных мощностей газопроводов».

Согласно СТО ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2-1-201, возможен расчет пропускной способности системы газоснабжения и газораспределения.

Поверочный расчет при нехватке давления

В случае недостаточного давления на входе в регулятор (ГРС, ГРП, ШРП и т. д.) расчет можно провести с учётом пониженного давления на входе в регулирующее устройство или без его учёта. В настройках расчета вы можете выбрать способ расчета при нехватке давления.

[Подсказка] Подсказка

Независимо от способа расчета, при нехватке давления на потребителях и регуляторах, в окно сообщения будут выводиться соответствующие предупреждения.

Настройка Pout = Pmin отключена: без учета давления на входе, давление после регулирующего устройства будет равное давлению, заданному в исходных данных. В этом случае на графике падения давления будет видно, что несмотря на пониженное давление на входе в ГРП, регулирующее устройство все равно поддерживает заданное давление после себя (Рисунок 94, «Пример расчета с нехваткой давления и отключенной настройкой Pout = Pmin»).

Пример расчета с нехваткой давления и отключенной настройкой Pout = Pmin

Рисунок 94. Пример расчета с нехваткой давления и отключенной настройкой Pout = Pmin

Настройка Pout = Pmin включена: допустим, давление на ГРП на входе меньше расчётного на выходе, и нужно смоделировать ситуацию, чтобы определить, на каких потребителях давление упадёт ниже расчётного. В этом случае давление после регулирующего устройства будет определяться в результате расчета, не учитывая заданное в исходных данных значение (Рисунок 95, «Пример расчета с нехваткой давления и включенной настройкой Pout = Pmin»).

Пример расчета с нехваткой давления и включенной настройкой Pout = Pmin

Рисунок 95. Пример расчета с нехваткой давления и включенной настройкой Pout = Pmin


Знакомство с панелью расчетов

Панель гидравлических расчетов состоит из нескольких вкладок, каждая вкладка отвечает за определенный расчет:

Рисунок 96. Панель расчетов

  1. Вкладка выбора вида расчета.

  2. Кнопка выбора слоя.

  3. Окно выбора источника для расчета.

  4. Выбор встроенных тематических раскрасок для анализа расчета.

  5. Кнопка запуска расчета.

  6. Кнопка для открытия окна настроек расчетов.


Запуск поверочного расчета от источников

[Примечание] Примечание

Прежде чем запускать расчет, внимательно проверьте настройки расчетов (Настройка объектов слоя, данных и размерности полей).

Для запуска поверочного расчета:

  1. Выполните команду главного меню Задачи|ZuluGaz или нажмите на панели инструментов кнопку [image] . Откроется окно гидравлических расчетов:

    Вкладка «Поверочный» диалога гидравлических расчетов

    Рисунок 97. Вкладка «Поверочный» диалога гидравлических расчетов

  2. Откройте вкладку Поверочный.

  3. Нажмите кнопку Слой..., выберите слой рассчитываемой газопроводной сети и нажмите кнопку ОК чтобы подтвердить выбор и закрыть диалог.

    Окно выбора слоя

    Рисунок 98. Окно выбора слоя

  4. Для снятия выделения со всех элементов установите флажок у первого элемента в списке.

    Отметьте источник, для которого будет производиться расчет, установив флажок рядом с названием источника.

    Выбор источника для расчета

    Рисунок 99. Выбор источника для расчета

  5. Для подсчета пропускной способности отметьте опцию Расчет пропускной способности. (Подробнее «Расчет сетей по методике СТО ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2–1–2013»).

  6. Нажмите кнопку Расчет.

Если в ходе занесения исходной информации какие-либо данные необходимые для расчета не были внесены или были внесены неверно, то при проведении расчетов в окне сообщений программа выдаст уведомление ошибке красным цветом (Рисунок 100, «Ошибка при запуске расчета»). Программа следит не только за наличием необходимой информации, но и за ее логической верностью, то есть, если в поле будет занесен диаметр участка более 1.4 м, то программа выдаст ошибку. Более подробно о возможных ошибках можно узнать в разделе Возможные ошибки расчетов).

Ошибка при запуске расчета

Рисунок 100. Ошибка при запуске расчета

  1. Окно Сообщения.

  2. Сообщение об ошибке.

  3. Окно базы данных объекта, у которого обнаружена ошибка.

  4. Поле базы данных с ошибочным значением.

  5. Объект с ошибкой в данных.

При отсутствии ошибок в данных или конфигурации сети программа выполнит расчет выбранной сети и заполнит результатами расчета таблицы для каждого типа объекта газопроводной сети. Протокол расчета будет отображаться в нижней части экрана в панели Сообщения.


Запуск поверочного расчета от узла

Поверочные расчеты можно проводить от любого узла или участка, не находящихся в кольце. Узел указывается на схеме, задаётся начальное давление и проводится расчет от указанного узла.

Для выполнения поверочного расчета от узла:

  1. Выполните команду главного меню Задачи|ZuluGaz или нажмите на панели инструментов кнопку [image] . Откроется окно расчетов:

    Вкладка «Поверочный» диалога гидравлических расчетов

    Рисунок 101. Вкладка «Поверочный» диалога гидравлических расчетов

  2. Откройте вкладку Поверочный.

  3. Нажмите кнопку Слой..., выберите слой рассчитываемой газопроводной сети и нажмите кнопку ОК чтобы подтвердить выбор и закрыть диалог.

  4. Переключить режим расчета на Расчет подсети от узла:

    Выбор режима поверочного расчета

    Рисунок 102. Выбор режима поверочного расчета

  5. Выделить [image] на схеме газопроводной сети начальный узел (участок) для расчёта.

    [Подсказка] Подсказка

    В случае, если объект не выделяется следует производить щелчок мыши удерживая нажатыми клавиши Ctrl+Shift.

  6. На панели Поверочного расчета нажмите кнопку Выбрать подсеть. При этом, если установлена опция Выделить цветом, то подсеть для которой будет проводиться расчет, на карте выделяется красным цветом, а незадействованная в расчетах часть сети – серым.

    Выбор подсети для расчёт от узла

    Рисунок 103. Выбор подсети для расчёт от узла

  7. Указать Давление: и выбрать единицы измерения в начальном узле на панели поверочного расчета.

  8. Для подсчета пропускной способности отметьте опцию Расчет пропускной способности. (Подробнее «Расчет сетей по методике СТО ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2–1–2013»).

  9. Нажать кнопку Расчёт для выполнения расчета.


Результаты поверочного расчета

Во время расчета в окне сообщений ведется протокол, в котором отображаются этапы расчета и при удачном итоге появляется сообщение Расчет окончен и указывается время проведения расчета.

Протокол поверочного расчета

Рисунок 104. Протокол поверочного расчета

В результате расчета по каждому объекту газопроводной сети будут записаны итоговые данные. Для просмотра результатов необходимо открыть окно семантической информации по конкретному объекту и посмотреть результаты.

  • «По регулирующим устройствам»;

  • «По потребителям»;

  • «По колодцам на газопроводе»;

  • «По участкам газопроводной сети»;

  • «По запорной арматуре».

По регулирующим устройствам

  1. Pin, Давление на входе, кПа — в результате расчета определяется давление на входе.

  2. Pfact, Фактическое давление на выходе, кПа — определяется в результате расчета фактическое давление на выходе регулирующего устройства.

    Доступно с версии — 10.0.0.8221(дата релиза — 04.07.2022).

  3. Gin, Расход при нормальных условиях, м3/ч — определяется в результате расчета суммарный расход при нормальных условиях от регулирующего устройства.

  4. Gstd, Расход при стандартных условиях, м3/ч — определяется в результате расчета суммарный расход при стандартных условиях от регулирующего устройства.

  5. Ro_t, Плотность, кг/м3 — в результате расчета плотность газа в данном узле.

По потребителям

  1. Pin, Давление на входе, кПа - в результате расчета определяется давление на входе.

  2. Ro_t, Плотность, кг/м3 - в результате расчета определяется плотность газа.

По колодцам на газопроводе

  1. P, Давление, кПа - в результате расчета определяется давление в узле.

  2. Ro_t, Плотность, кг/м3 - в результате расчета определяется плотность газа.

По участкам газопроводной сети

  1. Lr, Расчетная длина участка, м - определяется расчетная длина участка.

  2. G, Расход при нормальных условиях, м3/час - в результате расчета определяется расход газа при нормальных условиях.

  3. Gstd, Расход при стандартных условиях, м3/час - - в результате расчета определяется расход газа при стандартных условиях.

  4. Gv, Фактический расход, м3/час - в результате расчета определяется фактический (по результатам расчета) расход газа участке в м3/час.

  5. Pin, Давление в начале участка, кПа - в результате расчета определяется давление в начале участка.

  6. Pout, Давление в конце участка, кПа - в результате расчета определяется давление в конце участка.

  7. dPfact, Потеря давления, кПа - в результате расчета определяется потеря давления на участке.

  8. V, Скорость в начале участка, м/сек - в результате расчета определяется скорость газа в начале участка.

  9. Re, Число Рейнольдса - в результате расчета определяется число Рейнольдса.

  10. Lamda, Коэффициент гидравлического трения - в результате расчета определяется коэффициент гидравлического трения.

  11. Pg, Гидростатическое давление, кПа - в результате расчета определяется гидростатическое давление.

  12. Nu, Кинематическая вязкость, м2/сек - в результате расчета определяется кинематическая вязкость.

По запорной арматуре

  1. Pin, Давление, кПа - в результате расчета определяется давление в узле.

  2. Gin, Расход, м3/час - в результате расчета определяется расход.

  3. Ro_t, Плотность, кг/м3 - в результате расчета определяется плотность газа.


Конструкторский расчет

Цель расчета

Целью конструкторского расчета газопроводной сети является определение диаметров трубопроводов, обеспечивающих пропуск расчетных расходов газа при обеспечении требуемого давления на потребителях.

Расчет можно проводить от одного или сразу от нескольких источников. Диаметры определяются как для тупиковых, так и для сложных кольцевых сетей газоснабжения. При подборе диаметров возможно ограничение источников по максимальному расходу газа.

Расчет систем газоснабжения может производиться с использованием следующих методик (можно выбрать в настройках расчета):

  • При нормальных условиях работы по методическим рекомендациям СП 42-101-2003.

  • По СП 42-101-2003 c учетом температуры газа, отличающейся от нормальных условий.

  • По методике СТО ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2-1-2013 ПРОЦЕССЫ «Процесс работы с данными. Определение пропускной способности, расчет свободных мощностей газопроводов».

Критерии подбора диаметров

Подобранные диаметры должны обеспечить пропуск расчетных расходов до каждого потребителя. При определении диаметров используются следующие критерии:

  • Начальное давление.

  • Вид прокладки трубопровода.

  • Соблюдение принципа телескопичности.

  • Выбор диаметров из созданного пользователем справочника.

Расчёт возможен с учётом дополнительных условий подбора диаметров:

  • По желанию диаметры ряда трубопроводов можно считать фиксированными.

  • Последовательное отключения участков сети, находящихся в кольце.

  • Последовательного отключения одного из источников.

  • Допустимое снижение расхода у определенных потребителей.

Исходные данные

Расход газа на потребителях либо явно задаётся пользователем, либо определяется на основании номинальных расходов газовых приборов и их количества (с учетом коэффициента одновременности). Возможно указать путевой расход на участке газовой сети.

У потребителей необходимо указать минимальное давление на вводе.

[Подсказка] Подсказка

Подробнее смотрите раздел Исходные данные для выполнения конструкторского расчёта.


Знакомство с панелью расчетов

Панель конструкторского расчета представлена ниже:

Знакомство с панелью расчетов

Рисунок 105. Знакомство с панелью расчетов

  1. Вкладка выбора вида расчета.

  2. Кнопка выбора подсети для расчета (после того, как объект выделен на экране).

  3. Опции подбора диаметров и управления сортаментом труб.

  4. Кнопка запуска расчёта.

  5. Кнопка открытия общих настроек проведения расчетов.

  6. Кнопка выбора слоя.


Запуск конструкторского расчета

[Примечание] Примечание

Прежде чем запускать расчет, внимательно проверьте настройки расчетов (Настройка объектов слоя, данных и размерности полей).

Для запуска конструкторского расчета:

  1. Выполните команду главного меню Задачи|ZuluGaz или нажмите на панели инструментов кнопку [image] . Откроется окно гидравлических расчетов.

  2. Нажмите кнопку Слой..., выберите слой рассчитываемой газопроводной сети, затем для подтверждения выбора и закрытия диалога нажмите кнопку ОК.

    Окно выбора слоя

    Рисунок 106. Окно выбора слоя

  3. В окне расчетов перейдите на вкладку Конструкторский.

    Вкладка «Конструкторский» диалога гидравлических расчетов

    Рисунок 107. Вкладка «Конструкторский» диалога гидравлических расчетов

  4. Далее необходимо указать системе подсеть для расчета, для этого нажмите на панели навигации кнопку Выделить [image] . Выберите на схеме газопроводной сети участок подключения к одному из регулирующих устройств. В случае, если объект не выделяется следует производить щелчок мыши удерживая нажатыми клавиши Ctrl+Shift.

  5. На панели Конструкторского расчета нажмите кнопку Выбрать подсеть.

    [Примечание] Примечание

    Если включена опция Выделить цветом то:

    • участки участвующие в расчете будут выделены цветом;

    • отключаемые участки в кольцах будут окрашены красным цветом;

    • участки, не попавшие в выборку - останутся без изменений.

  6. Установите параметры проведения конструкторского расчёта:

    • Включите опцию Округлять по сортаменту - в этом случае диаметры будут подобраны в соответствии со справочником по трубам. При отключении данной опции диаметры будут вычисляться быстрее, но без соответствия сортаменту Сортаменту.

    • Если необходимо, установить опцию учитывать Отключение источников - при включении данной опции, диаметры будут подбираться с учётом отключения источников (ГРС, ГРПС и т.д.).

    • Для подбора диаметров с учётом отключений в кольцах, выберите способ Отключение участков в кольцах:

      • Отключать каждый участок - в этом случае будет отключаться каждый участок в кольце.

      • Отключать участки у разветвлений - при этом способе расчёта, будут отключаться только начальные участки у основных разветвлений (время выполнения расчёта сокращается).

  7. Нажмите кнопку Расчет.

Результаты расчета можно посмотреть в базе данных по участкам газопроводной сети или построить график падения давления по выбранному направлению (подробней о графике падения давления можно узнать в разделе График падения давления).


Дополнительные условия подбора диаметров

  • Отключение источников

  • Отключение участков в кольцах

  • Учитывать снижение нагрузки

  • Фиксированный диаметр

Отключение источников

Конструкторский расчёт сети с несколькими источниками можно проводить с учётом отключения источников (ГРС, ГРПС и т.д.). В этом случае диаметры участков будут подбираться так, чтобы один из источников обеспечивал бесперебойную подачу газа. При выполнении расчетов с учетом отключения элементов сети, система последовательно выполняет несколько гидравлических расчетов. Во время первого расчета, без учета отключений, фиксируются начальные диаметры. В дальнейшем происходит корректировка подобранных диаметров с учетом отключений.

[Подсказка] Подсказка

При расчетах с учетом отключения источников, возможно учитывать снижение расхода газа (нагрузки) на потребителях.

Далее на картинках изображены несколько вариантов расчёта: без учета и с учётом отключения источников.

Диаметры, подобранные без учёта отключения источников

Рисунок 108. Диаметры, подобранные без учёта отключения источников

Диаметры, подобранные с учётом отключения источников

Рисунок 109. Диаметры, подобранные с учётом отключения источников

Отключение участков в кольцах

При расчёте диаметров возможно учитывать отключение участков газовой сети в кольцах. Такие участки будут выделены красным цветом. При выполнении расчетов с учетом отключения элементов сети, система последовательно выполняет несколько гидравлических расчетов. Во время первого расчета, без учета отключений, фиксируются начальные диаметры. В дальнейшем происходит корректировка подобранных диаметров с учетом отключений.

[Подсказка] Подсказка

При расчетах с учетом отключений участков в кольцах, возможно учитывать снижение расхода газа (нагрузки) на потребителях.

  • Отключать каждый участок - в этом случае диаметры будут определяться с учетом отключения каждого участка в кольце.

    Отключение всех участков в кольцах

    Рисунок 110. Отключение всех участков в кольцах

  • Отключать участки у разветвлений - при этом способе расчёта, будут отключаться только начальные участки у основных разветвлений. В этом случае время выполнения расчёта сокращается.

Отключение участков у разветвлений

Рисунок 111. Отключение участков у разветвлений

Учитывать снижение нагрузки

При подборе диаметров газопровода с учетом отключений (участков или источников), возможно учитывать возможное снижение расхода на потребителях (например, на время устранения аварии).

Допустимый процент снижения расхода газа следует указать у потребителей в поле Kg, Снижение нагрузки, %.

При запуске конструкторского расчёта необходимо чтобы была включена опция Учитывать снижение нагрузки.

Фиксированный диаметр

При проведении конструкторского расчёта возможно "зафиксировать" диаметр определённых участков. На таких участках сети ZuluThermo подбирать диаметр не будет, но будет учитывать при расчёте других трубопроводов.

Для того чтобы зафиксировать диаметр трубопровода:

  1. Внести значения диаметра трубопровода в поле diam, Диаметр внутренний, м.

  2. Указать 1 в поле diam_con_status, Статус при подборе диаметра, для фиксации диаметра.


Пример конструкторского расчета

Для примера будет использована сеть Пример сети высокого и среднего давления, которую можно загрузить через меню Меню Пуск/Zulu 8.0/Газоснабжение/Пример сети высокого и среднего давления.

Пример проведения расчета:

  1. Выберите команду главного меню Задачи|ZuluGaz или нажмите на панели инструментов [image] . Откроется диалог гидравлических расчетов. Выберите вкладку Конструкторский.

    Рисунок 112. Вкладка Конструкторский

  2. Нажмите кнопку Слой.., в открывшемся диалоге выберите слой рассчитываемой газопроводной сети и нажмите кнопку ОК чтобы подтвердить выбор и закрыть диалог.

    Диалог выбора слоя

    Рисунок 113. Диалог выбора слоя

  3. В режиме выделить [image] выберите участок газопроводной сети, для подсети которого будет производиться конструкторский расчет. Выбор производится нажатием на него левой кнопкой мыши, при этом выделенный участок замигает. В случае если объект не выделяется (слой не активный), следует повторить выделение удерживая нажатыми клавиши Ctrl+Shift. Расчет будет производиться для всех участков, расположенных в той же подсети, где и выделенный участок.

    Рисунок 114. Выделение участка

  4. На панели Конструкторского расчета нажмите кнопку Выбрать подсеть.

    Выбор участка подключения

    Рисунок 115. Выбор участка подключения

    Если включена опция Выделить цветом то:

    • участки участвующие в расчете будут выделены цветом;

    • отключаемые участки в кольцах будут окрашены красным цветом;

    • участки, не попавшие в выборку - останутся без изменений.

    Выделение сети цветом

    Рисунок 116. Выделение сети цветом

  5. Установите параметры проведения конструкторского расчёта:

    • Включите опцию Округлять по сортаменту - в этом случае диаметры будут подобраны в соответствии со справочником по трубам. При отключении данной опции диаметры будут вычисляться быстрее, но без соответствия сортаменту Сортаменту.

    • Если необходимо, установить опцию учитывать Отключение источников - при включении данной опции, диаметры будут подбираться с учётом отключения источников (ГРС, ГРПС и т.д.).

    • Для подбора диаметров с учётом отключений в кольцах, выберите способ Отключение участков в кольцах:

      • Отключать каждый участок - в этом случае будет отключаться каждый участок в кольце.

      • Отключать участки у разветвлений - при этом способе расчёта, будут отключаться только начальные участки у основных разветвлений (время выполнения расчёта сокращается).

  6. Нажмите кнопку Расчет. После проведения расчёта, результаты можно просмотреть, открыв окно семантической информации по рассчитанным участкам трубопроводов (поле Расчетный диаметр, м).

    Просмотр результатов конструкторского расчета

    Рисунок 117. Просмотр результатов конструкторского расчета


Результаты конструкторского расчета

В результате расчета по каждому объекту газопроводной сети будут записаны итоговые данные. Для просмотра результатов необходимо открыть окно семантической информации по конкретному объекту.

  • «По регулирующим устройствам»

  • «По потребителям»

  • «По узлам (колодцам на газопроводе)»

  • «По участкам газопроводной сети»

По регулирующим устройствам

  1. Pin, Давление на входе, кПа - в результате расчета определяется давление на входе регулирующего устройства.

  2. Gin, Расход, м3/час - в результате расчета определяется расход газа.

  3. Ro_t, Плотность, кг/м3 - в результате расчета определяется плотность газа.

По потребителям

  1. Pin, Давление на вводе, кПа - в результате расчета определяется давление на вводе.

  2. Po_t, Плотность, кг/м3 - в результате расчета определяется плотность газа.

По узлам (колодцам на газопроводе)

  1. P, Давление, кПа - в результате расчета определяется давление.

  2. Po_t, Плотность, кг/м3 - в результате расчета определяется плотность газа.

По участкам газопроводной сети

  1. Lr, Расчетная длина участка, м - определяется расчетная длина участка.

  2. G, Расход при нормальных условиях, м3/час - в результате расчета определяется расход при нормальных условиях.

  3. Gv, Фактический расход, м3/час - в результате расчета определяется фактический (по результатам расчета) расход газа участке в м3/час.

  4. Pin, Давление в начале участка, кПа - в результате расчета определяется давление в начале участка.

  5. Pout, Давление в конце участка, кПа - в результате расчета определяется давление в конце участка.

  6. dPfact, Потеря давления, кПа - в результате расчета определяется потеря давления на участке.

  7. V, Скорость в начале участка, м/сек - в результате расчета определяется скорость газа в начале участка.

  8. Re, Число Рейнольдса - в результате расчета определяется число Рейнольдса.

  9. Lamda, Коэффициент гидравлического трения - в результате расчета определяется коэффициент гидравлического трения.

  10. Pg, Гидростатическое давление, кПа - в результате расчета определяется гидростатическое давление.

  11. Nu, Кинематическая вязкость, м2/сек - в результате расчета определяется кинематическая вязкость.

  12. diam_con, Расчетный внутренний диаметр, м - в результате расчета определяется внутренний диаметр участка трубопровода.

  13. Dcon_n, Расчетный наружный диаметр, м - в результате расчета определяется наружный диаметр участка трубопровода.


Определение объема природного газа при аварийных выбросах

Цель расчета

Цель расчета - определения объема природного газа при аварийных выбросах из наружных газопроводов сетей газораспределения и газопотребления. Расчеты предназначены для организаций, осуществляющих эксплуатацию сетей газораспределения.

Расчет производится в соответствии с методическими рекомендациями, изложенными в методике ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2-2-2015 Процесс работы с данными «Порядок определения объема природного газа при аварийных выбросах» https://www.politerm.com/zulugaz/doc/12.2.2-2-2015.pdf.

В соответствии с методическими рекомендациями, объем аварийных выбросов из поврежденного участка сети (V) определяется по следующей формуле:

Рисунок 118.

, где:

  • Vа – объем аварийных выбросов из поврежденного участка газовой сети до проведения работ по локализации аварии, м3.

  • Vп – объем аварийных выбросов из поврежденного участка газовой сети после проведения работ по локализации аварии, м3;

  • Vпз – объем газа, затрачиваемый на продувку газом локализованного при аварии участка газовой сети, м3;

  • Vрег – объем газа, затрачиваемый на регулировку и настройку газового оборудования пунктов редуцирования газа, м3.

Дополнительно, в результате расчета определяется группа изолированных участков и режим газоснабжения, нормальный или с нарушением. В случае нарушения нормального режима газоснабжения определяется перечень отключаемых потребителей и производится перерасчет аварийного выброса без их участия.


Запуск расчета аварийного выброса

Цель расчета - определение объема природного газа при аварийных выбросах из наружных сетей газораспределения и газопотребления. Расчет производится в соответствии с методическими рекомендациями, изложенными в методике ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2-2-2015 «Порядок определения объема природного газа при аварийных выбросах»

Результаты расчета:

  • перечень изолированных при локализации аварии участков;

  • суммарный объем аварийных выбросов;

  • расходы газа на участках газовой сети с учетом аварийных выбросов;

  • давления в узловых точках с учетом аварийных выбросов;

  • режим газоснабжения, нормальный или с нарушением.

Расчет аварийного выброса возможно выполнить одним из следующих способов:

  • Расчет подсети от источников

    Расчет по-умолчанию, проводится от источников питающих выбранную подсеть.

  • Расчет подсети от выбранного узла

    Проводится от указанного пользователем узла, например колодца на газопроводе. В этом случае указывается начальное давление в этом узле.


Расчет аварийного выброса от источников

[Предупреждение] Предупреждение

Перед расчетом объемов природного газа при аварийных выбросах, необходимо выполнить поверочный расчет газопроводной сети и убедиться в корректности собранной электронной модели Поверочный расчет газопроводной сети

Расчет по-умолчанию, проводится от источников питающих выбранную подсеть. Для запуска расчета от источников:

  1. Выполните команду главного меню Задачи|ZuluGaz или нажмите на панели инструментов кнопку [image] . Откроется окно гидравлических расчетов.

  2. Нажмите кнопку Слой..., выберите слой рассчитываемой газопроводной сети и нажмите кнопку ОК чтобы подтвердить выбор и закрыть диалог.

  3. Перейдите на вкладку Аварийный выброс:

    Вкладка «Аварийный выброс»

    Рисунок 119. Вкладка «Аварийный выброс»

  4. В нижней части окна выберите из выпадающего списка Расчет от источников.

  5. Выделите участок на карте, для которого будет наблюдаться аварийный выброс с помощью кнопки Выделить [image] .

    [Подсказка] Подсказка

    В случае, если объект не выделяется следует производить щелчок мыши удерживая нажатыми клавиши Ctrl+Shift.

  6. Нажмите кнопку Участок…, при этом подсеть, для которой будет проводиться расчет, на карте выделяется красным цветом. Правее от кнопки будет указан ID аварийного участка, а в поле Источники, указаны источники от которых будет проводиться расчет.

  7. Внесите дополнительные исходные данные, такие как параметры аварии, параметры окружающей среды, параметры для продувки локализованной сети, параметры для задания регулировки газового оборудования.

    [Примечание] Примечание

    Все данные необходимо вносить в соответствии с методикой ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2-2-2015 «Порядок определения объема природного газа при аварийных выбросах»

  8. При необходимости принять давление неизменным во время аварии. установите опцию Постоянное давление в месте аварии.

  9. Нажмите кнопку Расчет. При отсутствии ошибок в данных или конфигурации сети программа выполнит расчет выбранной сети.


Расчет аварийного выброса от заданного узла

[Предупреждение] Предупреждение

Перед расчетом объемов природного газа при аварийных выбросах, необходимо выполнить поверочный расчет газопроводной сети и убедиться в корректности собранной электронной модели Поверочный расчет газопроводной сети

Расчет аварийного выброса может проводиться от указанного пользователем узла, например колодца на газопроводе. В этом случае указывается участок с аварией и начальное давление в подсети.

Для запуска расчета аварийного выброса от заданного узла:

  1. Выполните команду главного меню Задачи|ZuluGaz или нажмите на панели инструментов кнопку [image] . Откроется окно гидравлических расчетов.

  2. Нажмите кнопку Слой..., выберите слой рассчитываемой газопроводной сети и нажмите кнопку ОК чтобы подтвердить выбор и закрыть диалог.

  3. Перейдите на вкладку Аварийный выброс:

    Вкладка «Аварийный выброс»

    Рисунок 120. Вкладка «Аварийный выброс»

  4. В нижней части окна выберите из выпадающего списка Расчет подсети от узла.

  5. Выделите узел (колодец) или участок на карте, где начнется начало "подсети" с помощью инструмента Выделить [image] .

    [Подсказка] Подсказка

    В случае, если объект не выделяется следует производить щелчок мыши удерживая нажатыми клавиши Ctrl+Shift.

  6. Нажмите кнопку Выбрать подсеть…, при этом подсеть, для которой будет проводиться расчет, на карте выделяется красным цветом. В поле ID будет указан ID (Sys) выбранного аварийного участка.

  7. Теперь следует Выделить [image] участок подсети, для которого будет наблюдаться аварийный выброс. Выбранный участок выделится другим цветом.

  8. Укажите давление в начальном (выбранном) узле, для этого:

    1. Выберите необходимые единицы измерения: кПа, МПА или мм вод. ст.

    2. Задайте начальное давление в поле Давление.

  9. При необходимости принять давление неизменным во время аварии. установите опцию Постоянное давление в месте аварии.

  10. Внесите дополнительные исходные данные, такие как параметры аварии, параметры окружающей среды, параметры для продувки локализованной сети, параметры для задания регулировки газового оборудования.

    [Примечание] Примечание

    Все данные необходимо вносить в соответствии с методикой ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2-2-2015 «Порядок определения объема природного газа при аварийных выбросах». https://www.politerm.com/zulugaz/doc/12.2.2-2-2015.pdf

  11. Нажмите кнопку Расчет. При отсутствии ошибок в данных или конфигурации сети программа выполнит расчет выбранной подсети от узла.


Дополнительные исходные данные для расчета аварийного выброса

При расчете аварийного выброса производится последовательное выполнение нескольких поверочных расчетов, соответственно перечень основных исходных данных по объектам газовой сети, полностью соответствует тем, что необходимы для выполнения поверочного расчета.

Для определения аварийного выброса дополнительно требуется внести ряд специфических данных. Все данные необходимо вносить в соответствии с методикой ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2-2-2015 «Порядок определения объема природного газа при аварийных выбросах». Эти данные указываются только в окне ZuluGaz перед запуском расчета.

Исходные данные для выполнения расчета

Рисунок 121. Исходные данные для выполнения расчета

К дополнительным исходным данным можно отнести:

  1. Параметры аварии:

    1. Место аварии (0-1) – заносится в долях от единицы, где 0 - начало участка, 1 – конец участка.

    2. Площадь отверстия - площадь аварийного отверстия в трубе газопровода, заносится в м2. Если площадь отверстия больше площади сечения трубы, в расчете принимается площадь сечения трубы.

    3. Время до локализации аварии - время истечения аварийного объема газа из газопровода до проведения работ по локализации аварии, заносится в часах.

  2. Параметры окружающей среды

    1. Т наруж. воздуха - температура наружного воздуха, заносится в ˚C.

    2. Атмосферное давление, Па.

  3. Параметры для продувки локализованной сети:

    1. Норматив. давление - нормативное значение давления газа, до которого ведется продувка газопровода газом после ликвидации последствий аварии, Па.

    2. Поправочный коэффициент, учитывающий реальное увеличение расхода газа на продувку.

  4. Параметры для задания регулировки газового оборудования:

    1. Внутренний диаметр продувочной свечи, м.

    2. Время регулировки - суммарное время, в течение которого осуществляется сброс газа в атмосферу при проведении работ по регулировке и настройке газового оборудования, заносится в часах.


Результаты расчета аварийного выброса

В результате расчета на карте зеленым цветом отобразится группа локализованных запорной арматурой участков. Результаты расчета аварийного выброса по локализованным участкам отображаться в нижней части экрана в панели Сообщения. Результаты гидравлического расчета для каждого типа объекта газопроводной сети будут заполнены в таблицы.

Результаты расчета аварийного выброса

Рисунок 122. Результаты расчета аварийного выброса

Результаты расчета можно разделить на 4 категории:

  1. Группа изолированных участков.

  2. Основные результаты расчета по объемам природного газа при аварийных выбросах.

  3. Результаты гидравлического расчета по объектам.

  4. Нарушение режима газоснабжения.

Подробное описание результатов расчета и возможные предупреждения представлены далее:

  1. Аварийный участок – подсвечивается розовым цветом.

    Группа локализованных запорной арматурой участков подсвечивается на карте зеленым цветом.

  2. Результаты расчета аварийного выброса по локализованным участкам отображаться в нижней части экрана в панели Сообщения. В результате расчета определяются:

    • Расход из аварийного отверстия до локализации при нормальных условиях, м3/ч.

    • Расход из аварийного отверстия до локализации при стандартных условиях, м3/ч.

    • Давление газа в месте аварии до локализации, кПа.

    • Плотность газа в месте аварии до локализации, кг/м3.

    • Объем аварийных выбросов из поврежденного участка до проведения работ по локализации, м3.

    • Объем аварийных выбросов из поврежденного участка после проведения работ по локализации, м3.

    • Объем газа, затрачиваемый на продувку газом локализованного участка, м3.

    • Объем газа, затрачиваемый на регулировку и настройку газового оборудования, м3.

    • Суммарный объем аварийных выбросов из поврежденного участка, м3.

  3. Результаты гидравлического расчета для каждого типа объекта газопроводной сети будут заполнены в таблицы. Значения и их перечень аналогичны результатам поверочного расчета, за исключением того, что получены с учетом определенного расхода аварийных выбросов из поврежденного участка.

  4. Определение режима газоснабжения, нормальный или с нарушением.

    В результате расчета в окне Сообщения может выводиться предупреждение: «Предупреждение Z602: ID=1 Давление на потребителе ниже минимального на XX.XXX кПа», которое сообщает о том, что авария будет протекать при нарушении нормального режима газоснабжения. Нарушение наступает в случае, если полученное в результате гидравлического расчета давление на вводе в потребитель, ниже Минимально необходимого и данный потребитель отключен от системы газоснабжения.


Определение времени работы газопровода на остаточном давлении при отключении источника

Цель расчета

Определить время работы системы газоснабжения на остаточном давлении, после отключения источника (среднего и высокого давления).

В результате расчета определяются:

  1. Объем остаточного запаса газа при нормальных и стандартных условиях, м3.

  2. Время работы на остаточном давлении после отключения источника, час.

  3. Расходы газа на участках газовой сети, давления во всех узловых точках, при минимально допустимом режиме работы сети на остаточном давлении.


Знакомство с панелью расчетов

Панель расчета остаточного запаса газа представлена ниже:

Знакомство с вкладкой «Остаточный запас»

Рисунок 123. Знакомство с вкладкой «Остаточный запас»

  1. Кнопка выбора слоя для расчета.

  2. Вкладка выбора вида расчета.

  3. Кнопка выбора источника (ГРС, ГРП) для расчета.

  4. Опция выделения цветом.

  5. Опции выполнения расчета.

  6. Кнопка открытия настроек расчетов.

  7. Кнопка запуска расчета.


Запуск расчета остаточного запаса газа

[Предупреждение] Предупреждение

Перед расчетом необходимо выполнить поверочный расчет газопроводной сети и убедиться в корректности собранной электронной модели Поверочный расчет газопроводной сети

Для запуска расчета и определения времени работы с использованием остаточного запаса газа:

  1. Выполните команду главного меню Задачи|ZuluGaz или нажмите на панели инструментов кнопку [image] . Откроется окно гидравлических расчетов.

  2. Перейдите на вкладку Остаточный запас:

    Вкладка «Остаточный запас»

    Рисунок 124. Вкладка «Остаточный запас»

  3. Нажмите кнопку Слой..., выберите слой рассчитываемой газопроводной сети и нажмите кнопку ОК чтобы подтвердить выбор и закрыть диалог.

  4. Выделите Источник (ГРС, ГРП) на карте, для которого будет проводиться расчёт запаса с помощью кнопки Выделить [image] .

    [Подсказка] Подсказка

    В случае, если объект не выделяется следует производить щелчок мыши удерживая нажатыми клавиши Ctrl+Shift.

  5. Проверить значение Давление в момент отключения, автоматически считываемое с выбранного источника. При необходимости, значение и единицы измерения можно изменить.

  6. Нажать кнопку Расчет. В окне сообщений отобразятся результаты расчета. Подробнее о результатах смотрите соответствующий раздел: «Результаты расчета остаточного запаса газа».


Результаты расчета остаточного запаса газа

  1. Результаты гидравлического расчета при минимально допустимом режиме работы сети на остаточном давлении будут заполнены в таблице. Значения и их перечень аналогичны результатам поверочного расчета

  2. Результаты расчета остаточного запаса газа отображаются в нижней части экрана в панели Сообщения. В результате расчета определяются:

    Результаты расчета остаточного запаса газа

    Рисунок 125. Результаты расчета остаточного запаса газа

    • Объем остаточного запаса газа при нормальных условиях, м3.

    • Объем остаточного запаса газа при стандартных условиях, м3.

    • Время работы на остаточном давлении после отключения источника, час


Описание расчета остаточного запаса газа

Определяется масса газа в отключаемых трубопроводах на момент отключения источника:

Рисунок 126.

, где m – количество элементарных участков;

Vi - геометрический внутренний объём i-го элементарного участка трубопровода, м3;

ρ i ср - средняя плотность газа на i-ом элементарном участке, кг/м3.

Определяется масса газа в отключаемых трубопроводах при предельно допустимом режиме работы сети.

Под этим режимом подразумевается, что у самого "плохого" потребителя обеспечивается минимально допустимое давление на вводе.

Рисунок 127.

Рассчитывается массовый запас газа в сети:

Рисунок 128.

Определяется объем остаточного запаса при нормальных условиях:

Рисунок 129.

, где ρ 0 - плотность газа при нормальных условиях, кг/м3

Рассчитывается объем остаточного запаса при стандартных условиях:

Рисунок 130.

, где ρ 20 - плотность газа при стандартных условиях, кг/м3

Определяется время работы после отключения источника:

Рисунок 131.

, где ∑Q0 - суммарный расчетный расход газа на отключаемых потребителях, м3/ч.


Расчёт резерва пропускной способности сетей газоснабжения

Цель расчета — определение резерва пропускной способности газопроводов. В результате расчета определяются максимально возможные для подключения расходы для каждого участка сети.

[Внимание] Внимание

Расчет Резерв пропускной способности требует лицензию на поверочный расчет, и должен проводиться только после проведения поверочных расчетов!

При выполнении данной задачи осуществляется проход с заданным пользователем шагом по всем газопроводам. На каждом шаге имитируется точка подключения и определяется максимально возможный расход в этой точке, при условии обеспечения минимальным давлением. Расчет можно выполнять с (и без) учетом максимально допустимых скоростей движения в газопроводах. Для ограничения максимального расхода на источнике газоснабжения следует задать поле Максимальный расход при нормальных условиях, м3/ч, Gmax_norm.

[Примечание] Примечание

При отсутствии данного поля в базе данных, следует добавить его и настроить поле, чтобы оно участвовало в расчете.

Расчёт может выполнятся (можно выбрать в настройках расчета):

  • по своду правил СП 42.101-2003 с учетом нормальных условий при температуре газа 0 °С;

  • с учетом температуры газа отличной от нормальных условий;

  • в соответствии с СТО ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2-1-2013 (учитывая сжатие газа)

Результаты расчета по каждой точке накапливаются в результирующем слое для записи. Для визуализации результата каждый участок результирующего слоя в зависимости от значения величины подключаемого расхода можно раскрашивать в цвета задаваемые пользователем. Количество цветов и диапазонов пользователь может менять самостоятельно.

Если сеть большая, есть возможность выполнить расчёт только для выделенных объектов сети.

Пример результатов расчёта резерва газовой сети

Рисунок 132. Пример результатов расчёта резерва газовой сети


Знакомство с панелью расчёта

Познакомьтесь с панелью расчета резерва сети:

Знакомство с вкладкой Резерв сети

Рисунок 133. Знакомство с вкладкой Резерв сети

  1. Выбор источника для расчета.

  2. Параметры проведения расчёта.

  3. Здесь, во время расчёта будет выводится процент выполнения.

  4. Кнопка запуска расчёта.

  5. Кнопка выбора слоя для расчета.

  6. Настройка цветов и диапазонов раскраски для результатов расчёт


Запуск расчёта

[Предупреждение] Предупреждение

Перед запуском расчета резерва обязательно следует:

  1. Выполнить поверочный расчет, чтобы убедиться в корректности собранной электронной модели Поверочный расчет газопроводной сети и отсутствии ошибок.

  2. Для ограничения максимального расхода на источнике газоснабжения следует задать поле Максимальный расход при нормальных условиях, м3/ч, Gmax_norm.

Для запуска расчета резерва газовой сети:

  1. Выполните команду главного меню Задачи|ZuluGaz или нажмите на панели инструментов кнопку [image] . Откроется окно гидравлических расчетов.

  2. Перейдите на вкладку Резерв сети:

  3. Нажмите кнопку Слой..., выберите слой рассчитываемой сети и нажмите кнопку ОК чтобы подтвердить выбор и закрыть диалог.

  4. Отметьте источник, для которого будет производиться расчет, установив флажок рядом с названием источника (ГРС, ГРП).

    [Подсказка] Подсказка

    Для расчёта выделенного фрагмента сети установите опцию Только выделенные участки.

    Вкладка Резерв сети

    Рисунок 134. Вкладка Резерв сети

  5. На панели укажите параметры проведения расчёта:

    • Hmin, кПа - минимальное давление в точках подключения.

    • Шаг, м - расстояние между расчётными точками.

  6. Чтобы включить проверку и ограничение по максимальной скорости движения газа, установить опцию Ограничение по скоростям.

  7. Нажмите кнопку Настройка цветов чтобы настроить цвета отображения в зависимости от значения величины подключаемого расхода.

    Настройка диапазонов и цветов отображения

    Рисунок 135. Настройка диапазонов и цветов отображения

  8. Нажмите кнопку Расчёт, откроется окно, где следует указать слой для записи результатов. В строке Имя файла введите имя файла латинскими символами и нажмите кнопку Сохранить.

    [Предупреждение] Предупреждение

    Если будет выбрано имя файла уже существующего слоя, то в результате создания нового слоя существующий слой будет уничтожен, и вместо него создастся новый.

  9. Во время выполнения расчета, на панели расчёта выводится процент выполнения.

  10. В протоколе расчета последовательно будет выводится информация о каждой точке подключения, на каком она участке, в каком месте и значение максимально возможного расхода, для подключения к этой точке.

    После окончания расчёта слой с результатами добавится в карту.

Слой с результатами расчёта резерва газовой сети

Рисунок 136. Слой с результатами расчёта резерва газовой сети


Результаты расчёта

Слой с результатами расчёта резерва сети повторяет геометрию сети, но состоит из более мелких сегментов, которые являются результатом разбиений исходных участков с заданным шагом. На конце каждого сегмента находятся расчётные точки, для которых определялись максимальные расходы для подключения.

Расчет ведётся по точкам, но для наглядности результатов раскрашиваются линейные объекты.

Слой с результатами расчёта резерва газовой сети

Рисунок 137. Слой с результатами расчёта резерва газовой сети

По каждой точке и линейному объекту в базу данных будет записаны:

  1. ID участка

    Идентификатор (SYS, ID) исходного участка газовой сети.

  2. Диаметр, м

    Диаметр исходного участка газовой сети.

  3. Расход при нормальных условиях, м3/ч

    Дополнительный расход (при н.у.), нм3/ч – максимальное значение расхода, которое может быть дополнительно подключено к сети при параметрах, указанных для Поверочного расчета, и ограничениях в точке подключения заданных в настройках расчета Резерва сети. Означает, что к данному фрагменту трубопровода можно подключить расход не менее указанного.

  4. Фактический расход, м3ч

    Существующий расход (при н.у.), нм3/ч – значение расхода равное расходу на участке при нормальных условиях, рассчитанному в результате Поверочного расчета.

  5. Давление, кПа

    Давление после подключения, кПа – давление в точке после добавления дополнительного расхода (определяется как результат поверочного расчета по сумме дополнительного и существующего расходов).

Результаты расчёта резерва газовой сети

Рисунок 138. Результаты расчёта резерва газовой сети


Технологическая схема

  • «Введение»

  • «Экспорт технологической схемы»

  • «Возможные ошибки при построении технологической схемы»

Введение

ZuluGaz 2021 позволяет создать технологическую ортогональную схему, по принципам описанным в ГОСТ Р 70107-2022 " Системы газораспределительные. Сети газораспределения. Общие требования к графическому отображению объектов сетей газораспределения".

Построение технологической схемы происходит на основе существующего слоя газовой сети, с наследованием ID (Sys) и атрибутов исходной газовой сети (базами данных). Участки в технологической схеме могут автоматически объединяться в один по различным условиям. Например, можно использовать поле с диаметром трубопровода. Если участки идут последовательно и между ними объект, который не участвует в экспорте (не отмечен галочкой в окне настроек Рисунок 146, «Настройка экспорта объектов»), то участки с одинаковым диаметром будут объединены в один. При объединении вы можете указать Поля для суммирования, например потери давления на участках или сумму местных сопротивлений и прочие поля.

Схема создается без системы координат (план-схема локальный датум). Пользователь указывает для какой газовой сети (от какого регулирующего устройства) будет происходить экспорт газовой сети.

[Предупреждение] Предупреждение

Сеть должна быть топологически связана!

В результате преобразования и экспорта в новом слое объекты технологической схемы автоматически располагаются, соблюдая принцип ортогональности, то есть с углом поворота, кратным 90°. При этом ориентация осей газопроводов по сторонам света может не соответствовать фактическому, так как для технологических схем сетей газораспределения привязка к плану населенного пункта не требуется.

При экспорте можно экспортировать только геометрию, надписи объектов, включая отключенные объекты слоя. В результирующей схеме можно избежать лишних пересечений, не учитывая их при построении. Подробнее о всех опциях создания технологической схемы, смотрите в разделе «Экспорт технологической схемы».

На следующей картинке далее приведён пример исходного слоя газовой сети, который далее будет экспортирован в ортогональную технологическую схему.

Исходный слой газовой сети

Рисунок 139. Исходный слой газовой сети

Результат преобразования представлен на картинке ниже Рисунок 140, «Результат экспорта слоя в ортогональную технологическую схему». Слой был преобразован с сохранением исходных топологических связей, баз данных и данных.

Результат экспорта слоя в ортогональную технологическую схему

Рисунок 140. Результат экспорта слоя в ортогональную технологическую схему

Вы можете выбрать какие узловые объекты будут участвовать в преобразовании, отметив их в списке объектов для экспорта технологической схемы (иначе они будут преобразованы как типовой узловой элемент узел, разветвление).

В базе данных по участках указываются поля с именем собственника, содержащее имя собственника. При экспорте схемы в точках, где собственник меняется будет изображена линия с надписями:

Отображение смены собственника на схеме

Рисунок 141. Отображение смены собственника на схеме


Экспорт технологической схемы

Для экспорта технологической схемы:

  1. Выполните команду главного меню Задачи|ZuluGaz или нажмите на панели инструментов кнопку [image] . Откроется окно расчетов ZuluGaz.

  2. Перейдите на вкладку Технологическая схема:

    Вкладка Технологическая схема

    Рисунок 142. Вкладка Технологическая схема

  3. Нажмите кнопку Слой..., выберите слой рассчитываемой газовой сети и нажмите кнопку ОК.

  4. Отметьте источник, для которого будет производиться расчет, установив флажок рядом с названием источника.

    Для снятия выделения со всех элементов установите флажок у первого элемента в списке.

    Выбор источника для расчета

    Рисунок 143. Выбор источника для расчета

  5. Укажите опции экспорта:

    • Только геометрия — при включении данной опции экспортирована будет только графика, без баз данных и надписей.

    • Показать результат в новом окне — после выполнения экспорта слой откроется в новом окне (новой карте).

    • Включать надписи — включите для экспорта бирок слоя на технологическую схему. Чтобы выбрать какие именно надписи будут экспортированы, нажмите кнопку Надписи и отметьте надписи для экспорта.

    • Сохранять переломы под прямым углом — при включении данной опции все повороты под прямым углом будут сохранены и повторяться в экспортированной схеме. На рисунке ниже исходная схема (1) и ниже показаны результаты без сохранения переломов (2) и с сохранением переломов (3).

      Сохранение переломов на схеме

      Рисунок 144. Сохранение переломов на схеме

    • Игнорировать отключения — при включении этой опции, ZuluGaz не учитывает отключения (отключенные участки, задвижки) и создает технологическую схему, включая в неё все связанные элементы.

    • Не обрабатывать пересечения — по умолчанию ZuluGaz учитывает все пересечения газопроводов при построении технологической схемы: если в исходном слое есть пересечение газопроводов, то и в готовой схеме оно тоже будет.

      [Примечание] Примечание

      В рассматриваемой ситуации речь идёт о визуальном пересечении газопроводов, при этом они не соединены между собой гидравлически.

      Чтобы в результирующей схеме не было пересечений, следует включить данную опцию.

      Пример построения схемы представлен на рисунке ниже:

      Построение схемы с опцией "Не обрабатывать пересечения"

      Рисунок 145. Построение схемы с опцией "Не обрабатывать пересечения"

    • Суммировать длины по зонам собственников — при включении суммируются длины по зонам собственников и позволяет установить дополнительные опции:

      • Один код для всех зон одного объекта — при включении данной опции участки одного владельца будут обозначены одинаковым кодом зоны. В противном случае участки одного собственника в разных зонах будут иметь разные номера зон.

      • Заполнять зоны без собственника кодами соседей — при включении данной опции, на участках у которых не указан собственник, код зоны собственника будет заполнен кодом "соседних" объектов (иначе это поле останется пустым).

  6. Чтобы заполнить номера зон введите собственников в базе данных по участкам и нажмите кнопку Зоны. В результате будут определены и записаны номера зон в соответствующих полях.

    [Примечание] Примечание

    Если полей в базе данных нет, то их следует добавить и настроить для участия в расчете.

  7. Для настройки объектов, которые будут участвовать в экспорте нажмите кнопку Настройка экспорта. Объекты, не указанные в настройках экспорта, будут преобразованы как типовой узловой элемент узел (разветвление).

  8. В открывшемся окне настройки объектов:

    Настройка экспорта объектов

    Рисунок 146. Настройка экспорта объектов

    1. Отметьте объекты (типы и режимы), которые будут участвовать в экспорте. Для выбора всех объектов установите галочку Все.

    2. Участки можно объединить в один на технологической схеме по различным условиям. Для этого вы можете указать:

      • Совпадение значений полей — указывается имя поля, по которому будет определяться одинаковые ли участки и объединять их в один.

        Например, можно использовать поле с диаметром трубопровода. Если участки идут последовательно и между ними объект, который не участвует в экспорте (не отмечен галочкой в окне настроек Рисунок 146, «Настройка экспорта объектов»), то участки с одинаковым диаметром будут объединены в один.

        Указываются реальные (имя поля) имена полей. Возможно указать несколько полей, для этого используйте разделитель точку с запятой ;. Например: diam; ..., где diam - диаметр участка. При указании нескольких полей участки будут объединены только если совпадают оба указанных поля (диаметр и материал).

        При объединении вы можете указать Поля для суммирования, например потери давления на участках или сумму местных сопротивлений и прочие поля. Указываются в данном окне в Полях для суммирования.

      • Совпадение типов — при включении данной опции участки будут объединяться не только по критерию Название поля, но и при условии совпадения типов. Если данную опцию не включать, то по данному полю будут объединяться участки разных типов.

      • Совпадение режимов — при включении данной опции участки будут объединяться не только по критерию Название поля, но и при условии совпадения режимов (и типов, если включена соответствующая опция). Если данную опцию не включать, то по названию будут объединяться участки разных режимов.

      • Поля для суммирования при объединении — указываются реальные имена полей. Возможно указать несколько полей, для этого используйте разделитель точку с запятой ;. Например: dPfact; ..., где dPfact - сумма потерь давления на участке.

    3. Опция Проверять переломы под острым углом включена по умолчанию и Минимальный угол в градусах указывается в поле рядом с опцией — перед экспортом будет проводиться проверка и если угол между объектам будет меньше 45° (значение по умолчанию), то будет выведено сообщение об ошибке и экспорт будет остановлен. Подробнее смотрите «Возможные ошибки при построении технологической схемы».

    4. Для сохранения настроек нажмите кнопку ОК.

  9. Чтобы запустить экспорт технологической схемы нажмите кнопку Расчет.

  10. В открывшемся диалоге укажите расположение и название слоя с результирующей технологической схемой. В строке Имя файла введите имя слоя и нажмите кнопку Сохранить.

    [Предупреждение] Предупреждение

    Если будет выбрано имя файла уже существующего слоя, то в результате создания нового слоя существующий слой будет уничтожен, и вместо него создастся новый.

  11. Введите пользовательское Название слоя и нажмите ОК.

    Начнется экспорт технологической схемы. Если включена опция Показать результат в новом окне, то после выполнения экспорта слой откроется в новом окне (новой карте).


Возможные ошибки при построении технологической схемы

  • DS_ZTECH_DUPLICATED_OBJECTS "Дублирование объектов: ID=XX"

    Ошибка возникает из-за дублирования объектов. В ошибке указан идентификатор ID (SYS) объекта с ошибкой.

    Для поиска всех дублированных объектов вы можете воспользоваться функцией выделения дублированных объектов.

    Чтобы исправить ошибку следует удалить объекты дубли.

  • IDS_ZTECH_COROSS_POINT_FAILED "Не удалось вставить точку пересечения:"

  • IDS_ZTECH_CROSS_CHECK "Ошибка в проверке пересечений схемы"

  • IDS_ZTECH_DEAD_END_CREATEION "Ошибка создания тупиков"

  • IDS_ZTECH_LABEL_NON_SCALABLE "Обнаружены немасштабируемые варианты бирок"

  • IDS_ZTECH_LINE_90_ANGLE "Линия не под прямым углом"

  • IDS_ZTECH_LINE_IN_POLYLINE "Линия является составной частью полилинии"

  • IDS_ZTECH_SHARP_ANGLES "Обнаружены участки с точками перелома под углом меньше 45°"

    Ошибка возникает если в настройках топологической схемы установлена опция Проверять переломы под острым углом. Угол 45° указан по умолчанию и может быть задан отличным от этого значения - тогда ошибка будет содержать указанное значение угла (например: если указано 30, то программа будет "ругаться" на углы меньше 30 градусов). В ошибке указан идентификатор ID (SYS) объекта с ошибкой.

    Следует либо графически исправить ошибки (изменить геометрию объектов) либо отключить данную опцию.

  • IDS_ZTECH_SHARP_INZIDENTS "Обнаружены участки, выходящие из одного узла, между которыми очень малый угол"

  • IDS_ZTECH_TOO_MUCH_PIPES "Из узла выходит более четырех участков:"

  • IDS_ZTECH_WITHIN_OBJECTS "Узел лежит на участке:"

Следующие "внутренние ошибки" пользователь исправить самостоятельно не сможет, следует сразу связаться с разработчиками ZuluGaz. Список внутренних ошибок:

  • IDS_ZTECH_PLEASE_CONTACT_US "Внутренняя ошибка. Свяжитесь с разработчиками"

  • IDS_ZTECH_SCHEME_CREATEION "Ошибка создания схемы"

  • IDS_ZTECH_BLOCK_CREATION "Ошибка создания блока"

  • IDS_ZTECH_BLOCK_CREATION_2 "Ошибка создания блока 2"

  • IDS_ZTECH_BLOCK_BUILD "Ошибка при построении блока"

  • IDS_ZTECH_BLOCK_ALIGNMENT "Ошибка в выравнивании блока"

  • IDS_ZTECH_BLOCK_CONNECTION "Ошибка соединения блоков"

  • IDS_ZTECH_BLOCK_MOVE_OBJECTS "Ошибка при движении объектов при создании блока

  • IDS_ZTECH_CHECK_NAIGHBOURS "Ошибка при проверке соседей"


Коммутационные задачи

Введение

Модуль Коммутационные задачи — это инструмент, который позволяет определять объекты газовой сети и здания, подлежащие отключению, выделять их на карте и формировать таблицы с информацией об отключениях. Поддерживает несколько режимов работы:

  • Анализ переключений

    Пользователь указывает элементы газовой сети (потребителя или участок), на котором произошла авария, и коммутационные задачи помогут быстро найти ближайшую запорную арматуру для отключения аварийных объектов. Отключенные участки, потребители и здания отображаются на карте в виде тематической раскраски. По отключаемым объектам формируется таблица-отчет, поля которой можно настроить самостоятельно. Также определяются итоговые значения: расход газа на продувку, заполнение и настройку газового оборудования.

    Пользователь может сохранить конфигурацию с перечнем отключаемых элементов сети, чтобы быстро вернуться к необходимой «аварийной ситуации».

  • Поиск в слое подложке

    Позволяет осуществить поиск в заданном слое (обычно слой зданий) — подложке объектов, местоположение которых совпадает с местоположением потребителей в слое сети.

    Слой подложка обычно представляет собой слой зданий, представленный в виде площадных объектов. Поиск в слое подложке позволяет определить здания, в которых находятся потребители газовой сети, и выделить их соответствующим цветом. Здания с активными потребителями будут окрашены в один цвет, а с отключенными — в другой. Результаты поиска также выводятся в таблицу-отчет.

    Пример поиска изолирующих задвижек с помощью Коммутационных задач

    Рисунок 147. Пример поиска изолирующих задвижек с помощью Коммутационных задач

Сформированные отчетные таблицы вы можете напечатать или экспортировать в Microsoft Excel.

Особенности коммутационных задач

  • Для выполнения коммутационных задач надо обязательно изображать на сети ВСЕ запорные устройства.

  • Используется 2 категории слоев: топологическая модель сети и слой подложка с объектами капитального строительства.

  • Модель открывается в режиме "чтения", изменения в математическую модель не заносятся.

[Предупреждение] Предупреждение

Слой сети и слой-подложка должны быть либо на сервере, либо локально!

[Примечание] Примечание

Для правильной работы коммутационных задач необходимо чтобы структура слоя была подготовлена (как отрыть структуру слоя смотрите «Общие сведения о структуре слоя»):

  • у типа Участок должно быть обязательно определено соответствующее состояние, то есть у участков с режимом Включен в списке Состояние было выбрано Включен. У отключенных соответственно - Отключен:

    Рисунок 148. Структура слоя

  • у типа Регулирующее устройство - графический тип должен быть определен как Символьный, Объект инженерных сетей/Источник:

    Рисунок 149. Структура слоя

Смотрите также:

  • «Анализ переключений».

  • «Поиск в слое-подложке».

  • «Настройки коммутационных задач».

  • «Работа со списком объектов».

  • «Просмотр результатов расчета».

  • «Экспорт в MS Excel».


Знакомство с окном Коммутационные задачи

Перед запуском расчета познакомимся с окном коммутационных задач (смотрите Рисунок 150, «Знакомство с окном Коммутационные задачи»).

Знакомство с окном Коммутационные задачи

Рисунок 150. Знакомство с окном Коммутационные задачи

  1. Вкладка выбора расчета Анализ переключений или Поиск в слое подложке.

  2. Поле выбора конфигурации (списка объектов) и кнопки действий с конфигурацией.

    Конфигурация хранит перечень отключаемых элементов сети, чтобы быстро вернуться к необходимой «аварийной ситуации».

  3. Список переключаемых объектов газовой сети.

  4. Дополнительные опции расчета:

    • Учитывать только изолированную область — при включении данной опции, итоговые значения (суммарный объем воды) будут рассчитываться только для отключенных участков.

    • Учитывать направление участков для отсекающих устройств — указывает, следует ли учитывать направления участков при поиске отключающих устройств.

    • Автообновление — отвечает за автоматическое обновление раскраски инженерной сети, при добавлении объектов в список переключений.

  5. Кнопка выбора слоя.

  6. Выбор действия с объектом (отключение, изолирования от источника):

    • Включить — режим объекта устанавливается на «Включен»;

    • Выключить — режим объекта устанавливается на «Выключен»;

    • Изолировать от источника — режим объекта устанавливается на «Выключен». При этом автоматически добавляется в список и переводится в режим отключения вся изолирующая объект от источника запорная арматура;

    • Отключить от источника — режим объекта устанавливается на «Выключен». При этом автоматически добавляется в список и переводится в режим отключения вся отключающая объект от источника запорная арматура.

  7. Кнопки добавления и удаления объектов в список переключений (3).

  8. Кнопка запуска расчета.

  9. Настройки модуля.


Анализ переключений

Цель анализа переключений – поиск ближайшей запорной арматуры для отключения и изоляции элемента сети (участок, потребитель и т.д.).

Пользователь указывает элементы газовой сети (потребителя или участок), на котором произошла авария, и коммутационные задачи помогут быстро найти ближайшую запорную арматуру для отключения аварийных объектов. Отключенные участки, потребители и здания отображаются на карте в виде тематической раскраски. По отключаемым объектам формируется таблица-отчет, поля которой можно настроить самостоятельно. Также определяются итоговые значения: расход газа на продувку, заполнение и настройку газового оборудования.

Пользователь может сохранить конфигурацию с перечнем отключаемых элементов сети, чтобы быстро вернуться к необходимой «аварийной ситуации».

При анализе переключений определяется, какие объекты попадают под отключения, и включает в себя:

  • вывод информации по отключенным объектам сети;

  • расход газа на продувку, куб. м;

  • расход газа на продувку и заполнение, куб. м;

  • расход газа на регулировку и настройку газового оборудования , куб. м;

  • отображение результатов расчета на карте в виде тематической раскраски;

  • вывод табличных данных в отчет, с последующей возможностью их печати, экспорта в формат MS Excel или HTML.

Для запуска Анализа переключений:

  1. Выберите команду главного меню Задачи|Коммутационные задачи или нажмите кнопку [image] на панели инструментов. Появится диалоговое окно Коммутационные задачи, (Рисунок 151, «Диалог «Коммутационные задачи»»).

    Диалог «Коммутационные задачи»

    Рисунок 151. Диалог «Коммутационные задачи»

  2. Нажмите кнопку Слой... и в появившемся диалоговом окне (Рисунок 152, «Диалог выбора слоя») с помощью левой кнопки мыши выберите слой газовой сети.

    Диалог выбора слоя

    Рисунок 152. Диалог выбора слоя

  3. Выберите вкладку Анализ переключений.

  4. Далее следует добавить отключаемые объекты газовой сети в список или загрузить пользовательскую конфигурацию.

    [Подсказка] Подсказка

    Подробнее о том как работать со списком объектов и конфигурацией: «Работа со списком объектов».

  5. В режиме Выделить [image] выберите на карте запорное устройство (или участок), для которого будет производиться отключение (слой при этом должен быть активным, либо удерживайте при выделении объекта клавиши Ctrl+Shift);

  6. Нажмите кнопку [image] панели. Выбранный объект добавится в список переключаемых объектов сети в диалоговом окне. (Рисунок 153, «Список переключаемых объектов»).

    Список переключаемых объектов

    Рисунок 153. Список переключаемых объектов

    После выбора на карте автоматически отобразится в виде раскраски расчетная зона отключенных участков сети. (Рисунок 154, «Отображение отключений на карте»).

    Если в настройках включена опция Учитывать слой подложку, то к этому слое-подложке (обычно слой зданий) будет тоже применения тематическая раскраска. Это позволяет наглядно показать отключения объектов.

    Отображение отключений на карте

    Рисунок 154. Отображение отключений на карте

    Для удаления объекта из списка выделить его в списке и нажать кнопку [image] . При передвижении по списку, на карте автоматически выделяется соответствующий объект;

  7. Выберите в поле Действие необходимый вид переключения (Рисунок 155, «Работа в окне Коммутационные задачи»).

    Работа в окне Коммутационные задачи

    Рисунок 155. Работа в окне Коммутационные задачи

    Виды переключений:

    • Включить — режим объекта устанавливается на «Включен»;

    • Выключить — режим объекта устанавливается на «Выключен»;

    • Изолировать от источника — режим объекта устанавливается на «Выключен». При этом автоматически добавляется в список и переводится в режим отключения вся изолирующая объект от источника запорная арматура;

    • Отключить от источника — режим объекта устанавливается на «Выключен». При этом автоматически добавляется в список и переводится в режим отключения вся отключающая объект от источника запорная арматура.

  8. Нажмите кнопку Выполнить. В результате выполнения задачи появится браузер Просмотр результата, содержащий табличные данные результатов расчета (Рисунок 156, «Окно результатов расчета»). Подробнее о работе с браузером результатов расчета «Просмотр результатов расчета». Вкладки браузера содержат таблицы попавших под отключение объектов сети и итоговые значения результатов расчета.

    Окно результатов расчета

    Рисунок 156. Окно результатов расчета

    При необходимости можно удалить раскраску с карты с помощью кнопки [image] .


Поиск в слое-подложке

Позволяет осуществить поиск в заданном слое (обычно слой зданий) — подложке объектов, местоположение которых совпадает с местоположением потребителей в слое сети. Результаты поиска отображаются на карте в виде тематической раскраски объектов слоя-подложки и выводятся в отчет.

Объекты выбранного слоя подложки будут раскрашены в зависимости от состояния потребителя изображенного на этом объекте, например, здания будут окрашены под выключенными потребителями (смотрите Рисунок 157, «Отображение отключений на тематической раскраске»).

[Предупреждение] Предупреждение

Слой сети и слой-подложка должны быть либо на сервере, либо локально!

Отображение отключений на тематической раскраске

Рисунок 157. Отображение отключений на тематической раскраске

Для запуска поиска в слое подложке:

  1. Выберите команду главного меню Задачи|Коммутационные задачи или нажмите кнопку [image] на панели инструментов. Появится диалоговое окно Коммутационные задачи.

    Диалог «Коммутационные задачи»

    Рисунок 158. Диалог «Коммутационные задачи»

  2. Нажмите кнопку Слой... и в появившемся диалоговом окне (Рисунок 159, «Диалог выбора слоя») с помощью левой кнопки мыши выберите слой газовой сети.

    Диалог выбора слоя

    Рисунок 159. Диалог выбора слоя

  3. Выберите вкладку Поиск в слое подложке.

    Окно поиска слоя в подложке

    Рисунок 160. Окно поиска слоя в подложке

  4. Выберите c помощью переключателей Учитывать потребителей необходимые условия поиска.

    • Всех в сети − поиск будет осуществляться для всех потребителей в слое сети, дополнительных настроек производить не надо, и можно сразу производить поиск;

    • Из группы − поиск будет осуществляться для потребителей, входящих в текущую группу в слое сети;

    • Из списка – поиск будет осуществляться для потребителей, которых пользователь добавит в список. Для этого следует выделить в режиме [image] на карте потребителя, для которого необходимо произвести поиск. Нажать кнопку [image] на панели диалога. Выбранный потребитель добавится в список в диалоговом окне. Таким же образом добавьте в список всех необходимых для поиска потребителей (Подробнее о работе со списком «Работа со списком объектов»).

  5. Нажмите кнопку Выполнить.

В результате выполнения задачи появится браузер Просмотр результата, содержащий табличные данные результатов поиска (подробнее о браузере можно узнать в разделе «Просмотр результатов расчета») и выполнится раскраска слоя - подложки в зависимости от режимов потребителей и выбранных настроек.

Каждая запись результирующей таблицы соответствует потребителю и соответствующему объекту слоя подложки и содержит заданные в настройках поля из баз данных, а также информацию о текущем режиме потребителя. При необходимости вы можете удалить раскраску с помощью кнопки [image] .


Настройки коммутационных задач

Перед запуском коммутационных задач следует предварительно настроить модуль, чтобы правильно рассчитывать итоговые значения, а также задать список объектов и полей, участвующий в анализе переключений (или поиске в слое подложке).

Чтобы открыть настройки коммутационных задач:

  1. Выберите команду главного меню Задачи|Коммутационные задачи или нажмите кнопку [image] на панели инструментов. Появится диалоговое окно Коммутационные задачи.

  2. Нажмите кнопку Настройка (Рисунок 161, «Настройки коммутационных задач»).

    Настройки коммутационных задач

    Рисунок 161. Настройки коммутационных задач

Настройки коммутационных задач содержат следующие вкладки:

  • «Настройки слоя сети».

  • «Настройки анализа переключений».

  • «Настройки слоя подложки».

  • «Настройки раскраски для коммутационных задач».

  • «HASP».

Настройки слоя сети

Вкладка «Слой сети» настройки коммутационных задач

Рисунок 162. Вкладка «Слой сети» настройки коммутационных задач

Вкладка Слой сети настроек коммутационных задач содержит следующие настройки:

  • Вариант — позволяет сохранять настройки, выбранные на всех вкладках окна настроек, в виде различных «вариантов». Эти варианты настроек дают возможность быстро переключаться между ними.

    [Внимание] Внимание

    По умолчанию при запуске коммутационных задач используются текущие настройки — в этом случае поле Вариант будет пустым.

    Чтобы переключится по умолчанию на другой вариант настроек, следует открыть Вариант, сохраненный ранее и применить его.

    Для сохранения варианта, используйте кнопки Применить и ОК в нижней части окна.

    Чтобы открыть (загрузить) вариант или удалить, используйте кнопки Открыть и Удалить, рядом с полем Вариант.

  • В списке Выберите слой сети выберите нужный слой сети из списка слоев карты.

  • в списке Выберите вид сети для правильного расчета итоговых значений, (Рисунок 162, «Вкладка «Слой сети» настройки коммутационных задач»), укажите тип инженерной сети — Газовая сеть .

  • Дополнительно вы можете выбрать:

    • атмосферное давление, Па;

    • внутренний диаметр продувочной свечи, м;

    • время регулировки и настройки, ч;

    • поправочный коэффициент.

Настройки анализа переключений

Настройка анализа переключений

Рисунок 163. Настройка анализа переключений

Вкладка Анализ переключений настроек коммутационных задач содержит следующие настройки:

  • Вариант — позволяет сохранять настройки, выбранные на всех вкладках окна настроек, в виде различных «вариантов». Эти варианты настроек дают возможность быстро переключаться между ними.

    [Внимание] Внимание

    По умолчанию при запуске коммутационных задач используются текущие настройки — в этом случае поле Вариант будет пустым.

    Чтобы переключится по умолчанию на другой вариант настроек, следует открыть Вариант, сохраненный ранее и применить его.

    Для сохранения варианта, используйте кнопки Применить и ОК в нижней части окна.

    Чтобы открыть (загрузить) вариант или удалить, используйте кнопки Открыть и Удалить, рядом с полем Вариант.

  • В списке Выберите типы объектов сети, участвующие в анализе отображается перечень всех типов для выбранного слоя сети. Чтобы включить определенный тип элементов в отчет, необходимо поставить флажок рядом с ним и выбрать нужные поля для отображения в отчете (Рисунок 163, «Настройка анализа переключений»).

  • При выборе объекта в верхней части окна, в списке Доступные поля отобразится список всех полей базы данных выбранного объекта, которые могут быть включены в отчет. В списке Поля для вывода отобразится список полей, которые были выбраны для включения в отчет.

    Для включения нужных полей в отчет следует выделить необходимые поля в левом списке, и нажать кнопку [image] . Выбранные поля перейдут в правый список. Для того чтобы добавить сразу все поля нужно нажать кнопку [image] . И наоборот, с помощью кнопок [image] и [image] поля удаляются из правого списка.

  • Слой-подложка – это слой, в котором будет осуществляться поиск и раскраска объектов, попадающих под потребителей сети. (Обычно слой зданий).

    Чтобы использовать слой подложку, включите опцию Использовать слой подложка и на следующей вкладке настройте объекты, а также поля слоя подложки (по зданиям может быть своя база данных, например с адресами).

Настройки слоя подложки

Вкладка Слой подложка настроек коммутационных задач содержит следующие настройки:

Рисунок 164. Настройка слоя-подложки

  • Вариант — позволяет сохранять настройки, выбранные на всех вкладках окна настроек, в виде различных «вариантов». Эти варианты настроек дают возможность быстро переключаться между ними.

    [Внимание] Внимание

    По умолчанию при запуске коммутационных задач используются текущие настройки — в этом случае поле Вариант будет пустым.

    Чтобы переключится по умолчанию на другой вариант настроек, следует открыть Вариант, сохраненный ранее и применить его.

    Для сохранения варианта, используйте кнопки Применить и ОК в нижней части окна.

    Чтобы открыть (загрузить) вариант или удалить, используйте кнопки Открыть и Удалить, рядом с полем Вариант.

  • В верхней части окна следует выбрать слой подложку и слой газовой сети (отметить флажками нужные).

    Слой-подложка – это слой, в котором будет осуществляться поиск и раскраска объектов, попадающих под потребителей сети. (Обычно слой зданий).

    Настройка слоя-подложки: выбор зданий

    Рисунок 165. Настройка слоя-подложки: выбор зданий

    Для выбора слоя подложки следует установить флажок рядом с требуемым слоем в верхнем списке вкладки.

    Далее обязательно следует указать слой газовой сети и его объекты:

    Настройка слоя-подложки: выбор газовой сети

    Рисунок 166. Настройка слоя-подложки: выбор газовой сети

  • Для того чтобы получить информацию о зданиях, попавших под отключение следует установить флажок Выводить отчет.

    Чтобы в отчет выводилась информация по объектам из слоя подложки, следует выделить курсором название слоя подложки, и в списке Доступные поля вкладки отобразятся поля для отчета. В списке Поля для вывода отобразится список полей, которые были выбраны для включения в отчет.

    Для включения нужных полей в отчет выделите поля в списке Доступные поля и нажмите кнопку [image] . Выбранные поля перейдут в список Поля для вывода. Для того чтобы добавить сразу все поля нажмите кнопку [image] . И наоборот, вы можете с помощью кнопок [image] и [image] удалять поля из правого списка.

Настройки раскраски для коммутационных задач

Вкладка Раскраска настроек коммутационных задач содержит настройки тематической раскраски.

Заданный стиль для состояния применяется только при установке соответствующего флажка. Для задания стиля и цвета заливки нужного режима нажмите кнопку под названием состояния. В открывшемся диалоге выберите нужные параметры.

Настройка раскраски слоя подложки

Рисунок 167. Настройка раскраски слоя подложки

  • В блоке Раскраска слоя подложки по состоянию потребителей сети задаются стили и цвета заливки объектов слоя подложки (зданий) сети в зависимости от режима работы потребителя.

    Режим Не определен соответствует ситуации, когда на один объект слоя подложки попадает несколько потребителей с разными режимами.

    Настройка раскраски площадных объектов слоя подложки

    Рисунок 168. Настройка раскраски площадных объектов слоя подложки

  • Раскраска участков позволяет выбрать цвета линейных объектов при выполнении коммутационных задач.

    Раскраска отключенных/изолированных участков сети

    Рисунок 169. Раскраска отключенных/изолированных участков сети

  • Раскраска запорных позволяет выбрать символ для отображения отключающих и изолирующих устройств.

    Раскраска отключенных/изолированных задвижек

    Рисунок 170. Раскраска отключенных/изолированных задвижек

HASP

В данной вкладке производится настройка опроса сетевого ключа HASP, функция включается/выключается установкой/снятием флажка Производить опрос сетевого ключа.

[Примечание] Примечание

Флажок обязательно должен быть установлен при использовании сетевого ключа, в противном случае расчет производиться не будет. При использовании локального ключа, данный флажок обязательно должен быть снят.

Вкладка «HASP» диалога «Настройки»

Рисунок 171. Вкладка «HASP» диалога «Настройки»


Работа со списком объектов

В список объектов следует добавлять элементы газовой сети из активного слоя карты. Список объектов можно сохранять в виде конфигурации. Конфигурация — список переключаемых объектов сети и соответствующих переключений. Конфигурацию можно сохранить и загрузить из слоя.

Добавление и удаление объектов в списке переключаемых объектов:

  1. В режиме Выделить [image] выберите на карте запорное устройство (участок), для которого будет производиться отключение (слой при этом должен быть активным, в противном случае требуется удерживать при выделении объекта Ctrl+Shift).

  2. Нажмите кнопку [image] . Объект будет добавлен в список.

    Для удаления объекта из списка выделите соответствующую строку и нажмите кнопку [image] .

  3. Напротив объекта в столбце Действие выберите вид переключения.

Для сохранения конфигурации (списка выбранных объектов) следует:

  1. Введите пользовательское название конфигурации в соответствующем поле.

  2. Нажмите кнопку Сохранить.

Загрузка конфигурации:

  1. В строке Конфигурация нажмите ˅ и выберите необходимую.

  2. Нажмите кнопку Открыть. В список объектов загрузятся данные конфигурации.

[Подсказка] Подсказка

Для удаления конфигурации служит кнопка Удалить.

Действия в списке переключаемых объектов

Рисунок 172. Действия в списке переключаемых объектов

При передвижении по списку, на карте автоматически выделяется соответствующий объект. Если объект не попадает в видимую область карты, то вид устанавливается таким образом, чтобы объект оказался в центре карты.

При выбранной вкладке Анализ переключений, с помощью кнопок [image] и [image] вы можете просмотреть и распечатать отчет по списку объектов. Поля для подготовки отчета берутся из настроек соответствующего типа объекта сети (Подробнее о настройке анализа переключений «Анализ переключений»).

Отчет по списку отключаемых объектов

Рисунок 173. Отчет по списку отключаемых объектов


Просмотр результатов расчета

После анализа переключений (или поиска в слое подложке) на экране отобразится окно с результатами расчета, показанное на Рисунок 174, «Окно результатов расчета». Вкладки окна содержат таблицы попавших под отключение объектов сети (если указано в настройках) и итоговые значения результатов расчета.

Окно результатов расчета

Рисунок 174. Окно результатов расчета

Навигация

Окно Просмотр результата содержит табличные данные результатов выполнения коммутационных задач: Итоговые значение, а также таблицы попавших под отключения объектов. Для того, чтобы сделать активной нужную таблицу щелчком левой кнопкой мыши выберите соответствующую вкладку, например, Потребитель, как показано на Рисунок 175, «Поиск выключенного объекта на карте».

Поиск выключенного объекта на карте

Рисунок 175. Поиск выключенного объекта на карте

При выделении записи в таблице, на карте автоматически выделяется соответствующий объект. Если объект не попадает в видимую область карты, то вид устанавливается таким образом, чтобы объект оказался в центре карты.

Печать отчета

Для создания отчета по табличным данным результатов расчета:

  1. Перейдите на нужную вкладку. (Потребитель, Итоговые значения и т.д.);

  2. Нажмите кнопку [image] . Появится диалог создания отчета. (смотрите Рисунок 176, «Диалог создания отчета»).

    Диалог создания отчета

    Рисунок 176. Диалог создания отчета

  3. Для предварительного просмотра отчета нажмите кнопку Просмотр.Для печати отчета нажмите кнопку Печать.

Экспорт в MS Excel

Для экспорта в электронную таблицу MS Excel табличных данных результатов расчета:

  1. Нажмите кнопку [image] . Появится диалог экспорта в MS Excel. (смотрите Рисунок 177, «Диалог экспорта в Excel»).

    Диалог экспорта в Excel

    Рисунок 177. Диалог экспорта в Excel

  2. В строке Путь к книге Excel нажмите кнопку Обзор и укажите путь и имя сохраняемого файла. В поле Имя листа введите имя листа, в который будут сохранены данные;

  3. Для предварительного просмотра отчета нажмите кнопку Просмотр;

  4. Нажмите кнопку Сохранить.

Экспорт в HTML

Для экспорта в HTML страницу табличных данных результатов расчета:

  1. Нажмите кнопку [image] . Появится диалог экспорта в HTML. (смотрите Рисунок 178, «Диалог экспорта в HTML»).

    Диалог экспорта в HTML

    Рисунок 178. Диалог экспорта в HTML

  2. В строке Имя файла нажмите кнопку Обзор и укажите путь и имя создаваемого HTML файла;

  3. Для предварительного просмотра отчета нажмите кнопку Просмотр;

  4. Нажмите кнопку Сохранить.


Топологические задачи

ZuluGIS поддерживает линейно-узловую топологию, что позволяет моделировать инженерные и другие сети (дорожная, электрическая и прочие). Топологическая сетевая модель представляет собой граф сети, узлами которого являются точечные (символьные) объекты: колодцы, источники, задвижки, рубильники, перекрестки, потребители и прочие. Рёбрами графа являются линейные объекты — кабели, трубопроводы, участки дорожной сети и так далее.

Используя модель сети можно решать ряд топологических задач:

  • Поиск связанных объектов.

  • Поиск по и против направления.

  • Поиск пути.

  • Поиск группы путей.

  • Поиск колец.

Топологические задачи также позволяют:

  • Выделить объекты сети удобный способом, с помощью "флажков".

  • Построить путь для пьезометрического графика (графика падения давления).

  • Выделить маршрут для экспорта продольного профиля инженерной сети в AutoCAD DXF (ZuluDrain, ZuluGaz).

  • В ZuluHydro для расчёта гидравлического удара указать путь для наблюдения.

С помощью кнопки Поиск пути [image] пользователь отмечает узловые (символьные) объекты на сети - "устанавливает флажки". Далее решается топологическая задача: поиск пути, связанности, колец и прочие. В результате решения топологической задачи, объекты на карте будут выделены красным цветом. Полученные результаты — объекты сети, можно выделить (добавить в уже существующую группу или исключить).

В том случае, если между объектами существует разрыв, то путь не будет найден и отобразится соответствующее сообщение.

Также можно указать участки, по которым не будет проходить маршрут. Для этого, удерживая клавишу Ctrl, щелкните левой кнопкой мыши по тем участкам, по которым не будет проходить маршрут, они отметятся красным крестиком.

[Подсказка] Подсказка

Цвет и стиль выделения результатов топологического анализа можно изменить в меню Сервис|Параметры|Карта. Подробнее смотрите раздел https://www.politerm.com/zuludoc/index.html#ui_customize_param_map.html.

Возможно быстро получить список отключающих (изолирующих) устройств, для выделенного объекта сети.

Для анализа изменений вследствие отключения задвижек или участков сети предназначен продукт Коммутационные задачи.


Поиск связанных и не связанных

В системе имеется возможность у сети, которая построена по типу графа (например инженерная или дорожная сеть) проверить связанность элементов для указанных узлов. Узлы указываются путем расстановки флагов.

Что бы найти связанные или несвязанные элементы сети надо:

  1. Сделать активным слой, для которого будут искаться связанные или несвязанные элементы сети.

  2. Выберите режим установки флагов, нажав кнопку Поиск пути [image] .

  3. Щелкнуть мышью по любому узлу (в данной точке установится красный флажок).

  4. В любом месте карты щелкнуть правой кнопкой мыши, в появившемся контекстном окне выбирать пункт Найти связанные или выбрать пункт главного меню Карта|Топология|Найти связанные.

    [Подсказка] Подсказка

    При выборе пункта Найти несвязанные будут выделены те объекты, которые не связаны с указанным флагом объектом.

Поиск против и по направлению

При поиске связанных объектов можно искать по направлению (по стрелкам) или против: используя пункты Найти связанные по направлению или Найти связанные против направления. При выборе поиск будет осуществляться по направлению участков (по стрелкам) или соответственно против.

[Подсказка] Подсказка

Следует учитывать, что направление участка определяется при его вводе, то есть направление участка будет от начальной точки ввода к конечной точке.

Контроль ошибок при вводе сети

Для проверки правильности нанесения схемы инженерной сети необходимо произвести проверку ее связности, для определения все ли узлы и участки связаны между собой. Проверку можно производить как для полностью нанесенной сети, так и для готовых ее частей.

Для проверки сети на связанность:

  1. Сделать активным слой инженерной сети.

  2. На панели навигации нажмите кнопку Поиск пути [image] .

  3. Левой кнопкой мыши установить флажок на любом объекте инженерной сети (кроме участков).

  4. Нажмите правую кнопку мыши и в появившемся меню (Рисунок 179, «Поиск связанных объектов») выберите пункт Найти связанные. Все найденные объекты сети, в соответствии с выбранным пунктом меню поиска, окрасятся в красный цвет.

  5. Для отмены результатов поиска нажмите кнопку Отмена пути [image] .

Поиск связанных объектов

Рисунок 179. Поиск связанных объектов

[Подсказка] Подсказка

Можно найти все связанные объекты сети по направлению от узла, на котором был установлен флажок, или против направления, для этого в меню выберите пункт Найти связанные по направлению или Найти связанные против направления. Следует учитывать, что направление участка определяется при его вводе, то есть направление участка будет от начальной точки ввода к конечной точке. Также можно найти несвязанные объекты (пункт Найти несвязанные).


Поиск пути

Построение пути может использоваться для решения следующих задач:

  1. Выделение объектов.

  2. Построения пути для пьезометрического графика (графика падения давления).

  3. Построение маршрута для экспорта продольного профиля инженерной сети в AutoCad DXF (ZuluDrain, ZuluHydro, ZuluGaz).

При построении пути соединяются начальный и конечный узлы. Возможно указание промежуточных последовательных точек. Если путей от одного узла до другого может быть несколько, то по умолчанию путь выбирается самый короткий, в том случае если нужен другой путь, то надо указать промежуточные узлы.

Для построения пути:

  1. Нажмите на панели навигации кнопку Поиск пути [image] .

  2. Подведите курсор мыши к начальному символьному объекту и нажмите левую кнопку мыши, после чего на выбранном объекте будет установлен красный флажок (Рисунок 180, «Путь для построения графика»a).

  3. Щелчком левой кнопкой мыши поставьте флажок на конечном объекте. При существовании нескольких маршрутов до конечного узла (в кольцевых сетях) установите флажки на промежуточных узлах сети. (Рисунок 180, «Путь для построения графика»b).

    [Подсказка] Подсказка

    Также можно указать участки, по которым не будет проходить маршрут. Для этого, удерживая клавишу Ctrl, щелкните левой кнопкой мыши по тем участкам, по которым не будет проходить маршрут, они отметятся красным крестиком.

  4. Подведите курсор к конечному узлу и установите флажок нажатием левой кнопки мыши.

  5. Сделайте двойной щелчок левой кнопкой мыши или щелкните правой кнопкой мыши и выберите Найти путь (Карта|Топология|Найти путь).

    Путь выделится красным цветом (Рисунок 180, «Путь для построения графика» c);

    Путь для построения графика

    Рисунок 180. Путь для построения графика


Поиск группы путей

Система позволяет построить группу путей - несколько путей между парами флагов (это позволяет далее выделить объекты, лежащих на пути).

Флаги устанавливаются парами, а поиск группы происходит с нажатой клавишей Alt. При поиске флаги соединяются по самому короткому пути парами: первый флаг со вторым, 3 с 4 и так далее.

Для поиска группы путей:

  1. Сделайте активным слой, содержащий сеть.

  2. Выберите режим установки флагов, нажав кнопку [image] .

  3. Щелкните левой кнопкой мыши по символьному объекту, на нём установится флажок.

  4. Аналогичным образом установить флажок на следующих объектах.

    [Примечание] Примечание

    Флажки следует добавлять парами (начальный и конечный).

  5. Удерживая клавишу Alt сделайте двойной щелчок в произвольной области карты.

    ИЛИ

    В любом месте карты щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Найти группу путей.

    [Подсказка] Подсказка

    Для автоматического добавления результатов в группу, в контекстном меню отметьте соответствующий пункт Добавлять в группу автоматически.

Поиск группы путей

Рисунок 181. Поиск группы путей


Поиск колец

Данная функция позволяет найти кольца в сети. Кольца будут найдены для областей сети, связанных с узлами, отмеченными флагами. Для поиска колец в сети:

  1. Сделайте активным слой, содержащий сеть.

  2. Выберите режим установки флагов, нажав кнопку [image] .

  3. Левой кнопкой мыши щелкните по символьному объекту слоя, на нем установится флажок.

    Пример нахождения колец в сети

    Рисунок 182. Пример нахождения колец в сети

  4. В любом месте карты щелкните правой кнопкой мыши. В появившемся контекстном меню выберите пункт Найти кольца или выберите пункт главного меню Карта|Топология|Найти кольца.

  5. В результате все найденные кольца выделятся красным цветом.

    [Подсказка] Подсказка

    В нижней части окно отобразится количество найденных колец.


Работа с флагами и результатом

Флажки устанавливаются на объекты активного слоя. Для перехода в режим установки флажков нажмите па панели инструментов кнопку Поиск пути [image] .

В режиме установки флагов щелчок правой кнопкой мыши открывает контекстное меню:

  • Для установки флажка щелкните левой кнопкой мыши по символьному объекту слоя.

  • Для удаления всех флажков нажмите правую кнопку мыши, и в контекстном окне выберите пункт Отменить флаги (или выберите пункт меню Карта|Топология|Отменить флаги.)

  • Для удаления флагов и результата (построенного пути) нажмите кнопку [image] на панели инструментов.

  • Чтобы удалить последний поставленный флаг, нажмите правую кнопку мыши, и в контекстном меню выберите пункт Отменить последний флаг (или выберите пункт главного меню Карта|Топология|Отменить последний флаг.)

  • Для удаления результата поиска нажмите правую кнопку мыши и выберите пункт Отменить результат. (Карта|Топология|Отменить результат).

Работа с результатом топологических задач

В результате решения топологических задачи, объекты выделяются на экране. Полученные результаты — объекты сети, можно выделить (добавить в уже существующую группу или исключить).

Чтобы добавить\создать группу, нажмите правую кнопку мыши, и в контекстном меню выберите соответствующий пункт Создать группу или Добавить в группу.

Возможно автоматическое добавление объектов в группу или создание группы. Для этого следует в режиме Поиск пути [image] щелкнуть правой кнопкой мыши и отметить соответствующий пункт Создавать группу автоматически (Добавлять в группу автоматически).

[Примечание] Примечание

При создании группы старое выделение снимается.


Поиск отключающих и изолирующих устройств

Возможно быстро получить список отключающих (изолирующих) устройств, для выделенного объекта сети.

Отключающими устройствами считаются те объекты сети, для которых в структуре слоя графический тип объекта инженерной сети установлен как «отсекающее устройство». Система будет искать устройства, изолирующие объект от источника.

Для анализа изменений вследствие отключения задвижек или участков сети предназначен продукт Коммутационные задачи.

Для поиска изолирующих устройств надо:

  1. Сделать слой, содержащий инженерную сеть активным.

  2. Выделить [image] на карте объект, который необходимо отключить.

  3. Выбрать пункт главного меню Задачи|Найти отключающие устройства

    или

    удерживая нажатой клавишу Ctrl нажать кнопку [image] на панели инструментов.

    [Подсказка] Подсказка

    Для поиска отключающих устройств нажать кнопку [image] , удерживая нажатой клавишу Ctrl.

В результате в окне Сообщения на вкладке Арматура появится список всех объектов, которые отключают выбранный объект. Если окно сообщений не появилось автоматически, тогда нажмите кнопку [image] , выберите вкладку Арматура или выберите пункт меню Окно|Сообщения, вкладка Арматура.

[Примечание] Примечание

Для того, чтобы убрать закладку Арматура, установите курсор на команду <Выход> и нажмите Enter или сделайте двойной щелчок мыши на этой команде. Для закрытия окна Сообщения нажмите кнопку [image] или выберите пункт меню Окно|Сообщения.


График падения давления

График изменения давления газовой сети является одним из основных инструментов анализа результатов расчетов для газопроводных сетей. Этот график изображает линию изменения давления в узлах сети по выбранному маршруту, например, от регулирующего устройства до потребителя.

График в системе строится по маршруту. Маршрут указывается автоматически, достаточно определить его начальный и конечный узлы. Если путей от одного узла до другого может быть несколько, то по умолчанию путь выбирается самый короткий, в том случае если нужен другой путь, то надо указать промежуточные узлы.

[Подсказка] Подсказка

Воспользуйтесь быстрой настройкой графика, чтобы настроить его масштаб, внешний вид и какие объекты отображаются на профиле.

Быстрая настройка графика падения давления

Большинство наиболее необходимых настроек графика можно изменить с помощью контекстного меню, вызываемого нажатием правой кнопки мыши в области окна График.

Быстрая настройка графика с помощью контекстного меню позволяет:

  • «Выделение графика»;

  • «Изменение внешнего вида графика»;

  • «Изменение масштаба графика»;

  • «Настройка кривых графика»;

  • «Изменений свойства графика».

Быстрые настройки графика

Рисунок 196. Быстрые настройки графика

Выделение графика

Выделить всю область пьезографика можно с помощью пункта Выделить все контекстного меню. Выделение может понадобиться для дальнейшего копирования и вставки пьезографика в какую либо программу, например в Microsoft Word™ или Microsoft Excel™ (подробней смотрите раздел «Сохранение графика падения давления в Ms Word и Excel»).

Изменение внешнего вида графика

При выборе пункта Вид контекстного меню откроется дополнительное меню со следующими опциями:

  1. Затенять при наложении - при совмещении нескольких пьезометрических графиков можно выбрать будет ли построенный ранее график затеняться или нет.

  2. Таблица - с помощью данной опции можно включать и выключать отображение табличной (или шкальной) области графика.

  3. Скрывать ячейки - с помощью данной опции можно скрыть частично видимые ячейки таблицы (в случае их наложения друг на друга).

  4. Показать/убрать колонки... - позволяет вручную скрывать колонки с данными из таблицы и графика. При выборе открывается окно со списком элементов графика (объектов, через которые построен путь для графика). Чтобы скрыть элемент на графике, нужно снять отметку напротив него.

    [Примечание] Примечание

    В настройках графика сохраняются идентификаторы скрытых объектов и в дальнейшем они не отображаются при построении новых графиков.

    Диалог Показать/убрать колонки...

    Рисунок 197. Диалог Показать/убрать колонки...

    Если объект скрыт с графика, то для его отображения следует установить галочку напротив его названия.

Изменение масштаба графика

При выборе пункта Масштаб контекстного меню откроется дополнительное окно настройки масштаба графика, в котором можно определить:

Масштаб для оси X:

  1. без масштаба (равномерные отсчеты) — стандартный вид графика с равномерными отступами между точками графика.

  2. без масштаба (компактно) — компактный вид графика, ширина колонки подбирается по текстовому содержимому.

  3. подбирать масштаб автоматически — программа автоматические подберёт подходящее значение масштаба (по отношению к длинам участков). Также возможно задать вручную используя следующий пункт;

  4. соблюдать масштаб, заданный пользователем, например 1:200, 1:400 (в окошке справа необходимо указать этот масштаб).

Масштаб для оси Y:

  1. подбирать автоматически

  2. соблюдать заданный пользовательский масштаб.

Для включения или отключения отображения нулевой геодезической отметки на графике. Для ее отключения надо снять флажок Всегда включать ноль в диапазон шкалы, для включения нуля наоборот установить флажок. Данная функция удобна при больших значениях геодезических отметок.

Настройка кривых графика

При выборе опции Кривые откроется дополнительное окно со списком всех кривых графика:

Список кривых пьезометрического графика

Рисунок 198. Список кривых пьезометрического графика

Для того чтобы скрыть или отобразить ранее скрытую кривую надо сделать щелчок левой кнопкой мыши слева от названия кривой на значке «глаза».

Двойной щелчок левой кнопкой мыши на названии кривой откроет диалоговое окно по настройке кривой.

Изменений свойства графика

Свойства пьезографика можно изменить, выбрав пункт контекстного меню Свойства (подробней о свойствах пьезографика можно узнать в разделе «Создание нового шаблона графика падения давления»).


Знакомство с окном графика

Перед запуском расчета полезно познакомиться с окном графика:

Знакомство с окном графика

Рисунок 183. Знакомство с окном графика

  1. Панель инструментов графика.

  2. Область линейного графика.

  3. Область шкального графика.

  4. Обозначение объекта газопроводной сети на графике (узел линейного графика).

  5. Планка изменения размера области заголовка шкального графика.

  6. Ячейка с наименованием объекта указанным выше на графике.

  7. Перемещаемая планка изменения размеров областей шкального и линейного графиков.

Условные обозначения по - умолчанию:

  • линия давления синим цветом.


Построение графика падения давления

Для того чтобы построить график падения давления:

  1. Нажмите на панели навигации кнопку Поиск пути [image] .

  2. Подведите курсор мыши к начальному объекту (например, к ГРС) и нажмите левую кнопку мыши, после чего на выбранном объекте будет установлен красный флажок:

    Установка начала пути для графика

    Рисунок 184. Установка начала пути для графика

  3. При существовании нескольких маршрутов до конечного узла (в кольцевых сетях) установите флажки на промежуточных узлах сети. Если необходим самый короткий путь, то достаточно указать первую и последнюю точку. Также можно указать участки, по которым не будет проходить маршрут. Для этого, удерживая клавишу Ctrl, щелкните левой кнопкой мыши по тем участкам, по которым не будет проходить маршрут, они отметятся красным крестиком.

    Установка промежуточной точки пути для графика

    Рисунок 185. Установка промежуточной точки пути для графика

  4. Подведите курсор к конечному узлу и установите флажок двойным нажатием левой кнопки мыши, в результате на конечном узле будет установлен флажок, а выбранный маршрут для построения графика высветится красным цветом:

    Путь для построения графика

    Рисунок 186. Путь для построения графика

  5. Для построения графика и открытия окна пьезометрического графика на панели инструментов нажмите кнопку Пьезометрический график [image] :

Окно пьезометрического графика

Рисунок 187. Окно пьезометрического графика


Панель инструментов графика падения давления

  • - кнопка обновления или добавления графика. Для выбора нажмите [image] и в открывшемся меню выберите требуемый пункт:

    • Обновить для перестроения графика после изменения пути или после изменения параметров;

    • Добавить для добавления нового графика к существующему, при этом первый график будет отображаться затененным цветом.

  • - кнопка разворота пьезометрического графика. Меняются местами начало и конец пути графика;

  • - изменение размера графика. Для выбора размера нажать [image] и выбрать желаемый размер в процентах от исходного;

  • - кнопка выбора принтера и запуска печати пьезометрического графика;

  • - кнопка предварительного просмотра страницы распечатываемого пьезометрического графика;

  • - кнопка редактирования макета страницы, изменение ориентации листа, изменения размера полей страницы;

  • - кнопка изменения или создания шаблона графика;

  • - окно выбора шаблона пьезометрического графика, для выбора нажмите [image] и в открывшемся меню выберите требуемый шаблон, по умолчанию используется стандартный;

  • - кнопка сохранения нового шаблона пьезометрического графика;

  • - кнопка удаления шаблона пьезометрического графика. Маршрут строится автоматически, достаточно указать его начальный и конечный узлы. Если путей от одного узла до другого может быть несколько, то достаточно указать ряд промежуточных узлов.


Сохранение графика падения давления

Для того чтобы какой-либо график падения давления всегда можно было открыть для просмотра, имеется возможность сохранить график в файл.

[Подсказка] Подсказка

Также вы можете сохранить график в виде отдельного файла ZuluGIS, скопировать как картинку или экспортировать как профиль в DXF.

Для сохранения графика:

  1. После построения пьезометрического графика выберите в диалоговом окне График меню Файл|Сохранить (для сохранения копии графика Файл|Сохранить как).

  2. В появившемся диалоговом окне укажите путь и в строке Имя файла задать имя для сохраняемого графика.

  3. Нажмите кнопку Сохранить.

Для открытия ранее сохраненного графика:

  1. В диалоговом окне График выберите пункт меню Файл|Открыть.

  2. В появившемся окне укажите файл для открытия и нажмите кнопку Открыть.

К сохраняемому графику можно добавить комментарий или примечание, для этого:

  1. В диалоговом окне График выберите пункт меню Файл|Варианты.

  2. В появившемся окне Варианты графика нажмите кнопку Добавить, после чего появится окно, в котором будет предложено внести комментарий к графику.

  3. Введите комментарии, нажмите кнопку ОК.

  4. Нажмите кнопку Закрыть для окончания ввода комментариев.

После добавления комментариев график обязательно надо сохранить.

Рисунок 188. Варианты графика


Сохранение графика падения давления в Ms Word и Excel

Для сохранения графика в Microsoft Word™ или Excel™ сначала надо график скопировать, а затем вставить в нужный файл.

[Подсказка] Подсказка

Также вы можете сохранить график в виде отдельного файла ZuluGIS, скопировать как картинку или экспортировать как профиль в DXF.

  1. Чтобы скопировать весь график, в любом месте пьезометрического графика нажмите правую клавишу мыши, после чего в открывшемся контекстном меню выберите пункт Выделить все. В результате весь график выделится рамкой.

    Выделение всего пьезометрического графика

    Рисунок 189. Выделение всего пьезометрического графика

    Если нужно копировать только табличную часть графика, выделите область таблицы графика, которую необходимо перенести, нажав на левую клавишу мыши и удерживая ее растяните область копирования до необходимых размеров:

    Выделение области таблицы

    Рисунок 190. Выделение области таблицы

  2. При копировании всего пьезографика нажмите правую кнопку мыши в любом месте графика, а при копировании только шкальной части щелкните правой кнопкой в выделенной области и в появившемся контекстном меню выберите пункт Копировать.

  3. Для того чтобы вставить скопированный график откройте программу, например Word или Excel, установите курсор в необходимое место документа, нажмите правую кнопку мыши и в открывшемся контекстном меню выберите пункт Вставить.


Копирование профиля в виде картинки

Вы можете скопировать график (профиль) в виде картинки в буфер обмена. График копируется в масштабе и с указанными настройками копирования изображения.

Чтобы скопировать график вызовите контекстное меню, щелкнув правой кнопкой мыши и выберите пункт Копировать изображение (Рисунок 191, «Копирование графика в виде изображения»).

[Примечание] Примечание

Если включено отображение таблицы на профиле, то копируется вместе с таблицей (отображение таблицы можно отключить - в контекстном меню графика выбрать Таблица|Отображать).

Настройки копирования изображения

Перед копированием вы можете настроить разрешение изображения в dpi, для этого вызовите контекстное меню, щелкнув правой кнопкой мыши и выберите пункт Настройки копирования изображения.... В открывшемся окне выберите один из вариантов:

  • 72 dpi

  • 150 dpi

  • 300 dpi

Копирование графика в виде изображения

Рисунок 191. Копирование графика в виде изображения


Экспорт графика падения давления

Вы можете экспортировать график падения давления в различные графические форматы:

  • BMP (*.bmp);

  • Enhanced Metafile (*.emf) - данный формат позволяет изменить только размеры документа.

  • JPEG (*.jpg, *.jpeg)

  • PNG (*.png)

При экспорте в BMP, JPEG и PNG дополнительно указываются Размеры документа:

  • ширина (мм);

  • высота (мм);

  • разрешение (dpi).

При экспорте в BMP можно изменить Формат экспортируемого файла: монохромный рисунок, 256-цветный рисунок или 24-разрядный рисунок.

Параметры экспорта графика

Рисунок 192. Параметры экспорта графика

[Подсказка] Подсказка

Также вы можете сохранить график в виде отдельного файла ZuluGIS, скопировать как картинку или экспортировать как профиль в DXF.

Чтобы экспортировать график:

  1. Постройте график или откройте сохраненный ранее.

  2. В окне График выберите пункт главного меню Файл|Экспорт...:

    Рисунок 193. Меню Файл|Экспорт

  3. В появившемся диалоговом окне в строке Тип файла выберите тип для сохраняемого файла:

    Выбор типа сохраняемого файла

    Рисунок 194. Выбор типа сохраняемого файла

  4. В строке Имя файла задайте имя и путь для нового файла.

  5. Нажмите кнопку Сохранить.

  6. Нажмите кнопку ОК.

    В указанной директории сохранится графический файл с графиком.


Совмещение графиков падения давления

Пьезометрические графики можно совмещать (накладывать друг на друга), для этого:

  1. Постройте первый график (смотрите «Построение графика падения давления») или откройте ранее сохраненный график (смотрите раздел «Сохранение графика падения давления»).

  2. Отметьте новый путь для построения второго графика или используйте оставшийся.

  3. В окне График нажать на [image] кнопки [image] и в открывшемся меню выбрать пункт Добавить. После чего новый график будет наложен на предыдущий. При этом первый график будет прорисован более тусклым цветом, а второй график более ярким:

    Совмещение графиков падения давления

    Рисунок 195. Совмещение графиков падения давления


Создание нового шаблона графика падения давления

По умолчанию график строится по стандартному шаблону, со стандартными настройками, но в системе имеется возможность создать новый шаблон с необходимыми параметрами.

Для создания нового шаблона:

  1. Установите курсор в окне выбора шаблона графика и задайте новое имя шаблона [image] . Нажмите кнопку [image] для сохранения нового шаблона.

  2. Нажмите кнопку редактора шаблона [image] , после чего появится следующее окно:

    Конструктор пьезометрического графика

    Рисунок 199. Конструктор пьезометрического графика

В левой части диалогового окна располагается дерево настроек, которое состоит из трех разделов:

  1. «Раздел График».

  2. «Раздел Кривые».

  3. «Раздел таблица».


Раздел График

Установив курсор на заголовок График можно настроить масштабирование графика: масштабировать вручную, автоматически по оси X и Y или вообще не придерживаться масштаба, а использовать равномерные отсчеты. При масштабировании графика выбирается способ определения длины участка - по масштабу с карты или по значению, записанному в поле базы данных по участкам сети. Ниже показан пример графика использующего автоматический подбор масштаба по оси X и Y.

Пример автоматического масштаба графика

Рисунок 200. Пример автоматического масштаба графика

При желании задать масштаб графика вручную необходимо установить маркер напротив строки Соблюдать масштаб и в поле справа ввести с клавиатуры требуемый масштаб, после чего нажать кнопку Применить.

Установив курсор на подзаголовок Фон и сетка, можно задать параметры отображения фона и сетки графика.

Настройка фона и сетки

Рисунок 201. Настройка фона и сетки

Установив курсор мыши на подзаголовок Ось X или Ось Y можно изменить параметры отображения осей X и Y, такие как: стиль линии отображающей ось, количество и внешний вид делений оси, внешний вид заголовка шкалы.

Настройка оси Y

Рисунок 202. Настройка оси Y


Шкала

Так же имеется возможность провести дополнительные настройки шкалы. Для этого следует в окне, которое появляется при выделении оси в правой нижней части окна сделать двойной щелчок левой кнопкой мыши по шкале Давление, кПа (основная). Откроется окно настроек шкалы:

Настройка шкалы пьезографика

Рисунок 203. Настройка шкалы пьезографика

Окно настроек шкалы имеет следующие вкладки:

  • Вид – в этой вкладке настраивается внешний вид шкалы (цвет линии, толщина, деления шкалы), а также задается заголовок шкалы;

  • Интервал – позволяет настроить интервал значений (максимальное, минимальное значение, цена промежуточных делений), а также выбрать размерность шкалы.

    Интервал значений по оси Х нельзя изменить при выбранном режиме без масштаба (равномерные отсчеты). При выборе подзаголовка Интервал для оси Y в разделе Дополнительно можно включить\отключить функцию Всегда отображать ноль в диапазоне шкалы. При убранном флажке ноль отображаться не будет, при этом минимальное значение шкалы Y будет подобрано автоматически. Данная функция удобна при больших значениях геодезических отметок;

  • Шрифт подписей – в этой вкладке настраивается внешний вид подписей шкалы (шрифт, начертание, размер, цвет);

  • Шрифт заголовка – в этой вкладке настраивается внешний вид заголовка шкалы (шрифт, начертание, размер, цвет).


Раздел Кривые

При установке курсора на заголовок Кривые можно выбрать состав отображаемых кривых на пьезометрическом графике. При желании скрыть какую либо кривую необходимо убрать флажок слева от наименования требуемой кривой.

Настройка кривых пьезометрического графика

Рисунок 204. Настройка кривых пьезометрического графика

При установке курсора на подзаголовок с наименованием кривой, например Давление, можно отредактировать вид, название кривой и выбрать шкалу к которой привязана данная кривая.

Рисунок 205. Настройка кривой

При установке курсора на подзаголовок Объекты можно выбрать объекты сети, для которых будут отображаться точки кривой.

Рисунок 206. Подраздел «Объекты»

При установке курсора на подзаголовок Стиль имеется возможность определить внешний вид выбранной кривой. Можно настроить цвет, толщину кривой, а также отображение узлов кривой.

Подраздел «Стиль кривой»

Рисунок 207. Подраздел «Стиль кривой»


Отображение узлов

Для отображения узлов на пьезографике необходимо установить флажок Отображать узлы. Можно указать форму узла (выбрать в выпадающем окошке форма ), и в окошке размер задать размеры выбранного символа.

Включение отображения узлов на кривой

Рисунок 208. Включение отображения узлов на кривой


Штриховка

В разделе Штриховка можно указать область и внешний вид штриховки, для этого выбрать тип штриховки:

  • нет;

  • до оси Х;

  • до другой кривой;

  • на заданную ширину.

При выборе типа на заданную ширину ниже необходимо указать в миллиметрах ширину штриховки, а при выборе типа до другой кривой необходимо указать кривую, до которой будет осуществляться штриховка. В окошке цвет можно выбрать - цвет штриховки, в окошке стиль - стиль отображения штриховки.

Рисунок 209. Настройка штриховки

Ниже на рисунке можно увидеть результат штриховки от кривой Давление до кривой X.

Пример графика со штриховкой

Рисунок 210. Пример графика со штриховкой


Надписи на пьезометрическом графике

При установке курсора на подзаголовок Надписи можно включить и настроить отображение надписей на пьезометрическом графике. В строке вариант выбирается тип надписи:

  • нет надписей;

  • простые бирки;

  • бирки с тенью.

В строке цвет фона и цвет рамки выбирается цвет фона и рамки надписи. В окне наклон выбирается ориентация надписи относительно точки на графике, то есть указывается на сколько градусов необходимо повернуть надпись. Значение вводится либо с клавиатуры либо задается с помощью левой кнопки мыши путем перемещения красной точки на шкале. Опция Округлять значения позволяет округлять выводимые значения до указанных знаков после запятой.

Настройка подписей кривой

Рисунок 211. Настройка подписей кривой

На рисунке, приведенном ниже можно увидеть результат включения режима отображения надписей на графике.

Пример графика с надписями

Рисунок 212. Пример графика с надписями

Установив курсор на подзаголовок Шрифт можно настроить параметры шрифта выводимых на график надписей.

Настройка шрифта надписей

Рисунок 213. Настройка шрифта надписей


Раздел таблица

При установке курсора на заголовок Таблица можно настроить отображаемые значения в табличной части пьезометрического графика. При желании скрыть какое-либо значение необходимо убрать галочку слева от наименования требуемого значения.

Настройка табличных данных графика

Рисунок 214. Настройка табличных данных графика

При установке курсора на подзаголовок с наименованием кривой, например Узел, можно отредактировать вид (видимая или невидимая) и название значений в табличной части графика.

Настройка табличных данных графика

Рисунок 215. Настройка табличных данных графика

При установке курсора на подзаголовок Объекты можно выбрать объекты сети, для которых будут отображаться значения полей баз данных в шкальной части графика.

Настройка Таблицы. Вкладка «Объекты».

Рисунок 216. Настройка Таблицы. Вкладка «Объекты».

Установив курсор на подзаголовок Стиль можно настроить ориентацию значений в ячейках, количество знаков после запятой для значений, выводимых в таблицу значений. А также задать цвет фона для строки, содержащей определенные значения.

Настройка Таблицы. Вкладка «Стиль»

Рисунок 217. Настройка Таблицы. Вкладка «Стиль»

Установив курсор на подзаголовок Шрифт можно настроить параметры шрифта выводимых в таблицу значений. Данные параметры можно изменять для всех значений таблицы.

Настройка таблицы. Вкладка Шрифт

Рисунок 218. Настройка таблицы. Вкладка Шрифт

После редактирования шаблона пьезометрического графика нажать ОК для выхода из редактора шаблона и нажать [image] для сохранения изменений.

На рисунке, приведенном ниже можно увидеть результат настройки стиля ячеек для всех значений и цвета фона для строки Узел.

Пример настройки табличных данных

Рисунок 219. Пример настройки табличных данных


Настройка HASP

При использовании сетевого ключа защиты HASP для полноценной работы графика падения давления необходимо указать опцию Производить опрос сетевого ключа.

Для того чтобы включить данную опцию следует:

  1. Открыть окно пьезометрического графика, нажав кнопку Пьезометрический график [image] .

  2. В окне График выбрать пункт меню Файл|Настройки....

    Рисунок 220. Настройки графика

  3. В появившемся окне можно установить/снять опцию Производить опрос сетевого ключа.

    Настройка HASP пьезометрического графика

    Рисунок 221. Настройка HASP пьезометрического графика

  4. Нажмите кнопку ОК чтобы сохранить изменения и закрыть окно.

[Примечание] Примечание

При использовании локального ключа опция Производить опрос сетевого ключа должна быть обязательно снята.


Экспорт продольного профиля в DXF

Продольный профиль газовой сети можно экспортировать в DXF формат (для дальнейшего оформления в Компас, AutoCAD и других САПР).

Профиль строится на основании высотной информации, а таблица профиля заполняется автоматически - на основании данных из базы данных и графического изображения объектов (углы поворотов берутся с карты). Высотная информация по объектам сети указывается пользователем или может быть автоматически считана со слоя рельефа.

На продольном профиле могут отображаться дополнительные объекты газовой сети:

  1. характерные точки на газопроводе;

  2. пикеты (могут быть автоматически расставлены с заданным шагом вдоль указанного пользователем маршрута);

  3. пересечения с другими коммуникациями.

[Примечание] Примечание

Дополнительные объекты изображаются пользователем "поверх" газовой сети, а при построении профиля привязываются в заданном радиусе.

Внешний вид профиля: вертикальный и горизонтальные масштабы, формат листа, вес линий и высота текста настраиваются пользователем при экспорте.

Фрагмент продольного профиля газовой сети в DXF

Рисунок 222. Фрагмент продольного профиля газовой сети в DXF


Быстрый старт

Вы можете ознакомиться с примером, который устанавливается с программой. Также вы можете использовать пример для импорта типов в свой слой или чтобы создать новый слой по образцу.

Продольный профиль строится, как и график падения давления, по указанному "флажками" пути. Перед началом работы следует подготовить структуру слоя для экспорта профиля. На этом этапе в структуру добавляются недостающие типовые объекты сети и поля исходных данных.

Рабочий процесс экспорта продольного профиля в DXF:

  1. В слое газовой сети следует нанести Характерные точки, для их отображения на профиле.

    [Примечание] Примечание

    Объекты изображаются "поверх" газопроводов. Привязка к участку происходит на указанном расстоянии (указанному в настройках), во время экспорта профиля.

  2. Изобразить на сети Пересечения с другими коммуникациями (при необходимости).

  3. При необходимости, изобразить Пикеты на сети. Вы можете автоматически расставить пикеты с заданным шагом вдоль выбранного пути.

  4. Внести необходимые исходные данные по всем объектам маршрута. Высотную информацию можно внести автоматически со слоя рельефа.

  5. Построить путь — маршрут, по которому будет проходить продольный профиль.

  6. Настроить параметры экспорта профиля в DXF.

  7. Запустить операцию экспорта профиля в DXF.


Подготовка структуры слоя для построения профиля

Перед началом работы следует подготовить структуру слоя, для этого выполните следующие шаги:

  1. Создайте новые типовые объекты.

  2. Добавьте поля по существующим объектам сети.

  3. Создайте базы данных для новых типов.

  4. Подключите базы данных к новым типам.

Шаг 1. Создание новых типовых объекты

В структуре слоя газовой сети следует создать следующие типовые объекты:

  1. Характерные точки.

  2. Пикеты.

  3. Пересечения.

[Примечание] Примечание

Все объекты относятся к символьным и не являются объектами инженерной сети.

Шаг 2. Добавление поля по существующим объектам сети

Для символьных объектов газовой сети (узел, колодец задвижка) следует добавить в базы данных поля:

Таблица 2. Исходные данные для построения профиля (символьные объекты).

№ п/п | Название поля | Тип поля | Описание
1 | Sys | Длинное целое | Ключевое поле связи с картой SYS или ID объекта. Является обязательным служебным полем. В запрос можно не добавлять.
2 | Отметка верха трубы, м | Вещественное | Указывается отметка верха трубы (в метрах). Может быть определена автоматически.
3 | Отметка земли, м | Вещественное | Указывается геодезическая отметка земли (в метрах). Можно автоматические считать со слоя рельефа.
4 | Наименование | Строковое | Указывается название пикета или характерной точки.
5 | Отметка дна траншеи, м | Вещественное | Указывается отметка дна траншеи (в метрах). Может быть определена автоматически.
6 | Глубина траншеи, м | Вещественное | Указывается глубина траншеи в метрах.

[Примечание] Примечание

О том как автоматически считать высотную информацию с карты смотрите раздел «Высотная информация по рельефу»

Шаг 3. Создание базы данных для новых типов

Для типов, созданных в шаге 1, следует создать базы данных. Пикеты и Характерные точки используют одну общую базу данных. Список полей аналогичен таблице из шага 2.

Для объектов Пересечения следует создать базу со следующим списком полей:

Таблица 3. Исходные данные для построения профиля (тип Пересечения).

№ п/п | Название поля | Тип поля | Описание
1 | Sys | Длинное целое | Ключевое поле связи с картой SYS или ID объекта. Является обязательным служебным полем. В запрос можно не добавлять.
2 | Геодезическая отметка земли, м | Вещественное | Указывается геодезическая отметка земли (в метрах). Можно автоматические считать со слоя рельефа.
3 | Отметка верха трубы коммуникации, м | Вещественное | Указывается отметка верха трубы пересекаемой коммуникации (в метрах). Может быть определена автоматически.
4 | Глубина траншеи коммуникации, м | Вещественное | Указывается геодезическая отметка земли (в метрах). Можно автоматические считать со слоя рельефа.
5 | Диаметр коммуникации, м | Вещественное | Указывается диаметр смежной (пересекаемой) коммуникации (в метрах).
6 | Наименование коммуникации | Строковое | Указывается наименование смежной (пересекаемой коммуникации).
7 | Отметка верха трубы, м | Вещественное | Указывается отметка верха трубы (в метрах). Может быть определена автоматически.
8 | Отметка дна траншеи, м | Вещественное | Указывается отметка дна траншеи (в метрах). Может быть определена автоматически.
9 | Глубина траншеи, м | Вещественное | Указывается глубина траншеи в метрах.

[Примечание] Примечание

О том как автоматически считать высотную информацию с карты смотрите раздел «Высотная информация по рельефу»

Шаг 4. Подключение базы данных к новым типам

В структуре слоя. к каждому созданному ранее типу следует подключить свою базу данных. Пикеты и Характерные точки используют одну общую базу данных.


Построение пути для экспорта продольного профиля

Чтобы указать путь, для построения продольного профиля следует:

  1. Нажать на панели навигации кнопку Поиск пути [image] .

  2. Подвести курсор мыши к начальному объекту (например, к ГРС) и нажмите левую кнопку мыши, после чего на выбранном объекте будет установлен красный флажок (Рисунок 223, «Построение продольного профиля», a);

  3. Щелчком левой кнопкой мыши поставьте флажок на конечном объекте (например, потребителе). При существовании нескольких маршрутов до конечного узла установите флажки на промежуточных узлах сети (Рисунок 223, «Построение продольного профиля», b). Также можно указать участки, по которым не будет проходить маршрут. Для этого, удерживая клавишу Ctrl, щелкните левой кнопкой мыши по тем участкам, по которым не будет проходить маршрут, они отметятся красным крестиком.

  4. Подведите указатель мыши к конечному узлу и установите флажок двойным щелчком левой клавиши мыши, в результате на конечном узле будет установлен флажок, а выбранный маршрут для построения профиля высветится красным цветом (Рисунок 223, «Построение продольного профиля», c).

    Построение продольного профиля

    Рисунок 223. Построение продольного профиля


Параметры экспорта профиля в DXF

Параметры экспорта профиля в DXF позволяет настроить поля и объекты, участвующие в построении профиля, масштаб и внешний вид продольного профиля, а также использование лицензии сетевого ключа Hasp.

[Внимание] Внимание

Чтобы открыть окно параметры экспорта перейдите к запуску операции экспорта профиля .

В окне параметры экспорта профиля разделены на несколько областей:

  • «Настройки объектов сети и дополнительных объектов профиля»

  • «Сервис»

  • «Параметры страницы»

  • «Масштаб»

  • «Параметры профиля»

  • «Настройка HASP»

Параметры экспорта профиля

Рисунок 224. Параметры экспорта профиля


Настройки объектов сети и дополнительных объектов профиля

Для экспорта продольного профиля в DXF следует настроить данные объектов газовой сети и дополнительных объектов, которые будут участвовать в операции, а также настроить соответствие полей.

[Предупреждение] Предупреждение

Для корректного построения профиля обязательно указать поля объектов. Красная надпись Настроить поля сообщает о том, что не все поля настроены. При их отсутствии — следует их добавить в базу данных. Видеоурок по разработке БД: https://www.politerm.com/videos/layerstruct/LayerStruct/

Настройка соответствия полей объектов сети

  1. Выделите курсором ячейку Настроить поля напротив объекта настройки.

  2. Нажмите кнопку ....

    Параметры экспорта профиля. Настройка поля.

    Рисунок 225. Параметры экспорта профиля. Настройка поля.

  3. В открывшемся окне Данные напротив каждого параметра выберите соответствующее поле из списка. В списке отображаются поля из базы данных выбранного типового объекта.

    Параметры экспорта профиля. Окно Данные.

    Рисунок 226. Параметры экспорта профиля. Окно Данные.

  4. После настройки всех параметров нажмите ОК.

Настройка соответствия полей дополнительных объектов

Для настройки дополнительных объектов (характерных точек, пикетов и пересечений с коммуникациями) укажите следующие настройки:

Настройки дополнительных объектов.

Рисунок 227. Настройки дополнительных объектов.

  • Использовать - включите, чтобы данный дополнительный объект участвовал в экспорте слоя.

  • Тип - выберите соответствующий типовой объект слоя.

  • Радиус поиска, м - укажите радиус в метрах, для автоматической привязки дополнительных объектов к газопроводам, так как объекты изображаются "поверх" газопроводов.

  • Расстояние между пикетами, м - только для пикетов. Указывается шаг - расстояние в метрах, на котором происходит автоматическая расстановка пикетов.

  • Данные - служит для открытия диалога настройки соответствия полей (см. раздел выше Настройка соответствия полей объектов сети).


Сервис

Область Сервис содержит следующие кнопки для запуска:

  • Высотная информация по рельефу — операция автоматического заполнения высотной информации для продольного профиля, на основе слоя рельефа.

  • Пикеты вдоль профиля — операция автоматической расстановки с заданным шагом пикетов, вдоль выбранного маршрута.

Рисунок 228. Область Сервис.

Высотная информация по рельефу

Данная операция позволяет автоматически заполнить ряд полей - исходных данных для построения продольного профиля (высотной информации). Высотная информация включает себя геодезические отметки земли, трубопроводов, дна траншеи. При наличии в карте слоя рельефа, для каждого объекта сети можно автоматически считать геодезическую отметку поверхности земли. На основании исходных данных о глубине траншеи и диаметрах трубопроводов (в том числе пересекаемых коммуникаций), автоматически определяется отметка дна траншеи и отметка верха трубы.

Для запуска операции заполнения высотной информации следует:

  1. Перейти в настройку экспорта профиля DXF.

  2. В области Cервис напротив строки Высотная информация по рельефу нажать кнопку …

  3. Отобразится сообщение "Перезаписывать текущие значения". Выберите необходимый вариант нажав Да/Нет.

    Начнется операция заполнения высотной информации.

Пикеты вдоль профиля

Данная операция позволяет автоматически изобразить пикеты с заданным шагом вдоль газопровода. Объекты устанавливаются вдоль указанного пути (маршрута, указанного "флажками"). Шаг установки задается в метрах во время настройки экспорта профиля.

Для запуска операции автоматической расстановки пикетов:

  1. Постройте путь, вдоль которого будут устанавливаться пикеты.

  2. Перейти в окно настроек экспорта профиля в DXF.

  3. Укажите шаг установки пикетов, для этого в области Дополнительные объекты в группе Пикеты задайте значение поля Расстояние между пикетами, м.

  4. В области Cервис напротив строки Пикеты вдоль профиля нажмите кнопку ….

  5. В появившемся окне подтвердите выполнение операции, нажав кнопку Да.

    Начнется операция расстановки пикетов вдоль профиля.


Параметры страницы

Размер страницы- выбирается формат страницы.

Расстояние между рамками профилей, (мм)- указывается расстояние между рамками профилей, при построении нескольких профилей на одном листе.


Масштаб

Масштаб горизонтальный- выбирается горизонтальный масштаб построения профиля.

Масштаб вертикальный- выбирается вертикальный масштаб построения профиля.


Параметры профиля

Отступ от профиля до штампа (мм) - задается расстояние вертикальное расстояние от профиля до таблицы штампа.

Вес линий профиля (мм) - настраивается вес линий профиля.

Высота текста (мм) - указывается высота текстовых объектов продольного профиля.


Настройка HASP

Настройка лицензии (сетевого ключа HASP) выполняется в окне параметров экспорта профиля. Для использования лицензии сетевого ключа, включите данную опцию.

Параметры экспорта профиля

Рисунок 229. Параметры экспорта профиля


Запуск экспорта профиля в DXF

[Внимание] Внимание

Перед запуском экспорта продольного профиля в DXF ознакомьтесь с разделом «Быстрый старт», а также убедитесь в следующем:

  1. Газовая сеть не имеет топологических ошибок.

  2. Структура сети для построения профиля правильно настроена.

  3. Указаны необходимые исходные данные для построения профиля.

Для запуска экспорта продольного профиля в DXF:

  1. Укажите путь для построения профиля.

    [Подсказка] Подсказка

    Путь строится также, как и для построения графика падения давления с помощью кнопки Поиск пути [image] .

  2. Выполните команду главного меню Задачи|ZuluGaz или нажмите кнопку [image] на панели инструментов. На экране появится панель расчетов.

  3. Нажмите кнопку Слой... и выберите из списка слой канализационной сети.

  4. Перейдите на вкладку Сервис.

    Запуск экспорта в DXF

    Рисунок 230. Запуск экспорта в DXF

  5. Нажмите кнопку Экспорт профиля в DXF, откроется окно настроек экспорта.

  6. Установите необходимые параметры экспорта профиля.

  7. Нажмите кнопку ... в строке Файл DXF: и укажите имя и выберите расположение создаваемого DXF файла.


Возможные ошибки расчетов

Общие сведения

После запуска расчета система может выдать ряд ошибок, ошибки бывают нескольких типов:

  • «Ошибки по топологии сети»;

  • «Ошибки по семантической информации»;

  • «Ошибки по результатам расчета»;

  • «Остальные ошибки».

При этом, пока не будут устранены ошибки первых двух типов, расчет не запустится. Для того чтобы определить по какому объекту выдана ошибка, выполните двойной щелчок левой кнопкой мыши по строке с ошибкой, после чего объект, по которому выдана ошибка, замигает. Если ошибка связана с семантикой, то откроется окно семантической информации и курсор встанет на строку, в которой необходимо внести или исправить информацию.

Далее, для исправления ошибки, необходимо (в зависимости от ее типа) либо исправить графическую информацию (отредактировать сеть), либо семантическую (внести или исправить данные в базе).

Во всех приведенных далее ошибках ХХ - индивидуальный номер объекта (ID или Sys), автоматически присваиваемый при прорисовке сети.


Ошибки по топологии сети

  1. Ошибка Z601: ID=ХХ Участок не имеет узла

    Ошибка Участок не имеет узла

    Рисунок 231. Ошибка Участок не имеет узла

    Данная ошибка скорей является не ошибкой, а предупреждением, поэтому она выводится синим цветом и не является причиной остановки расчета.

    Такое предупреждение будет выведено при неправильном нанесении сети, когда начальный или конечный узел участка не связан с каким-либо объектом, хотя при этом визуально может казаться, что участок связан с точечным объектом.

    Для проверки связности всей сети воспользуйтесь разделом «Контроль ошибок при вводе». Для исправления ошибки воспользуйтесь разделом «Перепривязка участка».

  2. Ошибка Z002: ID=ХХ Узел имеет неверное количество связей

    Такая ошибка может быть выведена в том случае, если в регулятор входит или выходит из него больше одного участка. Для устранения ошибки надо убрать участок, входящий в источник, или развернуть его.

  3. Ошибка Z006: ID=ХХ Регулятор в кольце

    Данная ошибка может образоваться в том случае, если из регулятор находится в кольце. Для устранения ошибки надо убрать регулирующее устройство из кольца, в противном случае расчет будет невозможен.


Ошибки по семантической информации

  1. Ошибка Z004: Нет данных по объектам 'Участок газопроводной сети'

    Ошибка Z005: ID=ХХ Отсутствуют данные по объекту

    Рисунок 232. Ошибка Z005

    Приведенные выше ошибки полностью идентичны, они означают что либо по участку, либо по какому другому объекту не были внесены данные в базу. Для исправления ошибки необходимо открыть окно семантической информации по объекту и занести исходные данные по нему.

  2. Ошибка ZD002: ID=ХХ Неверное значение поля

    Ошибка неверное значение поля

    Рисунок 233. Ошибка неверное значение поля

    На рисунке сверху выведены ошибки, связанные с неверным значением поля Длина, м и поля Шероховатость трубопровода, мм. В обоих случаях ХХ − индивидуальный номер объекта (ID или Sys), автоматически присваиваемый объекту при прорисовке сети.

    Данная ошибка выводится при наличии некорректных данных или при отсутствии исходной информации хотя бы в одной строке необходимой для расчетов. Для устранения ошибки необходимо дважды щелкнуть левой кнопкой мыши по сообщению, после чего откроется окно семантической информации по объекту с неверными или отсутствующими данными, и курсор встанет на поле, где необходимо ввести или исправить информацию.

    Исправление ошибки с неверным значением поля

    Рисунок 234. Исправление ошибки с неверным значением поля


Ошибки по результатам расчета

  1. Предупреждение Z602: ID=XX Давление на потребителе ниже минимального на YY кПа

    Сообщение о самом плохом потребителе

    Рисунок 235. Сообщение о самом плохом потребителе

    Данное предупреждение может появиться после проведения поверочного расчета. Оно возникает в том случае, если по результатам у потребителя давление на вводе ниже минимального.

    Где:

    • YY − значение давления которого не хватает

    • ID (ХХ) − индивидуальный номер потребителя.

    Для того, чтобы определить к какому потребителю относится данное сообщение надо сделать двойной щелчок левой кнопкой мыши на сообщении, соответствующий потребитель замигает на экране.

    Данная ошибка может вызвана несколькими причинами:

    1. Некорректными данными. Если величина нехватки давления выходит за рамки реальных значений для данной сети, то скорей всего имеет место ошибка при вводе исходных данных или ошибка при нанесении схемы сети на карту. Следует проверить правильно ли были занесены следующие данные:

      • По регулирующим устройствам:

        • Давление на выходе, кПа - проверить значение давления на выходе регулирующего устройства.

      • Параметры трубопроводов:

        • Диаметры трубопроводов - проверить правильность занесения диаметров трубопроводов, например, был введен диаметр 0.05 м вместо 0.5 метра;

        Данная ошибка может быть обнаружена с помощью построения пьезометрического графика, например:

        Обнаружение ошибки с помощью пьезометрического графика

        Рисунок 236. Обнаружение ошибки с помощью пьезометрического графика

        На данном графике видно, что на одном из участков сети имеет место большое падение давления. Причину можно обнаружить, если взглянуть в базе данных на диаметры трубопроводов, видно что на участке от ГК-8 до Предприятия происходит резкое сужение диаметра.

      • По потребителям сети:

        • Расчетный расход газа на потребителях − проверить правильно ли был задан расчетный расход газа на потребителе.

  2. Ошибка Z025: ID=10 В штатном режиме превышено ограничение на максимально допустимую скорость. (22.711 > 15.000)

    Ошибка при выполнении расчета резерва пропускной способности газовой сети. Штатный режим — это результаты поверочного расчета, так как перед расчетом резерва, автоматически запускается поверочный расчет. Ошибка в данном случае сообщает о том, что при выполнении поверочного расчета на участке ID = 10 скорость движения газовой смеси 22.711 м/с, что превышает допустимую (15 м/с).

  3. Предупреждение Z602: ID=55 Давление на потребителе ниже минимального на 12.1408 кПа

    Ошибка при выполнении расчета резерва пропускной способности газовой сети. Штатный режим — это результаты поверочного расчета, так как перед расчетом резерва, автоматически запускается поверочный расчет. О том как понять причину ошибки и исправить ее, смотрите пункт 1 данного раздела.

  4. Ошибка ZD006: ID=31 Неверное значение поля 'Pmin'-'Минимальное давление, кПа'

    Данная ошибка может быть из-за того, что значение поля Минимальное давление менее, чем значение поля Давление на выходе, кПа. (Для регулирующих пунктов: ГРП, ШРП и других объектов).


Остальные ошибки

Ошибка Z018: Не выбран ни один источник для расчета.

Ошибка, не выбран источник для расчета

Рисунок 237. Ошибка, не выбран источник для расчета

Данная ошибка появляется, если в панели гидравлических расчетов ZuluGaz при поверочном расчете не было отмечено ни одно регулирующее устройство. Чтобы отметить устройство рассчитываемой сети нужно левой клавишей мыши установить галочку в окне напротив его наименования. Если в слое несколько регулирующих устройств, не связанных между собой, то можно выделить только нужные:

Выбор источника для расчета

Рисунок 238. Выбор источника для расчета

Если источник (ГРС, ГРП) не отображается в панели расчётов и не доступен для выбора следует проверить,

что из источника (ГРС, ГРП) выходит только один участок газовой сети. Обязательно проверьте связанность и направление участков.


Автоматическое занесение исходных данных

Наименования начал и концов участков трубопроводов сети можно записать автоматически, при наличии наименований объектов сети, подробнее «Автоматическое занесение начала и конца участков».

Кроме имен, вы также можете автоматически заполнить ID (SYS) начала и конца участка.

При изображении сети на карте (в масштабе) можно считать длину участков с карты , подробнее «Автоматическое занесение длины с карты».

Для всех объектов газовой сети (кроме участков) необходимо задать значение H_geo, Геодезическая отметка, м. Если геодезические отметки неизвестны, то можно принять местность плоской, задав на всех объектах геодезическую отметку равную нулю. Геодезическая отметка также может быть считана со слоя рельефа (в том числе и слоя SRTM), подробнее об этом «Автоматическое занесение геодезических отметок объектов сети со слоя рельефа».


Автоматическое занесение длины с карты

При нанесении газопроводной сети на карту в масштабе, поле Длина можно заполнить автоматически для всех участков сети.

Данная операция выполняется только для тех участков, у которых не введена длина. Если же в поле Длина стоит какое-либо число, то никаких изменений для этого участка не произойдет. Т.е. введенные значения (или первоначально считанные с карты) перезаписываться не будут.

Для занесения длины с карты:

  1. Выберите команду главного меню Задачи|ZuluGaz или нажмите на панели инструментов кнопку [image] . На экране появится окно расчетов.

    Окно гидравлических расчетов ZuluGaz

    Рисунок 239. Окно гидравлических расчетов ZuluGaz

  2. Нажмите кнопку Слой... и выберите из списка слой газопроводной сети.

  3. Перейдите на вкладку Сервис.

  4. Нажмите кнопку Длины участков с карты:

    Рисунок 240. Вкладка Сервис

  5. Нажмите кнопку Длины участков с карты. Откроется окно с дополнительными опциями определения длины

  6. В открывшемся окне с дополнительными опциями определения длины можно выбрать:

    Окно опций определения длины

    Рисунок 241. Окно опций определения длины

    • Учитывать геодезические отметки узлов - при указании данной опции системой будут учитываться геодезические отметки объектов сети, в противном случае отметки учтены не будут.

    • Перезаписывать текущие данные - при установке данной опции произойдет перезапись длин у всех участков. В случае, если эта опция не установлена- длина будет считана только для тех участков, поле длина у которых не задано.

    • Для выполнения операции только для группы выделенных объектов установите опцию Только для выделенных участков.

  7. Нажмите кнопку ОК.

После завершения операции программа считает длины участков с нанесенной на карту расчетной схемы в соответствии с масштабом и запишет данные в базу данных по участкам в поле Длина.


Автоматическое занесение начала и конца участков

Если заданы наименования узловых объектов газовой сети (колодцев, потребителей, запорных устройств и др.), то для участков сети можно автоматически заполнить поля Начало участка и Конец участка. Имя начального узла будет наименованием начала участка, а имя конечного узла – наименование конца участка.

[Примечание] Примечание

Кроме имен, вы также можете автоматически заполнить ID (SYS) начала и конца участка.

Для проведения данной операции:

  1. Выберите команду главного меню Задачи|ZuluGaz или нажмите или нажмите на панели инструментов кнопку [image] . На экране появится окно гидравлических расчетов.

    Окно гидравлических расчетов ZuluGaz

    Рисунок 242. Окно гидравлических расчетов ZuluGaz

  2. Нажмите кнопку Слой... и выберите из списка слой сети.

  3. Перейдите на вкладку Сервис.

  4. Нажмите кнопку Начала и концы участков, после чего система автоматически заполнит поля Начало участка и Конец участка для всех участков.

    Рисунок 243. Вкладка «Сервис»

[Важно] Важно

При повторном использовании данной операции, происходит перезапись полей Начало участка и Конец участка.


Автоматическое занесение ID начала и конца участков

ZuluGaz позволяет автоматически заполнить ID (SYS) начала и конца участка газовой сети сразу для всех объектов слоя. В результате в базе данных по участкам в соответствующие поля будут записаны ID начального узла, из которого "выходит" участок и ID конечного узла.

Для автоматического заполнения ID начала и конца участков сети:

  1. Выберите команду главного меню Задачи|ZuluGaz или нажмите кнопку [image] на панели инструментов.

  2. Выберите слой газовой сети из списка, нажав кнопку Слой....

  3. На панели расчетов ZuluGaz перейдите на вкладку Сервис.

    Рисунок 244. Вкладка Сервис

  4. Нажмите кнопку Начала и концы участков.

    В результате по всем участкам будут заполнены поля Begin_node и End_node (а также Наименование начала участка и Наименование конца участка для всех участков).

[Важно] Важно

При повторном выполнении данной операции, происходит перезапись полей с результатами.

Если полей для записи результатов в базе данных нет, то их следует добавить самостоятельно и настроить в модели расчетов. Например, в базу данных по объекту Участок добавьте поля Begin_node - ID начала участка и End_node - ID конца участка. Тип полей: Вещественное:

  1. Открыть окно семантической информации по слою, которому в базу данных надо добавить поля (кнопка [image] ).

  2. Сделать щелчок правой кнопкой мыши в области окна, из появившегося контекстного меню выбрать пункт Добавить поле.

    Окно семантической информации

    Рисунок 245. Окно семантической информации

  3. В появившемся диалоге задать:

    • в строке Имя - имя для нового поля таблицы;

    • в строке Пользовательское имя - пользовательское имя для нового поля;

    • из списка Тип поля выбрать тип для создаваемого поля Вещественное.

    Окно добавления поля

    Рисунок 246. Окно добавления поля

  4. Нажать кнопку ОК.

  5. Аналогичным способом добавить еще одно поле.

    В результате проделанных действий в базу данных по участкам будут добавлены новые поля (в конец списка).

  6. Далее следует настроить новые поля для расчетной модели. Выберите команду главного меню Задачи|ZuluGaz или нажмите кнопку [image] на панели инструментов.

  7. Выберите слой газовой сети из списка, нажав кнопку Слой....

  8. Настройте добавленные поля в модели слоя:

    1. На панели расчетов ZuluGaz нажмите кнопку Настройки и перейдите на вкладку Данные.

    2. Выберите в списке объектов участок и нажмите кнопку Поля.

    3. В появившемся окне установите для полей ID начального узла и ID конечного узла соответствие с полями добавленными ранее, используя ... или кнопку Задать.

      Настройка полей объектов

      Рисунок 247. Настройка полей объектов

  9. Нажмите ОК и вернитесь на панель расчетов ZuluGaz.


Автоматическое занесение геодезических отметок объектов сети со слоя рельефа

При наличии в карте слоя рельефа (в том числе и слоя SRTM) для всех объектов слоя газовой сети можно автоматически считать геодезические отметки и занести их в соответствующее поле базы данных.

[Внимание] Внимание

Данная операция выполняется только для связанной инженерной сети. В случае когда объект не связан с сетью, геодезическая отметка считываться не будет.

Если отметки будут сниматься со слоя SRTM3, то необходимо убедиться, что слой сети хранит данные в одной из картографических проекций (Слой|Структура - Система координат). Если система координат «План-схема», то присвоения высот не будет, так как SRTM в географических координатах (широта\долгота) и связь план-схемы с глобусом отсутствует.

Для запуска операции занесения геодезических отметок следует:

  1. Выберите команду главного меню Задачи|ZuluGaz или нажмите или нажмите на панели инструментов кнопку [image] . На экране появится окно гидравлических расчетов.

    Окно гидравлических расчетов ZuluGaz

    Рисунок 248. Окно гидравлических расчетов ZuluGaz

  2. Нажмите кнопку Слой... и выберите из списка слой сети.

  3. Перейдите на вкладку Сервис.

  4. Нажмите кнопку Отметки высот с карты.

    Рисунок 249. Вкладка «Сервис»

  5. В появившемся окне нажмите кнопку Да, если вы хотите чтобы система записала высоты по всем узловым объектам слоя без исключения. В случае нажатия кнопки Нет - высоты будут записаны только для тех объектов, длины которых не указаны.

    В результате проведенной операции автоматически заполнится поле Геодезическая отметка для всех объектов сети.


Сценарии обработки данных

Сценарии обработки данных — это набор SQL-запросов, которые могут выполняться автоматически перед или после проведения расчета. Возможно ручное выполнение сценариев обработки данных. Сценарий может выполняться для выбранных пользователем типа расчета, например, только для поверочного, конструкторского и т.п.

Каждый сценарий может содержать набор (несколько) SQL-запросов, которые будут изменять ваши исходные данные или результаты расчетов. Вы можете создать собственные сценарии обработки данных для решения различных задач. Так как сценарии обработки данных строятся на основе SQL-запросов, вы получаете мощный инструмент, который экономит ваше время.

Сценарии обработки данных могут:

  1. запускаться автоматически перед/после выполнения расчёта или вручную;

    При автоматическом выполнении нескольких сценариев, пользователь может настроить очередность выполнения сценариев.

  2. выполняться до или после запуска указанных видов расчётов, например: перед поверочным, конструкторским и т.д. — указывается пользователем в настройках сценария;

[Предупреждение] Предупреждение

Если вы выбрали автоматическое выполнении перед расчетом, то сценарий выполнится в любом случае: даже если расчет не запустился или возникли ошибки!

Если расчет выполняется только для выбранного вами источника (газовой сети), то сценарий выполняется в соответствии с условием SQL-запроса и применяется ко всему слою инженерной сети. Для применения сценария к определенному источнику (газовой сети) можно:

  • написать SQL-запрос, с условием фильтрации, например, по значению поля Номер источника;

  • скопировать газовую сеть в отдельный слой.

Сценарии обработки данных сохраняются индивидуально для каждого слоя в списке сценариев.

Список сценариев обработки данных

Рисунок 250. Список сценариев обработки данных

Чтобы изменить порядок выполнения сценариев в окне Обработка данных используйте кнопки Вверх и Вниз — первый (верхний) в списке будет выполняться первым, и далее сверху→вниз.

Диалог настройки сценария обработки данных представлен на рисунке ниже. Для сценария указывается название, способ выполнения, SQL-запрос и выбираются инженерные расчеты, для которых выполняется данный сценарий.

Окно сценария обработки данных

Рисунок 251. Окно сценария обработки данных

[Примечание] Примечание

Чтобы избежать необходимости вносить изменения в SQL-запрос обработки данных при переименовании слоя или его копировании с другим именем, можно указать псевдоним текущего расчетного слоя — ${this_layer}.

В блоке Вывод на экран дополнительно можно настроить отображение результатов выполнения:

  • Название запроса - отображать или не отображать название сценария обработки данных.

  • Текст запроса - отображать или не отображать текст (код) SQL-запроса.

  • Рамки таблицы - для табличных результатов, отображать или не отображать рамки таблицы.

Отображение результатов выполнения в окне Сообщения

Рисунок 252. Отображение результатов выполнения в окне Сообщения


Псевдоним расчетного слоя в SQL-запросе

Чтобы избежать необходимости вносить изменения в SQL-запрос обработки данных при переименовании слоя или его копировании с другим именем, можно указать псевдоним текущего расчетного слоя.

Псевдоним указывается в коде в формате ${this_layer} вместо имени слоя. При выполнении SQL-запроса обработки данных этот псевдоним будет заменён на имя текущего слоя в расчетном модуле (выбранного на панели расчетов ZuluGaz).

Например следующий SQL-запрос:

UPDATE [Название слоя газовой сети]
SET [Расчетный расход воды, л/с] = [Текущий расход (приборы), л/с];

Можно переписать как:

UPDATE ${this_layer}
SET [Расчетный расход воды, л/с] = [Текущий расход (приборы), л/с];


Открыть список сценариев обработки данных

Сценарии сохраняются индивидуально для каждого слоя. Чтобы открыть список сценариев слоя:

  1. Выберите команду главного меню Задачи|ZuluGaz или нажмите кнопку [image] панели инструментов. На экране появится окно расчетов:

    Окно расчетов ZuluGaz

    Рисунок 253. Окно расчетов ZuluGaz

  2. Нажмите кнопку Слой... и выберите слой газовой сети.

  3. Перейдите на вкладку Сервис и нажмите кнопку Обработка данных. Откроется список сценариев, доступный для этого слоя.

    Список сценариев обработки данных

    Рисунок 254. Список сценариев обработки данных

  4. Для создания нового сценария нажмите кнопку Добавить. Для редактирования сценария выделите его в списке и нажмите кнопку Изменить.


Создать и редактировать сценарий обработки данных

В списке сценариев обработки данных представлены все сценарии, которые сохранены в слое.

[Подсказка] Подсказка

Рекомендуется перед созданием сценария протестировать работу SQL-запроса и скопировать его содержимое в буфер обмена — далее вы вставите его в окне параметров сценария.

Чтобы создать новый сценарий или отредактировать существующий:

  1. Откройте список сценариев обработки данных.

  2. Для создания нового сценария нажмите кнопку Добавить. Для редактирования существующего сценария выделите его в списке и нажмите кнопку Изменить.

    Откроется окно сценария обработки данных:

    Окно сценария обработки данных

    Рисунок 255. Окно сценария обработки данных

  3. Введите Название сценария.

  4. В выпадающем списке Выполнять укажите способ выполнения:

    • Вручную — сценарий будет запускаться вручную пользователем.

    • Автоматически перед расчетом — сценарий будет выполняться перед запуском расчёта.

      [Предупреждение] Предупреждение

      Если вы выбрали автоматическое выполнении перед расчетом, то сценарий выполнится в любом случае: даже если расчет не запустился или возникли ошибки!

      Если расчет выполняется только для выбранного вами источника (газовой сети), то сценарий выполняется в соответствии с условием SQL-запроса и применяется ко всему слою инженерной сети. Для применения сценария к определенному источнику (газовой сети) можно:

      • написать SQL-запрос, с условием фильтрации, например, по значению поля Номер источника;

      • скопировать газовую сеть в отдельный слой.

    • Автоматически после расчета — сценарий будет выполняться после проведения расчёта.

  5. В поле Запрос введите значение SQL-запроса или вставьте его из буфера обмена.

  6. Выберите для какого инженерного расчета будет применяться сценарий, отметив галочкой необходимые.

  7. В блоке Вывод на экран дополнительно можно настроить отображение результатов выполнения:

    • Название запроса - отображать или не отображать название сценария обработки данных.

    • Текст запроса - отображать или не отображать текст (код) SQL-запроса.

    • Рамки таблицы - для табличных результатов, отображать или не отображать рамки таблицы.

    Пример отображение результатов выполнения в окне Сообщения

    Рисунок 256. Пример отображение результатов выполнения в окне Сообщения

  8. Нажмите ОК.

  9. Если у вас несколько сценариев, то вы можете изменить порядок выполнения сценариев в окне со списком сценариев обработки с помощью кнопок Вверх и Вниз - первый (верхний) в списке будет выполняться первым, и далее сверху→вниз.

  10. Для сохранения изменений нажмите ОК.


Запуск вручную сценария обработки данных

Сценарии обработки данных могут выполняться вручную пользователем. Чтобы запустить вручную сценарий обработки данных:

  1. Откройте список сценариев обработки данных.

    Список сценариев обработки данных

    Рисунок 257. Список сценариев обработки данных

  2. Выберите необходимый сценарий из списка и нажмите кнопку Выполнить.

    Сценарий будет запущен, а в окне Сообщения отобразятся выполняемые в сценарии запросы.


Пример сценария обработки данных

Создайте и проверьте работу сценария обработки данных. Рассмотрим простой сценарий: у вас есть поле Расчетный расход, м3/час, которое автоматически должно заполнятся из поля Расход (приборы), м3/час. Сценарий должен выполняться только перед выполнением поверочного расчета.

SQL-запрос для сценария будет выглядеть следующим образом. Вам следует заменить название слоя и полей, если они отличаются от данного примера:

UPDATE ${this_layer}
SET [Расчетный расход, м3/час] = [Расход (приборы), м3/час];

Где:

  • ${this_layer} — псевдоним текущего расчетного слоя.

Создайте сценарий обработки данных:

  1. Выберите команду главного меню Задачи|ZuluGaz или нажмите кнопку [image] панели инструментов. На экране появится окно расчетов ZuluGaz:

    Окно расчетов ZuluGaz

    Рисунок 258. Окно расчетов ZuluGaz

  2. Нажмите кнопку Слой... и выберите слой газовой сети.

  3. Перейдите на вкладку Сервис и нажмите кнопку Обработка данных. Откроется список сценариев, доступный для этого слоя.

    Список сценариев обработки данных

    Рисунок 259. Список сценариев обработки данных

  4. Нажмите кнопку Добавить и укажите параметры сценария:

    • Название, например Расход абонентов с приборов.

    • Выполнять — Автоматически перед расчетом.

    • В поле Запрос вставьте SQL-запрос, описанный в начале статьи.

    • Отметьте галочкой Поверка для выполнения сценария только для поверочного расчета.

    Окно сценария обработки данных

    Рисунок 260. Окно сценария обработки данных

  5. Для сохранения сценария нажмите кнопку ОК.

Проверьте работу сценария

Для проверки работы созданного сценария обработки данных Запустите поверочный расчет для вашего слоя.

Сценарий будет автоматически запущен перед выполнением расчета, а в окне Сообщения отобразятся выполняемые запросы.

У потребителей газовой сети значение поля Расчетный расход, м3/час будет равно значению поля Расход (приборы), м3/час.


Справочники

В ZuluGaz используется только один пользовательский справочник: «Справочник по трубам (Сортамент)».


Справочник по трубам (Сортамент)

Для выполнения конструкторского расчета пользователь может самостоятельно создавать различные наборы диаметров (сортаменты), по которым программа будет выбирать нужный диаметр для каждого участка.

Каждому диаметру можно указать соответствующую толщину стенки трубопровода.

Сортамент можно создать самостоятельно, добавив новый материал или импортировать из существующего слоя ZuluGIS (ZuluServer). Также можно скопировать сортамент и изменить его "под себя". Для обмена сортаментами, их можно экспортировать различными способами.

[Подсказка] Подсказка

Производители трубопроводов для подготовки собственных сортаментов могут создать новый сортамент и экспортировать его в обменный файл с расширением .txt. Из этого обменного файла пользователи смогут импортировать сортамент и использовать его в своих слоях.

Справочник по трубам

Рисунок 261. Справочник по трубам

По умолчанию для каждой сети всегда существует сортамент под именем Сталь, он является основным. Если при подборе диаметров необходимо для разных участков использовать разные сортаменты, то имя нужного сортамента можно задать для каждого участка персонально поле Tubes, Сортамент в базе данных по участкам (смотритеРисунок 262, «Окно семантической информации по участкам»). Если это поле для участка пусто, то расчет для подбора диаметров для данного участка будет использовать основной сортамент.

Окно семантической информации по участкам

Рисунок 262. Окно семантической информации по участкам

Со справочником возможны следующие операции:

  • «Открытие справочника по трубам»;

  • «Выбор сортамента трубопровода»;

  • «Добавление нового диаметра к существующему сортаменту»;

  • «Удаление диаметра»;

  • «Добавление нового материала в справочник»;

  • «Удаление сортамента из справочника»;

  • «Копирование и добавление сортамента»;

  • «Импорт сортаментов»;

  • «Экспорт сортамента».


Хранение справочника по трубам

Для выполнения расчетов используется справочник Сортамент (справочник по трубам), который хранится непосредственно в слое водопроводной сети, далее будем называть его Справочник слоя. При создании нового слоя справочник слоя будет содержать "стандартный" набор сортаментов (Сталь, Чугун, ...).

Если у вас уже есть созданный ранее сортамент, то вам следует самостоятельно добавить его в свой слой. В справочник слоя можно добавить сортамент вручную или импортировать.

Импортировать сортамент можно из локального или серверного справочников, другого слоя или обменных файлов ZuluGaz с расширением .txt.

Подробнее о хранении справочников:

  • Справочник слоя

    Каждый слой водопроводной сети содержит собственные сортаменты, которые можно импортировать из различных источников: локального или серверного справочников, другого слоя или файла.

    Справочник слоя можно открыть через базу данных по участкам используя поле Материал трубопровода.

  • Локальный справочник

    Локальный справочник хранит список всех доступных сортаментов непосредственно на компьютере пользователя. Справочник хранится в файле "...\ZuluGIS\Preset\zpump\diameters_hydro.tl.

  • Серверный справочник

    Серверный справочник - список сортаментов хранится на ZuluServer. Позволяет организовать централизованное хранилище сортаментов.

  • Файл .txt

    Файл с расширением .txt - используется для обмена сортаментами. Список сортаментов импортируется или экспортируется из указанного пользователем текстового файла.


Открытие справочника по трубам

Для открытия справочника надо:

  1. Открыть окно семантической информации по конкретному участку ( [image] ).

  2. Установить курсор с правой стороны от строки Сортамент:

    Открытие справочника по трубам

    Рисунок 263. Открытие справочника по трубам

  3. Нажать кнопку .... Откроется окно справочника по трубам (Сортамент):

    Справочник по трубам

    Рисунок 264. Справочник по трубам


Выбор сортамента трубопровода

Для того чтобы выбрать сортамент из справочника по трубам надо:

  1. Открыть окно семантической информации по участку, на котором надо выбрать материал ( [image] ).

  2. Установить курсор с правой стороны от строки Сортамент.

  3. Нажать кнопку ...:

    Окно семантической информации по участкам

    Рисунок 265. Окно семантической информации по участкам

  4. В появившемся окне Сортамент нажать кнопку [image] и в открывшемся списке выбрать нужный сортамент. После чего Шероховатость, мм будет указана шероховатость труб выбранного сортамента, а в поле материал, соответственно материал сортамента.

    Рисунок 266. Сортамент

  5. Для подтверждения выбора и закрытия окна Сортамент необходимо нажать кнопку ОК.


Добавление нового диаметра к существующему сортаменту

Если в справочник к существующему сортаменту нужно добавить новый диаметр, то в этом случае следует:

  1. Открыть справочник по трубам (подробней смотрите «Открытие справочника по трубам»).

  2. Выбрать в верхнем списке сортамент к которому будет добавляться диаметр.

  3. Для добавления строки в конец списка нажать кнопку Добавить. Для добавления в определенном месте списка следует встать на определенную строку и нажать кнопку Вставить. Перед выделенной строкой добавится новая строка.

  4. Внести в добавленную строку новый наружный диаметр и толщину стенки трубопровода в мм.

  5. После ввода всех диаметров нажать кнопку Сохранить.

  6. Для закрытия окна Сортамент нажать кнопку ОК.


Удаление диаметра

Если возникнет необходимость удалить диаметр из сортамента, то для этого надо:

  1. Открыть справочник по трубам (подробней смотрите «Открытие справочника по трубам»).

  2. В появившемся окне из верхнего списка выбрать сортамент для удаления диаметра.

  3. В списке Наружный диаметр выделить удаляемый диаметр.

  4. Нажать кнопку Удалить.

  5. Нажать кнопку Сохранить. После сохранения изменений нажать кнопку ОК.


Добавление нового материала в справочник

В справочник по диаметрам трубопроводов можно добавлять новые сортаменты. Указание сортамента необходимо для того, чтобы при проведении конструкторского расчета программа «знала» какой набор диаметров существует для каждого материала.

Для того, чтобы добавить новый сортамент в справочник, следует:

  1. Открыть справочник по трубам (подробней смотрите «Открытие справочника по трубам»).

  2. Нажать кнопку Новый набор.

    или

    В окне Сортамент подвести курсор к списку с материалами, нажать правую кнопку мыши. В открывшемся контекстном меню выбрать пункт Добавить.

    Откроется диалог задания названия набора.

  3. Ввести название сортамента, нажать кнопку ОК.

  4. В список Внешний диаметр ввести все нужные диаметры и толщину стенки в мм. Добавление новой строки для диаметра вконец списка произойдет после нажатия кнопки Добавить, кнопка Вставить позволяет добавить диаметр над строкой с установленным курсором.

  5. В поле Шероховатость, мм занести шероховатость для создаваемого сортамент.

  6. Из списка Материал выбрать материал для сортамента.

  7. Для сохранения произведенных изменений надо нажать кнопку Сохранить.

  8. Для закрытия окна Сортамент нажать кнопку OK.


Удаление сортамента из справочника

Для того чтобы удалить сортамент из справочника надо:

  1. Открыть справочник по трубам (подробней смотрите «Открытие справочника по трубам»).

  2. Выбрать сортамент в справочнике.

  3. Нажать кнопку Удалить набор.

    или

    В окне Сортамент подвести курсор к списку сортаментов, нажать правую кнопку мыши. В открывшемся контекстном меню выбрать пункт Удалить.

  4. Нажать кнопку Сохранить.

  5. Для выхода из окна Сортамент нажать на кнопку OK.


Копирование и добавление сортамента

Для того, чтобы скопировать весь сортамент диаметров надо:

  1. Открыть справочник по трубам (подробней смотрите «Открытие справочника по трубам»).

  2. Для копирования диаметров выбрать сортамент в справочнике.

  3. Подвести курсор к списку с материалами, нажать правую кнопку мыши. В открывшемся контекстном меню выбрать пункт Копировать.

    Рисунок 267. Копирование сортамента

Для того, чтобы вставить сортамент диаметров надо:

  1. В окне Сортамент подвести курсор к списку сортаментов и нажать правую кнопку мыши. В открывшемся контекстном меню выбрать пункт Вставить.

  2. Ввести название для нового сортамента, нажать кнопку ОК.

  3. Нажать кнопку Сохранить.

  4. Для выхода из окна Сортамент нажать на кнопку OK.


Импорт сортаментов

Для выполнения расчетов используется справочник Сортамент (справочник по трубам), который хранится непосредственно в слое водопроводной сети, далее будем называть его справочник слоя.

Если у вас уже есть созданный ранее сортамент, то вы можете его импортировать. Импортировать сортамент можно из локального или серверного справочников, другого слоя или обменных файлов ZuluGaz с расширением .txt. При импорте сортамента, в вашем слое будет создана копия сортамента, которую вы можете изменить и использовать в своих расчетах.

Для импорта сортамента:

  1. Откройте справочник по трубопроводам.

  2. Нажмите кнопку Импорт:

    Рисунок 268. Импорт сортамента

  3. В открывшемся окне Сортамент нажать кнопку Импорт.

  4. В появившемся окне выбрать откуда будет производиться импорт.

    Диалог выбора источника при импорте сортаментов

    Рисунок 269. Диалог выбора источника при импорте сортаментов

    Подробнее об импорте смотрите соответствующие разделы:

    • «Импорт сортамента из слоя»

    • «Импорт сортамента из локального справочника»

    • «Импорт сортамента из справочника ZuluServer»

    • «Импорт сортамента из файла»


Импорт сортамента из слоя

Чтобы импортировать сортамент (справочник по трубам) из другого локального слоя в справочник слоя:

  1. В окне справочника насосов нажать кнопку Импорт. Откроется диалог выбора источника при импорте Рисунок 270, «Диалог выбора источника при импорте сортаментов»

    Диалог выбора источника при импорте сортаментов

    Рисунок 270. Диалог выбора источника при импорте сортаментов

  2. Нажать кнопку Импорт из слоя.

  3. В открывшемся окне выбрать слой газовой сети, из которого надо импортироваться сортамент.

  4. В открывшемся окне вы можете выбрать вручную сортаменты для экспорта. Опция Импортировать все позволяет выбрать сразу все сортаменты.

    Рисунок 271. Импорт сортаментов

  5. Нажмите кнопку Импортировать.

    Сортаменты из файла будут импортированы в сортамент слоя и будут доступны для выбора.

    Если в слое уже существует сортамент с таким именем, то при импорте в имя сортамента будет добавлен порядковый номер, например, Сталь (2).


Импорт сортамента из локального справочника

Чтобы импортировать сортамент (справочник по трубам) из локального справочника в справочник слоя:

  1. Откройте справочник по трубопроводам.

  2. В окне сортамента нажмите кнопку Импорт. Откроется диалог выбора источника для импорта:

    Диалог выбора источника при импорте сортаментов

    Рисунок 272. Диалог выбора источника при импорте сортаментов

  3. Нажмите кнопку Импорт из локального справочника.

  4. В открывшемся окне вы можете выбрать вручную сортаменты для экспорта. Опция Импортировать все позволяет выбрать сразу все сортаменты.

    Рисунок 273. Импорт сортаментов

  5. Нажмите кнопку Импортировать.

    Сортаменты из файла будут импортированы в сортамент слоя и будут доступны для выбора.

    Если в слое уже существует сортамент с таким именем, то при импорте в имя сортамента будет добавлен порядковый номер, например, Сталь (2).


Импорт сортамента из справочника ZuluServer

Чтобы импортировать сортамент (справочник по трубам) из справочника ZuluServer в справочник слоя:

  1. Откройте справочник по трубопроводам.

  2. В окне сортамента нажмите кнопку Импорт. Откроется диалог выбора источника для импорта:

    Диалог выбора источника при импорте сортаментов

    Рисунок 274. Диалог выбора источника при импорте сортаментов

  3. Нажмите кнопку Импорт из справочника на сервере. Откроется окно Источники геоданных.

    Окно Источники геоданных

    Рисунок 275. Окно Источники геоданных

  4. Выберите необходимый сервер из списка и нажмите ОК.

  5. В открывшемся окне вы можете выбрать вручную сортаменты для экспорта. Опция Импортировать все позволяет выбрать сразу все сортаменты.

    Рисунок 276. Импорт сортаментов

  6. Нажмите кнопку Импортировать.

    Сортаменты из файла будут импортированы в сортамент слоя и будут доступны для выбора.

    Если в слое уже существует сортамент с таким именем, то при импорте в имя сортамента будет добавлен порядковый номер, например, Сталь (2).


Импорт сортамента из файла

Чтобы импортировать сортамент (справочник по трубам) из файла в справочник слоя:

  1. Откройте справочник по трубопроводам.

  2. В окне сортамента нажмите кнопку Импорт. Откроется диалог выбора источника для импорта:

    Диалог выбора источника при импорте сортаментов

    Рисунок 277. Диалог выбора источника при импорте сортаментов

  3. Нажмите кнопку Импорт из файла и выберите необходимый .txt файл для импорта.

  4. В открывшемся окне вы можете выбрать вручную сортаменты для экспорта. Опция Импортировать все позволяет выбрать сразу все сортаменты.

    Рисунок 278. Импорт сортаментов

  5. Нажмите кнопку Импортировать.

    Сортаменты из файла будут импортированы в сортамент слоя и будут доступны для выбора.

    Если в слое уже существует сортамент с таким именем, то при импорте в имя сортамента будет добавлен порядковый номер, например, Сталь (2).


Экспорт сортамента

По-умолчанию сортамент (справочник по трубам) хранится в слое. Вы можете экспортировать сортамент из справочника слоя в локальный справочник, справочник на ZuluServer или в обменный файл .txt.

Для экспорта сортаментов из слоя:

  1. Откройте справочник по трубопроводам.

  2. В окне сортамента нажмите кнопку Экспорт.

  3. Отметьте сортаменты для экспорта. Чтобы выбрать все элементы, установите опцию Все.

    Рисунок 279. Экспорт сортаментов

  4. Выберите куда будет экспортирован сортамент и нажмите соответствующую кнопку:

    • Экспорт в файл — укажите имя и место расположения файла на локальном компьютере и сохраните файл в формате .txt.

    • Экспорт в локальный справочник — сохраните в локальный справочник сортаментов.

    • Экспорт в справочник на сервере — выберите соединение с ZuluServer, укажите данные авторизации и справочник будет сохранен на ZuluServer.

    Так как экспорт используется в основном для обмена сортаментами, то далее вы можете проверить — импортировать сортамент.


Отображение семантической информации на карте

Общие сведения

Для удобства анализа результатов расчета можно выводить атрибутивные данные по объектам на карту. Одновременно на карту можно выводить надписи по всем объектам, для каждого типа по своему шаблону. Надпись может быть по-разному расположена относительно объекта, сориентирована под произвольным углом и иметь различные стили.

[Примечание] Примечание

Надписи (бирки) обновляются автоматически, при обновлении значений в базе данных и карты.

В надписи по одному объекту могут участвовать значения разных его полей, которые можно выводить в одну или несколько строк, сопровождая каждое из полей своим шрифтом, цветом, префиксом и постфиксом. Можно выводить надписи по всем объектам, для каждого типа по своему варианту. Также имеется возможность одновременно подключать к каждому типу объектов слоя сразу несколько вариантов надписей.

Пример использования бирок для газопроводной сети

Рисунок 280. Пример использования бирок для газопроводной сети

[Примечание] Примечание

Подробнее о работе в редакторе можно узнать в справочном пособии по работе с ГИС ZuluGIS в разделе «Вывод данных на карту» http://politerm.com/zuludoc/label_overview.htm.


Тематическая раскраска

Общие сведения

Информация, внесенная в семантические базы данных, а также полученная в результате расчетов, может использоваться для тематической раскраски сети (изменения внешнего вида объектов). Раскраска позволяет проанализировать результаты расчета, а также наглядно выделить определенные объекты на карте.

Раскраску сети можно произвести двумя способами:

  1. «Раскраска с помощью встроенных фильтров» - позволяет окрасить сеть с помощью встроенных тематических фильтров после проведения поверочного расчета в зависимости от:

    • скорости движения газа в трубопроводе;

    • величины давления в трубопроводе.

  2. «Раскраска с помощью собственного фильтра» - позволяет окрасить любые объекты сети с помощью самостоятельно созданного нового тематического фильтра. Например, раскрасить трубопроводы в зависимости от расчетного расхода газа на участках.


Раскраска с помощью встроенных фильтров

  • «Запуск раскраски»;

  • «Настройки раскраски».


Запуск раскраски

[Важно] Важно

Окрасить сеть с помощью встроенных фильтров можно только после успешного проведения поверочного расчета.

Для того чтобы раскрасить сеть нужно:

  1. После успешного проведения поверочного расчета, в окне ZuluGaz в строке Раскраска нажать кнопку [image] . В открывшемся меню выбрать параметр, в зависимости от которого нужно произвести раскраску сети:

    Раскраска с помощью встроенных фильтров

    Рисунок 281. Раскраска с помощью встроенных фильтров

  2. После выбора параметра сеть окрасится в соответствии с заданными настройками (о настройках можно узнать в разделе «Настройки раскраски».

    Раскраска с помощью встроенных фильтров

    Рисунок 282. Раскраска с помощью встроенных фильтров


Настройки раскраски

Для того чтобы настроить тематические фильтры раскраски сети нужно:

  1. Выбрать команду главного меню Задачи|ZuluGaz или нажать на панели инструментов кнопку [image] .

  2. Нажать кнопку Слой... и выбрать слой сети.

  3. Нажать кнопку Настройки.

  4. Выбрать вкладку Раскраска.

    Рисунок 283. Настройки раскраски

  5. Выбрать тип настраиваемого параметра, нажав на соответствующую кнопку, например Скорость движения газа.

  6. В появившемся окне задать или изменить значения параметров V2 (V1 заполняется автоматически) и указать соответствующий этому диапазону значений цвет окраски:

    Настройка цветов для окраски

    Рисунок 284. Настройка цветов для окраски

    Кнопка Добавить служит для добавления пункта в конец списка. Для того чтобы вставить строчку перед определенным полем, необходимо выделить это поле, и нажать кнопку Вставить, перед выделенным полем появится новая строка.

  7. Нажать кнопку ОК для сохранения настроек.


Раскраска с помощью собственного фильтра

  • «Создание нового тематического файла»;

  • «Редактирование тематического файла»;

  • «Подключение тематической окраски»;

  • «Обновление тематической окраски»;

  • «Пример создания тематического фильтра».

[Примечание] Примечание

Более подробное описание тематической раскраски можно увидеть в справке по ZuluGIS в разделе Тематическая раскраска (смотрите http://politerm.com/zuludoc/theme_overview.htm)


Создание нового тематического файла

Система предусматривает возможность создания своего собственного фильтра по окраске объектов сети в зависимости от любого параметра семантической базы данных этих объектов. Создать, записать и отредактировать тематический фильтр можно в редакторе фильтров. Для вызова редактора следует выбрать пункт меню системы Карта|Тема|Редактор фильтра. На экране появится диалог редактора.

Зададим тематическую раскраску для участков, длина которых больше и меньше 300 метров.

Сначала необходимо создать тематический фильтр, для этого следует:

  1. В меню Карта выбрать команду Тема|Редактор фильтра.

  2. Нажать кнопку Слой, и в появившемся окне выбора файла указать слой газопроводной сети.

  3. В строке Шаблон ввести имя шаблона. (Например, Окраска по длине).

  4. Из открывающегося списка База выбрать базу данных Участок.

  5. В строке Имя задать название первого условия. (Например, Длина меньше 300 метров).

  6. В разделе набора условий в строке Длина, м ввести: <300.

    [Примечание] Примечание

    Синтаксис условий запроса аналогичен синтаксису в окне запросов по семантической базе данных.

  7. Указать тип объекта, выбрав вкладку Линейные. Задать цвет, стиль и толщину линий трубопровода:

    Создание тематического фильтра

    Рисунок 285. Создание тематического фильтра

  8. Для ввода следующего запроса нажать стрелку [image] в разделе [image] .

  9. В строке Имя задать название второго условия: Длина больше или равна 300 метров.

  10. В строке Длина, м ввести: >=300.

  11. В разделе Линии задать стиль, цвет и толщину трубопровода.

  12. Сохранить шаблон (кнопка Сохранить).

Создание тематического фильтра, 2-ое условие

Рисунок 286. Создание тематического фильтра, 2-ое условие

Теперь на основе тематического фильтра создаётся тематический файл:

  1. В меню Карта выбрать пункт Тема|Создать.

  2. В открывающемся списке Слой нажать на стрелку ( [image] ) и выбрать слой сети.

  3. В строке Фильтр нажать стрелку [image] и выбрать фильтр, созданный на предыдущем этапе (Окраска по длине).

  4. В строке Тема стереть надпись <Новая> и написать пользовательское название темы, например, также Окраска по длине.

  5. Отметить опцию Подключить к карте, нажать кнопку ОК.

    Создание тематического файла

    Рисунок 287. Создание тематического файла

    На экране отобразится созданная тематическая раскраска:

    Сеть с тематической окраской

    Рисунок 288. Сеть с тематической окраской


Редактирование тематического файла

Для редактирования тематической окраски надо:

  1. В меню Карта выбрать команду Тема|Редактор фильтра.

  2. Нажать на кнопку Слой, и в появившемся окне выбора файла указать слой сети.

  3. В строке Шаблон выбрать имя шаблона, который нужно отредактировать (Например, окраска по сети).

  4. Изменить необходимые параметры.

  5. Нажать кнопку ОК для сохранения изменений.

[Важно] Важно

После редактирования тематического фильтра, тематический файл надо обновить. Как это сделать можно узнать в разделе «Подключение тематической окраски».


Подключение тематической окраски

Для подключения тематической окраски необходимо:

  1. Выбрать пункт меню Карта|Тема|Подключить. Откроется окно Тематические раскраски.

  2. Дважды щелкнуть левой кнопкой мыши по названию раскраски. Двойной щелчок меняет вид иконки с цветного на черно-белый и наоборот. Цветная иконка означает, что окраска будет подключена к карте:

    Подключение тематической раскраски

    Рисунок 289. Подключение тематической раскраски

  3. После выбора необходимой раскраски и её подключения (отключения) нажмите кнопку ОК для сохранения.


Обновление тематической окраски

После расчета или после изменения исходных данных необходимо окрасить сеть повторно, для этого нужно:

  1. Выбрать пункт меню Карта|Тема|Подключить. Откроется окно Тематические раскраски.

  2. Выделить раскраску левой кнопкой мыши.

  3. Нажать кнопку Обновить.

  4. Нажать кнопку ОК для закрытия окна.

Обновление тематической окраски

Рисунок 290. Обновление тематической окраски


Пример создания тематического фильтра

Далее будет рассмотрен пример создания раскраски для потребителей карты Пример сети высокого и среднего давления, карту можно загрузить через меню Пуск/Zulu 8.0/Газоснабжение/сети низкого давления. Тематическая раскраска в примере будет создана для потребителей, у которых расчетный расход газа больше или равен 450 м3/час.

Первым этапом необходимо создание тематического фильтра.

  1. В меню Карта выбрать команду Тема|Редактор фильтра.

  2. Нажать кнопку Слой и в появившемся окне выбрать слой сети.

  3. В строке Шаблон ввести: Расчетный расход больше 450.

  4. В строке Имя задать название условия, например так же Расчетный расход больше или равен 450.

  5. Из списка База выбрать объект сети, в данном случае Потребитель.

  6. В разделе набора условий в строке Расчетный расход, м3/час ввести: >=450.

  7. Так как потребитель является символьным объектом, то в нижнем разделе надо выбрать вкладку Символьные.

  8. Нажать кнопку Новый символ и нарисовать символ в редакторе. Более подробное описание работы в графическом редакторе символов можно рассмотреть в справочном пособии по работе с ZuluGIS в разделе Векторный слой|Структура слоя|Символы|Редактор символов.

  9. В строке Размер установить значение 40.

    Пример создания тематического фильтра

    Рисунок 291. Пример создания тематического фильтра

  10. Сохранить шаблон (кнопка [image] Сохранить).

  11. Закрыть окно создания тематического фильтра (кнопка Закрыть).

Теперь следует на основе выбранного фильтра создать тематический файл, для этого надо:

  1. В меню Карта выбрать пункт Тема|Создать.

  2. В открывающемся списке Слой нажать на стрелку ( [image] ) и выбрать слой Система газоснабжения высокого давления.

  3. В строке Фильтр нажать на стрелку ( [image] ) и выбрать файл фильтра (Расчетный расход больше 450).

  4. В строке Тема стереть надпись <Новая> и ввести пользовательское название темы, например Потребители.

  5. Включить опцию Подключить к карте.

    Пример создания тематического файла

    Рисунок 292. Пример создания тематического файла

  6. Нажать кнопку ОK, после чего на экране отобразится созданная тематическая раскраска для потребителей:

    Пример подключенной тематической раскраски

    Рисунок 293. Пример подключенной тематической раскраски


Таблицы баз данных элементов газопроводной сети

  • «Регулирующее устройство»

  • «Узел сети (колодцы, разветвления)»

  • «Потребитель»

  • «Задвижка»

  • «Участок»

  • «Обратный клапан»


Регулирующее устройство

В таблицах используются следующие обозначения:

Поле | Обозначение
Исходные данные | ИД
Результаты расчета | Р

Вы можете самостоятельно настроить размерность полей, которые будут применяться для исходных данных и результатов вычислений.

Рекомендации по вводу исходных данных и список полей, необходимых для выполнения основных расчетов представлены в разделе Исходные данные для выполнения инженерных расчетов.

№

Имя поля

Наименование поля

Информация, записываемая в поле

Тип

1

Name

Наименование

Задается пользователем, например, ГРПШ-9.

ИД

2

Z_geo

Геодезическая отметка, м

Задается геодезическая отметка. Она может автоматически быть считана со слоя рельефа (смотрите «Автоматическое занесение геодезических отметок объектов сети со слоя рельефа»).

ИД

3

Preg

Давление на выходе, кПа

Задается давление на выходе регулирующего устройства.

ИД

4

Pin

Давление на входе, кПа

Определяется в результате расчета давление на выходе регулирующего устройства.

Р

5

Pfact

Фактическое давление на выходе, кПа

Определяется в результате расчета фактическое давление на выходе регулирующего устройства.

Доступно с версии — 10.0.0.8221(дата релиза — 04.07.2022).

Р

6

Gin

Расход при нормальных условиях, м3/ч

Определяется в результате расчета суммарный расход при нормальных условиях от регулирующего устройства.

Р

7

Gstd

Расход при стандартных условиях, м3/ч

Определяется в результате расчета суммарный расход при стандартных условиях от регулирующего устройства.

Р
8 Ro_t Плотность, кг/м3

Определяется в результате расчета плотность газа в данном узле.

Р
9 Pmin Минимальное давление, кПа

Пользователем указывается минимальное давление на входе на регулирующем устройстве.

В поверочном расчете значение данного поля должно быть больше или равно, чем значение поля Давление на выходе (Preg). Для поверочного расчета вы можете включить опцию Pmin равно давлению на выходе и оставить поле пустым.

В конструкторском расчете является обязательным, так как регулирующее устройство является "потребителем" с минимальным необходимым давлением.

ИД
10 | Gnorm | Расчетный расход, м3/час | Для конструкторского расчета задается пользователем расчетный расход газа. | ИД
11 | Kg | Снижение нагрузки, % | В настоящей версии в расчетах не используется. | ИД

12

Gmax_norm

Максимальный расход при нормальных условиях, м3/ч

Для поверочного расчета, конструкторского и расчета резерва. Пользователем указывается максимальный расход на данном регулирующем устройстве. При превышении максимального расхода, указанного на источнике, будет выводится предупреждающее сообщение (Расход на узле превышает максимальный ....).

Вы можете включить ограничение (регулирование) — для этого укажите 1 в поле Ограничитель по максимальному расходу.

Данное поле доступно, начиная с версии 10.0.0.8207 (дата релиза — 24.06.2022). После обновления вы можете его добавить самостоятельно и настроить, подробнее.

ИД

13

RegulG

Ограничитель по максимальному расходу

Для поверочного расчета, конструкторского и расчета резерва. Задаётся пользователем:

0 (или ПУСТО) — нет ограничения по расходу.

1 — включено ограничение максимального расхода на данном регулирующем устройстве.

[Предупреждение] Предупреждение

Ограничитель можно использовать только, если в сети есть несколько регулирующих устройств. Сразу на всех регулирующих устройствах ограничитель использовать нельзя — должен быть хотя бы один "неограниченный" источник.

В случае, когда с "неограниченного" источника расход будет превышать расчетный — давление на выходе будет снижаться.

Данное поле доступно, начиная с версии 10.0.0.8207 (дата релиза — 24.06.2022). После обновления вы можете его добавить самостоятельно и настроить, подробнее.

ИД


Узел сети (колодцы, разветвления)

В таблицах используются следующие обозначения:

Поле | Обозначение
Исходные данные | ИД
Результаты расчета | Р

Вы можете самостоятельно настроить размерность полей, которые будут применяться для исходных данных и результатов вычислений.

Рекомендации по вводу исходных данных и список полей, необходимых для выполнения основных расчетов представлены в разделе Исходные данные для выполнения инженерных расчетов.

№

Имя поля

Наименование поля

Информация, записываемая в поле

Тип

1

Name

Наименование

Задается пользователем.

ИД

2

H_geo

Геодезическая отметка, м

Задается отметка оси (верха) трубы, выходящей из колодца. Она может автоматически быть считана со слоя рельефа (смотрите «Автоматическое занесение геодезических отметок объектов сети со слоя рельефа»).

ИД

3

P

Давление, кПа

 В результате расчета определяется давление в узле.

Р

4

Ro_t

Плотность, кг/м3

 Определяется в результате расчета плотность газа.

Р

5

Sist

Источники

В результате расчета в данное поле записывается список источников (регулирующих устройств), от которых газ поступает к данному узлу.

По умолчанию записываются номера источников. Чтобы записывались наименования из поля Name, Наименование источника, следует в настройках расчетов включить опцию Записывать в поля "Источники" имена регуляторов.

Р


Потребитель

В таблицах используются следующие обозначения:

Поле | Обозначение
Исходные данные | ИД
Результаты расчета | Р

Вы можете самостоятельно настроить размерность полей, которые будут применяться для исходных данных и результатов вычислений.

Рекомендации по вводу исходных данных и список полей, необходимых для выполнения основных расчетов представлены в разделе Исходные данные для выполнения инженерных расчетов.

№

Имя поля

Наименование поля

Информация, записываемая в поле

Тип

1

Name

Название

Задается пользователем.

ИД
2 | Zgeo | Геодезическая отметка, м | Задается геодезическая отметка. Она может автоматически быть считана со слоя рельефа (смотрите «Автоматическое занесение геодезических отметок объектов сети со слоя рельефа»). | ИД

3

Sist

Источники

В результате расчета в данное поле записывается список источников (регулирующих устройств), от которых газ поступает к данному потребителю.

По умолчанию записываются номера источников. Чтобы записывались наименования из поля Name, Наименование источника, следует в настройках расчетов включить опцию Записывать в поля "Источники" имена регуляторов.

Р

4

Gnorm

Расчетный расход, м3/час

Задается пользователем по проектным данным, если потребитель задается как жилой дом, то данное поле не используется в расчетах.

ИД
5 | Knom | Коэффициент изменения расхода | При желании может быть задан пользователем коэффициент, который позволит уменьшить или увеличить расход, задается в долях от единицы. | ИД
6

Pmin

Минимальное давление, кПа

Задается пользователем по проектным данным.

ИД
7

Pmin

Максимальное давление, кПа

Задается пользователем по проектным данным.

ИД

8

G

Расход при нормальных условиях, м3/ч

В результате расчета определяется расход при нормальных условиях на данном участке.

Р

9

Gstd

Расход при стандартных условиях, м3/ч

В результате расчета определяется расход при стандартных условиях на данном участке.

Р

10

Gv

Фактический расход, м3/ч

В результате расчета определяется фактический расход (приведенный к заданным условиям температуры и давления в результате расчета) на данном участке .

РН

11

Pin

Давление на вводе, кПа

В результате расчета определяется давление на вводе.

 Р

12

Ro_t

Плотность, кг/м3

В результате расчета определяется плотность газа.

Р
13

Kg

Снижение нагрузки, %

Указывается допустимое снижение нагрузки на потребителе.

ИД

14

Type

Тип потребителя

Выбирается из списка тип потребителя (подробней см «Расход в зависимости от типа потребителя»). По умолчанию потребитель является Сосредоточенным.

ИД

15

Np4

Плита 4-конфорочная (количество)

В том случае, если потребитель задается как жилой дом, то необходимо задать количество оборудования на потребителе.

ИД

16

Qp4

Плита 4-конфорочная (номинальный расход)

В том случае, если потребитель задается как жилой дом, то необходимо задать номинальный расход газа на оборудовании.

ИД

17

Np2

Плита 2-конфорочная (количество)

В том случае, если потребитель задается как жилой дом, то необходимо задать количество оборудования на потребителе.

ИД

18

Qp4

Плита 2-конфорочная (номинальный расход)

В том случае, если потребитель задается как жилой дом, то необходимо задать номинальный расход газа на оборудовании.

ИД

19

Np4v

Плита 4-конфорочная и проточный нагреватель (количество)

 В том случае, если потребитель задается как жилой дом, то необходимо задать количество оборудования на потребителе.

ИД

20

Qp4v

Плита 4-конфорочная и проточный нагреватель (номинальный расход)

В том случае, если потребитель задается как жилой дом, то необходимо задать номинальный расход газа на оборудовании.

ИД

21

Np2v

Плита 2-конфорочная и проточный нагреватель (количество)

 В том случае, если потребитель задается как жилой дом, то необходимо задать количество оборудования на потребителе.

ИД

22

Qp2v

Плита 2-конфорочная и проточный нагреватель (номинальный расход)

В том случае, если потребитель задается как жилой дом, то необходимо задать номинальный расход газа на оборудовании.

ИД

23

Nev

Емкостной нагреватель, котел или печь (количество)

В том случае, если потребитель задается как жилой дом, то необходимо задать количество оборудования на потребителе.

ИД

24

Qev

Емкостной нагреватель, котел или печь (номинальный расход)

 В том случае, если потребитель задается как жилой дом, то необходимо задать номинальный расход газа на оборудовании.

ИД


Задвижка

В таблицах используются следующие обозначения:

Поле | Обозначение
Исходные данные | ИД
Результаты расчета | Р

Вы можете самостоятельно настроить размерность полей, которые будут применяться для исходных данных и результатов вычислений.

Рекомендации по вводу исходных данных и список полей, необходимых для выполнения основных расчетов представлены в разделе Исходные данные для выполнения инженерных расчетов.

№ | Имя поля | Наименование поля | Информация, записываемая в поле | Тип
1 | Name | Наименование запорного устройства | Задается пользователем, например Задвижка № 22 | ИД
2 | Zgeo | Геодезическая отметка, м | Задается отметка оси (верха) трубы, на которой установлено данное запорное устройство. Она может автоматически быть считана со слоя рельефа (смотрите «Автоматическое занесение геодезических отметок объектов сети со слоя рельефа»). | ИД
3 | P | Давление, кПа | В результате расчета определяется давление в узле. | Р
4 | Gin | Расход, м3/час | В результате расчета определяется расход в узле. | Р
5 | Ro_t | Плотность, кг/м3 | Определяется в результате расчета плотность газа. | Р


Участок

В таблицах используются следующие обозначения:

Поле | Обозначение
Исходные данные | ИД
Результаты расчета | Р

Вы можете самостоятельно настроить размерность полей, которые будут применяться для исходных данных и результатов вычислений.

Рекомендации по вводу исходных данных и список полей, необходимых для выполнения основных расчетов представлены в разделе Исходные данные для выполнения инженерных расчетов.

№

Имя поля

Наименование поля

Информация, записываемая в поле

Тип

1

Name

Наименование

Указывается пользователем наименование участка.

ИД

2

Begin_uch

Начало участка

Задается наименование начала участка (наименование узла, колодца, с которого данный участок начинается). Может быть внесено автоматически (подробней смотрите раздел «Автоматическое занесение начала и конца участков»).

ИД

3

End_uch

Конец участка

Задается наименование конца участка (наименование узла, колодца, в котором данный участок заканчивается). Может быть внесено автоматически (подробней смотрите раздел «Автоматическое занесение начала и конца участков»).

ИД

4

Beg_node

ID узла в начале

После завершения операции «Автоматическое занесение ID начала и конца участков» в это поле записывается идентификатор узлового объекта (SYS), который является началом данного участка.

5

End_node

ID узла в конце

После завершения операции «Автоматическое занесение ID начала и конца участков» в это поле записывается идентификатор узлового объекта (SYS), который является концом данного участка.

6

Zgeo

Геодезическая отметка начала, м

Задается геодезическая отметка начала участка в метрах. Используется для задания вертикальных опусков, подъемов, переходов над дорогами и т.п

ИД

7

Zgeo2

Геодезическая отметка конца, м

Задается геодезическая отметка конца участка в метрах. Используется для задания вертикальных опусков, подъемов, переходов над дорогами и т.п

ИД

8

len

Длина, м

Задается длина участка в плане, например 100, 150 м. Данное поле можно заполнить автоматически, сняв длину участка с карты в масштабе (смотрите раздел «Автоматическое занесение длины с карты»).

ИД

9

diam

Диаметр внутренний, м

Задается внутренний диаметр трубопровода, например 0.1.

ИД

10

ke

Шероховатость трубопровода, мм

Задается пользователем шероховатость, например, 0.1, 2, 3 мм.

ИД
11 kz Коэффициент местных потерь давления

Задается пользователем коэффициент местных потерь давления, который увеличивает расчетную длину участка, позволяя моделировать общие потери давления с учетом местных сопротивлений, таких как колена, тройники, запорная арматура, компенсаторы и другие элементы.

Если не указано поле Sum_Km (Сумма коэффициентов местных сопротивлений), то значение коэффициента местных потерь давления должно быть больше 1. Например, если вы введете 1.1 или 1.2, то расчетная длина участка трубопровода будет увеличена на 10% или 20%, соответственно.

Если же поле Sum_Km (Сумма коэффициентов местных сопротивлений) уже заполнено, то коэффициент местных потерь давления следует задавать равным 1.

ИД

12

Sum_Km

Сумма коэфф. местных сопротивлений

Указывается пользователем сумма коэффициентов местных сопротивлений ζ (всех кранов, тройников, запорной арматуры и т.д., на этом участке), на основании справочной литературы.

Данное поле можно оставить пустым, а общие потери давления с учетом местных сопротивлений, моделировать с помощью увеличения расчетной длины газопровода — для этого используйте поле kz, Коэффициент местных потерь давления.

ИД
13 Gw Путевой расход

Указывается пользователем путевой расход — суммарное потребление всех узловых расходов на расчетном участке; включает в себя расход всех мелких потребителей и ответвлений, не изображенные на схеме.

Если все потребители в сети изображены на схеме и заданы как потребители с расчетным расходом, то значение путевого расхода следует задавать равным 0.

ИД

14

Lr

Расчетная длина участка, м

Определяется в результате расчета (длина*коэффициент местных потерь давления).

P

15

G

Расход при нормальных условиях, м3/час

Определяется в результате расчета расход газа при нормальных условиях.

Р

16

Gstd

Расход при стандартных условиях, м3/ч

Определяется в результате расчета расход газа при стандартныз условиях.

Р

17

Gv

Фактический расход, м3/ч

Определяется в результате расчета. Значение объемного расхода на каждом участке получается из массового делением на фактическую плотность (сейчас плотность берется по начальному узлу участка).

Р

18

Pin

Давление в начале участка, к/Па

Определяется в результате расчета.

Р

19

Pout

Давление в конце участка, к/Па

Определяется в результате расчета.

Р

20

dPfact

Потеря давления, к/Па

Определяется в результате расчета.

Р

21

V

 Скорость в начале участка, м/сек

Определяется в результате расчета.

Р

22

Re

Число Рейнольдса

Определяется в результате расчета.

Р

23

Lamda

Коэффициент гидравлического трения

Определяется в результате расчета.

Р

24

Pg

Гидростатическое давление, к/Па

Определяется в результате расчета (только для низкого давления). Подробнее смотрите раздел Определение потерь давления в газопроводах.

Р

25

Nu

Кинематическая вязкость, м2/сек Определяется в результате расчета.

Р

26

sortament

Сортамент

 Выбирается пользователем из Справочника по трубам. Чтобы заполнить эту строку нажмите на кнопку .... Кнопка будет видна только, когда активна правая часть данной строки (подробней смотрите раздел «Справочник по трубам (Сортамент)»).

ИД

27

Proklad

Вид прокладки

Указывается для конструкторского расчёта. Вид прокладки выбирается из выпадающего списка:

1 — Подземная.

2 — Надземная.

3 — Наземная.

4 — Внутренняя.

ИД

28

diam_con

Расчетный внутренний диаметр, м

 Определяется в результате конструкторского расчета.

Р

29

Dcon_n

Расчетный наружный диаметр, м

Определяется в результате конструкторского расчета.

Р

30

diam_con_status

Статус при подборе диаметра

Позволяет зафиксировать диаметр при проведении конструкторского расчёта. Указывается или выбирается из списка:

0 (ПУСТО) — значение по-умолчанию. В результате конструкторского расчета для участка будет подобран диаметр.

1 — если в данном поле будет установлена 1, то на данном участке диаметр в результате расчета НЕ будет подбираться, а будет использоваться диаметр, указанный в поле Диаметр внутренний, м.

ИД

Следующие поля добавляются вручную и настраиваются для участия в расчете.

...

UserName1

Имя собственника

Поле используется в задаче Технологическая схема. Указывается строка - имя собственника для дальнейшего определения зон собственников.

ИД

...

UserName2

Номер зоны собственника

Используется в задаче Технологическая схема. После нажатия кнопки Зоны определяются номера зон собственников и записываются в данные поля.

Р


Обратный клапан

В таблицах используются следующие обозначения:

Поле | Обозначение
Исходные данные | ИД
Результаты расчета | Р

Вы можете самостоятельно настроить размерность полей, которые будут применяться для исходных данных и результатов вычислений.

Рекомендации по вводу исходных данных и список полей, необходимых для выполнения основных расчетов представлены в разделе Исходные данные для выполнения инженерных расчетов.

№ | Имя поля | Наименование поля | Информация, записываемая в поле | Тип
1 | Name | Наименование | Задается пользователем. | ИД
2 | H_geo | Геодезическая отметка, м | Задается геодезическая отметка оси (верха) трубы, выходящей из обратного клапана. Она может автоматически быть задана со слоя рельефа (смотрите «Автоматическое занесение геодезических отметок объектов сети со слоя рельефа»). | ИД
3 | Pin | Давление на входе, кПа | В результате расчета определяется давление в узле. | Р
4 | Pout | Давление на входе, кПа | В результате расчета определяется давление в узле. | Р
5 | Ro_t | Плотность, кг/м3 | Определяется в результате расчета плотность газа. | Р


Формулы

В данном разделе представлены формулы и определения используемые программой ZuluGaz. В дальнейшем данный раздел будет расширяться, однако сейчас в этом разделе представлены лишь некоторые зависимости. По всем формулам, отсутствующим в данном разделе Вы можете обратиться к разработчикам.


Основные понятия и определения

С целью однозначности понимания используемой терминологии введем следующие определения:

Расчетный участок газопровода – участок, в пределах которого нет изменения расхода газа; отсутствуют какие-либо источники, повышающие давление газа, например, компрессорные станции; отсутствуют устройства дросселирующие давление газа (ГРС, ГРП, ГРУ и т.д.); нет изменения диаметра трубопровода или типа прокладки, например, подземный, подводный, наземный или надземный.

Распределительные газопроводы, входящие в систему газоснабжения, подразделяются на:

  1. кольцевые;

  2. тупиковые;

  3. смешанные.

Газопроводы систем газоснабжения в зависимости от давления транспортируемого газа делятся на:

  1. Газопроводы высокого давления 1 категории - при рабочем давлении газа свыше 0,6 МПа (6 кгс/см2) до 1,2 МПа (12 кгс/см2) включительно для природного газа и газовоздушных смесей и до 1,6 МПа (16 кгс/см2 ) для сжиженных углеводородных газов (СУГ).

  2. Газопроводы высокого давления II категории - при рабочем давлении газа свыше 0,3 МПа (3 кгс/см2) до 0,6 МПа (6 кгс/см2).

  3. Газопроводы среднего давления - при рабочем давлении газа свыше 0,005 МПа (0,05 кгс/см2 до 0,3 МПа (3 кгс/см2).

  4. Газопроводы низкого давления - при рабочем давлении газа до 0,005 МПа (0,05 кгс/см2) включительно.


Нормальные и стандартные условия

Нормальными условиями принято считать давление газа P0=101.325 кПа и его температуру T0=0 ºС или T0=273.2 К.

ГОСТы на топливные газы принято утверждать при температуре T20=+20 ºС и P0101.325 кПа (760 мм рт.ст.), в связи с этим эти условия называют стандартными.

Нормальные и стандартные условия введены для сравнения объёмных количеств различных газов.

Приведение газа к нормальным условиям осуществляется по следующему уравнению:

Рисунок 294. (1)

Аналогично для приведения газа к стандартным условиям:

Рисунок 295. (2)

Иногда приходится газ, находящийся при нормальных и стандартных условиях, приводить к заданным условиям температуры и давления. Приведенные выше соотношения примут следующий вид:

Рисунок 296. (3)

Рисунок 297. (4)

где

  • V0- объём газа при нормальных условиях (P0, T0), м3;

  • V - объём газа при давлении P и температуре Т, м3;

  • P0 – нормальное давление газа, P0=101.325 кПа = 0.101325 МПа, (760 мм рт.ст.);

  • 273.2 – нормальная температура, то есть T0, К;

  • V20- объём газа при стандартных условиях (температуре T20=273.2+20=293.2 и давлении P0), м3.


Плотность

Плотность смеси сухих газов (упрощенная зависимость, приводится только для проверки полученных результатов расчета) можно определить как сумму произведений плотности компонентов на их объёмные доли в %

Рисунок 298. (5)

где

  • - плотность смеси сухого газа, кг/м3;

  • ri - объёмная доля i компонента в смеси, %;

  • - плотность i компонента, кг/м3.

[Предупреждение] Предупреждение

В программном комплексе расчет плотность смеси газов производится с учетом температуры и давления по специальной программе. Поэтому при проверке результатов расчета, значения плотности, определенные по зависимости *, могут несколько отличатся от величин приведенных в таблицах комплекса ZuluGaz.


Теплота сгорания

Низшую теплоту сгорания смеси газов определяют как сумму произведений величин теплоты сгорания горючих компонентов на их объёмные доли в %

Рисунок 299. (6)

где

  • - низшая теплота сгорания i компонента, ккал/м3.


Плотность и теплота сгорания простых газов

Газ | Химическая формула | Молекулярная масса | Плотность, кг/м3 при P0=101.3 кПа, Т0=0°С | Теплота сгорания
 |  |  |  | кДж/м3 при P0=101.3 кПа, Т0=0°С |  | кДж/3 при P0=101.3 кПа, Т0=0°С
 |  |  |  | высшая | низшая | высшая | низшая
Водород | H2 | 2.016 | 0.08999 | 12770 | 10800 | 3050 | 2579
Окись углерода | CO | 28.011 | 1.25 | 12640 | 12640 | 3019 | 3019
Метан | CH4 | 16.043 | 0.7168 | 39860 | 35840 | 9520 | 8560
Этан | C2H6 | 30.07 | 1.3566 | 70420 | 63730 | 16819 | 15221
Пропан | C3H8 | 44.097 | 2.019 | 101740 | 93370 | 24299 | 22300
Бутан | C4H10 | 58.124 | 2.60 | 133980 | 123770 | 31999 | 29560
Пентан | C5H12 | 72.151 | 3.221 | 158480 | 146340 | 37850 | 34951
Этилен | C2H4 | 28.05 | 1.26 | 65200 | 60100 | 15572 | 14354
Пропилен | C3H8 | 42.08 | 1.88 | 93900 | 87500 | 22427 | 20898
Бутилен | C4H8 | 56.11 | 2.5022 | 124000 | 115200 | 29615 | 27514
Ацетилен | C2H2 | 26.038 | 1.1707 | 58910 | 56900 | 14070 | 13590
Азот | N2 | 28.016 | 1.2505 | - | - | - | -
Кислород | O2 | 32 | 1.429 | - | - | - | -
Двуокись углерода | CO2 | 44.011 | 1.9768 | - | - | - | -
Двуокись серы | SO2 | 64.07 | 2.9266 | - | - | - | -
Сероводород | H2S | 34.082 | 1.5392 | 25460 | 23490 | 6081 | 5610
Воздух сухой (без CO2) | - | 28.96 | 1.2928 | - | - | - | -
Водяной пар | H2O | 18.016 | 0.768 | - | - | - | -

Наиболее важными параметрами являются номинальное и минимальное давление газа на входе в аппарат при работающей горелке.

Номинальное давление газа - это давление, при котором аппараты выдают заявленную мощность, при более низких давлениях газа аппараты будут сохранять работоспособность, но, естественно, не будут выдавать полную мощность.

Минимальное давления газа - это минимально возможное давление газа, при котором газовые аппараты будут сохранять работоспособность.

Ниже приведены значения номинального давления газа для газовых плит, колонок и котлов:

№ п/п | Тип газового прибора | Номинальное давление газа, КПа
1 | Газовая плита | 1.5
2 | Газовая колонка с пьезоэлектрическим поджигом | 1.3
3 | Газовая колонка с электрическим поджигом | 1.3
4 | Настенные газовые котлы | 1.3
5 | Напольные газовые котлы с атмосферными горелками | 1.8

[Примечание] Примечание

Точное значение минимально допустимого давления газа на входе можно узнать из инструкции на газовую горелку.

В отечественных газовых сетях низкого давления транспортирующих природный газ "нормальным" считается давление от 3.0 до 1.0 кПа то есть максимально допустимое давление газа перед газовым прибором, например, газовой плитой не должно превышать 3.0 кПа, минимальное давление газа не должно быть ниже 1.0 кПа.


Определение потерь давления в газопроводах

Основной формулой инженерной гидравлики, связывающей давление P, плотность [image] и скорость [image] является формула Дарси-Вейсбаха:

Рисунок 300. (17)

где

  • – потери давления на преодоление гидравлического сопротивления на участке газопровода [image] ;

  • - коэффициент гидравлического сопротивления;

  • и d– длина и внутренний диаметр трубы, м;

  • - скорость движения газа, м/с;

  • – плотность газа, кг/м3.

Расчет потерь давления на участках газовой сети низкого, среднего и высокого давления можно выполнять, с учетом температуры соответствующей нормальным условиям по СП 42-101-2003, так и с учетом температуры отличающейся от нормальных условий. В системе СИ эти формулы имеют вид:

Для газопроводов среднего и высокого давления

Рисунок 301. (18)

где

  • pн – абсолютное давление газа в начале газопровода, МПа;

  • pк – абсолютное давление газа в конце газопровода, МПа;

  • P0 – 0.101325 МПа;

  • – коэффициент гидравлического трения;

  • G0 – расход газа, м3/c, при нормальных условиях;

  • d – внутренний диаметр газопровода, м;

  • – плотность газа при нормальных условиях, кг/м3;

  • – расчетная длина газопровода постоянного диаметра, м.

Для газопроводов низкого давления

Рисунок 302. (19)

где

  • pн – давление газа в начале газопровода, Па;

  • pк – давление газа в конце газопровода, Па.

Формулы для определения потерь давления, учитывающие отличие температуры газа от 0 градусов Цельсия, имеют вид:

- для сетей среднего и высокого давлений

Рисунок 303. (20)

- для сетей низкого давления

Рисунок 304. (21)

где

  • T – температура газа, K;

  • T0 – температура газа при нормальных условиях, K.

Число Рейнольдса, определяющее режим движения газ по газопроводу, при расчетах по СП 42-101-2003 вычисляется по формуле:

Рисунок 305. (22)

где

  • G0 – расход газа, м3/ч, при температуре 0 °С и давлении 0,10132 МПа (760 мм. рт. ст.);

  • d – внутренний диаметр газопровода, см;

  • – коэффициент кинематической вязкости газа, м2/с (при температуре 0 °С и давлении 0,10132 МПа).

Число Рейнольдса, определяющее режим движения газ по газопроводу, с учетом температуры газа вычисляется по формуле:

Рисунок 306. (23)

где

  • - скорость течения газа, м/с;

  • d - внутренний диаметр газопровода, м;

  • – коэффициент кинематической вязкости газа при температуре T, м2/с;

  • G - объемный расход газа при температуре, м3/с.

Гидравлическая гладкость внутренней стенки трубопровода определяется по условию:

Рисунок 307. (24)

где

  • - эквивалентная абсолютная шероховатость внутренней поверхности стенки трубы, мм (см).

В зависимости от значения Re коэффициент гидравлического [image] трения можно определять по формуле:

В области ламинарного режима движения газа при

Рисунок 308. (25)

для критического режима работы при

Рисунок 309. (26)

- при в зависимости от выполнения условия *- Для гидравлически гладкой стенки (неравенство * справедливо):

При

Рисунок 310. (27)

при

Рисунок 311. (28)

Для шероховатых стенок (неравенство * несправедливо) при

Рисунок 312. (29)

При расчете газопроводов низкого давления следует учитывать дополнительное гидростатическое давление, возникающее из-за разности геодезических отметок конечной и начальной точек газопровода.

Рисунок 313. (30)

где

  • - плотность газа, кг/м3;

  • - разность геодезических отметок участка газопровода, м.

Дополнительное давление газа [image] с высотой возникает потому, что абсолютное давление в газопроводе падает в меньшей степени, чем барометрическое давление. При подъеме газопровода [image] будет положительным, а при опуске — отрицательным. Если газ тяжелее воздуха, (например, пропан), то дополнительное давление будет отрицательным (избыточное давление в газопроводе уменьшается).

Дополнительное избыточное давление учитывается при резко выраженном переменном рельефе местности.

Общие потери давления с учетом местных сопротивлений (колена, тройники, запорная арматура, компенсаторы, и др.) допускается определять путем увеличения фактической длины газопровода на 5 – 10% по формуле:

Рисунок 314. (31)

где

  • - потери давления по длине газопровода, Па;

  • =(1.05-1.1) - коэффициент местных потерь давления.

В случае, когда все местные сопротивления известны, расчетную длину участка газопровода можно определить по формуле:

Рисунок 315. (32)

где

  • - действительная длина участка, м;

  • - эквивалентная длина прямолинейного участка газопровода, м, потери давления на котором равны потерям давления в местном сопротивлении со значением коэффициента [image] =1.

Эквивалентная длина прямолинейного участка газопровода может быть определена по формуле:

Рисунок 316. (33)

где

  • - сумма коэффициентов местных сопротивлений расчетного участка;

  • - коэффициент гидравлического трения;

  • d - внутренний диаметр газопровода, м.


Путевой расход на участках

Путевой расход задается на участке газопровода. Чаще всего принимают, что расход от незначительных потребителей равномерно распределяется по длине участка, отбор газа сети принимается равномерным по всей его длине. Количество отбираемого газа заносится в базу данных по участкам поле Путевой расход.

  1. При расчете отдельного участка расход газа на нем определяется как половина от Путевого расхода:

    Рисунок 317.

  2. Если в конце участка установлен потребитель с сосредоточенным расходом то расход газа на нем определяется как сумма половины от Путевого расхода и сосредоточенного расхода:

    Рисунок 318.

  3. В случае, если этот участок транзитный Расход газа на нем равен сумме всех путевых и сосредоточенных расходов и половины от своего Путевого расхода:

    Рисунок 319.

Рисунок 320.


Расход в зависимости от типа потребителя

В Расчетном модуле ZuluGaz реализовано 2 способа задания потребителя. Расход будет определяться в зависимости от значения, которое указано в поле Тип потребителя.

Значение кода в справочнике 0- Сосредоточенный потребитель,

Значение кода в справочнике 1-Жилой дом.

  1. Сосредоточенный потребитель

    В качестве расхода указывается Максимальный расчетный часовой расход газа Qhd, м3/ч, при 0 °С и давлении газа 0,1 МПа (760 мм рт. ст.), определенному согласно СП 42-101-2003

  2. Жилой дом

    Согласно СП 42-101-2003 для отдельных жилых домов и общественных зданий расчетный часовой расход газа Qhd, м3/ч, следует определять по сумме номинальных расходов газа газовыми приборами с учетом коэффициента одновременности их действия по формуле:

    Рисунок 321.

где

  • - сумма произведений величин Ksim, qnom и ni от i до m;

  • Ksim - коэффициент одновременности, принимаемый для жилых домов по таблице ниже;

    qnom - номинальный расход газа прибором или группой приборов, м3/ч, принимаемый по паспортным данным или техническим характеристикам приборов;

    ni - число однотипных приборов или групп приборов;

    т - число типов приборов или групп приборов.

Число квартир | Коэффициент одновременности Ksim в зависимости от установки в жилых домах газового оборудования
Плита 4-конфорочная | Плита 2-конфо-рочная | Плита 4-конфорочная и газовый проточный водонагреватель | Плита 2-конфорочная и газовый проточный водонагреватель
1 | 1 | 1 | 0,700 | 0,750
2 | 0,650 | 0,840 | 0,560 | 0,640
3 | 0,450 | 0,730 | 0,480 | 0,520
4 | 0,350 | 0,590 | 0,430 | 0,390
5 | 0,290 | 0,480 | 0,400 | 0,375
6 | 0,280 | 0,410 | 0,392 | 0,360
7 | 0,280 | 0,360 | 0,370 | 0,345
8 | 0,265 | 0,320 | 0,360 | 0,335
9 | 0,258 | 0,289 | 0,345 | 0,320
10 | 0,254 | 0,263 | 0,340 | 0,315
15 | 0,240 | 0,242 | 0,300 | 0,275
20 | 0,235 | 0,230 | 0,280 | 0,260
30 | 0,231 | 0,218 | 0,250 | 0,235
40 | 0,227 | 0,213 | 0,230 | 0,205
50 | 0,223 | 0,210 | 0,215 | 0,193
60 | 0,220 | 0,207 | 0,203 | 0,186
70 | 0,217 | 0,205 | 0,195 | 0,180
80 | 0,214 | 0,204 | 0,192 | 0,175
90 | 0,212 | 0,203 | 0,187 | 0,171
100 | 0,210 | 0,202 | 0,185 | 0,163
400 | 0,180 | 0,170 | 0,150 | 0,135

Примечания:

1. Для квартир, в которых устанавливается несколько однотипных газовых приборов, коэффициент одновременности следует принимать как для такого же числа квартир с этими газовыми приборами.

2. Значение коэффициента одновременности для емкостных водонагревателей, отопительных котлов или отопительных печей рекомендуется принимать равным 0,85 независимо от количества квартир.


Расчет сетей по методике СТО ГАЗПРОМ ГАЗОРАСПРЕДЕЛЕНИЕ 12.2.2–1–2013

  • «Гидравлический расчет газопровода»

  • «Оценка пропускной способности газопроводов сетей газораспределения»


Гидравлический расчет газопровода

Гидравлический расчет газопровода проводится для стационарного режима течения и заключается в определении неизвестных параметров режима по заданным граничным условиям. В число параметров режима входят давление в начальной и конечной точке газопровода, расход и скорость течения газа. В качестве граничных условий задаются,как правило, два из трех параметров: расход, давление в начальной и конечной точке. Расчеты проводятся при заданном компонентном составе и температуре газа.

Основными задачами при выполнении гидравлического расчета для газопровода являются:

  • определение пропускной способности газопровода при заданном максимальном давлении газа в начальной точке и минимальном допустимом давлении газа в конечной точке;

  • определение давления в конечной точке газопровода при заданном расходе газа и давлении в начальной точке;

  • определение давления в начальной точке газопровода при заданном расходе газа и давлении в конечной точке;

  • определение расхода газа при заданных значениях давления в начальной и конечной точке газопровода.

Значения искомых величин определяются по формулам стационарного изотермического течения газа:

без учета рельефа трассы газопровода по формуле:

Рисунок 322.

с учетом рельефа трассы газопровода (hj ≠ hi) по формуле:

Рисунок 323.

Рисунок 324.

где

  • pi - абсолютное давление газа в начальной i точке u-го участка газопровода, МПа;

  • pj - абсолютное давление газа в конечной j точке u-го участка газопровода, МПа;

  • - КГС на участке газопровода u;

  • qu - расход газа при стандартных условиях по u-му участку газопровода, м3/ч;

  • |qu| - модуль величины qu , м3/ч;

  • - плотность газа при стандартных условиях, кг/м3;

  • Lu - расчетная длина u-го участка газопровода постоянного диаметра, м;

  • Tср - среднее значение температуры газа на участке газопровода, К;

  • zср - средний коэффициент сжимаемости газа;

  • g - ускорение свободного падения, м/с2;

  • hi - абсолютная отметка высот в начале (в узле i) u-го участка газопровода, м;

  • hj - абсолютная отметка высот в конце (в узле j) u-го участка газопровода, м;

  • R - газовая постоянная, Дж/(кг*К).

Коэффициент гидравлического трения λтр следует определять в зависимости от режима движения газа по газопроводу u, характеризуемого числом Рейнольдса:

Рисунок 325.

Коэффициент гидравлического трения следует определять по формуле:

Рисунок 326.

Коэффициент ε абсолютной эквивалентной шероховатости внутренней поверхности стенки трубы.

Среднее давление газа Рср по длине газопровода следует определять по формуле:

Рисунок 327.

где

  • p1 – абсолютное давление газа в начальной точке газопровода, МПа;

  • p2 – абсолютное давление газа в конечной точке газопровода, МПа.

Среднюю температуру газа Тср по длине газопровода следует принимать равной средней температуре газа (по данным телеметрии) или температуре окружающей среды (грунта для подземных газопроводов, воздуха – для надземных газопроводов).

Средний коэффициент сжимаемости газа по длине газопровода следует определять по формуле:

Рисунок 328.

Рисунок 329.

Рисунок 330.

Рисунок 331.

Максимальная скорость движения газа в u-ом участке газопровода νu, м/с, определяется по формуле:

Рисунок 332.

где

  • qu – расход газа при стандартных условиях по u-му участку газопровода, м3/ч;

  • Tср – среднее значение температуры газа на участке газопровода, К;

  • zср – средний коэффициент сжимаемости газа;

  • pi – абсолютное давление газа в начальной i точке u-го участка газопровода, МПа;

  • pj – абсолютное давление газа в конечной j точке u-го участка газопровода, МПа;

  • min (pi, pj) – минимальное значение из двух величин pi и pj;

  • du – внутренний диаметр u-го участка газопровода, мм.


Оценка пропускной способности газопроводов сетей газораспределения

Пропускная способность газопровода qпс.гп, м3/ч, определяется при заданных значениях давления газа в начальной точке р1, МПа, и в конечной точке р2, МПа, газопровода из соотношений:

– без учета рельефа трассы газопровода по формуле

Рисунок 333.

– с учетом рельефа трассы газопровода по формуле

Рисунок 334.

где

  • d – внутренний диаметр участка газопровода, мм;

  • λ – КГС на участке газопровода;

  • ρ0 – плотность газа при стандартных условиях, кг/м3;

  • L – расчетная длина участка газопровода, м;

  • Tср – среднее значение температуры газа на участке газопровода, К;

  • a – коэффициент, определяемый по формуле:

    Рисунок 335.

  • zср – средний коэффициент сжимаемости газа.


Коммутационные задачи


Расход газа на продувку

При вводе газопроводов и оборудования в эксплуатацию согласно требований п.6.48 «Правил безопасности в газовом хозяйстве» следует производить продувку газом до полного вытеснения всего воздуха.

Расход газа Qпр, м3, необходимый для осуществления продувки, определяется по формуле:

Рисунок 336. Расход газа

где

  • Vc - внутренний объем продуваемых газопроводов и оборудования, м3;

  • Pа - атмосферное давление, Па;

  • Pг - избыточное давление газа в газопроводе при продувке, Па (рабочее- для газопроводов низкого давления, не более 0,1 МПа- для газопроводов среднего и высокого давления);

  • tг - температура газа, °С.

  • k - поправочный коэффициент (1,25-1,30). Поправочный коэффициент учитывает реальное увеличение расхода газа на продувку, связанное с техническими сложностями точного определения момента завершения продувки. Коэффициент может быть уменьшен в зависимости от технической оснащенности эксплуатационной организации и квалификации персонала, в частности, при использовании переносных газоанализаторов для экспресс-анализа газа на наличие в нем воздуха.


Расход газа на продувку и заполнение

Определение расхода газа на ремонтные работы, связанные с отключением оборудования или отдельных участков газопровода, их разгерметизацией и последующей продувкой.

При проведении ремонтных работ, связанных с регламентной разгерметизацией оборудования и участков газопроводов, полный расход газа на эти работы Qр, м3, складывается из количества газа, удаляемого из оборудования и газопровода, а также расхода газа на их последующее заполнение, продувку и определяется по формуле:

Полный расход газа

Рисунок 337. Полный расход газа


Расход газа на регулировку и настройку газового оборудования

Определение расхода газа на регулировку и настройку газового оборудования ГРП, ШРП, ГРУ и другого технологического оборудования (при использовании продувочных свечей для регулировки и настройки оборудования).

Расход газа на регулировку и настройку газового оборудования перед вводом его в эксплуатацию Qрег, м3, определяется по формуле:

Расход газа на регулировку

Рисунок 338. Расход газа на регулировку

где

  • d - внутренний диаметр продувочной свечи, м;

  • - время регулировки и настройки, ч;

  • - плотность газа, кг/м3.


Обновление ПО и настройка защиты HASP

Пользуясь программным обеспечением компании Политерм важно следить за тем, чтобы работа производилась на крайней, наиболее полной версии. Так как наши разработчики постоянно развивают возможности системы, использование устаревшей версии существенно ограничивает возможности.

[Предупреждение] Предупреждение

При использовании локальной версии программы достаточно обновить только ZuluGIS. Если же используется серверная версия (сервер геонформационной системы) необходимо обновить ZuluServer за компьютером сервером и ZuluGIS на всех клиентских рабочих местах.

При любом из вышеперечисленных вариантов отдельно обновлять расчетные модули не требуется.

Для получения уведомлений о новой версии при запуске системы надо выбрать меню Справка|Проверка обновлений и отметить соответствующую опцию. Если установленная версия будет отличаться от свежей, то при запуске системы появится окно:

Рисунок 339. Версия системы

Скачать свежую версию можно пройдя по указанной в диалоге ссылке. Обновление в рамках версии ZuluGIS 2021 и версий ZuluGIS 5.2 - ZuluGIS 8.0 отличается. Перед обновлением рекомендуется ознакомиться с соответствующими инструкциями.

[Примечание] Примечание

После обновления версии рекомендуется ознакомиться с историей изменений. Просмотреть историю можно или перейдя на наш сайт или выбрав меню Справка|История изменений.

Для определения номера установленной версии ZuluGIS выберите в меню пункт Справка|О программе..., в появившемся окне обратите внимание на цифры, выделенные на рисунке снизу. Данные цифры являются номером версии и датой сборки.

Рисунок 340. Версия системы

Обновление системы в рамках версии 2021

Обновление системы

Для обновления установленной на рабочем месте ZuluGIS с сохранением пользовательских настроек и справочников, необходимо устанавливать обновление поверх существующей версии, в ту же самую папку (будет предложена при установке программой-установщиком).

[Внимание] Внимание

Перед установкой обновления обязательно закройте ZuluGIS и ZuluServer.

Процесс установки:

  1. Скачайте дистрибутив обновления:

    • для 32-битной версии – https://www.politerm.com/download/?dl=zulu2021msi_x86

    • для 64-битной версии – https://www.politerm.com/download/?dl=zulu2021msi_x64

  2. На компьютере, на котором будет производиться установка ZuluGIS, закройте все приложения.

  3. Запустите загруженный исполняемый файл.

  4. Следуйте инструкциям мастера установки.

В состав пакетов обновления входит:

  • ZuluGIS 2021 – геоинформационная система

  • ZuluThermo 2021 – расчёты систем теплоснабжения

  • ZuluSteam 2021 – расчёты систем пароснабжения

  • ZuluHydro 2021 – расчёты систем водоснабжения

  • ZuluDrain 2021 – расчёты систем водоотведения

  • ZuluGaz 2021 – расчёты систем газоснабжения

  • Коммутационные задачи

  • ПО для построения графиков

Скачать обновление для ZuluGIS так же можно в разделеhttps://www.politerm.com/download/?pr=zulugis.

После обновления полезно ознакомиться с историей внесенных изменений:

  • https://www.politerm.com/history/

Обновление справки

В текущей версии справка обновляется автоматически. Дату последней редакции справки можно посмотреть в разделе Контакты.


Настройка защиты HASP

Защита программного обеспечения ZuluGIS, в том числе и ZuluGaz осуществляется посредством ключа защиты HASP. Рассмотрим 2 основных варианта защиты:

1. Организация использует локальный ключ.

При использовании локального ключа защиты HASP, настройка заключается лишь в установке драйвер для USB ключа.

2. Организация использует сетевой ключ.

При использовании сетевого ключа защиты HASP обязательно следует проверить доступность сетевого ключа (по следующей строке в любом интернет браузере http://localhost:1947/_int_/ACC_help_index.html.

При доступности сетевого ключа, следует включить его использование для:

  1. Выполнения расчетов.

  2. Построения графика падения давления.

  3. Коммутационных задач.

  4. Построения и экспорта профиля в DXF.

    [Подсказка] Подсказка

    Опцию опроса сетевого также можно включить выбрав команду главного меню Сервис|Параметры и перейдя на вкладку Hasp.

[Внимание] Внимание

В случае возникновения проблем, обратитесь к подробной статье по настройке, представленной на нашем сайте в разделе Организация защиты продуктов.


Контакты

Если ознакомившись с данным руководством пользователя у вас еще остались вопросы по работе с системой, или в процессе работы возникли какие либо проблемы, то свяжитесь с нашей технической поддержкой. Так же мы будем рады слышать от вас пожелания по расширению функциональности системы и предложения по доработке справки.

[Важно] Важно

Прежде чем связываться с нашими специалистами, убедитесь что у вас установлена самая последняя версия ZuluGIS, так как после звонка к нам именно это первым делом попросит осуществить наша техническая поддержка. Связано это с тем, что обновления происходят регулярно, и может возникнуть такая ситуация, что ошибка уже была исправлена. Как установить новую версию можно узнать в разделе Обновление системы.

Техническая поддержка доступна по телефонам (812)767-0352, 767-0353, 766-6728, электронной почте politerm@politerm.com и на нашем форуме: https://www.politerm.com/forums/.

Данная версия справочной системы от 25 06 2025


Трубопроводы для газовой сети

Трубы стальные

N п.п | Диаметр трубопровода, мм |  |  | Толщина стенки трубы,мм
 | Условный | наружный | внутренний
1. | 50 | 57 | 50 | 3,5
2. | 70 | 76 | 69 | 3,5
3. | 80 | 89 | 82 | 3,5
4. | 100 | 108 | 100 | 4,0
5. | 125 | 133 | 125 | 4,0
6. | 150 | 159 | 150 | 4,5
7. | 175 | 194 | 184 | 5,0
8. | 200 | 219 | 207 | 6,0
9. | 250 | 273 | 259 | 7,0
10. | 300 | 325 | 309 | 8,0
11. | 350 | 377 | 359 | 9,0
12. | 350 | 377 | 357 | 10,0
13. | 400 | 426 | 414 | 6,0
14. | 400 | 426 | 408 | 9,9
15. | 450 | 480 | 468 | 6,0
16. | 450 | 480 | 466 | 8,0
17. | 500 | 529 | 517 | 6,0
18. | 500 | 529 | 515 | 7,0
19. | 600 | 630 | 616 | 7,0
20. | 600 | 630 | 614 | 8,0
21. | 700 | 720 | 706 | 7,0
22. | 700 | 720 | 704 | 8,0
23. | 700 | 720 | 702 | 9,0
24. | 800 | 820 | 804 | 8,0
25. | 900 | 920 | 902 | 9,0
26. | 1000 | 1020 | 1000 | 10,0
27. | 1200 | 1220 | 1198 | 11,0
28. | 1200 | 1220 | 1192 | 14,0
29. | 1400 | 1420 | 1398 | 11,0
30. | 1400 | 1420 | 1392 | 14,0

Трубы из полиэтилена высокой плотности (ГОСТ 118599-73)

Средний наружный диаметр. мм | Тип труб
 | Л |  | СЛ |  | С |  | Т
 | Номинальная толщина стенок, мм | Внутренний диаметр, мм | Номинальная толщина стенок, мм | Внутренний диаметр, мм | Номинальная толщина стенок, мм | Внутренний диаметр, мм | Номинальная толщина стенок, мм | Внутренний диаметр, мм
110 | 2.7 | 104.6 | 4.3 | 101.4 | 6.2 | 97.6 | 10.0 | 90
125 | 3.1 | 118.8 | 4.8 | 115.4 | 7.1 | 110.8 | 11.4 | 102.2
140 | 3.5 | 133 | 5.4 | 129.2 | 7.9 | 124.2 | 12.7 | 114.6
160 | 3.9 | 152.2 | 6.2 | 147.6 | 9.1 | 141.8 | 14.6 | 130.8
180 | 4.4 | 171.2 | 7.0 | 166 | 10.2 | 159.6 | 16.4 | 147.2
200 | 4.9 | 190.2 | 7.7 | 184.6 | 11.4 | 177.2 | 18.2 | 163.6
225 | 5.5 | 214 | 8.7 | 207.6 | 12.8 | 199.4 | 20.5 | 184
250 | 6.1 | 237.8 | 9.7 | 230.6 | 14.2 | 221.6 | 22.8 | 201.4
280 | 6.9 | 266.2 | 10.8 | 258.4 | 15.9 | 248.2 | 25.5 | 229
315 | 7.7 | 299.6 | 12.2 | 290.6 | 17.9 | 279.2 | - | -
355 | 8.7 | 337.6 | 13.7 | 327.6 | 20.1 | 314.8 | - | -
400 | 9.8 | 380.4 | 15.4 | 369.2 | 22.7 | 354.6 | - | -
450 | 11.0 | 428 | 17.3 | 415.4 | 25.5 | 399 | - | -
500 | 12.2 | 475.6 | 19.3 | 461.4 | - | - | - | -
560 | 13.7 | 532.6 | 21.6 | 516.8 | - | - | - | -
630 | 15.4 | 599.2 | 24.3 | 581.4 | - | - | - | -

Трубы из полиэтилена низкой плотности (ГОСТ 18599-73)

Средний наружный диаметр,мм | Тип труб
 | Л |  | Л |  | Л |  | Л
 | Номинальная толщина стенок, мм | Номинальная толщина стенок, мм | Номинальная толщина стенок, мм | Номинальная толщина стенок, мм | Номинальная толщина стенок, мм | Номинальная толщина стенок, мм | Номинальная толщина стенок, мм | Номинальная толщина стенок, мм
50 | 2.4 | 2.4 | 2.4 | 2.4 | 2.4 | 2.4 | 2.4 | 2.4
63 | 3.0 | 3.0 | 3.0 | 3.0 | 3.0 | 3.0 | 3.0 | 3.0
75 | 3.6 | 3.6 | 3.6 | 3.6 | 3.6 | 3.6 | 3.6 | 3.6
90 | 4.3 | 4.3 | 4.3 | 4.3 | 4.3 | 4.3 | 4.3 | 4.3
110 | 5.2 | 5.2 | 5.2 | 5.2 | 5.2 | 5.2 | 5.2 | 5.2
125 | 6.0 | 6.0 | 6.0 | 6.0 | 6.0 | 6.0 | 6.0 | 6.0
140 | 6.7 | 6.7 | 6.7 | 6.7 | 6.7 | 6.7 | 6.7 | 6.7
160 | 7.7 | 7.7 | 7.7 | 7.7 | 7.7 | 7.7 | 7.7 | 7.7

Трубы из полиэтилена низкого давления (ТУ 6-19-051-259-80)

Средний наружный диаметр,мм | Тип труб
 | Л |  |  |  | Л |  |
 | толщина стенок, мм | Внутренний диаметр, мм | толщина стенок, мм | Внутренний диаметр, мм | толщина стенок, мм | Внутренний диаметр, мм | толщина стенок, мм | Внутренний диаметр, мм
63 | - | 63 | - | 63 | - | 63 | - | 63
110 | - | 110 | - | 110 | - | 110 | - | 110
160 | - | 160 | - | 160 | - | 160 | - | 160
225 | - | 225 | - | 225 | - | 225 | - | 225
315 | - | 315 | - | 315 | - | 315 | - | 315
400 | - | 400 | - | 400 | - | 400 | - | 400
500 | - | 500 | - | 500 | - | 500 | - | 500
630 | - | 630 | - | 630 | - | 630 | - | 630
710 | - | 710 | - | 710 | - | 710 | - | 710
800 | - | 800 | - | 800 | - | 800 | - | 800
900 | 22.0 | 900 | 22.0 | 900 | 22.0 | 900 | 22.0 | 900
1000 | 24.4 | 1000 | 24.4 | 1000 | 24.4 | 1000 | 24.4 | 1000
1200 | 29.3 | 1200 | 29.3 | 1200 | 29.3 | 1200 | 29.3 | 1200

Применяемые материалы труб в зависимости от вида прокладки

Вид прокладки газопровода | Применяемый материал труб
Подземный | Полиэтилен, сталь
Наземный | Сталь
Надземный | Сталь
Подводный | Сталь
Внутренний | Сталь, медь

Значения эквивалентной шероховатости внутренней поверхности стенки трубы

Тип трубы | Состояние трубы | Эквивалентная шероховатость трубы, мм
Бесшовные стальные трубы | Новые и чистые | 0.1
Бесшовные стальные трубы | Бывшие в эксплуатации | 1.0
Стальные сварные трубы | Новые и чистые | 0.3
Полиэтиленовые | Новые, технически гладкие, независимо от срока эксплуатации | 0.007

Коэффициент местного сопротивления

№ п/п | Вид местного сопротивления | Значение
1 | Внезапное сужение в пределах перехода на следующий диаметр по ГОСТу | 0.35 *
2 | Тройник проходной | 1 **
3 | Тройник поворотный (ответвление) | <1.5 **
4 | Крестовина проходная | 2 **
5 | Крестовина поворотная | 3 **
6 | Отвод гнутый 90° | 0.3

Примечание:

* [image] отнесен к участку с меньшим диаметром;

** [image] отнесен к участку с меньшим расходом газа.


Компоненты газовой смеси

Состав газовой смеси может задаваться пользователем и это может быть не только природный газ, но и обычный воздух. Возможно задание следующих компонентов:

Метан | Пропилен | Пентан
Этан | CO2 | Изопентан
Пропан | Азот | Водород
Бутан | Кислород | CO
Изобутан | Аргон | Аммиак