ZuluGIS 2021

Добро пожаловать

Благодарим за использование наших продуктов!

Данное руководство составлено для ознакомления пользователя со всеми функциями и настройками геоинформационной системы ZuluGIS.

Пользуясь данным руководством, вы можете самостоятельно освоить систему. В конце многих разделов приведены практические примеры, которые полезно проработать для усвоения материала. Помимо этого, на нашем канале и сайте можно ознакомиться с видеоуроками, которые также будут полезны для быстрого и успешного освоения системы.

Данная версия справочной системы от 24-11-2025


Введение

  • «Назначение документа»

  • «Получение технической поддержки»

  • «Общие сведения о системе»

  • «Список поддерживаемых ZuluGIS форматов»

Пользуясь ZuluGIS, необходимо учитывать, что система постоянно дорабатывается и совершенствуется. На нашем сайте регулярно публикуются новые версии, в которых исправляются ошибки и добавляются новые функции и возможности. Наша компания стремится поддерживать постоянную связь с пользователями, прислушиваясь к их пожеланиям и реализуя их по мере возможности.

Из-за постоянного развития ZuluGIS, данное описание может быть неполным или содержать некоторые расхождения с тем, что пользователь видит на экране.

Последняя и актуальная версия справочной системы доступна на сайте компании Политерм. Вы можете найти её по следующей ссылке: https://www.politerm.com/zuludoc/index.html.


Назначение документа

Данное руководство составлено для ознакомления пользователя со всеми функциями и настройками геоинформационной системы ZuluGIS. Кроме того, в нем рассмотрены ключевые аспекты взаимодействия с ZuluServer, так как ZuluGIS выступает в роли клиента ZuluServer в процессе совместной работы с геоданными. В такой ситуации данные хранятся на сервере, а пользователи работают с ними, используя ZuluGIS.

Используя данное руководство, можно самостоятельно освоить систему, в конце многих разделов приведены практические примеры, которые полезно проработать для усвоения материала. Помимо этого, на нашем канале можно ознакомится с видеоуроками, которые будут полезны для быстрого и успешного освоения системы. Видеоуроки также доступны на нашем сайте.

Руководство предназначено для специалиста, имеющего знания и основные навыки работы с ЭВМ.

В основной части документа приведены сведения о назначении, возможностях, условии применения и организации данных системы. Для удобства работы руководство поделено на разделы и подразделы. В разделах, которые описывают возможности системы, приведены практические примеры, позволяющие лучше понять и освоить представленную информацию. Для закрепления материала рекомендуется проделать представленные примеры самостоятельно.


Получение технической поддержки

Если после изучения данного руководства у вас все равно возникли вопросы по работе системы, её использовании или настройке, то в этом случае рекомендуется обратиться в нашу техническую поддержку.

Также получить дополнительные знания по работе с системой возможно, ознакомившись с обучающими и демонстрационными ресурсами на нашем сайте.

Для пользователей, желающих получить более глубокие знания, проводится обучение по работе с системой.


Техническая поддержка

Для получения технической поддержки можно связаться с нашими сотрудниками. Контакты технической поддержки представлены на официальном сайте в разделе Контакты: https://www.politerm.com/contacts/.

Техническая поддержка не является обучением и осуществляется только в виде консультации по вопросам функционала программного обеспечения или помощи в решении проблем, возникших при работе с системой.

[Предупреждение] Предупреждение

Техническая поддержка доступна с понедельника по пятницу, 9:00 - 17:30 по Московскому времени.

В том случае, когда возникшие вопросы связаны с некорректной работой ПО, перед обращением обязательно следует скачать и установить обновление системы. Затем необходимо проверить корректность работы обновленной программы, если проблема осталась, то тогда следует связаться с поддержкой.

Пожалуйста, при обращении будьте готовы сообщить сотрудникам поддержки:

  1. Название организации.

  2. Версию и тип используемого программного обеспечения.

  3. Наименование и версию операционной системы.

  4. Краткое описание сути проблемы. Обратите внимание на такую информацию, как сообщения об ошибках, и на ситуации, при которых возникают данные ошибки.

[Примечание] Примечание

Получить ответы на возникающие вопросы также возможно на официальном форуме компании Политерм: https://www.politerm.com/forums/.


Обучающие и демонстрационные ресурсы

Для самостоятельного изучения на сайте представлены различные обучающие ресурсы, примеры и статьи об опыте использования:

  • Видеоуроки по работе с системой: на каналах RUTube https://rutube.ru/channel/23486420/, VK Видео https://vkvideo.ru/@politerm, YouTube https://www.youtube.com/user/ZuluGIS и на нашем сайте https://www.politerm.com/videos/.

  • Статьи и советы: https://www.politerm.com/articles/, https://vk.com/politerm.

  • Различные примеры (макросов, sql запросов и прочее): https://www.politerm.com/samples/.


Обучение сотрудников

Приглашаем специалистов, имеющих профильное образование (в зависимости от выбранного курса), пройти обучение по работе с программными продуктами. Курсы будут полезны как для начинающих пользователей, так и для специалистов, желающих повысить свои навыки владения нашими программами. Занятия проводятся квалифицированными преподавателями по методикам и материалам компании Политерм.

Целью курсов является получение минимально необходимых знаний и базовых навыков работы в наших программных продуктах. Сокращается время на изучение системы пользователями и её внедрения в организации. На лекциях слушатели получают информацию о работе с программными продуктами, а при выполнении практических заданий, подготовленных на основе реальных прикладных задач, отрабатывают навыки работы в программе. В дальнейшем полученные знания позволяют пользователям общаться на одном языке с консультантами ООО «Политерм» и другими ГИС специалистами.

Очные занятия проходят в офисе ООО «Политерм», дистанционные курсы проходят в режиме онлайн.

Более подробно об обучении вы можете узнать на странице Обучение.


Общие сведения о системе

  • «Основные характеристики и особенности системы»

  • «Возможности системы»

  • «Взаимодействие с другими программами»

  • «Сведения о технических и программных средствах, обеспечивающих выполнение системы»

  • «Список поддерживаемых ZuluGIS форматов»

Обозначение и наименование системы

Наименование системы – Геоинформационная система ZuluGIS 2021.

Обозначение – «ZuluGIS 2021».

Языки программирования, на которых написана система

Геоинформационная система ZuluGIS 2021 написана на языке программирования Visual C++™.

Назначение системы

Геоинформационная система ZuluGIS предназначена для редактирования и разработки ГИС приложений, требующих визуализации пространственных данных в векторном и растровом виде, анализа их топологии и их связи с семантическими базами данных. ZuluGIS может являться клиентом для ZuluServer.

С помощью ZuluGIS можно создавать всевозможные карты, планы и схемы, включая планы и схемы инженерных сетей с поддержкой их топологии, работать с растрами, тайлами, использовать и получать данные из различных источников BDE, ODBC, SQL Server LocalDB, PostgreSQL и др. Карты могут быть разработаны как в локальной системе декартовых координат, так и в различных географических системах координат.

Ограничения области применения системы

Ограничений в области применения системы нет.


Основные характеристики и особенности системы

ZuluGIS имеет многодокументный интерфейс, схожий с продуктами семейства Microsoft Office, что позволяет пользователю легко освоиться с работой в системе.

Одной из основных особенностей ZuluGIS является высокая скорость работы. Система сочетает современный уровень возможностей с быстротой их исполнения.

Помимо этого, ZuluGIS имеет возможность организовывать так называемые слои в памяти (tracking layers). Это слои, все объекты которых созданы в оперативной памяти, не требуют дискового пространства, они отображаются и изменяются чрезвычайно быстро, что позволяет с их использованием делать анимированные карты – например, отображать движущиеся объекты или данные телеметрии.

Наряду с обычным для ГИС разделением объектов на контуры, ломаные, поликонтуры, полиломаные, ZuluGIS поддерживает линейно-узловую топологию, что позволяет вместе с прочими пространственными данными (улицы, дома, реки, районы, озера и проч.) моделировать и инженерные сети. Система позволяет создавать классифицируемые объекты, имеющие несколько режимов (состояний), каждый из которых имеет свой стиль отображения. Ввод сетей производится с автоматическим кодированием топологии. Нарисованная в системе ZuluGIS сеть сразу готова для топологического анализа, что позволяет исключить длительный и утомительный этап занесения информации о связях между объектами.

ZuluGIS имеет открытую архитектуру, система спланирована для расширения как программами ООО «Политерм», так и программами пользователей. Архитектура plug-ins (плагинов – дополнительных встраиваемых модулей) позволяет использовать ZuluGIS как ГИС-платформу (или ГИС-среду) для работы других приложений, как это сделано нами же в тепловых и водопроводных расчетах.

Объектная модель ZuluGIS открыта для расширения приложениями пользователя через механизм COM. ZuluGIS предоставляет возможность использовать и расширять свою функциональность двумя способами – через написание модулей расширения системы (plug-ins) и через использование ActiveX компонентов в своих готовых приложениях.

Модули расширения создаются в виде ActiveX DLL с использованием любой среды разработки, позволяющей их создавать (Visual C++, Visual Basic, Delphi, C++Builder и т.д.).


Возможности системы

Система позволяет:

  • Создавать всевозможные карты местности в различных географических системах координат и картографических проекциях, отображать векторные графические данные со сглаживанием и без.

  • Работать с растровыми объектами, производить привязку растров на местности, группировку растров, перепроецирование растровых объектов, разбиение растровых объектов, производить трансформирование растровых объектов, осуществлять зональную статистику по растровым слоям.

  • Получать пространственные данные с серверов, поддерживающих спецификации WMS (Web Map Service), WMTS (Web Map Tile Service). Данные WMS и WMTS

  • Использовать картографические данные с Tile-серверов в качестве слоев карт и нарезать растровые слои на плитки для последующего использования на Tile-сервере.

  • Открывать и использовать файлы в формате GPS eXchange Format (GPX).

  • Читать географическую привязку растровых объектов в формате World File, если World File файл дополнительно снабжен файлом с тем же именем и расширением aux.xml.

  • Читать географическую привязку растровых объектов в формате GeoTIFF.

  • Векторизировать растровые изображения в векторные слои:

    • векторные слои в системе ZuluGIS хранятся во внутреннем бинарном формате, обеспечивающем высокую скорость работы с ними;

    • при векторизации используются как примитивные объекты (символьные, текстовые, линейные, площадные), так и типовые объекты, описываемые самостоятельно в структуре слоя.

  • Производить групповое изменение данных, масштабирование, поворот, трансформирование слоев методом «резиновый лист», аффинное преобразование, полиномиальное второй степени, выполнение оверлейных операций, построение буферных зон, вырезание данных по области, построение зоны близости, сетки по слою и т.п.

  • Работать с семантическими данными, подключаемыми к слою из внешних источников как коммерческих, так и бесплатных клиент-серверных СУБД: Microsoft SQL Server, Oracle, Sybase, PostgreSQL, MySQL, Линтер, и т.д., файл-серверных СУБД: SQLite, других источников, поддерживающих ODBC или ADO соединения.

  • Производить миграцию табличных данных из одного источника в другой.

  • Выполнять анализ данных с отображением результатов на карте (поиск определенной информации, нахождение суммы, максимального, минимального значения, и т.д.). Запросы выполняются как с помощью внутреннего конструктора запросов, так и с использованием языка запросов SQL. В пространственных запросах могут одновременно участвовать графические и семантические данные, относящиеся к разным слоям.

  • Выполнять пространственные запросы по объектам карты в соответствии со спецификациями OGC.

  • Создавать модель рельефа местности как в TIN, так и в SRTM формате. Строить на ее основе изолинии, зоны затопления, профили и растры рельефа, рассчитывать площади и объемы.

  • Импортировать данные в семантическую базу из таблиц Microsoft Excel™.

  • Экспортировать данные из семантической базы или результаты запроса в электронную таблицу Microsoft Excel™ или в HTML файл.

  • Создавать и использовать библиотеку графических элементов систем тепло-, водо-, паро- и газоснабжения и канализации. Для элементов предусмотрено использование нескольких графических изображений, отражающих режимы их работы.

  • Создавать расчетные схемы инженерных коммуникаций с автоматическим формированием топологии сети и соответствующих баз данных.

  • Изменять топологию сетей и режимы работы ее элементов.

  • Решать топологические задачи (изменение состояния объектов [переключения], поиск отключающих и изолирующих устройств, поиск кратчайших путей, поиск связанных объектов, поиск колец, поиск участков без узлов).

  • Решать транспортные задачи с учетом топологии.

  • Программно или по семантическим данным создавать тематические раскраски, с помощью которых меняется стиль отображения объектов.

  • Выводить для всех объектов слоя надписи или бирки, текст надписи может как браться из семантической базы данных, так и переопределяться программно.

  • Для быстрого перемещения в нужное место карты устанавливать закладки (закладку на точку на местности с определенным масштабом отображения и закладку на определенный объект слоя [удобно для объектов, движущихся по карте]).

  • С помощью проектов создавать многоуровневые карты, раскрывая с помощью дополнительных уровней структуру объектов, схематично изображенных на основной карте.

  • Создавать макеты печати.

  • Работать со слоем трекинга.

  • Импортировать данные из форматов MapInfo (MIF/MID), AutoCAD (DXF), ArcView (SHP), Metafile (WMF), GPX, треков из OziExplorer PLT, KML, KMZ, из таблицы (*.db), QGIS, GeoJSON, XML-документов Росреестра, текста с разделителями, LAS, моделей рельефа из LandXML TIN, Esri TIN, Intermediate TIN Format (ITF), импорт описателей из файлов с привязкой *.tab (MapInfo), *.map (OziExplorer) и данные растровых объектов в формат ESRI World File, импорт GeoTIFF в растровый слой ZuluGIS.

  • Экспортировать графические данные в форматы MapInfo (MIF/MID), OziExplorer, ESRI World File, AutoCAD 12 (DXF), ArcView (SHP), Google (KML), Windows Bitmap (BMP), в тайлы SQLite, MBTiles, рельеф в форматы LandXML TIN, Intermediate TIN Format (ITF), семантические данные в формат Microsoft Excel или электронную таблицу ODS.

  • Экспортировать проекцию слоя в строку WKT, proj4, Mapinfo.

  • Создавать макросы на языках VB Script или Java Script.

  • Осуществлять программный доступ к данным через объектную модель для написания собственных конвертеров.

  • Создавать собственные приложения, работающие под управлением ZuluGIS.

  • Подготавливать данные для веб-служб ZuluServer.

  • Система ZuluGIS может быть использована в виде полнофункционального рабочего места – в однопользовательском режиме, или в качестве клиента для ZuluServer, сохраняя функционал настольного приложения, в многопользовательском режиме.


Взаимодействие с другими программами

ZuluGIS позволяет импортировать данные из таких программ, как MapInfo, AutoCAD, ArcView и т.д. В результате импорта будут получены векторные слои с готовыми объектами, при этом все характеристики, такие как масштаб, цвет и т.д. будут сохранены. Если к объектам в обменном формате была прикреплена база данных, то она также импортируется в ZuluGIS. Полный список поддерживаемых ZuluGIS форматов можно посмотреть в соответствующем разделе: «Список поддерживаемых ZuluGIS форматов».

Помимо импорта ZuluGIS предоставляет возможность экспорта графических данных в такие программы, как MapInfo, AutoCAD, ArcView, Google Earth, в виде картинки с координатами в формате BMP. Также возможно «нарезание» карты на тайловые плитки и сохранение ее в формате SQLite или MBTiles.

Экспорт семантических данных возможен в электронную таблицу Microsoft Excel™ или файл HTML.

В системе ZuluGIS также могут использоваться описатели растровых объектов в форматах MapInfo и OziExplorer без преобразования.

Подробнее об операциях импорта и экспорта смотрите соответствующий раздел: Импорт и экспорт данных.


Сведения о технических и программных средствах, обеспечивающих выполнение системы

Далее представлены минимальные требования к аппаратной части компьютеров для работы с системой. Важно отметить, что требования могут сильно различаться в зависимости от решаемых задач. При больших объемах данных, если используется более производительный процессор, больше оперативной памяти, более производительная видеокарта и произведены необходимые настройки программного обеспечения, отдача от нашего программного обеспечения будет больше.

Поддерживаемые операционные системы:

  • Windows 11, Windows 10, Windows 7, Windows 8, Windows 8.1, Windows Vista Service Pack 2, Windows XP Service Pack 3

  • Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012, Windows Server 2012R2, Windows Server 2008 Service Pack 2, Windows Server 2008R2 SP1

  • РЕД ОС 7.3*, РЕД ОС 8*, Альт Рабочая станция 10*, Astra Linux Special Edition 1.7*

* В операционных системах семейства Linux программное обеспечение устанавливается и запускается с применением WINE или WINE@Etersoft.

Требования к оборудованию:

  • Процессор: 1.6 ГГц и выше.

  • Память: 2 ГБ и выше.

  • Диск: 1,5 Гб свободного места на жестком диске.

  • Видеоадаптер: для ОС Windows с поддержкой разрешения 1024 x 768 и полноцветного режима True Color (рекомендуется видеокарта, совместимая с DirectX 9 и выше).

Данные требования не включают в себя требования к остальному ПО, предполагаемому к использованию на том же компьютере.


Список поддерживаемых ZuluGIS форматов

Список поддерживаемых ZuluGIS форматов весьма обширен, некоторые из них можно открыть напрямую, загрузив сразу в текущую карту, а часть через импорт данных.

Форматы данных, которые возможно сразу загрузить в карту:

  • *.b00 – векторный слой ZuluGIS.

  • *.zrs – описатель растрового слоя.

  • *.zrg – растровая группа.

  • *.zl – файл описатель данных, создается в результате подготовки локальных данных ZuluGIS для использования их сервером ZuluServer или копирования слоя на сервер.

  • *.zww – WMS, WMTS слои, слои Tile-сервера, SRTM.

  • *.ztr – рельеф TIN модели.

  • *.zpr – проекты ZuluGIS.

  • *.plt – треки формата *.plt (OziExplorer). В ZuluGIS могут быть как непосредственно загружены в карту для просмотра, так и импортированы в векторный слой для просмотра и редактирования данных.

  • *.xml – межевые планы, могут быть загружены в карту ZuluGIS для просмотра.

  • *.bmp, *.jpg, *.jpeg, *.tif, *.tiff, *.gif, *.png, *.pcx, *.svg, *.heic – файлы изображений. После добавления изображения в карту для дальнейшей работы с ним необходимо сохранить файл описателя, в котором будут указаны координаты точек привязки файла. В результате проделанных действий будет получен описатель растрового слоя с расширением *.zrs.

  • *.tab – описатель растров программы MapInfo, поддерживается открытие и размещение на карте растров с такими описателями, с учетом заданной в описателе системы координат и привязки растра, и конвертирование файлов привязок в формат описателя растра ZuluGIS.

  • *.map – описатель растров программы OziExplorer, поддерживается открытие и размещение на карте растров с такими описателями, с учетом заданной в описателе системы координат и привязки растра, и конвертирование файлов привязок в формат описателя растра ZuluGIS.

  • *.bpw, *.bmpw, *.tfw, *.tifw, *.jgw, *.jpgw, *.gfw, *.gifw, *.pgw, *.pngw – растровые объекты в формате World File.

  • *.gpx – текстовый формат хранения и обмена данными GPS. В ZuluGIS может быть как непосредственно загружен в карту для просмотра, так и импортирован в векторный слой для просмотра и редактирования данных.

  • *.sqlitedb – тайлы в формате sqlitedb.

  • *.mbtiles – тайлы в формате MapBox MB Tiles.

Форматы данных, которые возможно загрузить в карту через импорт данных:

  • *.dxf – чертежи AutoCAD, для дальнейшей работы должны быть импортированы в ZuluGIS.

  • *.mif – файлы обменного формата MapInfo, для дальнейшей работы должны быть импортированы в ZuluGIS.

  • *.shp – Shape файл, векторный формат географических файлов. Разрабатывается и поддерживается компанией Esri. Для дальнейшей работы должен быть импортирован в ZuluGIS.

  • *.wmf – универсальный формат векторных графических файлов (Metafile). Для дальнейшей работы должен быть импортирован в ZuluGIS.

  • *.gpx – текстовый формат хранения и обмена данными GPS , основанный на XML. Для дальнейшей работы должен быть импортирован в ZuluGIS.

  • *.plt – треки формата *.plt. Для дальнейшей работы должны быть импортированы в ZuluGIS.

  • *.kml, *.kmz – формат представления трёхмерных геопространственных данных в программе Google Планета Земля (Google Earth). Для дальнейшей работы должен быть импортирован в ZuluGIS.

  • *.db – табличные данные, имеющие координатную привязку в слой ZuluGIS, с расставленными по координатам таблицы символьными объектами. Для дальнейшей работы должны быть импортированы в ZuluGIS.

  • *.qgc – проекты, разработанные в свободно распространяемой ГИС QGIS (Quantum GIS). Для дальнейшей работы должны быть импортированы в ZuluGIS.

  • *.geojson – GeoJSON, открытый формат, предназначенный для хранения географических структур данных, основан на JSON. Для дальнейшей работы данные должны быть импортированы в ZuluGIS.

  • *.gpkg – GeoPackage, это формат данных для хранения географических структур данных, может быть импортирован ZuluGIS.

  • *.csv, *.txt – текстовый файл с разделителями, для дальнейшей работы может быть импортирован в ZuluGIS.

  • *.xml – модель рельефа формата LandXML TIN, может быть импортирована, в результате импорта будет получен слой рельефа TIN модели. В импортируемом файле должен быть корневой индекс LandXML и TIN раздел со списком точек X, Y, Z.

  • *.xml – XML-документы Росреестра, могут быть импортированы ряд документов, соответствующих определенным схемам, в результате импорта будет получен векторный слой с базами данных.

  • *.adf – модель рельефа из формата Esri TIN, может быть импортирована, в результате импорта будет получен слой рельефа TIN модели, в котором по каждой точке можно получить значение высоты. Для импорта обязательно нужен набор файлов с расширением *.adf, содержащих массив x, у точек (tnxy.adf) и массив высот точек (tnz.adf).

  • *.itf – модель рельефа из формата Intermediate TIN Format (ITF), может быть импортирована. В результате будет получен слой рельефа TIN модели, в котором по каждой точке можно получить значение высоты.

  • *.las – архивированые данные облака лидарных (лазерных) точек. Для дальнейшей работы данные должны быть импортированы в ZuluGIS.

  • вы можете импортировать треки с веб-сервисов системы мониторинга, поддерживаются следующие веб-сервисы мониторинга:

    • Wialon

    • Omnicomm

    • Fort Monitor


Основные понятия и определения

  • «Представление информации»

  • «Слои»

  • «Объекты»

  • «Семантическая информация»

  • «Запросы пространственных данных»

  • «Карты»

  • «Проекты»

  • «Моделирование сетей»

Геоинформационная система (ГИС) – информационная система, обеспечивающая сбор, хранение, обработку, доступ, отображение и распространение пространственно-координированных данных.

ГИС включает в себя информацию о пространственных объектах в виде их цифровых представлений (векторных и растровых). Она предлагает набор функциональных возможностей, которые позволяют выполнять операции геоинформационных технологий, поддерживаемые аппаратным, программным и информационным обеспечением.

ZuluGIS — это система, которая может работать как в однопользовательском, так и в многопользовательском режиме. Во втором варианте с использованием ZuluServer для обеспечения доступа к данным. Важно отметить, что при использовании многопользовательской версии данные обязательно должны храниться на сервере.


Представление информации

ZuluGIS хранит два типа информации – графическую и семантическую. Структурная схема представления информации изображена на рисунке ниже.

Структурная схема представления информации в системе ZuluGIS

Рисунок 1. Структурная схема представления информации в системе ZuluGIS

Графические данные – это набор графических слоев, они всегда хранятся во внутреннем формате системы. Графический слой представляет собой совокупность пространственных объектов, относящихся к одной теме в пределах некоторой территории и в системе координат, общих для набора слоев.

Семантические данные представляют собой описание по объектам графической базы. Они могут храниться как в коммерческих, так и бесплатных клиент-серверных СУБД: Microsoft SQL Server, Oracle, Sybase, PostgreSQL, MySQL, Линтер, и т.д., файл-серверных СУБД: SQLite и других источниках, поддерживающие ODBC или ADO соединения. В поставку ZuluGIS входит бесплатная СУБД Microsoft SQL Server Express LocalDB. Информация в семантическую базу данных заносится пользователем. Семантическая база данных представляет собой набор таблиц, информационно связанных друг с другом. Одна из таблиц должна обязательно содержать поле связи с картой (по умолчанию это поле называется SYS), то есть поле, в которое заносятся ключевые значения (ID) графических объектов.

Например, для слоя «Здания» система хранит в графической базе данных информацию по каждому объекту (координаты каждого контура, цвет линии для каждого контура, цвет и стиль заливки, каждый объект слоя также имеет уникальный ключ – ID).

Для описания объектов графической базы данных (например, домов) создается семантическая база данных, в которую заносится информация по каждому дому: адрес, номер дома, тип дома и прочее. Для связи семантической и графической баз данных одно из полей семантической базы данных содержит ключ объекта графической базы, к которому относится одна или несколько строк семантической базы. При этом графическая и семантическая базы данных могут находиться в разных каталогах, на разных дисках и даже на разных компьютерах (сервере и локальном компьютере).

Пример взаимодействия семантической и графической баз данных

Рисунок 2. Пример взаимодействия семантической и графической баз данных


Слои

Слой – совокупность пространственных объектов, относящихся к одной теме (классу объектов) в пределах некоторой территории и в системе координат, общих для набора слоев. Послойное или многослойное представление является наиболее распространенным способом организации пространственных данных в послойно-организованных ГИС.

Слой является основной информационной единицей в системе ZuluGIS. Слои используются для хранения графических объектов. Каждый объект в слое имеет уникальный идентификатор, который также называют ID или ключ объекта.

Идентификатор (ID) – уникальный (в пределах слоя) номер, приписываемый пространственному объекту слоя, присваиваться автоматически, служит для связи графической и семантической части пространственных данных.

По способу хранения графической информации существуют следующие слои:

  • «Векторный слой»

  • «Растровый слой»

  • «Слои рельефа»

  • «Слои с web серверов»

  • «Слой Tile-сервера»

  • Слой трекинга


Векторный слой

Векторный слой - это слой, который содержит только векторные объекты.

Объекты в таких слоях получают или путем самостоятельного введения или в результате импорта данных. Как и другие слои, векторные обычно содержат объекты одной тематики. Слои инженерных сетей относятся к векторным слоям.

Прежде чем создавать слой, необходимо определиться с системой координат. В ZuluGIS слои могут храниться как в локальной системе координат (план-схема), так и в различных географических системах координат. Если проекция слоя выбрана правильно, то он будет корректно отображаться на местности и иметь реалистичные размеры объектов.

В системе доступно несколько вариантов создания новых векторных слоев: создание нового векторного слоя (с базой данных или без), слоя инженерных сетей (с готовой структурой и базами данных) и слоя по образцу уже существующего.

Векторный слой имеет два наименования:

  • Имя файла – это имя семейства файлов слоя. Данное имя отображается при просмотре файлов средствами Windows.

  • Название слоя - имя слоя в Zulu, называется так же пользовательским названием. Может состоять максимум из 40 символов. Отображается непосредственно при работе в ZuluGIS.

В текущей версии названия могут совпадать.

Векторные слои могут использоваться как в однопользовательской (ZuluGIS ) так и в многопользовательской (ZuluServer) версии. В первом варианте слои хранятся на компьютере, с которого осуществляется работа, во втором слои располагаются на сервере, что обеспечивает их доступность для всех пользователей.

[Примечание] Примечание

Как узнать где расположены слои можно здесь.

В векторном слое графические объекты независимо от их графического типа делятся на две разновидности: простые графические объекты (примитивы) и типовые (классифицированные) графические объекты.

Простые графические объекты содержат все атрибуты отображения внутри себя, они задаются непосредственно перед нанесением объекта. Типовые графические объекты содержат лишь ссылку на типовую структуру, которая и определяет графический тип, атрибуты отображения и текущее состояние объекта (такие объекты обязательно используются в инженерных сетях). Типовые объекты настраиваются структуре.

Тип объекта обязательно имеет от одного до нескольких режимов, которые имеют пользовательское название и задают различные способы отображения типового объекта.

Простые графические объекты могут быть связаны с одной семантической базой данных, общей для всего слоя. Каждый же типовой графический объект может быть связан со своей семантической базой, то есть сколько типов объектов, столько может быть и баз данных.

Пример карты с загруженными векторными слоями

Рисунок 3. Пример карты с загруженными векторными слоями

По мимо разработки типовых объектов в структуре описываются так же следующие важные настройки:

  • Векторный слой может иметь собственную символов библиотеки символов для отображения различных объектов. Символ может представлять собой сочетание векторных элементов и растровых изображений. Каждая группа имеет точку привязки и азимут относительно этой точки. Кроме того, каждый символ может иметь своё название.

  • При создании векторного слоя формируется библиотека стилей заливок для площадных объектов и стилей для линейных объектов. В процессе работы стили могут быть изменены и дополнены.

  • Могут быть настроены различные правила редактора на добавление, удаление объектов или смену типа или режима.

  • Настроены правила быстрого поиска объектов.

  • Разработаны правила для веб-служб ZuluServerstruct_rules_web.

Пример структуры векторного слоя

Рисунок 4. Пример структуры векторного слоя

Графическая база данных векторного слоя представляет собой семейство двоичных файлов, находящихся в одном каталоге и имеющих одно имя и разные расширения:

Расширение | Описание файла
b00 | заголовок графической базы
b01 | метрическая информация
b02 | структура типов и режимов слоя
b03, b04 | библиотека символов
Zsx | пространственный индекс
Zx | индексный файл для связи с семантикой
b05 | информация о подключенных к слою семантических базах данных (может отсутствовать)

Для каждого векторного графического слоя обязательно должны существовать файлы с расширением B00 и B01, содержащие метрическую информацию об объектах слоя.

Основные операции со слоями, содержащими векторные объекты, описаны в разделе Операции со слоями.

[Примечание] Примечание

Разработчики приложений могут получить доступ к параметрам слоя через объект Layer.


Растровый слой

Растровым слоем системы ZuluGIS может быть отдельный растровый объект или группа растровых объектов. Растры чаще всего используются либо как подложка для отрисовки данных, либо в качестве подложки для анализа термограмм в ZuluThermo.

[Примечание] Примечание

Имеется возможность импортировать растровые данные формата MapInfo, OziExplorer и ESRI World File.

Пример растрового слоя

Рисунок 5. Пример растрового слоя

Поддерживаемые форматы растров: *.bmp, *.jpg, *.jpeg, *.tif, *.tiff, *.gif, *.png, *.pcx, *.svg, *.heic.

Растровый объект задается описателем растрового слоя который определяет файл изображения и физические координаты на местности, соответствующие изображению. Описатели растровых объектов хранятся в файлах с расширением ZRS. Эти файлы имеют простой текстовый формат.

Пример 1. Фрагмент описателя растрового объекта

Zulu GIS Data
Version: 8.0
Type: raster
File: 50GIII.BMP
................

Растровая группа – это объединение растровых объектов, рассматриваемых системой как один объект. Если необходимо постоянно работать с двадцатью растровыми объектами одновременно, то можно загружать двадцать растровых слоев по одному растровому объекту в каждом. Однако для удобства эти растровые объекты можно объединить в группу растровых объектов. Тогда система будет воспринимать эти двадцать растров как один слой. Пять растровых групп по двадцать растров в каждой в свою очередь можно объединить в одну и т.д. Информация о растровых группах хранится в файлах с расширением ZRG. Эти файлы имеют простой текстовый формат: на каждой строке файла записывается имя файла растрового объекта или имя файла другой растровой группы. Пример файла описания растрового объекта приведен ниже:

Пример 2. Файл описания растровой группы

D:\PLAN\2430-00p.ZRS
D:\PLAN\2430-01p.ZRS
D:\PLAN\2430-02p.ZRS
D:\PLAN\2430-05p.ZRS
D:\PLAN\2430-06p.ZRS

В этом примере группа содержит четыре растровых объекта масштаба 1:2000 с трубопроводами, прозрачно накладывающихся на растровую группу, содержащую план местности той же территории. Последовательность отображения растров при выводе на карту соответствует их последовательности в списке растровой группы.

Растровая группа может содержать произвольное число растровых объектов или вложенных растровых групп.

Число растров в слое ограничено лишь дисковым пространством (ZuluGIS справляется с полем из нескольких тысяч растров).

Рисунок 6. Растровая группа


Слои рельефа

Модели рельефа, построенные в системе ZuluGIS, хранятся в виде особых слоев и бывают двух типов:

  1. TIN – модель, представляющая собой триангуляционную сетку, в которой известны высоты вершин всех треугольников.

  2. SRTM (Shuttle radar topographic mission) – «грубая» модель рельефа с использованием файлов высотных отметок, полученных из интернета.

Слой рельефа может быть импортирован из форматов LandXML TIN, Esri TIN, Intermediate TIN Format (ITF).

Подробнее ознакомиться с описанием слоев рельефа и с работой с ними можно в разделе Слои рельефа.


Слои с web серверов

В системе помимо растровых и векторных слоев имеется возможность использовать слои с серверов, поддерживающих различные спецификации.

WMS (Web Map Service) Данные WMS и WMTS.

WMTS (Web Map Tile Service) «WMTS слой»


Слой Tile-сервера

Слой Tile-сервера представляет собой картографическую информацию в виде растровых изображений, нарезанных на небольшие плитки или тайлы (tile). Из этих плиток формируется изображение всей территории в нескольких фиксированных масштабах. Все плитки одного масштаба образуют уровень. Тайловые слои чаще всего используются в виде подложки так как информацию на них нельзя редактировать (создавать новые и изменять существующие объекты). Имеется ряд слоев Tile-серверов, которые уже встроены в меню системы, как их добавить в карту можно узнать в разделе «Добавление «базового» слоя «подложки» с Tile-сервера».

Подробнее о работе со слоями Tile-сервера можно узнать в разделе Слой Tile-сервера.


Объекты

Основные виды объектов использующихся в ZuluGIS:

  • «Растровые объекты»;

  • «Векторные объекты».


Растровые объекты

Растровым объектом является растровый графический файл в одном из форматов *.bmp, *.jpg, *.jpeg, *.tif, *.tiff, *.gif, *.png, *.pcx, *.svg, *.heic, который привязывается к территории заданием координат его углов на местности. Растры могут быть цветными или монохромными. Монохромные растры обладают прозрачностью, что позволяет накладывать растры друг на друга. Для монохромных растров может задаваться цвет пикселей. К растровым объектам семантическая информация не привязывается.

Узнать подробнее о растровых объектам можно в соответствующем разделе: Растровый слой.


Векторные объекты

Векторные объекты, в отличие от растровых, описываются координатами. Все векторные объекты в первую очередь делятся на:

  • типовые – это объекты, которые обязательно должны быть описаны в структуре слоя в дереве типов и режимов. При описании объекта в структуре с помощью типа определяется его графический тип, указывается ID (индивидуальный номер) типа, при желании подключается база данных к типу. К каждому типу объекта подключается своя база данных. Для того, чтобы тип мог быть нанесен к нему обязательно должен быть создан как минимум один режим. С помощью режима определяется стиль объекта, размер, и еще ряд дополнительных настроек. Подробней о типовых объектах можно узнать в разделе «Типы и режимы».

    Таким образом, характеристики объекта уже заранее прописаны в структуре и в дальнейшем при нанесении объектов на карту они просто выбираются из меню типовых объектов.

  • примитивы (простые) – это графические объекты, которые содержат все атрибуты отображения внутри себя. Перед нанесением таких объектов понадобится задать характеристики их внешнего вида, такие как цвет, заливка, толщина линии или для символьных объектов создать символ для отображения.

Узнать графический тип объектов вы можете следующим образом:

  1. Откройте окно Объект.

  2. Нажмите на панели инструментов кнопку Выделить [image] .

  3. Нажмите и удерживайте на клавиатуре клавиши Shift и Ctrl.

  4. Сделайте щелчок левой кнопкой мыши по объекту. Слой с объектом станет активным, объект замигает и в окне отразятся данные.

    Рисунок 7. Типовой Участок

    Рисунок 8. Простой полигон

Помимо вышеперечисленного деления объекты можно еще разделить по графическому типу на:

  • «Линейные объекты (полилинии, поли-полилинии)»;

  • «Площадные объекты (полигоны, поли-полигоны)»;

  • «Символьные (узловые) объекты»;

  • «Текстовые объекты».

Группы графических объектов объединяются в слои графической информации. Информация о слое образует независимую графическую базу данных. Координаты точек, входящих в описание объектов слоя, хранятся в прямоугольной системе координат с точностью до 1 сантиметра.

Каждому элементу, образующему объект слоя, соответствует уникальный номер (ключ или ID), позволяющий однозначно идентифицировать данный элемент. Посредством ключей осуществляется привязка к графическим объектам семантической информации.

[Внимание] Внимание

Уникальная нумерация каждого объекта ведется внутри слоя и не зависит от других слоев.

Рисунок 9. Примеры объектов


Линейные объекты (полилинии, поли-полилинии)

Данный объект представляет собой цепочку точек, соединенных сегментами. Линейные объекты могут быть полилиниями и поли-полилиниями.

Полилиния - это ломаная, образованная последовательностью не менее 2-х точек. Поли-полилиния - это составная ломаная, которая может состоять из одного или нескольких сегментов. В этом случае объекты имеют имеет общий ключ (ID) и одинаковые параметры отображения. Примером такого линейного объекта может служить улица, прерывающаяся круглой площадью и продолжающаяся после площади дальше. Получить поли-полилинию можно в результате векторных оверлейных операций объединения объектов. Разъединить объекты можно обратной оверлейной операций - разъединения объектов или операциями разделения линейных объектов в узле и отсоединения сегмента.

Ниже на рисунке показано окно Свойства при выделении в режиме Узлы ( [image] ) поли-полилинии. Первый столбец отображает точки полилиний. 1-1, 1-2 - принадлежат первой полилинии в составе поли-полилинии, 2-1, 2-2, соответственно второй.

Рисунок 10. Стили ломаной

Любая ломаная может отображаться определенным стилем линий заданного цвета, толщины и типа. Ломаная может иметь свободные концы или быть замкнутой.

Рисунок 11. Стили ломаной

Варианты ломаной линии

Рисунок 12. Варианты ломаной линии

Несмотря на то, что ломаная может быть изображена замкнутой, она остается при этом ломаной. Соответственно, рассчитать площадь такого объекта, в отличие от полигона, не получится.


Площадные объекты (полигоны, поли-полигоны)

Эти объекты представляют собой замкнутые контуры, образованные цепочкой точек (узлов или вершин), соединенных отрезками (ребрами), где последний узел соединен с первым. Кроме того, каждый объект содержит точку внутри контура (центроид).

Такими объектами удобно описывать контуры зданий, площадные участки территории, слои различного районирования и зонирования и прочие.

Каждый такой объект отображается в виде замкнутой ломаной заданного цвета, толщины и стиля. По желанию пользователя внутренняя часть контура может быть залита заданным цветом и стилем.

Рисунок 13.

Площадные объекты могут быть как полигонами, так и поли-полигонами. Поли-полигоны это составные контурные объекты, которые состоят из нескольких сегментов. Группа контуров имеет один общий ключ (ID) и одинаковые параметры отображения. Получить поли-полигон можно в результате векторных оверлейных операций объединения объектов. Разъединить объекты можно обратной оверлейной операций - разъединения объектов или путем отсоединения сегмента.

Ниже на рисунке показано окно Свойства при выделении в режиме Узлы ( [image] ) поли-полигона. Первый столбец отображает точки контура. 1-1, 1-2, 1-3, 1-4, 1-5 - принадлежат первому сегменту в составе поли-полигона, 2-1, 2-2, 2-3, 2-4, 2-5, соответственно второму.

Рисунок 14.

Полигоны могут быть вложены друг в друга. В этом случае те области группы полигонов, которые принадлежат полигонам с четным порядком вложенности, образуют отверстие, то есть площадь этих областей будет вычитаться из площади объекта, а при отображении эти области будут прозрачны.

Рисунок 15.


Символьные (узловые) объекты

Данные объекты описываются в системе одной точкой (X, Y). Точкой можно представить одиночные объекты, протяженность которых в данном случае не имеет значения (дерево, памятник, дорожный знак, населенный пункт при определенном масштабе и т.п.), а также абстрактные объекты, не имеющие размеров, но требующие привязки к территории (почтовые адреса, места вывода названий и т.п.). Например, символьный объект может быть узлом инженерной сети. На экране символьные объекты могут отображаться в виде пиктограмм или символов.

Рисунок 16.

Символы могут быть созданы или импортированы и хранятся внутри в структуре слоя:

Разработанная библиотека символов слоя

Рисунок 17. Разработанная библиотека символов слоя


Текстовые объекты

Текстовый объект описывается текстовой строкой, координатами точки привязки левого нижнего угла прямоугольника, в который вписан текст, углом поворота, высотой шрифта (в сантиметрах на местности). Объект может отображаться заданным цветом и стилем шрифта. Так как высота текста описана в сантиметрах на местности, то размер текста меняется вместе с масштабом окна карты.

Рисунок 18.


Семантическая информация

Любому объекту графического слоя может быть поставлена в соответствие семантическая информация. Указав объект на карте, пользователь может получить семантическую информацию, соответствующую этому объекту. И наоборот, задав в запросе искомую комбинацию значений семантических полей, пользователь может узнать, каким графическим объектам они соответствуют.

Для решения различных задач, как правило, необходимо привязывать к одним и тем же территориальным объектам различную семантическую информацию. Например, для работы с графическим слоем, отображающим здания, одному пользователю требуется иметь для каждого здания такую информацию, как этажность и размер жилой площади, другому пользователю – количество пенсионеров, проживающих в этом доме, третьему – номера телефонов жильцов этого дома и т.д.

Семантическая информация может храниться, используя таблицы в базах данных SQLite, Microsoft SQL Server localDB – файл базы и таблицы хранится в группе файлов слоя, так и в клиент-серверных СУБД: Microsoft SQL Server, Oracle, Sybase, PostgreSQL, MySQL, Линтер. Во втором случае файл базы и таблицы хранится в области данных СУБД.

Для удобства доступа к семантическим данным ZuluGIS предлагает свои «источники данных». Подобно источникам данных ODBC DSN или связям с данными OLEDB UDL, эти источники данных можно использовать при добавлении таблиц в базу данных или выборе таблиц для других операций. Источники данных могут использоваться как локально в однопользовательской версии ZuluGIS, так и на сервере ZuluServer. В случае сервера они могут быть опубликованы и использоваться пользователями ZuluServer.

Посмотреть используемый источник данных можно в редакторе баз данных.

[Примечание] Примечание

С помощью операции миграции данных имеется возможность сменить источник данных.

Существует, однако, одно принципиальное ограничение, касающееся структуры базы данных, подключаемой к графическому слою. Привязать семантическую базу данных к графическому слою означает задать соответствие между объектами из графического слоя и записями из семантической базы данных. У любого графического объекта слоя имеется ключ (ID), который присваивается объекту при его создании, ключи в рамках слоя не повторяются. Исходя из этого, обязательно в базе должно присутствовать одно поле связи с графическим слоем – это поле базовой таблицы (обязательно числовое), значения которого соответствуют значениям ключей объектов слоя. По умолчанию это поле Sys.

Создание базы данных и ряд ее настроек производятся в описателе баз данных. Он хранит следующую информацию:

  • список таблиц, участвующих в запросе;

  • список таблиц-справочников;

  • набор запросов, задающих правила выборки данных из таблиц;

  • набор сменных форм для отображения разного представления информации;

  • ряд дополнительных настроек для работы с базами данных.

При создании слоев инженерной сети базы данных создаются автоматически с уже настроенной структурой. При создании векторного слоя, отличного от инженерной сети, также возможно создать базу данных одновременно с файлами слоя. При этом на любом этапе работы всегда имеется возможность отредактировать и сделать нужные настройки базы.

Подробнее о базах данных можно узнать в разделе «Общие сведения».

После настройки базы данных внесение данных и их выборка производится с использованием окна семантической информации.


Запросы пространственных данных

В системе ZuluGIS реализовано выполнение запросов по пространственным данным карт в соответствии со стандартом OGC.

Такие запросы позволяют проводить выборки данных из разных слоев карты с учетом их относительного пространственного расположения, выводить отчеты по отобранным объектам и показывать их на карте. Данные могут выбираться на основе пересечения, взаимодействия объектов, выполнения заданных условий (соответствия заданных атрибутов, геометрических параметров, выполнения логических операторов).

Несложные запросы могут конструироваться с помощью простого внутреннего языка запросов ZuluGIS. В том случае, если его возможностей оказывается недостаточно, запросы могут создаваться на языке SQL с использованием расширения OGC (подробнее см. Пространственные запросы).


Карты

Карта является основным документом системы ZuluGIS. Она содержит список слоев с параметрами их отображения, характерными для данной карты. Карта может иметь одно или несколько окон. Через окна карты пользователь может работать со слоями карты: просматривать, осуществлять запросы, редактировать, выводить на печать и т.д. Физически карта является двоичным файлом с расширением zmp. Карта хранит основные параметры, перечисленные в таблице.

[Внимание] Внимание

Следует отметить, что карта не содержит графической информации. Графическая информация находится в слоях, а карта хранит только список их имен. При этом слои и файлы карты могут располагаться на компьютере в разных местах. Удалив с диска файл карты, можно потерять только настройки отображения слоев для данной карты.

Подробнее о картах ZuluGIS и работе с ними можно узнать в разделе Карта.

Подробнее о проекции карты можно узнать в разделе «Проекция карты».

Таблица 1. Параметры карты в файле «zmp»

Параметр | Описание
Имя карты | Полное название (с путем) файла карты.
Название карты | Пользовательское название карты, отражающее ее содержание.
Цвет фона | Цвет фона окна карты.
Проекция | Информация о картографической проекции и системе координат карты.
Центр отображения | Координаты точки, являющейся отображаемой в центре окна карты.
Масштаб отображения | Число, определяющее текущий масштаб карты на экране. Изменение данного параметра позволяет увеличивать и уменьшать изображение.
Список слоев | Список имен слоев входящих в карту.
Активный слой | Имя активного слоя, который в данный момент реагирует на запросы с экрана и участвует в ряде других операций с картой.
Параметры настройки по каждому слою | Набор параметров, относящихся к настройке слоя для данной карты: текущая семантическая база данных слоя, текущий тематический файл слоя, текущий файл надписей, общие параметры отображения для векторных слоев (цвет, стиль и т.д.).
Макеты для печати | Макеты печати, внедренные в карту.

Ниже приведен пример карты с загруженными слоями. Загруженные слои: кварталы, дороги, зеленые насаждения, здания, тепловая сеть.

Пример карты с загруженными слоями

Рисунок 19. Пример карты с загруженными слоями

[Примечание] Примечание

Разработчики приложений могут получить доступ ко всем параметрам карты через объект MapDoc.


Проекты

Проект представляет собой совокупность карт, объединенных общим пользовательским именем и, если требуется, набором иерархических связей между этими картами. Это позволяет удобно организовать карты, объединенные общей тематикой. Физически информация о картах, входящих в проект, и их связях хранится в файле проекта с расширением zpr, который может находиться на компьютере в любом удобном для пользователя месте. В файле проекта содержатся только ссылки на карты (файлы с расширением zmp), поэтому одна карта может входить одновременно в несколько проектов, так же как один слой может входить сразу в несколько карт.

Пути всех файлов проектов, зарегистрированных в системе ZuluGIS, перечислены в реестре Windows и расположены в разделе HKEY_LOCAL_MACHINE\Software\ZuluGIS\Projects

Возможно использовать проекты для раскрытия структуры узлов инженерной сети. При нанесении тепловой сети на карту города не раскрывается структура тепловых камер с установленными задвижками. Все тепловые камеры подробно прорисовываются на оперативной схеме. После этого карту с технологической схемой связывают с картой, содержащей слой с оперативной схемой.

Рисунок 20. Пример проекта


Моделирование сетей

Наряду с обычным для ГИС разделением объектов на контуры, ломаные, комбинированные контуры и комбинированные ломаные, ZuluGIS поддерживает линейно-узловую топологию, что позволяет моделировать инженерные сети. Линейно-узловое представление (векторно-топологическое представление) – разновидность векторного представления линейных и полигональных пространственных объектов, описывающего не только их геометрию, но и топологические отношения между полигонами, дугами и узлами.

Моделирование инженерных сетей

Рисунок 21. Моделирование инженерных сетей

Система ZuluGIS позволяет создавать классифицируемые объекты, имеющие несколько режимов (состояний), каждое из которых (состояний) имеет свой стиль отображения на карте (схеме). При этом ввод сетей производится с автоматическим кодированием топологии. Нарисованная на экране сеть сразу готова для топологического анализа (информация о связях между объектами заносится автоматически).

В системе предусмотрены средства редактирования инженерных сетей, включающие возможность создания объектов инженерной сети, нанесения сети на карту, а также контроля действий пользователя при определении компонентов сети или изменении ее конфигурации.


Знакомство с системой

  • «Окно рабочей среды системы»

  • «Открытие и сохранение файлов»

  • «Нештатное завершение работы»

  • «Вспомогательные окна (панели)»

  • «Кнопки панелей инструментов»

Программа ZuluGIS по внешнему виду весьма похожа на широко распространенные продукты семейства Microsoft Office и имеет схожие меню и панели инструментов. Строка меню и панели инструментов могут быть перемещены со своего обычного местоположения и закреплены на любом краю главного окна программы или оставлены в любом месте экрана внутри плавающего окошка с маленьким заголовком.


Окно рабочей среды системы

Общий вид окна системы ZuluGIS
1 - панель навигации по карте; 2 - окно карты; 3 - окно сообщений; 4 - строка состояния; 5 - строка основного меню системы; 6 - список загруженных в карту слоев; 7 - панель инструментов; 8 - окно навигации; 9 - панель Рабочее место; 10 - окно семантической информации

Рисунок 22. Общий вид окна системы ZuluGIS

Загруженные карты отображаются в окне карты. Система позволяет одновременно открыть несколько карт, каждую в своем отдельном окне.

В строке состояния (она расположена в нижней части окна программы) выводится информация о текущем состоянии системы, которая меняется при смене режима работы системы. Команды работы с картой в целом, а также со слоями и отдельными объектами слоя вызываются из основного меню программы. Для быстрого доступа к наиболее часто вызываемым командам основного меню используются кнопки панели инструментов. Кнопки активных действий (действий, доступных в текущий момент) отображаются в цвете, а прочие – в оттенках серого. Для изменения масштаба карты, перемещения центра карты, выделения объекта или группы объектов слоя используется панель навигации.


Открытие и сохранение файлов

Программа ZuluGIS использует стандартные диалоги для открытия имеющихся на диске файлов и сохранения результатов работы. Примерный вид диалога работы с файлами представлен на рисунке ниже.

Диалог выбора файла

Рисунок 23. Диалог выбора файла

Для удобства работы с файлами картографических данных в настройках ZuluGIS задается личная папка хранения карт. В диалогах открытия и сохранения файлов можно перейти к этой папке, нажав кнопку Мои карты в левой части диалога. При первом нажатии данной кнопки откроется диалоге Обзор папок для выбора личной папки карт.

[Примечание] Примечание

Для того чтобы впоследствии сменить личную папку, выполните команду меню Сервис|Параметры, в разделе Общие открывшегося диалога настроек выберите пункт Мои карты в списке Назначенные папки, нажмите кнопку Изменить и выберите требуемую папку в открывшемся диалоге Обзор папок.

При работе с геоинформационными данными, расположенными на серверах ZuluServer, для перехода к данным на сервере нажмите кнопку Серверы геоданных в левой части диалога. Подробная информация по подключению к ZuluServer и загрузке данных с него приведена в руководстве программы ZuluServer.

При использовании диалога открытия файлов для открытия проектов, карт и их слоев вместо названий их файлов в диалоге отображаются пользовательские названия соответствующих объектов.

При сохранении файлов в задаваемом названии файла необязательно указывать его расширение, оно будет добавлено автоматически.

Расширения файлов системы ZuluGIS

Открываемый файл | Расширение файла
Проект | *.zpr
Карта | *.zmp
Слой | *.b00
Упакованный слой (архив) | *.zpkg
Растр | *.zrs, *.zrg
Макет отчета | *.zrp
WMS, WMTS слой | *.zww
Рельеф | *.zww


Вспомогательные окна (панели)

  • «Окно Сообщения»

  • «Окно Свойства»

  • «Окно Закладки»

  • «Окно Объект»

  • «Окно Группа»

  • «Окно Навигатор»

  • «Окно Макеты»

  • «Окно Рабочее место»

Вспомогательные окна используются либо для вывода дополнительной информации, либо для дополнительных операций с объектами системы. Вызов вспомогательных окон выполняется через меню Окно или соответствующей кнопкой панели инструментов. Уже открытое в системе окно отображается в меню в виде нажатой кнопки.

Любую из описанных ниже панелей можно переместить в удобное положение рабочего окна системы ZuluGIS. Для этого «возьмите» панель за заголовок и перетащите в новое положение. Для того чтобы панель не «прилипала» к краям экрана, при перемещении панели нажмите и удерживайте кнопку Ctrl.

Для изменения размеров панели надо подвести курсор к ее краю. Когда курсор поменяет вид, нажать левую кнопку мыши и, удерживая ее, изменить размеры панели, затем отпустить кнопку мыши.

Скрыть любую панель можно повторным выбором соответствующей команды меню Окно или нажатием кнопки панели инструментов. Панель можно также скрыть, щелкнув правой кнопкой мыши по ее заголовку и выбрав в открывшемся контекстном меню пункт Скрыть.


Окно Сообщения

  • Сохранение текста сообщений в файл

  • Помещение текста сообщений в буфер обмена

  • Поиск фрагмента текста в сообщениях

В данном окне выводится информация по проводимым расчетам или сообщения об ошибках. Например, при выполнении теплогидравлических расчетов сюда будет выведена информация о настройках, процессе и общих результатах текущего расчета. В случае ошибок или предупреждений, полученных в результате расчета, они также будут отображаться в данном окне.

Панель разделена на вкладки, каждая из которых содержит сообщения по теме, указанной в заголовке вкладки.

Чтобы показать или убрать панель, выберите пункт Сообщения в меню Окно или нажмите кнопку [image] панели инструментов.

По умолчанию информация в панели выводится по порядку без указания точного времени. Если требуется отображать время сообщений, то для этого надо сделать щелчок правой кнопкой мыши в области панели Сообщения и из контекстного меню выбрать Вид|Отображать время. Отключить отображение времени можно аналогичными действиями.

Включение отображения времени

Рисунок 24. Включение отображения времени

Навигация по окну сообщений осуществляется клавишами со стрелками, а также следующим клавишами:

Клавиша | Действие
PgUp | на страницу вверх
PgDn | на страницу вниз
Home | в начало строки
End | в конец строки
Ctrl + Home | в начало текста
Ctrl + End | в конец текста

Некоторые сообщения могут содержать дополнительную информацию или подразумевать некоторое дополнительное действие. Чтобы вызвать это действие, выполните двойной щелчок мыши по строке с таким сообщением или выделите эту строчку простым щелчком мыши и нажмите клавишу Enter. Например, двойной щелчок по сообщению Ошибка ZD010: ID=355 Неверное значение поля 'H_obr'-'Расчетный напоp в обpатн. тp-де на источнике, м' откроет окно информации для исправления указанной в сообщении ошибки.

Текст сообщений может быть скопирован в буфер обмена, а также записан в текстовый файл или файл HTM.

Сохранение текста сообщений в файл

Текст окна Сообщения может быть сохранен в текстовый файл или в файл формата HTM. Для сохранения:

  1. Сделайте щелчок правой кнопкой мыши в области окна Сообщения и из контекстного меню выберите пункт [image] Сохранить или же выделите любую строку в окне Сообщения и нажмите Ctrl + S на клавиатуре.

  2. В открывшемся окне укажите имя и каталог для создаваемого файла, затем из списка Тип файла выберите нужный тип файла.

  3. Нажмите кнопку ОК.

В результате в указанном каталоге будет создан файл *.log, или *.htm в зависимости от выбранного типа, * – указанное имя.

Помещение текста сообщений в буфер обмена

  1. Выделите нужный фрагмент текста либо с помощью мыши, либо удерживая клавишу Shift и используя клавиши со стрелками.

  2. Нажмите сочетание клавиш Ctrl + C или щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Копировать.

Поиск фрагмента текста в сообщениях

  1. Сделайте щелчок правой кнопкой мыши в области окна Сообщения и из контекстном меню выберите пункт [image] Найти или выделите любую строку в окне Сообщения и нажмите Ctrl+F на клавиатуре.

  2. В появившемся окне в поле Что задайте фрагмент текста.

  3. Укажите требуемые параметры поиска (нужно ли учитывать регистр и нужно ли искать только слово целиком).

  4. Нажмите кнопку Найти далее, после чего начнется поиск заданного фрагмента, начиная с текущей позиции текста, отмеченной мигающим курсором. Кнопка Отмена закроет окно без запуска поиска.

Рисунок 25. Диалог поиска


Окно Свойства

В окне Свойства в зависимости от выбранного режима и действия может отображаться та или иная информация.

Чтобы показать или убрать панель Свойства, выберите пункт Свойства в меню Окно или нажмите на панели инструментов кнопку [image] .

Например в нем отображаются координаты, вводимой полилинии или многоугольника. Или координаты выделенного в режиме Узлы [image] объекта. При необходимости эти данные могут быть откорректированы в окне для обеспечения точности ввода. Координаты могут отображаться или в метрах (X, Y) или в градусах (Широта, Долгота). Параметры отображения указываются в настройках карты.

Рисунок 26. Окно Свойства


Окно Закладки

Данное окно используется для работы с закладками карты. В нем можно создать, удалить, переименовать и сгруппировать закладки, а также перейти по ним. Чтобы показать или убрать панель Закладки, выберите пункт Закладки в меню Окно или нажмите на панели инструментов кнопку [image] .

Рисунок 27. Окно Закладки


Окно Объект

В окне Объект отображаются параметры активизированного объекта (который в данный момент мигает на карте).

Чтобы показать или убрать панель Объект, выберите пункт Объект в меню Окно или нажмите на панели инструментов кнопку [image] .

Рисунок 28. Окно Объект


Окно Группа

В окне Группа отображается таблица с ключами (ID) объектов, входящих в группу активного слоя текущей карты. При перемещении по строкам таблицы на карте начинает мигать объект с соответствующим ключом, при этом в окне Объект обновляется информация о текущем объекте карты.

Чтобы показать или убрать панель Группа, выберите пункт Группа в меню Окно или нажмите на панели инструментов кнопку [image] .

Рисунок 29. Окно Группа


Окно Навигатор

В этом окне отображается содержимое активной карты и навигационная рамка, размеры которой соответствуют текущему масштабу, центру и размерам окна карты. При перемещении и масштабировании рамки соответственно изменяется масштаб и центр активной карты, так же как и при изменении масштаба активной карты, размер рамки будет меняться.

Чтобы показать или убрать панель Навигатор, выберите пункт Навигатор в меню Окно или нажмите кнопку [image] панели инструментов.

Подробнее про панель Навигатор можно узнать в разделе Навигация по карте.


Окно Макеты

Окно макетов организует макеты печати карты и упрощает работу с ними. Макеты печати на панели представляются в виде списка.

Чтобы показать или убрать панель макетов, выполните команду Макеты в меню Окно или нажмите кнопку [image] панели инструментов.

Рисунок 30. Панель макетов


Окно Рабочее место

Рабочее место содержит окно иерархического списка с информацией о зарегистрированных проектах, входящих в них картах, слоях, связях между объектами слоев и картами, а также загруженных картах.

Чтобы показать или убрать панель Рабочее место, выберите пункт Рабочее место в меню Окно или нажмите на панели инструментов кнопку [image] . Пользователь самостоятельно может настроить как размеры панели, так и ее местоположение.

Пользуясь данной панелью, можно существенно ускорить рабочий процесс, так как выполнение многих функций будет производиться намного быстрее.

Пример окна Рабочее место

Рисунок 31. Пример окна Рабочее место

Раскрыть весь доступный список объектов панели можно нажатием на + слева от соответствующего пункта.

Для данной панели предусмотрено специальное контекстное меню, вызываемое щелчком правой кнопки мыши в пределах панели. В меню содержатся команды, относящиеся к выделенному элементу иерархического списка (либо к выделенному элементу списку, если щелчок был выполнен по свободному пространству панели).

Пример контекстного меню для слоя

Рисунок 32. Пример контекстного меню для слоя

В представленной ниже таблице приводится структура информации в панели с назначением пунктов контекстного меню. Вы можете увидеть иконки карт, слоев и проектов двух тонов. Если иконка голубых или зеленых тонов, то значит объект располагается на локальной машине. Если иконка в сиреневых тонах, значит объект находится на сервере, подробнее....

Таблица 2. Структура информации в панели «Рабочее место»

Проекты

Папка, в которой сгруппированы зарегистрированные проекты. Команды контекстного меню:

Проекты…

Вызывает панель менеджера проектов для добавления и удаления проектов. Также менеджер можно вызвать двойным щелчком левой кнопки мыши на названии раздела.

Создать проект... | Позволяет создать новый проект.
Добавить проект... | Позволяет добавить проект, не зарегистрированный в системе.

( [image] ) Название проекта

Элемент списка, соответствующий проекту. У проектов, располагающихся на сервере, цвет иконки сиреневый. Загруженный проект отмечается полужирным шрифтом. Команды контекстного меню:

Открыть проект

Открывает этот проект. Пункт отображается только для закрытых проектов. Открыть проект также можно, сделав двойной щелчок левой кнопкой мыши по его названию.

Еще проекты...

Вызывает диалог менеджера проектов для добавления и удаления проектов. Активен для закрытых проектов.

Карты проекта

Вызывает диалог менеджера карт проекта для добавления и удаления карт проекта. Активен для открытых проектов.

Добавить карту... | Открывает стандартное окно выбора для добавления карты в проект. Активен для открытых проектов.
Добавить активную карту... | Добавляет активную карту в загруженный проект. Активен для открытых проектов.
Закрыть проект | Закрывает проект. Активен для открытых проектов.

Название карты

Элемент списка, соответствующий карте, входящей в состав проекта, указанного выше. Команды контекстного меню:

Открыть

Открывает эту карту. Открыть карту также можно, сделав двойной щелчок левой кнопкой мыши по ее названию.

Показать | Делает активной окно данной карты.
( [image] ) Название растрового слоя | Отображается название растрового слоя в составе вышеуказанной карты.

( [image] ) Название слоя рельефа

Отображается название слоя рельефа в составе карты.

( [image] ) Название векторного слоя

Отображается название векторного слоя в составе вышеуказанной карты.

Ключ

Обозначает набор карт, подключенных к элементу с указанным ключом. Команды контекстного меню:

Показать объект

 Показывает на карте объект с данным ключом, при этом происходит перемещение карты таким образом, что объект оказывается в центре экрана и начинает мигать.

Название карты

Обозначает гиперссылку на карту от вышеуказанного элемента.

Карты

Папка, в которой сгруппированы открытые в настоящий момент карты. Команды контекстного меню:

Открыть карту

Вызывает диалог открытия карты.

Новая карта

Открывает окно с новой картой.

( [image] ) Название карты

Обозначает открытую карту. Если активно окно этой карты, то элемент обозначается полужирным шрифтом. У карт, располагающихся на сервере, цвет иконки сиреневый ( [image] ). Двойной щелчок по названию откроет диалог настройки слоев карты. Команды контекстного меню:

Показать

Делает окно этой карты активным. Активизировать карту также можно, сделав двойной щелчок левой кнопкой мыши по ее названию.

Закрыть

Закрывает эту карту.

Добавить слой

Вызывает диалоговое окно выбора файла слоя для добавления его в карту.

Слои

Вызывает диалог настройки слоев для данной карты.

Создать слой | Вызывает диалоговое окно создания нового векторного слоя.
Создать слой по образцу | Вызывает диалог выбора слоя, по образцу которого надо создать новый.
Подключить все надписи | Подключает все надписи всех слоев карты.
Отключить все надписи | Отключает все надписи всех слоев карты.

Настройка

Вызывает диалог настройки карты.

Настройка печати

Вызывает диалог настройки параметров печати карты.

Макеты

Вызывает диалог настройки макетов.

Добавить группу | Пункт отображается только у активной карты. Создает группу слоев.

( [image] ) Название векторного слоя

Векторный слой в составе вышеуказанной карты. Если слой активен, название слоя отображается полужирным шрифтом. В том случае, если слой не активен, то двойной щелчок по названию сделает его активным. У слоев, располагающихся на сервере, цвет иконки сиреневый.

Для скрытия/отображения слоя надо сделать щелчок левой кнопкой мыши по его иконке. Если он был скрыт, то теперь будет отображаться, а если отображался, то скроется. Активный слой не может быть скрытым, так как он обязательно должен выводиться на экран.

Команды контекстного меню:

Активный

Делает этот слой активным. Выбор данного пункта аналогичен двойному щелчку левой кнопки мыши по названию слоя.

Видимый

Скрывает/показывает этот слой в окне карты.

Редактировать

Включает/отключает редактирование слоя. У редактируемого слоя иконка меняет вид: .

Настройка

Открывает диалогнастройки слоя.

Структура

Открывает диалог структуры слоя.

По размерам слоя | Перестраивает изображение карты по размерам указанного слоя.
По размерам группы | Перестраивает изображение карты по размерам выделенной группы объектов. Пункт доступен только в том случае, если в указанном слое есть выделенная группа.
Информация | Открывает окно информации по слою.
Удалить из карты | Исключает слой из указанной выше карты. Слой при этом останется на диске.

Темы

Содержит все темы, имеющиеся в вышеуказанном слое.

Команды контекстного меню:

Создать

Открывает диалог создания тематической раскраски. Он может также быть вызван двойным щелчком мыши.

Подключить | Вызывает диалог Тематические раскраски.
Подключить все | Подключает все темы слоя одновременно.
Отключить все | Отключает все темы слоя одновременно.
Редактор фильтров | Вызывает диалог редактора тематических фильтров.
Импорт | Вызывает диалог импорта тематических раскрасок из одно слоя в другой.
( [image] ) Название темы

Тематический фильтр вышеуказанного слоя.

Команды контекстного меню:
Изменить

Открывает редактор тематического фильтра данной темы. Вызвать его также можно двойным щелчком левой кнопкой мыши по названию темы.

Обновить

Вызывает процедуру обновления темы слоя.

Автообновление | Устанавливает автообновление темы. Обновление темы будет происходить при перестроении масштаба карты или при ее перемещении.
Переименовать | Вызывает диалог переименования темы.

Удалить

Удаляет тематическую раскраску.

Подключить/Отключить | Подключает/отключает тему слоя. Подключить/отключить тему также можно, сделав щелчок левой кнопкой мыши по его иконке.

Надписи

Содержит все надписи, имеющиеся в вышеуказанном слое.

Команды контекстного меню:

Создать

Открывает диалог создания надписей слоя. Он также может быть вызван двойным щелчком мыши.

Подключить | Вызывает диалог подключения и отключения надписей.
Обновить | Вызывает процедуру обновления надписей слоя.
Подключить все надписи | Подключает все надписи слоя.
Отключить все надписи | Отключает все надписи слоя.
Импорт | Вызывает диалог импорта надписей раскрасок из одно слоя в другой.

( [image] ) Название надписи

Надпись вышеуказанного слоя.

Команды контекстного меню:

Изменить

Вызывает диалог редактирования варианта надписи.

Обновить

Вызывает процедуру обновления варианта надписей.

Удалить

Удаляет вариант надписей.
Подключить/Отключить | Подключает/отключает вариант надписей. Подключить/отключить вариант надписей также можно, сделав щелчок левой кнопкой мыши по его иконке.

Базы данных

Список баз данных слоя.

Команды контекстного меню:
Базы | Открывает диалоговое окно Базы данных, отображающее все базы слоя. Он также может быть вызван двойным щелчком мыши.
Сжать все базы слоя

Удаляет из баз слоя лишние записи. Лишние записи могут образоваться в результате удаления объектов слоя.

Заполнить все базы слоя | Заполняет базы слоя недостающими пустыми записями. Такая операция может понадобиться перед выполнением запросов к базе данных.

Название базы данных

База данных вышеуказанного слоя.

Команды контекстного меню:

Открыть браузер

Открывает окно браузера базы данных (окно семантической информации).

Сжать

Удаляет из указанной базы лишние записи.

Заполнить

Заполняет указанную базу недостающими пустыми записями.

Изменить

Вызывает редактор структуры базы данных.

Типы

Список типов и режимов слоя.
Примитивы | Элемент, обозначающий простые объекты слоя (примитивы). Повторные щелчки левой кнопкой мыши по иконке слева от названия включают и выключают отображение таких объектов слоя на карте.

( [image] [image] ) Название типа объектов слоя

Тип объектов слоя. Вид иконки обозначает, является ли тип символьным, линейным или площадным. Повторные щелчки левой кнопкой мыши по иконке слева от названия включают и выключают отображение на карте объектов слоя, принадлежащих данному типу.

Название базы данных (N) | База данных, подключенная к вышеуказанному типу, где N – ID типа в базе. Команды контекстного меню полностью соответствуют выше описанным.

( [image] [image] ) Название режима

Режим вышеуказанного типового объекта. Вид иконки обозначает, является ли режим символьным, линейным или площадным. Повторные щелчки левой кнопкой мыши по иконке слева от названия включают и выключают отображение на карте объектов указанного выше типа, находящихся в данном режиме.

Название тайлового слоя | Тайловый слой в составе вышеуказанной карты. Если слой активен, название слоя отображается полужирным шрифтом. Команды контекстного меню аналогичны командам векторного слоя, за исключением пункта Обновить, выбор данного пункта приведет к обновлению тайлов.

Название растрового слоя

Растровый слой в составе вышеуказанной карты. Если слой активен, название слоя отображается полужирным шрифтом. Команды контекстного меню аналогичны командам векторного слоя.

Закладки | Содержит все закладки, имеющиеся в вышеуказанной карте. Двойной щелчок вызовет диалог работы с закладками.

Название закладки

Элемент списка, соответствующий закладке, имеющейся в карте, указанной выше. Команды контекстного меню:
Перейти | Переходит к закладке. Также перестроить карту в соответствие с положением закладки можно, сделав двойной щелчок мыши по названию закладки.

Кроме перечисленных выше пунктов, во всех контекстных меню, открываемых для разных элементов панели Рабочее место, располагается пункт [image] Найти, при выборе которого открывается диалог поиска:

Диалог поиска объектов

Рисунок 33. Диалог поиска объектов

Элементы управления диалога Поиск:

  • В поле Образец вводится строка или фрагмент строки для поиска.

  • В группе флажков Искать выбираются виды объектов, среди которых производится поиск указанной строки.

  • В группе флажков Параметры задаются параметры поиска:

    • только слово целиком – поиск названия, в точности совпадающего с образцом;

    • с учетом регистра – при поиске по образцу учитывается не только совпадение букв в слове, но и регистр, т.е. какие буквы в слове написаны заглавными, а какие строчными.

  • Кнопка Найти далее выполняет поиск элемента, начиная с текущего выделенного.


Кнопки панелей инструментов

  • «Панель Стандартная»

  • «Панель Карта»

  • «Панель Редактор»

  • «Панель Навигация»

  • «Панель Форматирование»

  • «Панель Стиль»

  • «Панель Печать»

  • «Панель Операции»

  • «Панель Бирки»

  • «Панель Макет»

  • «Панель Рельеф»

  • «Панель Модули»


Панель Стандартная

Кнопка | Описание | Соответствующая команда меню
 | Создание новой карты | Файл|Создать|Карту
 | Открытие файла ZuluGIS (карты, проекта, слоя, базы данных). Нажатие в правой части кнопки вызывает меню последних открытых файлов. | Файл|Открыть
 | Сохранение активной карты | Файл|Сохранить
 | Печать активного документа. | Файл|Печатать
 | Просмотр документа перед печатью. | Файл|Предварительный просмотр
 | Создание нового макета печати. | Карта|Макеты и далее нажмите кнопку Создать в открывшемся диалоге.
 | Вырезание (удаление в буфер обмена) выделенного элемента или группы элементов. | Правка|Вырезать
 | Копирование выделенного элемента или группы элементов в буфер обмена. | Правка|Копировать
 | Вставка элемента(ов) из буфера обмена. | Правка|Вставить
 | Удаление выделенных элементов. | Правка|Удалить
 | Отмена последнего действия. При многократном нажатии отменяет последние действия в порядке обратном от того, в котором они были произведены. | Правка|Отменить
 | Возврат результата только что отмененного действия. Работает в паре с предыдущей командой. | Правка|Вернуть
 | Отображение панели свойств | Окно|Свойства
 | Отображение панели Рабочее место | Окно|Рабочее место
 | Отображение панели сообщений | Окно|Сообщения
 | Отображение окна навигатора | Окно|Навигатор
 | Вызов редактора баз данных. | Таблица|Редактор баз данных
 | Создание таблицы. | Таблица|Создать
 | Вызов таблицы для просмотра. | Таблица|Просмотр
 | Вызов окна справочной системы. | Справка|Справка по ZuluGIS


Панель Карта

Кнопка | Описание | Соответствующая команда меню
 | Загрузка слоя в карту | Карта|Добавить слой
 | Исключение слоя из карты | Карта|Убрать слой
 | Настройка параметров слоя | Карта|Настройка слоя
 | Включение и выключение режима редактирования слоя | Карта|Редактор слоя
 | Открывает диалог управления слоями. Диалог позволяет поменять слои местами, добавить слой, удалить слой, поменять структуру и настройку слоя. | -
 | Вызов диалога структуры слоя | Слой|Структура слоя
 | Отмена созданной группы объектов | Карта|Группа|Отменить
 | Смена режима для выделенного (мигающего) объекта | -
 | Поиск объекта по заданному ключу | Карта|Запрос|По ключу
 | Вызов браузера базы данных. | Карта|Запрос|По базе данных
 | Выделение объектов по атрибутам отображения | Карта|Запрос|По атрибутам
 | Возврат к предыдущему расположению. | Вид|Предыдущий
 | Переход вперед (к расположению до выполнения возврата). Активна только после выполнения команды возврата. | Вид|Вернуться
 | Левая часть – установка закладки, правая – выбор закладки и переход по ней | -
 | Переход на уровень вниз. | -
 | Переход на уровень вверх. | -
 | Создание связи объекта с другой картой. | -
 | Обновление связи. | -


Панель Редактор

(активна только в режиме редактирования)

Кнопка | Описание | Соответствующая команда меню
 | Установка режима выделения объектов для редактирования. | -
 | Установка режима выделения узлов. | -
 | Выбор типового объекта для нанесения на карту. | -
 | Установка режима ввода ломаных линий. | -
 | Режим ввода незаполненных прямоугольников. | -
 | Режим ввода заполненных прямоугольников. | -
 | Режим ввода окружностей. | -
 | Режим ввода заполненных окружностей. | -
 | Режим ввода многоугольников. | -
 | Режим ввода дуг. | -
 | Режим ввода сегментов. | -
 | Режим ввода заранее выбранного символа. | -
 | Режим нанесения надписей. | -
 | Добавление узла. | -
 | Удаление узла. | -
 | Вставка символа. | -
 | Удаление символа, находящегося на участке (символ удаляется только в том случае, если из него входят и выходят строго по одному участку. В результате символ удаляется, а участки объединяются в один). | -
 | Включение и выключение отображения сетки редактора. | -
 | Включение и выключение привязки к сетке. | -
 | Включение и выключение отображения узлов объектов. | -
 | Включение и выключение режима ортогонального нанесения ребер ломаных. | -
 | Включение режима поворота выделенного объекта. | -
 | Выполнение замыкания вокруг объекта. | -
 | Выполнение обхода объекта (трассировка линий). | -
 | Разбиение объекта. | -
 | Трансформация слоя с экрана. | -
 | Спрямление углов (используется для четырехугольных полигонов). | -


Панель Навигация

Кнопка | Описание | Соответствующая команда меню
 | Установка режима выделения (активизации) объектов активного слоя. | -
 | Установка режима выделения объектов прямоугольником. | -
 | Установка режима выделения объектов окружностью. | -
 | Установка режима выделения объектов произвольным замкнутым многоугольником. | -
 | Перестроение окна карты без изменения масштаба и центра изображения (обновить экран). | Вид|Обновить
 | Отображение всей карты. | Вид|По размерам|Карты
 | Увеличение карты. | Вид|Увеличить
 | Уменьшение карты. | Вид|Уменьшить
 | Установка режима произвольного перемещения центра изображения в пределах половины экрана. | -
 | Установка режима получения информации по объектам. | -
 | Включение инструмента быстрого поиска. Структура поиска предварительно должна быть настроена в структуре слоя. | -
 | Задание новых координат центра отображения. | Вид|Задать координаты
 | Установка режима измерения расстояний и площадей. | -
 | Поиск пути. | Карта|Топология|Найти путь
 | Отмена пути. | Карта|Топология|Отменить все


Панель Форматирование

Кнопка | Описание | Соответствующая команда меню
 | Выбор шрифта. | -
 | Выбор размера текста. | -
 | Установка жирного начертания шрифта. | -
 | Установка начертания шрифта курсивом. | -
 | Установка начертания шрифта с подчеркиванием. | -
 | Установка выравнивания по левому краю. | -
 | Установка выравнивания по центру. | -
 | Установка выравнивания по правому краю. | -
 | Выбор цвета шрифта. | -
 | Выбор цвета фона. | -
 | Выбор цвета линий. | -


Панель Стиль

Кнопка | Описание | Соответствующая команда меню
 | Открывает диалог для настройки стиля и цвета ломаной. | -
 | Выбор стиля заполненных фигур (площадных объектов). | -
 | Выбор символа для ввода. | -
 | Выбор стиля текста. | -


Панель Печать

Кнопка | Описание | Соответствующая команда меню
 | Вызов диалога параметров страницы. | Файл|Параметры страницы...
 | Вызов окна параметров печати карты. | Карта|Настройка печати...
 | Выделение область печати. | -
 | Редактирование области печати (активна, только если уже задана область печати). | -


Панель Операции

[Примечание] Примечание

Для выполнения ряда операций данной панели необходимо предварительно назначить объект-мишень. Для этого выберите объект и выполните команду меню Правка|Установить мишень или нажмите комбинацию клавиш Ctrl+T. Для последующей отмены назначения объекта мишенью выберите команду меню Правка|Отменить мишень.

Кнопка | Описание | Соответствующая команда меню
 | Объединение объектов. | Правка|Объединить объекты
 | Разделение объектов. | Правка|Разъединить объекты
 | Разделение мишени группой. | Правка|Разделить мишень группой
 | Вырезание группы из мишени. | Правка|Вырезать из мишени группу
 | Обрезка мишени вне группы. | Правка|Обрезать мишень вне группы
 | Узлование объектов. | Правка|Узлование


Панель Бирки

Кнопка | Описание | Соответствующая команда меню
 | Включение режима редактирования надписей, выведенных на карту из базы данных (бирок). | -
 | Установка режима 1:1: уменьшения надписей пропорционально масштабу карты. | -
 | Отмена режима 1:1. | -


Панель Макет

Данная панель активна только в режиме работы с макетом!

Кнопка | Описание | Соответствующая команда меню
 | Вставка карты в макет. | Вставка|Карта…
 | Вставка текста в макет. | Вставка|Текст…
 | Вставка масштаба в макет. | Вставка|Масштаб…
 | Вставка рисунка в макет. | Вставка|Рисунок…
 | Вставка таблицы в макет | Вставка|Таблица...
 | Установка режима стирания таблицы. | -
 | Выбор масштаба отображения макета. | -


Панель Рельеф

Кнопка | Описание | Соответствующая команда меню
 | Создание рельефа | Карта|Рельеф|Создать...
 | Задание пути. | -
 | Задание региона. | -
 | Очистка. | -


Панель Модули

Кнопка | Описание | Соответствующая команда меню
 | Вызов списка модулей. | Сервис|Модули…
 | Вызов диалога выполнения команд. | Сервис|Выполнить…
 | Поиск отключающих устройств в сети. | Задачи|Найти отключающие устройства
 | Вызов панели расчетов газоснабжения. | Задачи|ZuluGaz
 | Вызов панели расчетов теплоснабжения. | Задачи|ZuluThermo
 | Формирование пьезометрического графика газоснабжения. | Задачи|Пьезометрический график (газопровод)
 | Формирование пьезометрического графика водоснабжения. | Задачи|Пьезометрический график (водоснабжение)
 | Формирование пьезометрического графика паропровода. | Задачи|Пьезометрический график (паропровод)
 | Формирование пьезометрического графика теплоснабжения. | Задачи|Пьезометрический график (теплоснабжение)
 | Вызов панели расчетов паропроводов. | Задачи|ZuluSteam
 | Вызов панели расчетов водоснабжения. | Задачи|ZuluHydro
 | Вызов панели коммутационных задач. | Задачи|Коммутационные задачи
 | Вызов графиков суточного водопотребления. | -
 | Вызов справочника по насосам. | -
 | Вызов справочника по запорной арматуре. | -


Нештатное завершение работы

В редких случаях при работе с системой может произойти сбой. В случае такого нештатного завершения работы ZuluGIS (при вылете) создается текстовый файл zulu_crash_dump.txt, содержащий информацию о состоянии программы на момент вылета. При этом будет предложено отправить этот файл по почте на адрес нашей технической поддержки. Данная информация позволит быстрее выявить и устранить причины возникновения данной ошибки.


Нужен ли при работе доступ в интернет?

Ответ на этот вопрос зависит от того, каким образом настроена работа пользователей.

Если работа производится в локальной версии ZuluGIS и данные хранятся непосредственно на самом компьютере, то в этом случае интернет не нужен. При этом слои с Tile-серверов работать не будут, в том числе, например, уже интегрированные в систему слои космоснимков СКАНЭКС, OpenStreetMap, 2ГИС, ArcGIS Online. При необходимости использования таких слоев без интернета можно закешировать интересующие картографические сервисы и сохранить их в локальный архив .mbtiles или .sqlite.

Это можно сделать непосредственно в ZuluGIS. Для этого надо создать карту с необходимым слоем и действовать далее по инструкции. По мимо этого сформировать архив .mbtiles возможно в сторонней программе SAS.Planet, а затем добавить в ZuluGIS созданный архив.

Также без интернета не будут доступны сторонние данные, такие как:

  • классификатор ФИАС;

  • сервисы WMS/WMTS.

При использовании сетевой версии работа с ZuluServer может быть организована по протоколу TCP/IP либо по локальной сети, либо через интернет (по внешнему IP). Таким образом, связь между ZuluGIS и ZuluServer может установить по локальной сети, и она будет работать без подключения к сети интернет. В этом случае для соединения с сервером потребуется указать IP компьютера в локальной сети.


Географическая проекция и система координат

  • «Проекция карты»

  • «Проекция слоя»

В ZuluGIS работа с пространственными данными может проводиться как в локальной системе декартовых координат, так и в различных географических системах координат.

[Примечание] Примечание

Поддерживаемые ZuluGIS список проекций можно увидеть в приложении: Поддерживаемые типы проекций и датумы.

Поддерживается создание слоев и карт в таких проекциях, отображение (с возможностью данные заданные в одной проекции показывать в другой проекции), импорт пространственных данных из других систем (MapInfo, OziExplorer, ArcGIS, форматов Metafile WMF, OziExplorer PLT, Google Earth KML, GeoJSON и др.) c учетом системы координат и преобразование карт назначение данным созданным в локальной системе координат в географическую.

Если карте не назначена проекция, то в диалоге проекции карты (Карта|Настройка, вкладка Проекция карты) указана проекция Локальная (проекция карты – план/схема, датум – локальный датум).

В случае если проекция карты локальная, объекты слоев будут отображаться в обусловленных данными координатах, без привязки к сфероиду. В этой карте невозможно корректно работать с данными «базовых» слоев с Tile-серверов, данными WMS, слоями GPX треков и другими данными, выполненными в географических проекциях. При добавлении в карту слоев, содержащих разные параметры проекции, они не будут согласованы друг с другом и могут отображаться в разных местах. Иными словами, если в карте находятся слои с географической проекцией, то для совмещения данных у карты также должна быть назначена географическая проекция, при план-схеме данные не совместятся.

Особенности ZuluGIS:

  • есть проекция слоя – проекция хранения. Выражается координатами объектов при хранении и при наличии параметров проекции, возможностью пересчета хранимых Х и У в географическую широту и долготу или другую систему координат.

  • есть проекция карты – проекция отображения. Выражается в том, как выглядит карта в ZuluGIS и в каких координатах все будет отображаться.


Проекция карты

  • «Настройка проекции карты»

  • «Проекция слоя»

Диалоговое окно настройки карты вызывается через меню Карта|Настройка. Подробнее о том, как настроить проекцию карты, можно узнать в разделе «Настройка проекции карты».

В параметрах карты задается проекция, используемая для отображения картографических данных на экране. Эта проекция называется проекцией отображения.

При выводе на экран данные, хранимые в слоях карты, преобразуются из проекции хранения, заданной для слоя, в проекцию отображения данной карты, перепроецирование происходит «на лету». В карте могут находиться слои с разной проекцией, в этом случае будет производиться автоматическое перепроецирование данных в проекцию карты. При создании объектов в слое производится обратное преобразование – из проекции отображения в проекцию хранения данных слоя. Таким образом, возможно хранение данных в одной проекции, а отображение в другой, причем данные одного слоя могут отображаться в разных картах в разных проекциях отображения в зависимости от настройки.

В случае если проекция карты не совпадает с проекцией слоя, для отображения данных в карте затрачивается дополнительное время, поэтому рекомендуется, чтобы проекция карты и проекция самого «тяжелого» слоя совпадали. Для ускорения работы системы возможно перепроецирование пространственных данных в слоях из одной проекции в другую. Тайловые слои и слои WMS перепроецировать нельзя.

Отображение карты в разных проекциях

Рисунок 34. Отображение карты в разных проекциях

Важно отметить, что, если слою не назначена проекция (проекция карты – план/схема, датум – локальный датум), он не может корректно отображаться в карте, имеющей проекцию. Слою необходимо назначить проекцию. С данной операцией подробнее можно познакомиться в разделе «Назначение проекции слою».


Проекция слоя

  • «Проекция карты»

  • «Перепроецирование растровых слоев»

  • «Перепроецирование слоя»

  • «Назначение проекции слою»

Для отображения слоя в карте, проекция которой отличается от проекции – план-схема, слою должна быть назначена проекция, в противном случае данные слоя отобразятся либо на экваторе, либо вообще не отобразятся. Эта проекция называется проекцией хранения данных. Проекция хранения данных выбирается в соответствии с проекцией исходных данных, на базе которых формируются объекты слоя (печатные карты, геодезическая съемка местности, чертежи AutoCAD и прочие). Наличие у слоя подходящей проекции, отличной от план-схемы, позволяет этому слою отображаться абсолютно в любой проекции карты и совмещать данные слоя с тайловыми слоями, слоями WMS и другими слоями, имеющими проекцию.

[Примечание] Примечание

Чтобы узнать, указана ли у слоя проекция, отличная от план-схемы, необходимо выбрать меню Карта|Слои. Если справа от слоя располагается изображение глобуса [image] , это значит, что слою была назначена проекция, в противном случае у слоя проекция план-схема.

Проекцию определенного слоя можно посмотреть в настройках слоя, вкладка Общие.

От выбора системы координат зависит как расположение слоя на карте, так и то, насколько верные будут размеры объектов.

Если проекция у слоя не была задана при его создании, то ее также возможно задать позже.

Где взять проекцию:

  • наилучший вариант – знать, в какой проекции создавались данные;

  • или попробовать использовать проекцию по ГОСТ 51794-2008, если данные выполнены в ней. Так, для каждого региона своя местная система координат (МСК). Например, для Мурманской области такие данные легко найти, если поискать в интернете МСК-51.

  • в том случае, если параметры проекции неизвестны, а данные выполнены в местной системе координат, можно подобрать параметры МСК с помощью специальной программы. Для подбора проекции надо знать:

    • координаты двух точек в широте/долготе и соответствующие этим точкам координаты в местной системе координат;

    • или параметры центрального меридиана и координаты одной точки.

    Эти координаты заносятся в программу и после ее выполнения будут подобраны подходящие параметры указанной местности.

    [Примечание] Примечание

    Видеоурок с подбором проекции можно найти на нашем сайте https://www.politerm.com/videos/examples/CalcGaussKruger/.

Пример 1

В случае если данные выполнены с использованием местных систем координат (МСК), применяемых в Едином государственном реестре недвижимости и других отраслевых геодезических и кадастровых работах, или универсальной поперечной проекции Меркатора (UTM, определенной зоны), они спроецированы таким образом, что искажений нет. Используется проекция Меркатора, но уже не сферического, а поперечного. Если включить 6 или 3-градусную сетку у карты (Карта|Настройка|Проекция карты – градусная сетка), то в рамках центральной доли территория земли не будет иметь искажений. Чем дальше от центральной доли, тем сильнее будут искажения. Доля без искажений задается положением центрального меридиана. Таким образом, МСК уникальна для определенной местности.

Рисунок 35. Использование МСК-64

Чтобы задать МСК, надо обязательно знать:

  1. Общие параметры датума, эллипсоида. Параметры датума могут быть пользовательскими и задаваться вручную.

  2. Параметры центрального меридиана.

  3. Параметры восточного и северного смещения.

Пример 2

У широко известного слоя Google мировая проекция Сферического Меркатора WGS84, и она спроецирована таким образом, что имеются определенные искажения. Если посмотреть, то визуально кажется, что Гренландия больше, чем Южная Америка, хотя в реальности это не так. В случае если данные слоя созданы и обведены поверх подложки Google и проекция слоя – план-схема, то и линейные размеры у объектов слоя будут искажены. Чем дальше от экватора, тем больше коэффициент искажения. Таким образом, данный слой должен иметь любую географическую проекцию, при этом, даже если слой отрисован с визуальными искажениями, размеры объектов будут браться по сферической системе измерений – в натуральную величину.

Ниже представлена разница в длине между Гренландией и Южной Америкой.

Измерение размеров Гренландии и Южной Америки

Рисунок 36. Измерение размеров Гренландии и Южной Америки

На картинке ниже видно, что чем дальше расстояние от экватора, тем сильнее искажения. Если сопоставить реальные размеры Гренландии и Южной Америки, то мы увидим существенную разницу.

Сопоставление размеров Гренландии и Южной Америки

Рисунок 37. Сопоставление размеров Гренландии и Южной Америки


Теоретическая информация

  • «Географические координаты»

  • «Геоид, эллипсоид, датум»

Географические координаты

С помощью географических координат можно определить положение точки на земной поверхности, это самая распространенная система координат. Она образована сеткой меридианов и параллелей. Координатами в данной системе являются широта и долгота.

Широта – это угол между отвесной линией в данной точке и плоскостью экватора, отсчитываемый от 0 до 90 градусов в обе стороны от экватора. Географическую широту точек, лежащих в северном полушарии, (северную широту) принято считать положительной, широту точек в южном полушарии – отрицательной.

Долгота – это угол между плоскостью меридиана, проходящего через данную точку, и плоскостью начала меридиана, от которого ведется отсчет долготы. Долготы от 0 до 180 градусов к востоку от начала меридиана называют восточными, к западу – западными. Восточные долготы принято считать положительными, западные – отрицательными.

Географические координаты подойдут для определения местоположения объекта, но не подойдут для определения таких характеристик, как длина, площадь и прочих, так как географические широта и долгота не являются однозначными единицами измерения. Градус широты равен градусу долготы только на экваторе. Чтобы решить данную задачу, данные переводятся из сферических географических координат в прямоугольные спроектированные координаты.


Геоид, эллипсоид, датум

Чаще всего известную форму земли называют «геоидом». Данный термин был предложен в 1873 году немецким физиком Иоганном Бенедиктом Листингом. Определение термина геоид основано на том, что любая поверхность воды в спокойном состоянии (в чашке, ванне, море) является уровненной поверхностью. Вода всегда растекается так, что ее поверхность перпендикулярна к направлению силы тяжести. Такая поверхность принята за математическую поверхность земли, или «уровень моря», от которого отсчитывают высоты точек земной поверхности. Поверхность геоида, в отличие от физической поверхности земли, гладкая, но весьма неправильная из-за неравномерности распределения масс внутри планеты. Вследствие этого геоид по форме больше похож не на шар, а на грушу. Форма геоида весьма сложна и зависит от распределения масс и плотностей в теле земли.

Установить точное положение геоида под материками невероятно сложно, так как для математического выражения геоида используются коэффициенты сферических гармоник. Например, некоторые геоиды используют коэффициенты сферических гармоник для полиномов до 360 порядка, и для полного уравнения требуется более 60 000 коэффициентов. Для расчета поверхности это все слишком сложно. По этой причине используется более простая фигура, но с достаточной точностью описывающая землю.

Для упрощения математических расчетов используется более удобный двухосный эллипсоид вращения, при этом он не сильно отличается от формы земли. Поверхности эллипсоида и геоида отличаются в пределах 100 метров в ту или иную сторону.

Форма эллипса определяется двумя радиусами. Более длинный радиус называется большой полуосью (как правило, обозначается буквой a), а меньший (короткий) – малой полуосью (как правило, обозначается буквой b).

Рисунок 38. Эллипсоид

Эллипсоид вращения, который наилучшим образом согласуется с поверхностью геоида, называют общеземной эллипсоид или эллипсоид земли.

Эллипсоид, который наилучшим образом согласуется с геоидом на ограниченной части его поверхности, называется референц-эллипсоид (от лат. referens – вспомогательный).

Эллипсоид вращения может быть определен либо большой полуосью, a, и малой полуосью, b, либо величиной a и сжатием.

Сжатие – это разность в длине между двумя осями, выраженная простой или десятичной дробью:

f = (a- b) / a

Сжатие является маленькой величиной, поэтому, как правило, вместо него используется величина 1/f.

Далее представлены некоторые референц-эллипсоиды и их параметры:

Эллипсоид | Год | Большая полуось (а), м | 1/f
Крассовский | 1940 | 6 378 245 | 298.299 738 1
WGS-72 | 1972 | 6 378 135 | 298.26
GRS – 80 | 1979 | 6 378 137 | 298,25
WGS 84 | 1984 | 6378137 | 298.257223563
ПЗ-90 | 1990 | 6 378 136 | 298.258

Помимо эллипсоида, в геодезии используется такое понятие, как датум. Датум (лат. Datum) – набор параметров, используемых для смещения и трансформации референц-эллипсоида в локальные географические координаты. Понятие датум используется в геодезии и картографии для наилучшей аппроксимации к геоиду в данном месте.

Датум задается смещением референц-эллипсоида по осям: X, Y, Z, а также поворотом декартовой системы координат в плоскости осей на угол rX, rY, rZ. Также необходимо знать параметры референц-эллипсоида а и f, где а – размер большой полуоси, f – сжатие эллипсоида.

Существуют два типа датумов – геоцентрический (глобальный) и локальный. Геоцентрический датум использует центр масс земли в качестве начала отсчета. Начало отсчета системы координат для локального датума сдвинуто относительно центра земли. Локальный датум изменяет положение эллипсоида так, чтобы наиболее близко совместить его поверхность с нужной областью. Локальный датум не следует применять вне области, для которой он был разработан.

Наиболее широко используемым датумом является Мировая геодезическая система 1984 года (World Geodetic System 1984 – WGS84), он базируется на эллипсоиде WGS-84 с центром в центре масс земли. Также одним из достаточно распространенных датумов (используется в России и некоторых окружающих странах) является Pulkovo-1942 (СК-42), который базируется на эллипсоиде Крассовского. Начало координат у него смещено относительно центра масс на расстояние около 100 м.

Система WGS-84 широко применяется за рубежом, ее используют практически для всех данных, производимых в мире. Также она используется практически во всех навигаторах. СК-42 широко используется в российской картографии, на ней основываются все топографические материалы ВТУ ГШ РФ (Военно-топографического управления Генерального штаба Российской Федерации).

Далее представлены некоторые датумы:

Датум | Описание
WGS84 (World Geodetic System 1984) | Глобальный датум, использующий геоцентрический общемировой эллипсоид, вычисленный по результатам точных спутниковых измерений. Используется в системе GPS. В настоящее время принят как основной в США.
Пулково-1942 (СК-42, Система координат 1942) | Локальный датум, использующий эллипсоид Крассовского, максимально подходящего к европейской территории СССР. Основной (по распространенности) датум в СССР и постсоветском пространстве.
ПЗ-90 (Параметры Земли 1990) | Глобальный датум, основной (с 2012 года) в Российской Федерации (используются для глобальной навигационной спутниковой системы ГЛОНАСС).
СК-95 (система координат 1995) | Локальная система координат, используется в России (с 2002) для издания карт и геодезических работ.

Поддерживаемые ZuluGIS датумы приведены в приложении: Таблица 18, «Датумы».


Проекция

Поверхность земли имеет сферическую форму, поэтому приходится каким-то образом изображать реальный мир в плоской или планарной системе координат. При создании карт эллипсоид вращения должен быть развернут на плоскость. Понятно, что он не может быть развернут на плоскости без складок или разрывов, поэтому при создании карт прибегают к помощи картографических проекций, в которых отображение поверхности земли или иного небесного тела происходит по строгим математическим законам. Эти законы выражают функциональную связь координат точек на поверхности эллипсоида вращения и плоскости (карте). В основу такого отображения положена система географических или геодезических координат, координатными линиями которой являются меридианы и параллели.

Различные проекции имеют разные типы искажений. Некоторые проекции разработаны с учетом минимизации искажений одной или двух характеристик данных. Проекция может сохранять площадь объектов, но изменять их форму. Растяжение и сжатие отдельных частей изображения картографируемой поверхности в той или иной проекции неизбежно сопровождается искажениями длин, площадей и углов. В одних проекциях можно избежать искажения углов, в других – площадей, но длины линий будут искажены во всех проекциях, за исключением отдельных точек или некоторых линий на карте, о чем мы поговорим несколько позже.

Картографические проекции предназначены для определенных целей. Так, некоторые картографические проекции могут использоваться для отображения крупномасштабных объектов на ограниченной площади, другие – для составления мелкомасштабных карт мира.

Проекции классифицируются по следующим основным признакам:

  • по характеру искажений;

  • по виду нормальной сетки параллелей и меридианов;

  • по ориентировке вспомогательной поверхности.

По характеру искажений различают проекции:

  • Равновеликие – в них отсутствует искажение площадей. Значительны искажения углов и форм. Такие проекции часто используются для землеустроительных целей, измерения площадей и картографирования плотности населения, а также для исследований одной определённой области.

  • Равноугольные – в них отсутствует искажения углов, вследствие этого в них не искажаются формы фигур, а масштаб длин в любой точке остается одинаковым по всем направлениям. В этих проекциях карты больших территорий отличаются значительным искажением площадей. Весьма удобны для решения навигационных задач. Угол на местности всегда равен углу на карте, линия прямая на местности, прямая на карте. Главным примером данной проекции является поперечно-цилиндрическая Проекция Меркатора (1569 г.), она до сих пор используется для морских навигационных карт.

  • Произвольные – в них имеются искажения и углов, и площадей, но в значительно меньшей степени, чем в равновеликих и равноугольных проекциях, поэтому они используются чаще всего.

    Среди них особое место занимают равнопромежуточные проекции, в которых масштаб длин по одному из главных направлений сохраняется постоянным.

По по виду нормальной сетки параллелей и меридианов различают проекции:

  • Конические – это проекции, в которых поверхность эллипсоида переносится на боковую поверхность касательного к нему (а) или секущего его конуса (б), а затем последний разрезается по образующей его линии и развертывается в плоскость. В конических проекциях параллели – это дуги одноцентренных окружностей, а меридианы – прямые линии, сходящиеся в одной точке (полюсе) под углами, пропорциональными разности долгот (в). В таких проекциях искажения не зависят от долготы. Особо пригодны для территорий, вытянутых вдоль параллелей. Карты всей территории СССР часто составляются в равноугольных и равнопромежуточных конических проекциях.

    Рисунок 39. Коническая проекция

  • Цилиндрические – это проекции, в которых происходит проектирование земной поверхности на боковую поверхность цилиндра, которая потом разворачивается в плоскость. Цилиндр может быть касательным к земному шару или секущим его. В первом случае длины сохраняются по экватору. Во втором – по двум стандартным параллелям.

    Цилиндрические проекции бывают прямые, косые и поперечные. В прямых цилиндрических проекциях одни и те же участки поверхности изображаются одинаково вдоль линии разреза в восточной и западной частях карты, что обеспечивает удобство чтения карты по широтным поясам. Косые цилиндрические проекции имеют географическую сетку, которая дает представление о сферичности земного шара. С уменьшением широты полюса кривизна параллелей увеличивается, а их протяженность уменьшается, что дает представление о сферичности земли.

    Цилиндрические проекции применяются при составлении карт мелких и крупных масштабов – от общегеографических до специальных. Так, например, аэронавигационные маршрутные полетные карты чаще всего составляются в косых и поперечных цилиндрических равноугольных проекциях (на шаре).

    Рисунок 40. Цилиндрическая проекция

  • Азимутальные – проекции, в которых параллели нормальной сетки есть концентрические окружности, а меридианы – их радиусы, расходящиеся из общего центра параллелей под углами, равными разности долгот. Каждая точка на карте имеет тот же самый азимут по отношению к среднему меридиану, который эта же точка имеет со средним меридианом на сфере. Название азимутальных проекции получили благодаря основному их свойству сохранять без искажений азимуты линий, выходящих из точки касания картинной плоскости.

    Рисунок 41. Азимутальная проекция

    Применяются прямые, косые и поперечные азимутальные проекции, что определяется широтой центральной точки проекции, выбор которой зависит от расположения территории. Меридианы и параллели в косых и поперечных проекциях изображаются кривыми линиями, за исключением среднего меридиана, на котором находится центральная точка проекции. В поперечных проекциях прямой изображается также экватор: он является второй осью симметрии.

  • Псевдоконические – проекции, у которых параллели изображаются дугами концентрических окружностей, один из меридианов, называемый средним, – прямой линией, а остальные – кривыми, симметричными относительно среднего. Примером псевдоконической проекции может служить равновеликая псевдоконическая проекция Бонна.

  • Псевдоцилиндрические – проекции, в которых все параллели изображаются параллельными прямыми, средний меридиан – прямой линией, перпендикулярной параллелям, а остальные меридианы – кривыми. При этом средний меридиан является осью симметрии проекции. Псевдоцилиндрические проекции в основном применяются для изображения всей земной поверхности или значительных ее частей в мелких масштабах. По этой причине земная поверхность принимается за поверхность шара с радиусом R. Эти проекции имеют две оси симметрии – экватор и средний меридиан нормальной сетки. Косые и поперечные псевдоцилиндрические проекции используются крайне редко.


Проекция Гаусса-Крюгера

Проекция Гаусса-Крюгера – это поперечная цилиндрическая равноугольная картографическая проекция, разработанная немецкими учёными Гауссом и Крюгером. Применение этой проекции даёт возможность практически без существенных искажений изобразить довольно значительные участки земной поверхности и, что очень важно, построить на этой территории систему плоских прямоугольных координат.

В 1928 г. на III геодезическом совещании для всех геодезических и топографических работ в СССР была принята проекция Гаусса-Крюгера на эллипсоиде Бесселя. В этой проекции начали создавать топографические карты масштабов крупнее 1:500 000, а с 1939 г. проекция Гаусса-Крюгера стала применяться и для карты масштаба 1:500 000. В апреле 1946 г. постановлением правительства были утверждены размеры референц-эллипсоида Крассовского и новые исходные даты, характеризующие систему координат 1942 г.

В проекции Гаусса-Крюгера поверхность эллипсоида на плоскости отображается по меридианным зонам, ширина которых равна 6° (для карт масштабов 1:500 000-1:10 000) и 3° (для карт масштабов 1:5 000- 1:2 000). Меридианы и параллели изображаются кривыми, симметричными относительно осевого меридиана зоны и экватора, однако их кривизна настолько мала, что западная и восточная рамки карты изображаются прямыми линиями. Параллели, совпадающие с северной и южной рамками карт, изображаются прямыми на картах крупных масштабов (1:2 000-1:50 000), на картах мелких масштабов они изображаются кривыми. Начало прямоугольных координат каждой зоны находится в точке пересечения осевого меридиана зоны с экватором. В России принята нумерация зон, отличающаяся от нумерации колонн карты масштаба 1:1 000000 на тридцать единиц, то есть крайняя западная зона с долготой осевого меридиана L=21 имеет номер 4, к востоку номера зон возрастают. Номер зоны N и долгота осевого меридиана L° в градусах связаны между собой равенством L° == 6N- 3.

Территория России находится в северном полушарии, поэтому координаты ^ Х всех точек имеют положительное значение. Координаты Y имеют отрицательные значения левее осевого меридиана и положительные правее его. Чтобы исключить из обращения отрицательные координаты и облегчить пользование прямоугольными координатами на топографических картах, ко всем координатам Y добавляют постоянное число 500 000 м. Для указания зоны, к которой относятся координаты, к значению Y слева приписывают номер зоны. Например, запись координаты Y" 30 786 543 м означает, что точка находится в 30-й зоне, ее реальная координата равна 786 000- 500 000 = 286 543 м, то есть она расположена правее осевого меридиана 30-й зоны. Запись координаты Y= 8 397 720 м означает, что точка находится в 8-й зоне, ее реальная координата равна 397 720- 500 000 = 102 280 м, она расположена левее осевого меридиана 8-й зоны.

Рисунок 42. Проекция Гаусса-Крюгера

При создании любых карт важное значение имеет вопрос о выборе картографической проекции, которая обеспечит возможность оптимального решения различных задач по этим картам. Какая проекция будет использована при работе в первую очередь зависит от назначения карты и её масштаба, которыми часто обусловливается характер допускаемых искажений в избираемой проекции. Также существуют методики по выбору проекций.

Карты крупных и средних масштабов, предназначенные для решения метрических задач, обычно составляют в равноугольных проекциях, а карты мелких масштабов, используемые для общих обозрений и определения соотношения площадей каких-либо территорий, – в равновеликих. При выборе проекций начинают с простейших, затем переходят к более сложным проекциям, даже, возможно, модифицируя их.

Для изображения России удобны конические проекции, в которых воображаемый конус рассекает земной шар по параллелям 47 и 62° северной широты: на создаваемых подобным образом картах это так называемые линии нулевых искажений. Вблизи них сжатия и растяжения невелики, что удобно, поскольку между ними находятся самые густонаселённые области. Карты Северного Ледовитого океана или Антарктиды чаще всего составляются в азимутальной проекции, расположив воображаемую вспомогательную плоскость так, чтобы она касалась полюса. Тогда растяжения в полярных областях земли окажутся минимальными. В современной картографии достаточно большой набор проекций для любых карт (планета в целом, материки и океаны, страны и т. д.) и всевозможного назначения.

Для того, чтобы перейти из одной системы координат в другую, используется набор параметров, которые определяют отличие эллипсоида, на котором базируется одна СК, от другого. Это так называемые линейные элементы трансформирования, определяющие сдвиг центра масс эллипсоида относительно общеземного, и угловые элементы трансформирования, определяющие, соответственно, поворот эллипсоида относительно общеземного. Если видно, что какие-то данные равномерно смещены относительно других слоев на одинаковую величину, то, скорее всего, используются данные, находящиеся в разных системах координат.


Импорт параметров системы координат

Для удобства назначения проекции возможен импорт параметров системы координат из различных источников. Диалог импорта может быть вызван при:

  • привязке растрового слоя;

  • перепроецировании растрового слоя;

  • создании векторного слоя;

  • перепроецировании векторного слоя;

  • назначении проекции слою;

  • копировании слоя;

  • настройки проекции карты;

  • и в других случаях, когда необходимо задать проекцию.

Диалог выбора импорта

Рисунок 43. Диалог выбора импорта

Импорт из слоя

Позволяет импортировать из указанного локального или серверного слоя ZuluGIS. Для импорта надо нажать кнопку Импорт из слоя и указать слой, из которого будет импортирована проекция.

Импорт из файла PRJ

Считывает параметры проекции из файлов описаний систем координат, которые хранятся в специальных файлах с расширением .prj. Для импорта надо нажать кнопку Импорт из файла PRJ и указать файл, из которого будет импортирована проекция.

Строка WKT

Использует параметры проекции из строки текста, указанной в форме Well-Known Text (WKT). Для импорта надо нажать кнопку Строка WKT и в открывшемся окне ввести строку.

http://www.opengeospatial.org/standards/wkt-crs

https://en.wikipedia.org/wiki/Well-known_text#Coordinate_reference_systems

Пример строки wkt:

PROJCS["User",GEOGCS["GCS_PULKOVO_1942",DATUM["PULKOVO_1942",
        SPHEROID["USER",6378245.000000,298.300000],
        TOWGS84[28.000000,-130.000000,-95.000000,0.000000,0.000000,
        0.000000,0.000000]],PRIMEM["Greenwich",0],
        UNIT["Degree",0.017453292519943295]],PROJECTION["Transverse_Mercator"],
        PARAMETER["False_Easting",5500000.000000],PARAMETER["False_Northing",0.000000],
        PARAMETER["Central_Meridian",27.000000],PARAMETER["Scale_Factor",1.000000],
        PARAMETER["Latitude_Of_Origin",0.000000],UNIT["Meter",1.0]]

Строка MapInfo.prj

Использует параметры проекции из строки текста, указанной в форме строки MapInfo.prj. Для импорта надо нажать кнопку Строка MapInfo.prj и в открывшемся окне ввести строку.

Пример строки из файла MapInfo.prj:

CoordSys Earth Projection 8, 9999, 3, 28.000000, -130.000000, -95.000000, 0.000000, 0.000000,
         0.000000, 0.000000, 0, "m", 27.000000, 0.000000, 1.000000, 5500000.000000, 0.000000

Строка proj4

Использует параметры проекции из строки текста, указанной в форме строки proj4. Формат используется многими программами, одна из которых ГИС QGIS. Для импорта надо нажать кнопку Строка proj4 и в открывшемся окне ввести строку.

Пример строки proj4:

+proj=tmerc +lat_0=0 +lon_0=37.98333333333 +k=1 +x_0=1300000 +y_0=-4511057.628 +ellps=krass
+towgs84=23.57,-140.95,-79.8,0,0.35,0.79,-0.22 +units=m +no_defs


Карта

  • «Создание карты»

  • «Открытие карты»

  • «Загрузка слоя в карту»

  • «Настройка порядка отображения слоев»

  • «Группировка слоев карты»

  • «Исключение слоя из карты»

  • «Сохранение и дублирование файла карты»

  • «Копирование карты»

  • «Закрытие карты»

  • «Навигация по карте»

  • «Настройка карты»

  • «Закладки карты»

  • «Особенности работы с картами ZuluServer»

  • «Упаковка карты (архивация)»

Как уже ранее говорилось, карта является документом системы ZuluGIS. Она содержит список слоев. Для наглядности слои можно представить как прозрачные пленки, расположенные друг под другом. Слои в карте можно перемещать в нужном порядке. Каждый слой импортируется или разрабатывается самостоятельно пользователями. Чаще всего он содержит определенный тип информации, например, это может быть слой инженерных сетей, слой кварталов или слой зданий.

Если данные хранятся в формате, поддерживаемом ZuluGIS, то их можно добавить непосредственно на карту в виде слоя. В том случае, если требуется использовать данные неподдерживаемого формата, то их можно сначала импортировать и далее добавить в карту.

Существует ряд так называемых «базовых» слоев с картографической подложкой, они являются подключенными слоями Tile-серверов. Использование данных слоев может упростить работу, особенно на начальном этапе. Они уже добавлены в меню системы, для их загрузки потребуется доступ к интернету. Как добавить такие слои, можно узнать в разделе «Добавление «базового» слоя «подложки» с Tile-сервера».

В каждой карте индивидуально могут быть настроены режимы видимости слоя, параметры отображения, масштаб отображения, проекции, закладки и макеты.

[Примечание] Примечание

Важно запомнить, что карта НЕ содержит графической информации. Вся графическая информация находится в слоях, а карта хранит список их имен и параметры их отображения. При этом физически слои и файлы карты могут располагаться на компьютере в разных местах.


Создание карты

  • «Загрузка слоя в карту»

  • «Настройка порядка отображения слоев»

  • «Группировка слоев карты»

При запуске ZuluGIS автоматически создается новая карта с названием «Карта1». Также можно создать карту самостоятельно. Создать карту можно несколькими способами:

  • выберите пункт главного меню Файл|Создать|Новая Карта

    или

  • нажмите клавиши Ctrl+N

    или

  • нажмите на панели инструментов кнопку

    или

  • в панели Рабочее место подведите курсор к пункту [image] Карты, сделайте щелчок правой кнопкой мыши и выберите пункт [image] Новая карта.

При любом из вышеперечисленных действий на экране появится пустое окно карты с формальным пользовательским названием, например «Карта2».


Открытие карты

[Примечание] Примечание

Для того чтобы карта открывалась с восстановлением последнего местоположения, которое было до ее закрытия, следует в настройках параметров системы установить соответствующую опцию (Сервис|Параметры, вкладка Карта, параметр Восстанавливать последнее местоположение).

Есть несколько вариантов открытия карты в ZuluGIS.

Для открытия карты:

  1. Выберите пункт главного меню Файл|Открыть

    или

    нажмите на панели инструментов кнопку

    или

    нажмите клавиши Ctrl+O

    или

    в панели Рабочее место подвести курсор к пункту [image] Карты, сделайте щелчок правой кнопкой мыши и выберите пункт [image] Открыть карту.

  2. В открывшемся стандартном диалоге выбора файла укажите диск, каталог и имя файла карты (расширение ZMP). При работе в серверной версии (ZuluServer) карта загружается с сервера геоданных. Для доступа к нему надо нажать кнопку Серверы геоданных [image] , расположенную в левой части окна.

  3. Нажмите кнопку Открыть.

[Примечание] Примечание

Цвет иконок в панели Рабочее место карт, открытых с локальной машины и с сервера, отличается. У карты с локальной машины иконка зеленого цвета: , у карты с сервера иконка сиреневого цвета: .

[Примечание] Примечание

Список последних открывавшихся системой карт автоматически добавляется в конец меню Файл или вызывается нажатием стрелки на кнопке [image] панели инструментов. Количество последних открытых карт, выводимых в меню, устанавливается в диалоге Параметры (меню Сервис|Параметры, вкладка Общие, раздел Списки последних файлов).

Иногда при открытии карты может открыться диалоговое окно, изображенное на рисунке ниже.

Оно может появиться в нескольких случаях:

  • был удален или перемещен слой, который ранее находился в карте;

  • была удалена или перемещена база данных, используемая слоем.

    Диалоговое окно Не найден слой

    Рисунок 44. Диалоговое окно Не найден слой

В зависимости от того, в каком случае возник этот диалог, меняется его название: например, если не обнаружен слой, то название диалога будет Не найден слой.

Если объект был перемещен, то надо проделать следующие действия:

  1. В верхней строке указать новый путь до объекта, то есть указать, в какую папку он был перемещен (для открытия стандартного окна выбора файла воспользуйтесь кнопкой Обзор...). После указания нового пути в диалоге отразится реальное и пользовательское название объекта.

  2. Нажать кнопку Изменить путь, после чего до объекта будет установлен новый путь.

Если ZuluGIS не обнаружила несколько объектов, то после нажатия кнопки Изменить путь появится диалог о замене пути.

При нажатии на кнопку Да система автоматически пропишет новый заданный путь для всех объектов, которые не были найдены. Нажимать эту кнопку надо в том случае, когда все объекты были перемещены в одно место.

В том случае, если объекты расположены в разных папках, надо нажать кнопку Нет. После этого произойдет возврат к диалоговому окну Не обнаружен объект, в котором надо указать новый путь для следующего объекта.

При нажатии кнопки Игнорировать система пропускает указанный файл и не загружает его, но в следующий раз система будет вновь пытаться найти файл по указанному пути. Если требуется удалить сохранившуюся ссылку на отсутствующий объект, нажмите кнопку Удалить.

[Подсказка] Подсказка

Метод ZuluCommDlg.ShowOpen (1) открывает стандартное окно выбора файла. Маска для открытия карты = 1.


Загрузка слоя в карту

  • «Добавление слоев в карту»

  • «Добавление слоя из списка последних загружаемых слоев»

  • «Добавление слоя из открытой карты»

  • «Добавление слоя через диалог Загруженные слои»

  • «Добавление «базового» слоя «подложки» с Tile-сервера»

Перед добавлением слои должны быть предварительно созданы или импортированы. Слой может добавляться с локальной машины или с сервера. Если слой ранее добавлялся, то его можно выбрать из списка последних загруженных слоев. Также слой в карту можно добавить из другой открытой карты с использованием панели Рабочее место.

После добавления слоев в карту можно настроить их порядок отображения и сгруппировать их.

[Примечание] Примечание

Если слой уже добавлен в карту, то повторная его загрузка не произойдет.

В карту могут быть добавлены:

  1. Слои ZuluGIS (*.b00, *.zrs, *.zrg, *.zl, *.zww, *.zpr, *.gpx, *.plt*, *.xml).

  2. Файлы изображений (*.bmp, *.jpg, *.jpeg, *.tif, *.tiff, *.gif, *.png, *.pcx, *.svg, *.heic).

  3. Растры MapInfo (*.tab).

  4. Растры OziExplorer (*.map).

  5. Растровые объекты в формате World File (*.bpw, *.bmpw, *.tfw, *.tifw, *.jgw, *.jpgw, *.gfw, *.gifw, *.pgw, *.pngw).

  6. Файлы хранения и обмена данными GPS в формате GPX (GPS eXchange Format)(*.gpx).

  7. Тайлы в формате .sqlitedb (*.sqlitedb).

  8. Тайлы в формате MapBox MB Tiles (*.mbtiles).

[Примечание] Примечание

Цвет иконок в панели Рабочее место слоев, открытых с локальной машины и с сервера, отличается. Например, у векторного слоя с локальной машины иконка зеленого цвета: , а у векторного слоя с сервера геоданных иконка сиреневого цвета: .


Добавление слоев в карту

Для добавления слоя в карту:

  1. Выберите пункт главного меню Карта|Добавить слой, нажмите на панели инструментов кнопку [image] или нажмите правой кнопкой мыши по названию карты в панели Рабочее место и выберите в открывшемся контекстном меню пункт [image] Добавить слой.

  2. Помимо стандартных слоев, в ZuluGIS можно добавлять различные типы файлов, поэтому имеется возможность выбрать фильтр на нужный тип данных. Фильтр выбирается из списка Тип файлов:

    Переключение фильтра на тип файлов

    Рисунок 45. Переключение фильтра на тип файлов

    • векторный слой, растровый объект, группа растровых объектов, слои с серверов, поддерживающих спецификацию WMS, тайловые слои – данный фильтр стоит по умолчанию (Слои Zulu (*.b00; *.zrs; *.zrg; *.zl; *.zww; *.ztr; *.gpx, *.plt, *.xml))

    • файлы изображений (формат *.bmp, *.jpg, *.jpeg, *.tif, *.tiff, *.gif, *.png, *.pcx, *.svg, *.heic) – из списка Тип файлов выбрать Файлы изображений (формат *.bmp, *.jpg, *.jpeg, *.tif, *.tiff, *.gif, *.png, *.pcx, *.svg, *.heic);

    • растры MapInfo – из списка Тип файлов выбрать растры MapInfo (*.tab);

    • растры OziExplorer – из списка Тип файлов выбрать растры OziExplorer (*.map);

    • растровые объекты в формате World File – из списка Тип файлов выбрать World file ESRI (*.bpw, *.bmpw, *.tfw, *.tifw, *.jgw, *.jpgw, *.gfw, *.gifw, *.pgw, *.pngw);

      [Примечание] Примечание

      Для успешного добавления растровых данных сторонних программ в ZuluGIS растры и их описатели должны храниться в одной папке.

    • файлы хранения и обмена данными GPS в формате GPX (GPS eXchange Format) – из списка Тип файлов выбрать GPS eXchange Format (*.gpx);

    • тайловые данные, хранящиеся в базе данных в формате SQLITE – из списка Тип файлов выбрать Тайлы в формате .sqlitedb (*.sqlitedb) (в настоящей версии система читает базы с расширением .sqlitedb, где есть таблица с числовыми полями zoom или z, x, y и поле BLOB для хранения тайлов);

    • тайловый слой в виде базы данных SQLITE по спецификации MapBoxMBTiles – из списка Тип файлов выбрать Тайлы в формате MapBox .mbtiles (*.mbtiles).

  3. Далее укажите добавляемый слой. При работе в серверной версии (ZuluServer) слой должен выбираться с сервера геоданных. Для доступа к нему надо нажать кнопку [image] Серверы геоданных, расположенную в левой части окна. После выбора слоя нажать кнопку Открыть.

В результате проделанных действий произойдет загрузка данных в текущую карту. Загруженный слой добавляется в конец списка слоев карты, исключение – тайловые слои, они добавляются в начало списка. Если выбранный слой уже был загружен, то его вторичная загрузка в эту карту не производится.


Добавление слоя из списка последних загружаемых слоев

Для такой загрузки:

  1. Нажмите стрелку на кнопке [image] .

  2. Из списка последних загруженных системой слоев выберите требуемый слой.

Количество последних открытых слоев, выводимых в меню, регулируется в диалоге Параметры.

[Примечание] Примечание

  • Чтобы добавить в карту слой с сервера, поддерживающего спецификацию WMS, нужно предварительно сохранить этот слой в системе. Узнать, как это сделать, можно в разделе Задание WMS слоя.

  • После добавления файла изображения в карту необходимо сохранить его описатель (файл, содержащий координаты).

  • При добавлении файла описателя растрового объекта MapInfo/OziExplorer преобразование файла описателя в формат ZuluGIS не производится, но может быть проведено дополнительно.

[Подсказка] Подсказка

Слой можно добавить методом MapDoc.Layers.Add.


Добавление слоя из открытой карты

Для загрузки слоя из открытой карты предварительно в ZuluGIS должны быть загружены карта, из которой надо добавить слой, и карта, в которую слой будет добавляться. Так как такая загрузка осуществляется через панель Рабочее место, то она, соответственно, тоже должна быть открыта. Далее:

  1. В панели Рабочее место подведите курсор к слою, который должен быть добавлен в карту, нажмите левую клавишу мыши и, не отпуская, переместите курсор к названию карты, в которую надо переместить слой (a).

  2. Отпустите левую клавишу мыши, слой добавлен (b).

    Загрузка слоя из открытой карты

    Рисунок 46. Загрузка слоя из открытой карты


Добавление слоя через диалог Загруженные слои

Чтобы добавить слой из диалога Загруженные слои, сначала данный диалог надо открыть. Для этого выберите меню Карта|Слои или нажмите на панели инструментов кнопку [image] . Далее:

  1. В диалоге нажмите кнопку Добавить, после чего откроется окно выбора файла слоя.

  2. Укажите на диске добавляемый слой. При работе в многопользовательской версии (ZuluServer) слой должен располагаться на Сервере геоданных. Для доступа к нему надо нажать кнопку [image] Серверы геоданных, расположенную в левой части окна.

  3. После выбора слоя нажмите кнопку Открыть.


Добавление «базового» слоя «подложки» с Tile-сервера

[Предупреждение] Предупреждение

По умолчанию «базовые» слои с Tile-серверов добавляются в карту как локальные и могут быть сохранены только в локальной карте. При попытке сохранить серверную карту с такими слоями будет выдано сообщение об ошибке: Не сохранить карту. Слой не является слоем сервера. Для использования слоев в серверной карте их необходимо перенести на сервер. Чтобы перенести слой на сервер, воспользуйтесь операцией копирования слоя на сервер. Для работы удобнее, чтобы все тайловые слои хранились на сервере в одной папке, например, Tile. Далее для работы следует добавлять уже слой, скопированный с сервера.

В ZuluGIS можно использовать картографические данные сторонних Tile-серверов. Вы можете настроить подключение таких Tile-серверов самостоятельно, а также воспользоваться слоями, уже встроенными в меню.

Описанные далее слои будут загружены со сторонних Tile-серверов в виде растровых изображений, нарезанных на небольшие части – плитки или тайлы (tile). Для их загрузки необходим доступ в интернет. Функционал системы ZuluGIS по загрузке данных с Tile-серверов не предназначен для скачивания данных, защищенных авторским правом, без разрешения их правообладателей.

В меню уже встроены следующие слои Tile-серверов:

  • Космоснимки СКАНЭКС (http://www.scanex.ru/);

  • 2ГИС (http://api.2gis.ru/);

  • OpenStreetMap (http://www.openstreetmap.org):

    • MapQuest Open;

    • MapQuest Satellite;

    • OpenCircleMap;

    • OpenStreetMap;

    • OSM Landscape;

    • OSM Transport;

  • ArcGIS Online (https://www.esri.com/ru-ru/arcgis/products/arcgis-online/overview):

    • NatGeo_World_Map;

    • USA_Topo_Maps;

    • World_Imagery;

    • World_Physical_Map;

    • World_Shaded_Relief;

    • World_Street_Map;

    • World_Terrain_Base;

    • World_Topo_Map.

Для добавления слоя в активную карту выберите соответствующий пункт меню:

  • Космоснимки СКАНЭКС загружаются через меню Слой|Космоснимки СКАНЭКС|Kosmosnimki (base).

  • 2ГИС загружается через меню Слой|2ГИС|2GIS.

  • OpenStreetMap можно загрузить через меню Слой|OpenStreetMap, далее нужно выбрать из списка необходимый слой OpenStreetMap.

  • Слои ArcGIS Online загружаются с использованием меню Слой|ArcGIS Online, далее нужно выбрать из списка необходимый слой ArcGIS Online.


Исключение слоя из карты

  • Исключение слоя из активной карты

  • Исключение слоя через панель Рабочее место

  • Исключение слоя через диалог Загруженные слои

Исключение слоя из окна является операцией, обратной по отношению к загрузке слоя.

[Примечание] Примечание

В результате исключения слоя не происходит его физического уничтожения. Слой просто исключается из списка слоев карты, сам файл слоя остается на диске.

[Подсказка] Подсказка

Слой можно исключить методом MapDoc.Layers.Remove.


Исключение слоя из активной карты

Для исключения слоя из активной карты:

  1. Выберите пункт главного меню Карта|Удалить слой или нажмите на панели инструментов кнопку [image] .

  2. В открывшемся списке выделите слой или несколько слоев (выделение с клавишей Shift или Ctrl ), которые подлежат исключению.

  3. Нажмите кнопку Исключить.


Исключение слоя через панель Рабочее место

Исключить слой из карты также возможно через панель Рабочее место. Для этого надо нажать правой кнопкой мыши по названию слоя в панели Рабочее место и выбрать в открывшемся контекстном меню пункт [image] Удалить из карты:

Исключение слоя из карты

Рисунок 47. Исключение слоя из карты


Исключение слоя через диалог Загруженные слои

Для исключения слоя из диалога Загруженные слои сначала данный диалог надо открыть. Для этого следует выбрать меню Карта|Слои или нажать на панели инструментов кнопку [image] . Далее:

  1. В открывшемся списке выделить слой или несколько слоев (выделение с клавишей Shift или Ctrl ), которые подлежат исключению.

  2. Нажать кнопку Исключить.


Настройка порядка отображения слоев

[Важно] Важно

Настройки отображения слоёв сохраняются при сохранении файла карты. Также можно сохранить настройки отдельного слоя: «Сохранение настроек слоя».

Если в карту добавить новый слой, то он автоматически будет расположен поверх других слоев, за исключением слоя Tile-сервера, который будет размещен под слоями, загруженными в карту ранее. Соответственно, может возникнуть ситуация, когда потребуется настроить отображение слоев, то есть поменять слои карты местами. Например, слои, содержащие крупные объекты, такие как кварталы, должны располагаться под зданиями или инженерными коммуникациями.

Последовательность отображения слоев настраивается через диалог Загруженные слои или через панель Рабочее место. Вы можете перемещать как слои поштучно, так и ранее созданные группы слоев.

Настройка через диалог Загруженные слои

Диалог Загруженные слои можно вызвать, нажав на панели инструментов кнопки [image] или сделав щелчок правой кнопкой мыши по названию карты в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Слои. Для изменения порядка отображения слоя или группы слоев:

  1. Выделите слой или группу в списке слоев.

  2. Произведите перемещение с помощью кнопок Назад и Вперед или мыши. Для этого установите на слой или группу курсор, нажмите левую клавишу мыши и, не отпуская клавишу, переместите объект в нужное место.

    Самый нижний слой в диалоге является самым верхним слоем на карте.

[Примечание] Примечание

Если перед нажатием кнопок Назад и Вперед на клавиатуре нажать и удерживать клавишу Ctrl, то выделенный в списке слой или группа слоев будут перемещены в самый верх или низ списка, соответственно.

Настройка через панель Рабочее место

Так как такая настройка осуществляется через панель Рабочее место, то она, соответственно, должна быть открыта. Далее:

  1. В панели Рабочее место подведите курсор к слою или группе слоев, которые должны быть перемещены, нажмите левую клавишу мыши и, не отпуская, переместите в нужное место. Самый нижний слой в списке является самым верхним слоем на карте.

  2. Отпустите левую клавишу мыши, объект перемещен.


Диалог Загруженные слои

[Важно] Важно

Настройки отображения слоёв сохраняются при сохранении файла карты. Также можно сохранить настройки отдельного слоя: «Сохранение настроек слоя».

Используя данный диалог, можно сделать дополнительную настройку слоев карты. Диалог можно вызвать:

  • через меню Карта|Слои;

  • нажатием на панели инструментов кнопки [image] ;

  • сделав щелчок правой кнопкой мыши по названию карты в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Слои.

Диалог «Загруженные слои»

Рисунок 48. Диалог «Загруженные слои»

Диалог Загруженные слои позволяет:

  • Изменить порядок следования слоев карты

  • Добавить слой в карту

  • Группировать слои карты

  • Исключить слой из карты

  • Изменить параметры настройки слоя

  • Сохранить текущие настройки слоя

  • Настроить отображение группы слоев

  • Назначить проекцию слою

  • Изменить структуру слоя

  • Назначить сочетание клавиш для быстрой активизации слоя на карте

  • Изменить атрибуты слоя

    В списке слоев щелчком левой кнопки мыши можно установить атрибуты для каждого слоя:

    Таблица 3.

    символ отображается в том случае, если у слоя назначена проекция, отличная от план/схемы;

            отменить выделенную группу объектов (если имеются);

    слой является активным (может быть только один слой из списка);

    устанавливает/отменяет редактирование слоя;

    устанавливает/отменяет признак отображения слоя на экране (если кнопка серого цвета, то слой не отображается). Активный слой не может быть скрытым, так как он обязательно должен выводиться на экран. Также слой можно сделать невидимым на карте, сделав щелчок левой кнопкой мыши по иконке рядом с названием слоя в панели Рабочее место.

  • Показывать имена файлов

    Для вывода полных имен файлов слоев, загруженных в карту, установите флажок Показывать имена файлов.

Для подтверждения всех произведенных действий нажмите кнопку ОК, а для отмены новых установок – Отмена.


Настройка отображения группы слоев

Диалог Параметры видимости слоев позволяет провести групповую настройку видимости слоев. Настройка слоев карты производится в диалоге Загруженные слои, диалог можно вызвать нажатием на панели инструментов кнопки [image] .

Для настройки отображения группы слоёв:

  1. Откройте диалог Загруженные слои. Диалог можно вызвать, нажав на панели инструментов кнопку [image] или сделав щелчок правой кнопкой мыши по названию карты в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Слои.

  2. Выберите слой или группу слоев (используя клавиши CTRL или SHIFT).

  3. Правой кнопкой мыши откройте контекстное меню и выберите пункт Параметры отображения слоев.

    Параметры отображения слоев

    Рисунок 49. Параметры отображения слоев

  4. В открывшемся окне укажите нужные настройки видимости.

    Параметры видимости слоев

    Рисунок 50. Параметры видимости слоев

  5. Нажмите ОК для сохранения. Указанные опции запишутся в настройках каждого слоя.


Группировка слоев карты

  • Создание группы слоев

  • Перемещение слоев и групп

  • Переименование группы слоев

  • Удаление группы слоев

Использование группировки слоев позволит эффективнее настроить работу со слоями, это особенно актуально при большом количестве слоев. Также для группы возможно одновременное включение/отключение видимости и настройка порядка отображения слоев карты.

Группировка слоев может производиться в дополнительном окне Рабочее место или через диалоговое окно Загруженные слои.

Далее показано отличие несгруппированных слоев в ZuluGIS 8.0 и сгруппированных слоев в ZuluGIS 2021 системы ZuluGIS.

Слева без группировки, справа с группировкой

Рисунок 51. Слева без группировки, справа с группировкой


Создание группы

Вы можете создать группу двумя способами:

  • через диалоговое окно Загруженные слои;

  • с использованием панели Рабочее место.

[Предупреждение] Предупреждение

Произведенные изменения сохраняются только после сохранения карты!

Создание группы через диалоговое окно Загруженные слои

Для создания группы:

  1. Откройте диалог Загруженные слои. Для этого выберите меню Карта|Слои или нажмите кнопку [image] .

  2. Сделайте щелчок правой кнопкой мыши в области списка слоев карты или по названию уже существующей группы. Второй вариант используется, если требуется создать подгруппу. В контекстном меню выберите пункт Добавить группу....

    Добавление группы в карту через диалог Загруженные слои

    Рисунок 52. Добавление группы в карту через диалог Загруженные слои

  3. В появившемся окне введите название создаваемой группы или подгруппы и нажмите кнопку ОК.

    Задание названия для группы

    Рисунок 53. Задание названия для группы

    В диалоге Загруженные слои в конце списка слоев или в ранее указанной группе появится группа с указанным названием. Расположение группы зависит от того, из какого места была вызвано контекстное меню.

  4. Переместить нужные слои в созданную группу.

Создание группы через панель Рабочее место

Для создания группы:

  1. В панели Рабочее место сделайте щелчок правой кнопкой мыши по названию карты, в которой будет создаваться группа, или по названию уже существующей группы. Второй вариант используется, если требуется создать подгруппу. В контекстном меню выберите пункт Добавить группу....

    • Добавление группы в карту через панель Рабочее место

      Рисунок 54. Добавление группы в карту через панель Рабочее место

  2. В появившемся окне введите название создаваемой группы или подгруппы и нажмите кнопку ОК.

    Задание названия для группы

    Рисунок 55. Задание названия для группы

    В окне Рабочее место появится папка [image] с указанным названием.

    Рисунок 56. Созданная группа

  3. Переместите нужные слои в созданную группу.


Перемещение слоев и групп

  • Перемещение через диалог Загруженные слои

  • Перемещение через панель Рабочее место

Переместить можно как слой, так и уже созданную группу слоев, причем в диалоге Загруженные слои возможно групповое перемещение объектов.

[Предупреждение] Предупреждение

Произведенные изменения сохранятся только после сохранения карты!

Перемещение через диалог Загруженные слои

Для перемещения слоя или группы:

  1. Откройте диалог Загруженные слои. Для этого выберите меню Карта|Слои или нажмите кнопку [image] .

  2. Выделите перемещаемые объекты. Для выделения могут быть использованы клавиши Shift или Ctrl.

  3. Далее перемещение может быть произведено двумя способами:

    • Сделайте щелчок правой кнопкой мыши на одном из выделенных объектов и в контекстном меню выберите пункт Поместить в группу.... В появившемся диалоговом окне укажите ранее созданную группу, куда будут перемещены объекты, и нажмите кнопку ОК.

      Перемещение слоя через диалог Загруженные слои

      Рисунок 57. Перемещение слоя через диалог Загруженные слои

      [Примечание] Примечание

      При необходимости в диалоге Переместить в... возможно создание, удаление или переименование группы. Для переименования или удаления надо выделить группу в списке, затем сделать щелчок правой кнопкой мыши в области окна и выбрать нужный пункт меню. Для создания новой группы нажмите кнопку Новая группа или выберите пункт с таким же названием из меню.

      ИЛИ

    • Подведите курсор к одному из перемещаемых объектов, нажмите левую клавишу мыши и, не отпуская, переместите его в область ранее созданной группы. При необходимости можно точно так же переместить саму группу.

      Перемещение слоя через диалог Загруженные слои

      Рисунок 58. Перемещение слоя через диалог Загруженные слои

Перемещение через панель Рабочее место

Для перемещения слоя в созданную группу надо подвести курсор к слою, нажать левую клавишу мыши и, не отпуская, переместить слой в область созданной группы. При необходимости можно точно так же переместить саму группу.

Перемещение слоя через панель Рабочее место

Рисунок 59. Перемещение слоя через панель Рабочее место


Переименование группы слоев

[Предупреждение] Предупреждение

Произведенные изменения сохранятся только после сохранения карты!

Для переименования группы слоев:

  1. Так как переименование можно произвести в дополнительном окне Рабочее место (Окно|Рабочее место) или через диалоговое окно Загруженные слои (Карта|Слои), то, соответственно, нужно предварительно открыть необходимое окно.

  2. Сделайте щелчок правой кнопкой мыши по названию переименовываемой группы. В контекстном меню выберите пункт Переименовать.

  3. В появившемся окне введите новое название и нажмите кнопку ОК.


Удаление группы слоев

[Предупреждение] Предупреждение

Произведенные изменения сохранятся только после сохранения карты!

Для удаления группы слоев надо:

  1. Так как удаление можно произвести в дополнительном окне Рабочее место (Окно|Рабочее место) или через диалоговое окно Загруженные слои (Карта|Слои), то, соответственно, нужно предварительно открыть необходимое окно.

  2. Сделайте щелчок правой кнопкой мыши по названию удаляемой группы. В контекстном меню выберите пункт Разгруппировать.

    [Примечание] Примечание

    При удалении группы слои не удаляются!


Сохранение и дублирование файла карты

  • Сохранение карты

  • Дублирование файла карты

Для сохранения карты надо:

  1. Выбрать пункт главного меню Файл|Сохранить, нажать на панели инструментов кнопку [image] или нажать клавиши Ctrl+S. Также диалог сохранения карты можно вызвать, сделав щелчок правой кнопкой мыши на вкладке карты и выбрав пункт [image] Сохранить Карта 1.

  2. Задать имя и путь до файла. Имя слоя не должно содержать специальные символы, например, \ / | : * ? " < >. При работе в многопользовательской версии (ZuluServer) карта должна располагаться на Сервере геоданных. Для доступа к нему надо нажать кнопку [image] Серверы геоданных, расположенную в левой части окна.

  3. Нажать кнопку Сохранить.

[Предупреждение] Предупреждение

Невозможно сохранить карту с локальными слоями на сервере. Это связано с тем, что карта хранится на сервере и все слои должны браться с сервера. Может возникнуть ситуация, что эту карту может открыть кто-то еще и он не имеет файлового доступа к вашему компьютеру или к другому серверу.

Если возникла такая ситуация, то для ее решения надо скопировать слой на сервер. Затем исключить локальный слой и добавить копию с сервера.

[Примечание] Примечание

Исторически сложилось так, что карта в ZuluGIS имеет два наименования:

  • имя файла – это имя, задаваемое непосредственно файлу, которое будет отображаться, если просматривать расположение файла средствами Windows. Именно оно задается в п.2 выше.

  • пользовательское название – это наименование карты, которое отображается при открытии и дальнейшей работе с картой в ZuluGIS. По умолчанию при создании каждой новой карте присваивается пользовательское название Карта N, где N – порядковый номер созданной карты.

Именно из-за этой особенности для удобной дальнейшей работы рекомендуется каждой созданной карте помимо имени файла задать свое индивидуальное пользовательское название, которое будет отражать суть содержимого карты. Например: Карта города Санкт-Петербурга. Пользовательское название карты задается в настройках карты.

После произведенных действий произойдет запись текущего состояния карты (загруженных в карту слоев с их настройками, масштаба, центра отображения и настроек карты) в файл с расширением ZMP. Если карта уже существовала как объект на диске, то есть была загружена с диска или сохранена ранее, то запись ее текущего состояния произойдет без предупреждений в тот же файл. Если карта являлась временным объектом системы, то есть была открыта как новая карта, то на экране появится диалог сохранения карты в файл.

[Подсказка] Подсказка

Сохранение карты соответствует методу MapDoc.Save.

Дублирование файла карты (сохранение с новым именем)

[Предупреждение] Предупреждение

При дублировании файла карты графическая и семантическая информация НЕ дублируется! Дублирование файла карты – это сохранение нового файла карты с новым названием, со списком слоев и настроек. При таком дублировании слои НЕ КОПИРУЮТСЯ. Их надо дублировать отдельно!

Если требуется произвести полную копию данных, включая слои, базы и все настройки, то следует произвести копирование карты!

Для дублирования файла текущей карты, то есть сохранения его на диске под другим именем, нужно выбрать пункт главного меню Файл|Сохранить как... На экране появится диалог сохранения карты в файл. В нем надо задать диск, каталог и имя файла, в который будет дублироваться карта.

[Подсказка] Подсказка

Сохранение карты на диске под другим именем соответствует методу MapDoc.SaveAs.


Копирование карты

[Примечание] Примечание

Видеоурок по копированию карты можно посмотреть, пройдя по одной из ссылок: https://youtu.be/VYoBCgmeCls или https://www.politerm.com/videos/map/kopirovanie-karty/.

В результате данной операции произойдет копирование самой карты и загруженных в нее слоев, при этом в копии будут сохранены все настройки исходных данных.

[Примечание] Примечание

При копировании карты с локальной машины на сервер помимо копирования производится публикация данных (подготовка локальных данных к работе в серверной версии).

Для копирования карты надо:

  1. Загрузить карту для копирования.

  2. Выбрать пункт главного меню Карта|Операции|Копировать карту.

  3. В открывшемся диалоге нажать кнопку Обзор... и указать диск и каталог для копируемых данных. При работе с серверной версией слева надо выбрать [image] Серверы геоданных, указать нужное соединение и затем каталог в области данных сервера. В строке Имя файла ввести имя для копии файла карты и нажать кнопку Сохранить. Если выбрано имя файла уже существующей карты, то в результате копирования карты существующая будет УНИЧТОЖЕНА, а новая будет создана на месте этого файла.

  4. В строке Название карты автоматически подставляется пользовательское название исходной карты, по желанию его можно изменить.

  5. При установке опции Только геометрия копируется только графическая информация без баз данных.

  6. При установке опции Наследовать ключи при копировании будут сохранены все ID объектов.

  7. При копировании с базой данных из списка Источник для таблиц выбрать источник данных для таблиц. Если нужного источника в списке нет, то добавить новый.

  8. Для подтверждения копирования нажать кнопку ОК. Кнопка Отмена закроет диалог Копирование карты без сохранения изменений.

    Рисунок 60. Копирование карты

В результате проделанных действий в указанный каталог будет скопирована карта и все ее слои со всеми данными. Для работы с копией ее надо загрузить в ZuluGIS.


Закрытие карты

Закрыть окно карты можно несколькими способами:

  1. Нажать x на ярлыке закрываемой карты.

    Рисунок 61. Закрытие карты

    ИЛИ

  2. Сделать щелчок правой кнопкой мыши на ярлыке карты и выбрать пункт Закрыть.

    Рисунок 62. Закрытие карты

Если открыто много карт и требуется их закрыть, то можно сделать щелчок правой кнопкой мыши на ярлыке той карты, которую не следует закрывать, и выбрать пункт Закрыть другие вкладки.

[Примечание] Примечание

В том случае, если карта перед закрытием не была сохранена, то система предложит ее сохранить. Необходимо помнить о том, что, закрывая карту без сохранения, можно потерять произведенные ранее изменения данных.

[Примечание] Примечание

Для того чтобы далее при повторном открытии карты производилось восстановление последнего ее местоположения, которое было до ее закрытия, следует в настройках параметров системы установить опцию Восстанавливать последнее местоположение.


Навигация по карте

  • «Обновление без изменения масштаба»

  • «Произвольное перемещение центра изображения»

  • «Перемещение к определенным координатам и установка масштаба отображения карты»

  • «Возврат на предыдущее место просмотра»

  • «Отображение карты по размерам карты/слоя/группы»

  • «Изменение масштаба карты»

Под навигацией в окне подразумевается перестроение изображения, перемещение по карте и масштабирование.

Каждое окно карты характеризуется масштабом отображения графической информации (отношением размера карты на экране к ее реальному размеру или количеством сантиметров на местности, содержащихся в одном пикселе экрана, в зависимости от настроек системы), а также центром отображения (координатами на местности точки, которая в данный момент отображается в центр окна).

Курсор и текущие координаты окна

Активное в данный момент окно карты имеет соответствие между положением в нем курсора и координатами на местности той точки, на которую в данный момент указывает курсор. Эти текущие координаты курсора (если курсор находится в активном окне) непрерывно отображаются в правом нижнем углу экрана: . При выходе курсора за пределы активного окна карты отображение текущих координат прекращается.


Обновление без изменения масштаба

Обновление карты без смещения центра изображения осуществляется через меню Вид|Обновить или кнопкой [image] .

Нажатие одной из кнопок PageDown/PageUp/End/Home приведет к перестроению окна со смещением центра изображения на половину окна вверх/вниз/вправо/влево, соответственно.

Для «прокрутки» карты вверх/вниз/вправо/влево можно использовать соответствующие полосы прокрутки, принадлежащие данному окну.

[Примечание] Примечание

Полосы прокрутки по желанию пользователя могут быть отключены. Отключение/подключение полос происходит через диалог Параметры (меню Сервис|Параметры, вкладка Карта, опция Использовать полосы прокрутки).


Произвольное перемещение центра изображения

Работа с перемещением карты в системе может производиться разными способами.

С использованием мыши

  • нажать на панели навигации кнопку [image] , кнопка примет нажатое состояние. В этом режиме, удерживая нажатой левую клавишу мыши в любом месте окна карты, можно, перемещая курсор, перемещать изображение фрагмента карты или всю карту по экрану. При отпускании левой клавиши мыши изображение перестроится таким образом, что точка карты, соответствующая положению курсора в начале перемещения, займет на экране место, соответствующее положению курсора при отпускании клавиши мыши;

    ИЛИ

  • нажать колесико мыши (среднюю клавишу) и, удерживая его, перемещать курсор, чтобы переместить изображение фрагмента карты или всю карту по экрану;

    ИЛИ

  • нажать и удерживать стрелки (Up/Down/Left/Right) на клавиатуре (полезно, когда отсутствует средняя клавиша мыши).

[Примечание] Примечание

Описанные выше способы перестроения окна с изменением центра отображения позволяют осуществлять непрерывное перемещение по загруженной в окно карте в любом направлении. Параметр перемещения, то есть то, что будет перемещаться (фрагмент карты или вся карта), устанавливается в диалоге Параметры, вкладка Карта, раздел Перемещение изображения (режим рука).

С помощью окна Навигатор

Окно Навигатор вызывается через меню Окно|Навигатор или нажатием на панели инструментов кнопки [image] . В этом окне отображается содержимое активной карты и навигационная рамка, размеры которой соответствуют текущему масштабу, центру и размерам окна карты. При перемещении и масштабировании рамки соответственно изменяется масштаб и центра активной карты, так же как и при изменении масштаба активной карты изменяется размер рамки. Изменить размер навигационной рамки также можно, нажав (не отпуская) левую кнопку мыши в любом углу рамки, а затем перемещая курсор до тех пор, пока рамка не примет необходимые размеры.

Переместить навигационную рамку можно двумя способами:

  1. Нажать левую кнопку мыши на рамке в окне Навигатор и, не отпуская, «перетащить» рамку в любую часть карты.

  2. Щелкнуть левой кнопкой мыши в любом месте окна Навигатор, после чего рамка автоматически переместиться в это место.

Одновременно переместить рамку и изменить ее размеры можно, указав в окне навигатора (там, где рамки нет) один угол рамки, нажав (не отпуская) левую клавишу мыши, а затем переместив курсор с «резиновой» рамкой, закрепленной в указанной точке. Для завершения нужно отпустить левую клавишу мыши.

Общий вид системы с загруженной картой и окном Навигатор

Рисунок 63. Общий вид системы с загруженной картой и окном Навигатор


Перемещение к определенным координатам и установка масштаба отображения карты

Для перемещение к определенным координатам или установки масштаба отображения карты нажмите кнопку [image] или выберите пункт главного меню Вид|Задать координаты. При этом на экране появится диалог Масштаб и центр карты, в зависимости от вида проекции карты вид диалога будет меняться.

[Примечание] Примечание

Масштаб на карте может быть представлен в двух вариантах: геодезическом и в сантиметрах на пиксель. Выбор нужного масштаба осуществляется в параметрах системы.

При местной прямоугольной проекции можно задать новый масштаб (как отношение размера карты на экране к ее реальному размеру или как количество сантиметров на местности, содержащихся в одном пикселе экрана, в зависимости от настроек системы), координаты центра окна в метрах и поворот карты. Угол поворота задается в градусах. Направление вращения – против часовой стрелки.

При других проекциях (глобус, широта/долгота и т.д.) можно задать новый масштаб и широту/долготу в градусах (если единицы измерения установлены в метрах, то задаются X и Y). После ввода новых координат центра карты и нажатия кнопки OK произойдет перестроение окна в соответствии с новым масштабом и центром отображения.

Диалог Масштаб и центр карты

Рисунок 64. Диалог Масштаб и центр карты

[Подсказка] Подсказка

Вызов диалога задания масштаба и центра карты соответствует методу MapCtrl.DoChangeView.

[Примечание] Примечание

Для сенсорных экранов центр отображения карты можно изменить перемещением пальца по экрану (жест Pan).


Возврат на предыдущее место просмотра

Для того чтобы вернуться на предыдущее место просмотра карты с теми же координатами и масштабом, выберите на панели инструментов меню Вид|Предыдущий [image] . Для возврата выберите Вид|Вернуться [image] или нажмите на панели инструментов кнопки [image] и [image] , соответственно.


Отображение карты по размерам карты/слоя/группы

Для того чтобы перестроить изображение карты таким образом, чтобы на экране отображалась вся карта (слой/группа), надо выбрать меню Вид|По размерам|Карты (Слоя/Группы). Для слоя дальше необходимо указать слой, по размерам которого будет происходить масштабирование карты.

Также карту по размерам слоя или группы можно перестроить из панели Рабочее место. Для этого надо сделать щелчок правой кнопкой мыши на слое, по которому надо масштабировать карту, и в появившемся контекстном меню выбрать пункт По размерам слоя или По размерам группы, соответственно.

Рисунок 65. Контекстное меню

[Примечание] Примечание

Для того чтобы была возможность перемещаться по размерам группы, эту группу предварительно надо создать.


Изменение масштаба карты

Увеличить масштаб карты

Для увеличения масштаба (уменьшения изображения карты):

  • нажать кнопку [image] (масштаб будет увеличен в два раза), при этом произойдет перестроение карты в соответствии с новым масштабом;

    или

  • при наличии мыши с центральным колесом надо прокрутить колесо к себе или от себя (в зависимости от настройки), при этом при вращении колеса мыши масштабируется образ экрана и только при отпускании колеса произойдет реальное построение в окончательном масштабе.

Уменьшить масштаб карты

Для инициализации режима уменьшения масштаба (увеличения изображения карты):

  • нажать кнопку [image] , кнопка примет нажатое состояние. Если в этом режиме в любой точке карты нажать и отпустить левую клавишу мыши, то масштаб уменьшится в два раза, а точка, на которую указывал в данный момент курсор, переместится в центр карты. При этом произойдет перестроение карты в соответствии с новым масштабом и новым центром отображения;

    или

  • при наличии мыши с центральным колесом надо прокрутить колесо от себя или к себе (в зависимости от настройки), при этом при вращении колеса мыши масштабируется образ экрана и только при отпускании колеса произойдет реальное построение в окончательном масштабе.

[Примечание] Примечание

Настроить, каким образом будет уменьшаться или увеличиваться масштаб карты с помощью колеса мыши, можно через диалог Параметры. Для вызова диалога надо выбрать меню Сервис|Параметры, затем открыть вкладку Карта. Далее выбрать из списка Приближать вращением либо «от себя», либо «на себя», в зависимости от необходимости.

Также в этом диалоге можно выбрать настройку масштабирования, то есть то, будет ли масштабироваться фрагмент карты или вся карта. При выборе полной отрисовки экрана в результате масштабирования возможно замедление отрисовки карты.

Если в режиме уменьшения масштаба ( [image] ) в любой точке карты нажать и не отпускать левую клавишу мыши, то при перемещении курсора появится резиновая рамка, одним углом которой будет точка в момент нажатия клавиши, а вторым углом по диагонали от нее будет текущее положение курсора. При отпускании левой клавиши мыши центром отображения карты станет точка пересечения диагоналей прямоугольника, а масштаб изменится так, чтобы изображение, захваченное рамкой, полностью попадало в окно карты. При этом произойдет перестроение карты в соответствии с новым масштабом и новым центром отображения.

Если в режиме уменьшения масштаба ( [image] ) нажать и не отпускать левую клавишу мыши, одновременно удерживая нажатой левую клавишу Ctrl, инициализируется режим плавного изменения масштаба. В этом режиме перемещение курсора мыши вверх окна приведет к плавному уменьшению масштаба, перемещение курсора вниз окна приведет к плавному увеличению масштаба. Для выхода из режима плавного масштабирования нужно отпустить левую клавишу мыши.

[Примечание] Примечание

Режим плавного изменения масштаба не работает, если в карту добавлены слои с Tile-серверов.

Также, если в режиме уменьшения масштаба нажать и не отпускать левую клавишу мыши, одновременно удерживая нажатой левую клавишу Alt, то активизируется режим увеличения масштаба (уменьшение размеров карты). Этот режим будет активизирован до тех пор, пока не будет отпущена кнопка Alt.

[Примечание] Примечание

Для сенсорных экранов изменять масштаб отображения карты можно, сдвигая/раздвигая на экране два пальца (жест Zoom).


Поворот карты

Поворот карты возможен через панель Масштаб и центр карты, угол поворота задается в градусах. Направление вращения – против часовой стрелки.

Кроме того, изменять угол отображения карты можно вращением колеса мышки с нажатой при этом клавишей Ctrl. В этом случае при каждом повороте колеса угол будет изменяться на пять градусов. Вернуть угол поворота в ноль можно нажатием колеса мышки с нажатой клавишей Ctrl.

Вращение карты в проекции ГК

Рисунок 66. Вращение карты в проекции ГК


Измерение расстояний и площадей

Система позволяет измерять расстояние произвольной полилинии и площадь полигона, образуемого этой ломаной и отрезком, замыкающим ее концы.

[Примечание] Примечание

Измерения производятся в Декартовой или Сферической системе. Настройка системы измерений производится в настройках карты. Панель настроек открывается через меню Карта|Настройка, вкладка Проекция карты, раздел Система измерений.

Для инициализации режима измерения следует нажать кнопку [image] (кнопка примет нажатое состояние). Последовательно щелкать мышью по вершинам ломаной. При этом в строке состояния внизу экрана будут отображаться текущая длина отрезка (суммарная длина пути) ломаной и текущая площадь: .

Для привязки к узлам активного слоя удерживайте клавишу CTRL. Если надо «притянуться» к узлу объекта, находящегося в неактивном слое, то надо удерживать одновременно клавиши Ctrl и Shift.

Пример измерения расстояния

Рисунок 67. Пример измерения расстояния

Вычисляется площадь фигуры, получаемой замыканием линией первой и последней введенной точки пути.

Пошаговую отмену введенных точек можно произвести с помощью клавиши Esc или сделав щелчок правой кнопкой мыши и выбрав пункт Отменить последнюю точку.

Для завершения введения ломаной надо сделать двойной щелчок левой кнопкой мыши или щелкнуть правой кнопкой мыши и выбрать пункт отменить всю линию.


Настройка карты

  • «Общие настройки карты»

  • «Слои карты»

  • «Настройка сетки»

  • «Настройка проекции карты»

  • «Настройка режима псевдо-3D»

  • «Настройка подстановок для макетов карты»

Для настройки параметров текущей карты выполните команду меню Карта|Настройка или щелкните правой кнопкой мыши в рабочей области карты и выберите в открывшемся меню пункт Настройка. Также открыть настройки карты можно через панель Рабочее место. Для этого надо сделать щелчок правой кнопкой мыши на названии карты в панели, затем выбрать в контекстном меню пункт Настройка.

В результате откроется диалог настройки карты:

Вкладка «Карта» диалога настройки карты

Рисунок 68. Вкладка «Карта» диалога настройки карты

В зависимости от открытой вкладки, диалог позволяет выполнить действия, перечисленные далее.

Во вкладке Карта возможно:

  • установить пользовательское название карты;

  • просмотреть/скопировать расположение файла карты;

  • изменить цвет фона карты;

  • установить опцию сглаживания линий для лучшего отображения данных;

  • задать одинаковый стиль для всех растров;

  • установить интервал обновления карты;

  • задать способ загрузки данных с сервера.

Подробнее о перечисленных настройках можно узнать в разделе «Общие настройки карты».

Во вкладке Слои возможно:

  • настроить слои, загруженные в карту (переместить, добавить, исключить, настроить, просмотреть и изменить структуру).

Подробнее о перечисленных настройках можно узнать в разделе «Слои карты».

Во вкладке Сетка возможно:

  • установить и настроить планшетную сетку;

  • снять или установить отображение сетки редактора, задать параметры сеток и привязку к сетке редактора.

Подробнее о перечисленных настройках можно узнать в разделе «Настройка сетки».

Во вкладке Проекция карты возможно:

  • настроить картографическую проекцию карты.

Подробнее о перечисленных настройках можно узнать в разделе «Настройка проекции карты».

Во вкладке Псевдо-3D возможно:

  • настроить параметры отображения объектов в режиме псевдо-3D.

Подробнее о перечисленных настройках можно узнать в разделе «Настройка режима псевдо-3D».

Во вкладке Дополнительно возможно:

  • настроить подстановки для макетов карты.

Подробнее о перечисленных настройках можно узнать в разделе «Настройка подстановок для макетов карты».

[Примечание] Примечание

Для сохранения всех изменений, произведенных в диалоговом окне настройки карты, необходимо нажать кнопку [image] на панели инструментов или в главном меню Файл выбрать команду Сохранить.

Формат масштаба, используемый для всех карт в системе ZuluGIS, задается в разделе Карта диалога общих настроек системы (команда меню Сервис|Параметры). Требуемый формат масштаба выбирается в поле со списком Масштаб карты:

  • Геодезический – геодезический формат (1:2000, 1:5000);

  • Пиксел на сантиметр – в количестве пикселей на сантиметр карты.


Общие настройки карты

Общие параметры карты задаются следующими полями и группами полей вкладки Карта диалога:

  • Название карты – пользовательское наименование карты, это то название карты, которое видно при открытии ее через ZuluGIS и отображается в верхнем левом углу открытой карты.

    [Подсказка] Подсказка

    Пользовательское название карты соответствует свойству MapDoc.Name.

  • Путь – отображается путь до файла карты.

  • Цвет фона карты – поле для выбора цвета подложки карты, по умолчанию задается белый цвет.

    [Подсказка] Подсказка

    Параметр соответствует свойству MapDoc.BackColor.

  • Установка флажка Сглаживание линий (antialiasing) включает режим сглаживания линий на картах, что делает изображение лучше для восприятия.

    Параметры сглаживания для карт по умолчанию задаются в диалоге общей настройки (меню Сервис|Параметры, вкладка Карта).

  • Флажок Единый стиль для всех растров управляет стилем отображения монохромных растров на карте. Если флажок снят, то цвета выводимых монохромных растров определяются настройками слоев растров или настройками самих растров.

    Если же флажок установлен, то цвета всех монохромных растров в карте определяются цветами, выбранными в полях Цвет линий и Цвет фона.

    [Подсказка] Подсказка

    Параметр соответствует свойству MapDoc.Grid.

  • В поле Автообновление задается период времени (в секундах) между обновлением данных в карте. Если для поля установлено значение «0», обновление не производится. Если же значение указано, то через заданный промежуток времени перечитываются данные, входящие в карту (файлы слоев, растровых изображений, баз данных). Это может быть полезно для отображения на карте динамически изменяющихся данных.

  • В поле со списком Отображение данных с сервера выбирается способ загрузки картографических изображений с сервера (при работе с картами через ZuluServer) – в векторном формате или в виде растровых изображений. Выбор правильного формата позволяет значительно ускорить отображение карт с сервера. Векторный формат оптимален при небольшом количестве картографических объектов, отображаемых на экране. При увеличении их количества более быстрым является использование растрового формата. Оптимальный формат для карты подбирается экспериментально. При этом следует учитывать, что выгода использования векторного/растрового формата меняется в зависимости от масштаба карты и выводимого ее участка. Например, в векторном виде быстрее загружаются участки с лесами и водоемами, а в растровом – карты густонаселенной местности с большим количеством домов.

    При выборе растрового формата передачи данных можно дополнительно указать масштаб, начиная с которого он будет использоваться (см. ниже). При масштабе меньше указанного используется векторный формат передачи данных.

  • Флажок Растр при масштабе большем чем 1: доступен только при выборе растрового формата данных для передачи с сервера. При установке флажка данные с сервера передаются в растровом формате только при масштабе карты большем, чем указано в поле справа от флажка. При меньшем масштабе данные передаются в векторном формате.


Слои карты

Во вкладке Слои настраиваются слои, загруженные в карту, в ней частично повторяются операции из диалога Список слоев. Более подробно можно узнать в разделе «Диалог Загруженные слои».

Вкладка «Слои» диалога настройки карты

Рисунок 69. Вкладка «Слои» диалога настройки карты

Описание кнопок вкладки Слои:

  • Кнопки Назад и Вперед изменяют порядок следования слоев:

    • Назад перемещает выбранный слой на одну позицию к началу списка;

    • Вперед перемещает выбранный слой на одну позицию к концу списка.

  • Кнопки Добавить и Исключить позволяют добавить/исключить слои карты:

    • Добавить вызывает диалог выбора слоя для добавления в карту;

    • Исключить исключает выбранные слои из списка слоев карты.

  • Кнопка Настройка вызывает диалог настройки выбранного слоя.

  • Кнопка Структура открывает структуру выбранного слоя.

  • Кнопка Клавиша позволяет настроить сочетание клавиш для быстрой активизации слоя на карте.

При установке флажка Показывать имена файлов рядом с названиями слоев в списке выводя названия их файлов на диске и путь до них.


Настройка сетки

Вкладка «Сетка редактора» диалога настройки карты

Рисунок 70. Вкладка «Сетка редактора» диалога настройки карты

На карте могут отображаться две координатные сетки:

  • Сетка карты – сетка, разбивающая карту на планшеты заданного размера. Не рекомендуется включать при использовании картографических проекций по широте/долготе.

  • Сетка редактора – набор точек заданного цвета, нанесенных на карту с определенным шагом по осям координат, облегчающий ввод и редактирование графических объектов слоя. Один из узлов сетки должен совпадать с задаваемой опорной точкой. Разметка окна сеткой позволяет лучше ориентироваться при редактировании объектов, а также привязывать вводимые координаты объектов к узлам сетки.

Для настройки сетки карты задайте следующие параметры в группе настроек Сетка карты:

  • В поле Планшет можете выбрать одну из популярных планшетных сеток, после выбора шаг сетки будет внесен автоматически в соответствующие окна.

  • Если планшет не выбран, то в полях Шаг сетки по X, м и по Y, м внесите расстояние между линиями сетки на карте (в метрах).

  • В полях Опорная точка X, м и Y,м задайте координаты опорной точки сетки (в метрах).

  • В полях Стиль и Цвет выберите стиль и цвет линий сетки.

  • Для отображения сетки на карте установите флажок Отображать сетку карты.

Для настройки сетки редактора задайте следующие параметры в группе настроек Сетка редактора:

  • В полях шаг Сетки по X, м и по Y, м введите расстояние между узлами сетки на карте (в метрах).

  • В поле Цвет выберите цвет меток сетки.

  • Для отображения сетки редактора на карте установите флажок Отображать сетку редактора. Отображение сетки также может включаться кнопкой [image] на панели инструментов.

  • Если установить флажок Привязка к сетке, то при вводе объектов они будут «привязываться» к узлам сетки. Привязка к сетке также включается/выключается кнопкой [image] на панели инструментов. Эта кнопка доступна, только когда включено отображение сетки.


Настройка проекции карты

[Примечание] Примечание

Подробнее о проекции карты можно прочитать в разделе «Проекция карты».

Вкладка «Проекция карты» диалога параметров карты

Рисунок 71. Вкладка «Проекция карты» диалога параметров карты

Вы можете выбрать проекцию из списка готовых проекций (предложены наиболее часто используемые проекции), задать параметры проекции вручную или загрузить проекцию из слоя карты или из файла слоя на диске:

  • Выбор готовой проекции.

    Для выбора готовой проекции выберите тип проекции в поле типов проекций, после чего выберите требуемую проекцию в списке проекций. В области параметров проекции отобразится список параметров выбранной проекции, но без возможности их редактирования.

  • Задание проекции вручную.

    Для задания параметров проекции вручную выберите в поле выбора типа проекции значение Задать. Задайте настройки проекции в полях области параметров проекции.

  • Импорт параметров проекции из другого слоя данной карты.

    Для импорта проекции из другого слоя карты выберите в поле типов проекции значение Выбрать по слою карты и выберите в области списка проекций слой, проекцию которого требуется использовать для карты.

  • Импорт параметров проекции из файла слоя.

    Импорт параметров системы координат (из слоя Zulu, с помощью строки MapInfo.prj, строки WKT или файла проекции PRJ).

Отображение карты в разных проекциях

Рисунок 72. Отображение карты в разных проекциях

В области параметров отображения задаются настройки, управляющие выводом данных проекции на экран. Настройки разделены на несколько групп:

  • Градусная сетка. Управляет отображением градусной сетки на экране:

    • Градусная сетка выводится только в том случае, если установлен флажок Отображать;

    • Цвет линий сетки задается в поле Цвет;

    • Шаг линий сетки по широте и долготе (в градусах) задается в полях Шаг по широте, град. и Шаг по долготе, град.

  • Заливка. Управляет отображением фоновой заливки:

    • Заливка отображается при установленном флажке Отображать;

    • Цвет заливки задается в поле Цвет.

  • Переключатель Система измерений задает используемую систему координат: декартову или сферическую.

  • В группе полей Единицы измерения задаются используемые единицы измерения для координат, расстояний и площадей.

После завершения настройки проекции карты нажмите кнопку ОК диалога, чтобы сохранить изменения и закрыть диалог.

[Примечание] Примечание

Карты, выполненные в локальной системе координат, можно привязать к географической системе координат только в том случае, если для данной карты известны параметры перехода из локальной системы координат в географическую.

Если параметры известны, задайте параметры проекции и системы координат карты в соответствии с имеющимися параметрами перехода.


Настройка режима псевдо-3D

Вкладка «Псевдо 3D» диалога параметров карты

Рисунок 73. Вкладка «Псевдо 3D» диалога параметров карты

В полях данной вкладки задаются параметры отображения объектов при использовании режима псевдо-3D:

  • В полях Отклонение от нормали к экрану по вертикали/по горизонтали, град. группы настроек Наклон задается степень отклонения угла зрения на строимые изображения объектов в градусах по вертикали и горизонтали, соответственно (от 0 до 45 градусов). При значениях равных нулю отображается вид «строго сверху», совпадающий с изображением при отключенном режиме «псевдо-3D».

  • В полях группы настроек Раскраска боковых граней задается цвет раскраски боковых граней псевдо-3D объектов. Цвет раскраски боковых граней формируется на базе цвета заливки исходного объекта (являющегося «крышей» получающегося изображения). В полях Контраст в процентах от контраста крыши и Яркость в процентах от яркости крыши задается понижение контраста (в процентах) и понижение яркости (в процентах) исходного цвета для получения цвета боковых граней.

  • В полях группы настроек Раскраска ребер – Контраст в процентах от контраста крыши и Яркость в процентах от яркости крыши задается цвет раскраски боковых ребер псевдо-3D объектов. Цвет раскраски боковых ребер формируется из цвета заливки исходного объекта по принципу, описанному в предыдущем пункте.


Настройка подстановок для макетов карты

Используя данную вкладку, можно произвести индивидуальные настройки текстовых подстановок для макетов карты.

Вкладка «Дополнительно» диалога настройки карты

Рисунок 74. Вкладка «Дополнительно» диалога настройки карты


Настройка окон карты

  • «Создание новой группы карт»

  • «Перемещение карты из одной группы в другую»

В ZuluGIS одновременно может быть открыто несколько окон карт. Расположить открытые карты возможно последовательно друг за другом в одной группе или параллельно в вертикальных или горизонтальных группах.

Первый вариант используется по умолчанию, в этом случае на экране отображена только одна карта. Переключение между картами производится щелчком левой кнопки мыши на ярлыке с названием карты:

Переключение между картами

Рисунок 75. Переключение между картами

Во втором и третьем варианте на экране возможно отображение одновременно одной карты из каждой группы вертикально или горизонтально, в зависимости от выбранного варианта:

Отображение двух карт из вертикальных групп:

Рисунок 76. Отображение двух карт из вертикальных групп:

Отображение двух карт из горизонтальных групп:

Рисунок 77. Отображение двух карт из горизонтальных групп:

Создание новой группы карт

Для создания новой группы карт надо:

  1. Открыть карты для отображения в группах.

  2. Сделать щелчок правой кнопкой мыши на ярлыке с названием карты и в появившемся контекстном меню выбрать [image] Новая вертикальная группа или [image] Новая горизонтальная группа.

    Создание новой группы карт для отображения

    Рисунок 78. Создание новой группы карт для отображения

В результате указанная карта будет перемещена в новую группу.

Перемещение карты из одной группы в другую

Аналогично созданию группы происходит и перемещение карты из одной группы в другую. Если группа в результате перемещения карт осталась пустая, то она автоматически закрывается.

Для перемещения карты из группы в группу надо:

  1. Сделать щелчок правой кнопкой мыши на ярлыке карты, которую надо переместить, и в появившемся контекстном меню выбрать Переместить в следующую группу или Переместить в предыдущую группу.


Включение и отключение отображения слоев карты

Слой может находиться в карте, но при этом не отображаться. Отключать или включать отображение возможно как для одного слоя, так и одновременно для нескольких слоев. В том случае, если требуется включать/отключать видимость одновременно у нескольких слоев, есть два варианта:

  • предварительно создать группу слоев – это удобно при регулярной работе с включением/отключением отображения;

  • работать с настройкой отображения сразу нескольких несгруппированных слоев – такой вариант удобен в том случае, если нет необходимости регулярно включать/выключать отображение.

[Примечание] Примечание

Для сохранения произведенных изменений необходимо сохранить карту.

Производить включение/выключение отображение слоев можно несколькими способами.

[Примечание] Примечание

Активный слой не может быть скрытым, так как он обязательно должен выводиться на экран!

Включение/отключение отображения через диалог Загруженные слои

  1. Откройте диалог Загруженные слои (Карта|Слои).

  2. Сделав щелчок справа от слоя или группы слоев на значке [image] , включите/выключите отображение в зависимости от исходного состояния (если кнопка серого цвета, то слой не отображается).

    Включение/выключение отображения слоя на карте

    Рисунок 79. Включение/выключение отображения слоя на карте

  3. Для закрытия диалога нажмите кнопку ОК.

Включение/отключение отображения через панель Рабочее место

  1. Проверьте, что открыта панель Рабочее место.

  2. Для включения/отключения отображения слоя сделайте щелчок левой кнопкой мыши по иконке рядом с названием слоя или группы слоев в панели Рабочее место. Если иконка серого цвета [image] , то слой не отображается.

    Включение/выключение отображения слоя на карте

    Рисунок 80. Включение/выключение отображения слоя на карте

Включение/отключение отображения через диалог настройки слоя

  1. Откройте панель настройки слоя.

  2. Во вкладке Общие установите/снимите галочку Отображать слой на карте. Если галочка снята, слой не отображается.

  3. Для закрытия диалога нажмите кнопку ОК.


Вырезание слоев по области

В результате данной операции будет создана новая карта с копией слоев текущей карты и объектами, которые попадают в указанную область. При этом слои могут быть скопированы с сохранением настроек текущей карты, структурой, базой данных, бирками и.т.д.

[Примечание] Примечание

Видеоурок на тему вырезания слоев по области можно посмотреть, пройдя по одной из ссылок: https://www.politerm.com/videos/macros/map/vyrezanie-fragmenta-karty-po-oblasti/ или https://www.politerm.com/videos/map/vyrezanie-fragmenta-karty-po-oblasti/.

Для вырезания слоев по области надо:

  1. Сделать активным слой, в котором находится область для вырезания.

  2. Выделить объект или группу объектов, по границам которых будет происходить вырезание.

  3. Проверить, что на панели инструментов нажата кнопка [image] . Сделать щелчок левой кнопкой мыши по области для вырезания. Для выделения нескольких областей надо удерживать на клавиатуре клавишу Shift. Ошибочно добавленные области можно исключить, используя клавишу Ctrl.

  4. Выбрать меню Карта|Операции|Вырезать слои по области.

  5. В появившемся диалоге нажать кнопку Обзор..., затем указать название и расположение файла карты, в которую будут добавлены скопированные данные. Нажать кнопку Сохранить.

  6. В строке Название карты при необходимости изменить пользовательское название карты, оно по умолчанию берется из исходной карты.

  7. Из списка Источник для таблиц выбрать источник для хранения таблиц, если нужного источника в списке нет, то добавить новый.

  8. Для наследования ключей (ID объектов не изменятся) следует установить опцию Наследовать ключи.

  9. Если требуется скопировать только геометрические объекты без баз данных, то следует установить опцию Только геометрия.

  10. Выбрать из списка Способ пересечения с областью:

    • полное попадание – при выборе данного пересечения результатом вырезания будут только те объекты, которые полностью попадут в указанную ранее область;

    • любое пересечение – результатом вырезания будут объекты как полностью, так и частично попавшие в указанную область, объекты при этом обрезаны не будут;

    • обрезка по границе – в результате операции объекты, попавшие на границу области, будут обрезаны по ней.

    Диалог вырезать слои карты по заданной области

    Рисунок 81. Диалог вырезать слои карты по заданной области

  11. Для запуска процесса вырезания слоев по области нажать кнопку ОК.

Рассмотрим данную операцию на примере. На рисунке ниже изображена карта с группой слоев. Требуется вырезать слои по кварталу. Так как в данной карте отдельного слоя Кварталы с объектами для выделения области нет, то для вырезания такой слой был создан. В созданном слое нанесен объект, проходящий по границам нужного квартала. Объект нанесен в виде заполненного четырехугольника с прозрачной заливкой.

Карта с зоной для вырезания объектов

Рисунок 82. Карта с зоной для вырезания объектов

Для вырезания слоев надо:

  1. Сделать слой с областью активным, затем выделить область:

    Карта с выделенной зоной для вырезания объектов

    Рисунок 83. Карта с выделенной зоной для вырезания объектов

  2. Выбрать меню Карта|Операции|Вырезать слои по области.

  3. Заполнить диалог как указано выше (пункт 4-9).

  4. Нажать кнопку ОК.

Результат проделанных действий виден на рисунке ниже. Создана карта с указанным именем, в нее добавлены копии слоев, которые содержат объекты только по указанной области:

Карта с выделенной зоной для вырезания объектов

Рисунок 84. Карта с выделенной зоной для вырезания объектов


Режим псевдо-3D

Для слоев, объектам которых в базе данных задана информация о высоте, доступно отображение в режиме псевдо-3D. При использовании этого режима все объекты слоя отображаются в изометрической проекции с высотой боковых граней объектов, пропорциональной высоте объекта, указанной в базе данных. Режим позволяет визуально оценить высоту объектов от земли и относительно друг друга.

Рисунок 85. Режим псевдо-3D

В качестве данных о высоте объектов для построения изображения в режиме псевдо-3D можно использовать значения любого поля базы данных, используемого для объектов слоя. Высота объектов может задаваться в метрах или этажах. В последнем случае дополнительно указывается высота одного этажа.

Для включения использования режима псевдо-3D для слоя откройте диалог настроек слоя (Карта|Настройка слоя, двойной щелчок левой кнопкой мыши по слою) и установите флажок Отображать в псевдо 3D, после чего нажмите кнопку ОК диалога.

Далее, для построения псевдо-3D отображения объектов:

  1. Откройте диалог параметров псевдо-3D построения, выполнив команду меню Карта|Псевдо 3D|Задать высоты строений.

    Задание высот зданий

    Рисунок 86. Задание высот зданий

  2. В полях Тип, База данных и Запрос выберите тип объектов, базу данных слоя и запрос, по которым требуется выполнить построение.

  3. В поле Поле выберите поле, в котором указана высота объектов (в метрах или этажах).

  4. В поле Единицы выберите единицы, в которых задается высота объектов (Метры или Этажи).

  5. В поле Высота по умолчанию, м задайте высоту, которую должны иметь объекты, для которых не указана высота.

  6. Если в качестве единицы высоты выбраны этажи, в поле Высота этажа, м укажите высоту одного этажа в метрах.

  7. Флажок Подключить псевдо 3D дублирует функциональность аналогичного флажка в настройках слоя (см. выше). Установите его, чтобы включить режим псевдо-3D, или снимите, чтобы выключить.

  8. Нажмите кнопку ОК, чтобы закрыть диалог и выполнить построение объектов в режиме псевдо-3D.

Для обновления псевдо-3D представления при добавлении в слой новых объектов или изменении высоты уже введенных объектов требуется повторить процедуру построения псевдо-3D отображения. Настройки режима псевдо-3D отображения задаются во вкладке Псевдо 3D настроек карты (меню Карта|Настройка).


Закладки карты

  • «Создание закладок»

  • «Группировка закладок»

  • «Перемещение групп и закладок»

  • «Удаление закладок и разгруппировка групп»

  • «Переход по закладкам»

По аналогии с обычными книжными закладками имеется возможность сохранить вид карты с текущим масштабом и центром отображения и в дальнейшем быстро перейти к сохраненной закладке.

Рисунок 87. Пример закладок

Работа с закладками может осуществляться с использованием дополнительного окна Закладки, а также диалогового окна Закладки. Переход по закладкам также возможен через панель Рабочее место.

Вы можете создать два типа закладок:

  • первый тип – привязанные к конкретному виду отображения карты;

  • второй тип – привязанные к конкретному объекту слоя.

При перемещении объекта по карте автоматически изменяются координаты центра отображения карты. Таким образом, при создании закладки второго типа можно отслеживать перемещения объекта на карте.

Имеется возможность группировать закладки, что может облегчить работу с ними.


Создание закладок

[Внимание] Внимание

Сохранение закладок происходит при сохранении карты.

Создавать закладки можно с использованием диалога Закладки или дополнительного окна Закладки.

Создание закладки с использованием диалога Закладки

Для создания закладки выполните следующие действия:

  1. Установите нужный масштаб и центр отображения карты.

  2. При создании закладки, привязывающейся к объекту, а не к области карты, объект необходимо активировать ( [image] ).

  3. Для вызова диалога Закладки на панели инструментов нажмите кнопку [image] .

  4. Если ранее уже производилась группировка закладок, то установите курсор на группу, в которой требуется создать закладки. При отсутствии групп данный пункт следует пропустить.

  5. Нажмите кнопку Связать с центром, если создается закладка, привязанная к конкретному виду отображения карты, или кнопку Связать с объектом, если создается закладка, привязанная к конкретному объекту слоя.

  6. В строке Название закладки вместо текста <Новая> введите название закладки.

    Диалоговое окно «Введите название закладки»

    Рисунок 88. Диалоговое окно «Введите название закладки»

  7. Нажмите кнопку ОК.

    [Примечание] Примечание

    Имеется возможность переименовать закладку. Для этого ее надо выделить в списке, нажать кнопку Переименовать... и ввести новое название.

  8. При необходимости добавьте к закладке комментарий, для этого нажмите кнопку [image] в разделе Заметка, внесите его и нажмите кнопку ОК.

    Диалоговое окно «Закладки»

    Рисунок 89. Диалоговое окно «Закладки»

  9. Чтобы закрыть окно нажмите кнопку Закрыть.

Создание закладки с использованием вспомогательной панели Закладки

Для создания закладки:

  1. Установите нужный масштаб и центр отображения карты.

  2. При создании закладки, привязывающейся к объекту, а не к области карты, объект необходимо активировать ( [image] ).

  3. Если еще не открыта панель Закладки, выберите меню Окно|Закладки [image] .

  4. Если ранее уже производилась группировка закладок, то установите курсор на группу, в которой требуется создать закладки. При отсутствии групп данный пункт следует пропустить.

  5. Нажмите кнопку Связать с центром ( [image] ), если создается закладка, привязанная к конкретному виду отображения карты, или кнопку Связать с объектом ( [image] ), если создается закладка, привязанная к конкретному объекту слоя.

  6. Вместо текста <Новая> введите название закладки.

  7. При необходимости добавьте к закладке комментарий, для этого нажмите кнопку [image] в разделе Заметка, внесите его и нажмите кнопку ОК.

[Подсказка] Подсказка

Установить закладку, связанную с центром карты, можно с помощью свойства MapCtrl.Map.Bookmarks.AddByCenter.

Установить закладку, связанную с объектом, можно с помощью свойства MapCtrl.Map.Bookmarks.AddByElement.


Группировка закладок

Группировку закладок можно производить с использованием диалога Закладки или дополнительного окна Закладки.

[Примечание] Примечание

Создать группу для закладок невозможно без самих закладок, то есть закладки должны быть предварительно созданы!

Для создания группы закладок с использованием диалога Закладки:

  1. Вызовите диалог настройки закладок – кнопка [image] .

  2. Установите курсор на закладку, которая должна входить в создаваемую группу.

  3. Нажмите кнопку Группа|Создать.

  4. По умолчанию группы создаются с названиями Группа 1, Группа 2 и.т.д. Для переименования группы выделите ее, нажмите кнопку Переименовать... и ввести новое название.

Для создания группы закладок с использованием вспомогательного окна Закладки:

  1. Если еще не открыта панель Закладки, выберите меню Окно|Закладки [image] .

  2. Установите курсор на закладку, которая должна входить в создаваемую группу.

  3. Сделайте щелчок правой кнопкой мыши и выберите пункт Группировать.

  4. По умолчанию группы создаются с названиями Группа 1, Группа 2 и.т.д. Для переименования группы выделите ее, нажмите кнопку Переименовать... и ввести новое название.


Перемещение групп и закладок

Переместить закладку или группу из одной группы в другую можно с использованием диалога Закладки или вспомогательного окна Закладки.

[Примечание] Примечание

Если при перемещении закладок в группе не останется ни одной закладки, то группа будет автоматически УДАЛЕНА, так как существование группы без закладок невозможно.

Перемещение закладок или групп с использованием диалога Закладки

Перемещение в диалоге Закладки возможно двумя вариантами:

Первый вариант:

  1. Вызовите диалог настройки закладок – кнопка [image] .

  2. Подведите курсор к нужной закладке (группе), нажать левую клавишу мыши и, не отпуская, переместить закладку или группу в нужное место.

Второй вариант:

  1. Вызовите диалог настройки закладок – кнопка [image] .

  2. Выделите в списке нужную закладку (группу).

  3. Нажмите кнопку Группа|Переместить в....

  4. Укажите группу для перемещения и нажать кнопку ОК.

Для перемещения закладок или группы с использованием вспомогательного окна Закладки:

  1. Если еще не открыта панель Закладки, выберите меню Окно|Закладки [image] .

  2. Подведите курсор к нужной закладке (группе), нажмите левую клавишу мыши и, не отпуская, переместите закладку или группу в нужное место.


Удаление закладок и разгруппировка групп

Удалять закладки и производить разгруппировку групп можно с использованием диалога Закладки или вспомогательного окна Закладки.

[Примечание] Примечание

При разгруппировке закладки, входившие в группу, не удаляются.

Удаление и разруппировка групп с использованием диалога Закладки

Для удаления закладки:

  1. Вызовите диалог настройки закладок – кнопка [image] .

  2. Выделите в списке нужную закладку.

  3. Нажмите кнопку Удалить.

    [Примечание] Примечание

    Если закладка удалена ошибочно, то можно нажать кнопку Вернуть все, НО, если до этого ранее также были произведены и не сохранены какие-либо изменения, например, добавлены группы и закладки или производились перемещения, то все это будет ПОТЕРЯНО!

Для разгруппировки группы:

  1. Вызовите диалог настройки закладок – кнопка [image] .

  2. Выделите в списке нужную группу.

  3. Нажмите кнопку Группа|Разгруппировать.

Удаление и разруппировка групп с использованием вспомогательной панели Закладки

Для удаления закладки:

  1. Если еще не открыта панель Закладки, выберите меню Окно|Закладки [image] .

  2. Выделите в списке нужную закладку.

  3. Нажмите на панели окна кнопку Удалить [image] , сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Удалить или нажмите на клавиатуре клавишу Delete.

  4. В появившемся сообщении для подтверждения операции удаления нажмите кнопку Да, для отмены – кнопку Нет.

Для разгруппирования группы:

  1. Если еще не открыта панель Закладки, выберите меню Окно|Закладки [image] .

  2. Выделите в списке нужную группу.

  3. Сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Расгруппировать.


Переход по закладкам

Переход по закладкам может осуществляться несколькими способами:

  • с использованием вспомогательной панели Закладки;

  • через панель Рабочее место;

  • с использованием главной панели инструментов;

  • с использованием диалога Закладки.

Для перехода по закладке с использованием вспомогательной панели Закладки:

  1. Если еще не открыта панель Закладки, выберите меню Окно|Закладки [image] .

  2. Выделите в списке нужную закладку.

  3. Затем:

    сделайте двойной щелчок левой клавишей мыши

    или

    нажмите на панели кнопку

    или

    сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Перейти.

Для перехода с использованием панели Рабочее место надо:

  1. Открыть список закладок в панели, нажав [image] слева от списка закладок.

  2. Сделать двойной щелчок левой кнопкой мыши на названии закладки или сделать щелчок правой кнопкой мыши на названии закладки и выбрать в контекстном меню пункт Перейти.

    Список закладок карты

    Рисунок 90. Список закладок карты

Для перехода через главную панель инструментов надо:

  1. Нажать на панели инструментов стрелку вниз кнопки [image] .

  2. В открывшемся списке выбрать название закладки.

    Список закладок карты

    Рисунок 91. Список закладок карты

После выбора произойдет перестроение карты с изменением масштаба и центра отображения.

Для перехода по закладке с использованием диалога Закладки надо:

  1. Нажать на панели инструментов кнопку [image] .

  2. В списке выбрать название закладки. Если закладок много, то в строке [image] можно ввести название закладки, тогда в списке будут отображены только закладки, удовлетворяющие введенному названию.

  3. Нажать кнопку Перейти.

    Рисунок 92. Диалог Закладки


Поиск объекта по ключу

Зная ключ (ID) объекта активного слоя, можно найти объект на карте по этому значению. Для этого нужно выбрать пункт главного меню Карта|Запрос|По ключу или нажать кнопку [image] на панели инструментов. На экране появится диалог для указания ключа. Если набранный в диалоге ключ найден в активном слое, то на карте активизируется (замигает) объект, соответствующий этому ключу. Если объект не попадал в область отображения карты, то окно карты перестроится так, чтобы найденный объект оказался в центре окна.

Диалог для указания ключа объекта

Рисунок 93. Диалог для указания ключа объекта

[Подсказка] Подсказка

Поиск объекта по ключу соответствует установки свойства Layer.CurrentID.


Геокодирование (поиск объектов на карте)

Геокодирование – процесс преобразования адресов в географические координаты, которые используются для позиционирования карты. С помощью данного инструмента имеется возможность легко найти объект на карте с помощью его адреса.

Для наглядного поиска объектов удобней всего использовать слои OpenStreetMap, которые можно загрузить через меню Слой|OpenStreetMap|OpenStreetMap.

[Примечание] Примечание

Использование слоев OpenStreetMap возможно при условии соблюдения соответствующих авторских прав.

Для вызова геокодера надо выбрать меню Карта|Запрос|Геокодирование или на панели инструментов нажать кнопку [image] .

Появится диалоговое окно геокодирования:

Диалоговое окно геокодирования

Рисунок 94. Диалоговое окно геокодирования

Для поиска надо:

  1. Указать сервер, к которому система будет обращаться при запросе. Для этого нажать кнопку [image] и выбрать сервер из списка:

    Диалоговое окно геокодирования

    Рисунок 95. Диалоговое окно геокодирования

  2. В окно запросов ввести данные для поиска.

  3. Нажать кнопку [image] . Если объект будет найден, то произойдет автоматическое перемещение этого объекта в центр карты без изменения масштаба. В том случае, если будет найдено несколько объектов, то они будут списком выведены под строкой задания параметров. Для перехода к объекту достаточно установить курсор на его названии в списке.

[Примечание] Примечание

В зависимости от выбранного сервера для поиска, результаты одного и того же запроса могут отличаться, например:

Результат поиска OpenStreetMap.ru

Рисунок 96. Результат поиска OpenStreetMap.ru

Результат поиска OpenStreetMap.org

Рисунок 97. Результат поиска OpenStreetMap.org


Особенности работы с картами ZuluServer

Для того чтобы работать с картами удаленно, необходимо предварительно подготовить их к публикации. Подробнее о подготовке данных можно узнать в справке по ZuluServer (https://www.politerm.com/zuluserver/webhelp/index.html#zspublish.html).

При работе с удаленными картами на сервере ZuluServer следует учитывать следующие особенности работы с ним:

  • В зависимости от количества объектов на карте и скорости соединения с сервером, перерисовка удаленных карт может занимать заметное время. В целях его сокращения можно настроить передачу данных в растровом формате.

  • В настройках сервера ZuluServer может быть задано ограничение на время бездействия соединения. Если с удаленной картой не выполнялось никаких действий в течение заданного промежутка времени, соединение завершается с соответствующим уведомлением.

  • В настройках сервера ZuluServer может задаваться максимальное количество соединений с одного IP-адреса. Если с Вашего IP-адреса уже установлено максимальное доступное количество соединений, при попытке открыть дополнительное соединение будет отображаться соответствующее предупреждение. Такая ситуация возможна, например, в том случае, если на компьютере запущено несколько экземпляров программы ZuluGIS с картами, открытыми с сервера ZuluServer.


Упаковка карты (архивация)

При упаковке карты создается архив в виде единого файла с расширением ZPKG. Архив будет включать в себя карту и входящие в нее слои, по возможности будет сохранена исходная структура подпапок карты. При этом сохраняются все данные и настройки, такие как структура слоев, графическая и семантическая информация, варианты надписей, шаблоны и варианты тематических раскрасок, ассоциированные со слоем пользовательские данные и т.д.

Такая архивация данных удобна при передаче информации сторонним лицам. В результате, так же как и при архивации отдельного слоя, создается архив с СУБД независимыми данными. В дальнейшем при извлечении слоя для хранения таблиц возможно будет выбрать нужный источник.

Для упаковки карты:

  1. Загрузите в ZuluGIS карту, которую надо упаковать.

  2. Выберите пункт главного меню Файл|Упаковать.

  3. Проверьте, что в списке Исходная карта указано название нужной карты, также можно нажать кнопку Обзор и указать карту на диске.

  4. В строке файл архива укажите имя для архива и путь до него, для этого воспользуйтесь кнопкой Обзор.

    Диалоговое окно упаковки карты

    Рисунок 98. Диалоговое окно упаковки карты

  5. Нажмите кнопку ОК.


Извлечение упакованной карты

В результате операции в указанный каталог будет извлечена ранее упакованная карта со всей информацией, содержащейся в архиве. При извлечении можно указать источник данных для хранения табличной информации, отличный от исходного.

Для распаковки карты:

  1. Выберите пункт главного меню Файл|Извлечь.

  2. В стандартном окне выбора щелчком левой кнопки мыши укажите архив и нажмите кнопку Открыть.

  3. В диалоговом окне Сохранить файл укажите папку для распаковки и имя файла. Распаковать архив можно как на локальную машину, так и на сервер геоданных. Во втором случает требуется слева нажать кнопку [image] Сервер геоданных, выбрать сервер и указать на нем папку. Затем нажмите кнопку Сохранить.

  4. Если для слоев распаковываемой карты нужен новый, отличный от исходного источник данных для хранения табличной информации, выберите его из списка Источник для таблиц.

  5. При необходимости установите опцию Открыть по завершении, тогда после распаковки карта со всеми данными будет загружена в ZuluGIS.

    Диалоговое окно распаковки карты

    Рисунок 99. Диалоговое окно распаковки карты

  6. Нажмите кнопку ОК.


Растровый слой

  • «Корректировка растра»

  • «Привязка растрового объекта»

  • «Группировка растровых объектов»

  • «Перепроецирование растровых слоев»

  • «Разбиение растрового объекта»

  • «Настройка отображения растра»

  • «Перемещение и масштабирование растровых объектов»

  • «Трансформирование растровых объектов»

  • «Преобразование файлов растровых объектов сторонних программ»

  • «Копирование растрового слоя»

  • «Зональная статистика по растровым слоям»

[Примечание] Примечание

Подборку видеоуроков по работе с растрами можно посмотреть, пройдя по одной из ссылок: https://www.youtube.com/playlist?list=PLanfni5YNcFppxqNgrIWSyNJuriZ3xX37 или https://www.politerm.com/videos/raster/.

Работа с растровыми объектами производится в несколько этапов:

  1. Если источником информации для карт являются планшеты в бумажном виде, то сначала изображение сканируется и сохраняется в формате *.bmp, *.jpg, *.jpeg, *.tif, *.tiff, *.gif, *.png, *.pcx, *.svg или*.heic. В том случае, если планшет больше сканера, то есть его невозможно сканировать за один прием, его необходимо сканировать по частям, предварительно обозначив эти части на планшете. Удобнее всего для сканирования по частям расчертить планшет по квадратам.

    [Предупреждение] Предупреждение

    ZuluGIS быстрее всего работает с растрами в формате bmp, поэтому при работе с большим количеством растров желательно, чтобы растры были данного формата. Это связано с тем, что именно формат bmp является рабочим, и системе не придется его предварительно распаковывать, как это происходит с другими форматами. Также в дальнейшем для растров формата bmp возможно будет создавать постоянный кэш файл, который позволяет практически мгновенно открывать даже очень большое количество растров.

  2. Корректировка растров. Корректировка – не обязательная операция. С помощью нее можно убрать искажения и лишние края планшета. В том случае, если лишних краев и искажений у планшетов нет, корректировку делать не надо. Корректировка может выполняться только для планов в локальной декартовой системе координат.

  3. Привязка растрового объекта к местности. Для того чтобы растр сел в определенные координаты на местности и в заданном масштабе, необходимо его привязать к координатам. Иными словами, установить соответствие между точками растра и координатами этих же точек в одной из картографических проекций на местности. Привязка может выполняться как до размещения растра на карте, так и после, причем во втором варианте есть два способа: с использованием редактора привязки и с помощью трансформирования.

    [Примечание] Примечание

    Видеоурок о привязке растров можно посмотреть, пройдя по одной из ссылок: https://youtu.be/I3FayqSHxkY или https://www.politerm.com/videos/raster/RasterGeoref/.

    В том случае, если масштаб не важен, имеется возможность непосредственно добавить растры в карту без задания координат.

  4. Группировка растров. Используется для работы в ZuluGIS с несколькими растрами как с одним. Эта операция необязательна и рекомендуется в том случае, если ведется работа с большим количеством растров.

  5. Добавление растров или растровых групп в карту.

[Примечание] Примечание

Растры в карте можно перемещать, поворачивать и масштабировать или в режиме редактирования объектов или с помощью операций трансформирования.

Имеется возможность при необходимости перепроецировать растровые слои.

В системе поддерживается ограниченная работа с описателями растров программ MapInfo (файлы tab), или OziExplorer (файлы map). Возможно открытие и размещение на карте растров с такими описателями с учетом заданной в описателе системы координат и привязки растра и конвертирование файлов привязок в формат описателя растра ZuluGIS. Кроме того, поддерживается преобразование файлов поддерживаемых растровых форматов в формат bmp для ускорения работы с ними.


Корректировка растра

Вы можете при необходимости произвести корректировку растровых файлов, содержащих сканированную с планшетов топооснову. Корректировка искажений сканирования производится по точкам растра, координаты которых известны. Как минимум должны быть известны четыре точки, определяющие углы планшета. Процедура корректировки создает новый растр, углы которого совпадают с углами планшета, то есть процедура корректировки обрезает отсканированные, но лишние поля.

Как правило, планшеты разбиты равномерной сеткой, узлы которой отображаются на подоснове крестами. Например, квадратный планшет масштаба 1:2000 размером на местности километр на километр разбит двухсотметровой сеткой. Такой планшет кроме углов имеет 36 точек (если все кресты присутствуют) с известными координатами. После указания мест этих опорных точек на растре система получает список координат для корректировки растра. В результате корректировки методом интерполяции опорные точки растра займут идеальное положение, а остальные точки по условию непрерывности займут какие-то новые положения. Таким образом, в результате корректировки растра компенсируются искажения, внесенные в планшет при сканировании.

[Примечание] Примечание

Видеоурок по корректировке растрового объекта можно посмотреть, пройдя по одной из ссылок: https://youtu.be/aIqzSS9LIYw или https://www.politerm.com/videos/raster/RasterCorrect/.

Для выполнения корректировки растрового файла:

  1. Выберите пункт меню Растр|Корректировка. Откроется окно корректировки растровых изображений.

  2. Загрузите файл для корректировки. Для этого нажмите кнопку [image] , в стандартном окне выбора файла щелчком левой кнопки мыши выберите файл и нажмите кнопку Открыть. В окно корректировки загрузится растровое изображение, поверх которого отобразится сетка с опорными точками, обозначенными синими кружками:

    Окно корректировки растра

    Рисунок 100. Окно корректировки растра

  3. Задайте необходимое количество ячеек опорной сетки по вертикали и горизонтали. Для этого нажмите кнопку [image] и в появившемся диалоге задайте количество ячеек. Если выбрать число ячеек 1x1, то для корректировки растра потребуется задать только углы планшета.

    Окно задания количества ячеек опорной сетки

    Рисунок 101. Окно задания количества ячеек опорной сетки

  4. Для навигации по окну предназначены кнопки масштабирования и перемещения:

    • – увеличение изображения в два раза;

    • – уменьшение изображения в два раза;

    • – размеры окна по размерам изображения;

    • – перемещение изображения влево, при котором ближайшая слева опорная точка окажется в центре окна;

    • – перемещение изображения вниз, при котором ближайшая снизу опорная точка окажется в центре окна;

    • – перемещение изображения, при котором в центре окна окажется ближайшая с любой стороны опорная точка;

    • – перемещение изображения вверх, при котором ближайшая сверху опорная точка окажется в центре окна;

    • – перемещение изображения вправо, при котором ближайшая справа опорная точка окажется в центре окна.

  5. Совместите опорные точки сетки с соответствующими крестами на растре. Для совмещения каждой точки:

    1. Подведите курсор мыши к нужному кружку и захватите его, зажав левую кнопку мыши;

    2. Установите курсор мыши с захваченным кружком в центр креста на растре, соответствующего опорной точке:

      Результат совмещения опорных точек растра

      Рисунок 102. Результат совмещения опорных точек растра

    3. Отпустите левую клавишу мыши; узел опорной сетки займет новое положение.

  6. Если какие-то кресты на растре отсутствуют, то соответствующие им опорные точки не следует включать в список точек для корректировки, так как их положение не определено. Такие точки нужно отключить. Для этого подведите курсор мыши к данному кружку и нажмите левую клавишу мыши, удерживая при этом нажатой клавишу Ctrl, при этом кружок окрасится в красный цвет. Для включения отключенной опорной точки повторите те же действия, при этом красный кружок окрасится в синий цвет. Отметим, что наличие угловых точек растра обязательно для преобразования и отключить эти точки нельзя.

  7. После того как все опорные точки заданы, запустите процедуру корректировки растрового изображения. Для этого нажмите кнопку [image] . Процесс корректировки можно прервать, нажав кнопку [image] .

  8. Для записи откорректированного изображения нажмите кнопку [image] и в открывшемся диалоговом окне Сохранить как задайте новое название файла (при необходимости расширение файла можно поменять в поле Тип файла).

  9. Для корректировки следующего растра вернитесь к пункту 2.

  10. Для выхода из окна нажмите кнопку [image] .


Привязка растрового объекта

  • «Привязка растров с использованием диалога задания растра»

  • «Привязка растра на карте с использованием редактора привязки»

В результате данной операции создается файл описателя с расширением ZRS, в котором указываются координаты точек привязки растрового файла, ссылка на растр и дополнительная информация. Для привязки растра системе необходимо указать файл растрового изображения. Вы можете использовать изображения следующих форматов: *.bmp, *.jpg, *.jpeg, *.tif, *.tiff, *.gif, *.png, *.pcx, *.svg, *.heic.

[Примечание] Примечание

Видеоурок по привязке растровых объектов можно посмотреть, пройдя по одной из ссылок: https://youtu.be/I3FayqSHxkY или https://www.politerm.com/videos/raster/RasterGeoref/.

Привязка растрового объекта может осуществляться несколькими способами:

  1. Создание описателя с помощью диалога задания растра, в котором указываются точки привязки растрового слоя (координаты), а затем загрузка в карту созданного описателя. Данный способ удобно использовать в том случае, когда работа производится с планшетами и известны точки привязки или масштаб растра.

    Местоположение и размеры растра можно откорректировать и после загрузки его описателя в карту. О том, как это сделать. можно узнать в разделах «Привязка растра на карте с использованием редактора привязки» и «Перемещение и масштабирование растровых объектов».

    [Примечание] Примечание

    Для быстрой активизации растрового слоя нажмите кнопку активизации объекта ( [image] ) и, удерживая Alt + Ctrl + Shift, щелкните по растровому объекту.

  2. Привязка растра на карте с использованием редактора привязки. В этом случае растровый файл добавляется в карту, после чего в редакторе привязки задаются его координаты. Также в этом случае может использоваться и трансформирование растра. Затем производится сохранение описателя растрового объекта. Выполнять привязку растра на карте удобно в тех случаях, когда известны только приблизительные координаты растра и требуется их уточнить на местности. Кроме того, привязка на карте позволяет провести обрезку краев растра, если требуется.


Привязка растров с использованием диалога задания растра

  • «Диалог задания проекции слоя»

[Примечание] Примечание

Видеоурок о привязке растров можно посмотреть, пройдя по одной из ссылок: https://youtu.be/I3FayqSHxkY или https://www.politerm.com/videos/raster/RasterGeoref/.

Для привязки растра в местной декартовой системе координат достаточно знать координаты двух его точек, а в географической системе координат – не менее трех.

Диалог задания растров

Рисунок 103. Диалог задания растров

Для привязки растров выполните следующую последовательность действий:

  1. Выполните команду меню Растр|Задать. Откроется диалог задания растров.

  2. Откройте растр. Для этого нажмите кнопку Растровый файл диалога и укажите файл на диске. Изображение загрузится в область просмотра диалога. Масштаб изображения в области просмотра регулируется кнопками [image] и [image] , расположенными над областью, или колесом мыши.

  3. Нажмите кнопку Система координат и выберите систему координат в открывшемся диалоге.

  4. Задайте точки привязки растра к координатам.

    Данные о точках привязки отображаются в таблице Точки привязки растра:. В поле N приводится номер точки, в полях x, y – координаты точки растра (в пикселях), X и Y – координаты этой же точки на карте в выбранной системе координат. Флажок Автоматически добавлять строки под таблицей управляет добавлением в таблицу точек привязки. Если флажок установлен, то информация о добавляемой точке размещается в новой строке внизу таблицы, если флажок сброшен – замещается информация в текущей строке таблицы. Для добавления координат точки привязки на растре доступно несколько способов:

    • Щелкните левой кнопкой мыши в требуемой точке привязки на изображении.

    • Для добавления точки одного из углов растра нажмите кнопку [image] , [image] , [image] или [image] . В таблицу добавятся координаты соответствующего угла.

    • Либо введите координаты точки на растре вручную в поля x и y пустой строки внизу таблицы. Если пустой строки в таблице нет, нажмите кнопку [image] под таблицей для добавления такой строки.

    После указания координат точки на растре в полях X и Y строки введите координаты данной точки в выбранной системе координат на карте. Для изменения уже заданной точки выберите ее строку в таблице и задайте требуемые параметры точки. Для поворота растра необходимо задать не менее трех точек, не лежащих на одной прямой.

    Для удаления точки выберите ее строку в таблице и нажмите кнопку [image] под таблицей.

  5. Настройте дополнительные параметры задания растра. Эти параметры задаются в группе полей Параметры диалога.

    • Для задания цвета линий растра (только для монохромных растров) установите флажок использовать цвет линий и выберите требуемый цвет в поле справа от флажка.

    • Для задания цвета фона (только для монохромных растров) установите флажок использовать цвет фона и выберите требуемый цвет фона справа от флажка.

    • Для того чтобы белый цвет был прозрачным (только для монохромных растров), установите флажок Прозрачный белый. Флажок доступен только в том случае, если в поле Прозрачность установлено значение «0».

    • В поле Прозрачность задается степень прозрачности растра.

    • ZuluGIS может работать с растрами разных форматов, для комфортной работы с данными программа во временной папке системы создает свою оптимизированную копию данных – кэш. Он создается при открытии этих данных, что приводит к задержке при открытии слоев, и удаляется при завершении работы с ними.

      Для того чтобы единожды создать и зафиксировать этот кэш, что значительно увеличит скорость открытия слоев и работы с данными, надо установить флажок Использовать постоянный кэш. Его можно установить только для растров формата *.bmp.

      [Примечание] Примечание

      В случае если при работе будет использоваться значительное количество растров, рекомендуется перевести все графические файлы в формат *.bmp и активировать опцию Использовать постоянный кэш.

    • Для «обрезки» полей по точкам привязки следует установить флажок Обрезать по точкам привязки. Обрезка растра выполняется путем задания границы отображаемой части растра. Точки растра, находящиеся внутри границы, отображаются, точки снаружи – скрываются.

  6. После задания растра сохраните его файл-описатель. Для этого нажмите кнопку Сохранить и в стандартном диалоге сохранения файла задайте название сохраняемого файла-описателя.

  7. Для задания следующего растра нажмите кнопку Новый.

  8. По завершению задания растров нажмите кнопку Закрыть диалога.

В результате проделанных действий будет создан файл-описатель с расширением .zrs, который содержит указанные координаты, ссылку на графический файл растра и дополнительно заданные характеристики. Именно данный файл в дальнейшем загружается в ZuluGIS как растровый слой. Так как он не содержит непосредственно в себе само изображение, а только ссылку на него, то при перемещении слоев это надо учесть: необходимо перемещать как сам описатель, так и растр, на который он ссылается.

Для того чтобы изменить параметры уже созданного файла-описателя, в диалоге задания растров нажмите кнопку Открыть и выберите требуемый файл описатель (формата .zrs) в стандартном диалоге выбора файлов.


Диалог задания проекции слоя

Диалог параметров проекции слоя

Рисунок 104. Диалог параметров проекции слоя

[Примечание] Примечание

Необходимо понимать, что выбор проекции слоя – это очень важный момент, и пользователь должен четко понимать, какая проекция и какие ее параметры ему нужны для дальнейшей работы с данными. С теоретическими основами картографии можно познакомиться в разделе Географическая проекция и система координат.

Проекцию можно выбрать из списка готовых проекций (предложены наиболее часто используемые проекции), задать параметры проекции или импортировать.

  • Выбор готовой проекции. Для выбора готовой проекции выберите тип проекции в поле типов проекций, после чего выберите требуемую проекцию в списке проекций. В области параметров проекции отобразится список параметров выбранной проекции, но без возможности редактирования.

  • Задание проекции вручную. Для задания параметров проекции вручную выберите в поле выбора типа проекции значение <Задать>. Задайте настройки проекции в полях области параметров проекции.

  • Импорт параметров системы координат (из слоя Zulu, с помощью строки MapInfo.prj, строки WKT или файла проекции PRJ): «Импорт параметров системы координат».

После завершения настройки проекции карты нажмите кнопку ОК диалога, чтобы сохранить изменения и закрыть диалог.


Привязка растра на карте с использованием редактора привязки

  • «Добавление и редактирование точек привязки растра»

  • «Обрезка границ растра»

[Примечание] Примечание

Видеоурок о привязке растров можно посмотреть, пройдя по одной из ссылок: https://youtu.be/I3FayqSHxkY или https://www.politerm.com/videos/raster/RasterGeoref/.

Привязка растра на карте производится в два этапа:

  1. Добавление растра в карту.

  2. Привязка с использованием редактора привязки и при необходимости обрезка границ растра в том же редакторе.

Добавление растра в карту

В карту для перепривязки может быть добавлен как уже созданный растровый слой, так и новый растровый объект.

В первом случае выберите меню Карта|Добавить слой и укажите растровый слой.

Во втором случае растр без предварительной обработки добавляется сразу в карту. Если при добавлении он перекрывает область, на которую он должен быть в результате «посажен», то его можно переместить и при необходимости изменить его размеры.

Для добавления растра:

  1. Выберите пункт главного меню Карта|Добавить слой или нажмите кнопку [image] .

  2. В появившемся диалоговом окне Выбор слоя в списке Тип файлов выберите строку Файлы изображений ( *.bmp, *.jpg, *.jpeg, *.tif, *.tiff, *.gif, *.png, *.pcx, *.svg, *.heic).

  3. Укажите растровый файл, нажмите кнопку Открыть. Выбранный файл будет добавлен в список слоев карты и его изображение появится в центре окна карты.

[Примечание] Примечание

В том случае, когда используется растр в формате GeoTIFF, файлы данного типа добавятся в карту как обычный файл TIFF. Если в открываемом файле обнаружится и распознается информация о географической привязке, то растр будет помещен в карту в соответствии с этими данными.

Если растр перекрывает зону, к которой он будет «привязываться» и его требуется переместить или изменить размеры, то для этого:

  1. Сделайте растровой файл редактируемым.

  2. Включите режим Объект - [image] .

  3. Для перемещения растра подведите к нему курсор, нажмите и не отпускайте левую клавишу мыши. Переместите растр в нужное место.

    Если требуется изменить размер растра, подведите курсор к одному из квадратиков, расположенных на краю растра, нажмите левую клавишу мыши и, не отпуская ее, переместите «резиновую» рамку в нужное положение.

После добавления растрового объекта в карту желательно сохранить его описатель (ZRS). Если это не будет сделано на данном этапе, то система сама предложит это сделать при выходе из режима редактирования. Для сохранения описателя:

  1. Не выходя и режима редактирования, щелкните правой кнопкой мыши в области активной карты и в появившемся контекстном меню выберите команду Сохранить растровый объект.

  2. Укажите местоположение и имя файла для описателя растрового файла (название можно вводить без расширения). Нажмите кнопку Сохранить.

Привязка растра на карте и обрезка границ

[Примечание] Примечание

Вы можете через диалог привязки растров также экспортировать описатели растровых объектов в форматы MapInfo (*.tab), OziExplorer (*.map) и World File Esri (*.bpw, *.bmpw, *.tfw, *.tifw, *.jgw, *.jpgw, *.gfw, gifw, *.pgw, *.pngw). Подробнее об экспорте можно узнать в разделе «Экспорт описателей растровых объектов в форматы Mapinfo, OziExplorer, ESRI World File».

  1. Выберите меню Растр|Привязка.

    Диалог привязки растров

    Рисунок 105. Диалог привязки растров

  2. Проверьте чтобы в списке Слой диалога был указан нужный слой для привязки, а в поле Объект, соответственно объект (если в слое несколько объектов). Требуемый объект можно также выбрать, нажав клавишу Ctrl и, не отпуская ее, щелкнув левой кнопкой мыши по требуемому растру в карте.

    Растр может быть выбран и до открытия диалога. Для этого предварительно сделайте слой растра редактируемым, войдите в режим редактирования объектов (кнопка [image] ) и выберите требуемый растр на карте.

  3. Нажмите кнопку Система координат и выберите в открывшемся диалоге систему координат.

  4. В группе настроек Параметры можно задать дополнительные параметры отображения растра:

    • для задания цвета линий растра (только для монохромных растров) установите флажок Использовать цвет линий и выберите требуемый цвет в поле справа от флажка;

    • для задания цвета фона (только для монохромных растров) установите флажок Использовать цвет фона и выберите требуемый цвет фона справа от флажка;

    • для того чтобы белый цвет был прозрачным, установите флажок Прозрачный белый. Флажок доступен только в том случае, если в поле Прозрачность установлено значение 0;

    • в поле Прозрачность можно задать степень прозрачности растра.

    Чтобы настройки раздела были применены к растру нажмите кнопку Применить.

  5. При использовании растровых изображений в формате bmp, вы можете создать постоянный кэш. Для этого установите соответствующую галочку. Каждый раз при открытии растров создаётся временный кэш-файл. Если у вас много таких изображений, это может привести к задержкам при их открытии. Использование постоянного кэша позволяет ускорить загрузку растров, но при этом занимает больше места на диске.

    [Примечание] Примечание

    Если при работе будет использоваться значительное количество растров, рекомендуется перевести все графические файлы в формат *.bmp и активировать опцию Постоянный кэш.

  6. Проверьте чтобы переключатель диалогового окна, расположенный в верхней левой части стоял в режиме задания точек привязок [image] . Добавьте или отредактируйте точки привязки растра. Если не была установлена опция автообновления, то для перемещения растра по новым координатам нажмите кнопку Обновить.

  7. Если надо скрыть лишние границы растра, то переключите режим диалога в задание зоны видимости. Для этого нажмите на переключатель диалогового окна, расположенный в верхней левой части - [image] . Укажите границы растра.

  8. После внесения требуемых параметров нажмите кнопку Сохранить. Если ранее описатель растра не был сохранен, то укажите местоположение и имя файла для него. Если при переходе к другому растровому слою через поле Слой или при закрытии диалога система обнаружит не сохраненные изменения, то появляется соответствующее уведомление.

  9. После завершения работы с диалогом нажмите кнопку Выход.


Добавление и редактирование точек привязки растра

  • Редактирование точек привязки

  • Добавление точек привязки

Проверьте чтобы диалог был в режиме задания точек привязки растра – [image] .

В диалоге предусмотрено два режима обновления изображения на карте при добавлении и редактировании точек привязки. Выберите наиболее подходящий для вас:

  1. Автообновление. Растровое изображение на карте перерисовывается при любых изменениях точек привязки. Этот режим позволяет наглядно отслеживать изменения отображения растра, но его перерисовка может замедлять процесс заведения точек привязки. Так же при данном режиме не всегда можно наглядно увидеть посадку растра без удаления изначальных точек привязки. Режим автообновления действует при установленном флажке Автообновление в правой части диалога.

  2. Обновление по требованию. Перерисовка изображения растра производится только при нажатии кнопки Обновить диалога или при принятии изменений и закрытии диалога. Позволяет ускорить заведение точек привязки. Режим обновления по требованию действует при снятом флажке Автообновление в правой части диалога.

Данные о точках привязки отображаются в таблице привязок. В полях x, y приводятся координаты точки на растре в пикселях, X и Y – координаты этой же точки в выбранной ранее системе координат.

Редактирование точек привязки растра

После добавления растра в карту ему задаются три угловые точки привязки, координаты которых отражаются в таблице. Любые существующие точки можно отредактировать.

Редактирование возможно как изменением координат в таблице, так и переносом точек с помощью мыши.

Для редактирования координат в таблице установите курсор в соответствующую ячейку и введите новые координаты X и Y или x и y. Расположение точки будет изменено при переходе к следующей ячейки.

Для редактирование точек с помощью мыши подведите курсор к точке, нажмите левую клавишу мыши и переместите точку в необходимое положения. - обозначается точка из которой будет производится перемещение растра, а [image] - куда переместится.

Редактирование точек привязки

Рисунок 106. Редактирование точек привязки

Добавление новых точек привязки

Если точек привязки мало, то их можно добавить, для этого:

  1. Курсор мыши имеет вид [image] . Подведите его к точке на растре и щелкните левой кнопкой мыши. В указанной точке добавится значок [image] , курсор примет вид [image] , а в таблицу привязок добавится новая строка для создаваемой точки привязки (в поля x и y добавятся координаты точки растра в пикселях).

  2. Щелкните левой кнопкой мыши в точке карты, с которой должна совместиться выбранная точка растра. На карте отобразится значок [image] , в поля X и Y таблицы добавятся географические координаты указанной точки, выполнится преобразование растра с учетом заданного перехода между точками, а курсор мыши снова примет вид [image] .

    [Примечание] Примечание

    Если в настройках карты включена сетка карты, то при указании точек на карте можно «цепляться» к узлам сетки. Для этого нажмите и удерживайте на клавиатуре клавиши Shift и Ctrl, курсор примет вид [image] . Затем подведите курсор в область точки карты, с которой должна совместиться выбранная точка растра, щелкните левой кнопкой мыши. Точка будет установлена в ближайшем узле сетки карты.

  3. Повторяя действия 1, 2, задайте оставшиеся точки привязки.

    Если точка добавлена ошибочно, для ее отмены нажмите клавишу Esc или сделайте щелчок правой кнопкой мыши и выберите Отменить последнюю точку.

    Любую точку можно отредактировать.

Добавление точек привязки

Рисунок 107. Добавление точек привязки


Обрезка границ растра

Проверьте чтобы был установлен режим обрезки границ растра нажмите кнопку [image] .

Режим обрезки границ растра диалога привязки

Рисунок 108. Режим обрезки границ растра диалога привязки

Обрезка растра выполняется путем задания границы отображаемой части растра. Точки растра, находящиеся внутри границы, отображаются, точки снаружи – скрываются. При этом физического изменения растра не производится, и скрываемые части растра всегда могут быть отображены редактированием границы растра.

Обрезка границы растра

Рисунок 109. Обрезка границы растра

Граница отображаемой части растра формируется в виде многоугольника, данные точек которого хранятся в таблице, расположенной под строкой Система координат. Таблица состоит из двух столбцов x и y с координатами точек границы растра по горизонтали и вертикали (координаты даются в пикселях растра).

Предусмотрено два способа задания границы: ручной и по точками привязки.

При ручном способе задания:

  • Точки границы указываются на растре с помощью мыши. Перед началом ручного задания точек границы не должно быть задано ни одной точки границы (таблица точек должна быть пустой).

  • Для задания границы щелкните левой кнопкой мыши в точке растра, в которой должна располагаться первая точка границы, затем в точке второй точки границы и так далее, пока не будут нанесены все точки границы. В процессе нанесения точек границы области растра, отсекаемые границей, отображаются более бледным цветом.

  • Если надо добавить новые точки, сделайте щелчок левой кнопкой мыши на линии в месте добавления.

При задании точек границы по точкам привязки:

  • Точки границы задаются автоматически в соответствии с заданными для растра точками привязки, причем расположение точек границы необязательно совпадает с расположением точек привязки, а интерполируется с учетом используемой проекции и системы координат. Для создания границы по точкам привязки нажмите кнопку По привязке диалога.

После нанесения точек границы их положения можно отредактировать. Сделать это можно, просто перетащив точки мышью в подходящее положение или задав точные координат точки (в пикселях растра) в таблице.

При необходимости удалить точку границы выберите ее строку в таблице (или щелкните по точке на растре) и нажмите кнопку Удалить справа от таблицы. Для удаления всех точек в таблице нажмите кнопку Удалить все.


Группировка растровых объектов

Для работы с несколькими растрами одновременно растровые объекты удобно группировать в растровые группы. Растровая группа – это список растровых объектов и других растровых групп, записываемый в текстовой форме в файл с расширением ZRG. В дальнейшем растровая группа добавляется в карту так же, как и растровый объект или обычный слой.

[Примечание] Примечание

Видеоурок по группировке растровых объектов можно посмотреть, пройдя по одной из ссылок: https://www.politerm.com/videos/raster/RasterGroup/ или https://www.politerm.com/videos/raster/RasterGroup/.

Для создания или редактирования растровых групп:

  1. Выберите пункт меню Растр|Сгруппировать.

  2. В появившемся диалоге Растровая группа добавьте в список Состав группы все объекты, которые должны входить в состав группы. Для этого воспользуйтесь кнопками:

    • Добавить – вызывает диалог выбора файлов для добавления растровых объектов и групп в данную группу, в этом диалоге укажите добавляемые файлы и нажмите кнопку Открыть;

    • Удалить – удаляет выбранный элемент из списка группы.

    Список добавленных объектов отображается в окне состава группы в древовидной форме. Для объектов списка, являющихся другими растровыми группами, показывается их состав.

    Диалог группировки растровых объектов

    Рисунок 110. Диалог группировки растровых объектов

    [Примечание] Примечание

    Для вложенных групп редактирование их состава не предусмотрено, поэтому при выделении элементов этих групп кнопка Удалить становится недоступной.

  3. После того как растровая группа набрана и отредактирована, нажмите кнопку Сохранить и в появившемся диалоге выбора файла укажите файл для сохранения группы.

    [Примечание] Примечание

    Очистка полей диалога редактирования растровой группы выполняется кнопкой Новая. После нажатия этой кнопки система предложит сохранить текущие изменения, очистит все строки диалога и будет готова к заданию новой растровой группы.

Для того чтобы отредактировать уже существующую растровую группу:

  1. В диалоговом окне Растровая группа нажмите кнопку Открыть.

  2. В появившемся стандартном окне выбора файла выберите файл растровой группы для редактирования. Далее, выполните последовательность действий, описанную в пунктах 2 и 3 предыдущего списка.

Для загрузки растровой группы в карту:

  1. Создайте карту (если карта еще не создана) командой Файл|Создать карту или откройте уже существующую карту командой Файл|Открыть карту.

  2. В меню Карта выберите пункт Добавить слой и в стандартном окне выбора файла с помощью левой кнопки мыши выберите файл, который содержит растровую группу.

  3. Нажмите кнопку Открыть.

После загрузки растровой группы в карту имеется возможность перемещения и масштабирования растровых объектов.


Перепроецирование растровых слоев

Перепроецирование дает возможность из исходного растрового объекта, заданного в одной географической проекции, получать новый растр с привязкой в другой проекции.

[Примечание] Примечание

Подробнее о проекции можно узнать в разделе Географическая проекция и система координат.

Если растровый объект задан в одной географической проекции, а отображается в карте с другой проекцией, то пересчет изображения растра из одной проекции в другую происходит «на лету» и может вызывать замедление при отрисовке карты.

Если в таком режиме растровый объект используется постоянно, может иметь смысл один раз пересчитать изображение, создав новый растровый объект в нужной проекции, и затем использовать его для данной карты.

Для перепроецирования растрового слоя:

  1. Откройте карту с растрами или загрузите в активное окно растры для перепроецирования.

  2. Выберите пункт меню Растр|Перепроецировать.

  3. В диалоге Перепроецирование слоев карты нажмите кнопку Система координат, в открывшемся окне укажите новую систему координат и нажмите кнопку ОК.

  4. В том случае, если в карте загружены объекты с разных источников (локальные и серверные), в списке Выбирать из укажите, какой источник данных использовать.

  5. Если необходимо перепроецировать только определенную группу растров, то установите опцию Только выделенные (группа объектов должна быть заранее выделена).

  6. В разделе Растровые объекты выберите с помощью галочек объекты для перепроецирования.

  7. Укажите папку для записи перепроецированных растров, воспользуйтесь кнопкой [image] .

  8. Из открывающихся списков выберите Выходной формат и Единицы измерения для перепроецированных растров.

  9. Поставьте флажок Создать постоянный кэш, если необходимо создавать постоянные кэш-файлы для преобразуемых объектов (создание постоянного кэш-файла ускоряет загрузку объектов в карту, но потребляет некоторое пространство на диске).

    Диалог перепроецирования растровых объектов

    Рисунок 111. Диалог перепроецирования растровых объектов

  10. Нажмите кнопку ОК.

В результате выполненных действий растровые объекты будут перепроецированы в новую систему координат и сохранены в указанную папку.


Разбиение растрового объекта

Система имеет возможность разрезать исходный растровый объект на составные растровые объекты. Данная операция полезна в том случае, если исходный растр большого объема и работа с ним снижает производительность системы. Разделение большого растра на части может существенно повысить скорость отрисовки карты. Также данная процедура может понадобиться тогда, когда из растра для его быстрой загрузки и дальнейшей работы возможно убрать часть информации. Например, если инженерная сеть проходит по диагонали растра и требуется отображать только ее, то можно растр разделить на части и в дальнейшем загружать в карту только нужные растровые объекты.

[Примечание] Примечание

Видеоурок по разбиению растрового объекта можно посмотреть, пройдя по одной из ссылок: https://youtu.be/DJiyvWn4gIA или https://www.politerm.com/videos/raster/razdelenie-rastra/.

Для разделения растра:

  1. Откройте карту с растрами или загрузите в активное окно растры для разбиения.

  2. Выберите пункт меню Растр|Разделить на части.

  3. В том случае, если в карте загружены объекты с разных источников (локальные и серверные), в списке Выбирать из укажите, какой источник данных использовать.

  4. Если необходимо разбить только определенную группу растров, то установите опцию Только выделенные (группа объектов должна быть заранее выделена).

  5. В разделе Растровые объекты выберите с помощью галочек объекты для разбивки.

  6. Укажите папку для записи разделенных растров, воспользуйтесь кнопкой [image] .

  7. Из открывающегося списка выберите Выходной формат для разделенных растров.

    [Примечание] Примечание

    ZuluGIS быстрее всего работает с растрами в формате bmp, поэтому при работе с большим количеством растров желательно, чтобы растры были данного формата. Также для растров формата bmp возможно будет создать постоянный кэш, который значительно ускоряет работу с растрами.

  8. В разделе Разбить на части укажите количество частей для разбивки каждого растрового объекта.

  9. При установке опции Создать группу растр будет разделен на части, а затем эти части сгруппированы в растровую группу. Групп будет столько, сколько разбивается растров.

  10. Если необходимо создавать постоянные кэш-файлы для разделяемых объектов, поставьте флажок Создать постоянный кэш (создание постоянного кэш-файла ускоряет загрузку объектов в карту). Опция доступна только для растров формата bmp.

  11. При установке опции Добавить в карту после процедуры разделения объекты сразу будут добавлены в текущую карту.

    Диалог разделения растровых объектов

    Рисунок 112. Диалог разделения растровых объектов

  12. Нажмите кнопку ОК.

В результате выполненных действий на диске D в папке example/cut появятся следующие файлы:

  • 50GI.ZRG, 50GII.ZRG – группы разделенных растровых объектов;

  • 50GI_1.BMP, 50GI_2.BMP, 50GI_3.BMP, 50GI_4.BMP, 50GII_1.BMP,

    50GII_1.BMP, 50GII_2.BMP, 50GII_3.BMP, 50GII_4.BMP – разделенные растры;

  • 50GI_1.ZRS, 50GI_2.ZRS, 50GI_3.ZRS, 50GI_4.ZRS

    50GII_1.ZRS, 50GII_2.ZRS, 50GII_3.ZRS, 50GII_4.ZRS – файлы-описатели разделенных растровых объектов.


Настройка отображения растра

  • «Настройка отображения растра в параметрах слоя»

  • «Непосредственная настройка растрового объекта»

Параметры отображения растрового объекта (его цвета, прозрачность и т.д.) могут задаваться в настройках карты, слоя и самого объекта. Эти способы настройки отличаются как набором задаваемых параметров, так и методом их применения.

[Примечание] Примечание

Видеоурок по настройке отображения растра можно посмотреть, пройдя по одной из ссылок: https://youtu.be/tE6qvGctcd8 или https://www.politerm.com/videos/raster/nastroyka-otobrazheniya-rastrov/.

Параметры цветов растра, задаваемые в общих настройках карты, действуют на все растровые изображения в данной карте вне зависимости от настроек, указанных для конкретного слоя и изображения. Параметры действуют только в пределах данной карты и не влияют на отображение тех же слоев и растров в других картах («Настройка карты»).

Параметры, заданные в настройках растрового объекта, привязываются к этому объекту и применяются для его отображения во всех картах, в которых он используется.

Если какой-либо параметр отображения растрового слоя задан одновременно в настройках объекта и настройках карты, то в данной карте используются параметры, заданные в настройках карты.


Настройка отображения растра в параметрах слоя

Для настройки параметров растрового слоя в текущей карте:

  1. Выберите пункт меню Карта|Настройка слоя или нажмите на панели инструментов кнопку [image] .

  2. В появившемся окне Загруженные слои щелчком левой кнопки мыши выберите растровый слой и нажмите кнопку Настройка.

  3. Задайте необходимые параметры в открывшемся диалоге настройки.

    Во вкладке Общие диалога настраиваются общие параметры отображения слоя (вкладка аналогична соответствующей вкладке настроек векторного слоя):

    Окно настройки растрового слоя. Вкладка Общие

    Рисунок 113. Окно настройки растрового слоя. Вкладка Общие

    • флажок Отображать слой на карте включает и выключает отображение слоя на карте;

      [Подсказка] Подсказка

      Параметр соответствует свойству Layer.Visible.

    • флажок Отображать слой при печати – слой отображается при выводе на печать, только если данный флажок установлен;

      [Подсказка] Подсказка

      Параметр соответствует свойству Layer.Printable.

    • флажок Показ направлений для растрового слоя не используется;

    • флажок Отображать узлы для растрового слоя не используется;

    • В группе настроек Масштаб отображения задаются минимальный и максимальный масштаб, при котором слой не отображается на карте. Для того чтобы слой не отображался на карте при масштабе меньше определенного значения, установите флажок Не отображать при масштабе меньше, чем 1: и укажите минимальный масштаб в поле справа от флажка. Масштаб указывается или геодезический и в сантиметрах на пиксель, в зависимости от настроек системы.

      [Подсказка] Подсказка

      Параметр соответствует свойству Layer.MinScale.

      Для того чтобы слой не отображался на карте при масштабе больше определенного значения, установите флажок Не отображать при масштабе больше, чем 1: и укажите максимальный масштаб в поле справа от флажка. Масштаб указывается или геодезический и в сантиметрах на пиксель, в зависимости от настроек системы.

      [Подсказка] Подсказка

      Параметр соответствует свойству Layer.MaxScale.

    Во вкладке Параметры задаются цвета отображения растрового объекта:

    Окно настройки растрового слоя. Вкладка Параметры

    Рисунок 114. Окно настройки растрового слоя. Вкладка Параметры

    • флажки Использовать цвет линий и Использовать цвет фона позволяют установить цвета, выводимые для монохромного растра вместо его исходных цветов. Для задания требуемого цвета установите флажок и выберите цвет в поле справа от флажка;

    • флажок Прозрачный белый – установка этого флажка делает все белые области растра прозрачными;

    • поле Прозрачность устанавливает степень прозрачности растров. Прозрачность задается в процентах от 0 до 100.

  4. Для вступления в силу всех произведенных изменений установите флажок Использовать указанный стиль для всех таких объектов и нажмите кнопку ОК.

    [Внимание] Внимание

    Все настройки слоя сохраняются ТОЛЬКО при сохранении карты.

Также следует иметь в виду, что при настройке растрового слоя, приведенной выше, задается стиль ТОЛЬКО для отображения в данной карте. Если слой будет загружен в другую карту, то в новую карту эти настройки не передадутся.


Непосредственная настройка растрового объекта

[Предупреждение] Предупреждение

При задании настроек растрового объекта следует помнить, что изменения будут автоматически применены во всех картах, в которых уже есть данный растровый объект!

Для задания параметров растрового объекта:

  1. Сделайте редактируемым растровой слой, которому принадлежат требуемый объект ( [image] ).

  2. Войдите в режим выделения объектов ( [image] ).

  3. Дважды щелкните по растровому объекту (если необходимо настроить сразу несколько растровых объектов, то их надо предварительно выделить. Комбинация клавиш Ctrl+A позволяет выделить сразу все растровые объекты редактируемого слоя). Появится диалог настройки растрового объекта:

    Окно настройки растрового объекта

    Рисунок 115. Окно настройки растрового объекта

  4. Задайте требуемые настройки в диалоге:

    • Флажки Использовать цвет 1 и Использовать цвет 2 позволяют установить цвета, выводимые для монохромного растра вместо его исходных цветов. Для задания требуемого цвета установите флажок и выберите цвет в поле справа от флажка.

    • Флажок Прозрачный белый. Установка этого флажка делает все белые области растра прозрачными.

    • Поле Прозрачность устанавливает степень прозрачности растров. Прозрачность задается в процентах от 0 до 100. Возможно применение только прозрачного белого или общей прозрачности растра.

    • В том случае, если растр используется для анализа термограмм, то из списка Модель выбирается определенная модель термограммы. Подробнее познакомиться с термограммами возможно в справке по ZuluThermo, раздел Анализ термограмм.

    • Флажок Использовать постоянный кэш. Установка данного флажка включает использование постоянного кэша для растровых объектов, который не удаляется при выходе из программы, что при использовании большого количества растров значительно увеличивает скорость их загрузки. Если флажок сброшен, то для растровых объектов создаются временные файлы кэша, удаляемые при завершении работы системы и создаваемые повторно при следующей загрузке растров в систему, что может занять значительное время.

  5. Для подтверждения установки заданных настроек нажмите кнопку ОК.


Перемещение и масштабирование растровых объектов

После загрузки растрового слоя в карту его объекты могут масштабироваться и перемещаться. Эти операции могут выполняться как с помощью мыши, так и вводом координат и размера объекта с клавиатуры.

Для перемещения растрового объекта с помощью мыши:

  1. Сделайте растровой слой редактируемым ( [image] ).

  2. Войдите в режим выделения объектов ( [image] ).

  3. Подведите к объекту курсор, нажмите левую кнопку мыши и, не отпуская ее, начните перемещение объекта.

  4. Отпустите левую кнопку мыши на месте нового положения растрового объекта. Перемещение завершено.

Для перемещения группы растровых объектов с помощью мыши:

  1. Сделайте растровой слой редактируемым ( [image] ).

  2. Войдите в режим выделения объектов (кнопка [image] ).

  3. Выделите растровые объекты группы (если требуется выделить все объекты слоя, нажмите комбинацию клавиш Ctrl + A).

  4. Подведите к выделенной группе курсор, нажмите левую кнопку мыши и, не отпуская ее, начните перемещение объектов.

  5. Отпустите левую кнопку мыши на месте нового положения растрового объекта. Перемещение завершено.

Для масштабирования растрового объекта с помощью мыши:

  1. Сделайте растровой слой редактируемым ( [image] ).

  2. Войдите в режим выделения объектов ( [image] ).

  3. Выделите объект (подведите к объекту курсор и нажмите левую кнопку мыши). Выделенный объект окрасится заливкой выделения и по его контуру отобразятся узлы (черные квадраты).

  4. Подведите курсор мыши к одному из узлов, нажмите левую кнопку мыши и, не отпуская ее, перемещайте курсор по экрану, при этом узелок будет перемещаться за курсором, растягивая или сжимая растровый объект.

  5. Отпустите левую кнопку мыши, когда объект принял требуемые размеры. Изменение размера закончено.

Для масштабирования группы растровых объектов с помощью мыши:

  1. Сделайте растровой слой редактируемым ( [image] ).

  2. Войдите в режим выделения объектов ( [image] ).

  3. Выделите все растровые объекты группы (если требуется выделить все объекты слоя, нажмите комбинацию клавиш Ctrl-A). Выделенная группа объектов окрасится заливкой выделения и по ее контуру отобразятся узлы (черные квадраты).

  4. Подведите курсор мыши к одному из узлов, нажмите левую кнопку мыши и, не отпуская ее, перемещайте курсор по экрану, при этом узелок будет перемещаться за курсором, растягивая или сжимая группу растровых объектов.

  5. Отпустите левую кнопку мыши, когда группа приняла требуемые размеры. Изменение размера закончено.

Для ввода координат и размеров растрового объекта с помощью клавиатуры:

  1. Сделайте растровой слой редактируемым ( [image] ).

  2. Войдите в режим выделения объектов ( [image] ).

  3. Выделите объект (подведите к объекту курсор и нажмите левую кнопку мыши). Выделенный объект окрасится заливкой выделения и по его контуру отобразятся узлы (черные квадраты). Текущие координаты и размеры растрового объекта отобразятся в полях таблицы во вкладке Редактор панели свойств (панель открывается командой меню Окно|Свойства).

  4. В полях W и H вкладки Редактор отображается ширина и высота выделенного объекта, в полях X и Y – координаты его левого нижнего угла.

  5. Введите требуемые значения в полях и нажмите клавишу Enter. Объект переместится и изменит свой размер в соответствии с заданными значениями.

Для ввода координат и размеров группы растровых объектов с помощью клавиатуры:

  1. Сделайте растровой слой редактируемым ( [image] ).

  2. Войдите в режим выделения объектов ( [image] ).

  3. Выделите все растровые объекты группы (если требуется выделить все объекты слоя, нажмите комбинацию клавиш Ctrl-A). Выделенная группа объектов окрасится заливкой выделения и по ее контуру отобразятся узлы (черные квадраты). Текущие координаты и размеры группы отобразятся в полях таблицы во вкладке Редактор панели свойств (панель открывается командой меню Окно|Свойства).

  4. В полях W и H вкладки Редакторотображается ширина и высота выделенного объекта, в полях X и Y – координаты его левого нижнего угла.

  5. Введите требуемые значения в полях и нажмите клавишу Enter. Объект переместится и изменит свой размер в соответствии с заданными значениями.


Трансформирование растровых объектов

  • «Сдвиг»

  • «Масштабирование»

  • «Масштабирование с поворотом»

  • «Аффинная и проективная трансформации»

  • «Резиновый лист (локально-аффинное)»

  • «Управление трансформациями»

  • «Сохранение результатов трансформации»

При работе с пространственными данными часто возникает задача максимально точного их совмещения между собой и привязки к выбранной системе координат. Как правило, такая задача возникает при получении данных из разных источников. Типичным случаем является совмещение данных, оцифрованных с бумажных носителей, с уже имеющимися слоями карты, находящимися в плановой или географической системе координат.

Кроме того, трансформация данных часто требуется при обработке растровых изображений. Например, для растровых изображений, полученных в результате сканирования бумажных носителей, необходимо устранять нелинейные искажения, возникающие при сканировании. Для аэро- и космоснимков может понадобиться их геометрическое преобразование к текущей координатной системе карты. Выбор метода трансформации определяется исходя из конкретной задачи и характера искажений данных, которые надо устранить.

Методы трансформации:

  • «Сдвиг»

  • «Масштабирование»

  • «Масштабирование с поворотом»

  • «Аффинная и проективная трансформации»

  • «Резиновый лист (локально-аффинное)»


Сдвиг

При использовании данного метода происходит смещение данных по оси X и оси Y на величину, равную разнице между старыми и новыми координатами точки трансформации.

Метод требует задания 1-й пары точки трансформации.

Для сдвига растрового объекта:

  1. Сделайте растровой слой редактируемым ( [image] ).

  2. Нажмите на панели инструментов Редактор кнопку Трансформация слоя с экрана ( [image] ). Курсор примет вид [image] .

  3. Укажите точку, из которой надо переместить растровый объект, переместив курсор в эту точку и нажав левую кнопку мыши. После указания первой точки она отобразится на карте в виде кружка, ее координаты отобразятся также и в таблице на панели свойств системы (если она открыта), а курсор примет вид [image] .

  4. Аналогичным образом укажите вторую точку (куда надо переместить). Она отобразится в виде окружности.

  5. В рабочей области карты щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Сдвиг. Растровый объект переместится в новое место.

Используемые формулы:

X'= dx+X

Y'= dy+Y

где dx,dy – смещение по оси X и оси Y.


Масштабирование

Данный метод позволяет сделать следующие преобразования координат: изменять масштаб, смещать по оси X и оси Y.

Метод требует задания 2-х пар точек трансформации.

Для масштабирования растрового объекта:

  1. Сделайте растровой слой редактируемым ( [image] ).

  2. Нажмите на панели инструментов Редактор кнопку Трансформация слоя с экрана ( [image] ). Курсор примет вид [image] .

  3. Укажите точку, из которой надо переместить растровый объект, переместив курсор в эту точку и нажав левую кнопку мыши. После указания первой точки она отобразится на карте в виде кружка, ее координаты отобразятся также и в таблице на панели свойств системы (если она открыта), а курсор примет вид [image] .

  4. Аналогичным образом укажите следующую точку (куда надо переместить). Она отобразится в виде окружности.

  5. Повторите действия 3,4 для второй пары точек.

  6. В рабочей области карты щелкните правой кнопкой мыши и выберите в появившемся контекстном меню пункт Масштабирование. Растровый объект переместится и отмасштабируется.

В общем случае преобразование координат точки (X,Y) в новые координаты точки (X',Y') производится по формуле:

X' = dx + Xc + kx * (X - Xc)

Y' = dy + Yc + ky * (Y - Yc),

где:

  • dx, dy – смещение по оси X и оси Y;

  • kx ≠ ky – коэффициенты искажения масштаба по оси X и оси Y;

  • (Xc, Yc) – координаты точки поворота.


Масштабирование с поворотом

Данный метод позволяет выполнять следующие преобразования координат: изменять масштаб, смещать по оси X и оси Y, поворачивать данные на заданный угол вокруг заданного центра поворота.

Метод требует задания 2-х пар точек трансформации.

Для масштабирования с поворотом растрового объекта:

  1. Сделайте растровой слой редактируемым ( [image] ).

  2. Нажмите на панели инструментов Редактор кнопку Трансформация слоя с экрана ( [image] ). Курсор примет вид [image] .

  3. Укажите точку, из которой надо переместить растровый объект, переместив курсор в эту точку и нажав левую кнопку мыши. После указания первой точки она отобразится на карте в виде кружка, ее координаты отобразятся также и в таблице на панели свойств системы (если она открыта), а курсор примет вид [image] .

  4. Аналогичным образом укажите следующую точку (куда надо переместить). Она отобразится в виде окружности.

  5. Повторите действия 3,4 для второй пары точек.

  6. В рабочей области карты щелкните правой кнопкой мыши и выберите в появившемся контекстном меню пункт Масштабирование с поворотом. Растровый объект переместится и отмасштабируется.

В общем случае преобразование координат точки (X,Y) в новые координаты точки (X',Y') производится по формуле:

X'= dx+Xc+kx(X-Xc)cos(Fi)-ky(Y-Yc)sin(Fi)

Y'= dy+Yc+kx(X-Xc)sin(Fi)+ky(Y-Yc)cos(Fi),

где dx,dy – смещение по оси X и оси Y;

kx, ky – коэффициенты искажения масштаба по оси X и оси Y;

(Xc,Yc) – координаты точки поворота;

Fi – угол поворота.


Аффинная и проективная трансформации

Аффинная и проективная трансформация реализуется с помощью полиномиальной аппроксимации данных методом наименьших квадратов. Суть данного метода заключается в нахождении такого преобразования данных в новые координаты, при котором достигается наименьшая погрешность (невязка) между координатами заданных точек трансформации и значениями этих точек в новых координатах. В процессе ввода точек трансформации вы можете определить ожидаемую точность преобразования данных по значениям невязки – чем меньше значение невязки, тем точнее будет выполнено преобразование. Значение невязки отображается в панели Свойства (вкладка Трансформирование слоя, столбец E1).

В данном методе задача преобразования старых координат точки (X,Y) в новые координаты (X',Y') сводится к нахождению таких коэффициентов a1,...,an, b1,...,bn аппроксимирующего полинома, при которых минимизируется сумма квадратов отклонений заданных значений от построенной аппроксимирующей кривой:

Для аффинной трансформации:

X'= a1X + a2Y + a3

Y'= b1X + b2Y + b3

требуется задание не менее 3-х пар точек трансформации.

Рисунок 116. Аффинная трансформация

Для выполнения аффинной трансформации растрового объекта:

  1. Сделайте растровой слой редактируемым ( [image] ).

  2. Нажмите на панели инструментов Редактор кнопку Трансформация слоя с экрана ( [image] ). Курсор примет вид [image] .

  3. Укажите точку, из которой надо переместить растровый объект, переместив курсор в эту точку и нажав левую кнопку мыши. После указания первой точки она отобразится на карте в виде кружка, ее координаты отобразятся также и в таблице на панели свойств системы (если она открыта), а курсор примет вид [image] .

  4. Аналогичным образом укажите следующую точку (куда надо переместить). Она отобразится в виде окружности.

  5. Повторите действия 3,4 для второй и третьей пар точек.

  6. В рабочей области карты щелкните правой кнопкой мыши и выберите в появившемся контекстном меню пункт Аффинное (1 степени). Над растровым объектом будет соответствующее заданным точкам аффинное преобразование.

Для проективной трансформации полиномами 2-й степени:

X'= a1X2 + a2XY + a3Y2 + a4X + a5Y + a6

Y'= b1X2 + b2XY + b3Y2 + b4X + b5Y + b6

требуется задание не менее 6-и пар точек трансформации.

Проективная трансформация полиномами 2-й степени.

Рисунок 117. Проективная трансформация полиномами 2-й степени.

Для выполнения проективной трансформации 2-й степени растрового объекта:

  1. Сделайте растровой слой редактируемым ( [image] ).

  2. Нажмите на панели инструментов Редактор кнопку Трансформация слоя с экрана ( [image] ). Курсор примет вид [image] .

  3. Укажите точку, из которой надо переместить растровый объект, переместив курсор в эту точку и нажав левую кнопку мыши. После указания первой точки она отобразится на карте в виде кружка, ее координаты отобразятся также и в таблице на панели свойств системы (если она открыта), а курсор примет вид [image] .

  4. Аналогичным образом укажите следующую точку (куда надо переместить). Она отобразится в виде окружности.

  5. Повторите действия 3,4 еще для пяти пар точек.

  6. В рабочей области карты щелкните правой кнопкой мыши и выберите в появившемся контекстном меню пункт Проективное (2 степени). Над растровым объектом будет произведено соответствующее заданным точкам проективное преобразование 2 степени.


Резиновый лист (локально-аффинное)

Данный метод трансформации используется для устранения локальных искажений данных с помощью локально-аффинных преобразований. Суть данного метода заключается в нахождении такого преобразования данных в новые координаты, при котором координаты точек трансформации точно преобразуются в указанные новые координаты, а координаты остальных точек интерполируются с учетом изменения опорных точек трансформации. Зоной трансформации данных является область, состоящая из наименьшего выпуклого многоугольника, содержащего опорные точки трансформации.

Для данного метода требуется задание не менее 4-х пар точек трансформации.

В процессе данной трансформации производится также дополнительная коррекция растрового объекта – его обрезка. При необходимости этой коррекции можно избежать (см. ниже)

Рисунок 118. Резиновый лист

Для выполнения локально-аффинной трансформации растрового объекта:

  1. Сделайте растровой слой редактируемым ( [image] ).

  2. Нажмите на панели инструментов Редактор кнопку Трансформация слоя с экрана ( [image] ). Курсор примет вид [image] .

  3. Укажите границы обрезаемой области растрового объекта. Обрезка производится по контуру четырехугольника произвольной формы. Для установки области обрезки нажмите левую клавишу Alt и, не отпуская ее, переместите курсор на один из углов области обрезки и щелкните левой кнопкой мыши. В этой точке отобразится маркер. Таким же образом поставьте маркеры в остальных трех углах зоны обрезки. Для того чтобы при применении трансформации обрезка не проводилась, установите маркеры в углах растрового объекта.

  4. Задайте зону трансформации. На рисунке выше она указана голубым пунктиром. Зона трансформации представляет собой четырехугольник ограничивающий область локальных искажений. Если зона трансформации не задана, то локально-аффинная трансформация будет применяться ко всему растровому объекту. Для установки зоны трансформации нажмите левую клавишу Alt и, не отпуская ее, переместите курсор на один из углов предполагаемой зоны трансформации и щелкните левой кнопкой мыши. В этой точке отобразится маркер. Таким же образом поставьте маркеры в остальных трех углах зоны трансформации.

  5. Укажите точки локально-аффинной трансформации. Для этого:

    1. Укажите точку, из которой надо переместить растровый объект, переместив курсор в эту точку и нажав левую кнопку мыши. После указания первой точки она отобразится на карте в виде кружка, ее координаты отобразятся также и в таблице на панели свойств системы (если она открыта), а курсор примет вид [image] .

    2. Аналогичным образом укажите следующую точку (куда надо переместить). Она отобразится в виде окружности.

    3. Повторите действия 1,2 для оставшихся пар точек.

  6. В рабочей области карты щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Резиновый лист. В ограниченной области произойдет соответствующее заданным точкам локально-аффинное преобразование растрового объекта и его обрезка (если задана).


Управление трансформациями

При работе с трансформациями растровых объектов в ZuluGIS доступен ряд дополнительных действий:

Корректировка положения точек трансформации

Как уже отмечалось ранее, при задании точек трансформации их положения указываются в ячейках таблицы во вкладке Трансформирование слоя панели Свойства.

Для корректировки положения точки трансформации щелкните левой кнопкой мыши в таблице на ячейке требуемой точки и введите новые координаты. Точка передвинется в заданное положение.

Корректировку положения точек удобно использовать при двухэтапном задании точек трансформации: сначала с помощью мыши задаются примерные координаты точек трансформации, а затем они уточняются в таблице.

Отмена точек трансформации

Для отмены последней введенной точки трансформации нажмите клавишу Esc или щелкните правой кнопкой мыши по карте и в появившемся контекстном меню выберите пункт Отменить последнюю точку. Таким образом можно последовательно отменить ввод всех уже заданных точек трансформации.

Для отмены всех установленных точек трансформации щелкните правой кнопкой мыши по карте и в появившемся контекстном меню выберите пункт Очистить все.

Сохранение и загрузка точек трансформации

Для сохранения координат точек трансформации щелкните правой кнопкой мыши, в появившемся контекстном меню выберите пункт Сохранить точки трансформации и задайте имя для сохраняемого файла в появившемся диалоге.

Чтобы загрузить точки трансформации, щелкните правой кнопкой мыши, в появившемся контекстном меню выберите пункт Загрузить точки трансформации и выберите файл с координатами точек в открывшемся диалоге.

Отмена совершенных действий

Для отмены произведенных действий нажмите кнопку Отмена ( [image] ) на панели инструментов или щелкните правой кнопкой мыши по карте и выберите пункт Отменить действие в открывшемся контекстном меню.

Количество отменяемых действий не ограничено, но откат возможен только до выхода из режима редактирования.


Сохранение результатов трансформации

Для сохранения выполненных преобразований растрового объекта щелкните правой кнопкой мыши и в открывшемся контекстном меню выберите пункт Сохранить результат преобразования, после чего откроется диалог Сохранение результатов преобразования растра:

Диалог сохранения результатов преобразования

Рисунок 119. Диалог сохранения результатов преобразования

Результаты преобразования могут сохраняться как в текущем файле, так и в новом.

Для перезаписи текущего файла с сохранением его имени выберите переключатель Перезаписать текущий файл.

Для сохранения измененного растра в новом файле выберите переключатель Сохранить в новом файле. В этом случае дополнительно требуется задать следующие параметры:

  • Выбрать, требуется ли создавать для измененного растра объект на карте. Для создания нового объекта установите флажок Создать новый объект, в противном случае снимите его.

  • Если выбрано создание объекта, то выбрать, как будет добавляться объект в карту: с заменой текущего растрового объекта (переключатель Заменить текущий объект на карте) или как новый объект (переключатель Добавить новый объект в карту).

После задания настроек нажмите кнопку ОК диалога для сохранения растра.

Если результаты трансформации не сохранялись, то при закрытии карты отобразится запрос на сохранение: «Не сохранены результаты редактирования слоя. Сохранить?».

Для сохранения изменений растра нажмите кнопку Да, после чего откроется диалог сохранения результатов трансформации. Для закрытия карты без сохранения изменений в растре нажмите кнопку Нет.


Преобразование файлов растровых объектов сторонних программ

В системе предусмотрено преобразование используемых в картах описателей растров форматов MapInfo (файлы tab), OziExplorer (файлы map) или файлов World File (*.bpw, *.bmpw, *.tfw, *.tifw, *.jgw, *.jpgw, *.gfw, *.gifw, *.pgw, *.pngw) в формат описателя растра ZuluGIS (файлы zrs), а также конвертирование растров в картах в формат BMP. В том случае, если потребуется дальнейшая работа с такими растрами, то конвертация позволяет увеличить скорость и удобство работы с указанными объектами.

Для преобразования необходимо сначала загрузить растровые слои в ZuluGIS, а затем сделать следующие действия:

  1. Выполните команду меню Растр|Сохранить как. Откроется диалог преобразования растровых объектов.

    Диалог преобразования растровых объектов

    Рисунок 120. Диалог преобразования растровых объектов

  2. В диалоге сверху приведен список растровых объектов карты, доступных для преобразования. Установите флажки слева от объектов, которые требуется преобразовать (или установите флажок Все под списком, чтобы отметить сразу все объекты в списке).

  3. Если требуется перевести файлы растровых изображений в формат BMP, установите соответствующий флажок. Использование растров BMP формата значительно ускоряет работу с ними, так как для ZuluGIS такой формат является рабочим и для таких файлов возможно создать постоянный кэш. Новые файлы будут созданы в указанном в дальнейшем каталоге, исходные файлы при этом не изменяются.

  4. Для создания постоянных кэш-файлов поставьте флажок Создать постоянный кэш. Создание постоянного кэш-файла ускоряет загрузку объектов в карту, но потребляет некоторое пространство на диске. Такой кэш возможно создать только для файлов формата BMP.

  5. В строке Папка для записи нажмите кнопку [image] и укажите путь к папке для файлов преобразованных растровых объектов. Если путь к папке не указывать, то преобразованные объекты сохраняются в одной папке с исходными объектами. При указании папки надо быть внимательными, так как если не создаются дополнительные BMP файлы, то исходный растр и его описатель могут оказаться в разных местах, что в дальнейшем может создать проблемы при перемещении файлов.

  6. Нажмите кнопку ОК для выполнения преобразования и закрытия диалога. Кнопка Выход закрывает диалог без выполнения преобразования.

По завершении преобразования растровых объектов они замещают собой исходные объекты в карте. При этом файлы исходных объектов остаются нетронутыми.


Копирование растрового слоя

Копирование растрового слоя аналогично копированию векторного слоя.


Зональная статистика по растровым слоям

Использование зональной статистики позволяет вычислить статистику растрового изображения в области площадных объектов векторного слоя. Производится пересечение векторными объектами растра и подсчет статистики в рамках объектов. Статистика производится по модели RGB или по значению пикселя. По значению пикселя анализ может производиться, когда в файле хранится информация о температуре, то есть каждый пиксель – это число с плавающей точкой, в котором записана какая-то температура.

После подсчета статистики, если в семантической базе данных векторного слоя, в рамках объектов которого производится анализ, отсутствуют поля для записи данных, то они будут добавлены. Если же поля есть, то информация будет записана в них. В результате анализа могут быть добавлены следующие поля с готовой статистикой:

  • Count – количество;

  • Sum – сумма;

  • Mean – среднее;

  • Minimum – минимальное значение;

  • Maximum – максимальное значение.

Перед работой с зональной статистикой в карту должны быть загружены слой растра для анализа и векторный слой, в области объектов которого будет производиться анализ. К объектам векторного слоя обязательно должна быть подключена семантическая база данных. Если анализ требуется не по всем объектам векторного слоя, то надо заранее выделить объекты, в рамках которых по растру будет собрана зональная статистика.

На рисунке ниже показан растровый слой для статистики и векторный слой с сеткой, состоящей из прозрачных полигонов, в рамках которых будет производиться статистика.

Растр для статистики

Рисунок 121. Растр для статистики

Для запуска зональной статистики надо:

  1. Выбрать меню Растр|Зональная статистика.

  2. Из списка Растровый слой выбрать слой для анализа.

  3. Из списка Векторный слой выбрать слой с набором полигонов. Если в слое были выделены объекты, то установить опцию Только выделенные.

  4. Выбрать параметры для статистики, для этого надо установить нужную опцию:

    • Растровый канал – при указании данной опции также необходимо выбрать из списка канал для статистики;

    • Значение пикселя.

  5. В таблице проверить, чтобы были установлены галочки напротив полей, статистика по которым должна быть записана в базу данных. Справа при необходимости отредактировать поле для записи.

    Диалог зональной статистики

    Рисунок 122. Диалог зональной статистики

  6. Нажать кнопку ОК.

[Примечание] Примечание

Далее для анализа статистики возможно создать тематическую раскраску по результатам, например, по статистике растра, показанного выше:

Пример тематической окраски по результатам статистики

Рисунок 123. Пример тематической окраски по результатам статистики


Пример работы с растровыми объектами

[Примечание] Примечание

Подборку видеоуроков по работе с растрами вы можете найти на нашем сайте.

В приведенных ниже примерах используются уже существующие объекты 2529-01.tif и 2529-02.tif, находящиеся в каталоге Zulu/Tutorial.

Порядок работы с растровыми объектами:

  1. «Корректировка растра» (при необходимости).

  2. «Задание растрового объекта».

  3. «Группировка растров».


Корректировка растра

  1. Выберите пункт главного меню Растр|Корректировка.

  2. В появившемся окне корректировки нажмите кнопку [image] , в стандартном окне выбора в каталоге Zulu\Tutorial укажите файл 2529-01.tif и нажмите кнопку Открыть.

  3. Поверх загруженного растра отобразится сетка, опорные точки которой обозначены синими кружками. Нужное количество (в данном случае) ячеек опорной сетки по вертикали и горизонтали будет задано автоматически. Используя команды масштабирования и перемещения, совместите опорные точки сетки с соответствующими крестами на растре. Для совмещения точек:

    1. подведите курсор мыши к кружку первой опорной точки и захватить его, нажав и не отпуская левую клавишу мыши;

    2. установите курсор мыши с захваченным кружком в центр соответствующего опорной точке креста на растре;

    3. отпустите левую клавишу мыши, узел опорной сетки займет новое положение;

    4. повторите процесс с остальными опорными точками.

  4. После совмещения всех опорных точек растра нажатием кнопки [image] запустите процесс корректировки.

  5. Для сохранения растра нажмите на панели инструментов кнопку [image] и в поле Имя файла диалогового окна Сохранить как задайте имя растра: 2529-1.

  6. Проделайте пункты 2-5 для следующего растра 2529-02 и сохраните его под именем 2529-2.


Задание растрового объекта

Как было сказано ранее, задание растрового объекта может осуществляться двумя способами:

  • задание растра с непосредственным созданием описателя;

  • задание растра с добавлением растрового файла в карту.


Задание растра с непосредственным созданием описателя

  1. Выберите пункт главного меню Растр|Задать. Откроется диалог задания растра.

    Рисунок 124. Задание растра

  2. Нажмите кнопку Растровый файл и в стандартом окне выбора файла в каталоге Zulu\Tutorial с помощью левой кнопки мыши укажите файл 2529-01.tif (файл, сохраненный после корректировки растра).

  3. В разделе Точки привязки растра укажите координаты углов изображения (в см). Для растра 2529-01.tif масштаба 1:500, начинающегося с нулевых координат, задаются следующие координаты углов:

    • нажмите кнопку [image] и введите координаты левого нижнего угла – (0, 0);

    • нажмите кнопку [image] и введите координаты правого нижнего угла – (0, 25000).

  4. В разделе Параметры при желании использовать произвольный цвета растра установите флажки использовать цвет 1 и использовать цвет 2 и, нажав стрелку вниз, в окне выбора цвета выберите соответствующие цвета.

  5. Нажмите кнопку Сохранить и укажите название файла: 2529-01.zrs.

  6. Нажмите кнопку Новый, после чего произойдет очистка полей диалога Задание растра, и диалог будет готов к заданию параметров для следующего растра.

  7. Задайте следующий растр (2529-02.tif). Для этого повторите пункты 2-5, описанные выше, с тем исключением, что в списке Точки привязки растра (пункт 3) необходимо указать другие координаты углов изображения (в сантиметрах):

    • для левого нижнего угла – (0, 25000);

    • для правого нижнего угла – (0, 50000).

Растр 2529-02 (файл, сохраненный после корректировки растра) находится в каталоге Zulu\Tutorial.

Для загрузки растра в карту:

  1. Создайте карту (если карта еще не создана) командой Файл|Создать карту.

  2. В меню Карта выберите пункт Добавить слой, в стандартном окне выбора файла укажите файлы, созданные на предыдущем этапе, и нажмите кнопку Открыть.

    Рисунок 125. Выбор растра


Задание растра с непосредственным добавлением растрового файла в карту

  1. Создайте карту (если карта еще не создана) командой Файл|Создать|Новая карта.

  2. Выберите пункт главного меню Карта|Добавить слой.

  3. В появившемся диалоговом окне Выбор слоя в списке Тип файлов с помощью щелчка левой кнопки мыши выберите строку Файлы изображений (*.bmp;*.pcx;*.tiff;*.png;*.jpg;*.png).

    Выбор типа файлов

    Рисунок 126. Выбор типа файлов

  4. В каталоге Zulu\Tutorial левой кнопкой мыши укажите файл 2529-01.tif и нажмите кнопку Открыть.

    Выбранный файл будет добавлен в список слоев карты и его изображение появится в центре окна карты.

    Карта с загруженным растром

    Рисунок 127. Карта с загруженным растром

Для сохранения описателя растрового объекта:

  1. Сделайте растровый слой редактируемым ( [image] ).

  2. Щелкните правой кнопкой мыши в области открытой карты и в появившемся контекстном меню выберите команду Сохранить растровый объект.

  3. В диалоговом окне Сохранить как в строке Имя файла введите название для описателя растрового файла, например, Rastr_1 (расширение файла писать не надо).

  4. Нажмите кнопку Сохранить.

В результате выполнения описанного выше примера с непосредственным добавлением растрового файла в карту в итоге получается результат аналогичный первому варианту задания растра: с созданием описателя и последующим добавлением его в карту.

Ниже приведен пример изменения привязки для растрового файла, т.е. изменение его местоположения и масштаба на карте. Произвести изменения можно двумя способами: с помощью клавиатуры или мыши.

С помощью клавиатуры:

  1. Выполните команду меню Растр|Привязка. Откроется диалог задания растра.

    Задание растрового объекта

    Рисунок 128. Задание растрового объекта

  2. В полях Слой и Объект выберите требуемый растровый объект. В таблице точек привязки диалога отобразятся заданные координаты углов изображения (в см). Их можно изменить, для этого удалите уже установленные значения и внесите новые. Например, для растра масштаба 1:500 начинающегося с 0-х координат:

    • для левого нижнего угла – (0, 0);

    • для правого нижнего угла – (0, 25000).

    Цифра 25000 означает, что от левого нижнего угла растра до правого нижнего угла растра задается расстояние 250 метров, что соответствует масштабу 1:500.

  3. После внесенных изменений нажмите кнопку ОК.

С помощью мыши:

  1. Сделайте растровой файл редактируемым ( [image] ).

  2. Войдите в режим выделения объекта, для этого нажмите на панели инструментов кнопку [image] .

  3. Щелчком левой кнопки мыши выделите растр, после чего, удерживая кнопку, передвигайте растр по экрану или, «взявшись» за появившиеся узлы на растре, измените его размеры.


Группировка растров

Если в карту необходимо загрузить несколько растров, то для более удобной работы с ними их можно (но не обязательно) сгруппировать. Сгруппированным растрам дается одно общее название.

Для группировки растров:

  1. Выберите пункт меню Растр|Сгруппировать.

  2. В окне добавления растров нажмите кнопку Добавить.

  3. Выберите растры, созданные на предыдущем этапе (2529-1.ZRS, 2529-2.ZRS), и нажмите кнопку Открыть.

  4. Нажмите кнопку Сохранить и в появившемся диалоговом окне Сохранить как в строке Имя файла дайте название растровой группе, например, gruppa.

  5. Нажмите кнопку Закрыть.

    Создание растровой группы

    Рисунок 129. Создание растровой группы

Для загрузки растровой группы в карту:

  1. Создайте карту (если карта еще не создана) командой Файл|Создать карту.

  2. В меню Карта выберите пункт Добавить слой и в стандартном окне выбора файла укажите файл группы (gruppa.zrg).

После проделанных операций в карту загрузится группа растров.


Векторный слой

Как было сказано ранее, векторный слой – это слой с векторными данными, содержащий векторные объекты. Векторные слои могут быть различной тематики, например, содержать дорожную сеть, лесные насаждения, кварталы, дома, зоны влияния и еще множество разной информации.

Далее подробно рассмотрены темы создания векторного слоя, структура слоя и описаны операции с векторными слоями.


Создание векторного слоя

В системе ZuluGIS предусмотрено несколько вариантов создания нового векторного слоя:

  • Создание простого слоя. Такой слой, как правило, создается для хранения пространственной информации, такой как дома, кварталы и т.д.

  • Создание слоя инженерной сети (тепловой, водопроводной, газовой, паровой, канализационной). Если требуется слой сети, отличающийся от ранее перечисленных, то можно разработать самостоятельно свою сеть.

  • Создание нового слоя по образцу.

Любой векторный слой может создаваться как в локальной системе декартовых координат, так и в различных географических системах координат.

Простые векторные слои нужны для введения в карту различной пространственной информации общего характера, например, расположения зданий, кварталов, лесных насаждений, дорог и т.д.

Слои сети создаются уже определенного типа (тепловая, водопроводная и т.п.) и уже с готовой структурой. При создании слоя инженерной сети в его структуру автоматически добавляется набор типовых объектов и готовые базы данных выбранного типа сети.


Создание нового слоя

Имеется возможность создать как простой пустой векторный слой так и векторный слой и одновременно с базой данных.

Кроме базы данных в созданном слое будет уже настроено правило на добавление объектов (при добавлении любого объекта в слой к нему будет автоматически создана запись в таблице).

[Примечание] Примечание

Видеоурок по созданию слоя можно посмотреть пройдя по одной из ссылок: https://youtu.be/UICs-sgD2Pk или https://www.politerm.com/videos/layerstruct/sozdanie-sloya/.

Для создания такого слоя надо:

  1. Выбрать пункт главного меню Слой| [image] Создать... или пункт меню Файл|Создать|Слой| [image] Создать... Новый слой... или сделать щелчок правой кнопкой мыши на названии карты в панели Рабочее место и выбрать в контекстном меню пункт Создать слой.

  2. В открывшемся стандартном окне указать каталог для создаваемого слоя. При работе в однопользовательской версии (ZuluGIS) каталог должен располагаться на локальной машине. При работе в многопользовательской версии (ZuluServer) каталог должен располагаться на Сервере геоданных. Для доступа к нему надо нажать кнопку Серверы геоданных, расположенную в левой части окна:

    Пример диалога создания слоя с базой данных

    Рисунок 130. Пример диалога создания слоя с базой данных

    После указания каталога в строке Имя файла ввести имя файла слоя и нажать кнопку Сохранить. Если выбрано имя файла уже существующего слоя, то в результате создания нового слоя существующий слой будет УНИЧТОЖЕН, а новый будет создан на его месте. Имя слоя не должно содержать специальные символы, например \ / | : * ? " < >.

  3. В строке Название слоя автоматически повторяется ранее введенное имя, можно ввести отличное название. Желательно, чтобы пользовательское название слоя отображало тематику содержимого создаваемого слоя. Данное наименование будет использоваться при дальнейшем добавлении слоя в карту. При просмотре созданных файлов стандартными средствами операционной системы будет отображаться Имя файла.

  4. Для задания системы координат слоя надо нажать кнопку Система координат (списки поддерживаемых типов проекций и датумов см. Поддерживаемые типы проекций и датумы ). Если система координат для слоя указана не будет, то слой будет создан в системе координат карты.

  5. При создании слоя без базы, данный пункт следует пропустить. В том случае, если требуется не только создание слоя, но и одновременно создание базы данных установите опцию Создать таблицу. Окно будет изменено и появится диалог для указания полей таблицы, затем:

    • из списка Источник выбрать источник данных для таблиц, если нужного источника в списке нет, то добавить новый;

    • в создаваемой таблице необходимо указать имя и тип полей, подробней о создании таблиц можно узнать в разделе «Создание таблицы».

  6. Установить флажок добавить в карту для автоматического добавления слоя в текущую карту.

  7. После того, как все параметры диалога создания слоя заданы, нажать кнопку OK, что и завершит создание слоя.

    Пример диалога создания слоя без базы данных

    Рисунок 131. Пример диалога создания слоя без базы данных

    Пример диалога создания слоя с базой данных

    Рисунок 132. Пример диалога создания слоя с базой данных

После выполнения действий будет создан векторный слой (без объектов). Если при создании слоя устанавливалась опция Создать таблицу и были заданы поля для базы, то в данном слое уже будет создана база данных в состав которой будет включена таблица с указанными полями и разработан запрос (представление окна информации).

При необходимости созданную базу данных в имеется возможность изменить, например добавить/удалить поля, сделать их группировку, настроить цвет полей, подключить справочники, настроить всплывающие подсказки и др. как это сделать можно узнать в разделе «Редактирование и настройка базы данных».

Так же в созданном слое уже настроено правило редактора на добавление объектов.

В том случае, если был установлен флажок добавить в карту, созданный слой загружается в текущую карту.


Создание слоя инженерной сети

[Примечание] Примечание

Видеоурок по созданию слоя тепловой сети можно посмотреть пройдя по одной из ссылок: https://youtu.be/4sUsTyivhOY или https://www.politerm.com/videos/network/sozdanie-teplovoy-seti/.

Видеоурок по созданию слоя водопроводной сети можно посмотреть пройдя по одной из ссылок: https://youtu.be/BM6AvD-aDq8 или https://www.politerm.com/videos/network/sozdanie-vodoprovodnoy-seti/.

Общий видеоурок по созданию слоя инженерной сети можно посмотреть пройдя по ссылке: https://www.politerm.com/videos/network/layer_create_set/.

При создании слоя инженерной сети автоматически формируется слой с базовой структурой (набор типов, режимов, условных обозначений, баз данных, таблицы с атрибутами) необходимой для выполнения гидравлических расчетов. В дальнейшем структура слоя может настраиваться и дополняться новыми элементами.

Для создания слоя тепловой (водопроводной, паровой, газовой, канализационной) сети надо:

  1. Выбрать меню Слой|Создать инженерную сеть|Теплоснабжение (Водоснабжение, Пароснабжение, Газоснабжение, Канализация) соответственно.

    или

    В меню Задачи выбрать пункт ZuluThermo (ZuluHydro, ZuluSteam, ZuluGaz, ZuluDrain) или нажать на панели инструментов соответствующую кнопку [image] ( [image] , [image] , [image] , [image] ). Затем в появившемся диалоговом окне во вкладке Сервис нажать кнопку Создать новую сеть.

  2. В открывшемся стандартном окне выбрать диск и каталог, в котором будут храниться графические файлы, ввести имя файла слоя. Слой сети необходимо создавать в отдельной папке!

    При работе в многопользовательской версии (ZuluServer) каталог должен располагаться на Сервере геоданных. Для доступа к нему надо нажать кнопку Серверы геоданных, расположенную в левой части окна.

    В строке Имя файла ввести имя файла слоя и нажать кнопку Сохранить. Если выбрано имя файла уже существующего слоя, то в результате создания нового слоя существующий слой будет УНИЧТОЖЕН, а новый будет создан на его месте. Имя слоя не должно содержать специальные символы, например \ / | : * ? " < >.

  3. В строке Название слоя автоматически повторяется ранее введенное имя, можно ввести отличное название. Желательно, чтобы пользовательское название слоя отображало тематику содержимого создаваемого слоя. Данное наименование будет использоваться при дальнейшем добавлении слоя в карту. При просмотре созданных файлов стандартными средствами операционной системы будет отображаться Имя файла.

  4. Для задания системы координат слоя надо нажать кнопку Система координат (списки поддерживаемых типов проекций и датумов можно узнать в разделе Поддерживаемые типы проекций и датумы ). Если система координат для слоя указана не будет, то слой будет создан в системе координат карты.

  5. Так как при создании слоя инженерных сетей к объектам автоматически будут создаваться базы данных, то необходимо из списка Таблицы выбрать источник данных для таблиц, если нужного источника в списке нет, то добавить новый. При использовании многопользовательской версии (ZuluServer) рекомендуется выбирать собственные источники данных, созданные с применением клиент-серверных баз данных (Microsoft SQL Server, PostgreSQL, Oracle Database и т.п).

  6. При необходимости сразу добавить слой в текущую карту установите опцию добавить в карту.

    Окно создания нового слоя тепловой сети

    Рисунок 133. Окно создания нового слоя тепловой сети

  7. Для завершения создания слоя нажать кнопку ОК.

[Подсказка] Подсказка

Создание слоя с заданными параметрами соответствует методу ZuluCtrl.Tools.LayerCreate.


Создание нового слоя по образцу

Любой из созданных векторных слоев в процессе работы пользователь самостоятельно может «дорабатывать»:

  • в структуре слоя добавлять типы и режимы;

  • настраивать символы, стили линий и заливки;

  • создавать бирки;

  • создавать тематические раскраски;

  • настраивать поля базы данных;

  • настраивать правила редактора;

  • настраивать шаблоны быстрого поиска;

  • в инженерных сетях делать настройки расчетов, справочников насосов, опций;

  • в сетях водоотведения и газопровода настраивать расчетную модель.

[Примечание] Примечание

Видеоурок по созданию слоя по образцу можно посмотреть пройдя по одной из ссылок: https://youtu.be/MlIVuas69HQ или https://www.politerm.com/videos/layerstruct/sozdanie-sloya-po-obraztsu/.

Именно поэтому рекомендуется разработать «эталонный» слой с оптимальным наполнением, то есть заранее продумать и настроить: структуру слоя (типы, режимы, символы, размеры), настроить базу данных (поля в базах, настройки запросов), настроить расчетные сортаменты и т.д. по необходимости.

И в дальнейшем, когда понадобиться новый слой с такими же настройками его надо создавать по образцу «эталонного». Для этого:

  1. В меню Слой выберите команду Создать по образцу….

  2. В стандартном окне выбора фала укажите слой, по образцу которого надо создать новый.

  3. Справа от строки Имя в разделе Новый слой нажмите кнопку Обзор... и укажите каталог для нового файла слоя. При работе в однопользовательской версии (ZuluGIS) каталог должен располагаться на локальной машине. При работе в многопользовательской версии (ZuluServer) каталог должен располагаться на Сервере геоданных, для доступа к нему надо нажать кнопку Серверы геоданных, расположенную в левой части окна.

    После указания каталога в строке Имя файла введите имя файла слоя и нажмите кнопку Сохранить. Если выбрано имя файла уже существующего слоя, то в результате создания нового слоя существующий слой будет УНИЧТОЖЕН, а новый будет создан на его месте. Имя слоя не должно содержать специальные символы, например \ / | : * ? " < >.

  4. В поле Название слоя возможно задать пользовательское название отличное от имени файла.

  5. В разделе Система координат выберите проекцию для создаваемого слоя:

    • Взять с карты - система координат будет взята с текущей карты;

    • Взять у исходного слоя - система координат будет взята у «эталонного» слоя;

    • Задать заново - после выбора данной опции надо нажать кнопку Система координат и выбрать или импортировать нужную.

  6. Если необходимо поменять источник данных для хранения табличной информации (например, из Access в SQLite), выберите новый из списка Источник для таблиц. Если менять источник не требуется, пропустите данный пункт.

  7. Для автоматического добавления в текущую карту нового слоя установите флажок Добавить в карту.

    Диалоговое окно Создать слой по образцу

    Рисунок 134. Диалоговое окно Создать слой по образцу

  8. Нажмите кнопку ОК чтобы начать процесс создания нового слоя по образцу.

В результате проделанных действий будет получен пустой слой, структура которого будет являться полной копией «эталонного» слоя.


Структура слоя

  • «Открытие структуры слоя»

Для любого векторного слоя можно настроить собственную структуру. В первую очередь в структуре указывается имя, расположение и используемая система координат слоя.

В структуре могут быть настроены различные стили для линейных, площадных объектов, созданы графические символы, которые возможно использовать для ввода на карту нетипизированных символьных объектов (примитивов) и типовых объектов. Также символы могут использоваться в стилях линейных объектов и стилях заливки площадных объектов.

Так же через структуру может создаваться, редактироваться и подключаться база данных к объектам слоя.

Помимо ранее перечисленного в структуре указываются типовые графические объекты. Каждый типовой объект может иметь несколько режимов (обычно связываемых с режимами работы объекта в инженерной сети). С каждым режимом типового объекта связан отдельный символ библиотеки символов, эти символы используются для отображения режима типового объекта на карте. Типовые объекты слоя образуют структуру сети. Под структурой сети подразумеваются объекты (узлы) и связи (участки) сети, их условные обозначения, режимы функционирования каждого объекта и структура таблиц (семантических данных), связанных с этими объектами. В основе математической модели сети лежит граф, состоящий из узлов, соединенных дугами. В любой сети можно выделить свой набор узловых элементов и дуг. Так в теплоснабжении узлы – это источники, тепловые камеры, потребители, насосные станции, запорная арматура и прочие, а дуги – трубопроводы. Типовые графические объекты связываются только с семантической базой своего типа.

Все операции по изменению структуры слоя производятся в диалоге Структура слоя, с помощью диалога можно:

  • Настроить параметры слоя - изменить пользовательское название, описание, систему координат (см. раздел «Параметры слоя»).

  • Работать с символами:

    • создать, удалить или отредактировать символы, поменять ID символа (см. раздел «Символы», «Редактор символов»);

    • поменять размеры символов (см. раздел «Изменение размеров символов»).

  • Работать с стилями линий:

    • создать, удалить или отредактировать стили линейных объектов (см. раздел «Стили линий», «Редактор стиля линий»).

  • Работать с заливками (стилями площадных объектов):

    • создать, удалить или отредактировать заливки (см. раздел «Заливки», «Редактор стиля заливки»).

  • Импортировать элементы (символы, заливки, стили линий) из другого слоя (см. раздел «Импорт элементов из других слоев»);

  • Работать с базами данных:

    • создать, удалить или редактировать базу данных (см. раздел «Общие сведения»);

    • ознакомиться со списком всех баз данных слоя (см. раздел «Список баз данных слоя»);

    • подключить базу данных к простому объекту слоя (см. раздел «Назначение базы данных простым объектам»);

    • подключить базу данных к типовому объекту слоя (см. раздел «Назначение базы данных типовым объектам»).

  • Настроить правила для слоя:

    • создать правила для редактирования слоя (см. раздел «Правила Редактора»);

    • включить правила для надписей (см. раздел «Правила для надписей (бирок)»);

    • включить правило для копирования объектов (см. раздел «Правило при копировании объектов»);

    • создать правила для быстрого поиска (см. раздел «Правила Поиска»).

  • Настроить порядок отображения объектов в слое («Настройка порядка отображения объектов»)

  • Работать с типами и режимами слоя:

    • создать, удалить или редактировать типы (см. раздел «Работа с типами»);

    • создать, удалить или редактировать режимы (см. раздел «Работа с режимами»);

    • импортировать типы и режимы (см. раздел «Импорт типов и режимов»);

    • печатать список типов и режимов слоя (см. раздел «Печать списка типов и режимов»).

[Важно] Важно

Необходимо помнить, что при создании слоя инженерной сети (тепловой, водопроводной, газовой, паровой, канализационной) через меню Задачи (см. «Создание слоя инженерной сети»), создается слой с уже определенной структурой, заданными библиотеками символов, типами объектов, а так же с готовыми базами данных. Поэтому создавать структуру для такого слоя заново НЕ ТРЕБУЕТСЯ.

[Примечание] Примечание

Видеоролик по работе с типами и режимами вы можете найти на нашем сайте.

  • «Пример создания типовых объектов»

  • «Пример создания дополнительного режима для уже существующего типа объекта»

Пример создания типовых объектов

Рассмотрим создание типовых объектов на примере решения транспортных задач. Вне зависимости от предполагаемого применения ZuluGIS изучение этого примера будет полезно для обучения созданию любых видов типовых объектов.

До создания типовых объектов предварительно создайте простой векторный слой. простой векторный слой с названием Дороги. При создании слоя вы можете одновременно создать базу данных, которую в дальнейшем можно подключить к одному из типов объектов.

Для создания слоя:

  1. Выберите пункт меню Слой|Создать.

  2. В открывшемся диалоговом окне укажите расположение создаваемого слоя и внесите название файла, нажмите кнопку Сохранить.

  3. Выберите систему координат слою, для этого нажмите кнопку Система координат. Если система координат для слоя указана не будет, то слой будет создан в системе координат карты.

  4. Для создания базы данных установите галочку Создать таблицу.

  5. В качестве примера добавим одно поле с наименованием дорог. Внесите в столбец Имя поля - Название, из столбца Тип выберите - Строковое, длину измените на 100.

  6. Проверьте чтобы была установлена галочка Добавить в карту.

  7. Нажмите кнопку ОК.

    Создание типа объекта

    Рисунок 267. Создание типа объекта

Слой будет создан и добавлен в открытую карту.

Для создания типовых объектов слоя:

  1. Откройте структуру слоя Дороги. Для этого щелкните правой кнопкой мыши по слою Дороги в панели Рабочее место и выберите в открывшемся контекстном меню пункт Структура. Откроется диалог Структура слоя.

  2. Добавьте тип Дорога. Для этого, в диалоге структуры слоя нажмите кнопку [image] Новый и в открывшемся списке выберите пункт Новый тип.

  3. В поле Название области настроек типа напишите: Дорога.

  4. В группе настроек Графический тип: включите переключатель Линейный, и установите флажки участок и отсекающий.

  5. Подключите к типу базу данных. Для этого из списка База данных выберите базу Дороги.

    Создание типа объекта

    Рисунок 268. Создание типа объекта

    Так как по умолчанию создаваемая база подключена к примитивам слоя, то от них базу надо отключить. Укажите в дереве слева пункт Примитивы, справа из списка выберите нет базы данных.

  6. Добавьте в созданный тип режим Двустороннее движение. Для этого выделите тип Дорога, сделайте щелчок правой кнопкой мыши и в открывшемся контекстном меню выберите Новый режим.

  7. В поле Название области настроек режима напишите: Двустороннее движение.

  8. Установите цвет отображаемой линии, стиль, толщину линии при печати и толщину линии на экране. В поле со списком Состояние установите значение Включен.

    Создание режима объекта

    Рисунок 269. Создание режима объекта

  9. Добавьте к типу Дорога режим Одностороннее движение. Для этого выделите тип Дорога, сделайте щелчок правой кнопкой мыши и в открывшемся контекстном меню выберите Новый режим. В поле название введите: Одностороннее движение, задайте цвет отображаемой линии, стиль и толщину. В поле Состояние выберите значение Прямая проводимость. Данный режим проводит по направлению ввода (по стрелке).

  10. Аналогичным образом добавьте режим с названием Проезд закрыт. Установите для него цвет отображаемой линии, стиль и толщину. В поле Состояние выберите значение Отключен.

  11. Так как в основе математической модели сети лежит граф, а он состоит из узлов соединенных дугами, то возникает необходимость создать типовой объект, который будет играть роль узлов в графе. Для создания типа нажмите кнопку [image] Новый и в открывшемся меню выберите пункт Новый тип.

  12. В поле Название настроек типа напишите: Перекресток, В группе настроек Графический тип включите переключатель Символьный, установите флажок объект инженерных сетей и включите переключатель узел. Подключите к нему ту же базу данных, для этого из списка База данных выберите базу Дороги.

  13. Создайте для типа Перекресток новый режим с таким же названием.

  14. Создайте символ режима. Для этого нажмите кнопку Новый в области настроек режима и в открывшемся окне графического редактора на панели редактора выберите инструмент для рисования символа (например [image] – ввод эллиптического контура).

  15. На панели форматирования задайте параметры создаваемого объекта. Диалог настроек стиля контура открывается кнопкой [image] , задаются цвет узора, узор (по умолчанию узором является сплошная заливка цветом), толщина, цвет и стиль линии.

  16. В рабочем поле окна редактора в центре нарисуйте символ (например, окружность).

    Редактирование символа узла

    Рисунок 270. Редактирование символа узла

  17. Нажмите кнопку [image] чтобы сохранить символ и закройте окно редактора.

  18. Сохраните всю структуру слоя нажав кнопку [image] Сохранить.

  19. После проделанных действий в окне Структура слоя, в дереве типов и режимов будут отображены все созданные типы режимы.

Диалог «Структура слоя»

Рисунок 271. Диалог «Структура слоя»

После создания структуры слоя типовые объекты можно наносить на карту. Процесс нанесения дорожной сети аналогичен нанесению инженерной сети (см. справку ZuluThermo, ZuluHydro, ZuluSteam, ZuluGaz).

На рисунке, представленном ниже, изображена карта с нанесенной дорожной сетью, на которой найден самый короткий путь от одной заданной точки до другой с учетом направлений (подробно про поиск пути см. «Поиск пути по графу»).

Изображение карты с нанесенной дорожной сетью

Рисунок 272. Изображение карты с нанесенной дорожной сетью

Пример создания дополнительного режима для уже существующего типа объекта

Как уже говорилось ранее, при создании нового слоя тепловой (водопроводной, газовой, паровой, канализационной) сети автоматически создаются файлы графической базы данных с типовой структурой, таблицы и описатели семантической информации для каждого типового объекта.

Структура слоя тепловой сети

Рисунок 273. Структура слоя тепловой сети

Для работы со структурой слоя откройте диалог Структура слоя. Для этого выберите пункт меню Слой|Структура слоя... (или нажмите на панели инструментов кнопку [image] ), в появившемся стандартном окне выбора выберите требуемый и нажмите кнопку Открыть. Либо щелкните правой кнопкой мыши по названию слоя в панели Рабочее место и выберите в открывшемся контекстном меню пункт Структура. Откроется диалог Структура слоя.

Диалоговое окно разделено на две части, в зависимости от того, какой пункт выделен с левой стороны, справа будут происходить соответствующие изменения, то есть будет отображаться информация, относящаяся к выбранному пункту.

Так как выбранный слой уже имеет типовые объекты, то они отображаются слева в дереве типов и режимов (см. рисунок выше). Тип объектов можно увидеть сразу (Источник, Узел, Потребитель и прочие), а для просмотра режимов, которые содержаться в типе нажмите на значок «+», находящийся рядом с интересующим типом.

Структура слоя тепловой сети

Рисунок 274. Структура слоя тепловой сети

При выделении пункта Символы выводится библиотека символов данного слоя. Причем любой символ можно отредактировать и даже создать новый.

Ниже рассматривается пример создания режима для уже существующего типового объекта.

[Важно] Важно

Расчетный модуль ZuluThermo (ZuluHydro, ZuluSteam, ZuluGaz, ZuluDrain) может использовать в расчетах только ту информацию, которая предусмотрена разработчиками (то есть автоматически добавляемую при создании слоя соответствующей сети). Поэтому в слое тепловых (водо-, паро-, газопроводных, канализационных) сетей создавать новые типы объектов можно только в том случае, если они не будут участвовать в расчетах. А для уже существующих типов объектов создавать режимы можно только для типов «Узел», «Потребитель», «Участок».

Так как работа со структурой слоя аналогична для всех слоев, то будет рассмотрен только пример создания дополнительного режима для типа Узел тепловой сети.

  1. Выберите в разделе Типы и режимы структуры слоя.

Если нажать на «+» рядом с типом Узел, то откроется список его режимов:

  • Тепловая камера;

  • Разветвление;

  • Смена диаметра.

Предположим надо добавить новый режим, который будет называться Смена типа прокладки. Для его добавления:

  1. Выделите левой кнопкой мыши в дереве тип Узел, нажмите на панели инструментов диалога кнопку [image] Новый... и в открывшемся списке укажите Новый режим или выберите пункт меню Правка|Новый режим....

  2. В появившейся вкладке Режим в строке Название введите название создаваемого режима: Смена типа прокладки.

  3. Нажмите кнопку Новый и в окне редактора символов нарисуйте символ для отображения смены прокладки.

    Рисунок 275. Редактор символов

  4. Нажмите кнопку Сохранить и закройте окно редактора.

  5. Созданный режим отобразятся в дереве типов и режимов окна Структура слоя:

    Структура слоя тепловой сети

    Рисунок 276. Структура слоя тепловой сети

    Сохраните всю структуру слоя- кнопка [image] Сохранить.


Открытие структуры слоя

Все изменения структуры возможны только через диалог Структура слоя, перед его открытием проверьте чтобы слой не редактировался. Если слой в момент открытия будет редактироваться, то система выдаст сообщение: «В данный момент этот слой уже кто то редактирует». В этом случае следует нажать кнопку ОК и снять редактирование слоя ( [image] ).

Открыть Структуру слоя можно любым из следующих способов:

  • Выбрать пункт главного меню Слой|Структура слоя.

  • Нажать на панели инструментов кнопку [image] . В открывшемся диалоге выбора файлов указать файл требуемого слоя и нажмите кнопку Открыть.

  • Нажать правой кнопкой мыши по названию слоя в панели Рабочее место и выбрать в открывшемся контекстном меню пункт Структура.

  • Нажать кнопку Структура в диалоге Загруженные слои.

Диалог структуры слоя

Рисунок 135. Диалог структуры слоя

Диалог разделен на две части. В левой панели диалога представлено дерево структуры слоя. В правой части диалога отображаются настройки выбранного элемента структуры.

В дереве структуры содержатся все элементы структуры слоя. Далее представлено краткое описание элементов дерева структуры слоя:

  • Слой - содержит параметры слоя, возможно изменение пользовательского названия слоя, просмотр название файлов слоя и путь к ним, изменение системы координат слоя.

  • Символы - содержит библиотеку графических символов слоя. Возможно добавление новых и редактирование существующих символов, изменение размеров символов, изменение ID символа, а также импорт символов из других слоев.

  • Линии - содержит библиотеку стилей линейных объектов слоя. Возможно создание, редактирование и удаление таких стилей, импорт стилей из других слоев.

  • Заливки - библиотека стилей заливок площадных объектов слоя. Возможно создание, редактирование и удаление таких стилей, импорт стилей из других слоев.

  • Базы данных - содержит список баз данных слоя. Возможно создание и импорт баз данных, их правка и удаление.

  • Правила - содержит список правил слоя: Правила Редактора и Правила быстрого поиска.

  • Примитивы - позволяет подключить базу данных к нетипизированным объектам слоя (примитивам).

  • Типы и режимы - содержит список типовых объектов слоя и их режимы. Предусмотрен импорт типов и режимов из других слоев, создание и редактирование типов и режимов.

Для сохранения изменений внесенный в структуру слоя требуется нажать кнопку [image] Сохранить в панели инструментов диалога. Если при закрытии диалога в структуре слоя будут не сохраненные изменения, то будет предложено сохранить их.

[Примечание] Примечание

Пример создания типовых объектов для решения транспортных задач можно посмотреть «Пример создания типовых объектов». Пример создания дополнительного режима для уже существующего типа объекта можно посмотреть «Пример создания дополнительного режима для уже существующего типа объекта».


Параметры слоя

  • «Задание проекции слоя»

Для перехода к параметрам слоя выберите пункт Слой дерева структуры в окне Структура слоя:

Диалог структуры слоя

Рисунок 136. Диалог структуры слоя

В правой части окна откроется информация о параметрах слоя:

  • В поле Название приводится пользовательское название слоя. Для его изменения удалите текущее название и введите новое, затем нажмите кнопку Сохранить.

  • В поле Семейство файлов отображается название семейства файлов слоя – названия файлов, в которых хранится структура слоя начинаются с указанной в данном поле последовательности символов.

  • В поле Размещение указывается путь к каталогу, в котором располагаются файлы слоя.

  • Описание - текстовое поле для краткого описания слоя.

  • Кнопка Изменить в строке Система координат открывает диалог параметров картографической проекции хранения данных слоя.


Задание проекции слоя

Диалог параметров проекции слоя

Рисунок 137. Диалог параметров проекции слоя

Назначение слою проекции отличной от план-схемы дает возможность отображать его в абсолютно любой системе координат.

[Примечание] Примечание

Подробней о проекции слоя можно узнать в соответствующем разделе: «Проекция слоя».

Проекцию можно выбрать из списка готовых проекций (предложены наиболее часто используемые проекции), задать параметры проекции вручную, выбрать по слою карты, либо импортировать.

  • Выбор готовой проекции.

    Для указания готовой проекции, выберите тип проекции в поле типов проекций, после чего выберите требуемую проекцию в списке проекций. В области параметров проекции отобразится список параметров выбранной проекции, но без возможности редактирования.

  • Задание проекции вручную.

    Для задания параметров проекции вручную, выберите в поле выбора типа проекции значение Задать. Задайте настройки проекции в полях области параметров проекции.

  • Выбор параметров проекции по слою карты.

    Чтобы настроить параметры проекции точно такие же как у слоя загруженного в текущую карту надо в поле выбора типа проекции указать пункт Выбрать по слою карты, после чего в списке загруженных слоев выбрать нужный слой.

  • Импорт параметров проекции.

    Параметры могут быть импортированы:

    • из указанного локального или серверного слоя ZuluGIS;

    • из файла PRJ;

    • из строки WKT;

    • из строки формата MapInfo.prj;

    • из строки формата proj4.

    Подробней об импорте возможно узнать в разделе «Импорт параметров системы координат».

После завершения настройки проекции карты нажмите кнопку ОК диалога, чтобы сохранить изменения и закрыть диалог.


Символы

  • «Создание нового символа библиотеки символов»

  • «Редактирование символа библиотеки символов»

  • «Копирование символа»

  • «Удаление символа из библиотеки»

  • «Смена ID символа»

  • «Редактор символов»

  • «Изменение размеров символов»

[Примечание] Примечание

Видеоурок по работе с символами можно посмотреть пройдя по одной из ссылок: https://youtu.be/0Yb8Hw4iOVs или https://www.politerm.com/videos/layeredit/symbol/.

В библиотеке символов слоя содержатся все символы, которые могут использоваться в данном слое. Символ может состоять из комбинации векторных элементов и растровых изображений. При использовании сплошной заливки в векторных элементах для символа возможно настроить степень прозрачности.

Для перехода к библиотеке символов выберите пункт Символы дерева структуры слоя в окне Структура слоя. В правой части окна откроется область управления библиотекой. В верхней части области библиотеки располагается панель инструментов с кнопками для выполнения основных действий над символами.

При создании пустого слоя, библиотека символов также создается пустой. При создании слоя инженерной сети (тепловой, водопроводной, газовой, паровой, канализационной) библиотека символов создается с символами для режимов сети.

Рисунок 138. Библиотека символов

С символами в библиотеке доступны следующие основные действия:

  • создание нового символа библиотеки символов;

  • редактирование символа библиотеки символов;

  • копирование символа;

  • удаление символа;

  • смена ID символа;

  • импорт символов из другого слоя.


Создание нового символа библиотеки символов

Для создания символа:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Символы.

  2. Справа нажмите кнопку [image] Новый....

  3. В открывшемся редакторе символов нанесите символ, сохраните внесенные изменения ( [image] ).


Редактирование символа библиотеки символов

Для редактирования символа:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Символы.

  2. Сделайте двойной щелчок левой кнопкой мыши на символе для редактирования или выделите символ и нажмите кнопку [image] Изменить....

  3. В открывшемся редакторе символов отредактируйте символ, сохраните внесенные изменения ( [image] ).


Копирование символа

Для копирования символа:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Символы.

  2. Сделайте щелчок правой кнопкой мыши на символе и в появившемся контекстном меню выберите Копировать.

Скопированный символ можно вставить в редактор символов. Для этого надо его открыть (кнопка [image] Новый...), затем в рабочей области сделать щелчок правой кнопкой мыши и в контекстном меню выбрать пункт Вставить.


Удаление символа из библиотеки

Из библиотеки символов можно удалить как выделенный в списке символ так и символы, которые не используются.

Для удаления символа:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Символы.

  2. Выберите символ для удаления в библиотеке щелчком левой кнопки мыши.

  3. Нажмите кнопку [image] Удалить панели инструментов библиотеки. Символы, нанесенные на карту или используемые в режимах объектов удалены быть не могут.

Для удаления неиспользуемых символов:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Символы.

  2. Нажмите на кнопку [image] Операции и выберите пункт Удалить свободные. При этом символы, нанесенные на карту или используемые в режимах объектов удалены быть не могут.


Смена ID символа

Каждому символу при его создании присваивается уникальный код - ID, который не повторяется в рамках слоя. Если возникнет необходимость его сменить, для этого:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Символы.

  2. Сделайте щелчок правой кнопкой мыши на символе и в появившемся контекстном меню выберите Изменить ID.

  3. Введите новый ID и для подтверждения нажмите кнопку ОК.


Редактор символов

Редактор символов – это простейший графический редактор, предназначенный для создания и редактирования графических символов. Изображение может состоять из комбинации векторных элементов и растровых изображений (Bitmap). При использовании сплошной заливки у векторных элементов возможно задавать степень прозрачности символа.

Существует несколько способов открытия редактора символов:

  • В режиме библиотеки символов окна Структура слоя при создании нового символа, или редактировании существующего.

  • Из окна карты. Этот способ доступен только в режиме редактирования векторного слоя. Для вызова редактора нажмите на панели инструментов кнопку Символ для ввода ( [image] ), и далее, в открывшемся диалоге выбора символа нажмите кнопку Новый (для создания нового символа) или Изменить (для изменения выбранного в диалоге символа, кнопка активна только если выбран какой-либо символ).

Рабочее окно редактора представлено на рисунке ниже.

Окно редактора символов

Рисунок 139. Окно редактора символов

[Примечание] Примечание

Для создания изображения нового символа на базе уже существующего можно скопировать исходный символ, вставить его в редакторе и отредактировать. Для этого: в библиотеке символов щелкните правой кнопкой мыши по требуемому символу, выполните команду Копировать контекстного меню, далее нажмите кнопку [image] Новый... и в рабочем поле открывшегося окна редактора щелкните правой кнопкой мыши и выберите в меню пункт Вставить.

Создание изображения в редакторе символов состоит из следующей последовательности действий:

  1. В рабочем поле редактора создайте изображение символа. Поле изображения ограничено размером 256х256 точек. Изображение может быть создано или в векторном виде или в растровом.

    Векторные символы создаются с использованием стандартных объектов, таких как ломаная, круг, многоугольник, текст и другие.

    Параметры объектов для нанесения можно задавать как перед нанесением, так и менять уже после нанесения. Для задания их перед нанесением надо нажать соответствующую кнопку и выбрать параметры в появившемся диалоге:

    • - для заполненных площадных объектов, далее задать нужные параметры, они будут отображаться в окне Образец. В разделе Заливка задаются характеристики для заливки контура. При выборе узора в виде сплошной заливки возможно задание степени прозрачности от 0 до 100. Цвет узора у таких объектов может быть указан двумя способами. В первом случае задан определенный цвет из палитры, во втором в палитре выбрать верхний пункт (авто).

      В дальнейшем для символов с цветом авто цвет узора нужно задать либо в структуре слоя при создании режима, используемого данный символ или в панели стиль, когда символ используется как простой символьный объект. Цвет авто удобен тем, что в дальнейшем если потребуется символ использовать в нескольких режимах, то не надо будет создавать несколько символов, можно использовать один, меняя ему только цвет. Так же при создании тематической раскраски для символов не нужно создавать новые символы, достаточно так же будет поменять только цвет.

    • - для линейных объектов, далее задать цвет линии, толщину на экране, толщину при печати и стиль.

    • - для текстовых объектов, далее задать имя, начертание, стиль, цвет шрифта. Выбрать набор шрифта - Юникод, Арабский, Балтийский, Вьетнамский, Греческий, Западный, Иврит, Кириллический, Турецкий, Центральноевропейский.

    Если параметры нанесенных объектов заренее не были заданы и их требуется поменять, то надо нажать кнопку [image] , сделать на символе двойной щелчок и указать их.

  2. В поле Название задайте пользовательское название символа, в дальнейшем оно будет использоваться для идентификации символа в списке символов библиотеки данного слоя и на карте.

  3. При необходимости, укажите точку привязки символа к карте (по умолчанию точка привязки 0:0). Точка привязки, это точка на изображении символа, которая соответствует физическим координатам символа на карте.

  4. Сохраните символ, нажав кнопку [image] .

  5. Закройте окно редактора символов.

Редактирование векторных объектов в редакторе символов

Операции по созданию и редактированию векторных объектов выполняются с помощью инструментов расположенных на панели редактора и панели форматирования. Символы создаются в рабочем поле редактора. Принцип нанесения векторных элементов и текста аналогичен вводу и редактированию объектов карты.

Окно редактора символов

Рисунок 140. Окно редактора символов

Описание кнопок панелей инструментов:

Панель Стандартная

Сохранение символа в библиотеке символов;

Вырезание (удаление в буфер обмена) выделенного элемент или группы элементов;

Копирование выделенного объекта в буфер обмена;

Вставка объекта из буфера;

Удаление выделенного объекта;

Отмена последнего действия;

Повтор последнего выполненного действия.

Панель Навигация

Выделение группы элементов;

Увеличение рисунка;

Уменьшение рисунка;

Включение режима произвольного перемещения центра изображения в пределах экрана.

Панель Форматирования

Установка типа и размера букв для надписи;

Установка стиля букв надписи (полужирный, курсив, подчеркнутый);

Установка цвета и стиля шрифта;

Установка цвета, стиля и толщины линии;

Установка стиля заливки контуров.

Панель Редактирование

Установка режима выделения объекта для редактирования;

Установка режима выделения вершин для редактирования;

Установка режима ввода линий;

Режим ввода прямоугольников;

Режим ввода заполненных прямоугольников;

Режим ввода окружностей;

Режим ввода заполненных окружностей;

Режим ввода произвольных многоугольников;

Режим ввода дуг;

Режим ввода сегментов;

Режим ввода текста;

Помещение выделенного объекта впереди всех объектов;

Помещение выделенного объекта позади всех объектов.

Редактирование растровых изображений в редакторе символов

В редакторе символов предусмотрено создание новых, редактирование уже существующих растровых изображения, а также добавление в символ растровых изображений из файлов. Максимальный размер добавляемого растрового изображения – 256x256 пикселей.

Поместить уже существующее растровое изображение (Bitmap) в редактор символа можно как из файла, так и из буфера обмена.

Для добавления в символ растрового изображения из файла нажмите кнопку [image] панели управления окна редактора, либо нажмите правую кнопку мыши в области рабочего поля редактора и выберите в открывшемся контекстном меню команду Вставить рисунок. Далее, в открывшемся стандартном диалоге выбора файлов выберите нужный файл с картинкой (bmp, pcx, tiff, png, jpg) и нажмите кнопку Открыть.

Для добавления в символ растрового изображения из буфера обмена (если буфер содержит растровое изображение) нажмите кнопку [image] , либо вызовите контекстное меню и выберите в нем команду Вставить.

Для создания нового изображения нажмите кнопку [image] панели инструментов.

Для редактирования уже существующего растрового изображения в символе дважды щелкните по нему левой кнопкой мыши.

Для создания в символах новых растровых изображений и редактирования существующих используется растровый графический редактор:

Описание работы в растровом графическом редакторе:

Растровый графический редактор

Рисунок 141. Растровый графический редактор

Основные элементы окна растрового графического редактора:

  • рабочая область редактора - область редактирования изображения;

  • область просмотра - в ней отображается редактируемое растровое изображение в масштабе 1:1;

  • панель инструментов - с кнопками устанавливающими режим рисования в редакторе;

  • область настроек текущего инструмента - в этой области задаются дополнительные настройки некоторых инструментов;

  • индикатор текущих цветов - отображает текущие цвета;

  • палитра цветов- палитра предназначена для выбора цветов для рисования, нижний квадрат палитры- [image] , отвечает за прозрачный цвет.

Работа с цветом

В растровом редакторе используется два цвета – основной цвет и цвет фона.

Основной цвет используется для границ создаваемых площадных объектов и текста. Цвет фона используется для заполнения замкнутых фигур. Для создаваемых линий и заливок может использоваться как основной цвет, так и цвет фона.

Текущие основной цвет и цвет фона отображаются на индикаторе текущих цветов над палитрой палитры. В верхнем квадрате отображается основной цвет. В нижнем квадрате – цвет фона.

Задание основного цвета и цвета фона

Для выбора цветов используется палитра цветов редактора. Для задания основного цвета щелкните левой кнопкой мыши по требуемому цвету в палитре, для задания фонового цвета – щелкните правой кнопкой мыши по цвету.

Создание прозрачных областей

Для создания прозрачных областей в изображении требуется выбрать в палитре цветов прозрачный цвет (представленный квадратом [image] ) и далее использовать его для рисования обычными инструментами редактора. Области закрашиваемые прозрачным цветом становятся также прозрачными.

[Примечание] Примечание

Прозрачность изображения может использоваться только в символах слоев ZuluGIS. При сохранении рисунка в файл BMP информация о прозрачности теряется, и прозрачные места закрашиваются черным цветом.

Установка произвольного цвета

В редакторе предусмотрен выбор цветов не входящих в палитру редактора. Для выбора цвета:

  1. Для изменения основного цвета дважды щелкните левой кнопкой мыши по палитре, либо по индикатору цвета (для изменения цвета фона дважды щелкните правой кнопкой мыши).

  2. В диалоге выбора цвета выберите нужный цвет, затем закройте диалог нажав кнопку ОК.

Копирование цвета области

Используемые цвета можно выбрать с текущего изображения. Для этого:

  1. В панели инструментов нажмите кнопку Выбор цвета - [image] .

  2. Щелкните кнопкой мыши по области редактируемого изображения, цвет которой требуется выбрать. Для выбора основного цвета щелкните левой кнопкой, для выбора фонового – правой.

Работа с рисунком

Отмена изменений:

Чтобы отменить последнее изменение в рисунке, выберите в меню Правка команду Отменить, либо нажмите сочетание клавиш Ctrl-Z. Для отмены нескольких последних изменений выполните команду последовательно требуемое количество раз. Отменены могут быть все изменения, внесенные с момента открытия растрового графического редактора.

Изменение масштаба отображения:

  1. В панели инструментов нажмите кнопку [image] .

  2. Прокручивая колесо мыши, измените масштаб рисунка.

[Примечание] Примечание

При максимальном увеличении на рисунке появится сетка с размером ячейки, равным одному пикселю изображения. При этом прозрачные пиксели рисунка будут перечеркнуты.

Изменение размеров рисунка:

  1. Выберите в меню Рисунок команду Атрибуты.

  2. В открывшемся диалоге Атрибуты введите новую ширину и высоту рисунка в поля Ширина и Высота и закройте диалог, нажав кнопку ОК.

Диалоговое окно Атрибуты

Рисунок 142. Диалоговое окно Атрибуты

Растяжение и сжатие рисунка:

  1. Выберите в меню Рисунок команду Атрибуты.

  2. В диалоге Атрибуты введите новую ширину и высоту рисунка в полях Ширина и Высота.

  3. Установите флажок Сжать/Растянуть.

  4. Закройте диалог, нажав кнопку ОК.

Создание нового рисунка:

  1. Выберите в меню Файл команду Создать (кнопка [image] ) для создания нового рисунка.

Сохранение рисунка в файл:

  1. Выберите в меню Файл команду Сохранить как (кнопка [image] ) для того, чтобы сохранить отредактированный рисунок в файл BMP на диске.

Открытие существующего рисунка из файла:

  1. Выберите в меню Файл команду Открыть (кнопка [image] ) для того, чтобы открыть рисунок, сохраненный в формате BMP.

Работа с выделенными фрагментами изображения

Выделение фрагмента

  1. В панели инструментов нажмите кнопку Выделить- [image] .

  2. Подведите указатель мыши к одному из углов выделяемого фрагмента.

  3. Нажмите левую кнопку мыши и, не отпуская ее, переместите указатель в противоположный угол фрагмента.

  4. Отпустите левую кнопку мыши.

Копирование и вырезание фрагмента:

  1. Выделите фрагмент, если он еще не выделен.

  2. Выберите в меню Правка команду Копировать или Вырезать (соответственно кнопки [image] или [image] ) для копирования в буфер обмена или вырезания выделенного фрагмента рисунка.

Вставка рисунка:

  1. Выберите в меню Правка команду Вставить (кнопка [image] ) для замены рисунка на рисунок содержащийся в буфере обмена.

Рисование

Рисование линии:

  1. Нажмите в панели инструментов кнопку Линия – [image] .

  2. Выберите толщину линии в области настроек под панелью инструментов.

  3. Для рисования линии основным цветом нажмите левую кнопку мыши в точке начала линии и, не отпуская ее, переместите в точку окончания линии.

  4. Отпустите кнопку мыши, линия будет зафиксирована.

Рисование фоновым цветом выполняется аналогичным образом, но вместо левой кнопки мыши следует нажимать правую кнопку.

Рисование произвольной кривой:

  1. В панели инструментов нажмите кнопку Карандаш – [image] .

  2. Для нанесения кривой основным цветом нажмите левую кнопку мыши и перемещайте указатель по траектории наносимой кривой.

  3. По окончании нанесения кривой отпустите кнопку мыши.

Рисование фоновым цветом выполняется аналогичным образом, но вместо левой кнопки мыши следует нажимать правую кнопку.

Кривые рисуются с толщиной в 1 пиксель.

Рисование эллипса (круга):

  1. В панели инструментов нажмите кнопку Эллипс – [image] .

  2. Выберите стиль заливки в области настроек под панелью инструментов. Доступны три стиля (сверху-вниз): незаполненный эллипс, заполненный эллипс, эллипс заполненный цветом его границы.

  3. Нажмите левую кнопку мыши в позиции, совпадающей с одним из углов прямоугольника, в который вписан рисуемый эллипс (круг).

  4. Переместите указатель мыши так, чтобы отобразился требуемый эллипс (круг) и отпустите кнопку мыши.

При использовании для рисования эллипса (круга) левой кнопки мыши, граница эллипса изображается основным цветом, а заливка фоновым цветом. Если использовать правую кнопку мыши, то граница отображается цветом фона, а заливка – основным цветом.

Толщина границы эллипса (круга) соответствует толщине линии выбранной для инструмента Линия – [image] .

Рисование прямоугольника (квадрата):

  1. В панели инструментов нажмите кнопку Прямоугольник - [image] .

  2. Выберите стиль заливки в области настроек под панелью инструментов. Доступны три стиля (сверху-вниз): незаполненный прямоугольник, заполненный прямоугольник, прямоугольник заполненный цветом его границы.

  3. Нажмите левую кнопку мыши в позиции, совпадающей с одним из углов рисуемого прямоугольника (квадрата).

  4. Переместите указатель мыши так, чтобы отобразился требуемый прямоугольник (квадрат) и отпустите кнопку мыши.

При использовании для рисования прямоугольника (квадрата) левой кнопки мыши, граница прямоугольника (квадрата) изображается основным цветом, а заливка фоновым цветом. Если использовать правую кнопку мыши, то граница отображается цветом фона, а заливка – основным цветом.

Толщина границы прямоугольника (квадрата) соответствует толщине линии выбранной для инструмента Линия – [image] .

Рисование многоугольника:

  1. В панели инструментов нажмите кнопку Многоугольник- [image] .

  2. Выберите стиль заливки в области настроек под панелью инструментов. Доступны три стиля (сверху-вниз): незаполненный многоугольник, заполненный многоугольник, многоугольник заполненный цветом его границы.

  3. Нажмите левую кнопку мыши в точке одной из вершин рисуемого многоугольника.

  4. Последовательно перемещайте указатель мыши и нажимайте левую кнопку в точках остальных вершин многоугольника, кроме последней.

  5. Переместите указатель мыши в точку последней вершины многоугольника и дважды щелкните левой кнопкой мыши. Многоугольник будет зафиксирован.

При использовании для рисования многоугольника левой кнопки мыши, его граница изображается основным цветом, а заливка фоновым цветом. Если использовать правую кнопку мыши, то граница отображается цветом фона, а заливка – основным цветом.

Толщина границы многоугольника соответствует толщине линии выбранной для инструмента Линия – [image] .

Заливка области:

  1. В панели инструментов нажмите кнопку Заливка- [image] .

  2. Для заливки основным цветом, щелкните левой кнопкой мыши в области изображения, которую требуется залить текущим основным цветом.

Заливка фоновым цветом выполняется аналогичным образом, но вместо левой кнопки мыши следует нажимать правую кнопку.

Ввод и форматирование текста:

  1. В панели инструментов нажмите кнопку Текст- [image] .

  2. Щелкните левой кнопкой мыши в позиции начала текста.

  3. Введите текст.

Шрифт и атрибуты текста настраиваются стандартном диалоге настройки шрифтов вызываемом командой Шрифт меню Текст.

Для рисования текста используется текущий основной цвет.

Очистка области:

  1. В панели инструментов нажмите кнопку Резинка – [image] .

  2. Выберите толщину резинки в области настроек под панелью инструментов.

  3. Для стирания основным цветом нажмите левую кнопку мыши и перемещайте указатель по очищаемой области рисунка.

  4. По окончании очистки отпустите кнопку мыши.

Очистка фоновым цветом выполняется аналогичным образом, но вместо левой кнопки мыши следует нажимать правую кнопку.

[Примечание] Примечание

Вызвать редактор символов можно с помощью метода Layer.EditSymbol.


Изменение размеров символов

В системе ZuluGIS размеры графических символов задаются в относительных единицах (пикселях), поэтому заранее неизвестно, какого размера они будут на той или иной карте, так как слой может создаваться для масштабов области, города, квартала, помещения.

[Примечание] Примечание

Размер всех символов слоя одновременно возможно изменить используя операцию Изменения масштаба элементов.

Для регулирования размеров символьных объектов на карте вводится коэффициент масштабирующий отображение символов. Коэффициент задает масштаб карты, при котором символ будет отображаться в таком же размере, в каком он был создан в редакторе символов. Чем больше значение коэффициента, тем крупнее выглядят символьные объекты на карте (при одном и том же масштабе карты).

Размер для типовых символьных объектов и простых символьных объектов (примитивов) задается различными способами.

Для изменения размеров символов типового объекта:

  1. Откройте структуру слоя, в котором требуется изменить размеры символов ( [image] ).

  2. В разделе Типы и режимы окна Структура слоя выберите необходимый тип объекта.

  3. Нажмите знак «+» слева от названия выбранного типа. В раскрывшемся списке режимов выберите режим размер символа которого требуется изменить.

  4. В поле размер задайте требуемое значение.

    Вкладка с параметрами режима типового объекта

    Рисунок 143. Вкладка с параметрами режима типового объекта

  5. Нажмите кнопку Сохранить. Если символы уже нанесены на карту, то произойдет изменение их размеров.

Для изменения размеров символа простого объекта:

Размер символа может задаваться как до нанесения символьных объектов на карту (в этом случае заданный размер будет устанавливаться для всех наносимых далее символов), так и настраиваться для уже добавленных на карту символьных объектов.

Для задания размера символов вводимых на карту:

  1. Сделайте слой, в котором будут вводиться символы редактируемым.

  2. Нажмите кнопку [image] панели инструментов главного окна ZuluGIS. Откроется диалог выбора стиля вводимых символьных объектов.

  3. Выберите символ для ввода и в поле размер установите размер символа.

  4. Нажмите кнопку ОК диалога, чтобы закрыть его и принять изменения. Вводимые далее на карту символы будут иметь заданный размер.

    Диалоговое окно Стиль

    Рисунок 144. Диалоговое окно Стиль

Для изменения размера символьного объекта уже нанесенного на карту:

  1. Сделайте слой, в котором находится символьный объект редактируемым.

  2. Войдите в режим выделения объектов - кнопка [image] .

  3. Дважды щелкните левой кнопкой мыши по символьному объекту на карте. Откроется диалог редактирования стиля объекта.

  4. В поле размер установите размер символа и нажмите кнопку ОК диалога, чтобы закрыть его и принять изменения. Размер символьного объекта будет изменен.


Стили линий

  • «Создание нового стиля линии»

  • «Изменение стиля линии»

  • «Копирование стиля линии»

  • «Удаление стиля линии»

  • «Редактор стиля линий»

  • «Импорт элементов из других слоев»

При создании линейных объектов на карте для их отображения используются различные стили. Каждый векторный слой содержит собственную библиотеку стилей линий. При создании нового слоя он уже содержит библиотеку стандартных стилей линий. Причем во всех библиотеках стилей линий обязательно содержатся стили линий №5 (пустая линия), и №6 (сплошная линия), зарезервированные системой. Прочие стили могут редактироваться, удаляться и создаваться пользователями.

Стиль линии может состоять из комбинации линий и символов. При использовании символов со сплошной заливкой им может быть задана степень прозрачности.

Скопировать стиль объекта и применить его к другому можно в параметрах линейного объекта.

Для перехода к библиотеке стилей линий слоя, откройте окно структуры слоя (Слой|Структура слоя) и выберите в дереве структуры пункт Линии, библиотека стилей линий откроется в правой части окна структуры.

Раздел «Линии» диалога структуры слоя

Рисунок 145. Раздел «Линии» диалога структуры слоя

Со стилями линий в библиотеке доступны следующие действия:

  • создание нового стиля линии;

  • изменение стиля линии;

  • удаление стиля линии;

  • копирование стиля линии;

  • удаление стиля линии;

  • импорт стиля из другого слоя.

Все стили линий имеют один из следующих типов:

  • стиль с линейными элементами (линия заливается линиями с заданным видом штриховки, толщиной и цветом);

  • стиль с символьными элементами (линия заливается периодически повторяющимся или единичным векторным рисунком);

  • комбинированный стиль (содержит произвольную комбинацию из нескольких элементов первых двух типов).

Стиль с линейными элементами

Стиль с линейными элементами состоит из линий заданными параметрами штриховки, толщиной, цветом, линейными размерами.

Рисунок 146. Векторная штриховка

Стиль с символьными элементами

Для стиля с символьными элементами используется векторный рисунок, который выводится с заданными интервалами, и в заданном масштабе.

Рисунок 147. Векторная заливка

Комбинированный стиль

Комбинированный стиль- произвольное сочетание предыдущих стилей.

Комбинация линейных элементов:

Рисунок 148. Комбинированная заливка

Комбинация символьных элементов:

Комбинация векторных заливок

Рисунок 149. Комбинация векторных заливок

Комбинация линейных элементов и символьных элементов:

Комбинация векторных заливок и векторных штриховок

Рисунок 150. Комбинация векторных заливок и векторных штриховок


Создание нового стиля линии

Для создания нового стиля линии:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Линии.

  2. Справа нажмите кнопку [image] Новый....

  3. В открывшемся редакторе стиля линий создайте новый стиль, кнопкой ОК подтвердите внесенные изменения.


Изменение стиля линии

Для изменения стиля линии:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Линии.

  2. Сделайте двойной щелчок левой кнопкой мыши на стиле, который надо изменить или выделите его и нажмите кнопку [image] Изменить....

  3. Откроется редактор стиля линий, в который загрузится информация о выбранном стиле. Сделайте нужные изменения, кнопкой ОК подтвердите их.


Копирование стиля линии

Скопированный стиль может быть вставлен как в тоже же слой из которого происходило копирование, так и в другой слой.

Для копирования стиля линии:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Линии.

  2. Сделайте щелчок правой кнопкой мыши на стиле и в появившемся контекстном меню выберите Копировать.

Если ранее в буфер обмена был скопирован стиль линии, то этот стиль можно добавить в библиотеку стилей линий слоя. Для добавления стиля из буфера обмена:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Линии.

  2. В области списка стилей нажмите правую клавишу мышки и в открывшемся контекстном меню выберите команду Вставить.


Удаление стиля линии

Из библиотеки стилей можно удалить как выделенный в списке стиль так и стили, которые не используются.

Для удаления стиля:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] .

  2. Выберите стиль линии для удаления в библиотеке щелчком левой кнопки мыши.

  3. Нажмите кнопку [image] Удалить панели инструментов библиотеки. Стили линий, используемые в нанесенных объектах или используемые в режимах объектов удалены быть не могут.

Для удаления неиспользуемых стилей:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Линии.

  2. Нажмите на кнопку [image] Операции и выберите пункт Удалить свободные. Стили линий, используемые в нанесенных объектах или используемые в режимах объектов удалены быть не могут.


Редактор стиля линий

Создание стиля линии сводится к заданию элементов из которых формируется рисунок линии. Количество элементов в стиле не ограничено. При отображении элементы стиля накладываются друг на друга.

Диалог «Стиль заливки»

Рисунок 151. Диалог «Стиль заливки»

После вызова редактора для нового стиля на экране появится диалог, представленный на рисунке выше.

Диалог редактора состоит из следующих основных частей:

  • Область общих настроек стиля. В этой области собраны следующие параметры стиля:

    • В поле Название, при необходимости, задается название стиля линии. Название для стиля необязательно. Если названия нет, для именования стиля используется его номер;

    • В поле Единицы задаются единицы измерения для геометрических параметров стиля линии (пиксели или миллиметры). Все линейные размеры, шаги, сдвиги, толщины могут принимать не только целые, но и дробные значения. На экране дробные размеры округляются до экранных пикселей, но при печати все размеры воспроизводятся точно.

  • Список элементов стиля. В списке отображаются все элементы, используемые в данном стиле линии (см. Список элементов стиля);

  • Область настроек текущего элемента. Набор полей настроек в списке зависит от типа выбранного элемента в списке – линейного, или символьного;

  • Область просмотра стиля. Предварительный просмотр линии с редактируемым стилем.

Список элементов стиля

Элементы выводятся в списке в том же порядке, в каком они отображаются: сначала рисуется верхний элемент, затем, поверх него второй сверху, и т.д.

Слева от каждого элемента списка располагается флажок, элемент отображается в стиле, только когда этот флажок установлен.

Для выбора элемента списка достаточно щелкнуть по нему левой кнопкой мыши.

Под списком располагаются кнопки управления:

  • – сдвиг выбранного элемента вверх по списку;

  • – сдвиг выбранного элемента вниз;

  • – добавление нового линейного элемента стиля в нижнюю строку списка);

  • – добавление нового символьного элемента стиля в нижнюю строку списка;

  • – удаление выбранного элемента из списка.

Задание линейных элементов

Для задания нового линейного элемента стиля, нажмите кнопку [image] под списком элементов, для редактирования существующего линейного элемента выберите его в списке.

Параметры выбранного линейного элемента задаются в полях правой части диалога стиля:

  • Сплошная линия. Флажок задает тип линии элемента. Когда он установлен, линия рисуется сплошной, когда снят – прерывистой. Для прерывистых линий задаются дополнительные параметры: шаг, длина штриха, сдвиг штрихов вдоль линии (см. ниже);

  • Цвет. Цвет линии. В поле либо задается конкретный цвет, в этом случае линия всегда отображается выбранным цветом, либо выбирается значение «авто», – в этом случае линия отображается цветом выбранным в диалоге «Стиль» при нанесении линий;

  • Толщина. Толщина линии. В поле со списком выбирается способ задания толщины, а в поле ввода – толщина линии. Доступны следующие способы задания толщины линии:

    • «постоянная». Толщина линии остается всегда постоянной и равна значению, указанному в поле ввода;

    • «равна общей толщине плюс». Толщина отображаемой линии складывается из значения указанного в поле ввода + значение толщины линии указанное в диалоге Стиль при нанесении линий;

    • «пропорциональная». Толщина линии равна произведению значения указанного в поле ввода и толщины, указанной в диалоге Стиль при нанесении линий. Если необходимо чтобы линия масштабировалась при изменении масштаба карты, то устанавливается именно этот параметр, в противном случае масштабирования линии не будет.

  • Линейные размеры. В данной группе настроек задаются параметры штрихов для прерывистой линии, и сдвиг поперек направления линии для непрерывной линии;

    • В поле со списком задается способ расчета линейных размеров: «постоянные» – размеры равны указанным в соответствующих полях, и «пропорциональные» – размеры определяются как заданный размер * значение толщины линии указанное в диалоге Стиль при нанесении линий. Если в дальнейшем необходимо будет масштабирование линии в зависимости от масштаба карты, то в данном поле необходимо выбрать значение «пропорциональные» ;

    • Шаг (только для прерывистых линий). Задает шаг штрихов линии. Например, если для шага указано значение 10 пикселей, то каждые 10 пикселей линии будет начинаться новый штрих;

    • Длина штриха (только для прерывистых линий). Задает длину штрихов линии. Если штрих выступает за начало следующего штриха (длина штриха + смещение штриха по X превышает шаг штриха), то выступающая часть штриха отбрасывается;

    • Сдвиг по X (только для прерывистых линий). Смещение штриха вдоль направления линии. Смещение может иметь как положительное, так и отрицательное значение;

    • Сдвиг по Y. Смещение штриха поперек направления линии. Смещение может иметь как положительное, так и отрицательное значение.

  • Конец линии. Вид отображения концов линии – закругленный, квадратный, либо прямой.

Задание символьных элементов

Для задания нового символьного элемента стиля, нажмите кнопку [image] , для изменения вида существующего символьного элемента дважды щелкните левой кнопкой мыши по элементу в списке.

На экране появится редактор Рисунок 140, «Окно редактора символов» .

Подробно создание векторного рисунка описано в разделе см «Редактор символов».

По завершении создания векторного изображения в список элементов стиля добавляется символьный элемент. В правой части диалога Стиль заливки отображаются поля для задания параметров отображения данного символьного элемента. Для настройки параметров уже существующего символьного элемента достаточно его выбрать в списке.

Параметры символьного элемента

Рисунок 152. Параметры символьного элемента

Параметры символьного элемента задаются следующими полями:

  • Символ. Информационное поле, в котором приводится ширина и высота символа в выбранных единицах;

  • Масштаб элемента. Коэффициент масштабирования символа, – на эту величину умножаются линейные размеры данного элемента;

  • Шаг по горизонтали. Шаг, с которым выводится символ в линии;

  • Сдвиг по горизонтали. Расстояние вдоль линии, на которое сдвигается изображение символа;

  • Линейные размеры. Способ расчета размеров элемента при отображении линии: «постоянные» – размеры равны исходным размерам объекта, и «пропорциональные» – размеры определяются как исходный размер * значение толщины линии указанное в диалоге Стиль при нанесении линий. Если в дальнейшем необходимо будет масштабирование символа в зависимости от масштаба карты, то в данном поле необходимо выбрать значение «пропорциональные»;

  • Сдвиг по вертикали. Расстояние, на которое сдвигается изображение символа по вертикали;

  • Толщины. Способ расчета толщин линий символьного элемента при отображении линии: «постоянные» – толщины равны исходным толщинам, и «пропорциональные» – толщины определяются как исходная толщина * значение толщины линии указанное в диалоге Стиль при нанесении линий. Если в дальнейшем необходимо будет масштабирование линии в зависимости от масштаба карты, то в данном поле необходимо выбрать значение «пропорциональные»;

  • Угол. Угол поворота символа против часовой стрелки;

  • Установка. Способ установки объекта:

    • с заданным шагом - символ выводится с шагом указанным в поле Шаг по горизонтали;

    • в начале отрезка - символ выводится только в начале отрезка, отрезком считается кусок линии от одной точки перелома до другой;

    • в начале полилинии - символ выводится только в начале полилинии, независимо от точек перелома;

    • в конце отрезка - символ выводится только в конце отрезка, отрезком считается кусок линии от одной точки перелома до другой;

    • в конце полилинии - символ выводится только в конце полилинии, независимо от точек перелома.


Заливки

  • «Создание нового стиля заливки»

  • «Изменение стиля заливки»

  • «Копирование стиля заливки»

  • «Удаление стиля заливки»

  • «Редактор стиля заливки»

  • «Импорт элементов из других слоев»

При создании площадных объектов на карте для отображения их заливок используются различные стили. Каждый векторный слой содержит собственную библиотеку стилей заливок. При создании нового слоя он уже содержит библиотеку стандартных стилей заливок. Причем во всех библиотеках стилей заливок обязательно содержатся стили №1- пустая заливка (полигон не заливается) и заливка №2- сплошная заливка (полигон полностью заливается цветом узора). Прочие стили могут редактироваться, удаляться и создаваться пользователями.

Для перехода к библиотеке стилей заливок слоя, откройте окно структуры слоя (Слой|Структура слоя) и выберите в дереве структуры пункт Заливки, библиотека стилей заливок откроется в правой части окна структуры:

Раздел «Заливки» диалога структуры слоя

Рисунок 153. Раздел «Заливки» диалога структуры слоя

Со стилями заливок в библиотеке стилей заливок доступны следующие действия:

  • создание нового стиля заливки;

  • изменение стиля заливки;

  • копирование стиля заливки;

  • удаление стиля линии;

  • импорт стиля из другого слоя.

Стили заливки могут иметь один из следующих типов:

  • Растровая заливка. Полигон заливается периодически повторяющимся растровым рисунком.

  • Векторная заливка. Полигон заливается периодически повторяющимся векторным рисунком. При использовании у векторного рисунка сплошной заливки возможно задавать его прозрачность от 0 до 100.

  • Векторная штриховка. Полигон заливается параллельными линиями заданным стилем, толщиной и расстоянием между ними.

  • Комбинированный стиль. Содержит произвольную комбинацию предыдущих трех типов.

Растровая заливка

Для растровой заливки требуется растровый рисунок. Например, [image] . Рисунок в заливке повторяется с заданным шагом по вертикали и горизонтали.

Если шаг по горизонтали совпадает с шириной рисунка, а шаг по вертикали с высотой рисунка, то полигон заливается растровым рисунком без «щелей»:

Растровая заливка без зазоров

Рисунок 154. Растровая заливка без зазоров

Если шаг по горизонтали и/или по вертикали больше чем ширина и/или высота рисунка, то между соседними рисунками при заливке полигона образуются зазоры, которые заполняются цветом фона полигона, либо остаются прозрачными:

Растровая заливка с зазорами

Рисунок 155. Растровая заливка с зазорами

При масштабировании растровой заливки, например, при выводе на печать, точки рисунка увеличиваются в соответствии с масштабом, отображаясь в виде квадратиков.

Масштабирование растровой заливки

Рисунок 156. Масштабирование растровой заливки

Монохромные растры

Если растровый рисунок, используемый для заливки, монохромный (черно-белый), то в этом случае один цвет можно использовать как цвет фона (в том числе прозрачный), а другой как цвет узора: .

Монохромные растровые заливки

Рисунок 157. Монохромные растровые заливки

Примером растровой заливки с монохромным рисунком являются заливки, предоставляемые системой по умолчанию.

Векторная заливка

Для векторной заливки требуется векторный рисунок (метафайл), который выводится в заливаемой области с заданными интервалами по вертикали и горизонтали, и в заданном масштабе.

Рисунок 158. Векторные заливки

В отличие от растровой заливки качество изображения векторного рисунка не изменяется с изменением масштаба.

Векторная штриховка

При использовании векторной штриховки заливаемая область покрывается параллельными линиями с заданным стилем, толщиной, под заданным углом и с заданным расстоянием между соседними линиями.

Рисунок 159. Векторная штриховка

Комбинированная заливка

Комбинированная заливка – произвольное сочетание предыдущих трех заливок.

Комбинация векторных штриховок:

Комбинированная векторная штриховка

Рисунок 160. Комбинированная векторная штриховка

Комбинация векторных заливок:

Комбинированная векторная заливка

Рисунок 161. Комбинированная векторная заливка

Комбинация векторных заливок и векторных штриховок:

Комбинация векторных заливок и штриховок

Рисунок 162. Комбинация векторных заливок и штриховок

Комбинация векторных заливок, векторных штриховок и растровой заливки:

Комбинация векторных заливок, штриховок и растровой заливки

Рисунок 163. Комбинация векторных заливок, штриховок и растровой заливки

Следует иметь в виду, что вывод комбинированных заливок, использующих одновременно растровую и векторную информацию производится медленнее чем других видов заливок, поэтому без особой необходимости применять их нежелательно.


Создание нового стиля заливки

Для создания нового стиля заливки:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Заливки.

  2. Справа нажмите кнопку [image] Новый....

  3. В открывшемся редакторе стиля заливки создайте новый стиль, кнопкой ОК подтвердите внесенные изменения.


Изменение стиля заливки

Для изменения стиля заливки:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Заливки..

  2. Сделайте двойной щелчок левой кнопкой мыши на стиле, который надо изменить или выделите его и нажмите кнопку [image] Изменить....

  3. Откроется редактор стиля заливки, в который загрузится информация о выбранном стиле. Сделайте нужные изменения, кнопкой ОК подтвердите их.


Копирование стиля заливки

Скопированный стиль может быть вставлен как в тоже же слой из которого происходило копирование, так и в другой слой.

Для копирования стиля заливки:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Заливки.

  2. Сделайте щелчок правой кнопкой мыши на стиле и в появившемся контекстном меню выберите Копировать.

Если ранее в буфер обмена был скопирован стиль заливки, то этот стиль можно добавить в библиотеку стилей заливок слоя. Для добавления стиля из буфера обмена:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Заливки.

  2. В области списка стилей нажмите правую клавишу мышки и в открывшемся контекстном меню выберите команду Вставить.


Удаление стиля заливки

Из библиотеки стилей можно удалить как выделенный в списке стиль так и стили, которые не используются.

Для удаления стиля:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Заливки.

  2. Выберите стиль заливки для удаления в библиотеке щелчком левой кнопки мыши.

  3. Нажмите кнопку [image] Удалить панели инструментов библиотеки. Стили заливок, используемые в нанесенных объектах или используемые в режимах объектов удалены быть не могут.

Для удаления неиспользуемых стилей:

  1. Откройте структуру слоя, в дереве слева выберите пункт [image] Заливки.

  2. Нажмите на кнопку [image] Операции и выберите пункт Удалить свободные. Стили заливок, используемые в нанесенных объектах или используемые в режимах объектов удалены быть не могут.


Редактор стиля заливки

Создание стиля заливки сводится к заданию элементов из которых формируется заливка. Количество элементов в стиле не ограничено. При отображении элементы стиля накладываются друг на друга.

Диалог «Стиль заливки»

Рисунок 164. Диалог «Стиль заливки»

После вызова редактора для нового стиля на экране появится диалог, изображенный на рисунке выше.

Диалог редактора состоит из следующих основных частей:

  • Область общих настроек стиля. В этой области собраны следующие параметры стиля:

    • В поле Название, при необходимости, задается название стиля. Название для стиля необязательно. Если названия нет, для именования стиля используется его номер;

    • В поле Единицы задаются единицы измерения для геометрических параметров стиля заливки (пиксели или миллиметры). Все линейные размеры, шаги, сдвиги, толщины могут принимать не только целые, но и дробные значения. На экране дробные размеры округляются до экранных пикселей, но при печати все размеры воспроизводятся точно;

    • В поле Масштаб задается масштабный коэффициент, на который умножаются все линейные размеры заливки при отображении. Это позволяет одновременно масштабировать все элементы заливки.

  • Список элементов стиля. В списке отображаются все элементы, используемые в данном стиле линии (см. ниже «Редактор стиля заливки»);

  • Область настроек выбранного элемента стиля. Набор полей настроек в списке зависит от типа выбранного элемента в списке – растровой или векторной заливки, штриховки;

  • Область просмотра стиля. Предварительный просмотр заливки с редактируемым стилем.

Список элементов стиля

Элементы выводятся в списке в том же порядке, в каком они отображаются: сначала рисуется верхний элемент, затем, поверх него второй сверху, и т.д.

Слева от каждого элемента списка располагается флажок, элемент отображается в стиле, только когда этот флажок установлен.

Для выбора элемента списка достаточно щелкнуть по нему левой кнопкой мыши.

Под списком располагаются кнопки управления:

  • – сдвиг выбранного элемента вверх по списку;

  • – сдвиг выбранного элемента вниз;

  • – добавление нового растрового элемента заливки (см ниже, «Редактор стиля заливки»);

  • – Добавление новой штриховки (см. ниже, «Редактор стиля заливки»);

  • – Добавление нового векторного элемента заливки (см. ниже, «Редактор стиля заливки»);

  • – Удаление выбранного элемента из списка.

Задание растровой заливки

Для создания нового растрового элемента заливки нажмите кнопку [image] .

На экране появится окно редактора растровых изображений. Для открытия редактора для уже существующего растрового элемента достаточно дважды щелкнуть по нему в списке элементов.

Диалог редактирования изображения

Рисунок 165. Диалог редактирования изображения

Создание, загрузка и редактирование растровых изображений подробно описаны в разделе см. «Редактор символов».

По завершении создания растрового изображения в список элементов стиля добавляется растровый элемент. В правой части диалога Стиль заливки отображаются поля для задания параметров отображения данного растрового элемента. Для настройки параметров уже созданного растрового элемента достаточно его выбрать в списке.

Поля редактирования параметров растрового элемента заливки в диалоге стиля заливки.

Рисунок 166. Поля редактирования параметров растрового элемента заливки в диалоге стиля заливки.

Параметры растрового элемента задаются следующими полями:

  • Растр. Информационное поле в котором приводятся ширина и высота растра в выбранных единицах размера;

  • Масштаб. Коэффициент на который умножаются линейные размеры выбранного элемента при отображении;

  • Шаг по горизонтали/Шаг по вертикали. Шаг, с которым выводится в заливке растровый рисунок, по вертикали и горизонтали. Если шаг совпадает с размером рисунка по соответствующей оси, то соседние рисунки будет отображаться без зазоров между ними. Если шаг меньше размера рисунка, то соседние рисунки будут накладываться друг на друга;

  • Сдвиг по горизонтали/Сдвиг по вертикали. Смещение начальных координат рисунков по соответствующей оси. Может быть полезен при использовании комбинированной заливки – смещение позволяет задать относительное стартовое положение для элементов заливки;

  • Цвета пользователя. Флажок доступен только для монохромных растров состоящих из черного и белого цветов. Если флажок установлен, то при заливке полигона в качестве двух цветов используются цвет фона и цвет узора полигонального объекта.

Задание векторной заливки

Для создания нового элемента векторной заливки нажмите кнопку [image] .

На экране появится диалог выбора векторных изображений из библиотеки символов слоя:

Диалог «Выбор символа»

Рисунок 167. Диалог «Выбор символа»

Для выбора существующего изображения выберите в выпадающем списке нужный символ и нажмите кнопку Выбрать.

Для создания нового векторного изображения нажмите кнопку Новый. На экране появится редактор векторных изображений. Подробно создание векторного рисунка описано в разделе см. «Редактор символов».

Рисунок 168. Редактор символов

Для редактирования векторного элемента уже добавленного стиль заливки достаточно дважды щелкнуть левой кнопкой мыши по его строке в списке.

По завершении создания/выбора векторного изображения в список элементов стиля добавляется векторный элемент. В правой части диалога Стиль заливки отображаются поля для задания параметров отображения данного векторного элемента. Для настройки параметров уже существующего символьного элемента достаточно его выбрать в списке.

Поля редактирования параметров векторного элемента заливки в диалоге стиля заливки.

Рисунок 169. Поля редактирования параметров векторного элемента заливки в диалоге стиля заливки.

Параметры векторного элемента задаются в следующих полях:

  • Символ. Информационное поле в котором приводятся ширина и высота векторного символа в выбранных единицах размера;

                  • Масштаб элемента. Коэффициент на который умножаются линейные размеры выбранного элемента при отображении;

  • Шаг по горизонтали/Шаг по вертикали. Шаг, с которым выводится в заливке векторный символ, по вертикали и горизонтали. Если шаг меньше размера символа, то соседние символы будут накладываться друг на друга;

  • Сдвиг по горизонтали/Сдвиг по вертикали. Смещение начальных координат символов по соответствующей оси. Может быть полезен при использовании комбинированной заливки – смещение позволяет задать относительное стартовое положение для элементов заливки;

  • Угол. Угол поворота символа против часовой стрелки.

Задание векторной штриховки

Для задания нового элемента векторной штриховки нажмите кнопку [image] . В список элементов добавится элемент векторной штриховки, а в правой части диалога отобразятся поля для задания параметров отображения данной векторной штриховки. Для настройки параметров уже существующей векторной штриховки достаточно ее выбрать в списке.

Параметры векторной штриховки в диалоге стиля заливки

Рисунок 170. Параметры векторной штриховки в диалоге стиля заливки

Параметры штриховки задаются в следующих полях:

  • Расстояние между линиями. В этой группе настроек задается расстояние между линиями штриховки.

    В поле Перпендикулярно линиям задается расстояние между линиями перпендикулярно направлению линий.

    В поле По вертикали – задается расстояние по вертикали между соответствующими точками соседних линий. При угле поворота линии между 46 и 135 градусами (либо между 226 и 315 градусами) данное поле заменяется на поле По горизонтали, в котором задается расстояние по горизонтали между соответствующими точками соседних линий. Поля Перпендикулярно линиям и По вертикали (По горизонтали) связаны между собой, при изменении значения в одном поле, значение другого поля пересчитывается автоматически;

  • Сдвиг линий. Группа настроек в которой задается смещение линий относительно других элементов заливки при создании комбинированных заливок.

    В поле Перпендикулярно линиям задается смещение перпендикулярно направлению линии.

    В поле По вертикали – задается смещение линий по вертикали. При угле поворота линии между 46 и 135 градусами (либо между 226 и 315 градусами) данное поле заменяется на поле По горизонтали, в котором задается смещение по горизонтали.

    Поля Перпендикулярно линиям и По вертикали (По горизонтали) связаны между собой, при изменении значения в одном поле, значение другого поля пересчитывается автоматически;

  • В поле Угол, град задается поворот линий штриховки, в градусах, против часовой стрелки;

  • Поле Толщина линии задает толщину линии в заданных единицах;

  • Флажок Цвет линии указывает какой цвет используется для вывода линий штриховки. Если флажок сброшен, то используются цветы заданные для линии в стиле линии, если установлен – цвет, выбранный в поле справа от флажка;

  • Стиль линии. Стиль линии используемый для вывода линий штриховки. Стиль выбирается из стилей линий слоя.


Импорт элементов из других слоев

Система предусматривает возможность импортировать элементы библиотек (символы, стили линий и заливок) из одного слоя в другой, то есть, в библиотеку создаваемого слоя можно добавлять элементы уже созданные ранее для других слоев.

Для импорта элемента библиотеки в слой:

  1. В дереве структуры слоя в окне Структура слоя ( [image] ) выберите требуемый раздел (Символы, Линии, Заливки).

  2. Нажмите кнопку Операции и в появившемся контекстном меню выберите команду Импорт... Откроется стандартный диалог выбора файла.

  3. Выберите слой-источник из которого требуется импортировать элементы библиотеки и нажмите кнопку Открыть. Откроется диалог импорта элементов требуемого вида. Основную часть диалога импорта занимают две области. В верхней области диалога представлены все элементы выбранного вида слоя-источника, а в нижней – элементы, импортируемые в текущий слой. Если случайно был выбран не тот слой-источник, то выбрать указать новый можно нажав кнопку Выбор слоя.

  4. Для добавления части символов из слоя источника в текущий слой выберите требуемые элементы в верхней области (например щелкая левой кнопкой мыши по требуемым элементам с нажатой клавишей Ctrl) и нажмите кнопку Добавить.

    Для добавления всех элементов из верхнего списка в нижний нажмите кнопку Добавить все.

  5. Для исключения символов из списка элементов, предназначенных для импорта, выберите исключаемые символы в нижней области и нажмите кнопку Исключить (кнопка Исключить все исключает все элементы из нижней области).

  6. Нажмите кнопку Импортировать, выбранные элементы будут импортированы в библиотеку текущего слоя и диалог закроется. Для того чтобы закрыть диалог не проводя импорта, нажмите кнопку Закрыть.

    Окно импорта элементов библиотеки

    Рисунок 171. Окно импорта элементов библиотеки


Удаление неиспользуемых элементов

С помощью операции Удалить свободные имеется возможность удалить из структуры слоя неиспользуемые на карте элементы (символы, линии, заливки).

[Примечание] Примечание

Элементы, нанесенные на карту или используемые в режимах объектов, удалены быть не могут.

Для удаление неиспользуемых элементов:

  1. В дереве структуры слоя в окне Структура слоя ( [image] ) выберите требуемый раздел (Символы, Линии, Заливки).

  2. Нажмите кнопку Операции и в появившемся контекстном меню выберите команду Удалить свободные.

    Удаление неиспользуемых элементов

    Рисунок 172. Удаление неиспользуемых элементов

  3. Нажмите Сохранить для сохранения изменений.


Типы и режимы

  • «Работа с типами»

  • «Работа с режимами»

  • «Настройка порядка отображения объектов»

  • «Импорт типов и режимов»

  • «Печать списка типов и режимов»

[Примечание] Примечание

Видеоурок по работе с типами и режимами можно посмотреть пройдя по одной из ссылок: https://youtu.be/OKaqQViVphE или https://www.politerm.com/videos/layerstruct/tipy-i-rezhimy/.

В библиотеке типов и режимов слоя хранится информация обо всех типовых объектах, которые могут использоваться в данном слое и о режимах, между которыми могут переключаться данные объекты. Чаще всего типы и режимы используются в инженерных сетях, но они могут также использоваться и для других целей, например для решения транспортных задач.

Для создания нового типового объекта необходимо сначала создать тип объекта, в котором указывается его название, графический вид создаваемого типа, при необходимости подключается база данных. Далее для возможности нанесения объектов на карту к типу создается нужное количество режимов. В зависимости от выбранного графического вида объекта режимам задаются параметры отображения. Например, для символьного графического вида объекта необходимо будет задать символ с помощью которого он будет отображаться, для линейного характеристики линии (цвет, стиль, толщина).

[Примечание] Примечание

Для типовых объектов возможно настроить видимость типов и режимов в зависимости от масштаба карты.

[Предупреждение] Предупреждение

При создании слоя инженерной (тепловой, водопроводной, газовой, паровой, канализационной) сети через меню Задачи или Слой|Создать инженерную сеть типы и режимы создаются АВТОМАТИЧЕСКИ.

Для перехода к библиотеке типов и режимов слоя, откройте окно структуры слоя (Слой|Структура слоя). Список типов слоя представлен папками раздела Типы и режимы дерева структуры слоя. При выборе типа в списке, в правой части диалога открываются его настройки:

Параметры типа в диалоге структуры слоя

Рисунок 173. Параметры типа в диалоге структуры слоя

Режимы типа представлены списком вложенным в папку типа, для того чтобы раскрыть список режимов требуется дважды щелкнуть левой кнопкой мыши по значку типа в списке, либо нажать знак [image] слева от строки типа. При выборе режима в списке, в правой части диалога открываются его настройки.

[Примечание] Примечание

С примерами по работе со структурой можно познакомиться:

  • «Пример создания типовых объектов».

  • «Пример создания дополнительного режима для уже существующего типа объекта».

  • Видеоурок Редактирование символов можно посмотреть пройдя по ссылке: https://www.politerm.com/videos/layerstruct/layer_struct_edit_symbol/.


Работа с типами

С типами в библиотеке типов предусмотрены следующие действия:

  • Создание типов. Для создания нового типа на панели инструментов окна Структура слоя нажмите кнопку [image] Новый... и в открывшемся меню выберите пункт Новый тип, либо в меню диалога выберите пункт Правка|Новый тип... Новый тип будет создан и добавлен в список типов. Далее требуется задать параметры для созданного типа.

    [Подсказка] Подсказка

    Добавить новый тип в структуру слоя можно с помощью метода ObjectTypes.AddItem.

  • Редактирование существующих типов. Для редактирования уже созданного типа выберите его в списке и задайте требуемые параметры в правой части диалога структуры слоя;

  • Изменение порядка следования типов. Для изменения положения типа в дереве типов надо в дереве типов и режимов «встать» на нужный тип, нажать и удерживать клавишу Ctrl и перемещать режим по списку клавишами вверх/вниз (стрелками). Изменить порядок следования типов может понадобиться при настройке порядка отображения объектов слоя;

  • Удаление типов. Удалить можно только тип у которого нет режимов. Для удаления типа выберите его в структуре слоя и нажмите кнопку [image] Удалить на панели инструментов окна Структура слоя. При попытке удалить тип, занятый режимами появится сообщение Тип занят.

[Подсказка] Подсказка

Удалить тип из структуры слоя можно с помощью метода ObjectTypes.RemoveItem.

Настройка типов

Параметры выбранного типа объектов задаются следующими полями в правой части диалога структуры (см. Рисунок 173, «Параметры типа в диалоге структуры слоя»).

  • В поле Название задается название типа. При создании для типа автоматически назначается название вида «Новый тип # НОМЕР», где НОМЕР – id номер, назначенный типу.

  • В поле ID выбирается уникальный идентификатор типа объектов. При создании, типу назначается первый свободный номер ID. Если нужно его поменять нажмите кнопку [image] справа от поля, введите в открывшемся диалоге требуемый номер ID и нажмите кнопку OK. Смена номера произойдет только в том случае, если новый ID не занят другими типами, в противном случае отобразится соответствующее предупреждение.

  • В группе переключателей Графический тип выбирается тип графического объекта используемый для отображения типа: символьный, линейный, площадной либо текстовый. Для символьных и линейных графических объектов задаются дополнительные параметры.

    • Символьный графический тип

      Это тип, отображающийся с помощью символа, объекты которого определяются на местности координатой точки привязки (X,Y) и углом поворота символа вокруг точки привязки. Каждый режим такого типа обязательно связан с одним из символов библиотеки символов. Для решения инженерных задач у таких объектов требуется установить флажок Объект инженерной сети и выбрать тип объекта инженерной сети переключателем: источник, потребитель, отсекающее устройство, узел.

    • Линейный графический тип

      Это тип, который представляет собой ломаную. Типовой линейный объект может обладать признаком того, что данный тип является участком. Для линейного типового объекта являющегося участком инженерной сети требуется установить флажок участок. При вводе такой участок требует наличия на своих концах объектов символьного типа. Для участка сети может дополнительно устанавливаться флажок отсекающий. Если флажок сброшен, то при переключениях участки ведут себя пассивно, если же флажок установлен, то участок при решении задач топологического анализа рассматривается как отсекающее устройство, то есть отключение на схеме можно производить участком.

    • Площадной графический тип

      Представляет собой замкнутый контур. Каждый режим объекта имеет свой цвет, толщину и стиль линии контура, а также цвет и стиль заливки внутренней области контура.

    • Текстовый графический тип

      Представляют собой текст с заданными параметрами, такими как шрифт, начертание, размер, выравнивание.

  • Если база данных для типа уже создана, то она выбирается в поле со списком База данных, после чего она будет подключена к данному типу объектов. Выбранную базу можно отредактировать нажав кнопку Правка.... Чтобы создать новую базу данных для типа надо нажать кнопку Новая... (подробней о базах данных можно узнать в разделе Семантические базы данных).

    Если подключение типа к базе данных не требуется, оставьте в поле значение «(нет базы данных)». В слоях тепловых (водопроводных, газовых, паровых, канализационных) сетей базы данных создаются автоматически при создании слоя.


Работа с режимами

Создание типа еще не позволяет вводить в слой объекты данного типа, так как не существует информации о способе их отображения. Способ отображения типового объекта а так же дополнительные настройки задаются одним из его режимов.

Действия доступные с режимами:

  • Создание режимов. Щелчком левой кнопки мыши выберите тип, которому будете добавлять режим, далее:

    • сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Новый режим

      или

    • нажмите на панели инструментов диалога кнопку [image] Новый... и в открывшемся списке укажите Новый режим

      или

    • выберите пункт меню Правка|Новый режим.... Новый режим будет создан и добавлен в список режимов типа.

      Далее требуется задать параметры режима.

    [Подсказка] Подсказка

    Добавить новый режим в структуру слоя можно с помощью метода ObjectModes.AddItem.

  • Редактирование режимов. Для редактирования уже созданного режима выберите его в списке и задайте требуемые параметры в правой части диалога структуры слоя;

  • Изменение порядка следования режимов. Для изменения положения режима в списке режимов определенного типа в дереве типов и режимов левой клавишей мыши выделите режим. Затем нажмите и удерживайте клавишу Ctrl, далее перемещайте режим в нужное место клавишами вверх/вниз (стрелками).

  • Удаление режимов. Удаляется только последний в списке типа режим. Для удаления режима, выберите его в списке и нажмите кнопку [image] Удалить на панели инструментов. Режим можно удалить только тогда, когда он не занят объектами (в слое нет объектов этого режима).

[Подсказка] Подсказка

Удалить режим можно с помощью метода ObjectModes.RemoveItem.

Настройка режимов

Параметры режима в диалоге структуры слоя

Рисунок 174. Параметры режима в диалоге структуры слоя

Параметры выбранного режима задаются в правой части диалога структуры, изображенного на рисунке выше.

Набор параметров зависит от выбранного при создании нового типа графического типа. Общим для всех режимов является только поле Название в котором задается название режима. При создании режима по умолчанию для него задается название «Название режима # НОМЕР», где НОМЕР – порядковый номер режима в типе. Пользователь самостоятельно может изменить его на нужное название.

Далее будет рассмотрена настройка режимов для следующих графических типов:

  • для символьного графического типа;

  • для линейного графического типа;

  • для площадного графического типа;

  • для текстового графического типа.

Настройки режима для символьного графического типа

Каждый режим символьного графического типа связан с одним из символов библиотеки символов и для него должны быть заданы следующие параметры:

  • Из списка Символ из символов слоя выбирается символ, требуемый для отображения режима. В том случае, если подходящего символа нет, можно создать новый нажав кнопку Новый (подробней см. «Редактор символов»), либо отредактировать выбранный символ нажав кнопку Изменить.

  • В поле Размер выбирается размер символа.

  • Поле Цвет возможно использовать только для тех символов, у которых цвет узора выбран авто, цвет таких символов в списке символов слоя отображается в виде серо-белых квадратиков ( [image] ).

  • Для объектов графического типа Символьный с опцией Объект инженерных сетей в поле Состояние указывается проводимость объекта. Свойство проводимости объекта используется при решении задач топологического анализа.

    Виды проводимости для символьного типа, объекта инженерных сетей вида «источник», либо «отсекающее устройство»:

    • Включен – рабочее состояние, проводимость во всех направлениях.

    • Отключен – существует проводимость между всеми входящими и всеми выходящими. При этом разъединены только входящие участки с выходящими. Таким образом сохраняется проводимость между двумя любыми входящими или двумя любыми выходящими.

      Рисунок 175. Проводимость Отключен

    • Прямая проводимость – отсутствует проводимость от исходящих участков к входящим, в остальных случаях проводимость есть.

      Проводимость Прямая проводимость

      Рисунок 176. Проводимость Прямая проводимость

    • Обратная проводимость - отсутствует проводимость от входящих участков к исходящим, в остальных случаях проводимость есть.

      Проводимость Обратная проводимость

      Рисунок 177. Проводимость Обратная проводимость

    • Размыкатель - нет проводимости в любом случае не зависимо от направления участков, имеется только у вида отсекающее устройство.

    • Не работает - объект ведёт себя как простой узел (всегда открыта), имеется только у вида отсекающее устройство. Может использоваться для дополнительного режима работы задвижки. Например, можно создать дополнительный режим работы задвижки (Сломана) для того, чтобы в коммутационных задачах такие объекты учитывались.

    [Предупреждение] Предупреждение

    При добавлении дополнительных режимов в инженерные сети существуют определенные правила!

    Например, такие режимы как потребитель и задвижка следует добавлять в определенной последовательности и по определенным правилам:

    Задвижки задаются парами режимов, которые воспринимаются программой следующим образом: нечетный номер режима соответствует открытому состоянию, четный номер режима – закрытому (размыкатель).

    • «Номера режимов 1, 3, 5 и т. д.» – включена (состояние включен).

    • «Номера режимов 2, 4, 6 и т. д.» – отключена (состояние размыкатель).

    Для символьного типа, объекта инженерных сетей вида «потребитель» поле состояние отсутствует, но существуют такие же правила как и у задвижки: задаются парами режимов, которые воспринимаются программой следующим образом: нечетный номер режима соответствует включенному состоянию, четный номер режима – отключенному. В случае отключения участка сети, потребители, попавшие под отключение изменят режим работы на отключенный (перейдут в режим с номером на единицу больше).

    • «Номера режимов 1, 3, 5 и т. д.» – включен.

    • «Номера режимов 2, 4, 6 и т. д.» – отключен.

    [Примечание] Примечание

    Вы можете перемещать режимы вверх или вниз в дереве типов и режимов структуры слоя. Перемещение режима приводит к изменению его порядкового номера (номер режима). Именно порядковый номер (номер режима) определяет режим работы объекта и если вы ошиблись при создании, то можете быстро переместить режим вверх-вниз. Состояние проводимости у объектов используется для решения топологических задач.

    Подробней о правилах добавления режимов в конкретный вид инженерной сети можно ознакомиться в справке по этой сети:

    • тепловая сеть - https://www.politerm.com/zuluthermo/webhelp/index.html#layer_struct_regims_create_rules.html

    • водопроводная сеть - https://www.politerm.com/zuluhydro/webhelp/index.html#regims_create_rules.html

    • газопроводная сеть - https://www.politerm.com/zulugaz/webhelp/index.html#regims_create_rules.html

    • паропроводная сеть - https://www.politerm.com/zulusteam/webhelp/index.html#regims_create_rules.html

  • При установленном флажке Масштабировать для символа включается режим масштабирование, то есть размер символа изменяется при изменении масштаба карты.

  • Установленная опция Сохранять ориентацию при повороте карты позволяет при повороте карты сохранить ориентацию символа. То есть символ не будет поворачиваться.

  • При установленном флажке Не увеличивать больше указанного размера, символ не увеличивается при масштабе карты большем, чем указанный в поле размер.

  • При установленном флажке Не уменьшать меньше указанного размера, символ не уменьшается при масштабе карты меньшем, чем указанный в поле размер.

  • При установленном флажке Ориентировать при вводе участков, объекты, при вводе на карте будут повернуты по направлению ввода участков. Установка флажка не влияет на положение уже введенных на карту объектов.

  • При установленном флажке Поворачивать на 90 град., символ, при вводе на карте, поворачивается на угол 90 градусов по часовой стрелке, относительно изображения в редакторе символов. Параметр действует только при установленном флажке Ориентировать при вводе участков.

  • При установленном флажке Ориентация в верхней полуокружности объекты при нанесении будут принимать ориентацию в верхней полуокружности вводимого участка. Параметр действует только при установленном флажке Ориентировать при вводе участков.

Настройки режима для линейного графического типа

Параметры режима линейного графического типа в диалоге структуры слоя

Рисунок 178. Параметры режима линейного графического типа в диалоге структуры слоя

Для режимов линейного графического типа задаются цвет, толщина и стиль линии, указываются они в следующих полях:

  • В поле Цвет задается цвет линии режима.

  • В поле Стиль из линейных стилей слоя выбирается стиль режима. Стиль можно выбрать или нажав на [image] , в этом случае набор стилей откроется в виде списка или нажав кнопку ..., тогда стили откроются в дополнительном окне выбора (если нужного стиля нет в списке, его можно самостоятельно создать.

  • В полях Толщина на экране и Толщина при печати задается толщина линий режима при выводе на экран и при выводе на печать.

  • В поле Масштаб 1:1 задается коэффициент масштабирования. Он нужен для регулирования размеров толщины линии при изменении масштаба карты. Коэффициент применяется к величине толщины линии на экране. Например, при указанной толщине линии 1 пкс и коэффициенте 100 толщина линии на карте будет соответствовать 1 метру. Соответственно чем больше величина коэффициента, тем толще выглядит линия при одном и том же масштабе карты.

    Масштабирование линии будет производиться только при установленной опции Масштабировать.

    [Примечание] Примечание

    Масштабирование элементов сложного стиля линий, создаваемого пользователем будет возможно только при условии задания в редакторе стиля линий пропорциональных линейных размеров (см. «Редактор стиля линий»).

  • Отображать направления - при установке данной опции на линейном объекте стрелками будет отображаться направление. В дальнейшем если опция включена то отключить отображение направления не меняя свойства линейного режима возможно через настройку слоя. Если же опция отключена то даже при включении отображения в настройке слоя направление отображаться не будет.

  • Если при создании типа дополнительно были установлены опции участок и отсекающий дополнительно в поле Состояние можно задать свойство проводимости, эти параметры используются ТОЛЬКО для решения топологических задач. Виды проводимости линейных объектов (Участков):

    • Включен – проводит в обоих направлениях.

    • Отключен – нет проводимости.

    • Прямая проводимость – проводит по направлению ввода (по стрелке).

    • Обратная проводимость – проводит против направления ввода (против стрелки).

    [Предупреждение] Предупреждение

    При необходимости добавления дополнительных режимов для инженерных расчетов следует добавлять режимы линейных объектов в определенной последовательности и по определенным правилам, в зависимости от вида сети:

    • тепловая сеть - https://www.politerm.com/zuluthermo/webhelp/index.html#layer_struct_regims_create_rules.html

    • водопроводная сеть - https://www.politerm.com/zuluhydro/webhelp/index.html#regims_create_rules.html

    • газопроводная сеть - https://www.politerm.com/zulugaz/webhelp/index.html#regims_create_rules.html

    • паропроводная сеть - https://www.politerm.com/zulusteam/webhelp/index.html#regims_create_rules.html

  • Пересечение линий - в данном разделе производится настройка пересечения линейных объектов.

Настройки режима для площадного графического типа

Параметры режима площадного графического типа

Рисунок 179. Параметры режима площадного графического типа

Каждому режиму площадного типа надо задать цвет, толщину и стиль линии контура, а также цвет и стиль заливки внутренней области контура, параметры задаются в следующих полях:

  • в группе полей Граница настраиваются параметры границы площадного объекта:

    • в поле Цвет задается цвет границы;

    • в поле Стиль из линейных стилей слоя выбирается стиль границы. Стиль можно выбрать или нажав на [image] , в этом случае набор стилей откроется в виде списка или нажав кнопку ..., тогда стили откроются в дополнительном окне выбора (если нужного стиля нет в списке, его можно самостоятельно создать;

    • в полях Толщина на экране и Толщина при печати задается толщина границ при выводе на экран и при выводе на печать;

  • в группе полей Заливка настраиваются параметры заливки площадного объекта:

    • в полях Цвет фона и Цвет узора задаются цвета узора и фона заливки;

    • в поле Узор из площадных стилей слоя выбирается стиль заливки. Стиль можно выбрать или нажав на [image] , в этом случае набор стилей откроется в виде списка или нажав кнопку ..., тогда стили откроются в дополнительном окне выбора (если нужного стиля нет в списке, его можно самостоятельно создать;

    • в поле Прозрачность задается степень прозрачности заливки (от 0 до 100), поле активно только для заливки, у которой узор выбран сплошной заливкой;

    • В поле Масштаб 1:1 указывается масштаб, при котором размеры элементов заливки отображаются один к одному (параметр аналогичен размеру символа в настройке символьного объекта). Масштабирование будет производиться только при установленной опции Масштабировать.

Настройки режима для текстового графического типа

Параметры режима текстового графического типа

Рисунок 180. Параметры режима текстового графического типа

Для режимов текстового графического типа параметры задаются в следующих полях:

  • В разделе Шрифт - выбирается шрифт для текстового объекта.

  • В разделе Начертание - задается начертание для текстового объекта.

  • Из списка Набор надо выбрать набор для кодирования символов (по умолчанию используется Юникод).

  • В разделе Текст задаются дополнительные параметры для текста:

    • Подчеркнутый, Зачеркнутый - при выборе данных опций текст будет соответственно подчеркнут или зачеркнут;

    • из списка Цвет - выбрать цвет для шрифта;

    • в окошке Высота задать высоту текста, высота задается относительных единицах. Для регулирования размеров текстовых объектов на карте вводится коэффициент масштабирующий отображение текста. Коэффициент задает масштаб карты, при котором текст будет отображаться в таком же размере, в каком он был создан в структуре. Чем больше значение коэффициента, тем крупнее выглядят текст на карте (при одном и том же масштабе карты).

  • В разделе Фон можно задать:

    • из списка выбрать Тип текста- будет он с ореолом или выделен боксом вокруг текста, по умолчанию никаких эффектов у текста не будет;

    • при выборе типа Ореол или Бокс для них из списка Цвет выбирается цвет.

  • В разделе Выравнивание задается выравнивание для текста:

    • по горизонтали: лево, центр, право;

    • по вертикали: верх, базовая линия, низ;

    • при многострочном тексте: лево, центр, право.

[Примечание] Примечание

Все задаваемые параметры текстового объекта будут отображаться в окошке Образец.


Настройка порядка отображения объектов

В настоящей версии ZuluGIS реализовано два варианта настройки порядка отображения объектов в слое, для настройки:

  1. В дереве редактора структуры слоя выберите пункт Типы и режимы (Рисунок 182, «Вкладка Типы и режимы»).

    Вкладка Типы и режимы

    Рисунок 181. Вкладка Типы и режимы

  2. Укажите нужную опцию:

    • Площадные, линейные, символьные и текстовые - при выборе данной опции в слое будут отображены сначала площадные объекты, потом символьные и текстовые.

    • Примитивы, типовые по списку - при выборе этой опции сначала в слое будут отображаться примитивы, а затем типовые объекты. Типовые объекты будут выведены в соответствии со списком режимов в дереве типов и режимов. При этом объекты будут выведены по аналогии со списком слоев, то есть. самые верхние в списке, окажутся самыми нижними при выводе на экран. Для изменения положения типа в дереве типов надо в дереве типов и режимов «встать» на нужный тип, нажать и удерживать клавишу Ctrl, после чего перемещать режим по списку клавишами вверх/вниз (стрелками).

  3. Для сохранения изменений нажмите кнопку [image] Сохранить на панели диалога Структура слоя, после чего объекты слоя будут размещены в соответствии с указанным порядком следования.


Импорт типов и режимов

В системе ZuluGIS возможно из структуры одного слоя в структуру другого импортировать типы объектов, включая относящиеся к этим типам режимы, символы и структуры баз данных.

Для импорта:

  1. В дереве редактора структуры слоя выберите пункт Типы и режимы, нажмите кнопку Импортировать типы.

    Вкладка Типы и режимы

    Рисунок 182. Вкладка Типы и режимы

  2. В появившемся диалоге Импорт типов выберите слой, из которого будут импортированы типы, для этого нажмите кнопку Обзор... и выберите требуемый слой в открывшемся стандартном диалоге выбора файлов.

  3. В списке типов выбранного слоя отметьте флажками типы для импорта. Если необходимо импортировать все типы слоя, то установите флажок Все.

  4. По умолчанию импорт типов производится одновременно с структурой базы данных, в том случае если база данных не нужна снимите опцию Импортировать структуру базы данных.

  5. Завершите импорт нажатием кнопки Импорт.

    Диалог Импорт типов

    Рисунок 183. Диалог Импорт типов


Печать списка типов и режимов

В редакторе структуры можно распечатать типы и режимы слоев. В распечатке будет список типов объектов с их режимами, включая изображения внешнего вида объектов и названия используемых баз данных.

Диалоговое окно «Отчет по структуре слоя»

Рисунок 184. Диалоговое окно «Отчет по структуре слоя»

Для печати отчета по структуре:

  1. Выберите пункт меню Файл|Печать.

  2. Во вкладке Заголовок введите текст заголовка отчета. Нажмите кнопку Выбрать и задайте Параметры шрифта заголовка. Затем укажите тип выравнивания (по левому краю, по центру, либо по правому краю).

  3. Во вкладке Стили укажите информацию включаемую в отчет (типы, режимы базы данных) и задайте стиль вывода информации. Для каждого из перечисленных типов данных (сверху вниз) задаются следующие параметры:

    • для выводимых типов данных должен быть установлен флажок Включить в отчет;

    • кнопка Типы/Режимы/Базы открывает диалог для выбора шрифта печати Типа/Режима/Баз данных;

    • кнопки справа от поля с названием шрифта задают тип выравнивания (по левому краю, по центру, либо по правому краю);

    • в поле Отступ на странице (0,1 мм) задается отступ при печати соответствующих данных.

  4. Во вкладке Размеры задайте размеры печатаемых пиктограмм для графических объектов (ш - ширина, в - высота).

  5. Во вкладке Страница задаются параметры страниц для печати.

  6. Для предварительного просмотра отчета нажмите кнопку Просмотр....

  7. Нажмите кнопку Печать, выберите принтер, диапазон печати и число копий. Для запуска печати нажмите кнопку ОК.

Кнопка Отмена закроет диалог печати.


Базы данных

  • «Список баз данных слоя»

  • «Назначение базы данных простым объектам»

  • «Назначение базы данных типовым объектам»

Все простые объекты слоя (примитивы) привязываются к одной общей базе данных.

В то же время, каждый вид типовых объектов может привязываться к отдельной базе данных.

Для подключения к примитивам и типовым объектам доступны только уже существующие и добавленные в структуру слоя базы данных.

Управление базами данных производится в разделе диалога структуры слоя – Базы данных.

Подробно, работа с базами данных описана в разделе данного руководства: см. Семантические базы данных.

[Примечание] Примечание

При создании слоя инженерной (тепловой, водопроводной, газовой, паровой, канализационной) сети базы данных типовых объектов создаются автоматически.


Список баз данных слоя

Для перехода к списку баз данных, используемых слоем, в диалоге Структура слоя ( [image] ) выберите пункт Базы данных в дереве структуры слоя. Список баз откроется в правой части диалога.

Список баз данных в диалоге структуры слоя

Рисунок 185. Список баз данных в диалоге структуры слоя

В данном разделе диалога создаются новые базы, редактируются и удаляются существующие (подробней о базах данных см. «Общие сведения»).


Назначение базы данных простым объектам

Для того, чтобы указать какая база данных будет привязана к простым объектам слоя (примитивам) надо в дереве структуры слоя выбрать пункт Примитивы («Примитивы»). Затем из списка База данных выбрать заранее созданную базу.

Если для примитивов база данных не используется, в поле содержится значение «(нет базы данных)».

Раздел «Примитивы» диалога структуры слоя

Рисунок 186. Раздел «Примитивы» диалога структуры слоя


Назначение базы данных типовым объектам

Для того, чтобы задать базу данных, которая будет использоваться определенным типом объектов надо выбрать структуре слоя требуемый тип, затем из списка База данных (список содержит базы, подключенные к слою) нужную базу.

Если для типа база данных не используется, в поле содержится значение «(нет базы данных)».

Подключение базы данных к типовому объекту

Рисунок 187. Подключение базы данных к типовому объекту


Правила Редактора

  • «Редактирование правила»

  • «Удаление правила»

Правило редактора — это инструмент, который помогает ускорить и автоматизировать процесс ввода или редактирования данных. Настройки для этих правил находятся в Структуре слоя.

Правила могут быть настроены только для определенный операций редактирования. Ниже вы можете ознакомится со списком операций:

  • Вставка, копирование группы объектов;

  • Добавление объекта. Возможна настройка как создания пустой записи при добавлении, так и создания записи с определенными параметрами;

  • Разбиение контура. Можно настроить будет ли при разделении площадного объекта c помощью инструмента Разбить ( [image] ) запись в базе копироваться или добавляться пустая запись.

  • Разбиение линии. При разделении линии в узле на два объекта настраивается будет ли запись в базе копироваться или добавляться соответствующая ей пустая запись.

  • Разбиение участка одним символом или несколькими символьными объектами с заданным шагом. При разделении участка инженерной сети символьным объектом можно настроить разные параметры, например чтобы для линейного объекта производилось копирование данных и длина делилась пропорционально добавленному символу, подробней.

  • Разделение на отрезки. При разделении объекта в узлах на отрезки настраивается будет ли запись в базе копироваться или добавляться пустая запись.

  • Правила на смену режима объекта. При смене режима объекта возможно в базу данных внести дополнительную информацию, например номер режима, дату изменения и др.

  • Правила на смену типа объекта. При смене типа одного объекта или группы объектов возможно сохранить семантические данные у совпадающих полей.

  • Удаление группы объектов. После настройки правила при удалении группы объектов автоматически удаляются записи в базе данных.

  • Удаление объекта. После настройки правила при удалении объекта автоматически удаляется запись в базе данных.

  • Удаление символа, объединение участков. При удалении символьного объекта с участка инженерной сети можно удаление записей и суммирование длин объединенных участков.

  • Правила для надписей. Возможно включить следующие опции:

    • при добавлении записи в базу автоматически создавать бирку;

    • при перемещении объекта перемещать бирку.

  • Правило, применяемое при копировании объектов:

    • копировать табличные данные при дублировании объекта.

  • Правило, применяемое при удалении группы объектов:

    • предупреждать при удалении группы объектов.


Правила на вставку, копирование группы объектов

По умолчанию при вставке или копировании группы объектов в базу данных не добавляются пустые записи. Это значит, что без дополнительного обновления числа записей невозможно массово работать с базой данных этих объектов. Например, если не привести в соответствие количество графических объектов и строк в базе, невозможно будет вносить одинаковые семантические данные с помощью запросов.

Настройка правила на вставку и копирование группы объектов позволяет добавлять пустую запись в базу данных для каждого объекта при выполнении этих операций.

[Примечание] Примечание

Для копирования объектов вы можете так же включить дополнительную опцию, которая позволяет копировать не только графические но и табличные данные.

Для создания правила:

  1. Откройте структуру слоя (Слой|Структура слоя... или кнопка [image] ).

  2. В открывшемся окне слева в списке выберите Правила|Редактор.

  3. Далее сделайте щелчок правой кнопкой мыши в правой части окна и выберите Добавить операцию или сделайте двойной щелчок левой кнопкой мыши на пункте Операции редактирования.

    Рисунок 188. Добавление правила

  4. В открывшемся окне доступных операций выберите Вставка, копирование группы объектов, нажмите кнопку ОК.

    Рисунок 189. Доступные операции

  5. По умолчанию в списке выбран пункт любая. Это значит, что пустые записи будут добавляться ко всем объектам, независимо от их базы данных. Если же нужно добавлять новые записи только в определенные базы, укажите их в списке. После выбора нажмите кнопку ОК.

    Вставка, копирование группы объектов

    Рисунок 190. Вставка, копирование группы объектов

  6. Добавленное правило отобразится в окне структуры слоя. Нажмите кнопку [image] Сохранить для сохранения изменений.

    Правило на вставку, копирование группы объектов

    Рисунок 191. Правило на вставку, копирование группы объектов


Правила на добавление объекта

  • «Правила на добавление объекта с пустой записью»

  • «Правила на добавление объекта с полями по умолчанию»

При добавлении новых объектов можно настроить добавление в семантическую базу данных пустой записи или создание записи с определенными параметрами:

  • взять длину с карты;

  • взять высотную отметку с карты;

  • указать значение по умолчанию;

  • внести номер режима;

  • внести ID типа;

  • указать имя пользователя;

  • указать дату изменения.

Правила на добавление объекта с пустой записью

Данное правило работает следующим образом: при добавлении нового объекта на карту в базу данных будет добавлена соответствующая ему пустая запись.

[Примечание] Примечание

После настройки правила на добавление пустой записи возможна его доработка, которая позволит в запись автоматически добавлять определенные данные.

Для создания правила:

  1. Откройте структуру слоя (Слой|Структура слоя... или нажмите кнопку [image] ).

  2. Сделайте щелчок правой кнопкой мыши в правой части окна и выберите Добавить операцию или сделайте двойной щелчок левой кнопкой мыши на пункте Операции редактирования.

    Рисунок 192. Добавление правила

  3. В открывшемся окне доступных операций выберите операцию Добавление объекта:

    Рисунок 193. Доступные операции

  4. По умолчанию в списке выбран пункт любая. Это значит, что пустые записи будут добавляться ко всем добавляемым объектам, независимо от их базы данных. Если же нужно добавлять новые записи только в определенные базы, укажите их в списке. После выбора нажмите кнопку ОК.

    Рисунок 194. Добавление объекта

  5. Добавленное правило отобразится в окне структуры слоя. Нажмите [image] Сохранить для сохранения изменений.

    [Примечание] Примечание

    В том случае, если надо не просто добавить пустую запись но и в нее вносить определенную информацию, то далее надо доработать правило.

    Окно структуры слоя

    Рисунок 195. Окно структуры слоя

Правила на добавление объекта с полями по умолчанию

Ранее было описано создание правила на добавление объекта, в результате настройки которого после добавления в слой нового объекта к нему автоматически создается пустая запись в семантической базе данных. Это правило возможно дополнить, чтобы не только добавлялась пустая запись, но и в ней некоторые поля уже были заполнены определенными данными.

Можно внести следующие данные:

  • Длину с карты - используется для линейных или площадных объектов, во втором случае будет записана суммарная длина всех ребер объекта (периметр);

  • Высотную отметку с карты - для символьного объекта геодезическую отметку возможно считать только при наличии слоя рельефа с высотными отметками;

  • Значение по умолчанию - пользователь самостоятельно указывает значение для внесения;

  • Номер режима - порядковый номер режима добавленного объекта;

  • ID типа - ID типа из структуры слоя;

  • Имя пользователя - при использовании локальной версии в поле будет написано local, при использовании серверной версии в поле будет внесено имя пользователя добавившего объект;

  • Дату изменения - вносится дата и время добавления объекта.

Для создания правила на добавление объекта с полями по умолчанию:

  1. Создайте правило на добавление объекта.

  2. В окне Структура слоя перейдите на вкладку Правила|Редактор.

  3. Укажите в какое поле будет внесена какая информация. Для этого в дереве правил щелкните дважды по пункту База:... или сделайте на этом пункте щелчок правой кнопкой мыши и выберите Добавить поле. Так же можно сделать двойной щелчок по элементу Добавить пустую запись.

    Окно Структура слоя. Вкладка Редактор правил

    Рисунок 196. Окно Структура слоя. Вкладка Редактор правил

  4. Откроется окно выбора поля и действия для него.

    В верхней части окна выберите поле, а в списке Действие с полем укажите необходимое действие:

    • Взять длину с карты;

    • Взять высотную отметку с карты;

    • Значение по умолчанию.

    • Номер режима;

    • ID типа;

    • Имя пользователя;

    • Дата изменения.

      [Примечание] Примечание

      Тип поля для внесения данных должен соответствовать вносимой информации. В противном случае после добавления объекта будет выдано сообщение об ошибке.

      Окно выбора поля и действия

      Рисунок 197. Окно выбора поля и действия

    В том случае, если ранее не была выбрана конкретная база данных, а оставлен пункт <любая>, то есть внесение данных потребуется для всех баз. То тогда Имя поля необходимо будет внести вручную в соответствующее окно. И затем выбрать Действие с полем. Вносится реальное название поля.

    Окно выбора поля и действия

    Рисунок 198. Окно выбора поля и действия

  5. Нажмите кнопку ОК.

  6. Если в качестве действия было выбрано Значение по умолчанию:

    Окно выбора поля и действия

    Рисунок 199. Окно выбора поля и действия

    то откроется окно для его ввода. Введите нужное значение, подтвердите ввод кнопкой ОК:

  7. Результат отобразится в дереве Редактор - Правила:

    Результат добавления правила

    Рисунок 200. Результат добавления правила

  8. Нажмите кнопку [image] Сохранить.

Правила хранятся в файле слоя .b10, в виде xml:

<EditActions>
    <EditAction>
        Name: AddObject
        <Base>
            BaseId: 2
            Record: add_blank
            <Field>
                Name: Name
                Value: $Узел -
            </Field>
            <Field>
                Name: H_geo
                Value: $1.1
            </Field>
        </Base>
        <Base>
            BaseId: 6
            Record: add_blank
        </Base>
    </EditAction>
</EditActions>


Правила на разбиение контура

При разбиении контура объект делится на два объекта. По умолчанию один из них сохраняет исходные данные в семантической базе, а для второго запись не создается. Однако вы можете настроить правило, чтобы при разделении второму объекту автоматически создавалась запись с копией данных или пустой записью.

Для создания правила:

  1. Откройте структуру слоя (Слой|Структура слоя... или нажмите кнопку [image] ).

  2. Сделайте щелчок правой кнопкой мыши в правой части окна и выберите Добавить операцию или сделайте двойной щелчок левой кнопкой мыши на пункте Операции редактирования.

    Рисунок 201. Добавление правила

  3. В открывшемся окне доступных операций выберите операцию Разбиение контура и нажмите кнопку ОК.

    Рисунок 202. Доступные операции

  4. В верхней части появившегося диалога укажите базу данных для которой в дальнейшем будут применяться созданные правила, при выборе пункта <любая> указанные дальше действия будут применяться ко всем базам данных слоя.

  5. В нижней части окна выберите нужное действие:

    • Добавить пустую запись;

    • Копировать запись.

    Окно настроек при разбиении контура

    Рисунок 203. Окно настроек при разбиении контура

  6. Нажмите кнопку ОК.

  7. В окне структуры слоя нажмите кнопку [image] Сохранить.


Правила на разбиение линии

При разделении линии в узле линейный объект будет разделен на два объекта. По умолчанию один из них сохраняет исходные данные в семантической базе, а для второго запись не создается. Однако вы можете настроить правило, чтобы при разделении второму объекту автоматически создавалась запись с копией данных или пустой записью.

Для создания правила:

  1. Откройте структуру слоя (Слой|Структура слоя... или нажмите кнопку [image] ).

  2. Сделайте щелчок правой кнопкой мыши в правой части окна и выберите Добавить операцию или сделайте двойной щелчок левой кнопкой мыши на пункте Операции редактирования.

  3. Рисунок 204. Добавление правила

  4. В открывшемся окне доступных операций выберите операцию Разбиение линии и нажмите кнопку ОК.

    Рисунок 205. Доступные операции

  5. В верхней части появившегося диалога укажите базу данных для которой в дальнейшем будут применяться созданные правила, при выборе пункта <любая> указанные дальше действия будут применяться ко всем базам данных слоя.

  6. В нижней части появившегося окна выберите нужное действие:

    • Добавить пустую запись;

    • Копировать запись.

    Окно настроек при разбиении линии

    Рисунок 206. Окно настроек при разбиении линии

  7. Нажмите кнопку ОК.

  8. В окне структуры слоя нажмите кнопку [image] Сохранить.


Правила на разбиение участка одним символом или несколькими символьными объектами с заданным шагом

[Примечание] Примечание

При создании слоя инженерной сети в текущей версии ряд правил уже будут добавлены. Ознакомиться с ними и при желании отредактировать их можно открыв его структуру.

Вы можете настроить правила для операций разделения участка символьным объектом (добавления символьного объекта на существующий участок) и разделения участка несколькими символьными объектами с заданным шагом (разделение полилинии символами). Для каждой операции правила настраиваются отдельно.

Возможно настроить следующие параметры правил:

  • для линейного объекта (участка):

    • добавление пустых записей для новых объектов;

    • копирование записи с разбиваемого участка (то есть копирование всех полей);

    • пропорциональное разделение значения поля линейного объекта, например для участка сети поле длина будет разделено пропорционально делению самого участка символом;

    • копирование определенных полей, указанных в правилах;

    • очистка полей, указанных в правилах;

  • для символьного объекта (объект, которым производится разделение участка):

    • добавление пустых записей для новых объектов;

    • занесение высотной отметки с карты (геодезическую отметку возможно считать только при наличии слоя рельефа с высотными отметками);

    • занесение высотной отметки вычисленной интерполяцией Z вставляемого символа по Z на концах исходного участка и местоположению на этом участке места вставки - может применяться только для правила разделения участка одним символьным объектом;

    • занесение имени пользователя (при использовании локальной версии в поле будет написано local, при использовании серверной версии в поле будет внесено имя пользователя добавившего объект);

    • занесение даты изменения (вносится дата и время добавления объекта);

    • внесение значения по умолчанию (настраивается самостоятельно значение для внесения).

Чтобы настроить правила на разделения участка символьным объектом или разделения участка несколькими символьными объектами с заданным шагом:

  1. Откройте структуру слоя (Слой|Структура слоя... или нажмите кнопку [image] ).

  2. Сделайте щелчок правой кнопкой мыши в правой части окна и выберите Добавить операцию или сделайте двойной щелчок левой кнопкой мыши на пункте Операции редактирования.

  3. Рисунок 207. Добавление правила

  4. В открывшемся окне доступных операций выберите нужную операцию Разбиение участка символом или Разбиение участка символами. Нажмите кнопку ОК.

    Рисунок 208. Доступные операции

  5. В окне структуры отобразится выбранная операция. Далее отдельно добавляются правила для линейного и символьного объекта.

    Рисунок 209. Окно структуры

  6. Чтобы добавить правила линейным объектам сделайте двойной щелчок левой кнопкой мыши по пункту Линейный объект. Откроется окно выбора базы данных. В верхнем разделе укажите базу данных линейного объекта. При выборе пункта <любая> (по умолчанию) указанные дальше действия будут применяться ко всем базам линейных объектов слоя. Из списка Действие с записью укажите действие для записей выбранной базы:

    • Добавить пустую запись;

    • Копировать запись;

    • Очистить записи у обеих участков - применяется только для операции Разбиение участка символом.

    Для подтверждения действий нажмите кнопку ОК.

    Выбор базы и действия

    Рисунок 210. Выбор базы и действия

  7. Если для линейного объекта достаточно просто копирования или дублирования записей, то в этом случае можно переходить к настройке по символьным объектам. В противном случае, когда требуется не просто добавлять или копировать записи по объектам, а надо делать определенные манипуляции с полями, например очищать какие-то поля, копировать или значение поля разделить пропорционально в зависимости от вставленного символа, сделайте настройку этих полей.

    Для этого в дереве правил щелкните дважды по пункту База:... или сделайте на этом пункте щелчок правой кнопкой мыши и выберите Добавить поле.

    Указание базы для редактирования

    Рисунок 211. Указание базы для редактирования

  8. В появившемся диалоге в верхней части щелчком левой кнопки мыши выберите поле, для которого будут настраиваться параметры, например Длина (L или Length).

    Если ранее вы не выбрали конкретную базу данных и оставили пункт <любая>, то есть внесение данных потребуется для всех баз линейных объектов. То тогда Имя поля необходимо будет внести вручную в соответствующее окно. И затем выбрать Действие с полем. Вносится реальное название поля.

  9. В нижней части окна из списка выберите Действие с полем:

    • Пропорционально разделить значение поля - в данном случае значение поля будет разделено пропорционально внедренному на участок символу.

    • Очистить поле - выбранное поле будет очищено для новых участков после вставки символа.

    • Копировать поле - поле будет скопировано на новый участок, добавляемый при вставке символа.

    • Очистить поле у обеих участков - доступно только для операции Разбиение участка символом, у обеих участков примыкающих к добавляемому символу указанное поле будет очищено.

    Выбор поля и действия

    Рисунок 212. Выбор поля и действия

  10. Нажмите кнопку ОК. При необходимости добавьте действия со следующими полями.

  11. Для внедряемых в участок символьных объектов возможно настроить автоматическое добавление пустых записей и далее в эту запись возможно внести информацию. Чтобы это сделать щелкните дважды по пункту Символьный объект или сделайте на этом пункте щелчок правой кнопкой мыши и выберите Добавить базу. Откроется окно со списком баз данных слоя:

    Рисунок 213. Добавление объекта

  12. В верхнем разделе диалога выберите базу данных, в которую будет происходить добавление пустой записи. Если выбран пункт <любая> (по умолчанию), то настройка происходит для всех баз символьных объектов.

  13. Если требуется не просто добавить запись а еще дополнительно в нее определенные данные, то в верхней части окна выберите поле, а в списке Действие с полем укажите действие:

    • Взять высотную отметку с карты - геодезическая отметка может быть внесена только при наличии слоя рельефа с высотными отметками;

    • Имя пользователя - при использовании локальной версии в поле будет написано local, при использовании серверной версии в поле будет внесено имя пользователя добавившего объект;

    • Дата изменения - вносится дата и время добавления объекта;

    • Значение по умолчанию;

    • Вычислять высотную отметку по отметкам концов участка - может применяться только для правила разделения участка одним символьным объектом, отметка вычисляется интерполяцией Z вставляемого символа по Z на концах исходного участка и местоположению на этом участке места вставки. При использовании данного действия поля с геодезической отметкой для узлов разных типов должны называться одинаково.

      Тип поля для внесения данных должен соответствовать вносимой информации. В противном случае после добавления объекта будет выдано сообщение об ошибке.

      Окно выбора поля и действия

      Рисунок 214. Окно выбора поля и действия

  14. В том случае, если ранее не была выбрана конкретная база данных, а оставлен пункт <любая>, то есть внесение данных потребуется для всех баз. То тогда Имя поля необходимо будет внести вручную в соответствующее окно. И затем выбрать Действие с полем. Вносится реальное название поля.

    Окно выбора поля и действия

    Рисунок 215. Окно выбора поля и действия

    • Нажмите кнопку ОК.

    • Если в качестве действия было выбрано Значение по умолчанию:

      то откроется окно для его ввода. Введите нужное значение, подтвердите ввод кнопкой ОК:

  15. Нажмите кнопку ОК.

  16. В диалоговом окне структуры слоя нажмите кнопку [image] Сохранить.


Правило разделения на отрезки

Данное правило может быть настроено следующим образом, при разделении линейного объекта на отрезки (ломаная, прямоугольник или окружность): запись в базе копируется или же, добавляется пустая запись.

Для создания данного правила:

  1. Откройте структуру слоя (Слой|Структура слоя... или нажмите кнопку [image] ).

  2. Сделайте щелчок правой кнопкой мыши в правой части окна и выберите Добавить операцию или сделайте двойной щелчок левой кнопкой мыши на пункте Операции редактирования.

    Рисунок 216. Добавление правила

  3. В открывшемся окне доступных операций выберите операцию Разделить на отрезки и нажмите кнопку ОК.

    Рисунок 217. Доступные операции

  4. В верхней части появившегося диалога укажите базу данных для которой в дальнейшем будут применяться созданные правила, при выборе пункта <любая> указанные дальше действия будут применяться ко всем базам данных слоя.

  5. В нижней части появившегося окна выберите нужное действие:

    • Добавить пустую запись;

    • Копировать запись.

    Окно настроек при разделении на отрезки

    Рисунок 218. Окно настроек при разделении на отрезки

  6. Нажмите кнопку ОК.

  7. В окне структуры слоя нажмите кнопку [image] Сохранить.


Правила на смену режима объекта

Данное правило работает следующим образом: при смене режима объекта возможно в базу данных в указанные поля добавить следующую информацию:

  • Номер режима - порядковый номер режима на который была произведена смена;

  • ID типа - ID типа из структуры слоя;

  • Имя пользователя - при использовании локальной версии в поле будет написано local, при использовании серверной версии в поле будет внесено имя пользователя сменившего режим объекта;

  • Дату изменения - вносится дата и время изменения режима.

Для создания правила:

  1. Откройте структуру слоя (Слой|Структура слоя... или нажмите на панели инструментов кнопку [image] ).

  2. Перейдите на вкладку Правила|Редактор. Щелкните правой кнопкой мыши в правой части окна и выберите Добавить операцию или сделайте двойной щелчок левой кнопкой мыши на пункте Операции редактирования.

    Рисунок 219. Добавление правила

  3. В открывшемся окне доступных операций выберите операцию Смена режима объекта:

    Рисунок 220. Доступные операции

  4. В том случае, если внесение информации потребуется производить не во всех базах данных, то необходимо указать конкретные базы данных. Для этого выберите нужную базу из списка, при выборе <любая> записи будут добавляться во все базы данных слоя. После выбора нажмите кнопку ОК.

    Выбор базы данных

    Рисунок 221. Выбор базы данных

  5. Добавленное правило отобразится в окне структуры слоя.

    Окно структуры слоя

    Рисунок 222. Окно структуры слоя

  6. Далее необходимо указать в какое поле будет внесена какая информация. Для этого в дереве правил щелкните дважды по пункту База:... или сделайте на этом пункте щелчок правой кнопкой мыши и выберите Добавить поле.

    Указание базы для редактирования

    Рисунок 223. Указание базы для редактирования

  7. В появившемся диалоге в верхней части щелчком левой кнопки мыши выберите поле, в которое будут записаны данные.

  8. В нижней части из списка Действие с полем: выберите один из пунктов:

    • Номер режима;

    • ID типа;

    • Имя пользователя;

    • Дата и время.

    [Примечание] Примечание

    Тип поля для внесения данных должен соответствовать вносимой информации. В противном случае после смены режима будет выдано сообщение об ошибке.

    Выбор поля и действия

    Рисунок 224. Выбор поля и действия

    В том случае, если ранее не была выбрана конкретная база данных, а оставлен пункт <любая>, то есть внесение данных потребуется для всех баз. То тогда Имя поля необходимо будет внести вручную в соответствующее окно. И затем выбрать Действие с полем. Вносится реальное название поля.

    Выбор поля и действия

    Рисунок 225. Выбор поля и действия

  9. Нажмите кнопку ОК.

  10. Повторите пункты 6, 7 и 8 если необходимо чтобы данные вносились в несколько полей.

  11. Нажмите [image] Сохранить для сохранения изменений.


Правила на смену типа объекта

После настройки данного правила при смене типа одного объекта или группы объектов будут сохранены семантические данные у совпадающих полей.

Для настройки правила на смену типа объекта:

  1. Откройте структуру слоя (Слой|Структура слоя... или нажмите на панели инструментов кнопку [image] ).

  2. Перейдите на вкладку Правила|Редактор. Щелкните правой кнопкой мыши в правой части окна и выберите Добавить операцию или сделайте двойной щелчок левой кнопкой мыши на пункте Операции редактирования.

  3. Рисунок 226. Добавление правила

  4. В открывшемся окне доступных операций выберите операцию Смена типа объекта, нажмите кнопку ОК.

    Рисунок 227. Доступные операции

  5. Появится окно, в котором снизу в списке Действие с записью будет указан пункт Копировать значения совпадающих полей. Если по какой либо причине он не выбран, выберите его. Правило будет применяться для всех объектов, поэтому база данных в данном варианте не выбирается.

    Рисунок 228. Выбор действия

  6. Нажмите кнопку ОК.

  7. В диалоговом окне структуры слоя нажмите кнопку [image] Сохранить.


Правила на удаление группы объектов

После настройки данного правила при удалении группы объектов, удаляются соответствующие ей записи в базе данных.

[Предупреждение] Предупреждение

Необходимо понимать, что после настройки данного правила возврат (откат) действий по восстановлению записей в базе данных НЕВОЗМОЖЕН. То есть если например, при редактировании данных ошибочно была удалена группа объектов, по которым ранее были занесены данные в базу. То при возврате этой группы объектов (кнопка [image] или комбинация клавиш Ctrl+Z) графические объекты будут возвращены, а вот данные в семантической базе восстановить будет НЕВОЗМОЖНО.

Для создания правила на удаление объекта:

  1. Откройте структуру слоя (Слой|Структура слоя... или нажмите на панели инструментов кнопку [image] ).

  2. Перейдите на вкладку Правила|Редактор. Щелкните правой кнопкой мыши в правой части окна и выберите Добавить операцию или сделайте двойной щелчок левой кнопкой мыши на пункте Операции редактирования.

    Рисунок 229. Добавление правила

  3. В открывшемся окне доступных операций выберите операцию Удаление группы объектов и нажмите кнопку ОК.

    Рисунок 230. Доступные операции

  4. При необходимости, выберите базу данных из которой будет происходить удаление записей. Если выбран пункт <любая> (по умолчанию), то удаление записей будет происходить для всех баз слоя. Нажмите кнопку ОК.

    Рисунок 231. Удаление объекта

  5. Добавленное правило отобразится в окне структуры слоя. Нажмите [image] Сохранить для сохранения изменений.

    Рисунок 232. Окно структуры


Правила на удаление объекта

Данное правило работает следующим образом: при удалении объекта, удаляется соответствующая ему запись в базе данных.

[Предупреждение] Предупреждение

Необходимо понимать, что после настройки данного правила возврат (откат) действий по восстановлению записи в базе данных НЕВОЗМОЖЕН. То есть если, например при редактировании данных ошибочно был удален графический объект, по которому ранее были занесены данные в базу. То при возврате этого объекта (кнопка [image] или комбинация клавиш Ctrl+Z) графический объект будет возвращен, а вот данные в семантической базе восстановить будет НЕВОЗМОЖНО.

Для создания правила на удаление объекта:

  1. Откройте структуру слоя (Слой|Структура слоя... или нажмите на панели инструментов кнопку [image] ).

  2. Перейдите на вкладку Правила|Редактор. Щелкните правой кнопкой мыши в правой части окна и выберите Добавить операцию или сделайте двойной щелчок левой кнопкой мыши на пункте Операции редактирования.

    Рисунок 233. Добавление правила

  3. В открывшемся окне доступных операций выберите операцию Удаление объекта и нажмите кнопку ОК.

    Рисунок 234. Доступные операции

  4. При необходимости, выберите базу данных из которой будет происходить удаление записей. Если выбран пункт <любая> (по умолчанию), то удаление записей будет происходить для всех баз слоя. Нажмите кнопку ОК.

    Рисунок 235. Удаление объекта

  5. Добавленное правило отобразится в окне структуры слоя. Нажмите [image] Сохранить для сохранения изменений.

    Рисунок 236. Окно структуры


Правила на удаление символа, объединение участков

При объедении участков инженерной сети возможно настроить следующие действия:

  • удалять записи из базы для удаляемого символьного объекта и объединенного участка.

  • суммировать значения полей, указанных в правилах.

[Предупреждение] Предупреждение

Необходимо понимать, что после настройки правила по удалению записей возврат (откат) действий по восстановлению этих записей невозможен. То есть если, например при редактировании данных ошибочно был исключен символьный объект с участка сети. То при возврате этого объекта (кнопка [image] или комбинация клавиш Ctrl+Z) данные базы по ранее объединенному участку и исключенному символьному объекту восстановить будет НЕВОЗМОЖНО.

Для настройки данного правила:

  1. Откройте структуру слоя (Слой|Структура слоя... или нажмите на панели инструментов кнопку [image] ).

  2. Перейдите на вкладку Правила|Редактор. Щелкните правой кнопкой мыши в правой части окна и выберите Добавить операцию или сделайте двойной щелчок левой кнопкой мыши на пункте Операции редактирования.

    Рисунок 237. Добавление правила

  3. Выберите операцию Удалении символа, объединение участков в открывшемся окне доступных операций и нажать кнопку ОК.

    Рисунок 238. Доступные операции

  4. В окне структуры отобразится операция Удаление символа, объединение участков. Далее отдельно добавляются правила для линейного и символьного объекта.

    Рисунок 239. Окно структуры

  5. Для настройки правил линейного объекта дважды щелкните по пункту Линейный объект или сделайте щелчок правой кнопкой мыши на нем и выберите Добавить базу. Появится диалог, в верхнем разделе укажите базу данных линейного объекта. При выборе пункта <любая> (по умолчанию) указанные дальше действия будут применяться ко всем базам линейных объектов слоя. В списке Действие с записью автоматически выберется действие Удалить запись.

  6. Кроме удаления записи для линейного объекта возможно настроить суммирование значений полей, то есть например, при исключении символа с участка запись одного участка удаляется, а на втором участке поле длина суммируется с полем длина удаленной записи. Такая настройка возможна только в том случае, если на предыдущем шаге была указана конкретная база данных, чаще всего это база Участки.

    Для настройки суммирования в дереве правил щелкните дважды по пункту База:... или сделайте на этом пункте щелчок правой кнопкой мыши и выберите Добавить поле.

  7. В появившемся диалоге в верхней части щелчком левой кнопки мыши выберите поле, для которого будут настраиваться параметры, например Длина (L или Length). В нижней части окна автоматически выберется Суммировать значения полей. Нажмите кнопку ОК.

    Суммирование при объединении участков

    Рисунок 240. Суммирование при объединении участков

  8. Для символьного объекта в настоящей версии возможно настроить только удаление записи по нему в базе данных. Для этого дважды щелкните по пункту Символьный объект. Откроется окно следующее окно:

    Рисунок 241. Удаление объекта

  9. При необходимости, выберите базу данных из которой будет происходить удаление записей. Если выбран пункт <любая> (по умолчанию), то удаление записей будет происходить для всех баз данных символьных объектов. Нажмите кнопку ОК.

  10. Для сохранения внесенных изменений в диалоге Структура слоя нажмите кнопку Сохранить.


Правила для надписей (бирок)

Для слоя, в котором созданы надписи возможно применение следующих опций:

  • Создавать бирки для объекта при добавлении записи в базу. Данную опцию возможно использовать в том случае, если к слою подключены бирки. Если установлена данная опция, то при добавлении новых объектов на карту не придется в ручную обновлять бирки, они будут обновлены автоматически.

  • Перемещать бирки при перемещении объекта. Если данная опция установлена, то при перемещении объектов бирки так же будут перемещены.

Структура слоя. Правила редактора

Рисунок 242. Структура слоя. Правила редактора


Правило при копировании объектов

Для того, чтобы при копировании объектов так же копировались семантические данные необходимо установить соответствующую опцию:

  • Копировать табличные данные при дублировании объекта. В том случае если данная опция установлена при копировании объектов по мимо графической информации так же будет копироваться информация из таблиц семантической базы данных.

Структура слоя. Правила редактора

Рисунок 243. Структура слоя. Правила редактора


Правило на предупреждение при удалении группы объектов

По умолчанию предупреждение при удалении группы объектов появляется только при попытке удалить более 20 объектов. Но имеется возможность настроить индивидуально количество объектов, при котором будет выдаваться предупреждение.

Сообщение об удалении объектов

Рисунок 244. Сообщение об удалении объектов

Для настройки количества объектов укажите в соответствующем окне количество удаляемых объектов, при удалении которых будет выдаваться сообщение.

Структура слоя. Правила редактора

Рисунок 245. Структура слоя. Правила редактора


Редактирование правила

Для редактирования правила:

  1. Откройте Структуру слоя, правило которого будет отредактировано .

  2. В открывшемся окне слева в списке выберите Правила|Редактор. Далее в правой части окна сделайте щелчок правой на нужном пункте редактируемого правила. В зависимости от выбранного пункта появится то или иное меню.

    Рисунок 246. Редактирование правила

  3. Выберите нужный пункт меню и внесите изменения. Изменения вносятся точно так же как при создании правила редактора.

  4. Для сохранения нажмите кнопку [image] Сохранить.


Удаление правила

Правила могут быть удалены только по одному. Для того, чтобы удалить правило:

  1. Откройте Структуру слоя, правило которого надо удалить.

  2. В открывшемся окне слева в списке выберите Правила|Редактор.

  3. Щелкните правой кнопкой мыши по удаляемому правилу и выберите Удалить операцию.

    Рисунок 247. Удаление правила

  4. Для сохранения нажмите кнопку [image] Сохранить.


Правила Поиска

  • «Настройка быстрого поиска»

  • «Поиск объектов»

Инструмент Быстрый поиск разработан для удобного выбора данных из базы по пользовательскому условию. Поиск представляет собой строку для ввода запроса (как в интернет-поисковиках). Поиск возможен по всем объектам слоя или по выделенной группе объектов. Так же поиск возможно осуществлять как по оному полю, так и по нескольким полям базы данных. В результате поиска система выдает объект или список объектов, соответствующих поисковому запросу.

Для того чтобы выполнить быстрый поиск, необходимо сначала единожды произвести его настройку в структуре слоя и только затем осуществлять поиск.

[Подсказка] Подсказка

Видеоурок демонстрирующий настройку и работу быстрого поиска можно посмотреть пройдя по одной из ссылок: https://politerm.com/videos/database/sample_fast_search/ или https://www.politerm.com/videos/database/sample_fast_search/.


Настройка быстрого поиска

В рамках одного слоя может быть создано несколько условий поиска, в дальнейшем при поиске надо будет производить переключение между ними.

Для настройки быстрого поиска:

  1. Откройте структуру слоя у которого настраивается быстрый поиск (меню Слой|Структура слоя... или нажмите на панели инструментов кнопку [image] ).

  2. Слева выберите Правила|Поиск.

    Рисунок 248. Вкладка Правила|Поиск

  3. Для того чтобы создать условие поиска нажмите кнопку Новый.

  4. Укажите название шаблона поиска. Желательно, что бы название поиска ассоциировалось с условиями поиска. В случае, если условие поиска будет содержать несколько полей, все поля можно перечислить через запятую (именно запятая, в последствии, будет являться разделителем условий поиска).

    Настройка шаблона поиска

    Рисунок 249. Настройка шаблона поиска

    К примеру:

    1. Поиск зданий по двум полям, Наименование улицы и Номер дома, название условия поиска: Адрес| Улица, дом.

    2. Поиск насосных станций по полю адрес, название условия поиска: Насосные станции| Адрес.

  5. Укажите базу данных, подключенную к объектам слоя, по которой будет осуществляться поиск.

  6. Укажите наименование запроса и формы, по - умолчанию, поиск будет происходить по основному запросу.

  7. Укажите поле или список полей, по которым будет осуществляться поиск.

    1. Для того чтобы добавить дополнительное поле нажмите на кнопку +.

    2. Если поле было добавлено ошибочно, нажмите кнопку x.

    3. Если необходимо изменить порядок полей, при указании условий поиска воспользуйтесь кнопками: ˄ ˅.

    4. Можно установить значение поля по-умолчанию. В случае, если значение в условии поиска не будет указано, поиск будет осуществляться с подстановкой значения по-умолчанию, если значение в условии поиска будет указано, то значение по-умолчанию использоваться не будет.

  8. После задания параметров шаблона нажмите кнопку ОК. Кнопка Отмена закрывает диалог Шаблон поиска. После настройки шаблона можно приступать к поиску объектов.


Поиск объектов

Для того, чтобы начать поиск необходимо:

  1. Активировать панель поиска. Панель поиска включается нажатием на кнопку [image] Поиск, в панели навигация. В случае, если кнопки поиск нет, её можно добавить в настройках интерфейса:

    Рисунок 250. Кнопка Поиск

    1. Выбрать пункт основного меню Сервис|Настройка интерфейса.

    2. Перейти на вкладку Команды, категория - Карта.

    3. В списке команд найти Поиск.

    4. Удерживая левую кнопку мыши, поместить иконку Поиск на панель Навигация.

  2. Если поиск необходимо провести по группе объектов, то надо выделить объекты и нажать на панели поиска кнопку [image] (вокруг кнопки должен появиться голубой квадрат). Отмена поиска по группе произойдет при повторном нажатии на ту же кнопку. При поиске по всем объектам слоя данный пункт следует пропустить.

  3. В том случае, если в слое было настроено несколько условий поиска, то из списка, находящегося слева от строки поиска выбрать нужный. Когда настроено только одно условие данный пункт надо пропустить.

    Выбор условия поиска

    Рисунок 251. Выбор условия поиска

  4. Задать условие поиска, после чего нажать кнопку [image] или клавишу Enter на клавиатуре.

    Поиск по текстовым полям осуществляется по условию совпадения полного значения или его фрагмента, к примеру, чтобы найти значение наименования улицы Композиторов достаточно ввести:

    • весь текст целиком, независимо от регистра: Композиторов, КОМПОЗИТОРОВ;

    • фрагмент или фрагменты искомого выражения: комп, торов, ком торов.

    В случае, если таблицы хранятся с использованием BDE Paradox, значение условия поиска чувствительно к регистру, во всех остальных случаях (SQLite, SQL Server localDB, Microsoft SQL Server и прочие) регистр не имеет значения.

    Панель быстрого поиска

    Рисунок 252. Панель быстрого поиска

    Условие поиска может содержать уточняющие операторы.

    Оператор | Описание | Синтаксис | Пример условия | Результат
    Без указания | Полное совпадение значения | Значение | Композиторов | Будут найдены все здания на улице Композиторов
    Поиск значения по фрагменту по фрагменту | Фрагмент | Садов | Будут найдены все здания на улицах Садовая и Малая Садовая

    ,

             Если в настройках поиска указано несколько полей Значение поля1, Значение поля2 Воронежская, 33 а Будет найдено здание по адресу Воронежская, 33 а
    Если в настройках поиска указано несколько полей | Фрагмент значения1, Фрагмент значения2 | воронежск, 33 а | Будет найдено здание по адресу Воронежская, 33 а
    Если в настройках поиска указано несколько полей , ,Значение3 или Фрагмент значения3

    или

    ,Значение или Фрагмент знаяения2

            , ,жилой

    , 33

             В первом варианте будут найдены все жилые здания, во втором варианте

    будут найдены все дома у которых номер 33
    + Поиск нескольких значений Значение1 +Значение2 Воронежск +Лиговский Будут найдены все здания на улицах Воронежская и Лиговский проспект
    - Поиск значений в которых отсутствует фрагмент Значение -фрагмент Садовая –малая Исключение из результатов поиска значения Малая Садовая улица
    Поиск значений не соответствующих условию | -Значение | -Воронежская | Все здания за исключением тех, которые располагаются на Воронежской улице
    = Поиск полностью совпадающих значений, состоящих из одного или нескольких слов =Полное_значение или

    ="Полная фраза"

             ="Ул. Ленина 2" Если значение будет записано без = и кавычек, то в поиске будут выведены здания на Ул. Ленина 22, Ленина 222, Ул. Ленина 12 и т.д. Если же перед значением поставить =, то в результате поиска будут выбраны те объекты, данные которых полностью совпадут, в данном примере Ул. Ленина 2.
    Если в настройках поиска указано несколько полей | Значение1(фрагмент1), =Значение2 | композитор, =2 | Будет найдено здание по адресу Композиторов, 2. Без указания = в поиск попадут здания с адресом Композиторов, 2, Композиторов, 20, Композиторов, 21 и т.д.


Правила для веб-служб ZuluServer

  • шаблоны офлайн режима ZuluGIS Mobile

  • области закачки данных для офлайн режима ZuluGIS Mobile

  • поле для поиска по QR-коду в ZuluGIS Mobile

В данном разделе производятся настройки данных, которые в дальнейшем будут использованы в ZuluGIS Mobile.


Шаблоны офлайн режима ZuluGIS Mobile

Шаблон офлайн режима предназначен для ZuluGIS Mobile при работе в офлайн режиме слоя. Такой режим применяется при отсутствии интернета или связи с сервером. Используя его можно значительно увеличить скорость работы в ZuluGIS Mobile. В нем можно пользоваться графическим редактором, а именно вносить новые объекты с учетом топологических связей. Так же возможно описывать свойства объектов, загружать к ним документы, фотографии, делать аудио заметки и вносить QR-коды. Все изменения в офлайн режиме сохраняются локально на мобильном устройстве и затем при наличии хорошего интернета по команде загружаются на сервер.

После перевода слоя в ZuluGIS Mobile в офлайн режим в карте останется отображаться только его кэш из памяти устройства, а если кэш очистить, то объекты слоя вообще не будут отображаться пока слой не переключить обратно в онлайн режим. Для того, чтобы в офлайн режиме отображались объекты слоя надо настроить области для закачки данных.

Шаблон офлайн режима - это набор типовых объектов и соответствующих им форм или запросов. Все добавленные в шаблон объекты и поля формы или запроса будут доступны в офлайн режиме.

Для настройки шаблона офлайн режима:

  1. Откройте структуру слоя у которого настраивается шаблон (меню Слой|Структура слоя... или нажмите на панели инструментов кнопку [image] ).

  2. Слева выберите Правила|Веб.

  3. Сделайте двойной щелчок на строке Шаблоны офлайн режима ZuluGIS Mobile или щелкните правой кнопкой мыши на ней и выберите Новый шаблон. На экране появится диалог шаблона для ZuluGIS Mobile.

    Рисунок 253. Вкладка Правила|Веб

  4. В строке Название: укажите название шаблона.

  5. Нажмите кнопку +. В открывшемся окне из списка Тип выберите тип объекта. В разделе Формы - форму или запрос для него. Форма или запрос - это ранее сформированный при создании базы данных список полей для отображения по объекту. По умолчанию стандартной формой является Основной запрос.

    [Примечание] Примечание

    Типу может соответствовать только одна форма или запрос. При необходимости возможно в редакторе базы данных изменить или создать новые формы или запросы. Подробней с формами и запросами можно ознакомиться в разделе Создание базы данных.

    Нажмите кнопку ОК для подтверждения выбора типового объекта для офлайн режима.

    Выбор типа для шаблона

    Рисунок 254. Выбор типа для шаблона

  6. Повторите 5 пункт для всех типовых объектов, которые потребуется вводить в офлайн режиме.

    Добавленный в список тип объекта можно удалить или отредактировать. Для этого выделите его в списке и в первом случае нажмите кнопку ..., во втором кнопку -.

  7. После добавленных объектов для сохранения шаблона нажмите кнопку ОК.

    Шаблон для ZuluGIS Mobile

    Рисунок 255. Шаблон для ZuluGIS Mobile

  8. Сохраните структуру слоя используя кнопку Сохранить.


Области закачки данных для офлайн режима ZuluGIS Mobile

[Предупреждение] Предупреждение

Использование области закачки данных для офлайн режима невозможно без настройки шаблона офлайн режима для ZuluGIS Mobile!

Область закачки данных (зоны) используется ZuluGIS Mobile при работе в офлайн режиме. Ее настройка позволяет объекты и их атрибуты, которые попадают в указанную область скачать (закэшировать) в память устройства. После загрузки области без интернета или при плохой связи с сервером возможно будет редактировать закэшировные объекты, атрибуты к ним, а так же вносить новые объекты с атрибутами. Далее при наличии хорошей связи все изменения по команде загружаются на сервер.

[Примечание] Примечание

Важно отметить что в настроенные области будут загружены только те объекты, которые указаны в шаблоне офлайн режима для ZuluGIS Mobile.

Для настройки области закачки необходимо выполнить следующие этапы:

  1. Создать слой на сервере, в котором создаются и наносятся объекты областей закачки, к ним должна быть создана база данных (этап 1).

  2. Для каждого слоя область которого надо кэшировать настроить шаблоны офлайн закачки данных (этап 2).

  3. Опубликовать для веб-служб ZuluServer слой с областями (этап 3).

  4. Опубликованный слой с областями добавить в карту в мобильном приложении (этап 4).

1 этап

  1. Создайте на сервере векторный слой с базой данных. В базе данных должны быть как минимум два поля: sys - данное поле создается по умолчанию, и второе строковое поле, в которое в дальнейшем будет вноситься наименование областей.

    Диалог создания слоя

    Рисунок 256. Диалог создания слоя

  2. Области закачки данных - это полигоны, они могут быть как простыми объектами так и типовыми. Но при использовании простых объектов вносить области в слой возможно будет только в ZuluGIS, а вот при использовании типовых объектов области могут вноситься и редактироваться непосредственно в ZuluGIS Mobile. Именно поэтому рекомендуется создать в слое с областями типовой объект и в дальнейшем работать именно с ним.

    Для создания типового объекта откройте структуру слоя и создайте в ней тип и режим для областей.

    Графический тип для типового объекта выберите Площадной. В режиме настройте прозрачную заливку и желаемый цвет и толщину границ. В зависимости от данной настройки в дальнейшем будут отображаться указанные зоны закачки.

    Рисунок 257. Структура слоя

  3. Подключите к созданному типу объектов базу данных.

    Рисунок 258. Структура слоя

    И если слой создавался одновременно с базой данных отключите базу от примитивов (простых объектов).

    Рисунок 259. Структура слоя

  4. Нарисуйте в слое области для загрузки данных, в базу для каждой области внесите наименование.

    Рисунок 260. Структура слоя

2 этап

  1. Откройте структуру слоя данные которого надо закэшировать в областях.

  2. Перейдите на вкладку Правила|Веб.

  3. Сделайте щелчок правой кнопкой мыши на строке Области закачки данных для офлайн режима ZuluGIS Mobile и выберите Новая область. Или сделайте двойной щелчок левой кнопкой по данной строке.

  4. В появившемся диалоге нажмите кнопку Обзор... и выберите с сервера ( [image] ) ранее созданный и настроенный слой c областями.

  5. Нажмите кнопку +. В открывшемся окне из списка Тип выберите тип области.

  6. Если в слое несколько запросов, то убедитесь что в списке Запросы: выбран нужный запрос базы данных слоя. По умолчанию выбирается Основной запрос слоя.

  7. В разделе Поля: выделите поле с наименованием областей.

    Выбор типа для выбора областей

    Рисунок 261. Выбор типа для выбора областей

  8. Нажмите кнопку ОК.

    Добавленный в список тип области можно удалить или отредактировать. Для этого выделите ее в списке и в первом случае нажмите кнопку ..., во втором кнопку -.

  9. Для сохранения произведенных изменений в диалоге шаблона для ZuluGIS Mobile нажмите кнопку ОК.

    Диалог шаблона для ZuluGIS Mobile

    Рисунок 262. Диалог шаблона для ZuluGIS Mobile

  10. Сохраните структуру слоя используя кнопку Сохранить.

  11. Проделайте пункты 1-10 для всех слоев данные по областям которых необходимо закэшировать.

3 этап

Опубликуйте слой с областями для веб-служб ZuluServer или непосредственно из ZuluGIS или с использованием утилиты публикации данных веб-служб.

4 этап

Действия по добавлению слоя в ZuluMobile зависят от того, как организована работа с картой. Если слои сформированы в приложении и объединены в карту непосредственно в самом телефоне, то необходимо включить данный слой и добавить в карту в мобильном устройстве.

Если же работа в мобильном устройстве производится с серверными картами, то добавлять слой надо в ZuluGIS Online. После добавления слоя карту в ZuluGIS Online обязательно надо сохранить и затем уже в мобильном приложении обновить.

Определить откуда используется карта можно посмотрев раздел доступные карты в ZuluMobile, если цвет блока карты зеленый и под названием карты указан адрес сервера, то значит карта с сервера.

После проделанных действий в ZuluMobile для загрузки кэшированных данных областей надо будет перевести слой в офлайн режим и скачать нужные области.


Веб правило для поиска по QR-коду в ZuluGIS Mobile

[Примечание] Примечание

Видеоурок по работе с QR-кодами доступен по следующей ссылке https://youtu.be/WEXQ9gQcJbY

Для добавления возможностей работы с QR-кодами в структуре слоя ZuluGIS 2021 создается правило по обработке запросов к веб-службам ZuluServer. Настройка данного правила позволит производить поиск и внесение информации в ZuluGIS Mobile через QR-код.

Для успешного результата необходимо выполнить следующие этапы:

  1. В базе данных слоя, в котором в дальнейшем будет осуществляться внесение или поиск данных по QR-коду необходимо наличие поля для QR-кода (этап 1).

  2. Настроить правило для поиска по QR-коду в ZuluGIS (этап 2).

  3. Производить внесение или поиск по QR-коду из ZuluGIS Mobile (этап 3).

1 этап

  1. Чтобы работать с QR-кодом необходимо наличие поля, в которое будет вноситься и по которому после внесения QR-кода возможен будет поиск объектов. Для всех типовых объектов слоя используется поле с одним названием. То есть, внесение и поиск по коду будет производиться независимо от типа объекта. Тип поля обязательно должен быть Строковым.

    Если такое поле существует, то перейдите к следующему пункту. Если такого поля нет, то добавьте его к нужным объектам слоя. Это можно сделать двумя способами, более простой и удобный вариант добавить поле через окно семантической информации.

    Рисунок 263. Добавление поля

2 этап

Настройте правило в ZuluGIS:

  1. Откройте структуру слоя для которого надо настроить правило.

  2. Перейдите на вкладку Правила|Веб.

  3. Сделайте двойной щелчок по пункту Поле для поиска по QR-коду в ZuluGIS Mobile.

  4. В открывшемся диалоге Выбор поля для поиска по QR-коду из списка Поле слоя: выберите поле для кода.

  5. Нажмите кнопку ОК.

    Настройка поля для поиска по QR-коду

    Рисунок 264. Настройка поля для поиска по QR-коду

  6. Сохраните структуру слоя используя кнопку Сохранить.

3 этап

Для поиска объектов по QR-коду или занесения информации с QR-кода откройте ZuluGIS Mobile с картой, в которую добавлен настроенный слой.

Подробней о поиске можно узнать в справке по ZuluGIS Mobile. Поиск по QR-коду, о занесении данных справка по ZuluGIS Mobile. Ввод и редактирование информации.


Баннеры

[Примечание] Примечание

В текущей версии баннеры работают только ZuluGIS Online.

Баннеры - это всплывающие подсказки, которые появляются при наведении курсора на объект. Информация для отображения извлекается из указанных полей базы данных. Для баннеров можно настроить стиль, префикс, постфикс (по аналогии с надписями).

Для создания баннеров:

  1. Откройте структуру слоя для которого надо настроить баннеры.

  2. Перейдите на вкладку Правила|Баннеры.

  3. Нажмите кнопку Добавить тип.

  4. В открывшемся окне из списка Тип выберите тип объекта, для которого создается баннер.

  5. Если у выбранного типа в базе данных несколько запросов или форм, выберите нужную. По умолчанию будет использоваться основной запрос.

  6. Нажмите кнопку ОК.

  7. В столбце Цвет выберите цвет всплывающей подсказки. По умолчанию установлен желтый цвет [image] .

  8. Нажмите кнопку Добавить поле.

  9. Из списка выберите поле для вывода в баннерах, нажмите кнопку ОК.

  10. Для добавленного поля при необходимости настройте:

    • префикс - это постоянная составляющая, выводимая перед значением поля (спецсимволы могут быть вставлены из буфера обмена);

    • постфикс - это постоянная составляющая, выводимая после значения поля (спецсимволы могут быть вставлены из буфера обмена);

    • перенос - при установке данной опции поле, выводимое за настраиваемым полем, будет выводиться на следующей строчке;

    • цвет - цвет текста для выводимых данных, по умолчанию он черный [image] .

    В нижней части диалога имеется окно предварительного просмотра, отражающее примененные настройки.

  11. Для вывода нескольких полей одного типа, повторите пункты 8-10 для каждого поля.

  12. Если надо добавить несколько типов, то повторите пункты 3-7 для каждого добавляемого типа.

  13. Сохраните структуру слоя - кнопка Сохранить.

В результате все добавленные типы и их поля с настройками будут отражены в таблице баннеров.

Рисунок 265. Настройка баннеров

Результаты настройки можно посмотреть в ZuluGIS Online открыв карту и подведя курсор к объекту, у которого настроены баннеры.

Баннеры в ZuluGIS Online

Рисунок 266. Баннеры в ZuluGIS Online


Выделение группы объектов слоя

  • «Исключение объектов из группы»

  • «Инвертирование группы»

  • «Сохранение и загрузка группы»

  • «Импорт групп из XML файла»

  • «Экспорт групп в XML файл»

  • «Отмена группы»

Выделить группу - это значит сделать выборку из определенных объектов для дальнейшей совместной работы с ними. Выделенная группа может быть задействована в разнообразных режимах и операциях. Например, выделение служит основой для редактирования сразу нескольких объектов, заполнения их одинаковыми семантическими данными, изменения типа или режима, настройки надписей, расчёта определённой группы и многих других задач. Группа может включать как один объект, так и множество.

На экране выделенная группа отображается определенным цветом и стилем. По умолчанию группа создается в активном слое.

[Примечание] Примечание

Стиль выделения группы задается в меню Сервис|Параметры, пункт Карта.

[Подсказка] Подсказка

Группа слоя соответствует свойству Layer.Selection.

Выделить группу объектов можно множеством вариантов:

  • добавить в группу объектов по одному;

  • выделить группу в режиме редактирования слоя;

  • создать группу из всех объектов слоя;

  • создать группу из подобных объектов;

  • выделить группу указанием области;

  • выделить объекты одновременно в нескольких слоях;

  • создать группу по пересечению с полигоном другого слоя;

  • добавить объекты в группу по их ID;

  • создать группу по результатам запроса к семантической базе данных;

  • создать группу по выделенным записям в семантической базе данных

  • создать группу по графическим атрибутам объектов слоя;

  • создать группу объектов по пересечению со слоем;

  • создать группу выборкой объектов по условию;

  • создать группу инвертированием предыдущей группы;

  • создать группу по результатам топологических задач;

  • выделить дублированные объекты;

  • создать группу с использованием SQL запроса.

[Подсказка] Подсказка

Группа слоя соответствует свойству Layer.Selection.

Список выделенных объектов активного слоя можно увидеть в окне Группа. Для его открытия выберите пункт Окно|Группа. В окне будут отображены все ID (ключи) выделенных объектов активного слоя. При выделении строки с ID объект замигает и карта будет перестроена таким образом, чтобы объект был в центре экрана. При этом, если при выделении строки удерживать клавишу Alt, то так же будут происходить изменение масштаба карты.

Рисунок 277. Окно Группа

Так же список выделенных объектов с разделением на типы можно увидеть выбрав меню Карта|Группа|Инфо. Если объекты выделены в одном слое, то откроется следующее окно с информацией:

Окно Информация по группе

Рисунок 278. Окно Информация по группе

Если объекты выделены одновременно в разных слоях, то появится окно со списком слоев и количеством выделенных в них объектов. Для перехода к окну информации сделайте двойной щелчок левой кнопкой мыши по нужному слою в списке:

Список слоев с выделенными объектами

Рисунок 279. Список слоев с выделенными объектами

  • «Исключение объектов из группы»

  • «Инвертирование группы»

  • «Сохранение и загрузка группы»

  • «Отмена группы»


Добавление в группу объектов по одному

Для добавления в группу объектов по одному:

  1. Сделайте активным слой, в котором будет создаваться группа объектов.

  2. Выберите режим Выделить [image] .

  3. Нажмите и удерживайте клавишу Shift на клавиатуре.

  4. Сделайте щелчок левой клавишей мыши по добавляемому в группу объекту, объект добавлен.

  5. Не отпуская клавишу Shift сделайте щелчок левой клавишей мыши по каждому объекту, который надо добавить в группу.

[Примечание] Примечание

Если объект добавлен в группу ошибочно, то для его исключения нажмите и удерживайте клавишу Ctrl на клавиатуре. Затем сделайте щелчок левой клавишей мыши по нему.


Выделение группы в режиме редактирования слоя

Вы в процессе редактирования слоя можете выделить группу объектов. Добавление в группу можно производить по одному объекту или сразу несколько указанием прямоугольной области.

Для выделения:

  1. Проверьте чтобы был включен режим редактирования слоя ( [image] ).

  2. Установите Объект [image] .

  3. Для выделения объектов по одному. Нажмите и удерживайте клавишу Shift на клавиатуре. Сделайте щелчок левой клавишей мыши по добавляемому в группу объекту, объект добавлен. Не отпуская клавишу Shift сделайте щелчок левой клавишей мыши по каждому объекту, который надо добавить в группу.

    Иллюстрация добавления в группу по одному объекту

    Рисунок 280. Иллюстрация добавления в группу по одному объекту

    Для выделения нескольких объектов областью. Подведите курсор к месту одной из будущих вершин прямоугольной области. Нажмите левую клавишу мыши и не опуская ее переместите курсор до противоположной вершины. Для завершения выделения отпустите левую кнопку мыши.

    Иллюстрация создания группы выделением области

    Рисунок 281. Иллюстрация создания группы выделением области


Включение в группу всех объектов слоя

Для создания группы из всех объектов активного слоя нажмите комбинацию клавиш Ctrl+A.

Так же можно добавить в группу все объекты любого загруженного в текущую карту слоя, для этого выберите пункт главного меню Карта|Группа|Отметить все. Далее в появившемся списке загруженных в карту слоев укажите слой, в котором надо выделить группу и нажмите кнопку ОК.


Добавление в группу подобных объектов

Возможно создать группу из подобных объектов, то есть простых объектов одинакового стиля или типовых объектов одинакового режима. Создание группы из подобных объектов возможно двумя способами:

Вариант 1:

  1. Сделайте активным слой, в котором требуется создать группу.

  2. Выберите режим Выделить [image] .

  3. Сделайте щелчок по одному из объектов будущей группы, объект должен замигать.

  4. Щелкните правой кнопкой мыши в области карты и выберите пункт Объект|Добавить в группу подобные.

Вариант 2:

  1. Откройте окно Группа, для его открытия выберите пункт главного меню Окно|Группа.

  2. Выделите строку с ID объекта из подобных которому надо создать группу.

  3. Сделайте щелчок правой кнопкой мыши и из меню выберите пункт Добавить в группу подобные.


Выделение группы указанием области

Выделение объектов в слое может производиться в разных режимах: Выделить прямоугольником [image] , Выделить окружностью [image] , Выделить областью [image] .

  • Объекты, при выделении, могут добавляться в группу или исключаться из неё.

  • При выделении объектов учитывается способ взаимодействия с областью, полное или частично попадание в область.

  • Возможно выделение объектов одного или нескольких слоев сразу.

Действия с группой при выделении

Независимо от режима выделения областью можно использовать дополнительные клавиши, позволяющие добавить объекты группу или исключить объекты из группы:

  • если в момент завершения создания области нажата клавиша Shift, то объекты будут добавлены в группу;

  • если в момент завершения создания области нажата клавиша Ctrl, то объекты будут исключены из группы.

Способ взаимодействия с областью

Возможно выделение объектов «полностью входящих» в область или «полностью входящих или касающихся области». Настройка способа пересечения осуществляется в контекстном меню режима выделения областью. Для этого:

  1. Войдите в один из режимов выделения объектов, кнопки - [image] , [image] , [image] .

  2. Сделайте щелчок правой кнопкой мыши по карте и в контекстном меню выберите нужный пункт:

    • Полное попадание в контур;

    • Полное или частичное попадание в контур.

Данная настройка так же может быть произведена в настойках программы Сервис|Параметры, вкладка Карта.

Выделение по всем слоям

По умолчанию выделение объектов происходит только в активном слое, но при нажатии горячих клавиш Ctrl+Shift, в группу добавляются объекты всех слоев, которые взаимодействуют с областью.

Выделение группы объектов областью одновременно в нескольких слоях

[Примечание] Примечание

Создается не одна группа со всеми объектами слоев, а в каждом слое создается своя группа.

Для выделения группы прямоугольной областью:

  1. Сделайте активным слой, в котором надо выделить объекты.

  2. Выберите режим Выделить прямоугольником, для этого нажмите кнопку [image] .

  3. Левой кнопкой мыши укажите на карте одну вершину прямоугольника, удерживая кнопку мыши переместите курсор и укажите противоположную вершину прямоугольника, для завершения отпустите левую кнопку мыши (рисунок a).

    [Примечание] Примечание

    От того, как будет создаваться прямоугольная область слева-направо или справа-налево будет зависеть способ добавления объектов в группу, полное попадание или полное/частичное попадание.

Для выделения группы окружностью:

  1. Сделайте активным слой, в котором надо выделить объекты.

  2. Выберите режим Выделить окружностью, для этого нажмите [image] .

  3. Левой кнопкой мыши укажите на карте центр окружности, удерживая кнопку мыши переместите курсор и укажите вторую точку (задав радиус окружности), для завершения отпустите левую кнопку мыши (рисунок b).

    По умолчанию указываемая область имеет форму круга, если требуется выделить область овалом, то для этого зажмите и удерживайте на клавиатуре клавишу Shift. Клавишу следует отпустить до окончания выделения.

[Примечание] Примечание

От того, как будет создаваться область окружности сверху-вниз или снизу-вверх будет зависеть способ добавления объектов в группу, полное попадание или полное/частичное попадание.

Для выделения группы областью следует:

  1. Сделайте активным слой, в котором надо выделить объекты.

  2. Выберите режим Выделить областью, для этого нажмите [image] .

  3. Левой кнопкой мыши укажите на карте первую точку, так же левой кнопкой мыши укажите следующие точки многоугольника, для завершения выделения объектов в последней точке сделайте двойной щелчок левой клавишей мыши (рисунок c)

    Если в процессе создания области была указана лишняя или ошибочная точка ее можно отменить клавишей Esc или вызвав правой кнопкой мыши контекстное меню и выбрав пункт Отменить последнюю точку. Для отмены всей линии выделения выберите пункт Отменить всю линию.

Пример выделения объектов

Рисунок 282. Пример выделения объектов


Выделение группы объектов областью одновременно в нескольких слоях

В режиме выделения группы областью ( [image] ) возможно выделить объекты сразу во всех слоях попадающих в указанную область.

Для выделения группы объектов в нескольких слоях:

  1. Сделайте активным слой, в котором надо выделить объекты.

  2. Выберите режим Выделить областью, для этого нажмите [image] .

  3. Левой кнопкой мыши укажите на карте первую точку, так же левой кнопкой мыши укажите следующие точки многоугольника, для завершения выделения объектов в последней точке сделайте двойной щелчок левой клавишей мыши (рисунок c)

    Если в процессе создания области была указана лишняя или ошибочная точка ее можно отменить клавишей Esc или вызвав правой кнопкой мыши контекстное меню и выбрав пункт Отменить последнюю точку. Для отмены всей линии выделения выберите пункт Отменить всю линию.

  4. Нажмите и удерживайте на клавиатуре клавиши Shift и Ctrl.

  5. Сделайте двойной щелчок левой клавишей мыши. Объекты попавшие в область во всех слоях выделены.


Создание группы по пересечению с контуром другого слоя

В режиме Выделить областью ( [image] ) имеется возможность создать (выделить) группу из объектов, пересекающихся с контуром другого слоя, например выделить объекты тепловой сети, находящиеся в одном квартале. Заметим, что объекты тепловой сети и объекты кварталы находятся в разных слоях.

[Примечание] Примечание

Возможно выделение объектов «полностью входящих» в контур или «полностью входящих или касающихся контура». О данной настройке можно узнать здесь.

Для создания группы по пересечению с контуром другого слоя:

  1. Сделайте активным слой, в котором требуется создать группу. Проверьте чтобы не было включено редактирование слоя.

  2. Выберите режим Выделить областью, для этого нажмите [image] .

  3. Удерживая на клавиатуре клавишу Alt сделайте щелчок левой кнопкой мыши по объекту, в пределах которого надо выделить группу (например по кварталу). Если объекты, которые надо выделить окажутся в пределах нескольких объектов разных слоев, то на экране появиться диалоговое окно Пересечение с контуром из слоя. В этом окне укажите слой, в который входит объект, в пределах которого создается группа, и нажмите кнопку ОК.

    Диалоговое окно «Пересечение с контуром слоя»

    Рисунок 283. Диалоговое окно «Пересечение с контуром слоя»

На рисунке ниже показана созданная группа из объектов слоя Здания, которые графически попали в указанный квартал.

Создание группы объектов по пересечению с контуром

Рисунок 284. Создание группы объектов по пересечению с контуром


Добавление объектов в группу по их ID (ключу)

Для того чтобы добавить в группу объект с определенным ID (ключом):

  1. Сделайте активным слой, в котором требуется добавить объект.

  2. Выберите пункт Карта|Группа|Добавить, в появившемся диалоговом окне введите ID (ключ) и нажмите ОК. Кнопка Отмена закроет без изменений диалоговое окно Добавить объект в группу.

Для исключения объекта активного слоя из группы по его ID выберите меню Карта|Группа|Исключить, введите ID (ключ) исключаемого объекта и нажмите ОК.

[Примечание] Примечание

При открытой панели Свойства объект можно исключить из группы, установив курсор на его номере и нажав на клавиатуре последовательно Ctrl и Delete.


Создание группы по результатам запроса к семантической базе данных

Для создания группы по результатам запроса:

  1. Откройте окно семантической информации ( [image] ). Выберите вкладку Запрос.

  2. Напишите условия запроса, выполните его. Подробнее о запросах можно узнать в разделе «Выполнение запросов к базам данных».

  3. На панели окна семантической информации нажмите стрелку справа от кнопки Показать на карте ( [image] ). В открывшемся меню выберите пункт Выделить или Добавить в группу. В пером варианте группа объектов будет создана заново. Во втором варианте если ранее уже были выделены объекты, новые объекты будут добавлены к существующей группе.


Создание группы по выделенным записям в семантической базе данных

Для создания группы по выделенным записям в семантической базе данных:

  1. Откройте окно семантической информации ( [image] ), выберите вкладку База.

  2. Выделите записи по объектам которые надо добавить в группу. Выделить можно или группу последовательных записей или каждую запись отдельно. Для выделения последовательной группы записей укажите с помощью курсора начальную запись, затем нажмите на клавиатуре клавишу Shift и не отпуская укажите последнюю запись.

  3. Сделайте щелчок правой кнопкой мыши и в меню выберите пункт Выделить или Добавить в группу. В пером варианте группа объектов будет создана заново. Во втором варианте если ранее уже были выделены объекты, новые объекты будут добавлены к существующей группе.


Создание группы по графическим атрибутам объектов слоя

Группу можно создавать из объектов, обладающих определенными графическими свойствами (цветом, стилем, шрифтом, типом и т.д.).

[Примечание] Примечание

Видеоурок по выделению группы по графическим атрибутам можно посмотреть, перейдя по ссылке: https://www.politerm.com/videos/map/edit_group_attr/.

Для создания группы по графическим атрибутам объектов:

  1. Сделайте активным слой, в котором создаете группу объектов.

  2. Выберите в главном меню Карта|Запрос|По атрибутам или нажмите кнопку [image] .

  3. Для включения в выборку объектов с теми или иными атрибутами поставьте «галочку» напротив нужных объектов. Если поставить «галочку» напротив поля Все, тогда будут отмечены все объекты данной закладки.

    В зависимости от содержания конкретного слоя диалог может содержать несколько вкладок:

    • Типовые – содержит список всех типов и их режимов;

    • Контуры – содержит список всех встречающихся в слое заливок объектов (узор, цвет заливки, стиль, толщина, цвет границы);

    • Линии – содержит список всех встречающихся в слое способов отображения линий (цвет, толщина, стиль);

    • Текст – содержит список всех встречающихся в слое способов отображения текстовых объектов (имя шрифта, толщина, наклон, цвет); высота и угол наклона надписи не рассматривается;

    • Простые символы – содержит список всех встречающихся в слое простых символьных объектов.

    Окно выделения объектов по атрибутам

    Рисунок 285. Окно выделения объектов по атрибутам

    Если слой не содержит графических объектов, соответствующих той или иной закладке, то закладка диалоге отображаться не будет:

    Окно выделения объектов по атрибутам

    Рисунок 286. Окно выделения объектов по атрибутам

  4. В зависимости от выбранного режима группа будет создана заново или в уже существующей группе будут исключены/добавлены объекты. Режим выбирается из списка:

    Рисунок 287. Выбор режима

  5. При установке опции Искать среди выделенных поиск объектов будет осуществляться в заранее созданной группе.

  6. Для завершения процесса создания группы нажмите кнопку ОК.


Выделение группы объектов по пересечению со слоем

  • «Загрузка ранее сохраненной конфигурации»

Вы можете выделить группу объектов по пересечению со слоем, загруженным в карту. Например, можно одновременно выделить все дома, попадающие полностью или частично в область кварталов. Для успешного результата оба слоя должны быть либо локальные, либо с одного сервера.

Для выделения группы объектов по пересечению со слоем:

  1. Выберите меню Карта|Запрос|Пересечь со слоем.

  2. В списке Исходный слой выберите слой, в котором будет создаваться группа объектов.

  3. Укажите, какие объекты слоя будут выделены. Если слой содержит только простые объекты (примитивы), то для указания достаточно в левом верхнем углу окна установить/снять галочки напротив названия объектов. По умолчанию установлена опция Все объекты. Это означает, что все объекты указанного ранее слоя, попадающие под пересечение, будут выделены. В том случае если слой содержит типовые объекты, то список типов и режимов отобразится под названием слоя. В этом списке по умолчанию напротив всех объектов установлены галочки. Если не требуется выделение какого-либо типа, то галочку напротив его названия надо снять.

  4. Если предварительно уже была создана группа объектов, то при установке опции Выбирать только из выделенных объектов выделение будет осуществляться только из этой группы.

    Диалоговое окно Создать группу по пересечением со слоем

    Рисунок 288. Диалоговое окно Создать группу по пересечением со слоем

  5. Из списка Слой для пересечения выберите слой, с которым будет осуществляться пересечение.

  6. Далее укажите критерий пересечения. Возможные критерии:

    • полное попадание;

    • частичное попадание;

    • полное или частичное попадание;

    • полное непопадание;

    • полное или частичное непопадание;

    • полное совпадение.

  7. После выбора критерия в том случае, если необходимо произвести пересечение не со всеми объектами слоя, а с какой-то определенной группой объектов, установите опцию Пересекать только с выделенными объектами (группа должна быть предварительно создана).

  8. Из открывающегося списка выберите, как будет создаваться группа:

    • создать группу заново – группа будет создана заново, со всех других ранее выделенных групп выделение будет снято;

    • добавить в группу – группа будет добавлена к другим уже существующим группам слоя;

    • исключить из группы – группа будет исключена из ранее созданной группы слоя.

  9. Если в дальнейшем набор условий пересечения слоев (конфигурация пересечения) может еще понадобиться, то его возможно сохранить. Для сохранения конфигурации нажмите кнопку Сохранить. Введите для нее название и нажмите кнопку ОК. Конфигурация будет сохранена и затем доступна для дальнейшей загрузки только на том компьютере, на котором произошло ее сохранение.

    Для удаления ошибочно сохраненной конфигурации выберите ее из списка и нажмите кнопку Удалить. Затем нажмите кнопку Да для подтверждения удаления.

  10. Нажатие кнопки ОК завершит создание группы.

Рассмотрим пример. Предположим, имеется карта, содержащая несколько слоев, в том числе слои Кварталы и Тепловая сеть. Необходимо создать группу из отключенных участков, полностью попадающих в область трех определенных кварталов.

Для реализации этой задачи надо предварительно любым известным способом выделить кварталы, в которых должна быть создана группа из участков. Затем:

  1. Выбрать меню Карта|Запрос|Пересечь со слоем.

  2. В списке Исходный слой выбрать слой Тепловая сеть.

  3. Так как необходимо выделить не все типовые объекты слоя, то в верхнем левом углу диалогового окна надо снять опцию Все объекты. Далее в списке под слоем найти объект Участки, для раскрытия списка режимов нажать на «+» и напротив режима Отключен установить галочку.

  4. Из открывающегося списка Слой для пересечения выбрать слой Кварталы.

  5. Указать критерий пересечения Полное или частичное попадание, то есть группа будет создана из тех участков, которые полностью или частично попадают в кварталы.

  6. Установить опцию Пересекать только с выделенными объектами.

  7. Выбрать пункт Создать группу заново, то есть если в слое Тепловая сеть ранее уже были созданы какие-либо группы, то с них выделение будет снято.

    Диалоговое окно «Создать группу по пересечением со слоем»

    Рисунок 289. Диалоговое окно «Создать группу по пересечением со слоем»

  8. Нажать кнопку ОК.


Загрузка ранее сохраненной конфигурации

Если при создании группы по пересечению со слоем конфигурация была сохранена, то ее можно загрузить. Загрузка возможна только за тем компьютером, за которым она сохранялась.

Для ее загрузки:

  1. Выберите меню Карта|Запрос|Пересечь со слоем.

  2. В списке Исходный слой выберите слой, для которого сохранялась конфигурация.

  3. В разделе Конфигурация из списка выберите ранее сохраненную конфигурацию.

  4. Нажмите кнопку ОК.


Выделение группы по результатам топологических задач

Результаты топологических задач могут быть добавлены в группу.

Для добавления объектов, удовлетворяющих результатам топологических задач в группу (то есть объектов, выделенных красным цветом после решения топологической задачи), надо:

  1. Решить любую топологическую задачу.

  2. Сделать щелчок правой кнопкой мыши в любом месте карты и в появившемся контекстном меню выбрать пункт Создать группу или Добавить в группу.

[Примечание] Примечание

Возможно настроить автоматическое выделение результата топологических задач. Для этого нажмите кнопку Поиск пути – [image] . Сделайте щелчок правой кнопкой мыши в области карты и выберите пункт Создавать группу автоматически или Добавлять в группу автоматически. При выборе второго пункта объекты будут добавляться к уже существующей группе.


Выделение дублированных объектов

При некоторых операциях, например после импорта данных из какого-либо обменного формата в слое могут появиться дубликаты объектов. Под дублированными понимаются объекты, имеющие одинаковые координаты. Данная операция позволяет выделить в слое такие объекты.

Для выделения дублированных объектов:

  1. Выберите пункт меню Карта|Операции|Выделить дублированные объекты.

  2. В открывшемся диалоговом окне укажите слой, в котором необходимо выделить объекты.

  3. Выберите параметры выделения объектов:

    • Выделять дубликаты со старшим ID - выделены будут объекты, имеющие более старший номер ID;

    • Выделять дубликаты с меньшим ID - выделены будут объекты, имеющие более меньший номер ID.

  4. Так же вы можете добавить опцию Выделять в первую очередь дубликаты без атрибутов. В этом случае будут в первую очередь будут выделены объекты без записей, затем с пустой записью и затем объекты с меньшим количеством строк в записи.

  5. Нажмите кнопку ОК. Объекты с указанными параметрами будут выделены. Для просмотра списка с ключами (ID) выделенных объектов откройте окно Группа.

    Выделение дублированных объектов с опцией Выделять дубликаты со старшим ID

    Рисунок 290. Выделение дублированных объектов с опцией Выделять дубликаты со старшим ID

    Выделение дублированных объектов с опцией Выделять дубликаты со меньшим ID

    Рисунок 291. Выделение дублированных объектов с опцией Выделять дубликаты со меньшим ID


Создание группы по результатам SQL запроса

Автоматически создать группу объектов можно, применяя SQL запросы. Например, в результате приведенного ниже примера SQL запроса в слое Здания будут выделены объекты, у которых в строке Количество этажей будет стоять значение 4 или 5.

ALTER SELECTION ON [Здания]   ADD
SELECT * FROM [Здания]
where [Количество этажей] =4 or [Количество этажей] = 5

[Примечание] Примечание

Подробнее ознакомиться с SQL запросами можно в разделе Создание SQL запросов.


Исключение объектов из группы

Существует множество вариантов исключения объектов из выделенной группы объектов:

  • Исключение объектов в режиме выделить;

  • Исключение объектов с использованием окна Группа;

  • Исключение объектов по результатам запроса;

  • Исключение объектов по выделенным записям в семантической базе данных;

  • Исключение объектов по графическим атрибутам.

Исключение объектов в режиме выделить [image] :

  1. Сделайте активным слой, в котором требуется исключить объект из группы.

  2. Включите режим Выделить ( [image] ).

  3. Нажмите и удерживайте клавишу Ctrl на клавиатуре.

  4. Сделайте щелчок левой клавишей мыши на исключаемом объекте.

    Также можно пропустить 3 пункт, сделать щелчок на объекте левой кнопкой мыши, затем сделать щелчок правой кнопкой и выбрать из меню пункт Объект|Удалить из группы.

Исключение объектов с использованием окна Группа:

  1. Откройте окно Группа, для его открытия выберите пункт главного меню Окно|Группа.

  2. Выделите строку с ID объекта для исключения или несколько последовательных строк. Для этого укажите с помощью курсора начальную запись, затем нажмите на клавиатуре клавишу Shift и не отпуская укажите последнюю запись.

  3. Сделайте щелчок правой кнопкой мыши и из меню выберите пункт Исключить из группы.

Исключение объектов по результатам запроса:

  1. Откройте окно семантической информации ( [image] ). Выберите вкладку Запрос.

  2. Напишите условия запроса и выполните его. Подробнее о запросах можно узнать в разделе «Выполнение запросов к базам данных».

  3. На панели окна семантической информации нажмите стрелку справа от кнопки Показать на карте ( [image] ). В открывшемся меню выберите пункт Удалить из группы.

    Если же требуется исключить из группы не все объекты, попавшие в результат запроса, а только определенные, то можно сделать щелчок на строке с ID объекта, затем сделать щелчок правой кнопкой мыши и выбрать пункт Удалить из группы.

Исключение объектов по выделенным записям в семантической базе данных:

  1. Откройте окно семантической информации ( [image] ) и выберите вкладку База.

  2. Выделите записи, объекты которых надо исключить из группы. Выделить можно группу последовательных записей или каждую запись отдельно. Для выделения последовательной группы записей укажите с помощью курсора начальную запись, затем нажмите на клавиатуре клавишу Shift и не отпуская укажите последнюю запись.

  3. Сделайте щелчок правой кнопкой мыши и в меню выберите пункт Удалить из группы.

Исключение объектов по графическим атрибутам

  1. Сделайте активным слой, в котором надо исключить группу объектов.

  2. Выберите в главном меню Карта|Запрос|По атрибутам или нажмите кнопку [image] .

  3. Поставьте «галочку» напротив исключаемых объектов. Если поставить «галочку» напротив поля Все, тогда будут отмечены все объекты данной вкладки.

  4. Из списка снизу выберите пункт Удалить из группы:

    Рисунок 292. Выбор режима

  5. При установке опции Искать среди выделенных поиск исключаемых объектов будет осуществляться в заранее созданной группе. Для отображения точек перелома слоя нажмите на панели инструментов кнопку .

  6. Для завершения процесса удаления объектов из группы нажмите кнопку ОК.


Инвертирование группы

Инвертирование группы слоя представляет собой процесс, обратный преобразованию группы объектов. В ходе этой операции объекты, ранее входившие в группу, исключаются из неё, а из элементов, которые ранее не были частью группы, формируется новая.

Для инвертирования группы слоя выберите пункт главного меню Карта|Группа|Инвертировать. При этом на экране появится список загруженных в окно слоев, из которого укажите тот слой, для которого будет изменена группа. После выбора слоя для него произойдет инвертирование группы.


Сохранение и загрузка группы

[Примечание] Примечание

Группа сохраняется только в локальных данных за рабочим компьютером, для обмена сохраненных групп используете импорт и экспорт данных.

После того как группа создана, ее можно сохранить и затем при необходимости загрузить.

Для сохранения группы:

  1. Создайте группу объектов любым известным способом.

  2. Выберите меню Карта|Группа|Сохранить.

  3. В появившемся диалоговом окне в строке Название дайте название сохраняемой группы. При необходимости к названию можно добавить описание, оно заносится в одноименное окно.

  4. Чтобы завершить сохранение, нажмите кнопку ОК.

Для загрузки ранее сохраненной группы:

  1. Выберите меню Карта|Группа|Загрузить.

  2. В открывшемся диалоге сделайте двойной щелчок на названии загружаемой группы или выделите название группы и нажмите кнопку Загрузить.

[Примечание] Примечание

Для удаления ранее сохраненной группы выделите ее и нажмите кнопку Удалить.


Экспорт групп в XML файл

Сохраненную группу вы можете как экспортировать в файл XML, так и импортировать из XML файла.

Группы объектов сохраняются только локально за рабочим компьютером, импорт и экспорт групп используется для обмена данными.

Для экспорта групп:

  1. Выберите меню Карта|Группа|Загрузить.

  2. Установите галочки напротив групп, которые надо экспортировать в XML. Для того чтобы отметить сразу все группы, включите опцию Все, после чего напротив всех названий групп будут установлены галочки.

  3. Нажмите кнопку Экспорт в файл.

  4. Укажите папку и введите название для создаваемого XML файла.

  5. Нажмите кнопку Сохранить.

Экспорт завершен.


Импорт групп из XML файла

Сохраненную группу вы можете как импортировать из XML файла, так и экспортировать в файл XML.

Группы объектов сохраняются только локально за рабочим компьютером, импорт и экспорт групп используется для обмена данными.

Для импорта групп:

  1. Выберите меню Карта|Группа|Загрузить.

  2. Нажмите кнопку Открыть файл.

  3. Выберите на компьютере XML файл для импорта.

  4. Нажмите кнопку Открыть.

  5. В загруженном списке установите галочки напротив групп, которые надо импортировать. Для того чтобы отметить сразу все группы, включите опцию Все, после чего напротив всех названий групп будут установлены галочки.

  6. Нажмите кнопку Импорт. В результате успешного импорта будет выдано соответствующее сообщение.


Отмена группы

Для того чтобы отменить все ранее созданные группы во всех слоях карты:

  • выберите пункт главного меню Карта|Группа|Отменить

    или

  • нажмите на панели инструментов кнопку

    или

  • нажмите сочетание клавиш Ctrl+D.

Чтобы отменить группу только в одном слое, в списке загруженных слоев напротив слоя, в котором требуется отменить группу, нужно нажать кнопку [image] . Также данная кнопка доступна в списке слоев карты (Карта|Слои).

Отмена группы соответствует методу Layer.Selection.Clear.


Операции со слоями

В ZuluGIS со слоями возможно производить множество различных операций, которые подробно описаны далее:

  • «Настройка слоя»

  • «Информация по слою»

  • «Переименование слоя»

  • «Копирование слоя»

  • «Вырезание слоев по области»

  • «Индексация слоя»

  • «Сжатие слоя»

  • «Оптимизация слоя»

  • «Сетка по слою или по карте»

  • «Трансформирование слоя с клавиатуры»

  • «Трансформирование слоя с экрана»

  • «Перепроецирование слоя»

  • «Назначение проекции слою»

  • «Построение зон близости»

  • «Размещение фотографий в слое с привязкой к географическим координатам»

  • «Очистка слоя»

  • «Упаковка слоя (архивация)»

  • «Извлечение упакованного слоя»

  • «Обезличивание слоя сети»

  • «Уничтожение слоя»

  • «Тест слоя»

  • «Синхронизация слоя»


Настройка слоя

  • «Сохранение настроек слоя»

  • «Общие настройки»

  • «База данных»

  • «Линии»

  • «Контуры»

  • «Отображение типов»

  • «Редактор»

  • «Прозрачность»

На разных картах один и тот же слой может отображаться по-разному, например, его видимость может меняться в зависимости от масштаба карты, он может быть напечатан или нет, а также отображаться с указанием направлений участков или без них.

Настройки слоев сохраняются при сохранении файла карты. Также можно сохранить настройки отдельного слоя: «Сохранение настроек слоя». После сохранения настроек в слое они при необходимости могут применяться не только в локальных картах, но и в ZuluGIS Online, ZuluGIS Mobile или собственных приложениях.

Открыть диалог настройки слоя можно разными способами:

Выберите меню Карта|Слои... или нажмите на панели инструментов кнопку [image] . Если в карте один слой, то окно настроек откроется автоматически. Если слоев несколько, сначала выберите нужный слой, щелкнув по нему левой кнопкой мыши, затем нажмите кнопку Настройка.

ИЛИ

Сделайте щелчок правой кнопкой мыши по названию слоя в панели Рабочее место и выберите в открывшемся контекстном меню пункт [image] Настройка.

Далее описаны настройки векторных слоев. Настройки других типов слоев рассмотрены в разделах по этим слоям.


Сохранение настроек слоя

По умолчанию настройки отображения слоя сохраняются в файле карты при ее сохранении. Соответственно, при добавлении слоя в другую карту настройки применены не будут. В таких случаях применяют сохранение настроек внутри слоя (файл *.b10, где * – название слоя). При добавлении слоя с сохраненными настройками в другую карту настройки слоя будут восстановлены. Также сохраненные настройки слоя могут использоваться в опубликованных данных для веб-служб ZuluServer.

Для сохранения настроек слоя:

  1. Выберите команду главного меню Карта|Слои... или нажмите на панели инструментов кнопку [image] . Откроется окно Загруженные слои.

  2. Выберите слой или группу слоев (используя клавиши Ctrl или Shift). Сделайте щелчок правой кнопкой мыши и выберите Сохранить текущие настройки слоя. Настройки будут записаны в слой или группу слоев.

    Сохранение настроек слоя

    Рисунок 293. Сохранение настроек слоя

Настройки записываются внутри семейства файлов слоя (файл с расширением .b10). Информация хранится в формате xml в секции DefaultSettings.

Фрагмент секции DefaultSettings файла .b10:

<DefaultSettings>
    ShowDirection: 0
    ShowPrintDirection: 0
    MaxScale: 396.875
    MinScale: 0
    CopyRecordsOn: 1
    AddLabelOn: 1
    MoveLabelOn: 1
    <TypeVisibility>
        <TypeMode>
            Type: 3
            Mode: 0
            Flags: 2
            MinScale: 0
            MaxScale: 158.75
        </TypeMode>
    </TypeVisibility>
</DefaultSettings>


Общие настройки

Во вкладке Общие отображается следующая информация по слою:

Окно настройки слоя. Вкладка Общие

Рисунок 294. Окно настройки слоя. Вкладка Общие

Название слоя – отображается пользовательское наименование, которое указывается при его создании.

Путь – полный путь до места хранения слоя.

Источник – отображается версия ZuluServer или Локальный, если работа с данными осуществляется локально.

Проекция – в данной строке отображается назначенная слою проекция. Для отображения всех характеристик проекции или экспорта проекции слоя нажмите кнопку ....

Отображение:

  • отображать слой на карте – слой будет виден, если стоит галочка, в противном случае нет;

    [Подсказка] Подсказка

    Параметр соответствует свойству Layer.Visible.

  • отображать слой при печати – слой будет напечатан, если стоит галочка, в противном случае нет;

    [Подсказка] Подсказка

    Параметр соответствует свойству Layer.Printable.

  • отображать в псевдо 3D – включает режим псевдо 3D, данная опция будет активна только в том случае, если к слою подключена база данных с информацией о высоте объектов;

  • показ направлений на карте – показывать/не показывать стрелками направления для линейных объектов (участков сети - направленных графов). Если при включении данной опции направления на линейных объектах все равно не отображаются, то следует проверить режим линейных типовых объектов в структуре слоя. Если опция отключена в структуре, то даже при включении отображения в настройке слоя направление отображаться не будет;

  • показ направлений при печати – отображать/не отображать стрелками направления для участков сети при печати слоя;

  • отображать узлы – отображать/не отображать узлы объектов;

  • сглаживание линий – включить/отключить сглаживание линий (антиалиасинг) для слоя. Сглаживание линий для всех слоев одновременно задается в настройках карты (Карта|Настройка, вкладка Карта);

[Примечание] Примечание

Масштаб на карте может быть представлен в двух вариантах: геодезическом и в сантиметрах на пиксель. Выбор нужного масштаба осуществляется в параметрах системы.

Масштаб отображения:

  • не отображать при масштабе меньше, чем – слой не будет отображаться, если масштаб станет меньше заданного;

    [Подсказка] Подсказка

    Параметр соответствует свойству Layer.MinScale.

  • не отображать при масштабе больше, чем – слой не будет отображаться, если масштаб станет больше заданного.

    [Подсказка] Подсказка

    Параметр соответствует свойству Layer.MaxScale.


База данных

Во вкладке База данных указывается база данных, используемая примитивами слоя. Отображается только у локальных слоев.


Линии

Данная вкладка позволяет установить одинаковый стиль для всех линейных объектов слоя (ломаных). Следует иметь в виду, что при таком задании стиля отображения линейных объектов задается стиль ТОЛЬКО для отображения в данной карте. Если слой будет загружен в другую карту, то данные настройки отображения будут утеряны.

Окно настройки слоя. Вкладка Линии

Рисунок 295. Окно настройки слоя. Вкладка Линии

  • цвет – задается цвет для линии;

  • стиль – задается стиль для линии, если в списке стилей нет нужного, то его можно создать самостоятельно.

  • толщина на экране – задается толщина линейных объектов на экране пикселях;

  • толщина при печати – задается толщина линейных объектов при печати.

    Настройки для линейных объектов вступят в силу только после установки опции Использовать указанный стиль для всех таких объектов.


Контуры

Данная вкладка позволяет установить стиль для всех площадных объектов слоя (полигонов).

Следует иметь в виду, что при таком задании стиля отображения контурных объектов задается стиль ТОЛЬКО для отображения в данной карте. Если слой будет загружен в другую карту, то данные настройки отображения будут утеряны.

Окно настройки слоя. Вкладка Контуры

Рисунок 296. Окно настройки слоя. Вкладка Контуры

  • цвет фона – задается цвет фона;

  • цвет узора – задается цвет узора;

  • узор – задается узор для площадного объекта, если в списке стилей нет нужного, то его можно создать самостоятельно;

  • прозрачность – задается только для сплошного узора, значение прозрачности указывается в процентах от 0 до 100;

  • цвет – задается цвет для контура площадного объекта;

  • стиль – задается стиль контура площадного объекта, если в списке нет нужного, то его можно создать самостоятельно;

  • толщина на экране – задается толщина контура на экране пикселях;

  • толщина при печати – задается толщина контура при печати.

Настройки для контуров объектов вступят в силу только после установки опции Использовать указанный стиль для всех таких объектов.


Отображение типов

В данной вкладке вы можете настроить фильтр, который будет определять видимость различных типов и режимов в зависимости от масштаба карты. Это позволит ускорить процесс отрисовки слоев, содержащих множество объектов. Опция работает аналогично настройке видимости слоев и бирок.

[Примечание] Примечание

Масштаб на карте может быть представлен в двух вариантах: геодезическом и в сантиметрах на пиксель. Выбор нужного масштаба осуществляется в параметрах системы.

Окно настройки слоя. Вкладка Отображение типов

Рисунок 297. Окно настройки слоя. Вкладка Отображение типов

М.мин – минимальный масштаб. Если масштаб карты станет меньше заданного, тип (режим) не будет отображаться.

М.макс – максимальный масштаб. Если масштаб отображения станет больше заданного, тип (режим) не будет отображаться.

Например М.макс: 5000 означает, что объект будет невидимым при масштабах отображения карты более 1:5000.

Фильтры на отображение типов применяются только при выбранной опции Все фильтры включены. Если выбрать опцию Все фильтры отключены, то типовые объекты будут не будут скрываться.


Редактор

  • Геометрические построения

  • Ввод линейных и площадных объектов

  • Обновление данных на рабочих местах пользователей

Во вкладке Редактор выбирается, каким образом будут строится геометрические построения и вводиться линейные и площадные объекты. Так же настраивается интервал обновления данных на рабочих местах пользователей при работе с ZuluServer.

Окно настройки слоя. Вкладка Редактор

Рисунок 298. Окно настройки слоя. Вкладка Редактор

Геометрические построения

По аналогии с измерением расстояний и площадей геометрические построения при вводе различных объектов могут производиться как по проекции так и по сфероиду в зависимости от выбранной опции.

Для настройки построений следует выбрать нужный переключатель в соответствующем разделе:

  • По проекции – геометрические построения будут осуществляться по проекции;

  • По сфероиду – геометрические построения будут осуществляться по сфероиду.

По умолчанию установлена опция По сфероиду. Именно такой вариант позволяет производить построения в натуральную величину без искажений размеров вводимых объектов. На рисунке ниже показано два варианта построений участка сети. И в одном и в другом варианте при геометрических построениях использовался пункт контекстного меню На расстоянии, расстояние было указано 25 метров.

На первом рисунке варианте геометрические построения производились по сфероиду. В этом случае длина участка получилась реальная, это видно в окне Объект (Окно|Объект) строка Длина на сфероиде, м.

На втором рисунке геометрические построения производились по проекции, реальная длина участка в этом случае искажена.

Геометрические построения по сфероиду и проекции

Рисунок 299. Геометрические построения по сфероиду и проекции

Ввод линейных и площадных объектов

Ввод линейных и площадных объектов может производиться как по проекции так и по сфероиду в зависимости от выбранной опции.

Для настройки построений следует выбрать нужный переключатель в соответствующем разделе:

  • По проекции – ввод объектов будет осуществляться по проекции;

  • По сфероиду – ввод объектов будет осуществляться по сфероиду.

При относительно небольших расстояниях разницы между объектами нанесенными по сфероиду и по проекции не видно. Для того чтобы посмотреть длину введенного объекта надо открыть окно Объект (Окно|Объект), нажать кнопку [image] Выделить и сделать щелчок левой кнопкой по объекту (объект должен находиться в активном слое).

Визуальное отличие выбранной опции точно будет заметно при нанесении объектов у которых начальные и конечные точки находятся на значительном расстоянии друг от друга (больше 100 км). Например, на рисунке ниже изображены две линии проведенные от Санкт-Петербурга до Иркутска. Зеленая линия нанесена по сфероиду, а оранжевая по проекции, что при таких больших расстояниях отлично видно, соответственно у данных объектов будет разная длина.

Нанесение линии по проекции и по сфероиду

Рисунок 300. Нанесение линии по проекции и по сфероиду


Прозрачность

Для тайловых и WMS (WMTS) слоев, а также слоев рельефа SRTM возможно задание прозрачности. Прозрачность задается в %.

Окно настройки слоя. Задание прозрачности

Рисунок 301. Окно настройки слоя. Задание прозрачности


Информация по слою

[Примечание] Примечание

Информация по слою доступна для векторных слоев.

В системе предусмотрено удобное средство для получения краткой информации о векторных слоях. Чтобы воспользоваться им, выберите в главном меню пункт Слой|Информация…. Затем укажите слой, по которому хотите получить данные.

Кроме того, вы можете просмотреть информацию о слое через панель Рабочее место. Для этого наведите курсор на нужный слой, щёлкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Информация.

В окне информации по слою вы увидите общее количество объектов в этом слое, а также количество объектов каждого типа и режима.

Так же выводится параметр – фрагментация, который показывает процент логически удаленных объектов от общего количества объектов графической базы данных. Если этот процент велик, имеет смысл произвести Сжатие или Оптимизацию слоя.

Отображенная информация может быть скопирована в буфер, для этого нажмите кнопку Копировать.

Кнопка Проекция... откроет информацию о проекции слоя. Также из данного диалога возможно произвести экспорт проекции слоя.

[Примечание] Примечание

Видеоурок по просмотру информации слоя можно посмотреть, пройдя по одной из ссылок: https://youtu.be/J_dyxpE0O3g или https://www.politerm.com/videos/layerstruct/informatsiya-po-sloyu/.

Пример окна информации

Рисунок 302. Пример окна информации


Переименование слоя

Операция переименования может применяться к следующим слоям:

  • векторным слоям (*.b00);

  • растровым слоям (*.zrs);

  • слоям рельефа (*.ztr);

  • WMS, WMTS, слоям Tile-сервера, SRTM (*.zww);

  • слоям трекинга.

[Примечание] Примечание

Видеоурок по переименованию слоя можно посмотреть, пройдя по одной из ссылоке: https://youtu.be/eL4ZXTYPjFY или https://www.politerm.com/videos/layerstruct/layer_rename/.

Для локальных векторных слоев возможно переименование как пользовательского названия, так и имен всего семейства файлов слоя. Для остальных слоев производится переименование только пользовательского названия.

[Предупреждение] Предупреждение

Переименовать слои в файловой системе (проводнике) не рекомендуется. Это может привести к потере данных!

[Примечание] Примечание

Следует помнить, что если слой добавлен в несколько карт, то при переименовании семейства файлов этого слоя ссылка на него исчезнет, и его нужно будет добавить в карты заново.

Для переименования слоя:

  1. В меню Слой выберите команду Переименовать.

  2. В окне выбора слоя левой кнопкой мыши укажите слой, который надо переименовать, и нажмите кнопку Открыть.

  3. Если необходимо задать новое пользовательское имя для слоя, то в появившемся диалоговом окне в строке Пользовательское название слоя укажите новое название.

  4. Если необходимо сменить имя для семейства файлов локального векторного слоя, то в строке Новое имя файла укажите новое имя.

  5. Для запуска процесса переименования нажмите кнопку ОК.

[Примечание] Примечание

При задании нового имени для семейства файлов слоя переименованный слой будет исключен из карты. Для его добавления воспользуйтесь командой Карта|Добавить слой.

Диалоговое окно переименования слоя

Рисунок 303. Диалоговое окно переименования слоя

[Подсказка] Подсказка

Переименование слоя соответствует методу Layer.Rename.


Копирование слоя

[Примечание] Примечание

Имеется возможность копировать одновременно группу слоев по выделенной области. В результате будет получена новая карта с копией слоев, которые содержат объекты только по указанной области. О том, как это сделать, можно узнать в разделе «Вырезание слоев по области».

Копирование слоя заключается в создании его копии. Для нее по желанию можно задать новое имя файла и новое пользовательское название.

Копию слоя возможно создать как на локальной машине, так и на ZuluServer. Возможно копирование не всего слоя, а только части объектов. Для этого необходимо перед копированием выделить объекты для копирования.

Также имеется возможность произвести копирование только графики или структуры слоя. Скопированный слой может сразу быть добавлен в текущую карту.

[Примечание] Примечание

Видеоурок по копированию слоя можно посмотреть, пройдя по одной из ссылоке: https://youtu.be/EGlZor3-ac8 или https://www.politerm.com/videos/layerstruct/layer_copy/.

Серверный слой может быть скопирован на тот же сервер, на локальную машину или на другой сервер. При копировании слоя можно указать новую систему координат (копирование с перепроецированием) и новый источник данных для хранения табличной информации (например, из локальной базы данных в базу Microsoft SQL Server).

Для копирования слоя:

  1. В меню Слой выберите команду Скопировать…. Откроется диалог копирования слоя.

    Диалог копирования слоя

    Рисунок 304. Диалог копирования слоя

  2. В поле со списком Исходный слой выберите слой для копирования. В том случае, если слой находится в текущей карте, выберите его из открывающегося списка. Если же слой находится на диске, воспользуйтесь кнопкой Обзор....

  3. Чтобы скопировать группу выделенных заранее объектов слоя, следует установить флажок Только выделенные.

  4. Для наследования ключей при копировании группы (ID объектов не изменятся) следует установить опцию Наследовать ключи.

  5. В том случае, если при копировании на сервер требуется уменьшить время копирования, трафик или размер архива, можно скопировать базу данных слоя без данных в полях BLOB. Для этого следует установить опцию Без BLOB.

  6. В строке имя задайте полный путь к новому файлу слоя. Для этого воспользуйтесь кнопкой Обзор….

  7. В поле название укажите пользовательское название для нового слоя. Если было внесено ошибочное пользовательское название, то нажатие кнопки Исходное заменит его на пользовательское название исходного слоя.

  8. Для того чтобы перепроецировать пространственные данные слоя в другую картографическую проекцию в копии слоя, нажмите кнопку Система координат и задайте требуемую проекцию в открывшемся диалоге. Если систему координат не надо менять, пропустите данный пункт.

  9. Выберите требуемый вариант копирования:

    • Графику и таблицы – при выборе данного варианта будет скопирована вся информация слоя, включая графику и базу данных со всей внесенной ранее информацией;

    • Только графику – копируется только графическая информация без баз данных;

    • Только структуру – копируется только структура слоя.

  10. Если необходимо поменять источник данных для хранения табличной информации (например, из Access в SQLite), выберите новый из списка Источник для таблиц.

  11. Для автоматического добавления в текущую карту нового слоя установите флажок Добавить в карту.

  12. Нажмите кнопку ОК, чтобы начать процесс копирования.

[Подсказка] Подсказка

Копирование слоя соответствует методу Layer.CopyLayer.


Индексация слоя

В процессе ввода, редактирования и удаления объектов, содержащихся в слое, индексный файл графической базы данных слоя обновляется автоматически. Обычно в результате таких действий индексный файл постепенно увеличивается, что снижает скорость работы системы с этим слоем. По этой причине рекомендуется периодически производить переиндексацию слоя. Переиндексация может потребоваться и при изменении шага индексации, от которого также зависит скорость работы системы ZuluGIS со слоем. Кроме того, индексация слоя должна обязательно производиться, если слой не проиндексирован.

Если шаг индексации выбран неудачно (например, гораздо меньшим, чем средние габариты объектов слоя), то в процессе индексации может возникнуть переполнение индекса. При получении на экране сообщения о переполнении следует повторить процесс индексации слоя с указанием большего значения шага индексации.

Для индексации слоя следует выбрать пункт главного меню Слой|Индекс. При этом на экране появится диалог индексации слоя.

[Примечание] Примечание

Индексация слоя доступна для векторных слоев.

Для переиндексации слоя:

  1. В строке Имя выберите слой, подлежащий индексации (воспользуйтесь кнопкой [image] для открытия окна выбора файла).

  2. В строке Шаг индексации введите значение шага индексации (в сантиметрах). Если слой уже был проиндексирован, то в строке высветится текущий шаг индексации.

  3. Задав желаемое значение шага индексации, следует подтвердить ввод клавишей OK, после чего будет запущен процесс индексации.

Диалоговое окно Индексация слоя

Рисунок 305. Диалоговое окно Индексация слоя

[Подсказка] Подсказка

Если шаг индексации выбран неудачно (например, гораздо меньшим, чем средние габариты объектов слоя), то в процессе индексации может возникнуть переполнение индекса. При получении на экране сообщения о переполнении следует повторить процесс индексации слоя с указанием большего значения шага индексации.


Сжатие слоя

[Примечание] Примечание

Сжатие слоя доступно для векторных слоев.

В процессе редактирования или удаления объектов, содержащихся в слое, старые копии объектов, так же как и удаленные объекты, не удаляются из базы физически, а лишь помечаются как удаленные. Использование такого принципа существенно ускоряет ввод и позволяет в случае необходимости восстанавливать удаленные объекты. В то же время это приводит к постепенному увеличению объема графической базы данных, что снижает скорость построения и запросов и уменьшает место на диске. В связи с этим рекомендуется периодически производить сжатие графической базы данных, заключающееся в физическом удалении из базы объектов, помеченных на удаление, и следующей за этим автоматической переиндексации слоя.

Для запуска процесса сжатия слоя в меню Слой выберите команду Сжать…. При этом на экране появится диалог выбора слоя, в котором левой кнопкой мыши нужно выбрать слой, подлежащий сжатию, и нажать кнопку Открыть. После этого произойдет сжатие базы и ее переиндексация.


Оптимизация слоя

[Примечание] Примечание

Оптимизация слоя доступна для векторных слоев.

В процессе ввода данных в слой новый объект физически записывается в конец графической базы данных. Если территориальные объекты добавляются в графическую базу данных хаотично, то образующееся при этом неупорядоченное местонахождение объектов на диске друг относительно друга может замедлять процессы построения слоя (с большим числом объектов), его анализа, осуществления запросов, несмотря на наличие пространственной индексации. В связи с этим в ходе массового ввода объектов слоя рекомендуется периодически производить оптимизацию графической базы данных, заключающуюся в физическом упорядочении месторасположения в ней объектов слоя по определенному принципу (похоже на дефрагментацию дискового пространства).

Для оптимизации графической базы слоя следует выбрать пункт меню Слой|Оптимизация…. При этом на экране появится диалог выбора слоя, в котором нужно выбрать слой, подлежащий оптимизации. За выбором слоя последуют упорядочение базы и ее автоматическая переиндексация. В процессе упорядочения графической базы данных попутно выполняется и процесс ее сжатия. Следует отметить, что оптимизация слоя возможна только для индексированного слоя и только в том случае, если слой не находится в режиме редактирования.

[Подсказка] Подсказка

Оптимизация слоя соответствует методу Layer.Optimize.


Сетка по слою или по карте

В результате данной операции будет создан слой с сеткой из заполненных полигонов. Сетка может быть построена в нескольких вариантах: по габаритам карты, слоя, по выделенным объектам слоя и по выпуклой оболочке слоя. При создании сетки вы можете так же одновременно со слоем создать базу данных. Сетка может быть построена не по всем объектам, а только по выделенным, тогда объекты необходимо выделить заранее.

Для создания сетки по слою:

  1. В меню Карта выберите команду Операции|Сетку по слою.

  2. В открывающемся списке Исходный слой укажите слой, по которому создается сетка.

  3. В разделе Слой для записи в первой строке задайте имя файла, в который будет записываться создаваемая сетка (используйте кнопку Обзор... для открытия стандартного окна выбора файла), во второй строке при необходимости можно заменить пользовательское название слоя.

  4. Одновременно со слоем вы можете создать базу данных. Базу создают в том случае, когда слой сетки будет использован для многостраничной печати по планшетам. В созданной базе будет одно поле Name, тип поля - строковый. Для создания базы установите флажок База по умолчанию и из списка Источники данных выберите источник.

  5. В разделе Сетка введите шаг создаваемой сетки в сантиметрах и точку начала координат – Опорная точка.

  6. Выберите опцию По слою или По карте.

  7. Если требуется, чтобы сетка создавалась по выделенным заранее объектам, установите флажок Группа.

  8. Из списка выберите вариант построения сетки. В зависимости от выбранного варианта будет применен определенный алгоритм построения сетки:

    • Габариты – по габаритам слоя;

    • Объекты – по объектам слоя;

    • Выпуклая оболочка – по выпуклой оболочке.

  9. Для того чтобы созданный слой-сетка сразу был загружен в текущую карту, установите опцию Добавить в карту.

  10. Нажмите кнопку ОК.

Пример диалога создания сетки

Рисунок 306. Пример диалога создания сетки

В результате операции будет создан слой с сеткой. Если была отмечена опция Добавить в карту, то слой сетки автоматически загрузится в активную карту. При установке флажка База по слою создается база данных.

Рисунок 307. Пример сетки

[Примечание] Примечание

При необходимости созданный слой может быть исключен из карты или удален с диска.


Трансформирование слоя с клавиатуры

[Примечание] Примечание

Трансформирование слоя с клавиатуры доступно для растровых слоев, растровых групп и векторных слоев.

Система позволяет производить следующие аффинные преобразования слоев карты:

  • линейно изменять масштаб по оси X;

  • линейно изменять масштаб по оси Y;

  • смещать слой по оси X;

  • смещать слой по оси Y;

  • поворачивать слой на заданный угол вокруг заданного центра поворота;

  • производить преобразования с помощью коэффициентов трансформации.

При использовании сдвига, поворота, масштаба преобразование координат точки (X,Y) в новые координаты точки (X’,Y’) производится по формуле:

X’= Xs + Xc + Kx * (X-Xc) * cos(Fi) - Ky * (Y - Yc) * sin(Fi)

Y’=Ys + Yc + Kx * (X-Xc) * sin(Fi) + Ky * (Y - Yc) * cos(Fi),

где

  • Xs – смещение по X;

  • Ys – смещение по Y;

  • Kx – коэффициент искажения масштаба по X;

  • Ky – коэффициент искажения масштаба по Y;

  • (Xc,Yc) – координаты точки поворота;

  • Fi – угол поворота.

При использовании коэффициентов преобразование координат точки (X,Y) в новые координаты точки (X’,Y’) производится по формуле:

X' = a* X + b * Y + c

Y' = d * X + e * Y + f

[Важно] Важно

Прежде чем проводить трансформирование слоев карты, очень желательно сделать ее копию, так как трансформирование НЕ ИМЕЕТ ОТМЕНЫ, то есть возврата к первоначальному расположению объектов в слое.

Окно задания параметров трансформации слоев можно открыть через меню Карта|Операции|Трансформировать слои. Если необходимо трансформировать только один слой, то можно воспользоваться пунктом Слой|Трансформирование.

  1. В разделе Слои отметить слои для трансформации. Опция Все позволяет выделить все слои одновременно.

    [Предупреждение] Предупреждение

    В настоящей версии системы трансформация одновременно нескольких слоёв в разных проекциях запрещена! При такой операции будет выдано сообщение: Невозможно одновременно трансформировать слои с отличающимися проекциями!

  2. Из списка Параметры преобразования выбрать, по каким параметрам будет производиться трансформация: Сдвиг, поворот, масштаб или Коэффициенты.

  3. При выборе трансформации с помощью Сдвига, поворота, масштаба:

    • в разделе Смещение следует задать значения смещений слоя по X и Y в сантиметрах;

    • в разделе Масштаб следует задать значения коэффициентов искажения масштаба слоя по X и Y. Если установлен флажок Пропорционально, то коэффициенты масштабирования по осям X и Y будут одинаковыми;

    • В разделе Центр (см) следует задать координаты точки поворота слоя в сантиметрах и угол поворота в градусах.

  4. При выборе трансформации с помощью коэффициентов:

    • в разделе Коэффициенты надо задать коэффициенты для трансформации, смещения задаются в сантиметрах, ось X направлена вверх, Y вправо;

    • при нажатии кнопки Инвертировать коэффициенты будут обратно преобразованы.

  5. Если предварительно в трансформируемых слоях были выделены объекты, то при установке опции Трансформировать только выделенные объекты преобразование будет применяться только для них.

  6. После ввода требуемых параметров преобразования следует нажать кнопку OK, после чего запустится процесс трансформации слоя.

Диалог Трансформирования слоя

Рисунок 308. Диалог Трансформирования слоя

[Подсказка] Подсказка

Трансформация слоя соответствует методу Layer.Transform.


Трансформирование слоя с экрана

При работе с пространственными данными иногда возникает задача максимально точного их совмещения между собой и привязке к выбранной системе координат. Как правило, такая задача появляется, если данные получены из разных источников. Типичными случаями являются ситуации, когда необходимо совместить данные, оцифрованные с бумажных носителей, с уже имеющимися слоями карты, находящимися в плановой или географической системе координат. Также задача трансформации данных возникает при работе с растровыми изображениями. Например, для растровых изображений, полученных в результате сканирования бумажных носителей, необходимо устранить нелинейные искажения, возникающие при сканировании. Для аэро- и космоснимков может понадобиться их геометрическое преобразование к текущей координатной системе карты. Выбор метода трансформации определяется исходя из конкретной задачи и характера искажений данных, которые надо устранить.

[Примечание] Примечание

Далее будут приведены методы трансформации, помимо них также с помощью трансформации слоя с экрана возможно произвести копирование одиночного объекта или группы объектов.

Трансформирование слоя доступно для растровых слоев, растровых групп и векторных слоев.

Методы трансформации:

  • «Сдвиг»;

  • «Масштабирование»;

  • «Масштабирование с поворотом»;

  • «Аффинная и проективная трансформация»;

  • «Резиновый лист (локально-аффинная трансформация)».

[Подсказка] Подсказка

  • Система имеет возможность производить трансформацию сразу нескольких векторных слоев. Для этого надо перед запуском трансформации щелкнуть правой кнопкой мыши и в контекстном меню выбрать пункт Слои для трансформации. Далее в появившемся окне левой кнопкой мыши указать (поставить галочку), какие слои требуется трансформировать. При установки опции Все автоматически отметятся и будут трансформироваться все векторные слои, находящиеся в карте. При установке опции Только выделенные отмечены будут только те слои, в которых есть выделенные объекты (объекты необходимо выделить заранее).

    [Предупреждение] Предупреждение

    В настоящей версии системы трансформация одновременно нескольких слоёв в разных проекциях запрещена! При такой операции будет выдано сообщение: Невозможно одновременно трансформировать слои с отличающимися проекциями!

  • Если имеется необходимость трансформировать не все объекты слоя, а только некоторые, то для этого надо выделить объекты для трансформирования, при этом невыделенные объекты будут нетронуты.

  • После того как точки трансформации указаны (например, приблизительно), их положение можно отредактировать (уточнить) в соответствующих ячейках таблицы на панели Свойств. Для этого щелкните левой кнопкой мыши на нужной ячейке и введите новое значение.

  • При вводе точек можно осуществлять пошаговую отмену указанных точек. Для этого щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Отменить последнюю точку. Пошаговую отмену также можно сделать нажатием клавиши Esc.

  • Для отмены всех установленных точек трансформации щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Очистить все.

  • Для сохранения координат точек трансформации щелкните правой кнопкой мыши, в появившемся контекстном меню выберите пункт Сохранить точки трансформации и задайте имя для сохраняемого файла. Чтобы загрузить точки трансформации, щелкните правой кнопкой мыши, в появившемся контекстном меню выберите пункт Загрузить точки трансформации и выберите файл с координатами точек.

  • Откат (возврат) произведенных действий можно сделать с помощью пункта Отменить действие, расположенного в контекстного меню, вызываемом правой кнопкой мыши или нажатием на панели инструментов кнопки Отмена ( [image] ). Откат будет возможен только до того момента, пока не будет отключен режим редактирования.

  • Все произведенные преобразования векторного слоя сохраняются автоматически. Если не требуется их сохранять, то перед выходом из режима редактирования слоя произведите откат до начального состояния слоя.


Сдвиг

При использовании данного метода происходит смещение данных по оси X и оси Y на величину, равную разнице между старыми и новыми координатами точки трансформации.

Метод требует задания 1-й пары точек трансформации.

Для сдвига векторного объекта надо:

  1. Сделать векторный слой редактируемым ( [image] ).

  2. Нажать на панели инструментов кнопку Трансформация слоя с экрана ( [image] ). Курсор примет вид [image] .

  3. Перемещаясь по карте, с помощью нажатия левой кнопки мыши укажите точку, из которой надо переместить векторный слой. После указания первой точки она отобразится на карте в виде кружка, также ее координаты отобразятся в таблице на панели свойств системы (если она открыта), а курсор примет вид [image] .

  4. Аналогичным образом указать вторую точку (куда надо переместить). Она отобразится в виде окружности.

  5. В рабочей области карты щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Сдвиг. После произведенных действий произойдет соответствующее перемещение векторного слоя и отображение его на новом месте.

Используемые формулы:

X' = dx + X

Y' = dy + Y

где:

  • dx, dy – смещение по оси X и оси Y.


Масштабирование

Данный метод позволяет делать следующие преобразования координат: изменять масштаб, смещать по оси X и оси Y.

Метод требует задания 2-х пар точек трансформации.

Для масштабирования векторного объекта надо:

  1. Сделать векторный слой редактируемым ( [image] ).

  2. Нажать на панели инструментов кнопку Трансформация слоя с экрана ( [image] ). Курсор примет вид [image] .

  3. Перемещаясь по карте, с помощью нажатия левой кнопки мыши укажите точку, из которой надо переместить векторный слой. После указания первой точки она отобразится на карте в виде кружка, также ее координаты отобразятся в таблице на панели свойств системы (если она открыта), а курсор примет вид [image] .

  4. Аналогичным образом указать следующую точку (куда надо переместить). Она отобразится в виде окружности.

  5. Точно таким же образом укажите вторую пару точек.

  6. В рабочей области карты щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Масштабирование. После произведенных действий произойдет соответствующее перемещение и масштабирование векторного слоя и отображение его на новом месте.

В общем случае преобразование координат точки (X,Y) в новые координаты точки (X',Y') производится по формуле:

X' = dx + Xc + kx * (X - Xc)

Y' = dy + Yc + ky * (Y - Yc),

где:

  • dx, dy – смещение по оси X и оси Y;

  • kx ≠ ky – коэффициенты искажения масштаба по оси X и оси Y;

  • (Xc, Yc) – координаты точки поворота.


Масштабирование с поворотом

Данный метод позволяет делать следующие преобразования координат: изменять масштаб, смещать по оси X и оси Y, поворачивать данные на заданный угол вокруг заданного центра поворота.

Метод требует задания 2-х пар точек трансформации.

Для масштабирования векторного объекта надо:

  1. Сделать векторный слой редактируемым ( [image] ).

  2. Нажать на панели инструментов кнопку Трансформация слоя с экрана ( [image] ). Курсор примет вид [image] .

  3. Перемещаясь по карте, с помощью нажатия левой кнопки мыши укажите точку, из которой надо переместить векторный слой. После указания первой точки она отобразится на карте в виде кружка, также ее координаты отобразятся в таблице на панели свойств системы (если она открыта), а курсор примет вид [image] .

  4. Аналогичным образом указать следующую точку (куда надо переместить). Она отобразится в виде окружности.

  5. Точно таким же образом укажите вторую пару точек.

  6. В рабочей области карты щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Масштабирование с поворотом. После произведенных действий произойдет соответствующее перемещение и масштабирование векторного слоя и отображение его на новом месте.

В общем случае преобразование координат точки (X,Y) в новые координаты точки (X',Y') производится по формуле:

X' = dx + Xc + k * (X - Xc) * cos(Fi) - k * (Y - Yc) * sin(Fi)

Y' = dy + Yc + k * (X - Xc) * sin(Fi) + k * (Y - Yc) * cos(Fi),

где:

  • dx, dy – смещение по оси X и оси Y;

  • k – коэффициент изменения масштаба одинаковый по осям X и Y;

  • (Xc, Yc) – координаты точки поворота;

  • Fi – угол поворота.


Аффинная и проективная трансформация

Аффинная и проективная трансформация реализуется с помощью полиномиальной аппроксимации данных методом наименьших квадратов. Суть данных методов заключается в нахождении такого преобразования данных в новые координаты, при котором достигается наименьшая погрешность (невязка) между координатами заданных точек трансформации и значениями этих точек в новых координатах. В процессе ввода точек трансформации вы можете определить ожидаемую точность преобразования данных по значениям невязки – чем меньше значение невязки, тем точнее будет выполнено преобразование. Значение невязки отображается в окне Свойства (закладка Трансформирование слоя, столбец E1).

В данных методах задача преобразования старых координат точки (X,Y) в новые координаты (X',Y') сводится к нахождению таких коэффициентов a1,…,an, b1,…,bn аппроксимирующего полинома, при которых минимизируется сумма квадратов отклонений заданных значений от построенной аппроксимирующей кривой.

Метод требует задания не менее 3-х пар точек трансформации.

Для аффинной трансформации:

X' = a1X + a2Y + a3

Y' = b1X + b2Y + b3

Для аффинной трансформации векторного объекта надо:

  1. Сделать векторный слой редактируемым ( [image] ).

  2. Нажать на панели инструментов кнопку Трансформация слоя с экрана ( [image] ). Курсор примет вид [image] .

  3. Перемещаясь по карте, с помощью нажатия левой кнопки мыши укажите точку, из которой надо переместить векторный слой. После указания первой точки она отобразится на карте в виде кружка, также ее координаты отобразятся в таблице на панели свойств системы (если она открыта), а курсор примет вид [image] .

  4. Аналогичным образом указать следующую точку (куда надо переместить). Она отобразится в виде окружности.

  5. Точно таким же образом укажите еще две пары точек.

  6. В рабочей области карты щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Аффинное (1 степени). После произведенных действий произойдет соответствующее заданным точкам аффинное преобразование векторного слоя и отображение его на новом месте.

Рисунок 309.

Для проективной трансформации полиномами 2-й степени:

X' = a1X2 + a2XY + a3Y2 + a4X + a5Y + a6

Y' = b1X2 + b2XY + b3Y2 + b4X + b5Y + b6

Метод требует задания не менее 6-и пар точек трансформации.

Для проективной трансформации 2-й степени векторного объекта надо:

  1. Сделать векторный слой редактируемым ( [image] ).

  2. Нажать на панели инструментов кнопку Трансформация слоя с экрана ( [image] ). Курсор примет вид [image] .

  3. Перемещаясь по карте, с помощью нажатия левой кнопки мыши укажите точку, из которой надо переместить векторный слой. После указания первой точки она отобразится на карте в виде кружка, также ее координаты отобразятся в таблице на панели свойств системы (если она открыта), а курсор примет вид [image] .

  4. Аналогичным образом указать следующую точку (куда надо переместить). Она отобразится в виде окружности.

  5. Точно таким же образом укажите еще пять пар точек.

  6. В рабочей области карты щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Проективное (2 степени). После произведенных действий произойдет соответствующее заданным точкам проективное преобразование 2 степени векторного слоя и отображение его на новом месте.

Рисунок 310.


Резиновый лист (локально-аффинная трансформация)

Данный метод трансформации используется для устранения локальных искажений данных с помощью локально-аффинных преобразований. Суть данного метода заключается в нахождении такого преобразования данных в новые координаты, при котором координаты точек трансформации точно преобразуются в указанные новые координаты, а координаты остальных данных интерполируются с учетом изменения опорных точек трансформации. Зоной трансформации данных является область, состоящая из наименьшего выпуклого многоугольника, содержащего опорные точки трансформации (см. рисунок ниже).

Для данного метода требуется задание не менее 4-х пар точек трансформации.

Рисунок 311.

Для локально-аффинной трансформации векторного объекта надо:

  1. Сделать векторный слой редактируемым ( [image] ).

  2. Нажать на панели инструментов кнопку Трансформация слоя с экрана ( [image] ). Курсор примет вид [image] .

  3. Указать зону трансформации. На рисунке, представленном выше, она указана голубым пунктиром. С помощью указанной зоны вы ограничите область локальных искажений. Для указания зоны переместите курсор в первую точку и щелкните левой кнопкой мыши, удерживая при этом клавишу Alt. Оставшиеся точки укажите таким же образом. Если не указывать зону трансформации, то локально-аффинная трансформация применится ко всему слою. При установки пары точек с удерживанием клавиши Alt на экране будет видна только одна точка, это точка переходящая «сама в себя», то есть на самом деле устанавливаются две точки, имеющие одинаковые координаты.

  4. Теперь надо указать точки для локально-аффинной трансформации. Перемещаясь по карте, с помощью нажатия левой кнопки мыши укажите точку, из которой надо переместить векторный слой. После указания первой точки она отобразится на карте в виде кружка, также ее координаты отобразятся в таблице на панели свойств системы (если она открыта), а курсор примет вид [image] .

  5. Аналогичным образом укажите следующую точку (куда надо переместить). Она отобразится в виде окружности.

  6. Точно так же укажите оставшиеся пары точек.

  7. В рабочей области карты щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Резиновый лист. После произведенных действий в ограниченной области произойдет соответствующее заданным точкам локально-аффинное преобразование векторного слоя.


Перепроецирование слоя

  • «Проекция слоя»

В системе ZuluGIS есть возможность перевести слои карты из одной проекции в другую. При перепроецировании слоя происходит физический пересчет хранимых в слое координат объектов из текущей проекции слоя в новую проекцию. Новая проекция назначается слою в качестве текущей. Эта процедура отличается от простого назначения слою новой проекции, когда пересчета координат не происходит.

[Предупреждение] Предупреждение

Тайловые слои и слои WMS перепроецировать нельзя!

Для перепроецирования слоя:

  1. Откройте карту со слоями для перепроецирования или загрузите слои в активное окно карты.

  2. Выберите меню Карта|Операции|Перепроецировать слои.

  3. В диалоге Перепроецирование слоев карты нажмите кнопку Система координат, далее выберите готовую проекцию, задайте свою или импортируйте ее. Затем нажмите кнопку ОК.

  4. Укажите с помощью галочек слои для перепроецирования. Выделить сразу все слои можно, поставив галочку на против опции Все.

  5. Нажмите кнопку ОК.

Рисунок 312. Диалог перепроецирования

В результате выполненных действий слои будут перепроецированы в указанную систему координат.

[Примечание] Примечание

Перепроецирование слоя также возможно при его копировании.


Назначение проекции слою

  • «Проекция слоя»

Если нужно, чтобы слой отображался на карте в определенной проекции, вы можете ее назначить. При этом обновится только информация о существующей системе координат, а сами данные останутся НЕИЗМЕННЫМИ!

[Предупреждение] Предупреждение

Операцию можно использовать только для слоев, не имеющих проекцию (Проекция – План-схема, Датум – Локальный датум). В случае ее ошибочного применения для слоев с проекцией данные теряют географическую привязку и могут отобразиться в любом произвольном места, а в ряде случаев (когда проекция – Поперечная Меркатора (Гаусса-Крюгера)) вообще пропасть с карты.

[Примечание] Примечание

Видеоурок, в котором определяется проекция слоя, можно посмотреть, пройдя по ссылке: https://www.politerm.com/videos/examples/CalcGaussKruger/.

Для назначения проекции:

  1. Откройте в ZuluGIS карту или загрузите в активное окно слой для назначения проекции.

  2. Выберите меню Карта|Слои или нажмите на панели инструментов кнопку [image] .

    Слои, проекция которых отлична от плана-схемы, справа от названия слоя имеют иконку глобуса [image] , не рекомендуется назначать им альтернативную проекцию.

  3. Из появившегося списка слоев карты выделите слой или группу слоев, которым будет назначена проекция. Несколько слоев можно выделить, удерживая клавишу Ctrl или клавишу Shift для выбора нескольких последовательных.

  4. Сделайте щелчок правой кнопкой мыши и в открывшемся контекстном меню выберите пункт Назначить проекцию.

  5. В появившемся диалоге Система координат выберите готовую проекцию, задайте свою или импортируйте ее. Затем нажмите кнопку ОК.

  6. Для завершения назначения проекции и сохранения данных нажмите кнопку ОК.


Построение зон близости

Задача построения зон близости сводится к тому, чтобы найти все точки плоскости, для которых расстояние s до заданного множества объектов является минимальным. Когда все объекты являются точками, данная задача известна как задача построения диаграмм Вороного.

Диаграмма Вороного конечного множества точек S на плоскости представляет такое разбиение плоскости, при котором каждая область этого разбиения образует множество точек, более близких к одному из элементов множества S, чем к любому другому элементу множества.

Операция построения зон близости может использоваться в различных случаях, например, для нахождения зон скорейшего обслуживания (зон близости) из заданных базовых пунктов (почта, больницы, магазины и т.д.).

Для построения зон близости надо:

  1. Выбрать меню Карта|Операции|Построение зон близости.

  2. В появившемся диалоге из списка Исходный слой выбрать слой, по которому будут строиться зоны.

  3. Справа от сроки Слой для записи нажать кнопку [image] . В открывшемся диалоге указать путь до создаваемого слоя с зонами и его имя.

  4. Указать пользовательское название создаваемого слоя с зонами.

  5. При необходимости установить опцию Добавить в карту, созданный слой тогда будет добавлен в текущую карту.

  6. Нажать кнопку ОК.

    В результате будет создан слой с зонами близости.

Диалог построения зон близости

Рисунок 313. Диалог построения зон близости

Рисунок 314. Зоны близости


Размещение фотографий в слое с привязкой к географическим координатам

Для фотографических изображений формата JPEG, в полях параметров EXIF которых указаны географические координаты места выполнения съемки, в системе предусмотрена операция по их размещению в слое карты с одновременным их автоматическим позиционированием на карте в соответствии с заданными координатами.

[Примечание] Примечание

При размещении в слое фотографий, в параметрах которых указана ориентация фотоаппарата во время съемки, выполняется их автоматический поворот.

[Примечание] Примечание

Видеоурок по привязке фотографий к слою можно посмотреть, пройдя по ссылке: https://www.politerm.com/videos/map/photo_geocoding/.

Координаты привязки фотографии должны быть заданы в соответствующих тэгах EXIF графического файла. При размещении фотографии в слое для нее создается символ (кружок), показывающий ее фактическое расположение на карте, а в базе данных слоя для данного символа сохраняются параметры фотографии. Набор сохраняемых данных определяется в процессе процедуры привязки фотографий и может включать следующие поля:

  • ImageName – название фотографии и ссылка на ее файл;

  • Make, Model – производитель и название модели камеры;

  • DateTime – дата и время съемки;

  • GPSVersionID – идентификатор версии тэгов GPS;

  • GPSLatitude, GPSLongitude, GPSAltitude – широта, долгота и высота точки в которой был выполнен снимок;

  • GPSImgDirection – направление, в котором была направлена камера;

  • GPS MapDatum – датум координат снимка.

[Предупреждение] Предупреждение

При размещении фотографий в слое его содержание предварительно очищается, поэтому не следует использовать для размещения фотография слои, содержащие какие-либо необходимые данные.

Привязка фотографий в слое выполняется в диалоговом окне Привязка фотографий.

Диалог привязки фотографий

Рисунок 315. Диалог привязки фотографий

Для выполнения привязки:

  1. Откройте диалог привязки фотографий, выполнив команду Карта|Операции|Привязка фотографий главного меню.

  2. Нажмите кнопку [image] справа от поля Папка с фотографиями и выберите в стандартном диалоге выбора файлов каталог, в котором располагаются требуемые фотографии.

  3. Если в указанной папке имеются еще вложенные папки с фотографиями, которые также будут использованы, то установите опцию Смотреть во вложенных файлах.

  4. Нажмите кнопку [image] справа от поля Слой для записи и выберите в открывшемся диалоге выбора слоя слой, в котором будут сохранены данные привязки фотографий. При выборе уже существующего слоя он будет замещен новым слоем с данными привязки, о чем будет выведено предупреждение.

    [Подсказка] Подсказка

    При создании серверного слоя все размещаемые фотографии будут скопированы на сервер, и к слою будут привязываться уже копии фотографий на сервере.

  5. Для выбора географической проекции слоя нажмите кнопку [image] справа от поля Проекция и «укажите требуемую географическую проекцию» в открывшемся диалоге.

  6. Из списка Источник данных выберите источник для хранения табличной информации. Если нужного источника в списке нет, то добавьте новый.

  7. В поле Символ выберите символ, который будет отображаться в слое для фотографий. Если символ не выбрать, для фотографий будет отображаться кружки. Символы, используемые для фотографий, являются стандартными символьными объектами ZuluGIS и могут быть заменены на любые другие символьные объекты после создания слоя.

  8. В поле со списком Поля таблицы указаны поля EXIF фотографий, данные из которых будут сохраняться в соответствующих поля таблицы фотографий базы данных. Для того чтобы изменить список сохраняемых полей, нажмите кнопку справа от поля и выберите требуемые поля в открывшемся диалоге Поля таблицы. Установите флажки у полей, которые требуется сохранять в таблице, или установите флажок Все, чтобы добавить все поля списка. После задания требуемых полей нажмите кнопку ОК, чтобы сохранить изменения и закрыть диалог, или кнопку Отмена, чтобы закрыть диалог без сохранения изменений.

    Диалог добавления полей

    Рисунок 316. Диалог добавления полей

  9. Если требуется добавлять создаваемый слой в текущую карту, установите флажок Добавить в карту.

  10. Выберите нужную опцию:

    • Создавать слой заново – при выборе данной опции слой с фотографиями будет создан заново;

    • Добавлять только новые фото – если выбрана данная опция, то новые фото будут добавлены к уже существующему слою, при этом изменить структуру таблиц (добавить или убрать поля) будет невозможно.

  11. После задания всех параметров привязки фотографий нажмите кнопку ОК, чтобы выполнить процесс привязки, или кнопку Отмена, чтобы закрыть диалог без выполнения привязки фотографий.

Привязанные фотографии отображаются в слое в виде выбранных символов, привязанных в БД слоя к таблице, с названием, совпадающим с названием слоя. Доступ к записям осуществляется с помощью стандартных механизмов системы ZuluGIS.

Размещение привязанных фотографий на карте

Рисунок 317. Размещение привязанных фотографий на карте

Запись БД с параметрами фотографии

Рисунок 318. Запись БД с параметрами фотографии


Очистка слоя

При очистке слоя происходит удаление из графической базы данных слоя всех объектов. В результате данной операции файлы слоя с диска не удаляются, но становятся пустыми, структура слоя при этом сохраняется.

[Предупреждение] Предупреждение

Производя операцию очистки слоя, необходимо четко понимать, что сделать «откат» будет невозможно. Удаленные данные будут потеряны безвозвратно.

[Примечание] Примечание

Очистка слоя доступна для векторных слоев.

Для очистки слоя:

  1. Выберите пункт главного меню Слой|Очистить. При этом на экране появится диалог выбора слоя.

  2. Левой кнопкой мыши укажите слой, который надо очистить, и нажмите кнопку Выбрать. Или сделайте двойной щелчок левой кнопкой мыши по очищаемому слою.

  3. В окне очистки нажмите кнопку Да, после чего произойдет очистка (обнуление) графической базы данных слоя.

    Окно очистки слоя

    Рисунок 319. Окно очистки слоя

[Подсказка] Подсказка

Если на экране появится окно предупреждения «В данный момент этот слой уже кто-то редактирует», тогда нажмите кнопку ОК и завершите редактирование слоя.

[Подсказка] Подсказка

Очистка слоя соответствует методу Layer.Empty.


Упаковка слоя (архивация)

При упаковке слоя создается его архив в виде единого файла с расширением ZPKG. Архив может включать в себя как всю информацию слоя( структуру слоя, графическую и семантическую информацию, варианты надписей, шаблоны и варианты тематических раскрасок, ассоциированные со слоем пользовательские данные и т.д.), так и только выделенные объекты, структуру слоя или графику.

Такая архивация данных удобна при передаче информации сторонним лицам, в результате создается архив с СУБД независимыми данными. В дальнейшем при извлечении слоя для хранения таблиц возможно будет выбрать нужный источник.

[Примечание] Примечание

Видеоурок по упаковке слоя можно посмотреть, пройдя по одной из ссылок: https://youtu.be/nwKNZIxOzWo или https://www.politerm.com/videos/layerstruct/upakovka-sloya/.

[Примечание] Примечание

Если требуется уменьшить размер архива, то возможна упаковка слоя без данных полей типа BLOB (загруженные в базу фото, документы и т.д.).

[Примечание] Примечание

Для упаковки только выделенных объектов необходимо их заранее выделить.

Для упаковки слоя:

  1. Выберите пункт главного меню Слой|Упаковать.

  2. В том случае, если у вас не открыта ни одна карта со слоями, то в стандартном окне выбора щелчком левой кнопки мыши укажите слой для упаковки. Нажмите кнопку Открыть.

    Если же карта со слоями открыта, то слой для упаковки выберите из открывающегося списка Исходный слой или нажмите кнопку Обзор и укажите его на диске. Нажмите кнопку Открыть.

  3. В строке файл архива укажите имя для архива и путь до него, воспользуйтесь кнопкой Обзор.

  4. По умолчанию стоит опция Упаковать все, это означает, что слой будет упакован со всеми данными. Дополнительно можно настроить параметры упаковки:

    • Только структуру – будет упакована только структура слоя;

    • Только графику – будет упакована только графическая информация без баз данных;

    • Только выделенные объекты – будут упакованы только заранее выделенные объекты. Если в слое нет выделенных объектов, то данный пункт будет не активен;

    • Без BLOB – слой будет упакован без данных полей типа BLOB, что может существенно уменьшить объем архива.

    Диалоговое окно упаковки слоя

    Рисунок 320. Диалоговое окно упаковки слоя

  5. Нажмите кнопку ОК.

[Примечание] Примечание

В случае если в упаковываемом локальном слое имеются проблемы с данными, например, отсутствуют ссылки на таблицы в базе, то появится диалог с выбором Прервать/Повтор/Пропустить операцию. При выборе последнего пункта ошибка будет проигнорирована, и слой упакуется в текущем состоянии, о чем появится соответствующее сообщение.

Если в серверном слое присутствуют проблемы с данными, то будет выдано сообщение о последней ошибке, остальные ошибки отразятся в окне Сообщений. После чего появится выбор, сохранить ли архив на клиентской машине или нет. Если нажата кнопка Да, то архив сохранится в текущем состоянии, о чем появится сообщение. В противном случае слой не упаковывается.


Извлечение упакованного слоя

В результате извлечения из ранее созданного упаковкой архива будет создан слой со всей информацией, содержащейся в архиве. При извлечении можно указать источник данных для хранения табличной информации, отличный от исходного.

[Примечание] Примечание

Видеоурок по извлечению слоя можно посмотреть, пройдя по одной из ссылок: https://youtu.be/nwKNZIxOzWo или https://www.politerm.com/videos/layerstruct/upakovka-sloya/.

Для распаковки слоя:

  1. Выберите пункт главного меню Слой|Извлечь.

  2. В стандартном окне выбора щелчком левой кнопки мыши укажите файл архива для распаковки. Нажмите кнопку Открыть.

    [Примечание] Примечание

    Если будет указан не архив слоя, а архив карты, то есть в нем содержится несколько слоев, то появится диалог для выбора слоя. Укажите слой для извлечения и нажмите кнопку Далее.

  3. В диалоговом окне Сохранить файл задайте папку для распаковки и имя файла, после чего нажмите кнопку Сохранить.

  4. Если для распаковываемого слоя нужен новый, отличный от исходного источник данных для хранения табличной информации, то выберите его из списка Источник для таблиц.

  5. При необходимости установите опцию Добавить в карту, распакованный слой тогда будет добавлен в текущую карту.

    Диалоговое окно распаковки слоя

    Рисунок 321. Диалоговое окно распаковки слоя

  6. Нажмите кнопку ОК.


Уничтожение слоя

С помощью данной операции можно уничтожить все файлы, относящиеся к слою, или только графическую информацию.

[Предупреждение] Предупреждение

Производя операцию уничтожения слоя, необходимо четко понимать, что сделать «откат» будет невозможно. Уничтоженные данные будут потеряны безвозвратно.

Для уничтожения слоя:

  1. Выберите пункт главного меню Слой|Уничтожить.

  2. В стандартном окне выбора щелчком левой кнопки мыши укажите слой, который необходимо уничтожить, и нажмите кнопку Выбрать.

  3. В разделе Параметры укажите нужную опцию:

    • Удалять все – будет уничтожена вся информация, относящаяся к слою;

    • Удалять только графику и файлы структуры – после уничтожения останутся только таблицы;

    • Удалять файлы слоя и семантические данные – не будут удаляться локальные таблицы;

    Диалоговое окно удаления слоя

    Рисунок 322. Диалоговое окно удаления слоя

  4. Нажмите кнопку ОК.

В результате произойдет физическое уничтожение слоя с диска компьютера, и, если слой был загружен в одно или несколько окон-карт, произойдет его автоматическое удаление из этих окон.

[Подсказка] Подсказка

Удаление слоя соответствует методу Layer.Delete.


Тест слоя

Тестирования слоя проводит анализ целостности слоев ZuluGIS (несуществующие типы, режимы, поврежденные слои). Данная операция позволяет проверить массово файлы .b00 и .zl на наличие ошибок.

[Предупреждение] Предупреждение

Не следует запускать во время работы пользователей.

Для запуск данной операции, например, для теста всех файлов на диске D:

  1. Выберите пункт главного меню Слой|Тест.

  2. Нажмите кнопку Обзор и в стандартном окне выберите папку (диск) для проверки.

  3. Укажите расширения файлов для поиска: .b00 или .zl.

    Диалоговое окно теста слоёв

    Рисунок 323. Диалоговое окно теста слоёв

  4. Нажмите кнопку Старт. В окне Сообщения будут отображаться результаты проверки:

    Результаты теста данных

    Рисунок 324. Результаты теста данных


Синхронизация слоя

Если у вас имеется слой, который содержит индивидуальные настройки структуры, то вы можете синхронизировать этот слой-эталон с одним или несколькими слоями. После синхронизации структура слоев для синхронизации будет приведена в соответствие с структурой слоя-эталона.

[Предупреждение] Предупреждение

Синхронизация не имеет отката! Если в результате синхронизации итоговый результат вас не устроит, то вы не сможете автоматически вернуть синхронизируемый слой в исходное состояние! Поэтому перед запуском операции ОБЯЗАТЕЛЬНО скопируйте слои, которые будут синхронизироваться! Синхронизируйте копию слоя.

Могут быть синхронизированы:

  • символы;

  • стили линий;

  • стили заливок;

  • базы данных: таблицы, справочники, запросы;

  • типы и режимы.

Для синхронизации:

  1. Выберите пункт главного меню Слой|Операции|Синхронизация.

  2. Нажмите кнопку Выбрать и в стандартном окне выбора укажите слой-эталон, с которым будет производиться сравнение.

  3. Нажмите кнопку Добавить и выберите слой, в который будут внесены изменения. Слой отразиться в списке Слои для синхронизации. Повторите данный пункт столько раз, сколько требуется. Ошибочно добавленный слой можно выделить в списке и нажать кнопку Убрать.

  4. Нажмите кнопку Далее.

  5. Программа произведет сравнение структур слоев. Напротив разделов, в которых нашлись различия будет +. Если отличий нет, то + отсутствует.

    По умолчанию все найденные расхождения будут внесены из слоя-эталона в слой для синхронизации. Указывается так же операция с объектом:

    • создать - объект будет создан заново.

    • изменить - в объект будут внесены изменения.

    Вы можете указать, если в какие то разделы не надо вносить изменения. Слева выделите один из разделов. Справа отразятся найденные отличия в данном разделе и напротив каждого объекта будет установлена галочка, если ее снять, то синхронизация данного объекта произведена не будет.

    Для более подробной информации в каждом разделе нажмите +. При выделении объекта в списке справа отразится информация по выполняемой операции. При снятии галочки синхронизации объекта не будет.

    Рисунок 325. Синхронизация слоев

    Для таблиц базы данных доступен выбор, будет таблица изменена или создана заново. Если такой таблицы нет в слое, то вы можете изменить название результата. Так же возможно менять названия добавляемых полей в таблицу.

  6. После проверки всех параметров нажмите кнопку Далее.

  7. Для запуска синхронизации нажмите кнопку Старт. Мастер синхронизации отобразит список произведенных изменений в слоях для синхронизации.


Ввод и редактирование объектов слоя

  • «Активизация слоя»

  • «Включение редактирования слоя»

  • «Дополнительные опции при вводе новых объектов»

  • «Ввод новых объектов»

  • «Редактирование объектов»

  • «Редактирование группы объектов»

  • «Редактирование элементов объекта»

  • «Оверлейные операции»

Данный раздел посвящен созданию новых объектов и редактированию уже существующих. Прежде чем приступить к работе, важно понять разницу между активным и редактируемым слоями. В процессе работы следите за тем, в каком слое вы работаете, чтобы не допустить ошибок.

Также стоит обратить внимание на то, как объекты делятся на типовые и примитивы. Процесс их создания и редактирования имеет существенные различия, поэтому важно их различать.


Активизация слоя

  • Активизация слоя

  • Активизация объекта

  • Как узнать в каком слое находится объект

Активизация слоя

Активный слой – это слой, к которому в данный момент осуществляются запросы с карты, выделение группы объектов, привязка к узлам объектов слоя в процессе ввода и редактирования этого или других слоев.

[Примечание] Примечание

Назначить сочетание клавиш для быстрой активизации слоя на карте возможно в диалоге Загруженные слои.

Сделать слой активным можно разными способами:

  1. Выбрать его в списке загруженных слоев панели Карта:

    Активация слоя через панель Карта

    Рисунок 326. Активация слоя через панель Карта

  2. Выбрать пункт главного меню Карта|Активный слой, после чего в списке загруженных в карту слоев выбрать левой кнопкой мыши выбрать слой, который необходимо сделать активным.

  3. Сделать двойной щелчок левой кнопкой мыши на названии слоя в панели Рабочее место. После чего название выделится жирным текстом.

  4. Щелкнуть правой кнопкой мыши на названии слоя в панели Рабочее место и выбрать в контекстном меню пункт Активный.

    Панель Рабочее место

    Рисунок 327. Панель Рабочее место

  5. Автоматически переключить активный слой можно, если при нажатых клавишах Ctrl + Shift в режиме активизации объекта ( [image] ) щелкнуть левой кнопкой мыши в любой объект любого слоя. В результате выбранный объект активизируется (мигает), а слой, которому объект принадлежит, становится активным.

Активизация объекта

[Примечание] Примечание

При наличии слоя рельефа по активному (мигающему) линейному объекту возможно построение профиля.

Под активизацией объекта подразумевается перевод одного из объектов слоя в активный режим, отображаемый на карте миганием. Для того, чтобы активизировать («замигать») объект активного слоя карты:

  1. Включите режим Выделить - кнопка [image] на панели навигации.

  2. Подведите курсор мыши к объекту (объект должен находиться в активном слое) и щелкните левой клавишей мыши. Если объект находится не в активном слое, то при щелчке на клавиатуре надо удерживать клавиши Ctrl + Shift, тогда объект активируется (замигает) и слой, в котором он находится станет активным.

[Примечание] Примечание

Отменить активизацию (мигание) объекта можно или сделав щелчок левой кнопкой мыши на карту рядом с объектом или нажав на клавиатуре сочетание клавиш Ctrl+B.

После активации объекта в строке состояния внизу экрана отобразится его значение ключа (ID). Если в данный момент открыта панель Объект (Окно|Объект…), то в ней отобразятся общие параметры активизированного объекта в зависимости от его графического и структурного типа.

Пример окна Объект для типового символа

Рисунок 328. Пример окна Объект для типового символа

Также объект возможно активировать в режиме получения информации ( [image] ), тогда помимо активизации объекта выполнится запрос к семантической базе данных.

[Примечание] Примечание

Если в режиме активизации объекта ( [image] ) удерживать на клавиатуре клавишу Alt, то при работе с инженерной сетью, даже при очень маленьком масштабе всегда будут активизироваться участки.

[Подсказка] Подсказка

Мигающий объект активного слоя соответствует свойству MapDoc.Layers.Active.CurrentID.

[Подсказка] Подсказка

Событие, возникающие при указании объекта с карты: MapCtrl.ObjectSelect.

Как узнать в каком слое находится объект

Обычно в процессе работы известно, в каком слое находятся объекты. Однако иногда, например, после импорта данных, необходимо определить слой объекта.

Для этого:

  1. Включите режим Выделить - кнопка [image] .

  2. Нажмите и удерживайте на клавиатуре клавиши Ctrl + Shift.

  3. Сделайте щелчок левой кнопкой мыши по объекту. Объект активируется (замигает) и слой, в котором он находится станет активным.

    Как узнать в каком слое находится объект

    Рисунок 329. Как узнать в каком слое находится объект


Включение редактирования слоя

Прежде чем добавлять новые объекты в слой или редактировать уже существующие, необходимо активировать режим редактирования слоя. В режиме редактирования все внесённые изменения будут автоматически сохранены.

После включения режима редактирования становятся доступны панели инструментов редактор и стиль.

[Примечание] Примечание

В режиме редактирования слоя для произведения тех или иных действий возможно пользоваться «горячими» клавишами.

Редактирование слоя можно включить несколькими способами:

  1. Выбрать пункт главного меню Карта|Редактор слоя или нажать на панели инструментов кнопку [image] . Если карта содержит только один слой, то этот слой сразу станет редактируемым. Если же в карте несколько слоев, то на экране появится список слоев карты, в котором нужно левой кнопкой мыши указать слой, который надо редактировать и нажать кнопку ОК.

  2. Нажать на панели Карта в списке слоев напротив нужного слоя кнопку [image] .

    Список слоев текущей карты

    Рисунок 330. Список слоев текущей карты

  3. В панели Рабочее место сделать щелчок правой кнопкой мыши на названии слоя и выбрать в контекстном меню пункт Редактировать.

    Панель Рабочее место

    Рисунок 331. Панель Рабочее место

  4. В том случае, если нужный слой уже активный нажать на клавиатуре сочетание клавиш Ctrl+E.

  5. Нажать кнопку [image] в списке слоев текущей карты (вызывается кнопкой [image] ).

[Примечание] Примечание

Отключить редактирование слоя возможно проделав повторно те же действия, которые необходимы для включении редактирования.

[Предупреждение] Предупреждение

После отключения режима редактирования отмена действий, произведенных в данном режиме будет невозможна.

[Подсказка] Подсказка

Редактируемый слой задается свойством MapDoc.Layers.EditLayer.


Дополнительные опции при вводе новых объектов

  • «Сетка редактора»

  • «Сетка редактора»

  • «Ортогональный ввод»

  • «Отображение узлов объектов и привязка к ним»

  • «Пошаговая отмена введенных точек»

Эти функции значительно упрощают процесс ввода и редактирования объектов. В любой момент работы вы можете включить или выключить их по своему усмотрению.


Сетка редактора

Для более комфортного ввода новых объектов можно включить сетку редактора. Сетка выводится в виде точек заданного цвета в узлах сетки с заданным шагом по обеим осям. Разметка окна сеткой позволяет лучше ориентироваться при редактировании объектов, а также привязывать вводимые координаты объектов к узлам сетки.

Включение сетки редактора

Для отображения сетки:

  • нажмите кнопку [image] на панели инструментов

    или

  • установите флажок Отображать сетку редактора на вкладке Сетка диалога настройки карты (Карта|Настройка).

Настройка сетки редактора

Шаг сетки и опорная точка меняется во вкладке Сетка диалога настройки карты в разделе Сетка редактора.

[Подсказка] Подсказка

Отображение сетки редактора можно установить с помощью свойства MapCtrl.Map.EditGrid.Visible.

Привязка к сетке

Для включения привязки сетки:

  • нажмите кнопку [image] на панели инструментов, кнопка будет доступна только после включения отображения сетки [image] и редактирования слоя

    или

  • установите флажок Привязка к сетке на вкладке Сетка диалога настройки карты (Карта|Настройка).

[Подсказка] Подсказка

Привязку к сетке редактора можно установить с помощью свойства MapCtrl.Map.EditGrid.SnapTo.


Ортогональный ввод

Чтобы включить ортогональный ввод, нажмите кнопку [image] на панели инструментов или удерживайте клавишу Shift при вводе объекта. В этом режиме каждая последующая точка ломаной, начиная со второй, будет вводиться так, чтобы последний отрезок ломаной образовывал с предыдущим угол в 90, 180 или 270 градусов.


Отображение узлов объектов и привязка к ним

Для отображения всех узлов активного слоя нажмите кнопку [image] .

Если при вводе линии курсор подвести к одному из узлов (точек перелома) объекта активного слоя на близкое расстояние, то при фиксации точки с одновременно нажатой клавишей Ctrl, точка «притянется» к указанному узлу и точно получит координаты этого узла.

[Примечание] Примечание

По по умолчанию радиус захвата узла 10 пикселей, но его можно изменить.

Если надо «притянуться» к узлу объекта, находящегося в неактивном слое, тогда при фиксации точки надо удерживать одновременно клавиши Ctrl и Shift.

[Примечание] Примечание

Привязка точки к узлу объекта активного слоя имеет более высокий приоритет, чем привязка к сетке и ортогональный ввод.


Пошаговая отмена введенных точек

Пошаговая отмена доступна для объектов, которые создаются последовательно, с фиксацией точек, например, для ломаных или многоугольников. Чтобы отменить последнюю добавленную точку, вы можете воспользоваться клавишей Esc или контекстным меню, которое вызывается правой кнопкой мыши в любом месте карты. В этом меню есть опция Отменить последнюю точку, и при каждом нажатии будет отменяться последняя добавленная точка. Также в контекстном меню есть возможность отменить нанесение всей ломаной, выбрав опцию Отменить всю линию.


Ввод новых объектов

Вводить можно как простые (примитивы), так и типовые (классифицированные) объекты. Типовые объекты перед вводом должны быть предварительно созданы в структуре слоя.

[Примечание] Примечание

Ввод объектов инженерных сетей описан отдельно в разделе: «Ввод объектов сети».

Далее будут описаны следующие операции:

  • «Ввод полилинии (ломаной)»;

  • «Ввод площадного объекта (полигона)»;

  • «Ввод символа»;

  • «Ввод текста».


Ввод полилинии (ломаной)

Данный объект представляет собой цепочку точек, соединенных сегментами. Подробней о ломаных можно узнать в разделе «Линейные объекты (полилинии, поли-полилинии)».

Ломаная может иметь свободные концы или быть замкнутой. Она может быть представлена в виде линии, прямоугольника, круга или сегмента.

Варианты ломаной линии

Рисунок 332. Варианты ломаной линии

В зависимости от той фуры, которую надо получить из полилинии ввод осуществляется по разному.

Если ввести надо линию произвольной формы- то ввод осуществляется последовательным добавлением цепочек точек, координаты каждой из которых задаются различными способами. Если полилиния прямоугольник, круг или сегмент, то ввод осуществляется в соответствии с выбранной фигурой.

При последовательном вводе точек один из вариантов ввода — с помощью мыши на экране, произвольно или «цепляясь» за имеющиеся точки активного слоя. Такой способ можно использовать, например, при векторизации растра.

Второй вариант последовательного ввода точек — использование геометрических построений. Он позволяет добиться более точного расположения линий. Место расположения очередной точки выбирается из контекстного меню, пункты которого меняются в зависимости от этапа ввода. Доступны различные варианты: ввод по координатам, вдоль линии, параллельно линии, под определенным углом и другие.

Также можно ввести ломаную по точкам строго по координатам, которые вводятся с клавиатуры в окно Свойства.

Кроме перечисленных способов, существует возможность трассировки или автозамыкания линии.

Вы можете комбинировать любой вариант нанесения полилинии в зависимости от поставленных задач.

Если линии уже ранее введена, то можно продолжить ее ввод.

Линии так же как и все остальные объекты слоя делятся на простые (примитивы) и типовые. Процесс их ввода различается.

Перед тем как вводить примитивы, необходимо задать стиль для создаваемых объектов. В отличие от этого, стиль для типовых объектов задаётся только один раз в структуре слоя.

  • «Ввод простой полилинии (ломаной) с экрана»

  • «Ввод типовой полилинии (ломаной) с экрана»

  • «Ввод простой полилинии (ломаной) с экрана с использованием геометрических построений»

  • «Ввод типовой полилинии (ломаной) с экрана с использованием геометрических построений»

  • «Ввод простой полилинии (ломаной) с клавиатуры»

  • «Ввод типовой полилинии (ломаной) с клавиатуры»

  • «Ввод полилинии (ломаной) по дуге»

  • «Продолжение введенной ломаной»

  • «Трассировка ломаной или полигона»

  • «Автозамыкание ломаной или полигона»


Ввод простой полилинии (ломаной) с экрана

[Примечание] Примечание

Ввод полилинии (ломаной) может производиться как по проекции так и по сфероиду в зависимости от выбранной опции.

Для начала ввода простого линейного объекта с экрана:

  1. Сделайте слой редактируемым.

  2. В том случае, если ранее вводились типовые объекты, нажмите на панели редактирования кнопку [image] и выберите в меню пункт Примитивы. В противном случае и так же если редактируемый слой не содержит типовых объектов, то данный пункт пропустите.

  3. Настройте стиль вводимого линейного объекта.

  4. На панели редактирования выберите режим ввода и нанесите объект:

    • Для ввода ломаной произвольной формы нажмите кнопку [image] . Подведите курсор к началу ломаной, зафиксируйте первую точку нажатием левой кнопки мыши. Затем последовательно перемещайте курсор мыши к очередной точке на карте и фиксируйте эту точку нажатием левой кнопки мыши. Для завершение ввода ломаной сделайте или двойной щелчок левой кнопкой мыши или нажмите клавишу Enter или выберите в контекстном меню пункт Закончить объект или нажмите кнопку [image] на панели инструментов.

      Ввод ломаной произвольной формы

      Рисунок 333. Ввод ломаной произвольной формы

      [Примечание] Примечание

      Пошаговую отмену введенных точек можно сделать клавишей Esc.

      Ввод полилинии произвольной формы можно так же осуществлять с использованием геометрических построений, с клавиатуры, с автозамыканием и с использованием трассировки.

    • Для ввода полилинии в виде прямоугольника нажмите кнопку [image] . Подведите курсор к одному из будущих углов объекта. Щелкните левой клавишей мыши для фиксации первой вершины, точно так же зафиксируйте вторую вершину прямоугольника, после чего растяните «резиновую» рамку прямоугольника до нужных размеров, для завершения процесса рисования прямоугольника сделайте щелчок левой кнопкой мыши.

      Ввод ломаной в виде прямоугольника

      Рисунок 334. Ввод ломаной в виде прямоугольника

    • Для ввода полилинии в виде окружности нажмите кнопку [image] . Щелкните мышью в центр создаваемого объекта, растяните окружность до нужного размера. При растяжении справа снизу в строке состояния будет отображаться радиус круга, например - [image] . После того как контур будет растянут до нужного радиуса сделайте щелчок левой кнопкой мыши.

      Ввод ломаной в виде окружности

      Рисунок 335. Ввод ломаной в виде окружности

      Для ввода полилинии в виде овала щелкните мышью в центр создаваемого контура, нажмите клавишу Shift, растяните овал до нужного размера. Для поворота фигуры нажмите клавишу Ctrl, с помощью курсора задайте нужный угол и не отпуская клавишу сделайте щелчок левой кнопкой мыши. При вводе объекта справа снизу в строке состояния будут отображаться его размеры и угол поворота, например [image] .

      Ввод ломаной в виде овала

      Рисунок 336. Ввод ломаной в виде овала

    • Для ввода полилинии в виде дуги нажмите кнопку [image] . Щелкните левой клавишей мыши для фиксации первой точки, нажмите левую кнопку мыши во второй точке сегмента и удерживая ее нажатой растяните «резиновую» рамку до нужных размеров, для завершения процесса рисования сегмента отпустите левую клавишу мыши.

      Ввод ломаной в виде дуги

      Рисунок 337. Ввод ломаной в виде дуги

[Примечание] Примечание

Видеоурок по вводу полилинии можно посмотреть пройдя по ссылке: https://www.politerm.com/videos/layeredit/EditInputPolyline/.


Ввод типовой полилинии (ломаной) с экрана

[Примечание] Примечание

Ввод полилинии (ломаной) может производиться как по проекции так и по сфероиду в зависимости от выбранной опции.

[Примечание] Примечание

Перед вводом типовые объекты обязательно должны быть созданы в структуре слоя!

Для начала ввода типового линейного объекта:

  1. Сделайте слой редактируемым.

  2. Нажмите на панели редактирования кнопку [image] и в открывшемся меню типовых объектов выберите нужный режим нужного линейного графического типа.

  3. Так как далее ввод типовой полилинии аналогичен вводу простой линии то повторите пункт 4 раздела «Ввод простой полилинии (ломаной) с экрана». Отличия относятся только к линейным объектам, являющимся участками, подробней о вводе сети можно узнать в теме «Ввод объектов сети».

[Важно] Важно

Если линейный типовой объект является участком, то ломаная обязательно должна начинаться и заканчиваться типовым символьным объектом.

[Примечание] Примечание

В процессе ввода ломаной можно накладывать дополнительные условия.


Ввод простой полилинии (ломаной) с экрана с использованием геометрических построений

[Примечание] Примечание

Ввод объектов с использованием геометрических построений может производиться как по проекции так и по сфероиду в зависимости от выбранной опции. По умолчанию ввод производится по сфероиду.

Система позволяет вводить с экрана с использованием геометрических построений объекты, которые наносятся последовательным добавлением цепочек точек. Для их фиксации в слое используется контекстное меню. Данный способ позволяет задавать точку по двум расстояниям от заданных точек, пересечению двух направлений или на расстоянии от заданной точки, пересеченной с направлением и др. Наноситься могут как типовые так и простые полилинии.

Для нанесения простой полилинии данным способом:

  1. Сделайте слой редактируемым.

  2. В том случае, если ранее вводились типовые объекты, нажмите на панели редактирования кнопку [image] и выберите в меню пункт Примитивы. В противном случае, и так же если редактируемый слой не содержит типовых объектов, то данный пункт выполнять не надо.

  3. Настройте стиль вводимого линейного объекта.

  4. На панели инструментов нажмите кнопку [image] .

  5. Далее для ввода используйте контекстное меню, вызываемое нажатием правой клавишей мыши в области активной карты:

    Рисунок 338. Контекстное меню

[Предупреждение] Предупреждение

При работе с контекстным меню есть определенные правила:

  • При работе с линией (параллельно, на расстоянии, перпендикулярно и прочее). В том случае, когда линия находится в активном слое, то она указывается щелчком левой кнопки мыши. Если же она находится в неактивном слое, то при указании (щелчке левой кнопки мыши) необходимо удерживать клавишу Ctrl.

  • При работе с точкой (на расстоянии от заданной точки, направление через точку, и другие). Точка может быть как произвольно указана на карте, так и «притянута» к одному из узлов или точек перелома объекта карты или вводимой линии. Точка указывается щелчком левой кнопки мыши. Если необходимо привязаться к одному из узлов или точек перелома объекта карты, находящемуся не в активном слое, тогда при указании точки необходимо удерживать клавиши Ctrl+Shift, если в активном то придерживая Ctrl.

В зависимости от этапа ввода линии содержание контекстного меню будет меняться.

  • Отменить последнюю точку ESC - отменяет последнюю введенную точку, аналогично нажатию клавиши Esc.

  • Задать координаты - вызывает окно введения координат для следующей точки. Окно появляется с координатами 0;0, сотрите их, и введите с клавиатуры новые координаты:

    Диалоговое окно введения координат точки

    Рисунок 339. Диалоговое окно введения координат точки

    После нажатия кнопки ОК произойдет перестроение экрана вместо с указанными координатами, и там будет закреплена новая точка ломаной. Кнопка Отмена закрывает окно введения координат, введение ломаной при этом не заканчивается.

  • На расстоянии... - вызывает окно задания расстояния. Расстояние задается в метрах, и отсчитывается оно от предыдущей зафиксированной точки ломаной.

    Диалоговое окно задания расстояния

    Рисунок 340. Диалоговое окно задания расстояния

    После нажатия кнопки ОК вокруг последней зафиксированной точки появится круг, с «бегающей» на нем точкой, точку можно зафиксировать в нужном месте щелчком левой кнопки мыши.

    Если до фиксации «бегающей» точки щелкнуть правой кнопкой мыши, то появится новое контекстное меню.

    Дополнительное контекстное меню

    Рисунок 341. Дополнительное контекстное меню

    • Отменить - отменяет введение точки.

    • Вдоль линии - после выбора данной опции курсор примет вид стрелки с двумя параллельными полосами и левой кнопкой мыши надо указать вдоль какой линии будет проходить точка.

    • Направление через точку - позволяет указать через какую точку будет проходить следующая точка вашей ломаной.

    • На расстоянии от второй точки - позволяет задать вторую точку для прохождения вашей ломаной. Для второй точки так же можно указать координаты с помощью контекстного меню, которое вызывается правой копкой мыши.

  • В направлении - позволяет указать направление, которое будет задано через предыдущую зафиксированную точку ломаной. После выбора данной опции появляется направляющая линия, проходящая через конечную зафиксированную точку ломаной, при щелчке левой кнопки мыши линия фиксируется, и на ней появляется «бегающая» точка, вторым щелчком левой кнопки мыши очередная точка вашей ломаной будет зафиксирована. Если сразу после выбора данного пункта (до первого щелчка левой кнопки мыши) произвести щелчок правой кнопкой мыши, то появится контекстное меню:

    • Задать угол - вызывает диалоговое окно задания угла для направляющей линии.

    • Параллельно - дает возможность указать параллельно какому отрезку объекта карты или вводимой линии будет направлена линия.

      Рисунок 342. Контекстное меню

    • Перпендикулярно - позволяет указать, перпендикулярно какому отрезку объекта карты или вводимой линии направлена линия.

    • Под углом к - при выборе данной опции сначала надо левой кнопкой мыши указать под углом к какому отрезку объекта будет расположена направляющая линия, а затем в появившемся окне задать угол.

      Если же щелкнуть правой кнопкой мыши после фиксации линии, то появится другое контекстное меню:

      Рисунок 343. Контекстное меню

      • Второе направление вдоль линии - позволяет щелчком левой кнопки мыши задать вдоль какого отрезка объекта карты или вводимой линии будет расположена вторая направляющая линия, тогда точка будет находиться на пересечении этих двух линий.

      • Второе направление через точку - дает возможность указать точку, через которую будет проходить вторая направляющая линия.

      • Длиной с - дает возможность ввести следующий отрезок ломаной равным указанному отрезку объекта на карте или вводимой линии.

      • На расстоянии от точки - после выбора данной опции левой кнопкой мыши укажите точку, на расстоянии от которой надо закрепить следующую точку вводимой ломаной. После указания точки в появившемся окошке введите расстояние.

      • На расстоянии от линии - после выбора данной опции левой кнопкой мыши укажите линию, на расстоянии от которой надо закрепить следующую точку вводимой ломаной. После указания точки в появившемся окошке введите расстояние.

  • Под углом - при выборе данной опции появляется диалоговое окно, в котором надо задать угол, который будет отсчитываться от предыдущего введенного отрезка ломаной. После введения угла появляется фиксированная направляющая линия. Щелчком правой кнопкой мыши можно вызвать контекстное меню, изображенное на рисунке выше.

  • Перпендикулярно - после выбора данной опции укажите левой кнопкой мыши, перпендикулярно какому отрезку объекта карты или вводимой линии надо закрепить точку. Щелчком правой кнопкой мыши можно вызвать контекстное меню, изображенное на рисунке выше.

  • Параллельно - позволяет указать левой кнопкой мыши, параллельно какому отрезку объекта карты или вводимой линии надо закрепить точку. Щелчком правой кнопкой мыши можно вызвать контекстное меню, изображенное на Рисунок 343, «Контекстное меню».

  • Вдоль линии - после выбора данной опции укажите левой кнопкой мыши, вдоль какого отрезка объекта карты или вводимой линии надо закрепить точку. Щелчком правой кнопкой мыши можно вызвать контекстное меню, изображенное на рисунке Рисунок 343, «Контекстное меню».

  • Задать направление - дает возможность задать левой кнопкой мыши направление, в котором надо закрепить точку.

  • На расстоянии от заданной точки - после выбора данной опции сначала левой кнопкой мыши укажите точку, от которой далее в появившемся диалоговом окне задайте расстояние.

  • Отменить всю линию - отменяет всю вводимую линию.

  • Закончить объект - заканчивает вводимый объект.

[Примечание] Примечание

Видеоурок по вводу полилинии с использованием геометрических построений можно посмотреть пройдя по ссылке: https://www.politerm.com/videos/layeredit/EditToolPolyline/.


Ввод типовой полилинии (ломаной) с экрана с использованием геометрических построений

[Примечание] Примечание

Ввод объектов с использованием геометрических построений может производиться как по проекции так и по сфероиду в зависимости от выбранной опции. По умолчанию ввод производится по сфероиду.

[Примечание] Примечание

Для того, чтобы вводить типовые линейные объекты необходимо предварительно их создать в структуре слоя!

Для начала ввода типового линейного объекта с помощью геометрических построений:

  1. Сделайте слой редактируемым.

  2. Нажмите кнопку [image] и в открывшемся меню типовых объектов выберите нужный режим нужного линейного типа.

  3. Так как ввод типового объекта полностью аналогичен описанному ранее вводу простой ломаной, то повторите пункты начиная с 5.

    Отличия относятся только к линейным объектам, являющимся участками.


Ввод простой полилинии (ломаной) с клавиатуры

[Примечание] Примечание

Ввод ломаной может производиться как по проекции так и по сфероиду в зависимости от выбранной опции.

Ввод полилинии с клавиатуры производится с использованием панели Свойства, для открытия панели выберите меню Окно|Свойства или нажмите на панели инструментов кнопку Свойства [image] .

Если ломаную уже начали вводить с помощью мыши, то процесс ввода отображается в таблице на этой панели.

Каждая строка таблицы содержит информацию об одной из точек вводимой ломаной.

В первой колонке таблицы записывается порядковый номер точки. В следующих двух колонках - координаты точки, они могут отображаться или в метрах (X, Y) или в градусах (Широта, Долгота). Параметры отображения указываются в настройках карты.

Колонка Длина содержит длину отрезка ломаной из предыдущей точки к текущей. Последняя колонка Азимут/Угол(в зависимости от настройки) содержит значение азимута/угла, измеряемого из точки предшествующей текущей.

Способы ввода ломаной

Рисунок 344. Способы ввода ломаной

Для ввода простой ломаной с клавиатуры:

  1. Сделайте слой редактируемым.

  2. В том случае, если ранее вводились типовые объекты, нажмите на панели редактирования кнопку [image] и выберите в меню пункт Примитивы. В противном случае и так же если редактируемый слой не содержит типовых объектов, то данный пункт выполнять не надо.

  3. Настройте стиль вводимого линейного объекта.

  4. На панели инструментов нажмите кнопку [image] .

  5. Далее:

    Ввод очередной точки с клавиатуры:

    Если встать в таблице на последнюю запись и нажать клавишу «стрелка вниз», то в таблице добавится новая пустая строка. Если ввести с клавиатуры координаты новой точки и снова нажать клавишу «стрелка вниз», то новая точка с введенными координатами добавится к вводимой ломаной и отобразится на экране. Значения длины и азимута заполнятся в таблице автоматически. Повторяя эту операцию можно всю линию ввести вручную с клавиатуры.

    Завершение ввода всей ломаной

    Завершить ввод можно кнопкой [image] на панели редактирования или с помощью пункта Закончить объект контекстного меню, вызываемого правой кнопкой мыши.

    Корректировка координат введенных точек:

    Перемещаясь по записям таблицы, можно исправлять с клавиатуры значения координат тех или иных точек. При этом изменения сразу будут отображаться на экране, а значения длины и азимута будут автоматически пересчитываться. Вместо значений координат можно корректировать значение длины или азимута. В этом случае пересчитываться автоматически будут координаты точек. Точка, соответствующая текущей записи в таблице, отображается на ломаной большим кружком и перемещается синхронно со сменой записи.

    Удаление введенных точек:

    Удалить пошагово введенные точки можно Esc или воспользовавшись контекстным меню, которое вызывается щелчком правой кнопкой мыши в любом месте карты (Отменить последнюю точку Esc).

    Так же имеется возможность удалять точки не пошагово. Для удаления какой то конкретной точки поставьте курсор на строку с удаляемой точкой и нажмите комбинацию клавиш Ctrl+Del.


Ввод типовой полилинии (ломаной) с клавиатуры

[Примечание] Примечание

Ввод ломаной может производиться как по проекции так и по сфероиду в зависимости от выбранной опции.

[Примечание] Примечание

Для того, чтобы вводить типовые объекты необходимо предварительно их создать в структуре слоя!

Ввод полилинии с клавиатуры производится с использованием панели Свойства, для открытия панели выберите меню Окно|Свойства или нажмите на панели инструментов кнопку Свойства [image] .

Если ломаную уже начали вводить с помощью мыши, то процесс ввода отображается в таблице на этой панели.

Каждая строка таблицы содержит информацию об одной из точек вводимой ломаной.

В первой колонке таблицы записывается порядковый номер точки. В следующих двух колонках - координаты точки, они могут отображаться или в метрах (X, Y) или в градусах (Широта, Долгота). Параметры отображения указываются в настройках карты.

Колонка Длина содержит длину отрезка ломаной из предыдущей точки к текущей. Последняя колонка Азимут/Угол(в зависимости от настройки) содержит значение азимута/угла, измеряемого из точки предшествующей текущей.

Способы ввода ломаной

Рисунок 345. Способы ввода ломаной

Для ввода типового линейного объекта:

  1. Сделайте слой редактируемым.

  2. В том случае, если ранее вводились типовые объекты, нажмите на панели редактирования кнопку [image] и выберите в меню пункт Примитивы. В противном случае, и так же если редактируемый слой не содержит типовых объектов, то данный пункт выполнять не надо.

  3. Далее ввод линии аналогичен вводу простой линии с клавиатуры.

    Отличия относятся только к линейным объектам, являющимся участками, подробней о вводе сети можно узнать в разделе «Ввод объектов сети».

[Важно] Важно

Если линейный типовой объект является участком, то ломаная обязательно должна начинаться и заканчиваться типовым символьным объектом, подробнее можно узнать в разделе Слой инженерной сети.

[Примечание] Примечание

В процессе ввода ломаной можно накладывать дополнительные условия.


Ввод полилинии (ломаной) по дуге

При воде как простой так и типовой ломаной возможно ввести часть объекта в виде дуги. Дуга полилинии представляет собой множество точек перелома (узлов) на полуокружности. На рисунке далее показаны две ломаные с дугами. Сверху располагается простая ломаная (примитив) а снизу типовой участок сети. Для наглядности на линиях отображены точки перелома (включен режим отображения узлов- [image] ).

Ломаные с частью линии в виде дуги

Рисунок 346. Ломаные с частью линии в виде дуги

Для ввода линии с дугой:

  1. В режиме ввода простой или типовой линии подведите курсор к первой точке дуги и сделайте щелчок левой кнопкой мыши. Затем сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт По дуге.

  2. Подведите курсор к месту, где должна стоять последняя точка дуги и сделайте щелчок левой кнопкой мыши.

  3. Перемещая курсор растяните сегмент дуги до нужных размеров, для завершения процесса рисования дуги ломаной сделайте щелчок левой кнопкой мыши. Дуга будет зафиксирована.

  4. Продолжайте ввод ломаной или завершите ее двойным щелчком левой кнопкой мыши.

    Ввод ломаной с частью линии в виде дуги

    Рисунок 347. Ввод ломаной с частью линии в виде дуги


Продолжение введенной ломаной

Для того чтобы продолжить ввод ранее нанесенной ломаной:

  1. Сделайте слой редактируемым.

  2. Включите режим Узлы ( [image] ).

  3. Отметьте начальный или конечный узел ломаной, после чего нажмите правую клавишу мыши, и в контекстном меню выберите команду Продолжить линию. При этом редактор инициализирует обычный режим ввода полилинии с начальной точкой в указанном узле. После завершения ввода полилинии, результирующий объект будет содержать исходную полилинию и продолженную от ее конца полилинию как единый сегмент.


Настройка стиля простой ломаной

Для настройки стиля простой ломаной:

  1. Проверьте чтобы было включено редактирование слоя.

  2. Нажмите кнопку [image] . В появившемся диалоге задайте необходимые параметры. По умолчанию в настройках линия черного цвета толщиной в 1 пиксель. Настроить можно следующие параметры:

    • цвет линии;

    • толщину на экране в пикселях;

    • толщина при печати, заданная величина умножается на 0.1 мм;

    • стиль вводимой линии, недостающие стили можно создать самостоятельно;

      [Примечание] Примечание

      Масштаб на карте может быть представлен в двух вариантах: геодезическом и в сантиметрах на пиксель. Выбор нужного масштаба осуществляется в параметрах системы.

    • признак масштабирования линии и масштаб. Признак устанавливается опцией Масштабировать, тогда линия будет изменять свою толщину, пропорционально масштабу отображения карты. При этом в окне Масштаб 1:1 надо ввести коэффициент масштабирования. Коэффициент применяется к величине толщины линии на экране. Например, при указанной толщине линии 1 пкс и коэффициенте 100 толщина линии на карте будет соответствовать 1 метру. Соответственно чем больше величина коэффициента, тем толще выглядит линия при одном и том же масштабе карты.

    [Примечание] Примечание

    Стиль объекта достаточно установить один раз, для всех вводимых объектов данного типа будет применяться установленный стиль.

  3. Для сохранения заданного стиля нажмите кнопку ОК, для закрытия окна без сохранения нажмите кнопку Отмена.


Ввод площадного объекта (полигона)

Полигон представляет собой замкнутый контур, образованный последовательностью точек, которые соединены отрезками. Последний узел в этой цепочке всегда соединен с первым. Такие объекты чаще всего используют для нанесения зданий, кварталов и различных участков территорий.

Каждый такой объект отображается в виде замкнутой ломаной линии, цвет, толщина и стиль которой могут быть заданы пользователем. По желанию внутренняя часть полигона может быть залита другим цветом и стилем. Так же можно внутреннюю часть сделать прозрачной.

Варианты ломаной полигонов

Рисунок 348. Варианты ломаной полигонов

В зависимости от той фуры, которую надо получить из полигона ввод осуществляется по разному.

Если ввести надо полигон произвольной формы- то ввод осуществляется последовательным добавлением цепочек точек, координаты каждой из которых задаются различными способами. Первая и последняя точка полигона замыкаются по прямой линии. Если полигон в виде прямоугольника, круга или сегмента, то ввод осуществляется в соответствии с выбранной фигурой.

При последовательном вводе точек один из вариантов ввода — с помощью мыши на экране, произвольно или «цепляясь» за имеющиеся точки активного слоя. Такой способ можно использовать, например, при векторизации растра.

Второй вариант последовательного ввода точек — использование геометрических построений. Он позволяет добиться более точного расположения точек полигона. Место расположения очередной точки выбирается из контекстного меню, пункты которого меняются в зависимости от этапа ввода. Доступны различные варианты: ввод по координатам, вдоль линии, параллельно линии, под определенным углом и другие.

Также можно ввести полигон по точкам строго по координатам, которые вводятся с клавиатуры в окно Свойства.

Кроме перечисленных способов, существует возможность трассировки или автозамыкания полигона.

Вы так же можете ввести полигон с использованием эквидистанты, данный вариант может быть использован для нанесения объекта с одной шириной по всей длине.

Можно комбинировать любой вариант нанесения полигона в зависимости от поставленных задач.

Полигоны так же как и все остальные объекты слоя делятся на простые (примитивы) и типовые. Процесс их ввода различается.

Перед тем как вводить примитивы, необходимо задать стиль для создаваемых объектов. В отличие от этого, стиль для типовых объектов задаётся только один раз в структуре слоя.

  • «Ввод простого площадного объекта (полигона) с экрана»

  • «Ввод типового площадного объекта (полигона) с экрана»

  • «Ввод простого площадного объекта (полигона) с экрана с использованием геометрических построений»

  • «Ввод типового площадного объекта (полигона) с экрана с использованием геометрических построений»

  • «Ввод простого площадного объекта (полигона) с клавиатуры»

  • «Ввод типового площадного объекта (полигона) с клавиатуры»

  • «Ввод площадного объекта (полигона) по дуге»

  • «Трассировка ломаной или полигона»

  • «Автозамыкание ломаной или полигона»


Ввод простого площадного объекта (полигона) с экрана

[Примечание] Примечание

Ввод полигона может производиться как по проекции так и по сфероиду в зависимости от выбранной опции.

Для начала ввода простого полигона:

  1. Сделайте слой редактируемым.

  2. В том случае, если ранее вводились типовые объекты, то на панели редактирования нажмите кнопку [image] и выберите в меню пункт Примитивы. Если типовые объекты не вводились, данный пункт выполнять не надо.

  3. Настройте стиль простого полигона.

  4. На панели редактирования выберите режим ввода и нанесите объект:

    • Для ввода полигона произвольной формы нажмите кнопку [image] . Подведите курсор к началу полигона, зафиксируйте первую точку нажатием левой кнопки мыши. Затем последовательно перемещайте курсор мыши к очередной точке на карте и фиксируйте эту точку нажатием левой кнопки мыши. Для завершение ввода сделайте или двойной щелчок левой кнопкой мыши или нажмите клавишу Enter или выберите в контекстном меню пункт Закончить объект или нажмите кнопку [image] на панели инструментов.

    • Ввод полигона произвольной формы

      Рисунок 349. Ввод полигона произвольной формы

      [Примечание] Примечание

      Пошаговую отмену введенных точек можно сделать клавишей Esc.

      Ввод полигона произвольной формы можно так же осуществлять с использованием геометрических построений, с клавиатуры, с автозамыканием и с использованием трассировки.

    • Для ввода полигона в виде прямоугольника нажмите кнопку [image] . Подведите курсор к одному из будущих углов объекта. Щелкните левой клавишей мыши для фиксации первой вершины, точно так же зафиксируйте вторую вершину прямоугольника, после чего растяните «резиновую» рамку прямоугольника до нужных размеров, для завершения процесса рисования прямоугольника сделайте щелчок левой кнопкой мыши.

      Ввод полигона в виде прямоугольника

      Рисунок 350. Ввод полигона в виде прямоугольника

    • Для ввода полигона в виде окружности нажмите кнопку [image] . Щелкните мышью в центр создаваемого объекта, растяните окружность до нужного размера. При растяжении справа снизу в строке состояния будет отображаться радиус круга, например - [image] . После того как контур будет растянут до нужного радиуса сделайте щелчок левой кнопкой мыши.

      Ввод полигона в виде окружности

      Рисунок 351. Ввод полигона в виде окружности

      Для ввода полигона в виде овала щелкните мышью в центр создаваемого контура, нажмите клавишу Shift, растяните овал до нужного размера. Для поворота фигуры нажмите клавишу Ctrl, с помощью курсора задайте нужный угол и не отпуская клавишу сделайте щелчок левой кнопкой мыши. При вводе объекта справа снизу в строке состояния будут отображаться его размеры и угол поворота, например [image] .

      Ввод полигона в виде овала

      Рисунок 352. Ввод полигона в виде овала

    • Для ввода полигона в виде сегмента (дуги) нажмите кнопку [image] . Щелкните левой клавишей мыши для фиксации первой точки, нажмите левую кнопку мыши во второй точке сегмента и удерживая ее нажатой растяните «резиновую» рамку до нужных размеров, для завершения процесса рисования сегмента отпустите левую клавишу мыши.

      Ввод ломаной в виде дуги

      Рисунок 353. Ввод ломаной в виде дуги

[Примечание] Примечание

Видеоурок по вводу геометрических примитивов можно посмотреть пройдя по ссылке: https://www.politerm.com/videos/layeredit/EditTool/.


Ввод типового площадного объекта (полигона) с экрана

[Примечание] Примечание

Ввод полигона может производиться как по проекции так и по сфероиду в зависимости от выбранной опции.

[Примечание] Примечание

Чтобы вводить типовые объекты необходимо предварительно их создать в структуре слоя!

Для начала ввода типового полигона:

  1. Сделайте слой редактируемым.

  2. Нажмите кнопку [image] и выберите в меню типовых объектов нужный режим объекта.

  3. Далее ввод типовых объектов аналогичен примитивам, для ввода повторите пункт 4 раздела «Ввод простого площадного объекта (полигона) с экрана».

[Примечание] Примечание

Ввод произвольного полигона можно так же как и для ломаной производить с экрана с использованием геометрических построений, с клавиатуры, с автозамыканием и с использованием трассировки.


Ввод простого площадного объекта (полигона) с экрана с использованием геометрических построений

[Примечание] Примечание

Ввод объектов может производиться как по проекции так и по сфероиду в зависимости от выбранной опции.

С использованием геометрических построений возможен ввод полигона только в виде произвольной фигуры - [image] , которая задается пошаговым введением точек. Для его ввода:

  1. Сделайте слой редактируемым.

  2. В том случае, если ранее вводились типовые объекты, то на панели редактирования нажмите кнопку [image] и выберите в меню пункт Примитивы. Если типовые объекты не вводились, данный пункт выполнять не надо.

  3. Настройте стиль простого полигона.

  4. На панели инструментов нажмите кнопку [image] .

  5. Далее для ввода используйте контекстное меню, вызываемое нажатием правой клавишей мыши в области активной карты:

    Рисунок 354. Контекстное меню

    [Предупреждение] Предупреждение

    При работе с контекстным меню есть определенные правила:

    • При работе с линией (параллельно, на расстоянии, перпендикулярно и прочее). В том случае, когда линия находится в активном слое, то она указывается щелчком левой кнопки мыши. Если же она находится в неактивном слое, то при указании (щелчке левой кнопки мыши) необходимо удерживать клавишу Ctrl.

    • При работе с точкой (на расстоянии от заданной точки, направление через точку, и другие). Точка может быть как произвольно указана на карте, так и «притянута» к одному из узлов или точек перелома объекта карты или вводимой линии. Точка указывается щелчком левой кнопки мыши. Если необходимо привязаться к одному из узлов или точек перелома объекта карты, находящемуся не в активном слое, тогда при указании точки необходимо удерживать клавиши Ctrl+Shift, если в активном то придерживая Ctrl.

    В зависимости от этапа ввода содержание контекстного меню будет меняться.

    • Отменить последнюю точку ESC - отменяет последнюю введенную точку, аналогично нажатию клавиши Esc.

    • Задать координаты - вызывает окно введения координат для следующей точки. Окно появляется с координатами 0;0, сотрите их, и введите с клавиатуры новые координаты:

      Диалоговое окно введения координат точки

      Рисунок 355. Диалоговое окно введения координат точки

      После нажатия кнопки ОК произойдет перестроение экрана вместо с указанными координатами, и там будет закреплена новая точка ломаной. Кнопка Отмена закрывает окно введения координат, введение ломаной при этом не заканчивается.

    • На расстоянии... - вызывает окно задания расстояния. Расстояние задается в метрах, и отсчитывается оно от предыдущей зафиксированной точки ломаной.

      Диалоговое окно задания расстояния

      Рисунок 356. Диалоговое окно задания расстояния

      После нажатия кнопки ОК вокруг последней зафиксированной точки появится круг, с «бегающей» на нем точкой, точку можно зафиксировать в нужном месте щелчком левой кнопки мыши.

      Если до фиксации «бегающей» точки щелкнуть правой кнопкой мыши, то появится новое контекстное меню.

      Дополнительное контекстное меню

      Рисунок 357. Дополнительное контекстное меню

      • Отменить - отменяет введение точки.

      • Вдоль линии - после выбора данной опции курсор примет вид стрелки с двумя параллельными полосами и левой кнопкой мыши надо указать вдоль какой линии будет проходить точка.

      • Направление через точку - позволяет указать через какую точку будет проходить следующая точка вашей ломаной.

      • На расстоянии от второй точки - позволяет задать вторую точку для прохождения вашей ломаной. Для второй точки так же можно указать координаты с помощью контекстного меню, которое вызывается правой копкой мыши.

    • В направлении - позволяет указать направление, которое будет задано через предыдущую зафиксированную точку полигона. После выбора данной опции появляется направляющая линия, проходящая через конечную зафиксированную точку ломаной, при щелчке левой кнопки мыши линия фиксируется, и на ней появляется «бегающая» точка, вторым щелчком левой кнопки мыши очередная точка вашей ломаной будет зафиксирована. Если сразу после выбора данного пункта (до первого щелчка левой кнопки мыши) произвести щелчок правой кнопкой мыши, то появится контекстное меню:

      • Задать угол - вызывает диалоговое окно задания угла для направляющей линии.

      • Параллельно - дает возможность указать параллельно какому отрезку объекта карты или вводимой линии будет направлена линия.

        Рисунок 358. Контекстное меню

      • Перпендикулярно - позволяет указать, перпендикулярно какому отрезку объекта карты или вводимой линии направлена линия.

      • Под углом к - при выборе данной опции сначала надо левой кнопкой мыши указать под углом к какому отрезку объекта будет расположена направляющая линия, а затем в появившемся окне задать угол.

        Если же щелкнуть правой кнопкой мыши после фиксации линии, то появится другое контекстное меню:

        Рисунок 359. Контекстное меню

        • Второе направление вдоль линии - позволяет щелчком левой кнопки мыши задать вдоль какого отрезка объекта карты или вводимой линии будет расположена вторая направляющая линия, тогда точка будет находиться на пересечении этих двух линий.

        • Второе направление через точку - дает возможность указать точку, через которую будет проходить вторая направляющая линия.

        • Длиной с - дает возможность ввести следующий отрезок ломаной равным указанному отрезку объекта на карте или вводимой линии.

        • На расстоянии от точки - после выбора данной опции левой кнопкой мыши укажите точку, на расстоянии от которой надо закрепить следующую точку вводимой ломаной. После указания точки в появившемся окошке введите расстояние.

        • На расстоянии от линии - после выбора данной опции левой кнопкой мыши укажите линию, на расстоянии от которой надо закрепить следующую точку вводимой ломаной. После указания точки в появившемся окошке введите расстояние.

    • Под углом - при выборе данной опции появляется диалоговое окно, в котором надо задать угол, который будет отсчитываться от предыдущего введенного отрезка ломаной. После введения угла появляется фиксированная направляющая линия. Щелчком правой кнопкой мыши можно вызвать контекстное меню, изображенное на рисунке выше.

    • Перпендикулярно - после выбора данной опции укажите левой кнопкой мыши, перпендикулярно какому отрезку объекта карты или вводимой линии надо закрепить точку. Щелчком правой кнопкой мыши можно вызвать контекстное меню, изображенное на рисунке выше.

    • Параллельно - позволяет указать левой кнопкой мыши, параллельно какому отрезку объекта карты или вводимой линии надо закрепить точку. Щелчком правой кнопкой мыши можно вызвать контекстное меню, изображенное на Рисунок 343, «Контекстное меню».

    • Вдоль линии - после выбора данной опции укажите левой кнопкой мыши, вдоль какого отрезка объекта карты или вводимой линии надо закрепить точку. Щелчком правой кнопкой мыши можно вызвать контекстное меню, изображенное на рисунке Рисунок 343, «Контекстное меню».

    • Задать направление - дает возможность задать левой кнопкой мыши направление, в котором надо закрепить точку.

    • На расстоянии от заданной точки - после выбора данной опции сначала левой кнопкой мыши укажите точку, от которой далее в появившемся диалоговом окне задайте расстояние.

    • Отменить всю линию - отменяет всю вводимую линию.

    • Закончить объект - заканчивает вводимый объект.

    [Примечание] Примечание

    Видеоурок по вводу объектов с использованием геометрических построений можно посмотреть пройдя по ссылке: https://www.politerm.com/videos/layeredit/EditToolPolyline/.


Ввод типового площадного объекта (полигона) с экрана с использованием геометрических построений

[Примечание] Примечание

Ввод объектов может производиться как по проекции так и по сфероиду в зависимости от выбранной опции.

С использованием геометрических построений возможен ввод полигона только в виде произвольной фигуры - [image] , которая задается пошаговым введением точек. Для его ввода:

  1. Сделайте слой редактируемым.

  2. Нажмите кнопку [image] и в меню типовых объектов выберите нужный режим объекта (в структуре слоя тип объекта должен быть площадным).

  3. На панели инструментов нажмите кнопку [image] .

  4. Далее ввод типового полигона аналогичен вводу простого, повторите пункты с 5го раздела «Ввод простой полилинии (ломаной) с экрана с использованием геометрических построений».


Ввод простого площадного объекта (полигона) с клавиатуры

[Примечание] Примечание

Ввод полигона может производиться как по проекции так и по сфероиду в зависимости от выбранной опции.

Ввод полигона с клавиатуры производится с использованием панели Свойства, для открытия панели выберите меню Окно|Свойства или нажмите на панели инструментов кнопку Свойства [image] .

Если площадной объект уже начали вводить с помощью мыши, то процесс ввода отображается в таблице на этой панели.

Каждая строка таблицы содержит информацию об одной из точек вводимого полигона.

В первой колонке таблицы записывается порядковый номер точки. В следующих двух колонках - координаты точки, они могут отображаться или в метрах (X, Y) или в градусах (Широта, Долгота). Параметры отображения указываются в настройках карты.

Колонка Длина содержит длину отрезка полигона из предыдущей точки к текущей. Последняя колонка Азимут/Угол(в зависимости от настройки) содержит значение азимута/угла, измеряемого из точки предшествующей текущей.

С использованием клавиатуры возможен ввод полигона только в виде произвольной фигуры - [image] , которая задается пошаговым введением точек. Для его ввода:

  1. Сделайте слой редактируемым.

  2. В том случае, если ранее вводились типовые объекты, то на панели редактирования нажмите кнопку [image] и выберите в меню пункт Примитивы. Если типовые объекты не вводились, данный пункт выполнять не надо.

  3. Настройте стиль простого полигона.

  4. На панели инструментов нажмите кнопку [image] .

  5. Далее:

    Ввод очередной точки с клавиатуры:

    Если встать в таблице на последнюю запись и нажать клавишу «стрелка вниз», то в таблице добавится новая пустая строка. Если ввести с клавиатуры координаты новой точки и снова нажать клавишу «стрелка вниз», то новая точка с введенными координатами добавится к вводимому полигону и отобразится на экране. Значения длины и азимута заполнятся в таблице автоматически. Повторяя эту операцию можно весь полигон ввести вручную с клавиатуры.

    Завершение ввода полигона

    Завершить ввод можно кнопкой [image] на панели редактирования или с помощью пункта Закончить объект контекстного меню, вызываемого правой кнопкой мыши.

    Корректировка координат введенных точек:

    Перемещаясь по записям таблицы, можно исправлять с клавиатуры значения координат тех или иных точек. При этом изменения сразу будут отображаться на экране, а значения длины и азимута будут автоматически пересчитываться. Вместо значений координат можно корректировать значение длины или азимута. В этом случае пересчитываться автоматически будут координаты точек. Точка, соответствующая текущей записи в таблице, отображается на ломаной большим кружком и перемещается синхронно со сменой записи.

    Удаление введенных точек:

    Удалить пошагово введенные точки можно Esc или воспользовавшись контекстным меню, которое вызывается щелчком правой кнопкой мыши в любом месте карты (Отменить последнюю точку Esc).

    Так же имеется возможность удалять точки не пошагово. Для удаления какой то конкретной точки поставьте курсор на строку с удаляемой точкой и нажмите комбинацию клавиш Ctrl+Del.


Ввод типового площадного объекта (полигона) с клавиатуры

[Примечание] Примечание

Ввод полигона может производиться как по проекции так и по сфероиду в зависимости от выбранной опции.

Ввод площадного объекта с клавиатуры производится с использованием панели Свойства, для открытия панели выберите меню Окно|Свойства или нажмите на панели инструментов кнопку Свойства [image] .

Если полигон уже начали вводить с помощью мыши, то процесс ввода отображается в таблице на этой панели.

Каждая строка таблицы содержит информацию об одной из точек вводимого полигона.

В первой колонке таблицы записывается порядковый номер точки. В следующих двух колонках - координаты точки, они могут отображаться или в метрах (X, Y) или в градусах (Широта, Долгота). Параметры отображения указываются в настройках карты.

Колонка Длина содержит длину отрезка полигона из предыдущей точки к текущей. Последняя колонка Азимут/Угол(в зависимости от настройки) содержит значение азимута/угла, измеряемого из точки предшествующей текущей.

С использованием клавиатуры возможен ввод полигона только в виде произвольной фигуры - [image] , которая задается пошаговым введением точек. Для его ввода:

  1. Сделайте слой редактируемым.

  2. Нажмите кнопку [image] и выберите в меню типовых объектов нужный режим объекта (в структуре слоя тип объекта должен быть площадным).

  3. На панели инструментов нажмите кнопку [image] .

  4. Ввод типового полигона аналогичен вводу простого, повторите пункты начиная с 5го раздела «Ввод простого площадного объекта (полигона) с клавиатуры».


Ввод простого площадного объекта (полигона) с использованием эквидистанты

Эквидистанта - это множество точек, равноудалённых от заданного множества. При введении площадного объекта это ломаная, которая параллельна на указанном расстоянии другой ломаной. Таким образом при введении полигона первоначально наносится ломаная линия, а затем указывается направление эквидистанты и расстояние, на котором она будет расположена.

Для ввода простого полигона:

  1. Сделайте слой редактируемым.

  2. В том случае, если ранее вводились типовые объекты, то на панели редактирования нажмите кнопку [image] и выберите в меню пункт Примитивы. Если типовые объекты не вводились, данный пункт выполнять не надо.

  3. Настройте стиль простого полигона.

  4. На панели редактирования нажмите кнопку Многоугольник [image] .

  5. Подведите курсор к началу полигона, зафиксируйте первую точку нажатием левой кнопки мыши. Затем последовательно перемещайте курсор мыши к очередной точке на карте и фиксируйте эту точку нажатием левой кнопки мыши. Таким образом введите одно ребро будущего полигона.

    [Примечание] Примечание

    Пошаговую отмену введенных точек можно сделать клавишей Esc.

  6. По окончанию ввода ребра нажмите правую кнопку мыши и выберите в контекстном меню пункт Эквидистанта.

  7. Подведите курсор к той стороне ребра, с которой будет нанесена эквидистанта, сделайте щелчок левой кнопкой мыши, в указанном направлении появится стрелка.

  8. В появившемся окне введите расстояние от ребра до эквидистанты, нажмите кнопку ОК. Ввод завершен.

    Ввод полигона с использованием эквидистанты

    Рисунок 360. Ввод полигона с использованием эквидистанты


Ввод типового площадного объекта (полигона) с использованием эквидистанты

[Примечание] Примечание

Чтобы вводить типовые объекты необходимо предварительно их создать в структуре слоя!

Для начала ввода типового полигона:

  1. Сделайте слой редактируемым.

  2. Нажмите кнопку [image] и выберите в меню типовых объектов нужный режим объекта. Режим обязательно должен иметь площадной графический тип.

  3. Далее ввод типовых объектов аналогичен примитивам, для ввода повторите пункт 5 раздела «Ввод простого площадного объекта (полигона) с использованием эквидистанты».

[Примечание] Примечание

Ввод произвольного полигона можно так же как и для ломаной производить с экрана с использованием геометрических построений, с клавиатуры, с автозамыканием и с использованием трассировки.


Ввод площадного объекта (полигона) по дуге

При воде как простого, так и типового полигона в виде произвольной фигуры - [image] возможно ввести часть объекта в виде дуги. Дуга полигона представляет собой множество точек перелома (узлов) на полуокружности. На рисунке далее показан полигон, часть которого нанесена в виде дуги. Для наглядности на полигоне отображены точки перелома (включен режим отображения узлов- [image] ).

Полигон с дугой

Рисунок 361. Полигон с дугой

Для ввода полигона с дугой:

  1. В режиме ввода простого или типового полигона подведите курсор к первой точке дуги и сделайте щелчок левой кнопкой мыши. Затем сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт По дуге.

  2. Подведите курсор к месту, где должна стоять последняя точка дуги и сделайте щелчок левой кнопкой мыши.

  3. Перемещая курсор растяните сегмент дуги до нужных размеров, для завершения процесса рисования дуги ломаной сделайте щелчок левой кнопкой мыши. Дуга будет зафиксирована.

  4. Продолжайте ввод полигона или завершите ее двойным щелчком левой кнопкой мыши.

    Ввод полигона с дугой

    Рисунок 362. Ввод полигона с дугой


Настройка стиля простого площадного объекта (полигона)

Стиль любого полигона может быть настроен в соответствии с пожеланиями. Отдельно настраивается стиль контура полигона и стиль заливки. Заливка может быть прозрачной.

Для настройки стиля полигона нажмите кнопку [image] и задайте в открывшемся диалоге Стиль параметры стиля заполненных объектов:

Диалоговое окно «Стиль»

Рисунок 363. Диалоговое окно «Стиль»

В разделе Заливка задается цвет фона, цвет узора и узор заливки объекта.

По умолчанию используется узор со сплошной заливкой (полигон полностью заливается цветом узора), поэтому для установки цвета объекта достаточно задать цвет узора. Если в списке узоров нет нужного, то его возможно создать самостоятельно.

В поле прозрачность задается степень прозрачности заливки (от 0 до 100), поле активно только для сплошной заливки. Для полной прозрачности можно выбрать узор без заливки. Если требуется прозрачность для заливки с символами, то она настраивается в редакторе символов при создании заливки.

В разделе Линии задаются цвет, стиль, толщина на экране и толщина при печати контура объекта. Если необходимого стиля в списке нет, то его можно создать самостоятельно.

[Примечание] Примечание

Стиль объекта можно скопировать/вставить, вызвав контекстное меню правой кнопкой мыши, а также в режиме редактирования с помощью контекстного меню редактора.


Трассировка ломаной или полигона

[Примечание] Примечание

Ввод объектов может производиться как по проекции так и по сфероиду в зависимости от выбранной опции.

Трассировка объектов позволяет при вводе простой или типовой ломаной или полигона повторять целые участки цепочек узлов, принадлежащих уже существующим объектам.

[Примечание] Примечание

Так же для ввода объектов можно использовать автозамыкание.

Если объект, участок которого надо повторить находится в редактируемом слое, тогда для трассировки:

  1. Сделайте слой активным и редактируемым.

  2. Для трассировки типовых ломаных нажмите на панели редактирования кнопку [image] и в меню типовых объектов выберите тип вводимой ломаной или полигона.

    Для трассировки простых объектов в том случае, если ранее вводились типовые объекты, нажмите на панели редактирования кнопку [image] и выберите в меню пункт Примитивы. В противном случае и так же если редактируемый слой не содержит типовых объектов, то данный пункт выполнять не надо.

  3. Для простых линий настройте стиль вводимого линейного объекта. Для простого полигона настройте стиль простого полигона.

    [Примечание] Примечание

    Стиль объекта достаточно установить один раз, для всех простых объектов (примитивов) данного вида будет применяться установленный стиль.

  4. На панели инструментов нажмите кнопку для ввода линии [image] или [image] для ввода полигона.

  5. «Прицепите» (с нажатой клавишей Ctrl) очередную точку вводимого объекта к первому узлу трассируемого участка (чтобы были видны все узлы активного слоя нажмите кнопку [image] ).

  6. Для задания направления «прицепите» (с прижатой клавишей Ctrl) следующую точку вводимого объекта к следующему за первым узлу трассируемого участка.

    Задание направления трассировки

    Рисунок 364. Задание направления трассировки

  7. Нажмите кнопку [image] . Система начнет искать последовательность узлов по указанному направлению и остановится либо в том узле, где цепочка заканчивается, либо там, где из узла выходит более одного ребра.

    Трассировка до пересечения

    Рисунок 365. Трассировка до пересечения

    Для продолжения трассировки повторите действия с п. 4 и 5.

    Задание следующего направления трассировки

    Рисунок 366. Задание следующего направления трассировки

    Задание следующего направления трассировки

    Рисунок 367. Задание следующего направления трассировки

    В том случае, если надо сделать частичную трассировку объекта, то есть повторить не весь контур, а только его определенную часть, то для этого надо аналогично привязать первые две точки, а потом таким же образом указать (привязать) последнюю точку, и только после этого нажать кнопку обход ( [image] ). После чего линия «пробежится» до последней точки цепочки либо остановится в точке первого разветвления трассируемого маршрута.

  8. Для завершения ввода объекта сделайте двойной щелчок левой кнопкой мыши в последней точке или нажмите клавишу Enter или выберите в контекстном меню пункт Закончить объект или нажмите кнопку [image] на панели инструментов.

    Результат трассировки ломаной

    Рисунок 368. Результат трассировки ломаной

Если объект, участок которого надо повторить находится не в редактируемом слое, тогда для трассировки:

  1. Сделайте слой в котором будет вводиться новый объект редактируемым.

  2. Сделайте активным слой, в котором находится объект, участок которого надо повторить.

  3. Повторите пункты 2-7, описанные выше.


Автозамыкание ломаной или полигона

[Примечание] Примечание

Ввод объектов может производиться как по проекции так и по сфероиду в зависимости от выбранной опции.

Если вводится объект, граничащий с одним или несколькими соседними контурами, то можно сократить время ввода, не проходя дважды по уже введенным для соседей точкам. Автозамыкание можно применить как к простым объектам так и к типовым.

[Примечание] Примечание

Для частичного повтора объектов так же можно использовать трассировку.

Если объект, участок которого надо повторить находится в редактируемом слое, тогда для автозамыкания:

  1. Сделайте слой активным и редактируемым.

  2. Для автозамыкания типового полигона нажмите на панели редактирования кнопку [image] и в меню типовых объектов выберите режим вводимого объекта.

    Для автозамыкания простого полигона в том случае, если ранее вводились типовые объекты, нажмите на панели редактирования кнопку [image] и выберите в меню пункт Примитивы. В противном случае и так же если редактируемый слой не содержит типовых объектов, то данный пункт выполнять не надо.

  3. Для простых ломаных настройте стиль вводимого линейного объекта. Для простого площадного объекта настройте стиль простого полигона.

    [Примечание] Примечание

    Стиль объекта достаточно установить один раз, для всех простых объектов (примитивов) данного вида будет применяться установленный стиль.

  4. На панели инструментов нажмите кнопку для ввода линии [image] или [image] для ввода полигона.

  5. Чтобы были видны все узлы активного слоя нажмите кнопку [image] .

  6. Подведите курсор к одному из узлов объекта, часть которого надо повторить, «прицепитесь» к нему. Для этого нажмите Ctrl, и не отпуская ее сделайте щелчок левой кнопкой мыши на узле.

    Привязка к узлу существующего полигона

    Рисунок 369. Привязка к узлу существующего полигона

  7. Доведите новый объект против часовой стрелки до другого узла соседнего объекта и так же как «зацепитесь» за него.

    Привязка ко второму узлу существующего полигона

    Рисунок 370. Привязка ко второму узлу существующего полигона

  8. Нажмите кнопку [image] , при этом, если путь, проходящий по существующим узлам объекта слоя, будет найден, то произойдет автоматическое замыкание объекта по уже существующим узлам.

    Рисунок 371. Автозамыкание

    Рисунок 372. Результат автозамыкания

Если объект, участок которого надо повторить находится не в редактируемом слое, тогда для автозамыкания:

  1. Сделайте слой в котором будет вводиться новый объект редактируемым.

  2. Сделайте активным слой, в котором находится объект, участок которого надо повторить.

  3. Повторите пункты 2-7, описанные выше.


Ввод символа

Символ это объект, который описывается в системе одной точкой (X, Y) независимо от его размера. Символами могут обозначаться деревья, памятники, дорожные знаки и т.п. В инженерной сети все объекты кроме линейных (участков) так же являются символами.

[Примечание] Примечание

Подробней об инженерной сети можно узнать в разделе Слой инженерной сети.

На рисунке ниже приведены примеры различных символов. Для наглядности отображены точки привязки символов (включен режим отображения узлов- [image] ).

Рисунок 373. Символы

Символ можно вводить на произвольное место карты с помощью мыши. В этом случае вы визуально оцениваете расположения символа. Так же символ может быть введен на точное место с указанием его координат или соблюдая какие либо условия, например расстояния от определенной точки. Во втором варианте используется нанесение символа с помощью геометрических построений.

Вводить можно как простые символьные объекты, так и типовые символьные объекты:

  • «Ввод простого символа»;

  • «Ввод типового символа»;

  • «Ввод символов с использованием геометрических построений».


Ввод простого символа

Символ может быть введен как на любое место карты, так и прикреплен к точке перелома (узлу) площадного или линейного объекта этого же слоя.

Для начала ввода простого символьного объекта:

  1. Сделайте слой редактируемым.

  2. В том случае, если ранее вводились типовые объекты, нажмите на панели редактирования кнопку [image] и выберите в меню пункт Примитивы. В противном случае и так же, если редактируемый слой не содержит типовых объектов, данный пункт выполнять не надо.

  3. Нажмите на панели инструментов кнопку [image] и если символ уже существует, то из открывающегося списка символ выберите его (см. Рисунок 374, «Диалоговое окно выбора символа»), если символа нет, то нажмите кнопку Новый и создайте символ.

    В строке размер задайте размер вводимого символа. Поскольку размеры символов из библиотеки символов задаются в относительных единицах (пикселях), то заранее неизвестно, какого размера они будут на той или иной карте, так как слой может создаваться для масштабов области, города, квартала, помещения. Чем больше значение коэффициента, тем крупнее будут выглядеть символы на карте (при одном и том же масштабе карты).

    Если у символа цвет узора задан как авто, то необходимо дополнительно цвет выбрать из списка цвет. Если цвет узора уже был указан при создании символа, то этого делать не надо:

    Диалоговое окно выбора символа

    Рисунок 374. Диалоговое окно выбора символа

  4. Нажмите кнопку [image] , кнопка примет нажатое состояние. Система перейдет в режим ввода символов.

  5. Далее:

    • Для ввода простого символьного объекта на любое место карты подведите курсор мыши к нужному месту и нажмите левую клавишу мыши. Если символ устанавливается рядом с уже нанесенными объектами не редактируемого слоя, то для установки его по координатам одного из узлов объекта при вводе символа нажмите и удерживайте клавиши Ctrl+Shift.

    • Для ввода с прикреплением к точке перелома линейного или площадного объекта редактируемого слоя сначала удобней включить отображение узлов - кнопка [image] . Если точки перелома нет на объекте, то подведите курсор к месту желаемого прикрепления и удерживая клавишу Alt на клавиатуре сделайте щелчок левой кнопкой мыши по нему. В результате будет добавлена точка перелома и выбранный символ будет прикреплен к ней.

      Ввод символа с прикреплением к точке перелома

      Рисунок 375. Ввод символа с прикреплением к точке перелома

      Если точка перелома уже есть, то подведите курсор с символом к ней и удерживая клавишу Ctrl на клавиатуре сделайте щелчок левой кнопкой мыши. В результате выбранный символ будет прикреплен к указанной точке перелома.

    [Примечание] Примечание

    Открепить символ от объекта можно в режиме Объект [image] или Узлы [image] с нажатой клавишей Shift.

Для смены текущего вводимого символа повторите пункт 3.

Повторяя эту операцию, можно ввести требуемое количество простых символьных объектов.


Ввод типового символа

[Примечание] Примечание

Чтобы появилась возможность вводить типовые объекты, они должны быть созданы в структуре слоя. При создании слоя типовой инженерной сети такие объекты создаются автоматически. Во всех же остальных случаях такие объекты разрабатываются самостоятельно.

Объекты могут вводится:

  • на пустое место карты или с прикреплением к узлу линейного или площадного объекта без его разделения

  • на участок инженерной сети с его разделением

Ввод типового символьного объекта на пустое место или с прикреплением к узлу линейного или площадного объекта без его разделения

  1. Включите редактирование слоя.

  2. Нажмите на панели инструментов кнопку [image] , в открывшемся меню типовых объектов выберите нужный объект.

    Окно выбора символа

    Рисунок 376. Окно выбора символа

  3. Далее:

    • Для ввода типового символьного объекта на любое место карты подведите курсор мыши к нужному (пустому) месту на карте и нажмите левую клавишу мыши. Объект отобразится на экране. Если символ устанавливается рядом с уже нанесенными объектами не редактируемого слоя, то для установки его по координатам одного из узлов объекта при вводе символа нажмите и удерживайте клавиши Ctrl+Shift.

    • Для ввода с прикреплением к точке перелома линейного или площадного объекта редактируемого слоя сначала удобней включить отображение узлов - кнопка [image] . Если точки перелома нет на объекте, то подведите курсор к месту желаемого прикрепления и удерживая клавишу Alt на клавиатуре сделайте щелчок левой кнопкой мыши по нему. В результате будет добавлена точка перелома и выбранный символ будет прикреплен к ней.

      Ввод символа с прикреплением к точке перелома

      Рисунок 377. Ввод символа с прикреплением к точке перелома

      Если точка перелома уже есть, то подведите курсор с символом к ней и удерживая клавишу Ctrl на клавиатуре сделайте щелчок левой кнопкой мыши. В результате выбранный символ будет прикреплен к указанной точке перелома.

    [Примечание] Примечание

    Открепить символ от объекта можно в режиме Объект [image] или Узлы [image] с нажатой клавишей Shift.

[Примечание] Примечание

Как изменить размер отображения типового символьного объекта см. «Изменение размеров символов».

Если с прикреплением к точке перелома символ добавляется на участок инженерной сети, то при этом разбиение участка не происходит. Такая операция может понадобиться в том случае, когда участок требуется пометить символом. В расчетах добавленный таким образом символ участвовать не будет. В инженерных сетях таким символом может случить например символ аварии на участке.

[Примечание] Примечание

Символ может добавляться не только на типовые объекты но и на точки перелома простых линейных или площадных объектов.


Ввод символов с использованием геометрических построений

[Примечание] Примечание

Ввод объектов с использованием геометрических построений может производиться как по проекции так и по сфероиду в зависимости от выбранной опции. По умолчанию ввод производится по сфероиду.

Геометрические построения можно использовать для ввода как простых так и типовых символов. Ввод символа заключается в его предварительном выборе и затем установки в указанной точке. Точка фиксируется в зависимости от выбранного пункта контекстного меню. Например, по введенным координатам, на расстоянии от указанной точки, вдоль выбранной линии и др.

Чтобы вводить символы с использованием геометрических построений надо:

  1. Для ввода простого символа. Если ранее вводились типовые объекты, нажмите на панели редактирования кнопку [image] и выберите в меню пункт Примитивы. В противном случае и так же, если редактируемый слой не содержит типовых объектов, данный пункт выполнять не надо.

    Нажмите на панели инструментов кнопку [image] и если символ уже существует, то из открывающегося списка символ выберите его (см. Рисунок 374, «Диалоговое окно выбора символа»), если символа нет, то нажмите кнопку Новый и создайте символ. В строке размер задайте размер вводимого символа. Поскольку размеры символов из библиотеки символов задаются в относительных единицах (пикселях), то заранее неизвестно, какого размера они будут на той или иной карте, так как слой может создаваться для масштабов области, города, квартала, помещения. Чем больше значение коэффициента, тем крупнее будут выглядеть символы на карте (при одном и том же масштабе карты). Если у символа цвет узора задан как авто, то необходимо дополнительно цвет выбрать из списка цвет. Если цвет узора уже был указан при создании символа, то этого делать не надо.

    Нажмите кнопку [image] , кнопка примет нажатое состояние. Система перейдет в режим ввода символов.

    Для ввода типового символа. Нажмите на панели инструментов кнопку [image] , в открывшемся меню типовых объектов выберите нужный объект.

  2. Далее используйте контекстное меню, вызываемое нажатием правой клавишей мыши в области активной карты:

    Рисунок 378. Контекстное меню

[Предупреждение] Предупреждение

При работе с контекстным меню есть определенные правила:

  • При работе с линией (параллельно, на расстоянии, перпендикулярно и прочее). В том случае, когда линия находится в активном слое, то она указывается щелчком левой кнопки мыши. Если же она находится в неактивном слое, то при указании (щелчке левой кнопки мыши) необходимо удерживать клавишу Ctrl.

  • При работе с точкой (на расстоянии от заданной точки, направление через точку, и другие). Точка может быть как произвольно указана на карте, так и «притянута» к одному из узлов или точек перелома объекта карты или вводимой линии. Точка указывается щелчком левой кнопки мыши. Если необходимо привязаться к одному из узлов или точек перелома объекта карты, находящемуся не в активном слое, тогда при указании точки необходимо удерживать клавиши Ctrl+Shift, если в активном то придерживая Ctrl.

В зависимости от этапа ввода линии содержание контекстного меню может меняться.

  • Задать координаты - вызывает окно введения координат для точки привязки символа. Окно появляется с координатами 0;0, сотрите их, и введите с клавиатуры новые координаты. Координаты вводятся или в метрах (X, Y) или в градусах (Широта, Долгота). Параметры отображения указываются в настройках карты.

    Диалоговое окно введения координат точки

    Рисунок 379. Диалоговое окно введения координат точки

    После нажатия кнопки ОК произойдет установка символа в указанную точку. Кнопка Отмена закроет окно введения координат.

  • На расстоянии от точки. После выбора данного пункта необходимо указать ка карте точку от которой будет рассчитываться расстояние. Далее в появившемся окне ввести расстояние, оно задается в метрах.

    Диалоговое окно задания расстояния

    Рисунок 380. Диалоговое окно задания расстояния

    После нажатия кнопки ОК вокруг указанной точки появится круг, с «бегающей» на нем точкой. Сделайте щелчок левой кнопкой мыши для ее фиксации и установки символа.

    Если до фиксации «бегающей» точки щелкнуть правой кнопкой мыши, то появится новое контекстное меню, которое позволяет задать дополнительные параметры.

    Дополнительное контекстное меню

    Рисунок 381. Дополнительное контекстное меню

    • Отменить - отменяет введение точки.

    • Вдоль линии - после выбора данной опции курсор примет вид стрелки с двумя параллельными полосами и левой кнопкой мыши надо указать вдоль какой линии будет проходить точка. Указанная линия должна пересекать построенную окружность вокруг указанной точки.

    • Направление через точку - позволяет указать через какую точку будет проходить линия пересечения с ранее построенной окружностью.

    • На расстоянии от второй точки - после выбора данного пункта необходимо указать вторую точку, вокруг которой будет построена окружность с указанным радиусом. Необходимым условием является пересечение окружностей. Если они не будут пересекаться, то надо заново указать точку и расстояние от нее. После пересечения окружностей для установки символа выберите одну из точек пересечения.

  • Вдоль линии - после выбора данной опции укажите левой кнопкой мыши, вдоль какого отрезка объекта карты надо закрепить точку. После чего на вдоль указанной линии появится линия с «бегающей» точкой, сделав щелчок левой кнопкой мыши на ней будет установлен символ. До фиксации токи щелчком правой кнопкой мыши можно вызвать контекстное меню:

    Рисунок 382. Контекстное меню

    • Второе направление вдоль линии - позволяет щелчком левой кнопки мыши задать вдоль какого отрезка объекта карты будет расположена вторая направляющая линия, тогда точка установки символа будет находиться на пересечении этих двух линий.

    • Второе направление через точку - дает возможность указать точку, через которую будет проходить вторая направляющая линия. Вторая линия фиксируется щелчком левой кнопкой мыши, точка установки символа будет на пересечении линий. Если до фиксации линии сделать щелчок правой кнопкой мыши, то появится дополнительное контекстное меню:

      Рисунок 383. Контекстное меню

      • Задать угол - вызывает диалоговое окно задания угла для направляющей линии.

      • Параллельно - дает возможность указать параллельно какому отрезку объекта карты будет направлена линия.

      • Перпендикулярно - позволяет указать, перпендикулярно какому отрезку объекта карты направлена линия.

      • Под углом к - при выборе данной опции сначала надо левой кнопкой мыши указать под углом к какому отрезку объекта будет расположена направляющая линия, а затем в появившемся окне задать угол. После этого выбрать точку пересечения линий для установки символа.

  • На расстоянии от линии - после выбора данной опции левой кнопкой мыши укажите линию, на расстоянии от которой надо установить символ. Далее в появившемся окошке введите расстояние, нажмите кнопку ОК. Появится линия с «бегающей» точкой на указанном расстоянии. Щелчком левой кнопкой мыши в точке установите символ. Если до установки символа сделать щелчок правой кнопкой мыши, то появится контекстное меню, изображенное на рисунке Рисунок 382, «Контекстное меню».

  • Направление через точку - после выбора данного пункта необходимо указать точку чрез которую будет проведена линия, фиксация линии производится щелчком левой кнопки мыши. После фиксации на ней появится «бегающая» точка, выбрав которую будет установлен символ. Если до фиксации линии сделать щелчок правой кнопкой мыши то появится контекстное меню, изображенное на рисунке Рисунок 383, «Контекстное меню».


Ввод текста

Возможно вводить как простые текстовые объекты, так и типовые текстовые объекты, при этом в любые из этих объектов могут быть добавлены специальные символы.

  • «Ввод простого текстового объекта»;

  • «Ввод типового текстового объекта»;

  • «Ввод специальных символов».

Пример текстовых объектов

Рисунок 384. Пример текстовых объектов


Ввод простого текстового объекта

Для начала ввода простого текстового объекта:

  1. Включите редактирование слоя.

  2. В том случае, если ранее вводились типовые объекты, то на панели редактирования нажмите кнопку [image] и выберите в меню пункт Примитивы. Если типовые объекты не вводились, данный пункт выполнять не надо.

  3. Далее можно заранее настроить параметры текстового объекта, для этого нажать кнопку [image] и задать в открывшемся диалоге Стиль параметры:

    Диалоговое окно «Стиль»

    Рисунок 385. Диалоговое окно «Стиль»

    • раздел Шрифт - задается наименование шрифта;

    • раздел Начертание - задается начертание шрифта, доступно начертание: курсив, обычный, полужирный, полужирный курсив;

    • из списка Набор имеется возможность выбрать подходящий набор для текстовых объектов (Юникод, Арабский, Балтийский, Вьетнамский, Греческий, Западный, Иврит, Кириллический, Турецкий, Центральноевропейский);

    • в разделе Текст задается стиль шрифта (подчеркнутый, зачеркнутый);

    • цвет шрифта задается с помощью открывающегося окна Цвет;

    • параметры фона шрифта задаются в разделе Фон с помощью списков Тип и Цвет.

    С помощью кнопки ОК подтвердить заданные параметры.

  4. Нажмите на панели инструментов кнопку [image] , система войдет в режим ввода текстовых объектов.

  5. Подведите курсор к точке установки текста и сделайте щелчок левой кнопкой мыши. Если ранее не были заданы параметры текста, то их можно задать на данном этапе, для этого при щелчке надо удерживать кнопку Ctrl, затем в появившемся диалоговом окне Стиль их задать. В указанном месте появится мигающий курсор.

    [Примечание] Примечание

    Вы можете задать как один цвет, так и разные цвета для одного текстового объекта. В первом случае цвет текста выбирается из списка Цвет. Задание же разных цветов для одного текстового объекта возможно только после его нанесения, и производится это в режиме редактирования.

  6. Введите текст.

  7. Для задания угла текстового объекта на карте нажмите правую клавишу мыши, и, не отпуская ее, перемещайте курсор до нужного угла. Отпустите клавишу. Надпись повернется на указанный угол. При этом ввод и редактирование текста можно продолжать.

  8. Для завершения ввода текстового объекта нажмите левую клавишу мыши. Для ввода следующего текстового объекта повторите действия с п. 5.

  9. Для отмены текущего ввода нажмите клавишу Esc.


Ввод типового текстового объекта

[Примечание] Примечание

Для того, чтобы вводить типовые объекты необходимо предварительно их создать в структуре слоя!

Для начала ввода типового текстового объекта:

  1. Включите редактирование слоя.

  2. Нажмите на панели инструментов кнопку [image] и в открывшемся меню типовых объектов выберите нужный режим нужного текстового типа (графический тип в структуре слоя должен быть задан как текстовый).

    Окно выбора символа

    Рисунок 386. Окно выбора символа

Дальнейшие действия аналогичны вводу простых текстовых объектов (начиная с пункта 5).


Ввод специальных символов

Вы можете наносить на карту по мимо обычного текста специальные символы, находящиеся в выбранном шрифте.

Перед вставкой спец символов предварительно на карту надо нанести простой или типовой текстовый объект.

Для ввода спец символов:

  1. Откройте диалоговое окно Стиль (оно открывается двойным щелчком мыши на нанесенном текстовом объекте в режиме выделения объекта - кнопка [image] , слой должен быть редактируемым.

  2. Проверьте чтобы у текстового объекта был установлен Набор: Юникод, так как вставка специальных символов возможна только при данном наборе, соответственно если используется другой набор, поменять его на Юникод:

    • для простого текстового объекта набор меняется в уже открытом ранее диалоге Стиль вкладка Текст, список Набор;

    • для типового текстового объекта набор меняется в структуре слоя, в нужном режиме.

  3. Перейдите на вкладку Параметры.

  4. Нажмите кнопку Символы, после чего появится диалоговое окно Выбор символов:

    Диалоговое окно Выбор символов

    Рисунок 387. Диалоговое окно Выбор символов

  5. В общем списке символов левой кнопкой мыши выделите нужный символ, при этом он отобразится в правом нижнем окошке. Нажмите кнопку Выбрать. Выбрать символ возможно так же с помощью двойного щелчка левой кнопкой мыши.

    Ошибочно выбранный символ возможно удалить стандартно клавишами Backspace или Delete.

  6. После того, как нужный символ выбран необходимо нажать кнопку Копировать.

    [Примечание] Примечание

    Вид символов, находящихся в общем списке будет меняться от выбранного шрифта, он выбирается в диалоге Стиль, на закладке Текст.

  7. Для закрытия диалога выбора символов нажмите кнопку Закрыть, диалог Стиль при этом не закроется.

  8. Для вставки выбранного символа в диалоге Стиль в разделе Текст щелкните правой кнопкой мыши, в открывшемся контекстном меню выберите пункт Вставить.

    Диалоговое окно «Стиль»

    Рисунок 388. Диалоговое окно «Стиль»

  9. После произведенных изменений нажмите кнопку ОК.

[Примечание] Примечание

Если введенный текст необходимо отредактировать, тогда войдите в режим выделения объекта - кнопка [image] (слой должен быть редактируемым) и сделайте двойной щелчок левой кнопкой мыши на редактируемом объекте. Все изменения производятся в появившемся диалоговом окне Стиль.

[Примечание] Примечание

Для поворота уже нанесенного текстового объекта надо в режиме выделения объекта ( [image] ) сделать один щелчок левой кнопкой мыши на тексте, после чего вокруг него появится красный квадрат с кружком в правом нижнем углу, затем необходимо сделать щелчок левой кнопкой мыши на этом кружке. Для произвольного поворота текста поверните текст на необходимый угол, и сделайте щелчок левой кнопкой мыши, при повороте новое положение текста показывает прозрачная рамка.

Для поворота текста на заданный угол после нажатия на кружок надо сделать щелчок правой кнопкой мыши и в контекстном меню выбрать пункт Задать угол. После чего задать угол поворота и нажать кнопку ОК.

Для поворота текста параллельно или перпендикулярно какой либо линии после нажатия на кружок надо сделать щелчок правой кнопкой мыши и в контекстном меню выбрать пункт Повернуть параллельно линии или Повернуть перпендикулярно линии соответственно. Затем указать линию, если она находится в активном слое, то надо к ней подвести курсор и сделать щелчок левой кнопкой мыши, если она находится в неактивном слое, то дополнительно еще необходимо нажать на клавиатуре кнопку Ctrl.

Рисунок 389. Поворот текста


Меню типовых объектов

Ввод типовых объектов слоя производится с использованием специального меню. Оно открывается в режиме редактирования слоя нажатием на кнопку выбор типа [image] . В данном меню отображаются только типы и режимы, которые описаны в дереве типов и режимов структуры слоя.

В начале меню выведены режимы, которые использовались недавно для ввода объектов. Далее каждый тип объекта отделен от следующего горизонтальной линией. При желании список последних режимов или режимы любого типа могут быть скрыты, для этого надо сделать щелчок левой кнопкой мыши на стрелке рядом с их названием в меню.

Рисунок 390. Поиск

Поиск по меню

Чтобы найти тип или режим по названию надо в строку Поиск... его ввести, при этом поиск производится по любой части названия:

Рисунок 391. Поиск

Изменение размеров меню

Для удобства ввода объектов размер меню типовых объектов может быть изменен индивидуально. Чтобы изменить размеры меню следует подвести курсор либо к нижнему краю либо к правому нижнему углу, курсор при этом изменит внешний вид. Затем надо сделать щелчок левой кнопкой мыши и не отпуская ее установить нужные размеры, по окончанию надо отпустить кнопку мыши.

Назначение горячих клавиш

Назначение различным режимам горячих клавиш значительно может повысить скорость ввода объектов. Клавиша подключается к наименованию режима, при смене его имени назначение клавиши отменяется. Данные о назначениях хранятся локально на компьютере пользователя.

Для назначения клавиши надо в меню типовых объектов сделать щелчок правой кнопкой мыши рядом с нужным режимом, выбрать пункт Назначить клавишу. Затем в появлявшемся диалоге в строке Буква внести с клавиатуры нужную клавишу, для подтверждения назначения нажать кнопку ОК. Кнопка Отмена закроет диалог без сохранения изменений.

Рисунок 392. Назначение клавиши

После назначения клавиши напротив режима она будет прописана. В дальнейшем при вводе объектов вместо выбора объекта в списке достаточно будет нажать соответствующую клавишу на клавиатуре.

Для изменения/удаления назначения надо повторно в меню типовых объектов сделать щелчок правой кнопкой мыши рядом с нужным режимом, выбрать пункт Назначить клавишу. Затем в появлявшемся диалоге в строке Буква внести с клавиатуры нужную клавишу или удалить назначенную ранее, для подтверждения назначения нажать кнопку ОК


Редактирование объектов

  • «Редактирование группы объектов»

  • «Редактирование элементов объекта»

[Примечание] Примечание

Особенности редактирования объектов инженерной сети дополнительно описаны в разделе «Редактирование сети».

Вы можете произвести следующие операции редактирования:

  • «Перемещение и масштабирование объекта»

  • «Перемещение объекта к заданной точке»

  • «Перемещение символьного или текстового объекта по указанным координатам»

  • «Перемещение символьного или текстового объекта с использованием геометрических преобразований»

  • «Копирование (дублирование) объекта»

  • «Поворот объекта»

    • «Поворот символа или текста на произвольный угол»

    • «Поворот площадного объекта (полигона)»

    • «Поворот полигонов и ломаных параллельно линии»

    • «Поворот символьных и текстовых объектов на заданный с клавиатуры угол»

  • «Изменение стиля и дополнительных параметров объекта»

    • «Изменение параметров простого символьного объекта»

    • «Параметры простого линейного объекта»

    • «Параметры простого площадного объекта»

    • «Параметры типового объекта (символьного, линейного, площадного)»

    • «Параметры простого текстового объекта»

    • «Параметры типового текстового объекта»

  • «Заполнение полигона линиями с заданным шагом»

  • «Разбиение контура»

  • «Сглаживание геометрии объекта»

  • «Упрощение геометрии объекта»

  • «Преобразование полигона в ломаную»

  • «Преобразование ломаной в полигон»

  • «Преобразование ломаных и полигонов в символ»

  • «Преобразование примитивов в типовые объекты»

  • «Преобразование типовых объектов в примитивы»

  • «Удаление объекта»

[Примечание] Примечание

Кроме описанных выше операций изменение геометрии объектов так же возможно с использованием оверлейных операций.


Перемещение и масштабирование объекта

Для перемещения объекта:

  1. Включите редактирование слоя в котором требуется переместить объект ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Подвести курсор к объекту и нажмите левую клавишу мыши (a).

  4. Не отпуская левую клавишу мыши, начните перемещение объекта (b).

    Если перемещаемый объект топологически связан с другими объектами слоя, то эти объекты трансформируются так, чтобы сохранить существующую связь с перемещенным объектом.

    Во время перемещения связи перемещаемого объекта с соседями отображаются инверсными «резиновыми» линиями.

    Если необходимо переместить только сам объект (оторвать его от соседей в любом случае), следует выполнять перемещение с нажатой клавишей Shift. В этом случае захваченный объект будет перемещаться независимо от остальных объектов, но при этом он потеряет существовавшие связи, если таковые имелись.

  5. Отпустите левую клавишу мыши на месте нового положения объекта. Перемещение завершено (c).

Иллюстрация операции перемещения объекта

Рисунок 393. Иллюстрация операции перемещения объекта

Перемещения объекта топологически связанного с другими

Рисунок 394. Перемещения объекта топологически связанного с другими

Перемещение отдельного объекта

Рисунок 395. Перемещение отдельного объекта


Перемещение объекта к заданной точке

Предусмотрено перемещение объекта с совмещением выбранного узла (точки перелома) объекта с заданной точкой на карте. При этом остальные точки объекта перемещаются путем параллельного переноса.

Для выполнения такого перемещения объекта:

  1. Включите редактирование слоя в котором надо переместить объект ( [image] ).

  2. Установите режим Узлы ( [image] ).

  3. Выберите узел перемещаемого объекта. Для этого переместите указатель мыши к требуемому узлу объекта и щелкните левой кнопкой мыши.

  4. Щелкните правой кнопкой мыши в произвольной части карты и в открывшемся контекстном меню выберите пункт Совместить с точкой.

  5. Переместите указатель мыши в точку, с которой надо совместить выбранную точку объекта и щелкните левой кнопкой мыши. Объект будет перемещен.

    Доступно также использование геометрических построений для расчета требуемой точки. Для применения геометрических построений достаточно вместо щелчка левой кнопкой в месте требуемой точки, щелкнуть правой кнопкой мыши в произвольном месте карты и выбрать требуемое геометрическое построение в открывшемся меню.

    Если необходимо «прицепить» перемещаемую точку объекта к любой из уже существующих вершин линии или полигона, одного из слоев карты, являющегося в данный момент активным, то, подведя курсор мыши к этой точке, одновременно с нажатием левой кнопки мыши, следует удерживать нажатым правый Ctrl клавиатуры. При этом, если курсор мыши находился в пределах пяти экранных пикселов от узла активного слоя, устанавливаемая точка получит его координаты (X, Y). Если надо «притянуться» к узлу объекта, находящегося в неактивном слое, тогда при фиксации точки надо удерживать одновременно клавиши Ctrl и Shift.


Перемещение символьного или текстового объекта по указанным координатам

Перемещение по координатам производится с использованием панели Свойства, для открытия панели выберите меню Окно|Свойства или нажмите на панели инструментов кнопку Свойства [image] .

Для перемещения объекта:

  1. Включите редактирование слоя ( [image] ).

  2. Установите режим Узлы ( [image] ).

  3. Подведите к точке привязки объекта и щелкните левой клавишей мыши. При указанная точка должна выделиться. Для отображения всех точек привязки активного слоя можно нажать кнопку [image] .

  4. После выделения точки привязки в окне Свойства отобразятся ее текущие координаты. Они могут отображаться или в метрах (X, Y) или в градусах (Широта, Долгота). Параметры отображения указываются в настройках карты. Измените с клавиатуры координаты на нужные. Новое местоположение в соответствии с указанными данными объект примет сразу при переходе к каким либо другим действиям.


Перемещение символьного или текстового объекта с использованием геометрических преобразований

Перемещение символьного или текстового объекта так же можно сделать с помощью геометрических преобразований.

Для этого:

  1. Включите редактирование слоя, в котором находится объект ( [image] ).

  2. Установите режим Узлы ( [image] ).

  3. Отметьте точку привязки перемещаемого объекта. Для этого подведите к объекту курсор к точке привязки объекта и щелкните левой клавишей мыши. При указанная точка должна выделиться прямоугольником. Для отображения всех точек привязки активного слоя можно нажать кнопку [image] .

  4. Нажмите правую кнопку мыши, после чего на экране появится контекстное меню, изображенное на рисунке ниже:

    Рисунок 396. Контекстное меню

    Для перемещения объектов можно использовать пункты контекстного меню:

    • Направление через точку - при выборе данной опции курсор примет вид [image] , после этого надо левой кнопкой мыши указать точку на карте, через которую будет проходить направляющая линия. Если необходимо «притянуться» к какому либо узлу объекта, находящегося в активном слое, тогда при указании точки необходимо удерживать клавишу Ctrl. В том случае, когда объект, к узлу которого надо «притянуться» находится не в активном слое, при указании точки необходимо удерживать клавиши Ctrl+Shift. После указания точки при движении курсора направляющая линия будет поворачиваться, если щелкнуть левой кнопкой мыши, то она зафиксируется и второй щелчок левой кнопки мыши переместит редактируемый узел в указанную точку. Если сразу после фиксации направляющей линии сделать щелчок правой кнопкой мыши, то на экране появится контекстное меню, рассмотренное в разделе «Ввод простой полилинии (ломаной) с экрана с использованием геометрических построений».

    • Вдоль линии - после выбора данной опции курсор примет вид стрелки с двумя параллельными полосами и левой кнопкой мыши надо указать вдоль какой линии будет перемещен узел. Если линия, вдоль которой должен перемещаться узел находится в активном слое, тогда она указывается щелчком левой кнопки мыши, если же она находится в неактивном слое, то при указании (щелчке левой кнопки мыши) необходимо удерживать клавиши Ctrl+Shift. Повторное нажатие левой кнопки переместит редактируемый узел в указанную точку. Если перед этим нажать правую кнопку мыши, то на экране появится меню, рассмотренное в разделе «Ввод простой полилинии (ломаной) с экрана с использованием геометрических построений».

    • На расстоянии от точки - после выбора данной опции левой кнопкой мыши укажите точку, на расстоянии от которой надо переместить редактируемый узел, точка может как произвольно быть указана на карте, так быть «притянута» к одному из узлов или точек перелома объекта карты или вводимой линии. После указания точки в появившемся окошке введите расстояние. Кнопка ОК подтвердит введенное расстояние, и вокруг указанной точки образуется круг с «бегающей» на нем точкой, точку можно зафиксировать в нужном месте щелчком левой кнопки мыши. Если до фиксации «бегающей» точки щелкнуть правой кнопкой мыши, то появится новое контекстное меню, рассмотренное в разделе «Ввод простой полилинии (ломаной) с экрана с использованием геометрических построений». Если объект, к узлу которого необходимо «притянуть» точку находится в активном слое, тогда она указывается щелчком левой кнопки мыши, если же он находится в любом другом слое, то при указании (щелчке левой кнопки мыши) необходимо удерживать клавиши Ctrl+Shift.

    • На расстоянии от линии - после выбора данной опции левой кнопкой мыши укажите линию, на расстоянии от которой надо переместить редактируемый узел. После указания линии в появившемся окошке введите расстояние. Кнопка ОК подтвердит введенное расстояние, и параллельно указанной линии появится вторая с «бегающей» на ней точкой, точку можно зафиксировать в нужном месте щелчком левой кнопки мыши. Если до фиксации «бегающей» точки щелкнуть правой кнопкой мыши, то появится новое контекстное меню, рассмотренное в разделе «Ввод простой полилинии (ломаной) с экрана с использованием геометрических построений». Если объект, к линии которого необходимо «притянуть» точку находится в активном слое, тогда она указывается щелчком левой кнопки мыши, если же он находится в любом другом слое, то при указании (щелчке левой кнопки мыши) необходимо удерживать клавиши Ctrl+Shift.

    • Отменить действие - отменяет произведенные изменения, отмена будет работать до выхода из режима редактирования.

    • Вернуть действие - возвращает отмененное действие.


Копирование (дублирование) объекта

  • «Дублирование с помощью режима Объект»

  • «Дублирование в режиме Трансформации слоя с экрана»

Копировать (дублировать) объекты можно либо в режиме перемещения одиночного объекта либо в режиме трансформации слоя с экрана. В обеих случаях перемещаемый объект остается на прежнем месте, а на новое место записывается его копия.


Дублирование с помощью режима Объект

Дублирование объекта является одним из способов создания нового объекта. В качестве исходного отмечается один из существующих объектов слоя, и на указанном месте создается новый объект с тем же типом, режимом и той же формы, что и исходный. Действия при дублировании объекта почти полностью совпадают с перемещением объекта с отрывом от сети.

[Примечание] Примечание

При дублировании объекта создается новый элемент, с новым ID. По умолчанию копируется только графическая информация без табличных данных. Для того, чтобы они тоже скопировались в структуре слоя (Слой|Структура слоя), раздел Правила/Редактор надо установить опцию Копировать табличные данные при дублировании объекта.

Для дублирования объекта:

  1. Включите редактирование слоя, в котором необходимо продублировать объект ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Если нужно продублировать объект, который связан с другими, например элемент сети, то для его отрыва нажмите и удерживайте клавишу Shift.

  4. Подведите курсор к объекту для копирования, нажмите и не отпуская, левую клавишу мыши начните перемещение объекта.

    Иллюстрация процесса дублирования объекта

    Рисунок 397. Иллюстрация процесса дублирования объекта

  5. Переместите объект в новое положение. Не отпуская клавишу мыши, нажмите клавишу Ctrl, рядом с курсором появится +.

    Иллюстрация процесса дублирования объекта

    Рисунок 398. Иллюстрация процесса дублирования объекта

  6. Отпустите левую кнопку мыши. После этого клавишу Ctrl можно отпустить. Исходный объект будет продублирован в новое место.

    Иллюстрация процесса дублирования объекта

    Рисунок 399. Иллюстрация процесса дублирования объекта

    Иллюстрация процесса дублирования объекта

    Рисунок 400. Иллюстрация процесса дублирования объекта

Для прерывания процесса дублирования нажмите правую кнопку мыши.


Дублирование в режиме Трансформации слоя с экрана

[Примечание] Примечание

В результате дублирования объекта создается новый элемент, с новым ID. По умолчанию копируется только графическая информация без табличных данных. Для того, чтобы они тоже скопировались в структуре слоя (Слой|Структура слоя), раздел Правила/Редактор надо установить опцию Копировать табличные данные при дублировании объекта.

При использовании данного способа имеется возможность точно указать точки откуда и куда дублировать объект. При этом если дублируются объекты сети, то в результате копирования можно получить связанную сеть. Для дублирования нужно:

  1. Включите редактирование слоя, в котором необходимо продублировать объект ( [image] ).

  2. Установите режим Объект ( [image] ), выделите объект для дублирования:

    Слева исходный объект, справа выделенный

    Рисунок 401. Слева исходный объект, справа выделенный

  3. Нажмите на панели инструментов кнопку Трансформация слоя с экрана - [image] . Курсор примет вид [image] .

  4. Подведите курсор к исходной точке дублирования, нажмите левую кнопку мыши. Если при этом необходимо «прицепиться» к определенной точке, то дополнительно требуется удерживать клавишу Ctrl:

    Исходная точка копирования

    Рисунок 402. Исходная точка копирования

    После указания точка отобразится на карте в виде кружка, а ее координаты будут видны в таблице на панели свойств (если она открыта), курсор примет вид [image] .

  5. Аналогичным образом укажите точку, в которую следует скопировать объект. Она отобразится в виде окружности:

    Итоговая точка копирования

    Рисунок 403. Итоговая точка копирования

  6. В рабочей области карты сделайте щелчок правой кнопкой мыши, в появившемся контекстном меню выберите пункт Дублировать:

    Итоговая точка копирования

    Рисунок 404. Итоговая точка копирования

    В результате проделанных действий графический объект будет скопирован:

    Рисунок 405. Результат копирования

    Рисунок 406. Иллюстрация копирования

[Примечание] Примечание

Описанный выше способ копирования так же подходит и для группы объектов.


Поворот объекта

Далее описаны процедуры поворота следующих объектов:

  • «Поворот символа или текста на произвольный угол»;

  • «Поворот площадного объекта (полигона)»;

  • «Поворот полигонов и ломаных параллельно линии»;

  • «Поворот символьных и текстовых объектов на заданный с клавиатуры угол».


Поворот символа или текста на произвольный угол

Поворот символьного и текстового объекта аналогичен, для поворота:

  1. Включите редактирование слоя в котором надо повернуть объект ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Подведите к объекту курсор, нажмите левую клавишу мыши. Вокруг объекта отобразится рамка с небольшим кружком в одном из ее углов ( Рисунок 407, «Поворот символа» b).

  4. Подведите курсор мыши к кружку, нажмите левую клавишу мыши.

  5. Для произвольного поворота текста или символа поверните текст на необходимый угол, и затем сделайте щелчок левой кнопкой мыши, при повороте новое положение объекта показывает прозрачная рамка (c):

Рисунок 407. Поворот символа


Поворот символьных и текстовых объектов на заданный с клавиатуры угол

Вы можете повернуть символьные и текстовые объекты на заданный c клавиатуры угол. Для выполнения поворота:

  1. Включите редактирование слоя в котором надо повернуть объект ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Подведите курсор к объекту и нажмите левую клавишу мыши, объект выделится.

  4. Щелкните правой кнопкой мыши и в открывшемся контекстном меню выберите Задать угол. Откроется диалог задания угла поворота.

  5. Введите угол поворота и нажмите кнопку ОК.

    Иллюстрация поворота объекта

    Рисунок 408. Иллюстрация поворота объекта


Поворот площадного объекта (полигона)

  1. Включите редактирование слоя в котором надо повернуть объект ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Подведите к объекту курсор, нажмите левую клавишу мыши. Объект выделится.

    Иллюстрация процесса поворота контура

    Рисунок 409. Иллюстрация процесса поворота контура

  4. Установите режим вращения – кнопка [image] .

  5. Сделайте щелчок левой клавишей мыши в предполагаемом центре поворота контура.

  6. Перемещайте мышь до установления нужного угла поворота. Текущее положение вращаемого объекта отображается прозрачным контуром без заливки.

    Иллюстрация процесса поворота контура

    Рисунок 410. Иллюстрация процесса поворота контура

  7. После поворота контура объекта снова сделайте щелчок левой клавишей мыши. Поворот завершен.

    Иллюстрация процесса поворота контура

    Рисунок 411. Иллюстрация процесса поворота контура

Чтобы прервать процесс вращения, нажмите клавишу Esc.


Поворот полигонов и ломаных параллельно линии

Вы можете повернуть полигон или ломаную таким образом, чтобы одно из ребер полигона или сегментов ломаной стали параллельно указанной линии на карте. Для поворота:

  1. Включите редактирование слоя в котором надо повернуть объект ( [image] ).

  2. Установите режим Узлы ( [image] ).

  3. Щелчком левой кнопки мыши выберите ребро полигона или сегмент ломаной.

    Иллюстрация процесса поворота полигона параллельно линии

    Рисунок 412. Иллюстрация процесса поворота полигона параллельно линии

  4. Сделайте щелчок правой кнопкой мыши и в открывшемся контекстном меню выберите пункт Повернуть параллельно линии.

    Иллюстрация процесса поворота полигона параллельно линии

    Рисунок 413. Иллюстрация процесса поворота полигона параллельно линии

  5. Сделайте щелчок левой кнопкой мыши по линии, параллельно которой должна развернуться выбранный сегмент или ребро. Если линия находится в другом слое, при щелчке нажмите и удерживайте клавишу Ctrl.

    Иллюстрация процесса поворота контура параллельно линии

    Рисунок 414. Иллюстрация процесса поворота контура параллельно линии


Изменение стиля и дополнительных параметров объекта

Изменение параметров для каждого вида объекта индивидуально. Например, для простого символьного объекта это может быть смена символа на другой, для типового объекта смена типа или режима, для текстового объекта изменение текста или его стиля. Далее описано изменение параметров для каждого вида объекта отдельно:

  • «Изменение параметров простого символьного объекта»;

  • «Параметры простого линейного объекта»;

  • «Параметры простого площадного объекта»;

  • «Параметры типового объекта (символьного, линейного, площадного)»;

  • «Параметры простого текстового объекта»;

  • «Параметры типового текстового объекта».


Изменение параметров простого символьного объекта

Для изменения параметров простого символьного объекта:

  1. Включите редактирование слоя, в котором находится объект для изменения параметров ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Подведите курсор к объекту и дважды щелкните на нем левой клавишей мыши. На экране появится диалог задания параметров объекта:

    Окно Стиль символьного объекта

    Рисунок 415. Окно Стиль символьного объекта

  4. В данном диалоге вы можете:

    • заменить символ - для этого надо сделать щелчок левой кнопкой мыши по открывающемуся списку символ и указать новый символ для отображения;

    • изменить существующий символ - нажать кнопку Изменить..., подробнее о редактировании символьного объекта можно узнать в разделе «Редактор символов»;

    • нарисовать новый символ - кнопка Новый, подробнее о редактировании символьного объекта можно узнать в разделе «Редактор символов».

    • изменить размер символа - размеры символов из библиотеки символов задаются в относительных единицах (пикселах), для регулирования размеров символов на карте вводится масштабирующий отображение символов коэффициент. В строке размер указывается тот масштаб карты, при котором символ будет отображаться в размере 1:1 как он был создан в редакторе символов;

      [Примечание] Примечание

      Возможно изменить размер одновременно для всех символов слоя, это можно произвести с использованием масштабирующего коэффициента, подробней.

    • задать цвет символа - цвет символу можно задать только в том случае, когда при его создании в редакторе символов его цвет узора был выбран как авто.

    • задать масштабирование символа - флажок Масштабировать регулирует изменение размеров символа при изменении масштаба карты. Если установлен флажок Не увеличивать больше указанного размера, то при уменьшении масштаба карты меньше указанного в строке размер, символ больше увеличиваться не будет.

  5. После изменения параметров нажмите кнопку ОК.


Параметры простого линейного объекта

Для изменения параметров простого линейного объекта:

  1. Включите редактирование слоя, в котором находится объект для изменения параметров ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Подведите курсор к объекту и дважды щелкните на нем левой клавишей мыши. На экране появится диалог задания параметров объекта:

    Окно Стиль для простого линейного объекта

    Рисунок 416. Окно Стиль для простого линейного объекта

  4. Для простого линейного объекта можно изменить:

    • цвет;

    • стиль линии - если в списке стилей нет нужного, то его можно создать самостоятельно;

    • толщину на экране;

    • толщину при печати;

      [Примечание] Примечание

      Масштаб на карте может быть представлен в двух вариантах: геодезическом и в сантиметрах на пиксель. Выбор нужного масштаба осуществляется в параметрах системы.

    • настроить масштабирование линии - если необходимо чтобы линия изменяла свою толщину, пропорционально масштабу отображения карты, то надо установить опцию Масштабировать и в окне Масштаб 1:1 ввести требуемый масштаб.

  5. После изменения параметров нажмите кнопку ОК.

[Подсказка] Подсказка

Стиль объекта можно скопировать/вставить, вызвав контекстное меню правой кнопкой мыши.


Параметры простого площадного объекта

Для изменения параметров простого площадного объекта:

  1. Включите редактирование слоя, в котором находится объект для изменения параметров ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Подведите курсор к объекту и дважды щелкните на нем левой клавишей мыши. На экране появится диалог задания параметров объекта:

  4. Окно Стиль для простого площадного объекта

    Рисунок 417. Окно Стиль для простого площадного объекта

  5. Для простого линейного объекта можно изменить:

    • цвет фона - выбрать из списка новый цвет;

    • цвет узора - выбрать из списка новый узор, если в списке узоров нет нужного, то его возможно создать самостоятельно. Для узоров, отличающихся от сплошной заливки по умолчанию цвет фона не отображается, для отображения надо установить опцию отображать фон;

    • прозрачность - устанавливается только при сплошной заливке, значение прозрачности задается в процентах от 0 до 100.

    • цвет линии - возможно поменять для границы площадного объекта цвет;

    • стиль - изменить стиль для границы площадного объекта, если в списке стилей нет нужного, то его можно создать самостоятельно;

    • толщину на экране - толщина отображения на экране границы площадного объекта;

    • толщину при печати - толщина при печати для границы площадного объекта.

  6. После изменения параметров нажмите кнопку ОК.

[Подсказка] Подсказка

Стиль объекта можно скопировать/вставить, вызвав контекстное меню правой кнопкой мыши.


Параметры типового объекта (символьного, линейного, площадного)

[Предупреждение] Предупреждение

Чтобы при смене типа объекта были сохранены семантические данные совпадающих полей необходимо сделать соответствующие настройки в структуре слоя!

Для типового объекта смена параметров объекта сводится к заданию нового режима и/или типа. В окне диалога содержится список типов объектов, которые могут быть выбраны в качестве нового типа для изменяемого объекта (для узлового объекта только узлы, для участка - только линейные). Причем менять тип объекта можно только на тот тип, который имеет то же количество связей (участков). Например, в тепловой сети нельзя менять тепловую камеру, в который входит и выходит трубопровод на потребителя, так как потребитель должен быть конечным объектом. В окошке Режим диалога выводится список режимов, соответствующих типу, выбранному в окошке Тип.

[Примечание] Примечание

Имеется еще один вариант смены режима объекта без использования режим редактирования, подробней можно узнать в разделе «Смена типа/режима объекта или направления участка сети».

Для изменения параметров типового объекта:

  1. Включите редактирование слоя, в котором находится объект для изменения параметров ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Подведите курсор к объекту и дважды щелкните на нем левой клавишей мыши. На экране появится диалог задания параметров объекта.

  4. Смена режима для узлового (символьного) типового объекта:

    Окно изменения режима/типа для узлового объекта

    Рисунок 418. Окно изменения режима/типа для узлового объекта

    Смена режима для участка (линейного типового объекта):

    Окно изменения режима/типа для участка

    Рисунок 419. Окно изменения режима/типа для участка

    Опция Сменить направление появляется только если изменяемый объект - участок. Выбор данной опции и нажатие кнопки ОК изменяет направление участка на противоположное, то есть изменяет направление стрелки.

[Подсказка] Подсказка

Если необходимо поменять символ (или стиль отображения) для отображения типового объекта, то это можно сделать в диалоге Структура слоя.


Параметры простого текстового объекта

Для простого текстового объекта изменение параметров осуществляется в двух вкладках диалога Стиль: Текст и Параметры.

На вкладке Текст возможно задать:

  • имя шрифта – раздел Шрифт;

  • начертание шрифта – раздел Начертание;

  • стиль шрифта – раздел Текст;

  • набор шрифта - список Набор (Юникод, Арабский, Балтийский, Вьетнамский, Греческий, Западный, Иврит, Кириллический, Турецкий, Центральноевропейский);

  • цвет шрифта (одновременно для всего текста) – открывающееся окно Цвет (если необходимо чтобы текст был разных цветов, то нужно задавать специальные параметры, подробней см. ниже);

  • параметры фона шрифта – раздел Фон.

    Окно Стиль для текстового объекта. Вкладка Текст

    Рисунок 420. Окно Стиль для текстового объекта. Вкладка Текст

На вкладке Параметры задаются:

  • высота на местности, то есть размер текста (см.) – строка Высота;

  • угол наклона текста (град.) – строка Угол;

  • содержание текста – окно Текст;

    [Примечание] Примечание

    В том случае, если необходимо чтобы текст в одном текстовом объекте был разных цветов, то нужно указать с помощью специального тэга цвет в шестнадцатеричной системе в палитре GBR.

    Условие для цвета задается следующим образом:

    {\C цвет} текст {\C} текст...

    Основные цвета в шестнадцатеричной системе в палитре GBR:

    • 000000 - черный;

    • 0000FF- красный;

    • 008000 - зеленый;

    • FF0000 - синий;

    • 00FFFF - желтый;

    • 808080 - серый;

    • FFFFFF - белый.

    Рассмотрим задание цвета на конкретном примере, предположим необходимо, чтобы название улицы отображалось следующим образом: , то есть слово улица черным цветом, часть названия красным, а затем опять черным цветом. Для вывода данных таким образом в окне Текст необходимо ввести:

    улица {\C0000FF}Большая{\C} Конюшенная

    Если в приведенном выше примере название улицы нужно было бы все отображать красным цветом, то конечный тэг {\C} для закрытия цвета можно было бы не вводить:

    улица {\C0000FF}Большая Конюшенная

  • выравнивание относительно точки привязки – раздел Положение относительно точки привязки;

  • при многострочном тексте - выравнивание (лево, центр, право);

  • кнопка Символы вызывает диалоговое окно Выбор символов, которое позволяет вставить специальные символы, находящиеся в выбранном шрифте.

    Окно Стиль для простого текстового объекта. Вкладка Параметры

    Рисунок 421. Окно Стиль для простого текстового объекта. Вкладка Параметры

После изменения параметров нажмите кнопку ОК.


Параметры типового текстового объекта

Для типового текстового объекта возможно сменить тип и/или режим, отредактировать текст или сменить угол наклона текста:

  • для смены типа или режима выберите тип или режим из соответствующих открывающихся списков;

  • для смены угла текста введите с клавиатуры новое значение в окошко Угол;

  • для занесения символа нажмите кнопку Символы, работа с символами производится точно так же как при вводе текста (подробней см. «Ввод специальных символов»);

  • новый текст можно ввести в окно Текст.

    Окно Параметры текста для типового текстового объекта

    Рисунок 422. Окно Параметры текста для типового текстового объекта

После изменения параметров нажмите кнопку ОК.


Разбиение контура

[Примечание] Примечание

Для данной операции вы можете настроить правила редактора.

Используя данную операцию возможно разбить (разделить) площадной объект (контур) ломаной линией по указанным вершинам.

[Примечание] Примечание

Разделение объектов так же возможно с использованием оверлейных операций.

Для разбиения объекта:

  1. Включите редактирование слоя в котором находится объект ( [image] ).

  2. Установите режим Узлы ( [image] ).

  3. Подведите к объекту курсор и щелкните левой клавишей мыши. При этом должны выделиться все вершины (узлы) отмеченного объекта.

    Рисунок 423. Разделение объекта

  4. Нажмите на панели инструментов кнопку Разбить - [image] .

  5. Подведите курсор к первой вершине (узлу) разделяемого полигона, нажмите левую клавишу мыши. После чего от указанной вершины объекта будет протянута «резиновая» линия.

  6. Если разделение требуется не по прямой линии, то последовательно перемещайте курсор мыши к очередной точке ломаной и фиксируйте эту точку нажатием левой кнопки мыши. Если требуется разделение прямой линией, данный пункт пропустите.

  7. Подведите курсор к вершине полигона, на которой должна закончиться линия разделения и сделайте двойной щелчок левой кнопкой мыши.

    Рисунок 424. Разбиение объекта

    [Примечание] Примечание

    Если на разделяемом объекте не хватает узлов для разделения, то их можно добавить.

    Рисунок 425. Результат разделения

    Рисунок 426. Иллюстрация разделения

В результате проделанных действий объект будет разделен на два объекта ломаной по указанным вершинам. При этом у получившихся объектов будет общая сторона и если один из них начать перемещать, то второй потянется за ним. Для отсоединения объектов при перемещении следует держать нажатой клавишу Shift.


Заполнение полигона линиями с заданным шагом

В результате операции по форме выбранного полигона будет создан новый объект состоящий из множества линий указанного стиля с заданным шагом.

Пример заполнения линиями полигона

Рисунок 427. Пример заполнения линиями полигона

[Примечание] Примечание

Ширина шага между заполняемыми линиями задается по проекции.

Для заполнения полигона линиями:

  1. Сделайте активным и редактируемым слой, в котором надо заполнить полигон ( [image] ).

  2. Задайте стиль для линий заполнения, для этого нажмите кнопку [image] . Недостающие стили можно создать самостоятельно в структуре слоя.

  3. Установите режим Объект ( [image] ).

  4. Выделите полигон для заполнения.

  5. Сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Заполнить полигон линиями.

  6. Далее необходимо задать направление линий заполнения, для этого щелчком левой кнопки мыши надо указать две точки. Если необходимо указать точку в одной из уже существующих вершин линии или полигона текущего слоя, то подведя курсор мыши к этой точке, одновременно с нажатием левой кнопки мыши, следует удерживать нажатым правый Ctrl клавиатуры. В этом случае создаваемый объект будет «прикреплен» к указанной точке. Для захвата точки в неактивном слое следует удерживать клавиши Ctrl и Shift.

  7. В появившемся окне задайте в метрах шаг штриховки, нажмите кнопку ОК. Операция завершена.

[Примечание] Примечание

Созданный объект из множества линий возможно разделить на отдельные линии.


Сглаживание геометрии объекта

Операция сглаживания геометрии позволяет производить сглаживание площадных (полигонов) и линейных (ломаных) объектов. В результате путем добавления множества вершин будут сглажены прямые ребра и ломаные углы объектов, угловатая форма будет заменена плавными линиями. Ниже приведен пример сглаживания для полигона и ломаной:

Пример сглаживания для полигона и ломаной. Черный цвет исходные объекты, красный - результат сглаживания.

Рисунок 428. Пример сглаживания для полигона и ломаной. Черный цвет исходные объекты, красный - результат сглаживания.

При сглаживании возможно использовать несколько методов с различными параметрами, что дает возможность получить соответственно разные результаты.

Одновременно со сглаживанием может быть применено упрощение геометрии объекта. Чтобы видеть изменение количества вершин вы можете включить режим Отображать узлы [image] .

Для сглаживания объекта:

  1. Включите редактирование слоя, в котором надо сгладить объект ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Нажатием левой кнопки мыши отметьте объект для сглаживания.

    [Примечание] Примечание

    Вы можете работать не только с одним объектом, но и одновременно с группой объектов. Для этого их надо выделить.

  4. Сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Сгладить геометрию.

  5. Из списка выберите метод сглаживания:

    • Чайкин - рекурсивный метод сглаживания углов Чайкина. Алгоритм, позволяющий сглаживать каждый угол объекта по отдельности. К данному алгоритму дополнительно необходимо задать:

      • Отношение - расположение точек сглаживания на ребрах в процентах от угла.

      • Число - количество итераций алгоритма, каждая итерация увеличивает количество точек вдвое.

    • Свертка - метод свертки, генерализует исходную кривую. Свертка является фильтром, который в зависимости от степени сглаживания устраняет те или иные детали исходной линии. Дополнительно необходимо задать:

      • Сглаживающий Фильтр:

        • Парабола;

        • Экспонента;

        • Треугольник;

        • Гауссиан.

      • Ширина фильтра - определяет степень генерализации (сглаживания), задавая данный параметр необходимо учесть что при использовании больших величин сглаживание будет более плавным, но результат будет выходить за пределы исходного объекта.

      • Масштаб фильтра - выбирается масштаб фильтра, при выборе Авто - берется процент от средней величины сегмента, применяется при одновременном сглаживании объектов разного калибра.

      • Число точек - количество точек на сегмент, выбирается в зависимости от размеров объекта, увеличенное количество точек может значительно увеличить время сглаживания объектов. При одновременном сглаживании нескольких объектов разного калибра для идентичного сглаживания возможно взять увеличенное число точек, и дополнительно установить опцию Применять в разделе Упрощение после сглаживания.

  6. Одновременно со сглаживанием возможно упрощение геометрии объекта, для его применения надо в разделе Упрощение после сглаживания установить опцию Применять и задать точность упрощения в метрах.

    Диалог сглаживания объектов

    Рисунок 429. Диалог сглаживания объектов

  7. Для подтверждения операции нажмите кнопку ОК.


Упрощение геометрии объекта

Функция Упростить геометрию уменьшает количество вершин и упрощает форму объектов используется алгоритм Дугласа — Пекера.

Результат зависит от Точности упрощения - максимальное расстояние, которое может быть между исходной и упрощённой полилиниями (то есть, максимальное расстояние от точек исходной к ближайшему участку полученной полилинии). Упрощенная полилиния состоит из подмножества точек, которые определяются из исходной.

Применяется для линейных, площадных объектов, а также для инженерных сетей (с сохранением топологических связей).

Задание точности упрощения

Рисунок 430. Задание точности упрощения

Упрощение ломаной черная до упрощения, красная после

Рисунок 431. Упрощение ломаной черная до упрощения, красная после

Чтобы видеть изменение количества вершин вы можете включить режим Отображать узлы [image] .

Для упрощения геометрии объекта:

  1. Включите редактирование слоя, в котором надо упростить объект ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Отметьте объект для сглаживания, щелкнув на нем левой клавишей мыши.

    [Примечание] Примечание

    Вы можете работать не только с одним объектом, но и одновременно с группой объектов. Для этого их надо выделить.

  4. Сделайте щелчок правой кнопкой мыши и в контекстом меню выберите пункт Упростить геометрию.

  5. В открывшемся окне укажите Точность упрощения в метрах.

  6. Для подтверждения нажмите кнопку ОК.


Преобразование полигона в ломаную

Для преобразования полигона:

  1. Включите редактирование слоя с полигонами ( [image] ).

  2. Если преобразовать надо группу объектов, то выделите их. Если один объект,то пропустите данный пункт.

  3. Установите режим Объект ( [image] ).

  4. Преобразование объекта производится в соответствии с настроенным стилем ломаных объектов. При необходимости поменяйте стиль.

  5. Нажмите клавишу Shift и не отпуская ее сделайте двойной щелчок по объекту. На экране появится окно Объекты для изменения параметров группы.

    [Примечание] Примечание

    Диалог Объекты для изменения параметров группы вы так же можете вызвать выделив объекты, сделав щелчок правой кнопкой мыши в области карты и выбрав пункт Свойства объектов. Или выделив объекты и выбрав меню Правка|Свойства объектов.

  6. Если работа производится с несколькими объектами, проверьте чтобы в списке слева был выделен нужный графический тип объекта. Нажмите кнопку Преобразовать в линии.

    Диалоговое окно изменения параметров объектов

    Рисунок 432. Диалоговое окно изменения параметров объектов

    Иллюстрация преобразования полигонов в ломаную

    Рисунок 433. Иллюстрация преобразования полигонов в ломаную


Преобразование ломаной в полигон

Для преобразования ломаной:

  1. Включите редактирование слоя с объектами ( [image] ).

  2. Если преобразовать надо группу объектов, то выделите их. Если один объект,то пропустите данный пункт.

  3. Установите режим Объект ( [image] ).

  4. Преобразование объекта производится в соответствии с настроенным стилем полигонов. При необходимости поменяйте стиль.

  5. Нажмите клавишу Shift и не отпуская ее сделайте двойной щелчок по объекту. На экране появится окно Объекты для изменения параметров группы.

    [Примечание] Примечание

    Диалог Объекты для изменения параметров группы вы так же можете вызвать выделив объекты, сделав щелчок правой кнопкой мыши в области карты и выбрав пункт Свойства объектов. Или выделив объекты и выбрав меню Правка|Свойства объектов.

  6. Если работа производится с несколькими объектами, проверьте чтобы в списке слева был выделен нужный графический тип объекта. Нажмите кнопку Преобразовать в контуры.

    Диалоговое окно изменения параметров объектов

    Рисунок 434. Диалоговое окно изменения параметров объектов

  7. На экране появиться окно задания окрестности для замыкания контура. В нем необходимо задайте область в которой система будет замыкать контур. Если расстояние между полилиниями больше заданной области, то преобразования в контуры не произойдет.

  8. Нажмите кнопку ОК.

    Иллюстрация преобразования ломаных в полигон

    Рисунок 435. Иллюстрация преобразования ломаных в полигон


Преобразование ломаных и полигонов в символ

Вы можете преобразовать указанные полигоны или ломаные на выбранный символ.

Для преобразования объектов в символ:

  1. Включите редактирование слоя.

  2. Укажите символ на который будет производиться замена. Для этого нажмите на панели инструментов кнопку Символ для ввода [image] и если символ уже существует, то из открывающегося списка Символ выберите его. Если символа нет, то создайте его (кнопка Новый).

    В строке размер задайте размер символа. Поскольку размеры символов из библиотеки символов задаются в относительных единицах (пикселях), то заранее неизвестно, какого размера они будут на той или иной карте, так как слой может создаваться для масштабов области, города, квартала, помещения. Чем больше значение коэффициента, тем крупнее будут выглядеть символы на карте (при одном и том же масштабе карты).

    Если у символа цвет узора задан как авто, то дополнительно цвет выберите из списка цвет. Если цвет узора уже был указан при создании символа, то этого делать не надо.

  3. Если преобразовать надо группу объектов, то выделите их. Если один объект,то пропустите данный пункт.

  4. Нажмите клавишу Shift и не отпуская ее сделайте двойной щелчок по объекту. На экране появится окно Объекты для изменения параметров группы.

    [Примечание] Примечание

    Диалог Объекты для изменения параметров группы вы так же можете вызвать выделив объекты, сделав щелчок правой кнопкой мыши в области карты и выбрав пункт Свойства объектов. Или выделив объекты и выбрав меню Правка|Свойства объектов.

  5. Если работа производится с несколькими объектами, проверьте чтобы в списке слева был выделен нужный графический тип объекта. Нажмите кнопку Преобразовать в символы.

После проделанных действий каждый выделенные объекты будут преобразованы в выбранный символ.


Преобразование примитивов в типовые объекты

Вы можете преобразовать простые объекты (примитивы) в типовые объекты. Для осуществления данной операции в структуре слоя должны быть созданы типы и режимы в которые производится преобразование. Преобразовать возможно только объекты одного графического типа.

[Примечание] Примечание

Если вам надо преобразовать простые объекты в сеть, то вы можете воспользоваться соответствующей операцией.

Для преобразования в типовые объекты:

  1. Включите редактирование слоя с объектами ( [image] ).

  2. Если преобразовать надо группу объектов, то выделите их. Если один объект,то пропустите данный пункт.

  3. Установите режим Объект ( [image] ).

  4. Нажмите клавишу Shift и не отпуская ее сделайте двойной щелчок по объекту. На экране появится окно Объекты для изменения параметров группы.

    [Примечание] Примечание

    Диалог Объекты для изменения параметров группы вы так же можете вызвать выделив объекты, сделав щелчок правой кнопкой мыши в области карты и выбрав пункт Свойства объектов. Или выделив объекты и выбрав меню Правка|Свойства объектов.

  5. Если работа производится с несколькими объектами, проверьте чтобы в списке слева был выделен нужный графический тип объекта. Нажмите кнопку Сделать типовым.

    Диалоговое окно изменения параметров объектов

    Рисунок 436. Диалоговое окно изменения параметров объектов

  6. На экране появиться диалог Смена режима. В верхнем разделе Тип выберите тип объекта, в нижнем Режим, соответственно режим объекта.

    [Примечание] Примечание

    Если диалог Смена режима не появился, значит в структуре слоя отсутствуют подходящие режимы для преобразования.

  7. Нажмите кнопку ОК.


Преобразование типовых объектов в примитивы

Вы можете преобразовать типовые объекты в примитивы.

Для преобразования:

  1. Включите редактирование слоя с объектами ( [image] ).

  2. Если преобразовать надо группу объектов, то выделите их. Если один объект,то пропустите данный пункт.

  3. Установите режим Объект ( [image] ).

  4. Нажмите клавишу Shift и не отпуская ее сделайте двойной щелчок по объекту. На экране появится окно Объекты для изменения параметров группы.

    [Примечание] Примечание

    Диалог Объекты для изменения параметров группы вы так же можете вызвать выделив объекты, сделав щелчок правой кнопкой мыши в области карты и выбрав пункт Свойства объектов. Или выделив объекты и выбрав меню Правка|Свойства объектов.

  5. Если работа производится с несколькими объектами, проверьте чтобы в списке слева был выделен нужный графический тип объекта. Нажмите кнопку Сделать примитивом.

    Диалоговое окно изменения параметров объектов

    Рисунок 437. Диалоговое окно изменения параметров объектов

  6. На экране появиться диалог Стиль. Настройте в нем стиль для примитивов и нажмите кнопку ОК.


Удаление объекта

[Предупреждение] Предупреждение

  • Если объект является частью инженерной сети и расположен не в начале или конце участка так удалять его нельзя! Как удалить не конечный объект участка можно узнать в разделе «Исключение символьного объекта из нанесенной сети (объединение последовательно соединенных участков)».

  • Отменить произведенное действие вы можете нажатием кнопки [image] на панели инструментов или комбинацией клавиш Ctrl и Z. Отмена действий возможна только до выхода из режима редактирования слоя!

  • По умолчанию, если удаленному объекту соответствовала запись в базе данных, то для удаления этой записи базу данных необходимо сжать, для этого надо выбрать меню Карта|Запрос|По базе данных, в открывшемся диалоговом окне выбрать слой, и нажать кнопку Сжать. Так же возможно настроить правила редактора на удаление, в результате применения которых при удалении объекта запись так же будет удалена. Но в этом случае при отмене удаления (Ctrl и Z) семантические данные объекта будут потеряны!

Для удаления объекта:

  1. Включите редактирование слоя с удаляемым объектом - [image] .

  2. Установите режим Объект - [image] .

  3. Отметьте удаляемый объект, щелкнув на нем левой клавишей мыши.

  4. Нажмите на панели инструментов кнопку [image] или клавишу Delete на клавиатуре или сделайте щелчок правой кнопкой мыши и выберите пункт Удалить. Объект будет удален.


Редактирование группы объектов

Для работы с группой объектов эту группу предварительно необходимо выделить:

  • «Выделение группы объектов слоя».

Возможны следующие операции с группой объектов:

  • «Перемещение и масштабирование группы объектов»;

  • «Поворот группы объектов» («Поворот группы на произвольный угол», «Поворот группы на заданный с клавиатуры угол»);

  • «Копирование (дублирование) группы объектов»;

  • «Сглаживание геометрии группы объектов»;

  • «Запись группы объектов в другой слой»;

  • «Упрощение геометрии группы объектов»;

  • «Копирование группы в буфер обмена»;

  • «Изменение параметров группы объектов»;

  • «Отмена группы»;

  • «Удаление группы объектов».


Перемещение и масштабирование группы объектов

Для перемещения группы:

  1. Включите редактирование слоя с объектами ( [image] ).

  2. Установите режим Объект [image] .

  3. Для перемещения группы. Подведите курсор к одному из объектов, входящих в группу. Нажмите и не отпускайте левую клавишу мыши. По габаритам объектов, входящих в группу, отобразится рамка. Переместите объекты в нужное место и отпустите левую клавишу мыши.

    Иллюстрация перемещения объектов

    Рисунок 438. Иллюстрация перемещения объектов

    Если необходимо переместить группу объектов с отрывом от соседних объектов, не входящих в группу (например, некоторые объекты нужно оторвать от сети), то перед перемещением нажмите и удерживайте клавишу Shift. В этом случае захваченная группа объектов будет перемещаться независимо от остальных объектов, но при этом он потеряет существовавшие связи, если таковые имелись.

    [Примечание] Примечание

    Для прерывания процесса перемещения можно нажать правую клавишу мыши.

    Для масштабирования группы. Подведите курсор к одному из маленьких черные квадратики, которые появились в углах и на ребрах рамки, и не отпуская левой клавиши мыши измените размер группы. Для завершения масштабирования отпустите левую клавишу мыши.

    Иллюстрация масштабирования объектов

    Рисунок 439. Иллюстрация масштабирования объектов


Поворот группы объектов

Вы можете повернуть группу объектов на заданный угол или на произвольный угол с помощью мышки.

  • «Поворот группы на произвольный угол»

  • «Поворот группы на заданный с клавиатуры угол»


Поворот группы на произвольный угол

[Предупреждение] Предупреждение

При работе с данными с сервера операция поворота группы объектов группы на произвольный угол отката (возврата) не имеет!

Для поворота группы:

  1. Включите редактирование слоя с объектами ( [image] ).

  2. Установите режим Объект [image] .

  3. Нажмите кнопку Вращать [image] .

  4. Щелкните левой кнопкой мыши по одному из объектов группы начав этим процесс вращения.

  5. Переместите указатель мыши, при этом будет отображаться контур группы, показывающий положение группы после поворота.

  6. Щелкните левой кнопкой мыши для выполнения поворота.

    Иллюстрация поворота объектов

    Рисунок 440. Иллюстрация поворота объектов

Чтобы прервать процесс вращения, либо задать точный угол поворота, нажмите правую кнопку мыши и выберите соответствующий пункт открывшегося меню.


Поворот группы на заданный с клавиатуры угол

Поворот на заданный с клавиатуры угол возможен только для таких объектов как символ и текст. Для выполнения поворота группы на заданный угол:

  1. Включите редактирование слоя с объектами ( [image] ).

  2. Установите режим Объект [image] .

  3. Щелкните правой кнопкой мыши и в открывшемся контекстном меню выберите пункт Задать угол. Откроется диалог задания угла поворота.

  4. Введите угол поворота и нажмите кнопку ОК.

    Для того чтобы отменить выполнение поворота, нажать кнопку Отмена.


Копирование (дублирование) группы объектов

  • «Дублирование группы в режиме Объект»

  • «Дублирование группы в режиме трансформации слоя с экрана»

Дублирование группы объектов является одним из способов создания новых объектов. В качестве исходных объектов берется выделенная группа объектов редактируемого слоя, и на указанном месте создается новый набор объектов с тем же типами, режимами, той же формы и с тем же взаимным расположением друг относительно друга, что и объекты исходной группы. Дублировать (копировать) группу объектов можно либо в режиме Объект либо в режиме трансформации слоя с экрана.


Дублирование группы в режиме Объект

[Примечание] Примечание

По умолчанию происходит дублирование только графических данных, если требуется копировать и данные из таблиц, то для этого надо сделать дополнительную настройку. Чтобы табличные данные тоже копировались необходимо в структуре слоя (Слой|Структура слоя) в разделе Правила/Редактор установить опцию Копировать табличные данные при дублировании объекта.

Для дублирования группы в режиме Объект:

  1. Включите редактирование слоя с объектами ( [image] ).

  2. Установите режим Объект [image] .

  3. Если объекты дублируемой группы топологически связаны с другими объектами слоя (например объекты инженерной сети), то нажмите и удерживайте клавишу Shift. Если группа с другими объектами не связана, то пропустите данный пункт.

  4. Подведите курсор к любому из объектов, входящих в группу, нажмите не отпуская, левую клавишу мыши начните перемещение объектов.

  5. Переместите объекты в новое положение. Не отпуская клавишу мыши, нажмите клавишу Ctrl (если в этот момент удерживалась клавиша Shift, то отпустите ее). Потом отпустить левую клавишу мыши на месте нового положения группы объектов. Дублирование завершено.

    Иллюстрация дублирования группы объектов не имеющих топологических связей

    Рисунок 441. Иллюстрация дублирования группы объектов не имеющих топологических связей

    Иллюстрация дублирования группы объектов имеющих топологические связи

    Рисунок 442. Иллюстрация дублирования группы объектов имеющих топологические связи

Для прерывания процесса дублирования нажмите правую клавишу мыши.


Дублирование группы в режиме трансформации слоя с экрана

[Примечание] Примечание

По умолчанию происходит дублирование только графических данных, если требуется копировать и данные из таблиц, то для этого надо сделать дополнительную настройку. Чтобы табличные данные тоже копировались необходимо в структуре слоя (Слой|Структура слоя) в разделе Правила/Редактор установить опцию Копировать табличные данные при дублировании объекта.

При использовании данного способа имеется возможность точно указать точки откуда и куда дублировать объекты. При этом если дублируются объекты сети, то в результате можно получить связанную сеть. Для дублирования нужно:

  1. Включите редактирование слоя с объектами ( [image] ).

  2. Выделите группу объектов:

    Выделенная группа объектов

    Рисунок 443. Выделенная группа объектов

  3. Нажмите на панели инструментов кнопку Трансформация слоя с экрана ( [image] ). Курсор примет вид [image] .

  4. Подведите курсор к исходной точке дублирования, нажмите левую кнопку мыши (если при этом необходимо «прицепиться» к определенной точке, то дополнительно требуется удерживать клавишу Ctrl):

    Исходная точка дублирования

    Рисунок 444. Исходная точка дублирования

    После указания точка отобразится на карте в виде кружка, а ее координаты будут видны в таблице на панели свойств системы (если она открыта), курсор примет вид [image] .

  5. Аналогичным образом укажите точку, в которую следует скопировать объекты. Она отобразится в виде окружности:

    Итоговая точка копирования

    Рисунок 445. Итоговая точка копирования

  6. В рабочей области карты сделайте щелчок правой кнопкой мыши, в открывшемся контекстном меню выберите пункт Дублировать:

    Итоговая точка копирования

    Рисунок 446. Итоговая точка копирования

    В результате проделанных действий группа объектов будет скопирована:

    Рисунок 447. Результат копирования

В приведенном выше примере при копировании объектов сети были при указании точек копирования была удержана клавиша Ctrl, в результате чего скопированные объекты связаны с исходной сетью:

Рисунок 448. Результат копирования

Рисунок 449. Иллюстрация дублирования


Сглаживание геометрии группы объектов

Данная операция позволяет производить сглаживание площадных (полигонов) и линейных (ломаных) групп объектов. Для более качественного результата желательно чтобы объекты группы для сглаживания были приблизительно одинакового размера, при существенных отличиях в размерах объектов одинаковые параметры сглаживания для них могут не подойти.

Подробно сглаживание объектов описано в разделе «Сглаживание геометрии объекта».


Упрощение геометрии группы объектов

Функция Упростить геометрию уменьшает количество вершин и упрощает форму объектов (используется алгоритм Дугласа — Пекера).

Для упрощения геометрии надо:

  1. Выделить группу объектов.

  2. Упростить геометрию точно так же как и у одиночного объекта.


Запись группы объектов в другой слой

[Предупреждение] Предупреждение

Проверьте, совпадают ли структуры исходного слоя и слоя для записи. Также следует учитывать соответствие типов полей и длины Строковых полей.

[Примечание] Примечание

Видео урок Объединение слоев доступен по следующей ссылке http://www.politerm.com/videos/layeredit/layer_grouprecord/.

Для того чтобы записать группу объектов из одного слоя в другой предварительно загрузите эти слои в текущую карту. Далее:

  1. Выделите группу объектов для записи.

  2. Выберите пункт меню Карта|Группа|Записать.

  3. В появившемся диалоговом окне выберите исходный слой объекты которого будут записаны в другой слой (воспользуйтесь кнопкой Обзор...).

  4. Выберите слой, куда будет происходить запись (воспользуйтесь кнопкой Обзор...). Слой должен находиться в той же карте, где находится исходный слой.

  5. Выберите как будет произведено копирование.

    Диалоговое окно Запись группы в другой слой

    Рисунок 450. Диалоговое окно Запись группы в другой слой

    1. Наследовать ключи, в этом случае у объектов сохраняются те же ключи (ID), что и в исходном слое.

      [Предупреждение] Предупреждение

      При совпадении ключей объектов в слое для записи и в исходном слое, объекты с совпадающими ключами будут уничтожены, и вместо них скопированы объекты из исходного слоя, что может привести к потере данных!

    2. Объединять базы атрибутов. Если в слое, куда будет копироваться группа уже имеется база данных, имеющая такие поля,которым в слое для записи будет найдено соответствие, то тогда группа запишется с сохранением данных (то есть со всей семантической информацией).

      При выборе опции Объединять базы атрибутов имеется возможность создать протокол изменение ключей (ID), для этого надо установить соответствующую галочку. Создание протокола возможно только при работе с локальными данными. Данный протокол отобразится в окне Сообщения, и будет содержать список как предыдущих ключей группы, так и новых. Ключи (ID) будут перечислены в столбик: старый ID, новый ID.

    3. Перенос надписей - если в исходном слое имеются надписи (бирки), то при установке данной опции они так же будут записаны в слой для записи.

  6. Нажмите кнопку ОК.


Копирование группы в буфер обмена

Группу любого активного слоя (не обязательно редактируемого) можно скопировать в буфер обмена Windows нажатием кнопки [image] .

Если активный слой редактируемый, то можно удалить группу объектов, одновременно скопировав ее в буфер обмена (вырезать) нажатием кнопки [image] .

Скопировав группу в буфер в одном слое, ее можно вставить в другой, обязательно редактируемый слой, если его структура и графический формат совместим с данными из буфера. Для этого нужно нажать кнопку [image] .

[Примечание] Примечание

  • Для типового объекта при копировании его из слоя в слой через буфер обмена копируются и все параметры объекта: тип, все режимы, символы, которыми каждый режим обозначается и т. п. Таким образом, при копировании типового объекта происходит изменение структуры слоя-получателя.

  • Система запрещает вставлять данные из буфера в тот слой, который эти данные туда и скопировал.


Изменение параметров группы объектов

В зависимости от объектов входящих в группу вы можете изменить те или иные параметры. Например, для типовых объектов изменить режим или тип объекта, линейные объекты преобразовать в контуры и др.

Для изменения параметров отображения группы:

  1. Включите редактирование слоя ( [image] ).

  2. Установите Объект ( [image] ).

  3. Подведите курсор мыши к любому из объектов входящих в группу, нажмите и удерживайте клавишу Shift. Дважды щелкните на объекте левой клавишей мыши.

    [Примечание] Примечание

    Диалог для изменения параметров выделенной группы также можно вызвать через меню Правка|Свойства объектов или через пункт Свойства объектов контекстного меню, которое можно вызвать щелчком правой кнопки мыши.

  4. В диалоговом окне для справки выводится количество объектов группы того или иного графического типа. В зависимости от того, какой тип объектов будет отмечен, в диалоге будет происходить изменение внешнего вида кнопок.

    Окно выбора объекта для изменения параметров группы

    Рисунок 451. Окно выбора объекта для изменения параметров группы

  5. Для преобразования параметров в списке слева выделите графический тип объектов и нажмите соответствующую кнопку. Следует иметь в виду, что внесенные изменения будут применены ко всей группе объектов. Подобное описание каждого варианта описано в разделе редактирование объектов:

    • Изменить параметры на экране откроется окно редактирования параметров соответствующего объекта;

    • Сделать примитивом преобразует типовые объекты в примитивы;

    • Сделать типовым - выполняет операцию по преобразованию примитива в типовой объект в соответствии с заданными параметрами;

    • Преобразовать в контуры - позволяет преобразовать ломаные в полигоны;

    • Преобразовать в линии - дает возможность преобразовать контурных объектов в линейные (ломаные).

    • Преобразовать в линии - преобразует линейные или полигональные объекты в символы.


Удаление группы объектов

[Примечание] Примечание

  • Отменить произведенное действие вы можете нажатием кнопки [image] на панели инструментов или комбинацией клавиш Ctrl и Z. Отмена действий возможна только до выхода из режима редактирования слоя!

  • По умолчанию предупреждение при удалении группы объектов появляется только при попытке удалить одновременно более 20 объектов. Изменить количество объектов, при котором будет появляться сообщение можно в Структуре слоя, в разделе Правила.

Для удаления группы:

  1. Включите редактирование слоя ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Выделите удаляемую группу.

  4. Нажмите кнопку [image] или клавишу Delete на клавиатуре или выберите пункт [image] Удалить контекстного меню, вызываемого щелчком правой кнопки мыши. Группа объектов будет удалена.

[Примечание] Примечание

Отменить произведенное действие можно нажатием кнопки [image] на панели инструментов или комбинацией клавишей Ctrl+Z.


Редактирование элементов объекта

Элементами объектов являются точки перелома (вершины) ломаных и полигонов, стороны (ребра, сегменты) отрезков, ломаных и контуров.

Элементы выделенного объекта: a - контура, b - линии

Рисунок 452. Элементы выделенного объекта: a - контура, b - линии

Возможны следующие варианты редактирования элементов объекта:

  • «Перемещение точек перелома (вершин) объекта»

  • «Перемещение точек перелома (вершин) объекта»

  • «Добавление точки перелома (вершины)»

  • «Автоматическое добавление точек перелома»

  • «Удаление точки перелома (вершины)»


Перемещение точек перелома (вершин) объекта

Переместить вершины объекта возможно следующими способами:

  • «Перемещение точек перелома (вершин) с помощью мыши»

  • «Перемещение точек перелома (вершин) с клавиатуры»

  • «Перемещение точек перелома (вершин) с помощью геометрических построений»


Перемещение точки перелома (узла)

Вы можете перемещать точки перелома нанесенных объектов несколькими способами. Чаще всего при редактировании сети используют перемещение с использованием мыши.

[Примечание] Примечание

Для того, чтобы были видны все точки перелома (узлы) активного слоя, нажмите кнопку [image] .

Перемещение возможно осуществлять:

  • Перемещение точки перелома с помощью мыши;

  • «Перемещение точек перелома (вершин) с клавиатуры»;

  • «Перемещение точек перелома (вершин) с помощью геометрических построений».

Перемещение точки перелома с помощью мыши

Для перемещения:

  1. Включите редактирование слоя ( [image] ).

  2. Выберите режим Узлы [image] .

  3. Подведите курсор к точке перелома, нажмите и, не отпуская левую клавишу мыши, переместите курсор в место нового положения точки.

    [Примечание] Примечание

    Перемещаемую вершину возможно «прицепить» к какой-либо вершине активного (не обязательно редактируемого) слоя. Для этого нужно, подведя к нему курсор, перед отпусканием клавиши мыши прижать клавишу Ctrl. Если вершина, к которой надо «прицепиться» находится в неактивном слое, тогда при фиксации точки надо удерживать одновременно клавиши Ctrl и Shift.

  4. Отпустите левую клавишу мыши.

    Рисунок 538. Перемещение узла

    [Примечание] Примечание

    Точно таким же образом можно перенести любой символьный объект, только при выполнении пункта 3 надо обязательно попасть в точку привязки объекта (как правило − это центр объекта).


Перемещение точек перелома (вершин) с клавиатуры

[Примечание] Примечание

Для отображения точек перелома слоя нажмите на панели инструментов кнопку [image] .

Данный вариант перемещения позволяет указать точные координаты точкам перелома объектов. Перемещение вершин с клавиатуры производится с использованием панели Свойства. Для открытия панели выберите меню Окно|Свойства или нажмите на панели инструментов кнопку Свойства [image] .

Далее:

  1. Включите редактирование слоя ( [image] ).

  2. Установите режим Узлы ( [image] ).

  3. Подведите к объекту курсор и сделайте на нем щелчок левой клавишей мыши. Все вершины отмеченного объекта выделятся и в окне свойств отобразится информация по объекту. Если на объекте выделить конкретную вершину, то строка, которая к ней относится будет так же выделена.

    Каждая строка таблицы содержит информацию о вершинах. В первой колонке таблицы записывается порядковый номер вершины. В следующих двух колонках - координаты, они могут отображаться или в метрах (X, Y) или в градусах (Широта, Долгота). Параметры отображения указываются в настройках карты.

    Колонка Длина содержит длину отрезка контура или ломаной из предыдущей точки к текущей. Последняя колонка Азимут/Угол(в зависимости от настройки) содержит значение азимута/угла, измеряемого из точки предшествующей текущей.

  4. Для редактирования местоположения вершины установите курсор в нужную строку (вершина, к которому данная строка относится выделится) и введите новое значение. Новое местоположение в соответствии с указанными данными вершина примет сразу при переходе к каким либо другим действиям.

    Таким образом перемещаясь по записям панели Свойства, можно исправлять с клавиатуры значения координат тех или иных точек. При этом изменения сразу будут отображаться на экране, а значения длины и азимута будут автоматически пересчитываться. Вместо значений координат можно корректировать значение длины или азимута. В этом случае пересчитываться автоматически будут координаты точек. Точка, соответствующая текущей записи в таблице, отображается на объекте большим кружком.

    [Примечание] Примечание

    Так же имеется возможность с клавиатуры удалить точки перелома. Для удаления какой то конкретной точки нужно встать на строку с удаляемой точкой и нажать комбинацию клавиш Ctrl+Del.


Перемещение точек перелома (вершин) с помощью геометрических построений

[Примечание] Примечание

Для отображения точек перелома слоя нажмите на панели инструментов кнопку [image] .

Перемещение вершин объекта так же можно сделать с помощью геометрических построений.

Для этого:

  1. Включите редактирование слоя ( [image] ).

  2. Установите режим Узлы ( [image] ).

  3. Отметьте объект, подлежащий редактированию. Для этого подведите к объекту курсор и щелкните левой клавишей мыши. При этом должны выделиться все вершины отмеченного объекта.

  4. Выделите левой кнопкой мыши редактируемую вершину. Нажмите правую кнопку мыши, после чего на экране появится контекстное меню, изображенное на рисунке ниже:

    Иллюстрация процесса перемещения вершины объекта

    Рисунок 457. Иллюстрация процесса перемещения вершины объекта

    Удалить точку перелома - выделенная вершина в данном случае является точкой перелома, поэтому при выборе данной опции точка перелома удалится.

    Вставить символьный объект - позволяет на место вершины вставить типовой символьный объект. Заметим, что для того, чтобы воспользоваться данной опцией в структуре слоя типовые объекты уже должны быть созданы в структуре слоя.

    Исключить символьный объект - если в выделенной вершине находится типовой символьный объект и при этом в него входит только один линейный объект и только один выходит, то при выборе данной опции символ удалится, но точка перелома останется. После удаления символьного объекта два линейных объекта объединятся в один.

    Направление через точку - при выборе данной опции курсор примет вид [image] , после этого надо левой кнопкой мыши указать точку на карте, через которую будет проходить направляющая линия. Если необходимо «притянуться» к какой либо вершине объекта, находящегося в активном слое, тогда при указании точки необходимо удерживать клавишу Ctrl. В том случае, когда объект, к вершине которого надо «притянуться» находится не в активном слое, при указании точки необходимо удерживать клавиши Ctrl+Shift. После указания точки при движении курсора направляющая линия будет поворачиваться, если щелкнуть левой кнопкой мыши, то она зафиксируется и второй щелчок левой кнопки мыши переместит редактируемую вершину в указанную точку. Если сразу после фиксации направляющей линии сделать щелчок правой кнопкой мыши, то на экране появится контекстное меню, рассмотренное в разделе «Ввод простой полилинии (ломаной) с экрана с использованием геометрических построений».

    Вдоль линии - после выбора данной опции курсор примет вид стрелки с двумя параллельными полосами и левой кнопкой мыши надо указать вдоль какой линии будет перемещена вершина. Если линия, вдоль которой должна перемещаться вершина находится в активном слое, тогда она указывается щелчком левой кнопки мыши, если же она находится в неактивном слое, то при указании (щелчке левой кнопки мыши) необходимо удерживать клавиши Ctrl+Shift. Повторное нажатие левой кнопки переместит редактируемую вершину в указанную точку. Если перед этим нажать правую кнопку мыши, то на экране появится меню, рассмотренное в разделе «Ввод простой полилинии (ломаной) с экрана с использованием геометрических построений».

    На расстоянии от точки - после выбора данной опции левой кнопкой мыши укажите точку, на расстоянии от которой надо переместить редактируемую вершину, точка может как произвольно быть указана на карте, так быть «притянута» к одной из вершин объекта карты или вводимой линии. После указания точки в появившемся окошке введите расстояние. Кнопка ОК подтвердит введенное расстояние, и вокруг указанной точки образуется круг с «бегающей» на нем точкой, точку можно зафиксировать в нужном месте щелчком левой кнопки мыши. Если до фиксации «бегающей» точки щелкнуть правой кнопкой мыши, то появится новое контекстное меню, рассмотренное в разделе «Ввод простой полилинии (ломаной) с экрана с использованием геометрических построений». Если объект, к вершине которого необходимо «притянуть» точку находится в активном слое, тогда она указывается щелчком левой кнопки мыши, если же он находится в любом другом слое, то при указании (щелчке левой кнопки мыши) необходимо удерживать клавиши Ctrl+Shift.

    На расстоянии от линии - после выбора данной опции левой кнопкой мыши укажите линию, на расстоянии от которой надо переместить редактируемую вершину. После указания линии в появившемся окошке введите расстояние. Кнопка ОК подтвердит введенное расстояние, и параллельно указанной линии появится вторая с «бегающей» на ней точкой, точку можно зафиксировать в нужном месте щелчком левой кнопки мыши. Если до фиксации «бегающей» точки щелкнуть правой кнопкой мыши, то появится новое контекстное меню, рассмотренное в разделе «Ввод простой полилинии (ломаной) с экрана с использованием геометрических построений». Если объект, к линии которого необходимо «притянуть» точку находится в активном слое, тогда она указывается щелчком левой кнопки мыши, если же он находится в любом другом слое, то при указании (щелчке левой кнопки мыши) необходимо удерживать клавиши Ctrl+Shift.

    Отменить действие - отменяет произведенные изменения, отмена будет работать до выхода из режима редактирования.

    Вернуть действие - возвращает отмененное действие.


Перемещение ребра (сегмента)

Данная операция подходит как для перемещения ребер многоугольников, сегментов ломаных, так и для перемещения отрезков инженерной сети.

Для перемещения:

  1. Включите редактирование слоя, в котором находится объект ( [image] ).

  2. Установите режим Узлы ( [image] ).

  3. Сделайте щелчок левой клавишей мыши по объекту, при этом должны выделиться все вершины указанного объекта.

  4. Подведите к ребру курсор, нажмите и не отпускайте левую клавишу мыши. Если захваченный отрезок принадлежит нескольким объектам слоя (контурный объект), то в перемещении будут участвовать все объекты, содержащие этот отрезок. Если все же необходимо «отцепить» отрезок данного объекта от других объектов слоя, то перед нажатием левой клавиши мыши нажмите и удерживайте клавишу Shift. После захвата вершины Shift можно отпустить.

  5. Не отпуская левую клавишу мыши, переместите курсор в место нового положения отрезка.

  6. Отпустите левую клавишу мыши.

Иллюстрация процесса перемещения ребра объекта

Рисунок 458. Иллюстрация процесса перемещения ребра объекта


Добавление точки перелома (вершины)

[Примечание] Примечание

Для отображения точек перелома слоя нажмите на панели инструментов кнопку [image] .

Чтобы добавить новую точку перелома (вершины) в ребро контура или ломаной:

  1. Включите редактирование слоя, в котором находится объект ( [image] ).

  2. Установите режим Узлы ( [image] ).

  3. Добавить точку перелома можно двумя способами:

    • Нажмите и удерживайте на клавиатуре клавишу Ctrl. Подведите курсор к месту предполагаемого внедрения точки перелома и щелкните левой клавишей мыши.

      Иллюстрация добавления точки перелома

      Рисунок 459. Иллюстрация добавления точки перелома

    • Подведите курсор к месту предполагаемого внедрения точки перелома, щелкните левой кнопкой мыши. Затем нажмите на панели инструментов кнопку [image] или щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Добавить точку перелома.

      Иллюстрация добавления точки перелома

      Рисунок 460. Иллюстрация добавления точки перелома


Автоматическое добавление точек перелома

Вы можете автоматически вставить точки перелома с заданным шагом разбиения. Они могут быть добавлены как для одного объекта, его сегмента или его отрезка, так и для группы объектов одновременно.

[Примечание] Примечание

Для отображения существующих точек перелома слоя нажмите на панели инструментов кнопку [image] .

Чтобы автоматически добавить точки перелома:

  1. Включите редактирование слоя, в котором будут производится изменения ( [image] ).

  2. Если добавлять точки перелома надо группе, то выделите ее. Если одному объекту, пропустите данный пункт.

  3. Выберите нужный режим:

    • Объект [image] - если работа будет проводиться с группой объектов;

    • Узлы [image] - если работа будет проводиться с элементами объекта (сегментом или отрезком) или одним этим объектом.

  4. В зависимости от выбранного режима сделайте щелчок левой кнопкой мыши по одному из объектов группы или по ребру объекта, его сегменту или отрезку.

  5. Сделайте щелчок правой кнопкой мыши и в контекстом меню выберите пункт Вставить точки перелома.

  6. В открывшемся диалоговом окне укажите:

    • В разделе Шаг разбиения внесите шаг в метрах с которым будут добавлены точки перелома.

    • Выберите положение переключателя По сфероиду или По проекции. По умолчанию установлена опция По сфероиду. Именно такой вариант позволяет производить построения в натуральную величину без искажений размеров вводимых объектов.

    • Из списка Способ разбиения укажите как будет производится работа с остатком линии:

      - Остаток разбиения в конце линии;

      - Остаток разбиения в начале линии;

      - Округлять шаг до разбиения на равные части.

    • При необходимости отметьте дополнительные опции:

      - Разбивать до остатка - опция будет доступна только если разделение производится с остатком. При ее выборе участок будет разбит до конца, остаток будет меньше указанного шага.

    • Выберите элемент разбиения: Объект, Сегмент или Отрезок. Два последних будут доступны только в режиме Узлы [image] .

  7. Для запуска процедуры разделения нажмите кнопку ОК. Кнопка Отмена закроет диалог Вставка точек перелома без сохранения.

    Процесс автоматического добавления точек перелома отрезка

    Рисунок 461. Процесс автоматического добавления точек перелома отрезка

    Процесс автоматического добавления точек перелома для группы объектов

    Рисунок 462. Процесс автоматического добавления точек перелома для группы объектов


Удаление точки перелома (вершины)

[Примечание] Примечание

Для отображения точек перелома слоя нажмите на панели инструментов кнопку [image] .

[Предупреждение] Предупреждение

  • Для контурных объектов запрещено удаление вершины, если в контуре всего три вершины.

  • Для ломаных запрещено удаление точки перелома, связанной более чем с двумя отрезками. Если точка связан с двумя отрезками, при удалении точки образуется один отрезок, соединяющий их оставшиеся концы.

  • Если удаление происходит у ломаной, которая имеет всего две вершины, то будет удалена вся ломаная.

Чтобы удалить точку перелома объекта:

  1. Включите редактирование слоя, в котором находится объект ( [image] ).

  2. Установите режим Узлы ( [image] ).

  3. Подведите курсор к точке перелома и щелкните левой клавишей мыши. Отмеченная точка выделиться.

    Вы можете удалить сразу несколько вершин, для этого надо их выделить. Выделить можно несколькими способами:

    • по очереди отметьте вершины щелчком левой кнопки мыши удерживая при этом клавишу Ctrl;

    • если необходимо выделить последовательную группу вершин, то достаточно указать с помощью курсора начальную и конечную вершины, удерживая при этом клавиши Ctrl и Shift, после чего будут отмечены все точки вершины, располагаемые между отмеченными вершинами;

    • выделить вершины можно так же с помощью окна Свойства, выделение произвольных вершин в списке возможно с помощью курсора и удерживания клавиши Ctrl, для выделения последовательной группы вершин необходимо удерживать клавишу Shift, с помощью курсора при этом достаточно указать начальную и конечную вершину.

  4. Нажмите на панели инструментов кнопку [image] или клавишу Delete или щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Удалить точку перелома. Вершина или группа вершин в зависимости от выбора будут удалены.

    Иллюстрация удаления точки перелома

    Рисунок 463. Иллюстрация удаления точки перелома


Масштабирование элементов слоя

[Примечание] Примечание

Масштаб на карте может быть представлен в двух вариантах: геодезическом и в сантиметрах на пиксель. Выбор нужного масштаба осуществляется в параметрах системы.

Используя операцию масштабирования элементов возможно одновременно изменить размеры примитивов, типовых объектов или надписей указанного слоя. Размер меняется в соответствии с введенным коэффициентом. Чем больше коэффициент, тем больше размер объекта. Коэффициент применяется к исходным данным элементов:

  • символы (примитивы) - это значение указанное в строке Размер окна Стиль;

  • символы (типовые)- это значение указанное в строке Размер режима в Структуре слоя;

  • линии (примитивы) - это значение указанное в строке Масштаб 1:1 диалога Стиль. Для масштабирования обязательно должна быть установлена опция Масштабировать;

  • линии (типовые) - это значение указанное в строке Масштаб 1:1 раздела Линии линейного графического типа в Структуре слоя, масштабирование будет применяться только в том случае, когда установлена опция Масштабировать. Так же промасштабированы могут быть пересечения линий, в этом случае изменяться будет значение поля Масштаб 1:1 раздела Пересечения линий. Для масштабирования обязательно должна быть установлена опция Масштабировать;

  • надписи (бирки) - это значение указанное в строке Масштаб 1:1 диалога Создание надписей, масштабирование будет применяться только в том случае, когда установлена опция Масштабировать.

[Примечание] Примечание

В более ранних версиях размеры символов и надписей слоев менялись при изменении проекции карты. Так же при печати или публикации данных для ZuluGIS Online и ZuluGIS Mobile размеры отличались от исходных. В текущей версии размеры объектов не зависят от параметров проекции, в результате чего все надписи и символы будут одинакового размера как в настольной, мобильной, онлайн версии, так и при печати данных. После обновления версии в связи с изменениями в системе размеры вышеуказанных объектов автоматически пересчитаются и в некоторых случаях потребуется их разовое масштабирование. Для него следует воспользоваться операцией масштабирования элементов.

Для настройки масштабирования объектов слоя:

  1. Выберите меню Слой|Операции|Изменить масштаб элементов.

  2. Из списка Слой укажите слой для масштабирования. Слой НЕ должен в этот момент быть редактируемым.

  3. С помощью галочек определите для каких элементов выбранного слоя будет производиться масштабирование элементов:

    • Типовые объекты;

    • Примитивы;

    • Бирки.

  4. В строке Коэффициент введите коэффициент масштабирования. Если нажать кнопку [image] то произойдет пересчет коэффициента 1/К, где К - введенный коэффициент. Таким образом возможно при повторном масштабировании элементов вернуться к изначальному масштабу.

    Диалог масштабирования элементов слоя

    Рисунок 464. Диалог масштабирования элементов слоя

  5. Для подтверждение масштабирования нажмите кнопку Применить. Кнопка Отмена закроет диалог без применения изменений.


Дополнительные операции редактирования

  • «Построение буферных зон»

  • «Построение выпуклой оболочки»

  • «Построение вогнутой оболочки»

  • «Создание контуров по сети»

  • «Подтягивание концов линий к узлам»

  • «Объединение концов линий»

  • «Примыкание»

  • «Объединение сегментов линий»

  • «Разделение линий на отрезки»

  • «Разделение линейных объектов в узле»

  • «Отсоединение сегмента»

  • «Удаление сегмента»

  • «Объединение участков с исключением узлов»


Построение буферных зон

Буферная зона - полигональный слой, образованный путем расчета и построения эквидистант, равноудаленных относительно множества точечных, линейных или полигональных объектов.

Построение буферной зоны заключается в очерчивании вокруг группы объектов активного слоя контура (или нескольких контуров), все точки которого отстоят от объектов группы на заданную величину. Полученный в результате контур (группа контуров) записывается в редактируемый слой. Расстояние для построения буферной зоны либо задается постоянной для всех объектов группы, либо берется из указанного числового поля подключенной в данный момент к активному слою таблицы.

В результате построения буфера у созданных объектов могут быть унаследованы атрибуты слоя источника.

Построение буферной зоны может использоваться для многих задач, например для выделения охранной зоны трубопроводов, определения зеленых поясов между жилыми домами, нахождения водозащитных зоны вокруг рек, определение зон вокруг школ, зона ремонта вокруг трубопровода и др. Полученный буфер может быть объединен в общий буфер или построен отдельно для каждого объекта.

Зона записывается в виде контурного или комбинированного площадного объекта с текущими параметрами редактора.

Процесс построения буферных зон

Рисунок 465. Процесс построения буферных зон

Буферная зона может быть преобразована в набор отрезков средствами системы (см. «Преобразование полигона в ломаную»):

Построение буферных зон: a -в виде контуров; b - в виде линий

Рисунок 466. Построение буферных зон: a -в виде контуров; b - в виде линий

Для построения буферной зоны:

  1. Включите редактирование слоя для записи зоны ( [image] ).

  2. В редактируемом слое настройте стиль для буферной зоны.

  3. Сделайте активным слой, по объектам которого строится зона.

  4. Выделите в активном слое один или группу объектов, относительно которых будет строиться зона.

  5. Выберите пункт главного меню Правка|Буферная зона. При этом на экране появится диалог построения буферных зон.

    В диалоге выводится имя активного слоя, по которому создается зона (Слой источник) и имя слоя для записи (Слой для записи).

    Пример диалога построения буферной зоны

    Рисунок 467. Пример диалога построения буферной зоны

  6. Задайте параметры создаваемой буферной зоны.

    • Ширина буфера: в этом окошке задается значение ширины буферной зоны, которое используется при отсутствии данных о ширине из таблицы.

    • По умолчанию: если отмечена эта опция, то если значения ширины буфера берутся из таблицы, и эти значения для каких-либо объектов отсутствуют или неверны, то значение по умолчанию будет браться из окошка Ширина буфера. Если эта опция не отмечена, то любое неверное значение ширины из таблицы приведет к остановке процесса создания буферной зоны.

    • Поле базы: открывающийся список, заполняется именами полей текущей семантической базы данных, подключенной к активному слою (слою источнику). Если в списке выбрано одно из полей, то значения ширины буфера будут браться из этого поля. Единицы измерения значений в выбранном поле указываются в соседнем открывающемся списке.

    • Объединять зоны в один объект: если буферная зона строится для нескольких объектов, тогда можно поставить галочку на против строки Объединять зоны в один объект. В этом случае построенная буферная зона для всех объектов будет единым целым, иначе для каждого объекта будет своя, отдельная буферная зона.

    • Вырезать из зоны сам объект: данную опцию следует отметить в том случае, если требуется из построенной буферной зоны вырезать объект, по которому она строилась.

    • Наследовать атрибуты - при установке данной опции атрибуты слоя (данные базы) источника будут скопированы в созданные объекты буфера слоя для записи. Подробней....

    • Концы линий - из открывающегося списка выбираются концы линий для буферной зоны:

      • Закругленный - концы линий будут закруглены, наружные углы на построенной буферной зоне так же будут закруглены, число точек на окружность необходимо указать в соответствующем окне;

        Буферная зона с закругленными концами линий

        Рисунок 468. Буферная зона с закругленными концами линий

      • Квадратный - концы линий на буферной зоне будут квадратными, углы так же будут квадратными;

        Буферная зона с квадратными концами линий

        Рисунок 469. Буферная зона с квадратными концами линий

      • Прямой - концы линий будут прямые, наружные углы на построенной буферной зоне будут закруглены, число точек на окружность необходимо указать в соответствующем окне.

        Буферная зона с прямыми концами линий

        Рисунок 470. Буферная зона с прямыми концами линий

    • Укажите точки перелома: закругленные или квадратные. Ели ранее были выбраны закругленные концы линий, то точки перелома могут быть тоже только закругленные.

    • Число точек на окружность: в данном окошке можно установить число точек, которое будет использоваться при создании окружностей буферной зоны. Чем больше количество точек, тем плавней будут окружности в зоне, точек можно задать от 12 до 360 шт.

    • Из списка выберите как будет производиться измерение ширины буфера, по аналогии с геометрическими построениями:

      • По проекции;

      • По сфероиду.

  7. Нажмите кнопку ОК для запуска процедуры создания буферной зоны.

[Подсказка] Подсказка

Построить буферную зону можно с помощью метода Layer.AddBufferZone.


Наследование атрибутов исходного слоя

Установка опции Наследовать атрибуты позволяет скопировать данные баз исходного слоя в базу данных, подключенную к создаваемым буферным объектам.

Если в группу объектов, для которых будет строиться буферная зона, попадет несколько различных типовых объектов с разными базами, список полей по которому будет происходить наследование атрибутов берется по одной базе, той которая соответствует элементу наименьшим ID (ключом SYS). Если в базах данных остальных объектов присутствуют одноименные поля, по ним данные так же запишутся.

Для успешного наследования атрибутов необходимо выполнение следующих условий:

  1. В слое, в котором будет строится буферная зона к примитивам должна быть подключена база данных.

  2. В базе данных слоя с буферной зоной поля, для которых требуется наследование атрибутов должны быть полностью идентичны полям слоя источника.

Рассмотрим пример.

Предположим, необходимо построить охранную зону вокруг трубопроводов шириной 6 метров. В результирующий слой необходимо скопировать такие данные как:

  • балансодержатель - Owner;

  • наименование начала участка - Begin_uch;

  • наименование конца участка - End_uch;

  • длина участка - L;

  • внутренний диаметр подающего трубопровода - Dpod;

  • внутренний диаметр обратного трубопровода - Dobr.

Далее проделаем следующие действия:

  1. Откроем карту со слоем, по которому будет построена буферная зона или добавим в активную карту этот слой.

  2. Для буферной зоны создадим отдельный слой одновременно с базой данных с полями, атрибуты которых требуется скопировать:

    Создание слоя с базой данных

    Рисунок 471. Создание слоя с базой данных

    [Примечание] Примечание

    При необходимости пользовательские названия для создаваемых полей в дальнейшем можно отредактировать на более читабельные.

  3. Сделаем редактируемым слой для записи зоны - Охранная зона ( [image] ).

  4. Сделаем активным слой, по объектам которого строится зона.

  5. Выделим в активном слое только участки ( [image] ).

  6. Выберем пункт главного меню Правка|Буферная зона. При этом на экране появится диалог построения буферных зон.

  7. Зададим параметры создаваемой буферной зоны:

    • Ширина буфера - 6.

    • Наследовать атрибуты - опцию отмечаем.

    • Концы линий - Закругленный.

    • Число точек на окружность - 36.

    Диалог построения буферной зоны

    Рисунок 472. Диалог построения буферной зоны

  8. Для запуска построения нажимаем кнопку ОК.

В результате проделанных действий в слое Охранная зона вокруг каждого выделенного участка будет построена буферная зона шириной 6 метров. При этом в ее базу данных будет скопирована семантическая информация по совпадающим полям исходного слоя:

Результат построения буферной зоны

Рисунок 473. Результат построения буферной зоны


Построение выпуклой оболочки

Выпуклой оболочкой множества X называется наименьшее выпуклое множество, содержащее X. «Наименьшее множество» здесь означает наименьший элемент по отношению к вложению множеств, то есть такое выпуклое множество, содержащее данную фигуру, что оно содержится в любом другом выпуклом множестве, содержащем данную фигуру.

В качестве простого наглядного примера выпуклой оболочки можно представить доску, в которую вбито, но не по самую шляпку много гвоздей. Натянутое вокруг гвоздей резиновое кольцо стянется и образует выпуклую оболочку, то есть оно окружает все гвозди, но касается она только некоторых, самых внешних.

Оболочка будет создана в редактируемом слое, который не всегда совпадает расположением исходных объектов. Она может быть построена по разным объектам, но результатом всегда является полигон:

Процесс построения выпуклой оболочки для символьных объектов

Рисунок 474. Процесс построения выпуклой оболочки для символьных объектов

Процесс построения выпуклой оболочки для линейных объектов

Рисунок 475. Процесс построения выпуклой оболочки для линейных объектов

Процесс построения выпуклой оболочки для площадных объектов

Рисунок 476. Процесс построения выпуклой оболочки для площадных объектов

Для построения выпуклой оболочки:

  1. Включите редактирование слоя ( [image] ) в который будет записан результат построения оболочки.

  2. Сделайте активным слой, по объектам которого будет строиться оболочка. Выделите эти объекты.

  3. Выберите пункт главного меню Правка|Выпуклая оболочка.

[Примечание] Примечание

В том случае, если исходные объекты и результат построения находятся в одном слое, то они будут связаны между собой. Попытка переместить оболочку приведёт к искажению исходных объектов. Чтобы переместить оболочку отдельно от исходных объектов, нужно выполнять перемещение, удерживая клавишу Shift.


Построение вогнутой оболочки

Вы можете создать вогнутую оболочку по выделенной группе объектов, все объекты группы будут включены в оболочку. Результат оболочки будет зависеть от исходных объектов и заданных параметров:

  • минимальной длины ребра (м);

    или

  • отношении длины ребра, которое рассчитывается Length = Ratio * (maxLen – minLen) + minLen, где Ratio — коэффициент, maxLen — самая большая длина, minLen — самая малая длина.

Оболочка может быть построена по разным объектам, но результатом всегда является полигон:

Построение вогнутой оболочки для символьных объектов, минимальная длина ребра 50 метров

Рисунок 477. Построение вогнутой оболочки для символьных объектов, минимальная длина ребра 50 метров

Построение вогнутой оболочки для линейных объектов, минимальная длина ребра 50 метров

Рисунок 478. Построение вогнутой оболочки для линейных объектов, минимальная длина ребра 50 метров

Построение вогнутой оболочки для площадных объектов, минимальная длина ребра 50 метров

Рисунок 479. Построение вогнутой оболочки для площадных объектов, минимальная длина ребра 50 метров

Для построения вогнутой оболочки:

  1. Включите редактирование слоя ( [image] ) в который будет записан результат построения оболочки.

  2. Сделайте активным слой, по объектам которого будет строиться оболочка. Выделите эти объекты.

  3. Выберите пункт главного меню Правка|Вогнутая оболочка.

  4. В открывшемся окне выберите из списка параметр и внесите его значение:

    • минимальной длины ребра (м);

      или

    • отношение длины ребра.

  5. Нажмите ОК.

[Примечание] Примечание

В том случае, если исходные объекты и результат построения находятся в одном слое, то они будут связаны между собой. Попытка переместить оболочку приведёт к искажению исходных объектов. Чтобы переместить оболочку отдельно от исходных объектов, нужно выполнять перемещение, удерживая клавишу Shift.


Создание контуров по сети

В системе имеется возможность автоматического поиска замкнутых контуров, образуемых узлами и ребрами выделенных линейных объектов, не содержащих внутри себя других узлов и ребер этого слоя, а также возможность записывать найденные контуры в редактируемый слой.

Если линии пересекаются без узлов, по конур не будет создан. Для добавления узлов в точки пересечения выполните узлование.

Для создания контуров по сети:

  1. Включите редактирование слоя для записи контуров ( [image] ).

  2. Сделайте активным слой, по объектам которого будут создаваться контуры.

  3. Выделите в активном слое группу объектов для оконтуривания (Ctrl+A — выделение всех объектов слоя).

  4. Выберите пункт главного меню Правка|Контуры по сети.

Иллюстрация процесса создания контура по сети

Рисунок 480. Иллюстрация процесса создания контура по сети


Подтягивание концов линий к узлам

В системе имеется возможность автоматического подтягивания концов линий к узлам. Такая операция может потребоваться после импорта слоя инженерной сети из какого либо обменного формата, когда сеть состоит из линий (примитивных или типовых) и узлов.

Для подтягивания концов линий к узлам:

  1. Включите редактирование слоя, в котором надо проделать эту операцию ( [image] ).

  2. Любым известным способом выделите линии (комбинация клавиш Ctrl+A используется для выделения всех объектов слоя).

  3. Выберите пункт главного меню Правка|Концы линий к узлам.

  4. В появившемся окне задайте диапазон в котором система будет подтягивать концы линий к узлам.

    Окно задания окрестности

    Рисунок 481. Окно задания окрестности

  5. Нажмите кнопку ОК, после чего система подтянет все концы линий к узлам в заданном диапазоне.

Иллюстрация процесса подтягивания концов линий к узлам

Рисунок 482. Иллюстрация процесса подтягивания концов линий к узлам


Объединение концов линий

Операция объединения концов линий также может потребоваться после импорта слоя инженерной сети из какого либо обменного формата. В результате этой операции конечные вершины ломаных в пределах заданного диапазона будут объединены.

Для объединения концов линий:

  1. Включите редактирование слоя, в котором надо проделать эту операцию ( [image] ).

  2. Любым известным способом выделите линии (комбинация клавиш Ctrl+A используется для выделения всех объектов слоя).

  3. Выберите пункт главного меню Правка|Объединить концы линий.

  4. В появившемся окне задайте диапазон, в котором система будет объединять концы линий.

  5. Нажмите кнопку ОК, после чего система объединит все концы линий в заданном диапазоне.

Иллюстрация процесса объединения концов линий

Рисунок 483. Иллюстрация процесса объединения концов линий


Примыкание

Операция примыкания может понадобиться после импорта слоя из какого-либо обменного формата.

Эта операция изменяет длину линейных объектов в указанной окрестности, пока они не пересекутся с другими объектами. Если пересечение произошло, то в пересекающихся объектах добавляется новый узел.

Для примыкания линий:

  1. Включите редактирование слоя, в котором надо проделать эту операцию ( [image] ).

  2. Любым известным способом выделите ломаные (комбинация клавиш Ctrl+A используется для выделения всех объектов слоя).

  3. Выберите пункт главного меню Правка|Примыкание.

  4. В появившемся окне задайте окрестность, в пределах которой система произведет примыкание.

  5. Нажмите кнопку ОК, после чего операция будет завершена.

Иллюстрация процесса примыкания

Рисунок 484. Иллюстрация процесса примыкания


Объединение сегментов линий

Данная операция позволяет объединить сегменты линии в один объект.

После импорта из различных обменных форматов может возникнуть такая ситуация, когда линейные объекты импортируются в виде казалось бы целых линий, но на самом деле таковыми не являться. То есть линия может выглядеть единой, при перемещении вести себя как целый объект, но пои этом будет состоять из нескольких сегментов. С помощью операции объединения сегментов линий можно объединить все сегменты в одну полилинию.

Сперва рассмотрим каким образом можно распознать линию, состоящую из сегментов. Для того, чтобы определить такой ли является линия надо войти в режим редактирования узлов - [image] и выделить линию. Окно Свойства при этом должно быть открыто (меню Окно/Свойства), именно в нем в столбце N - номер точки будет видно, является ли объект целым или состоит из сегментов. В цельном объекте в данном столбце будет просто перечислена нумерация точек: 1, 2, 3, 4..., в объекте же состоящем из сегментов нумерация будет отличаться, сначала будет номер сегмента, а затем номер точки: 1-1, 1-2, 1-3... 2-1, 2-2, 2-3...

Объединение сегментов линий

Рисунок 485. Объединение сегментов линий

Для объединения сегментов линий:

  1. Включите редактирование слоя, в котором надо проделать эту операцию ( [image] ).

  2. Любым известным способом выделите линии (комбинация клавиш Ctrl+A используется для выделения всех объектов слоя).

  3. Выберите пункт главного меню Правка|Объединить сегменты линий.

После проделанных действий каждая из выделенных линий будет состоять из одного сегмента, проверить это можно так как описано выше.

Если необходимо объединить сегменты только у одной линии, то можно воспользоваться таким вариантом:

  1. Включите редактирование слоя, в котором находится объект ( [image] ).

  2. Установите режим Узлы ( [image] ).

  3. Щелкните левой кнопкой мыши по линии.

  4. Сделайте щелчок правой кнопкой мыши и в открывшемся контекстом меню выберите пункт Объединить сегменты.


Разделение линий на отрезки

[Примечание] Примечание

К данной операции вы можете настроить правило редактора для работы с базой данных.

Операция позволяет разделить линии на отрезки, разделение линий будет производиться в точках перелома (там где проставлены узлы). После разделения отрезки будут прицеплены к друг другу (при необходимости их можно отцепить), но при этом каждый отрезок уже является самостоятельным объектом со своим ID.

Для разделения линий на отрезки:

  1. Включите редактирование слоя, в котором надо проделать эту операцию ( [image] ).

  2. Любым известным способом выделите линии (комбинация клавиш Ctrl+A используется для выделения всех объектов слоя).

  3. Выберите пункт главного меню Правка|Разделить линии на отрезки.

Если необходимо разделить отрезки только одну линию, то можно воспользоваться таким вариантом:

  1. Сделайте редактируемым слой, в котором надо проделать эту операцию ( [image] ).

  2. Установите режим Узлы ( [image] ), затем выделите линию.

  3. Сделайте щелчок правой кнопкой мыши и в открывшемся контекстом меню выбрать пункт Разделить на отрезки.

[Примечание] Примечание

  • Имеется возможность настроить правила редактора на разделение на отрезки, в результате применения которых при разделении линейного объекта на отрезки запись базы данных будет либо скопирована либо добавлена пустая.

На рисунке ниже можно увидеть линию, разделенную на отрезки, видно что каждый отрезок является отдельным объектом со своим ID:

Разделение линии на отрезки

Рисунок 486. Разделение линии на отрезки


Разделение линейных объектов в узле

[Примечание] Примечание

Для данной операции может быть настроено правило редактирования.

Вы можете разделить линейные объекты в узле (точке перелома). В результате операции объект будет разделен в указанной точке на два отдельных объекта. Для разделения:

  1. Включите редактирование слоя, в котором находится объект ( [image] ).

  2. Установите режим Узлы ( [image] ).

  3. Подведите курсор к точке перелома, в которой надо произвести разделение и сделайте щелчок левой кнопкой мыши. Точка выделится. Включить отображение всех точек перелома слоя можно нажатием кнопки [image] .

  4. Сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Разделить в узле.

    Ниже приведена иллюстрация разделения в узле сложной поли-полилинии. То что это поли-полилиния отображено в окне Свойства (меню Окно/Свойства). В простой полилинии в столбце N - перечислена нумерация точек 1, 2, 3, 4..., в объекте же состоящем из сегментов нумерация отличается, сначала указан номер сегмента, а затем номер точки: 1-1, 1-2, 1-3... 2-1, 2-2, 2-3... После разделения видно что объект отделен.

    Иллюстрация разделения линейного объекта в узле

    Рисунок 487. Иллюстрация разделения линейного объекта в узле


Отсоединение сегмента

В результате различных преобразований могут быть получены сложные составные объекты. Определить простой объект или составной можно следующим образом. Откройте окно Свойства (меню Окно/Свойства). Включите режим Узлы ( [image] ) и выделите объект. В столбце N - номер точки будет видно, является ли объект целым или состоит из сегментов. В цельном объекте в данном столбце будет просто перечислена нумерация точек: 1, 2, 3, 4..., в объекте же состоящем из сегментов нумерация будет отличаться, сначала будет номер сегмента, а затем номер точки: 1-1, 1-2, 1-3... 2-1, 2-2, 2-3...

В составном объекте вы можете отсоединить сегмент. Для этого:

  1. Включите редактирование слоя, в котором находится объект ( [image] ).

  2. Установите режим Узлы ( [image] ).

  3. Щелкните левой клавишей мыши по любой точке перелома отсоединяемого сегмента.

  4. Сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Отсоединить сегмент.

    Иллюстрация отсоединения сегмента линейного объекта

    Рисунок 488. Иллюстрация отсоединения сегмента линейного объекта

    Иллюстрация отсоединения сегмента площадного объекта

    Рисунок 489. Иллюстрация отсоединения сегмента площадного объекта


Удаление сегмента

В результате различных преобразований могут быть получены сложные составные объекты. Определить простой объект или составной можно следующим образом. Откройте окно Свойства (меню Окно/Свойства). Включите режим Узлы ( [image] ) и выделите объект. В столбце N - номер точки будет видно, является ли объект целым или состоит из сегментов. В цельном объекте в данном столбце будет просто перечислена нумерация точек: 1, 2, 3, 4..., в объекте же состоящем из сегментов нумерация будет отличаться, сначала будет номер сегмента, а затем номер точки: 1-1, 1-2, 1-3... 2-1, 2-2, 2-3...

В составном объекте вы можете удалить сегмент. Для этого:

  1. Включите редактирование слоя, в котором находится объект ( [image] ).

  2. Установите режим Узлы ( [image] ).

  3. Щелкните левой клавишей мыши по любой точке перелома удаляемого сегмента.

  4. Сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Удалить сегмент.

    Иллюстрация удаления сегмента линейного объекта

    Рисунок 490. Иллюстрация удаления сегмента линейного объекта

    Иллюстрация удаления сегмента площадного объекта

    Рисунок 491. Иллюстрация удаления сегмента площадного объекта


Оверлейные операции

Оверлейные (overlay) операции осуществляют преобразование над множеством объектов одного слоя или пересечения двух множеств одного или разных слоев. То есть оверлейные операции могут производиться как с множеством объектов одного слоя, так и между объектами разных слоев. Результаты преобразований всегда записываются в редактируемый слой.

Одно множество объектов во всех операциях участвует всегда — это уже описанная ранее группа объектов. Второе множество объектов, если оно требуется для операции, создается только для редактируемого слоя и называется мишенью.

Доступны следующие векторные оверлейные операции:

  • «Объединение объектов»

  • «Разъединение объектов»

  • «Разделение мишени группой»

  • «Вырезка из мишени группы»

  • «Обрезание мишени вне группы»

  • «Узлование»

  • «Разрезание мишени полилинией»

Установка мишени

Оверлейные операции производятся с использованием мишени. Мишень - это определенным образом выделенный объект или множество объектов, которые в дальнейшем используются при выполнении оверлейных операций. Она создается только для редактируемого слоя.

Для создания мишени:

  1. В редактируемом слое ( [image] ) выделите один или несколько объектов любым из известных способов.

  2. Выберите пункт меню Правка|Установить мишень или нажмите клавиши Ctrl+T. При этом сама группа отменится, а все объекты, включенные в группу, станут входить в мишень.

[Примечание] Примечание

Так как группа и мишень могут существовать у одного слоя одновременно, то желательно, чтобы отображение объектов, входящих в группу и в мишень, отличалось друг от друга. Параметры отображения группы и мишени для линейных и контурных объектов устанавливаются в диалоге настройки параметров системы Сервис|Параметры (пункт Карта).

Выделение объекта: а) не входит ни в мишень, ни в группу; b) входит в группу; c) входит в мишень; d) входит и в мишень, и в группу

Рисунок 492. Выделение объекта: а) не входит ни в мишень, ни в группу; b) входит в группу; c) входит в мишень; d) входит и в мишень, и в группу

Отмена мишени

Для отмены мишени следует выбрать пункт главного меню Правка|Отменить мишень.


Объединение объектов

Вы можете объединить площадные, линейные или символьные объекты. При объединении нескольких объектов образуется один (в общем случае составной объект). Собственно это один из способов создания комбинированного объекта. При объединении один из объектов должен быть указан как родительский объект, чей ключ (ID) и параметры отображения унаследует результирующий объект.

Для объединения объектов:

  1. Включите редактирование слоя с объектами ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Щелчком левой кнопкой мыши выделите объект, он будет родительским.

  4. Выберите пункт меню Правка|Установить мишень или нажмите клавиши Ctrl+T.

  5. Создайте группу, в которую войдут остальные объекты, подлежащие объединению.

  6. Выберите пункт главного меню Правка|Объединить объекты или нажмите кнопку [image] . При этом произойдет объединение объектов.

Иллюстрация процесса объединения ломаных (а-с) и контуров (1-4)

Рисунок 493. Иллюстрация процесса объединения ломаных (а-с) и контуров (1-4)

Иллюстрация процесса объединения ломаных

Рисунок 494. Иллюстрация процесса объединения ломаных

Иллюстрация процесса объединения площадных объектов

Рисунок 495. Иллюстрация процесса объединения площадных объектов


Разъединение объектов

Объект, который был получен объединением из нескольких, не пересекающихся объектов (комбинированный контурный или комбинированный линейный объект), можно разъединить.

[Примечание] Примечание

Имеется возможность не только разъединять все объекты, но и отдельно отсоединить сегмент.

Для разъединения объектов:

  1. Включите редактирование слоя с объектами ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Щелчком левой кнопкой мыши выделите комбинированный объект.

  4. Выберите пункт главного меню Правка|Разъединить объекты или нажмите кнопку [image] . Так же разъединять объекты можно удерживая на клавиатуре клавишу Ctrl, в этом случае - вырезаны области будут удалены из мишени и сохранены в отдельные площадные объекты.

    Иллюстрация процесса разъединения объектов

    Рисунок 496. Иллюстрация процесса разъединения объектов

    После разъединения у одного из объектов остается ключ комбинированного исходного объекта, а другие объекты получают новые ключи.

[Примечание] Примечание

В том случае, если до объединения объекты пересекались, то разъединение не возможно.


Разделение мишени группой

В результате этой операции контурные объекты, входящие в мишень редактируемого слоя, разделяются группой контурных объектов активного слоя. При этом активный и редактируемый слои могут не совпадать. Разделение приводит к тому, что область объекта мишени, попавшая в область, занимаемую группой, исключается из объекта мишени и образует новый объект, наследующий параметры отображения от исходного объекта.

[Предупреждение] Предупреждение

Внимание! Операция возврата (отката) не имеет!

Для разделения:

  1. Включите редактирование слоя с объектами, которые будут разделены ( [image] ).

  2. Установите режим Объект ( [image] ) и создайте мишень для редактируемого слоя.

  3. Выделите группу объектов в активном слое (активный слой не обязательно редактируемый).

  4. Выберите пункт меню Правка|Разделить мишень группой или нажмите кнопку [image] .

Иллюстрация процесса разделения мишени группой

Рисунок 497. Иллюстрация процесса разделения мишени группой


Вырезка из мишени группы

В результате этой операции из площадных объектов, входящих в мишень редактируемого слоя, исключаются области, занимаемые группой контурных объектов активного слоя. При этом активный и редактируемый слои могут не совпадать. Такая операция может использоваться для высчитывания чистых площадей объектов. Например, площади квартала без домов или площади озера без островов.

Для вырезки из мишени группы:

  1. Создайте мишень для редактируемого слоя (1).

  2. Выделите группу объектов в активном слое (активный слой не обязательно редактируемый) (2).

  3. Выберите пункт меню Правка|Вырезать из мишени группу или нажмите кнопку [image] (3).

Иллюстрация процесса вырезания из мишени группы

Рисунок 498. Иллюстрация процесса вырезания из мишени группы

Классический пример на эту тему: есть слой озер и слой островов, нужно из озер вырезать площади, занимаемые островами.

  1. Сделайте слой озер активным и редактируемым ( [image] ).

  2. Выделите озера, все озера можно выделить комбинацией клавиш Ctrl+A.

  3. Нажмите Ctrl+T, из выделенных объектов будут создана мишень.

  4. Сделайте слой островов активным.

  5. Выделите острова, все острова можно выделить комбинацией клавиш Ctrl+A.

  6. Выберите пункт меню Правка|Вырезать из мишени группу или нажмите кнопку [image] .

Иллюстрация процесса вырезания из слоя озер островов

Рисунок 499. Иллюстрация процесса вырезания из слоя озер островов


Обрезание мишени вне группы

В результате этой операции из контурных объектов, входящих в мишень редактируемого слоя, исключаются области, не попавшие в области, занимаемые группой контурных объектов активного слоя. При этом активный и редактируемый слои могут не совпадать.

Для обрезания мишени по группе следует:

  1. Создайте мишень для редактируемого слоя (1).

  2. Выделите группу объектов в активном слое (активный слой не обязательно редактируемый) (2).

  3. Выберите пункт меню Правка|Обрезать мишень вне группы или нажмите кнопку [image] (3).

Иллюстрация процесса обрезания мишени вне группы

Рисунок 500. Иллюстрация процесса обрезания мишени вне группы


Узлование

В результате этой операции ребра контуров или отрезки полилиний мишени разбиваются узлами в точках пересечения с ребрами контуров или отрезков входящих в группу активного слоя. При этом активный и редактируемый слои могут не совпадать.

Для выполнения узлования следует:

  1. Создайте мишень для редактируемого слоя (1).

  2. Выделите группу объектов в активном слое (активный слой не обязательно редактируемый) (2).

  3. Выберите пункт меню Правка|Узлование или нажмите кнопку [image] (3).

Иллюстрация процесса узлования

Рисунок 501. Иллюстрация процесса узлования

Узлами разбиваются только объекты мишени. Если необходимо, чтобы все объекты группы имели узлы друг с другом, нужно, чтобы эти объекты одновременно входили и в мишень, и в группу.

Иллюстрация процесса выделения узлов

Рисунок 502. Иллюстрация процесса выделения узлов


Разрезание мишени полилинией

Операция позволяет разрезать полилинией объекты установленной мишени на несколько частей. Полилиния может находится как в одном слое с объектами, так и в разных слоях. Она должна располагаться в активном слое и быть непрерывной (не состоять из нескольких ломаных).

Для выполнения операции:

  1. Включите редактирование слоя с объектами, которые надо разделить.

  2. Установите мишень на разделяемые объекты (а).

  3. Введите полилинию линию поверх мишени, если она ранее введена пропустите данный пункт.

  4. Если слой с полилинией не активный, активируйте его. Затем включите режим Объект [image] и выделите линию щелчком левой кнопкой мыши (б).

  5. Выберите пункт меню Правка|Разрезать полилинией. Объекты мишени будут разделены по линии (в).

Иллюстрация процесса разрезания мишени ломаной

Рисунок 503. Иллюстрация процесса разрезания мишени ломаной


Слой инженерной сети

Общие сведения

  • «Создание нового типового слоя сети»

  • «Разработка нового нетипового слоя сети»

  • «Ввод объектов сети»

  • «Проверка связанности объектов сети»

  • «Преобразование объектов в сеть»

  • «Обезличивание слоя сети»

  • «Объединение участков с исключением узлов»

  • «Редактирование сети»

ZuluGIS поддерживает линейно-узловую топологию, которая позволяет моделировать инженерные и другие сети. Модель сети представляет собой граф, где узлы обозначаются символьными объектами (например, колодцами, источниками, задвижками, рубильниками, перекрёстками, потребителями и так далее), а рёбрами являются линейные объекты (трубопроводы, кабели, участки дорожной сети и другое). Связь в сети основана на соответствии координат. Начальный узел имеет координаты x1 y1. Выходящий участок начинается с координат первой точки, которые равны координатам символьного объекта x1 y1. Затем следуют точки перелома с координатами x2 y2, x3 y3 и так далее до x10 y10. Конечный символьный объект имеет координаты x11 y11.

[Примечание] Примечание

Используя модель сети можно решать ряд топологических задач: поиск кратчайшего пути, анализ связности, анализ колец, анализ отключений, поиск отключающих устройств и т.д.

В инженерной сети используются только типовые объекты. Для каждого объекта сети обязательно должен быть создан тип и режим, все они описаны в структуре слоя. При создании типа определяется его графический тип. Например, символьный графический тип может быть источником, отсекающим устройством, потребителем или узлом. Линейный графический тип - участок отсекающий. Каждому типу указывается соответствующая ему база данных.

У всех типов должен быть хотя бы один режим. В режиме для всех объектов настраивается стиль отображения на карте. А для объектов, которые могут находиться в разных состояниях, например, быть включёнными или отключёнными, определяется их состояние в топологической модели сети.

ZuluGIS позволяет создавать как типовые инженерные сети так и не типовые. Типовые сети создаются с уже готовой структурой, то есть в нее будут добавлены необходимые для нанесения объекты. По мимо структуры автоматически создаются базы данных, в которые в дальнейшем пользователем заносится информация для расчетов. Такие сети соответствуют требованиям расчетных модулей ZuluThermo (тепловые сети), ZuluHydro (водопроводные сети), ZuluDrain (сети водоотведения), ZuluGaz (сети газопровода), ZuluSteam (сети паропровода) и соответственно могут рассчитываться. Типовую сеть можно настроить индивидуально, например добавить новые режимы или дополнительные поля в базы данных. Как создать новый слой типовой инженерной сети можно узнать в разделе «Создание нового типового слоя сети».

Структура и базы данных нетиповых сетей разрабатываются самостоятельно. Расчету модулями Zulu они не подлежат. Но они подходят для решения ряда ряд топологических задач. Примером такой сети может быть электрическая или дорожная сеть. Как создавать такие сети можно узнать в разделе «Разработка нового нетипового слоя сети».

[Примечание] Примечание

В данной справке предоставлена краткая информация по типовым инженерным сетям, более подробную информацию о работе с сетью, расчетах и методиках можно найти в справках по сетям:

  • ZuluThermo (тепловые сети) – https://politerm.com/zuluthermo/webhelp/index.html

  • ZuluHydro (водопроводные сети) – https://politerm.com/zuluhydro/webhelp/index.html

  • ZuluDrain (сети водоотведения) – https://politerm.com/zuludrain/webhelp/index.html

  • ZuluGaz (сети газопровода) – https://politerm.com/zulugaz/webhelp/index.html

  • ZuluSteam (сети паропровода) – http://politerm.com/zulusteam/webhelp/index.html


Создание нового типового слоя сети

Формулировка типовой слой сети применяется как общее описание слоев тепловой, паровой, водопроводной, газовой или канализационной сети. Такие сети подлежат расчету с применением модулей ZuluThermo, ZuluHydro, ZuluDrain, ZuluGaz, ZuluSteam.

При создании слоя структура создается автоматически и содержит все необходимые для выполнения инженерных расчетов объекты:

  • библиотека стилей линий и символов (условных обозначений) используемых при построении модели сети;

  • список типов описывающих функцию объектов в топологической модели и подключенных к ним базы данных;

  • список режимов, описывающие стиль объекта и его состояние в топологической модели;

  • базы данных, включающие в себя набор таблиц с необходимым для описания и задания расчетных атрибутов полей справочников и запросов, описывающих внешний вид окна для занесения информации;

  • минимальный набор правил редактирования.

[Примечание] Примечание

Иногда в процессе работы необходимо создать слой сети, который полностью повторяет структуру уже существующего слоя. Однако эта структура может отличаться от стандартной и быть доработанной пользователем: например, добавлены новые режимы или настроены параметры базы данных. В таких случаях рекомендуется использовать метод создания нового слоя по образцу.

[Примечание] Примечание

Видеоурок по созданию слоя тепловой сети можно посмотреть пройдя по одной из ссылок: https://youtu.be/4sUsTyivhOY или https://www.politerm.com/videos/network/sozdanie-teplovoy-seti/.

Видеоурок по созданию слоя водопроводной сети можно посмотреть пройдя по одной из ссылок: https://youtu.be/BM6AvD-aDq8 или https://www.politerm.com/videos/network/sozdanie-vodoprovodnoy-seti/.

Для создания слоя тепловой (водопроводной, паровой, газовой, канализационной) сети:

  1. Выберите меню Слой/Создать инженерную сеть/Теплоснабжение (Водоснабжение, Пароснабжение, Газоснабжение, , Канализация) соответственно.

    или

    В меню Задачи выберите пункт ZuluThermo (ZuluHydro, ZuluSteam, ZuluGaz, ZuluDrain) или нажмите на панели инструментов соответствующую кнопку [image] ( [image] , [image] , [image] , [image] ). Затем в появившемся диалоговом окне во вкладке Сервис нажмите кнопку Создать новую сеть.

  2. В открывшемся окне выберите диск и каталог, в котором будут храниться графические файлы, введите имя файла слоя. Слой сети необходимо создавать в отдельной папке!

    При работе в многопользовательской версии (ZuluServer) каталог должен располагаться на Сервере геоданных. Для доступа к нему нажмите кнопку Серверы геоданных [image] , расположенную в левой части окна.

    В строке Имя файла введите имя файла слоя и нажмите кнопку Сохранить. Если выбрано имя файла уже существующего слоя, то в результате создания нового слоя существующий слой будет УНИЧТОЖЕН, а новый будет создан на его месте. Имя слоя не должно содержать специальные символы, например \ / | : * ? " < >.

  3. В строке Название слоя автоматически подставляется ранее введенное имя. Однако вы можете ввести и другое название. Желательно, чтобы оно отражало тему содержимого создаваемого слоя. Это имя будет использоваться при добавлении слоя на карту. При просмотре созданных файлов стандартными инструментами операционной системы будет отображаться имя файла.

  4. Для задания системы координат слоя нажмите кнопку Система координат (списки поддерживаемых типов проекций и датумов можно узнать в разделе Поддерживаемые типы проекций и датумы ). Если система координат для слоя указана не будет, то слой будет создан в системе координат карты.

  5. Так как при создании слоя инженерных сетей к объектам автоматически будут создаваться базы данных, то необходимо из списка Таблицы выбрать источник данных для таблиц, если нужного источника в списке нет, то добавить новый. При использовании многопользовательской версии (ZuluServer) рекомендуется выбирать SQL Server.

  6. При необходимости сразу добавить слой в текущую карту установите опцию добавить в карту.

    Окно создания нового слоя тепловой сети

    Рисунок 504. Окно создания нового слоя тепловой сети

  7. Для завершения создания слоя нажмите кнопку ОК.

В результате будет создан слой, который уже содержит файлы графической базы данных с типовой структурой, таблицы и описатели семантической информации для каждого типового объекта.

Структура слоя тепловой сети

Рисунок 505. Структура слоя тепловой сети

[Примечание] Примечание

Для созданного нового слоя типовой инженерной сети автоматически будут настроены следующие правила редактора:

  • добавление объекта - для каждого нового объекта будет добавляться пустая запись;

  • разбиение участка символом - при разбиении участка символом для линейного объекта (участка) запись базы будет копироваться, а значение поля длина пропорционально разделено. Для символьного объекта (внедряемого в участок) - будет добавляться пустая запись.

  • удаление символа, объединение участков - для линейного объекта (участка) запись удаляется, а поле длина суммируется;

  • разбиение линии - при разбиении линии в узле для линейного объекта (участка) запись базы будет копироваться, а значение поля длина пропорционально разделено.

Кроме вышеперечисленных правил по умолчанию будут установлены опции для бирок и правило копирования:

  • создавать бирки для объекта при добавлении записи в базу;

  • перемещать бирки при перемещении объекта;

  • копировать табличные данные при дублировании объекта.

Для того, чтобы посмотреть структуру созданного слоя выберите меню Слой|Структура слоя или нажмите на панели инструментов кнопку [image] (слой сети должен быть не редактируемым).

Подробнее о структуре слоя можно узнать в разделе «Структура слоя».


Разработка нового нетипового слоя сети

Самостоятельная разработка сети может потребоваться, если нужна сеть, структура которой не создаётся автоматически системой. Например, это может быть электрическая или дорожная сеть. Такие сети не могут быть рассчитаны стандартными модулями Zulu.

Для создания такой сети:

  1. Создать векторный слой.

  2. В структуре слоя создайте типовые объекты и режимы для них. Для нанесения любой сети необходимо добавить следующие типы и режимы:

    • линейный графический тип (участок/отсекающий) - данный тип объекта при нанесении на карту будет соединять символьные объекты. Для электрической сети это кабель, для дорожной это дороги соответственно. Чтобы данный тип возможно было нанести на карту ему так же необходимо создать режимы, которыми будет определен стиль объектов и их состояние. Как минимум должен быть создан один режим, но при необходимости их может быть и больше.

      Например, в дорожной сети могут быть созданы следующие режимы: двустороннее движение (для такого режима состояние ставится как включен), одностороннее движение (состояние прямая проводимость), дорога закрыта (состояние отключен). Для электрической сети могут быть например добавлены режимы: воздушные линии электропередач (состояние включен), воздушные линии электропередач обрыв (состояние отключен), подземные линии (состояние включен), подземные линии обрыв (состояние отключен).

    • символьные графические типы, объекты инженерных сетей (источник/отсекающее устройство/потребитель/узел). Символьных типов может быть несколько. Например, для электрической сети: источник (графический тип символьный/объект инженерных сетей/источник), опоры (графический тип символьный/объект инженерных сетей/узел), потребитель (графический тип символьный/объект инженерных сетей/потребитель), рубильник (графический тип символьный/объект инженерных сетей/отсекающее устройство).

      Обязательно для каждого типа необходимо создать один или несколько режимов с помощью которых во первых будет определен его стиль. Для этого необходимо разработать в редакторе символов новые символы. Если при создании символа его цвет узора определен как авто, то в режиме для него дополнительно нужно указать цвет.

      Для символьного типа - объект инженерных сетей (источник, отсекающее устройство) и линейного типа (участок/отсекающий) в созданных режимах так же необходимо задать состояние (включен/отключен и другие).

    [Примечание] Примечание

    Пример создания типовых объектов для дорожной сети можно посмотреть в разделе «Пример создания типовых объектов».

  3. Если для объектов сети необходимы базы данных, то создать их и затем назначить каждому типу свою базу данных. Если базы не нужны то данный шаг можно пропустить.

  4. Далее, после того как создан слой, разработана его структура и базы данных можно приступать к его нанесению на карту.


Ввод объектов сети

[Примечание] Примечание

Видеоурок по вводу сети можно посмотреть пройдя по одной из ссылок: https://youtu.be/4R45qj3hFtU или https://www.politerm.com/videos/layeredit/vvod-seti/.

Ввод сети возможен только при правильном создании слоя инженерной сети! В слое обязательно должна быть структура, содержащая линейные и символьные объекты сети.

[Примечание] Примечание

При нанесении сети на карту возможно использовать:

  • геометрические построения, точно так же как и при вводе простой ломаной линии;

  • ввод объектов с клавиатуры аналогично вводу типовой линии;

  • дополнительные возможности ввода.

Для ввода объектов сети:

  1. Включите режим редактирования слоя [image] .

  2. Нажмите кнопку [image] , в появившемся меню типовых объектов выберите объект для нанесения на карту. Чтобы избежать ошибок при вводе, для рисования сети рекомендуется выбирать линейный объект, например, участок.

    Участок инженерной сети должен начинаться и заканчиваться символьными объектами. Поэтому при вводе участка система автоматически предложит вам выбрать начальный и конечный объекты.

    Выбор участка для ввода

    Рисунок 506. Выбор участка для ввода

  3. Подведите курсор к месту начала участка и установки начального объекта сети. Сделайте щелчок левой кнопкой мыши. Если был выбран участок, то появится список символьных объектов этого слоя. Выберите объект, который будет служить началом участка.

    Выбор объекта для ввода

    Рисунок 507. Выбор объекта для ввода

    В том случае, если в меню типовых объектов объекту ранее была назначена «горячая» клавиша, то для установки данного объекта достаточно нажать ее на клавиатуре.

  4. Затем необходимо проложить «резиновую линию» до следующего узла сети или до места, где участок поворачивает. Если вам нужно обозначить точку поворота (перелома) участка, щёлкните один раз левой кнопкой мыши в нужном месте.

    Чтобы отметить конец участка, дважды щёлкните левой кнопкой мыши. После этого появится список объектов сети. Выберите в списке символьный объект, который будет обозначать конец участка. Или, если вы ранее назначили горячей клавише объекта в меню типовых объектов, для установки данного объекта просто нажмите эту клавишу на клавиатуре.

    Рисунок 508. Нанесение сети

  5. Чтобы добавить новый участок, щёлкните левой кнопкой мыши в точке привязки (в узле) символьного объекта. Обычно узел находится в центре объекта. Если щелчок будет произведен в радиусе от узла более указанного в настройках системы, то будет предложен ввод нового символа а не прикрепление к уже нанесенному. В этом случае нажмите кнопку Esc, подведите курсор ближе к узлу и снова сделайте щелчок левой кнопкой мыши.

    Далее переместите курсор к месту поворота участка или концу. Для поворота щёлкните один раз левой кнопкой мыши. Чтобы завершить ввод участка, сделайте двойной щелчок и выберите в списке объектов символ, который должен быть концом участка.

    Рисунок 509. Нанесение сети

    [Примечание] Примечание

    При желании можно изменить радиус захвата узла символа при вводе сети, по умолчанию радиус 10 пикселей.

    Так же имеется возможность ввести участок с одновременным нанесением символьного объекта и разделением уже существующего участка.

[Примечание] Примечание

В точке разветвления участков ОБЯЗАТЕЛЬНО должен стоять символьный объект (узел). Более подробно о воде инженерных (тепловых, водопроводных, паровых, газовых, канализационных) сетей можно узнать в соответствующей справке по ZuluThermo (ZuluHydro, ZuluSteam, ZuluGaz, ZuluDrain).

[Предупреждение] Предупреждение

После нанесения сети обязательно произведите проверку связности объектов между собой!

Рисунок 510. Тепловая сеть


Проверка связанности объектов сети

После ввода сети надо произвести проверку связности ее объектов между собой. Это необходимо для того, чтобы проверить отсутствие ошибок, которые могли возникнуть при нанесении сети.

[Примечание] Примечание

Об остальных задачах топологического анализа можно узнать в разделе Задачи топологического анализа.

Проверку можно производить как для полностью нанесенной сети, так и для отдельных ее частей.

Для проверки:

  1. Сделайте слой сети активным.

  2. На панели навигации нажмите кнопку Поиск пути [image] .

  3. Для установки флажка сделайте щелчок левой кнопкой мыши на любом символьном объекте сети, нажмите правую клавишу мыши. В появившемся меню выберите пункт Найти связанные.

  4. Можно найти все связанные объекты сети по направлению от узла, на котором был установлен флажок, или против направления, для этого в меню выберите пункт Найти связанные по направлению или Найти связанные против направления. Следует учитывать, что направление участка определяется при его вводе, то есть направление участка будет от начальной точки ввода к конечной точке. Также можно Найти несвязанные объекты. Для поиска колец тепловой сети выберите в меню пункт Найти кольца.

    Все найденные объекты сети, в соответствии с выбранным пунктом меню поиска, окрасятся в красный цвет. Если найдены несвязанные объекты, то необходимо отредактировать сеть таким образом, чтобы в ней не было несвязанных объектов.

    Рисунок 511. Контекстное меню

  5. Для отмены результатов поиска нажмите кнопку Отмена пути [image] .


Преобразование объектов в сеть

В системе предусмотрена возможность автоматического преобразования объектов в сеть. Это может быть полезно, например, после импорта сети из другой программы, где она представлена ломаными линиями и точечными объектами.

В сеть могут быть преобразованы как как простые, так и типовые. В случае с простыми объектами при преобразовании в сеть они могут быть автоматически преобразованы в типовые и затем уже в сеть.

В том случае, если в исходном слое нет типовых объектов, то при желании во время преобразования в структуру слоя автоматически может быть добавлен один тип для участков и один тип для узлов созданной сети. Если требуется, чтобы объекты были преобразованы в уже существующие типы и режимы, то соответственно они должны быть созданы в структуре слоя. Чтобы вручную не создавать структуру, возможно создать слой нужной инженерной сети с уже готовой структурой и в него скопировать объекты для преобразования.

Преобразование ломаных в сеть

Рисунок 512. Преобразование ломаных в сеть

Для выполнения преобразования:

  1. Сделайте слой сети с преобразуемыми ломаными активным и редактируемым ( [image] ).

  2. Включите режим объект [image] .

  3. Выделите группу объектов для преобразования.

  4. Выполните команду меню Карта|Операции|Преобразовать в сеть.

  5. В открывшемся диалоге задайте требуемые параметры преобразования:

    • список Слой – слой, в котором сохраняется полученная сеть;

    • опция Декомбинировать мультилинии. При установленной опции мультилинии будут разбиты на составляющие отрезки;

    • опция Узловать в точках пересечения линий. При установленной опции, в точках пересечения линий создаются узлы;

    • опция Подтягивать концы линий к узлам. При установленной опции «свободные» концы линий после преобразования будут подтянуты к ближайшим узлам, в поле справа от флажка задается максимальное расстояние на которое могут подтягиваться концы;

    • опция Объединять концы линий. При установленной опции «свободные» разомкнутые концы линий подтягиваются друг к другу, в поле справа от флажка задается максимальное расстояние на которое могут подтягиваться концы;

    • опция Узловать в точках примыкания линий. При установленной опции на концах линий «примыкающих» к другим линиям создаются узлы, в поле справа от флажка задается максимальное расстояние на которое могут подтягиваться концы линий для выполнения примыкания;

    • опция Разделять участки узлами используется в том случае, если на ломаных, которые надо преобразовать в сеть имеются символьные объекты. Тогда символы будут преобразованы в типовые объекты и внедрены в участки. В поле справа от флажка задается максимальное расстояние для «захвата» узлов.

    • опция Разделять участки узлами в точках перелома аналогична предыдущей опции, только символьные объекты будут установлены в каждой вершине ломаных (точках перелома);

    • опция Удалять дублированные объекты. Если опция установлена, дублирующиеся объекты при преобразовании удаляются;

    • в группе полей Участки задается тип (в поле Тип) и режим (в поле Режим) участков создаваемых из ломаных. Для выполнения преобразования ломаных в участки должна быть установлена опция Преобразовывать примитивы в участки;

    • опция Копировать атрибуты при разбиении участка. Если опция установлена, то при разбиении участка его атрибуты будут скопированы во все итоговые участки. В том случае, когда надо чтобы данные поля длины участка не просто были скопированы, а разбиты пропорционально в соответствии с новыми получившимися участками надо дополнительно установить опцию Поле длины и из списка выбрать соответствующее поле (по умолчанию это поле L);

    • в группе полей Узлы задаются типы (в поле Тип) и режимы (в поле Режим) узлов инженерной сети создаваемых на разветвлениях (группа На разветвлениях) и в тупиках (группа На тупиках) сети. Создание узлов сети производится только при установленном флажке Преобразовывать примитивы в узлы.

      Диалог преобразования в сеть

      Рисунок 513. Диалог преобразования в сеть

  6. После задания параметров преобразования нажмите кнопку ОК, чтобы выполнить преобразование, либо кнопку Отмена, чтобы отменить его.


Обезличивание слоя сети

Операция обезличивания слоя сети позволяет создать новый слой с изменённым до неузнаваемости графическим видом. В результате все объекты будут находиться на новых местах. При этом топологические связи сохранятся, и такую сеть, хотя и изменившую свой внешний вид, можно будет посчитать. Все семантические данные, за исключением наименований, будут сохранены.

[Предупреждение] Предупреждение

Обезличенный слой невозможно вернуть в исходное состояние!

Ниже на рисунке можно увидеть результат обезличивания.

Рисунок 514. Исходная сеть

Рисунок 515. Обезличенная сеть

Для обезличивания сети:

  1. Выберите меню Слой|Операции|Обезличить слой сети...

  2. Если слой сети для обезличивания загружен ранее в карту, то выберите его из открывающегося списка Исходный слой. В противном случае нажмите кнопку Обзор... и выберите слой.

  3. В разделе Слой для записи справа от строки имя нажмите кнопку Обзор... и укажите имя слоя и папку в которую будет записан новый обезличенный слой сети.

  4. В строке название можете поменять пользовательское название для обезличенного слоя.

  5. Если необходимо новому слою поменять источник данных для хранения табличной информации (например, из Access в SQLite) то выберите новый из списка Источник для таблиц.

    Диалог Обезличить слой инженерной сети

    Рисунок 516. Диалог Обезличить слой инженерной сети

  6. Для завершения операции нажмите кнопку ОК.


Объединение участков с исключением узлов

Эта операция используется для упрощения инженерной сети, когда нужно убрать лишние символьные объекты и объединить участки. В системе также есть возможность удалять объекты с объединением участков поштучно.

Перед объединением выбираются объекты для удаления и задаются дополнительные условия. Есть несколько вариантов условий для объединения:

  • совпадающие данные в полях участков - будут объединены только участки, имеющие общий узел, данные в которых совпадают. Например участки с одинаковым значением в поле Балансодержатель;

  • совпадение типов участков - объединяются участки одного типа, имеющие общий узел;

  • совпадение режимов участков - объединяются участки одного режима, имеющие общий узел.

    [Предупреждение] Предупреждение

    Изучение данной операции лучше производить на копии слоя.

    Операция отмены действий (Правка|Отменить или нажатие на клавиатуре сочетание клавиш Ctrl+Z) отменяет только графические изменения, не затрагивая значения в безе данных.

    Операция отмены действий восстановит сеть к исходному состоянию с учетом значений в базе данных если:

    • в структуре слоя нет настройки правила удаления записей при удаление объектов;

    • операция происходила БЕЗ суммирования значений поля, при объединенных участков;

    • если после операции объединения база данных НЕ была сжата.

Для объединения участков и исключения узлов откройте карту со слоем, в котором надо объединить участки или добавьте слой в текущую карту, далее:

  1. Сделайте активным слой для объединения и включите его редактирование.

  2. Выделите все объекты для объединения включая узлы.

  3. Выберите меню Правка|Объединить участки, исключая узлы.

  4. В появившемся диалоге Объединение участков слева будет отображен список объектов, которые могут быть исключены из сети при объединении участков. Установите галочки напротив объектов которые требуется исключить. Для того чтобы выбрать все объекты одновременно установите галочку Все.

  5. Для того, чтобы объединялись только участки с общим узлом, у которых в полях семантической базы данных внесены одинаковые значения внесите в строку Совпадение значений полей название поля, по которому следует проводить проверку совпадения значений. Если введенного названия поля не существует, то будет выдано соответствующее сообщение.

  6. Для объединения участков, имеющих общий узел только при совпадении типа установите опцию Совпадение типов.

  7. Для объединения участков, имеющих общий узел только при совпадении режима установите опцию Совпадение режимов.

  8. Для суммирования значений полей объединенных участков введите соответствующие названия полей в строку Поля для суммирования при объединении. Если таких полей несколько, то их следует разделять точкой с запятой - «;».

    Диалог Объединение участков

    Рисунок 517. Диалог Объединение участков

  9. Для запуска процесса объединения нажмите кнопку ОК.

На рисунке ниже показана исходная схема сети и результат объединения участков, условия объединения заданы на рисунке выше. Красные участки одного типа, синие другого графического типа.

Схема с выделенными объектами до объединения

Рисунок 518. Схема с выделенными объектами до объединения

Результат объединения участков

Рисунок 519. Результат объединения участков

  • a - объединенные по типам участки;

  • b - соседние участки не объединены так как по правилам если в одной точке сходятся более двух участков, то там обязательно должен стоять узел;

  • с - участки не объединены так как в поле Балансодержатель внесены разные значения;

  • d - участки не объединены так как их соединяет узел не отмеченный для удаления.


Редактирование сети

Редактирование сети так же как и редактирование всех других слоев возможно только в режиме редактирования слоя. Операции редактирования сети условно можно разделить на:

  • Редактирование одиночных объектов сети – например, поворот объекта, удаление, перемещение и т.д. Данная операция применяется ко всему объекту (символьному объекту или участку сети) или группе объектов целиком.

  • Редактирование элементов объекта – например, перемещение, добавление, удаление точки перелома участка, перепривязка участка и т.д. Редактирование применяется к элементам объекта (отрезки, точки перелома).

  • Редактирование стиля объектов – изменение внешнего вида, размера символов, импорт символов и др. Стиль отображения типовых объектов сети изменяется в окне редактора структуры слоя.

[Примечание] Примечание

Видеоурок по редактированию сети можно посмотреть пройдя по одной из ссылок: https://youtu.be/BGO1Wd6FeW0 или https://www.politerm.com/videos/layeredit/redaktirovanie-seti/.


Редактирование объектов сети

Редактирование объектов сети включает следующие операции:

  • перемещение объекта;

  • поворот символьного объекта;

  • дублирование объекта;

  • смена типа или режима объекта;

  • удаление объекта;

  • добавление символьного объекта на существующий участок (разделение участка символьным объектом);

  • разделение участка символьными объектами с заданным шагом (разделение полилинию символами)

  • удаление объекта с нанесенной сети (объединение последовательно соединенных участков);

  • добавление объекта на участок без его разбиения;

  • ориентирование символьного объекта сети по направлению входящих в него участков;

  • отображение дугой пересечения линейных объектов.


Перемещение объекта

Объекты инженерной сети имеют типологическую связь друг с другом. Перемещение этих объектов может происходить двумя способами: с сохранением топологических связей или с их разрывом.

В первом случае изменяется только местоположение объекта, при этом связность других объектов остаётся неизменной, то есть топология сети не нарушается.

Во втором случае связь перемещаемого объекта с сетью прерывается, поэтому такое перемещение обычно применяется как промежуточная операция.

Для перемещения объекта с сохранением связей:

  1. Включите редактирование слоя ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Подведите курсор к на перемещаемому объекту.

    [Примечание] Примечание

    Перемещение выделенной группы объектов производится полностью аналогично перемещению одиночного объекта.

  4. Нажмите левую клавишу мыши и, не отпуская ее, начните перемещение.

  5. Переместите объект в новое положение.

  6. Для завершения перемещения отпустите левую клавишу мыши.

    Перемещение объекта с сохранением топологических связей

    Рисунок 520. Перемещение объекта с сохранением топологических связей

Для перемещения объекта с отрывом от сети:

  1. Включите редактирование слоя ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Подведите курсор к на перемещаемому объекту.

    [Примечание] Примечание

    Перемещение выделенной группы объектов производится полностью аналогично перемещению одиночного объекта.

  4. Нажмите и не отпускайте клавишу Shift.

  5. Нажмите левую клавишу мыши и, не отпуская ее, начните перемещение. После начала перемещения клавишу Shift можно отпустить.

  6. Переместите объект в новое положение.

  7. Для завершения перемещения отпустите левую клавишу мыши.

    Перемещение объекта с разрывом топологических связей

    Рисунок 521. Перемещение объекта с разрывом топологических связей

Так как в результате таких действий топологическая связь перемещаемого объекта нарушается, то данная операция как правило используется как промежуточная.


Поворот символьного объекта

[Примечание] Примечание

Кроме описанных ниже операций так же доступно ориентирование символьного объекта по направлению участков входящих в данный объект.

Поворот символа может осуществляться:

  • на произвольный угол с помощью мышки;

  • на угол, заданный с клавиатуры.

Для поворота на произвольный угол:

  1. Включите редактирование слоя ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Подведите курсор к объекту и нажмите левую клавишу мыши. Вокруг объекта отобразится рамка с небольшим кружком в одном из ее углов.

  4. Подведите курсор мыши к кружку, нажмите левую клавишу мыши.

  5. Перемещая мышь, поворачивайте символ до нужного угла.

  6. Сделайте щелчок левой кнопкой мыши.

Поворот символа на произвольный угол

Рисунок 522. Поворот символа на произвольный угол

Для поворота на заданный с клавиатуры угол:

  1. Включите редактирование слоя ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Подведите курсор к объекту и нажмите левую клавишу мыши, объект выделится.

  4. Щелкните правой кнопкой мыши и в открывшемся контекстном меню выберите Задать угол. Откроется диалог задания угла поворота.

  5. Введите угол поворота, нажмите кнопку ОК.

Поворот символа на заданный угол

Рисунок 523. Поворот символа на заданный угол


Дублирование объекта

Дублирование объекта является одним из способов создания нового объекта. В качестве исходного отмечается один из существующих объектов слоя, и на указанном месте создается новый объект с тем же типом, режимом и той же формы, что и исходный.

[Примечание] Примечание

Будут ли копироваться по мимо графических данных табличные зависит от настроек редактора в Структуре слоя (опция Копировать табличные данные при дублировании объекта).

Для дублирования:

  1. Включите редактирование слоя ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Подведите курсор к дублируемому объекту.

    [Примечание] Примечание

    Дублирование выделенной группы объектов производится полностью аналогично дублированию одиночного объекта.

  4. Нажмите и не отпускайте клавишу Shift.

  5. Нажмите левую клавишу мыши и, не отпуская ее, начните перемещение. После начала перемещения клавишу Shift можно отпустить.

  6. Нажмите и не отпускайте клавишу Ctrl. Перемещайте объект в новое положение.

  7. Отпустите левую клавишу мыши на месте копии объекта. Дублирование завершено.

    Для прерывания процесса дублирования нажмите правую клавишу мыши.

    Рисунок 524. Дублирование объекта


Смена типа/режима объекта или направления участка сети

[Предупреждение] Предупреждение

Чтобы при изменении типа объекта семантические данные совпавших полей остались прежними, необходимо выполнить определённые настройки в структуре слоя.

При изменении типа объекта следует учитывать правила редактируемой инженерной сети. Менять тип объекта можно только на тот тип, который должен иметь то же количество связей (участков).

Например, нельзя заменить разветвление, в которое входит и выходит несколько трубопроводов, на запорное устройство. Это связано с тем, что запорное устройство должно иметь только один вход и выход.

Все правила, касающиеся нанесения каждой сети, подробно описаны в справке по сетям.

Изменить параметры объектов можно двумя способами:

  1. В режиме редактирования слоя.

  2. Без редактирования слоя.

Смена типа или режима или направления участка сети в режиме редактирования слоя

  1. Включите редактирование слоя ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Подведите курсор к объекту и дважды щелкните на нем левой клавишей мыши. На экране появится диалог Смена режима. В зависимости от графического типа выделенного объекта будет отображен список доступных для смены типов и режимов. В верхнем разделе выбирается тип объекта, в нижнем его режим.

    Окно изменения режима/типа для символьного объекта

    Рисунок 525. Окно изменения режима/типа для символьного объекта

    Окно изменения режима/типа для участка

    Рисунок 526. Окно изменения режима/типа для участка

    Опция Сменить направление появляется только если изменяемый объект - участок.

  4. Для смены типа/режима выделите в диалоге нужный тип или режим объекта.

    Для смены направления участка на противоположное установите опцию Сменить направление.

  5. Чтобы подтвердить изменения нажмите кнопку ОК.

Смена типа или режима или направления участка сети без редактирования слоя

  1. Сделайте активным слой сети.

  2. Включите режим Выделить [image] .

  3. Щелкните левой кнопкой мыши по объекту, которому требуется изменить состояние, он замигает.

  4. Сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Объект| [image] Режим или на панели инструментов нажмите кнопку [image] .

  5. Для смены типа/режима выделите в диалоге нужный тип или режим объекта.

    Для смены направления участка на противоположное установите опцию Сменить направление.

  6. Нажмите кнопку ОК.

    Смена режима потребителя

    Рисунок 527. Смена режима потребителя

  7. В результате произойдет замена типа/режима или смена направления участков.

[Примечание] Примечание

После произведенных изменений возможно обносить состояние сети. В этом случае будут так же изменены состояния объектов, на которых изменения отразились. Например, в результате отключения участка потребители, которым теперь не будет поступать вода будут переведены в состояние Отключен.

Важно понимать, что обновлены будет ВСЕ сети указанного слоя. То есть все потребители, к которым не подведен участок или подведен отключенный участок будут переведены в режим Отключен. Такая же ситуация будет при отключенном источнике! Данная операция возврата (откате) НЕ ИМЕЕТ!

Если вы уверены что надо обновить состояние сети, то выберите меню Карта|Операции|Обновить состояние сети. Далее укажите слой, в котором требуется сделать обновления и нажмите кнопку ОК, после чего состояние сети обновиться.


Удаление объекта

В инженерных сетях удаление, описанное в этом разделе, применяется редко. Причина в том, что удаление объекта может привести к разрыву сети. Поэтому таким способом удаляют только начальные или конечные элементы сети!

Если же требуется удалить объект, который не является конечным, то для этого следует воспользоваться информацией из раздела «Исключение символьного объекта из нанесенной сети (объединение последовательно соединенных участков)».

[Предупреждение] Предупреждение

  • Отменить произведенное действие можно нажатием кнопки [image] на панели инструментов или комбинацией клавиш Ctrl и Z. Отмена действий возможна только до выхода из режима редактирования слоя!;

  • По умолчанию, если удаленному объекту соответствовала запись в базе данных, то для удаления этой записи базу данных необходимо сжать, для этого надо выбрать меню Карта|Запрос|По базе данных, в открывшемся диалоговом окне выбрать слой, и нажать кнопку Сжать. Так же возможно настроить правила редактора на удаление, в результате применения которых при удалении объекта запись так же будет удалена. Но в этом случае при отмене удаления (Ctrl и Z) семантические данные объекта будут потеряны!

Для удаления объекта:

  1. Включите редактирование слоя ( [image] ).

  2. Установите режим Объект ( [image] ).

  3. Отметьте удаляемый объект, щелкнув на нем левой клавишей мыши.

  4. Нажмите на панели инструментов кнопку [image] или клавишу Delete на клавиатуре или сделайте щелчок правой кнопкой мыши и выберите пункт Удалить. Объект будет удален.

    Для удаления вы можете выделить не один объект, а сразу несколько объектов.


Добавление символьного объекта на существующий участок (разделение участка символьным объектом)

Эта операция используется для добавления новых символьных объектов в нанесенную инженерную сеть. Например, можно добавить водопроводный колодец в участок водопроводной сети. После выполнения операции участок будет разделён на два новых участка, а между ними появится типовой символьный объект.

Есть несколько способов выполнить эту операцию:

  • вставить символьный объект в режиме его ввода;

  • вставить в участок введенный ранее символьный объект;

  • вставить символьный объект в режиме ввода участка;

  • вставить символьный объект в режиме Узлы.

[Примечание] Примечание

В системе реализована возможность разделить участок символьными объектами с заданным шагом.

[Примечание] Примечание

Для операций внедрения и удаления узловых объектов в структуре слоя имеется возможность настроить правила Редактора.

Вставить символьный объект в режиме его ввода

Для того чтобы вставить символьный объект в режиме его ввода:

  1. Включите редактирование слоя сети ( [image] ).

  2. Нажмите кнопку [image] . В открывшемся меню типовых объектов выберите символьный объект для ввода, например тепловую камеру.

  3. Подведите курсор к предполагаемому месту внедрения символьного объекта и удерживая клавиши CTRL+ALT [image] сделайте щелчок левой кнопкой мыши.

    Внедрение символа в участок в режиме его ввода

    Рисунок 528. Внедрение символа в участок в режиме его ввода

    Объект добавится в указанное место, а участок будет разделён.

    Для внедрения этого же символа в другие участки повторите пункт 3 столько раз, сколько это необходимо. Если требуется изменить символ для ввода, то вернитесь к пункту 2.

Вставить в участок введенный ранее символьный объект

Если символьный объект уже ранее введен, то его можно переместить и одновременно внедрить в участок тем самым разделив его на два участка, для этого:

  1. Включите редактирование слоя сети ( [image] ).

  2. Выберите режим Узлы - кнопка [image] .

  3. Подведите курсор к символьному объекту, нажмите левую клавишу мыши.

  4. Не отпуская левую клавишу мыши нажмите и удерживайте на клавиатуре клавишу ALT, курсор примет вид - [image] .

  5. Переместите объект на участок.

    Внедрение в участок ранее нанесенный символьный объект

    Рисунок 529. Внедрение в участок ранее нанесенный символьный объект

    Объект внедрится в указанное место, пори этом участок будет разделён на два.

Вставить символьный объект в режиме ввода участка

Вводя инженерную сеть в режиме ввода Участка, можно быстро внедрить узловой объект на существующую сеть и затем продолжить введение сети, для этого:

  1. Включите редактирование слоя сети.

  2. Нажмите кнопку [image] и в открывшемся списке выберите участок.

  3. Вы можете сначала начать вводить участок или сразу подвести курсор к предполагаемому месту внедрения объекта на уже существующем участке.

  4. Удерживая клавиши CTRL+ALT [image] сделайте одинарный или двойной щелчок левой кнопкой мыши зависимости от того ставите ли вы первую или конечную точку нового участка. В появившемся списке выберите объект для внедрения. Далее продолжайте вводить сеть.

    Внедрение символьного объекта в режиме ввода участка

    Рисунок 530. Внедрение символьного объекта в режиме ввода участка

    Выбранный из списка объект добавится в указанное место, а участок будет разделён.

Вставить символьный объект в режиме Узлы

Для внедрения объекта на существующий участок в режиме Узлы:

  1. Включите режим редактирования слоя ( [image] ).

  2. Выберите режим Узлы ( [image] ).

  3. Подведите к предполагаемому месту внедрения символьного объекта в участок, щелкните левой клавишей мыши. Указанное на ребре место отметится кружком (b).

  4. Сделайте щелчок правой кнопкой мыши, в появившемся контекстном меню выберите пункт Вставить символьный объект, после чего из списка типовых объектов данного слоя выберите нужный объект. Так же вставить символьный объект можно нажав на панели инструментов кнопку [image] . Разделение завершено.

Иллюстрация процесса разбиения участка

Рисунок 531. Иллюстрация процесса разбиения участка


Разделение участка символьными объектами с заданным шагом (разделение полилинии символами)

[Примечание] Примечание

Для данной операции в структуре слоя имеется возможность настроить правила Редактора.

Используя данную операцию вы можете разделить участки сети одинаковыми символьными объектами с заданным шагом. В результате выделенные участки будут разбиты на несколько частей одинакового размера, между которыми размещаются символы. Чтобы выполнить разделение:

  1. Включите редактирование слоя ( [image] ).

  2. Выделите один или группу участков для разделения.

  3. Выберите режим Объект ( [image] ).

  4. В области карты сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Разбить полилинию символами.

  5. В появившемся диалоговом окне укажите:

    • В разделе Шаг разбиения внесите шаг в метрах с которым будут разбиты участки символами.

    • Выберите положение переключателя По сфероиду или По проекции. По умолчанию установлена опция По сфероиду. Именно такой вариант позволяет производить построения в натуральную величину без искажений размеров вводимых объектов.

    • Нажмите кнопку Символ и выберите символ для разделения.

    • Из списка Способ разбиения укажите как будет производится работа с остатком линии:

      - Остаток разбиения в конце линии;

      - Остаток разбиения в начале линии;

      - Округлять шаг до разбиения на равные части.

    • При необходимости отметьте дополнительные опции:

      - Разбивать до остатка - опция будет доступна только если разделение производится с остатком. При ее выборе участок будет разбит до конца, остаток будет меньше указанного шага.

      - Ориентировать символы по направлению линии - при установке данной опции внедренные символы будут ориентированы по направлению участков.

    • Для запуска процедуры разделения нажмите кнопку ОК. Кнопка Отмена закроет диалог Разбиение линии символами без сохранения.

      Диалоговое окно Разбиение линий символами

      Рисунок 532. Диалоговое окно Разбиение линий символами

    Рисунок 533. Результат разделения


Исключение символьного объекта из нанесенной сети (объединение последовательно соединенных участков)

Если два участка сети имеют общий символьный объект, который связан только с этими участками, то этот объект можно исключить таким образом, что два связанных с ним участка объединятся в один, а на месте исключенного узла будет точка перелома объединенного участка.

В отличие от простого удаления, при котором концы участков «повисают», в этом случае, несмотря на изменение топологии (сеть уменьшается на один узел и одно ребро), связность сети при этом не нарушается.

[Примечание] Примечание

Для операций внедрения и исключения символьных объектов в структуре слоя имеется возможность настроить правила Редактора.

Для исключения символьного объекта:

  1. Включите редактирование слоя ( [image] ).

  2. Выберите режим Узлы [image] .

  3. Отметьте удаляемый объект. Для этого надо подвести курсор к объекту и нажать левую клавишу мыши (b).

  4. Щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Исключить символьный объект или нажмите на панели инструментов кнопку [image] . В результате этого действия объект удалится, а два участка превратятся в один.

Иллюстрация процесса удаления объекта

Рисунок 534. Иллюстрация процесса удаления объекта

[Примечание] Примечание

Если число связей отмеченного символьного объекта отлично от двух. То есть у него связь с тремя и более участками или связь только с одним участком, то удаление объекта не произойдет. Такие объекты можно либо заменить на другие либо удалить с помощью кнопки [image] . Но надо помнить, что при таком удалении сеть будет разорвана!


Добавление символьного объекта на участок без его разбиения

В результате данной операции к точке перелома участка сети будет добавлен (прикреплен) символьный объект, при этом разбиение участка не происходит. Такая операция может понадобиться в том случае, когда участок требуется пометить символом. В расчетах добавленный таким образом символ участвовать не будет. В инженерных сетях таким символом может случить например символ аварии на участке.

[Примечание] Примечание

Символ может добавляться не только на типовые объекты но и на точки перелома простых линейных или площадных объектов.

Для добавления символа на участок без его разбиения:

  1. Включите редактирование слоя ( [image] ).

  2. Выберите режим Узлы [image] .

  3. Для открытия меню типовых объектов нажмите кнопку [image] и выберите в списке символ для добавления.

  4. Символ прикрепляется к точке перелома участка, поэтому сначала удобней включить отображение узлов - кнопка [image] . Если точки перелома нет на объекте, то подведите курсор к месту желаемого прикрепления и удерживая клавишу Alt на клавиатуре сделайте щелчок левой кнопкой мыши по нему. В результате будет добавлена точка перелома и выбранный символ будет прикреплен к ней.

    Если точка перелома уже есть, то подведите курсор с символом к ней и удерживая клавишу Ctrl на клавиатуре сделайте щелчок левой кнопкой мыши. В результате выбранный символ будет прикреплен к указанной точке перелома.

    Добавления объекта на участок без его разбиения

    Рисунок 535. Добавления объекта на участок без его разбиения

[Примечание] Примечание

Открепить символ от участка можно в режиме Объект [image] или Узлы [image] с нажатой клавишей Shift.


Ориентирование символьного объекта сети по направлению входящих в него участков

Для выполнения ориентации уже нанесенных символьных объектов сети по направлению участков входящих в данный объект:

  1. Включите редактирование слоя ( [image] ).

  2. Выделите символьные объекты для ориентирования.

  3. В области карты нажмите правую кнопку мыши и выберите в открывшемся контекстном меню команду Ориентировать по участкам.


Отображение дугой пересечения линейных объектов

  • Создание пересечения

  • Удаление пересечения

  • Настройка пересечения линий

Можно графически обозначить дугой место пересечения типовых линейных объектов как показано на рисунке ниже. Чтобы обозначить пересечение на участке, необходимо предварительно определить точку перелома (узел), которая будет центром обозначения пересечения.

Рисунок 536. Схема сети

Создание пересечения

Для создания пересечения на сети:

  1. Включите редактирование слоя ( [image] ).

  2. Выберите режим Узлы [image] .

  3. Выделите точку перелома (узел) которая будет центром пересечения. В том случае, если в нужном месте узла нет, то его следует добавить.

  4. Сделайте щелчок правой кнопкой мыши и в контекстом меню выберите пункт Отметить пересечение линий.

Удаление пересечения

Для удаления пересечения на сети:

  1. Включите редактирование слоя ( [image] ).

  2. Выберите режим Узлы [image] .

  3. Выделите точку перелома (узел) которая является будет центром пересечения.

  4. Сделайте щелчок правой кнопкой мыши и в контекстом меню выбрать пункт Отметить пересечение линий.

Настройка пересечения линий

У пересечения линий настраивается масштаб и радиус дуги. Настройка производится отдельно для каждого режима линейного объекта. Для настройки:

  1. Откройте структуру слоя.

  2. Из дерева типов и режимов выберите режим, которому надо настроить пересечение линий.

  3. Справа в разделе Пересечение линий укажите:

    • Радиус - радиус пересечения в пикселях;

      [Примечание] Примечание

      Масштаб на карте может быть представлен в двух вариантах: геодезическом и в сантиметрах на пиксель. Выбор нужного масштаба осуществляется в параметрах системы.

    • Масштаб - указывается масштаб карты с которого пересечения будут уменьшаться, для включения масштабирования так же надо установить опцию Масштабировать.

      Рисунок 537. Настройка пересечений

  4. Сохраните произведенные изменения - кнопка Сохранить [image] .


Редактирование элементов объекта

Редактирование элементов объекта:

  • перемещение точки перелома (узла);

  • перемещение отрезка сети;

  • добавление точки перелома (узла);

  • автоматическое добавление точек перелома (узлов);

  • удаление точки перелома (узла);

  • перепривязка участка.


Перемещение отрезка сети

Для перемещения отрезка:

  1. Включите редактирование слоя ( [image] ).

  2. Выберите режим Узлы [image] .

  3. Подведите курсор к отрезку, нажмите левую клавишу мыши. Не отпуская клавишу переместите отрезок на нужное место. Так как объекты сети связаны между собой, то в перемещении будут участвовать все части перемещаемого участка и связанные с ним объекты. Если все же необходимо «отцепить» участок от других объектов, то перед нажатием левой клавиши мыши нужно нажать и удерживать клавишу Shift. После захвата вершины Shift можно отпустить.

    Перемещение отрезка сети

    Рисунок 539. Перемещение отрезка сети

  4. Отпустить левую клавишу мыши (c).


Добавление точки перелома (узла)

Данная операция позволяет добавить на участок точку перелома, которая одновременно может являться точкой поворота для участка.

Для добавления точки перелома на участок:

  1. Включите редактирование слоя ( [image] ).

  2. Выберите режим Узлы [image] .

  3. Подведите к ребру курсор и щелкните в месте предполагаемого перегиба участка левой кнопкой мыши с прижатой клавишей Ctrl на клавиатуре.

    Или нажмите кнопку [image] на панели редактирования.

    Или щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Добавить точку перелома.

    После проделанных действий будет создана новая точка перелома на участке, затем при необходимости точку можно переместить.

    Иллюстрация процесса внедрения узла

    Рисунок 540. Иллюстрация процесса внедрения узла


Автоматическое добавление точек перелома

Вы можете автоматически вставить на участки точки перелома с заданным шагом разбиения. Они могут быть добавлены как для одного объекта, его сегмента или его отрезка, так и для группы объектов одновременно.

[Примечание] Примечание

Для отображения существующих точек перелома слоя нажмите на панели инструментов кнопку [image] .

Чтобы автоматически вставить точки перелома:

  1. Включите редактирование слоя, в котором будут производится изменения ( [image] ).

  2. Если добавлять точки перелома надо группе, то выделите ее. Если одному объекту, пропустите данный пункт.

  3. Выберите нужный режим:

    • Объект [image] - если работа будет проводиться с группой участков;

    • Узлы [image] - если работа будет проводиться с элементами объекта (сегментом или отрезком) или одним этим объектом.

  4. В зависимости от выбранного режима сделайте щелчок левой кнопкой мыши по одному из объектов группы или по ребру объекта, его сегменту или отрезку.

  5. Сделайте щелчок правой кнопкой мыши и в контекстом меню выберите пункт Вставить точки перелома.

  6. В открывшемся диалоговом окне укажите:

    • В разделе Шаг разбиения внесите шаг в метрах с которым будут добавлены точки перелома.

    • Выберите положение переключателя По сфероиду или По проекции. По умолчанию установлена опция По сфероиду. Именно такой вариант позволяет производить построения в натуральную величину без искажений размеров вводимых объектов.

    • Из списка Способ разбиения укажите как будет производится работа с остатком линии:

      - Остаток разбиения в конце линии;

      - Остаток разбиения в начале линии;

      - Округлять шаг до разбиения на равные части.

    • При необходимости отметьте дополнительные опции:

      - Разбивать до остатка - опция будет доступна только если разделение производится с остатком. При ее выборе участок будет разбит до конца, остаток будет меньше указанного шага.

    • Выберите элемент разбиения: Объект, Сегмент или Отрезок. Два последних будут доступны только в режиме Узлы [image] .

  7. Для запуска процедуры разделения нажмите кнопку ОК. Кнопка Отмена закроет диалог Вставка точек перелома без сохранения.

    Процесс автоматического добавления точек перелома отрезка

    Рисунок 541. Процесс автоматического добавления точек перелома отрезка


Удаление точки перелома (узла)

Ошибочно введенный или лишний узел на участке можно удалить, либо указывая удаляемую точку на карте, либо указывая ее в панели свойств.

Для удаления точки перелома первым способом:

  1. Включите редактирование слоя ( [image] ).

  2. Выберите режим Узлы [image] .

  3. Выделите удаляемую точку перелома, для этого надо сделать щелчок левой кнопкой мыши на ней. Нажмите на панели инструментов кнопку [image] или на клавиатуре кнопку Delete. Так же можно щелкнуть правой кнопкой мыши и в появившемся контекстном меню выбрать пункт Удалить точку перелома.

    Иллюстрация процесса удаления точки перелома

    Рисунок 542. Иллюстрация процесса удаления точки перелома

Возможен второй способ удаления точки перелома:

  1. Нажмите кнопку Панель свойств [image] . В правой части экрана появится окно Свойства.

  2. Выберите режим Узлы [image] .

  3. Подведите курсор к участку, на котором находится удаляемая точка, нажмите левую клавишу мыши. В окне свойств отобразятся параметры участка: координаты начальной, конечной и промежуточных точек, длина и азимут промежуточных отрезков.

    При перемещении в окне Свойств, точки соответствующие строке, на которой находится курсор, будут выделяться черным квадратом.

  4. Поставьте курсор на строку, соответствующую удаляемой точке и нажмите на клавиатуре комбинацию клавиш Ctrl+Delete (b).

  5. Выделенная точка и строка, соответствующая ей удалится, а отрезок выпрямится (c).

    Иллюстрация процесса удаления точки перелома с помощью панели Свойства

    Рисунок 543. Иллюстрация процесса удаления точки перелома с помощью панели Свойства


Перепривязка участка

Для перепривязки участка от одного объекта к другому:

  1. Включите редактирование слоя ( [image] ).

  2. Выберите режим Узлы [image] .

  3. Отметьте щелчком перепривязываемый участок, щелкнув по нему левой кнопкой мыши. На отмеченном участке будет отмечены узлы (a).

    [Примечание] Примечание

    Клавиша Shift в данном случае используется для того, чтобы «оторвать» участок от объекта.

    Иллюстрация процесса перепривязки участка

    Рисунок 544. Иллюстрация процесса перепривязки участка

  4. Удерживая левую клавишу мыши и Shift отведите участок в сторону (b). Таким образом отцепляется участок от объекта.

  5. Щелчком левой кнопкой мыши «ухватитесь» за конечную точку участка. Не отпуская клавишу мыши и удерживая клавишу Ctrl на клавиатуре подведите конец участка к узлу привязки, при этом вид курсора изменится на следующий [image] (c).

  6. Отпустите клавишу мыши для окончания перепривязки участка (d).

    [Примечание] Примечание

    Клавиша Ctrl в данном случае используется для того, чтобы участок «прицепился» к объекту.


Изменение внешнего стиля объекта

Стиль любого объекта, уже добавленного на карту или который вы только собираетесь добавить, можно изменить. Для этого нужно воспользоваться окном редактора структуры слоя. Изменения, внесённые в стиле, будут применяться ко всем объектам выбранного типа на карте.

Редактор структуры слоя позволяет:

  • создать, удалить или отредактировать символ;

  • поменять размер символов;

  • импортировать символ из другого слоя;

  • импортировать типы и режимы из других слоев;

  • создавать и редактировать тип объекта;

  • создавать и редактировать режим объекта;

  • настраивать правила для слоя, применяемые при редактировании объектов.


Данные WMS и WMTS

  • «WMS слой»

  • «Задание WMS слоя»

  • «WMTS слой»

  • «Задание WMTS слоя»

Сервис WMS позволяет получить доступ к картам и данным через локальную сеть или через интернет с удаленных серверов, которые поддерживают данную спецификацию. Протокол разработан консорциумом открытых ГИС (Open GIS Consortium – OGC).

ZuluGIS и ZuluServer реализуют спецификации WMS 1.1.1, WMS 1.3.0 (Open GIS Consortium – OGC). Это позволяет получать информацию с картографических серверов, которые поддерживают данные протоколы.

Наши продукты протестированы на совместимость с этими стандартами и имеет соответствующий сертификат:

Рисунок 545. Сертификат OGC


WMS слой

Общие сведения

WMS (Web Map Service) – это протокол, созданный для работы через интернет с географически привязанными изображениями. Изображения генерируются картографическим сервером на основе данных из баз данных ГИС. Таким образом, WMS позволяет получить доступ к картам и данным через локальную сеть или через интернет с удаленных серверов, которые тоже удовлетворяют данным спецификациям. Данный протокол был разработан консорциумом открытых ГИС (Open GIS Consortium – OGC).

ZuluGIS реализует спецификации организации OGC WMS 1.1.1, WMS 1.3.0, программа протестирована на совместимость с этими стандартами и имеет соответствующие сертификаты.

В результате пользователь, зная адреса, может использовать данные с серверов WMS для работы. Слой WMS может использоваться как подложка на карте, при этом к нему также можно добавлять свои собственные слои. Возможно задание прозрачности слоя.


Задание WMS слоя

Для использования данных с удаленного сервера необходимо эти данные загрузить и сохранить как WMS слой, для этого:

  1. Откройте карту, в которую планируется добавить слой WMS. Выполните команду меню Слой|WMS. Откроется диалог Параметры WMS.

    Окно Параметры WMS

    Рисунок 546. Окно Параметры WMS

  2. В поле Сервер WMS введите адрес веб–сервера (ранее вводимый адрес можно выбрать из списка).

  3. В том случае, если для данных необходим Referer внесите его в строку Referer, в конце всегда ставится ?

  4. При повторном вводе адреса нажмите кнопку Запросить, при выборе адреса из списка, запрос к серверу происходит автоматически. После запроса к серверу в окне Слои WMS будут отображены доступные слои сервера, в списке Проекция указана проекция, и, в том случае, если слой имеет стили, при его выделении они будут указаны в списке Стиль. У слоя, не содержащего атрибутивные данные, иконка будет серого цвета, в противном случае – синего.

  5. Для просмотра слоя можно выбрать его в списке и нажать кнопку Показать слой.

  6. Следующий этап: выбор тех слоев, которые в дальнейшем будут сохранены. Для выбора слоя выделите его в списке Слои WMS и нажмите кнопку [image] , если слой выбран ошибочно, то удалить его из списка можно с помощью кнопки [image] .

    Напротив выбранных слоев будут отображены иконки: и [image] , щелкая по ним, вы можете отключить видимость слоя и получаемую информацию, соответственно. Если данные отключены, иконки будут отображены серым цветом.

    Выбранные слои в дальнейшем будут отображены в обратном порядке их выбора, то есть самый верхний слой будет последним в выбранном списке. Если нужно поменять порядок отрисовки слоёв, воспользуйтесь кнопками [image] и [image] . Полученный результат можно увидеть, нажав кнопку Показать результат. Необходимо учитывать, что встречается такой размер слоев, что в результате масштабирования он может быть не виден в диалоге.

  7. Далее установите параметры для WMS слоя:

    • проекцию – список доступных проекций определяется настройками сервера, при неправильно выбранной проекции данные могут быть искажены;

    • формат растра (png, gif, jpeg) – формат jpeg используется в том случае, если не принципиально качество изображения, так как алгоритм сжатия предполагает его небольшую потерю. Использование png формата подразумевает более качественное воспроизведение слоев, при этом, соответственно, объем информации будет увеличен;

    • прозрачность или цвет фона – прозрачность доступна только для форматов png, gif. Формат jpeg ее не поддерживает!

    • подбор полупрозрачности – при установке данной опции запускается алгоритм оптимизации изображения; на рисунке ниже слева выведено изображение без подбора полупрозрачности, справа – с подбором:

      Слева – слой WMS без подбора полупрозрачности, справа – с подбором полупрозрачности

      Рисунок 547. Слева – слой WMS без подбора полупрозрачности, справа – с подбором полупрозрачности

    • формат получаемой информации (text/plain, text/html, aplication/vnd.ogc) – данная опция определяет, в каком формате будет получен ответ на запрос информации от сервера:

      • text/plain – простой текст, при каждом запросе будет скачиваться текстовый файл;

      • text/html – текст в формате HTML, при запросе откроется браузер с данными объекта;

      • application/vnd.ogc.gml – ответ в формате GML.

    • максимальную ширину и высоту – от сервера данные получаются в виде множества квадратов, необходимо задать их максимальный размер, надо учитывать, что чем меньше указанные значения, тем меньше качество изображения в результате малого разрешения.

  8. В поле Название введите пользовательское название слоя.

  9. Нажмите кнопку Сохранить, укажите папку и введите имя файла, снова нажмите кнопку Сохранить, после чего созданный слой будет загружен в текущую карту.

  10. Для закрытия диалогового окна Параметры WMS нажмите кнопку ОК.

[Примечание] Примечание

Параметры прокси-сервера для выполнения HTTP запросов к WMS и тайл-серверам задаются в диалоге Сервис|Параметры|Сеть.


WMTS слой

Общие сведения

WMTS (Web Map Tile Service) – стандарт, разработанный консорциумом открытых ГИС (Open GIS Consortium – OGC), является открытой спецификацией для публикации в сети цифровых карт с использованием кэшированных листов изображений. WMTS сервисы являются заранее вычисленным и кэшированным рядом небольших листов, покрывающих экстент карты. Эти сервисы не имеют легенды и не позволяют включать/выключать отдельные подслои в слой карты сервиса.

ZuluGIS реализует работу с сервисами WMTS по спецификации организации OGC WMTS 1.0.0, которые используют в запросах либо кодировку REST, либо "ключ/значение" (KVP). Подробнее о сервисах WMTS можно узнать на веб-сайте организации: Open Geospatial Consortium (http://www.opengeospatial.org/standards/wmts).

ZuluGIS взаимодействует с сервисом WMTS путем добавления параметров к URL сервиса. Для обращения к сервису WMTS необходимо знать URL, который имеет следующий формат:

http://<имя сервера или ip адрес>:<порт>/<URI сервиса>


Задание WMTS слоя

Для использования данных с удаленного сервера необходимо эти данные загрузить и сохранить как WMTS слой, для этого:

  1. Выполните команду меню Слой|Задать WMTS. Откроется диалог WMTS задать параметры слоя.

    Окно параметров WMTS слоя

    Рисунок 548. Окно параметров WMTS слоя

  2. В поле Источник введите URL сервиса WMTS.

  3. Нажмите кнопку Соединится. Список Слой заполнится списком слоев, прочитанных с сервера, а таблица содержания, соответственно, заполнится списками стилей, схем листов и проекций для каждого слоя.

  4. Выберите нужный слой и соответствующие параметры в таблице содержания:

    • стиль;

    • схема листов;

    • проекция.

  5. В поле Название слоя введите пользовательское название слоя.

  6. Нажмите кнопку Сохранить, введите имя файла и снова нажмите кнопку Сохранить.

  7. Для закрытия диалогового окна WMTS задать параметры слоя нажмите кнопку ОК.

Для загрузки слоя в карту:

  1. Выберите меню Карта|Добавить слой или нажмите кнопку [image] .

  2. Укажите на диске созданный ранее слой.

  3. Нажмите кнопку Открыть.

[Примечание] Примечание

Параметры прокси-сервера для выполнения HTTP запросов к WMS, WMTS и тайл-серверам задаются в диалоге Сервис|Параметры|Сеть.


Слой Tile-сервера

Общие сведения

  • «Добавление «базового» слоя «подложки» с Tile-сервера»

  • «Работа со слоем Tile-сервера»

    • «Настройка и подключение описателя Tile-сервера»

    • «Кэширование данных Tile-сервера»

  • «Примеры подключения тайловых слоев»

  • «Используемые проекции»

  • «Система координат тайловой системы»

  • «Формирование запроса к Tile-серверу»

  • «Сдвиг тайлового слоя»

  • «Настройка прозрачности тайлового слоя»

  • «Рабочая область тайлового слоя»

В настоящее время многие ГИС сервера, такие как Google Maps, OpenStreetMaps, Wikimapia, Яндекс Карты, HERE WeGO Maps, Космоснимки и другие, имеют возможность предоставлять картографическую информацию в виде растровых изображений, нарезанных на небольшие части – плитки или тайлы (tile). Часто в качестве тайлов используются квадраты со стороной 256 пикселей. Из этих плиток формируется изображение всей территории в нескольких фиксированных масштабах. Все плитки одного масштаба образуют уровень (level). Уровень на единицу больше данного содержит в четыре раза больше плиток. Таким образом, каждая плитка одного уровня представляется на следующем уровне четырьмя плитками. Совокупность плиток всех уровней образует тайловую систему (tile system).

Система ZuluGIS предоставляет функциональные возможности по использованию картографических данных с таких Tile-серверов в качестве слоев карт и нарезке растровых слоев на плитки для последующего использование на Tile-сервере. В качестве Tile-сервера может использоваться система ZuluServer.

[Примечание] Примечание

Для упрощения работы со слоями Tile-серверов несколько таких слоев уже встроены в меню системы, и для использования их в качестве «базового» слоя «подложки» они просто добавляются в карту. Как это сделать, можно узнать в разделе «Добавление «базового» слоя «подложки» с Tile-сервера».

[Примечание] Примечание

Параметры прокси-сервера для выполнения HTTP запросов к WMS и тайл-серверам задаются в диалоге Сервис|Параметры|Сеть.

[Предупреждение] Предупреждение

Функционал системы ZuluGIS по загрузке данных с Tile-серверов не предназначен для скачивания данных, защищенных авторским правом, без разрешения их правообладателями. Реальные названия серверов используются только для примера реализации соответствующих моделей формирования запросов.

Функции загрузки данных с Tile-серверов предназначены для доступа к Tile-серверам, специально организованным для работы с системой ZuluGIS, или к серверам, в условиях использования которыми явно оговорено разрешение на скачивание данных с помощью сторонних программ.


Работа со слоем Tile-сервера

  • «Кэширование данных Tile-сервера»

Слой Tile-сервера системы ZuluGIS – это особый тип слоя, который позволяет работать с данными тайловых систем, соответствующих одной из моделей, описанных ранее. Параметры Tile-сервера хранятся в описателе слоя, который представляет собой текстовый файл с расширением zww. Структура описателя Tile-сервера описана в приложении Формат файла описателя Tile-сервера.

При работе с тайловым слоем имеется возможность при необходимости произвести его сдвиг в ту или иную сторону или настроить прозрачность.

Настройка и подключение описателя Tile-сервера

Настройка описателя Tile-сервера и его подключения в качестве слоя карты выполняется с помощью диалога Параметры Tile-сервера программы ZuluGIS. Для открытия диалога выполните команду главного меню программы ZuluGIS Слой|Tile-сервер|Задать.

[Примечание] Примечание

В системе уже реализована интеграция некоторых тайловых слоев, которые возможно использовать в работе при соблюдении соответствующих авторские прав. Как добавить такие слои в карту, можно узнать в разделе «Добавление «базового» слоя «подложки» с Tile-сервера».

[Примечание] Примечание

Видеопример, демонстрирующий создание описателя Tile-сервера: https://www.politerm.com/videos/tile/tile_create/.

Диалог настройки описателя Tile-сервера

Рисунок 549. Диалог настройки описателя Tile-сервера

В группе настроек Слой задается описатель Tile-сервера, используемый в качестве слоя:

  • В поле Имя файла описателя отображается название выбранного файла-описателя слоя, при работе с ZuluServer слой следует сохранять на сервере;

  • В поле Название слоя задается название слоя карты, в котором отображаются графические данные с Tile-сервера. В объектной модели соответствует свойству Layer.UserName;

  • Для того чтобы выбрать уже существующий файл-описатель, нажмите кнопку Открыть и выберите файл-описатель на диске;

  • Для того чтобы очистить параметры описателя и задать их с нуля, нажмите кнопку Новый;

  • По завершении редактирования параметров описателя нажмите кнопку Сохранить, чтобы сохранить изменения в текущем файле-описателе, или кнопку Сохранить как, чтобы сохранить новый файл-описатель.

В группах полей Запрос и Уровни задаются параметры обращения к Tile-серверу). Часть полей данного раздела могут становиться неактивными в том случае, если они не используются в выбранной модели обращения к серверу:

  • В поле запрос задается строка шаблона запроса, зависящая от используемой сервером модели запроса. При использовании модели кэша SAS.Планета, нажав кнопку … справа от поля, можно указать путь к папке кэша.

    Для модели Zulu Server параметр должен содержать URL тайлового слоя на ZuluServer, например:

    Address: zulu://zs.zulugis.ru:6473/osm/Relief_Maps-For_Free.zl

    Для всех остальных моделей параметр должен содержать шаблон HTTP запроса, обязательно начинаясь с указания протокола «http://», например:

    Address: http://www.maps-for-free.com/layer/relief

  • В поле со списком Модель выбирается используемая модель обращения к серверу;

  • В поле со списком Проекция выбирается код используемой картографической проекции;

  • В поле со списком Порядок координат задается последовательность указания параметров X и Y в модели «OpenStreetMap»;

  • В поле Расширение задается расширение запрашиваемого файла изображения. Применяется для моделей «OpenStreetMap» и «Map-For-Free». Для остальных моделей расширение изображения либо жестко задано, либо определяется динамически;

  • В полях Широта и Долгота группы настроек Начало отсчета указываются, соответственно, широта и долгота точки начала отсчета;

  • В полях По широте и По долготе группы настроек Ориентация осей задается ориентация осей Y и X;

  • В полях со списком Минимальный и Максимальный группы настроек Уровни задаются минимальный и максимальный уровень запрашиваемых с сервера плиток;

  • При установке флажка Использовать кэш запрашиваемые данные кэшируются, путь к папке кэша указывается в поле Папка кэша (см. «Принудительное кэширование данных Tile-сервера»).

После завершения настройки параметров доступа к Tile Server нажмите кнопку Закрыть и подтвердите добавление слоя в карту.

[Примечание] Примечание

Чтобы обеспечить плавное масштабирование карты с тайловыми слоями, в диалоге настройки карты (Карта|Настройка) необходимо отключить опцию Дискретный масштаб с тайловыми слоями.

Возможно задание прозрачности слоя: «Настройка прозрачности тайлового слоя»


Кэширование данных Tile-сервера

  • «Просмотр местоположения кэша»

  • «Принудительное кэширование данных Tile-сервера»

  • «Создание данных для Tile-сервера»

  • «Обновление кэша Tile-сервера»

При работе с Tile-сервером кэширование – это сохранение на жестком диске полученных с сервера растровых изображений с целью их дальнейшего многократного использования без повторных обращений к серверу.

[Примечание] Примечание

Для слоя OpenStreetMap кэширование не производится.

Если кэш содержит достаточное количество данных для работы, пользователь может работать с этими данными offline, не загружая глобальную сеть.

Изображения, сохраняемые на диске, должны быть организованы определенным образом.

Текущая версия ZuluGIS и ZuluServer для организации кэшируемых файлов использует файловую структуру кэша программы SAS.Планета.

<Корневая папка>\z[Z+1]\[X/1024]\x[X]\[Y/1024]\[Y].<EXT>

Следует отметить, что, независимо от системы отсчета плиток в исходной тайловой-системе, в кэш плитки складываются всегда в системе координат Lat0 = 90, Lon0 = -180, ось X – на восток, ось Y – на юг. Для записи в кэш нового файла, его исходные параметры X, Y, Z сначала преобразуются в новые параметры X, Y, Z для кэша. При совпадении систем координат тайлового слоя и кэша параметры X, Y, Z не изменятся.

Корневая папка

Местоположение корневой папки кэша, создаваемого ZuluGIS или ZuluServer на компьютере, определяется следующим образом:

<Папка приложений для всех пользователей>\Zulu\ztc_<Код кэша>\

Папка приложений для всех пользователей – это системная папка для создания приложениями данных для всех пользователей компьютера.

В зависимости от используемой операционной системы, путь папки может быть разным.

Windows XP:

C:\Documents and Settings\All Users\Application Data\

Windows 10:

C:\ProgramData\Zulu\Tiles

Код кэша – числовой код, автоматически формируемый ZuluGIS, как контрольная сумма строки с шаблоном запроса (значение параметра Address в описателе).

Пример:

Address:

http://www.maps-for-free.com/layer/relief/

Папка кэша:

Windows XP:

C:\Documents and Settings\All Users\Application Data\Zulu\ztc_2138735954\

Windows 10:

C:\ProgramData\Zulu\Tiles\ztc_2138735954\

Для плитки Z = 15, X = 19141, Y = 9525 имя файла в формате PNG в Windows 10 сформируется так:

C:\ProgramData\Zulu\Tiles\ztc_2138735954\z16\18\x19141\9\y9525.png

Выбор общей для всего компьютера папки и создание единого кода для разных описателей с одинаковым шаблоном запроса позволяет избежать дублирования кэша для одних и тех же данных.

[Примечание] Примечание

Корневая папка для кэширования тайловых данных, отличная от папки по умолчанию, может быть задана через меню Сервис|Параметры|Сеть.

Варианты кэширования

Возможны несколько вариантов использования механизма кэширования.

Первый вариант. Описатель слоя расположен на том же компьютере, и в шаблоне запроса указана связь с данными по протоколу HTTP.

Address: http://<шаблон запроса>

В этом случае запросы на получение плиток идут непосредственно к указанному в шаблоне серверу. Полученные плитки складываются в кэш на этом компьютере.

При этом, если в организации несколько компьютеров обращаются к одному и тому же ресурсу глобальной сети, на каждой машине будет создаваться свой кэш, а общая нагрузка на глобальную сеть возрастет пропорционально количеству пользователей.

Второй вариант. Описатель тайлового слоя можно разместить на компьютере, где установлен ZuluServer, и опубликовать данный слой как слой ZuluServer, создав соответствующий описатель.

Например, если в область данных сервера поместить описатель sample.zww, то для его публикации на сервере достаточно создать в той же папке текстовый описатель sample.zl с одной строкой:

Path: sample.zww

В этом случае клиенты ZuluServer будут обращаться за данными не прямо к серверу тайловых данных, а к тайловому слою, опубликованному на ZuluServer (например, Zulu://zs_host:6473/sample.zl).

При обращении клиента к ZuluServer за плиткой, ZuluServer проверит, нет ли такого изображения в кэше сервера. Если изображение найдено в кэше сервера, оно будет отправлено клиенту без обращения в глобальную сеть. Если изображение в кэше отсутствует, ZuluServer запросит его из глобальной сети, положит себе в кэш и отправит клиенту.

Таким образом, ZuluServer может выступать как посредник в предоставлении данных тайл-сервера клиенту.

Удобство такого варианта в том, что для всех клиентов ZuluServer кэш будет создаваться в одном месте, на диске сервера, сильно сокращая количество запросов в глобальную сеть и существенно экономя дисковое пространство клиентских машин.

Кроме того, при таком подходе клиентские машины вообще могут не иметь доступа в интернет.

Третий вариант. Кэш располагается на локальном компьютере, но данные для него запрашиваются не из глобальной сети, а от ZuluServer.

Для этого нужно создать на локальной машине описатель с моделью «Тайловый слой ZuluServer» и в шаблоне запроса указать имя тайлового слоя на сервере:

Method: ZS Address: Zulu://zs_host:6473/sample.zl

В этом случае для получения изображения клиент проверяет, нет ли его в локальном кэше. Если нет, клиент обращается за изображением на ZuluServer. ZuluServer проверяет, нет ли изображения в его кэше.

Если нет, ZuluServer обращается за изображением в глобальную сеть, получает изображение, сохраняет его в своем кэше и отправляет клиенту.

Клиент, получив изображение от ZuluServer, кладет изображение в свой кэш.

При таком комбинированном варианте клиент нагружает ZuluServer только по необходимости, а ZuluServer только по необходимости загружает глобальную сеть.


Просмотр местоположения кэша

Если вы работаете с tile-слоем локально, то можете увидеть расположение кэша. Однако если работа осуществляется на ZuluServer, то местоположение кэша не будет отображаться.

Для просмотра расположение кэша tile-слоя:

  1. Сделайте активным тайловый слой.

  2. Включите режим Информация - [image] .

  3. Щелкните левой кнопкой мыши на объекте в той области, где надо заменить плитку.

  4. В результате откроется окно с загруженной плиткой. В котором так же будет отображен полный путь до файла кэша и адрес запроса tile-слоя.

    Диалог работы с кэшем Tile-сервера

    Рисунок 550. Диалог работы с кэшем Tile-сервера


Принудительное кэширование данных Tile-сервера

Вы можете выполнить принудительное кэширование всех или части графических данных. Управление кэшированием на удаленном сервере ZuluServer возможно только при наличии соответствующих прав.

Для принудительного кэширования:

  1. Выполните команду меню Слой|Tile-сервер|Кэшировать.

    Диалог работы с кэшем Tile-сервера

    Рисунок 551. Диалог работы с кэшем Tile-сервера

  2. Нажмите кнопку [image] справа от поля Имя файла и выберите файл-описатель для доступа к требуемому Tile-серверу. В поле Название отобразится название сервера, а в поле Папка кэша – путь к папке кэша. Путь будет отображен только при локальной работе с данными.

  3. В полях Диапазон уровней укажите минимальный и максимальный уровни диапазона кэшируемых тайлов.

  4. В поле Область кэширования укажите, какую часть карты следует кэшировать:

    • текущий вид – отображаемую область в активном окне карты;

    • габариты карты;

    • габариты слоя;

    • объекты слоя.

  5. Если в качестве области кэширования были выбраны габариты слоя или его объектов, в поле Слой требуется выбрать необходимый слой. Также можно установить флажок Только выделенные объекты, чтобы в слое учитывались только выделенные его объекты.

  6. Нажмите кнопку Кэшировать. Процесс может занять значительное время, особенно если выбран большой диапазон уровней.

По завершении работы с кэшем нажмите кнопку Выход.


Обновление кэша Tile-сервера

Обновление кэша заключается в его удалении и последующей загрузке нового кэша с Tile-сервера. Вы можете обновить весь кэш, определенные уровни или конкретную плитку. Такая операция нужна в том случае, если данные на Tile-сервере изменились. Управление кэшированием на удаленном сервере ZuluServer возможно только при наличии соответствующих прав.

Обновление всего кэша или определенных уровней

Для обновления всего кэша или определенных уровней:

  1. Выберите меню Слой|Tile-сервер|Кэшировать.

    Диалог кэширования данных Tile-сервера

    Рисунок 552. Диалог кэширования данных Tile-сервера

  2. Нажмите кнопку … справа от поля Имя файла и выберите файл-описатель для доступа к требуемому Tile-серверу. В поле Название отобразится название сервера, а в поле Папка кэша – путь к папке кэша. Путь будет отображен только при локальной работе с данными.

  3. Далее:

    • Для обновления всего кэша нажмите кнопку Удалить весь кэш и подтвердите удаление. Кэш будет удален.

    • Для обновления определенных уровней из списка Диапазон уровней выберите минимальный и максимальный уровни диапазона удаляемых из кэша тайлов. Затем нажмите кнопку Удалить уровни и подтвердите удаление указанного диапазона тайлов.

    По завершении работы с кэшем нажмите кнопку Выход для того, чтобы закрыть диалог.

Обновление кэша определенной плитки

Для обновления плитки tile - слоя:

  1. Сделайте активным тайловый слой.

  2. Включите режим Информация - [image] .

  3. Щелкните левой кнопкой мыши на объекте в той области, где надо заменить плитку.

  4. В результате откроется окно с загруженной плиткой. Для обновления плитки с сервера нажмите кнопку [image] .


Создание данных для Tile-сервера

Система ZuluGIS позволяет имеющуюся карту нарезать в виде тайлов разных форматов. В дальнейшем сохранённые данные можно использовать в различных программах, поддерживающих эти форматы. Например, файлы формата *.sqlite можно загрузить в мобильное приложение в ZuluGIS Mobile и использовать как офлайн подложку или в навигационное приложение Locus Map.

Нарезаемые данные могут сохраняться в следующих форматах:

  • SAS.Planet cache – в формате кэша программы SAS.Планета;

  • .mbtiles – «база данных» по спецификации MapBoxMBTiles, данный формат можно использовать как тайловый слой в ZuluGIS или в различных программах для мобильных устройств (например, Locus для Android или MBTiles GPS для iOS). Подробнее: «Экспорт в MBTiles»

  • .sqlite – в формате SQLite, широко используемом на мобильных устройствах. Подробнее:«Экспорт в SQLite»

Нарезка карт на плитки выполняется в диалоговом окне Создание данных для Tile-сервера. Операция производится для текущей карты в окне ZuluGIS.

Для того чтобы открыть диалоговое окно, выполните команду Слой|Tile-Сервер…|Создать….

Диалог создания данных для Tile-сервера

Рисунок 553. Диалог создания данных для Tile-сервера

Для создания нарезки карты на плитки:

  1. Создайте новый файл описателя, нажав кнопку Новый, затем:

    • для создания кэша программы SAS.Планета – укажите путь и название файла в диалоге создания файла (параметры нарезки карты сохранятся в файле описателя zww);

    • для создания базы данных SQLite по спецификации MapBox MBTiles – укажите путь и название файла в диалоге создания файла (параметры нарезки карты сохранятся в файле описателя mbtiles), затем из списка Тип файлов выберите Файлы в формате МapBox (*.mbtiles);

    • для создания базы данных формате SQLite – укажите путь и название файла в диалоге создания файла (параметры нарезки карты сохранятся в файле описателя sqlitedb), затем из списка Тип файлов выберите Файлы в формате sqlitedb (*.sqlitedb).

    [Подсказка] Подсказка

    Путь можно указывать как на локальном компьютере, так и на сервере геоданных ZuluServer. Название файла-описателя отобразится в поле Имя файла описателя.

  2. В поле Название слоя задайте имя слоя, в котором будут отображаться нарезанные данные при их открытии в карте с помощью данного файла описателя.

  3. При создании тайлового слоя формата zww необходимо выбрать каталог, в котором сохраняются нарезанные плитки. Если файл описателя создан на локальном компьютере, нажмите кнопку … справа от поля Папка для данных и выберите требуемый каталог. Если каталог уже занят кэшем, действие запрещается. Если файл описателя был создан на сервер геоданных, кнопка справа от поля Папка для данных будет неактивна.

    Введите в поле название подпапки, которая будет создана на сервере для хранения плиток.

  4. В поле со списком Проекция выберите проекцию, в которой сохраняются нарезаемые данные (поле доступно только при создании тайлового слоя формата zww).

  5. В поле со списком Формат растра выберите тип графических файлов, в которых сохраняются плитки.

  6. При установке флажка Прозрачность при нарезке плиток будет сохраняться параметр прозрачности нарезаемых графических данных.

  7. В полях Диапазон уровней укажите минимальный и максимальный уровни диапазона сохраняемых плиток.

  8. В поле Область кэширования укажите, какую часть карты следует кэшировать:

    • текущий вид – отображаемую область в активном окне карты;

    • габариты карты;

    • габариты слоя;

    • объекты слоя.

  9. Если в качестве области кэширования были выбраны габариты слоя или его объектов, в поле Слой требуется выбрать необходимый слой. Также можно установить флажок Только выделенные объекты, чтобы в слое учитывались только выделенные его объекты.

  10. Для выполнения процесса нарезки нажмите кнопку Создать.

Для редактирования параметров уже выполненной нарезки откройте существующий файл описателя, нажав кнопку Открыть и выбрав требуемый файл в диалоге выбора файлов (можно выбрать как локальный файл, так и файл на сервере геоданных ZuluServer). Название файла описателя отобразится в поле Имя файла описателя.

Если для данного описателя уже выполнялось создание плиток, изменение параметров нарезки и создания плиток недоступны, и возможны только следующие действия:

  • Создание плиток для заданного диапазона уровней. Если вы хотите перезаписать уже существующие плитки для указанных уровней, установите флажок Заменять существующие плитки. Для создания плиток укажите сохраняемую область карты в поле Область интересов (и, если требуется, в полях Слой и Только выделенные объекты слоя), укажите диапазон уровней в полях Диапазон уровней и нажмите кнопку Создать.

  • Удаление заданного диапазона плиток. Для удаления уровней укажите диапазон уровней в полях Диапазон уровней и нажмите кнопку Удалить уровни.

  • Удаление всех сохраненных данных кэша. Для этого нажмите кнопку Удалить все данные. После удаления данных становится возможным изменить часть параметров нарезки карты в части: проекцию, формат сохраняемых растров.

Для закрытия диалога нажмите кнопку Выход.


Примеры подключения тайловых слоев

  • «Подключение tile-слоя OpenStreetMap»

  • «Подключение tile-слоя Yandex с использованием кэша формата SQLite3»

  • «Создание из карты Zulu tile-слоя»


Подключение tile-слоя OpenStreetMap

В ZuluGIS уже интегрирован тайловый слой OpenStreetMap, и его можно легко добавить на карту, выбрав в меню Слой|OpenStreetMap. Поскольку адрес сервера, предоставляющего данные для этого слоя, известен, ниже представлен пример, демонстрирующий процесс его подключения. Таким же образом можно подключить любой тайловый слой, адрес которого вы знаете.

Для задания параметров Tile-сервера:

  1. Выберите меню Слой|Tile-сервер|Задать.

  2. В строке Название слоя введите пользовательское название для будущего тайлового слоя, например – OSM.

  3. Из списка Модель выберите OpenStreetMap.

  4. В строке Источник укажите http://a.tile.openstreetmap.org/.

  5. Порядок координат: X/Y.

  6. Из списка Проекция: выберите EPSG:3857.

    Диалог настройки описателя Tile-сервера

    Рисунок 554. Диалог настройки описателя Tile-сервера

  7. Начало отсчета: Широта: 90, Долгота: -180 и ориентацию осей по широте: Юг.

  8. В разделе Уровни вы можете настроить количество уровней. При загрузке слоя с сервера система будет запрашивать нужные уровни плиток в соответствии с выбранными параметрами.

  9. Установите опцию Использовать кэш.

  10. Нажмите кнопку Сохранить и в открывшемся окне укажите папку и название для создаваемого слоя. Если работать с данным слоем планируется в многопользовательском режиме, то слой следует сохранять на сервере.

  11. Закройте окно с помощью кнопки Закрыть, при закрытии система спросит, добавлять ли слой в текущую карту. Если у вас открыта карта, то нажмите Да. В противном случае нажмите Нет, затем откройте нужную карту и добавьте туда созданный слой. Обязательно карта, в которую будет добавлен слой должна иметь проекцию отличную от план схемы. В противном случае добавленный слой может отобразиться в любом произвольном месте карты.


Подключение tile-слоя Yandex с использованием кэша формата SQLite3

Кэш многих карт формата SQLite3 можно получить из программы SAS.Планета. Сохраните его в папку, к которой далее будет указан путь для подключения, в данном случае он сохранен в папку yasat.

Для задания подключения:

  1. Выберите меню Слой|Tile-сервер|Задать.

  2. В строке Название слоя введите пользовательское название для будущего тайлового слоя, например – Yandexsat.

  3. Из списка Модель выберите SASPlanet Caсhe SQL3.

  4. В строке Источник укажите путь до файлов кэша, в данном варианте он расположен на диске D:\TilesCaсhe\yasat.

  5. Из списка Проекция: выберите EPSG:3395. Если проекция подобрана неверно, то тайловый слой будет сдвинут относительно остальных слоев. Исправить ситуацию можно открыв сохраненный слой и выбрав новую проекцию.

    Диалог настройки описателя Tile-сервера

    Рисунок 555. Диалог настройки описателя Tile-сервера

  6. В разделе Уровни вы можете настроить количество уровней. При загрузке слоя с сервера система будет запрашивать нужные уровни плиток в соответствии с выбранными параметрами.

  7. Нажмите кнопку Сохранить и в открывшемся окне укажите папку и название для создаваемого слоя. Если работать с данным слоем планируется в многопользовательском режиме, то слой следует сохранять на сервере.

  8. Закройте окно с помощью кнопки Закрыть, при закрытии система спросит, добавлять ли слой в текущую карту. Если у вас открыта карта, то нажмите Да. В противном случае нажмите Нет, затем откройте нужную карту и добавьте туда созданный слой. Обязательно карта, в которую будет добавлен слой должна иметь проекцию отличную от план схемы. В противном случае добавленный слой может отобразиться в любом произвольном месте карты.


Создание из карты Zulu tile-слоя

В данном примере рассмотрено создание тайлового слоя по модели ZuluMap (zmp), в нем будет использована карта Пример тепловой сети, которая устанавливается вместе с ZuluGIS.

Для задания параметров Tile-сервера:

  1. Выберите меню Слой|Tile-сервер|Задать.

  2. В строке Название слоя задайте пользовательское название для будущего тайлового слоя, например – map_tile.

  3. Из списка Модель выберите Zulu Map (zmp).

  4. В строке источник укажите карту ZuluGIS, которая будет являться источником тайлового слоя. Для этого нажмите на кнопку … и в открывшемся окне выберите карту, в нашем случае Пример тепловой сети. При этом карта может быть выбрана как с локальной машины, так и с ZuluServer.

  5. Так как карта создана в локальной прямоугольной системе координат, то выберите Проекция: CRS:LOCAL.

    Диалог настройки описателя Tile-сервера

    Рисунок 556. Диалог настройки описателя Tile-сервера

  6. Нажмите кнопку Сохранить и в открывшемся окне укажите папку и название для создаваемого слоя.

  7. Закройте окно с помощью кнопки Закрыть, при закрытии система спросит, добавлять ли слой в текущую карту. Если у вас открыта карта, то нажмите Да. В противном случае нажмите Нет, затем откройте нужную карту и добавьте туда созданный слой. Обязательно карта, в которую будет добавлен слой должна иметь проекцию отличную от план схемы. В противном случае добавленный слой может отобразиться в любом произвольном месте карты.

В результате проделанных действий мы получили тайловый слой, созданный на основе указанной карты. При этом, если в исходную карту будут внесены изменения, то при следующем перестроении тайлового слоя они в нем будут отражены.

[Подсказка] Подсказка

Возможно задание прозрачности слоя: «Настройка прозрачности тайлового слоя».


Используемые проекции

Рассмотрим две основные географические проекции, для которых строится тайловая система на весь земной шар.

Проекция Меркатора

На нулевом уровне вся Земля помещается в одну квадратную плитку со стороной, равной длине экватора. Для остальных уровней количество плиток определяется по формуле:

N = H * W

H = W = 2^Z, где H – количество плиток по высоте, W – количество плиток по ширине, Z – номер уровня, начиная с нуля.

Для тайловой системы в проекции Меркатора часто используются две системы координат:

  • EPSG:3395 – WGS 84/World Mercator на сфероиде. Эта проекция используется такими сервисами как Космоснимки, Яндекс Карты, Карты mail.ru (спутник) и другими;

  • EPSG:3857 – WGS 84/Pseudo-Mercator (Spherical Mercator) на сфере. Эта проекция используется такими сервисами как Google, Virtual Earth, Maps-For-Free, Wikimapia, OpenStreetMap, Роскосмос, Навител, Nokia и др.

Проекция plate carrée (широта/долгота)

На нулевом уровне вся Земля помещается в две квадратные плитки с координатами (-90, -180, 90, 0) и (-90, 0, 90, 180). Для остальных уровней количество плиток определяется по формуле:

N = H * W, где

H = 2^Z – количество плиток по высоте, W = (2^Z)*2 – количество плиток по ширине, Z – номер уровня, начиная с нуля.

В случае широты/долготы, как правило, используется проекция EPSG:4326 – WGS 84.


Система координат тайловой системы

Каждая плитка в тайловой системе задается тремя параметрами: номером уровня (Z), положением плитки по горизонтали (X) и положением плитки по вертикали (Y).

Направление отсчета местоположения плитки по горизонтали, как правило, идет слева направо (с запада на восток).

Направление отсчета местоположения плитки по вертикали может идти как сверху вниз (на юг), так и снизу вверх (на север).

Начало отсчета системы (положение плитки с параметрами X=0, Y=0) тоже может задаваться по-разному.

На рисунках приведено несколько примеров систем координат с разным началом отсчета и ориентацией осей для уровня Z=2.


Формирование запроса к Tile-серверу

Для получения растрового изображения плитки с параметрами X, Y, Z по протоколу HTTP следует сформировать и отправить на сервер запрос, соответствующий следующему шаблону:

http://<хост>:<порт>/<URL-путь>?<параметры>

Запрос содержит информацию об имени сервера, названии и настройке карты, фрагмент которой требуется получить. Для разных серверов формирование запроса может происходить по-разному. В любом случае в пути, в параметрах, в хосте или в их комбинации должна содержаться информация об X, Y, Z. При описании шаблона запроса к серверу необходимо знать, какую модель запроса он поддерживает.

На данный момент ZuluGIS поддерживает следующие модели обращения к Tile-серверам:

  • «Модель XYZ»

  • «Модель Bing Maps Tile System»

  • «Модель OpenStreetMap»

  • «Модель Yahoo»

  • «Модель ZuluServer»

  • «Модель Роскосмос»

  • «Модель Navitel»

  • «Модель Wikimapia»

  • «Модель ZuluMap (zmp)»

  • «Модель Maps-For-Free»

  • «Модель кэша SAS. Планета»

  • «Модель кэша SAS.Планета SQLite3»


Модель XYZ

Для данной модели в запросе в явном виде должны присутствовать значения X, Y, Z. Модель позволяет описать запросы ко многим сервисам, среди которых Google, Яндекс, Космоснимки, Mail.ru, ArcGIS Server, Nokia и другие.

При формировании строки-шаблона запроса необходимо указать места подстановки параметров изображения в виде полей подстановки <x>, <y>, <z> для X, Y, Z соответственно.

Если строки для подстановки <x>, <y>, <z> не указаны, то по умолчанию к концу строки шаблона добавляется строка &x=<x>&y=<y>&z=<z>

Картографическая проекция на разных серверах может быть разной: EPSG:3395, EPSG:3857 (EPSG:900913), EPSG:4326 и другие

Начало системы координат и ориентация осей для разных серверов также может быть различным.

Пример 1

Система координат: Lat0 = 90, Lon0 = -180, ось X – на восток, ось Y – на юг, EPSG:3857.

Шаблон запроса:

http://maps.rosreestr.ru/ArcGIS/rest/services/BaseMaps/BaseMap/MapServer/tile/<z>/<y>/<x>

Для плитки Z = 2, X = 3, Y = 1:

http://maps.rosreestr.ru/ArcGIS/rest/services/BaseMaps/BaseMap/MapServer/tile/2/1/3

Пример 2

Система координат: Lat0 = 90, Lon0 = -180, ось X – на восток, ось Y – на юг, проекция EPSG:3857.

Шаблон запроса:

http://khm0.google.com/kh/v=92&x=<x>&y=<y>&z=<z>&s=Galileo

Для плитки Z = 2, X = 3, Y = 1:

http://khm0.google.com/kh/v=92&x=3&y=1&z=2&s=Galileo

Пример 3

Система координат: Lat0 = 90, Lon0 = -180, ось X – на восток, ось Y – на юг, проекция EPSG:3857.

Шаблон запроса:

http://khm0.google.com/kh/v=92&s=Galileo

Для плитки Z = 2, X = 3, Y = 1:

http://khm0.google.com/kh/v=92&s=Galileo&x=3&y=1&z=2


Модель Bing Maps Tile System

Для каждой плитки, начиная с уровня Z = 1, на базе параметров X, Y, Z строится код квадро-дерева далее используемый в запросе.

Подробно о модели Bing и построении кода квадро-дерева можно прочесть на сайте Microsoft: http://msdn.microsoft.com/en-us/library/bb259689.aspx

Система координат: Lat0 = 90, Lon0 = -180, ось X – на восток, ось Y – на юг.

Место подстановки кода квадро-дерева в шаблоне запроса указывается строкой <k>.

Пример

Шаблон запроса:

http://a0.ortho.tiles.virtualearth.net/tiles/a<k>.jpeg?g=72

Для плитки Z = 6, X = 41, Y = 26:

http://a0.ortho.tiles.virtualearth.net/tiles/a123021.jpeg?g=72


Модель OpenStreetMap

Данная модель применяется некоммерческим сетевым картографическим проектом OpenStreetMap (OSM) http://www.openstreetmap.org/

Структура запроса:

http://<хост>:<порт>/<URL-путь>/Z/X/Y.png

Вариант модели XYZ, в котором не требуется указывать места подстановки параметров плитки.

По умолчанию расширение файла изображения png. В общем случае в описателе ZuluGIS расширение можно задавать дополнительно.

Пример

Система координат: Lat0 = 90, Lon0 = -180, ось X – на восток, ось Y – на юг, проекция EPSG:3857.

Шаблон запроса:

http://a.tile.openstreetmap.org/

Для плитки Z = 2, X = 3, Y = 1:

 http://a.tile.openstreetmap.org/2/3/1.png

Эту модель можно использовать для формирования запросов и к другим серверам со схожей структурой.


Модель Yahoo

Разновидность модели XYZ. Отличается от базовой модели тем, что отсчет уровней идет не с нуля, а с единицы.

Система координат: Lat0 = 0, Lon0 = -180, ось X – на восток, ось Y – на север, проекция EPSG:3857.

Пример

Шаблон запроса:

http://maps.yimg.com/ae/ximg?v=1.9&t=a&r=1

Для плитки Z = 2, X = 3, Y = 1:

 http://maps.yimg.com/ae/ximg?v=1.9&t=a&r=1&x=3&y=0&z=3


Модель ZuluServer

В этой модели в качестве источника тайловых данных используется уже готовый описатель Tile-сервера.


Модель Роскосмос

Модель применяется на гео-портале Роскосмос http://geoportal.ntsomz.ru/ Структура запроса:

http://<хост>:<порт>/<URL-путь>/<код>.jpg

Код представляет собой дополнение к общему пути и вычисляется для X, Y, Z по определенному алгоритму, поэтому в шаблоне запроса указывается только хост и общая часть пути.

Система координат: Lat0 = 90, Lon0 = -180, ось X – на восток, ось Y – на юг, проекция EPSG:3857.

Пример

Шаблон запроса:

http://geoportal.ntsomz.ru/coverages/images/

Для плитки Z = 2, X = 1, Y = 2:

 http://geoportal.ntsomz.ru/coverages/images/2/10-01. jpg

Для плитки Z = 7, X = 64, Y = 46:


Модель Navitel

Модель работает на сайте Navitel http://maps.navitel.su

Структура запроса:

http://<хост>:<порт>/<URL-путь>?t=<0...0>X, <0...0>Y, <0>Z

Количество нулей перед X таково, чтобы общая сумма цифр нулей и X была равна 8. То же относится к количеству нулей перед Y. Если Z <10, перед номером уровня ставится 0.

Система координат: Lat0 = -90, Lon0 = -180, ось X – на восток, ось Y – на север, проекция EPSG:3857.

Пример

Шаблон запроса:

http://maps.navitel.su/navitms.fcgi?

Для плитки Z = 4, X = 9, Y = 11:

http://maps.navitel.su/navitms.fcgi?t=00000009,00000011,04


Модель Wikimapia

Модель работает на сайте wikimapia.org.

Система координат: Lat0 = 90, Lon0 = -180, ось X – на восток, ось Y – на юг, проекция EPSG:3857.

Структура запроса:

http://[HOST] /?x=[X]&y=[Y]&zoom=[Z]

, где HOST – это i[NUM].wikimapia.org, где

NUM=[X]%4+([Y]%4)*4

При такой структуре X и Y участвуют в формировании имени хоста.

Пример

Шаблон запроса:

http://wikimapia.org/?lng=1

Для плитки Z = 5, X = 15, Y = 10 запрос сформируется так:

http://i11.wikimapia.org/?lng=1&x=15&y=10&zoom=5


Модель ZuluMap (zmp)

В этой модели в качестве источника тайловых данных может быть указана любая карта ZuluGIS, что позволяет получать в виде плиток (256*256 пикселей) всегда актуальные данные без предварительной «нарезки».


Модель Maps-For-Free

Модель работает на сайте http://maps-for-free.com/

Система координат: Lat0 = 90, Lon0 = -180, ось X – на восток, ось Y – на юг, проекция EPSG:3857.

Структура запроса:

http://www.maps-for-free.com/layer/[layer name]/z[Z]/row[Y]/[Z]_[X]- [Y].<EXT>

layer name – имя слоя, входит в запрос как часть шаблона.

EXT – расширение запрашиваемого файла, которое задается в описателе.

Пример

Шаблон запроса: http://www.maps-for-free.com/layer/relief

Для плитки Z = 5, X = 17, Y = 12 запрос сформируется так:

http://www.maps-for-free.com/layer/relief/z5/row12/5_17-12.jpg


Модель кэша SAS. Планета

В качестве источника тайловых данных можно использовать файловые структуры в формате кэша программы SAS.Планета.

Система координат: Lat0 = 90, Lon0 = -180, ось X – на восток, ось Y – на юг, проекция должна быть известна.

Структура имени файла:

<Корневая папка>\z[Z+1]\[X/1024]\x[X]\[Y/1024]\[Y].<EXT>

Пример

Шаблон запроса:

d:\SASPlanet\cache\WikiMap\

Для плитки Z = 15, X = 19141, Y = 9525 имя файла формируется так:

 d:\SASPlanet\cache\WikiMap\z16\18\x19141\9\y9525.png


Модель кэша SAS.Планета SQLite3

В качестве источника тайловых данных можно использовать файлы формата кэша программы SAS.Планета SQLite3.

Система координат: Lat0 = 90, Lon0 = -180, ось X – на восток, ось Y – на юг, проекция должна быть известна.

Структура имени файла:

<Корневая папка>\z[Z+1]\[X/1024]\[Y/1024]\[X/256].[Y/256].sqllitedb.<EXT>

Пример

Шаблон запроса:

d:\SASPlanet\cache\Yandex\

Для плитки Z = 15, X = 19141, Y = 9525 имя файла формируется так:

 d:\SASPlanet\cache\Yandex\z16\18\9\74.37.sqllitedb


Сдвиг тайлового слоя

ZuluGIS позволяет задать вертикальный/горизонтальный сдвиг в метрах для тайлового слоя. Сдвиг может быть как положительным, так и как отрицательным числом, от этого будет зависеть направление смещения: вверх/вниз, влево/вправо. Значения сдвига сохраняется при сохранении файла карты.

Сдвиг дает возможность более точного совмещения различные тайловых слоев, например, 2ГИС. Расстояние сдвига указывается в проекции/системе координат описателя слоя. Можно измерить инструментом линейка на экране в режиме текущей проекции.

[Предупреждение] Предупреждение

Ограничения: в разных областях (регионах) разные значения сдвигов.
Настройки сдвига тайлового слоя

Рисунок 557. Настройки сдвига тайлового слоя

Для задания сдвига:

  1. Выбрать меню Карта|Настройка слоя или нажать на панели инструментов кнопку [image] .

  2. В появившемся окне Загруженные слои щелчком левой кнопки мыши выбрать слой и нажать кнопку Настройка.

  3. Перейти на вкладку Настройки:

    Настройки сдвига тайлового слоя

    Рисунок 558. Настройки сдвига тайлового слоя

  4. Ввести Сдвиг по Х и Сдвиг по У.

  5. Нажать кнопку Применить. Изменения отобразятся на экране.

  6. При необходимости изменить значения сдвигов.

  7. Нажать кнопку ОК для сохранения изменений.


Настройка прозрачности тайлового слоя

При работе с тайловым слоем возможно настроить его прозрачность.

Для настройки прозрачности слоя надо:

  1. Выбрать меню Карта|Настройка слоя или нажать на панели инструментов кнопку [image] .

  2. В появившемся окне Загруженные слои щелчком левой кнопки мыши выбрать слой и нажать кнопку Настройка.

    [Примечание] Примечание

    Также панель настройки слоя возможно открыть через панель Рабочее место. Для этого надо сделать щелчок правой кнопкой мыши на названии слоя в панели и в контекстном меню выбрать пункт [image] Настройка.

  3. Перейти на вкладку Настройки.

  4. В окно Прозрачность, % ввести нужное значение.

  5. Нажать кнопку Применить. Изменения отобразятся на экране.

  6. Нажать кнопку ОК для сохранения изменений.


Рабочая область тайлового слоя

Рабочая область тайлового слоя – это заданная пользователем полигональная область, внутри которой отображаются и загружаются (кэшируются) плитки тайлового слоя. За границами рабочей области тайловый слой не отображается.

[Примечание] Примечание

Рабочая область настраивается отдельно для каждого тайлового слоя и сохраняется в файле карты.

Применение рабочей области тайлового слоя уменьшает количество загружаемых плиток, упрощает навигацию по карте (в том числе делает более удобным использование функции Вид|По размерам|Карты [image] ).

Область может состоять из нескольких полигонов. Цвет и стиль полигонов рабочей области настраивается пользователем. Возможно включение/отключение видимости рабочей области на экране, а также её отмена. Изображается рабочая область в режиме редактирования слоя инструментом Многоугольник [image] . При наложении объектов они будут объединяться в один полигон с общими границами.

Возможно использовать другие слои для задания области – скопировать полигоны из векторного слоя и вставить из буфера обмена.

Редактирование существующей рабочей области возможно путем добавления новых полигонов или создания области заново.

Пример отображения рабочей области тайлового слоя

Рисунок 559. Пример отображения рабочей области тайлового слоя


Настройка рабочей области тайлового слоя

Для настройки (создания, редактирования, очистки) рабочей области тайлового слоя следует:

  1. Включить редактор для тайлового слоя, нажав на панели инструментов кнопку [image] или выбрав пункт главного меню Карта|Редактор слоя.

  2. Используя инструмент Многоугольник [image] , изобразить на экране рабочую область.

    [Подсказка] Подсказка

    Вместо ручного изображения области можно вставить полигоны из буфера обмена (предварительно скопировав полигоны из векторного слоя)

  3. Для удаления всех объектов (очистки области) нажать кнопку [image] или клавишу Delete на клавиатуре.

  4. Для задания дополнительных настроек перейти в настройки слоя: выбрать меню Карта|Настройка слоя или нажать на панели инструментов кнопку [image] .

  5. Перейти на вкладку Настройки:

    Настройки рабочей области тайлового слоя

    Рисунок 560. Настройки рабочей области тайлового слоя

  6. Нажать кнопку ОК для сохранения настроек.

  7. Отключить редактор слоя [image] .


Слои рельефа

Система ZuluGIS имеет возможность работать с двумя видами слоев рельефа.

Первый вид – это TIN модель, работая с которой, можно моделировать поверхность земли, что позволяет решать различные пространственные задачи:

  • построение изолиний;

  • построение зон затопления;

  • построение профиля;

  • вычисление площади и объема;

  • построение растра рельефа;

  • определение высотных отметок инженерных сетей (тепловые сети, водопроводные сети, сети водоотведения, газопроводные сети).

Второй вид рельефа – это общедоступные данные земной поверхности SRTM (Shuttle Radar Topography Mission – радарная интерферометрическая съемка поверхности земного шара). SRTM данные легко найти в свободном доступе в интернете, они, как правило, представлены в виде архивных файлов. В настоящей версии, работая с SRTM слоем, возможно решать следующие задачи:

  • построение профиля;

  • определение высотных отметок инженерных сетей (тепловые сети, водопроводные сети, сети водоотведения, газопроводные сети).

Слои рельефа могут иметь свои параметры отображения и использоваться в различных картах.


Общие сведения

TIN модель

  • «Создание рельефа (TIN)»

  • «Редактирование рельефа (TIN)»

  • «Настройка рельефа (TIN)»

  • «Операции с рельефом»

  • «Сохранение TIN в формат SRTM»

При наличии слоя (слоев), содержащего изолинии и/или точки c высотными отметками рельефа, и подключенной к нему базы данных с высотами имеется возможность построить модель рельефа для дальнейшей обработки и анализа. Например, для определения высоты в любой точке карты, анализа зон затопления или построения изолиний. Кроме того, можно выполнить расчеты площадных и объемных характеристик поверхностей, уклона, отмывки рельефа, построить поперечный профиль по заданному пути и так далее (подробнее).

После того как модель построена, она сохраняется в виде отдельного файла и добавляется в карту как слой. Далее модель рельефа будет называться слоем рельефа. По слою рельефа можно определить координаты, высоту, уклон и азимут в любой точке данного слоя.

Ниже показан пример TIN рельефа.

Пример TIN рельефа

Рисунок 561. Пример TIN рельефа

Модель рельефа представляет собой триангуляцию, в которой известны высоты вершин всех треугольников. Погрешность такой модели будет зависеть от способа триангуляции (построения модели). Система позволяет строить несколько видов триангуляция:

  1. Триангуляция Делоне. Это триангуляция, при которой никакая вершина треугольника не содержится внутри окружности, описанной вокруг любого треугольника, такого, что ни одной из вершин его не является данная вершина. В этом случае при построении используются только точки высотных отметок и вершины (но не ребра) полилиний и полигонов.

  2. Триангуляция Делоне с ограничениями. В этом случае ни одно ребро триангуляции (сторона треугольника) не должно пересекать ребра полилиний и полигонов, то есть все отрезки исходных полилиний и полигонов должны проходить по ребрам триангуляции.

  3. Триангуляция с улучшением рельефа. В этом случае к исходному набору вершин добавляются дополнительные вершины с тем, чтобы исключить наличие треугольников, все вершины которых имели бы одну и ту же высоту (например, принадлежали бы одной и той же изолинии). Этот метод избавляет модель рельефа от горизонтально расположенных треугольников, которые искажают картину рельефа.

О создании слоя рельефа TIN можно узнать в разделе: «Создание рельефа (TIN)».

SRTM

  • «Подключение данных высотных отметок SRTM3»

  • «Настройка SRTM»

  • «Операции с рельефом»

  • «Создание рельефа в формате SRTM»

  • «Сохранение TIN в формат SRTM»

SRTM (Shuttle Radar Topography Mission) – это радарная интерферометрическая съемка поверхности земного шара. Съемка была проведена с помощью двух радиолокационных сенсоров, которые были установленных на борту корабля. Используя ZuluGIS, возможно как подключить скачанные файлы съемки, так и создать слой рельефа формата SRTM на основе векторных слоев с изображениями горизонталей или точек высот рельефа с подключенной базой данных, в одном из полей которой заданы высоты объектов в метрах.

Данные SRTM являются универсальным источником для моделирования земной поверхности, главным образом для построения цифровых моделей рельефа и цифровых моделей местности.

Данные съемки представляют собой набор файлов, каждый из которых покрывает территорию размером 1х1 градус, с разрешением в 3 секунды в 1 пикселе (примерно 90 м в широтном направлении), такой квадрат является матрицей размером 1201х1201 элементов (пикселей). Каждому пикселю присвоена высотная отметка в метрах. Референц-эллипсоид данных – WGS84.

Пример SRTM рельефа

Рисунок 562. Пример SRTM рельефа

Съемку легко найти в свободном доступе в интернете (http://viewfinderpanoramas.org/Coverage%20map%20viewfinderpanoramas_org3.htm). Она, как правило, представлена в виде архивных файлов, в каждом архиве находится файл формата NXXE0YY.hgt, где XX – широта, YY – долгота, то есть в названии каждого файла содержатся координаты левого нижнего угла покрытия.

Однако вопрос применения радарных высотных данных SRTM в качестве исходной информации для построения электронных моделей инженерных систем взамен стандартному способу путем оцифровки топографической съемки должен решаться в каждом случае индивидуально. Определяется этот способ в зависимости от:

  • поставленной перед специалистом задачи;

  • характеристик рельефа искомой местности;

  • требуемой точности высотной привязки.

О подключении высотных отметок SRTM можно узнать в разделе «Подключение данных высотных отметок SRTM3».


Создание рельефа (TIN)

[Примечание] Примечание

Если из-за большого объёма данных создание рельефа в формате TIN невозможно, то в этом случае на основании этих же данных можно построить рельеф SRTM.

Для создания слоя рельефа необходим один или несколько векторных слоев с изображениями горизонталей или точек высот рельефа с подключенной базой данных, в одном из полей которой заданы высоты объектов в метрах.

[Примечание] Примечание

Видеоурок по созданию слоя рельефа можно посмотреть, пройдя по ссылке: https://www.politerm.com/videos/relief/relief_create/.

Для создания рельефа:

  1. Загрузите в карту слой с горизонталями или точками высот рельефа.

  2. Выполните команду меню Карта|Рельеф|Создать. Откроется диалог создания рельефа.

  3. Укажите слой, по которому будет создаваться рельеф. Рельеф может строиться по данным из нескольких слоев, например, слоя с горизонталями и слоя с точками высот. Информация об используемых слоях приводится в списке в верхней части диалога.

    Для добавления слоя данных:

    • Нажмите кнопку Данные. Откроется диалог выбора данных:

      Диалог задания данных

      Рисунок 563. Диалог задания данных

    • Из списка Слой выберите слой карты с данными для построения рельефа;

    • В списке Тип отметьте флажком тип объектов слоя, к которым подключена база данных с высотами. Если база данных подключена к примитивам, то установите флажок напротив строки <Примитивы>;

    • В поле со списком Поле выберите поле базы данных слоя, в котором записаны высоты;

    • Нажмите кнопку Выбрать, чтобы закрыть диалог выбора и добавить выбранные данные в список (кнопка Отмена закроет диалог без сохранения изменений);

    • Если требуется добавить еще слой, повторите для него действия, описанные выше.

  4. В разделе Триангуляция выберите требуемый тип триангуляции:

    • Делоне;

    • с ограничениями;

    • с улучшением рельефа.

    Чаще всего используется триангуляция с улучшением рельефа.

    [Подсказка] Подсказка

    При наличии в исходных данных изолиний (полилиний и полигонов) для построения модели рельефа лучше использовать триангуляцию с улучшением рельефа.

    Если в качестве исходных данных используются только точечные объекты (высотные отметки), то в любом случае будет построена триангуляция Делоне.

  5. Рельеф может быть создан с учётом вогнутой оболочки, нужно ли использовать данную опцию зависит от исходных данных и желаемого результата. Чтобы включить эту опцию, установите флажок Вогнутая оболочка. Затем из списка выберите и введите Минимальную длину ребра в метрах или Отношение длины ребра. Во втором случае длина определяется коэффициентом, самой большой длиной и самой малой длиной:

    Length = Ratio * (maxLen – minLen) + minLen,

    где Ratio — коэффициент, maxLen — самая большая длина, minLen — самая малая длина.

  6. По умолчанию для создаваемого слоя рельефа используется система координат слоя, из которого берутся данные для построения рельефа.

    При необходимости можно изменить систему координат создаваемого слоя рельефа, для этого нажмите кнопку Изменить группы настроек Система координат и укажите требуемую систему координат и проекцию.

  7. В группе настроек Слой для записи задайте параметры создаваемого слоя рельефа.

    • В строке Имя файла нажмите кнопку Обзор... и в появившемся стандартном диалоге выбора файлов укажите путь и имя для файла слоя создаваемого рельефа.

    • В поле Название при необходимости можно изменить пользовательское название (по умолчанию оно совпадает с именем файла).

    • Из списка Цвет выберите цвет для создаваемого рельефа.

    • Для того чтобы слой после создания сразу загрузился в активную карту, установить флажок Добавить в карту.

    Диалог создания рельефа

    Рисунок 564. Диалог создания рельефа

  8. Для запуска создания рельефа с указанными параметрами нажмите кнопку ОК.

[Примечание] Примечание

Все параметры созданных слоев рельефа будут сохранены на клиенте, в дальнейшем их возможно будет загрузить для редактирования (см. «Редактирование рельефа (TIN)»)

В зависимости от исходных данных и настроек результат будет отличаться.

На рисунке ниже представлен рельеф, созданный на основе двух слоев: слоя с горизонталями и слоя с точками высот рельефа. При создании рельефа использовалась триангуляция с улучшением рельефа и местная прямоугольная система координат.

Рисунок 565. Модель рельефа

Ниже показаны еще варианты построенных рельефов, на основе одного слоя с точками высот рельефа.

Первый вариант с использованием метода Делоне и вогнутой оболочкой с минимальной длиной ребра 300 метров.

Рисунок 566. Модель рельефа

Второй вариант так же с использованием метода Делоне и вогнутой оболочкой, но минимальная длина ребра 50 метров.

Рисунок 567. Модель рельефа

По созданному слою рельефа можно определить координаты, высоту, уклон и азимут в любой точке данного слоя. Для определения этих параметров сделайте слой рельефа активным, установите режим выделения ( [image] ), откройте панель Объект (команда меню Окно|Объект) и щелкните левой кнопкой мыши в нужной точке (точка начнет мигать), после чего все данные точки отобразятся в открытой панели:

Рисунок 568. Панель Свойства


Редактирование рельефа (TIN)

Иногда при работе с рельефом необходимо повторно вернуться к построению рельефа. В этом случае есть возможность загрузить настройки ранее созданного рельефа, для этого:

  1. Загрузите в карту слой с горизонталями или точками высот рельефа.

  2. Выполните команду меню Карта|Рельеф|Создать. Откроется диалог создания рельефа.

  3. Чтобы открыть список ранее созданных на данном клиенте слоев рельефа, нажмите кнопку История....

  4. Выделите слой и нажмите кнопку ОК, после чего в диалог будут загружены все параметры рельефа, которые можно отредактировать и сохранить.


Настройка рельефа (TIN)

Слой рельефа, так же как и обычный векторный слой в разных картах может отображаться по-разному, с разной прозрачностью, освещенностью.

[Важно] Важно

Все настройки, произведенные указанным далее способом относятся только к текущей карте, и сохраняются ТОЛЬКО при сохранении карты. И если настройки не были сохранены в слое, то при добавлении данного слоя в другую карту настройки выполненные для первой карты применяться не будут.

Для настройки слоя рельефа:

  1. Выполните команду меню Карта|Настройка слоя или нажмите на панели инструментов кнопку [image] .

  2. В появившемся окне Загруженные слои выберите слой рельефа и нажмите кнопку Настройка. Откроется диалог настройки рельефа.

    Диалог настройки рельефа

    Рисунок 569. Диалог настройки рельефа

  3. Параметры отображения рельефа задаются в следующих группах настроек вкладки Отображение рельефа.

    1. Группа настроек Отображение:

      • рельеф отображается на карте только при установленном флажке отображать слой на карте;

      • для того чтобы рельеф печатался должен быть установлен флажок отображать слой при печати.

    2. Группа настроек Раскраска:

      • в поле со списком Тип выбирается тип отображения: «по освещенности», «уклонам», или «по экспозиции склонов»;

      • в поле Прозрачность задается прозрачность рельефа, от 0 до 100, где 0 - полностью непрозрачен, 100 - полностью прозрачен;

      • при установленном флажке отображать треугольники отображаются треугольники рельефа;

      • в поле Масштаб по Z устанавливается масштаб по шкале Z.

        [Примечание] Примечание

        Масштаб на карте может быть представлен в двух вариантах: геодезическом и в сантиметрах на пиксель. Выбор нужного масштаба осуществляется в параметрах системы.

    3. Группа настроек Масштаб отображения.

      • Используется для задания минимального и максимального масштаба, при котором слой не отображается на карте. Для того чтобы слой не отображался на карте при масштабе меньше определенного значения, установите флажок Не отображать при масштабе меньше, чем 1: и укажите минимальный масштаб в поле справа от флажка. Для того чтобы слой не отображался на карте при масштабе больше определенного значения, установите флажок Не отображать при масштабе больше, чем 1: и укажите максимальный масштаб в поле справа от флажка. Масштаб указывается или геодезический и в сантиметрах на пиксель, в зависимости от настроек системы.

  4. Во вкладке Треугольники устанавливаются цвет, стиль, толщина треугольников рельефа.

    Вкладка «Треугольники» диалога настройки рельефа

    Рисунок 570. Вкладка «Треугольники» диалога настройки рельефа

  5. По завершении задания настроек слоя нажмите кнопку ОК чтобы сохранить изменения и закрыть диалог. Кнопка Отмена закрывает диалог без сохранения изменений.

    Пример настройки рельефа

    Рисунок 571. Пример настройки рельефа


Сохранение фрагмента TIN рельефа

Используя данную операцию возможно сохранить указанный фрагмент рельефа в новый слой. Для сохранения:

  1. Загрузите в активную карту слой из которого требуется сохранить фрагмент рельефа.

  2. Нажмите на панели инструментов рельеф кнопку Задать регион - [image] .

  3. Укажите область фрагмента. Область задается аналогично многоугольнику. Точки области фиксируются нажатием левой кнопки мыши, для окончания ввода региона выполните двойной щелчок левой кнопкой мыши, при этом первая и последняя точка будут соединены по прямой линии. Для отмены последней введенной точки щелкните правой кнопкой мыши и выберите в появившемся контекстном меню пункт Отменить последнюю точку.

    Указный фрагмент рельефа

    Рисунок 572. Указный фрагмент рельефа

  4. Выполните команду меню Карта|Рельеф|Сохранить фрагмент рельефа. Откроется диалог сохранения рельефа.

  5. Укажите название и местоположение слоя для записи фрагмента. Для этого нажмите кнопку Обзор..., выберите каталог и в строке Имя файла введите название. Нажмите кнопку Сохранить. Если исходный слой был локальной версии, то его сохранение возможно как на сервер (кнопка Серверы геоданных) так и на локальную машину. Фрагмент серверного слоя можно сохранить только на сервер. При желании можно так же заменить пользовательское название создаваемого слоя (строка Название слоя).

  6. Из списка Цвет выберите цвет для фрагмента.

  7. Установите флажок Добавить в карту для автоматического добавления слоя в текущую карту.

  8. Для запуска копирования фрагмента нажмите кнопку ОК.

    Указный фрагмент рельефа

    Рисунок 573. Указный фрагмент рельефа

В результате проделанных действий будет создан новый слой рельефа с выбранным фрагментом:

Рисунок 574. Фрагмент рельефа


Создание рельефа в формате SRTM

При большом объеме исходных данных для создания рельефа в формате TIN может не хватить оперативной памяти компьютера. В этом случае возможно создание слоя рельефа в формате SRTM. Исходными данными для такого слоя являются так же как и для слоя TIN один или несколько слоев с изображениями горизонталей или точек высот рельефа, с подключенной базой данных, в одном из полей которой заданы высоты объектов в метрах.

Рельеф может быть создан как SRTM1 так и SRTM3 формата. SRTM1 - сетка с размером ячейки 1х1 угловая секунда (с пространственным разрешением 30 м) – эти данные более точны, но соответственно они будут больших размеров чем SRTM3. SRTM3 – сетка с размером ячейки 3х3 угловые секунды (с пространственным разрешением 90 м).

В результате процедуры в указанных папках будут созданы файл описатель и файлы формата *.hgt.

Для создания рельефа в формате SRTM:

  1. Загрузите в карту слой с горизонталями или точками высот рельефа.

  2. Выполните команду меню Карта|Рельеф|SRTM|Создать рельеф в формате SRTM. Откроется диалог создания рельефа.

  3. Укажите слой, по которым будет создаваться рельеф. Рельеф может строиться по данным из нескольких слоев, например, слоя с горизонталями и слоя с точками высот. Информация об используемых слоях приводится в списке в верхней части диалога.

    Для добавления слоя данных:

    • Нажмите кнопку Данные. Откроется диалог выбора данных:

      Диалог задания исходных данных

      Рисунок 575. Диалог задания исходных данных

    • Выберите слой карты с данными для построения рельефа в поле Слой;

    • В списке Тип отметьте флажком тип объектов слоя к которым подключена база данных с высотами. Если база данных подключена к примитивам, то установите флажок напротив строки <Примитивы>;

    • В поле со списком Поле выберите поле базы данных слоя в котором записаны высоты;

    • Нажмите кнопку Выбрать чтобы закрыть диалог выбора и добавить выбранные данные в список (кнопка Отмена закроет диалог без сохранения изменений);

    • Если требуется добавить еще слой, повторите для него действия, описанные выше.

    [Примечание] Примечание

    Возможно загрузить настройки ранее созданного рельефа, для этого надо нажать кнопку История...,, выделить слой для загрузки данных и нажать кнопку ОК.

  4. В строке Имя файла нажмите кнопку Обзор... и в появившемся стандартном диалоге выбора файлов укажите путь и имя для файла слоя создаваемого рельефа.

  5. В поле Название введите пользовательское название (по умолчанию оно совпадает с именем файла).

    Папка для файлов формата HGT будет автоматически создана в том же каталоге где располагается слой.

  6. Из списка Формат выберите формат создаваемых данных: SRTM1 или SRTM3.

  7. Для того чтобы слой после создания сразу загрузился в активную карту, установить флажок Добавить в карту.

    Диалог создания слоя SRTM рельефа

    Рисунок 576. Диалог создания слоя SRTM рельефа

  8. Для запуска создания рельефа с указанными параметрами нажмите кнопку ОК.


Подключение данных высотных отметок SRTM3

Данные SRTM3 съемки можно свободно скачать из открытых источников в формате *.hgt. Чтобы использовать эти данные в системе в качестве слоя рельефа, их необходимо подключить и одновременно создать новый слой. Обратите внимание, что перед подключением скачанные файлы нужно разархивировать!

[Примечание] Примечание

После создания слоя высотных отметок в дальнейшем он может быть использован для автоматического снятия геодезических отметок у инженерных сетей (подробней об этом можно знать в соответствующей справке: ZuluHydro https://www.politerm.com/zuluhydro/webhelp/index.html#auto_geo.html, ZuluThermo https://www.politerm.com/zuluthermo/webhelp/index.html#auto_geo.html, ZuluDrain https://www.politerm.com/zuludrain/webhelp/index.html#auto_geo.htm, ZuluSteam https://www.politerm.com/zulusteam/webhelp/index.html#auto_geo.htm).

[Примечание] Примечание

Видео урок по работе с SRTM3 данными можно посмотреть пройдя по ссылке: https://www.politerm.com/videos/relief/ReliefSRTM/.

Для подключения скачанных данных:

  1. Выберите пункт меню Карта|Рельеф|Подключить данные SRTM3. Откроется диалог подключения данных.

  2. В строке Название слоя укажите пользовательское название для слоя высотных отметок.

  3. С правой стороны от строки Папка с файлами HGT нажмите кнопку Обзор и укажите каталог, в котором расположены файлы съемки (*.hgt).

  4. Нажмите кнопку Сохранить, задайте имя файла для слоя высотных отметок.

  5. Если созданный слой необходимо сразу добавить в карту то установите опцию Добавить в карту.

    Диалог подключения данных SRTM3

    Рисунок 577. Диалог подключения данных SRTM3

  6. Нажмите кнопку ОК, которая запустит создание слоя высотных отметок на основании указанных данных.

В результате проделанных действий будет создан файл с расширением *.zww, при загрузке его в карту он будет выглядеть следующим образом:

Карта с загруженным слоем высотных отметок

Рисунок 578. Карта с загруженным слоем высотных отметок

[Примечание] Примечание

При необходимости можно настроить ему прозрачность.

Если слой отметок активный, то при щелчке мыши в любой его области в окне Объект будет отображаться следующая информация:

  • ID плитки;

  • LAT, градусы – широта;

  • LON, градусы – долгота;

  • Zc, м – и высота точки, занесенная в ячейку;

  • Z, м – уточненная высота, именно она используется при считывании высот, данная высота выведена на основе анализа высот соседних ячеек.

На рисунке выше для наглядности отображена градусная сетка с шагом 1х1 градус, в каждой клетке которой находится отдельная плитка (включить сетку можно через меню Карта|Настройка|Проекция карты, раздел Градусная сетка).

Созданный файл *.zww функционально представляет собой только ссылку на данные, если файл открыть, например с помощью блокнота, то можно увидеть, что он содержит три строки, в которых указан тип данных, название файла и относительный путь до данных:

      Type: SRTM3
      Title: Высотные отметки
      Folder: .\

[Примечание] Примечание

Для того чтобы использовать файл высотных отметок в ZuluServer предварительно необходимо все данные перенести на сервер и затем опубликовать.


Настройка SRTM

После того, как SRTM слой добавлен в карту имеется возможность произвести дополнительные настройки.

[Важно] Важно

Все настройки, произведенные указанным далее способом относятся только к текущей карте, и сохраняются ТОЛЬКО при сохранении карты. И если настройки не были сохранены в слое, то при добавлении данного слоя в другую карту настройки выполненные для первой карты применяться не будут.

Для настройки SRTM слоя:

  1. Выполните команду меню Карта|Настройка слоя или нажмите на панели инструментов кнопку [image] .

  2. В появившемся окне Загруженные слои выберите слой рельефа и нажмите кнопку Настройка. Откроется диалог настройки рельефа.

    Также вызвать диалог настройки возможно, сделав щелчок правой кнопкой мыши по названию слоя в панели Рабочее место и выбрав в открывшемся контекстном меню пункт [image] Настройка.

    Настройки SRTM слоя

    Рисунок 579. Настройки SRTM слоя

  3. Параметры отображения рельефа задаются в следующих группах настроек вкладки Общие:

    1. Группа настроек Отображение:

      • слой отображается на карте только при установленном флажке отображать слой на карте;

      • для того чтобы слой печатался должен быть установлен флажок отображать слой при печати.

    2. Группа настроек Масштаб отображения:

      • не отображать при масштабе меньше, чем - слой не будет отображаться, если масштаб станет меньше заданного, масштаб указывается или геодезический и в сантиметрах на пиксель, в зависимости от настроек системы.

      • не отображать при масштабе больше, чем - слой не будет отображаться, если масштаб станет больше заданного, масштаб указывается или геодезический и в сантиметрах на пиксель, в зависимости от настроек системы.

  4. Во вкладке Настройки можно задать % прозрачности для слоя SRTM, где 0 - прозрачность отсутствует, 100 - полностью прозрачен.

  5. По завершении задания настроек слоя нажмите кнопку ОК чтобы сохранить изменения и закрыть диалог. Кнопка Отмена закрывает диалог без сохранения изменений.


Сохранение TIN в формат SRTM

Возможно сохранить рельеф TIN формата в одно секундный формат - SRTM1 или трех секундный - SRTM3. В первом варианте точность данных будет выше, но и соответственно будет больший объем данных.

Для сохранения TIN рельефа в формат SRTM:

  1. Загрузите в карту слой TIN рельефом.

  2. Выполните команду меню Карта|Рельеф|SRTM|Сохранить TIN в формате SRTM.

  3. Из списка Экспортируемый слой выберите слой, на основе которого будет создан SRTM слой.

  4. Справа от строки Имя файла описателя нажмите кнопку Обзор... и в открывшемся окне укажите путь и имя для файла описателя создаваемого рельефа.

  5. В соответствующую строку введите название слою.

  6. Из списка Формат выберите SRTM1 или SRTM3.

  7. Справа от строки Папка с файлами HGT нажмите кнопку Обзор... и укажите папку куда будут сохранены создаваемые файлы HGT.

  8. Если установить опцию Добавить в карту, то слой будет создан и добавлен в текущую карту.

    Сохранение TIN рельефа в SRTM формат

    Рисунок 580. Сохранение TIN рельефа в SRTM формат

  9. Для запуска процедуры сохранение нажмите кнопку ОК.

В результате в указанных папках будет создан описатель и файлы формата *.hgt.


Операции с рельефом

В зависимости от вида слоя рельефа возможны следующие операции:

  • «Построение изолиний (горизонтальных разрезов)»

  • «Построение зон затопления»

  • «Построение профиля»

  • «Вычисление площади и объема»

  • «Построение растра рельефа»


Построение изолиний (горизонтальных разрезов)

Построение изолиний возможно как для TIN так и для SRTM рельефа.

Изолинии представляют собой линии, которые находятся на одном уровне. Построение изолиний является эффективным методом для определения участков с одинаковой высотой. Они также играют важную роль в визуализации поверхности, так как позволяют наглядно показать плоские и крутые зоны, основываясь на расстоянии между изолиниями.

В ZuluGIS изолинии строятся по слою рельефа и затем сохраняются в отдельный векторный слой.

К построенным изолиниям может быть применена операция сглаживания, после применения которой будут сглажены прямые ребра и ломаные углы изолиний, угловатая форма будет заменена плавными линиями.

[Примечание] Примечание

С построением изолиний по TIN рельефу можно познакомится в видеоуроке по ссылке: https://www.politerm.com/videos/relief/relief_create/.

Построение изолиний по SRTM рельефу рассмотрено в следующем видео: https://youtu.be/6i0QBX3zTes.

Изолинии строятся либо по всему слою, либо по выделенной заранее области. Если требуется построить изолинии по области, то для ее выделения надо на панели Рельеф нажать кнопку Задать регион – [image] . После чего указать область построения. Область задается аналогично многоугольнику. Точки области фиксируются нажатием левой кнопки мыши, для окончания ввода региона выполните двойной щелчок левой кнопкой мыши, при этом первая и последняя точка будут соединены по прямой линии. Для отмены последней введенной точки щелкните правой кнопкой мыши и выберите в появившемся контекстном меню пункт Отменить последнюю точку.

Для построения изолиний:

  1. Выполните команду меню Карта|Рельеф|Построение изолиний. Откроется диалог построения изолиний.

    Диалог «Построение изолиний»

    Рисунок 581. Диалог «Построение изолиний»

  2. В списке Слой рельефа выберите слой для построения изолиний.

  3. Установите начальную высоту, конечную высоту, шаг рельефа в соответствующих полях. В том случае, если необходимо построение изолиний только на одном уровне, установите флажок На одном уровне и задайте начальную высоту.

  4. В строке Слой для записи нажмите кнопку Обзор..., укажите путь и имя файла создаваемого слоя изолиний в стандартном диалоге выбора файлов и нажмите кнопку Сохранить.

  5. В поле Название слоя введите пользовательское название для слоя изолиний, по умолчанию оно точно такое же как у имени файла.

  6. Изолинии могут быть построены в виде полилиний и/или полигонов, установите требуемый флажок и задайте цвет изолиний в полях Цвет от и до.

  7. Если построенные изолинии требуется сгладить, то надо поставить опцию Сглаживание и для задания параметров сглаживания нажать соответствующую кнопку. Параметры сглаживания настраиваются аналогично параметрам сглаживания объектов, подробно о настройках можно узнать в разделе «Сглаживание геометрии объекта».

  8. При необходимости создать таблицу высот установите флажок Создавать таблицу высот.

  9. Если созданный слой изолиний должен быть сразу добавлен в карту, то установите флажок Добавить слой в карту.

  10. Для завершения создания слоя изолиний нажмите кнопку ОК. Кнопка Отмена закроет диалоговое окно Построение изолиний без сохранения изменений.

На рисунке ниже показан слой изолиний, в котором изолинии строились с шагом по высоте в 10 м, изолинии построены в виде полилиний и полигонов.

Рисунок 582. Слой изолиний


Построение зон затопления

Построение зон затопления возможно только для рельефа TIN.

Зона затопления представляет собой область на модели рельефа, которая была бы заполнена водой при превышении уровня воды в заданной точке рельефа на заданную величину.

В ZuluGIS зоны затопления строятся по слою рельефа и затем сохраняются в отдельный векторный слой.

Для построения зон затопления:

  1. Сделайте активным слой рельефа.

  2. Установите режим выделения – [image] , и с помощью левой кнопки мыши укажите точку, с которой будут построены зоны.

  3. Выполните команду меню Карта|Рельеф|Зоны затопления. Отобразится диалог построения зон затопления с координатами указанной ранее точки в полях X м, Y м и Z м.

    Диалог построения зон затопления

    Рисунок 583. Диалог построения зон затопления

  4. В полях Превышение уровня воды и Шаг по высоте задайте уровень превышения и шаг по высоте соответственно. Значения вводятся с клавиатуры. Если зоны затопления нужно строить только на одном уровне, установите флажок На одном уровне, в этом случае Шаг по высоте не задается.

  5. В строке Слой для записи нажмите кнопку [image] , укажите путь и имя файла создаваемого слоя изолиний в стандартном диалоге выбора файлов и нажмите кнопку Сохранить.

  6. В поле Название слоя введите пользовательское название для слоя затоплений.

  7. Зоны затопления могут быть построены в виде полилиний и/или полигонов, установите требуемый флажок и задайте цвет изолиний в полях Цвет от и до.

  8. При необходимости создать таблицу высот установите флажок Создавать таблицу высот.

  9. Если созданный слой зон затопления должен быть сразу добавлен в карту, то установите флажок Добавить слой в карту.

  10. Для завершения создания слоя затоплений нажмите кнопку ОК. Кнопка Отмена закроет диалоговое окно Построение зон затоплений без сохранения изменений.

    [Примечание] Примечание

    С построением зон затопления можно ознакомиться в видеоуроке по ссылке: https://www.politerm.com/videos/relief/relief_create/.


Построение профиля

  • «Вид профиля»

  • «Копирование и сохранение таблицы профиля в Microsoft Excel и Microsoft Word»

Построение профиля возможно как рельефа TIN, так и для SRTM слоя.

Результат построения профиля отображается в виде графика высот вдоль заданного пути и таблицы высот с координатами, высотой и длиной каждого отрезка профиля. Построение профиля высот в системе ZuluGIS выполняется на загруженном в карту слое рельефа. В панели инструментов системы должна быть предварительно добавлена панель Рельеф (переместите указатель мыши на панели инструментов ZuluGIS щелкните правой кнопкой мыши и установите флажок в строке Рельеф открывшегося списка).

[Примечание] Примечание

С построением профиля можно ознакомиться в видеоуроке по ссылке: https://www.politerm.com/videos/relief/relief_create/.

Для построения профиля:

  1. Укажите путь для профиля, путь будет отображен в виде ломаной. Профиль возможно построить:

    • По произвольно указанному пути, чтобы нанести такой путь нажмите на панели инструментов кнопку Задать путь – [image] . Ввод такого пути аналогичен вводу обычной ломаной линии. Точки пути фиксируются нажатием левой кнопки мыши, а для окончания ввода пути выполните двойной щелчок левой кнопкой мыши. Для отмены последней введенной точки возможно либо нажать клавишу Esc, либо щелкнуть правой кнопкой мыши и выбрать в появившемся контекстном меню пункт Отменить последнюю точку. Так же через контекстное меню возможно отменить всю линию выбрав соответствующий пункт. Для построения профиля по указанному пути надо выбрать меню Карта|Рельеф|Построить профиль.

      [Примечание] Примечание

      Для удаления пути нажмите на панели управления кнопку Очистить рельеф [image] .

    • По мигающему линейному объекту. Перед построением данного пути объект, по которому будет построен путь необходимо активировать ("замигать"). Далее сделать щелчок правой кнопкой мыши и в появившемся контекстном меню выбрать пункт Объект|Профиль по рельефу. При этом, если удалить из карты слой по объекту которого был построен путь сам путь автоматически не удаляется.

    • По построенному пути по сети. При выборе данного варианта сначала необходимо построить путь по сети. Затем в области карты сделать щелчок правой кнопкой мыши и выбрать пункт Профиль пути по рельефу. При этом, если удалить из карты слой по объектам которого был построен путь сам путь автоматически не удаляется.

      Построение пути для профиля

      Рисунок 584. Построение пути для профиля

  2. В результате откроется окно Продольный профиль, которое разделено на две части. С левой стороны расположен построенный по пути профиль. Справа расположена таблица, состоящая из нескольких столбцов: координат точек профиля, высоты, длинны каждого отрезка профиля. Если данные, по которым строился профиль находятся в картографической проекции то в таблице будет выведена Широта/Долгота в WGS 84, в том случае когда данные в план-схеме в таблицу будут выведены координаты план-схемы.

    Рисунок 585. Продольный профиль

Вид профиля

После построения профиля имеется возможность отображать ноль на шкале профиля или нет. Для включения/исключения нуля надо выбрать меню Вид|Всегда включать в шкалу ноль.

При необходимости обновить вид профиля, например если построен новый путь возможно или кнопкой [image] или выбрав меню Вид|Обновить.

Копирование и сохранение таблицы профиля в Microsoft Excel и Microsoft Word

Данные таблицы возможно экспортировать в Microsoft Excel и Microsoft Word. Для экспорта надо сделать щелчок правой кнопкой мыши в области таблицы и выбрать соответствующий пункт. После чего, в появившемся диалоговом окне, нажав кнопку Обзор указать папку и имя для создаваемого файла. Для экспорта в Excel дополнительно необходимо в соответствующем окне надо задать имя листа Excel. Завершение экспорта производится нажатием кнопки Сохранить. Кнопка Отмена закроет диалог экспорта без сохранения изменений.

Так де информация из таблицы может быть скопирована в буфер для дальнейшей вставки в какой либо текстовый редактор. Для ее копирования надо сделать щелчок левой кнопкой мыши в области окна графика и выбрать пункт Копировать или нажать на панели окна профиля кнопку [image] .


Вычисление площади и объема

Вычисление площадей и объемов замкнутых областей на карте с учетом рельефа возможно только в случае использования TIN-рельефа. Вы можете указать область самостоятельно или воспользоваться отдельным слоем с уже заданными областями.

После выполнения вычислений результаты могут быть окрашены и записаны в отдельный слой. В панели инструментов системы должна быть предварительно добавлена панель Рельеф (переместите указатель мыши на панели инструментов ZuluGIS, щелкните правой кнопкой мыши и установите флажок в строке Рельеф открывшегося списка).

[Примечание] Примечание

Видеоурок по вычислению площади и объема можно посмотреть пройдя по ссылке: https://www.politerm.com/videos/relief/relief_square_size/.

Для вычисления площади и объема:

  1. Нажмите на панели инструментов кнопку Задать регион – [image] .

  2. Укажите область для вычисления:

    • Новая область задается аналогично многоугольнику. Точки области фиксируются нажатием левой кнопки мыши, для окончания ввода выполните двойной щелчок левой кнопкой мыши, при этом первая и последняя точка будут соединены по прямой линии. Для отмены последней введенной точки щелкните правой кнопкой мыши и выберите в появившемся контекстном меню пункт Отменить последнюю точку.

    • Так же для указания области может использоваться отдельный слой с уже ранее нанесенными областями. Области в слое должны быть площадными объектами (полигонами). Для использования готовой области из другого слоя нажмите клавишу Alt и не отпуская ее сделайте щелчок левой кнопкой мыши по области слоя, область выделится.

    Построение новой области

    Рисунок 586. Построение новой области

    Использование области из другого слоя

    Рисунок 587. Использование области из другого слоя

  3. Выполните команду меню Карта|Рельеф|Площадь, Объем. Откроется диалог вычисления площадей и объемов.

    Диалог Вычисление площади и объема

    Рисунок 588. Диалог Вычисление площади и объема

  4. В окне Уровень разреза укажите уровень разреза в метрах.

  5. Нажмите кнопку Расчет, после чего в полях диалога отобразятся результаты вычислений.

  6. Если результаты необходимо отобразить на карте и записать в отдельный слой, то для этого необходимо задать цвета областей в соответствующих разделах. Далее, в строке Слой для записи нажмите кнопку [image] , укажите путь, имя файла создаваемого слоя. В поле Название слоя введите его пользовательское название.

  7. Если созданный слой должен быть сразу загружен в активную карту, то установите флажок Добавить слой в карту, после чего нажмите кнопку Записать ответ в слой.

  8. Для закрытия окна Вычисление площади и объема нажмите кнопку Выход.


Построение растра рельефа

Построение растрового изображения по слою рельефа возможно только для рельефа TIN.

[Примечание] Примечание

С построением профиля можно ознакомиться в видеоуроке по ссылке: https://www.politerm.com/videos/relief/relief_create/.

Для построения растра рельефа:

  1. Выполните команду меню Карта|Рельеф|Запись в растр. Откроется диалог создания растра Создание растра по триангуляции. В демонстрационном окне в правой части диалога отображается примерный вид раскраски с заданными параметрами.

    Диалог «Создание растра по триангуляции»

    Рисунок 589. Диалог «Создание растра по триангуляции»

  2. В поле со списком Слой выберите слой рельефа, по которому требуется создать растр.

  3. В поле Число точек выберите число точек формируемого растра (по большей стороне создаваемого растра). При выбранном пункте «Авто» количество точек подбирается автоматически.

  4. Если требуется раскраска растра по высоте, установите флажок в группе настроек Раскраска по высоте и задайте цвета для раскраски в полях Цвет от и до.

  5. Для добавления отмывки рельефа (освещения ) в растр установите флажок группы настроек Отмывка рельефа и укажите масштаб высоты, направление источника света (в градусах) и его угол над горизонтом (в градусах) в соответствующих полях. В поле Уровень задается коэффициент смешения раскраски по высоте (если она используется) и отмывки. Значение может изменяться в пределах от «0» до «100», при значении «0» – применяется только раскраска, при «100» – только отмывка.

  6. В строке Растровый объект нажмите кнопку [image] и укажите путь и имя файла для создаваемого файла растрового изображения.

  7. Если требуется добавить в карту созданный растровый объект, установите флажок Добавить слой в карту.

  8. Для завершения создания растра нажмите кнопку ОК. Кнопка Отмена закроет диалоговое окно Создание растра по триангуляции без сохранения изменений.


Импорт рельефа

Текущая версия позволяет импортировать рельеф из следующих форматов:

  • «Импорт модели рельефа из LandXML TIN»

  • «Импорт модели рельефа из Esri TIN»

  • «Импорт модели рельефа из Intermediate TIN Format (ITF)»

[Примечание] Примечание

Видеоурок по импорту рельефа можно посмотреть пройдя по ссылке: https://www.youtube.com/watch?v=RCyS2BrXvc0.


Импорт модели рельефа из LandXML TIN

В результате импорта поверхностей нерегулярной триангулированной сети (TIN) из формата LandXML TIN будет получен слой рельефа TIN модели в котором по каждой точке можно получить значение высоты. Для успешного импорта в XML файле должен быть корневой индекс LandXML и TIN раздел со списком точек X, Y, Z. В том случае, если импортируемый XML файл не будет соответствовать LandXML формату, то будет выдано соответствующее сообщение.

Чтобы импортировать модель рельефа:

  1. Выполните команду меню Карта|Рельеф|Импорт|LandXML TIN.

  2. Выберите XML файл для импорта, нажмите кнопку Открыть.

  3. В диалоге Импорт модели рельефа из LandXML справа от строки Имя слоя нажмите кнопку Обзор.... Далее укажите каталог и имя для создаваемого в результате импорта файла рельефа.

  4. В строке Название слоя имеется возможность задать пользовательское название слоя отличное от имени файла.

  5. Из списка Цвет можно выбрать цвет для сетки рельефа.

  6. При установке опции Добавить в карту слой рельефа будет создан и добавлен в текущую карту.

  7. Кнопка ОК завершит процедуру импорта.

    Импорт рельефа из LandXML

    Рисунок 590. Импорт рельефа из LandXML


Импорт модели рельефа из Esri TIN

В результате импорта модели рельефа из формата Esri TIN будет получен слой рельефа TIN модели в котором по каждой точке можно получить значение высоты. Для импорта обязательно нужен набор файлов с расширением *.adf, содержащих массив x, у точек (tnxy.adf), массив высот точек (tnz.adf) и описанием треугольников (tnod.adf). Если отсутствует файл с описанием треугольников, то триангуляция будет выполнена системой. Импортируемые файлы должны располагаться в одном каталоге.

Чтобы импортировать модель рельефа:

  1. Выполните команду меню Карта|Рельеф|Импорт|Esri TIN.

  2. Укажите для импорта файл, содержащий массив x, y точек – tnxy.adf. Нажмите кнопку Открыть.

  3. В диалоге Импорт модели рельефа из Esri TIN справа от строки Имя слоя нажмите кнопку Обзор.... Далее укажите каталог и имя для создаваемого в результате импорта файла рельефа.

  4. В строке Название слоя имеется возможность задать пользовательское название слоя отличное от имени файла.

  5. Из списка Цвет можно выбрать цвет для сетки рельефа.

  6. При установке опции Добавить в карту слой рельефа будет создан и добавлен в текущую карту.

  7. Кнопка ОК завершит процедуру импорта.

    Импорт рельефа из Esri TIN

    Рисунок 591. Импорт рельефа из Esri TIN


Импорт модели рельефа из Intermediate TIN Format (ITF)

В результате импорта модели рельефа из формата ITF будет получен слой рельефа TIN модели в котором по каждой точке можно получить значение высоты.

Чтобы импортировать модель рельефа:

  1. Выполните команду меню Карта|Рельеф|Импорт|Intermediate TIN Format (ITF).

  2. Укажите для импорта файл *.itf. Нажмите кнопку Открыть.

  3. В диалоге Импорт модели рельефа из Intermediate TIN Format (ITF) справа от строки Имя слоя нажмите кнопку Обзор.... Далее укажите каталог и имя для создаваемого в результате импорта файла рельефа.

  4. В строке Название слоя имеется возможность задать пользовательское название слоя отличное от имени файла.

  5. Из списка Цвет можно выбрать цвет для сетки рельефа.

  6. При установке опции Добавить в карту слой рельефа будет создан и добавлен в текущую карту.

  7. Кнопка ОК завершит процедуру импорта.

    Импорт рельефа из Intermediate TIN Format (ITF)

    Рисунок 592. Импорт рельефа из Intermediate TIN Format (ITF)


Экспорт рельефа

Текущая версия позволяет экспортировать рельеф в следующие форматы:

  • «Экспорт рельефа в формат LandXML TIN»

  • «Экспорт рельефа в Intermediate TIN Format (ITF)»

  • «Сохранение TIN в формат SRTM»


Экспорт рельефа в формат LandXML TIN

Для экспорта слоя рельефа в формат LandXML TIN:

  1. Если слой для экспорта не загружен в карту, загрузите его.

  2. Выполните команду меню Карта|Рельеф|Экспорт|LandXML TIN.

  3. Из списка Экспортируемый слой выберите слой для экспорта.

  4. В поле Файл укажите путь и имя создаваемого XML файла. Для этого нажмите кнопку Обзор... справа от поля и задайте требуемый путь и имя файла в стандартном файловом диалоге.

  5. Завершите экспорт рельефа нажатием кнопки ОК.

    Экспорт рельефа в формат LandXML

    Рисунок 593. Экспорт рельефа в формат LandXML


Экспорт рельефа в Intermediate TIN Format (ITF)

Для экспорта слоя рельефа в Intermediate TIN Format (ITF):

  1. Если слой для экспорта не загружен в карту, загрузите его.

  2. Выполните команду меню Карта|Рельеф|Экспорт|Intermediate TIN Format (ITF).

  3. Из списка Экспортируемый слой выберите слой для экспорта.

  4. В поле Файл укажите путь и имя создаваемого файла. Для этого нажмите кнопку Обзор... справа от поля и задайте требуемый путь и имя файла в стандартном файловом диалоге.

  5. Завершите экспорт рельефа нажатием кнопки ОК.

    Экспорт рельефа в Intermediate TIN Format (ITF)

    Рисунок 594. Экспорт рельефа в Intermediate TIN Format (ITF)


Слой трекинга

  • «Просмотр информации по объектам слоя трекинга»

  • «Настройка отображения слоя трекинга»

  • «Индивидуальная настройка отображения треков»

  • «Редактирование баз данных слоя трекинга»

  • «Изменение источника данных»

  • «Экспорт слоя трекинга в векторный слой»

Введение

Слой трекинга отображает маршруты и текущее местоположение движущихся объектов на карте. Этот специальный слой предназначен для хранения и отображения данных о позициях и путях объектов.

Возможности слоя трекинга

  • Слежение за объектами в режиме реального времени. Слой трекинга поддерживает связь с устройствами отслеживания GPS, что позволяет отображать геоданные в режиме реального времени.

  • Отображение текущего местоположения или маршрутов объектов, а также названий объектов слоя.

  • Переключение отображения текущего местоположения объекта или пройденного им маршрута.

  • Фильтр по объектам и по дате.

  • Задание индивидуальных стилей отображения треков для различных пользователей: цвет, стиль и толщина линий.

  • Хранение в базе данных информации о маршрутах и текущем положении объектов слоя трекинга.

  • Поддерживается одновременная работа с несколькими слоями трекинга.

ZuluGIS позволяет провести различные настройки слоя трекинга: настроить отображение и фильтр по дате или по любым полям таблицы mobile_cu, редактировать базы данных слоя.

[Примечание] Примечание

Для обмена информацией с ZuluServer используются HTTP запросы для работы со слоями трекинга, которые обрабатываются веб-службой сервера.

Просмотр информации по объектам слоя трекинга

Рисунок 595. Просмотр информации по объектам слоя трекинга


Создание и настройка слоя трекинга

Создается слой трекинга с помощью утилиты публикации данных для веб-служб, которая входит в состав ZuluServer. По умолчанию он создаётся в проекции Широта/Долгота WGS 84. В качестве базы данных для него используется MS SQL LocalDB, которую можно легко перенести на MS SQL Server.

Также возможно использование СУБД Oracle для хранения данных этого слоя. В этом случае вам нужно будет самостоятельно подготовить базу данных. Более подробную информацию вы можете получить, связавшись с отделом технической поддержки.

[Примечание] Примечание

При необходимости источник данных таблиц слоя можно изменить.

Слой создается на сервере и для дальнейшей работы с ним необходимо сделать дополнительные настройки. Эти настройки выполняются в приложении ZuluGIS Mobile на устройстве, данные которого будет передавать трек.

Необходимо сделать следующие настройки:

  1. Добавить созданный слой в ZuluGIS Mobile.

  2. Произвести настройки ZuluGIS Mobile.

  3. Так же в мобильном приложении можно настроить интервал обновления и временной фильтр.


Просмотр информации по объектам слоя трекинга

Если слой трекинга не загружен в карту, то загрузите его.

Чтобы просмотреть информацию об объектах слоя трекинга, откройте окно информации по объекту, щёлкнув левой кнопкой мыши в режиме [image] Информация. При этом слой трекинга должен быть активным.

Для переключения между просмотром информации о текущем местоположении (current) или о точках маршрута (tracks), используйте переключатель формы, который изображён на следующем рисунке.

Вы так же можете редактировать базу данных слоя трекинга, например, чтобы переименовать существующие поля или добавить новые.

Выбор формы для просмотра информации

Рисунок 596. Выбор формы для просмотра информации

Для хранения информации в слое трекинга используются две таблицы:

  1. mobile_track – таблица для хранения маршрутов, содержащая следующую информацию:

    • UserID – ID объекта слоя трекинга;

    • Lat – широта, град;

    • Lon – долгота, град;

    • Z – высота, м;

    • V – скорость движения, м/с;

    • D – дата и время записи координат в базу данных трекинга;

    • Dm – дата и время записи координат на мобильном устройстве.

    Таблица mobile_track для хранения маршрутов

    Рисунок 597. Таблица mobile_track для хранения маршрутов

  2. mobile_cur – таблица, хранящая информацию о текущем местоположении объектов, содержащая следующий список полей:

    • UserID – ID объекта слоя трекинга;

    • UserName – имя пользователя или устройства;

    • DisplayName - имя отображающееся на карте;

    • Device – модель устройства;

    • Lat – широта, град;

    • Lon – долгота, град;

    • Z – высота, м;

    • D – дата и время записи координат в базу данных трекинга;

    • Dm – дата и время записи координат на мобильном устройстве;

    • LineColor – цвет линии отображения маршрута объекта, настраивается пользователем индивидуально для каждого объекта;

    • LineStyle – стиль линии отображения маршрута объекта, указывается пользователем при помощи номера стиля линии индивидуально для каждого объекта;

    • LineWidth – толщина линии в пикселях, указывается пользователем индивидуально для каждого объекта;

    • Description – текстовое описание устройства или объекта трекинга;

    • Img – строка для добавления символа, который будет отображен на карте в месте нахождения устройства.

    Таблица mobile_cur, хранящая информацию о текущем местоположении объектов.

    Рисунок 598. Таблица mobile_cur, хранящая информацию о текущем местоположении объектов.


Настройка отображения слоя трекинга

Настройка слоя трекинга позволяет задать отображение определённых пользователей по любым данным таблицы mobile_cur или установить фильтр по дате, чтобы ограничить видимость данных только за определённый период.

Кроме того, есть возможность включить отображение маршрутов вместо текущего местоположения объектов в этом слое. Также вы можете настроить масштаб для наименования из поля DisplayName или UserName и масштаб символов из поля Img.

[Примечание] Примечание

Произведенные настройки отображения слоя трекинга будут сохранены только при сохранении карты.

Для настройки отображения слоя трекинга:

  1. Выберите меню Карта|Настройка слоя или в панели Рабочее место сделайте щелчок правой кнопкой мыши по названию слоя и выберите в открывшемся контекстном меню пункт Настройка.

  2. Перейдите на вкладку Фильтр.

    Настройка отображения слоя трекинга. Вкладка Фильтр.

    Рисунок 599. Настройка отображения слоя трекинга. Вкладка Фильтр.

  3. Далее можно настроить следующие фильтры:

    • Фильтр по объектам

      В данном разделе может быть настроен фильтр по любым полям таблицы mobile_cur. Используя фильтр, вы можете настроить отображение определенных объектов на экране.

      Для фильтрации отображаемых данных информацию, по которой требуется фильтровать, вводят в таблицу справа от названия поля. Синтаксис в фильтре по данным аналогичен правилам написания запросов в окне семантической информации.

    • Фильтр по дате

      Для фильтрации отображения треков за определенный период времени следует выбрать:

      • Без фильтра – слой будет отображен без фильтра по дате;

      • Сегодня – отображает данные только за текущий день;

      • Последние N дней – для фильтрации по данному параметру справа следует ввести количество дней;

      • Интервал – устанавливается интервал времени, в течение которого требуется отобразить треки.

  4. Также возможно установить следующие опции отображения:

    • Отображать треки – данная опция включает отображение треков (маршрутов) объектов на экране;

    • Отображать имена объектов – данная опция включает отображение названий объектов из поля DisplayName или из поля UserName, если данные в первом поле отсутствуют;

    • Отображать последнее местоположение – при включении данной опции текущее местоположение объектов будет отображаться красным кружком;

    • Отображать точки трека - при включении данной опции на экране будут отражаться точки трека.

  5. Изменить масштаб отображения наименования трека и символа, которым отображается на карте устройство можно изменив масштабирующий коэффициент в окошке Масштаб надписей и Масштаб символов соответственно. По умолчанию установлен минимальный масштаб 1.

  6. Интервал между треками при необходимости задается в минутах в соответствующем окне. Если время между соседними точками трека больше интервала, то они не соединяются линией, то есть будут отдельные полилинии.

  7. Кнопка Экспорт откроет окно экспорта слоя трекинга.

  8. Кнопка База откроет редактор баз данных для редактирования баз.

  9. Нажмите ОК для сохранения настроек.


Индивидуальная настройка отображения треков

Вы можете настроить отображение треков в соответствии с вашими предпочтениями: имя, цвет, стиль и толщину линий. Кроме того, можно добавить специальный символ, который будет отображаться на карте в месте нахождения вашего устройства. Для индивидуальной настройки стиля отображения:

  1. Откройте окно информации по объекту.

  2. В открывшемся окне информации выберите форму current, используя переключатель в правой части окна.

    Выбор формы для просмотра информации

    Рисунок 600. Выбор формы для просмотра информации

  3. Для настройки служат следующие поля в базе данных:

    • DisplayName – в данное поле вводится наименование для его отображения на карте, если поле не заполнено, данные для вывода будут браться из поля UserName;

    • LineColor – при нажатии на правую часть строки отобразится палитры выбора цвета;

    • LineStyle – указывается номер стиля линии для отображения;

    • LineWidth – указывается толщина линии в пикселях;

    • Img – загружается символ, который будет отображен на карте в месте нахождения устройства.

    Индивидуальная настройка отображение треков объекта

    Рисунок 601. Индивидуальная настройка отображение треков объекта

  4. Чтобы сохранить изменения, нажмите кнопку [image] (Ctrl+S).


Редактирование баз данных слоя трекинга

Вы можете работать с базой данных слоя трекинга: переименовывать существующие поля, добавлять новые, менять внешний вид отображения в браузере БД.

Для редактирования баз данных слоя трекинга:

  1. Выберите меню Карта|Настройка слоя или в панели Рабочее место сделайте щелчок правой кнопкой мыши по названию слоя и выберите в открывшемся контекстном меню пункт Настройка.

  2. Перейдите на вкладку Фильтр.

    Настройка отображения слоя трекинга. Вкладка Фильтр.

    Рисунок 602. Настройка отображения слоя трекинга. Вкладка Фильтр.

  3. Нажмите кнопку База. Откроется редактор базы данных слоя трекинга. По умолчанию в базе содержатся две таблицы mobile_cur, mobile_track и соответствующие им запросы currents и tracks.

    База данных слоя трекинга

    Рисунок 603. База данных слоя трекинга

  4. Далее вы можете редактировать базу данных по собственному усмотрению.


Изменение источника данных

При необходимости источник данных для таблиц слоя трекинга можно заменить. Для этого:

  1. Создайте подключение к источнику данных, например, Postgre SQL.

  2. Опубликуйте источник данных в администраторе ZuluServer.

  3. Осуществите миграцию таблиц из редактора баз данных. Для этого откройте настройку слоя трекинга. Выберите вкладку Фильтр, нажмите кнопку База. Далее сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Задачи/Миграция данных... Выполните миграцию.


Экспорт слоя трекинга в векторный слой

Вы можете экспортировать слой трекинга в векторный слой. В результате экспорта будет создан векторный слой с простыми линейными объектами, повторяющими маршруты слоя трекинга. К объектам будет подключена база с полями UserID и UserName.

Для экспорта:

  1. Загрузите слой трекинга трекинга в текущую карту.

  2. В панели Рабочее место сделайте щелчок правой кнопкой мыши по названию слоя и выберите в открывшемся контекстном меню пункт Настройка.

    или выберите меню Карта|Настройка слоя и укажите слой в списке.

  3. Перейдите на вкладку Фильтр.

  4. Нажмите кнопку Экспорт.

  5. В открывшемся диалоге нажмите кнопку Обзор... и укажите место и название для создаваемого векторного слоя.

  6. Из списка Таблица выберите таблицу для баз данных.

  7. Если надо изменить систему координат, нажмите соответствующую кнопку и укажите новую систему координат для создаваемого слоя (списки поддерживаемых типов проекций и датумов см. Поддерживаемые типы проекций и датумы). Подробней о географических проекциях и системах координат можно узнать в разделе Географическая проекция и система координат.

  8. Установите флажок Добавить в карту для автоматического добавления созданного слоя в текущую карту.

    Диалог экспорт слоя трекинга в векторный слой

    Рисунок 604. Диалог экспорт слоя трекинга в векторный слой

  9. Нажмите кнопку ОК.


Особенности работы с данными через ZuluServer

  • «Как определить, расположен ли слой на сервере или на локальной машине»

  • «Подготовка данных с помощью утилиты ZSDataPrepare.exe»

  • «Подготовка данных с помощью копирования их на сервер геоданных»

  • «Соединение с сервером»

  • «Обновление данных на рабочих местах пользователей»

  • «Как узнать версию ZuluServer с клиента»

  • «Возможные проблемы при работе со слоями через ZuluServer»

Вся работа с данными производится в ZuluGIS. ZuluGIS позволяет редактировать данные, хранящиеся на диске используя файловый доступ, в однопользовательском режиме, а также данные на сервере геоданных в многопользовательском режиме.

[Предупреждение] Предупреждение

Не рекомендуется и не сопровождается использование многопользовательского режима, если данные открываются из расширенной сетевой папки, так как это может привести к повреждению данных и блокировка доступа к ним. Для многопользовательской работы с данными необходимо открывать их с ZuluServer и созданного к нему подключения через сервер геоданных.

При работе с данными на сервере геоданных формат данных (растровых, векторных, WMS и тайловых слоёв) не изменяется. Добавляется только описатель слоя в виде файла с расширением .zl. Этот файл содержит путь к основному файлу слоя (B00, ZRS, ZRG, ZWW и т. д.). В серверную карту добавляются именно данные файлы-описатели, то есть карта должна содержать в качестве ссылок на слои не имена слоев, а имена их описателей.

При создании слоя на сервере геоданных и копировании слоя на сервер геоданных файлы слоя и файл описатель создаются в одно месте. Путь в файле zl указывают что все файлы слоя в одном месте.

При публикации слоёв (если они передаются кому-либо) файлы zl и файлы слоя могут быть размещены в разных местах, а путь в файле zl может быть как относительным, так и абсолютным. Если изменить расположение файлов слоя, то файлы zl могут перестать работать. Поскольку основной единицей хранения данных является слой, файл карты при сохранении на сервере геоданных или на диске не изменяется, но внутри него прописываются пути к открываемым слоям и их настройки.

Публикация данных возможна двумя способами:

  • «Подготовка данных с помощью утилиты ZSDataPrepare.exe»

  • «Подготовка данных с помощью копирования их на сервер геоданных»

[Примечание] Примечание

Подробнее об организации данных ZuluServer можно узнать в справке по данному программному продукту: https://www.politerm.com/zuluserver/webhelp/index.html#zsdata.html


Как определить, расположен ли слой на сервере или на локальной машине

Определить, расположен ли слой на сервере или на локальной машине, можно двумя способами, во втором варианте также виден путь до слоя.

Первый вариант – это обратить внимание на цвет иконки слоя в окне Рабочее место. Слой с иконкой с сервера имеет сиреневый оттенок, a слой с локальной машины – зеленый оттенок. То же самое относится к карте:

Окно Рабочее место

Рисунок 605. Окно Рабочее место

Второй вариант – это узнать точное расположение слоя в диалоге Загруженные слои. Для этого надо открыть диалог (Карта|Слои). По цвету иконок точно так же, как и в окне Рабочее место, можно сразу определить, где находится слой: на сервере или на локальной машине.

Для того чтобы увидеть путь до слоя, надо, чтобы в диалоге была установлена опция Показывать имена файлов:

Диалог Загруженные слои

Рисунок 606. Диалог Загруженные слои

У слоя, располагающегося на сервере, путь обязательно начинается с zulu://:

Слой на сервере

Рисунок 607. Слой на сервере

У локального слоя путь начинается с названия диска:

Слой на локальной машине

Рисунок 608. Слой на локальной машине


Подготовка данных с помощью утилиты ZSDataPrepare.exe

Утилита расположена в папке, в которой установлен ZuluServer, запустить ее можно через меню Пуск, каталог ZuluGIS/Публикация данных для ZuluServer 2021. Используя данную утилиту, можно подготовить к работе с ZuluServer как слои, так и карты и проекты.

[Примечание] Примечание

Доступ к утилите ZSDataPrepare.exe возможен только после установки ZuluServer.

Подробнее о утилите публикации данных ZSDataPrepare.exe можно узнать в справке по ZuluServer.

После подготовки данных сами данные не будут изменены, к ним будут созданы дополнительные файлы с расширением *.zl, которые будут ссылаться на реальные данные.

Например, необходимо опубликовать слой house, который расположен: D:\Map\house.b00.

Для публикации первым делом надо указать папку, в которую будет сохранен созданный файл-описатель. По умолчанию в качестве него принимается подкаталог Data каталога, где установлен сервер. Область данных сервера находится в корневой папке данных сервера и любых его подкаталогах. Корневой каталог данных сервера указан в конфигурационном файле ZuluServ.cfg в переменной RootDir.

Для записи опубликованного файла создадим каталог Test. Для этого в диалоге Публикация данных справа от строки Каталог для надо нажать кнопку Обзор.... Затем в появившемся окне Обзор папок нажать кнопку Создать папку, задать название новой папке и подтвердить ее создание кнопкой ОК.

Диалог для каталога

Рисунок 609. Диалог для каталога

Следующим этапом надо указать слои для публикации, для этого нажмите кнопку Выбрать слои и укажите необходимые файлы.

Диалог подготовки данных

Рисунок 610. Диалог подготовки данных

Обратите внимание, что в диалоге Обзор папок полный путь не виден, полный путь до созданного каталога отображен в диалоге Публикация данных в строке Каталог для.

Для завершения подготовки данных нажмите кнопку Создать, после чего появится окно со списком опубликованных ресурсов.

В результате проделанных действий исходный слой будет нетронут, а в каталоге C:\Program Files\ZuluGIS\Data\Test будет создан файл описатель вида *.zl, где * – название исходного слоя.

[Примечание] Примечание

Данный описатель содержит только ссылку на слой. Сам слой остается неизменным, и его местоположение не меняется.

Пример файла описателя слоя

Рисунок 611. Пример файла описателя слоя


Подготовка данных с помощью копирования их на сервер геоданных

[Примечание] Примечание

Данный способ публикации данных возможен, только когда у пользователя есть права на создание слоев и карт на сервере.

Для подготовки данных с помощью копирования надо скопировать их на сервер геоданных. Копировать на сервер возможно как отдельно слои, так и карту целиком. Во втором варианте производится копирование как карты, так и одновременно всех ее слоев.

Для копирования карты выберите пункт меню Карта|Операции|Копировать карту. Далее в разделе Карта для записи с использованием кнопки Обзор укажите каталог на сервере геоданных (кнопка [image] Серверы геоданных).

Подробнее о копировании карты можно узнать разделе «Копирование карты».

Для копирования слоя выберите пункт меню Слой|Скопировать. Далее в диалоге Копировать слой в разделе Исходный слой укажите слой для копирования, а в разделе Слой для записи справа от строки имя нажмите кнопку Обзор, выберите раздел Серверы геоданных, укажите папку для копирования или создайте новую. Подробнее о копировании слоя можно узнать разделе «Копирование слоя».

Диалог копирования слоя

Рисунок 612. Диалог копирования слоя

Данные в результате будут скопированы на сервер, и к ним будет добавлен файл-описатель с расширением *.zl, содержащим путь до скопированного файла. При этом путь будет указан относительный. Например, в результате копирования слоя, представленного на рисунке выше, содержимое файла *.zl будет таким:

Рисунок 613. Файл-описатель

Это означает, что файл слоя находится в той же папке, что и файл-описатель.

[Примечание] Примечание

Именно такой способ публикации векторных слоев наиболее предпочтителен, так как благодаря относительному пути в файле *.zl можно будет избежать ошибок при перемещении данных.


Соединение с сервером

  • «Смена пароля пользователя»

Для создания соединения клиента с сервером в ZuluGIS:

  1. Откройте диалог открытия слоя или открытия карты. Слева в диалоге нажмите кнопку [image] Серверы геоданных, после чего будет отображена виртуальная папка со списком соединений.

    Диалог открытия карты

    Рисунок 614. Диалог открытия карты

  2. В папке соединений дважды щелкните по строчке Добавить/удалить соединение.

  3. В открывшейся панели Источники геоданных нажмите кнопку Добавить.

    Диалог Источники геоданных

    Рисунок 615. Диалог Источники геоданных

  4. Далее в панели Источник данных задайте параметры соединения:

    Диалог Источники геоданных

    Рисунок 616. Диалог Источники геоданных

    • В поле Название впишите название источника, потом это имя будет появляться в папке списка соединений.

    • В поле адрес укажите адрес сервера. Можно указывать доменное имя (например zs.zulugis.ru), ip-адрес (например 164.121.2.1) или сетевое имя компьютера в локальной сети или сети интернет (например IGOR_II).

    • В поле порт указывается номер порта, на котором работает сервер (по умолчанию 6473), порт должен быть открыт, особенно при подключении пользователей через интернет.

    • В разделе Пользователь укажите способ авторизации на сервере: Учетные сведения Windows или Используя логин и пароль.

      Во втором случае сами логин и пароль задавать не обязательно – Zulu запросит их в момент соединения. Все настройки пользователей и их пароли изначально задаются в администраторе ZuluServer.

  5. Нажмите ОК и в панели Источники геоданных нажмите Закрыть.


Смена пароля пользователя

[Примечание] Примечание

Смена пароля пользователем возможна только в режиме повышенной безопасности ZuluServer!

Для смены пароля:

  1. Откройте диалог открытия слоя или открытия карты. Слева в диалоге нажмите кнопку [image] Серверы геоданных.

  2. В папке соединений дважды щелкните по строчке Добавить/удалить соединение.

  3. В панели Источники геоданных в списке выделите соединение для смены пароля.

  4. Нажмите кнопку Изменить.

  5. Справа от строки Пароль нажмите кнопку [image] и выберите Задать новый пароль.

  6. Введите новый пароль. Пароль должен содержать символы верхнего и нижнего регистра и специальные символы. По умолчанию длина должна быть не менее 8 символов, но она может быть изменена администратором.

  7. Нажмите ОК.


Обновление данных на рабочих местах пользователей

По умолчанию данные у пользователей обновляются при перестроении карты. Можно настроить автоматическое обновление через определенный интервал. Тогда после изменений у одного пользователя данные всех остальных обновятся с этим интервалом. Обновятся все данные: графические, семантические, тематические раскраски и так далее.

Для настройки обновления:

  1. Откройте диалоговое окно настроек слоя «Настройка слоя», для этого выберите меню Карта|Слои... или нажмите на панели инструментов кнопку [image] . Если в карте один слой, то окно настроек откроется автоматически. Если слоев несколько, сначала выберите нужный слой, щелкнув по нему левой кнопкой мыши, затем нажмите кнопку Настройка.

    ИЛИ

    Сделайте щелчок правой кнопкой мыши по названию слоя в панели Рабочее место и выберите в открывшемся контекстном меню пункт [image] Настройка.

  2. Откройте вкладку Редактор.

  3. Из списка Интервал обновления выберите интервал, с которым необходимо обновлять данные на рабочих местах.

    Окно настройки слоя. Вкладка Редактор

    Рисунок 617. Окно настройки слоя. Вкладка Редактор

  4. Для закрытия диалога и сохранения настроек нажмите кнопку ОК.


Как узнать версию ZuluServer с клиента

[Примечание] Примечание

Как определить номер локальной версии ZuluGIS, можно узнать в разделе Обновление ПО.

При работе с данными через ZuluServer важно, чтобы номер локальной версии ZuluGIS совпадал с номером версии ZuluServer. Если работа производится непосредственно за компьютером-сервером, то версию можно определить, например, просмотрев информацию о программе в Администраторе ZuluServer или мониторе ZuluServer.

При работе за клиентским местом определить номер версии ZuluServer можно двумя способами:

  1. В настойках слоя, открытого с сервера.

  2. По HTTP запросу адреса сервера.

Определение номера версии с клиента через настройки слоя

Для определения номера версии загрузите в активную карту слой с ZuluServer. Обратите внимание на то, что у слоя, загруженного с сервера геоданных, цвет иконки в панели Рабочее место сиреневый – [image] . Далее:

  • Сделайте щелчок правой кнопкой мыши на слое в панели Рабочее место и в появившемся контекстном меню выберите пункт [image] Настройка.

    ИЛИ

  • Выберите меню Карта|Настройка слоя, выделите слой в списке и нажмите кнопку Настройка.

В открывшемся окне номер и разрядность версии ZuluServer указан в строке Источник.

Например:

  • если сервер 32-бит - ZuluServer 10.0.0.9316u.win32;

  • если сервер 64-бит - ZuluServer 10.0.0.9316u.x64.

Окно настройки слоя

Рисунок 618. Окно настройки слоя

Определение номера версии с клиента по HTTP запросу адреса сервера

Для определения номера версии по запросу надо в адресной строке браузера ввести запрос:

​http://localhost:6473/

где вместо localhost требуется указать адрес сервера. В результате при переходе по ссылке браузер показывает, что ZuluServer работает, и отображает его версию:

Номер версии ZuluServer

Рисунок 619. Номер версии ZuluServer


Возможные проблемы при работе со слоями через ZuluServer

При работе с векторными слоями через ZuluServer могут возникнуть различные проблемы, например:

  • При загрузке слоя в карту появляется сообщение Невозможно загрузить слой 'путь и название слоя'.

  • После копирования при редактировании копии в исходных данных также происходят изменения.

Обе приведенные выше ошибки возникают вследствие неправильного пути до файла слоя в файле-описателе *.zl.

В первом случае ошибка может возникнуть, если файл слоя был удален или перемещен.

Вторая ошибка возможна в случае копирования слоя не средствами ZuluGIS. Например, необходимо создать перспективную сеть, в этом случае пользователь часто просто делает копию каталога с данными. При таком копировании (если путь был абсолютным) ссылка в файле-описателе будет указывать на предыдущий, а не скопированный слой.

Для того чтобы исправить вышеприведенные ошибки, необходимо отредактировать файл-описатель *.zl. Файл располагается в корневом каталоге ZuluServer или его подкаталогах. Для редактирования его надо открыть текстовым редактором (например, блокнотом), исправить путь до файла слоя и затем сохранить. При этом для избежания дальнейших ошибок при перемещении данных желательно задать относительный путь.


Подготовка данных для веб-служб ZuluServer

  • Публикация данных для веб-служб ZuluServer

  • Редактирование ранее опубликованных данных

Работа со слоями ZuluServer в ZuluGIS Online и ZuluGISMobile без предварительной подготовки невозможна. Подготовка заключается в публикации данных. Она осуществляется с использованием специальной утилиты ZsWsSetup.exe или непосредственно из ZuluGIS. Информацию о публикации через утилиту можно найти в справке по ZuluServer. Ниже описан второй вариант публикации, он производится по протоколу ZWS.


Публикация данных для веб-служб ZuluServer

Чтобы опубликовать серверный слой для веб-служб ZuluServer из ZuluGIS:

  1. Выберите меню Слой|Опубликовать для веб-служб ZuluServer.

  2. Если слой заранее не загружен в активную карту, то в открывшемся окне Выбор слоя укажите слой на сервере геоданных для публикации. Если слой загружен, то откроется диалоговое окно Публикация слоев по протоколу ZWS. В нем из списка Слой выберите слой. Также слой возможно выбрать, нажав кнопку Обзор.

    [Предупреждение] Предупреждение

    Слой для публикации должен быть опубликован на ZuluServer.

    При выборе для публикации локального слоя появится сообщение: Локальный слой не может быть опубликован для WEB. Выберите слой на сервере. Далее необходимо нажать кнопку ОК и указать слой на сервере геоданных.

  3. Создайте пространство имён. Для этого следует нажать кнопку Добавить и в появившемся окне внести название для пространства. Допустимыми в названии являются латинские буквы, арабские цифры и символ "_". Если нужное пространство уже имеется, то его надо выбрать из соответствующего списка.

  4. В строке Имя ZWS введите служебное имя слоя и установите опцию Доступ.

  5. Выберите параметры отображения слоя:

    • по умолчанию – слой будет отображаться без собственных настроек отображения;

    • из настроек слоя – при отображении слоя будут использоваться настройки (масштаб отображения слоя, типов и режимов, направлений), сохранённые в слое.

  6. Обновление, с - указывается в секундах частота обращения клиента к серверу для проверки актуальности текущих данных. Необходимо указывать только в случаях, когда данные слоя меняются «внешними средствами», например при записи в базу данных слоя SCADA системой или изменении данных с помощью запросов внутри СУБД. Если данные меняются средствами Zulu, то в этом случае обновление настраивается непосредственно в ZuluGIS Online или ZuluGISMobile.

  7. Для отключения в опубликованном слое поиска объектов по ID снимите опцию Поиск по ID.

  8. При установке опции Редактирование геометрии через веб отключено запрещается редактирование графической информации через веб-службы. В этом случае при попытке редактирования геометрии через ZuluGIS Online или ZuluGISMobile будет появляться ошибка.

  9. При установке опции Редактировать в ZuluGISMobile только по GPS в ZuluGISMobile координаты при вводе объекта возможно получать только по GPS данным.

  10. Для инженерных сетей из списка Расчетная модель можно указать расчетную модель, которая соответствует публикуемому слою. Данный параметр следует обязательно указывать только в том случае, если планируется вести гидравлические расчеты из веб-интерфейса через тонкого клиента с использованием ZuluNetTools.

    Диалог Публикация слоев по протоколу ZWS

    Рисунок 620. Диалог Публикация слоев по протоколу ZWS

  11. Нажать кнопку Опубликовать.

    В случае удачной публикации в разделе Публикации появится название пространства имен и через двоеточие название опубликованного слоя.


Редактирование ранее опубликованных данных для веб-служб

Отредактировать настройки ранее опубликованного слоя можно через утилиту ZsWsSetup.exe. Утилита расположена в том же каталоге, где установлен сервер ZuluServ.exe. Интерфейс утилиты выполнен в виде «проводника». Слева расположено дерево разделов. При выделении нужного раздела в дереве разделов справа отображается страница свойств, касающихся выделенного раздела.

[Примечание] Примечание

Подробнее об утилите ZsWsSetup.exe можно почитать в справке по ZuluServer.

Чтобы отредактировать настройки:

  1. Запустите утилиту с правами администратора.

  2. Слева в дереве разделов выделите нужное пространство имен. Справа при этом отобразится список слоев выделенного пространства.

  3. Справа сделайте двойной щелчок мыши по названию слоя для его редактирования или выделите слой и нажмите кнопку Изменить.

  4. В появившемся окне настроек измените необходимые параметры, нажмите кнопку ОК.

    Редактирование слоя по протоколу ZWS

    Рисунок 621. Редактирование слоя по протоколу ZWS

  5. Для сохранения настроек выберите меню Файл|Сохранить.


Семантические базы данных

  • «Окно семантической информации»

  • «Источники данных ZuluGIS»

  • «Миграция данных»

  • «Создание базы данных»

  • «Редактирование и настройка базы данных»

  • «Заполнение базы данных (табличной информации)»

  • «Работа с заполненной базой данных (табличными данными)»

Общие сведения

Для хранения семантической информации ZuluGIS может использовать различные источники табличных данных. Это могут быть как коммерческие, так и бесплатные клиент-серверные СУБД: Microsoft SQL Server, Oracle, Sybase, PostgreSQL, MySQL, Линтер, и т.д., файл-серверные СУБД: SQLite, другие источники, поддерживающие ODBC или ADO соединения. В поставку ZuluGIS входит бесплатная СУБД Microsoft SQL Server Express LocalDB.

Для удобства и единообразия доступа к семантическим данным ZuluGIS описывает подключения к различным СУБД в виде своих «источников данных». Подобно источникам данных ODBC DSN или связям с данными OLEDB UDL эти источники данных можно использовать при добавлении таблиц в базу данных или выборе таблиц для других операций. Источники данных могут использоваться как локально в однопользовательской версии ZuluGIS, так и на ZuluServer. Подробнее об источниках данных «Источники данных ZuluGIS».

Физически файлы таблиц могут располагаться в удобном для пользователя месте (на сервере, на локальной машине в отдельном каталоге, в том же каталоге, что и файлы графической базы данных). Желательно чтобы файл описателя базы данных хранился в том же каталоге, что и файл графической базы данных. Описатель базы данных ZuluGIS хранит следующую информацию:

  • список таблиц, участвующих в запросе;

  • если необходимо – набор справочников;

  • набор запросов, задающих правила выбора значений из таблиц и содержащих ссылки на таблицы, из которых выполняется выборка, связи между таблицами, набор полей для вывода с пользовательскими названиями;

  • если необходимо – набор форм для разного отображения информации.


Окно семантической информации

  • «Общие сведения об окне семантической информации»

  • «Дополнительные возможности при работе с окном семантической информации»

Окно семантической информации используется для просмотра и редактирования информации по объектам.

Открытие окна семантической информации

Для открытия окна семантической информации по объекту:

  1. Включите режим Информация - [image] .

  2. Сделайте активным слой, по которому надо получить информацию.

  3. Щелкните левой кнопкой мыши на объекте.

    [Примечание] Примечание

    Вы можете заранее не активизировать слой. В этом случае перед щелчком по объекту нажмите и удерживайте клавиши Ctrl+Shift. Данное сочетание клавиш активизирует слой, в котором находится объект.

    В результате откроется окно семантической информации, содержащее результаты запроса по указанному объекту. По умолчанию открывается вкладка Текущая запись. Для получения информации по следующему объекту щелкните по нему левой кнопкой мыши.

    Если в режиме получения информации по активному слою удерживать на клавиатуре клавишу Alt, то при работе с инженерной сетью, даже при очень маленьком масштабе всегда будет вызываться окно семантической информации по участкам.

    По умолчанию в окне отображается основной запрос базы данных. Если в базе ранее были настроены формы, то вы можете переключаться между ними.

    Окно семантической информации вкладка Текущая запись

    Рисунок 622. Окно семантической информации вкладка Текущая запись

    Чтобы просмотреть все записи базы, перейдите на вкладку База. По мере того как вы будете перемещаться по записям в таблице, на карте будут отображаться соответствующие объекты слоя, которые будут мигать. Вы можете перемещаться по полям, используя стрелки на клавиатуре или щелкая левой кнопкой мыши по нужной строке. Если во втором случае нажать и удерживать клавишу Alt, карта будет масштабирована так, чтобы объект, к которому относится запись, оказался в центре экрана.

    Окно семантической информации вкладка База

    Рисунок 623. Окно семантической информации вкладка База

    По умолчанию при открытии окна семантической информации запрос производится по активному слою. Если же в режиме получения информации по объекту нажать и удерживать клавишу Ctrl, то запрос будет выполнен по всем слоям карты одновременно. При получении ответа от одного слоя, откроется окно семантической информации этого слоя. При получении ответов от нескольких слоев, появится окно со списком этих слоев, кликая на который, можно открывать семантическую информацию конкретного слоя. Если окна семантической информации тех или иных слоев уже открыты, в них просто будут отображаться полученные ответы.

    Рисунок 624. Выбор слоя

[Примечание] Примечание

При желании вы можете настроить, чтобы всегда выполнялся запрос по всем слоям карты (без дополнительно нажатой клавиши Ctrl). Для этого откройте диалоговое окно Параметры (Сервис|Параметры), вкладку Карта и в разделе Кнопка "Информация" установите опцию По всем слоям карты. В этом случае уже запрос только к активному слою будет выполняться с клавишей Ctrl.

Кроме выше описанного варианта открытие окна семантической информации можно осуществить через окно Базы данных, которое вызывается через:

  • меню Карта|Запрос|По базе данных;

  • через кнопку [image] на панели инструментов;

  • нажав правой кнопкой мыши по разделу Базы данных в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Базы или сделав двойной щелчок левой кнопкой мыши на данном разделе.

В дереве диалога содержится список всех слоев текущей карты и список имен баз данных ZuluGIS, подключенных в данный момент к каждому слою. После выбора нужной базы данных на экране откроется окно семантической информации, соответствующее данной базе.

Окно Базы данных

Рисунок 625. Окно Базы данных

Подробнее об окне семантической информации вы можете узнать в разделе «Общие сведения об окне семантической информации»


Общие сведения об окне семантической информации

  • «Дополнительные возможности при работе с окном семантической информации»

Окно семантической информации это окно, в котором отображаются данные из подключенной к слою базе данных. Как его открыть описано ранее.

Окно семантической информации c данными по источнику показано на рисунке ниже:

Окно семантической информации

Рисунок 626. Окно семантической информации

Окно имеет несколько вкладок, которые отображают следующую информацию:

  • Текущая запись - отображает данные текущей записи в виде сводки, содержащей имена полей и их значения. Данные отображаются по активному (мигающему) объекту. Вкладка может использоваться как для отображения так и для внесения новых или изменения существующих данных.

  • Запрос - вкладка для задания условий фильтрации или изменения данных. Запросы позволяют выбирать (фильтровать) информацию по объектам, результаты такого запроса отображаются во вкладках Текущая запись и Ответ. Запросы позволяют выполнять массовое изменение характеристик объектов в базе данных: для всех записей(объектов), для определённой группы объектов или в соответствии с заданными условиями фильтра.

  • База - содержит в табличном виде все записи из базы данных согласно описателю базы данных. Используя данную вкладку так же возможно вносить изменения в базу.

  • Ответ - в данную вкладку помещаются результаты запросов. Используя данную вкладку так же возможно вносить изменения в базу.

Кроме того, при выполнении статистических запросов, появляется закладка Статистика, в которой помещаются результаты таких запросов. Каждая из закладок отвечает за соответствующий режим работы окна, поэтому в разных режимах становятся доступными только соответствующие этому режиму кнопки инструментов.

Назначение кнопок окна семантической информации:

Таблица 4.

Переключает вид текущей записи в браузере на традиционный и сгруппированный (сгруппированный вид будет только в том случае, если заранее группы были созданы). Работает во вкладках Текущая запись и Запрос.
Переместиться в начало набора записей. Работает во вкладке Текущая запись.
Переместиться на предыдущую запись. Работает во вкладке Текущая запись.
Переместиться на следующую запись. Работает во вкладке Текущая запись.
Переместиться в конец набора записей. Работает во вкладке Текущая запись.
Обновить число записей. Работает во вкладках Текущая запись и База.
Обновить окно семантической информации. Работает во вкладках Текущая запись и База.
Показать объекты на карте. Работает во вкладках Текущая запись, База, Ответ. Нажатие на стрелку рядом с кнопкой откроет дополнительное контекстное меню, с помощью которого можно выделить объекты, добавить в группу или удалить из группы.
Очистить все поля. Работает во вкладках Текущая запись и Запрос.
Сохранить текущую запись. Работает во вкладке Текущая запись.
Добавить новую запись. Работает во вкладке Текущая запись.
Удалить выделенную запись. Работает во вкладках Текущая запись, База и Ответ.
Сохранить результаты запроса в отдельной таблице. Работает во вкладках Текущая запись, База и Ответ.
Запустить мастер печати данных. Работает во вкладках Текущая запись, База и Ответ.
Запустить мастер экспорта данных в Microsoft Excel. Работает во вкладках Текущая запись, База и Ответ.
Запустить мастер экспорта данных в HTML. Работает во вкладках Текущая запись, База и Ответ.
Запустить мастер импорта данных из Microsoft Excel. Работает во вкладках Текущая запись и База.
Выполнить запрос. Работает во вкладках Запрос.
Включить (выключить) режим фильтра по группе. Работает во вкладках Запрос.
Найти значение в колонке. Работает во вкладках База, Ответ.
Переключение между дополнительными пользовательскими запросами и формами

Кнопки перемещения по набору записей работают во вкладке Текущая запись. Если был выполнен запрос, то набором записей, по которому осуществляется навигация, является таблица ответа, иначе набором служит запрос по всей базе. При смене текущей записи соответствующий элемент слоя (имеющий идентификатор, совпадающий со значением поля связи с картой) будет отмечаться на карте.


Дополнительные возможности при работе с окном семантической информации

  • Отображение пользовательских и реальных названий полей

  • Переключение форм

  • Сворачивание/разворачивание групп полей

  • Создание группы объектов на основании выделенных в базе записей

  • Выравнивание по названиям полей

  • Сортировка введенных данных

  • Перемещение и изменение размера окна

Отображение пользовательских и реальных названий полей

В некоторых базах данных поля в подключенных таблицах и поля в визуальных запросах отличаются названиями. Чаще в таблицах встречаются названия на латинице, а в запросах для более удобного визуального восприятия на кириллице. Так например, настроены базы данных слоев инженерных сетей. Имеется возможность в окне семантической информации переключать отображение тех или иных названий. Для смены названий сделайте щелчок правой кнопкой мыши в области семантического окна и снимите или установите опцию Реальные названия полей:

Переключение названий полей

Рисунок 627. Переключение названий полей

Переключение форм

Какие поля будут отображены в окне семантической информации, определяется дополнительными пользовательскими запросами и формами. При создании слоя инженерных сетей или векторного слоя одновременно с базой данных в каждой созданной автоматически базе данных будет сформирован запрос (Основной), который по умолчанию отображается как форма. В базах, разработанных самостоятельно формой по умолчанию назначен запрос, созданный пользователем (по умолчанию Запрос1). В том случае, когда требуется выводить не все поля основного запроса имеется возможность создать дополнительные формы и в дальнейшем при работе переключаться между ними.

Для переключения нажмите кнопку [image] и в списке форм выберите нужную.

Окно семантической информации

Рисунок 628. Окно семантической информации

Сворачивание/разворачивание групп полей

Если в базе данных настроена группировка полей, то по умолчанию список полей во вкладке Текущая запись будет выведен в соответствии с ней. Такие группы автоматически формируются при создании инженерных слоев. Но так же они могут быть и самостоятельно разработаны.

Включение и отключение группировки полей производится нажатием кнопки [image] .

Окно семантической информации

Рисунок 629. Окно семантической информации

Создание группы объектов на основании выделенных в базе записей

Для выделения группы объектов на основании выделенных в базе записей:

  1. Выберите вкладку База.

  2. Выделите записи. Выделить можно или группу последовательных записей или каждую запись отдельно. Для выделения отдельной записи щелкните по ней левой клавишей мыши. Для выделения последовательной группы записей укажите с помощью курсора начальную запись, затем нажмите на клавиатуре клавишу Shift и не отпуская укажите последнюю запись.

  3. Сделайте щелчок правой кнопкой мыши и в меню выберите пункт Выделить или Добавить в группу. В пером варианте группа объектов будет создана заново. Во втором варианте если ранее уже были выделены объекты, новые объекты будут добавлены к существующей группе.

    [Примечание] Примечание

    Вы можете создать группу объектов по результатам запроса к семантическим базам данных.

Окно семантической информации

Рисунок 630. Окно семантической информации

Выравнивание по названиям полей

Для более удобного визуального отображения информации вы можете произвести выравнивание по названиям полей. Чтобы выровнять по названиям полей сделайте щелчок правой кнопкой мыши в области семантического окна выберите пункт Выровнять по названиям полей:

Окно семантической информации

Рисунок 631. Окно семантической информации

Сортировка введенных данных

Во вкладках База и Ответ для более удобного просмотра информации есть возможность сортировки записей по возрастанию или убыванию для выбранного поля. Для сортировки щелкните мышкой в заголовке столбца, при этом все данные таблицы сортируются по возрастанию выбранного поля, а в заголовке столбца появляется стрелка вниз, что символизирует о сортировке столбца по возрастанию. Повторное нажатие на заголовок столбца изменяет сортировку на сортировку по убыванию, а стрелка в заголовке столбца будет указывать вверх.

Окно семантической информации

Рисунок 632. Окно семантической информации

Перемещение и изменение размера окна

Для перемещения окна семантической информации подведите курсор к заголовку окна. Нажмите левую клавиши мыши и не отпуская ее переместите окно в нужно место экрана.

Если при открытии окна семантической информации не устраивает его размер, то его можно изменить. Для увеличения/уменьшения ширины окна подведите курсор мыши к боковому краю окна, после появления двунаправленной стрелки удерживая левую кнопку мыши растяните окно семантической информации. Для увеличения размеров окна по высоте проделайте аналогичную операцию, но курсор мыши при этом подводите к верхнему или нижнему краю семантического окна. Для одновременного увеличения окна по ширине и по высоте подводите курсор к любому углу окна. Чтобы развернуть окно на весь экран нажмите кнопку [image] , нажатие кнопки [image] приведет размер окна к исходному.

Окно семантической информации

Рисунок 633. Окно семантической информации

После изменения размера окна семантической информации система запоминает его параметры и положение на карте, и уже при следующем открытии окно будет находиться в том положении, которое было настроено ранее.


Источники данных ZuluGIS

  • «Типы источников данных»

  • «Использование источников данных»

  • «Файл настроек источников данных DataSrc.cfg»

  • «Создание источника данных»

  • «Изменение настроек источника данных»

  • «Удаление источника данных»

  • «Просмотр источника данных таблиц»

Чтобы обеспечить удобный и эффективный доступ к разнообразным источникам семантической информации, особенно при работе с ZuluServer и большим количеством пользователей, можно воспользоваться многопользовательской (клиент-серверной) СУБД. Для этого необходимо создать подключения к СУБД в виде источников данных.

[Примечание] Примечание

Вы можете изменить источник данных используя миграцию данных.

Поддерживаются различные технологии прямого доступа к PostgreSQL, SQLite, SQL Server LocalDB, а также подключения через ADO (OLE DB) и ODBC.

Создание источников данных не является обязательной процедурой, многим пользователям достаточно встроенных возможностей программного обеспечения и использования локальных источников данных, автоматически создаваемых вместе со слоем в базах, хранимых в файлах SQLite (*.sqlite), SQL Server LocalDB (*.mdf), в предыдущих версиях использовались Microsoft Access (*.mdb) и BDE Paradox (*.db). Файлы базы данных создаются в директории со слоем.

Один источник данных и содержащиеся в нем таблицы могут использоваться несколькими слоями. При хранении таблиц в файлах SQLite или SQL Server LocalDB таблицы доступны только в рамках одного слоя, для использования одного файла базы данных несколькими слоями так же создаются источники данных.

[Примечание] Примечание

В рамках одной базы данных ZuluGIS могут использоваться таблицы из одного источника данных.

При использовании собственных источников данных возможно пользоваться встроенными возможностями выбранного СУБД, к примеру такие как расширенный список типов полей таблицы, уникальные свойства полей (такие как поля-счётчики, запрет на пустые значения, автоматически заполняемые и вычисляемые поля), операции массового импорта данных в таблицы (BULK INSERT), инструменты администрирования и настройки баз данных, представления, триггеры и другие возможности.

Информация об источниках данных хранится в конфигурационном файле DataSrc.cfg в папке, где установлена система ZuluGIS или ZuluServer.

По аналогии с источниками данных, с точки зрения создания и функционала, могут создаваться Соединения. Соединения хранятся в фале базы данных ZuluGIS и доступны только в рамках этой базы данных.

Источники данных могут использоваться как однопользовательской версией ZuluGIS, так и на сервере ZuluServer. В случае сервера они должны быть опубликованы в администраторе ZuluServer и доступны пользователями.

[Примечание] Примечание

Подробней об источниках данных ZuluServer.


Типы источников данных

Источники данных могут быть следующих типов:

  • Соединение ADO (OLE DB)

    Источник содержит параметры соединения OLEDB. Это может быть строка соединения, либо путь к файлу связи с данными UDL.

  • Источник ODBC

    Источник содержит параметры соединения ODBC. Источник может ссылается на уже имеющийся источник данных ODBC DSN (пользовательский или системный), задаваться в виде строки соединения, либо содержать путь к файлу связи с данными DSN.

  • Псевдоним BDE

    В текущей версии не используется, оставлен для поддержи предыдущих версий.

  • Локальная папка

    В текущей версии не используется, оставлен для поддержи предыдущих версий.

  • База данных Microsoft Access

    Источник ссылается на базу данных в файле .mdb. Может быть недоступен, если не установлен Microsoft Access Database Engine.

  • База данных SQLite

    Источник ссылается на базу данных в файле .sqlite

  • База данных SQL Server LocalDB

    Источник ссылается на базу данных в файле .mdf.

  • PostgreSQL

    Источник содержит параметры прямого подключения к PostgreSQL.

Рисунок 634. Источники данных


Использование источников данных

Источники данных ZuluGIS и ZuluServer могут быть использованы:

  • при создании слоев;

  • при создании базы данных и добавлении таблиц в базу;

  • при появлении потребности использовать одни и те же таблицы в нескольких слоях;

  • при миграции данных из локальных источников.

Источники данных можно использовать как средства интеграции ZuluGIS/ZuluServer со сторонним программным обеспечением, за счет общей СУБД и реляционных связей.

Рисунок 635. Источники данных


Файл настроек источников данных DataSrc.cfg

  • «Содержание файла»

В конфигурационном файле DataSrc.cfg содержится информация об источниках данных, настройки СУБД и выполнения запросов с оператором ИЗМЕНИТЬ (GANGETO). Хранится файл в папке, где установлена система ZuluGIS или ZuluServer. Представляет из себя текстовый файл в кодировке UTF-8 и может быть открыт обычным текстовым редактором.

Фрагмента файла конфигурации DataSrc.cfg:

# To pass authorization info to DBMS transitively
# dbms-auth-pass: all
local-dbms: sqlite
restrict-changeto: no
localdb: v11
<datasrc>
    name: ODBC_SQL_system
    type: odbc/dsn
    dsn: ODBC_SQL_con
    <access>
        require: valid-user
    </access>
</datasrc>
<datasrc>
    name: ODBC_File_DSN_SQL
    type: odbc/file
    file: C:\ZuluGIS\file_conn\File_DSN.dsn
    login: zu
    pswd: $zs2$mcmUz8WR7rEOtnfcBDh9G.
    bulk-dir: C:\Logs
</datasrc>
<datasrc>
    name: ODBC_SQL_str
    type: odbc/connstr
    connstr: DSN=ODBC_SQL_con;Trusted_Connection=No;APP=ZuluGIS 2021;WSID=DIMA-E;DATABASE=Zulu_test;
    login: zu
    pswd: $zs2$mcmUz8WR7rEOtnfcBDh9G.
</datasrc>
<datasrc>
    name: SQLite_all_layers
    type: sqlite
    path: C:\ZuluGIS\file_conn\all_layers.sqlite
</datasrc>
<datasrc>
    name: Native_PostgreSQL_1
    type: postgresql/connstr
    connstr: host=localhost;port=5432;dbname=zulu
    login: zulu
    pswd: $zs2$1eaUGwCQUX9rISXYUl7CC1
</datasrc>


Содержание файла

Все опции в файле указываются с новой строки. Если строка начинается со знака решетки (#), весь текст, указанный в текущей строке, считается «закомментированным» и опция не применяется.

Передавать учетные сведения на сервер СУБД

Используется в многопользовательском режиме работы ГИС, при использовании ZuluServer. Опция может быть установлена вручную или используя Мастер настройки.

Опция распространяется на все источники данных ZuluServer. Для передачи учетных сведений конкретного источника данных данная опция может быть указана в секции <datasrc>…</datasrc> конкретного источника данных.

dbms-auth-pass: all

Ограничение запросов на изменение

Можно указать вручную возможные значения параметра restrict-changeto:

  • yes или group – ограничивать по группе.

  • no – не ограничивать (работать как прежде).

Настройка, выполненная на компьютере, где установлена программа ZuluGIS действует на слои, открываемые с локальной машины (путь к слою начинается с названия диска).

Настройка, выполненная на компьютере, где установлена программа ZuluServer действует на слои, открываемые с данного ZuluServer (путь к слою начинается с zulu://).

Как определить расположен слой на сервере или на локальной машине можно узнать здесь.

restrict-changeto: group

Используемое СУБД по умолчанию

Можно указать вручную, но обычно задается в настройках ZuluGIS.

local-dbms: sqlite

Версия используемого SQL Server LocalDB по умолчанию

Можно указать вручную, но обычно задается в настройках ZuluGIS.

localdb: v11

Параметры источников данных

Задаётся группа параметров, содержащих настройки источников данных. Секция параметры источника данных ограничена блоками <datasrc> ….. </datasrc> . Можно указать вручную, но обычно задается при формировании источника данных.

Фрагмента задания источника данных:

<datasrc>
name: ODBC_File_DSN_SQL
    type: odbc/file
    file: C:\ZuluGIS\file_conn\File_DSN.dsn
    login: zu
    pswd: $zs2$mcmUz8WR7rEOtnfcBDh9G.
    bulk-dir: C:\Logs
    <access>
        require: anybody
    </access>
</datasrc>

  • Name – наименование источника данных. Произвольный текст.

  • Type – тип источника данных. Может принимать значения odbc/dsn, odbc/file, ado/udl, ado/connstr, postgresql/connstr, sqlite, localdb.

  • Connstr – указывается строка соединения, содержание зависит от выбранного типа источника данных и драйвера поставщика данных.

  • Path – указывается путь файлу dsn или файлу базы данных, в зависимости от выбранного типа источника данных.

  • Dsn - наименование dsn используемого при построении источника данных.

  • Udl- указывается путь файлу Udl

  • Login – логин, для авторизации на СУБД

  • Pswd – пароль для авторизации на СУБД, записывается в зашифрованном виде

  • dbms-auth-pass: on – при авторизации на СУБД использовать учетные сведения пользователя ZuluServer

  • bulk-dir - указывается специальная папка, позволяющая ускорить операции массового импорта (BULK INSERT).

    [Предупреждение] Предупреждение

    В случае если ZuluGIS/ZuluServer и SQL Server установлены на разных компьютерах папка должна быть доступна по указанному пути с обоих компьютеров.

    Используемая учетная запись должна обладать разрешениями, необходимыми для работы с этой папкой на удаленном диске.

  • <access> …. </access> - в секции access записываются сведения о публикации источника данных на ZuluServer и его доступности. Настраивается в администраторе ZuluServer. Если секция отсутствует, значит источник не опубликован или опция require имеет значение – nobody (require: nobody).

    Возможные значения параметра require:

    • require:valid-user - источник опубликован и доступен зарегистрированным пользователям;

    • require:anybody - источник опубликован и доступен всем пользователям;

    • require:users User1 Group1 - источник опубликован и доступен перечисленным пользователям, группам пользователей.


Создание источника данных

  • «Создание источника данных ADO(OLEDB)»

  • «Создание источника данных ODBC»

  • «Создание источника данных PostgreSQL»

  • «Создание источника данных SQLite, SQL Server LocalDB, Microsoft Access»

В ZuluGIS предусмотрена возможность добавления, изменения и удаления источников данных. Эти операции доступны из панели Источники данных, которую можно вызвать несколькими способами:

  1. Выбрав пункт главного меню Таблица/Источники данных....

    ИЛИ

  2. Из редактора баз данных выбрав меню Сервис|Настройки, вкладка Источники данных.

    ИЛИ

  3. Из редактора баз данных при создании/добавлении таблицы выбрав пункт Добавить/удалить источник.

При создании источников данных указывается

  1. Тип подключения. Происходит прямое указание СУБД или тип источника ADO (OLE DB) и ODBC. По мнению большинства пользователей приоритетным будет использование прямого соединения, далее ADO (OLE DB) и на последнем месте ODBC.

  2. Способ соединения. Способ соединения может быть задан строкой соединения, сохранен в файле или выбрано системное название DSN(DSN должен быть предварительно создан в операционной системе).

  3. Параметры авторизации на СУБД.

    Для авторизации в системе СУБД могут используются учётные данные, логин и пароль или учётные данные Windows. Логин и пароль указываются в строке подключения в открытом виде (этот способ не рекомендуется). При авторизации с использованием учётных данных Windows ZuluGIS или ZuluServer должны выполняться от имени учётной записи, имеющей доступ к СУБД.

    Учетные сведения для авторизации на СУБД могут быть прописаны в графе пользователь, при этом не учитываются параметры указные в строке соединения (они могут быть не указаны), логин и пароль прописываются в файле DataSrc.cfg, пароль сохраняется в зашифрованном виде (рекомендуемый способ).

    При работе в многопользовательском режиме, используя ZuluServer, пользователи ZuluGIS при обращении к табличным данным будут авторизовываться на СУБД, указанным выше способами. Все пользователи ZuluGIS под одними учетными сведениями, указанными в настройках источника данных.

    Имеется более гибкий способ настройки, при котором учётные сведения пользователя ZuluServer могут использоваться для авторизации на сервере СУБД. Эта опция полезна в том случае, когда разграничение прав доступа на семантические данные «отданы на откуп» самому серверу СУБД. Передаче подлежат либо логин и пароль пользователя ZuluServer, либо учётные данные пользователя Windows, который осуществляет работу в ZuluGIS. Подробнее о передач учетных сведений на СУБД.

  4. Папка для передачи данных – указывается специальная директория, позволяющая ускорить операции массового импорта (BULK INSERT) и массового экспорта.

Подробнее о каждом типе соединения:

  • «Создание источника данных ADO(OLEDB)»

  • «Создание источника данных ODBC»

  • «Создание источника данных PostgreSQL»

  • «Создание источника данных SQLite, SQL Server LocalDB, Microsoft Access»


Создание источника данных ADO(OLEDB)

ADO (от англ. ActiveX Data Objects — «объекты данных ActiveX») — интерфейс программирования приложений для доступа к данным, разработанный компанией Microsoft (MS Access, MS SQL Server) и основанный на технологии компонентов ActiveX. Используя тип подключения Соединение ADO(OLEDB) можно создавать подключения к таким СУДБ как Microsoft SQL Server, Microsoft Access, Oracle, MySQL, Firebird и другим, поддерживающим данную технологию.

Для некоторых систем управления базами данных (СУБД) при создании источника данных необходимо установить ADO (OLEDB) драйвер, который поддерживается выбранным типом СУБД. При выборе драйвера необходимо отталкиваться от разрядности программ (с версии ZuluGIS 2021 и ZuluServer 2021 пользователям доступны 32-разрядная и 64-разрядные версии программ).

Для добавления источника данных:

  1. В панели Источники данных нажмите кнопку Добавить.

  2. В панели появившейся панели Источник данных в окошке Название источника впишите название нового источника. Используйте те же правила для названия, что и для имен файлов и папок, то есть можно использовать символы латиницы и кириллицы, цифры, пробелы, знаки подчеркивания, но нельзя использовать знаки косой черты, двоеточия, знака вопроса и т.п.

  3. Выберите нужный Тип подключения соединения ADO (OLEDB).

  4. Укажите способ подключения:

    • Либо выберите опцию Использовать строку соединения и задайте строку соединения или воспользуйтесь кнопкой Построить, чтобы вызвать стандартное окно задания связи с поставщиком данными.

      [Примечание] Примечание

      Не рекомендуется указывать логин и пароль в строке соединения в открытом виде, см. пункт 5.

      [Примечание] Примечание

      В данном случае все параметры подключения будут храниться в файле DataSrc.cfg.

    • Либо выберите опцию Использовать файл связи с данными (UDL) и укажите путь к файлу UDL. Воспользуйтесь кнопкой Обзор, чтобы найти и выбрать этот файл на компьютере.

      [Примечание] Примечание

      UDL- это всего лишь способ хранения параметров подключения, таким образом настройки подключения могут храниться либо двух файлах UDL и DataSrc.cfg, либо только DataSrc.cfg.

      [Примечание] Примечание

      Как создать UDL файл.

  5. В группе настроек Пользователь укажите учетные сведения для авторизации на СУБД. При этом не учитываются параметры указные в строке соединения (они могут быть не указаны), логин и пароль прописываются в файле DataSrc.cfg, пароль в зашифрованном виде. При работе в многопользовательском режиме, используя ZuluServer параметры пользователя могут быть переданы для авторизации на сервер СУБД. Передаче подлежат либо логин и пароль пользователя ZuluServer, либо учётные сведения Windows. Подробнее о передача учетных сведений на СУБД.

  6. Укажите Папку для передачи данных – указывается специальная директория, позволяющая ускорить операции массового импорта (BULK INSERT) и массового экспорта.

    Настройки источников данных сохраняются в файл DataSrc.cfg

Примеры источников данных

Пример 1

Подключение к Microsoft SQL Server DIMA-E\SQLEXPRESS19 используя строку соединения, в которой не указан логин и пароль, с указанием логина и пароля в графе пользователь (пароль в зашифрованном виде) и папки для ускорения операции массового импорта (BULK INSERT).

<datasrc>
   name: ADO_SQL_STR
   type: ado/connstr
   connstr: Provider=SQLOLEDB.1;Persist Security Info=True; Initial Catalog=Zulu_test2;Data Source=DIMA-E\SQLEXPRESS19
   login: zu
   pswd: $zs2$mcmUz8WR7rEOtnfcBDh9G.
   bulk-dir: C:\Logs
</datasrc>

Пример 1 подключение к Microsoft SQL Server

Рисунок 636. Пример 1 подключение к Microsoft SQL Server

Пример 2

Подключение к Microsoft SQL Server DIMA-E\SQLEXPRESS19 используя строку соединения, в которой указан логин и пароль, с указанием и папки для ускорения операции массового импорта (BULK INSERT).

<datasrc>
    name: ADO_SQL_UDL_pass
    type: ado/connstr
    connstr: Provider=SQLOLEDB.1;Password=zu;Persist Security Info=True;User ID=zu;Initial Catalog=Zulu_test2;Data Source=DIMA-E\SQLEXPRESS19
    bulk-dir: C:\Logs
</datasrc>

Пример 2 подключение к Microsoft SQL Server

Рисунок 637. Пример 2 подключение к Microsoft SQL Server

Пример 3

Подключение к Microsoft SQL Server DIMA-E\SQLEXPRESS19 используя файл связи UDL, в котором не указан логин и пароль, c указанием логина и пароля в графе пользователь (пароль в зашифрованном виде).

<datasrc>
    name: ADO_SQL_UDL
    type: ado/udl
    udl: C:\ZuluGIS\file_conn\SQL_test2.udl
    login: zu
    pswd: $zs2$mcmUz8WR7rEOtnfcBDh9G.
</datasrc

Пример 3 подключение к Microsoft SQL Server

Рисунок 638. Пример 3 подключение к Microsoft SQL Server

Пример 4

Подключение к Microsoft SQL Server DIMA-E\SQLEXPRESS19 используя строку соединения, в которой указан способ авторизации используя учетные сведения Windows, без указания логина и пароля в графе пользователь. ZuluGIS или ZuluServer должны выполняться от имени учётной записи, имеющей доступ к СУБД.

<datasrc>
    name: ADO_SQL_SSPI
    type: ado/connstr
    connstr: 'Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Inf'\
             'o=False;Initial Catalog=Zulu_test2;Data Source=DIMA-E\\SQLEXPRESS'\
             '19'
</datasrc>

Пример 4 подключение к Microsoft SQL Server

Рисунок 639. Пример 4 подключение к Microsoft SQL Server


Создание источника данных ODBC

ODBC (англ. Open Database Connectivity) — это программный интерфейс доступа к базам данных, разработанный компанией Microsoft на основе спецификаций Call Level Interface (CLI). Создан унифицировать программное взаимодействие с СУБД, сделать его независимым от поставщика СУБД и программно-аппаратной платформы. Используя тип подключения Источник ODBC можно создавать подключения к таким СУДБ как PostgreSQL, Microsoft SQL Server, Microsoft Access, Oracle, MySQL, Firebird и другим, поддерживающим данную технологию.

Для некоторых систем управления базами данных (СУБД) при создании источника данных необходимо установить ODBC драйвер, который поддерживается выбранным типом СУБД. При выборе драйвера необходимо отталкиваться от разрядности программ (с версии ZuluGIS 2021 и ZuluServer 2021 пользователям доступны 32-разрядная и 64-разрядные версии программ).

Для добавления источника данных:

  1. В панели Источники данных нажмите кнопку Добавить.

  2. В появившейся панели Источник данных в окошке Название источника впишите название нового источника. Используйте те же правила для названия, что и для имен файлов и папок, то есть можно использовать символы латиницы и кириллицы, цифры, пробелы, знаки подчеркивания, но нельзя использовать знаки косой черты, двоеточия, знака вопроса и т.п.

  3. Выберите Тип подключения Источник ODBC:

  4. Укажите способ подключения:

    • Либо Использовать имя источника данных выберите из списка или впишите имя источника данных ODBC DSN.

      Источника данных ODBC DSN создается в стандартном диалоге Windows «Администратор источников данных ODBC». Системный DSN (более универсален) доступен всем пользователям компьютера, пользовательский DSN доступен только одному пользователю. Обычно ZuluGIS запутается от пользователя, ZuluServer от системы.

      [Примечание] Примечание

      DSN - это всего лишь способ хранения параметров подключения, таким образом часть настроек подключения будут храниться в реестре операционной системы часть в файле DataSrc.cfg.

    • Либо выберите опцию Использовать строку соединения и задайте строку соединения вручную или воспользуйтесь кнопкой Построить, чтобы вызвать стандартное окно задания связи с данными.

      [Примечание] Примечание

      Не рекомендуется указывать логин и пароль в строке соединения в открытом виде, см п5.

      [Примечание] Примечание

      В данном случае все параметры подключения будут храниться в файле DataSrc.cfg.

    • Либо выберите опцию Использовать файл связи с данными (DSN) и укажите путь к файлу. Воспользуйтесь кнопкой Обзор, чтобы найти и выбрать этот файл на компьютере.

      [Примечание] Примечание

      Как создать DSN файл

      [Примечание] Примечание

      DSN - это всего лишь способ хранения параметров подключения, таким образом настройки подключения могут храниться либо двух файлах DSN и DataSrc.cfg, либо только DataSrc.cfg.

  5. В группе настроек Пользователь укажите учетные сведения для авторизации на СУБД, при этом не учитываются параметры указные в строке соединения, логин и пароль прописываются в файле DataSrc.cfg, пароль в зашифрованном виде.

    При работе в многопользовательском режиме, используя ZuluServer параметры пользователя могут быть переданы для авторизации на сервер СУБД. Передаче подлежат либо логин и пароль пользователя ZuluServer, либо параметры учетных сведений Windows. Подробнее о передача учетных сведений на СУБД.

  6. Укажите Папку для передачи данных – указывается специальная директория, позволяющая ускорить операции массового импорта (BULK INSERT) и массового экспорта.

    Настройки источников данных сохраняются в файл DataSrc.cfg.

Примеры источников данных

Пример 1

Подключение к Microsoft SQL Server DIMA-E\SQLEXPRESS19 используя системный DSN в котором не указан логин и пароль, но указанием логина и пароля в графе пользователь (пароль в зашифрованном виде).

<datasrc>
    name: ODBC_SQL_system
    type: odbc/dsn
    dsn: ODBC_SQL_con
    login: zu
    pswd: $zs2$mcmUz8WR7rEOtnfcBDh9G.
</datasrc>

Пример 1 подключение к Microsoft SQL Server

Рисунок 640. Пример 1 подключение к Microsoft SQL Server

Пример 2

Подключение к Microsoft SQL Server DIMA-E\SQLEXPRESS19 используя файл DSN в котором не указан логин и пароль, но указанием логина и пароля в графе пользователь (пароль в зашифрованном виде).

<datasrc>
    name: ODBC_File_DSN_SQL
    type: odbc/file
    file: C:\ZuluGIS\file_conn\File_DSN.dsn
    login: zu
    pswd: $zs2$mcmUz8WR7rEOtnfcBDh9G.
</datasrc>

Пример 2 подключение к Microsoft SQL Server

Рисунок 641. Пример 2 подключение к Microsoft SQL Server

Пример 3

Подключение к Microsoft SQL Server DIMA-E\SQLEXPRESS19 используя строку соединения, в которой не указан логин и пароль, но с указанием логина и пароля в графе пользователь (пароль в зашифрованном виде).

<datasrc>
    name: ODBC_SQL_str
    type: odbc/connstr
    connstr: DSN=ODBC_SQL_con;Trusted_Connection=No;APP=ZuluGIS 2021;WSID=DIMA-E;DATABASE=Zulu_test;
    login: zu
    pswd: $zs2$mcmUz8WR7rEOtnfcBDh9G.
</datasrc>

Пример 3 подключение к Microsoft SQL Server

Рисунок 642. Пример 3 подключение к Microsoft SQL Server

Пример 4

Подключение к Microsoft SQL Server DIMA-E\SQLEXPRESS19 используя строку соединения, в которой указан логин и пароль.

<datasrc>
    name: ODBC_SQL_str_pass
    type: odbc/connstr
    connstr: DSN=ODBC_SQL_con;UID=zu;PWD=zu;Trusted_Connection=No;APP=ZuluGIS 2021;WSID=DIMA-E;DATABASE=Zulu_test;
</datasrc>

Пример 4 подключение к Microsoft SQL Server

Рисунок 643. Пример 4 подключение к Microsoft SQL Server


Создание источника данных PostgreSQL

С PostgreSQL возможно создать источник данных используя соединение ODBC, требуется установить ODBC драйвер или прямое подключение. Прямое подключение к PostgreSQL не доступно в ZuluGIS 8.0 и более ранних версиях.

Прямое подключение к PostgreSQL рекомендуется использовать при установке ZuluGIS или ZuluServer на Linux-системах.

[Примечание] Примечание

Если при работе требуется использование схем, то создайте их предварительно с помощью инструментов самой СУБД, например pgAdmin.

Для добавления источника данных:

  1. В панели Источники данных нажмите кнопку Добавить.

  2. В панели появившейся панели Источник данных в окошке Название источника впишите название нового источника. Используйте те же правила для названия, что и для имен файлов и папок, то есть можно использовать символы латиницы и кириллицы, цифры, пробелы, знаки подчеркивания, но нельзя использовать знаки косой черты, двоеточия, знака вопроса и т.п.

  3. Выберите Тип подключения соединения PostgreSQL.

  4. Укажите логин и пароль пользователя для подключения к серверу СУБД.

  5. Укажите Параметры подключения:

    • Имя или адрес сервера

    • Порт

    • Наименование Базы данных

    [Примечание] Примечание

    Для выбора базы данных необходимо указать логин и пароль, он указывается в п.4, если п.4 не выполнен логи и пароль потребуется ввести в открывающемся окне.

  6. Вы можете указать имя схемы PostgreSQL, в которой будут хранится таблицы. Для этого установите опцию Использовать схему. Чтобы в одной базе данных не создавалось множество баз для однотипных слоев (например, копий слоев с инженерными сетями), следует использовать разные схемы PostgreSQL. В PostgreSQL схема представляет собой пространство имён, которое можно сравнить с «папкой» для таблиц в рамках одной базы данных. Схемы они не могут быть вложенными.

[Примечание] Примечание

Программное обеспечение ZuluGIS/ZuluServer и PostgreSQL могут быть установлены на разных компьютерах.

При работе в многопользовательском режиме, используя ZuluServer параметры пользователя могут быть переданы для авторизации на сервер СУБД. Передаче подлежат логин и пароль пользователя ZuluServer. Соответствующие логины и пароли должны быть заведены в PostgreSQL.

Пример подключения к PostgreSQL

  • Адрес: 192.168.1.10

  • порт: 5432

  • база данных: zulu

  • логин: zulu, пролью в зашифрованном виде

<datasrc>
    name: Native_PostgreSQL_1
    type: postgresql/connstr
    connstr: host=192.168.1.10;port=5432;dbname=zulu
    <access>
        require: anybody
    </access>
    login: zulu
    pswd: $zs2$1eaUGwCQUX9rISXYUl7CC1
</datasrc>

Пример подключения к PostgreSQL

Рисунок 644. Пример подключения к PostgreSQL


Создание источника данных SQLite, SQL Server LocalDB, Microsoft Access

Большинству пользователей достаточно встроенных возможностей программного обеспечения и использования локальных источников данных, автоматически создаваемых вместе со слоем в базе, которая хранится в директории со слоем в файлах SQLite (*.sqlite), SQL Server LocalDB (*.mdf), в предыдущих версиях использовались Microsoft Access (*.mdb) и BDE Paradox (*.db).

При хранении таблиц в файлах SQLite или SQL Server LocalDB таблицы доступны только в рамках одного слоя, для использования одного файла базы данных несколькими слоями создаются источники данных.

Процесс создания источников данных используя базы данных SQLite, SQL Server LocalDB, Microsoft Access одинаков и заключается в указании места расположения файла базы данных.

Для добавления источника данных:

  1. В панели Источники данных нажмите кнопку Добавить.

  2. В панели появившейся панели Источник данных в окошке Название источника впишите название нового источника. Используйте те же правила для названия, что и для имен файлов и папок, то есть можно использовать символы латиницы и кириллицы, цифры, пробелы, знаки подчеркивания, но нельзя использовать знаки косой черты, двоеточия, знака вопроса и т.п.

  3. Выберите Тип подключения:

    • либо SQL Server LocalDB

    • либо база данных SQLite

    • либо база данных Microsoft Access (не рекомендуется использовать в ZuluGIS 2021).

  4. Укажите файл базы данных:

    • Если файл база данных существует, Воспользуйтесь кнопкой Обзор…, чтобы найти и выбрать этот файл на компьютере.

    • Если необходимо создать новый файл Воспользуйтесь кнопкой Новая…, укажите место сохранение и наименование нового файла базы данных.

Примеры источников данных

Пример 1

Подключение к файлу баз данных SQL Server LocalDB (all_layers.mdf) расположенному в директории C:\ZuluGIS\file_conn\

<datasrc>
    name: SQL_LocalDB_all_layers
    type: localdb
    path: C:\ZuluGIS\file_conn\all_layers.mdf
    <access>
        require: anybody
    </access> </datasrc>

Пример подключения к SQL Server LocalDB

Рисунок 645. Пример подключения к SQL Server LocalDB

Пример 2

Подключение к файлу баз данных SQLite (all_layers.sqlite) расположенному в директории C:\ZuluGIS\file_conn\

<datasrc>
    name: SQL_LocalDB_all_layers
    type: localdb
    path: C:\ZuluGIS\file_conn\all_layers.mdf
    <access>
        require: anybody
    </access> </datasrc>

Пример подключения к SQLite

Рисунок 646. Пример подключения к SQLite


Изменение настроек источника данных

Для изменения:

  1. Откройте панель Источники данных.

  2. Выберите источник из списка и нажмите Изменить.

  3. Измените настройки источника.

  4. Нажмите OK.


Удаление источника данных

Для удаления:

  1. Откройте панель Источники данных.

  2. Выберите источник из списка и нажмите Удалить.

  3. В появившемся окне предупреждения подтвердите выбор кнопкой Да.


Просмотр источника данных таблиц

[Примечание] Примечание

Источник данных возможно изменить с помощью миграции данных.

Для того, чтобы узнать какой источник данных у таблиц:

  1. Откройте редактор баз данных для нужной базы.

  2. По умолчанию при открытии в редакторе слева выбран пункт [image] Таблицы, если он не выбран, выберите его. После чего будет отображен список таблиц загруженной в редактор базы данных. Справа от каждой таблицы указывается её источник данных:

    • SQL Server LocalDB - SQL Server LocalDB;

    • SQLite - База данных SQLite;

    • Microsoft Access - База данных Microsoft Access;

    • Таблицы Paradox - название таблицы.db графа источник пусто;

    • Внешние СУБД базы PostgreSQL или Microsoft SQL Server - наименование источника (Источник данных).

    Источники данных таблиц

    Рисунок 647. Источники данных таблиц


Миграция данных

Мастер миграции – инструмент для переноса табличных данных в различные СУБД, например SQL Server, Oracle и в другие доступные ZuluGIS источники данных.

[Подсказка] Подсказка

Миграция локальных данных позволяет изменить способ хранения таблиц. Как узнать какой источник данных используется таблицами можно узнать здесь.

[Примечание] Примечание

Видео по миграции данных возможно просмотреть пройдя по одной из ссылок: https://youtu.be/wgOOzSjqxFI или https://www.politerm.com/videos/database/migratsiya-dannykh/.

Основные возможности:

  • позволяет перенести сразу данные всех слоёв карты;

  • просмотр данных таблиц при переносе;

  • указание новых имён таблиц, при необходимости;

  • перенос связанных между собой таблиц, с дальнейшем возможностью объединения.

Смотрите также:

  • «Выполнение миграции»

  • «Источники данных ZuluGIS»


Выполнение миграции

  1. Для запуска мастера миграции данных выберите команду главного меню Таблица|Миграция данных.

  2. Откроется окно с выбором слоев для переноса (по умолчанию добавляются все слои активной карты).

    С помощью кнопок Добавить и Убрать можно добавлять и удалять слои из списка.

    Кнопка [image] позволяет вернуться на предыдущий шаг мастера.

    Выбор слоев для переноса данных

    Рисунок 648. Выбор слоев для переноса данных

  3. Выберите источник, куда будет производится перенос данных и нажать кнопку Далее.

    Выбор конечного источника для переноса данных

    Рисунок 649. Выбор конечного источника для переноса данных

  4. Отметьте в открывшемся окне таблицы для переноса.

    Источник – название исходной таблицы. Назначение – результирующая таблицы. С помощью кнопки ... можно указать название и размещение таблицы.

    Выбор слоев для переноса данных

    Рисунок 650. Выбор слоев для переноса данных

    [Предупреждение] Предупреждение

    При наличии таблицы с таким же названием в результирующем источнике данных отобразится предупреждение [image] . В этом случае можно либо указать новое имя конечной таблицы, либо изменить параметры переноса таблицы.

    Кнопка Изменить... открывает Параметры таблицы при переносе:

    • Копировать в новую таблицу – вариант по умолчанию: создается новая таблица, куда переносятся данные;

    • Перезаписать существующую таблицу – при наличии таблицы с таким же названием в результирующем источнике данных, перезаписывает её;

    • Использовать существующую таблицу (не перезаписывать) – использует таблицу, уже существующую в источнике данных.

    Параметры миграции таблицы

    Рисунок 651. Параметры миграции таблицы

  5. После выбора таблиц и настройки параметров переноса нажмите кнопку Далее для начала процесса миграции.

    Статус выполнения операции отобразится на экране.

    Отображение статуса выполнения операции

    Рисунок 652. Отображение статуса выполнения операции


Создание базы данных

Создание базы данных состоит из нескольких этапов:

  1. Создание описателя баз данных.

  2. Создание структуры таблиц. При необходимости имеется возможность настроить источники данных.

  3. При необходимости создание и подключение таблиц – справочников.

  4. Создание запроса. При необходимости установка связей между таблицами.

  5. При необходимости создание форм вывода.

  6. Подключение семантической БД к объектам слоя.

При работе с SQL Server имеет возможность задать дополнительные настойки.

[Примечание] Примечание

Видеоурок по разработке базы данных можно посмотреть пройдя по одной из ссылок: https://youtu.be/WfzxWjkYkjM или https://www.politerm.com/videos/database/sozdanie-bazy-dannykh/.


Создание описателя базы данных

Описатель базы данных (далее будет называться просто - база данных) представляет из себя файл, в котором хранятся сведения об используемых внутри базы данных таблицах, справочниках, запросов, форм и дополнительные настройки базы данных. Атрибутивные данные по объектам внутри описателей базы данных не хранятся, они сохраняются в таблицах, которые включены в состав этой базы.

Файл описателя базы (файл *.d00), данных хранится в директории с остальными всеми файлами слоя. В 8-й и предыдущих версиях программы файл описателя базы имел расширение *.zb).

Описатель баз данных удобней создавать через структуру слоя, для его создания надо:

  1. Откройте структуру слоя, для которого надо создать базу данных.

  2. В диалоговом окне Структура слоя в дереве слева выделите пункт Базы данных.

  3. В открывшейся вкладке справа нажмите кнопку [image] Создать... или сделайте щелчок правой кнопкой мыши на разделе с базами данных и в контекстном меню выберите пункт Создать.

  4. В появившемся окне Новая база данных задайте название для базы и нажмите кнопку ОК.

    Диалоговое окно Новая база данных

    Рисунок 653. Диалоговое окно Новая база данных

  5. Нажмите кнопку [image] Конструктор... или сделайте щелчок правой кнопкой мыши на созданной базе и в контекстном меню выберите пункт Конструктор, после чего на экране появится редактор баз данных. В нем последовательно:

    • создайте таблицы;

    • при необходимости создайте справочники;

    • создайте запрос;

    • при необходимости создайте формы вывода;

    • подключите семантическую базу данных к объектам слоя.

      Диалоговое окно База данных

      Рисунок 654. Диалоговое окно База данных


Редактор баз данных

Создание и редактирование базы данных происходит в редакторе баз данных.

Редактор баз данных может быть открыт для конкретного описателя несколькими способами:

  1. Через структуру слоя, для этого надо сначала открыть структуру нужного слоя (Слой|Структура слоя, слой при этом НЕ должен быть редактируемым).

    В открывшемся диалоговом окне Структура слоя в дереве слева выделить пункт [image] Базы данных.

    Справа выделить нужный описатель и нажать кнопку [image] Конструктор....

  2. В панели рабочее место сделать щелчок правой кнопкой мыши по нужному описателю и выбрать пункт Изменить.

    Панель рабочее место

    Рисунок 655. Панель рабочее место

Окно редактора разделено на две части, слева расположены кнопки. В зависимости от нажатой кнопки справа будут отображаться объекты, относящиеся к выбранной кнопке:

Диалоговое окно База данных

Рисунок 656. Диалоговое окно База данных

Выбирая слева кнопки возможно осуществить следующие операции:

  • Таблицы:

    • «Создание таблицы»;

    • «Добавление таблицы в описатель базы данных»;

    • «Экспертный режим»;

    • «Замена исходной таблицы»;

    • «Просмотр таблицы»;

    • «Изменение структуры таблицы»;

    • «Копирование таблицы»;

    • «Переименование таблицы»;

    • «Импорт таблицы»;

    • «Экспорт таблицы»;

    • «Очистка таблицы»;

    • «Уничтожение таблицы»;

    • «Миграция данных».

  • Справочники:

    • «Создание справочника»;

    • «Изменение справочника»;

    • «Изменение свойств справочника»;

    • «Копирование справочника»;

    • «Экспорт справочника»;

    • «Импорт справочника»;

    • «Переименование справочника»;

    • «Удаление справочника».

  • Запросы:

    • «Создание запроса» («Связь нескольких таблиц в запросе»);

    • «Изменение запроса»;

    • «Импорт запроса»;

    • «Переименование запроса»;

    • «Тестирование запроса»;

    • «Удаление запроса».

  • Формы:

    • «Создание формы»;

    • «Изменение формы»;

    • «Переименование формы»;

    • «Удаление формы»;

    • «Смена формы по умолчанию».

  • Сервис

    • «Дополнительные настройки»


Таблицы

Таблицы являются основным компонентом базы данных. Таблица имеет определённую структуру, которая включает в себя набор полей для хранения информации.

Таблицы могут быть сохранены в различных форматах баз данных, таких как SQLite (файл .sqlite), SQL Server LocalDB (файл .mdf), размещаются они в директории, где хранится слой. Так же могут использоваться пользовательские источники данных, такие как PostgreSQL, Microsoft SQL Server и другие источники ADO(OLE DB) или ODBC.

В 8-й и предыдущих версиях программы таблицы также могли храниться в базах данных Microsoft Access (файл .mdb) и таблицах Paradox или dBase (файл .db).

[Примечание] Примечание

Как посмотреть источник данных у таблиц базы данных можно узнать здесь.

Выбор способа хранения таблиц должен основываться на предпочтениях пользователей. При необходимости можно воспользоваться инструментами для миграции данных и изменить способ хранения таблиц.

Операции с таблицами:

  • «Создание таблицы»;

  • «Добавление таблицы в описатель базы данных»;

  • «Экспертный режим»;

  • «Замена исходной таблицы»;

  • «Просмотр таблицы»;

  • «Изменение структуры таблицы»;

  • «Копирование таблицы»;

  • «Переименование таблицы»;

  • «Импорт таблицы»;

  • «Экспорт таблицы»;

  • «Очистка таблицы»;

  • «Уничтожение таблицы».


Создание таблицы

После создания описателя необходимо создать таблицу(ы) для хранения данных.

Для создания новой таблицы:

  1. В редакторе баз данных слева нажмите кнопку [image] Таблицы.

  2. Затем нажмите кнопку [image] Создать... или сделайте щелчок правой кнопкой мыши в области таблиц и выберите пункт Создать.

  3. В диалоговом окне Сохранить таблицу выберите источник для хранения таблиц, если нужного источника в списке нет, то создайте новый.

  4. В строке Имя таблицы введите имя для создаваемой таблицы.

  5. Нажать кнопку Сохранить. После произведенных действий появится окно Новая таблица, в ней список полей организован в табличной форме, для каждого поля отображается его порядковый номер, название поля, тип поля, длина (для полей строкового типа), а также ключик, помечающий, что поле входит в первичный индекс.

    Всегда при создании таблицы в список полей автоматически добавляется поле «Sys». Это поле нужно для таблиц, которые должны быть связаны непосредственно с объектами слоя. Данное поле индексированное, его так же называют ключевым или уникальным полем, в нем не допускается ввод повторяющихся значений. Уникальность поля указывается стоящим напротив поля ключом [image] . В системе по умолчанию оно используется для связи графической и семантической информации. Если у таблиц, связанных с объектами данное поле удалить, то при попытке изменить таблицу будет выдана ошибка: «не удаётся обновить данные, так как базовая таблица * не проиндексирована».

    Для таблиц, не связанных напрямую с объектами карты это поле можно удалить.

  6. Нажмите кнопку Добавить поле, после чего в таблице появится новое поле. В данном поле в столбце Имя поля введите название.

  7. В столбце Тип из открывающегося списка выберите нужный тип поля.

    Список возможных типов полей зависит от используемой базы данных, а также от выбранного «режима»: обычного или экспертного.

    Наиболее часто используемые типы данных:

    • Строковое - символьный тип данных, имеет диапазон от 0 до 255 символов (используется как правило для наименований).

    • Короткое целое - целочисленный цифровой тип данных, позволяет хранить целые числа диапазоном от -32768 до 32767.

    • Длинное целое - цифровой тип данных, позволяет хранить целые числа диапазоном от -2147483648 до 2147483647.

    • Вещественное - цифровой тип данных, имеет диапазон приблизительно [-1.7x10^-308, -1.7x10^+308] и [+1.7x10^-308, +1.7x10^+308] (используется для тех данных, у которых по мимо целой части может быть еще и дробная).

    • Длинный текст - строковый тип данных. Часто используемый вариант при хранении больших текстовых данных.

    • Логическое - может сохранять следующие значения: true/да или false/нет.

    • BLOB - специальный тип данных, предназначенный для хранения изображений, текстов, аудио, видео и zip архивов;

    • Дата и время - данный тип данных предназначен для хранения даты и времени. Если требуется только дата, то используйте тип Date, он доступен в экспертном режиме.

  8. В столбце Длина для строкового типа при можно исправить максимальное количество символов, по умолчанию оно устанавливается 50.

  9. С помощью кнопки Добавить поле, которая добавляет новое поле в конец списка и кнопки Вставить поле, которая вставляет поле в список полей перед выделенной, наберите остальные необходимые поля таблицы. Если было добавлено лишнее поле, то его можно удалить с помощью кнопки Удалить поле.

  10. Для сохранения таблицы нажмите кнопку Сохранить.

    Диалоговое окно создания таблицы

    Рисунок 657. Диалоговое окно создания таблицы

  11. Для закрытия окна создания таблицы нажмите кнопку Закрыть.


Экспертный режим

В экспертном режиме отображается расширенный список типов полей. Список типов полей зависит от используемой СУБД. В некоторых СУБД, например в SQL Server localDB дополнительно возможно настроить свойства полей.

Экспертный режим SQL Server localDB

Рисунок 658. Экспертный режим SQL Server localDB

Экспертный режим SQL Lite

Рисунок 659. Экспертный режим SQL Lite

Включается/отключается экспертный режим с помощью опции, расположенной внизу окна:

Экспертный режим таблицы SQL Server

Рисунок 660. Экспертный режим таблицы SQL Server


Добавление таблицы в описатель базы данных

Таблицы, созданные через описатель базы данных автоматически добавляются в него, но так же имеется возможность в него добавить другие таблицы. Добавленные таблицы могут будут участвовать в запросах или описываться как справочники. Поля для вывода и связи задаются только на множестве таблиц, указанных в данном списке. Физически файлы таблиц могут располагаться в удобном для пользователя месте (на сервере, на локальной машине в отдельном каталоге, в том же каталоге, что и файлы графической базы данных).

Таблицы, добавленные в базу данных, отображаются в списке таблиц. Для каждой таблицы указывается имя файла таблицы (колонка Таблица) и источник, откуда взята таблица (колонка Источник) при включении табличного режима просмотра (кнопка [image] ), или только имя файла таблица при списочном режиме просмотра (кнопка [image] ).

Для добавления таблицы:

  1. В редакторе баз данных, в разделе Таблицы нажмите кнопку [image] Добавить..., или сделайте щелчок правой кнопкой мыши в области таблиц и выберите пункт Добавить, после чего появится стандартное окно выбора файла.

    Таблица может быть добавлена как источник данных, подробней о настройках источников данных можно узнать в разделе «Источники данных ZuluGIS».

Диалоговое окно База данных. Тип объектов - Таблицы

Рисунок 661. Диалоговое окно База данных. Тип объектов - Таблицы

Чтобы удалить таблицу из списка, выполните следующее:

  1. Выделите в списке нужную таблицу.

  2. Нажмите кнопку [image] .

[Важно] Важно

При удалении таблицы все ссылки на эту таблицу в справочниках и запросах будут потеряны.


Замена исходной таблицы

Чтобы заменить источник таблицы выполните следующее:

  1. Выделите в списке таблиц нужную запись.

  2. Нажмите кнопку [image] Заменить..., или сделайте щелчок правой кнопки мыши на таблице и выберите пункт Заменить, после чего появится панель, вид которой схож с видом панели Выбор таблицы.

  3. В появившейся панели выберите таблицу. Для переключения между локальными таблицами, таблицами, добавленными как источник данных BDE, ODBC и др. выберите слева соответствующий пункт, нажмите кнопку Открыть.


Просмотр таблицы

Для просмотра таблицы базы данных:

  1. В редакторе баз данных нажмите кнопку [image] Таблицы.

  2. Сделайте щелчок правой кнопкой мыши на таблице, которую надо просмотреть, и в контекстном меню выберите пункт Просмотр. После выполнения этих действий появится панель просмотра выбранной таблицы. Если в таблице уже внесены данные, то они отобразятся.

    Панель просмотра таблицы

    Рисунок 662. Панель просмотра таблицы

  3. Для того чтобы закрыть панель просмотра таблицы нажмите кнопку Закрыть.

    При необходимости в данной панели имеется возможность добавить или удалить запись:

    • для добавления новой записи нажмите кнопку [image] , после чего курсор переместится в конец таблицы на добавленную пустую запись (строку);

    • для удаления текущей выделенной записи нажмите кнопку [image] .

Для поиска нужной информации можно нажать кнопку [image] и в появившемся окне ввести данные для поиска. Поиск будет производиться по тому столбцу, на котором в данный момент находится курсор мыши.

Для открытия следующей таблицы нажмите кнопку [image] .

[Примечание] Примечание

Открыть таблицу для просмотра можно так де через главное меню Таблица/Просмотр.

Вводить и редактировать записи таблицы удобней через окно семантической информации.


Изменение структуры таблицы

При реструктуризации таблицы можно добавлять и удалять поля, изменять их названия и типы.

Удобней получить доступ к структуре таблицы двумя способами: в редакторе баз данных из раздела Таблицы и из раздела Запросы.

Для изменения структуры таблицы из раздела Таблицы:

  1. В редакторе баз данных нажмите кнопку [image] Таблицы.

  2. Сделайте щелчок правой кнопкой мыши на таблице, структуру которой надо изменить и в контекстном меню выберите пункт Реструктурировать.

Для изменения структуры таблицы из раздела Запросы:

  1. В редакторе баз данных нажмите кнопку [image] Запросы.

  2. Сделайте двойной щелчок левой кнопкой мыши на запросе, в который входит таблица.

  3. В открывшемся окне Запрос на таблице сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Реструктуризовать.

    Рисунок 663. Реструктурирование таблицы

Не зависимо от способа доступа к структуре на экране появится панель, идентичная панели создания таблицы (см. Рисунок 657, «Диалоговое окно создания таблицы»). Она содержит информацию о полях открытой таблицы. В случае, если тип поля по какой-либо причине не определен из списка доступных типов, в колонке Тип для этого поля будет стоять знак «?». Это потребует задания наиболее подходящего типа из предоставленных в открывающемся списке доступных типов.

Редактирование структуры таблицы осуществляется так же, как и при создании таблицы.

После того, как необходимые изменения внесены, нажмите кнопку Сохранить, для закрытия панели надо нажать кнопку Закрыть.

[Примечание] Примечание

Если в таблице добавлялись или удалялись поля, то после изменения структуры необходимо так же изменить запрос.


Копирование таблицы

Для копирования таблицы:

  1. В редакторе баз данных нажмите кнопку [image] Таблицы.

  2. Сделайте щелчок правой кнопкой мыши в области таблиц. В появившемся контекстном меню выберите пункт Задачи|Копировать таблицу.

  3. В окне выбора файла укажите таблицу, которую надо скопировать, нажмите кнопку Открыть.

  4. В диалоговом окне Копировать таблицу в строке Новая таблица задайте имя файла новой таблицы.

    Диалоговое окно копирования таблицы

    Рисунок 664. Диалоговое окно копирования таблицы

  5. Для завершения операции нажмите кнопку OK.

[Примечание] Примечание

Копирование таблицы так же возможно через главное меню. Для копирования надо выбрать Таблица|Скопировать, указать источник данных таблицы, базу данных и саму копируемую таблицу. Далее задать имя для новой таблицы и нажать кнопку ОК.


Переименование таблицы

Данная функция позволяет переименовать файл таблицы.

Для переименования таблицы:

  1. В редакторе баз данных нажмите кнопку [image] Таблицы.

  2. Сделайте щелчок правой кнопкой мыши на таблице, которую надо переименовать. В контекстном меню выберите пункт Переименовать.

  3. Затем в появившемся диалоговом окне задайте новое имя для таблицы.

    Диалоговое окно переименования таблицы

    Рисунок 665. Диалоговое окно переименования таблицы

  4. Для завершения операции нажмите кнопку OK.

    [Примечание] Примечание

    Диалог переименования таблицы можно вызвать так же сделав щелчок правой кнопкой мыши в области таблиц. Затем надо в появившемся контекстном меню выбрать пункт Задачи|Переименовать таблицу. В окне выбора файла указать таблицу, которую надо переименовать и нажать кнопку Открыть.


Импорт таблицы

Имеется возможность импортировать таблицы из текстовых файлов (.txt, .csv), книг Excel, баз данных SQLite, Microsoft Access, Microsoft SQL Server. Также таблицы можно импортировать из других описателей баз данных Zulu.

  • Импорт из текстовых файлов и книги Excel

  • Импорт таблицы из базы данных (SQLite, MS Access,MS SQL Server)

Для добавления импортированной таблицы в описатель базы данных:

  1. Откройте редактор баз данных.

  2. Нажмите кнопку [image] Таблицы.

  3. Справа в области таблиц сделайте щелчок правой кнопкой мыши и в открывшемся контекстом меню выберите пункт Добавить.

  4. Выберите на диске таблицу для добавления и нажмите кнопку Открыть.


Импорт из текстовых файлов и книги Excel

Система предоставляет сервис по импорту файлов из формата текстовых файлов (*.txt, *.csv) и книги Excel (*.xls). Для импорта информация должна быть записана следующим образом: каждая запись начинается с новой строки, значения полей одной записи отделяются друг от друга, строковые значения заключены в кавычки, первая строка файла может хранить названия полей.

Для импорта текстового файла необходимо:

  1. В диалоговом окне База данных/раздел Таблицы сделать щелчок правой кнопкой мыши и выбрать пункт Импорт или в главном меню Таблица выбрать пункт Импорт таблицы.

  2. В стандартном окне выбора файла справа от строки Имя файла выбрать формат импортируемого файла: Текстовые файлы (*.txt, *.csv) или Книга Excel (*.xls).

  3. Указать файл для импорта.

  4. Система зачитывает информацию и отображает эту информацию в таблице.

    Диалоговое окно Импорт таблицы

    Рисунок 666. Диалоговое окно Импорт таблицы

  5. В открывшемся окне в списке Разделитель полей необходимо выбрать символ, который используется в качестве разделителя полей записи.

  6. Если строковые значения заключены в кавычки, то в списке Ограничитель текста выберите тип кавычек (двойные или одинарные) или установите параметр {отсутствует}.

  7. Если первая строка текстового файла содержит названия полей, то установите флажок Первая строка содержит имена полей.

  8. После задания всех установок нажмите кнопку Далее.

  9. В следующем диалоговом окне в строке Таблица необходимо указать полный путь к файлу таблицы Paradox, задать его имя (используйте кнопку Обзор... для открытия стандартного окна выбора файла) и выбрать дополнительную опцию:

    • создать таблицу с новой структурой;

    • заменить данные в имеющейся таблице;

    • добавить данные в имеющуюся таблицу.

    Для перехода к следующему этапу импорта нажмите кнопку Далее.

  10. В следующем диалоговом окне (Рисунок 667, «Диалоговое окно Импорт таблицы») необходимо задать имена полей, типы полей, а также для строковых полей задать длину поля. Для задания имени поля достаточно щелкнуть мышью в нужной ячейке. Система переходит в режим редактирования текста ячейки (имена полей желательно задавать латинскими буквами).

  11. Для запуска процедуры импорта нажмите кнопку Готово. Если система не сможет импортировать все данные из текстового файла в таблицу, будет выдано соответствующее сообщение.

    Диалоговое окно Импорт таблицы

    Рисунок 667. Диалоговое окно Импорт таблицы


Импорт таблицы из базы данных (SQLite, MS Access,MS SQL Server)

Для импорта существующей таблицы из различных файлов баз данных следует:

  1. В диалоговом окне База данных|Таблицы сделать щелчок правой кнопкой мыши и выбрать пункт Импорт или в меню Таблица выбрать пункт Импорт таблицы.

  2. В стандартном окне выбора файла справа от строки Имя файла выбрать формат импортируемого файла:

    Базы данных SQLite (*.sqlite, *.sqlitedb)

    Базы данных Microsoft Access (*.mdb, *.accdb)

    Базы данных Microsoft SQL Server (*.mdf)

    Импорт таблицы из базы данных

    Рисунок 668. Импорт таблицы из базы данных

  3. Выбрать файл для импорта с помощью двойного клика мышью.

  4. Система считает информацию и откроется диалог Выбор источника для записи таблиц. В этом окне следует указать, куда будут импортироваться данные.

    Выбор источника для записи

    Рисунок 669. Выбор источника для записи

  5. Если в импортируемой базе данных хранится нескольких таблиц, то откроется окно Выбора таблиц.

    Следует отметить необходимые таблицы для импорта или использовать опцию Отметить всё.

    В последнем столбце указывается новое имя таблицы в конечной базе данных.

    Выбор таблиц для импорта

    Рисунок 670. Выбор таблиц для импорта

  6. Нажать кнопку ОК для начала выполнения операции.


Экспорт таблицы

Экспорт таблицы может осуществляться в формат текстовых файлов (*.txt, *.csv), файлов SQL-запросов (*.sql), баз данных SQLite (*.sqlite, *sqlitedb), баз данных Microsoft Access (*.mdb, *.accdb), баз данных Microsoft SQL Server (*.mdf), таблиц Paradox (*.db) и таблиц dBase (*.dbf).

Для экспорта надо:

  1. В редакторе баз данных/раздел Таблицы выделить таблицу для экспорта, затем сделать щелчок правой кнопкой мыши и выбрать пункт Экспорт.

  2. В стандартном окне в списке Тип файла выбрать формат экспорта данных: Текстовые файлы (*.txt, *.csv), Файлы SQL-запросов (*.sql), Базы данных SQLite (*.sqlite, *sqlitedb), Базы данных Microsoft Access (*.mdb, *.accdb), Базы данных Microsoft SQL Server (*.mdf), Таблицы Paradox (*.db), Таблицы dBase (*.dbf).

  3. При экспорте в файлы SQL-запросов и текстовые файлы необходимо будет указать дополнительные параметры:

    • для SQL-запросов: имя таблицы, диалект SQL, указать будут ли включены структуры таблиц, будут ли включены данные и выбрать формат файла, указать кодировку файла;

    • для текстового файла: выбрать разделители полей, ограничители текста, указать содержит ли первая строка имена полей, являются ли они пользовательскими, указать кодировку файла.

  4. Для запуска экспорта нажать кнопку ОК.


Очистка таблицы

Под операцией «очистка таблицы» подразумевается удаление всех записей из таблицы, при этом сама таблица не удаляется, структура так же остается без изменений.

Для очистки таблицы надо:

  1. В редакторе баз данных нажать кнопку [image] Таблицы.

  2. Сделать щелчок правой кнопкой мыши в зоне расположения таблиц. В появившемся контекстном меню выбрать пункт Задачи|Очистить таблицу.

  3. В окне выбора файла указать таблицу, которую надо очистить, нажать кнопку Открыть.

  4. Кнопкой ОК, подтвердить уничтожение всех записей таблицы.


Уничтожение таблицы

В результате данной операции файлы указанной таблицы будут удалены с диска.

Для удаления таблицы надо:

  1. В редакторе баз данных нажать кнопку [image] Таблицы.

  2. Сделать щелчок правой кнопкой мыши в области таблиц. В появившемся контекстном меню выбрать пункт Задачи|Уничтожить таблицу.

  3. В окне выбора файла указать таблицу, которую надо уничтожить, нажать кнопку Открыть.

  4. Для подтверждения удаления таблицы нажмите кнопку OK.


Миграция данных

Миграция таблиц - перенос табличных данных из одной СУБД в другую.

Для миграции данных:

  1. В редакторе баз данных нажмите кнопку [image] Таблицы.

  2. Сделайте щелчок правой кнопкой мыши в зоне расположения таблиц. В появившемся контекстном меню выберите пункт Задачи|Миграция данных.

  3. Выберите источник, куда будет производится перенос данных и нажмите кнопку Далее.

  4. Отметьте в открывшемся окне таблицы для переноса.

    Источник – название исходной таблицы. Назначение – результирующая таблицы. С помощью кнопки ... можно указать название и размещение таблицы.

    [Предупреждение] Предупреждение

    При наличии таблицы с таким же названием в результирующем источнике данных отобразится предупреждение [image] . В этом случае можно либо указать новое имя конечной таблицы, либо изменить параметры переноса таблицы.

    Кнопка Изменить... открывает Параметры таблицы при переносе:

    • Копировать в новую таблицу – вариант по умолчанию: создается новая таблица, куда переносятся данные;

    • Перезаписать существующую таблицу – при наличии таблицы с таким же названием в результирующем источнике данных, перезаписывает её;

    • Использовать существующую таблицу (не перезаписывать) – использует таблицу, уже существующую в источнике данных.

      Параметры миграции таблицы

      Рисунок 671. Параметры миграции таблицы

    После выбора таблиц и настройки параметров переноса нажмите кнопку Далее. Затем Пуск для начала процесса миграции. Статус выполнения операции отобразится на экране.


Справочники

Справочники используются для удобства занесения информации по объектам, они исключают возможность допущения ошибки при вводе.

[Примечание] Примечание

Видео по работе со справочниками можно посмотреть пройдя по одной из ссылок: https://youtu.be/m2WUcGCg4aI или https://www.politerm.com/videos/database/sozdanie-prostogo-spravochnika/.

Существует несколько видов справочников:

  • простой справочник - справочник будет содержать список предопределенных именованных значений;

  • таблица-справочник - справочник будет создан автоматически по таблице;

  • справочник через запрос - множество значений справочника определяются визуальным запросом.

Окно редактора БД. Тип объектов - Справочники

Рисунок 672. Окно редактора БД. Тип объектов - Справочники

Пример подключенного к полю справочника

Рисунок 673. Пример подключенного к полю справочника

Операции со справочниками:

  • «Создание справочника»;

  • «Изменение справочника»;

  • «Изменение свойств справочника»;

  • «Экспорт справочника»;

  • «Импорт справочника»;

  • «Переименование справочника»;

  • «Удаление справочника».


Создание справочника

  • Создание простого справочника

  • Создание таблицы-справочника

  • Создание справочника через запрос


Создание простого справочника

Простой справочник является наиболее легким по способу создания справочником, для его создания:

  1. В диалоговом окне База данных нажмите кнопку [image] Справочники.

  2. Нажмите кнопку [image] Создать....

  3. В диалоговом окне Новый справочник щелчком левой кнопки мыши укажите тип справочника - Простой справочник, нажмите кнопку ОК.

  4. В появившемся на экране диалоговом окне внесите исходные данные справочника. Данные вводятся в два столбца: код – в который вводятся коды значений, и столбец значение, в который соответственно вводится значение.

    Окно создания справочника

    Рисунок 674. Окно создания справочника

  5. При заполнении справочника можно пользоваться кнопками:

    - добавить запись;

    - удалить запись.

  6. Если необходимо чтобы записи справочника выводились в алфавитном порядке, то установите опцию Автоматическая сортировка. Если же значения должны будут выводиться в том порядке, в котором были внесены, то проверьте, чтобы данная опция была снята.

  7. При желании можно задать свойства справочника, их можно открыть с помощью кнопки [image] Параметры.... В строке Название задайте название справочника, в стоке Описание опишите содержимое справочника, нажмите кнопку ОК.

  8. Для завершения процедуры создания справочника нажмите кнопку ОК. Если ранее в свойствах не было задано название справочника, то система потребует его ввести.


Создание таблицы-справочника

При создании таблицы-справочника его данные будут взяты из таблицы. Процесс создания такого справочника состоит из нескольких этапов:

  1. Импортировать таблицу с данными в Zulu.

  2. Добавить импортированную таблицу в редактор базы данных.

  3. Создать и настроить таблицу-справочник.

1 этап - импорт таблицы с данными в ZuluGIS

Имеется возможность импортировать таблицы из текстовых файлов (.txt, .csv), книг Excel, баз данных SQLite, Microsoft Access, Microsoft SQL Server. Также таблицы можно импортировать из других описателей баз данных ZuluGIS.

Таблицу удобней импортировать через редактор базы данных. Подробно о импорте таблиц каждого формата можно узнать в разделе «Импорт таблицы».

2 этап - добавление импортированной таблицы в редактор базы данных

  1. В редакторе баз данных нажать кнопку [image] Таблицы.

  2. Сделать щелчок правой кнопкой мыши в зоне расположения таблиц. В появившемся контекстном меню выбрать пункт Добавить, выбрать импортированную на предыдущем этапе таблицу и нажать кнопку Открыть.

3 этап - создание и настройка таблицы-справочника

  1. В редакторе баз данных нажать кнопку [image] Справочники.

  2. Нажать кнопку [image] Создать....

  3. В диалоговом окне Новый справочник щелчком левой кнопки мыши указать тип справочника - Таблица-справочник, нажать кнопку ОК.

  4. В появившемся окне выбора таблиц указать таблицу, значения которой будут браться для справочника, нажать кнопку Выбрать.

  5. В окне настройки справочника необходимо указать поле связи. Для этого надо нажать кнопку Выбор..., и в открывшемся списке полей таблицы выбрать поле по которому будет осуществлена связь между таблицами, нажать кнопку ОК. Если списка полей не видно, то надо щелкнуть левой кнопкой мыши по «+» рядом с названием таблицы.

  6. Если в импортированной таблице поля задавались латинскими буквами, то лучше задать пользовательские поля полей запроса, их можно задать в столбце Название.

  7. В том случае, когда в таблице больше двух столбцов, то из списка поле-заголовок необходимо выбрать столбец, из которого будут браться данные. Если поле не выбрано, то по умолчанию данные будут взяты из первого по порядку столбца импортируемой таблицы.

    Рисунок 675. Окно Справочник

  8. При желании можно задать дополнительные свойства справочника, их можно открыть с помощью кнопки [image] Параметры.... В стоке Название задается название справочника, в стоке Описание возможно описать опишите содержимое справочника. Для сохранения введенных данных надо нажать кнопку ОК.

  9. Для завершения процедуры создания справочника надо нажать кнопку Сохранить. Если ранее в свойствах не было задано название справочника, то система потребует его ввести. Кнопка Закрыть закроет окно создания справочника.

[Примечание] Примечание

Создание таблицы-справочника по умолчанию производится в упрощенном режиме. Для перехода в экспертный режим надо в окне Справочник в области строк сделать щелчок правой кнопкой мыши и выбрать пункт Экспертный режим. Возврат в упрощенный режим осуществляется аналогичным образом. Экспертный режим рассчитан на более опытных пользователей, именно в нем происходит создание справочника через запрос.


Создание справочника через запрос

Создание справочника через запрос происходит в окне Справочник. Процесс создания справочника аналогичен процессу создания визуального запроса и имеет те же этапы создания, а именно:

  1. Набрать список таблиц, составляющих справочник.

  2. Установить связи между выбранными таблицами.

  3. Набрать поля, составляющие справочник.

  4. Установить свойства полей справочника (пользовательские названия для закладки Текущая запись, названия колонок в закладке База, признак отображения поля в окне семантической информации).

  5. Указать поле связи справочника с таблицей.

  6. Сохранить справочник, задав его пользовательское название.

Чтобы создать справочник через запрос надо:

  1. В редакторе баз данных нажать кнопку [image] Справочники.

  2. Нажать кнопку [image] Создать....

  3. В появившемся окне Новый справочник щелчком левой кнопки мыши указать тип справочника - Справочник через запрос, нажать кнопку ОК.

  4. В окне добавления таблицы левой кнопкой мыши выделите таблицу справочника и нажать кнопку Добавить. Таблица должна быть предварительно создана.

  5. После того, как таблица добавлена в окно справочника надо добавить поля из таблицы в список полей справочника. Для этого надо:

    1. выделить поле в таблице;

    2. щелкнуть два раза левой кнопкой мыши по полю.

    Рисунок 676. Окно Справочник

  6. Если при создании таблицы поля задавались латинскими буквами, то лучше задать пользовательские поля полей запроса, их можно задать в столбце Название или в окне Свойства, которое вызывается нажатием кнопки [image] .

  7. Далее необходимо выбрать поле связи, для этого надо нажать кнопку Выбор, и в открывшемся списке полей таблицы выбрать поле (по умолчанию это поле Sys), затем нажать кнопку ОК. Если списка полей не видно, то надо щелкнуть левой кнопкой мыши по «+» рядом с названием таблицы.

    Окно выбора поля связи

    Рисунок 677. Окно выбора поля связи

  8. В том случае, если в таблице больше одного столбца, то надо указать столбец из которого будут взяты данные для справочника, он выбирается из списка поле-заголовок.

  9. Для сохранения справочника надо нажать кнопку Сохранить.

  10. В появившемся окне введите имя для создаваемого справочника, нажмите кнопку ОК.

  11. С помощью кнопки Закрыть закройте окно создания справочника.


Изменение справочника

Для изменения справочника:

  1. В редакторе баз данных нажмите кнопку [image] Справочники.

  2. В списке выделите нужный справочник.

  3. Нажмите кнопку [image] Изменить... или сделайте двойной щелчок левой кнопкой мыши на названии справочника.

  4. В появившемся окне сделайте необходимые изменения, для подтверждения изменений нажмите кнопку ОК.


Изменение свойств справочника

Для задания/изменения свойств справочника:

  1. В редакторе баз данных нажмите кнопку [image] Справочники.

  2. Выделите нужный справочник в списке.

  3. Щелкните по нему правой кнопкой мыши для открытия контекстного меню.

  4. В открывшемся меню выберите команду Свойства.

  5. В окне свойств задайте необходимые свойства справочника, для подтверждения изменений нажмите кнопку ОК.


Копирование справочника

Для копирования справочника:

  1. В редакторе баз данных нажмите кнопку [image] Справочники.

  2. Выделите в списке справочник для копирования. Сделайте щелчок правой кнопкой мыши, в появившемся контекстном меню выберите пункт Копировать. Справочник скопирован.

[Примечание] Примечание

Вставить скопированный справочник можно как в исходный описатель, так и в любой другой. Для этого надо открыть редактор баз данных с загруженной базой (если он еще не открыт). Нажать кнопку [image] Справочники. В области справочников сделать щелчок правой кнопкой мыши и выбрать пункт Вставить.

При вставке справочника в тот же описатель, откуда он был скопирован ему будет присвоено имя Справочник(x), где ч - порядковый номер справочника. При необходимости справочник можно переименовать.


Экспорт справочника

В настоящей версии системы экспорт возможен только для простого справочника. Экспорт справочника может быть произведен как в таблицу базы данных, так и в файл различных форматов (текстовые файлы *.txt, csv, таблицы Paradox *.db, таблицы dBase *.dbf).

При работе с сервером экспорт в таблицу возможен только на сервер, при локальной версии экспорт в таблицу может осуществляться в любое место.

Для экспорта справочника надо:

  1. В редакторе баз данных выделить простой справочник для экспорта, затем нажать кнопку [image] Изменить... или сделать двойной щелчок левой кнопкой мыши на названии справочника.

  2. В диалоговом окне Справочник выбрать меню Файл|Экспорт|В таблицу или Файл|Экспорт|В файл.

  3. При экспорте в таблицу указать каталог для экспорта и имя для таблицы, если используется серверная версия, то экспорт в таблицу возможен только на сервер.

    При экспорте в файл указать каталог для экспорта, имя для создаваемого файла и из списка Тип файла выбрать нужный тип.

  4. Для подтверждения процедуры экспорта нажать кнопку Сохранить.

  5. При экспорте в текстовый файл необходимо задать дополнительные параметры:

    • выбрать разделитель полей;

    • выбрать ограничитель текста;

    • указать содержит ли первая строка имена полей;

    • выбрать кодировку.

    Формат текстового файла

    Рисунок 678. Формат текстового файла

    Для завершения экспорта надо нажать кнопку ОК.


Импорт справочника

Имеется несколько вариантов для импорта справочника:

  • импорт через редактор баз данных (в локальной версии таким образом могут быть импортированы из уже существующей базы данных как простые справочники так и справочники через запрос);

  • импорт из таблицы (таблица будет преобразована в простой справочник);

  • импорт из файла (импорт может осуществляться из текстовых файлов *.txt, csv, таблиц Paradox *.db и таблиц dBase *.dbf).


Импорт справочника через редактор баз данных

Для импорта справочника через редактор баз данных (данный вариант возможен только при локальной работе):

  1. В редакторе баз данных нажать кнопку [image] Сервис.

  2. В открывшемся списке выбрать пункт Импорт.

  3. Далее указать базу данных, из которой надо импортировать справочник, нажать кнопку Открыть.

  4. Затем установить галочки напротив тех справочников, которые требуется импортировать. Если необходимо импортировать все справочники установите галочку напротив раздела Справочники.

  5. Для подтверждения импорта нажмите кнопку ОК.


Импорт данных справочника из таблицы

Для импорта данных справочника из таблицы надо:

  1. Создать простой справочник, в который будут импортированы данные (кнопка [image] Создать...).

  2. В диалоговом окне Справочник выбрать меню Файл|Импорт|Из таблицы.

  3. В стандартном окне выбора указать таблицу, из которой надо импортировать данные, нажать кнопку Открыть. При работе с серверной версией таблицу можно будет выбрать только на сервере.

  4. Из открывающихся списков выбрать поля соответствия справочника и таблицы:

    • поле кодов;

    • поле значений;

    • поле для сортировки данных.

    Нажать кнопку ОК, после чего появится сообщение о количестве импортированных записей.

  5. Для подтверждения импорта и сохранения справочника нажать кнопку ОК, кнопка Отмена закроет окно Справочник не сохранив импортированные данные.

  6. Ввести имя для справочника, затем нажать кнопку ОК.

    [Примечание] Примечание

    При попытке сохранения импортированного справочника система может выдать ошибку: Запись справочника задана не полностью. Такая ошибка возникает в том случае, если после импорта в справочнике останутся не заполненные поля в столбце Код или Значение. Для сохранения справочника их надо будет заполнить в ручную.


Импорт справочника из файла

Для импорта справочника из файла надо:

  1. Создать простой справочник, в который будут импортированы данные (кнопка [image] Создать...).

  2. В диалоговом окне Справочник выбрать меню Файл|Импорт|Из файла.

  3. В стандартном окне выбора из открывающегося списка, расположенного справа от строки Имя файла выбрать тип импортируемого файла (текстовые файлы *.txt, csv, таблицы Paradox *.db или таблицы dBase *.dbf). Затем указать каталог и имя файла для импорта, нажать кнопку Открыть.

  4. При импорте из текстового файла необходимо выбрать разделитель полей и ограничитель текста, в том случае если среди предложенных нет подходящего, то вписать в соответствующее окно нужный символ.

    Если первая строка содержит имена полей необходимо установить опцию Первая строка содержит имена полей.

    Импорт справочника из текстового файла

    Рисунок 679. Импорт справочника из текстового файла

    При импорте из таблицы Paradox *.db или таблицы dBase *.dbf надо из открывающихся списков выбрать поля соответствия справочника и таблицы: поле кодов, поле значений, поле для сортировки данных.

  5. Нажать кнопку ОК, после чего появится сообщение о количестве импортированных записей.

  6. Для подтверждения импорта и сохранения справочника нажать кнопку ОК, кнопка Отмена закроет окно Справочник не сохранив импортированные данные.

  7. Ввести имя для справочника, затем нажать кнопку ОК.

    [Примечание] Примечание

    При попытке сохранения импортированного справочника система может выдать ошибку: Запись справочника задана не полностью. Такая ошибка возникает в том случае, если после импорта в справочнике останутся не заполненные поля в столбце Код или Значение. Для сохранения справочника их надо будет заполнить в ручную.


Переименование справочника

Для переименования справочника надо:

  1. В редакторе баз данных нажать кнопку [image] Справочники.

  2. Выделить нужный справочник в списке редактора базы данных.

  3. Щелкнуть по нему правой кнопкой мыши для открытия контекстного меню.

  4. В открывшемся меню выбрать команду Переименовать.

  5. В строке редактирования изменить название справочника.


Удаление справочника

Для удаления справочника из списка необходимо:

  1. В редакторе баз данных нажать кнопку [image] Справочники.

  2. Выделить справочник в списке.

  3. Нажать кнопку [image] .

  4. Подтвердить удаление нажатием кнопки Да.

[Важно] Важно

При удалении справочника все ссылки на этот справочник в запросах будут потеряны.


Запросы

Запрос — это компонент базы данных, который включает в себя набор таблиц с их полями и свойствами. Для пользователя он представляется как окно, которое открывается при выборе информации об объекте. Запросы позволяют просматривать, изменять и анализировать данные различными способами.

Визуальный запрос ZuluGIS определяет правила выбора значений из таблицы и связи таблицы с графическими объектами слоя. Для создания запроса необходимо определить таблицы, участвующие в запросе, указать поле связи с картой, выбрать поля, указать пользовательские названия и свойства полей, которые будут отображаться в окне семантической информации.

В запросе может участвовать несколько таблиц, в таком случае необходимо указать связи между полями таблиц.

Они также могут служить источниками записей для форм.

Рисунок 680. Запрос

Операции с запросами:

  • «Создание запроса» (Связь нескольких таблиц в запросе);

  • «Изменение запроса»;

  • «Импорт запроса»;

  • «Переименование запроса»;

  • «Тестирование запроса»;

  • «Удаление запроса».


Создание запроса

Для создания нового запроса надо:

  1. В редакторе баз данных нажать кнопку [image] Запросы.

  2. Нажать кнопку [image] Создать....

  3. В появившемся диалоговом окне Добавить таблицы выделить таблицу, которая будет участвовать в запросе, нажать кнопку Добавить.

    Окно Добавить таблицу

    Рисунок 681. Окно Добавить таблицу

  4. Если для запроса необходимо несколько таблиц, то необходимо повторить пункт 3.

    Добавленные в запрос таблицы отображаются в виде прямоугольников со списком полей таблицы.

  5. Для закрытия окна добавления таблиц нажать кнопку Закрыть.

    [Примечание] Примечание

    • В запросе можно использовать как таблицы, справочники, так и уже существующие запросы.

    • Для повторного вызова диалогового окна Добавить таблицы надо нажать на панели инструментов кнопку [image] .

    • Если таблица в запрос была добавлена ошибочно, то исключить из за проса ее можно с помощью кнопки [image] .

  6. В том случае, если в запросе будут участвовать несколько таблиц провести связи между полями таблиц. Если в запросе участвует только одна таблица, то данный пункт следует пропустить.

    Для установки связей:

    • выделите поле одной таблицы;

    • не отпуская левой кнопки мыши протяните курсор к полю другой таблицы;

    • отпустите кнопку мыши - связь проведена (подробней о связях таблиц можно узнать в разделе Связь нескольких таблиц в запросе).

      [Примечание] Примечание

      Для подчиненной таблицы возможно назначить роль, от которой будет зависеть как поля из таких таблиц будут обрабатываться в браузере.

  7. Выбрать поля, которые будут отображаться в окне семантической информации при выполнении данного запроса.

    Это можно сделать несколькими способами:

    • щелкнуть два раза на поле таблицы, добавленной в запрос - данное поле появится в списке полей запроса

      или

    • выделить поле таблицы, добавленной в запрос и, не отпуская левой кнопки мыши, протянуть курсор вниз, в список полей запроса, отпустить кнопку мыши

      или

    • щелкнуть правой кнопкой мыши в области полей добавленной таблицы, в появившемся контекстном меню выбрать пункт Добавить поле или Добавить все поля. При выборе пункта Добавить поле в список полей запроса будет добавлено поле, выделенное в окне таблицы. При выборе пункта Добавить все поля в список полей запроса будут добавлены все поля, а так же автоматически выберется Поле связи с картой (Sys).

      Диалоговое окно Запрос

      Рисунок 682. Диалоговое окно Запрос

      При необходимости порядок полей запроса можно изменять как с помощью контекстного меню, вызываемого щелчком правой кнопкой мыши в списке полей запроса:

      Рисунок 683. Контекстное меню

      так и при помощи мыши или с помощью следующих кнопок, расположенных на панели инструментов:

      - перемещает поле в самое начало списка;

      - выполняет сдвиг на одно поле вверх;

      - выполняет сдвиг на одно поле вниз;

      - перемещает поле в самый конец списка.

      Так же перемещение полей возможно с помощью мыши, для этого надо:

      1. Выделить левой кнопкой мыши поле, которое надо переместить.

      2. Перевести курсор в столбец с номером поля (№) на перемещаемое поле, нажать левую кнопку мыши.

      3. Не отпуская кнопку начать перемещение поля.

      4. Для прерывания процесса перемещения отпустите левую кнопку мыши.

      Выделив поле в списке и нажав кнопку [image] можно удалить ошибочно добавленное поле.

  8. Вызвать диалоговое окно Свойства для задания пользовательских названий и дополнительных атрибутов полей запроса.

  9. Установите поле связи с картой (если оно еще не установлено), для этого в строке поле связи нажмите кнопку Выбор и в открывшемся списке укажите поле связи с картой (по умолчанию полем связи с картой является Sys). Нажатие кнопки ОК подтвердит выбор и закроет диалог Выбор поля.

    [Примечание] Примечание

    Поле связи не обязательно должно присутствовать в списке полей описателя БД.

  10. После создания запроса его необходимо сохранить - кнопка [image] Сохранить и затем закрыть окно запроса с помощью кнопки Закрыть.


Свойства полей запроса

Настройка свойств для любого поля производится с использования специального диалогового окна.

Возможно сделать следующие настройки поля:

  • задать пользовательское имя

  • запретить редактирование поля

  • задать обязательное для заполнения поле

  • указать справочник для поля

  • изменить стиль поля, цвет, шрифт, начертание

  • задать группировку полей

  • задать дополнительные тэги, используя которые возможно подключать к полям и загружать в поля различные файлы, базу ФИАС, хранить в поле цвет, записывать в поле данные gps

  • настроить всплывающие подсказки для поля (задать описание поля)

Рисунок 684. Пример настройки

Вызвать диалоговое окно Свойства возможно несколькими способами:

  • щелкнув два раза на любом поле в списке полей запроса

    или

  • нажав кнопку [image] (кнопка будет активной только в том случае, если в списке полей запроса выделено хотя бы одно поле)

    или

  • щелкнув правой кнопкой мыши в списке полей запроса, и в появившемся контекстном меню выбрав пункт Свойства.

Окно свойств поля запроса

Рисунок 685. Окно свойств поля запроса

Такие настройки как стиль, группа и тэги могут быть заданы одновременно для нескольких полей. Для групповой настройки полей следует выделить группу полей и нажать кнопку [image] Свойства. Чтобы выделить поле нажмите и не отпускайте клавишу Ctrl и с помощью мыши укажите нужные поля в списке. Если необходимо выделить сразу несколько последовательно идущих поля, то на клавиатуре можно удерживать клавишу Shift, а мышью при этом указать первое и последнее поле.

Окно задания свойств для группы полей запроса

Рисунок 686. Окно задания свойств для группы полей запроса

В открывшемся диалоговом окне Свойства:

  • строка пользовательское имя – в данную строку при необходимости возможно ввести новое значение для поля. Например в том случае, если имя поля ранее было задано латинскими буквами, и именно оно будет отображаться в окне семантической информации;

  • если поле должно быть запрещено к редактированию, то установить опцию нередактируемое;

  • если поле должно быть обязательно для заполнения, то установить опцию обязательное, в окне семантической информации такое поле будет помечено красной точкой и без внесения данных в это поле при сохранении информации будет выдано сообщение о необходимости указания значений поля;

  • если поле должно выбираться из справочника, то надо установить опцию значение поля выбирать из справочника и в открывающемся списке выбрать справочник, справочник при этом должен быть заранее создан;

  • в разделе Стиль возможно установить стиль отображения полей заголовков (названия) и полей значений (значения) в окне семантической информации. Стиль возможно задать одновременно нескольким полям, как выделить группу описано выше;

    [Подсказка] Подсказка

    Стиль поля можно копировать/вставлять (рис. Рисунок 683, «Контекстное меню »). Для этого надо вернуться в редактор запросов (закрыть окно Свойства), выделить поле в списке, нажатием правой мыши, открыть контекстное меню и выбрать пункт Копировать стиль. Затем, для вставки стиля в новое поле выделить его, опять сделать щелчок правой кнопкой мыши и в контекстном меню выбрать пункт Вставить стиль.

    Настройка стиля полей семантической информации

    Рисунок 687. Настройка стиля полей семантической информации

    Рисунок 688. Результат

    или

    Стиль полей семантической информации

    Рисунок 689. Стиль полей семантической информации

  • в строке группа можно задать группы полей, это делается для того, чтобы в браузере баз данных поля были сгруппированы в древовидный список. Для того чтобы заданное поле принадлежало какой-то группе нужно указать имя этой группы в настройках этого поля в редакторе запроса. Для задания подгруппы следует использовать знак «\» (обратная косая черта) или «/» (косая черта). Группа может быть задана одновременно для нескольких полей, как выделить группу полей описано выше;

    Задание названия группы в окне Свойства

    Рисунок 690. Задание названия группы в окне Свойства

    Результат в окне семантической информации

    Рисунок 691. Результат в окне семантической информации

  • в разделе Дополнительно находятся опции, предназначенные для программного расширения функциональных возможностей ZuluGIS:

    имя модели данных - в данной строке можно задать имя поля для модели данных;

    псевдоним колонки ответа - можно ввести название поля, которое будет отображаться в названии столбца закладок База и Ответ окна семантической информации, псевдоним задается только латинскими буквами или цифрами без пробелов и знаков препинания, и начинаться он должен обязательно с буквы;

  • в разделе тэги выбираются нужные тэги. Тэги могут быть заданы одновременно для нескольких полей, как выделить группу полей описано выше;

    [Примечание] Примечание

    Использование тэгов позволяет расширить возможности системы, например можно подключать к полям и загружать в поля различные файлы, подключить базу ФИАС, хранить в поле цвет, записывать в поле данные gps.

    Видео с примером применения тэгов можно посмотреть пройдя по ссылке: https://youtu.be/I4aIjiGwlPc или https://www.politerm.com/videos/database/ispolzovanie-tegov/.

    Выбор тэга осуществляется из соответствующего списка окна Свойства. Определенные тэги могут применяться к определенным типам полей исходной таблицы запроса.

    Рисунок 692. Выбор тэга

    [Примечание] Примечание

    Так как тэгов много и возможно к одному полю применение нескольких тэгов, то что бы не забыть специфические свойства и тэги, назначены полям, им можно создать примечания в виде всплывающих подсказок.

    Список доступных тэгов:

    Таблица 5.

    document gallery
    picture custombrowseobject
    url custombrowsemethod
    text gps
    color mobileeditonly
    fias cameraonly
    audio

    [Примечание] Примечание

    Подробней об использовании тэгов для подключения файлов к базе данных можно узнать в разделе «Подключение файлов к базе данных слоя».

    • тэг document - может быть применен к полю типа Строковое. Позволяет открывать файл, путь к которому будет прописан в поле окна семантической информации. Это может быть фотография, картинка, текстовый файл или например таблица Excel.

      Если подключены документы типа Microsoft Excel, Microsoft Word или например pdf формата, то в случае нажатия на ярлык ( [image] ) с одновременно нажатой клавишей Ctrl, файл будет открыт в программе соответствующей расширению файла и скачан в папку Загрузки. Правый клик по кнопке ( [image] ) ярлыка вызывает контекстное меню, в котором можно выбрать Показать или Скачать подключенный файл.

      Если выделена строка с подключенным файлом, то для скачивания файла в папку Загрузки так же можно сделать щелчок правой кнопкой мыши и выбрать пункт [image] Скачать, данный пункт доступен только для соответствующего поля.

      Путь до подключенного файла может быть как абсолютным, так и относительным. Если задан относительный путь, то он рассчитывается относительно папки указанной в поле Папка для изображений и документов настроек БД если это поле задано, либо относительно папки карты в противном случае.

      Применение тэга document

      Рисунок 693. Применение тэга document

      [Примечание] Примечание

      При работе с подключёнными данными важно правильно организовать работу. Желательно документы располагать не в разных местах на компьютере, а скопировать их в один каталог, который при необходимости может включать в себя подкаталоги. Директория расположения файлов указывается в редакторе баз данных, вкладка Сервис - Папка для изображений и документов.

    • тэг picture может применяться к полям типа BLOB или Строковое, во втором случае данный тэг применяется совместно с тэгом document. Данный тэг указывает программе что файл, путь к которому задается в этом поле, является изображением. Для таких объектов в диалоге редактирования записи отображается уменьшенное его изображение, а двойной щелчок по фото или нажатие кнопки ... справа от фото откроет изображение в специальном окне просмотра. В данном окне возможно загружать файлы, копировать, печатать или открывать окно редактора изображений.

      Применение тэга picture

      Рисунок 694. Применение тэга picture

      [Примечание] Примечание

      Пример применения тэгов для подключения документов можно посмотреть в разделе «Подключение файлов к базе данных».

    • url - может быть применен к полю типа Строковое. В дальнейшем в поле возможно вписать адрес типа ​http://politerm.com/. При нажатии на кнопку справа от введенного адреса [image] в браузере по умолчанию откроется указанный сайт:

      Применение тэга url

      Рисунок 695. Применение тэга url

    • text - может быть применен к полю типа BLOB. Позволяет вносить в поле текст или загружать текстовые файлы (*.txt). Нажатие на кнопку ... справа от поля откроет окно в котором текст возможно отредактировать, сохранить в новый текстовый файл или загрузить файл;

      Использование тэга text

      Рисунок 696. Использование тэга text

    • color - применяя данный тэг имеется возможность в поле хранить цвет, используется для полей типа длинное целое:

      Использование тэга color, вкладка Текущая запись

      Рисунок 697. Использование тэга color, вкладка Текущая запись

      Использование тэга color, вкладка База

      Рисунок 698. Использование тэга color, вкладка База

    • fias - подключает классификатор ФИАС к полю, подробней можно узнать в разделе Подключение ФИАС к полю базы;

    • gallery - позволяет подключать несколько файлов к одному полю, применяется для поля типа BLOB. Справа от тега возможно указать дополнительные опции, если опции не использовать, то файлы будут загружены в базу данных.

      Дополнительные опции к тэгу gallery:

      • files - в поле будут храниться данные, при применении только одной этой опции данные загружаются в базу так же если бы опция не применялась;

        Пример применения тэга gallery с опцией files или без нее

        Рисунок 699. Пример применения тэга gallery с опцией files или без нее

      • links - в поле будут храниться ссылки на данные. При использовании данной опции важно правильно организовать работу. Желательно документы располагать не в разных местах на компьютере, а в одном каталоге, который при необходимости может включать в себя подкаталоги. Директория расположения файлов указывается в редакторе баз данных, вкладка Сервис - Папка для изображений и документов.

        Установка опции links

        Рисунок 700. Установка опции links

        Для загрузки файла по ссылке надо сделать по нему двойной щелчок левой кнопкой мыши или сделать щелчок правой кнопкой мыши и выбрать пункт Открыть.

        Пример применения тэга gallery с опцией links

        Рисунок 701. Пример применения тэга gallery с опцией links

      • комбинация files и links - указываются через пробел или запятую, позволяют использовать сочетание ссылок на файлы и непосредственное добавление файлов в базу (не рекомендуется).

        Установка комбинации опций files и links

        Рисунок 702. Установка комбинации опций files и links

        В том случае, если опции применяются совместно, то при указании файла надо будет выбрать способ загрузки:

        Выбор способа загрузки данных при применении опций lfiles и links

        Рисунок 703. Выбор способа загрузки данных при применении опций lfiles и links

        Пример применения тэга gallery с опциями lfiles и links

        Рисунок 704. Пример применения тэга gallery с опциями lfiles и links

    • custombrowseobject и custombrowsemethod - задают соответственно, com-объект, зарегистрированный в реестре и метод у этого объекта, который будет вызываться (используются программистами). Подробнее смотрите раздел Объекты-обработчики.

    • gps - используется для записи данных gps в поле базы данных. При добавлении объекта в ZuluGIS Mobile, у него будут автоматически заполнятся настроенные поля. Дополнительно справа от тега следует указать необходимый параметр gps для записи:

      • lat.decimal - широта.

      • lon.decimal - долгота.

      • Altitude - высота над уровнем моря.

      • accuracy - точность gps.

      • vertical_accuracy - вертикальная точность gps.

      • time - время.

      Настройка поля для записи GPS тегов

      Рисунок 705. Настройка поля для записи GPS тегов

    • mobileeditonly - тег, который позволяет изменять данные по объектам только из ZuluGIS Mobile, в ZuluGIS это поле редактироваться не будет по аналогии с опцией нередактируемое.

    • cameraonly - применяется для полей, предназначенных для подключения документов. С данным тэгом возможность подключать документы с компьютера или памяти телефона блокируется, остается возможность загружать только фотографии в ZuluGIS Mobile, сделанные камерой мобильного устройства. На стороне сервера поведение тега совпадает с тегом mobileeditjnly, отличия появляются только при обработке в Android приложении.

    • audio - при применении тэга в поле встраивается плеер-рекордер для проигрывания аудио файлов. В текущей версии используется только для ZuluGIS Mobile. Используется только с типом поля BLOB.

      [Примечание] Примечание

      Подробней о работе с аудиополями

    Для перехода к следующему/предыдущему полю запроса нажмите кнопку След. или Пред. окна свойств. Нажатие кнопки ОК подтвердит произведенные изменения и закроет окно Свойства.

  • в разделе Описание (всплывающая подсказка) можно задать комментарий, который в дальнейшем будет появляться при подведении курсора к названию поля в окне семантической информации.

    [Примечание] Примечание

    По умолчанию перенос строк всплывающей раскраски происходит автоматически. Для принудительного переноса строк надо установить курсор в конце строки, после которой должен осуществляться перенос, затем нажать на клавиатуре клавишу Ctrl и не отпуская ее нажать Enter.

    Задание всплывающей подсказки в окне Свойства

    Рисунок 706. Задание всплывающей подсказки в окне Свойства

    Результат в окне семантической информации

    Рисунок 707. Результат в окне семантической информации


Связь нескольких таблиц в запросе

В том случае, если в запросе участвует несколько таблиц, то устанавливают связь между ними. Для установки связи надо:

  1. Щелчком левой кнопки мыши выделить поле одной таблицы.

  2. Удерживая нажатой левую кнопку мыши, протянуть курсор от поля одной таблицы к полю второй таблицы.

  3. Отпустить левую кнопку мыши, после чего между таблицами появится линия связи.

Рисунок 708. Связанные таблицы

Тип установленной связи можно изменить, если щелкнуть дважды по линии связи. При этом открывается окно задания параметров связи. Связь между таблицами может иметь один из трех типов:

  1. Один к одному - объединяет только те записи, в которых связанные поля совпадают.

  2. Много к одному - объединяет все записи из левой таблицы и только те записи из правой таблицы, в которой связанные поля совпадают.

  3. Один ко многим - объединяет все записи из правой таблицы и только те записи из левой таблицы, в которой связанные поля совпадают.

Окно Параметры связи

Рисунок 709. Окно Параметры связи

Выбор необходимого типа связи производится переключателем, для подтверждения установленной связи надо нажать кнопку ОК, кнопка Отмена закроет окно параметров связи без изменений.

Для удаления связи между таблицами щелкните мышкой по связи и нажмите клавишу Del на клавиатуре.


Роль подчиненной таблицы

Для таблиц в визуальном запросе, состоящем из двух или более связанных таблиц, имеется возможность назначить роль, от которой будет зависеть как поля из таких таблиц будут обрабатываться в браузере.

Назначаться могут две роли:

  • Таблица - таблица, имеющая эту роль, обрабатывается как обычная таблица. Данные этой таблицы можно непосредственно редактировать в окне браузера. Базовая таблица, то есть таблица чьё поле указано как поле связи, всегда имеет эту роль. Если подчинённая таблица связана с полем базовой таблицы, совпадающим с полем связи с картой, такая таблица также имеет эту роль.

    Рисунок 710. Роль таблица

    При роли Таблица просмотр заполненных данных для полей типа BLOB возможен по двойному щелчку на этом поле. А при нажатии на кнопку [image] будет открываться меню:

    Работа с полем типа BLOB

    Рисунок 711. Работа с полем типа BLOB

    Выбор пункта Открыть откроет окно для просмотра или внесения данных, выбор поля Выбрать/Изменить откроет окно подчиненной таблицы.

  • Справочник - подчинённая таблица, имеющая эту роль, рассматривается как справочник. У полей из этой таблицы в браузере отображается многоточие, чтобы можно было выбрать нужную запись из справочника. Добавленные в запрос справочники или подзапросы всегда имеют эту роль.

    Рисунок 712. Роль справочник

Для назначения роли подчиненной таблице надо в редакторе запроса сделать щелчок правой кнопкой мыши на подчиненной таблице и в контекстном меню в пункте Роль указать нужную роль - Справочник/Таблица.

Те таблицы, чья роль не уточнена, отображаются серым цветом.

Назначение роли подчиненной таблицы

Рисунок 713. Назначение роли подчиненной таблицы


Изменение запроса

Для изменения запроса:

  1. В редакторе баз данных нажмите кнопку [image] Запросы.

  2. Сделайте двойной щелчок левой кнопкой мыши на нужном запросе

    или

    выделите нужный запрос в списке редактора базы данных и нажмите кнопку [image] Изменить...

    или

    сделайте на запросе щелчок правой кнопкой мыши и в контекстом меню выберите [image] Изменить....

  3. В появившемся окне сделайте необходимые изменения. В запросе возможно поменять порядок полей запроса, кнопки:

    • - перемещает поле в самое начало списка;

    • - выполняет сдвиг на одно поле вверх;

    • - выполняет сдвиг на одно поле вниз;

    • - перемещает поле в самый конец списка.

    Удалить поле из запроса - кнопка [image] .

    Так же в диалоговом окне свойства можно настраивать свойства полей:

    • задать пользовательское имя

    • запретить редактирование поля

    • задать обязательное для заполнения поле

    • указать справочник для поля

    • изменить стиль поля, цвет, шрифт, начертание

    • задать группировку полей

    • задать дополнительные тэги, используя которые возможно подключать к полям и загружать в поля различные файлы, базу ФИАС, хранить в поле цвет, записывать в поле данные gps

    • настроить всплывающие подсказки для поля (задать описание поля)

    [Примечание] Примечание

    В том случае, если слой создавался одновременно с базой данных, редактор запросов откроется в упрощенном режиме, в котором возможности редактирования ограниченны (например нельзя добавлять/удалять поля таблицы). Для перехода в экспертный режим надо в области полей сделать щелчок правой кнопкой мыши и выбрать пункт Экспертный режим.

  4. Для сохранения изменений нажмите кнопку Сохранить и закройте окно Запрос.


Импорт запроса

Для импорта запроса из другого слоя:

  1. В редакторе баз данных нажать кнопку [image] Сервис.

  2. В открывшемся списке выбрать пункт Импорт.

  3. В стандартном окне выбора файла указать слой, из которого надо импортировать запрос, нажать кнопку Открыть.

  4. В диалоговом окне Импорт установить галочки напротив тех запросов, которые требуется импортировать. Если необходимо импортировать все запросы установите галочку напротив раздела Запросы.

  5. Для подтверждения импорта нажмите кнопку ОК.


Переименование запроса

Для переименования запроса надо:

  1. В редакторе баз данных нажать кнопку [image] Запросы.

  2. Выделить нужный запрос в списке редактора базы данных.

  3. Щелкнуть по нему правой кнопкой мыши для открытия контекстного меню.

  4. В открывшемся меню выбрать команду Переименовать.

  5. В строке редактирования изменить название запроса.


Тестирование запроса

Режим тестирования позволяет протестировать созданный запрос и посмотреть полученные результаты. Для входа в режим тестирования надо открыть окно Запрос нажать кнопку [image] Тест и в окне тестирования установить параметры выполняемого запроса.

Рисунок 714. Окно Запрос

В разделе Запрос формируется строка запроса в режиме SQL. Данная строка может быть отредактирована.

Для выборки всех значений из базы нажмите кнопку [image] . В результате в поле Запрос появится строка для выборки всех записей из базы в соответствии с созданным запросом. Для выполнения запроса нажмите кнопку [image] . Чтобы получить одну запись по ключу, в поле ввода необходимо указать ключ объекта, после чего нажать кнопку [image] - поле Запрос будет сформирована строка запроса по заданному условию. Для выполнения запроса нажать кнопку [image] .

Кнопка [image] Браузер открывает окно семантической информации, что позволяет непосредственно в этом окне протестировать созданный запрос.


Удаление запроса

Для удаления запроса:

  1. В редакторе баз данных нажмите кнопку [image] Запросы.

  2. Выделите запрос в списке редактора базы данных.

  3. Нажмите кнопку [image] .

  4. Подтвердите удаление нажатием кнопки Да.


Формы

Очень часто поля одного и того же запроса необходимы для выполнения разных этапов работы. Например, для занесения исходной информации по участку тепловой сети необходимы одни поля таблицы Участок, расчетные значения заносятся в другие поля той же таблицы, при эксплуатации необходим контроль определенного набора полей. Для решения таких проблем и используются формы. На основании уже существующего запроса создается форма, в которой присутствует часть полей основного запроса. Для каждого запроса может быть создано любое необходимое количество форм.

[Примечание] Примечание

Видео по созданию форм можно посмотреть пройдя по одной из ссылок: https://youtu.be/Q-SXPeM6-H8 или https://www.politerm.com/videos/database/nastroyka-spiska-poley-formy/.

Но надо помнить, что в списке форм автоматически создаются формы на основе запросов с теми же названиями, помеченные в списке форм как «стандартная форма для запроса». Такие формы нельзя редактировать, то есть удалять, переименовывать или изменять параметры. Редактирование доступно только для форм, созданных пользователем на основании запроса.

Окно редактора БД. Тип объектов – Формы

Рисунок 715. Окно редактора БД. Тип объектов – Формы

Операции с формами:

  • «Создание формы»;

  • «Изменение формы»;

  • «Переименование формы»;

  • «Удаление формы»;

  • «Смена формы по умолчанию».


Создание формы

Для создания новой формы необходимо:

  1. В редакторе баз данных нажать кнопку [image] Формы.

  2. Нажать кнопку [image] Создать....

  3. В окне Выбор запроса выделить тот запрос, на основании которого создается форма.

  4. Нажать кнопку ОК.

  5. В появившемся диалоговом окне в строке Название формы рекомендуется задать то название, которое будет отражать назначение создаваемой формы.

  6. В списке все поля выделить поле, которое необходимо отобразить в окне семантической информации и нажать кнопку [image] , в результате чего выделенное поле появится в списке поля формы. Добавить сразу все поля запроса в форму можно с помощью кнопки [image] . Кнопка [image] позволяет удаляет выделенное поле из списка полей формы. А с помощью кнопки [image] можно удалить все поля из списка полей формы (при удалении поля, участвующего в одной или нескольких связях, также будет удалены и подобные связи).

    Для одновременного добавления в форму сразу нескольких полей одновременно их предварительно следует выделить. Выделение группы полей, расположенных по порядку делается щелчком сначала по первому полю, потом по последнему, так же при этом на клавиатуре надо удерживать клавишу Shift. Для выделения определенных полей надо сделать на каждом поле щелчок левой кнопкой мыши одновременно удерживая на клавиатуре клавишу Ctrl.

  7. При необходимости повторить действия, описанные в пункте 6 для тех полей, которые нужно отобразить в окне семантической информации.

    Окно выбора полей для формы

    Рисунок 716. Окно выбора полей для формы

  8. Если надо переместить поля формы, то это делается с помощью кнопок:

    - переместить выделенное поле на самый верх;

    - переместить выделенное поле на одно поле вверх;

    - переместить выделенное поле на одно поле вниз;

    - переместить выделенное поле в самый низ.

  9. Для сохранения формы и закрытия окна создания форм нажать на кнопку ОК.

  10. Для того, чтобы созданная форма применялась вместо основного запроса, ее необходимо выбрать из списка Форма по умолчанию.

    Если не будет выбрана форма по умолчанию, то при открытии окна семантической информации будет отображен основной запрос, но на нее можно переключиться.


Изменение формы

Если требуется изменить форму, то доля этого надо:

  1. В редакторе баз данных нажать кнопку [image] Формы.

  2. Выделить форму в списке редактора базы данных.

  3. Нажать кнопку [image] Изменить... или сделать щелчок правой кнопкой мыши на изменяемой форме и выбрать пункт Изменить.

  4. В появившемся окне сделать необходимые изменения.

  5. Для подтверждения изменений нажать кнопку ОК.


Переименование формы

Для переименования формы надо:

  1. В редакторе баз данных нажать кнопку [image] Формы.

  2. Сделать щелчок правой кнопкой мыши на изменяемой форме и выбрать пункт Переименовать.

  3. В строке редактирования изменить название формы.


Удаление формы

Для удаления формы надо:

  1. В редакторе баз данных нажать кнопку [image] Формы.

  2. Выделить форму в списке редактора базы данных.

  3. Нажать кнопку [image] .

  4. Подтвердить удаление нажатием кнопки Да.


Смена формы по умолчанию

Для смены формы по умолчанию надо:

  1. В редакторе баз данных нажать кнопку [image] Формы.

  2. В открывающемся списке Форма по умолчанию выбрать ту форму, поля которой в данный момент необходимо выводить в окне семантической информации.

  3. Сохранить произведенные изменения с помощью кнопки [image] Сохранить.

Если не будет выбрана форма по умолчанию, то при открытии окна семантической информации будет отображен основной запрос, но на нее можно переключиться.


Дополнительные настройки

Дополнительно имеется возможность настроить такие параметры как пароль для СУБД, папку для изображений и сохранение информации о структуре таблиц и индексах. Для перехода на диалог настроек в редакторе баз данных нажмите кнопку [image] Сервис.

При работе с серверной СУБД, пароль и имя пользователя можно прописать внутри базы данных.

Для этого в окне задания настроек установите переключатель на нужную опцию. Установив опцию Использовать следующие имя и пароль и, задав в соответствующих графах значения, можно добиться того, что при открытии окна семантической информации не будет возникать окна по вводу пароля для соединения с базой данных.

Настройка работы с источниками данных

Рисунок 717. Настройка работы с источниками данных

При использовании тэга document желательно указывать папку в которой будут храниться прикрепленные файлы. Это позволит в дальнейшем избежать путаницы в хранимых данных и значительно упростит передачу данных другим лицам в случае необходимости. Базовая папка задается в поле Папка для изображений и документов. При задании относительных путей к таким файлам, полный путь рассчитывается от данной базовой папки. Если базовый путь не указан, относительные пути рассчитываются относительно папки слоя.

[Примечание] Примечание

При работе в многопользовательской версии (ZuluServer) когда слой хранится на сервере путь указывается непосредственно за компьютером сервером. Слой на компьютере сервере для задания папки необходимо открыть как локальный, указав до него полный путь на машине и только тогда задавать папку. Если в конфигурационном файле корневой каталог не указан, то по умолчанию в качестве него принимается подкаталог Data. Важно указать отдельную папку для хранения файлов так как ZuluServer копирует указанные файлы на сервер и соответственно в том случае, если папка не будет указана они будут скопированы в ту же директорию где располагается слой, что может в дальнейшем усложнить работу с данными.

Опция Кэшировать данные схемы — сохраняет информацию о структуре таблиц и индексах, необходимую для выполнения запроса. Сокращает количество обращений к СУБД и ускоряет работу. Кнопка Сброс... служит для очистка кэша данных схемы.


Связь базы данных со слоем и с объектами

Подключение базы данных к слою

Если описатель базы данных создавался через структуру слоя, то он автоматически оказывается уже связанным со слоем, в противном случае его необходимо добавить в список баз слоя. Для добавления базы надо:

  1. Открыть окно Структура слоя – кнопка [image] (слой при этом должен быть не редактируемым).

  2. Слева в дереве выбрать пункт [image] Базы данных.

  3. Справа в открывшейся вкладке нажать кнопку [image] Добавить....

  4. В стандартном окне выбора файла указать необходимую базу и нажать кнопку Открыть.

[Примечание] Примечание

Если база была добавлена ошибочно, то удалить ее из списка можно с помощью кнопки [image] Удалить, при этом с диска база не удалится.


Подключение базы данных к объектам

  • Подключение базы данных к примитивам слоя

  • Подключение базы данных к типовым объектам слоя

После того, как описатель базы данных создан или добавлен в список слоев, необходимо указать какие объекты ее будут использовать.

Базу данных можно подключить к двум видам объектов: к примитивам и к типовым объектам. Примитивы слоя могут использовать только одну общую базу. Каждый же типовой объект может использовать свою базу данных. При выделении элемента слоя с помощью инструмента «Информация» (кнопка [image] ) ZuluGIS произведет запрос к используемой базе данных через созданный описатель. Если выделенный элемент является нетипизированным объектом слоя (примитивом), то будет использоваться общая база данных, а если элемент является объектом некоторого типа, то база данных будет взята из информации о типе объекта. Выполняя запрос к базе данных, ZuluGIS будет использовать идентификатор выбранного элемента как значение ключевого поля, которое выбрано как поле связи с картой при создании описателя базы данных. Результаты запроса будут отображаться в панели окна семантической информации.

Подключение базы данных к примитивам слоя

Для того чтобы указать, какая база данных будет использоваться примитивами слоя надо:

  1. Открыть окно Структура слоя - кнопка [image] (слой при этом должен быть не редактируемым).

  2. Слева в дереве выбрать пункт Примитивы.

  3. В открывающемся списке База данных выбрать необходимую базу данных.

  4. Сохранить произведенные изменения с помощью кнопки [image] Сохранить.

    Подключение базы к примитивам

    Рисунок 718. Подключение базы к примитивам

Подключение базы данных к типовым объектам слоя

Для подключения базы данных к определенному типу объектов слоя надо:

  1. Открыть окно Структура слоя - кнопка [image] (слой при этом должен быть не редактируемым).

  2. Слева в дереве типов и режимов выбрать нужный тип.

  3. Справа в открывшейся вкладке, относящейся к типу, в разделе База данных из открывающегося списка выбрать базу данных.

  4. Сохранить произведенные изменения с помощью кнопки [image] Сохранить.

    Подключение базы к типовому объекту

    Рисунок 719. Подключение базы к типовому объекту

[Примечание] Примечание

При создании слоя типовой тепловой (водопроводной, газовой, паровой) сети через меню Задачи нет необходимости создавать и подключать базы данных для типовых объектов слоя. Создание и подключение баз данных происходит автоматически.


Примеры создания базы данных

Далее будут рассмотрены следующие примеры:

  • «Создание базы данных с одной таблицей»;

  • «Создание базы данных с двумя таблицами, связанными между собой по ключу»;

  • «Создание описателя из двух таблиц, одна из которых является справочником через запрос»;

  • «Создание простого справочника»;

  • «Создание описателя «Адресные точки»»;

  • «Подключение файлов к базе данных»;

  • «Изменение источника данных»;

  • «Пример добавления полей в базу данных».


Создание базы данных с одной таблицей

Ниже рассмотрен пример, в котором к слою Дома будет подключена таблица с информацией об адресе дома, типе строения, его высоте (слой предварительно должен быть создан).

Шаг 1. Создание описателя базы данных

  1. Откройте структуру слоя Дома, для этого выберите пункт меню Слой|Структура слоя или нажмите на панели инструментов кнопку [image] (слой при этом НЕ должен быть редактируемым).

  2. В открывшемся диалоговом окне Структура слоя в дереве слева выделите пункт [image] Базы данных.

  3. В открывшейся вкладке справа нажмите кнопку [image] Создать....

  4. В диалоговом окне Новая база данных задайте название для базы, например База по домам.

    Диалоговое окно Новая база данных

    Рисунок 720. Диалоговое окно Новая база данных

  5. Нажмите кнопку ОК, после чего в окне структуры слоя появится новый пустой описатель с заданным ранее названием.

    Окно структуры слоя

    Рисунок 721. Окно структуры слоя

  6. Наполнение описателя таблицами, справочниками и формами происходит через редактор баз данных, для его вызова выделите созданную базу и нажмите кнопку [image] Конструктор....

Шаг 2. Создание таблицы

В описателе обязательно должна присутствовать хотя бы одна таблица. Для создания таблицы к слою Дома выполните следующие действия:

  1. В редакторе баз данных нажмите кнопку [image] Таблицы.

  2. Далее нажмите кнопку [image] Создать....

  3. В диалоговом окне Сохранить таблицу в строке Имя таблицы ведите имя для создаваемой таблицы, например Address.

  4. Нажмите кнопку Сохранить. После произведенных действий появится окно Новая таблица. Всегда при создании таблицы в список полей автоматически добавляется поле «Sys», которое является уникальным ключевым полем (справа оно помечено ключиком). Данное поле необходимо для связи графической и семантической баз данных, не трогайте его.

  5. Для того чтобы вся требуемая информация по описанию дома могла быть занесена в таблицу, добавьте следующие поля:

    Street – название улицы (тип поля - строковое);

    Num_house – номер дома (тип поля - строковое);

    Type_house – тип дома (тип поля - строковое);

    Height_house – высота дома, кол-во этажей (тип поля - короткое целое).

    Для добавления первого поля нажмите кнопку Добавить поле и в строке ввода в столбце Имя поля введите Street, в столбце Тип в открывающемся списке выберите Строковое, в столбце Длина введите 50 – это будет максимально допустимое количество символов для данного поля.

  6. Повторите пункт 5 для создания остальных полей таблицы, при этом для поля Height_house тип поля выберите – Короткое целое. В итоге получится таблица, представленная на рисунке ниже.

    Диалоговое окно Новая таблица

    Рисунок 722. Диалоговое окно Новая таблица

  7. Для сохранения таблице нажмите кнопку Сохранить, и нажав кнопку ОК подтвердите ранее введенное имя.

Шаг 3. Создание запроса к таблицам семантической базы данных

На данном шаге будет разработано описание запроса. Для создания запроса необходимо определить те таблицы, которые участвуют в запросе, определить поля, выводимые в результате выполнения запроса и определить стиль этих полей.

Для создания запроса выполните следующее:

  1. В редакторе баз данных нажмите кнопку [image] Запросы.

  2. Нажмите кнопку [image] Создать....

  3. В появившемся диалоговом окне Добавить таблицы выделите таблицу Address и нажмите кнопку Добавить.

    Диалоговое окно добавления таблицы

    Рисунок 723. Диалоговое окно добавления таблицы

  4. Закройте это окно кнопкой Закрыть.

  5. Теперь из добавленной таблицы необходимо выбрать поля, которые будут появляться в окне семантической информации при выполнении данного запроса. Добавить сразу все поля можно сделав щечек правой кнопкой мыши на таблице и выбрав пункт Добавить все поля.

    Поштучно добавлять поля можно сделав на каждом двойной щелчок мыши.

    Диалоговое окно создания запроса

    Рисунок 724. Диалоговое окно создания запроса

  6. В случае поштучного добавления полей надо в строке поле связи нажать кнопку Выбор… и в открывшемся списке выбрать поле Sys. Закройте окно выбора поля нажатием кнопки ОК.

    Рисунок 725. Выбор поля

  7. Для удобства работы с окном семантической информации рекомендуется задавать пользовательские названия полей. Для этого в списке полей запроса щелкните два раза на поле Street или выделите поле Street и нажмите кнопку [image] (свойства). В появившемся окне свойств поля в строке пользовательское имя введите: Название улицы. При желании так же можно задать в разделе Стиль цвет и стиль названия поля и значений. Для перехода к окну свойств следующего поля нажмите кнопку След >.

    Рисунок 726. Свойства поля

  8. Точно так же как описано выше задайте пользовательские названия для всех полей запроса.

  9. Закройте окно свойств нажатием кнопки ОК.

    Диалоговое окно Запрос

    Рисунок 727. Диалоговое окно Запрос

  10. Для сохранения запроса нажмите кнопку [image] Сохранить....

  11. Задайте имя запроса - Адреса домов, нажмите кнопку ОК.

  12. Закройте окно создания запроса с помощью кнопки Закрыть.

    В результате проделанных операций в редакторе баз данных появится запрос с названием Адреса домов.

Шаг 4. Сохранение и подключение базы к объектам

  1. Для сохранения базы данных нажмите кнопку [image] Сохранить.

  2. Для закрытия редактора баз данных нажмите кнопку [image] Выход.

  3. В данном примере база данных создавалась для слоя Дома, объекты в этом слое не типизированы, то есть являются примитивами. Примитивы в системе могут использовать только одну базу на всех. Для того, чтобы указать что сознанную базу будут использовать примитивы в окне Структура слоя слева в дереве выберите пункт Примитивы.

  4. В открывшейся вкладке справа из открывающегося списка База данных выберите созданную базу.

    Выбор базы данных

    Рисунок 728. Выбор базы данных

  5. Для сохранения произведенных изменений нажмите кнопку [image] Сохранить.

  6. Для закрытия окна Структура слоя нажмите кнопку [image] Выход.

Шаг 5. Открытие окна семантической информации

Для проверки правильности создания и подключения базы данных надо открыть окно семантической информации:

  1. На панели навигации нажмите кнопку информация [image] .

  2. Сделайте активным слой Дома или нажмите и не отпускайте на клавиатуре клавиши Ctrl и Shift.

  3. Щелкните левой кнопкой мыши по любому объекту слоя. При этом на экране откроется окно семантической информации, готовое для занесения данных.

    Окно семантической информации

    Рисунок 729. Окно семантической информации


Создание базы данных с двумя таблицами, связанными между собой по ключу

Усложним задачу. Изменим созданную в предыдущем примере базу данных таким образом, чтобы, список всех названий улиц города существовал в отдельной таблице. Каждая запись в таблице имеет свой уникальный код. Тогда в таблице адресов вместо поля Название улицы будет поле Код улицы. Таблицы будут связаны между собой по полю Код улицы. При выполнении запроса к семантической базе данных будет происходить выборка значений из таблицы address, название улицы будет выбираться из таблицы street.

Шаг 1. Открытие описателя базы данных

  1. Откройте структуру слоя Дома, для этого выберите пункт меню Слой|Структура слоя или нажмите на панели инструментов кнопку [image] (слой при этом НЕ должен быть редактируемым).

  2. В открывшемся диалоговом окне Структура слоя в дереве слева выделите пункт Базы данных.

  3. Справа в открывшейся вкладке выделите созданную ранее базу База по домам, нажмите кнопку [image] Конструктор....

Шаг 2. Создание таблицы Список улиц

Создайте таблицу со списком улиц и указанными ниже полями аналогично примеру Создание базы данных с одной таблицей, шаг 2. Назовите эту таблицу street. Так как данная таблица не будет напрямую связана с объектами карты, то в ней поле Sys - поле связи с картой не нужно, поэтому просто выделите его и удалите с помощью кнопки Удалить поле.

Таблица должна иметь следующие поля:

  • Cod_street – код улицы (тип поля короткое целое);

  • Name_street – название улицы (тип поля строковое).

Поле Cod_street сделайте ключевым, для этого сделайте щелчок левой кнопки мыши в столбце Ключ.

В результате проделанных операций у вас должна получиться таблица, идентичная представленной на рисунке ниже.

Рисунок 730. Создание таблицы

Шаг 3. Изменение таблицы Адреса

Для изменения таблицы выполните следующие действия:

  1. В редакторе баз данных выделите таблицу address.DB.

  2. Сделайте щелчок правой кнопкой мыши и в появившемся контекстном меню выберите команду Реструктурировать.

  3. В окне редактирования таблицы нажмите кнопку Добавить поле и в свободной строке введите имя поля Cod_street, тип выберите короткое целое.

  4. Сохраните таблицу с тем же именем (кнопка Сохранить).

  5. Закройте окно с помощью кнопки Закрыть.

Шаг 4. Создание запроса к семантической БД

  1. В редакторе баз данных нажмите кнопку [image] Запросы.

  2. Нажмите кнопку [image] Создать....

  3. В появившемся диалоговом окне Добавить таблицы выделите таблицу address, нажмите кнопку Добавить, а затем таблицу street и снова нажмите кнопку Добавить.

  4. Закройте это окно кнопкой Закрыть.

  5. Проведите связь между полем Cod_street таблицы Address и Cod_Street таблицы Street. Для этого щелкните мышью на названии поля Cod_street таблицы Address и, удерживая нажатой левую кнопку мыши, протяните связь к полю Cod_Street таблицы Street (тип установленной связи — один к одному).

  6. Добавьте в список полей запроса следующие поля (для добавления поля сделайте по нему двойной щелчок левой кнопкой мыши):

    Из таблицы Street:

    • Name_street.

    Из таблицы Address:

    • Num_house;

    • Type_house;

    • Hight_house.

  7. Задайте пользовательские названия полей запроса. Для этого выделите поле в списке полей запроса и нажмите кнопку [image] (свойства). В открывшемся диалоговом окне в строке пользовательское имя введите пользовательское название полей такие, как указано на рисунке ниже. Нажмите кнопку ОК.

  8. Выберите поле связи с картой, для этого в строке поле связи нажмите кнопку Выбор… и в открывшемся списке выделите поле Sys из таблицы аddress и нажмите кнопку ОК.

    Рисунок 731. Создание запроса

  9. Для сохранения запроса нажмите кнопку [image] Сохранить....

  10. Задайте имя запроса, например Две таблицы, нажмите кнопку ОК.

  11. Закройте окно создания запроса с помощью кнопки Закрыть.

Шаг 5. Выбор основного запроса

Теперь описатель хранит два визуальных запроса. Необходимо определить, какой запрос будет открываться при выборе окна семантической информации. Для этого:

  1. В окне редактора баз данных для объектов типа Запрос в строке Основной запрос выберите из ниспадающего списка нужный запрос (Две таблицы).

    Выбор основного запроса

    Рисунок 732. Выбор основного запроса

  2. Сохраните описатель – кнопка [image] Сохранить и закройте окно редактора баз данных.

Шаг 6. Открытие окна семантической информации

Для проверки правильности создания и подключения базы данных надо открыть окно семантической информации:

  1. На панели навигации нажмите кнопку информация [image] .

  2. Сделайте активным слой Дома или нажмите и не отпускайте на клавиатуре клавиши Ctrl и Shift.

  3. Щелкните левой кнопкой мыши по любому объекту слоя. При этом на экране откроется окно семантической информации, готовое для занесения данных.

    Окно семантической информации

    Рисунок 733. Окно семантической информации

    В строке Название улицы кнопка [image] открывает окно подчиненной таблицы.

    Окно подчиненной таблицы

    Рисунок 734. Окно подчиненной таблицы


Создание описателя из двух таблиц, одна из которых является справочником через запрос

Таблица street.db – это справочник улиц города. При создании описателя такие таблицы можно описывать как отдельный тип объектов – Справочники. Выделение отдельных таблиц или группы таблиц, связанных между собой в качестве справочников позволяет упростить процедуру создания запроса, что будет показано ниже.

Шаг 1. Открытие описателя базы данных

  1. Откройте структуру слоя Дома, для этого выберите пункт меню Слой|Структура слоя или нажмите на панели инструментов кнопку [image] (слой при этом НЕ должен быть редактируемым).

  2. В открывшемся диалоговом окне Структура слоя в дереве слева выделите пункт Базы данных.

  3. Справа в открывшейся вкладке выделите созданную ранее базу База по домам, нажмите кнопку [image] Конструктор....

Шаг 2. Изменение структуры таблицы

  1. В редакторе баз данных выделите таблицу street.db.

  2. Сделайте щелчок правой кнопкой мыши и в открывшемся контекстом меню выберите пункт Реструктурировать.

  3. Нажмите кнопку Добавить поле и в свободной строке введите имя поле L_street, установите для него тип - Короткое целое.

  4. Для сохранения таблицы нажмите кнопку Сохранить.

  5. Закройте окно изменения таблицы – кнопка Закрыть.

Шаг 3. Создание объекта - справочника (через запрос)

  1. В редакторе баз данных нажмите кнопку [image] Справочники.

  2. Нажмите кнопку [image] Создать....

  3. В окне Новый справочник укажите тип справочника – Справочник через запрос, нажмите кнопку ОК.

  4. Добавьте в справочник таблицу street, для этого выделите ее и нажмите кнопку Добавить. Закройте окно добавления таблиц.

  5. Добавьте в список полей справочника поля Name_street и L_street.

  6. Задайте пользовательские поля для полей справочника Название улицы и Длина улицы соответственно.

  7. В строке поле связи нажмите кнопку Выбор и укажите поле — Cod_Street.

    Рисунок 735. Справочник

  8. Сохраните справочник под именем Улицы.

  9. Закройте окно создания справочника.

Шаг 4. Создание запроса с использованием таблицы - справочника

  1. В редакторе баз данных нажмите кнопку [image] Запросы.

  2. Нажмите кнопку [image] Создать....

  3. В появившемся диалоговом окне Добавить таблицы выделите таблицу address, нажмите кнопку Добавить.

  4. Закройте это окно кнопкой Закрыть.

  5. Добавьте в список полей запроса все поля, кроме поля Street выбранной таблицы.

  6. Дайте полям пользовательские названия.

  7. C помощью стрелок или мыши переместите поле Cod_street в самый верх списка полей запроса.

  8. Укажите поле связи – Sys.

  9. В списке полей запроса выделите поле Cod_street и нажмите кнопку [image] (свойства). В открывшемся окне свойств установите флажок значение поля выбирать из справочника и в открывающемся списке выберите справочник – Улицы. Нажмите кнопку ОК.

    Диалоговое окно Свойства

    Рисунок 736. Диалоговое окно Свойства

  10. Для сохранения запроса нажмите кнопку [image] Сохранить....

  11. Укажите имя запроса, например - Адреса со справочником, нажмите кнопку ОК.

Шаг 5. Выбор основного запроса

Далее необходимо определить, какой запрос будет открываться при выборе окна семантической информации. Для этого:

  1. В окне описателя для объектов типа Запрос в строке Основной запрос выберите из ниспадающего списка запрос Адреса со справочником.

  2. Сохраните описатель – кнопка [image] Сохранить и закройте окно редактора баз данных.

Шаг 6. Открытие окна семантической информации

Для проверки правильности создания и подключения базы данных откройте окно семантической информации, для его открытия:

  1. На панели навигации нажмите кнопку информация [image] .

  2. Сделайте активным слой Дома.

  3. Щелкните левой кнопкой мыши по любому объекту слоя. При этом на экране откроется окно семантической информации, готовое для занесения данных. В строке Название улицы кнопка [image] открывает окно список выбора значений из справочника.

    Окно семантической информации

    Рисунок 737. Окно семантической информации


Создание простого справочника

Создадим простой справочник, содержащий список типов дома. Подключим данный справочник к таблице address к полю Тип дома.

Шаг 1. Открытие описателя базы данных

  1. Откройте структуру слоя Дома, для этого выберите пункт меню Слой|Структура слоя или нажмите на панели инструментов кнопку [image] (слой при этом НЕ должен быть редактируемым).

  2. В открывшемся диалоговом окне Структура слоя в дереве слева выделите пункт Базы данных.

  3. Справа в открывшейся вкладке выделите созданную ранее базу База по домам, нажмите кнопку [image] Конструктор....

Шаг 2. Создание простого справочника

  1. В редакторе баз данных нажмите кнопку [image] Справочники.

  2. Нажмите кнопку [image] Создать....

  3. В окне Новый справочник укажите тип справочника – Простой справочник, нажмите кнопку ОК.

  4. Заполните таблицу справочника таким образом, как указано на рисунке ниже.

    Диалоговое окно создания простого справочника

    Рисунок 738. Диалоговое окно создания простого справочника

  5. Нажмите кнопку ОК.

  6. Назовите справочник Тип дома.

Шаг 3. Подключение справочника к таблице

  1. В редакторе баз данных нажмите кнопку [image] Запросы.

  1. Выделите запрос Адреса домов, нажмите кнопку [image] Изменить....

  2. В открывшемся окне создания запроса в списке полей запроса выделите поле Type_house (Тип дома), нажмите кнопку [image] .

  3. В окне свойств установите флажок значение поля выбирать из справочника и в открывающемся списке выберите справочник – Тип дома. Нажмите кнопку ОК.

  4. Сохраните запрос, кнопкой [image] Сохранить..., закройте окно запроса.

Шаг 4. Выбор основного запроса

Далее необходимо определить, какой запрос будет открываться при выборе окна семантической информации. Для этого:

  1. В окне описателя для объектов типа Запрос в строке Основной запрос выберите из ниспадающего списка запрос Адреса домов.

  2. Сохраните описатель – кнопка [image] Сохранить и закройте окно редактора баз данных.

Шаг 5. Открытие окна семантической информации

Для проверки правильности создания и подключения базы данных откройте окно семантической информации, для его открытия:

  1. На панели навигации нажмите кнопку информация [image] .

  2. Сделайте активным слой Дома.

  3. Щелкните левой кнопкой мыши по любому объекту слоя. При этом на экране откроется окно семантической информации, готовое для занесения данных. В строке Тип дома кнопка [image] открывает окно список выбора значений из справочника.

    Окно семантической информации

    Рисунок 739. Окно семантической информации


Создание описателя «Адресные точки»

Рассмотрим пример базы данных, связывающей объекты слоя Дома с семантической информацией – адресом здания. Допустим, что адрес дома задается названием улицы или проспекта, типом («улица», «проспект», «набережная» и т.д.) и номером дома. Базовой таблицей для задания адреса будет таблица address.db, связывающая идентификаторы элементов слоя (поле Sys) с кодом адреса и номером дома. Таблица addrcode.db будет связывать код адреса с парой идентификаторов названия улицы и типа, соответственно названия («Невский», «Гороховая», «Сенная» и т.д.) будут храниться в таблице street.db, а типы («проспект», «улица», «площадь» и т.д.) — в таблице strtype.db. Нам же нужно получить для запрашиваемого элемента слоя информацию в виде названия, типа и номера дома.

Шаг 1. Открытие описателя базы данных

  1. Откройте структуру слоя Дома, для этого выберите пункт меню Слой|Структура слоя или нажмите на панели инструментов кнопку [image] (слой при этом НЕ должен быть редактируемым).

  2. В открывшемся диалоговом окне Структура слоя в дереве слева выделите пункт Базы данных.

  3. Справа в открывшейся вкладке выделите созданную ранее базу База по домам, нажмите кнопку [image] Конструктор....

Шаг 2. Редактирование таблицы Address.db

  1. В редакторе баз данных выделите таблицу address.

  2. Сделайте щелчок правой кнопкой мыши и в открывшемся контекстом меню выберите пункт Реструктурировать.

  3. Нажмите кнопку Добавить поле и в свободной строке введите имя поле Addr_code, установите для него тип - Короткое целое.

  4. Точно так же как в пункте 3 добавьте поле Bld_no, тип поля установите так же короткое целое.

  5. Для сохранения таблицы нажмите кнопку Сохранить.

  6. Закройте окно изменения таблицы – кнопка Закрыть.

Шаг 3. Создание таблиц addrcode.db и strtype.db

  1. Нажмите кнопку [image] Создать....

  2. Задайте имя таблицы addrcode, нажмите Сохранить.

  3. Поле Sys в данной таблице не нужно, удалите его.

  4. Добавьте поля.

    • Addr_code – тип короткое целое;

    • Street_code – тип короткое целое;

    • Type_code – тип короткое целое.

  5. Сохраните таблицу, закройте окно.

  6. Точно таким же образом создайте и сохраните таблицу strtype с полями.

    • Street_type – тип короткое целое;

    • Name – тип строковое.

Шаг 4. Создание запроса

  1. В редакторе баз данных нажмите кнопку [image] Запросы.

  2. Нажмите кнопку [image] Создать....

  3. Добавьте в запрос таблицы address, addrcode, street и strtype.

  4. Проведите связь между полями таблиц.

    • Address.AddrCode->AddrCode.Addr_Code;

    • AddrCode.Street_Code->Street.Code_Street;

    • AddrCode.Type_Code->StrType.Street_Type.

  5. Из выбранных таблиц наберите список полей, участвующих в запросе (из таблицы Street - поле Name_street, из таблицы Strtype - поле Name, из таблицы Addres - поле Bld_No).

  6. Задайте пользовательские названия полей запроса.

  7. Выберите поле связи с картой, (для рассматриваемого примера - поле Sys из таблицы Address).

  8. Для сохранения запроса нажмите кнопку [image] Сохранить....

  9. Задайте имя запроса, например Адресные точки, закройте окно создания запроса.

Диалоговое окно Запрос

Рисунок 740. Диалоговое окно Запрос

Шаг 5. Выбор основного запроса

  1. В окне описателя для объектов типа Запрос в строке Основной запрос выберите из ниспадающего списка запрос Адресные точки.

  2. Сохраните описатель – кнопка [image] Сохранить и закройте окно редактора баз данных.


Подключение файлов к базе данных

ZuluGIS имеет возможность к полям базы данных подключать какие либо файлы, это может быть паспорт объекта, схема или например фотография. База может быть настроена таким образом, что подключаться к полю может как один файл, так и несколько одновременно. Имеется несколько вариантов подключения, основное отличие их состоит в том, будут ли подключенные файлы храниться в самой базе, или на них будет только дана ссылка. Каждый вариант имеет свои преимущества и недостатки.

В рассмотренном далее примере используется таблица address, в которую будут добавлены поля следующие поля для подключения документов:

  • паспорт - к данному полю файлы будут подключаться через особенный тип поля BLOB без дополнительных тэгов, в этом случае файл будет храниться в самой базе;

  • фотография - к данному полю подключение будет происходить с использованием тэгов, в этом случае будет указана только ссылка на файл;

  • галерея - к данному полю возможно будет подключать одновременно несколько файлов, при этом тип поля будет устанавливаться так же как в поле паспорт - BLOB, но так же будут использован тэг и дополнительные опции к нему, в этом случае часть файлов будет сохранена в базе данных а на часть будет даваться ссылка.

Шаг 1. Настройка папки для документов

При хранении в базе ссылок на файлы предварительно необходимо настроить папку для хранения документов. ZuluGIS Mobile, ZuluGIS Online и ZuluServer файлы на которые дается ссылка в базе автоматически копируют в указанную папку. Если папку не указать, то файлы будут скопированы в ту же папку где расположен слой.

  1. В редакторе баз данных нажмите кнопку [image] Сервис.

  2. Справа от строки Папка для изображений и документов нажмите кнопку Обзор... и укажите папку.

    При работе в многопользовательской версии (ZuluServer) когда слой хранится на сервере путь указывается непосредственно за компьютером сервером. Слой на компьютере сервере для задания папки необходимо открыть как локальный, указав до него полный путь на машине и только тогда задавать папку. Если в конфигурационном файле корневой каталог не указан, то по умолчанию в качестве него принимается подкаталог Data.

Шаг 2. Редактирование таблицы address

  1. В редакторе баз данных выделите таблицу address.

  2. Сделайте щелчок правой кнопкой мыши и в открывшемся контекстом меню выберите пункт Реструктурировать.

  3. Добавьте в таблицу поля:

    • Pasport – тип BLOB;

    • Photo – тип строковое, размер 150 символов;

    • Gallery - тип поля BLOB.

  4. Сохраните и закройте окно реструктурирования таблицы.

Шаг 3. Создание запроса

  1. В редакторе баз данных нажмите кнопку [image] Запросы.

  2. Нажмите кнопку [image] Создать....

  3. Добавьте в запрос таблицу address.

  4. Добавьте в список полей запроса поля.

    • Street;

    • Num_house;

    • Type_house;

    • Passport;

    • Photo;

    • Gallery.

  5. Дайте полям пользовательские названия.

  6. Укажите поле связи – Sys.

  7. В списке полей запроса выделите поле Photo и нажмите кнопку [image] (свойства). В окне свойств в разделе тэги в первой строке из открывающегося списка выберите тэг document - он укажет системе, что из данного поля надо вызвать файл, путь к которому будет прописан в нем. Во второй строке выберите тэг picture - он означает что файл, путь к которому задается в этом поле, является изображением, и он будет отображаться в окне семантической информации в виде уменьшенного изображения. Применение данного тэга не обязательно, и при больших объемах прикрепленного файла возможно замедление открытия базы данных.

    Для закрытия окна нажмите кнопку ОК.

    Рисунок 741. Установка Тэгов

  8. Далее аналогично в списке полей запроса выделите поле Gallery, нажмите кнопку [image] (свойства). В окне свойств в разделе тэги из открывающегося списка выберите тэг gallery - данный тэг позволяет подключать несколько файлов к одному полю. Справа от тэга введите опции files и links через пробел или запятую:

    Тэг gallery и опции files и links

    Рисунок 742. Тэг gallery и опции files и links

    Использование одновременно опций files и links позволяют использовать сочетание ссылок на файлы и непосредственное добавление файлов в базу.

    Для закрытия окна нажмите кнопку ОК.

  9. Для сохранения запроса нажмите кнопку [image] Сохранить....

    Диалоговое окно Запрос

    Рисунок 743. Диалоговое окно Запрос

  10. Укажите имя запроса, например – База с документами, нажмите кнопку ОК.

Шаг 4. Выбор основного запроса

  1. В редакторе баз данных нажмите кнопку Запрос, в строке Основной запрос выберите из ниспадающего списка запрос База с документами.

  2. Сохраните описатель – кнопка [image] Сохранить и закройте окно редактора баз данных.

Шаг 5. Задание папки для изображений

При использовании тэга document желательно указывать папку в которой будут храниться прикрепленные файлы. Это позволит в дальнейшем избежать путаницы в хранимых данных и значительно упростит передачу данных другим лицам в случае необходимости. Для назначения папки:

  1. В редакторе баз данных нажмите кнопку [image] Сервис.

  2. В стоке Папка для изображений и документов нажмите кнопку Обзор... и в появившемся окне укажите каталог в котором будут храниться документы. В дальнейшем при задании относительных путей к файлам, полный путь рассчитывается от данной базовой папки. Если базовый путь не указан, относительные пути рассчитываются относительно папки карты.

    [Примечание] Примечание

    При работе с серверными данными (ZuluServer) подробней о папке для изображений можно узнать в разделе «Дополнительные настройки».

Шаг 6. Открытие окна семантической информации

Для проверки правильности создания и подключения базы данных откройте окно семантической информации, для его открытия:

  1. На панели навигации нажмите кнопку информация [image] .

  2. Сделайте активным слой Дома.

  3. Щелкните левой кнопкой мыши по любому объекту слоя. При этом на экране откроется окно семантической информации, готовое для занесения данных. В строке Паспорт для подключения документа надо нажать кнопку [image] . Далее выбрать меню Файл|Загрузить и в открывшемся окне указать файл для загрузки. Если в настройках базы данных заранее указана папка по умолчанию, то будет открываться она.

    Фотография подключается точно таким же способом:

    Окно семантической информации

    Рисунок 744. Окно семантической информации

  4. Файлы в поле Галерея загружаются аналогично, только в меню надо выбрать Файл|Добавить, выбрать вариант загрузки и только потом указать файл:

    Выбор варианта загрузки

    Рисунок 745. Выбор варианта загрузки

    В зависимости от выбранного варианта будет либо в базу добавлен сам файл либо ссылка на него. Таким образом в галерею можно добавить нужное количество файлов:

Добавленные файлы и ссылки

Рисунок 746. Добавленные файлы и ссылки

Как видно из приведенного выше описания подключение файлов происходит по разному, и оно имеет одно принципиальное отличие. В том случае, когда дается ссылка на файл, база просто устанавливает с ним связь, и если документ будет изменен, то открываться будет уже измененный документ. Но при перемещении документа на новое место связь с ним будет утеряна! Когда же файл загружается в базу, связь с исходным файлом будет утеряна, изменения файла могут осуществляться только через ZuluGIS, при этом надо учитывать что объем базы данных будет сильно увеличиваться, особенно при использовании фотографий.


Изменение источника данных

Очень часто при переходе от одного источника данных к другому структура таблиц остается, а меняется только источник данных (например, были локальные таблицы Paradox, теперь база данных SQL Server). В таком случае нет необходимости переделывать все запросы в описателе, а достаточно только сменить источник данных для таблицы.

В одном описателе можно использовать таблицы с разными источниками данных.

Например, все таблицы по участкам преобразованы из Paradox в SQL Server. Для изменения описателя достаточно:

  1. Открыть существующий описатель, например Участок.

  2. Выбрать тип объектов - [image] Таблицы.

  3. Выделить таблицу, нажать кнопку [image] Заменить....

  4. В окне Выбор таблицы в дереве источников данных выберите нужный предварительно созданный источник данных.

  5. Сохраните описатель с тем же или измененным именем.


Редактирование и настройка базы данных

Редактирование базы данных может включать в себя:

  • «Добавление и удаление полей базы данных» («Пример добавления полей в базу данных»)

  • Настройку полей базы данных, например:

    • изменение пользовательского названия поля (название которое отображается в окне семантической информации);

    • группировка полей;

    • выделение поля цветом;

    • настроить всплывающие подсказки для поля;

    • подключение справочника к полю;

    • подключение специальных тэгов к полю.

  • Настройку вида окна семантической информации. Формы


Добавление и удаление полей базы данных

В данном разделе будут подробно рассмотрены действия, необходимые для добавления или удаления полей базы. Любая из этих операций производится через редактирование структуры базы данных.

[Важно] Важно

Удалять уже существующие поля из баз данных инженерных сетей НЕЛЬЗЯ, так как данные могут использоваться для расчетов. Удалить можно только те поля, которые были добавлены самостоятельно.

Редактирование структуры базы данных возможно двумя способами:

  • упрощенный вариант через окно семантической информации - подходит только для добавления дополнительных полей в базу данных;

  • редактирование через редактор базы данных - данный вариант подходит как для добавления полей, так и для их удаления.

[Примечание] Примечание

Видео по добавлению и удалению полей базы данных можно посмотреть пройдя по одной из ссылок: https://youtu.be/rO-djkeW86c или https://www.politerm.com/videos/database/dobavlenie-udalenie-poley-bazy-dannykh/.


Добавление полей через окно семантической информации

Данный вариант подойдет только для того, чтобы добавить дополнительные поля в базу данных, удалить поля таким способом невозможно. В том случае, когда требуется не просто добавить поле в конец списка, а сделать еще дополнительные настройки, например подключить к нему справочник, задать цвет, добавить в группу, приведенный ниже способ не очень подходит. В этом случае лучше воспользоваться способом редактирования через редактор базы данных.

Для добавления полей через окно семантической информации надо:

  1. Открыть окно семантической информации по слою, которому в базу данных надо добавить поля (кнопка [image] ).

  2. Сделать щелчок правой кнопкой мыши в области окна, из появившегося контекстного меню выбрать пункт Добавить поле.

    Окно семантической информации

    Рисунок 747. Окно семантической информации

  3. Далее в появившемся диалоге задать:

    • в строке Имя - имя для нового поля таблицы, в том случае, если поле в таблицу было заранее добавлено, его надо выбрать из списка;

    • в строке Пользовательское имя - пользовательское имя для нового поля;

    • из списка Тип поля выбрать тип для создаваемого поля (при выборе типа Строковое необходимо так же будет задать максимальное количество символов для поля в строке Длина);

    • при наличии нескольких таблиц в базе выбрать из списка нужную таблицу.

      Окно добавления поля

      Рисунок 748. Окно добавления поля

  4. Нажать кнопку ОК.

В результате проделанных действий в базу данных в будет добавлено новое поле, поле будет внесено в конец списка:

Окно семантической информации

Рисунок 749. Окно семантической информации

[Примечание] Примечание

Переместить поле или задать дополнительные настройки для добавленного поля можно через редактор баз данных, как это сделать можно узнать в разделе «Настройка полей базы данных».


Редактирование структуры через редактор базы данных

Далее будут рассмотрены следующие операции:

  • Добавление полей в базу данных

  • Удаление полей из базы данных

Редактирование через редактор происходит в два этапа:

  1. Реструктурирование таблицы (изменение структуры).

  2. Изменение запроса.

Добавление полей

Этап 1. Реструктурирование таблицы для добавления полей

  1. Откройте редактор базы данных, нажмите кнопку [image] Таблицы.

  2. Сделайте щелчок правой кнопкой мыши по таблице, которую надо отредактировать и в открывшемся контекстом меню выберите пункт Реструктурировать.

  3. В открывшемся окне для добавления поля в конец таблицы нажмите кнопку Добавить поле и введите название нового поля (имя поля не должно содержать спецсимволы, точки, запятые, вопросы, восклицательные знаки, скобки). Кнопка Вставить поле позволяет вставить поле в середину таблицы над выделенным в списке полем.

    Окно реструктурирования таблицы

    Рисунок 750. Окно реструктурирования таблицы

  4. В столбце Тип надо определить тип добавляемого поля. Для типа Строковое необходимо задать длину. Список возможных типов полей зависит от используемой базы данных, а также от выбранного «режима»: обычного или экспертного.

  5. Если необходимо добавить несколько полей, то можно повторить выше перечисленные действия столько раз, сколько нужно.

  6. Для сохранения изменений нажмите кнопку Сохранить и затем с помощью кнопки Закрыть произведите закрытие окна реструктурирования.

Этап 2. Изменение запроса (добавление полей)

  1. В редакторе баз данных нажмите кнопку [image] Запросы.

  2. Выделите запрос Основной (либо тот, который создавался на основе редактируемых таблиц), нажмите кнопку [image] Изменить... или сделайте на нем двойной щелчок левой кнопкой мыши.

  3. В окне Запрос в таблице сделайте на добавленном на предыдущем этапе поле двойной щелчок или выделить его, щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Добавить поле:

    Добавление нового поля

    Рисунок 751. Добавление нового поля

  4. В нижнем разделе окна Запрос выделить появившееся в самом конце поле, и в столбце Название при необходимости задайте пользовательское название нового поля, после чего нажмите кнопку ОК.

    [Примечание] Примечание

    Как видно из рисунка выше окно реструктурирования таблицы возможно вызвать и на данном этапе через контекстное меню.

  5. При необходимости откройте панель свойства и задайте добавленному полю дополнительные настройки, такие как цвет, стиль текста, группировка и др. Подробнее....

  6. При необходимости с помощью стрелок ( [image] [image] [image] [image] ) переместите поле в нужное место запроса.

  7. Сохраните запрос (кнопка Сохранить), закройте его (кнопка Закрыть).

  8. Сохраните редактор баз данных, нажатием кнопки [image] Сохранить, кнопкой [image] Выход закройте окно База данных.

  9. Чтобы проверить произведенные изменения откройте окно семантической информации:

    Окно семантической информации с добавленным полем

    Рисунок 752. Окно семантической информации с добавленным полем

Удаление полей

Этап 1. Реструктурирование таблицы (удаление полей)

  1. Откройте редактор баз данных, нажмите кнопку [image] Таблицы.

  2. Сделайте щелчок правой кнопкой мыши по таблице, которую надо отредактировать и в открывшемся контекстом меню выберите пункт Реструктурировать.

  3. В открывшемся окне со списком полей открытой таблицы щелкните левой кнопкой мыши на том поле, которое надо удалить. Нажмите кнопку Удалить поле.

  4. Для сохранения изменений нажмите кнопку Сохранить и затем с помощью кнопки Закрыть произведите закрытие окна реструктурирования.

Этап 2. Реструктурирование запроса (удаление полей)

  1. Нажмите кнопку [image] Запросы.

  2. Выделите запрос Основной (либо тот, который создавался на основе редактируемых таблиц), нажмите кнопку [image] Изменить....

  3. В нижнем разделе окна Запрос выделите строчку, которую надо удалить, и нажмите кнопку [image] .

  4. Сохраните запрос (кнопка Сохранить), закрыть его (кнопка Закрыть).

  5. Сохраните редактор баз данных, нажатием кнопки [image] Сохранить, кнопкой [image] Выход закроейте окно База данных.

Чтобы проверить произведенные изменения надо открыть окно семантической информации.


Пример добавления полей в базу данных

Предположим, нам необходимо к уже существующей базе Дома (\Examples\Termo\Kvartal\Doma.zb) добавить поле, в котором будет указано количество жителей каждого дома, тип поля цифровой (короткое целое), данное поле должно располагаться в середине окна семантической информации.

Добавление полей в базу данных возможно двумя вариантами, в данном примере будет рассмотрен более сложный вариант: редактирование через браузер базы данных.

Откройте карту Пример тепловой сети (\Examples\Termo\Kvartal\Пример тепловой сети).

Этап 1. Реструктурирование таблицы

  1. Для того чтобы реструктурировать таблицу сначала откройте описатель, в который эта таблица входит. Для этого выберите пункт меню Слой|Структура слоя или нажмите на панели инструментов кнопку [image] (слой при этом НЕ должен быть редактируемым). Далее укажите слой Здания, выделите пункт Базы данных и справа в открывшейся вкладке выделить базу Дома и нажмите кнопку [image] Конструктор....

  2. Нажмите кнопку [image] Таблицы.

  3. Выделите таблицу Doma, сделайте щелчок правой кнопкой мыши и в открывшемся контекстом меню выберите пункт Реструктурировать.

  4. Для добавления поля нажмите кнопку Добавить поле, далее введите название нового поля, например Kol_giteley (напомним, что название задается латинскими буквами без пробелов), и задайте тип поля, выбрав из открывающегося выпадающего списка Короткое целое.

  5. Для сохранения изменений надо нажмите кнопку Сохранить и затем с помощью кнопки Закрыть закройте окна реструктурирования.

    Окно реструктурирования таблицы

    Рисунок 753. Окно реструктурирования таблицы

Этап 2. Реструктурирование запроса

  1. Нажмите кнопку [image] Запросы.

  2. Выделите Основной запрос, нажмите кнопку [image] Изменить....

  3. В окне Запрос в таблице выделите поле Kol_giteley, щелкнете правой кнопкой мыши и в появившемся контекстном меню выберите пункт Добавить поле или сделайте на добавляемом поле двойной щелчок левой кнопкой мыши.

    Добавление нового поля

    Рисунок 754. Добавление нового поля

  4. В нижнем разделе окна Запрос выделите появившееся в самом конце поле, и в столбце Название задайте пользовательское название нового поля – Количество жителей, после чего нажмите кнопку ОК.

  5. При помощи стрелок - [image] [image] [image] [image] переместите добавленное поле в нужное место.

    Добавленное в запрос поле

    Рисунок 755. Добавленное в запрос поле

  6. Сохраните запрос (кнопка Сохранить) и закройте его (кнопка Закрыть).

  7. Сохраните редактор баз данных, нажатием кнопки [image] Сохранить, кнопкой [image] Выход закройте окно База данных.

  8. Закройте окно структуры слоя.

  9. Сделайте активным слой Здания, нажмите кнопку [image] , и щелкните по любому дому, после чего откроется окно семантической информации с добавленным полем.

Окно семантической информации

Рисунок 756. Окно семантической информации


Настройка полей базы данных

Настройка для полей базы данных производится индивидуально. Настроить возможно следующие параметры:

  • изменить пользовательское название поля (название которое отображается в окне семантической информации);

  • изменить порядок следования полей;

  • настроить стиль текста и поля для названий и данных базы (цвет, начертание шрифта);

  • сделать группировку полей;

  • настроить всплывающие подсказки для поля;

  • подключить справочник к полю;

  • подключить специальные тэги к полю (тэги используются для расширения возможностей базы, например для прикрепления к полю файла, справочника fias, для записи данных gps, добавление возможности прикреплять к одному полю несколько файлов и др.).

[Примечание] Примечание

Видео по настройке полей базы данных можно посмотреть пройдя по одной из ссылок: https://youtu.be/zfqqDRT9k48 или https://www.politerm.com/videos/database/okno-informatsii-nastroyka-poley/.

Для настройки вышеперечисленного надо:

  1. Открыть описатель базы данных. Для этого надо выбрать пункт меню Слой|Структура слоя или нажать на панели инструментов кнопку [image] (слой при этом НЕ должен быть редактируемым). Далее указать слой, базу которого надо отредактировать. Для этого выделить пункт Базы данных и справа в открывшейся вкладке выделить созданную ранее базу, и нажать кнопку [image] Конструктор....

    [Примечание] Примечание

    Получить быстрый доступ к описателю базы так же можно через панель рабочее место. Для этого надо нажатием на + открыть список баз данных слоя, сделать щелчок правой кнопкой мыши на нужной базе и выбрать пункт Изменить.

  2. В диалоговом окне Структура слоя в дереве слева выделить пункт Базы данных.

  3. В открывшейся вкладке справа выбрать базу данных для редактирования.

  4. Нажать кнопку [image] Конструктор... или сделать щелчок правой кнопкой мыши на выбранной базе и в контекстном меню выбрать пункт Конструктор.

  5. В появившемся окне База данных выбрать вкладку Запросы.

    Диалоговое окно База данных

    Рисунок 757. Диалоговое окно База данных

  6. Справа выделить нужный запрос. На нем сделать двойной щелчок левой кнопкой мыши или нажать на панели инструментов кнопку [image] Изменить.... Открыть запрос для изменения также можно сделав на нем щелчок правой кнопкой мыши и выбрав в контекстном меню пункт Изменить.

    [Примечание] Примечание

    В том случае, если слой создавался одновременно с базой данных, редактор запросов откроется в упрощенном режиме, в котором возможности редактирования ограниченны (например нельзя добавлять/удалять поля таблицы). Для перехода в экспертный режим надо в области полей сделать щелчок правой кнопкой мыши и выбрать пункт Экспертный режим.

  7. В столбце Название выделить нужное поле и внести вместо него новое название. Исходное название в таблице при этом затронуто не будет.

  8. Изменение порядка следования полей возможно только в Экспертном режиме! В этом случае диалог должен выглядеть как на рисунке выше. Для перемещения поля надо его выделить, щелчком правой кнопкой мыши вызвать контекстное меню и выбрать нужный пункт, или нажать нужную кнопку, расположенную на панели инструментов:

    - перемещает поле в самое начало списка;

    - выполняет сдвиг на одно поле вверх;

    - выполняет сдвиг на одно поле вниз;

    - перемещает поле в самый конец списка.

  9. Остальные настройки задаются в диалоговом окне Свойства. Для его открытия внизу, в списке полей запроса надо выделить поле, сделать щелчок правой кнопкой мыши и в появившемся контекстном меню выбрать пункт Свойства.

    Такие настройки как стиль, название группы и тэги могут быть заданы одновременно для нескольких полей. Для задания одинаковых параметров одновременно нескольким полям, их предварительно надо выделить. Выделение группы полей, расположенных по порядку делается щелчком сначала по первому полю, потом по последнему, так же при этом на клавиатуре надо удерживать клавишу Shift. Для выделения определенных полей надо сделать на каждом поле щелчок левой кнопкой мыши одновременно удерживая на клавиатуре клавишу Ctrl.

    После выделения полей для вызова диалога Свойства надо сделать щелчок правой кнопкой мыши и в появившемся контекстном меню выбрав пункт Свойства.

    [Примечание] Примечание

    Настройка всплывающих подсказок и подключение справочника возможно только для каждого поля отдельно.

  10. В открывшемся диалоговом окне Свойства произвести настройку нужных параметров. Подробней о настройках можно узнать в разделе свойства полей запроса.

  11. Для подтверждения произведенных изменений нажать кнопку ОК в диалоге Свойства и закрыть окно.

  12. Затем сохранить запрос - кнопка [image] Сохранить и закрыть окно запроса с помощью кнопки Закрыть.

  13. Сохранить описатель базы данных - кнопка [image] Сохранить, закрыть окно описателя.

Произведенные изменения будут отображаться в окне семантической информации.


Настройка списка полей семантической информации. Формы

Набор полей, выводимых в окне семантической информации, определяется кнопкой Формы ( [image] ) редактора баз данных.

При создании слоя инженерных сетей или векторного слоя одновременно с базой данных в каждой созданной автоматически базе данных будет сформирован запрос (Основной), который по умолчанию отображается как форма. В базах, созданных самостоятельно формой по умолчанию назначен запрос, созданный пользователем (по умолчанию Запрос1).

В том случае, когда для требуется выводить не все поля основного запроса имеется возможность создать дополнительные формы и в дальнейшем при работе переключаться на нужную.

[Примечание] Примечание

Видео по созданию форм можно посмотреть пройдя по одной из ссылок: https://youtu.be/Q-SXPeM6-H8 или https://www.politerm.com/videos/database/nastroyka-spiska-poley-formy/.

Переключение между формами можно производить и непосредственно в окне семантической информации. Процесс переключения между формами показан на рисунках ниже:

Выбор форм по нажатию кнопки

Рисунок 758. Выбор форм по нажатию кнопки

Включена форма «Адрес»

Рисунок 759. Включена форма «Адрес»


Подключение файлов к базе данных слоя

[Примечание] Примечание

Видео с примером подключения файлов к базе данных слоя можно посмотреть пройдя по одной из ссылок: https://youtu.be/WfbwnWZ5UHw или https://www.politerm.com/videos/database/podklyuchenie-faylov-k-baze-dannykh-sloya/.

Пример подключения файлов к базе данных можно посмотреть пройдя по ссылке «Подключение файлов к базе данных».

Имеется возможность подключить к полям базы данных различные файлы. Это могут быть фотографии, различные документы или например таблицы Excel. В текущей версии реализовано два варианта подключения данных:

  • хранение подключенных файлов внутри базы;

  • хранение в базе ссылок на подключенные файлы.

Каждый из выбранных способов имеет свои преимущества и недостатки и прежде чем настраивать базу для подключения файлов необходимо решить какой вариант хранения данных подходит именно вам.

При хранении файлов внутри базы плюсом является то что файл уже там, если требуется перенести слой на другой компьютер, то все подключенные файл автоматически будут перемещены вместе с ним. При добавлении определенного тэга например Word файл возможно непосредственно из базы отредактировать и сохранить. Но весьма существенный минус состоит в том, что при подключении файлов большого объема, например фотографий размер базы сильно увеличивается. И рано или поздно наступит тот момент что с базой будут работать затруднительно, ее открытие займет весьма значительное время. Так же при больших объемах данных потребуется много свободного места на диске для архива информации, который очень желательно делать регулярно.

Если в базе хранятся не сами файлы а ссылки, то в этом случае размер базы практически не увеличивается, что является большим преимуществом. Минус же состоит в том что файлы, ссылки на которые даются, располагаются отдельно. И если работа изначально не правильно организована, то при необходимости переноса данных возникнут проблемы. А вот при правильной настройке данный способ присоединения файлов является оптимальным.

[Примечание] Примечание

В ZuluGIS 8.0 не предусмотрено автоматическое изменение способа хранения присоединенных файлов, это возможно только программным способом!


Настройка базы данных для хранения подключенных файлов внутри базы

[Предупреждение] Предупреждение

При использовании описанного ниже варианта хранения подключенных данных размер базы данных увеличивается. Если планируется загрузка файлов большого размера, то данный вид хранения не подходит. Потому что в этом случае размер базы может увеличиться на столько, что работа с ней будет затруднительна. В этом случае лучше использовать хранение в базе ссылок на подключенные файлы.

Перед произведением настройки семантическая база данных уже должна быть создана. Чтобы настроить базу для хранения подключенных файлов внутри базы надо:

  1. Открыть редактор баз данных для редактируемой базы данных.

  2. В открывшемся окне нажать кнопку [image] Запросы.

  3. Выделить нужный запрос в списке.

  4. Нажать кнопку [image] Изменить….

  5. Далее необходимо в таблицу запроса добавить поле для загрузки данных. Для этого надо сделать щелчок правой кнопкой на таблице запроса и в контекстном меню выбрать пункт Реструктурировать.

    Рисунок 760. Реструктурирование таблицы

  6. В открывшемся диалоговом окне нажать кнопку Добавить поле. В столбце Имя поля внести имя, например Документы, Фото и др., в столбце тип выбрать тип поля BLOB.

  7. Нажать кнопку Сохранить и закрыть окно реструктурирования таблицы.

  8. Если в поле планируется загружать только один файл, то далее следует перейти к следующему пункту пропуская данный. Для расширения возможностей можно к полю добавить дополнительные тэги.

    В данном случае возможно использовать следующие тэги:

    • picture - он укажет системе, что файл, который добавляется в поле является изображением. Для таких документов вызывается не программа по умолчанию, а встроенный просмотр изображений, а в окне семантической информации отображается уменьшенное изображение из файла. Важно что при использовании данного тэга может замедляться открытие окна информации по объекту.

    • gallery - позволяет загружать в одно поле несколько файлов.

    Для добавления к полю тэгов следует выделить его в списке полей запроса, нажать кнопку свойства [image] . Затем в разделе тэги выбрать нужные тэги и нажать кнопку ОК:

    Добавление тэгов к полю

    Рисунок 761. Добавление тэгов к полю

  9. Сохранить запрос нажав кнопку [image] Сохранить и далее закрыть окно запроса с помощью кнопки Закрыть.

  10. Нажать кнопку [image] Сохранить в окне редактора баз данных и так же закрыть его.

  11. Проверить результат, для этого надо открыть окно семантической информации. Установить курсор справа от добавленного поля, там будет кнопка ..., нажатие на нее откроет окно в котором можно выбрать меню Файл/Добавить и загрузить нужный файл в поле.


Настройка базы данных для хранения в базе ссылок на подключенные файлы

Если стоит задача хранить в базе данных ссылки на файлы, то в этом случае обязательно надо правильно организовать работу. Все файлы, ссылки на которые будут даны желательно хранить в отдельной папке. Это будет базовая папка и полный путь до файлов будет рассчитываться от нее. Данную папку необходимо самостоятельно указать.

Если работа производится в ZuluGIS Mobile, ZuluGIS Online и ZuluServer файлы на которые дается ссылка в базе автоматически копируются в указанную папку. Если папка не будет указана, то файлы будут копироваться в ту же папку, в которой располагается слой.

Чтобы указать папку для документов:

  1. Откройте редактор баз данных для редактируемой базы данных.

  2. В открывшемся окне нажмите кнопку [image] Сервис.

  3. Справа от строки Папка для изображений и документов нажмите кнопку Обзор... и укажите папку.

    При работе в многопользовательской версии (ZuluServer), когда слой хранится на сервере путь надо указывать непосредственно за компьютером сервером. Слой, которому будет задаваться папка для хранения данных открывается как локальный. То есть при загрузке слоя надо указать до него полный путь на машине, а не загружать слой через серверы геоданных. Если в конфигурационном файле корневой каталог не указан, то слои сервера хранятся по умолчанию в каталоге Data в папке, где установлен ZuluServer.

При хранении в базе данных ссылок на файлы возможно два варианта настройки базы:

  • хранение в каждой строке одной ссылки;

  • хранение в одной строке несколько ссылок.


Хранение в каждой строке одной ссылки

Перед произведением настройки семантическая база данных уже должна быть создана. Чтобы настроить базу для хранения в каждой строке одной ссылки надо:

  1. Открыть редактор баз данных для редактируемой базы данных.

  2. В открывшемся окне нажать кнопку [image] Запросы.

  3. Выделить нужный запрос в списке.

  4. Нажать кнопку [image] Изменить….

  5. Далее необходимо в таблицу запроса добавить поле для ссылки. Для этого надо сделать щелчок правой кнопкой на таблице запроса и в контекстном меню выбрать пункт Реструктурировать.

    Рисунок 762. Реструктурирование таблицы

  6. В открывшемся диалоговом окне нажать кнопку Добавить поле. В столбце Имя поля внести имя, например Фото, в столбце тип выбрать тип поля Строковое, в столбце Длина установить максимальное количество символов для строки. Для данного типа значение не может превышать 255 символов.

  7. Нажать кнопку Сохранить и закрыть окно реструктурирования таблицы.

  8. Затем для поля необходимо добавить тэг document именно он позволяет вызвать файл, путь к которому будет прописан в поле окна семантической информации.

    Если к полю подключается фото возможно добавить дополнительный тэг picture, который укажет системе, что файл, который добавляется в поле является изображением. И в этом случае в поле будет отображался не путь до файла а уменьшенное изображение из файла. Но надо учесть что при использовании данного тэга может замедляться открытие окна информации по объекту.

    Для добавления к полю тэгов следует выделить его в списке полей запроса, нажать кнопку свойства [image] . Затем в разделе тэги выбрать нужные тэги и нажать кнопку ОК:

    Добавление тэгов к полю

    Рисунок 763. Добавление тэгов к полю

  9. Сохранить запрос нажав кнопку [image] Сохранить и далее закрыть окно запроса с помощью кнопки Закрыть.

  10. Нажать кнопку [image] Сохранить в окне редактора баз данных и так же закрыть его.

  11. Проверить результат, для этого надо открыть окно семантической информации. Установить курсор справа от добавленного поля, там будет кнопка ..., нажатие на нее откроет окно в котором можно выбрать меню Файл/Загрузить и загрузить нужный файл в поле.


Хранение в одной строке несколько ссылок

Перед произведением настройки семантическая база данных уже должна быть создана. Чтобы настроить базу для хранения подключенных файлов внутри базы надо:

  1. Открыть редактор баз данных для редактируемой базы данных.

  2. В открывшемся окне нажать кнопку [image] Запросы.

  3. Выделить нужный запрос в списке.

  4. Нажать кнопку [image] Изменить….

  5. Далее необходимо в таблицу запроса добавить поле для загрузки данных. Для этого надо сделать щелчок правой кнопкой на таблице запроса и в контекстном меню выбрать пункт Реструктурировать.

    Рисунок 764. Реструктурирование таблицы

  6. В открывшемся диалоговом окне нажать кнопку Добавить поле. В столбце Имя поля внести имя, например Документы, Фото и др., в столбце тип выбрать тип поля BLOB.

  7. Нажать кнопку Сохранить и закрыть окно реструктурирования таблицы.

  8. Затем к полю надо подключить тэги. В данном случае используется тэг gallery, он позволяет загружать в одно поле несколько файлов. Но по умолчанию будет происходить именно загрузка файлов, а для того чтобы файлы не загружались, а давалась ссылка на них к тэгу справа надо выбрать опцию links.

    Для добавления к полю тэга следует выделить его в списке полей запроса, нажать кнопку свойства [image] . Затем в разделе тэги выбрать нужный тэги, справа внести опцию links и нажать кнопку ОК:

    Добавление тэгов к полю

    Рисунок 765. Добавление тэгов к полю

  9. Сохранить запрос нажав кнопку [image] Сохранить и далее закрыть окно запроса с помощью кнопки Закрыть.

  10. Нажать кнопку [image] Сохранить в окне редактора баз данных и так же закрыть его.

  11. Проверить результат, для этого надо открыть окно семантической информации. Установить курсор справа от добавленного поля, там будет кнопка ..., нажатие на нее откроет окно в котором можно выбрать меню Файл/Добавить и загрузить нужный файл в поле. Для загрузки следующего файла повторить действие.


Перенос данных из полей типа BLOB в файлы

Текущая версия автоматически может изменить способ хранения документов и изображений. В результате данной процедуры:

  • информация из указанного поля типа BLOB сохраняется в указанную папку, что сильно уменьшит размер базы данных;

  • автоматически редактируется запрос базы данных, к полю BLOB добавляется дополнительный тэг gallery с опцией links;

  • в базе данных вместо файлов вставляются ссылки них.

Для переноса данных надо:

  1. Открыть редактор баз данных.

  2. Нажать кнопку [image] Таблицы.

  3. Справа в области таблиц сделать щелчок правой кнопкой мыши и в контекстом меню выбрать пункт Задачи|Перенос BLOB....

  4. В открывшемся мастере переноса данных выбрать запрос и поле BLOB данные из которого надо перенести. Нажать кнопку Далее.

  5. При работе с локальным слоем:

    • если для слоя не указана папка для документов, то по умолчанию все документы и изображения предлагается поместить в папку files, которая будет создана там же где располагается слой. Для изменения папки надо нажать кнопку Обзор... и выбрать новую папку.

      Если дополнительно установить опцию Назначить папкой для документов, то соответственно указанная папка так же будет прописана как папка для документов по умолчанию;

    • если у слоя папка для документов указана, то появляется возможность создать в ней дополнительную подпапку, для этого, следует установить опцию Помещать в подпапку и в строке ниже дать название создаваемой подпапки. Если уже такая папка существует, то новая создаваться не будет.

    При работе с серверным слоем:

    • если для слоя не указана папка для документов, то по умолчанию все документы и изображения предлагается поместить в папку files, которая будет создана там же где располагается слой.

    • если у слоя папка для документов указана, то данные сохраняются в нее, так же есть возможность создать в ней дополнительную подпапку, для этого, следует установить опцию Помещать в подпапку и в строке ниже дать название подпапки. Если папки с указанным названием нет, то она будет создана, если она существует, то новая создаваться не будет.

  6. В строке шаблон имени для новых файлов настраивается шаблон. Для его настройки надо нажать кнопку Изменить...

    По умолчанию шаблон имени файла предлагается следующего вида: $(filename)$(index)$(ext), где:

    $(filename) - имя файла, если имя не восстановить, то по умолчанию присваивается имя File, для замены имени возможно удалить данный параметр и внести свое имя;

    $(index) - порядковый номер для файла 1, 2, 3 и т.д.;

    $(ext) - расширение файла.

    Например, если требуется чтобы после импорта все файлы имели название вида Акт1, Акт2, Акт3 и т.д. то шаблон будет выглядеть следующим образом: Акт$(index)$(ext).

    [Примечание] Примечание

    Если данные хранились в поле BLOB без тэга gallery, то исходное имя файла восстановить невозможно!

  7. Настроить действие мастера переноса на тот случай если имена переносимых данных совпадут. Имеется три варианта:

    • Перезаписывать существующий - если файл с таким именем в папке уже есть, то он будет заменен на новый;

    • Использовать существующий - если файл с таким именем в папке уже есть, то он не будет изменен;

    • Добавлять индекс к имени файла - к новому файлу будет добавлен индекс 1, 2, 3 и т.д.

  8. Нажать кнопку Далее.

  9. Для запуска процедуры нажать кнопку Пуск.

  10. После окончания переноса данных появится соответствующее сообщение. Для закрытия мастера переноса данных нажать кнопку Закрыть.

  11. Так как мастер переноса изменяет запрос базы данных - к полю BLOB добавляется дополнительный тэг gallery с опцией links, то для сохранения изменений необходимо сохранить Браузер базы данных - кнопка [image] Сохранить.


Классификатор ФИАС

К полю базы данных ZuluGIS возможно подключить классификатор адресов ФИАС (Федеральная информационная адресная система) https://fias.nalog.ru/. Программа позволяет вести адресную базу данных в соответствии с требованиями ФИАС – на основе принципов единства технологии формирования адресов. Сведения ФИАС являются открытыми и предоставляются на бесплатной основе. Источниками адресной информации на данный момент является http://suggestions.dadata.ru/suggestions.

Интернет запросы к базе ФИАС могут выполнятся централизованно через ZuluServer или с клиентских рабочих мест. Полный адрес содержит: Индекс, Регион, Район, Город, Улица, Дом, код (GUID). Формат записи и отображения адреса объекта настраивается при настройке классификатора. Для удобства работы, возможно ограничения области применения классификатора пользовательским регионом.

[Предупреждение] Предупреждение

Для использования классификатора ФИАС обязательно должен присутствовать доступ в интернет на ZuluServer или клиентских рабочих местах. Работа справочника оффлайн не предусмотрена.

Пользователи могут выбирать адресные элементы из списка. При вводе фрагмента адреса, реализована фильтрация списка. Пример работы со справочником адресов ФИАС представлен на следующей картинке:

Пример выбора адреса из классификатора ФИАС

Рисунок 766. Пример выбора адреса из классификатора ФИАС

Схема состава подчиненности объектов в ФИАС такая: Российская Федерация состоит из регионов, в состав регионов включаются города и районы, районы также содержат города и населенные пункты, а город или населенный пункт состоят из улиц, которые в свою очередь состоят из домов.


Подключение ФИАС к полю базы

[Примечание] Примечание

Видео с примером подключения справочника ФИАС и дополнительной таблицы с портала Реформа ЖКХ можно посмотреть пройдя по ссылке: https://youtu.be/3Jr49xSmAos.

Для подключения классификатора ФИАС к полю базы:

  1. В окне База данных нажать кнопку [image] Запросы.

  2. Выделить нужный запрос в списке редактора базы данных.

  3. Нажать кнопку [image] Изменить….

  4. Щелчком правой кнопкой мыши открыть контекстное меню для поля и выбрать Свойства:

    [Предупреждение] Предупреждение

    Нельзя подключать ФИАС к существующему полю с данными.

    Контекстное меню для поля

    Рисунок 767. Контекстное меню для поля

  5. В левой части области тэги выбрать fias из выпадающего списка.

  6. Настроить классификатор, нажав кнопку … в правой области тэги, напротив (fias):

    Рисунок 768. Свойства поля

  7. Откроется окно настройки ФИАС. В строке Вариант выбрать, как будет отображаться адрес, , после чего в строках Формат и Пример будет показан выбранный вариант:

    Настройка формата отображения адреса ФИАС.

    Рисунок 769. Настройка формата отображения адреса ФИАС.

    Настройка формата так же возможна с непосредственным занесением кодов формата в поле Вариант, по мимо кодов в данную строку может быть занесена нужная информация, которая будет отображена в неизменном виде. Пример по введенным данным будет отображаться в строке Пример.

    Таблица 6. Список кодов

    Код | Обозначение
    Z | индекс
    R | регион
    r | уникальный номер региона (код ФИАС)
    D | район
    d | уникальный номер района (код ФИАС)
    C | город
    c | уникальный номер города (код ФИАС)
    S | улица
    s | уникальный номер улицы (код ФИАС)
    B | дом
    b | уникальный номер дома (код ФИАС)

  8. Перейти на вкладку Настройки и при необходимости указать дополнительные настройки:

    Использовать локально — для серверного слоя по-умолчанию запросы к веб-сервису ФИАС выполняются с ZuluServer. При установке данной опции онлайн запросы к веб-сервису ФИАС будут выполнятся с клиентского компьютера. Используется если у сервера нет выхода в интернет.

    Настройки источника и области применения ФИАС.

    Рисунок 770. Настройки источника и области применения ФИАС.

  9. В разделе Область применения возможно указать регион, который будет указываться «по-умолчанию» (при вводе адреса будет уже введён).

    При установке опции Ограничить выбор областью применения для выбора адреса будут доступные только записи из Области применения, поля области применения будут скрыты для ввода.

    Выбор адреса из ФИАС с ограничением области применения

    Рисунок 771. Выбор адреса из ФИАС с ограничением области применения

  10. Нажать кнопку ОК для сохранения настроек ФИАС.

  11. Сохранить и закрыть все активные окна связанные с базой данных.


Выбор адреса из классификатора ФИАС

Для выбора адреса из классификатора ФИАС:

  1. Открыть окно семантической информации ( [image] ) по объекту, для выбора адреса.

  2. Установить курсор с правой стороны строки со справочником ФИАС и нажать кнопку … .

    Выбор адреса из классификатора ФИАС

    Рисунок 772. Выбор адреса из классификатора ФИАС

  3. Заполнить адрес, выбирая необходимые значения из выпадающих списков.

    [Подсказка] Подсказка

    При вводе фрагмента адреса, реализована фильтрация списка элементов.

  4. Нажать кнопку ОК. Адрес будет записан в поле в преднастроенном формате.

  5. Сохранить текущую запись [image] .


Заполнение базы данных (табличной информации)

Заполнение базы данных возможно несколькими способами:

  • в окне семантической информации через вкладку Текущая запись;

  • в окне семантической информации через вкладку База;

  • в окне семантической информации с помощью запросов;

  • используя SQL запросы.

[Примечание] Примечание

Видеоурок по заполнению табличных данных можно посмотреть пройдя по одной из ссылок: https://youtu.be/wqZlmXbDYd8 или https://www.politerm.com/videos/database/izmenenie-informatsii-vypolnenie-zaprosov/.

Примеры работы с семантической информацией можно найти в разделе «Примеры работы с семантической информацией».


Заполнение табличных данных через вкладку Текущая запись

[Примечание] Примечание

Для того чтобы ввести небольшое количество повторяющихся данных, удобно использовать функцию копирования полей. Чтобы скопировать все поля объекта, щелкните правой кнопкой мыши в окне семантической информации и в контекстном меню выберите пункт Копировать значения (Ctrl+Shift+C).

Чтобы вставить скопированные данные в другой объект, откройте окно семантической информации по этому объекту, снова откройте контекстное меню и выберите пункт Вставить значения (Ctrl+Shift+V). Если вы хотите скопировать только одну выделенную строку, воспользуйтесь пунктом Копировать в контекстном меню.

Если одинаковых данных по объектам много, то в этом случае целесообразней воспользоваться запросами.

Данный вид заполнения удобен при внесении информации для небольшого количества объектов с индивидуальными данными. Чтобы внести табличную информацию через вкладку Текущая запись предварительно необходимо открыть окно семантической информации, далее:

  1. Сделайте щелчок левой кнопкой мыши на объекте, которому необходимо внести информацию.

  2. Для ввода или редактирования данных достаточно щелкнуть мышью в любом поле и ввести требуемое значение.

    • В поле, в котором не делались дополнительные настройки - установите курсор справа от поля и внесите с клавиатуры значение:

      Окно семантической информации

      Рисунок 773. Окно семантической информации

    • В поле, к которому подключен справочник - значение поля выбирается из открывающегося списка справочника. Для открытия списка надо нажать на [image] справа от поля. В том случае, если значений в справочнике много, то можно установить курсор справа от поля, где расположен значок [image] и ввести значение для поиска. Поиск осуществляется как по целому значению, так и по его части.

      Окно семантической информации

      Рисунок 774. Окно семантической информации

    • В поле, для которого указан тэг document, задается путь к подключаемому файлу. Путь может быть как абсолютным, так и относительным. Относительные пути рассчитываются от папки карты, либо от заданного базового каталога. Для файлов находящихся на диске отличном от базового могут задаваться только абсолютные пути. Путь может задаваться вручную, либо с помощью стандартного диалога выбора файлов, открывающегося при нажатии кнопки [image] справа от поля. Справа от поля с путем к файлу находится также кнопка [image] , при нажатии которой заданный файл открывается в стандартном для него приложении (если для его расширения в системе задано приложение). Ниже указан абсолютный путь до файла:

      Окно семантической информации

      Рисунок 775. Окно семантической информации

    • Если для поля задан тэг тэг picture, то есть поле определено как путь к графическому файлу, то после указания файла вместо пути к нему в поле будет показано его уменьшенное изображение.

      Окно семантической информации

      Рисунок 776. Окно семантической информации

      Для того чтобы указать файл или просмотреть ранее загруженное изображение в увеличенном масштабе надо нажать справа кнопку ... или сделать двойной щелчок левой кнопкой мыши на нужной строке, откроется окно просмотра документов ZuluGIS. В текущей версии окно «плавающее», что позволяет просматривать файлы разных объектов не закрывая его. При работе с данным окном возможно:

      • загрузить новый файл - выберите меню Файл|Загрузить и укажите картинку для загрузки;

      • сохранить загруженный файл - нажмите кнопку Сохранить [image] ;

      • сохранить загруженный ранее файл на диск - выберите меню Файл|Сохранить как, задайте название и нажмите кнопку Сохранить;

      • удалить ранее загруженное изображение - выберите меню Файл|Очистить или нажать кнопку [image] Удалить;

      • скопировать в буфер обмена загруженное изображение - нажмите кнопку [image] Копировать;

      • вставить ранее скопированное изображение - нажмите кнопку [image] Вставить;

      • отредактировать загруженное изображение в программе просмотра изображений установленной на компьютере по умолчанию (возможно только при строковом типе поля таблицы) - сделать щелчок правой кнопкой мыши в области изображения и выбрать пункт Открыть;

      • отредактировать загруженное изображение (возможно только при строковом типе поля таблицы) - сделать щелчок правой кнопкой мыши в области изображения и выбрать пункт Изменить, после чего будет открыт редактор изображений, настроенный на компьютере по умолчанию;

      • напечатать загруженное изображение (возможно только при строковом типе поля таблицы) - сделать щелчок правой кнопкой мыши в области изображения и выбрать пункт Печатать.

      Окно семантической информации

      Рисунок 777. Окно семантической информации

    • Если тип поля при создании таблицы задан как ВLOB (специальный тип данных, предназначенный для хранения изображений, текстов, аудио и видео), то для внесения данных в поле следует нажать кнопку [image] справа от поля. В появившемся окне добавления файла выбрать меню Файл|Загрузить. В том случае, если к полю дополнительно подключен тэг тэг gallery, то для добавления файла в коллекцию следует выбрать меню Файл|Добавить. При добавлении к тэгу тэг gallery опций files и links дополнительно потребуется указать будет загружен сам файл или только ссылка на него.

      После добавления данных в поле будет написано (данные), просмотреть или отредактировать их можно нажав на кнопку [image] справа от строки. Откроется тоже окно просмотра галереи что и ранее открывалось для добавления файлов. В текущей версии окно «плавающее», что позволяет просматривать файлы разных объектов не закрывая его.

      Для увеличенного просмотра или редактирования добавленного файла сделайте двойной щелчок мыши на нем. В результате будет открыто или окно просмотра изображений или окно редактора в зависимости от типа файла.

      Окно семантической информации

      Рисунок 778. Окно семантической информации

      Просмотр галереи фотографий

      Рисунок 779. Просмотр галереи фотографий

    • В том случае, если тип поля в исходной таблице указан как Дата и время или Дата, в поле будет отображаться значок календаря [image] , нажав на который откроется календарь, в котором можно выбрать нужные параметры:

      Окно семантической информации

      Рисунок 780. Окно семантической информации

    • Если для поля задан тэг тэг color (в поле будет храниться цвет), то для выбора цвета надо нажать на [image] справа от поля и в открывшейся палитре выбрать нужный цвет:

      Окно семантической информации

      Рисунок 781. Окно семантической информации

    • Если к полю подключена база тэг ФИАС, то для выбора адреса нажмите кнопку [image] справа от поля. В открывшемся окне начните вносить первые значения адреса, система сама произведет поиск по базе и откроет список подходящих, выберите подходящий адрес.

      Окно семантической информации

      Рисунок 782. Окно семантической информации

  3. Для сохранения произведенных изменений нажмите кнопку [image] .


Заполнение табличных данных через вкладку База

Данный вид заполнения удобен при внесении однотипной информации. Чтобы заполнить базу данных через вкладку База предварительно необходимо открыть окно семантической информации. Затем убедиться в том, что количество записей в базе соответствует количеству объектов на карте. Для обновления числа записей надо нажать кнопку [image] . Если количество объектов и записей в базе было изменено, то на экране появится служебное сообщение с предложением обновления.

Несоответствие количеству записей и объектов в базе может быть в следующих случаях:

  • при начале работы с базой данных, то есть когда графические объекты уже нанесены на карту, а записи в базе данных еще не созданы (автоматически запись создается при штучном занесении данных), тогда в заголовке окна семантической информации имеется надпись Нет данных;

  • при удалении графических объектов (или группы объектов), в этом случае ZuluGIS не удаляет записи в подключенной семантической базе данных для сохранения целостности данных в СУБД на случай отмены операции удаления.

[Примечание] Примечание

В том случае, если в базе слишком много записей, то возможно сделать запрос с выборкой по определенной группе объектов, после чего производить заполнение данных в открывшейся вкладке Ответ. Работа в ней производится полностью аналогично с вкладкой База.

Для внесения информации необходимо:

  1. Сделать щелчок левой кнопкой мыши на одном из объектов, для которых необходимо внести информацию.

  2. В окне семантической информации выбрать вкладку База.

  3. Установить курсор в нужный столбец и внести или отредактировать необходимые данные.

  4. Для внесения информации по следующему объекту переместиться по строкам вкладки База или при помощи стрелок на клавиатуре или с помощью мыши. Объект, к которому относится выделенная строчка, замигает и переместится в центр карты. Если при указании строки с помощью мыши удерживать клавишу Alt, то помимо перемещения объекта произойдет масштабирование карты по размерам объекта. Таким же образом вносится информация для необходимого количества объектов.

  5. Сохранение данных происходит при переходе от одной строки к другой. Если после внесения данных перехода к следующей строке не произошло, то запрос о сохранении произведенных таким образом изменений будет происходить при открытии других вкладок окна, или при его закрытии.

    [Примечание] Примечание

    Имеется возможность выделить несколько ячеек по столбцам и строкам в закладке База. Для выделения надо удерживать клавишу Shift и делать щелчки левой кнопки мыши по нужным ячейкам. В дальнейшем выделенные ячейки можно скопировать сделав щелчок правой кнопкой мыши и выбрав в контекстном меню пункт Копировать.


Выполнение запросов к базам данных

  • «Общие сведения»;

  • «Обновление числа записей базы данных»;

  • «Отображение результатов запроса к базе данных на карте»;

  • «Сохранение условий запроса»;

  • «Сохранение результатов запроса».

[Примечание] Примечание

Видеоурок по заполнению табличных данных с использованием запросов можно посмотреть пройдя по одной из ссылок: https://www.youtube.com/watch?v=wqZlmXbDYd8&t=1984s или https://www.politerm.com/videos/database/izmenenie-informatsii-vypolnenie-zaprosov/.

Видеоурок по выборке табличных данных с использованием запросов можно посмотреть пройдя по одной из ссылок: https://www.politerm.com/videos/database/prosmotr-informatsii-vypolnenie-zaprosov/ или https://www.youtube.com/watch?v=X5o_ZMP4uqg&t=18s.

[Примечание] Примечание

Примеры работы с запросами можно увидеть в разделе «Примеры запросов к семантическим базам данных».

Использование запросов упрощает работу с базами данных, особенно это актуально при больших объемах информации. Возможно реализовать множество различных действий, например:

  • осуществлять быстрый поиск (выборку) определенной информации по заданным условиям;

  • заносить одинаковые данные одновременно для группы объектов;

  • производить копирование данных из одного поля в другое для группы объектов;

  • производить вычисление или сведение данных;

  • и т.д.

[Примечание] Примечание

В том случае, если при работе недостаточно встроенного языка запросов ZuluGIS, то тогда возможно использовать OGC расширения языка SQL.

Для выполнения запросов к базе данных:

  1. Если работа будет производиться не со всеми объектами базы, а с определенной группой объектов, то выделите ее.

  2. Откройте окно семантической информации ( [image] ).

  3. Убедитесь в том, что количество записей в базе соответствует количеству объектов на карте. Для обновления числа записей нажмите кнопку [image] .

    [Примечание] Примечание

    Несоответствие количеству записей и объектов в базе может быть в следующих случаях:

    • при начале работы с базой данных, то есть когда графические объекты уже нанесены на карту, а записи в базе данных еще не созданы (если не настроено добавление пустых записей), тогда в заголовке окна семантической информации имеется надпись Нет данных. В слоях, созданных в текущей версии по умолчанию данная опция установлена;

    • при удалении графических объектов (или группы объектов), в этом случае ZuluGIS без определенных настроек не удаляет записи в подключенной семантической базе данных для сохранения целостности данных в СУБД на случай отмены операции удаления.

  4. В окне семантической информации выберите вкладку Запрос.

    Окно семантической информации. Вкладка Запрос

    Рисунок 783. Окно семантической информации. Вкладка Запрос

  5. При необходимости очистите поля запроса с помощью кнопки [image] .

  6. Напишите условия запроса. Операторы для запросов могут выбираться из списка или вноситься с клавиатуры. Список операторов открывается нажатием кнопки [image] . Для внесения изменений используется оператор ИЗМЕНИТЬ/CHANGETO. Кроме операторов из списка возможно использовать функции, которые поддерживает используемая база данных (как посмотреть какой источник данных используется). Подробней об условиях запросов.

    [Примечание] Примечание

    Условия запроса могут быть сохранены и в дальнейшем при необходимости загружены.

  7. По умолчанию в текущей версии стоит запрет на выполнение массового изменения данных сразу по всем объектам слоя с использованием оператора обновления ИЗМЕНИТЬ/CHANGETO. Запрос с данным оператором допускается выполнять только по группе выделенных объектов. Если запрос выполняется с использованием оператора ИЗМЕНИТЬ/CHANGETO или других операторов, но не для всей базы данных, а для определённой группы объектов, убедитесь, что в окне семантической информации активирована соответствующая кнопка. .

    [Примечание] Примечание

    Вы можете снять требование на ограничение по группе (как это было в 8 и предыдущих версиях программы) как это сделать можно узнать в разделе Настройка работы с оператором ИЗМЕНИТЬ (CHANGETO).

  8. Для выполнения запроса нажмите кнопку [image] . В зависимости от вида запроса по результатам будет открыта определенная вкладка. Если производится запрос на выборку информации, то откроется вкладка Ответ, со списком строк, удовлетворяющих результату запроса. Если же выполнялся запрос на изменение (ИЗМЕНИТЬ), то есть внесение новой информации в базу. То в этом случае появится окно подтверждения запроса со следующим текстом: Будет модифицировано следующее число записей N. Подтвердите выполнение изменений. Где N-изменяемое количество записей. Обратите внимание на то чтобы значение N соответствовало количеству объектов, которым необходимо внести изменения в базу. Для подтверждения выполнения запроса нажмите кнопку Да.


Общие сведения

  • «Описание идентификаторов, констант, функций и операторов»

Условия запроса вводятся в оно семантической информации, вкладка Запрос:

Окно семантической информации. Вкладка Запрос

Рисунок 784. Окно семантической информации. Вкладка Запрос

Любая запись в строке запроса поля базы данных интерпретируется как условие соответствия значения указанного поля значению, введенному в строке.

Условия запроса могут быть записаны как на одной строке, так и на нескольких. Если используется несколько условий в одной строке, то их следует отделять запятой: <Выражение 1>,< Выражение 2>,< Выражение3>. Если условия записаны сразу в нескольких строках запроса, то при формировании строк ответа эти условия объединяются логической функцией И (AND). То есть если на строке Улица записать Лермонтова, в строке Номер дома 5. То в результате выполнения запроса будут найдены дома данные которых совпадают с запросом - по улице Лермонтова дом 5.

При задании условий запроса в системе ZuluGIS можно использовать константы, идентификаторы, функции, операторы. Функции и операторы вносятся как вручную так и выбираются из прикрепленного списка. Для открытия списка надо нажать кнопку [image] . При внесении вручную регистр не влияет на результат, для системы оператор ИЗМЕНИТЬ и изменить интерпретируется одинаково.

Окно семантической информации. Список операторов

Рисунок 785. Окно семантической информации. Список операторов

Операторы и функции могут отображаться как на русском, так и на английском языке. Для того, чтобы настроить язык отображения надо в окне семантической информации, во вкладке Запрос сделать щелчок правой кнопкой мыши, в появившемся контекстном меню выбрать пункт Язык ключевых слов и выбрать нужный язык.

Выбор языка для отображения операторов

Рисунок 786. Выбор языка для отображения операторов

«Описание идентификаторов, констант, функций и операторов»


Описание идентификаторов, констант, функций и операторов

Идентификаторы

Это названия полей базы данных, при этом каждое поле имеет свой уникальный псевдоним, который можно использовать при написании запросов. Псевдонимы отображаются в окне семантической информации, во вкладке Запрос справа от каждого поля.

Псевдоним может использоваться в сочетании с операторами например: для копирования данных из одного поля в другое, для сложения/вычитания/деления данных цифровых полей, для конкатенации (объединения строк) и др. Например, F4 + F5, то есть выбрать те записи, у которых значение поля равно сумме полей с псевдонимами F4 и F5. По мимо цифровых псевдонимов в условиях могут быть использованы названия полей, при чем как исходных табличных так и псевдонимов. Их следует писать в скобках и кавычках. Например, F("H_pod") или field("Располагаемый напор, м").

Так же идентификаторы могут использоваться для написания более сложных условий запроса, например: (F7>0 AND F8 > 0) OR F9>0. В данном случае условия необходимо заносить в верхнюю строку *.

Константы

Используют для сравнения со значениями в полях таблиц, могут быть строковыми, числовыми. Тип константы (значение, с которым необходимо сравнивать значения в поле таблицы) должен совпадать с типом данных в этом поле. То есть, если поле является числовым, то и сравнивать нужно с числом. В противном случае возникает сообщение о несоответствии типов.

При поиске информации в полях типа строковое возможно вводить не полное значение, а использовать маску поиска, с применением * (например, маске *Невск* соответствует «Невский проспект» и «Невская улица»). Для точного поиска через условие «равно» условие следует задавать в кавычках, например следующим образом: ="ТК-1".

При вводе констант строкового типа по умолчанию учитывается регистр, если требуется чтобы он не учитывался, то следует снять соответствующую опцию. Для этого надо открыть окно семантической информации, выбрать вкладку Запрос, сделать щелчок правой кнопкой мыши и в открывшемся меню снять опцию Учитывать регистр.

Для числовых полей условие отбора может содержать просто число (при проверке на равенство), а также операторы сравнения (> – больше, < – меньше, >= – больше либо равно, <= – меньше либо равно, <> – не равно).

Так же для числовых полей могут быть использованы более сложные условия с применением различных идентификаторов и операторов описанных далее, например (F7 > 0 OR F8 > 0) AND F9 < 0. Такого типа запросы пишутся в самую верхнюю строку, обозначенную *.

Функции

Встроенные функции системы, такие как суммирование, нахождение минимального, максимального значения и т. д. Следует учитывать, что такие функции, как нахождение среднего, минимального или максимального значения можно применять только к числовым полям. В противном случае появляется сообщение о несоответствии типов.

[Примечание] Примечание

Текущая версия позволяет по мимо «встроенных» функций, которые возможно открыть нажатием кнопки [image] использовать некоторые функции, которые поддерживает целевая СУБД. Их необходимо вносить с клавиатуры.

Операторы

Таблица 7.

+ | ИЗМЕНИТЬ (CHANGETO) | ТИП (TYPE)
- | ПУСТО (BLANK) | РЕЖИМ (MODE)
* | , | ДЛИНА (LENGTH)
/ | ЧИСЛО (COUNT) | ПЕРИМЕТР (PERIMETER)
= | СРЕДНЕЕ (AVG) | ПЛОЩАДЬ (AREA)
<,> | СУММА (SUM) | ДЛИНА_СФ (LENGTH_SPH)
<=,>= | МАКС (MAX) | ПЕРИМЕТР_СФ (PERIMETER_SPH)
<> | МИН (MIN) | ПЛОЩАДЬ_СФ (AREA_SPH)
|| | ROUND | ТЕКСТ (TEXT)

Ряд операторов и функций, которые возможно использовать при написании запросов, описаны в таблице ниже:

Таблица 8.

Оператор

Пояснение
+ При использовании с цифровым типом данных - оператор сложения. При использовании с строковым типом данных - оператор конкатенации (объединения).

Например, в результате запроса для строковых данных вида ИЗМЕНИТЬ F2+" д. "+F3 система объединит данные строк F2 и F3, и между ними подставит букву д.:

Окно семантической информации. Вкладка Запрос

Рисунок 787. Окно семантической информации. Вкладка Запрос
- Оператор вычитания. Используется с цифровым типом данных.
* Оператор умножения. Используется с цифровым типом данных.
/ Оператор деления. Используется с цифровым типом данных.
= Оператор сравнения. Используется как для цифровых полей так и для строковых, во втором случае константа для сравнения пишется в кавычках.
<, > Операторы сравнения, > – больше, < – меньше, применяются к цифровым полям.
<=,>= Операторы сравнения, >= – больше либо равно, <= – меньше либо равно, применяются к цифровым полям.
<> Оператор сравнения, <> – не равно.
|| Оператор конкатенации (объединения строк). Работает аналогично + со строковым типом данных.

НЕ (NOT), И (AND), ИЛИ (OR)

Логическое НЕ , И, ИЛИ.

ИЗМЕНИТЬ (CHANGETO)

[Предупреждение] Предупреждение

Операция обновления возврата (отката) НЕ ИМЕЕТ!

Оператор обновления данных. После оператора ИЗМЕНИТЬ (CHANGETO) указывается значение, которое будет присвоено сразу всем объектам по которым выполняется запрос. Запрос может выполняться только если выделена группа объектов и нажата кнопка фильтр по группе [image] . Существует множество способов для добавления объектов группу, все они рассмотрены здесь.

[Примечание] Примечание

Можно снять требование ограничение по группе (как это было в 8 и предыдущих версиях программы ) как это сделать можно узнать в разделе «Настройка работы с оператором ИЗМЕНИТЬ (CHANGETO)».

Для полей текстового формата данные, на которые надо заменить значение поля вносятся в кавычках, например ИЗМЕНИТЬ "Некрасова".

Для числовых полей поля кавычки не нужны. Например, в результате запроса вида ИЗМЕНИТЬ 0.2, в указанных полях будет внесено 0.2.

Запрос может выполняться по всем объектам группы или по объектам, удовлетворяющим условиям выбора. Условие выбора может указываться как в соседних полях, так и в поле, к которому выполняется запрос.

Окно семантической информации. Вкладка Запрос

Рисунок 788. Окно семантической информации. Вкладка Запрос

ПУСТО (BLANK)

Логический оператор. Принимает значение истина если поле пусто. Может использоваться для поиска полей в которых отсутствуют данные. Используется самостоятельно или в комбинации с другими операторами, например с ИЗМЕНИТЬ.

Например, в результате запроса вида ПУСТО , ИЗМЕНИТЬ "ГУП ТЭК", система найдет пустые поля и только для них внесет значение ГУП ТЭК.

Окно семантической информации. Вкладка Запрос

Рисунок 789. Окно семантической информации. Вкладка Запрос

,

Запятая, оператор разделения условий.

ЧИСЛО (COUNT)

Оператор подсчета количества записей, удовлетворяющих остальным условиям. Результат запроса появится в закладке Ответ. С помощью него возможно подсчитать количество домов на определенной улице, количество трубопроводов определенного диаметра, количество отключенных потребителей и т.д.

Например, для подсчета количества участков, у которых внутренний диаметр подающего трубопровода 0,2 м надо написать следующий запрос:

Окно семантической информации. Вкладка Запрос

Рисунок 790. Окно семантической информации. Вкладка Запрос

СРЕДНЕЕ (AVG)

Оператор подсчета среднего значения поля. Результат запроса появится в закладке Ответ.

Например, для подсчета среднего количества жителей в 5 этажных домах выделенного квартала (нажата кнопка фильтр по группе - [image] ), надо написать следующий запрос:

Окно семантической информации. Вкладка Запрос

Рисунок 791. Окно семантической информации. Вкладка Запрос

СУММА (SUM)

Оператор подсчета суммы значений. Результат запроса появится в закладке Ответ.

Например, для подсчета суммарной длины подающего трубопровода диаметром 0.2 м для всей сети, надо написать следующий запрос:

Окно семантической информации. Вкладка Запрос

Рисунок 792. Окно семантической информации. Вкладка Запрос

МАКС (MAX)

Оператор подсчета максимального значения поля. Результат запроса появится в закладке Ответ.

Например, для нахождения максимального значения геодезической отметки у потребителей, надо написать следующий запрос:

Окно семантической информации. Вкладка Запрос

Рисунок 793. Окно семантической информации. Вкладка Запрос

МИН (MIN)

Оператор подсчета минимального значения поля. Результат запроса появится в закладке Ответ.

ROUND Функция округления, производит округление данных, возвращает числовое значение, округленное до указанной длины или точности.

Данной функции нет в списке, вносится в поле вручную. Формат ее аргументов зависит от используемой СУБД. Например в Microsoft SQL Server она принимает 2 или 3 аргумента (https://learn.microsoft.com/ru-ru/sql/t-sql/functions/round-transact-sql?view=sql-server-ver16) и округление до 2-х знаков после запятой выглядит так: ROUND(…, -2).

В SQLite она тоже есть, но принимает 1 или 2 аргумента (https://www.w3resource.com/sqlite/core-functions-round.php) и округление до 2-х знаков после запятой выглядит так: ROUND(…, 2).

Например, если используется SQLite, то для округления внесенной площади до 1 знака после запятой, надо написать следующий запрос:

Окно семантической информации. Вкладка Запрос

Рисунок 794. Окно семантической информации. Вкладка Запрос

Так же помимо приведенных выше операторов и функций существуют дополнительные параметры:

Таблица 9.

Оператор

Пояснение

ТИП (TYPE)

Параметр возвращает объекты, относящиеся к заданному типу (ID объекта). Результат запроса появится в закладке Ответ. Записывается в виде ТИП =X, где X номер типа в структуре слоя.

РЕЖИМ (MODE)

Параметр возвращает объекты, относящиеся к заданному режиму объекта. Результат запроса появится в закладке Ответ. Записывается в виде РЕЖИМ =Y, где Y порядковый номер режима в структуре слоя.

Например, для вывода списка отключенных потребителей в выделенном районе (нажата кнопка фильтр по группе - [image] ), надо написать следующий запрос:

Окно семантической информации. Вкладка Запрос

Рисунок 795. Окно семантической информации. Вкладка Запрос

ДЛИНА (LENGTH)

Параметр возвращает длину объекта, взятую с карты. Используется при локальной системе координат. Результат запроса появится в закладке Ответ. Для внесения длинны в определенное поле оператор используется совместно с оператором ИЗМЕНИТЬ.

ПЕРИМЕТР (PERIMETER)

Параметр возвращает периметр объекта, взятый с карты. Используется при локальной системе координат. Результат запроса появится в закладке Ответ. Для внесения периметра в определенное поле оператор используется совместно с оператором ИЗМЕНИТЬ.

ПЛОЩАДЬ (AREA)

Параметр возвращает площадь объекта, взятую с карты. Используется при локальной системе координат. Результат запроса появится в закладке Ответ. Для внесения площади в определенное поле оператор используется совместно с оператором ИЗМЕНИТЬ.

ДЛИНА_СФ (LENGTH_SPH)

Параметр возвращает длину объекта, взятую с карты. Используется при географической системе координат. Результат запроса появится в закладке Ответ.

ПЕРИМЕТР_СФ (PERIMETER_SPH)

 Параметр возвращает периметр объекта, взятый с карты. Используется при географической системе координат. Результат запроса появится в закладке Ответ.

ПЛОЩАДЬ_СФ (AREA_SPH)

 Параметр возвращает длину объекта, взятую с карты. Используется при географической системе координат. Результат запроса появится в закладке Ответ.

Например, для внесения площади выделенных домов (нажата кнопка фильтр по группе - [image] ) в соответствующее поле, надо написать следующий запрос:

Окно семантической информации. Вкладка Запрос

Рисунок 796. Окно семантической информации. Вкладка Запрос

Округлить внесенные данные возможно с использованием функции ROUND.

ТЕКСТ (TEXT) Параметр возвращает текстовое значение объекта. Данный оператор может использоваться в том случае, если например имеется слой с высотными отметками в виде текстовых объектов и требуется их значения перенести в семантическую базу данных. Для этого в базе должно быть создано поле для отметок и в нем выполнен запрос вида ИЗМЕНИТЬ ТЕКСТ.


Настройка работы с оператором ИЗМЕНИТЬ (CHANGETO)

По умолчанию стоит запрет на выполнение массового изменения данных сразу по всем объектам слоя с использованием операторов обновления, таких как ИЗМЕНИТЬ «текст» или ИЗМЕНИТЬ число (CHANGETO «текст» или CHANGETO число). Допускается выполнять изменение только по группе выделенных объектов.

При попытке сделать изменения по всем объектам базы без выделения группы появится сообщение:

Сообщение о запрете операции

Рисунок 797. Сообщение о запрете операции

[Предупреждение] Предупреждение

Поскольку операция обновления с использованием оператора ИЗМЕНИТЬ (CHANGETO) НЕ ИМЕЕТ функции отката, вы должны осознавать, что при снятии ограничения на изменения только по группе объектов неопытный пользователь может случайно внести необратимые изменения в данные.

За управление правилами выполнения запросов на изменение с оператором ИЗМЕНИТЬ (CHANGETO), отвечает опция restrict-changeto в файле DataSrc.cfg:

  • restrict-changeto отсутствует - стоит запрет на выполнение запроса на изменение без выделения группы;

  • restrict-changeto: yes - стоит запрет на выполнение запроса на изменение без выделения группы;

  • restrict-changeto: no - выполнение запроса на изменение без выделения группы разрешено.

Для снятия запрета

Если слой открыт с ZuluServer (в многопользовательском режиме), настройки необходимо выполнять за серверным компьютером:

  1. Перейдите за компьютер, где установлен ZuluServer.

  2. Найдите файл DataSrc.cfg, он располагается в папке, куда устанавливался ZuluServer. По умолчанию для установки программы предлагается директория Zulu 2021 внутри Program Files (или Program Files (x86) для 32-битных версии).

  3. Откройте его любым текстовым редактором, к примеру Блокнотом.

  4. Пропишите опцию restrict-changeto: no

  5. Сохраните изменения и перезапустите ZuluServer.

Если слой открыт локально (в однопользовательском режиме), настройки необходимо выполнять непосредственно за компьютером, на котором работаете:

  1. Закройте ZuluGIS.

  2. Найдите файл DataSrc.cfg, располагается он в папке, куда устанавливалась ZuluGIS. По умолчанию для установки программы предлагается директория Zulu 2021 внутри Program Files (или Program Files (x86) для 32-битных версии).

  3. Откройте его любым текстовым редактором, к примеру Блокнотом.

  4. Пропишите restrict-changeto: no.

  5. Сохраните изменения и перезапустите ZuluGIS.


Обновление числа записей базы данных

В текущей версии системы слои создаются с уже имеющимися определенными настройками правил редактора слоя, в результате которых например при добавлении объекта на карту к нему добавляется пустая строка в базу данных. Обратная ситуация возникает при удалении объектов с карты. В этом случае система не удаляет записи в подключенной семантической базе данных для сохранения целостности данных в СУБД на случай отмены операции удаления. Поэтому после активного графического редактирования объектов перед работой с базой данных рекомендуется привести в соответствие количество графических объектов и записей в семантической базе данных.

В слоях созданных в более ранних версиях настройки правил для слоя автоматически не создаются, но их можно при желании создать самостоятельно. В том случае, если данные по объектам заполняются поштучно через окно семантической информации, запись будет создана автоматически. Если же для заполнения надо воспользоваться запросами, то предварительно необходимо привести в соответствие количество графических объектов и количество записей.

Обновление числа записей базы данных в ZuluGIS возможно через:

  • заполнение базы данных пустыми записями - создание пустых записей для новых объектов;

  • сжатие базы данных - удаление тех записей из базы, которые не привязаны к графическим объектам.

Одновременно и сжать и заполнить базу возможно через окно семантической информации. Для этого надо открыть окно по нужной базе и нажать кнопку [image] . После чего система выдаст соответствующее сообщение, в котором будет указано количество удаляемых и добавляемых записей:

Сообщение об обновлении числа записей

Рисунок 798. Сообщение об обновлении числа записей

Для подтверждения процедуры обновления числа записей надо нажать кнопку Да, для отмены Нет.

Отдельно сжать или заполнить базу возможно через диалоговое окно Базы данных, для этого надо:

  1. Выбрать меню Карта|Запрос|По базе данных;

    или

    нажать на панели инструментов кнопку [image] ;

    или

    сделать щелчок правой кнопкой мыши по разделу Базы данных в панели Рабочее место и выбрать в открывшемся контекстном меню пункт Базы;

    или

    сделать двойной щелчок левой кнопкой мыши по разделу Базы данных в панели Рабочее место.

  2. Выделить в списке нужную базу или слой, базы которого надо сжать или заполнить.

  3. Для сжатия базы нажмите кнопку Сжать.

    Для заполнения базы нажмите кнопку Заполнить.

Так же по мимо выше описанных вариантов заполнить и сжать базы можно сделав щелчок правой кнопкой мыши по разделу Базы данных или по конкретной базе слоя в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Сжать все базы слоя/Заполнить все базы слоя или Сжать/Заполнить соответственно.


Отображение результатов запроса к базе данных на карте

Кроме подсветки элементов при перемещении с записи на запись в закладке Ответ, тот же результат можно получить, нажав кнопку [image] в режиме Текущая запись. Вместе с этим существует возможность изменять группу выделенных элементов слоя в соответствии с результатами запросов.

Для этого после выполнения запроса надо нажать стрелку кнопки [image] , которая вызовет открывающееся меню.

В этом меню выбрать пункт, в зависимости от того, как следует отметить элементы, удовлетворяющие условию запроса:

Рисунок 799. Контекстное меню

  • Для того, чтобы отметить на карте только элементы, удовлетворяющие условиям запроса, выбрать пункт Выделить. Имеющаяся группа выделенных элементов, если такая была, будет заменена новым множеством элементов.

  • Для того, чтобы элементы, удовлетворяющие условиям запроса, добавить к имеющейся группе выделенных элементов, выбрать пункт меню Добавить в группу. Если же группа еще не была создана до этого, то результат операции идентичен команде Выделить.

  • Наконец, для того, чтобы элементы, удовлетворяющие условиям запроса, исключить из имеющейся группы выделенных элементов, выбрать пункт Исключить из группы.


Сохранение условий запроса

Для того чтобы сохранить условия запроса:

  1. Сделайте щелчок правой кнопкой мыши в окне семантической информации на вкладке Запрос, в открывшемся контекстном окне выберите пункт Сохранить запрос:

    Рисунок 800. Контекстное меню

  2. Условия запроса можно сохранить как в сам слой так и на диск. В первом случае сохраненные условия могут загружаться только в этот слой, во втором случае в дальнейшем условия могут быть загружены и импортированы в другие слои. Для сохранения запроса в слой укажите название сохраняемого запроса в верхней строке диалогового окна Сохранить запрос и нажмите кнопку Сохранить.

    Если условия надо сохранить на диске, тогда в окне Сохранить запрос нажмите кнопку Сохранить на диске…, укажите путь и дайте название файлу в котором будет сохранен запрос. В результате операции в указанной папке будет сохранен файл с введенным названием и расширением *.zq.

[Примечание] Примечание

Сохраненный запрос можно будет загрузить или импортировать.

Для загрузки ранее сохраненных условий запроса в контекстном меню, изображенном на рисунке выше надо выбрать пункт Загрузить запрос.


Загрузка и импорт условий запроса

Загрузить ранее сохраненные запросы можно как из самого слоя, так и с диска. Во втором варианте по мимо загрузки условия запроса могут быть импортированы в слой. Для загрузки или импорта условий запроса:

  1. Сделайте щелчок правой кнопкой мыши в окне семантической информации на вкладке Запрос, в открывшемся контекстном окне выберите пункт Загрузить запрос:

    Рисунок 801. Контекстное меню

  2. Если нужный запрос есть в списке сохраненных запросов, то для его загрузки выделите его и нажмите кнопку Открыть. Или сделайте на нем двойной щелчок левой кнопкой мыши.

    Если запроса для загрузки в списке нет, то его можно загрузить с диска или импортировать. В первом варианте для повторной загрузки запроса его снова придется загружать с диска. Во втором варианте после импорта запрос будет добавлен в список запросов слоя и в дальнейшем для загрузки его надо будет просто выбирать из списка. При импорте условий запроса в слой дополнительно необходимо будет задать им название.


Сохранение результатов запроса

После выполнения запроса его результаты можно сохранить, для этого:

  1. В окне семантической информации на вкладке Ответ, Статистика или База нажмите кнопку [image] или комбинацию клавиш Ctrl+S.

  2. В открывшемся окне укажите путь и дайте название таблице, в которой будет сохранен запрос.

  3. Нажмите кнопку Сохранить.

Для просмотра результата надо выбрать в главном меню Таблица, пункт Просмотр.


Примеры работы с семантической информацией

Все приведенные ниже примеры показаны на основе карты Пример тепловой сети, которая устанавливается вместе с системой. Открыть папку с картой можно или через кнопку Пуск/Примеры или напрямую с диска. Карта расположена в той же папке где и система, в каталоге Examples\Termo\Kvartal. Для открытия сделайте двойной щелчок на файле TeploNet.zmp в указанной папке.

Ниже будут рассмотрены «Примеры запросов к семантическим базам данных».

Перед работой с примерами проверьте, что в карту загружены слои Кварталы, Здания, Надписи, Пример тепловой сети. Убедитесь, что к слою Здания подключена база данных. Для этого в меню Слой выберите пункт Структура слоя (слой в этот момент НЕ должен быть редактируемым), слева в дереве выберите пункт Примитивы, после чего справа должна открыться вкладка с прикрепленной базой:

Окно структуры слоя

Рисунок 802. Окно структуры слоя

[Примечание] Примечание

Во всех приведенных ниже примерах используется отображение операторов на русском языке.

Чтобы выполнить любой запрос обязательно надо открыть окно семантической информации по нужному слою, для этого:

  1. Выберите инструмент [image] - получение информации по объекту.

  2. Установите активным слой Здания.

  3. Щелкните по любому объекту этого слоя.

Скопировать группу значений из строки базы данных

  1. В окне семантической информации во вкладке Текущая запись сделайте щелчок правой кнопкой мыши.

  2. В открывшемся контекстном меню выберите пункт Копировать значения.

  3. Щелкните на любом другом объекте того же слоя.

  4. Нажмите правую клавишу мыши и выберите пункт Вставить значения.

В результате значения всех полей нового объекта будут заменены на значения полей первоначально выбранного объекта.

Найти определенное значение в колонке

  1. В окне семантической информации откройте вкладку База или Ответ.

  2. Установите курсор в колонку, в которой необходимо осуществить поиск.

  3. Нажмите кнопку [image] .

  4. В открывшемся окне введите значение для поиска и нажмите кнопку ОК.


Примеры запросов к семантическим базам данных

[Примечание] Примечание

На нашем сайте вы можете просмотреть уроки по работе с запросами: Изменение информации, Выполнение запросов и Просмотр информации. Выполнение запросов.

Далее рассмотрены следующие примеры:

  • «Просмотреть информацию по всем домам, находящимся на 5-ом Южном переулке»;

  • «Найти на 5-ом Южном переулке все дома, площадь которых больше или равна 2000 м2»;

  • «Подсчитать количество домов по 2-ому Южному переулку»;

  • «Заполнить поле Квартал для всех домов 1-ого Южного переулка, у которых квартал не задан значением 103»;

  • «Выбрать из базы строки, у которых значение поля Улица 1-ый Южный переулок или 3-й Южный переулок»;

  • «Занести для группы участков одинаковое значение Внутреннего диаметра подающего трубопровода»;

  • «Скопировать данные из поля Внутренний диаметр подающего трубопровода, м, в поле Внутренний диаметр обратного трубопровода, м»;

  • «Вывести список участков, у которых длинна >70 м и внутренний диаметр подающего трубопровода <0.25 м»;

  • «Подсчитать суммарную длину подающего трубопровода с внутренним диаметром 0.1 м»;

  • «Перенести значение диаметра трубопровода в новую строку и перевести это значение в миллиметры»;

  • «Вывести данные по отключенным потребителям и подсчитать их количество»;

  • «Заменить название улицы»;

  • «Округлить площадь дома до двух знаков после запятой».


Просмотреть информацию по всем домам, находящимся на 5-ом Южном переулке

Чтобы выполнить запрос к базе данных:

  1. В окне семантической информации откройте вкладку Запрос.

  2. В строке Улица напишите: 5й Южный пер.

  3. Нажмите кнопку [image] .

Пример задания запроса

Рисунок 803. Пример задания запроса

В результате откроется вкладка Ответ, в таблицу попадут только те записи, которые удовлетворяли условиям запроса, то есть только дома 5-го Южного переулка.

Результат выполненного запроса

Рисунок 804. Результат выполненного запроса

При переходе от одной записи к другой во вкладке Ответ на карте автоматически будут отображаться объекты, соответствующие этим записям (мигающий прямоугольник на объекте).

Теперь выделим на карте группу зданий по результатам запроса. Для этого щелкните по стрелке кнопки [image] и в открывшемся меню выберите команду Выделить. В результате все здания по 5-ому Южному переулку будут выделены.


Найти на 5-ом Южном переулке все дома, площадь которых больше или равна 2000 м2

1 способ (только если по результатам предыдущего запроса была выделена группа объектов):

  1. В окне семантической информации откройте вкладку Запрос, проверьте чтобы был включен режим фильтра по группе – нажата кнопка [image] .

  2. В строке Площадь введите условие >=2000 (строка Улица пустая).

  3. Нажмите кнопку [image] .

    Пример создания запроса по группе

    Рисунок 805. Пример создания запроса по группе

2 способ:

  1. В окне семантической информации откройте закладку Запрос.

  2. В строке Улица напишите: 5й Южный пер.

  3. В строке Площадь введите условие >=2000 (для выбора операторов воспользуйтесь кнопкой [image] ). Проверьте чтобы кнопка фильтр по группе не была нажата [image] .

  4. Нажмите кнопку [image] .

Пример создания запроса

Рисунок 806. Пример создания запроса

В результате в ответ вошли только дома по 5-ому Южному переулку, площадь которых >=2000. Можно выделить эту группу домов. Для этого нажмите стрелку у кнопки [image] и выберите команду Выделить.


Подсчитать количество домов по 2-ому Южному переулку

  1. В окне семантической информации откройте вкладку Запрос.

  2. В строке Улица наберите: ЧИСЛО , 2й Южн* (для выбора операторов воспользуйтесь кнопкой [image] ).

    ЧИСЛО (COUNT) – оператор подсчета количества записей;

    2й Южн* – условие выбора только домов по 2-ому Южному переулку (* заменяет любое количество любых символов);

    , – разделитель между операторами.

  3. Нажмите кнопку [image] .

Пример создания запроса

Рисунок 807. Пример создания запроса

После выполнения запроса откроется вкладка Статистика и выдаст число – суммарное количество домов по 2-ому Южному переулку.


Заполнить поле Квартал для всех домов 1-ого Южного переулка, у которых квартал не задан значением 103

  1. Выделите на карте дома, с которыми будет производиться работа.

  2. Откройте окно семантической информации по участкам, выберите вкладку Запрос.

  3. Проверьте чтобы был включен фильтр по группе - нажата кнопка [image] .

  4. В строке Квартал наберите: ПУСТО, ИЗМЕНИТЬ "103" (для выбора операторов воспользуйтесь кнопкой [image] ).

  5. В строке Улица наберите 1й Южн*.

  6. Нажмите кнопку [image] . После чего появится сообщение: Будет модифицировано следующее число записей: n. Подтвердите выполнение изменений. Нажмите кнопку Да.

Пример создания запроса

Рисунок 808. Пример создания запроса

В результате запроса во всех домах 1-ого Южного переулка, у которых не задано значение квартала, значение будет занесено 103.


Выбрать из базы строки, у которых значение поля Улица 1-ый Южный переулок или 3-й Южный переулок

  1. В оокне семантической информации откройте вкладку Запрос.

  2. В строке Улица напишите: 1й Южн* ИЛИ 3й Южн*.

  3. Нажмите кнопку [image] .


Занести для группы участков одинаковое значение Внутреннего диаметра подающего трубопровода

В данном примере используется семантическая база данных Участок (Uch.zb), которая присоединена к типовому объекту Участок слоя Пример тепловой сети (\Examples\Termo\Kvartal).

Для ее открытия:

  1. Откройте карту Пример тепловой сети (если она еще не открыта).

  2. Выберите инструмент [image] - получение информации по объекту.

  3. Установите активным слой Пример тепловой сети.

  4. Щелкните по любому участку этого слоя, откроется окно окне семантической информации.

  5. Выделите на карте группу участков, для которых вы хотите задать одинаковое значение диаметра.

  6. Проверьте чтобы был включен фильтр по группе - нажата кнопка [image] .

  7. Во вкладке Запрос в строке Внутренний диаметр подающего трубопровода наберите: ИЗМЕНИТЬ 0.05.

  8. Выполните запрос кнопкой [image] . После чего появится сообщение: Будет модифицировано следующее число записей: n, где n- количество выделенных участков. Подтвердите выполнение изменений. Нажмите кнопку Да.

Результат: после выполнения запроса все участки, входящие в выделенную группу в строке Внутренний диаметр подающего трубопровода будут содержать значение 0.05. Если в выбранной группе объектов в поле Внутренний диаметр подающего трубопровода уже стояло какое либо значение, то оно так же будет заменено на 0.05.

Если значение надо внести только в пустые строки, то условия запроса будут выглядеть так: ПУСТО, ИЗМЕНИТЬ 0.05.


Скопировать данные из поля Внутренний диаметр подающего трубопровода, м, в поле Внутренний диаметр обратного трубопровода, м

  1. Выделите на карте группу участков, для которых будут копироваться данные.

  2. Откройте окно семантической информации по участкам, выберите вкладку Запрос.

  3. Проверьте чтобы был включен фильтр по группе - нажата кнопка [image] .

  4. В строке Внутренний диаметр обратного трубопровода, м введите: ИЗМЕНИТЬ F7, где F7 - это псевдоним поля Внутренний диаметр обратного трубопровода, м.

  5. Нажмите кнопку [image] . После чего появится сообщение: Будет модифицировано следующее число записей: n, где n- количество выделенных участков. Подтвердите выполнение изменений. Нажмите кнопку Да.

    Пример создания запроса

    Рисунок 809. Пример создания запроса

Результат: после выполнения запроса по всем объектам данные из поля F7 (Внутренний диаметр подающего трубопровода,м) будут скопированы в поле F7 (Внутренний диаметр обратного трубопровода, м).


Вывести список участков, у которых длинна >70 м и внутренний диаметр подающего трубопровода <0.25 м

  1. В окно семантической информации по участкам откройте вкладку Запрос.

  2. Поскольку поиск мы будем осуществлять по всей базе, а не по конкретной группе объектов, убедитесь, что фильтр по группе отключен. Для этого проверьте, не нажата ли кнопка [image] .

  3. В строке Длина участка введите >70.

  4. В строке Внутренний диаметр подающего трубопровода введите: <0.25.

  5. Нажмите кнопку [image] .

Пример создания запроса

Рисунок 810. Пример создания запроса

Результат: после выполнения запроса откроется вкладка Ответ, и в ней будет отображен список участков, соответствующих заданным параметрам.


Подсчитать суммарную длину подающего трубопровода с внутренним диаметром 0.1 м

  1. В окно семантической информации по участкам откройте вкладку Запрос.

  2. В строке Длина участка выберите оператор СУММА.

  3. В строке Внутренний диаметр подающего трубопровода, м введите: 0.1.

  4. Нажмите кнопку [image] .

    Пример создания запроса

    Рисунок 811. Пример создания запроса

В результате будет подсчитана суммарная длинна подающих трубопроводов диаметра 0.1 метр. В том случае, если поле Внутренний диаметр подающего трубопровода, м оставить не заполненным, то будет подсчитана суммарная длинна всех подающих трубопроводов, независимо от диаметра.

Если же заранее выделить группу трубопроводов, поле Внутренний диаметр подающего трубопровода, м оставить не заполненным, и затем перед выполнением запроса нажать кнопку фильтр по группе - [image] , то будет подсчитана суммарная длинна выделенных трубопроводов.


Перенести значение диаметра трубопровода в новую строку и перевести это значение в миллиметры

Предположим, пользователю необходимо видеть значение диаметров трубопровода не в метрах, а в миллиметрах. Текущая версия программы позволяет изменять единицы измерения для диаметров участков, выбрать можно метры или миллиметры. В ранних версиях диаметр указывался только в метрах. Рассмотрев данный пример вы сможете переводить в нужные единицы измерения любое поле базы.

Сначала добавим в базу по трубопроводу дополнительную строку: Внутренний диаметр подающего трубопровода, мм. Для этого:

  1. Выделите на карте группу участков, с которыми будет производиться работа.

  2. Откройте окно семантической информации по трубопроводу.

  3. Сделайте щелчок правой кнопкой мыши в области окна, в появившемся контекстном меню выберите пункт Добавить поле.

    Рисунок 812. Контекстное меню

  4. В окне Добавить поле внесите:

    • Имя - Dpod_new;

    • Пользовательское имя - Внутренний диаметр подающего трубопровода, мм;

    • Тип поля - Вещественное.

      Добавление новой строки

      Рисунок 813. Добавление новой строки

      Нажмите кнопку ОК.

      Добавление строки закончено, срока будет добавлена в самый низ таблицы.

Далее, с помощью запроса скопируем значение трубопровода и умножим его на 1000. Для этого:

  1. В окне семантической информации по участкам откройте вкладку Запрос.

  2. Проверьте, чтобы был включен режим фильтра по группе - нажата кнопка [image] .

  3. В добавленной строке Внутренний диаметр подающего трубопровода, мм введите: ИЗМЕНИТЬ F7*1000, где F7 - псевдоним поля Внутренний диаметр подающего трубопровода, м. То есть, в результате запроса значение поля F7 будет скопировано в данную строку и умножено на 1000 (перевод из м в мм).

    Пример создания запроса

    Рисунок 814. Пример создания запроса

  4. Выполните запрос кнопкой [image] . После чего появится сообщение: Будет модифицировано следующее число записей: n, где n - количество выделенных участков. Подтвердите выполнение изменений. Нажмите кнопку Да.

В результате проделанного запроса данные будут скопированы и одновременно умножены на 100:

Рисунок 815. Результат запроса


Вывести данные по отключенным потребителям и подсчитать их количество

Предварительно отключите несколько потребителей.

Для вывода списка отключенных потребителей:

  1. Откройте окно семантической информации по потребителям, выберите вкладку Запрос.

  2. В строке, помеченной * введите РЕЖИМ=2.

  3. Нажмите кнопку [image] .

    Пример создания запроса

    Рисунок 816. Пример создания запроса

    В результате выполнения запроса откроется вкладка Ответ, в которой будут содержаться данные по всем объектам, у которых режим 2. Режим 2 у потребителей соответствует отключенному состоянию, какой режим какому состоянию соответствует, можно узнать в структуре слоя.

Для того, чтобы подсчитать количество отключенных потребителей:

  1. Откройте окно семантической информации по потребителям, выберите вкладку Запрос.

  2. В строке, помеченной * введите РЕЖИМ=2, ЧИСЛО.

  3. Нажмите кнопку [image] .

    Пример создания запроса

    Рисунок 817. Пример создания запроса


Заменить название улицы

Предположим, переименовали улицу 1й Южный пер. в улицу Лермонтова. То есть необходимо найти объекты по которым произошло переименование и заменить у них название улицы.

  1. Выделите на карте все дома, в которых будет производиться поиск.

  2. Откройте окно семантической информации по ним, выберите вкладку Запрос.

  3. Проверьте, чтобы был включен режим фильтра по группе - нажата кнопка [image] .

  4. В строке Улица напишите: 1й Южный пер., ИЗМЕНИТЬ "Лермонтова". То есть в результате запроса сначала произойдет поиск объектов, у которых внесено значение 1й Южный пер., а затем это значение будет заменено на Лермонтова.

  5. Нажмите кнопку [image] . После чего появится сообщение: Будет модифицировано следующее число записей: n, где n - количество объектов, в которых будет производиться переименование. Подтвердите выполнение изменений. Нажмите кнопку Да.

Пример создания запроса

Рисунок 818. Пример создания запроса

В результате запроса произойдет замена названия одной улицы на другую.


Округлить площадь дома до двух знаков после запятой

В используемом примере в базе данных по зданиям уже имеется поле площадь. Информация в это поле ранее была занесена с использованием оператора ПЛОЩАДЬ_СФ (AREA_SPH). Для ее занесения использовался следующий запрос: ИЗМЕНИТЬ ПЛОЩАДЬ_СФ.

Далее для более удобной работы внесенные данные округлим до 2 знаков после запятой. Округление данных производится с помощью функции ROUND, ее необходимо ввести в поле вручную. Формат ее аргументов зависит от используемой СУБД. Например в Microsoft SQL Server она принимает 2 или 3 аргумента (https://learn.microsoft.com/ru-ru/sql/t-sql/functions/round-transact-sql?view=sql-server-ver16) и округление до 2-х знаков после запятой выглядит так: ROUND(…, -2).

В SQLite она принимает 1 или 2 аргумента (https://www.w3resource.com/sqlite/core-functions-round.php) и округление до 2-х знаков после запятой выглядит так: ROUND(…, 2).

В примере используется база данных SQLite. Как посмотреть свой источник данных можно узнать в разделе «Просмотр источника данных таблиц».

Для округления площади до двух знаков после запятой:

  1. Выделите на карте все дома, у которых будут округляться значения.

  2. Откройте окно семантической информации по ним, выберите вкладку Запрос.

  3. Проверьте, чтобы был включен режим фильтра по группе - нажата кнопка [image] .

  4. В строке Площадь введите: ИЗМЕНИТЬ ROUND (F13, 2).

    Пример создания запроса

    Рисунок 819. Пример создания запроса

  5. Выполните запрос кнопкой [image] . После чего появится сообщение: Будет модифицировано следующее число записей: n, где n - количество выделенных домов. Подтвердите выполнение изменений. Нажмите кнопку Да.

Результат выполнения запроса:

Пример создания запроса

Рисунок 820. Пример создания запроса


Работа с заполненной базой данных (табличными данными)

Работа с заполненной базой данных может состоять из:

  • выборки данных из базы;

  • экспорта данных в Microsoft Excel или электронную таблицу ODS;

  • импорта данных из Microsoft Excel;

  • просмотра и печати отчетов.


Выборка данных из базы

Система позволяет производить различные выборки, необходимые для формирования отчетов. Это возможно как с помощью встроенных запросов, через окно семантической информации, через быстрый поиск, так и с помощью SQL запросов.

[Примечание] Примечание

Видеоурок по работе с табличными данными можно посмотреть пройдя по ссылке: https://youtu.be/X5o_ZMP4uqg.

В дальнейшем отобранную из базы данных информацию возможно:

  • экспортировать в Microsoft Excel или электронную таблицу ODS;

  • просматривать и печатать.

Так же возможен импорт данных из Microsoft Excel в семантическую базу данных.


Экспорт данных

Данные из базы возможно напечатать, экспортировать в Microsoft Excel (*.xls), электронную таблицу ODS (*.ods), или файлы HTML (*.htm):

  • «Экспорт данных в формат Microsoft Excel или электронную таблицу ODS»;

  • «Экспорт данных в HTML страницу».

[Примечание] Примечание

Видеоурок по экспорту данных и печати отчетов можно посмотреть пройдя по ссылке: https://youtu.be/x3KVX2YpO8Q.

Перед началом работы с данными предварительно надо определиться с информацией, которую требуется экспортировать или печатать.

Для вывода всех объектов базы надо сначала открыть окно семантической информации по нужным объектам, затем перейти во вкладку База.

Для вывода информации по определенным объектам предварительно с помощью запроса требуется сделать выборку по объектам.

Так же выбрать объекты, данные по которым надо печатать или экспортировать можно с помощью выделения их на карте и выполнения пустого запроса по базе.


Экспорт данных в формат Microsoft Excel или электронную таблицу ODS

[Примечание] Примечание

С примерами экспорта данных в Excel можно ознакомиться в разделе «Примеры экспорта данных в Microsoft Excel».

В режиме работы окна семантической информации Текущая запись, Ответ или База предусмотрен экспорт соответствующего набор записей в лист Microsoft Excel или электронную таблицу ODS (OpenOffice или LibreOffice) для последующего анализа.

Данные могут быть экспортированы в таблицу как с пользовательскими названиями полей так и с реальными. Экспорт производится с теми названиями, которые отображены в окне. Для смены названий надо сделать щелчок правой кнопкой мыши в области семантического окна и снять или установить опцию Реальные названия полей:

Переключение названий полей

Рисунок 821. Переключение названий полей

Для экспорта данных в Microsoft Excel или электронную таблицу ODS:

  1. В окне семантической информации на вкладке Ответ или База нажмите кнопку [image] .

  2. В диалоговом окне Экспорт в Microsoft Excel из списка Шаблоны отчетов выберите нужный шаблон, при экспорте в Excel используются либо такие же шаблоны как и для печатных отчетов, либо шаблоны на основе файлов шаблонов Excel (формата xlt).

  3. Если не устраивают существующие шаблоны, то нужно нажать кнопку Новый и создать новый шаблон.

  4. В строке Путь к книге Excel нажмите кнопку Обзор..., укажите полный путь до него, затем:

    • для экспорта в книгу Excel из списка тип файла выберите Книга Excel (*.xls);

    • для экспорта в электронную таблицу ODS из списка тип файла выберите Электронная таблица OpenOffice (*.ods).

  5. В строке Имя листа укажите имя листа, на котором будут размещены данные, например Лист1.

    Окно мастера экспорта данных в Microsoft Excel

    Рисунок 822. Окно мастера экспорта данных в Microsoft Excel

  6. Нажмите кнопку Сохранить, после чего ZuluGIS начнет процедуру экспорта, о чем будет информировать индикатор процесса. Процедуру экспорта можно прервать, нажав кнопку Отмена на панели этого индикатора.

    [Примечание] Примечание

    Если при экспорте в электронную таблицу ODS на компьютере не установлены OpenOffice или LibreOffice система выдаст сообщение об ошибке: ошибка использования OpenOffice Calc и остановит процедуру экспорта.

  7. Для просмотра полученных результатов запустите соответствующее программное обеспечение и его средствами откройте созданный файл.


Создание и редактирование шаблонов экспорта данных в Excel

[Примечание] Примечание

Видеоурок по экспорту табличных данных с использованием шаблона Microsoft Excel можно посмотреть пройдя по одной из ссылок: https://youtu.be/YrurN_UNyXQ или https://www.politerm.com/videos/print/export_excel_xlt/.

Предусмотрено создание шаблонов для экспорта данных в Excel как с использованием встроенного механизма системы ZuluGIS, так и с помощью файлов шаблонов программы MS Excel, формата .xlt. Последний вариант предполагает вывод отчетов в виде таблиц с произвольным оформлением с использованием основных средств оформления программы Excel.

Для создания нового шаблона нажмите кнопку Новый в мастере экспорта в Excel, в результате откроется диалог параметров вывода отчета.

Диалог параметров вывода отчета

Рисунок 823. Диалог параметров вывода отчета

Для создания шаблона на базе механизма отчетов ZuluGIS установите переключатель Использовать собственные настройки. Создание подобных отчетов освещено выше, в разделе «Просмотр и печать отчетов».

Для создания шаблона на базе файла шаблона MS Excel:

  1. Установите переключатель Использовать настройки шаблона Excel (подробно см. «Файл шаблона в формате .xlt»).

  2. В поле Файл шаблона укажите путь к файлу шаблона. Для этого, нажмите кнопку [image] справа от поля и укажите в открывшемся диалоге выбора файлов путь к файлу шаблона в формате .xlt.

  3. С помощью переключателя Тип отчета укажите тип отчета формируемого шаблоном, Табличный, либо Свободной формы (подробно см. «Файл шаблона в формате .xlt»), при выборе значения Свободной формы в поле Диапазон области данных также выбирается диапазон шаблона из которого формируется запись отчета.

  4. В таблице Соответствие полей и диапазонов шаблона указывается в каких именованных диапазонах шаблона отображаются поля базы данных. В столбце Поля перечислены поля базы данных, а в столбце Диапазон указываются соответствующие им диапазоны шаблона. По умолчанию, для полей подставляются диапазоны с соответствующими названиями (знаки подчеркивания в названии диапазона рассматриваются как пробелы).

По завершению настройки шаблона нажмите кнопку ОК, чтобы сохранить изменения и закрыть диалог.

[Примечание] Примечание

Существующий шаблон можно отредактировать, для этого в открывающемся списке в мастере экспорта в Excel выберите шаблон для редактирования и нажать кнопку Изменить, после внесения изменений нажмите кнопку ОК. Для удаления ненужного шаблона нажмите кнопку Удалить.


Файл шаблона в формате .xlt

Шаблоны экспорта данных представляют собой файлы в формате шаблонов программы MS Excel (с расширением .xlt). Шаблоны можно создавать «с нуля», либо на базе уже существующих шаблонов.

В шаблонах для вывода данных из базы данных ZuluGIS применяются именованные ячейки и диапазоны ячеек листа Excel. В настройках вывода данных задается соответствие между полями базы данных и именами шаблона. При экспорте данных на базе такого шаблона поля базы данных слоя выводятся в места диапазонов шаблона с соответствующими именами.

Предусмотрены два режима вывода данных с помощью шаблона: табличный и в свободной форме, применяемый способ задается в настройках вывода данных (см. «Создание и редактирование шаблонов экспорта данных в Excel»).

[Примечание] Примечание

Для того чтобы задать имя для диапазона, выделите диапазон на листе MS Excel и введите в поле Имя (располагается с левого края строки формул, в нем отображается адрес текущей ячейки) название.

Для того чтобы изменить название или удалить имя диапазона, выполните команду меню MS Excel Вставить|Имя|Присвоить и в открывшемся диалоге выполните требуемые действия.

[Внимание] Внимание

В названиях полей и диапазонов следует использовать только буквы (латиницу и кириллицу), цифры и знаки подчеркивания (знаками подчеркивания следует использовать вместо пробелов).

Табличный вывод

При табличном выводе, в шаблоне задается строка именованных диапазонов, и отчет формируется в виде таблицы, поля первой записи выводятся в диапазоны с соответствующим именами, вторая запись – в ячейки строкой ниже и т.д. При этом в отчете, над таблицей выводится шапка отчета, строки, располагающиеся в шаблоне над поименованными диапазонами.

Вывод отчета в табличном формате

Рисунок 824. Вывод отчета в табличном формате

Последовательность действий по созданию нового шаблона в табличном виде (на примере MS Excel 2003):

  1. Создайте новую книгу MS Excel.

  2. Добавьте в книгу постоянную информацию, которая должна присутствовать во всех книгах отчетов на базе данного шаблона (Листы с текстом, формулами, графиками и т.д.).

  3. Создайте лист для вывода отчета. В верхней части создайте шапку отчета (Название отчета, заголовки столбцов отчета и т.д.). Под шапкой задайте строку именованных диапазонов (обычно одиночных ячеек), которые будут служить основой таблицы отчета.

  4. Сохраните полученный шаблон в формате xlt.

Вывод в свободной форме

При выводе в свободной форме, для каждой записи отчета создается отдельная «карточка» произвольных размеров, Карточки в отчете выводятся одна под другой.

Шаблон карточки создается в виде области листа Excel, в ячейках которой задается текст и оформление постоянной части карточки (одинаковой для всех формируемых карточек отчета) и именованными диапазонами отмечаются места для добавления полей из базы данных. Границы карточки задаются именованным диапазоном ячеек. Название этого диапазона указывается в поле Диапазон области данных настроек вывода данных.

Вывод отчета в свободной форме

Рисунок 825. Вывод отчета в свободной форме

Последовательность действий по созданию нового шаблона в свободной форме (на примере MS Excel 2003):

  1. Создайте новую книгу MS Excel.

  2. Добавьте в книгу постоянную информацию, которая должна присутствовать во всех книгах отчетов на базе данного шаблона (Листы с текстом, формулами, графиками и т.д.).

  3. Создайте лист для вывода данных. В ячейки листа добавьте постоянные детали карточки отчета, постоянные для всех карточек Название отчета, названия полей отчета и т.д. Для ячеек, в которые должны выводится данные из полей отчета задайте имена.

  4. Задайте границы карточки отчета. Для этого выделите диапазон ячеек по размеру создаваемой карточки и задайте для него имя. Для того чтобы каждая карточка печаталась на отдельной странице, укажите размер карточки по размерам страницы на печати.

  5. Сохраните полученный шаблон в формате xlt.

Примеры экспорта в Excel приведены в разделе «Примеры экспорта данных в Microsoft Excel».


Экспорт данных в HTML страницу

В режиме работы окна семантической информации Текущая запись, Ответ или База имеется возможность экспортировать соответствующий набор записей в HTML страницу для последующего анализа.

Для экспорта данных в HTML надо:

  1. В окне семантической информации на вкладке Ответ или База нажать кнопку [image] .

  2. В диалоговом окне Экспорт в HTML из списка Шаблоны отчетов выбрать нужный шаблон, при экспорте в HTML используются те же шаблоны с настройками, что и для отчетов.

  3. Если не устраивают существующие шаблоны, то нужно нажать кнопку Новый и создать новый шаблон.

  4. В строке Путь к файлу нажать кнопку Обзор и указать имя файла страницы HTML и полный путь до него.

    Окно мастера экспорта данных в HTML

    Рисунок 826. Окно мастера экспорта данных в HTML

  5. Нажать кнопку Сохранить, после чего ZuluGIS начнет процедуру экспорта, о чем будет информировать индикатор процесса. Процедуру экспорта можно прервать, нажав кнопку Отмена на панели этого индикатора.

  6. Для просмотра полученных результатов надо запустить программу Microsoft Internet Explorer и открыть средствами этой программы созданный файл.


Импорт данных из Microsoft Excel

Процедура импорта из Microsoft Excel позволяет перенести данные из таблицы Excel в семантическую базу данных. Необходимое условие для успешного импорта это наличие в таблице столбца с информацией о поле связи с картой (по умолчанию поле Sys). Благодаря такому импорту имеется возможность вносит информацию и редактировать базу данных не только средствами ZuluGIS, но и с использованием Excel. То есть можно сначала произвести экспорт данных из базы в Microsoft Excel, сделать в них необходимые изменения и затем импортировать файл с информацией обратно в ZuluGIS.

Для импорта надо:

  1. Открыть окна семантической информации.

  2. Нажать кнопку [image] , выбрать файл Excel для импорта.

  3. В появившемся Мастере импорта Excel выбрать лист файла импорта.

  4. В том случае, если требуется импортировать не все данные, в разделе Диапазон данных возможно указать диапазон, в том числе нужные строки и колонки.

  5. Если первая строка таблицы содержит имена полей, то следует установить соответствующую опцию. При этом в разделе Предварительный просмотр будут отображены данные для импорта.

    Окно мастера импорта из Excel

    Рисунок 827. Окно мастера импорта из Excel

  6. Нажать кнопку Далее.

  7. Из списка Запрос выбрать запрос в который импортируются данные.

  8. Установить опцию в зависимости от которой данные будут либо обновлены либо обновлены и добавлены. Во втором случае если в импортируемой таблице есть новые строки с данными то они будут добавлены в базу.

  9. Указать поле связи с картой.

  10. Далее необходимо указать называние и типы полей запроса. Для импорта всех пролей необходимо чтобы была установлена опция Выбрать все. Для импорта определенных полей снимите данную опцию и установите галочки напротив импортируемых полей. Проверьте чтобы напротив каждого поле Excel было соответствующее поле запроса. При необходимости поле запроса возможно изменить. Для этого надо сделать на нем щелчок левой кнопкой мыши и выбрать новое поле. Если в таблице имеются данные справочников, то в одноименном столбце надо выбрать содержат они ключ или значение справочника.

  11. После установки всех параметров нажать кнопку Далее и затем для запуска импорта кнопку Пуск.

    Окно мастера импорта из Excel

    Рисунок 828. Окно мастера импорта из Excel


Просмотр и печать отчетов

В режиме работы окна семантической информации Текущая запись, Ответ или База имеется возможность отобразить информацию в файле отчета и распечатать ее.

Для создания отчета надо:

  1. В окне семантической информации на вкладке Ответ или База нажать кнопку [image] .

  2. В диалоговом окне Отчет – печать из списка Шаблоны отчетов выбрать нужный шаблон печати.

  3. Если не устраивают существующие шаблоны, то нужно создать новый шаблон. Для этого надо нажать кнопку Новый, после чего задать все необходимые настройки. На рисунке ниже показано окно создания нового шаблона отчета. Во вкладке Настройка полей необходимо выбрать (отметить галочками) те поля, которые должны быть отображены в отчете.

    Если нужно вывести все поля, то надо установить флажок Выбрать все поля, при этом автоматически будут отмечены все поля из располагающегося под этим флажком списка. Если же вместо пользовательских названий полей необходимо, чтобы отображались реальные названия полей, взятые из таблиц, то надо установить флажок Физическое имя поля.

    Параметры шрифтов для заголовков и для данных задаются нажатием на кнопку Шрифт… в соответствующем разделе. Цвета устанавливаются выбором из открывающегося списка.

    В окне внутренняя и внешняя рамка имеется возможность выбрать из списка толщину внешней и внутренней рамки.

    Если установлена опция Использовать перенос слов, тогда слова будут в ячейке переноситься для уменьшения ширины колонки (опция установлена по умолчанию).

    В закладке Заголовок вводится заголовок отчета и с помощью кнопки Выбрать… устанавливается для него шрифт.

    В закладке Страница устанавливается размер бумаги, подача бумаги на принтер, ориентация (как отчет будет расположен на листе) и поля.

    Создание нового шаблона заканчивается нажатием кнопки ОК и заданием имени шаблону отчета.

    Окно «Редактор шаблона»

    Рисунок 829. Окно «Редактор шаблона»

  4. После выбора уже существующего либо сознания нового шаблона для предварительного просмотра отчета надо нажать кнопку [image] Просмотр....

  5. Запуск на печать может осуществляться либо из окна Отчет – печать нажатием на кнопку [image] Печать... или из окна предварительного просмотра нажатием на кнопку [image] .

[Примечание] Примечание

Существующий шаблон можно отредактировать, для этого в открывающемся списке надо выбрать шаблон для редактирования и нажать кнопку Изменить, после внесения изменений нажать кнопку ОК. Для удаления ненужного шаблона нажать кнопку Удалить.


Примеры экспорта данных в Microsoft Excel

Далее будут рассмотрены два варианта экспорта данных в Excel по шаблонам xlt:

  • «Экспорт с использованием настроек ZuluGIS»;

  • «Экспорт в свободной форме c использованием шаблона Excel».

В любом из приведенных выше вариантов сначала надо определиться с данными, которые необходимо экспортировать.


Экспорт с использованием настроек ZuluGIS

Предположим надо вывести данные по слою Здания, они должны быть экспортированы в одну книгу Excel, но при этом список зданий каждой улицы должен быть вынесен в отдельный лист. Для этого:

  1. Откройте окно семантической информации по слою Здания ( [image] ).

  2. Сделайте запрос по 1й Южный пер.. В результате у вас на экране должно быть открыто окно семантической информации с вкладкой Ответ и списком всех зданий по 1-ому Южному переулку.

  3. Нажмите кнопку Экспорт в Microsoft Exсel ( [image] ).

  4. Создайте новый шаблон отчетов, для этого нажмите кнопку Новый.

  5. В окне Редактор шаблона проверьте чтобы была выбрана опция Использовать собственные настройки.

  6. Во вкладке Настройка полей по умолчанию для шаблона выбраны все поля, нам нужны будут только несколько. Сделайте щелчок левой кнопкой мыши на опции Выбрать все поля, с полей снимутся галочки. И поле этого отметьте поля для вывода: Улица, Номер дома, Корпус, Количество жителей:

    Рисунок 830. Редактор шаблона

  7. Во вкладке Заголовок напишите Краткий отчет.

  8. Нажмите кнопку ОК.

  9. Задайте имя отчета, например отчет по улицам, нажмите кнопку ОК.

  10. Справа от сроки Путь к книге Excel нажмите кнопку Обзор, выберите путь и задайте имя файла, например doma.

  11. В строке Название листа задайте название для листа Exсel, например SPB.

  12. Нажмите кнопку Сохранить.

    Рисунок 831. Диалог экспорта

  13. Повторите пункт 2, только запрос сделайте по 2й Южный пер., выполните пункт 3.

  14. Из списка Шаблоны отчетов выберите отчет по улицам.

  15. Нажмите кнопку Изменить. В диалоговом окне Редактор шаблона выберите вкладку Заголовок и исправьте 1й Южный пер. на 2й Южный пер., нажмите кнопку ОК.

  16. Справа от строки Путь к книге Excel нажмите кнопку Обзор и укажите файл, созданный ранее в пункте 10, в нашем случает файл отчет.

  17. В строке Название листа задайте название для листа 2й Южный пер.

  18. Нажмите кнопку Сохранить.

  19. Повторите пункты 13-18 для 3го Южного переулка.

В результате проделанных действий мы получим файл книги Excel с тремя листами: 1й Южный пер., 2й Южный пер., 3й Южный пер.:

Рисунок 832. Результат экспорта


Экспорт в свободной форме c использованием шаблона Excel

Предположим, нам надо экспортировать информацию по зданиям в виде карточек в файле Excel. Шаблон карточки надо создать в виде области листа Excel, в ячейках которой будет задаваться текст и оформление постоянной части карточки (одинаковой для всех формируемых карточек отчета) и именованные диапазоны, куда будут добавляться поля из базы данных. В каждой карточке будут содержаться поля: Квартал, Улица, Номер дома, Количество жителей. Для создания шаблона:

  1. Откройте Excel с новой чистой книгой.

  2. Объедините четыре горизонтальные ячейки, задайте в этих ячейках общий заголовок для карточки.

  3. Внесите в карточку названия: Квартал, Улица, Номер дома, Количество жителей таким образом как указано ниже на рисунке. Отрегулируйте ширину ячеек, при желании задайте цвет ячейкам, выделите границы.

    Рисунок 833. Задание цвета

  4. Далее надо присвоить имена ячейкам, в которые будут выводиться данные. В нашем случае информация будет выводиться справа от соответствующей строки. Для этого сделайте щелчок правой кнопкой мыши на ячейке, расположенной справа ячейки Квартал и в появившемся контекстном меню выберите пункт Присвоить имя.

    Рисунок 834. Присваивание имени

  5. В строке Имя ничего менять не надо, оно будет соответствовать названию выводимых данных, в списке Область выберите Лист 1. Нажмите ОК.

    Рисунок 835. Задание области

  6. Повторите пункт 4 и 5 со всеми остальными полями для вывода данных.

  7. Выделите всю карточку и вокруг нее небольшую область, сделайте щелчок правой кнопкой мыши в области карточки и в контекстном меню выберите пункт Присвоить имя. Свободная область выделяется для того, чтобы карточки выводились не вплотную, а с зазором между ними.

    Рисунок 836. Присваивание имени

  8. Аналогично именам ячеек, в строке Имя оставляем название Здания, из списка Область выбираем Лист 1. Нажимаем кнопку ОК.

  9. Следующим этапом необходимо сохранить созданный шаблон. Для этого выберите меню Файл|Сохранить. В строке Имя файла задайте имя, например шаблон по зданиям, в списке Тип файла из списка выберите Шаблон Excel 97-2003, укажите папку для сохранения шаблона. После сохранения закройте Excel.

  10. Далее в ZuluGIS откройте окно семантической информации по зданиям ( [image] ), откройте вкладку База.

  11. Нажмите кнопку Экспорт в Microsoft Exсel ( [image] ).

  12. В диалоговом окне Экспорт в Microsoft Exсel нажмите кнопку Новый.

  13. В диалоговом окне Редактор шаблона выберите опцию Использовать настройки шаблона Excel.

  14. В строке Файл шаблона нажмите кнопку [image] и укажите файл шаблона, созданный ранее.

  15. В разделе Тип отчета выберите опцию Свободной формы.

  16. В списке Диапазон области данных из выпадающего списка выберите диапазон, в нашем случае это Лист1 Здания.

  17. Далее необходимо указать соответствие полей и диапазонов шаблона, укажите так, как указано на рисунке ниже:

    Рисунок 837. Задание диапазонов

  18. Нажмите кнопку ОК.

  19. Введите имя отчета: отчет по зданиям в свободной форме, нажмите кнопку ОК.

  20. Справа от строки Путь к книге Excel нажмите кнопку Обзор и укажите путь и название создаваемого файла отчета, например так же как и у шаблона: отчет по зданиям в свободной форме.

  21. В строке Название листа введите Лист1.

  22. Нажмите кнопку Сохранить.

В результате проделанных действий мы получим файл Excel с данными по слою здания в виде карточек, расположенных на одном листе:

Рисунок 838. Результат экспорта


Пространственные запросы

ZuluGIS позволяет проводить пространственный анализ местоположения (размещения), связей и иных пространственных отношений объектов в совокупности с их собственными атрибутивными данными.

В системе предусмотрено три режима выполнения пространственных запросов:

  • Выборка данных по условию, с использованием внутреннего языка запросов;

  • Формирование групп объектов по условию, с использованием внутреннего языка запросов;

  • Выборка данных по запросу SQL с использованием расширения OGC.


Выборка данных по условию

Для открытия диалога запроса выполните команду меню системы Карта|Запрос|Выборка по условию, либо нажмите кнопку [image] на панели инструментов.

Диалог выборки по условию

Рисунок 839. Диалог выборки по условию

Выборка производится по выбранным полям одного из слоев карты. Слой выбирается в поле со списком Слой, а в списке Поля для выборки флажками отмечаются поля слоя для выборки.

В каждом слое доступна группа полей «Геометрия» с полями геометрических свойств слоя, в слоях с базами данных доступны для выбора и поля баз данных слоя.

[Примечание] Примечание

Для быстрого поиска нужных полей в списке введите начало названия требуемого поля в поисковой строке над списком, в списке будут отображаться только поля, начинающиеся с введенных символов.

Текст запроса составляется в группе полей Условия выборки. Текст запроса вводится вручную, в поле ввода, либо конструируется визуально, кнопками панели инструментов, над полем ввода. Запрос состоит из набора условных выражений, соединяемых булевыми операторами (И/ИЛИ/НЕ), условные выражения можно группировать с помощью скобок.

Флажок Учитывать регистр под полем управляет способом отбора строковых полей – если флажок установлен, отбор производится с учетом регистра строк.

При установленном флажке Выбирать из выделенных объектов, запрос выполняется только по выделенным объектам слоя

Предусмотрены несколько видов условных выражений:

  • Сравнение. Синтаксис условия: Аргумент1 условие Аргумент2.

    В выражении аргументы сравниваются с использованием заданного условия. Допускаются следующие условия: <, >, =, <=, >=, <>. Условия вводятся непосредственно с клавиатуры, либо выбираются на панели инструментов условий выборки.

    Примеры.

    • Длина > 10;

    • [Номер дома] <> 5;

    • [Улица] = «Нахимова».

  • Проверка существования значения поля. Проверяется, задано ли для объекта указанное поле. Возможны два варианта условного выражения:

    • Поле IS NULL – значения поля не задано;

    • Поле IS NOT NULL – значение поля задано.

    Способ указания названий полей см. ниже, в описании видов аргументов.

    Значения IS, NULL, NOT вводятся вручную, либо кнопками на панели инструментов условий выборки.

  • Проверка соответствия аргумента строковому шаблону. Синтаксис выражения: Аргумент LIKE «ШАБЛОН», где ШАБЛОН – строка шаблона. Проверка соответствия проводится таким образом:

    • Для любых символов, кроме «_» и «%», проводится проверка наличия такого же символа;

    • Для символов «_» проверяется наличие одного произвольного символа;

    • Для символов «%» проверяется наличие любого количества произвольных символов;

    • Для комбинации символов [набор_символов], проверяется наличие одного любого символа из указанного набора. Набор может задаваться простым перечислением символов (например [abc] – проверяется наличие символа a, либо b, либо c), либо диапазоном символов (например [a-z], – любой символ от a до z, или [1-9], – цифра от 1 до 9). В числе проверяемых символов могут использоваться символы «_» и «%», но не символы «[» и «]»;

    • Для комбинации символов [^набор_символов], проверяется несовпадение с каким либо из символов набора (проверка прошла успешно, если в проверяемой позиции символ не соответствует набору). Правила формирования набора см. в предыдущем пункте.

      Примеры:

      • [Улица] LIKE «Нев%» – все объекты со строковым полем Улица, начинающимся на «Нев», в том числе: «Невский», «Невель», «Нева» и т.д.;

      • [Город] LIKE «_оскв[а-я]» – все объекты со строковым полем Город, начинающимися с произвольной буквы, продолжающимися буквами «оскв» и заканчивающимся на любую букву в диапазоне а-я, например – «Москва»;

    • Пространственные отношения. Проверяет пространственные отношения объектов слоя выборки с объектами другого слоя. Синтаксис: ОТНОШЕНИЕ [Название_слоя]. Предусмотрены следующие отношения:

      • «Содержит». Объект слоя выборки содержит в себе объект указанного слоя;

      • «Внутри». Объект слоя выборки находится внутри объекта указанного слоя.

      Примеры:

      • содержит [Пример тепловой сети];

      • внутри [Здания].

В аргументах условных выражений могут использоваться следующие элементы:

  • Значения полей слоев. Для полей геометрии пишется просто название поля, для полей БД – название, заключенное в квадратные скобки. Если поле находится не в текущем слое (слое по которому проводится выборка), то перед названием поля идет название слоя в квадратных скобках, и точка. Название поля может задаваться вручную, либо для этого можно использовать диалог выбора поля.

    Примеры.

    • Поле геометрии текущего слоя: Периметр;

    • Поле БД текущего слоя: [Квартал];

    • Поле БД слоя отличного от текущего: [Пример тепловой сети].[Адрес узла ввода].

  • Арифметические действия и скобки: +, –,*, /,(). Значки действий вводятся с клавиатуры, либо выбираются в панели управления выборки.

    Примеры.

    • Площадь / 2;

    • (Длина +5)/4.

  • Математические и строковые функции. Функции вводятся вручную, либо выбираются в панели выбора функций, открываемой кнопкой Функция панели управления выборки.

    Примеры.

    • Корень из длины объекта: SQRT(Длина);

    • Название улицы в верхнем регистре: UPPER([Улица])

Пример запроса из нескольких условных выражений: (содержит [Пример тепловой сети] И [Пример тепловой сети].ИмяТипа=«Потpебитель») ИЛИ [Улица] = «Нахимова»

После завершения набора запроса, нажмите кнопку ОК, результаты запроса отобразятся в панели данных.


Диалог выбора поля

Диалог выбора поля

Рисунок 840. Диалог выбора поля

В диалоге выбора поля выбираются поля слоев карты и их значения для добавления в условные выражения.

В области ввода, в нижней части диалога, формируется строка для добавления в запрос. Строку можно редактировать вручную, либо добавлять в нее значения из списков диалога и панели инструментов.

В левой части диалога, в области настроек Поля выбираются поля слоев карты. В поле со списком выбирается слой, в списке под полем отображаются поля этого слоя, сгруппированные по БД слоя. При двойном щелчке левой кнопкой мыши по названию поля, оно добавляется в область ввода (с учетом названия слоя).

[Примечание] Примечание

Для быстрого поиска нужных полей в списке Поля, введите начало названия требуемого поля в поисковой строке под списком, в списке будут отображаться только поля, начинающиеся с введенных символов

В средней части диалога располагается панель инструментов, позволяющая добавлять в формируемое выражение требуемые операторы (аналогично панели диалога выборки).

Диалог позволяет вывести список доступных значений любого поля, для этого выберите требуемое поле в списке Поля и нажмите кнопку Обновить в строке Значения в правой части диалога. В списке, под строкой, отобразится список значений выбранного поля. Двойным щелчком левой кнопки мыши на значении можно его добавить в область ввода.

По завершении формирования строки в области ввода, нажмите кнопку Вставить, чтобы добавить строку в запрос и закрыть диалог. Кнопка Отмена закрывает диалог без добавления информации в запрос.


Формирование групп объектов по условию

В системе предусмотрено быстрое формирование групп объектов с помощью генератора запросов. Для вызова диалога формирования групп по условию выполните команду меню программы Карта|Группа|По условию. Откроется диалог формирования групп по условию.

Диалог формирования групп по условию

Рисунок 841. Диалог формирования групп по условию

Для формирования группы:

  1. В поле со списком Слой выберите слой, из объектов которого создается группа.

  2. В группе полей Условия выборки задайте текст запроса.

  3. В поле со списком Группа выберите способ формирования группы.

    • Создать группу заново – формируется группа только из объектов выбранных в соответствии с запросом.

    • Добавить в группу – выбранные на основе запроса объекты добавляются к существующей группе (если она уже была выбрана).

    • Удалить из группы – выбранные на основе запроса объекты удаляются из уже существующей группы (если она уже была выбрана).

  4. Нажмите кнопку ОК чтобы сформировать группу и закрыть диалог.


Панель данных

В панели данных отображаются результаты выполненных запросов.

Рисунок 842. Панель данных

Данные отображаются в виде таблицы, в каждой строке которой выводится информация об одном объекте.

В панели инструментов собраны кнопки и меню инструментов для дополнительных действий с полученными данными:

  • В меню [image] собраны команды управляющие выделением на карте отобранных данных (меню доступно только если в результатах запроса есть столбец Sys, идентификатор объекта):

    • команда Выделить выделяет все отобранные объекты на карте;

    • команда Добавить в группу добавляет отобранные объекты в текущую группу;

    • команда Удалить из группы удаляет отобранные объекты из текущей группы;

    • при установленном флажке отмечать на карте автоматически, при выборе объекта в списке, он отмечается на карте.

  • Кнопка [image] (недоступна для результатов SQL запросов) вызывает диалог редактирования запроса.

  • Кнопка [image] вызывает стандартный диалог сохранения результатов запроса. Результаты могут сохраняться в формате Paradox, dBase, либо в виде текстового файла.

  • Кнопка [image] вызывает диалог печати результатов запроса.

  • Кнопки [image] и [image] вызывают диалоги сохранения результатов запроса в формате Microsoft Excel, либо в формате HTML соответственно.

  • Кнопка [image] (недоступна для результатов SQL запросов) создает новую пустую вкладку в панели результатов запроса.


Создание SQL запросов

В том случае, если встроенного языка запросов ZuluGIS недостаточно, запросы могут выполняться с использованием OGC расширения языка SQL.

В программе используется диалект языка SQL, основанный на диалекте Transact-SQL, разработанном компаниями Microsoft и Sybase (см. http://msdn.microsoft.com/en-us/library/bb510741(SQL.100).aspx и http://infocenter.sybase.com/help/index.jsp?topic=/com.sybase.help.ase_15.0.sqlug/html/sqlug/title.htm). Используемый диалект дополнен в соответствии с OGC расширением языка SQL, информация о котором приводится по адресам http://www.opengeospatial.org/standards/sfa (общая архитектура) и http://www.opengeospatial.org/standards/sfs (SQL расширение).

IntelliSense – технология автодополнения, дописывающая название функции при вводе начальных букв. Кроме прямого назначения, IntelliSense используется для доступа к документации и для устранения неоднозначности в именах переменных, функций и методов. Подсветка синтаксиса – выделение синтаксических конструкций текста с использованием различных цветов, шрифтов и начертаний. Обычно применяется для облегчения чтения исходного текста компьютерных программ и улучшения визуального восприятия.

Написание SQL запроса с IntelliSense

Рисунок 843. Написание SQL запроса с IntelliSense

[Примечание] Примечание

Видеоуроки с примерами выполнения SQL запросов можно посмотреть в разделе: https://www.politerm.com/videos/geosql/.

Для вызова диалога формирования SQL запросов выполните команду меню Карта|Запрос|SQL запрос или нажмите кнопку [image] на панели инструментов.

Диалог SQL запроса

Рисунок 844. Диалог SQL запроса

В области ввода задается текст SQL запроса. В правой части диалога расположен навигатор по полям карты (Источник:), позволяющий быстро добавить запрос данных из какого-либо поля карты. Для добавления запроса данных поля выберите в списке требуемый слой, БД и выполните двойной щелчок по названию поля, запрос будет добавлен в область ввода.

[Примечание] Примечание

Для быстрого поиска нужных полей в списке Источник введите начало названия требуемого поля в поисковой строке над списком. В списке будут отображаться только поля, начинающиеся с введенных символов.

Для отображения реальных названий полей базы данных в области полей сделайте щелчок правой кнопкой мыши и в контекстном меню выберите Реальные имена полей. Для возврата к пользовательским названиям надо снять опцию Реальные имена полей.

После задания текста запроса нажмите кнопку Выполнить панели инструментов, в области Ответ в нижней части диалога отобразится панель данных с результатами запроса. Панель можно открепить от диалога запроса для дальнейшей работы с результатами, для этого наведите указатель мыши на заголовок панели, нажмите левую кнопку мыши и, не отпуская ее, переместите мышь в произвольную часть окна программы ZuluGIS, после чего отпустите кнопку мыши. Подробнее о панели данных см. «Панель данных».

В диалоге SQL запросов предусмотрено сохранение текущего запроса в файл, открытие запроса из файла и создание нового запроса:

  • Для открытия запроса из файла (в формате .sql) выполните команду меню Файл|Открыть или нажмите кнопку панели инструментов [image] и выберите требуемый файл в стандартном диалоге выбора файлов;

  • Для сохранения текущего запроса в файле (формата .sql) выполните команду меню Файл|Сохранить или нажмите кнопку панели инструментов [image] и задайте требуемое название файла в стандартном диалоге сохранения файлов;

  • Для создания нового запроса выполните команду меню Файл|Новый запрос или нажмите кнопку панели инструментов [image] .


Общие сведения

В программе используется диалект языка SQL, основанный на диалекте Transact-SQL, разработанном компаниями Microsoft и Sybase (см. http://msdn.microsoft.com/en-us/library/bb510741(SQL.100).aspx и http://infocenter.sybase.com/help/index.jsp?topic=/com.sybase.help.ase_15.0.sqlug/html/sqlug/title.htm). Используемый диалект дополнен в соответствии с OGC расширением языка SQL, информация о котором приводится по адресам http://www.opengeospatial.org/standards/sfa (общая архитектура) и http://www.opengeospatial.org/standards/sfs (SQL расширение).

Далее можно познакомиться со следующими разделами:

  • «Введение в язык SQL» – в разделе можно найти общее описание принципов формирования запросов на языке SQL и описание их синтаксиса;

  • «Выборка данных» – раздел посвящен выборке данных для их вывода в виде таблицы в области результатов запроса;

  • «Агрегирование и группировка данных» – в данном разделе можно познакомится с применением в запросе агрегирующих функций;

  • «Выборка данных из нескольких слоев» – в разделе подробно описывается выборка данных из нескольких слоев карты;

  • «Работа с переменными» – раздел описывает работу с переменными в SQL;

  • «Подзапросы» – раздел посвящен вложенным командам выборки, подзапросам;

  • «Операторы и функции языка SQL» – содержит описание общих функций языка SQL;

  • «Работа с пространственными данными в запросах» – раздел содержит описание функций SQL, связанных с запросами пространственных данных;

  • «Примеры выполнения SQL запросов» – раздел с двумя примерами, описанными также в видеоуроках.

Во всех примерах, приведенных далее, предполагается, что они применяются к картам «Пример тепловой сети» или «Пример водопроводной сети», поставляемым вместе с системой ZuluGIS.


Введение в язык SQL

SQL или Structured Query Language (язык структурированных запросов) – язык программирования, предназначенный для управления данными в системах управления реляционными базами данных.

Рассмотрим ключевые моменты обращения к данным карт из SQL-запросов:

  • Карта делиться на отдельные слои. В запросах SQL запрашиваются данные из одного или нескольких слоев карты.

  • У каждого пространственного объекта слоя есть уникальный для этого слоя идентификатор Sys.

  • Все поля данных БД слоя привязываются к пространственным объектам слоя по номерам Sys, причем названия таблиц БД слоя в запросах не учитываются.

В системе ZuluGIS в результате выполнения запроса SQL может выводиться таблица с выборкой данных из слоев текущей карты и результатами вычисления выражений.

В данном руководстве приняты следующие соглашения по отображению элементов SQL:

  • SELECT – ключевые слова языка.

  • Название поля – названия полей баз данных слоев и названия слоев карт ZuluGIS.

  • Пример кода – примеры запросов SQL в тексте.

  • <Описание элементов> – подстановочные поля, используемые в данном документе для удобства описания и к синтаксису SQL не относящиеся. На месте подстановочного поля в SQL запросе подставляются элементы описанные отдельно, либо описанные в самом подстановочном поле.

  • [Элементы в квадратных скобках] – необязательные элементы выражения.

  • A|B – вертикальной чертой отделяются возможные варианты ключевых слов или значений.

При составлении выражений SQL следует руководствоваться следующими правилами написания отдельных его элементов:

  • Регистр символов ключевых слов SQL, названий полей и слоев не учитываются. Ключевое слово введенное прописными буквами, строчными и в смешанном регистре воспринимаются как одно ключевое слово. Например, ключевое слово SELECT может быть записано как Select, или select, а поле perimeter может быть записано так же, как и Perimeter, либо PERIMETER.

    Тем не менее, для удобства восприятия, в данном документе ключевые слова языка SQL будут записываться прописными буквами.

  • Длинная команда, состоящая из нескольких ключевых слов, может разбиваться на несколько строк.

  • Команды запроса разделяются знаком «;» После последней команды знак «;»ставить необязательно.

  • Названия полей и слоев в запросах, содержащие пробелы, должны заключаться в квадратные скобки, например название поля Номер источника должно быть записано как [Номер источника].

  • Все строковые значения в запросах заключаются в одинарные или двойные кавычки. Если требуется использовать данные символы в самой строке, следует их дублировать, либо использовать кавычки отличающиеся от тех, что окружают данную строку (например, допускается использовать одинарные кавычки в строке окруженной двойными кавычками и двойные кавычки в строке окруженной одинарными кавычками).

    Примеры задания строковых значений:

    • «Текстовая строка» – строковое значение в двойных кавычках;

    • 'Текстовая строка' – строковое значение в одинарных кавычках;

    • «Строка с текстом в кавычках - ""дублированных "" и 'нет'»– Использование кавычек в текстовой строке.

  • При необходимости задания в запросе поля данных с указанием слоя, которому он принадлежит, название поля задается в формате: <Название слоя>.<Название поля>. Например, для задания поля Номер источника слоя Пример тепловой сети в запросе следует ввести строку [Пример тепловой сети].[Номер источника].

  • В строках запроса значения могут не только вводиться непосредственно и получаться из полей БД, но вычисляться с помощью строковых и численных выражений. Такие выражения могут включать в себя различные константы, названия полей данных, функции и подзапросы, объединенные арифметическими или побитовыми операторами и скобками («Работа с пространственными данными в запросах»);

  • В текст запроса могут добавляться комментарии, не влияющие на ход выполнения запроса. Комментарии могут использоваться для пояснения деталей запроса, либо для временного исключения отдельных команд из запроса.

    Предусмотрены два вида комментариев:

    • Комментарий строки. Такой комментарий начинается с сочетания символов «--», комментарием считаются все символы до конца строки после знаков начала комментария;

    • Комментарий фрагмента. Такие комментарии начинаются сочетанием символов «/*», а заканчивается сочетанием «*/». Все символы между начальными и конечными символами считаются комментарием. Такие комментарии могут занимать несколько строк, либо часть строки, но не могут разрывать собой ключевые слова, названия функций.


Максимальное время выполнения SQL запроса

[Внимание] Внимание

Важные изменения в работе SQL запросов!

Начиная с версии ZuluGIS 8.0.0.7754 (дата релиза — 24.03.2021), введён таймаут (максимальное время) выполнения SQL запроса (значение таймаута по умолчанию — 60 сек). Это позволяет избежать зависаний при выполнении "продолжительных" запросов. По истечении времени таймаута выдаётся соответствующая ошибка.

Если запрос на обновление данных по объектам должен выполняться 100 секунд, а таймаут 60 секунд — данные не обновятся и отобразится сообщение о превышении таймаута.

Таймаутом можно управлять прямо в теле запроса, указав максимальное время в секундах, например:

SET TIMEOUT <число>;
SELECT <какой-то длинный запрос>;

Чтобы задать "бесконечный" таймаут используйте аргумент INFINITE, например, для запроса на изменение:

SET TIMEOUT INFINITE;
UPDATE <какой-то длинный запрос>;


Выборка данных

  • «Задание названий для столбцов таблицы»

  • «Избавление от повторяющихся записей»

  • «Ограничение вывода данных»

  • «Использование псевдонимов»

  • «Задание условий отбора полей»

  • «Применение логических операторов»

  • «Сортировка итоговой таблицы»

Основным действием выполняемым с помощью SQL запросов в системе ZuluGIS является выборка данных для их вывода в виде таблицы в области результатов запроса. Выборка данных производится с помощью ключевого слова SELECT, после которого задаются параметры выборки.

[Примечание] Примечание

Как правило, выборка данных производится из записей полей БД слоев карты, но ключевое слово SELECT также может использоваться для вывода в поле результатов вычисления произвольных выражений, приведенных в строке после SELECT. Можно одновременно вывести результаты вычисления нескольких выражений, перечислив их через запятую.

Например, команда SELECT "Результаты вычисления", 2+2, выведет в области результатов таблицу из двух ячеек с данными «Результаты вычисления» и 4.

Строка команды выборки состоит из трех основных частей, в которых задается какие поля таблиц выводятся в итоговую таблицу, из каких слоев берутся данные и по каким условиям отбираются данные для итоговой таблицы.

При запросе данных из одного слоя карты, для использования в команде выборки полей данных достаточно указывать только их названия. Если же в выборке используются поля из нескольких слоев, то названия полей требуется указывать в формате <Название слоя>.<Название поля>.

Типовой запрос имеет следующий вид:

SELECT <выводимые колонки> [FROM <список слоев>] [WHERE <условия отбора> ]

где:

SELECT <выводимые колонки>

Часть команды выборки в которой задаются колонки выводимой таблицы данных. В области <выводимые колонки> через запятую перечисляются названия полей, значения которых выводятся в колонках таблицы, либо выражения, результаты расчета которых выводятся в таблице («Операторы и функции языка SQL»).

Для вывода в таблице значений всех полей данных из указанных в запросе слоев, задайте вместо списка полей символ « * ». В таком случае, значения полей в таблице будут выводиться в том же порядке, в котором они заданы в БД.

Для того чтобы в итоговой таблице выводились только отличающиеся друг от друга записи, задайте списком полей ключевое слово DISTINCT («Избавление от повторяющихся записей»).

FROM <список слоев>

Часть строки выборки в которой через запятую перечисляются слои карты из которых запрашиваются данные.

Если все поля в запросе указаны в формате <Название слоя>.<Название поля>, часть запроса с ключевым словом FROM может быть опущена.

Если данные запрашиваются из более чем одного слоя карты, в итоговой таблице будет выведено декартово пересечение записей запрошенных слоев. Например, в случае запроса полей из двух слоев в итоговой таблице будет набор записей со всеми возможными комбинациями полей из записей первого и второго слоя, т.е., например при запросе поля А из слоя содержащего 2 записи и запросе поля B из слоя также содержащего две записи, в итоговой таблице будет четыре записи со следующими данными: A1+B1, A1+B2, A2+B1, A2+B2.

WHERE <условия отбора>

Часть, в которой задаются условия, в соответствии с которыми отбираются записи данных в таблицу результатов.

В качестве условий могут использоваться операции сравнения, проверки равенства, вхождения значений полей в заданный диапазон, проверки относительного расположения элементов и т.д. Подробно синтаксис условий будет рассмотрен далее.

Если в таблице результатов требуется вывести все записи для указанных полей, эта часть запроса может быть опущена.

Также в команде выборки могут использоваться различные дополнительные команды, рассматриваемые в последующих подразделах.

Примеры выборок

Простейшая выборка

SELECT * FROM Кварталы

В результате данного запроса выводится таблицу со всеми записями данных об объектах слоя Кварталы, причем в таблице выводятся все доступные поля данных слоя.

Пример выполнения запроса

Рисунок 845. Пример выполнения запроса

Команда выборки с перечислением требуемых полей

SELECT Sys, perimeter, [Количество этажей] FROM Здания

В результате запроса выводится таблица с полями Sys, perimeter, Количество этажей всех записей слоя Здания.

Команда выборки без FROM части

SELECT Здания.Sys, Здания.Адрес

В данном запросе для всех полей явно указан используемый слой, поэтому нет необходимости дополнительно указывать слой с помощью ключевого слова FROM.

Выборка с отбором по условию

SELECT [Номер дома] FROM Здания WHERE Улица='5й Южный пер.'

В результате данного запроса выводится таблица со значениями поля Номер дома для всех записей слоя Здания у которых значение поля Улица равняется строке 5й Южный пер..

Выборка по нескольким слоям

SELECT Кварталы.sys, Здания.Улица + " " + Здания.[Номер дома]
FROM Здания, Кварталы
WHERE Здания.Geometry.STWithin(Кварталы.Geometry)

В результате такого запроса будут отобраны объекты слоя Здания располагаются в объектах слоя Квартал и будет выведена таблица из двух столбцов, в первом из которых выводятся поля Sys объектов слоя Квартал, а во втором - адреса зданий в слое Здания помещающихся в указанных объектах слоя Квартал. Используемая в данном запросе конструкция Здания.Geometry.STWithin(Кварталы.Geometry) проверяет, не располагается ли объект слоя Здания внутри объекта слоя Кварталы (подробнее «Работа с пространственными данными в запросах»).


Задание названий для столбцов таблицы

Столбцы таблицы, выводимой в результате запроса, по умолчанию называются по названиям полей, значения которых в них выводятся. Для столбцов в которых выводятся результаты выражений, задаются названия вида F1,F2,...FN.

Для того чтобы задать для столбца таблицы произвольное название, достаточно в команде выборки запроса после названия выводимого поля данных, либо выражения, добавить ключевое слово AS и требуемое название столбца.

Если название столбца содержит знаки отличные от цифр и букв (пробелы, знаки препинания, математические символы, кавычки), его следует заключить в кавычки.

Примеры задания названий столбцам

Задание названия для столбца выводящего значения поля БД

SELECT Area as "Площадь дома" FROM Здания

Выводит таблицу из одного столбца Площадь дома со значениями поля Area БД слоя Здания карты.

Задание названия для столбца выводящего результаты выражения

SELECT Улица + " " + [Номер дома] as Адрес FROM Здания

Выводит результаты вычисления выражения в столбце Адрес таблицы.


Избавление от повторяющихся записей

Для того чтобы исключить из результатов выборки одинаковые записи, добавьте перед списком полей выборки ключевое слово DISTINCT. На идентичность проверяются только значения полей, выводимые в результатах запроса. Т.е. в результате запроса SELECT Улица FROM Здания будет выведен список значений поля Улица всех записей БД слоя, а по запросу

SELECT DISTINCT Улица FROM Здания

только список доступных значений данного поля.


Ограничение вывода данных

При выполнении команд выборки предусмотрена возможность ограничения количества выводимых в итоговую таблицу результатов. Для этой цели в команде выборки используются ключевые слова TOP и LIMIT.

Конструкция TOP <число> ограничивает число выводимых записей числом <число>. Конструкция задается в команде выборки непосредственно после ключевого слова SELECT, перед перечислением выводимых полей данных.

При использовании в команде выборки конструкции LIMIT <нач_номер>, <число_результатов>, в итоговую таблицу записываются результаты выборки с номера <нач_номер> и в количестве не превышающем число <число_результатов>. Результаты выборки нумеруются с 0. Конструкция записывается в самом конце команды выборки, в том числе после конструкции ORDER BY.

Одновременное использование в одной команде выборки ключевых слов TOP и LIMIT не допускается.

Примеры ограничения вывода данных

Использование ключевого слова TOP

SELECT TOP 20 * FROM Здания

Команда выводит первые 20 записей слоя Здания.

Использование ключевого слова LIMIT

SELECT * FROM Здания ORDER BY Sys LIMIT 10,15

Команда выводит с 11 по 26 результаты выборки из слоя Здания отсортированного по полю Sys.


Использование псевдонимов

В выборках можно заменять названия слоев карты псевдонимами.

При использовании псевдонимов для названий слоев, обращаться к этим слоям в запросе можно по псевдониму, что позволяет, например, использовать в запросе короткие, одно-двух буквенные названия для слоев.

Для создания псевдонима для слоя, во FROM части запроса, после названия слоя следует указать псевдоним для этого слоя (перед псевдонимом можно также добавить ключевое слово AS).

Примеры создания псевдонимов

Создание псевдонима для названия слоя

SELECT c.Квартал FROM Здания c

Создание псевдонима для названия слоя с использованием ключевого слова AS

SELECT c.Квартал FROM Здания AS c


Задание условий отбора полей

Условия отбора записей из запрошенных в команде выборки данных определяются ключевым словом WHERE и идущим за ним набором логических условий.

В каждом условии посредством операторов сравнения задается проверка соответствия некоторого выражения (как правило значения поля БД) заданному значению в формате <выражение1> <оператор сравнения> <выражение2>, выражение 1 и выражение 2 (3 и т.д.) - выражения, которые могут состоять из констант, названий полей данных, функций и подзапросов, объединенных арифметическими операторами и скобками. Например, при заданном в запросе условии Квартал='105', в таблице результатов будут выведены все записи БД слоя, для которых в поле Квартал задано значение 105.

Условия отбора могут объединяться с использованием логических операторов NOT, AND, OR. («Применение логических операторов»)

Полный список доступных операторов сравнения приведен в таблице далее:

Таблица 10. Операторы сравнения

Оператор | Описание | Примеры
IS NULL, IS NOT NULL

Выражение IS NULL проверяет, равно ли выражение в левой части оператора - Null, то есть пустому значению. Значение равное Null имеют незаданные поля.

Выражение IS NOT NULL соответственно проверяет неравенство значения Null.

Улица IS NULL (все записи в которых не задано поле Улица)

Area IS Not NULL (все записи в которых задано поле Area)

=

Проверяется равенство значений.

Проверка равенства для строковых значений с учетом регистра значений, т.е. значение Самолет и самолет будут признаны разными значениями

Квартал='105' (Здания относящиеся к 105 кварталу)
>, < Операторы «строгого» неравенства, проверяется что значение в левой части выражения строго больше, либо строго меньше значения в правой.

perimeter>50 (все здания с периметром более 50 метров)

area<300 (все здания с площадью меньше 300 кв.м.

>=, <= Операторы «нестрогого» неравенства, проверяется что значение в левой части выражения больше либо равно, или меньше либо равно значению в правой части.

perimeter>=50 (все здания периметр которых равен, либо более 50 метров)

area<=300 (все здания с площадью меньше, либо равной 300 кв.м.)

!<, !> Альтернативная запись операторов нестрого неравенства. Проверяется что значение в левой части выражения не меньше, либо не больше значения в правой части.

perimeter!<50 (все здания с периметром равным, либо превышающим 50 метров)

area!>300 (все здания с площадью не больше 300 кв.м.)

<>, != Операторы неравенства. Проверяется, неравенство значений.

Улица<>'2й Южный пер.'

Квартал!='105'
BETWEEN Операция сравнения, проверяющая расположение значения в левой части выражения в заданном диапазоне значений в правой части выражения. Оператор задается в формате <выражение 1>BETWEEN<1>AND<2>, где <1> и <2> нижняя и верхняя границы допустимых значений.

[Номер дома] BETWEEN 1 AND 5 (все здания с номерами от 1 до 5)

LIKE

Проверяется соответствие строкового значения шаблону, заданному в параметре оператора LIKE. В шаблоне могут использоваться буквы алфавита и знаки препинания, а также различные символы и выражения подстановки:

  • % - вместо данного символа в искомой строке может располагаться любое количество произвольных символов. Для поиска в искомой строке непосредственно символа %следует его продублировать;

  • _- один произвольный символ;

  • Квадратные скобки [] - на место квадратных скобок символ указанный в данных скобках. В скобках могут либо перечисляться допустимые символы (например [abc] соответствует символам a, или b, или c , либо указываться диапазон допустимых символов, (например [a-z] соответствует любому символу от а до z).

    Если после открывающей скобки стоит знак ^, допустимы все символы кроме заданных в скобках. Например для выражения [^135] допустимы любые символы, кроме 1, 3, 5.

Для поиска в исходной строке самих символов подстановки можно заключать их в квадратные скобки (например [%] для поиска знака %, или [[] для поиска символа [), либо задать так называемый escape символ (задается выражением ESCAPE <символ> после команды LIKE). В шаблоне подстановки escape символ указывается перед символом подстановки который требуется искать в строке.

Улица LIKE '%Южный пер.' (все записи с текстом заканчивающимся на Южный пер.)

Улица LIKE '_й Южный пер.' (все строки начинающиеся с произвольного символа и заканчивающиеся на й Южный пер.)

Улица LIKE '[0-9]%' (строки начинающиеся с цифры)

Улица LIKE '[авдй]_' (строки из двух символов - первый символ один из а, в, д, й и второй - произвольный)

Улица LIKE '[^0-9]%' (любая строка не начинающаяся с цифры)

Улица LIKE '[[]%]' (строки заключенные в квадратные скобки) Обратите внимание, что знак ] не является сам по себе символом подстановки и может указываться напрямую.

Улица LIKE '!%%!^' ESCAPE '!' (любая строка, начинающаяся со знака % и заканчивающаяся знаком ^).

IN

Проверяется соответствие значения одному из значений перечисленному после ключевого слова IN в формате <Выражение>IN (<Значение1>, <Значение2>...,<Значение N>), где <Значение1> -<Значение N>, список допустимых значений записи.

Список допустимых значений может быть результатом выполнения подзапроса («Подзапросы»).

Улица IN ('Нахимова', '1й Южный пер.') (все здания располагающиеся на улицах Нахимова и 1й Южный пер.)
EXISTS | Операция сравнения, которая возвращает TRUE, если подзапрос (subquery) возвращает по крайней мере одну строку («Подзапросы»). | EXISTS (subquery)


Применение логических операторов

Логический оператор NOT перед условием обращает его, т.е. условие считается выполненным при его невыполнении. Например условие NOT A=5 считается выполненным в тех случаях когда А не равняется 5.

Несколько условий могут объединяться с помощью логических операторов соединения AND, OR <Условие1> <оператор соединения><Условие2>.

При использовании оператора AND для выполнения условия должны быть выполнены оба подусловия которые он соединяет. Например условие A=5 AND D>10 будет выполнено только если значение A равняется 5 и значение D превышает 10.

При использовании оператора OR для выполнения условия достаточно выполнения одного из подусловий.

Логические операторы могут соединять несколько условий, по цепочке, при этом сначала проверяются подусловия с оператором Not, затем подусловия соединенные операторами AND и затем, соединенные операторами OR. Для изменения порядка применения логических операторов можно заключать часть выражения в скобки, при этом операторы в скобках применяются в первую очередь.

Примеры применения логических операторов

Оператор NOT

SELECT * FROM Здания WHERE NOT Улица LIKE '%Южный пер.'

Выводятся все записи в которых значение поля Здания не оканчивается строкой Южный пер..

Оператор AND

SELECT * FROM Здания WHERE Улица='Нахимова' AND Area>500

Выводятся записи в которых значение поля Улица равняется строке Нахимова и значение поля Area превышает 500.

Оператор OR

SELECT * FROM Здания WHERE Perimeter>100 OR Area>500

Выводятся записи в которых значение поля Perimeter превышает 100, значение поля Area превышает 500, либо выполняются оба условия одновременно.

Одновременно несколько логических операторов

SELECT * FROM Здания WHERE Улица='1й Южный пер.' AND
[Номер дома] NOT BETWEEN 10 AND 20 OR
Улица='2й Южный пер.' AND [Номер дома] BETWEEN 1 AND 10

Выводятся все записи для домов по улице 1й Южный пер. кроме домов с 10 по 20 и все записи для домов улицы 2й Южный пер. с 1 по 10.

Изменение порядка применения операторов с помощью скобок

SELECT * FROM Здания WHERE
(Perimeter>100 OR Area>500) AND [Количество этажей] = 5

Выводятся все записи в который значение поля Количество этажей равно 5 и, одновременно значение поля Perimeter превышает 100, либо значение поля Area превышает 500.


Сортировка итоговой таблицы

По умолчанию, записи выводимых в таблице данных упорядочиваются так, чтобы это сопровождалось наименьшими издержками с точки зрения траты компьютерных ресурсов. Как правило, порядок вывода связан с физической последовательностью выводимых записей в БД.

При необходимости, можно явно задать способ сортировки записей в таблице. Для этого используется ключевое слово ORDER BY.

Формат использования: ORDER BY <данные для сортировки>, где в качестве данных для сортировки могут использоваться названия полей данных по которым сортируется таблица, либо номера столбцов таблицы выводимой в результате запроса (нумерация столбцов идет с 1). Данные для сортировки перечисляются через запятую.

Допускается выполнять сортировку по полям БД, не выводимым в итоговой таблице. Ключевое слово ORDER BY располагается в запросе после ключевых слов FROM, WHERE, GROUP BY, HAVING.

Сортировка может выполняться как по одному полю, так и по нескольким. При сортировке по нескольким полям, сначала производится сортировка по первому указанному полю, затем - по второму, и т.д.

По умолчанию, сортировка выполняется по возрастанию значений поля, для выполнения сортировки по уменьшению значений, задайте ключевое слово DESC после названия поля сортировки. При сортировке по нескольким полям допускается для части полей сортировка по возрастанию значений, а для части - по уменьшению.

Примеры сортировки данных

Сортировка по одному полю

SELECT area, perimeter FROM Здания ORDER BY Sys

Сортирует итоговую таблицу по значениям поля Sys при том, что поле Sys не выводится в таблице.

Сортировка по нескольким полям

SELECT area, perimeter FROM Здания
ORDER BY [Количество этажей], Area

Сортирует таблицу сначала по значению поля Количество этажей, а затем - по Area.

Сортировка по столбцу итоговой таблицы

 SELECT area/perimeter FROM Здания
ORDER BY 1

Сортирует таблицу по первому ее столбцу (частному от деления площадей зданий на их периметры).

Сортировка по убыванию значений

SELECT area, perimeter FROM Здания
ORDER BY Area DESC

Сортирует таблицу по убыванию значения поля Area.

Сортировка по возрастанию и по убыванию значений

SELECT area, perimeter FROM Здания
ORDER BY Area DESC, Sys

Сортирует таблицу по убыванию значения поля Area, записи с равными значениями данного поля сортируются по возрастанию значения поля Sys.


Агрегирование и группировка данных

В данном разделе рассматривается применение в запросе агрегирующих функций- функций вычисляющих результат по набору значений группы, либо всех записей БД. Например, функция sum возвращает сумму значений заданного поля, а функция count - общее число записей.

Агрегирующая функция может применяться ко всем записям БД слоя, к выборке по заданным условиям и, кроме того, возможно группирование записей слоя в несколько групп, и применение агрегирующей функции к каждой группе («Группировка записей»).

Применяемые агрегирующие функции записываются после ключевого слова SELECT. Также допускается использовать агрегирующие функции в составе выражений, включающих функции, арифметические и побитовые операции. В одном запросе может перечисляться несколько выражений с агрегирующими функциями. Не допускается в запросе одновременно с агрегирующими функциями запрашивать значения полей записей БД, либо использовать в аргументах неагрегирующих функций обращения к полям записей БД . Например, запрос вида SELECT SQRT(Area), SUM(Perimeter) FROM Здания не допускается, поскольку аргументом функции SQRT является название поля данных.

Общая запись агрегирующих функций:

<Функция>([DISTINCT]<выражение>)

В качестве аргумента агрегирующей функции обычно используется название поля, над значениями которого проводятся вычисления. Также допускается в качестве аргумента использовать выражения, включающие в себя произвольную комбинацию названий полей, констант, функций и подзапросов, объединенных арифметическими и побитовыми операциями.

Остальная часть запроса задается стандартным образом.

Перед аргументом функции (кроме функций MAX и MIN)может указываться ключевое слово DISTINCT. В этом случае итоговое значение вычисляется только для различающихся значений аргумента. При использовании ключевого слова DISTINCT в качестве аргумента агрегирующей функции нельзя использовать арифметические выражения, - только названия полей.

В языке SQL используются следующие агрегирующие функции:

SUM([DISTINCT] <выражение>)

Выводит в итоговой таблице сумму значений для выражения по полям выборки. Выражение должно возвращать числовое значение.

AVG([DISTINCT] <выражение>)

Среднее значение для выражения. Выражение должно возвращать числовое значение.

COUNT([DISTINCT] <выражение> |*)

Подсчитывает число записей, в который выражение не имеет значение Null (поля имеют значение Null, когда никакое значение для них не задано). Выражение может возвращать произвольное значение.

При используемом формате функции COUNT(*) возвращает общее количество записей в БД слоя.

MAX( <выражение>)

Возвращает максимальное значение выражения для выборки.

MIN(<выражение>)

Возвращает минимальное значение выражения из выборки.

Применение агрегирующих функций

Простой пример

SELECT SUM(Perimeter) FROM Здания

Выводит сумму периметров зданий.

Одновременное применение нескольких функций

SELECT AVG(Area), Count(*) FROM Здания

Выводит среднюю площадь здания и общее количество зданий.

Применение функций совместно с условиями отбора

SELECT SUM(Area) FROM Здания WHERE Улица='Нахимова'

Возвращает сумму площадей зданий расположенных на улице Нахимова.

Применение выражений в качестве аргументов агрегирующих функций

SELECT SUM(Area/Perimeter*2) FROM Здания

Для каждого здания рассчитывается величина равная Площадь/Периметр*2 и суммируется.

Применение агрегирующих функций в составе выражений

SELECT SQRT(SUM(Area)), "Общий периметр" + SUM(Perimeter) FROM Здания

Возвращает квадратный корень от суммарной площади всех зданий и фразу вида «Общий периметр XXX», где XXX - суммарный периметр всех зданий.

Использование ключевого слова DISTINCT

SELECT COUNT(DISTINCT Улица) FROM Здания

Возвращает количество разных названий улиц в БД слоя.


Группировка записей

Конструкция GROUP BY в команде выборки позволяет разделить записи БД слоя на группы. Группировка записей может выполняться по значениям одного или нескольких полей записей, либо на основании значений столбцов таблицы результатов выборки.

Формат конструкции: GROUP BY <поля данных>|<номера столбцов>. При задании названии полей данных группировка выполняется по полям данных таблицы, если же номера столбцов - то по номерам столбцов выводимой таблицы (нумерация столбцов начинается с 1).

В команде выборки конструкция GROUP BY размещается непосредственно после конструкции WHERE, перед HAVING и ORDER.

Группировка записей всегда используется совместно с агрегирующими функциями. В таком случае агрегирующие функции применяются отдельно к каждой группе записей. Например, при группировке записей слоя Здания по полю Улица, все записи БД слоя будут разбиты на несколько групп, в каждой группе записи с одинаковой улицей. И, при применении функции COUNT в таком запросе, будет выведено количество записей в каждой группе.

Группировка одновременно может выполняться по нескольким полям (столбцам). Поля (столбцы) группировки перечисляются через запятую, после слов GROUP BY. Группировка сначала выполняется по первому полю, затем, уже сгруппированные записи разбиваются на подгруппы по второму полю и т.д.

При использовании в запросе группировки, среди выводимых столбцов выборки могут задаваться агрегирующие функции, и поля записей по которым выполняется группировка, либо выражения включающие эти поля.

Пример группировки записей

Группировка по полю данных

SELECT Улица, COUNT(*) FROM Здания GROUP BY Улица

Выводит список улиц и для каждой улицы количества записей.

Группировка по номеру столбца

SELECT FLOOR(Area/10)*10, SUM(Area) FROM Здания GROUP BY 1

Группирует записи по площади домов (с шагом 10, в первой группе с 0 до 10, во второй с 10 до 20 и т.д.) и выводит список групп площадей суммарную площадь для каждой группы.

Группировка по нескольким полям

SELECT COUNT(*) FROM Здания GROUP BY Квартал, Улица

Группирует записи по кварталам, а в кварталах по улицам и выводит количество записей для каждой подгруппы.


Фильтрация сгруппированных данных

Данные, сгруппированные конструкцией GROUP BY можно дополнительно отфильтровать. Для этого используется конструкция HAVING <условия отбора>. Условия отбора применяются к уже сформированным группам записей. Правила использования конструкции аналогичны правилам использования конструкции WHERE, и в качестве условий отбора могут использоваться агрегирующие функции, применяемые к отобранным группам записей, либо поля данных по которым проводится группировка.

Применение конструкции HAVING

Применение аналогично WHERE

SELECT Улица, COUNT(*) FROM Здания
GROUP BY Улица HAVING Улица Like '%пер.'

Группировка всех записей по полю Улица, и вывод значений для групп в которых название улицы заканчивается символами «пер.».

Отбор групп

SELECT Улица, AVG(Area) FROM Здания
GROUP BY Улица HAVING COUNT(*)>3

Группировка записей по названию улицы, и вывод названий улиц и средних площадей зданий для групп в которых более трех записей.


Выборка данных из нескольких слоев

Как уже упоминалось выше, в системе ZuluGIS допускается выборка данных из нескольких слоев карты. При этом в результате такой выборки будет выведена таблица с декартовым пересечением запрошенных полей перечисленных слоев. Дополнительные возможности по управлению выборками из нескольких слоев предоставляет конструкция JOIN, располагающаяся в команде выборки после ключевого слоя FROM, но перед ключевыми словами WHERE, GROUP BY, HAVING и ORDER BY. В конструкции задаются условия, по которым объединяются и выводятся поля БД слоев.

В системе ZuluGIS предусмотрено несколько вариантов использования данной конструкции, каждый из которых имеет свои особенности и область применения:

INNER JOIN (внутреннее соединение)

Каждая запись данных первого слоя сопоставляется с каждой записью другого слоя на предмет выполнения условия соединения (например, выполнения условия пространственного соответствия для объектов соединяемых слоев) и выводятся все соответствующие условию записи.

Конструкция имеет следующий синтаксис: [INNER] JOIN <Слой> ON <Условие>, где <Слой> - слой добавляемый к выборке, а <Условие> - логическое выражение по которому проводится отбор полей. Ключевое слово INNER необязательно и может быть опущено в команде выборки.

По результату, конструкция внутреннего соединения аналогична применению условия (с помощью ключевого слова WHERE) к выборке по нескольким слоям.

Пример применения INNER JOIN

SELECT b.Sys AS Здание, k.Sys AS Квартал FROM Здания AS b
INNER JOIN Кварталы AS k
ON b.Geometry.STWithin(k.geometry) ORDER BY 2

В результате данной команды выборки (конструкция b.Geometry.STWithin(k.geometry) проверяет не находится ли объект слоя Здания геометрически внутри объекта слоя Кварталы, (см. "Работа с пространственными данными в запросах") будут выведены значения полей Sys для всех пар объектов слоев Здание и Квартал в которых объект слоя Здание находится внутри объекта слоя Кварталы. Результаты сортируются по второму столбцу таблицы.

Аналогичных результатов можно добиться с использованием ключевого слова WHERE

SELECT b.Sys AS Здание, k.Sys AS Квартал FROM Здания AS b, Кварталы AS k
WHERE b.Geometry.STWithin(k.geometry) ORDER BY 2

CROSS JOIN (перекрестное соединение)

Результаты применения данной конструкции в команде полностью аналогичны перечислению названий двух слоев после ключевого слова FROM. В таблице, отображаемой в результате выполнения выборки выводится декартово пересечение записей, в запросе будет набор записей со всеми возможными комбинациями полей из записей первого и второго слоя, т.е., например при запросе поля А из слоя содержащего 2 записи и запросе поля B из слоя также содержащего две записи, в итоговой таблице будет четыре записи со следующими данными: A1+B1, A1+B2, A2+B1, A2+B2.

Конструкция имеет синтаксис CROSS JOIN <Слой>.

Пример применения CROSS JOIN

SELECT * FROM Здания CROSS JOIN Кварталы

В результате выполнения команды выборки будут выведено декартово пересечение полей БД слоев Здания и Кварталы.

Такой же результат будет при выполнении следующей команды выборки:

SELECT * FROM Здания, Кварталы

OUTER JOIN (внешнее соединение)

Как и в других вариантах использования конструкции JOIN в команде выборки задаются два слоя. Один после ключевого слова FROM и еще один, - в конструкции JOIN.

В результате выполнения команды выборки для одного из заданных слоев (назовем его основным) выводятся значения для всех его записей, а для другого слоя (назовем его дополнительным) выводятся только значения для записей соответствующих записям основного слоя по условию заданному в конструкции JOIN.

В системе ZuluGIS предусмотрено два варианта использования конструкции OUTER JOIN : LEFT OUTER JOIN (левое соединение) и RIGHT OUTER JOIN (правое соединение). В первом случае основным слоем считается слой задаваемый после ключевого слоя FROM, а во-втором - задаваемый в конструкции JOIN.

Конструкция имеет синтаксис LEFT|RIGHT [OUTER] JOIN <Слой> ON <Условие>, где LEFT|RIGHT - вид используемого соединения, <Слой> - слой добавляемый к выборке, а <Условие> - логическое выражение по которому проводится отбор полей. Ключевое слово OUTER необязательно и может быть опущено в команде выборки.

Пример применения OUTER JOIN

SELECT b.sys AS Здание, k.sys AS Квартал FROM Здания AS b
LEFT JOIN Кварталы AS k ON b.Geometry.STOverlaps(k.Geometry)

В результате выполнения команды выборки (конструкция b.Geometry.STOverlaps(k.Geometry) проверяет, не пересекается ли геометрически объект слоя Здания с объектом слоя Кварталы) будут выведены поля Sys для всех объектов слоя Здания и поля Sys объектов слоя Кварталы пересекаемых объектами слоя Здания.

Если же выполнить команду:

SELECT b.sys AS Здание, k.sys AS Квартал FROM Здания AS b
RIGHT JOIN Кварталы AS k ON b.Geometry.STOverlaps(k.geometry)

То будут выведены поля Sys для всех объектов слоя Кварталы, а для слоя Здания будут выведены только Sys объектов пересекающих границы объектов слоя Кварталы.

В команде выборки может последовательно использоваться несколько конструкций JOIN, в результате чего будет выполнено соединение полей из нескольких заданных слоев. Например, команда выборки SELECT * FROM Здания CROSS JOIN Кварталы CROSS JOIN Надписи формирует таблицу с декартовым пересечением всех трех перечисленных слоев.


Работа с переменными

Для создания сложных запросов, выполняемых в несколько этапов, в SQL предусмотрены переменные.

В переменных могут сохраняться результаты вычисления встроенных функций и констант.

Для использования переменной, ее надо предварительно «объявить», выполнив команду DECLARE языка SQL. Команда DECLARE имеет следующий формат: DECLARE <имя_переменной> <тип_переменной>, где <имя_переменной> - это название объявляемой переменной, а <тип_переменной> - тип данных, хранимых в ней. Названия переменных начинаются с символа «@», после которого могут использоваться буквы латинского алфавита, цифры и знаки «@», «$», «%», «&», «~», «_».

Поддерживаются следующие основные типы данных:

  • Geometry- пространственный объект;

  • BigInt - целочисленное значение в диапазоне от -263-1 до 263 (от - 9,223,372,036,854,775,808 по +9,223,372,036,854,775,807);

  • Int - целочисленное значение в диапазоне от -231 (-2,147,483,648) to 231-1 (2,147,483,647);

  • SmallInt - целочисленное значение в диапазоне от -215 (-32,768) to 215-1 (32,767);

  • Double, Float, Real- число с плавающей точкой;

  • char, varchar- строковое значение.

Переменным можно присваивать только значения соответствующего типа данных. Для задания значения переменной используется команда SET языка SQL, имеющая формат SET <имя_переменной>=<Выражение>, где <Выражение> - выражение составленное из числовых и строковых функций и констант, соединенных знаками сложения, вычитания, умножения и деления, и сгруппированных с помощью скобок.

Использование переменных

DECLARE @i Int;
SET @i = 2+2;
SELECT @i*3

В примере объявляется переменная @g типа Int. Для переменной задается значение - результат вычисления выражения 2+2, после чего значение переменной умноженной на 3 выводится в область ответа с помощью ключевого слова SELECT.


Подзапросы

В командах выборки могут использоваться вложенные команды выборки, или подзапросы. При использовании подзапросов, при выборке данных из каждого следующей записи в основной команде выборки, в общем случае производится выборка по всем записям выборки подзапроса. В том случае если результаты выполнения подзапроса для всех записей основной выборки являются одинаковыми, подзапрос выполняется однократно и его результаты используются при выполнении основной выборки для всех записей.

В подзапросах могут использоваться значения полей, получаемые в основной выборке, причем если в основной выборке и в подзапросе запрашиваются данные из одного и того же слоя, то для него должны быть заданы псевдонимы, отличающиеся для основной выборки и подзапроса, и обращение к полям следует выполнять используя псевдоним названия слоя.

[Примечание] Примечание

Подзапросы использующие данные из полей основной выборки значительно замедляют выполнение команды выборки, поскольку такие подзапросы выполняются для каждой записи в основной выборке. Поэтому рекомендуется по возможности заменять их использование другими средствами языка SQL.

Возможны три основные варианты использования подзапросов:

  1. Результатом выполнения подзапроса является единственное значение. Это возможно, например, если в подзапросе вычисляется значение агрегирующей функции по всем записям выборки. Такие подзапросы могут использоваться в составе выражений в командах выборки, наряду с обычными значениями и функциями.

    Использование подзапроса возвращающего единственное значение

    SELECT b.sys, b.Geometry.STArea(), k.sys
FROM Здания AS b, Кварталы AS k
WHERE b.Geometry.Within(k.Geometry)
AND b.Geometry.STArea()/
(SELECT SUM(b2.Geometry.STArea())
FROM Здания AS b2
WHERE b2.Geometry.STWithin(k.Geometry)) > 0.1

    где:

    • конструкция b.Geometry.STArea() возвращает площадь объекта слоя с псевдонимом b;

    • для слоя Здания задается псевдоним b. По этому псевдониму можно обращаться к полям записи запрашиваемой в основной команде выборки;

    • конструкция b.Geometry.Within(k.Geometry) проверяет, располагается ли здание внутри квартала;

    • результатом выполнения вложенного запроса является суммарная площадь зданий в квартале в который входит искомое здание;

    • в подзапросе происходит обращение к объекту слоя Кварталы из основной выборки.

    Приведенный запрос находит объекты слоя Здания (или просто здания) располагающиеся внутри объектов слоя Кварталы (кварталов), находится общая площадь зданий в данном квартале и выводятся информация о записях площадь которых больше 10% от общей площади зданий в данном квартале.

    Вывод результата подзапроса

    SELECT b.sys, b.Geometry.STArea()/(
SELECT SUM(b2.Geometry.STArea()) FROM Здания AS b2
WHERE b2.Geometry.STIntersects(k.Geometry)), k.sys
FROM Здания AS b, Кварталы AS k
WHERE b.Geometry.intersects(k.Geometry)
AND b.Geometry.STArea()/(
SELECT SUM(b2.Geometry.STArea()) FROM Здания AS b2
WHERE b2.Geometry.STIntersects(k.Geometry)) > 0.1

    Приведенный запрос аналогичен рассмотренному в предыдущем примере, за тем исключением, в результате выполнения команды выборки выводятся не площади объектов, а их отношение к общей площади объектов в квартале.

  2. Результатом выполнения запроса является список значений. Такие подзапросы используются в качестве операнда оператора проверки значений по списку IN («Задание условий отбора полей»). Подзапросы такого вида должны возвращать список из значений одного поля, либо выражения (после ключевого слова SELECT указывается только одно выражение для вывода).

    Использование подзапроса возвращающего список значений

    SELECT sys, Улица
FROM Здания WHERE Улица IN (
SELECT Улица from Здания GROUP BY Улица HAVING COUNT(*)>20
)

    Запрос возвращает список записей в которых значение поля Улица входит в список улиц имеющих более двадцати записей.

  3. Результатом выполнения подзапроса является любое значение. Такие подзапросы используются в качестве операнда оператора EXISTS проверяющего, вернет ли подзапрос какое-либо значение («Задание условий отбора полей»). На подзапросы такого вида не накладывается никаких ограничений.

    Использование подзапроса с оператором EXISTS

    SELECT sys FROM Кварталы AS k WHERE EXISTS(
SELECT * FROM Здания AS b where b.Geometry.Intersects(k.Geometry) AND
b.perimeter < k.perimeter /13
)

    Запрос возвращает список объектов слоя Кварталы для которых существуют объекты слоя Здания которые взаимодействуют с данными кварталами и при этом периметр таких зданий не менее чем в 13 раз меньше периметра данных кварталов.


Операторы и функции языка SQL

Система ZuluGIS поддерживает выполнение в SQL запросах ряда типовых арифметических и текстовых операций.

  • «Арифметические операции»

  • «Операции с текстовыми значениями»


Арифметические операции

В запросах поддерживаются все основные арифметические операции с числовыми величинами (сложение, вычитание, умножение и деление). Кроме того, поддерживается выполнение ряда математических функций:

Abs(<число>)

Возвращает модуль числа.

Cos(<число>), Sin(<число>), Tan(<число>), Cot(<число>), ASin(<число>), ACos(<число>), ATan(<число>)

Возвращает результаты вычисления соответствующей тригонометрической функции для угла, в радианах (косинуса, синуса, тангенса, котангенса, арксинуса, арккосинуса, либо для арктангенса).

Degrees(<число>)

Возвращает для угла радианах, соответствующее значение в градусах.

Exp(<число>)

Возвращает экспоненту от аргумента.

Floor(<число>)

Округляет аргумент до ближайшего меньшего целого.

Pi()

Возвращает значение числа пи.

Radians(<число>)

Возвращает для угла в градусах, соответствующее значение в радианах.

Sign(<число>)

Возвращает 1 для положительного аргумента, либо -1, - для отрицательного.

SQRT(<число>)

Возвращает квадратный корень от аргумента.


Операции с текстовыми значениями

Конкатенация строк

Для текстовых данных предусмотрена операция «конкатенации», - объединения нескольких строковых значений в одну общую строку. Для выполнения конкатенации необходимо соединить объединяемые значения знаком «+». При этом допускается объединять строковые значения с числовыми, последние при этом будут автоматически преобразовываться в строковые.

Примеры конкатенации строк

Простая конкатенация

SELECT "Принадлежность =" + Принадлежность FROM Здания

Выводит строки вид: «Принадлежность = ПЖКО „Ягры“» для записей БД слоя.

Конкатенация с конвертацией чисел

SELECT Улица +" "+ [Номер дома] FROM Здания

Выводить список адресов для всех записей слоя Здания вида: «2й Южный пер. 25». Числовое значение Номер дома в процессе конкатенации было преобразовано в строчное.

Строковые функции

Lower(<строка>)

Возвращает строку <строка> с прописными буквами преобразованными в строчные.

Upper(<строка>)

Возвращает строку <строка> со строчными буквами преобразованными в прописные.

ASCII(<строка>)

Возвращает число — ASCII код первого символа строки <строка>.

LTrim(<строка>)

Возвращает строку <строка> с удаленными пробелами в начале строки.

RTrim(<строка>)

Возвращает строку <строка> с удаленными пробелами в конце строки.

Trim(<строка>)

Возвращает строку <строка> с удаленными пробелами в начале и в конце строки.

StrLen(<строка>), Len(<строка>)

Возвращает количество символов в строке <строка>.

Reverse(<строка>)

Возвращает строку <строка> развернутую задом-наперед.


Работа с пространственными данными в запросах

В системе ZuluGIS запросы SQL позволяют манипулировать не только текстовыми и числовыми данными, но и пространственными объектами на карте.

Пространственные объекты имеют тип данных Geometry.

В SQL запросах с пространственными данными могут выполняться такие действия, как:

  • Получение новых пространственных объектов на базе их строкового описания или бинарного представления или получение описания бинарного представления из пространственного объекта («Создание пространственных объектов и преобразование из пространственных объектов»).

  • Получение информации о пространственных объектах (их типы, размеры, расположение на карте) («Получение информации о пространственных объектах»).

  • Сравнение между собой пространственных объектов и отбор записей БД, относящихся к данным объектам, на основе результатов сравнения («Сравнение пространственных объектов между собой»).

  • Геометрические преобразования объектов и их наложение друг на друга («Преобразования пространственных объектов»).

Для обращения к пространственным объектам слоя используется синтаксис <Название_слоя>.Geometry (если выполняется запрос из одного слоя, название слоя можно опустить).

Для вызова функций работы с пространственным объектом предусмотрены два варианта синтаксиса:

  • <Пространственный_объект>.<Функция>, где <Пространственный_объект> – это пространственный объект, к которому применяется функция, а <Функция> – это сама вызываемая функция. При использовании такого синтаксиса <Пространственный объект> используется как первый аргумент функции;

  • Geometry::<Функция>, где <Функция> – вызываемая функция. Для функций создания пространственных объектов STGeomFromText и STGeomFromWKB используется только такой синтаксис.

Пример использования разных синтаксисов вызова пространственных функций

Рассмотрим разные синтаксисы на основе функции STWithin, проверяющей, не располагается ли один объект в другом.

Первый синтаксис

SELECT b.Sys, k.Sys, b.Geometry.STWithin(k.Geometry)
from Здания as b, Кварталы as k

Второй синтаксис

SELECT b.Sys, k.Sys, Geometry::STWithin(b.Geometry, k.Geometry)
from Здания as b, Кварталы as k

Результаты выполнения этих двух запросов абсолютно одинаковы.

[Примечание] Примечание

Для простоты во всех описаниях функций в данном разделе далее будет использоваться первый синтаксис. Иными словами, для использования функции по второму синтаксису в список аргументов функции первым пунктом нужно добавить пространственный объект, к которому она применяется (или первый пространственный объект, если функция применяется к нескольким пространственным объектам). Исключение составят только функции STGeomFromText и STGeomFromWKB, для которых допускается использовать только второй синтаксис и у которых не задается пространственный объект в качестве первого аргумента.

Все пространственные объекты, которыми можно манипулировать в SQL запросах, могут быть одного из нескольких типов геометрических фигур:

  • Многоугольник (POLYGON). Замкнутая фигура, состоящая из набора вершин, соединенных линиями, и имеющая заливку внутреннего объема. В системе ZuluGIS представителями данного типа являются прямоугольники, окружности, многоугольники и сегменты.

  • Ломаная (LINESTRING). Набор последовательно соединенных линий. В ZuluGIS представлена ломаными, прямоугольниками, окружностями и дугами.

  • Точка (POINT). В системе ZuluGIS точками являются символьные объекты.

  • Набор многоугольников (MULTIPOLYGON). Совокупность из нескольких многоугольников, не обязательно соединенных друг с другом, но являющихся одним объектом.

  • Набор ломаных (MULTILINESTRING). Совокупность из нескольких ломаных.

  • Набор точек (MULTIPOINT). Совокупность из нескольких точек.


Создание пространственных объектов и преобразование из пространственных объектов

В запросах SQL можно создавать пространственные объекты из их текстового описания или из бинарного представления пространственного объекта.

Для получения пространственного объекта из текстового описания используется функция STGeomFromText(<строка_описания_объекта>, <id_проекции>), где <строка_описания_объекта> – текстовая строка с описанием объекта, а <id_проекции> – идентификатор используемой в карте проекции. Для идентификатора проекции в большинстве случаев следует оставлять значение 0 – автоматическое задание проекции. Формат строки описания объекта зависит от типа создаваемого объекта:

Многоугольник (POLYGON)

POLYGON ((<X1> <Y1>, <X2> <Y2>,....,<XN> <YN>)), где <X1> <Y1> - <XN> <YN> – координаты вершин многоугольника;

Ломаная (LINESTRING)

LINESTRING (<X1> <Y1>, <X2> <Y2>,....,<XN> <YN>), где <X1> <Y1> - <XN> <YN> – координаты точек, соединяемых линиями ломаной в том порядке, в котором они заданы;

Точка (POINT)

POINT (<X> <Y>), где <X>,<Y> – координаты точки;

Набор многоугольников (MULTIPOLYGON)

MULTIPOLYGON (((<X11> <Y11>,....,<X1N> <Y1N>)),((<X21> <Y21>, ....,<X2N> <Y2N>))...,((<XN1> <YN1>,....,<XNN> <YNN>))), где <X11> <Y11> - <X1N> <Y1N> – координаты вершин первого многоугольника, <X21> <Y21> - <X2N>,<Y2N> – второго и т.д.

Набор ломаных (MULTILINESTRING)

MULTILINESTRING ((<X11> <Y11>,....,<X1N> <Y1N>),(<X21> <Y21>, ....,<X2N> <Y2N>)...,(<XN1> <YN1>, ....,<XNN> <YNN>)), где <X11> <Y11> - <X1N>,<Y1N> – координаты точек первой ломаной, <X21> <Y21> - <X2N> <Y2N> – второй и т.д.

Набор ломаных (MULTIPOINT)

MULTIPOINT ((<X1> <Y1>),(<X2> <Y2>),....,(<XN> <YN>)), где <X1> <Y1> – координаты первой точки, <X2> <Y2> – второй и т.д.

Примеры формирования геометрических объектов из текстового описания

Создание многоугольника

Geometry::STGeomFromText("POLYGON((5522.66 9710.55,5523.11 9711.31,5523.59 9712.04,5524.13 9712.74))", 0)

Строка описывает четырехсторонний многоугольник.

Создание набора ломаных

Geometry::STGeomFromText("MULTILINESTRING((5522.66 9710.55,5523.11 9711.31,5523.59 9712.04,5524.13 9712.74),
(563379 965260,555165 956116,555220 956116))", 0)

Строка описывает набор из двух ломаных: первая соединяет четыре точки, вторая – три.

Для получения геометрического представления объекта из бинарного представления следует использовать функцию STGeomFromWKB(<бинарное_представление_объекта>, <id_проекции>), где <бинарное_представление_объекта> – описание пространственного объекта в бинарном формате (WKB или Well Known Binary). Бинарное представление может храниться в полях таблиц БД или быть получено преобразованием пространственного объекта в бинарный формат.

Для получения из пространственного объекта его текстового и бинарного представления используются функции STAsText и STAsBinary. Аргументом обеих функций является геометрический объект. Первая возвращает его текстовое описание, вторая же – бинарное.

Пример использования функций преобразования форматов

DECLARE @g1 Geometry;
DECLARE @g2 Geometry;
DECLARE @b Binary;

SET @g = Geometry::STGeomFromText(«POLYGON((5850.56 9849.42,
5753.64 9588.67,5618.16 9639.25,5715.91 9899.35,5850.56 9849.42))»,0);
SET @b = @g.STAsBinary()
SET @g2 = Geometry::STGeomFromWKB(@b)

SELECT Sys FROM [Здания] WHERE geometry.within(@g)
где,

  • DECLARE @g1 Geometry, DECLARE @g2 Geometry, DECLARE @b Binary – задаются переменные для хранения промежуточных данных;

  • SET @g = Geometry::STGeomFromText(«POLYGON((5850.56 9849.42,5753.64 9588.67,5618.16 9639.25,5715.91 9899.35,5850.56 9849.42))»,0) – переменной @g1 присваивается пространственный объект, полученный из строки;

  • SET @b = @g.STAsBinary() – бинарное описание полученного пространственного объекта сохраняется в переменной @b;

  • SET @g2 = Geometry::STGeomFromWKB(@b) – из бинарного описания создается пространственный объект и сохраняется в переменной g2;

  • SELECT Sys FROM [Здания] WHERE geometry.within(@g) – производится выборка данных из слоя Здания c выводом поля Sys для всех пространственных объектов, располагающихся внутри пространственного объекта, сохраненного в переменной g2.


Получение информации о пространственных объектах

Функции данной группы возвращают различную информацию о пространственном объекте – аргументе функции.

STDimension

Возвращает количество измерений пространственного объекта (для точки – 0, для кривой – 1, для многоугольника – 2).

STGeometryType

Возвращает тип геометрического объекта.

STSRID

Возвращает идентификатор географической проекции пространственного объекта.

STIsEmpty

Проверяет, является ли пространственный объект пустым (пустое множество точек).

Возвращает 1 (True) для пустых объектов и 0 (False) для всех остальных. Объекты типа точка (Point) не могут являться пустыми.

STIsSimple

Проверяет, является ли пространственный объект простым (в нем отсутствуют самопересечения и самокасания).

Возвращает 1 (True) для простых объектов и 0 (False) для всех остальных. Объекты типа точка (Point) всегда простые.

STLength

Возвращает длину объекта (только для объектов типов LineString и MultiLineString).

STX

Для объектов типа Point возвращает координату X.

STY

Для объектов типа Point возвращает координату Y.

STNumPoints

Возвращает количество точек заданных для объекта (только для объектов типов Point, MultiPoint, LineString, MultiLineString).

STPointN(<номер_точки>)

Возвращает пространственный объект – точку объекта под номером <номер_точки> (только для объектов типов MultiPoint, LineString, MultiLineString).

STArea

Возвращает площадь объекта (только для объектов типов Polygon и MultiPolygon).

STIsClosed

Проверяет, является ли пространственный объект замкнутой геометрической фигурой (только для типов LineString и Polygon). Замкнутыми фигурами считаются такие, у которых координаты последней точки совпадают с координатами первой.

Возвращает 1 (True) для замкнутых объектов и 0 (False) для незамкнутых.

Text

Для текстовых объектов (бирок) возвращает текст, присвоенный этим объектам.


Сравнение пространственных объектов между собой

Критерии пересечения объектов

Рисунок 846. Критерии пересечения объектов

STDistance(<объект_сравнения>)

Возвращает расстояние между ближайшими точками сравниваемых объектов.

STEquals(<объект_сравнения>)

Выполняет сравнение пространственного объекта, для которого вызвана функция, с пространственным объектом <объект_сравнения>. Сравнение выполняется по типу объектов, размерам и положению в пространстве.

Возвращает 1 (True), если объекты равны, и 0 (False) в обратном случае.

STDisjoint(<объект_взаимодействия>)

Проверяет отсутствие пересечений и касаний пространственного объекта, для которого вызвана функция, с пространственным объектом <объект_взаимодействия>.

Возвращает 1 (True), если <объект_взаимодействия> пространственно никак не накладывается, не пересекает и не касается данного объекта, и 0 (False) в обратном случае.

STTouches(<объект_касания>)

Проверяет, не касается ли <объект_касания> пространственного объекта, для которого вызвана функция.

Возвращает 1 (True) в случае касания и 0 (False) в обратном случае.

STWithin(<объект_вхождения>)

Проверяет объект, для которого вызвана функция, на вхождение в пространственный объект <объект_вхождения>. Пространственный объект считается входящим в другой объект, если все его точки лежат внутри границ другого объекта.

Возвращает 1 (True) в случае вхождения и 0 (False) в обратном случае.

STOverlaps(<объект_перекрытия>)

Проверяет, не перекрывает ли пространственный объект, для которого вызвана функция, пространственный объект <объект_перекрытия>. Считается, что один пространственный объект перекрывает другой, если часть его точек лежит внутри границ второго объекта, а часть – снаружи.

STCrosses(<объект_пересечения>)

Проверяет, пересекает ли пространственный объект, для которого вызвана функция, объект <объект_пересечения>. Пересекать другие объекты могут пространственные объекты типов LineString и Point.

Пересечением считается случай, в котором точки пересекающего объекта располагаются от одной границы пересекаемого объекта до другой, либо, в случае пересечения ломаной, достаточно расположения хотя бы одной точки пересекающего объекта на пересекаемой ломаной.

Возвращает 1 (True) в случае пересечения и 0 (False) в обратном случае.

STIntersects(<объект_взаимодействия>)

Проверяет пространственный объект, для которого вызвана функция, на пространственное взаимодействие с с объектом <объект_взаимодействия>. Взаимодействием считается касание, перекрытие, пересечение одного объекта другим и включение одного объекта в другой.

Возвращает 1 (True) в случае взаимодействия и 0 (False) в обратном случае.

STContains(<объект_вхождения>)

Проверяет, не включает ли пространственный объект, для которого вызвана функция, в себя пространственный объект <объект_вхождения>.

Возвращает 1 (True) в случае вхождения и 0 (False) в обратном случае.

STRelate(<объект_сравнения>,<матрица_сравнения>)

Выполняет сравнение пространственного объекта, для которого вызывает функция, с объектом <объект_сравнения> в соответствии с заданной матрицей сравнения <матрица_сравнения>.

Матрица сравнения является матрицей 3x3, в ячейках которой задается тип взаимодействия между внутренними областями, границами и внешними областями сравниваемых пространственных объектов. Матрица имеет вид, представленный таблицей (). Столбцы матрицы отвечают за один сравниваемый объект, строки – за другой.

В ячейках таблицы сравнения записывается, какое количество измерений должно иметь взаимодействие соответствующих частей объектов:

  • F – не должно быть взаимодействия;

  • T – должно быть взаимодействие, количество измерений неважно;

  • * – не имеет значения, есть ли взаимодействие или нет;

  • 0, 1, 2 – взаимодействие должно иметь указанное количество измерений.

В аргументе функции Relate матрица взаимодействия записывается в виде строки, в которой перечислены требуемые значения всех ячеек матрицы сравнения, слева-направо, сверху-внизу.

Например, для двух пространственных объектов a и b строка a.Relate(b, "TFFFTFFFT") аналогична строке a.Equals(b).

Таблица 11. Матрица сравнения пространственных объектов

 | Внутренняя область | Граница | Внешняя область
Внутренняя область |  |  |
Граница |  |  |
Внешняя область |  |  |


Преобразования пространственных объектов

Функции этой группы возвращают пространственные объекты, создаваемые в результате преобразования пространственных объектов – аргументов функции.

STEnvelope

Возвращает пространственный объект – минимальный прямоугольник (тип данных – Polygon), описывающий пространственный объект, переданный функции.

STIntersection(<объект_пересечения>)

Возвращает пространственный объект, являющийся общей областью объекта, для которого вызвана функция, с объектом <объект_пересечения>.

STDifference(<объект_вычитания>)

Возвращает пространственный объект, являющийся результатом геометрического вычитания объекта <объект_вычитания> из пространственного объекта, для которого была вызвана функция.

STSymDifference(<объект_вычитания>)

Возвращает пространственный объект, являющийся симметрической разностью пространственного объекта, для которого была вызвана функция, с объектом <объект_вычитания>.

Union(<объект_сложения>)

Возвращает пространственный объект, являющийся результатом геометрического сложения объекта, для которого была вызвана функция, с объектом <объект_сложения>.

STBuffer(<Расстояние>)

Возвращает пространственный объект, содержащий все точки, расстояние которых от объекта, для которого была вызвана функция, меньше либо равно числовому значению <Расстояние>.

STConvexHull

Возвращает пространственный объект, являющийся наименьшим выпуклым множеством, содержащим пространственный объект, для которого была вызвана функция.


Примеры выполнения SQL запросов

На данный момент в справочном руководстве представлено несколько запросов. На официальном сайте и форуме компании вы сможете найти дополнительный примеры запросов.

  • «Отчет по участкам: количество и протяженность трубопроводов с разбивкой по диаметрам»

  • «Заполнение адресов по потребителям значениями из базы по домам»


Отчет по участкам: количество и протяженность трубопроводов с разбивкой по диаметрам

В конструкции этого запроса используется оператор GROUP BY, который позволяет разделить записи базы данных по участку на группы. Группировка записей выполняется по значению внутреннего диаметра трубопровода.

Выборка данных производится с помощью ключевого слова SELECT, после которого задаются параметры выборки.

Осуществляется выбор следующих параметров:

  • Внутренний диаметр трубы, м;

  • Количество участков данного диаметра, для определения количества участков используются функция COUNT;

  • Протяженность трубопроводов заданного диаметра, функция SUM определяет суммарную длину участков.

Ключевое слова AS используется для указания названий столбцов.

После ключевого слова FROM указывает слой, в котором будет производиться выбор.

Выражение WHERE используется для указания критериев выборки, в данном случае выбор осуществляется только по участкам. Участки водопроводной сети в структуре слоя имеют тип-8, условие type=8, в версии сборки 7.0.0.5425 и выше задается typeid=8.

SELECT [Внутренний диаметр трубы, м] AS "Диаметр",
COUNT(*) AS "Количество участков",
SUM([Длина участка, м]) AS "Протяженность" FROM [Пример водопроводной сети]
WHERE typeid=8
GROUP BY [Внутренний диаметр трубы, м]


Заполнение адресов по потребителям значениями из базы по домам

В запросе осуществляется работа с пространственными данными.

В конструкции этого запроса используется оператор сравнения пространственных объектов между собой STWithin. Он проверяет объект, для которого вызвана функция, на вхождение в указанный пространственный объект сравнения.

Для внесения изменения в заданные столбцы таблицы (базы данных слоя) используется оператор UPDATE; он употребляется в связке с ключевым словом SET, после которого следует наименование обновляемых полей таблицы.

После выражения WHERE задаются критерии, по которым будут происходить обновления. В данном случае происходит обновление поля Адрес базы данных по потребителям (потребители водопроводной сети в структуре слоя имеют тип-5) при условии, что символ потребителя находится внутри площадного объекта здания. Условие выбора потребителей type=8, в версии сборки 7.0.0.5425 и выше задается typeid=8.

UPDATE [Пример водопроводной сети]
SET [Пример водопроводной сети].[Адрес] =
[Здания].[Улица]+" "+[Здания].[Номер дома]
WHERE [Пример водопроводной сети].typeid=5
AND [Пример водопроводной сети].Geometry.STWithin([Здания].Geometry)

Конструкцию запроса можно изменить, применив псевдонимы для названий слоев. Для создания псевдонима для слоя используется оператор FROM; после названия слоя следует указать псевдоним для этого слоя (перед псевдонимом можно также добавить ключевое слово AS).

UPDATE L1 SET L1.[Адрес] = L2.[Улица]+" "+ L2.[Номер дома]
FROM [Пример водопроводной сети] AS L1, [Здания] AS L2
WHERE L1.typeid=5 AND L1.Geometry.STWithin(L2.Geometry)


Справочник по GeoSQL

  • «Инструкции»

  • «Операторы»

  • «Функции»

  • «Объект Geometry»

В программе используется диалект языка SQL, основанный на диалекте Transact-SQL, разработанном компаниями Microsoft и Sybase (см. http://msdn.microsoft.com/en-us/library/bb510741(SQL.100).aspx и http://infocenter.sybase.com/help/index.jsp?topic=/com.sybase.help.ase_15.0.sqlug/html/sqlug/title.htm). Используемый диалект дополнен в соответствии с OGC расширением языка SQL, информация о котором приводится по адресам: http://www.opengeospatial.org/standards/sfa (общая архитектура) и http://www.opengeospatial.org/standards/sfs (SQL расширение).


Инструкции

«Оператор SELECT»

«Выражение FROM»

«Выражение WHERE»

«Выражение GROUP BY»

«Выражение HAVING»

«Выражение ORDER BY»

«Оператор UPDATE»

«Оператор DECLARE»

«Оператор SET»

«Оператор CONST»

«Оператор ALTER SELECTION»

«Оператор USING»


Оператор SELECT

Оператор SELECT позволяет делать выборку из одного или нескольких слоёв.

Синтаксис

SELECT [ ALL | DISTINCT ]
    [ TOP { (record_count) | record_count } ]
    <select-list>
    [ FROM <from-clause> ]
    [ WHERE <search-condition> ]
    [ GROUP BY <group-by-clause> ]
    [ HAVING <search-condition> ]
    [ ORDER BY <order-by-clause> ]
    [ LIMIT { record_count [ OFFSET record_start ] | record_start, record_count } ]
<select-list> ::=
    {
        *
        | { source_name | source_alias }.*
        | {
            [ { source_name | source_alias }. ]
            column_name [ { . | :: } { property_name
                | method_name ( argument [ ,...n ] ) }  ]
            | expression
            [ [ AS ] column_alias ]
          }
    } [ ,...n ]

Аргументы

ALL

Указывает, что в результирующем наборе могут появиться повторяющиеся строки. ALL является параметром по умолчанию.

DISTINCT

Указывает, что в результирующем наборе могут появиться только уникальные строки.

TOP

Ограничивает выборку указанным числом записей. Здесь record_count – целое число.

select-list

Задает столбцы в результирующем наборе.

LIMIT

Ограничивает выборку указанным числом записей. Помимо этого, позволяет задать смещение, начиная с которого записи будут попадать в результирующую выборку. Где record_count – целое число-константа, задающее максимальное число возвращаемых записей, record_start – целое число, задающее смещение (начиная с 1).


Выражение FROM

Указывает слои, которые используются операторами SELECT и UPDATE.

Синтаксис

FROM { <source> } [ ,...n ]

<source> ::= { { <source-name> | (subquery) } [ [AS] source_alias] } | <joined-source>

<source-name> ::= { layer_name | layer_path }

<joined-source> ::= { <source> <join-type> <source> ON <search-condition>
    | <source> CROSS JOIN <source>
    | [ ( ] <joined-source> [ ) ]
}

<join-type> ::= [ { INNER | { LEFT | RIGHT } [ OUTER ] } ] JOIN

Аргументы

source

Указывает слой источник.

source-name

Имя слоя источника.

source-alias

Псевдоним слоя источника.

layer_name

Пользовательское имя слоя.

layer_path

Полный путь к слою или URL.

subquery

Оператор SELECT, чей результат используется как источник данных.

source_alias

Псевдоним для source, который может использоваться как для удобства, так и для различения слоя во вложенном запросе.

joined-source

Соединяемая слой – это результирующий набор, полученный из двух или более слоев. Для нескольких соединений следует использовать скобки, чтобы изменить естественный порядок соединений.

search-condition

Условие отбора записей.

join-type

Указание типа операции соединения.

CROSS JOIN

Указывает перекрестное произведение двух слоев.

INNER

Указывает, что возвращаются все совпадающие пары строк. Отмена несовпадающих строк из обеих слоев. Если тип соединения не указан, этот тип задается по умолчанию.

FULL [ OUTER ]

Указывает, что в результирующий набор включаются строки как из левого, так и из правого слоя, несоответствующие условиям соединения, а выходные столбцы устанавливаются в значение NULL. Этим дополняются все строки, обычно возвращаемые при помощи INNER JOIN.

LEFT [ OUTER ]

Указывает, что все строки из левого слоя, не соответствующие условиям соединения, включаются в результирующий набор, а выходные столбцы из оставшейся таблицы устанавливаются в значение NULL в дополнение ко всем строкам, возвращаемым внутренним соединением.

RIGHT [ OUTER ]

Указывает, что все строки из правого слоя, не соответствующие условиям соединения, включаются в результирующий набор, а выходные столбцы, соответствующие оставшейся таблице, устанавливаются в значение NULL в дополнение ко всем строкам, возвращаемым внутренним соединением.


Выражение WHERE

Задает условие отбора записей для выполнения оператора.

Синтаксис

WHERE <search-condition>

<search-condition> ::=
    { [ NOT ] <predicate> | ( <search-condition> ) }
    [ { AND | OR } [ NOT ] { <predicate> | ( <search-condition> ) } ]
[ ,...n ]

<predicate> ::=
    { expression { = | <> | != | > | >= | !> | < | <= | !< } expression
    | expression [ NOT ] LIKE expression [ ESCAPE 'escape_character' ]
    | expression [ NOT ] BETWEEN expression AND expression
    | expression IS [ NOT ] NULL
    | EXISTS ( subquery )
    }

Аргументы

search-condition

Условие отбора записей.

NOT

Инвертирует логическое выражение, задаваемое предикатом.

AND

Объединяет два условия и выдает значение TRUE, если оба условия имеют значение TRUE.

OR

Объединяет два условия и выдает значение TRUE, если хотя бы одно условие имеет значение TRUE.

predicate

Любое выражение, результатом которого являются значения TRUE или FALSE.

[ NOT ] LIKE

Указывает, что последующая строка символов будет использоваться с сопоставлением шаблонов.

ESCAPE 'char'

Позволяет найти сам символ-шаблон (char) в строке (вместо того чтобы использовать его как шаблон).

[ NOT ] BETWEEN

Задает включающий диапазон значений. Используйте оператор AND для разделения начальных и конечных значений.

IS [ NOT ] NULL

Задает поиск значений NULL или значений, не являющихся значениями NULL, в зависимости от используемых ключевых слов.

EXISTS

Используется во вложенном запросе для проверки существования строк, возвращенных вложенным запросом.


Выражение GROUP BY

Группирует результаты оператора SELECT в соответствии со значениями одного или нескольких выражений столбцов.

Синтаксис

GROUP BY { <column_spec> } [ ,...n ]

<column_spec>::={[ {<source_name> | source_alias} .] column_name |column_no |column_alias}

Аргументы

column-spec

Столбец или выражение, на основании которого выполняется операция группирования.

source-name

Имя слоя источника.

source-alias

Псевдоним слоя источника.

column_alias

Псевдоним колонки ответа так, как он задан в предложении SELECT.

column_name

Имя колонки.

column_no

Номер колонки ответа, начиная с 1.


Выражение HAVING

Определяет условие поиска для группы или статистического выражения. Предложение HAVING можно использовать только в инструкции SELECT. Предложение HAVING обычно используется в предложении GROUP BY. Когда GROUP BY не используется, предложение HAVING работает так же, как и предложение WHERE.

Синтаксис

HAVING <search-condition>

Аргументы

search-condition

Условие отбора записей.


Выражение ORDER BY

Задает сортировку результирующего набора записей.

Синтаксис

ORDER BY { <column-spec> [ ASC | DESC ] } [ ,...n ]

<column-spec> ::= { [ { source_name | source_alias } . ] column_name | column_no | column_alias }

Аргументы

column-spec

Столбец, на основании которого выполняется операция группирования.

ASC

Задает тип сортировки столбца по возрастанию. Это вариант по умолчанию.

DESC

Задает тип сортировки столбца по убыванию.

source-name

Имя слоя источника.

source-alias

Псевдоним слоя источника.

column_alias

Псевдоним столбца так, как он задан в предложении SELECT.

column_name

Имя колонки

column_no

Номер колонки ответа, начиная с 1.


Оператор UPDATE

Позволяет изменять существующие данные.

Синтаксис

UPDATE <target-spec> SET { <target-prop> = <expression> } [ ,...n ]
[ FROM <from-clause> ]
[ WHERE <search-condition> ]

<target-spec> ::= { <source-name> | source_alias }

<target-prop> ::= { [ <target-spec>. ] column_name }

Аргументы

target-spec

Имя слоя или псевдоним, данные которого будут обновлены.

target-prop

Имя слоя или псевдоним и имя изменяемого поля, записанное в виде [target-spec].column_name.

expression

Значение expression, заменяет существующее значение target-prop.

from-clause

Указывает слои, которые используются в инструкциях.

source-name

Имя слоя источника.

source-alias

Псевдоним слоя источника.

search-condition

Условие отбора записей.


Оператор DECLARE

Объявляет одну или несколько переменных.

Синтаксис

DECLARE { @variable data_type } [ ,...n ]

Аргументы

@variable

Имя объявляемой переменной, начинается с символа @.

data_type

Тип данных объявляемой переменной.

Поддерживаемые типы данных

Тип | Описание
varchar | строка ANSI
nchar, nvarchar | строка UNICODE
smallint | короткое целое (16 бит)
int, integer | целое
bigint | целое 64 бит
float, double, real | вещественное
datetime | дата/время
geometry | объект geometry
guid | идентификатор GUID


Оператор SET

Задает значение переменной.

Синтаксис

SET @variable = <expression>

Аргументы

@variable

Имя переменной (начинается с символа @), значение которой устанавливается.

expression

Выражение, которое заменяет существующее значение @variable.


Оператор CONST

Объявляет одну или несколько констант.

Синтаксис

CONST { @variable = <expression> } [ ,...n ]

Аргументы

@variable

Имя объявляемой переменной, начинается с символа @.

<expression>

Выражение, результатом которого должно быть константное значение.


Оператор ALTER SELECTION

Оператор ALTER SELECTION используется для добавления, удаления или модификации колонки в уже существующей выборке.

Синтаксис

ALTER SELECTION ON layer_name { SET | ADD | DELETE } { ALL | (subquery) }

Аргументы

layer_name

Имя слоя, чья группа изменяется. Слой должен быть загружен в карту, чтобы изменения группы имели эффект.

SET

Создает или заменяет существующую группу заданным множеством элементов.

ADD

Добавляет элементы в существующую группу или создает новую группу с заданным множеством элементов.

DELETE

Удаляет элементы из группы.

ALL

Множество элементов задаётся всеми элементами слоя.

(subquery)

Множество элементов задаётся результатом оператора SELECT. Результирующий набор записей должен содержать одну колонку численных значений, соответствующих ключам элементов.


Оператор USING

Оператор USING служит для уточнения или ограничения объектов системы, используемых при выполнении SQL.

Обычно при выполнении SQL оператора используются данные из текущего основного запроса, заданного в базе данных, подключенной к слою. Кроме того, к слою могут быть подключены несколько баз данных, в соответствии с разными типами объектов слоя. Оператор USING используется для уточнения того, какой именно базой данных или запросом нужно ограничить выполнение последующих SQL операторов.

Операторы USING DATABASE и USING QUERY можно сочетать, чтобы точно задать ограничение конкретной базой данных и запросом в ней.

Синтаксис

USING { DATABASE | QUERY } [ <object_name> | id=<object_id> ]

Аргументы

DATABASE

Ограничивает использование семантических данных в последующих операторах указанной базой данных. Остальные базы данных, подключенные к слоям, используемых в запросах, игнорируются.

QUERY

Ограничивает использование семантических данных в последующих операторах указанным запросом. Если такого запроса нет в базе данных, то такая база игнорируется.

object_name

Имя (пользовательское название) базы данных или запроса.

object_id

Численный идентификатор базы данных или запроса.


Оператор TIMEOUT

Начиная с версии ZuluGIS 8.0.0.7754 (дата релиза – 24.03.2021), введён таймаут (максимальное время) выполнения SQL запроса (значение таймаута по умолчанию – 60 секунд). Это позволяет избежать зависаний при выполнении продолжительных запросов. По истечении времени таймаута выдается соответствующая ошибка.

Если запрос на обновление данных по объектам должен выполняться 100 секунд, а таймаут 60 секунд, то данные не обновятся, и отобразится сообщение о превышении таймаута.

Таймаутом можно управлять прямо в теле запроса, указав максимальное время в секундах, например:

SET TIMEOUT <число>;
SELECT <какой-то длинный запрос>;

Чтобы задать "бесконечный" таймаут, используйте аргумент INFINITE, например, для запроса на изменение:

SET TIMEOUT INFINITE;
UPDATE <какой-то длинный запрос>;


Операторы

Логические операторы | Операторы множеств
«AND» «BETWEEN» «EXISTS» «IN» «IS NULL» «LIKE» «NOT» «OR» | «Оператор UNION» «Оператор EXCEPT» «Оператор INTERSECT»


Логические операторы

Логические операторы

«AND»

«BETWEEN»

«EXISTS»

«IN»

«IS NULL»

«LIKE»

«NOT»

«OR»


AND

Объединяет два логических выражения и возвращает значение TRUE, если оба выражения имеют значение TRUE. Если в инструкции используется более одного логического оператора, то операторы AND вычисляются первыми. Порядок вычисления можно изменить с помощью скобок.

Синтаксис

<boolean_expression> AND <boolean_expression>

Аргументы

boolean_expression

Любое допустимое выражение, результатом которого являются логические значения TRUE или FALSE.


BETWEEN

Определяет диапазон для проверки.

Синтаксис

<expression> [ NOT ] BETWEEN begin_expression AND end_expression

Аргументы

expression

Выражение для проверки на принадлежность диапазону.

NOT

Задает отрицание логического результата. Предикат меняет возвращаемые выражением значения на обратные.

begin_expression

Выражение, определяющее начало диапазона. Должно иметь тот же тип данных, что и expression и end_expression.

end_expression

Выражение, определяющее конец диапазона. Должно иметь тот же тип данных, что и expression и end_expression.

AND

Служит заполнителем, который указывает на то, что значение expression должно находиться в диапазоне от begin_expression до end_expression.


CASE

Оператор CASE, в зависимости от указанных условий, возвращает одно из множества возможных значений.

Может быть использован в одной из двух форм записи:

  • простое выражение CASE для определения результата сравнивает выражение с набором простых выражений;

  • поисковое выражение CASE для определения результата вычисляет набор логических выражений.

При использовании первой синтаксической формы условие WHEN удовлетворяется, когда значение проверяемого выражения станет равным значению выражения, указанного в предложении WHEN. При использовании второй синтаксической формы условие WHEN удовлетворяется, если предикат принимает значение TRUE. При удовлетворении условия оператор CASE возвращает значение, указанное в соответствующем предложении THEN. Если ни одно из условий WHEN не выполнилось, то будет использовано значение, указанное в предложении ELSE.

Синтаксис

--Простое выражение
CASE input_expression
     WHEN when_expression THEN result_expression [ ...n ]
     [ ELSE else_result_expression ]
END

-- Поисковое выражение
CASE
    WHEN boolean_expression THEN result_expression [ ...n ]
    [ ELSE else_result_expression ]
END

Аргументы

input_expression

Выражение, полученное при использовании простого формата функции CASE.

when_expression

Простое выражение, с которым сравнивается input_expression.

boolean_expression

Логическое выражение, полученное при использовании поискового формата функции CASE.

result_expression

Возвращаемое выражение, когда when_expression имеет значение TRUE.

else_result_expression

Если ни одно из условий WHEN не выполнилось, то будет использовано значение, указанное в предложении ELSE.


EXISTS

Указывает вложенный запрос для проверки существования строк.

Синтаксис

EXISTS [ ( ] (subquery) [ ) ]

Аргументы

(subquery)

Запрос SELECT, чей результат проверяется на наличие записей.

Описание

Функция EXISTS возвращает TRUE, если выборка (subquery) не пуста.


IN

Определяет, совпадает ли данное значение с каким-либо значением во вложенным запросе или списке.

Синтаксис

test_expression [ NOT ] IN
   ( subquery

      | expression [ ,...n ]
   )

Аргументы

test_expression

Выражение для проверки на принадлежность диапазону.

NOT

Задает отрицание логического результата. Предикат меняет возвращаемые выражением значения на обратные.

subquery

Множество элементов задаётся результатом оператора SELECT. Результирующий набор записей должен содержать одну колонку численных значений, соответствующих ключам элементов.

expression

Может быть константой, столбцом или функцией, а также любым сочетанием арифметических, побитовых и строковых операторов.


IS NULL

Проверяет, является ли указанное выражение NULL.

Синтаксис

expression IS [ NOT ] NULL

Аргументы

expression

Может быть константой, столбцом или функцией, а также любым сочетанием арифметических, побитовых и строковых операторов.

NOT

Задает отрицание логического результата. Предикат меняет возвращаемые выражением значения на обратные.


LIKE

Определяет, совпадает ли указанная символьная строка с заданным шаблоном. Шаблон может включать обычные символы и символы-шаблоны. Во время сравнения с шаблоном необходимо, чтобы его обычные символы в точности совпадали с символами, указанными в строке.

Синтаксис

match_expression [ NOT ] LIKE pattern

Аргументы

match_expression

Любое допустимое выражение символьного типа данных.

NOT

Задает отрицание логического результата. Предикат меняет возвращаемые выражением значения на обратные.

pattern

Конкретная строка символов для поиска в match_expression может содержать следующие допустимые символы-шаблоны (%_[] [^]


NOT

Оператор NOT изменяет значение любого логического выражения на противоположное.

Синтаксис

NOT <boolean_expression>

Аргументы

boolean_expression

Любое допустимое выражение, результатом которого являются значения TRUE или FALSE.


OR

Объединяет два условия. Если в инструкции используется более одного логического оператора, то операторы OR вычисляются после операторов AND. Порядок выполнения можно изменить с помощью скобок.

Синтаксис

<boolean_expression> OR <boolean_expression>

Аргументы

boolean_expression

Любое допустимое выражение, результатом которого являются значения TRUE или FALSE.


Операторы множеств

Операторы множеств

«Оператор UNION»

«Оператор EXCEPT»

«Оператор INTERSECT»


Оператор UNION

Объединяет результаты нескольких запросов в один результирующий набор. Этот набор включает все строки, относящиеся ко всем запросам в объединении.

Если определен параметр ALL, то сохраняются все дубликаты выходных строк; в противном случае в результирующем наборе присутствуют только уникальные строки. Можно связывать вместе любое число запросов, например: SELECT ... UNION SELECT ... UNION SELECT ...

Кроме того, с помощью скобок можно задавать порядок объединения: (SELECТ ... UNION SELECT ...) EXCEPT (SELECT ...)

Основные правила объединения:

  • количество и порядок столбцов должны быть одинаковыми во всех запросах;

  • типы данных должны быть совместимыми.

  • ORDER BY применяется к результату соединения, поэтому оно может быть указано только в конце запроса.

Синтаксис

{ <query> | ( <query_expression> ) }
{ UNION [ ALL ]
    { <query> | ( <query_expression> ) }
    [ ...n ] }

Аргументы

query

Простое выражение, возвращающее данные для объединения.

query_expression

Выражение запроса, возвращающее данные для объединения. Например, SELECT ... UNION SELECT ... UNION SELECT ...)

ALL

Объединяет в результирующий набор все строки, в том числе повторяющиеся. Если обратное не указано, дубликаты строк удаляются (по умолчанию подразумевается DISTINCT).


Оператор EXCEPT

Оператор EXCEPT возвращает уникальные строки первого запроса, которые отсутствуют во втором.

Синтаксис

{ <query> | ( <query_expression> ) }   EXCEPT { <query> | ( <query_expression> ) }

Аргументы

query

Простое выражение, возвращающее данные для сравнения.

query_expression

Выражение запроса, возвращающее данные для сравнения.


Оператор INTERSECT

Оператор INTERSECT возвращает все уникальные значения, входящие в результаты выполнения запросов, указанных как слева, так и справа от оператора.

Результатом будут строки, которые присутствуют в обоих запросах.

Синтаксис

{ <query> | ( <query_expression> ) } INTERSECT { <query> | ( <query_expression> ) }

Аргументы

query

Простое выражение, возвращающее данные для сравнения.

query_expression

Выражение запроса, возвращающее данные для сравнения.


Функции

Математические | Строковые | Дата | Логические | Статические | Преобразования
«ABS» «ACOS (ARCCOS)» «ACTG (ACOT, ARCCTG)» «ASIN» «ATAN» «CEIL» «COS» «COT (CTG)» «DEG (DEGREES)» «EXP» «FLOOR» «PI» «POW (POWER)» «RAD (RADIANS)» «ROUND» «SIGN» «SIN» «SQRT» «SQUARE» «TAN» | «ASCII» «CHAR» «CHARINDEX» «LEFT» «LEN (STRLEN)» «LOWER (LCASE)» «LTRIM» «NCHAR» «RCHARINDEX» «REPLACE» «REPLICATE» «REVERSE» «RIGHT» «RTRIM» «SPACE» «SUBSTRING» «TRIM» «UNICODE» «UPPER (UCASE)» «ByRef» «ByVal» | «DATEPART» «DAY» «GETDATE» «MONTH» «NOW» «TODAY» «TOMORROW» «YEAR» «YESTERDAY» «BETWEEN» | «GREATEST» «IN» «IS NULL» «LEAST» | «AVG» «COUNT» «MIN» «MAX» «SUM» | «CAST»


Математические

Математические функции

«ABS»

«ACOS (ARCCOS)»

«ACTG (ACOT, ARCCTG)»

«ASIN»

«ATAN»

«CEIL»

«COS»

«COT (CTG)»

«DEG (DEGREES)»

«EXP»

«FLOOR»

«PI»

«POW (POWER)»

«RAD (RADIANS)»

«ROUND»

«SIGN»

«SIN»

«SQRT»

«SQUARE»

«TAN»


ABS

Возвращает положительное значение числового выражения.

Синтаксис

ABS ( <expression> )

Аргументы

expression

Числовое выражение.


ACOS (ARCCOS)

Возвращает арккосинус числа (в радианах).

Синтаксис

ACOS ( <expression> )

Аргументы

expression

Числовое выражение. Допустимо только значения в диапазоне от –1,00 до 1,00.


ACTG (ACOT, ARCCTG)

Возвращает арккотангенс числа (в радианах).

Синтаксис

ACTG ( <expression> )

Аргументы

expression

Числовое выражение.


ASIN

Возвращает арксинус числа (в радианах).

Синтаксис

ASIN ( <expression> )

Аргументы

expression

Числовое выражение. Допустимо только значения в диапазоне от –1,00 до 1,00.


ATAN

Возвращает арктангенс числа (в радианах).

Синтаксис

ATAN ( <expression> )

Аргументы

expression

Числовое выражение.


CEIL

Округляет число в большую сторону до ближайшего целого.

Синтаксис

CEILING ( <expression> )

Аргументы

expression

Числовое выражение.


COS

Возвращает косинус числа (в радианах).

Синтаксис

COS ( <expression> )

Аргументы

expression

Числовое выражение.


COT (CTG)

Возвращает котангенс числа (в радианах).

Синтаксис

COT ( <expression> )

Аргументы

expression

Числовое выражение.


DEG (DEGREES)

Эта функция возвращает для числа (в радианах) соответствующее значение в градусах.

Синтаксис

DEGREES ( <expression> )

Аргументы

expression

Числовое выражение.


EXP

Возвращает значение экспоненты заданного числового выражения.

Синтаксис

EXP ( <expression> )

Аргументы

expression

Числовое выражение.


FLOOR

Возвращает наибольшее целое число, меньшее или равное указанному числовому выражению.

Синтаксис

FLOOR ( <expression> )

Аргументы

expression

Числовое выражение.


PI

Возвращает значение числа Пи.

Синтаксис

PI ()


POW (POWER)

Возвращает результат возведение числа в степень.

Синтаксис

POWER ( <expression>, <y> )

Аргументы

expression

Числовое выражение.

y

Степень, в которую возводится аргумент expression.


RAD (RADIANS)

Для введенного числового выражения в градусах возвращает значение в радианах.

Синтаксис

RADIANS ( <expression> )

Аргументы

expression

Числовое выражение.


ROUND

Возвращает число, округленное до указанной длины (точности).

Синтаксис

ROUND ( <expression>, <length> )

Аргументы

expression

Числовое выражение.

length

Точность, с которой должно быть округлено значение expression.

Описание

Функция округляет численное выражение expression с учётом целочисленного аргумента length. Если length – положительное число, выражение округляется до числа разрядов, указанных в length. Если length – отрицательное число, то выражение округляется слева от десятичной запятой, как указано в length.


SIGN

Возвращает положительное (+1), нулевое (0) или отрицательное (-1) значение, обозначающее знак заданного выражения.

Синтаксис

SIGN ( <expression> )

Аргументы

expression

Числовое выражение.


SIN

Возвращает значение тригонометрического синуса указанного угла в радианах.

Синтаксис

SIN ( <expression> )

Аргументы

expression

Числовое выражение.


SQRT

Возвращает квадратный корень данного числа.

Синтаксис

SQRT ( <expression> )

Аргументы

expression

Числовое выражение.


SQUARE

Возвращает квадрат указанного числа.

Синтаксис

SQRT ( <expression> )

Аргументы

expression

Числовое выражение.


TAN

Возвращает тангенс указанного выражения в радианах.

Синтаксис

TAN ( <expression> )

Аргументы

expression

Числовое выражение.


Строковые функции

Строковые функции

«ASCII»

«CHAR»

«CHARINDEX»

«LEFT»

«LEN (STRLEN)»

«LOWER (LCASE)»

«LTRIM»

«NCHAR»

«RCHARINDEX»

«REPLACE»

«REPLICATE»

«REVERSE»

«RIGHT»

«RTRIM»

«SPACE»

«SUBSTRING»

«TRIM»

«UNICODE»

«UPPER (UCASE)»


ASCII

Возвращает код ASCII первого символа указанного символьного выражения.

Синтаксис

ASCII ( <expression> )

Аргументы

expression

Строковое выражение.


CHAR

Эта функция преобразует код ASCII в значение символа.

Синтаксис

CHAR ( <int> )

Аргументы

int

Положительное целое число – код символа.


CHARINDEX

Эта функция выполняет поиск одного символьного выражения внутри второго символьного выражения, возвращая начальную позицию первого выражения, если найдено.

Синтаксис

CHARINDEX ( <expressionToFind>, <expressionToSearch>, <start_location> )

Аргументы

expressionToFind

Символьное выражение, содержащее последовательность для поиска.

expressionToSearch

Символьное выражение, в котором производится поиск.

start_location

Позиция, с которого начинается поиск. Если аргумент start_location не указан, имеет отрицательное значение или равен нулю (0), то поиск начинается с начала выражения.


LEFT

Возвращает указанное число символов символьного выражения (слева направо).

Синтаксис

LEFT ( <expression>, <int> )

Аргументы

expression

Строковое выражение.

int

Положительное целое число, указывающее количество символов выражения expression, которое будет возвращено.


LEN (STRLEN)

Возвращает количество символов указанного строкового выражения.

Синтаксис

LEN ( <expression> )

Аргументы

expression

Строковое выражение.


LOWER (LCASE)

Возвращает символьное выражение преобразования символов верхнего регистра в символы нижнего регистра.

Синтаксис

LOWER ( <expression> )

Аргументы

expression

Строковое выражение.


LTRIM

Возвращает символьное выражение после удаления начальных пробелов.

Синтаксис

LTRIM ( <expression> )

Аргументы

expression

Строковое выражение.


NCHAR

Возвращает символ Юникода с указанным целочисленным кодом, определенным в стандарте Юникода.

Синтаксис

NCHAR ( <expression> )

Аргументы

expression

Строковое выражение.


RCHARINDEX

Эта функция выполняет поиск справа налево одного символьного выражения внутри второго символьного выражения, возвращая начальную позицию первого выражения, если найдено.

Синтаксис

RCHARINDEX ( <expressionToFind>, <expression>, <start_location> )

Аргументы

expressionToFind

Символьное выражение, содержащее последовательность для поиска.

expression

Символьное выражение, в котором производится поиск.

start_location

Позиция, с которого начинается поиск. Если аргумент start_location не указан, имеет отрицательное значение или равен нулю (0), то поиск начинается с начала выражения.


REPLACE

Заменяет все вхождения указанного строкового значения другим строковым значением.

Синтаксис

REPLACE ( <expression>, <pattern>, <replacement> )

Аргументы

expression

Строковое выражение, в котором выполняется поиск.

pattern

Подстрока для поиска.

replacement

Строка замещения.


REPLICATE

Повторяет значение строки указанное число раз.

Синтаксис

REPLICATE ( <expression>, <int> )

Аргументы

expression

Строковое или числовое выражение.

int

Положительное целое число, указывающее количество повторов.


REVERSE

Возвращает строковое значение, где символы переставлены в обратном порядке справа налево.

Синтаксис

REVERSE ( <expression> )

Аргументы

expression

Строковое выражение.


RIGHT

Возвращает указанное число символов символьной строки справа налево.

Синтаксис

RIGHT ( <expression>, <int> )

Аргументы

expression

Строковое выражение.

int

Положительное целое число, указывающее количество символов выражения expression, которое будет возвращено.


RTRIM

Возвращает строку символов, из которой удалены все завершающие пробелы.

Синтаксис

RTRIM ( <expression> )

Аргументы

expression

Строковое выражение.


SPACE

Возвращает строку пробелов.

Синтаксис

SPACE ( <int> )

Аргументы

int

Положительное целое число, определяющее количество пробелов в строке


SUBSTRING

Возвращает часть символьного, текстового выражения.

Синтаксис

SUBSTRING ( <expression>, <start>, <length> )

Аргументы

expression

Строковое выражение.

start

Целое число или выражение, указывающее начальную позицию возвращаемых символов.

length

Положительное целое число или выражение, указывающее количество символов выражения expression, которое будет возвращено


TRIM

Возвращает строку символов, из которой удалены все завершающие пробелы.

Синтаксис

TRIM ( <expression> )

Аргументы

expression

Строковое выражение.


UNICODE

Возвращает целочисленное значение, соответствующее стандарту Юникод, для первого символа входного выражения.

Синтаксис

UNICODE ( <expression> )

Аргументы

expression

Строковое выражение (Юникод).


UPPER (UCASE)

Возвращает символьное выражение, в котором символы нижнего регистра преобразованы в символы верхнего регистра.

Синтаксис

UPPER ( <expression> )

Аргументы

expression

Строковое выражение.


ByRef

Для полей с подключенным справочником возвращает реальное значение поля, а не значение из справочника.

[Подсказка] Подсказка

Если соответствующее поле числовое, то искомое значение нужно указывать как есть, а если поле таблицы строковое, то в двойных кавычках, например, byref[proklad] = "3".

Синтаксис

ByRef[Имя поля]

Пример запроса

SELECT byref[Вид прокладки тепловой сети]
FROM [Пример квартальной сети]
where byref[Вид прокладки тепловой сети] = 3

Пример ответа

3
3
3
3
...


ByVal

Для полей с подключенным справочником возвращает значение из справочника.

Синтаксис

ByVal[Имя поля]

Пример запроса

SELECT byval[Вид прокладки тепловой сети]
FROM [Пример квартальной сети]
where byref[Вид прокладки тепловой сети] = 3

Пример ответа

Подземная бесканальная
Подземная бесканальная
Подземная бесканальная
Подземная бесканальная
.....


Функции даты и времени

Функции даты и времени

«DATEADD»

«DATEDIFF»

«DATEPART»

«DAY»

«GETDATE»

«MONTH»

«NOW»

«TODAY»

«TOMORROW»

«YEAR»

«YESTERDAY»


DATEADD

Добавляет целое число со знаком (number) к указанной части (datepart) выражения date и возвращает измененное значение даты или времени.

Синтаксис

DATEADD ( <datepart>, <number>, <date> )

Аргументы

datepart

Определенная часть аргумента date, к которой функция DATEADD прибавляет целое число.

В таблице ниже приведены возможные значения datepart. Функция принимает либо полное имя datepart, либо указанные сокращения полного имени. Использование переменных или строк в кавычках не допускается.

datepart | Сокращения
year | y,yy,yyyy
month | m,mm
day | d,dd
hour | hh
minute | n,mi
second | s,ss
millisecond | ms

number

Выражение типа целого числа со знаком, которое будет прибавлено к компоненту datepart выражения date. В случае, если number принимает значение с десятичной дробью, то оно будет усечено до целого. Можно использовать отрицательные значения для вычитания нужного числа из datepart.

date

Выражение типа даты. Аргумент date может быть выражением, значением столбца, определяемой пользователем переменной или строкой.


DATEDIFF

Возвращает количество пересечённых границ в виде целого число со знаком компонента (datepart) промежутка времени, заданного выражениями start-date и end-date.

Синтаксис

DATEDIFF ( <datepart>, <start-date>, <end-date> )

Аргументы

datepart

Единицы, в которых функция DATEDIFF возвращает разницу между start-date и end-date.

В таблице ниже приведены возможные значения datepart. Функция принимает либо полное имя datepart, либо указанные сокращения полного имени. Использование переменных или строк в кавычках не допускается.

datepart | Сокращения
year | y,yy,yyyy
month | m,mm
day | d,dd
hour | hh
minute | n,mi
second | s,ss
millisecond | ms

start-date

end-date

Выражение типа даты. Аргумент может быть выражением, значением столбца, определяемой пользователем переменной или строкой.


DATEPART

Возвращает целое число, представляющее указанную часть (datepart) заданного выражения date.

Синтаксис

DATEPART ( <datepart>, <date> )

Аргументы

datepart

Определенная часть аргумента date, для которого функция DATEPART вернет значение типа integer.

В таблице ниже приведены возможные значения datepart. Функция принимает либо полное имя datepart, либо указанные сокращения полного имени. Использование переменных или строк в кавычках не допускается.

datepart | Сокращения
year | y,yy,yyyy
month | m,mm
day | d,dd
hour | hh
minute | n,mi
second | s,ss
millisecond | ms

date

Выражение типа даты. Аргумент date может быть выражением, значением столбца, определяемой пользователем переменной или строкой.


DAY

Возвращает целое число, представляющее день месяца указанного выражения date.

Синтаксис

DAY ( <date> )

Аргументы

date

Выражение типа даты. Аргумент date может быть выражением, значением столбца, определяемой пользователем переменной или строкой.


GETDATE

Возвращает текущую системную метку времени в виде значения datetime. Это значение наследуется от операционной системы компьютера.

Синтаксис

GETDATE ()


MONTH

Возвращает целое число, представляющее месяц указанной даты (date).

Синтаксис

MONTH (< date> )

Аргументы

date

Выражение типа даты. Аргумент date может быть выражением, значением столбца, определяемой пользователем переменной или строкой.


NOW

Возвращает текущее значение даты и времени.

Синтаксис

NOW ()


TODAY

Возвращает значение даты (date) текущего дня.

Синтаксис

TODAY ()


TOMORROW

Возвращает значение даты (date) для завтрашнего дня.

Синтаксис

TOMORROW ()


YEAR

Возвращает целое число – год для указанной даты (date).

Синтаксис

YEAR ( <date> )

Аргументы

date

Выражение типа даты. Аргумент date может быть выражением, значением столбца, определяемой пользователем переменной или строкой.


YESTERDAY

Возвращает значение даты для вчерашнего дня.

Синтаксис

YESTERDAY ()


Логические функции

Логические

«GREATEST»

«IN»

«IS NULL»

«LEAST»


GREATEST

Функция GREATEST возвращает максимальное значение из указанного списка или выражения.

Все указанные в аргументе значения или выражения должны иметь сопоставимый тип данных, который может быть преобразован в тип с высшим приоритетом.

Если сравниваемые величины имеют одинаковый тип данных, то результат будет иметь такой же тип.

Если сравниваемые величины разного типа, то величины с типом данных с меньшим приоритетом сначала преобразуются в тип данных с большим приоритетом.

Возвращаемый результат будет с типом данных, имеющий наивысший приоритет.

ZuluServer использует следующий порядок приоритета для типов данных:

  1. char (низший приоритет)

  2. int

  3. int64

  4. double

  5. date (высший приоритет)

Синтаксис

GREATEST ( expression1, [, ...expressionN ] )

Аргументы

expression1, expressionN

Список выражений, разделенный запятыми. Каждое выражение может быть константой, переменной, столбцом или функцией, а также сочетанием арифметических, битовых и строковых операторов.

Пример

Найти максимальную скорость движения на участках: максимальное значение в подающем или обратном трубопроводе.

SELECT Sys, GREATEST([Скорость движения воды в под.тр-де, м/с], [Скорость движения воды в обр.тр-де, м/с]) as max_value
FROM [Пример тепловой сети]
where typename = "Участки"


IIF

Проверяет, является ли указанное выражение NULL.

Синтаксис

IIF ( <logical-expression>, <expression-if-true>, <expression-if-false> )

Аргументы

logical-expression

Логическое выражение.

expression-if-true

Выражение, значение которого возвращается, если значение logical-expression имеет значение TRUE.

expression-if-false

Выражение, значение которого возвращается, если значение logical-expression имеет значение FALSE.


ISNULL

Заменяет значение NULL указанным замещающим значением.

Синтаксис

ISNULL ( <expression> , <expression-if-null> )

Аргументы

expression

Выражение, которое сравнивается с NULL. Если значение выражения не NULL, функция возвращает это же самое значение.

expression-if-null

Выражение, значение которого возвращает функция, если выражение expression равно NULL.


LEAST

Функция LEAST возвращает минимальное значение из указанного списка или выражения.

Все указанные в аргументе значения или выражения должны иметь сопоставимый тип данных, который может быть преобразован в тип с высшим приоритетом.

Если сравниваемые величины имеют одинаковый тип данных, то результат будет иметь такой же тип.

Если сравниваемые величины разного типа, то величины с типом данных с меньшим приоритетом сначала преобразуются в тип данных с большим приоритетом.

Возвращаемый результат будет с типом данных, имеющий наивысший приоритет.

ZuluServer использует следующий порядок приоритета для типов данных:

  1. char (низший приоритет)

  2. int

  3. int64

  4. double

  5. date (высший приоритет)

Синтаксис

LEAST ( expression1, [, ...expressionN ] )

Аргументы

expression1, expressionN

Список выражений, разделенный запятыми. Каждое выражение может быть константой, переменной, столбцом или функцией, а также сочетанием арифметических, битовых и строковых операторов.

Пример

Найти минимальную скорость движения на участках: максимальное значение в подающем или обратном трубопроводе.

SELECT Sys, GREATEST([Скорость движения воды в под.тр-де, м/с], [Скорость движения воды в обр.тр-де, м/с]) as min_value
FROM [Пример тепловой сети]
where typename = "Участки"


Статистические функции

Статические (агрегатные) функции

«AVG»

«COUNT»

«MIN»

«MAX»

«SUM»


AVG

Возвращает среднее арифметическое группы значений. Значения NULL не учитываются.

Синтаксис

AVG ( [ ALL | DISTINCT column ] )

Аргументы

ALL

Применяет агрегатную функцию ко всем значениям. ALL является параметром по умолчанию.

DISTINCT

Указывает, что функция AVG возвращает сумму только уникальных значений из указанного столбца column.

expression

Может быть константой, столбцом или функцией, а также любым сочетанием арифметических, побитовых и строковых операторов.


COUNT

Функция Count возвращает количество записей (строк) таблицы. Можно использовать для подсчета количества записей в запросе SELECT. Условие, по которому будут выбираться записи, задается с помощью команды WHERE.

Запись функции с указанием маски * вернет количество всех записей в таблице.

Если указать столбец (синтаксис ниже), то вернет количество записей конкретного столбца, за исключением NULL записей. Например:

Синтаксис

COUNT ( * | [ ALL | DISTINCT column ] )

Аргументы

*

Указывает, что функция COUNT должна учитывать все записи для возврата.

ALL

Применяет агрегатную функцию ко всем значениям. ALL является параметром по умолчанию, указывать не обязательно. Например, два следующих запроса равноценны:

SELECT COUNT([Номер источника]) FROM [Тепловые сети]

SELECT COUNT(ALL [Номер источника]) FROM [Тепловые сети]

DISTINCT

Указывает, что функция COUNT возвращает только уникальные значения из указанного столбца column.

Примеры

  • Сколько всего потребителей (typeid=3 – это номер типа 3) в слое тепловой сети:

    SELECT COUNT(*)
FROM [Тепловые сети] WHERE typeid=3;

  • Какое количество уникальных Номеров схем подключений у потребителей в слое тепловой сети:

    SELECT COUNT(DISTINCT [Номер схемы подключения потребителя])
FROM [Тепловые сети] WHERE typeid=3;


MIN

Возвращает минимальное значение выражения.

Синтаксис

MIN ( <expression> )

Аргументы

expression

Может быть константой, столбцом или функцией, а также любым сочетанием арифметических, побитовых и строковых операторов.


MAX

Возвращает максимальное значение выражения.

Синтаксис

MAX ( <expression> )

Аргументы

expression

Может быть константой, столбцом или функцией, а также любым сочетанием арифметических, побитовых и строковых операторов.


SUM

Возвращает сумму значений (всех или только уникальных) в выражении. Значения NULL не учитываются.

Синтаксис

SUM ( [ ALL | DISTINCT column ] )

Аргументы

ALL

Применяет агрегатную функцию ко всем значениям. ALL является параметром по умолчанию.

DISTINCT

Указывает, что функция SUM возвращает сумму только уникальных значений значений из указанного столбца column.


Функции преобразования

Функции преобразования

«CAST»


CAST

Преобразует выражение из одного типа данных в другой тип данных.

При преобразовании из float или numeric в integer функция CAST усекает результат. Для других преобразований функция CAST будет округлять результат.

[Внимание] Внимание

  1. Не любые преобразования типов возможны (стандарт содержит таблицу допустимых преобразований типов данных).

  2. Результат функции CAST для значения выражения, равного NULL, тоже будет NULL.

Синтаксис

CAST ( expression AS data_type [ ( length ) ] )

Аргументы

expression

Значение для преобразования в другой тип данных.

data_type

Тип данных, к которому вы хотите преобразовать выражение. Это может быть одно из следующих: bigint, int, smallint, tinyint, bit, decimal, numeric, money, smallmoney, float, real, datetime, smalldatetime, char, varchar, text, nchar, nvarchar, ntext, binary, varbinary или image.

length

Необязательный. Длина результирующего типа данных для типов char, varchar, nchar, nvarchar, binary и varbinary.

Примеры

SELECT CAST(15.79 AS int);

Результат: 16

SELECT CAST(15.79 AS float);

Результат: 15.79

SELECT CAST("15,79" AS float);

Результат: 15.79


Объект Geometry

Для представления пространственных данных и геообработки поддерживается объект Geometry. Объект Geometry представляет собой пространственные данные и поддерживает набор методов, определенных стандартом OGC.

Объект Geometry

«AsBinary»

«AsRaw»

«AsText»

«AsTextWGS84»

«Boundary»

«Buffer»

«Centroid»

«Contains»

«ConvexHull»

«Crosses»

«Difference»

«Dimension»

«Disjoint»

«Distance»

«EndPoint»

«Envelope»

«Equals»

«ExteriorRing»

«GeometryN»

«GeometryType»

«GeomFromText»

«GeomFromWKB»

«InteriorRingN»

«Intersection»

«Intersects»

«Is3d»

«IsClosed»

«IsEmpty»

«IsMeasured»

«IsRing»

«IsSimple»

«IsValid»

«Length»

«Length_sph»

«MakeValid»

«NumGeometries»

«NumInteriorRing»

«Overlaps»

«PointN»

«Relate»

«Selected»

«Srid»

«StartPoint»

«SymDifference»

«Touches»

«Union»

«Within»

«X»

«X_WGS84»

«Y»

«Y_WGS84»

«Z»


AsBinary

Возвращает представление экземпляра geometry в двоичном формате WKB консорциума OGC.

Синтаксис

geometry.AsBinary()

Тип результата

Двоичные данные varbinary.


AsRaw

Возвращает представление экземпляра geometry во внутреннем двоичном ("raw") формате.

Синтаксис

geometry.AsRaw()

Тип результата

Двоичные данные varbinary.


AsText

Возвращает текстовое представление экземпляра geometry в формате WKT консорциума OGC.

Синтаксис

geometry.AsText()

Тип результата

Строка.


AsTextWGS84

Возвращает текстовое представление экземпляра geometry в формате WKT консорциума OGC. Координаты объекта записываются в формате широта/долгота в геодезической системе WGS84.

Синтаксис

Geometry.AsTextWGS84()

Тип результата

Строка.

Пример запроса:

SELECT Sys, L.Geometry.AsTextWGS84() FROM [Здания] AS L


Boundary

Возвращает геометрический объект, представляющий границы объекта geometry.

Синтаксис

geometry.Boundary()

Тип результата

Объект geometry.


Buffer

Возвращает геометрический объект, представляющий собой объединение всех точек, расстояние которых от экземпляра geometry меньше или равно указанному значению.

Синтаксис

geometry.STBuffer ( <distance> )

Аргументы

distance

Числовое значение – расстояние от экземпляра geometry, вокруг которого вычисляется буфер.

Тип результата

Объект geometry.


Centroid

Возвращает геометрический центр любого объекта geometry. Тип возвращаемых данных: Точка.

Синтаксис

geometry.STCentroid()

Тип результата

Объект geometry.


Contains

Возвращает значение 1, если экземпляр geometry полностью содержит другой экземпляр geometry. В противном случае возвращается значение 0.

Синтаксис

geometry.Contains( <other_geometry> )

Тип результата

Целое число 0 или 1.

Аргументы

other_geometry

Другой экземпляр geometry для сравнения (пересечения).


ConvexHull

Возвращает объект, представляющий выпуклую оболочку экземпляра geometry.

Синтаксис

geometry.ConvexHull()

Тип результата

Объект geometry.


Crosses

Возвращает значение 1, если экземпляр geometry пересекается с другим экземпляром geometry. В противном случае возвращается значение 0.

Синтаксис

geometry.Crosses( <other_geometry> )

Аргументы

other_geometry

Другой экземпляр geometry для сравнения (пересечения).

Тип результата

Целое число 0 или 1.


Difference

Возвращает объект, представляющий набор точек одного экземпляра geometry, которые не расположены в пределах другого экземпляра geometry.

Синтаксис

geometry.Difference( <other_geometry> )

Аргументы

other_geometry

Другой экземпляр geometry для сравнения (пересечения).

Тип результата

Объект geometry.


Dimension

Возвращает максимальную размерность экземпляра geometry.

Синтаксис

geometry.Dimension()


Disjoint

Возвращает 1, если экземпляр geometry не имеет пространственного перекрытия с другим экземпляром geometry. В противном случае возвращается значение 0.

Синтаксис

geometry.Disjoint( <other_geometry> )

Аргументы

other_geometry

Другой экземпляр geometry для сравнения (пересечения).

Тип результата

Целое число 0 или 1.


Distance

Возвращает наименьшее расстояние от точки в экземпляре geometry до точки в другом экземпляре geometry.

Синтаксис

geometry.Distance( <other_geometry> )

Аргументы

other_geometry

Другой экземпляр geometry, от которого измеряется расстояние.

Тип результата

Вещественное число.


EndPoint

Возвращает конечную точку экземпляра geometry.

Синтаксис

geometry.EndPoint()

Тип результата

Объект geometry.


Envelope

Возвращает минимальный, выровненный по осям, ограничивающий прямоугольник экземпляра geometry.

Синтаксис

geometry.Envelope()

Тип результата

Объект geometry.


Equals

Возвращает значение 1, если экземпляр geometry представляет тот же набор точек, что и другой экземпляр geometry. В противном случае возвращается значение 0.

Синтаксис

geometry.Equals( <other_geometry> )

Аргументы

other_geometry

Другой экземпляр geometry для сравнения.

Тип результата

Целое число 0 или 1.


ExteriorRing

Возвращает внешнее кольцо экземпляра geometry, который является многоугольником.

Синтаксис

geometry.ExteriorRing()

Тип результата

Объект geometry.


GeometryN

Возвращает указанную геометрию из коллекции GeometryCollection.

Синтаксис

geometry.GeomtryN( <int> )

Аргументы

int

Целое число от 1 до количества экземпляров в коллекции GeometryCollection.

Тип результата

Объект geometry.


GeometryType

Возвращает строку с именем типа OGC, представленное экземпляром geometry.

Синтаксис

geometry.GeometryType()


GeomFromText

Создает пространственный объект geometry из текстового описания в формате Open Geospatial Consortium (OGC) Well-Known Text (WKT).

Синтаксис

STGeomFromText ( 'geometry_text' , SRID )

Аргументы

geometry_text

Строковое WKT-представление возвращаемого экземпляра geometry.

SRID

Целочисленное выражение, представляющее идентификатор пространственной ссылки (SRID) возвращаемого экземпляра geometry.

Тип результата

Объект geometry.

Пример запроса:

DECLARE  @g_wkt geometry;
SET @g_wkt = Geometry::STGeomFromText("POLYGON((8397031.49 3358974.05, 8397031.49 3359473.28,
8396744.85 3359473.28, 8396744.85 3358974.05, 8397031.49 3358974.05))",0);
SELECT Geometry::Area(@g_wkt) AS Area;

Результат:

Area
14.3099287200332


GeomFromWKB

Возвращает экземпляр geometry из WKB-представления OGC.

Синтаксис

geometry.GeomFromWKB ( 'WKB_geometry', SRID )

Аргументы

WKB_geometry

WKB бинарное представление возвращаемого экземпляра geometry.

SRID

Целочисленное выражение, представляющее идентификатор пространственной ссылки (SRID) возвращаемого экземпляра geometry.

Тип результата

Объект geometry.


InteriorRingN

Возвращает указанное внутреннее кольцо экземпляра Polygongeometry.

Синтаксис

geometry.STInteriorRingN( <int> )

Аргументы

int

Целое число (выражение) от 1 до количества внутренних колец в экземпляре geometry.

Тип результата

Объект geometry.


Intersection

Возвращает объект, представляющий точки, в которых экземпляр geometry пересекается с другим экземпляром geometry.

Синтаксис

geometry.Intersection ( <other_geometry> )

Аргументы

other_geometry

Другой экземпляр geometry для сравнения.

Тип результата

Объект geometry.


Intersects

Возвращает значение 1, если экземпляр geometry пересекается с другим экземпляром geometry. В противном случае возвращается значение 0.

Синтаксис

geometry.Intersects ( <other_geometry> )

Аргументы

other_geometry

Другой экземпляр geometry для сравнения.

Тип результата

Целое число 0 или 1.


Is3d

Синтаксис

Аргументы


IsClosed

Возвращает значение 1, если начальная и конечная точки заданного экземпляра geometry совпадают. Возвращает значение 1 для типов коллекции geometrycollection, если каждый содержащийся в ней экземпляр geometry является замкнутым. Возвращает значение 0, если экземпляр является незамкнутым.

Синтаксис

geometry.IsClosed()

Тип результата

Целое число 0 или 1.


IsEmpty

Возвращает значение –1, если экземпляр geometry является пустым. Возвращает значение 0, если экземпляр geometry не является пустым.

Синтаксис

geometry.IsEmpty()

Тип результата

Целое число 0 или 1.

Аргументы


IsMeasured

Синтаксис

Аргументы


IsRing

Возвращает 1, если экземпляр geometry соответствует указанным ниже требованиям.

  1. Является экземпляром LineString.

  2. Закрыт.

  3. Является простым.

Возвращает значение 0, если экземпляр LineString не соответствует требованиям.

Синтаксис

geometry.STIsRing()

Тип результата

Целое число 0 или 1.


IsSimple

Возвращает 1, если экземпляр geometry является простым по определению консорциума OGC. Возвращает значение 0, если экземпляр geometry не является простым.

Синтаксис

geometry.IsSimple()

Тип результата

Целое число 0 или 1.


IsValid

Возвращает значение 1, если экземпляр geometry является экземпляром правильного формата на основе соответствующего типа OGC. Возвращает значение 0, если экземпляр geometry является экземпляром недопустимого формата.

Синтаксис

geometry.IsValid()

Тип результата

Целое число 0 или 1.


Length

Возвращает общую длину (на плоскости) элементов в экземпляре geometry.

[Примечание] Примечание

Данный метод не учитывает параметры проекции слоя. Для получения длины по сфероиду используйте метод «Length_sph».

Если экземпляр geometry замкнут, его длина вычисляется как общая длина пути обхода; длина любого многоугольника – его периметр, а длина точки – 0.

Для группы объектов находится путем вычисления суммы размеров всех содержащихся в нем экземпляров geometry.

Синтаксис

geometry.Length()

Тип результата

Вещественное число.


Length_sph

Возвращает общую длину по сфероиду (с учётом проекции слоя) элементов экземпляра geometry.

Синтаксис

geometry.Length_sph()

Пример запроса:

SELECT Sys, L.Geometry.Length(), L.Geometry.Length_sph()
FROM [Название слоя] as L

Тип результата

Вещественное число.


MakeValid

Преобразует недопустимый экземпляр geometry в экземпляр geometry с допустимым типом открытого геопространственного консорциума (OGC).

Применение этого метода может вызвать изменение типа экземпляра geometry, а также привести к небольшому сдвигу точек в экземпляре geometry.

Синтаксис

geometry.MakeValid()


NumGeometries

Этот метод возвращает число кривых в экземпляре geometry, представленном типом одномерных пространственных данных.

Синтаксис

geometry.NumCurves()

Тип результата

Целое число.


NumInteriorRing

Возвращает количество внутренних колец экземпляра Polygongeometry.

Синтаксис

geometry.NumInteriorRing()

Тип результата

Целое число.


NumPoints

Возвращает суммарное количество точек в каждой из фигур в экземпляре geometry.

Синтаксис

geometry.NumPoints()

Тип результата

Целое число.


Overlaps

Возвращает значение 1, если экземпляр geometry перекрывает другой экземпляр geometry. В противном случае возвращается значение 0.

Синтаксис

geometry.Overlaps ( <other_geometry> )

Аргументы

other_geometry

Другой экземпляр geometry для сравнения.

Тип результата

Целое число 0 или 1.


PointN

Возвращает конкретную точку в экземпляре geometry.

Синтаксис

geometry.PointN ( <int> )

Аргументы

int

Выражение типа int от 1 до количества точек в экземпляре geometry.

Тип результата

Объект geometry.


Relate

Синтаксис

Аргументы


Selected

Возвращает значение 1, если объект входит в коллекцию выделенных на карте объектов, иначе 0.

Синтаксис

geometry.Selected()

Тип результата

Целое число 0 или 1.


Srid

STSrid является целым числом, представляющим собой идентификатор пространственной ссылки экземпляра.

Синтаксис

Аргументы


StartPoint

Возвращает начальную точку экземпляра geometry.

Синтаксис

geometry.StartPoint()

Тип результата

Объект geometry.


SymDifference

Возвращает объект, представляющий все точки, принадлежащие одному из экземпляров geometry или geometry, но не лежащие одновременно в обоих экземплярах.

Синтаксис

geometry.SymDifference ( <other_geometry> )

Аргументы

other_geometry

Другой экземпляр geometry для сравнения.

Тип результата

Объект geometry.


Touches

Возвращает значение 1, если экземпляр geometry пространственно контактирует с другим экземпляром geometry. В противном случае возвращается значение 0.

Синтаксис

geometry.Touches ( <other_geometry> )

Аргументы

other_geometry

Другой экземпляр geometry для сравнения.

Тип результата

Целое число 0 или 1.


Union

Возвращает объект, представляющий объединение экземпляра geometry с другим экземпляром geometry.

Синтаксис

geometry.Union ( <other_geometry> )

Аргументы

other_geometry

Другой экземпляр geometry, образующий объединение.

Тип результата

Объект geometry.


Within

Возвращает значение 1, если экземпляр geometry находится полностью в другом экземпляре geometry. В противном случае возвращается значение 0.

Синтаксис

geometry.Within ( <other_geometry> )

Аргументы

other_geometry

Другой экземпляр geometry для сравнения.

Тип результата

Целое число 0 или 1.


X

Возвращает координату X для символьных объектов (типа Point). Если у слоя географическая система координат, то и координата Х находится в географической системе.

Синтаксис

geometry.X()

Тип результата

Вещественное число.

Пример запроса:

SELECT sys, geometry.x() as X
from teploset
where typename="Потребитель"

Результат:

sys | X
10 | 3359727.47
12 | 3359569.82
4 | 3359744.19
14 | 3359598.48


X_WGS84

Возвращает долготу в градусах (в системе WGS84) для символьного объекта (типа Point).

Синтаксис

geometry.X_WGS84()

Тип результата

Вещественное число.

Пример запроса:

SELECT sys, geometry.X_WGS84() as X_WGS84
from teploset
where typename="Потребитель"

Результат:

sys | X_WGS84
10 | 30.180945367772
12 | 30.1795291737266
4 | 30.1810955660875
14 | 30.1797866308871


Y

Возвращает координату Y для символьных объектов (типа Point). Если у слоя географическая система координат, то и координата Y находится в географической системе.

Синтаксис

geometry.Y()

Тип результата

Вещественное число.

Пример запроса:

SELECT sys, geometry.Y() as Y
from teploset
where typename="Потребитель"

Результат:

sys | Y
10 | 8396718.03
12 | 8396689.36
4 | 8396949.73
14 | 8396899.57


Y_WGS84

Возвращает широту в градусах (в системе WGS84) для символьного объекта (типа Point).

Синтаксис

geometry.Y_WGS84()

Тип результата

Вещественное число.

Пример запроса:

SELECT sys, geometry.Y_WGS84() as Y_WGS84
from teploset
where typename="Потребитель"

Результат:

sys | Y_WGS84
10 | 59.9864332877329
12 | 59.986304461177
4 | 59.9874743963984
14 | 59.9872490128545


Z

Возвращает Z (высоту) объекта. В карту обязательно должен быть добавлен слой рельефа.

Синтаксис

geometry.Z()

Тип результата

Вещественное число.


Вывод данных на карту

  • «Создание шаблона надписей»

  • «Подключение надписей»

  • «Отключение надписей»

  • «Обновление надписей»

  • «Копирование надписей»

  • «Редактирование надписей»

  • «Запись надписей в слой»

  • «Настройка порядка отображения надписей в панели Рабочее место»

  • «Удаление надписей»

  • «Импорт шаблонов надписей из одного слоя в другой»

  • «Примеры работы с надписями»

Общие сведения

Вы можете вывести на карту любые данные из базы данных. Для каждого графического объекта можно отобразить как несколько значений полей, так и только одно.

Например, если к слою зданий подключена база адресов, то адрес дома можно представить на карте различными способами. Как видно на рисунках ниже, надпись может быть расположена по-разному относительно объекта и сориентирована под произвольным углом. Также доступны различные стили настройки надписи и бирки.

В надписи по одному объекту могут участвовать значения из разных полей. Вы можете выводить их в одну или несколько строк, сопровождая каждое поле своим шрифтом, цветом, префиксом и постфиксом. Для цифровых полей можно использовать округление и множитель, для текстовых перенос слов. Цвет текста или линий надписей может быть автоматически подобран к цвету режимов типовых объектов.

Также имеется возможность одновременно подключать к каждому типу объектов слоя сразу несколько вариантов надписей.

Варианты вывода надписей на карту

Рисунок 847. Варианты вывода надписей на карту

Можно настроить индивидуальный масштаб отображения надписей, сделать настройки цвета надписи в зависимости от условий выводимых данных, скрывать определенные надписи вручную или с помощью тематических раскрасок или дополнительных настроек надписей.

[Примечание] Примечание

Подборку видеоуроков на тему работы с надписями можно посмотреть на канале компании Политерм: https://www.youtube.com/playlist?list=PLanfni5YNcFoMjF-PExFmRU3xxtbvCU71 или на сайте: https://www.politerm.com/videos/labels/.

В слое, где каждый тип объекта может иметь свою семантическую базу данных, одновременно на карту можно выводить надписи по всем объектам, для каждого типа по своему варианту.

Надписи к типовым объектам слоя

Рисунок 848. Надписи к типовым объектам слоя

Для вывода данных на карту необходимо создать надписи и подключить их.


Создание шаблона надписей

[Примечание] Примечание

Для созданных надписей в структуре слоя можно задать дополнительные опции:

  • Создавать бирки для объекта при добавлении записи в базу – если установлена данная опция, то при добавлении новых объектов на карту не придется вручную обновлять бирки, они будут обновлены автоматически.

  • Перемещать бирки при перемещении объекта – если установлена данная опция, то при перемещении объектов бирки также будут перемещены.

Эти опции можно установить в разделе Правила|Редактор структуры слоя (Слой|Структура слоя).

[Примечание] Примечание

Видеоурок по созданию надписей можно посмотреть, пройдя по одной из ссылок: https://youtu.be/AAYFCjP9-e4 или https://www.politerm.com/videos/labels/birki/MapLabelCreateUch/.

Для создания нового шаблона надписей:

  1. Выберите пункт меню Карта|Надписи|Создать надписи.

    Данный диалог также можно вызвать, сделав двойной щелчок левой клавишей мыши по разделу [image] Надписи в панели Рабочее место или нажав правой кнопкой мыши на этом же разделе и выбрав в контекстном меню пункт Создать.

    Диалог создания надписей

    Рисунок 849. Диалог создания надписей

  2. В диалоговом окне Создание надписей из открывающегося списка Слой выберите слой, для которого будут создаваться надписи (при открытии диалога будет автоматически загружен активный слой).

  3. В строке Вариант надписей вместо слова <Новый> задайте название для создаваемых надписей.

  4. Если надписи надо создать для типовых объектов, то из списка Тип объекта выберите тип, для которого они создаются. В том случае, когда надписи создаются для Примитивов (простых объектов), выбирать ничего не надо. Для примитивов слоя надписи создаются по умолчанию. В результате в строку База данных загрузится название используемой базы данных примитивами или указанным типовым объектом, а в раздел Поля базы загрузится список полей основного запроса базы.

  5. При использовании в базе данных нескольких запросов тот, по которому нужно создать надписи, можно выбрать из списка Запрос. После выбора запроса в раздел Все поля загрузится список полей выбранного запроса (если в базе данных имеется только один запрос, то выпадающий список Запрос не будет активным).

    Диалог создания надписей

    Рисунок 850. Диалог создания надписей

  6. Если в выбранном типе имеется несколько режимов и необходимо вывести надписи только для определенных режимов, то нажмите кнопку Режимы и снимите/установите флажки для необходимых режимов. Для подтверждения выбора нажмите кнопку ОК.

  7. На следующем этапе укажите поля, которые будут отображаться в надписи, они выбираются из списка Поля базы. При большом количестве полей нужное поле можно найти через поиск. Для этого введите хотя бы часть наименования поля в строку [image] , после чего ниже будет отображен список полей, удовлетворяющий введенным данным.

    Для выбора поля левой кнопкой мыши выделите его и нажмите кнопку [image] , поле добавится последним в список Поля для вывода.

    Если случайно было добавлено ненужное поле, то для того чтобы его переместить обратно в список Все поля, выделите его с помощью левой кнопки мыши и нажмите кнопку [image] . Для перемещения всех полей из списка Поля для вывода используйте кнопку [image] .

  8. Для каждого выводимого поля имеется возможность задать индивидуальные дополнительные параметры, такие как префикс, постфикс, шрифт, цвет шрифта, признак переноса для полей, следующих за этим полем, а для цифровых полей точность, специальные символы, множитель и количество выводимых знаков после запятой.

    Чтобы задать параметры, выделите нужное поле в списке Поля для вывода и сделайте для него соответствующие настройки. Подробнее.

  9. Затем в разделе Ориентация укажите способ расположения надписи относительно объекта. Подробнее.

  10. В разделе Стиль бирки определяется наличие и внешний вид выносной линии и внешний вид бирки, на фоне которой отображается надпись. При многострочном тексте бирок можно задать выравнивание текста (лево, право, центр), задать цвет надписи и ее скрытие в зависимости от ее содержимого. Также можно скрыть надписи, у которых отсутствуют данные. Подробнее.

  11. При работе с большим объемом данных вы можете установить дополнительные параметры:

    • Кэширование – с помощью данной опции можно увеличить скорость отображения бирок, при ее установке системой создается образ надписей, и он используется при каждом следующем отображении, то есть непосредственного обращения к базе данных не происходит.

      [Примечание] Примечание

      Данную опцию целесообразно использовать только в том случае, если данные в базе не меняются, так как при каждом изменении данных образ будет создаваться заново.

    • Авто фильтр – данную опцию можно попробовать включить при большом объеме данных и «подтормаживании» при отображении надписей, она регулирует внутренние процессы системы по отображению бирок.

  12. Для сохранения созданной надписи нажмите кнопку [image] Сохранить..., после чего станет активной опция, расположенная правее строки Вариант надписей. При установке данной опции произойдет подключение созданных надписей к слою.

    Рисунок 851. Подключение надписей

Если надо создать еще один вариант надписей для того же типа объекта, то из открывающегося списка Вариант надписей выберите <Новый> и место слова <Новый> введите название надписи. Далее задайте все остальные параметры.

[Примечание] Примечание

После подключения надписей можно отредактировать их положение на карте и масштаб, с которого они уменьшаются, о том, как это сделать, можно узнать в разделе «Редактирование надписей».


Дополнительные параметры выводимых полей

Дополнительные параметры задаются отдельно для каждого поля, поэтому для их задания требуется с помощью левой кнопки мыши установить курсор на одном из полей в списке Поля для вывода и только потом задать нужные настройки. Возможно настроить следующие параметры:

  • Префикс и постфикс

  • Цвет шрифта

  • Шрифт

  • Ввод специальных символов

  • Округление

  • Перенос строки

  • Перенос слов

  • Множитель

Префикс и постфикс

Это постоянная составляющая, выводимая перед (префикс) и/или после (постфикс) значением поля. Данные приставка и окончание выводятся тем же стилем, что и поле. Они могут использоваться для вывода обозначений поля или единиц измерений. Следует отметить, что если какое-то значение поля базы, входящего в надпись, пусто, то в надписи не выводится как само значение этого поля, так и его постфикс и префикс. Для настройки префикса или постфикса установите курсор в нужное окно и введите с клавиатуры данные, они так же могут быть добавлены из буфера обмена.

Для полей типа Длинный текст доступна опция Все строки. При ее установке префикс и постфикс будет выводиться для каждой отдельной строки многострочного текста.

[Примечание] Примечание

В качестве префикса и постфикса возможно использовать специальные символы, например знак диаметра.

Префикс и постфикс

Рисунок 852. Префикс и постфикс

Рисунок 853. Результат

Префикс и постфикс для полей типа Длинный текст с опцией Все строки

Рисунок 854. Префикс и постфикс для полей типа Длинный текст с опцией Все строки

Результат полей типа Длинный текст с опцией Все строки

Рисунок 855. Результат полей типа Длинный текст с опцией Все строки

Цвет шрифта

Чтобы задать один цвет сразу для всего поля достаточно из списка Цвет выбрать нужный. Цвет Авто используется для типовых объектов, при его выборе цвет текста будет подобран в соответствии с цветом их режимов.

[Примечание] Примечание

В том случае, когда при задании цвета шрифта используется цвет авто, в дальнейшем при необходимости записи надписей в слой создаваться новые типы для вариантов надписей НЕ будут.

Использование цвета Авто для шрифта

Рисунок 856. Использование цвета Авто для шрифта

Если требуется, чтобы у одного поля одновременно было задано несколько цветов, то для этого необходимо в поле Префикс или Постфикс указать с помощью специального тэга цвет в шестнадцатеричной системе в палитре GBR.

Условие для цвета задается следующим образом:

{\C цвет} префикс {\C цвет} префикс

Основные цвета в шестнадцатеричной системе в палитре GBR:

  • 000000- черный;

  • 0000FF- красный;

  • 008000- зеленый;

  • FF0000- синий;

  • 00FFFF- желтый;

  • 808080- серый;

  • FFFFFF- белый.

Рассмотрим задание цвета на конкретном примере. Предположим необходимо, чтобы поле внутренний диаметр газопровода отображался следующим образом: . То есть сначала обозначение трубопровода красным цветом, затем знак диаметра и сам диаметр черным цветом. Для вывода данных таким образом в поле Префикс необходимо ввести:

{\C 0000FF} Г3 {\C}Ø

Рисунок 857. Параметры ввода

Рисунок 858. Результат

Шрифт

Каждое из полей, входящее в надпись, может выводиться своим шрифтом. Шрифт может быть любым, установленным в Windows. Так же для шрифта могут использоваться дополнительные настройки: размер, жирность, наклон, подчеркивание, перечеркивание, ореол и бокс. Для задания шрифта и его настроек надо нажать кнопку Шрифт:

Диалоговое окно «Стиль»

Рисунок 859. Диалоговое окно «Стиль»

Ввод специальных символов

Используя кнопку [image] возможно вставить в префикс и постфикс специальные символы, например знак диаметра, подробней о вставке символов можно узнать далее в разделе «Вставка специальных символов». Специальные символы возможно использовать только при кодировке Юникод, для смены кодировки нажмите кнопку Шрифт и из открывающегося списка Набор: выберите Юникод.

Округление

Округление задается в окне Округлять до, используется для числовых полей, входящих в надпись, можно установить ограничение по выводу знаков и одновременное округление значений.

Рисунок 860. Параметры ввода

Рисунок 861. Результат

Рисунок 862. Параметры ввода

Рисунок 863. Результат

Перенос строки

Любое поле, входящее в надпись, может быть снабжено признаком переноса. Он означает, что все поля, выводимые за этим полем, будут выводиться на следующей строчке. В частности, этот признак позволяет выводить значения полей одно под другим.

Рисунок 864. Параметры ввода

Рисунок 865. Результат

Перенос слов

Если выводится длинный текст, то имеется возможность с помощью данного значения ограничить число символов в одной строке. При этом система анализирует данные и если в них окажутся слова, количество символов в которых больше указанного, то автоматически максимальное количество символов в строке будет увеличено в соответствии с количеством символов максимально длинного слова. Таки образом, если количество символов на строке будет больше введенного значения, то система будет разбивать текст построчно, и в каждой строке будет не более указанного пользователем количества, но при этом слова не разбиваются. Так же в данном разделе из списка возможно выбрать выравнивание текста: Лево, Цент, Право.

Рисунок 866. Параметры ввода

Рисунок 867. Результат

Множитель

В поле Множитель вводится число, на которое будет умножаться значение поля надписи перед выводом на экран. Например, это дает возможность хранить данные в метрах, а на карту выводить в миллиметрах, литры в кубических метрах и т.д. В системе диаметр труб для расчетов используется в метрах, а например пользователю надо вывести на карту в миллиметрах, то в этом случае в поле Множитель надо внести - 1000:

Рисунок 868. Параметры ввода

Рисунок 869. Результат


Вставка специальных символов

Для любого выводимого поля базы данных можно в качестве префикса и постфикса использовать специальные символы. Символы будут меняться в зависимости от выбранного шрифта, он выбирается в диалоге Стиль, на вкладке Шрифт (диалог вызывается кнопкой Шрифт). Так же при использовании символов, в том же диалоге обязательно необходимо установить Набор: Юникод:

Рисунок 870. Диалог Стиль

Для того чтобы вставить специальный символ:

  1. В диалоговом окне Создание надписей нажмите кнопку [image] .

  2. В общем списке символов левой кнопкой мыши выделите нужный символ, при этом он отобразится в правом нижнем окошке.

  3. Сделайте на символе двойной щелчок левой кнопкой мыши или нажмите кнопку Выбрать. Если символ был выбран ошибочно щелкните левой кнопкой мыши в строке выбранных символов и кнопкой Delete удалите ненужный символ.

  4. После выбора символа нажмите кнопку Копировать.

  5. Кнопкой Закрыть закрыть окно Выбор символов.

    Диалог выбора символов

    Рисунок 871. Диалог выбора символов

  6. В диалоге Создание надписей в разделе Поля для вывода выделите поле, для которого будет использоваться символ.

  7. Установите курсор в поле Префикс или Постфикс, сделайте щелчок правой кнопкой мыши. В открывшемся контекстном меню выберите пункт Вставить.


Ориентация надписи

В данном разделе задается расположение надписи относительно объектов и ее масштабирование.

Доступны следующие опции ориентации:

  • Вдоль линии

  • Авто

  • Наклон

  • Точка привязки надписи

  • Сдвиг надписи

  • Сдвиг надписи от габаритов объекта

  • Масштабирование надписи

  • Отображение для коротких линий

  • Сохранять угол при повороте карты

Диалог создания надписей

Рисунок 872. Диалог создания надписей

Вдоль линии

Опция может применяться как для линейных объектов так и для символьных.

Для линейных объектов при установке данной опции надпись будет выводится под тем же углом, что и линейный объект. Для полилинии надпись будет выводиться вдоль самого длинного отрезка ломаной.

Для символьных объектов надпись будет ориентирована вдоль горизонтальной оси, редактора символов. При установке данной опции дополнительно заданная ориентация будет игнорироваться.

Авто

В текущей версии опция Авто используется как для линейных, площадных так и для символьных объектов.

Для линейных и площадных объектов при указании данной опции, в том случае, если объект не будет полностью помещаться на экране, надпись будет отображаться всегда в центре видимой области объекта.

Для символьных объектов при установке Авто положение бирок будет настраиваться параметрами сдвига в разделе ориентация. Надписи всегда будут ориентированы в верхней полуокружности, что не позволит ей перевернуться.

При этом параметры сдвига, которые были заданы и сохранены до применения опции Авто будут запомнены системой, и при снятии опции Авто и сохранении изменений бирки будут возвращены в соответствии с ними.

Наклон

В редактируемом окне Наклон возможно задать в градусах угол наклона для всех надписей слоя. При установки опции Авто данный параметр будет игнорироваться.

Точка привязки надписи

С помощью курсора на пиктограмме меняется местоположение точки привязки надписи, по умолчанию точка привязки находится в центре.

Сдвиг надписи

С помощью сдвига можно задать положение надписей относительно объектов на карте (выше-ниже-справа-слева-по центру). Для этого в окне Сдвиг задается на сколько метров будет сдвинута рамка относительно объекта и направление сдвига (в градусах, 0-вправо, 90-наверх и т.д.). Если установлена опция Вдоль линии, то направление сдвига игнорируется.

Рисунок 873. Параметры ввода

Рисунок 874. Результат

[Предупреждение] Предупреждение

Если изначальные параметры сдвига были введены неверно, и шаблон надписи требуется отредактировать, то для того, чтобы новые введенные данные сдвига были применены надо установить опцию Переписать существующие надписи.

Важно! К этому нужно относится осторожно, так как в результате ВСЕ надписи или выделенная группа надписей (если применяется опция Только выделенные) примут указанное местоположение. И если ранее какие либо надписи были перемещены вручную, то вся работа по перемещению будет ПОТЕРЯНА. Возврата данной операции НЕТ. Выбирайте эту опцию только когда точно хотите избавиться от существующего варианта.

Сдвиг надписи от габаритов объекта

Опция Габарит применяется для символьных элементов. Если для надписи применяется механизм сдвига, то при включении данной опции сдвиг будет осуществляться не от центра, а от габарита объекта. Опцию можно включить только после применения опции Авто.

[Примечание] Примечание

Масштаб на карте может быть представлен в двух вариантах: геодезическом и в сантиметрах на пиксель. Выбор нужного масштаба осуществляется в параметрах системы.

Масштабирование надписи

  • Опция Масштаб 1:1 позволяет установить масштаб карты с которого создаваемые надписи при изменении масштаба будут уменьшаться.

  • При установке опции Не увеличивать больше размера 1:1 надписи не будут масштабироваться больше установленного масштаба, если же отключить эту опцию, то надписи будут изменять размер пропорционально изменению масштаба карты (аналогично текстовому объекту).

Отображение для коротких линий

По умолчанию, если при изменении масштаба надпись становится больше линейного участка, то она скрывается. Опция Отображать для коротких линий устанавливается в том случае, если необходимо выводить надпись независимо от длины объекта, к которому эта надпись относится. Эта опция становится доступна только для линейных объектов.

Сохранять угол при повороте карты

Если необходимо чтобы при повороте карты надписи сохраняли свой угол, то есть не изменяли угол наклона, то нужно установить опцию Сохранять угол при повороте карты, в противном случае надписи будут повернуты в соответствии с поворотом карты.


Стиль бирки

Стиль бирки можно настроить двумя способами. Первый способ заключается в том, что стиль не будет изменяться в зависимости от выводимых данных. Второй вариант может использоваться для числовых полей и позволяет сделать настройки таким образом, чтобы в зависимости от выводимых данных сама бирка или ее текст меняли цвет. Например, цвет бирок может отличаться у участков разной длинны, у потребителей с разной нагрузкой или у зданий разной высотности. При этом, если будут изменены данные базы, то цвет надписей тоже изменится автоматически. Такая настройка возможна для типа бирки рамка и рамка с тенью.

Так же возможно настроить чтобы скрывались или определенные надписи или все надписи у которых отсутствуют данные в указанном поле.

Настройка стиля бирки

Рисунок 875. Настройка стиля бирки

Настройка неизменяемого стиля бирки

Для такой настройки параметры выбираются из списков, которые открываются нажатием на кнопку [image] (параметр прозрачность используется только для рамки и рамки с тенью).

Все изменения по настройке стиля бирки моментально отражаются в окне справа:

Рисунок 876. Результат настройки

Тип бирки

Выбирается из списка Тип бирки и может выводиться:

  • без рамки;

  • уголком (прозрачная);

  • рамка с заливкой (по умолчанию непрозрачная, дополнительно может настраиваться прозрачность);

  • рамка с тенью (по умолчанию непрозрачная, дополнительно может настраиваться прозрачность);

  • угол с полками (прозрачный);

  • рамка с полками (прозрачная);

  • полка (прозрачная);

  • пустая рамка (прозрачная).

Цвет заливки

Настраивается для рамки с заливкой и рамки с тенью. По умолчанию цвет заливки белый. Выбирается из соответствующего списка.

Выносная линия

Выбирается из списка Выносная линия, может быть:

  • не отображаться;

  • простая;

  • со стрелкой в начале;

  • со стрелкой на конце.

Цвет линий

Выбирается из списка Цвет линий. Цвет Авто используется для типовых объектов. Если используются Типы бирки без изначальной заливки цветом, такие как уголком, угол с полками, рамка с полками, полка, пустая рамка то цвет линий подбирается в соответствии с цветом режимов, для которых выводится надпись. Когда используются типы бирки рамка с заливкой или рамка с тенью, то цвет подбирается в зависимости от цвета заливки бирок.

[Примечание] Примечание

Важно учесть такой момент, что в том случае, когда при задании цвета линий используется цвет авто, в дальнейшем при необходимости записи надписей в слой создаваться новые типы для вариантов надписей НЕ будут.

Прозрачность

Настраивается для рамки и рамки с тенью. По умолчанию рамки не прозрачны. Для настройки следует ввести нужное значение прозрачности.

Настройка скрытия бирки, цвета рамки и текста в зависимости от данных

Настройка цвета бирки может применяться только в том случае, если Тип бирки для нее выбран как рамка или рамка с тенью. Для остальных вариантов типа рамки цвет заливки задать невозможно.

Чтобы вызвать окно настройки надо нажать кнопку Дополнительно. Далее из списка Поле надписи следует выбрать поле, для которого будет производится настройка. Затем задаются параметры настройки:

  • В столбцах От и до задаются диапазоны окраски бирок.

  • В столбцах Цвет рамки и Цвет текста, соответственно из открывающихся палитр выбираются цвет для рамки и текста для указанного диапазона.

  • Если требуется чтобы бирка с определенными данными скрывалась то справа в столбце Отображать следует снять галочку. По умолчанию все бирки отображаются.

  • Для скрытия бирок с отсутствующими данными в указанном поле следует установить опцию Не отображать бирку для пустого поля.

Дополнительные строки для ввода параметров в конец списка добавляются кнопкой Добавить. Если требуется вставить дополнительную строку в середину списка, следует установить курсор в строку, над которой требуется добавление и нажать кнопку Вставить.

Лишние строчки можно выделить и удалить нажатием кнопки Удалить.

Ниже представлен пример настройки в зависимости от температуры внутреннего воздуха:

Рисунок 877. Настройка параметров

Рисунок 878. Результат настройки


Подключение надписей

  • «Подключение надписей поштучно»

  • «Подключение всех надписей одновременно»

Подключить те или иные надписи к тому или иному слою на карте, означает указать системе для какого слоя какой вариант из ранее созданных надписей выводить на карту. Можно надписи подключать как поштучно так и подключить все надписи карты или слоя одновременно.

Подключение надписей поштучно

[Примечание] Примечание

Видеоурок по подключению, отключению и обновлению надписей можно посмотреть пройдя по одной из ссылок: https://youtu.be/6gcejP--8OU или https://www.politerm.com/videos/labels/birki/podklyuchenie-otklyuchenie-i-obnovlenie-nadpisey/.

[Примечание] Примечание

Если подключенные надписи перекрывают друг друга, то порядок их отображения на карте и соответственно перекрытия будет определяться порядком их включения. Последняя включенная надпись перекроет предыдущие.

Существует несколько вариантов подключения надписей.

Первый вариант:

  1. Выбрать пункт меню Карта|Надписи|Подключить надписи или сделать щелчок правой кнопкой мыши по разделу [image] Надписи соответствующего слоя в панели Рабочее место и выбрать в открывшемся контекстном меню пункт Подключить.

  2. Подвести курсор к варианту надписи, который надо подключить и сделать на нем двойной щелчок левой кнопкой мыши. Подключенная надпись будет помечена иконкой [image] .

    Кнопка Включить все произведет подключение сразу всех надписей карты.

  3. Чтобы подтвердить подключение надписи надо нажать кнопку Применить, для подтверждения подключения и одновременно закрытия диалогового окна бирки, надо нажать кнопку ОК.

    Окно подключения надписей к слою

    Рисунок 879. Окно подключения надписей к слою

Для подключенного варианта надписи возможно установить дополнительные опции:

  • Кэширование данных - с помощью данной опции можно увеличить скорость отображения бирок, при ее установке системой создается образ надписей, и при каждом следующем отображении он используется, т.е. непосредственного обращения к базе данных не происходит. НО опцию целесообразно использовать только в том случае, если данные в базе не меняются, так как при каждом изменении данных образ будет создаваться заново.

  • Авто фильтр - при большом объеме данных и «подтормаживании» при отображении надписей данную опцию можно попробовать включить, она регулирует внутренние процессы системы по отображению бирок.

  • Не отображать при масштабе меньше, чем 1: - при установке данной опции надписи не будут отображаться, если масштаб станет меньше заданного (значение применяется для конкретной карты и сохраняется в ее описателе ZMP), масштаб указывается или геодезический и в сантиметрах на пиксель, в зависимости от настроек системы.

  • Не отображать при масштабе больше, чем 1: - при установке данной опции надписи не будут отображаться, если масштаб станет больше заданного (значение применяется для конкретной карты и сохраняется в ее описателе ZMP), Масштаб указывается или геодезический и в сантиметрах на пиксель, в зависимости от настроек системы.

  • Порядок отображения: - определяет порядок вывода надписей на карте:

    • Отображать после всех слоев - при выборе данной опции надписи будут выведены поверх всех слоев карты.

    • Отображать после своего слоя - при выборе данной опции надписи будут отображены после своего слоя, то есть если над слоем с подключенными надписями в карте будут находится еще слои, то их объекты могут перекрыть надписи.

      [Примечание] Примечание

      Надписи, созданные с опцией Авто всегда будут поверх всех слоев.

Второй вариант подключения надписей:

Подключить конкретную надпись можно также нажав правой кнопкой мыши по названию надписи в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Подключить или сделав щелчок левой кнопкой мыши по его иконке [image] .

Надписи в панели рабочее место

Рисунок 880. Надписи в панели рабочее место

Подключение всех надписей одновременно

Возможно подключить одновременно все надписи определенного слоя или карты.

Для подключения всех надписей карты выберите меню Карта|Надписи| [image] Включить все надписи или сделайте щелчок правой кнопкой мыши по названию карты в панели Рабочее место и выберите в открывшемся контекстном меню пункт [image] Подключить все надписи.

Подключить все надписи определенного слоя можно сделав щелчок левой клавишей мыши по иконке [image] Надписи соответствующего слоя в панели Рабочее место или сделав щелчок правой кнопкой мыши по названию слоя в панели Рабочее место и выбрав в контекстном меню пункт Подключить все.

Надписи в панели рабочее место

Рисунок 881. Надписи в панели рабочее место


Отключение надписей

  • «Отключение надписей поштучно»

  • «Отключение всех надписей одновременно»

Отключать надписи можно как поштучно так и все надписи карты или слоя одновременно.

Отключение надписей поштучно

Отключение надписей может осуществляться разными способами.

[Примечание] Примечание

Видеоурок по подключению, отключению и обновлению надписей можно посмотреть пройдя по одной из ссылок: https://youtu.be/6gcejP--8OU или https://www.politerm.com/videos/labels/birki/podklyuchenie-otklyuchenie-i-obnovlenie-nadpisey/.

Первый вариант отключения надписей:

  1. Отключение надписей так же как и подключение может осуществляться через диалог Бирки, для вызова диалога надо выбрать пункт меню Карта|Надписи|Подключить надписи или сделать щелчок правой кнопкой мыши по разделу [image] Надписи соответствующего слоя в панели Рабочее место и выбрать в открывшемся контекстном меню пункт Подключить.

  2. Подвести курсор к варианту надписи, который надо отключить и сделать на нем двойной щелчок левой кнопкой мыши. Отключенная надпись будет помечена иконкой [image] .

    Кнопка Отключить все произведет отключение сразу всех надписей карты.

  3. Чтобы подтвердить отключение надписи надо нажать кнопку Применить, для подтверждения отключения и одновременно закрытия диалогового окна бирки, надо нажать кнопку ОК.

Кнопка Вернуть произведет возврат диалога Бирки в начальное состояние.

Кнопка Удалить удаляет текущий в диалоге вариант надписей (шаблон при этом остается).

Второй вариант отключения надписей:

Отключить конкретную надпись можно также нажав правой кнопкой мыши по названию надписи в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Отключить или сделав щелчок левой кнопкой мыши по его иконке [image] .

Надписи в панели рабочее место

Рисунок 882. Надписи в панели рабочее место

Отключение всех надписей одновременно

Возможно отключить одновременно все надписи определенного слоя или карты.

Отключить все надписи карты можно через меню Карта|Надписи| [image] Отключить все надписи или сделав щелчок правой кнопкой мыши по названию карты в панели Рабочее место и выбрать в открывшемся контекстном меню пункт [image] Отключить все надписи.

Отключить все надписи определенного слоя можно сделав щелчок левой клавишей мыши по иконке [image] Надписи соответствующего слоя в панели Рабочее место или сделав щелчок правой кнопкой мыши по названию слоя в панели Рабочее место и выбрав в контекстном меню пункт Отключить все.

Надписи в панели рабочее место

Рисунок 883. Надписи в панели рабочее место


Обновление надписей

[Примечание] Примечание

Для автоматического обновления надписей рекомендуется в структуре слоя (Слой|Структура слоя) в разделе Правила/Редактор задать дополнительную опцию:

  • Создавать бирки для объекта при добавлении записи в базу - если установлена данная опция, то при добавлении новых объектов в слой не придется в ручную обновлять бирки, они будут обновлены автоматически.

Надписи обновлять можно разными способами.

[Примечание] Примечание

Видеоурок по подключению, отключению и обновлению надписей можно посмотреть пройдя по одной из ссылок: https://youtu.be/6gcejP--8OU или https://www.politerm.com/videos/labels/birki/podklyuchenie-otklyuchenie-i-obnovlenie-nadpisey/.

Первый вариант обновления надписей:

  1. Открыть диалог Бирки, для этого выбрать пункт меню Карта|Надписи|Подключить надписи или сделать щелчок правой кнопкой мыши по разделу [image] Надписи соответствующего слоя в панели Рабочее место и выбрать в открывшемся контекстном меню пункт Подключить.

  2. Обновление надписей для вновь созданных объектов выполняется нажатием кнопки Обновить. Выполнение обновления зависит от выбранных элементов в списке объектов диалога:

    • если выбран конкретный вариант надписи, то обновляется именно он;

    • если выбран определенный тип объектов слоя, то обновляются все варианты надписей для этого типа;

    • если выбран слой – обновляются все варианты надписей для всех типов в этом слое.

  3. Чтобы подтвердить обновление надо нажать кнопку Применить, для подтверждения обновления и одновременно закрытия окна, надо нажать кнопку ОК.

Второй вариант обновления надписей:

Обновить надписи можно так же сделав щелчок правой кнопкой мыши по разделу Надписи (тогда будут обновлены все надписи слоя) или по названию надписи (тогда будет обновлена только данная надпись) в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Обновить.


Копирование надписей

Вы можете копировать надписи несколькими способами.

Первый вариант копирование надписей:

  1. Сделайте щелчок правой кнопкой мыши на надписи, которую надо скопировать в окне Рабочее место.

  2. В открывшемся меню выберите пункт Дублировать.

  3. Введите название для копии надписей, нажмите кнопку ОК.

    Рисунок 884. Копирование надписей

Второй вариант копирование надписей:

  1. Откройте диалог Бирки. Для этого выберите пункт меню Карта|Надписи|Подключить надписи или сделайте щелчок правой кнопкой мыши по разделу [image] Надписи соответствующего слоя в панели Рабочее место и выберите в открывшемся контекстном меню пункт Подключить.

  2. Выделите надпись, для копирования.

  3. Нажмите кнопку Дубль....

  4. В открывшемся окне введите название для копии, нажмите кнопку ОК.

  5. Закройте диалоговое окно Бирки.


Редактирование надписей

Вы можете редактировать как созданный ранее шаблон надписи так и редактировать сами надписи непосредственно на карте.

Редактирование шаблона надписей:

  • «Редактирование шаблона надписи»

Редактирование надписей на карте:

  • «Настройка масштабирования надписей»

  • «Выделение группы объектов для редактирования надписей»

  • «Перемещение надписей»

  • «Поворот надписи»

  • «Скрытие надписей»

  • «Перемещение точки привязки указания выносной линии»


Редактирование шаблона надписи

[Примечание] Примечание

Видеоурок по редактированию шаблона надписей можно посмотреть пройдя по ссылке: https://youtu.be/LW5COf9enIs.

По умолчанию изменения в шаблоне применяются ко всем надписям. Однако можно настроить ориентацию надписи, например, изменить её наклон или сдвинуть, только для группы определённых объектов. Для этого необходимо заранее выделить эти объекты.

Для редактирования шаблона надписи:

  1. Откройте шаблон для редактирования. Это можно сделать несколькими способами.

    Выберите пункт меню Карта|Надписи|Создать надписи. Из списка Слой выберите слой, шаблон надписи которого надо отредактировать. Из списка Вариант надписей выберите вариант для редактирования. После этого в диалог загрузятся все установленные для него опции. Если в списке вариантов нет нужного, тогда нажмите кнопку Открыть и в открывшемся стандартном окне выбора файлов найдите файл шаблона.

    ИЛИ

    Выберите пункт меню Карта|Надписи|Подключить надписи. Выделите в списке вариант надписи для редактирования и нажмите кнопку Изменить.

    ИЛИ

    Нажмите на + напротив пункта [image] Надписи в панели Рабочее место. В списке открывшихся надписей сделайте двойной щелчок по требуемому варианту надписи.

    ИЛИ

    Нажмите на + напротив пункта [image] Надписи в панели Рабочее место. Сделайте щелчок правой кнопкой мыши по требуемому варианту надписи и выберите в открывшемся контекстном меню пункт Изменить.

  2. В диалоговом окне Создание надписей сделайте редактирование.

    Отредактировать можно все доступные опции:

    • В строке Вариант надписей - название шаблона надписей.

    • В разделе Ориентация - изменить ориентацию надписей.

      Наклон и сдвиг можно применить как для всех объектов так и для выделенной группы, объекты надо заранее выделить и установить опцию Только выделенные.

      Если установлена опция Авто, то другие настройки сдвига и наклона будут проигнорированы!

      [Предупреждение] Предупреждение

      Важно! Все произведенные изменения вступят в силу после сохранения шаблона. За исключением изменений наклона, сдвига и опции Вдоль линии. Данные изменения вступят в силу только после установки опции Переписать существующие надписи и затем сохранения шаблона.

      К этому нужно относится осторожно, чтобы не потерять ценную информацию. Если нужно сменить только шаблон, но сохранить существующие местоположения надписей, скорректированных, например, редактором надписей, то эту опцию отмечать НЕЛЬЗЯ. В противном случае весь труд по редактированию пропадет. Выбирайте эту опцию только когда точно хотите избавиться от существующего варианта.

    • В разделе Стиль бирки - изменить стиль надписей.

    • Отредактировать запрос или выводимые поля.

    • Изменить дополнительные параметры выводимых полей.

    • Установить дополнительные опции для бирок.

  3. Для сохранения измененного шаблона нажмите кнопку [image] Сохранить..., если надписи подключены к слою, то произведенные изменения сразу отобразятся на карте.


Настройка масштабирования надписей

[Примечание] Примечание

Размер всех надписей слоя одновременно возможно изменить используя операцию Изменения масштаба элементов.

Основным параметром настройки масштабирования надписей является масштаб уменьшения надписей. Это тот масштаб, с которого надписи при перерисовке карты будут уменьшаться. Так как к одним и тем же объектам могут присоединяться сразу несколько вариантов надписей, то система позволяет задать масштаб, с которого надписи будут уменьшаться, как для всех вариантов надписей одновременно, так и отдельно для определенных вариантов надписей.

[Примечание] Примечание

Видеоурок по редактированию шаблона надписей можно посмотреть пройдя по одной из ссылок: https://youtu.be/aofZ040k40E или https://www.politerm.com/videos/labels/birki/nastroyka-masshtaba-nadpisey/.

Для того, чтобы задать или сменить масштаб всех вариантов надписей слоя одновременно:

  1. Сделайте слой, к которому подключены надписи редактируемым.

  2. Нажмите кнопку [image] .

  3. Если надписи уже были промасштабированы, то для отмены масштаба уменьшения нажмите кнопку [image] .

  4. Любым известным способом установите требуемый масштаб карты, и, убедившись что он визуально подходит (надписи не загромождают карту), нажмите кнопку [image] .

Для задания или смены масштаба уменьшения определенного варианта надписей:

  1. Сделайте слой, к которому подключены надписи редактируемым.

  2. Нажмите кнопку [image] .

  3. Если надписи уже были промасштабированы, то для отмены масштаба уменьшения подведите курсор к точке вывода нужного варианта надписи, сделайте щелчок правой кнопкой мыши и в открывшемся контекстном меню выберите пункт Отменить 1:1.

  4. Любым известным способом установите требуемый масштаб карты, убедитесь, что он визуально подходит (надписи не загромождают карту).

  5. Опять подведите курсор к точке вывода любой надписи данного варианта, щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Установить 1:1.

    Масштабирование определенного варианта надписи

    Рисунок 885. Масштабирование определенного варианта надписи


Выделение группы объектов для редактирования надписей

Операция выделения надписей может понадобиться для одновременного изменения параметров надписей, таких как «Поворот надписи», «Скрытие надписей», «Перемещение надписей».

По мимо далее описанного выделения возможно выделить объекты к которым относятся надписи любым известным способом.

[Примечание] Примечание

Если пред включением режима редактирования надписей ( [image] ) объекты, к которым подключены надписи были выделены, то после включения режима редактирования надписей надписи этих объектов так же будут выделены.

Для выделения объектов с надписями:

  1. Сделайте редактируемым слой, к которому подключены надписи.

  2. Включите режим редактирования надписей - [image] .

  3. Удерживая клавишу Shift подведите курсор к точке вывода надписи, нажмите левую клавишу мыши, надпись будет добавлена в группу.

    Для исключения надписи из группы удерживая клавишу Ctrl подведите курсор к точке вывода надписи и нажмите левую клавишу мыши.

    Выделение объектов с надписями

    Рисунок 886. Выделение объектов с надписями


Перемещение надписей

Надписи можно переместить как поштучно так и группой.

[Предупреждение] Предупреждение

Система не даст переместить надписи если в их шаблоне была применена опция Авто так как их местоположение определяется автоматически.

[Примечание] Примечание

Видеоурок по перемещению и повороту надписей можно посмотреть пройдя по одной из ссылок: https://youtu.be/vgr0ybpn07Y или https://www.politerm.com/videos/labels/birki/MapLabelMove/.

Для перемещения надписей:

  1. Сделайте редактируемым слой, к которому подключены надписи ( [image] ).

  2. Нажмите на панели инструментов кнопку [image] . В результате на всех бирках редактируемого слоя в виде белых квадратиков отобразятся точки привязки надписи и точки указания выносной линии.

  3. Если требуется переместить сразу одновременно несколько надписей, выделите их.

  4. Подведите курсор к точке вывода надписи и нажмите, не отпуская, левую клавишу мыши (a).

  5. Переместите надпись, при этом будет отображаться рамка, указывающая будущее положение надписи (b). При выделении группы надписей будут перемещаться сразу все надписи указанной группы.

  6. Для фиксации нового положения надписи отпустите левую клавишу мыши (c).

Рисунок 887. Перемещение надписи

[Примечание] Примечание

Если надпись была перемещена ошибочно, то для возврата ее в исходное положение нажмите кнопку [image] или комбинацию клавиш Ctrl+Z.


Перемещение точки привязки указания выносной линии

[Примечание] Примечание

Видеоурок по перемещению и повороту надписей можно посмотреть пройдя по одной из ссылок: https://youtu.be/vgr0ybpn07Y или https://www.politerm.com/videos/labels/birki/MapLabelMove/.

Для перемещения точки привязки выносной линии:

  1. Сделайте редактируемым слой, к которому подключены надписи.

  2. Нажмите на панели инструментов кнопку [image] . В результате на всех бирках редактируемого слоя в виде белых квадратиков отобразятся точки привязки надписи и точки указания выносной линии.

  3. Подведите курсор к точке указания выносной линии. Нажмите и не отпуская, левую клавишу мыши переместите курсор в новое положение. Отпустите левую клавишу мыши.

    Поворот надписи на заданный угол

    Рисунок 888. Поворот надписи на заданный угол

[Примечание] Примечание

Если точка привязки была перемещена ошибочно, то для возврата ее в исходное положение надо нажать кнопку [image] или комбинацию клавиш Ctrl+Z.


Поворот надписи

Поворот надписи может осуществляться или на заданный с помощью клавиатуры угол или с помощью мыши на произвольный угол.

[Предупреждение] Предупреждение

Система не даст повернуть надписи, если в их шаблоне была применена опция Авто так как угол их поворота определяется автоматически.

[Примечание] Примечание

Видеоурок по перемещению и повороту надписей можно посмотреть пройдя по одной из ссылок: https://youtu.be/vgr0ybpn07Y или https://www.politerm.com/videos/labels/birki/MapLabelMove/.


Поворот надписи на заданный пользователем угол

[Примечание] Примечание

Если перед поворотом предварительно выделена группа надписей, то поворот будет применим для всей группы одновременно.

Для поворота:

  1. Сделайте редактируемым слой, к которому подключены надписи.

  2. Нажмите на панели инструментов кнопку [image] . В результате на всех бирках редактируемого слоя в виде белых квадратиков отобразятся точки привязки надписи и точки указания выносной линии.

  3. Подведите курсор к точке вывода надписи, нажмите правую клавишу мыши и в появившемся контекстном меню выберите:

    • Задать угол... – при выборе данного пункта поворот надписи произойдет против часовой стрелки на заданный угол.

      ИЛИ

    • Повернуть на угол... – при выборе данного пункта заданное значение будет прибавлено к исходному углу поворота надписи, в результате надпись будет повернута на сумму углов.

  4. В появившемся диалоге в строке Угол введите значение для поворота.

  5. Для подтверждения поворота нажмите кнопку ОК. Кнопка Отмена закроет диалог без изменений.

    Поворот надписи на заданный угол

    Рисунок 889. Поворот надписи на заданный угол

[Примечание] Примечание

Если надпись была повернута ошибочно, то для возврата ее в исходное положение надо нажать кнопку [image] или комбинацию клавиш Ctrl+Z.


Поворот надписи на произвольный угол с помощью мыши

Для поворота надо:

  1. Сделайте редактируемым слой, к которому подключены надписи.

  2. Включите режим редактирования надписей ( [image] ).

  3. Подведите курсор к точке вывода надписи, нажмите и не отпускайте левую клавишу мыши.

  4. Нажмите и удерживайте на клавиатуре клавишу Ctrl.

  5. Перемещая курсор поверните надпись на необходимый угол, при этом будет отображаться рамка указывающая будущее положение надписи.

  6. Для фиксации нового положения надписи отпустите клавишу Ctrl, после чего система перейдет в режим перемещения надписи, для выхода из него надо отпустите левую клавишу мыши.

    Поворот надписи на произвольный угол

    Рисунок 890. Поворот надписи на произвольный угол

[Примечание] Примечание

Если надпись была повернута ошибочно, то для возврата ее в исходное положение надо нажать кнопку [image] или комбинацию клавиш Ctrl+Z.


Скрытие надписей

[Примечание] Примечание

Видеоурок по скрытию надписей можно посмотреть пройдя по одной из ссылок: https://youtu.be/_7KSAXbYMGs или https://www.politerm.com/videos/labels/birki/skrytie-nadpisey/.

Для того чтобы скрыть одну или несколько надписей надо:

  1. Сделайте редактируемым слой, к которому подключены надписи ( [image] ).

  2. Нажмите кнопку [image] .

  3. Если необходимо скрыть сразу несколько надписей, выделите эту группу надписей.

  4. Сделайте щелчок правой кнопкой мыши на точке вывода скрываемой надписи или одной из группы скрываемых надписей и в появившемся контекстном меню левой кнопкой мыши выбрать пункт Скрыть (a) или Скрыть все выделенные соответственно. После проделанной операции надпись будет перечеркнута (b), но невидимой она станет только после выхода из режима редактирования надписей (с).

Рисунок 891. Скрытие надписи

[Примечание] Примечание

Скрытые надписи могут быть не только перечеркнуты, но и скрыты в режиме экранного редактора. Для этого в режиме редактирования бирок с экрана нужно кликнуть правой клавишей мыши на карте и в контекстном меню отключить опцию Отображать скрытые в редакторе.

Для того, чтобы надпись сделать опять видимой, надо проделать то же самое, что и для скрытия только выбрать пункт Отображать или при выделенной группе объектов Отображать все выделенные.


Запись надписей в слой

[Примечание] Примечание

Видеоурок по записи надписей в слой можно посмотреть пройдя по одной из ссылок: https://youtu.be/TZHGGHb2b9A?list=PLanfni5YNcFoMjF-PExFmRU3xxtbvCU71 или https://www.politerm.com/videos/labels/birki/zapis-nadpisey-v-sloy/.

Операция записи надписей позволяет скопировать надписи или группу надписей в уже существующий или автоматически создаваемый слой. Надписи могут быть скопированы как в виде простого текста, ломаных или площадных объектов, так и в виде типового текстового объекта. Все атрибуты стилей объектов при копировании будут сохранены.

[Примечание] Примечание

Если требуется скопировать только определенные надписи, то их следует заранее выделить.

Для записи надписей в слой:

  1. Выберите меню Карта|Надписи|Записать в слой....

  2. В строке Имя слоя укажите слой для записи, для этого нажмите кнопку Обзор. Слой может быть как уже существующий, так и новый. При записи в уже существующий слой надо его указать и нажать кнопку Сохранить. Если требуется создать новый слой, то в строке Имя файла укажите имя для нового слоя, а в строке Название слоя - его пользовательское название.

  3. При использовании уже существующего слоя, выберите опцию Добавить в слой (надписи будут добавлены к уже существующим объектам слоя) или Создать слой заново (все ранее существующие объекты будут удалены!, а надписи добавлены).

  4. В том случае, если требуется произвести запись только определенных бирок, то их следует заранее выделить и установить опцию Записывать только бирки выделенных объектов.

  5. По умолчанию при копировании надписей в слой они копируются в виде набора простых объектов, для того, чтобы текст был скопирован как типовой объект установите дополнительные параметры:

    • Если в слое, куда будет скопирован текст уже существуют соответствующие типы и режимы, к которым должны относится надписи, то надо установить опцию Искать соответствие среди существующих типов. В результате копирования если система найдет в слое, куда будут копироваться надписи соответствующие типы и режимы, то надписи будут преобразованы в них, в противном случае надписи будут скопированы как простые объекты.

    • Если при копировании нужные типы отсутствуют, то надо установить опцию Создавать новые типы для вариантов надписей. В этом случае в структуре слоя, куда будут скопированы надписи будут созданы новые типы и режимы с параметрами копируемых бирок. Названия создаваемых типов будет соответствовать названию слоя, из которого копируются надписи, а названия создаваемых режимов будут соответствовать названию полей базы данных из которых брались данные для бирок. Стиль режимов будет соответствовать стилю исходных надписей.

      [Примечание] Примечание

      Новые типы для вариантов надписей не будут созданы если при задании цвета шрифта или линий был выбран цвет Авто.

  6. При установке опции По возможности объединять поля в один объект надписи, расположенные в одной строке, и имеющие одинаковые шрифт, размер и начертание будут объединены в один объект.

  7. С помощью галочек укажите какие надписи будут скопированы, по умолчанию галочки стоят у подключенных к текущей карте надписей.

  8. Для того, чтобы слой с записанными в него надписями был добавлен в текущую карту, установите опцию Добавить слой в карту.

    [Примечание] Примечание

    Масштаб на карте может быть представлен в двух вариантах: геодезическом и в сантиметрах на пиксель. Выбор нужного масштаба осуществляется в параметрах системы.

  9. В окне Масштаб 1:1 укажите масштаб для отображения надписей, масштаб по умолчанию считывается с карты.

    Диалоговое окно Запись бирок в слой

    Рисунок 892. Диалоговое окно Запись бирок в слой

  10. Нажмите кнопку ОК.


Настройка порядка отображения надписей в панели Рабочее место

Порядок отображения надписей в панели Рабочее место можно изменить, это особенно удобно при их большом количестве. Перемещение производится способом Drag-and-drop.

[Примечание] Примечание

Настроенный порядок отображения надписей сохраняется в файле *.b10, где * - название слоя. И данная последовательность отображения надписей будет не свойством слоя в карте, а непосредственно свойством слоя. То есть при добавлении слоя в другую карту порядок следования надписей будет сохранен. Как сохранить настройки слоя можно узнать здесь.

Для перемещения надписи:

  1. В панели Рабочее место подведите курсор к надписи, которую надо переместить. Нажмите левую клавишу мыши и не отпуская переместите надпись в нужное место.

  2. Отпустите левую клавишу мыши, объект перемещен.

    Изменение порядка отображения надписей

    Рисунок 893. Изменение порядка отображения надписей


Удаление надписей

[Примечание] Примечание

Видеоурок по удалению надписей можно посмотреть пройдя по одной из ссылок: https://youtu.be/gcBatRoR2y0 или https://www.politerm.com/videos/labels/birki/udalenie-nadpisey/.

Удалить надпись возможно двумя способами.

Первый способ:

  1. Выбрать пункт меню Карта|Надписи|Подключить надписи. В диалоге выводится список всех доступных вариантов надписей для всех слоев, входящих в текущую карту.

  2. Выделить надпись, для удаления.

  3. Нажать кнопку Удалить.

  4. Для подтверждения нажать кнопку Применить или кнопку ОК (кнопка ОК подтвердит произведенные изменения и закроет диалоговое окно Бирки).

ИЛИ

  1. Сделать щелчок правой кнопкой мыши по конкретной надписи в панели Рабочее место, в открывшемся меню выбрать пункт Удалить.

  2. Подтвердить удаление надписи нажатием кнопки Да.


Импорт шаблонов надписей из одного слоя в другой

Перед импортом в карту надо добавить слои источника шаблона надписей и слой, в который шаблоны планируется импортировать. Так же для успешного импорта необходимо убедиться, что используемые в шаблоне надписи поля баз данных имеются о обоих слоях. В случае отсутствия полей в слое для записи, в окне сообщений будет выдано сообщение об ошибке импорта.

Для импорта:

  1. В панели Рабочее место сделайте щелчок правой кнопкой мыши по разделу [image] Надписи слоя, в который требуется импортировать шаблоны надписей. В открывшемся контекстном меню выберите пункт Импорт.

    или

    Выберите меню Карта|Надписи|Подключить надписи, затем в общем списке слоев и надписей выделите слой, в который требуется импортировать шаблоны надписей. Нажмите кнопку Импорт.

  2. В открывшемся диалоге Импорт бирок из списка Слой источник выберите слой, из которого будут импортированы шаблоны.

  3. В окне Бирки для импорта отметьте шаблоны для импорта. Для одновременного выделения всех шаблонов установите опцию Все.

    Диалоговое окно Импорт надписей

    Рисунок 894. Диалоговое окно Импорт надписей

  4. Нажмите кнопку ОК.

В случае удачного импорта шаблонов надписей будет выдано соответствующее сообщение. Если импорт невозможен, то причина отобразится в окне сообщений.


Примеры работы с надписями

[Примечание] Примечание

Подборку видеоуроков по работе с надписями вы можете найти на нашем сайте.

Далее рассмотрен пример создания надписей для слоя Здания и слоя Пример квартальной сети, которые находятся в карте Пример тепловой сети и расположены в папке \Examples\Termo\Kvartal\. В результате выполнения примера будет создано следующие варианты надписей:

  • вариант надписи, в котором будет выводиться номер дома и корпус для слоя Здания;

  • вариант надписи, в котором будет выводиться длинна, диаметр в миллиметрах и удельное сопротивление участка;

  • вариант надписи, в котором будет выводиться расчетная нагрузка на отопление, расчетная нагрузка на вентиляцию, и расчетная средняя нагрузка на ГВС у потребителя.

Для выполнения примера запустите ZuluGIS и загрузите карту Пример тепловой сети.


Пример вывода на карту номеров домов и корпусов

Для создания и подключения варианта надписи, в котором будет выводиться номер дома и корпус выполните следующее:

  1. В меню Карта выберите команду Надписи|Создать надписи.

  2. Из открывающегося списка Слой выберите слой Здания.

  3. В строке Вариант надписей вместо слова <Новый> задайте название для создаваемых надписей, например Номер дома и корпус.

  4. В строке Тип объекта ничего изменять не надо, там должна оставаться надпись <Примитивы>, так как дома в данном примере являются простыми объектами, то есть примитивами.

  5. Далее надо указать поля, которые будут отображаться в надписи. Выделите с помощью левой кнопки мыши поле Номер дома в списке Все поля и нажмите кнопку [image] , после этого имя выбранного поля добавится в список Поля для вывода. Таким же образом добавьте поле Корпус.

  6. Следующим этапом надо задать префикс, стиль шрифта и признак переноса для надписей. Для задания этих параметров с помощью левой кнопки мыши выделите поле Номер дома в списке Поля для вывода, далее занесите для него в строку Префикс «д.», нажмите кнопку Шрифт, в появившемся диалоге выберите Полужирный и нажмите ОК. Установите опцию Перенос строки. Снимите опцию Округлять до.

    Точно таким же образом для поля Корпус задайте префикс «к.», полужирный шрифт снимите опцию Округлять до.

  7. В разделе Ориентация установите опцию Масштаб 1:1 (уменьшение надписей будет происходить с текущего масштаба).

  8. В разделе Стиль бирки задайте стиль бирки. Параметры выбираются из списков, которые откроются нажатием на кнопку [image] . Задайте рамку с тенью с голубой заливкой. Прозрачность поставьте 50%.

  9. Нажмите кнопку Сохранить, в следствии чего произойдет сохранение созданной надписи и станет активной опция, расположенная правее строки Вариант надписей. Для подключения созданного варианта надписей к слою установите данную опцию.

Создание варианта надписи "Номер дома и корпус"

Рисунок 895. Создание варианта надписи "Номер дома и корпус"


Пример вывода на карту длин, диаметров участков и удельных линейных потерь

Для создания и подключения варианта надписи, в котором будет выводиться длинна, диаметр участка (в миллиметрах) и удельные линейные потери выполните следующее:

  1. В меню Карта выберите команду Надписи|Создать надписи.

  2. В диалоговом окне Создание надписей из списка Слой выберите слой Пример тепловой сети.

  3. В строке Вариант надписей вместо слова <Новый> задайте название для создаваемых надписей, например Длинна, диаметр и удельные потери.

  4. Из списка Тип объекта выберите тип Участки, после чего в раздел Все поля загрузится подключенная к участкам база.

  5. Для того, чтобы данные выводились только по включенным участкам нажмите кнопку Режимы и установите галочку напротив режима Включен. Чтобы подтвердить выбор нажмите кнопку ОК.

  6. Далее укажите поля, которые будут отображаться в надписи. Выделите с помощью левой кнопки мыши поле Длинна участка в списке Все поля и нажмите кнопку [image] , после этого имя выбранного поля добавится в список Поля для вывода. Таким же образом добавьте поля Внутренний диаметр подающего трубопровода и Удельные линейные потери напора в под. тр-де.

  7. В списке Поля для вывода выделите поле Длина участка и для него задайте:

    • Префикс - для ввода префикса установите курсор в строку Префикс и введите «L=».

    • Постфикс, постфиксом в данном случае будут единицы измерения, т.е. метры. Для этого установите курсор в строку Постфикс и введите «м».

    • Полужирное начертание шрифта, для этого нажмите кнопку Шрифт и в появившемся диалоге выберите Полужирный, кнопкой ОК подтвердите установку начертания.

    • Проверьте чтобы была установлена галочка Округлять до и в окошке поставьте 1 знак.

  8. В списке Поля для вывода выделите поле Внутренний диаметр и для него задайте:

    • Префикс, им будет специальный символ диаметра. Для его задания предварительно надо установить нужную кодировку, нажмите кнопку Шрифт, справа из списка Набор: выберите Юникод, нажмите ОК. Далее нажмите кнопку [image] , в открывшемся окне выделите символ диаметра, нажмите кнопку Выбрать, затем Копировать и Закрыть. Установите курсор в поле Префикс, сделайте щелчок правой кнопкой мыши и в открывшемся меню выберите пункт Вставить.

    • Постфикс, для его задания установите курсор в строку Постфикс, внесите «мм», и укажите полужирный шрифт.

    • Установите опцию перенос строки.

    • Так как диаметр трубопровода надо выводить в миллиметрах, а в базу для расчетов он внесен в метрах, то необходимо задать множитель, в данном случае множитель для перевода будет - 1000. Множитель вводится в окно Множитель.

    • Чтобы после точки не выводились дополнительные нули проверьте чтобы была установлена опция Округлять до и в окошке установите 0 знаков.

  9. В списке Поля для вывода выделите поле Удельные линейные потери напора в под. тр-де и для него задайте:

    • Префикс - внесите в окошко «hl=».

    • Постфикс, для его задания установите курсор в строку Постфикс, внесите «мм/м», и укажите полужирный шрифт.

    • Проверьте чтобы была установлена галочка Округлять до и в окошке поставьте 2 знака.

  10. В разделе Ориентация установите опции Вдоль линии и Авто, это нужно для того, чтобы надписи были ориентированы вдоль участков и всегда отображались в центре видимой части участка соответственно. Так же установите опции Масштаб 1:1, Не увеличивать больше размера 1:1 и Сохранять угол при повороте карты.

  11. Для того чтобы надписи выводились в рамке в разделе Стиль бирки из списка Тип бирки выберите рамка.

  12. Далее настроим надписи таким образом, чтобы их цвет менялся в зависимости от данных в поле Удельные линейные потери. Для этого нажмите кнопку Дополнительно. Из списка Поле надписи выберите Удельные линейные потери. Затем задайте промежутки и цвета, соответствующие им:

    Задание настраиваемого цвета надписей

    Рисунок 896. Задание настраиваемого цвета надписей

    Для подтверждения и закрытия диалога Цвета нажмите ОК.

  13. Нажмите кнопку Сохранить, в следствии чего произойдет сохранение созданной надписи и станет активной опция, расположенная правее строки Вариант надписей. Для подключения созданного варианта надписей к слою установите данную опцию:

    Создание варианта надписи "Длинна, диаметр и удельные линейные потери"

    Рисунок 897. Создание варианта надписи "Длинна, диаметр и удельные линейные потери"

В результате проделанных действий были созданы надписи для вывода данных из базы, цвет надписей будет меняться в зависимости от содержимого поля Удельные линейные потери.

Подключенные надписи к участкам

Рисунок 898. Подключенные надписи к участкам


Пример вывода на карту расчетной нагрузки на отопление, расчетной нагрузки на вентиляцию, и расчетной средней нагрузки на ГВС

Для создания и подключения варианта надписи, в котором будет выводиться расчетная нагрузка на отопление, расчетная нагрузка на вентиляцию, и расчетная средняя нагрузка на ГВС у потребителя выполните следующее:

  1. В меню Карта выберите команду Надписи|Создать надписи.

  2. В диалоговом окне Создание надписей из списка Слой выберите слой Пример тепловой сети.

  3. Из Проверьте чтобы в списке Вариант надписей стоял <Новый>, вместо слова <Новый> задайте название для создаваемых надписей, например Нагрузки.

  4. Из списка Тип объекта выберите тип Потребитель, после чего в раздел Все поля загрузится подключенная к потребителям база.

  5. Далее укажите поля, которые будут отображаться в надписи. Выделите с помощью левой кнопки мыши поле Расчетная нагрузка на отопление в списке Все поля и нажмите кнопку [image] , после этого имя выбранного поля добавится в список Поля для вывода. Таким же образом добавьте поля Расчетная нагрузка на вентиляцию и Расчетная нагрузка на ГВС.

  6. Задайте префикс, постфикс, стиль шрифта и признак переноса для надписей. Для задания этих параметров с помощью левой кнопки мыши выделите поле Расчетная нагрузка на отопление в списке Поля для вывода, далее занесите для него в строку Префикс «Qo=», в строку Постфикс «Гкал/ч», нажмите кнопку Шрифт, в появившемся диалоге выберите Полужирный. Установите опцию Перенос строки. Точно таким же образом для поля Расчетная нагрузка на вентиляцию задайте префикс «Qv=», постфикс «Гкал/ч», и полужирный шрифт. Установите опцию Перенос строки.

    Аналогично для поля Расчетная нагрузка на ГВС задайте префикс «Qgv=», в строку Постфикс «Гкал/ч», и полужирный шрифт.

  7. В разделе Стиль бирки выберите выносную линию, тип бирки и цвет линий.

  8. Для того, чтобы надписи не загораживали потребителей в разделе Ориентация установите Сдвиг на 5 метров, наклон на 30 градусов, точку привязки надписи перенесите в правый верхний угол, так же установите опции Масштаб 1:1 и Не увеличивать больше размера 1:1.

  9. Нажмите кнопку Сохранить, в следствии чего произойдет сохранение созданной надписи и станет активной опция, расположенная правее строки Вариант надписей. Для подключения третьего варианта надписей к слою установите данную опцию.

  10. Создание варианта надписи “Нагрузки”

    Рисунок 899. Создание варианта надписи “Нагрузки”

  11. Если надписи при установленном сдвиге все равно загораживают потребителей, то можно его изменить. НО изменения сдвига вступят в силу только при установленной опции Переписать существующие надписи. С этой опцией надо быть очень осторожными, так как она возвращает перемещенные ранее вручную надписи в исходное положение, на указанное количество метров и градусов!

  12. Закройте диалоговое окно Создание надписей.

Результат создания и подключения надписей

Рисунок 900. Результат создания и подключения надписей


Тематическая раскраска

  • «Создание тематической раскраски»

  • «Создание тематического фильтра»

  • «Редактирование темы»

  • «Подключение темы»

  • «Отключение темы»

  • «Обновление темы»

  • «Переименование темы»

  • «Копирование тематической раскраски»

  • «Удаление темы»

  • «Импорт тематических раскрасок из одного слоя в другой»

  • «Примеры работы с тематической раскраской»

В ZuluGIS вы можете изменять индивидуальные параметры отображения графических объектов по заданным условиям выборки информации из семантических баз данных, подключенных к объектам слоя. С помощью ряда запросов можно присвоить те или иные параметры отображения графическим объектам, удовлетворившим тому или иному условию запроса. Например, сделать для участков окраску в зависимости от диаметра трубопровода или от скорости движения воды или задать цвет всем нежилым домам, как показано на рисунке ниже. Желтый – нежилые дома, красный – жилые, школы – голубые, детские сады – зеленые:

Пример тематической раскраски карты

Рисунок 901. Пример тематической раскраски карты

С помощь окраски можно не только менять цвет объекта, но и делать новые стили для объектов, скрывать объекты или подключенные к ним надписи, устанавливать на площадные объекты символы, менять символам размер или отображать символьные объекты новыми символами. При этом тематическая раскраска может применяться не ко всем объектам типа, а к определенным режимам или условиям фильтра.

Тематических фильтров может быть сколько угодно, и один слой можно «раскрашивать» различными способами, подключая к нему ту или иную тему.

Имеются следующие виды раскраски:

  • раскраска с помощью собственного фильтра – позволяет окрасить любые объекты сети с помощью самостоятельно созданного нового тематического фильтра, далее описано создание именно этого вида раскраски.

  • раскраска с помощью встроенных фильтров – данный вид раскраски используется только для инженерных сетей, применяют ее сразу после расчета. По умолчанию при закрытии панели расчетов раскраска отменяется, но имеется возможность ее сохранить. Такой вид раскраски не редактируется так как не содержит фильтров, его так же можно программно создавать. Сохранение раскраски по зонам не предусмотрено.

    Подробно о раскраске после расчетов написано в документации по сетям:

    • ZuluThermo;

    • ZuluHydro;

    • ZuluGaz;

    • ZuluSteam.

Тематическая раскраска состоит из темы – результата раскраски и фильтра, в котором указываются параметры, по которым будет производиться изменение внешнего вида объектов. К слою в дальнейшем подключается тема.


Создание тематической раскраски

Перед тем как приступить к созданию тематической раскраски, загрузите в карту слой, для которого будет создаваться эта раскраска. Также проверьте, чтобы к объектам данного была подключена база данных. В дальнейшем для этой базы будут задаваться условия запросов, на основе которых и будет осуществляться раскраска.

Для создания темы:

  1. Выберите пункт меню Карта|Тема|Создать.

  2. Из списка Слой выберите слой, для которого создается тема (рисунок Рисунок 903, «Диалоговое окно создания тематической раскраски»).

    Данный диалог также можно вызвать, нажав правой кнопкой мыши по разделу Темы нужного слоя в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Создать.

    Создание темы в панели Рабочее место

    Рисунок 902. Создание темы в панели Рабочее место

  3. С правой стороны от списка Фильтр нажмите кнопку Редактор и в открывшемся диалоговом окне настройте и сохраните новый тематический фильтр (начиная с пункта 3). Если фильтр был ранее уже создан, то для подключения к теме его надо выбрать из списка.

  4. После того как тематический фильтр уже создан, в строке Тема вместо надписи <Новая> введите название темы. Желательно, чтобы название коротко раскрывало смысл данной «раскраски» слоя. Именно это название в дальнейшем будет отображаться в списке тематических раскрасок. Если надо переписать уже существующею тему, которая ранее подключалась к выбранному слою, то ее название выбирается из открывающегося списка.

  5. Чтобы при изменении значений в семантической базе данных тематическая раскраска будет обновляться автоматически установите опцию Обновлять автоматически.

  6. Для подключения темы сразу после создания отметьте опцию Подключить к карте.

    Диалоговое окно создания тематической раскраски

    Рисунок 903. Диалоговое окно создания тематической раскраски

  7. Создание темы завершается нажатием кнопки OK.

Если все настройки были произведены верно, то тема будет подключена к слою.


Создание тематического фильтра

В тематическом фильтре задаются параметры, по которым будет производиться изменение внешнего вида объектов. При этом в одном фильтре условия могут быть заданы по разным семантическим базам.

Если диалог создания фильтра был открыт через диалог Создания тематической раскраски, то переходите сразу к пункту 3, в противном случае начните с 1 пункта:

  1. Для создания и настройки фильтра выберите пункт меню Карта|Тема|Редактор фильтра.

  2. Нажмите кнопку [image] Слой..., в появившемся стандартном окне выбора файла выберите имя слоя, для которого будет создаваться тематическая раскраска.

    Данный диалог также можно вызвать, нажав правой кнопкой мыши по разделу Темы в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Редактор фильтров.

  3. В строке Шаблон вместо слова <Новый> задайте пользовательское название шаблона тематического фильтра. Желательно, чтобы данное название отражало смысл раскраски.

    [Примечание] Примечание

    Если шаблон уже существует, то его можно выбрать из списка.

  4. В фильтре может быть задано как одно условие, так и несколько, для каждого условия есть возможность задать имя (данное поле не обязательно). Имя условия вводится в строку Имя.

  5. Из списка База выберите базу данных, на основе которой будут настраиваться условия для тематического отображения. Список будет отображать те базы данных, которые используются примитивами или типовыми объектами ранее выбранного слоя. Если в базе создано несколько запросов, в поле Запрос также требуется выбрать нужный запрос.

    После выбора базы и запроса левая колонка таблицы диалога заполнится пользовательскими названиями полей выбранной базы данных.

    Рисунок 904. Выбор режима

  6. В правой колонке таблицы напротив желаемых полей задайте первое условие для тематического фильтра. При задании условий можно использовать идентификаторы полей (F1, F2, ...), константы, функции и операторы, их список вызывается нажатием на кнопку [image] . Синтаксис условий аналогичен синтаксису в окне запросов по семантической базе данных. Условия могут быть заданы как по одному полю, так и по нескольким одновременно.

  7. Если у объектов, для которых создается тематический фильтр, имеется несколько режимов, то можно настроить раскраску только для определенных режимов. При этом раскраска может применяться как к указанным режимам, так и к конкретным условиям фильтра режимов. В первом случае, например, можно изменить внешний вид только для работающих потребителей, а для отключенных потребителей раскраску не применять. Во втором случае раскраска может применяться, например, к включенным потребителям, удовлетворяющим определенным, прописанным в фильтре условиям.

    Для того чтобы весь тематический фильтр применялся к определенным режимам, надо нажать кнопку Режимы общие, затем установить флажок напротив нужных режимов.

    Если же фильтр должен применяться к режимам, удовлетворяющим определенным условиям, то надо нажать кнопку Режимы условия и затем установить флажок напротив нужных режимов. В этом случае раскраска будет применена к выбранным режимам и условиям, которые были заданы на предыдущем этапе (пункт 6).

    Рисунок 905. Выбор режима

  8. В зависимости от графического вида объектов, для которых создается раскраска, выберите соответствующую вкладку и задайте желаемые параметры отображения (цвет, стиль, толщину и т.д.), соответствующие первому запросу. При задании параметров указывайте только те из них, которые интересуют (например, только цвет узора). Остальные при отображении слоя будут браться такими же, как если бы тема к слою не была подключена. Если в окошке отображается -1 или [image] , это означает, что значение параметра не будет меняться и останется исходным.

    • Во вкладке Площадные параметры задаются для площадных объектов – полигонов (домов, кварталов, водоемов и т.д.). Для каждого условия можно задать как цвет, стиль заливки, стиль и цвет границы площадного объекта и прозрачность, так и символ заданного размера с заданными условиями масштабирования. Точки вывода символов внутри площадных объектов при создании раскраски из диалога Создание тематической раскраски определяются автоматически. Символ должен быть заранее создан в структуре слоя.

      Настройка площадных объектов

      Рисунок 906. Настройка площадных объектов

    • Во вкладке Линейные задаются параметры для линейных объектов (участков, ж.д. дорог и т.д.).

      В разделе Линия можно задать цвет, выбрать стиль ( [image] ), толщину на экране и при печати.

      Помимо этого, возможно установить масштабирование линии в зависимости от масштаба карты. Масштабирование будет производится после ведения коэффициента масштабирования в строку Масштаб1:. Если для тематической окраски введено значение толщины линии на экране, то коэффициент будет применяться к данному значению. Если он не введен, стоит -1, то коэффициент будет применен к исходным параметрам линейных объектов. Масштаб указывается аналогично масштабу, который задается для типовых объектов при создании режима, а для простых объектов он указывается перед их нанесением.

      В разделе Ореол вы можете настроить параметры ореола для линейных объектов. В выпадающем списке Цвет выберите желаемый цвет ореола, а в окне Процент от толщины линии установите необходимый процент от текущей толщины. Например, если толщина линии составляет 4 пикселя, а процент — 100, то ореол будет иметь ширину 2 пикселя с каждой стороны линии.

      [Примечание] Примечание

      При подключении тематической раскраски с указанным коэффициентом масштаба линия будет масштабироваться независимо от того, установлена ли опция масштабирования в ее исходный параметрах.

      Настройка линейных объектов

      Рисунок 907. Настройка линейных объектов

    • Во вкладке Символьные задаются параметры для символьных объектов (потребителей, узлов, источников и других). Задать можно цвет, размер и признак масштабируемости. Параметр цвет для символа будет применен только в том случае, если изначальный цвет символа был задан как авто.

      Для символов, у которых был задан определенный цвет, требуется создать новый символ, которым будут отображены объекты, удовлетворяющие заданным условиям. Для создания нового символа надо нажать кнопку Новый символ и нарисовать его в редакторе символов. Кнопка Изменить символ также откроет окно редактора символов, но с загруженным в него текущим символом для его изменения.

      Настройка символьных объектов

      Рисунок 908. Настройка символьных объектов

  9. Также помимо ранее указанных характеристик объекты могут быть скрыты совсем или при определенном масштабе и скрыты надписи, подключенные к ним. Для включения этих параметров установите галочку напротив нужной опции. Если в окошке отображается -1 или [image] , это означает, что значение параметра не будет меняться и останется исходным.

    • Невидимый объект – объекты, соответствующие заданному условию станут невидимыми. Для скрытия их при определенном масштабе внесите масштаб в одно или оба окошка М мин и М макс. Например, если надо скрыть объекты при масштабе равном или больше чем 5000 в окно М мин внесите значение 5000.

    • Невидимая надпись – надписи, подключенные к объектам, соответствующим заданному условию, станут невидимыми.

  10. Для ввода следующего условия запроса нажмите кнопку [image] . Таблица очистится, далее повторите пункты с 4 по 9. Пункт 5 повторяется в том случае, если надо задать условия запроса по другой базе данных, используемой выбранным слоем. Пункт 7 повторяется, если раскраска задается определенному режиму по условиям.

    Количество запросов не ограничено. Запросы при подключении тематической раскраски будут выполняться последовательно, начиная с первого. Соответственно, объекты, удовлетворившие условиям запроса, получат параметры отображения в той же последовательности. По этой причине рекомендуется более общие запросы ставить вначале.

    Например, если мы хотим покрасить все жилые дома красным, а жилые пятиэтажные дома зеленым, то в поле базы данных по адресам «Тип» первым должен стоять запрос *КЖ*, а вторым 5КЖ. В противном случае более общее условие перекроет более конкретное.

    При необходимости запросы можно поменять местами, для этого используются кнопки:

    • Вверх, [image] Вниз – изменить местоположение текущего условия на одно положение вверх или вниз соответственно;

    • Вставить – вставить новое условие перед текущим условием;

    • Удалить – удалить текущее условие запроса из списка запросов;

    • Очистить – очистить все строки текущего условия.

    Перемещаться между запросами можно, используя следующие кнопки:

    • , [image] – переместиться к предыдущему/следующему запросу, соответственно;

    • , [image] – переместиться к первому/последнему запросу, соответственно.

    Диалоговое окно создания тематического фильтра

    Рисунок 909. Диалоговое окно создания тематического фильтра

  11. Для завершения создания шаблона тематического фильтра нажмите кнопку [image] Сохранить....

  12. Затем закройте окно создания тематического фильтра с помощью кнопки Закрыть.

    Если диалог Тематический фильтр был вызван из диалога Создание тематической раскраски, то после нажатия кнопки Закрыть будет произведен возврат к нему.


Редактирование темы

Если тематическая раскраска уже была создана, то ее редактирование заключается в изменении параметров тематического фильтра. Для его редактирования:

  1. Выберите пункт меню Карта|Тема|Редактор фильтра или нажмите правой кнопкой мыши по разделу Темы нужного слоя в панели Рабочее место и выберите в открывшемся контекстном меню пункт Редактор фильтров.

    Так же если в окне Рабочее место сделать двойной щелчок по нужной теме ( [image] ) или сделать щелчок правой кнопкой мыши на конкретной теме и выбрать пункт Изменить, то откроется фильтр уже с загруженными данными, тогда далее следует перейти сразу к пункту 4.

  2. Если слой не выбран, то нажмите кнопку [image] Слой..., в появившемся стандартном окне выбора файла выберите имя слоя, тематический фильтр которого надо редактировать.

  3. Щелкните на стрелку открывающегося списка Шаблон и выберите из списка шаблон для редактирования. После выбора шаблона левая колонка таблицы диалога заполнится пользовательскими названиями полей базы данных, а правая первым условием запроса. Если в списке шаблонов нет нужного шаблона, тогда в окне Тематический фильтр надо нажать кнопку Открыть и в открывшемся стандартном окне выбора файлов найти необходимый шаблон.

  4. Сделайте нужные изменения в шаблоне, все параметры редактируются аналогично созданию тематического фильтра. Для перехода от одного запроса к другому воспользуйтесь кнопками [image] и [image] . Кнопки [image] и [image] позволят перейти к первому и последнему запросу соответственно.

  5. После завершения редактирования тематического фильтра нажмите кнопку [image] Сохранить.... В том случае если тема подключена к слою, то результаты редактирования сразу будут отражены в слое.


Подключение темы

  • «Подключение тем поштучно»

  • «Подключение всех тем слоя»

Если при создании темы была отмечена опция Подключить к карте, то сразу после создания тема будет подключена. В дальнейшем для подключения темы можно использовать несколько способов. Можно подключать как каждую тему отдельно так и сразу все темы слоя.

Подключение тем поштучно

[Примечание] Примечание

Порядок отображения тем на карте определяется порядком их включения. Последняя включенная тематическая окраска будет отображаться самой последней, и соответственно возможно перекрывать предыдущие темы.

Первый вариант:

  1. Выберите пункт меню Карта|Тема|Подключить. В диалоге выводится список всех доступных тематических раскрасок для всех слоев, входящих в текущую карту.

    Данный диалог также можно вызвать нажав правой кнопкой мыши по разделу Темы в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Подключить.

  2. Подведите курсор к тематической раскраске, которую надо подключить и сделайте двойной щелчок левой кнопкой мыши. Подключенная раскраска будет помечена иконкой - [image] .

  3. Для подтверждения подключения темы нажмите кнопку Применить или кнопку ОК (кнопка ОК подтвердит произведенные изменения и закроет диалоговое окно Тематические раскраски).

    Диалоговое окно подключения тематических раскрасок

    Рисунок 910. Диалоговое окно подключения тематических раскрасок

    С помощью кнопки Вернуть можно произвести возврат диалога Тематические раскраски в исходное состояние.

    Кнопка Изменить вызывает окно редактирования тематического фильтра.

Второй вариант подключения темы:

Подключить тему можно нажав правой кнопкой мыши по названию темы в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Подключить или сделав один щелчок левой кнопкой мыши по его иконке [image] .

Тематические раскраски в панели рабочее место

Рисунок 911. Тематические раскраски в панели рабочее место

Подключение всех тем слоя

[Примечание] Примечание

При одновременном включении всех тем слоя порядок отображения тем на карте определяется порядком их расположения в окне Рабочее место. Темы включаются и накладываются друг на друга последовательно начиная с самой верхней в списке. При совпадающих условиях тематического фильтра возможно перекрытие тем друг другом. При необходимости тематические раскраски возможно переместить в окне, что изменит последовательность наложения их друг на друга.

Подключить все тематические раскраски можно двумя способами:

Первый вариант подключения всех тем слоя:

Сделайте щелчок левой клавишей мыши по иконке [image] Темы соответствующего слоя в панели Рабочее место. Если ни одна тема не подключена к слою, то иконка будет выглядеть следующим образом: .

Второй вариант подключения всех тем слоя:

Сделайте щелчок правой кнопкой мыши по пункту [image] Темы соответствующего слоя в панели Рабочее место и в открывшемся контекстном меню выберите пункт Подключить все.

Тематические раскраски в панели рабочее место

Рисунок 912. Тематические раскраски в панели рабочее место


Отключение темы

  • «Отключение тем поштучно»

  • «Отключение всех тем слоя»

Отключать тематические раскраски можно как поштучно так и все раскраски слоя сразу.

Отключение тем поштучно

Отключение тем поштучно может осуществляться двумя способами.

Первый вариант отключения тематической раскраски:

  1. Выберите пункт меню Карта|Тема|Подключить.

  2. Подведите курсор к тематической раскраске, которую надо отключить и сделайте двойной щелчок левой кнопкой мыши. Отключенная тема будет помечена иконкой серого цвета - [image] .

  3. Для подтверждения отключения темы нажмите кнопку Применить или кнопку ОК (кнопка ОК подтвердит произведенные изменения и закроет диалоговое окно Тематические раскраски).

С помощью кнопки Вернуть можно произвести возврат диалога Тематические раскраски в исходное состояние.

Кнопка Изменить вызывает диалог Тематический фильтр, в котором можно изменить выделенную тему.

Второй вариант отключения тематической раскраски:

Отключить тему можно нажав правой кнопкой мыши по названию темы в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Отключить или сделав щелчок левой кнопкой мыши по его иконке [image] .

Тематические раскраски в панели рабочее место

Рисунок 913. Тематические раскраски в панели рабочее место

Отключение всех тем слоя

Отключить все тематические раскраски можно двумя способами:

Первый вариант отключения всех тем слоя:

Сделайте щелчок левой клавишей мыши по иконке [image] Темы соответствующего слоя в панели Рабочее место. Если хотя бы одна тема слоя не подключена, то иконка будет выглядеть следующим образом: .

Второй вариант подключения всех тем слоя:

Сделайте щелчок правой кнопкой мыши по пункту [image] Темы соответствующего слоя в панели Рабочее место и в открывшемся контекстном меню выберите пункт Отключить все.

Тематические раскраски в панели рабочее место

Рисунок 914. Тематические раскраски в панели рабочее место


Обновление темы

Если при создании темы не была установлена опция автообнавления тематической раскраски, то при изменении данных, на основе которых делается тематическая раскраска обновления тематической раскраски не произойдет. Можно или принудительно каждый раз обновлять тему или установить опцию автообновления. Обновлять темы можно разными способами, во втором описанном ниже варианте возможно обновление одновременно всех тем слоя.

Первый вариант обновления темы:

  1. Выберите пункт меню Карта|Тема|Подключить. В диалоге выводится список всех доступных тематических раскрасок для всех слоев, входящих в текущую карту.

  2. Выделите тему, для обновления.

  3. Нажмите кнопку Обновить, для того чтобы тема обновлялась автоматически можно установить опцию Автообновление.

    [Примечание] Примечание

    При выборе опции Автообновление обновление темы происходит при перестроении масштаба карты или при ее перемещении. Так же, в настройках карты (Карта|Настройка) можно установить частоту автообновления, тогда обновление будет происходить через заданный промежуток.

  4. Для подтверждения нажмите кнопку Применить или кнопку ОК (кнопка ОК подтвердит произведенные изменения и закроет диалоговое окно Тематические раскраски).

Второй вариант обновления темы:

Обновить тему или все темы слоя можно так же через панель Рабочее место.

Для обновления:

  1. Чтобы обновить одну тему сделайте щелчок правой кнопкой мыши по нужной тематической раскраске в панели. Для обновления всех раскрасок слоя сделайте щелчок правой кнопкой мыши по пункту [image] Темы конкретного слоя.

  2. В открывшемся меню для разового обновления выберите Обновить.

    Обновление всех раскрасок слоя в панели рабочее место

    Рисунок 915. Обновление всех раскрасок слоя в панели рабочее место

    Если требуется чтобы в дальнейшем тема обновлялась автоматически выберите пункт Автообновление. Данная опция настраивается для каждой темы отдельно.

    Опция автообновления раскраски

    Рисунок 916. Опция автообновления раскраски


Переименование темы

Переименование темы возможно двумя способами.

Первый вариант переименования темы:

  1. Выберите пункт меню Карта|Тема|Подключить. В диалоге выводится список всех доступных тематических раскрасок для всех слоев, входящих в текущую карту.

  2. Выделите тему, для переименования.

  3. Нажмите кнопку Переименовать. В открывшемся окне введите новое название для темы, нажмите кнопку ОК.

  4. Для подтверждения нажмите кнопку Применить или кнопку ОК (кнопка ОК подтвердит произведенные изменения и закроет диалоговое окно Тематические раскраски).

Второй вариант переименования темы:

  1. Сделайте щелчок правой кнопкой мыши по конкретной тематической раскраске в панели Рабочее место, в открывшемся меню выберите пункт Переименовать.

  2. В открывшемся диалоге внесите новое название темы, для подтверждения нажмите кнопку ОК.


Копирование тематической раскраски

  • «Копирование раскраски»

  • «Копирование фильтра»

Вы можете отдельно скопировать как тематическую раскраску полностью, так и тематический фильтр отдельно.

Копирование тематической раскраски используется для:

  • создания точно такую же раскраски, как и существующая, но с небольшими изменениями;

  • для сохранения раскраски, которая производится после расчетов, так как при закрытии панели расчета раскраска исчезает, то именно с помощью копирования темы возможно ее зафиксировать.


Копирование раскраски

Вы можете копировать раскраски как созданные самостоятельно с помощью собственного фильтра, так и раскраски с помощью встроенных фильтров.

Для копирования раскраски с собственным фильтром

  • В окне Рабочее место сделайте щелчок правой кнопкой мыши на раскраске для копирования и выберите пункт Дублировать. В открывшемся окне введите название для раскраски, нажмите кнопку ОК. Новая раскраска с указанным названием сразу появится в списке раскрасок слоя. Вы можете ее отредактировать.

    или

  • Выберите меню Карта|Тема|Подключить. В диалоге Тематические раскраски выделите раскраску для копирования. Далее нажмите кнопку Дубль.... В открывшемся окне введите название для раскраски, нажмите кнопку ОК.

Копию раскраски вы можете отредактировать.

Для копирования раскраски с встроенным фильтром

  1. Произведите расчет. Из списка Раскраска выберите встроенную раскраску.

  2. Не закрывая панель расчетов:

    • В окне Рабочее место сделайте щелчок правой кнопкой мыши на раскраске с названием Временная раскраска (Id=xxxxx), где xxxxx - номер раскраски и выберите пункт Дублировать. В открывшемся окне введите название для раскраски, нажмите кнопку ОК.

      или

    • Выберите меню Карта|Тема|Подключить. В диалоге Тематические раскраски выделите раскраску с названием Временная раскраска (Id=xxxxx), где xxxxx - номер раскраски. Далее нажмите кнопку Дубль.... В открывшемся окне введите название для раскраски, нажмите кнопку ОК.

Такой вид раскраски не редактируется так как не содержит фильтров.


Копирование фильтра

Для копирования фильтра:

  1. Откройте фильтр для копирования. Самый удобный способ открытия: в окне Рабочее место сделать щелчок правой кнопкой мыши уже на конкретной теме и выбрать пункт Изменить. Открыть фильтр так же можно выбрав пункт меню Карта|Тема|Редактор фильтра, затем в диалоге нажать кнопку [image] Слой..., указать в списке нужный слой. Далее из списка Шаблон надо выбрать шаблон фильтра для копирования.

  2. Нажмите кнопку Дублировать....

  3. Введите имя для копии тематического фильтра. Чтобы подтвердить копирование нажмите кнопку ОК. Кнопка Отмена закроет окно задания имени без изменений.

В результате проделанных действий будет создана копия шаблона тематического фильтра, которую заем можно использовать в новой теме. Для этого при ее создании надо не задавать параметры фильтра заново а выбрать из списка Шаблон нужный фильтр. При необходимости скопированный фильтр имеется возможность изменить.


Настройка порядка отображения тем в панели Рабочее место

Порядок отображения тем в панели Рабочее место можно изменить, это особенно удобно при их большом количестве. Перемещение производится способом Drag-and-drop.

[Примечание] Примечание

Настроенный порядок отображения тем сохраняется в файле *.b10, где * - название слоя. И данная последовательность отображения тем будет не свойством слоя в карте, а непосредственно свойством слоя. То есть при добавлении слоя в другую карту порядок следования тем будет сохранен. Как сохранить настройки слоя можно узнать здесь.

Для перемещения темы:

  1. В панели Рабочее место подведите курсор к тематической раскраске, которую надо переместить. Нажмите левую клавишу мыши и не отпуская переместите ее в нужное место.

  2. Отпустите левую клавишу мыши, объект перемещен.

Изменение последовательности тем

Рисунок 917. Изменение последовательности тем


Удаление темы

Так как создание темы происходит в несколько этапов, сначала создается тематический фильтр, а затем сама тема, то для полного удаления тематической раскраски требуется так же отдельно удалить фильтр и тему.

Удаление темы:

  1. Выберите пункт меню Карта|Тема|Подключить. В диалоге выводится список всех доступных тематических раскрасок для всех слоев, входящих в текущую карту.

  2. Выделите тему для удаления.

  3. Нажмите кнопку Удалить.

  4. Для подтверждения нажмите кнопку Применить или кнопку ОК (кнопка ОК подтвердит произведенные изменения и закроет диалоговое окно Тематические раскраски).

ИЛИ

  1. Сделайте щелчок правой кнопкой мыши по конкретной тематической раскраске в панели Рабочее место, в открывшемся меню выберите пункт Удалить.

  2. Подтвердите удаление темы нажатием кнопки Да.

Удаление тематического фильтра:

  1. Выберите пункт меню Карта|Тема|Редактор фильтра.

  2. Нажмите кнопку [image] Слой..., в появившемся стандартном окне выбора файла выберите имя слоя, для которого ранее создавался фильтр.

    Данный диалог также можно вызвать нажав правой кнопкой мыши по разделу Темы в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Редактор фильтров.

    Так же можно сделать щелчок правой кнопкой мыши по конкретной теме в панели Рабочее место и выбрать в открывшемся контекстном меню пункт Изменить. Тогда фильтр загрузится уже с данными и далее следует перейти сразу к пункту 4.

  3. Из списка Шаблон выберите шаблон тематического фильтра для удаления.

  4. Нажмите кнопку [image] справа от названия фильтра.

  5. Подтвердите удаление фильтра нажатием кнопки Да. Нажатие кнопки Нет отменяет удаление фильтра.

  6. Закройте диалог Тематический фильтр.


Импорт тематических раскрасок из одного слоя в другой

Перед импортом в карту надо добавить слои источника тематической раскраски и слой, в который раскраску требуется импортировать. Так же для успешного импорта необходимо убедиться, что используемые в шаблоне темы поля баз данных имеются о обоих слоях. В случае отсутствия полей в слое для записи, в окне сообщений будет выдано сообщение об ошибке импорта.

Для импорта:

  1. В панели Рабочее место сделайте щелчок правой кнопкой мыши по разделу [image] Темы слоя, в который требуется импортировать раскраски. В открывшемся контекстном меню пункт выберите Импорт.

    или

    Выберите меню Карта|Тема|Подключить, затем в общем списке слоев и тем выделите слой, в который требуется импортировать шаблоны тем. Нажмите кнопку Импорт.

  2. В открывшемся диалоге Импорт тематических раскрасок из списка Слой источник выберите слой, из которого будут импортированы тематические раскраски.

  3. В разделе Темы для импорта отметьте нужные темы. Для одновременного выделения всех тем установите опцию Все.

    Диалоговое окно Импорт тематических раскрасок

    Рисунок 918. Диалоговое окно Импорт тематических раскрасок

  4. Нажмите кнопку ОК.

В случае удачного импорта тематических раскрасок будет выдано соответствующее сообщение. Если импорт невозможен, то причина отобразится в окне сообщений.


Примеры работы с тематической раскраской

Ниже рассмотрены два примера:

  • «Пример тематической раскраски для простых площадных объектов»

  • «Пример тематической раскраски для типовых линейного и символьного объектов»

В приведенных примерах используется карта Пример тепловой сети (карта находится в папке \Zulu\Examples\Termo\Kvartal на том диске, где установлена ZuluGIS).


Пример тематической раскраски для простых площадных объектов

В первом примере будет рассмотрено создание тематической раскраски для слоя Здания. Раскраска домов будет произведена в зависимости от квартала, в котором они находятся. То есть дома, у которых в базе данных в поле Квартал написано, например значение 105 будут одним цветом, у которых 202 другим и т.д.

Для создания темы по кварталам:

  1. Выберите меню Карта|Тема|Создать.

  2. Из списка Слой выберите слой Здания.

  3. В строке Фильтр нажмите кнопку Редактор, она вызовет диалог создания тематического фильтра.

  4. В диалоге Тематический Фильтр из списка Шаблон выберите <Новый>, после чего сотрите и введите название шаблона, например, Дома кварталов.

  5. В строке Имя введите Квартал №105 - это название первого условия.

  6. Из открывающегося списка База выберите базу данных Здания.

  7. В строке поля Квартал введите условие первого запроса - 105 (то есть для всех домов, номер квартала которых равен 105).

  8. Во вкладке Площадные установите желаемые параметры отображения (цвет, стиль, толщина и т.д.) объектов слоя, соответствующие первому запросу. Например, цвет узора установить синим, остальные параметры не менять.

  9. Для ввода следующего запроса нажмите кнопку [image] с правой стороны от строки Имя.

  10. Повторите пункты 5, 7 и 8 для второго запроса. Условием запроса поставьте квартал 202.

  11. Для сохранения тематического фильтра нажмите кнопку [image] Сохранить....

    Окно тематического фильтра

    Рисунок 919. Окно тематического фильтра

  12. Закройте диалоговое окно Тематический фильтр (кнопка Закрыть).

  13. После закрытия окна Тематический фильтр произойдет возврат в диалог Создание тематической раскраски, в нем проверьте, чтобы в списке Фильтр было название только что созданного фильтра – Дома кварталов.

  14. В строке Тема сотрите надпись <Новая> и напишите название темы Дома кварталов.

  15. Для дальнейшего автообновления установите опцию Обновлять автоматически.

  16. Установите опцию Подключить к карте.

    Окно создания темы

    Рисунок 920. Окно создания темы

  17. Нажмите кнопку ОК, подключение и создание тематической окраски закончено.

Результат подключения созданной темы к слою Здания

Рисунок 921. Результат подключения созданной темы к слою Здания


Пример тематической раскраски для типовых линейного и символьного объектов

Во втором примере создадим тематическую раскраску для включенных потребителей, у которых расчетная нагрузка на отопление меньше 0.2 Гкал/ч и для всех участков тепловой сети, длина которых больше 50 метров.

Для создания темы по типовым объектам:

  1. Выберите меню Карта|Тема|Создать.

  2. Из списка Слой выберите слой Пример тепловой сети.

  3. В строке Фильтр нажмите кнопку Редактор, она вызовет диалог создания тематического фильтра.

  4. Из списка Шаблон выберите <Новый>, после чего сотрите и введите название шаблона, например, Окраска по сети.

  5. В строке Имя задайте название первого условия, например Нагр. меньше 0.2.

  6. Из списка База выберите базу данных Потребитель.

  7. В разделе набора условий в строке Расчетная нагрузка на отопление введите: <0.2.

  8. Откройте вкладку Символьные. Из палитры Цвет выберите цвет для окраски символов.

    [Примечание] Примечание

    Окраска символа цветом возможна только в том случае если цвет его заливки изначально задан как АВТО («Символы»). Если же у символа уже выбран определенный цвет, то для применения тематической окраски символ, которым будут отображены объекты, удовлетворяющие условиям темы создать заново. Для этого надо нажать кнопку Новый символ и создать его в редакторе символов.

  9. Чтобы тематический фильтр применялся только ко включенным потребителям нажмите кнопку Режим и установите галочку напротив режима Работа.

    Окно тематического фильтра для типового символьного объекта

    Рисунок 922. Окно тематического фильтра для типового символьного объекта

  10. Для ввода следующего запроса по участкам нажмите кнопку [image] , расположенную справа от строки Имя.

  11. В строке Имя задайте название второго условия, например Длина > 50.

  12. Из открывающегося списка База выберите базу данных Участки.

  13. В разделе набора условий в строке Длина участка введите: >50.

  14. Откройте вкладку Линейные и задайте цвет трубопровода, например коричневый. Стиль, толщину на экране и при печати менять не будем.

  15. Для сохранения тематического фильтра нажмите кнопку [image] Сохранить....

    Окно тематического фильтра для типового линейного объекта

    Рисунок 923. Окно тематического фильтра для типового линейного объекта

  16. Закройте диалоговое окно Тематический фильтр (кнопка Закрыть).

  17. После закрытия окна Тематический фильтр произойдет возврат в диалог создание тематической раскраски, в нем проверьте, чтобы в списке Фильтр было название только что созданного фильтра – Окраска по сети.

  18. В строке Тема сотрите надпись <Новая> и напишите название темы Окраска по сети.

  19. Для дальнейшего автообновления установите опцию Обновлять автоматически.

  20. Установите опцию Подключить к карте.

    Окно создания темы

    Рисунок 924. Окно создания темы

  21. Нажмите кнопку ОК, подключение и создание тематической окраски закончено.

Результат подключения созданной темы к слою Пример тепловой сети

Рисунок 925. Результат подключения созданной темы к слою Пример тепловой сети


Проекты. Иерархия карт

Проект представляет собой совокупность карт, объединенных общим пользовательским именем и, если требуется, набором иерархических связей (ссылок) между этими картами. В файле проекта содержатся только ссылки на карты (файлы с расширением zmp), поэтому одна карта может входить одновременно сразу в несколько проектов, так же как один слой может входить сразу в несколько карт.

Практически проект можно использовать для раскрытия структуры того или иного объекта, изображенного на карте схематично. Например, раскрыть план здания, изображенного на схеме в виде многоугольника, т. е. дать возможность пользователю «заглянуть внутрь» выбранного объекта.

Рисунок 926. Пример проекта


Общие сведения

Проект – это совокупность карт, объединенных общим пользовательским именем и, если требуется, набором иерархических связей между этими картами. Это позволяет удобно организовать карты, объединенные общей тематикой. Физически информация о картах, входящих в проект, и их связях хранится в файле проекта с расширением ZPR, который может находиться на компьютере в любом удобном для пользователя месте. В файле проекта содержатся только ссылки на карты (файлы с расширением ZMP), поэтому одна карта может входить одновременно сразу в несколько проектов, так же как один слой может входить сразу в несколько карт.

Практически проект можно использовать для раскрытия структуры того или иного объекта, изображенного на карте схематично. Например, раскрыть план здания, изображенного на схеме в виде многоугольника, т. е. дать возможность пользователю «заглянуть внутрь» выбранного объекта.


Создание и открытие проекта

  • «Создание и открытие проекта»

  • «Открытие проекта»

  • «Закрытие проекта»

Создание проекта

Для создания нового проекта нужно:

  1. Выбрать пункт главного меню Файл|Создать|Новый проект или в диалоге Проекты нажать кнопку Создать. Ещё один способ – на панели Рабочее место сделать щелчок правой кнопкой мыши на папке Проекты и в появившемся контекстном меню выбрать пункт Создать проект.

  2. В появившемся стандартном диалоге указать папку, в которой будет создан проект, и в строке Имя файла задать его имя.

  3. Нажать кнопку Сохранить.

  4. В диалоге Новый проект в строке Название задать пользовательское название проекта. Это может быть любая строка длиной до 49 символов.

    Диалоговое окно Новый проект

    Рисунок 927. Диалоговое окно Новый проект

  5. Завершить создание, нажав кнопку ОК. В результате образуется проект с заданным именем и пустым списком карт. При этом созданный проект автоматически регистрируется системой ZuluGIS, т.е. включается в список проектов.


Открытие проекта

Открыть проект можно несколькими способами:

  1. Выбрать пункт главного меню Файл|Открыть. Из открывающегося списка Тип файлов выбрать Проекты Zulu(*.zpr).

  2. В стандартном окне выбора файла выбрать нужный файл проекта, имеющий расширение ZPR.

  3. Нажать кнопку Открыть.

ИЛИ

  1. Открыть диалог Проекты.

  2. Выделить в списке нужный проект.

  3. Нажать кнопку Открыть.

ИЛИ

  1. На панели Рабочее место открыть список зарегистрированных проектов. Для этого надо нажать [image] рядом с папкой Проекты.

  2. Сделать двойной щелчок на названии проекта, который надо открыть.

ИЛИ

  1. На панели Рабочее место открыть список зарегистрированных проектов. Для этого надо нажать [image] рядом с папкой Проекты.

  2. Сделать щелчок правой кнопкой мыши на проекте, который надо открыть.

  3. В появившемся контекстном меню выбрать пункт Открыть проект.

Также открыть проект можно через ярлык на рабочем столе. Таким образом проект будет открываться в том случае, когда установлена стартовая карта (см. «Карты проекта»). При этом можно запускать через ярлык и проект, расположенный на ZuluServer. Например, с:\Program Files\Zulu 8.0\Zulu.exe Zulu://zs.Zulugis.ru:6473/prj_test.zpr

После выбора нужного проекта система осуществит проверку реального наличия по указанным путям всех файлов карт, входящих в проект, всех файлов слоев, входящих во все карты проекта, всех семантических баз данных, связанных со всеми слоями, входящими во все карты проекта, и всех связей между картами. Если какой-либо компонент проекта не найден по записанному в файле проекта пути (например, было изменено местонахождение слоя или карты на компьютере, или проект был перенесен с другого компьютера), система выдаст диалог, предлагающий указать новый путь до этого компонента или игнорировать данный компонент (Рисунок 928, «Диалоговое окно для указания нового пути к карте»).

Для изменения пути к файлу карты или слоя необходимо:

Нажать кнопку [image] и в стандартном окне выбора файла указать новый путь к файлу.

Для сохранения нового пути в файле проекта необходимо нажать кнопку Изменить путь. При нажатии кнопки Игнорировать система пропускает указанный файл и не загружает его, но при последующих открытиях проекта система будет вновь пытаться найти файл по указанному пути. Чтобы исключить из проекта данный файл, нажмите кнопку Удалить. При этом из проекта будет удалена ссылка на указанный файл, и при последующих открытиях проекта данный файл открываться не будет.

Диалоговое окно для указания нового пути к карте

Рисунок 928. Диалоговое окно для указания нового пути к карте

После открытия проекта в заголовке окна программы появится его пользовательское название. Если проект до открытия не был зарегистрирован в системе ZuluGIS, то он автоматически добавится в список проектов системы.


Закрытие проекта

Для закрытия проекта надо:

  1. В меню Файл надо выбрать команду Закрыть проект.

ИЛИ

  1. На панели Рабочее место открыть список зарегистрированных проектов. Для этого надо нажать [image] рядом с папкой Проекты.

  2. Сделать щелчок правой кнопкой мыши на проекте, который надо закрыть.

  3. В появившемся контекстном меню выбрать пункт Закрыть проект.

[Примечание] Примечание

При закрытии проекта карты, которые были открыты на экране, НЕ закрываются.


Диалог «Проекты»

При создании или открытии проекта происходит его автоматическая регистрация в системе ZuluGIS. Просмотреть и изменить список зарегистрированных проектов можно в диалоге Проекты.

Чтобы открыть диалог Проекты надо:

  1. Выбрать пункт главного меню Файл|Проекты...

ИЛИ

  1. На панели Рабочее место сделать двойной щелчок на папке Проекты.

На рисунке ниже изображен пример диалога Проекты со списком зарегистрированных в системе проектов. Раздел Зарегистрированные проекты содержит имена всех проектов, ранее зарегистрированных и физически существующих по указанным путям. Для регистрации проекта в списке нажмите кнопку Обзор. При нажатии на эту кнопку открывается стандартное окно выбора файла, после выбора файла проекта этот проект автоматически добавляется в список зарегистрированных проектов.

Рисунок 929. Диалог «Проекты»

Назначение командных кнопок диалога представлено ниже:

Таблица 12.

Кнопка | Описание
Открыть | Открывает зарегистрированный проект.
Обзор... | Открывает стандартное окно выбора файлов проекта для его регистрации в системе.
Создать... | Позволяет создать новый проект.
Переименовать | С помощью нее имеется возможность изменить пользовательское название выделенного в списке проекта.
Исключить | Исключает выделенные проекты из списка зарегистрированных проектов.
Закрыть | Закрывает диалог Проекты.

[Подсказка] Подсказка

При выполнении команды Открыть не происходит автоматического открытия всех карт проекта. Для открытия каждой карты проекта необходимо вызвать диалог Карты проекта из меню Файл. При открытии проекта меняется заголовок главного окна системы.


Карты проекта

  • «Добавление карты в проект»

  • «Исключение карты из проекта»

Для настройки карт проекта используется диалог Карты Проекта. Данный диалог позволяет открыть карту, добавить новую карту в проект, исключить карту из проекта, сделать карту стартовой. Вид диалога настройки карт проекта изображен на рисунке ниже.

Для открытия диалога надо:

  1. Выбрать меню Файл|Карты Проекта.

ИЛИ

  1. На панели Рабочее место открыть список зарегистрированных проектов. Для этого надо нажать [image] рядом с папкой Проекты.

  2. Сделать щелчок правой кнопкой мыши на проекте, карты которого надо показать (проект при этом должен быть открыт).

  3. В появившемся контекстном меню выбрать пункт Карты проекта....

В диалоге Карты Проекта выводится список всех карт, входящих в открытый проект. Предусмотрена возможность изменения вида отображения списка карт: список и таблица. Вид меняется нажатием на кнопку Вид и выбором соответствующего пункта.

Диалог Карты Проекта

Рисунок 930. Диалог Карты Проекта

Назначение командных кнопок диалога представлено ниже:

Таблица 13.

Кнопка

Описание

Открыть

Открывает выделенную в списке карту.

Открыть все

Открывает все карты проекта.

Добавить активную

Если в системе уже была открыта карта, не входящая в проект, то можно добавить ее в список карт проекта. Карта при этом обязательно должна быть активной.

Исключить из проекта

Исключает из проекта выделенную карту, не закрывая при этом окно этой карты.

Сделать стартовой

Позволяет сделать стартовой карту, выделенную в списке карт. Стартовая карта – это карта, которая будет загружаться одновременно с открытием самого проекта.

Это свойство позволяет прямо с ярлыка на рабочем столе сразу открыть ZuluGIS, нужный проект и его стартовую карту. При этом можно запускать через ярлык и проект, расположенный на ZuluServer. Например, с:\Program Files\Zulu 6.0\Zulu.exe Zulu://zs.Zulugis.ru:6473/prj_test.zpr

Отменить стартовую

Отменяет стартовую карту.

Закрыть

Закрывает диалог Проект.


Добавление карты в проект

Карта в проект может быть добавлена несколькими способами:

  1. В диалоговом окне Проект нажать кнопку Найти и добавить. При этом открывается стандартный диалог выбора файла на диске. Выберите диск, каталог и имя файла карты, которую необходимо открыть.

ИЛИ

  1. Через меню Файл открыть карту стандартным способом. После этого вызвать диалог Карты проекта и нажать кнопку Добавить активную.

ИЛИ

  1. В диалоговом окне Связь объекта с другой картой нажать кнопку Найти и связать.

ИЛИ

  1. На панели Рабочее место открыть список зарегистрированных проектов (если он еще не открыт). Для этого надо нажать [image] рядом с папкой Проекты.

  2. Сделать щелчок правой кнопкой мыши на проекте, в который надо добавить карту (проект должен быть открыт).

  3. В появившемся контекстном меню выбрать пункт Добавить карту..., после чего в стандартном диалоге выбора файла выбрать диск, каталог и имя карты, которую необходимо открыть.

    В том случае, если карта активная, можно выбрать пункт Добавить активную карту.


Исключение карты из проекта

Чтобы исключить карту из проекта, необходимо:

  1. В окне Проект выделить карту в списке карт.

  2. Нажать кнопку Исключить из проекта.

ИЛИ

  1. На панели Рабочее место открыть список зарегистрированных проектов (если он еще не открыт). Для этого надо нажать [image] рядом с папкой Проекты.

  2. Развернуть список карт открытого проекта ( [image] ).

  3. Сделать щелчок правой кнопкой мыши на карте, которую надо исключить.

  4. В появившемся контекстном меню выбрать пункт Исключить.


Связи между картами проекта

  • «Установка связи объекта с картой»

  • «Удаление связи»

  • «Переход по связям»

Карты проекта связываются между собой. Например, на карте Пример тепловой сети мы хотим более подробно рассмотреть план отопления одного из зданий, а у этого здания подробнее рассмотреть схему теплового узла. Т. е., три карты: Пример тепловой сети, Здание-1 этаж и Тепловой узел необходимо объединить, связав карту более низкого уровня с одним из объектов на карте более высокого уровня:

Здание на карте Пример тепловой сети – карта Здание-1 этаж – Тепловой узел на карте Здание-1 этаж – карта Тепловой узел.


Установка связи объекта с картой

Чтобы установить связь объекта с картой, необходимо:

  1. Активизировать объект на карте – [image] (слой, в котором находится объект, должен быть активным).

  2. Нажать на панели инструментов кнопку [image] .

  3. В открывшемся диалоге выбрать карту, с которой необходимо связать объект, и нажать кнопку Связать. Если карты нет в списке карт, то надо нажать кнопку Найти и связать. Это даст возможность выбрать карту непосредственно с диска компьютера.

    Диалоговое окно связь объекта с другой картой

    Рисунок 931. Диалоговое окно связь объекта с другой картой


Удаление связи

Чтобы удалить связь, необходимо:

  1. Выделить объект на карте [image] (слой, в котором находится объект, должен быть активным).

  2. Нажать на панели инструментов кнопку [image] .

  3. В открывшемся диалоге в нижнем списке выбрать ту карту, связь с которой необходимо удалить, и нажать кнопку Удалить связь.


Переход по связям

Для карт, между которыми установлена связь, активизируются кнопки перехода между картами.

Переход от карты к карте сверху вниз

  1. Активизируйте на карте объект, для которого была установлена связь с картой ( [image] ).

  2. На панели инструментов нажмите кнопку [image] . Если с объектом связано несколько карт, то нажатие на эту кнопку открывает список всех связанных с объектом карт. Щелчком левой кнопки мыши выберите из списка нужную карту.

Переход от карты к карте снизу вверх

Для перехода вверх на один уровень нажмите кнопку [image] на панели инструментов.

[Подсказка] Подсказка

Система запоминает параметры карты, на которую устанавливается связь (например, масштаб карты), и при переходе показывает карту в том виде, в котором карта была, когда на нее устанавливали связь. Для изменения параметров отображения связанной с объектом карты (масштаб, центр карты) необходимо установить новые параметры и нажать кнопку [image] (обновить связь).


Панель Проектов

При работе с проектами весьма удобно пользоваться панелью Рабочее место, разделом Проекты. Чтобы показать или убрать панель Рабочее место, выберите пункт Рабочее место в меню Окно или нажмите на панели инструментов кнопку [image] .

В окне проектов можно посмотреть все зарегистрированные в системе проекты, список карт, входящих в каждый проект, слои карты, связь объектов карт с другими картами. Для работы с этим окном предусмотрено контекстное меню, вызываемое щелчком правой кнопки мыши. В меню, кроме общих команд управления панелью проектов, содержатся пункты, относящиеся к выделенному элементу иерархического списка.

Пример панели Проектов

Рисунок 932. Пример панели Проектов

Возможности панели описаны в разделе «Окно Рабочее место».

Далее можно ознакомится с возможностями панели:

Таблица 14. Панель «Рабочее место» раздел Проекты

Проекты | Папка, в которой сгруппированы зарегистрированные проекты. Команды контекстного меню:
 | Проекты… | Вызывает панель менеджера проектов для добавления и удаления проектов (подробней см. «Диалог «Проекты»»). Также менеджер можно вызвать двойным щелчком левой кнопки мыши на названии раздела.
 | Создать проект... | Позволяет создать новый проект.
 | Добавить проект... | Позволяет добавить не зарегистрированный в системе проект.
Название проекта | Элемент списка, соответствующий определенному проекту. Загруженный проект отмечается полужирным шрифтом. Команды контекстного меню:
 | Открыть проект | Открывает этот проект, пункт отображается только для закрытых проектов. Открыть проект также можно, сделав двойной щелчок левой кнопкой мыши по его названию.
 | Еще проекты... | Вызывает диалог менеджера проектов для добавления и удаления проектов, активен для закрытых проектов (подробней см. «Диалог «Проекты»»).
 | Карты проекта... | Вызывает диалог менеджера карт проекта для добавления и удаления карт проекта, активен для открытых проектов (подробней см. «Карты проекта»).
 | Добавить карту... | Открывает стандартное окно выбора для добавления карты в проект, активен для открытых проектов.
 | Добавить активную карту... | Добавляет активную карту в загруженный проект, активен для открытых проектов.
 | Закрыть проект | Закрывает проект, активен для открытых проектов.
Название карты | Элемент списка, соответствующий карте, входящей в состав проекта, указанного выше. Команды контекстного меню:
 | Открыть | Открывает эту карту. Открыть карту также можно, сделав двойной щелчок левой кнопкой мыши по её названию.
 | Показать | Делает активной окно данной карты.
Ключ | Обозначает набор карт, подключенных к элементу с указанным ключом. Команды контекстного меню:
 | Показать объект | Показывает на карте объект с данным ключом, при этом происходит перемещение карты таким образом, что объект оказывается в центре экрана и начинает мигать.
Название карты | Обозначает гиперссылку на карту от вышеуказанного элемента.

[Примечание] Примечание

Рекомендуем использовать проекты для раскрытия структуры узлов тепловой сети. При нанесении тепловой сети на карту города не раскрывается структура тепловых камер с установленными задвижками. Все тепловые камеры подробно прорисовываются на оперативной схеме. После этого карту с технологической схемой связывают с картой, содержащей слой с оперативной схемой.


Пример работы с проектом

[Примечание] Примечание

Видеоурок по созданию проекта можно посмотреть пройдя по ссылке: https://www.politerm.com/videos/map/project_create/.

Рассмотрим пример создания проекта для раскрытия плана здания. Карты, используемые в проекте, находятся в той же директории, в которой установлена ZuluGIS.

  1. Выберите пункт главного меню Файл|Создать|Новый проект.

  2. В открывшемся окне укажите папку, в которой будет создаваться проект. В строке Имя файла

    задайте его имя, например Building_project. Нажмите кнопку Сохранить.

  3. В строке Название задайте пользовательское название, например, Проект здания.

  4. Нажмите кнопку ОК.

    Диалоговое окно создания проекта

    Рисунок 933. Диалоговое окно создания проекта

  5. Проверьте, чтобы слой Здания был активным, войдите в режим активизации объекта (кнопка [image] ) и левой кнопкой мыши выделите на карте любое здание.

  6. На панели инструментов нажмите кнопку [image] , в открывшемся окне нажмите кнопку Найти и связать и в стандартном окне выбора файла укажите карту Здание – 1 этаж, нажмите кнопку Открыть. Данная карта расположена на том же диске, что и система ZuluGIS, в директории \ZuluGIS\Examples\Building\FLOOR.

  7. Нажмите кнопку Закрыть.

    Окно связи объекта с другой картой

    Рисунок 934. Окно связи объекта с другой картой

  8. Проверьте, что дом до сих пор выделен, на панели инструментов нажмите кнопку [image] , после чего произойдет переход на уровень вниз, то есть на связанную карту.

  9. В карте с планом здания установите масштаб и центр отображения таким образом, чтобы план помещался на весь экран. Для сохранения произведенных изменений нажмите кнопку Обновить связь [image] .

  10. Для того чтобы вернуться на исходную карту, нажмите кнопку [image] (на уровень вверх).


Печать карты, копирование в буфер и экспорт в PDF

  • «Настройка принтера»

  • «Печать с использованием панели печати»

  • «Макет печати»

  • «Экспорт в PDF»

  • «Копирование фрагмента карты в буфер обмена»

Печать карт доступна с различными настройками: область печати, масштаб, количество страниц, формат бумаги и её ориентация, колонтитулы и листы всклейку. Легко создавать печатные формы, используя макеты с рамкой, штампом, подстановками и другими элементами: изображениями, условными обозначениями или текстом. С помощью макета можно настроить печать как одной, так и нескольких страниц карты.

Вы можете копировать фрагмент карты в буфер обмена для дальнейшего использования.

Перед началом печати необходимо настроить принтер, используя команду главного меню Файл|Принтер....

Настройки параметров страницы производятся через меню Файл|Параметры страницы. Данный диалог также вы можете вызвать, нажав на кнопку [image] .

[Предупреждение] Предупреждение

Для корректной печати данных в соответствии с реальными размерами необходимо, чтобы печатаемые слои имели проекцию, которая не имеет графических искажений печатаемой области. Например, это может быть проекция Гаусса-Крюгера в соответствии с центральным меридианом или соответствующая МСК.

В зависимости от поставленных задач вы можете использовать следующие варианты печати:

  • печать с использованием панели печати – упрощенный вариант печати, с помощью которого возможно настроить масштаб карты, ее положение на странице, колонтитулы и еще несколько параметров;

  • печать с использованием макета печати – позволяет создавать, сохранять и редактировать макеты для печати карт различной сложности с добавлением дополнительных элементов;

  • печать карты в PDF файл – используя данный вариант, подготовленный к печати материал можно экспортировать в PDF файл;

  • копирование фрагмента карты в буфер обмена.

    [Примечание] Примечание

    Предварительный просмотр печати можно осуществить, выбрав меню Файл|Предварительный просмотр или нажав кнопку [image] панели инструментов.


Настройка принтера

Окно настройки печати позволяет настроить устройство печати: принтер или плоттер, размер страницы и ее ориентацию. При дальнейшей работе данные настройки будут использоваться при печати карты и при создании макета.

Для настройки принтера:

  1. Выберите пункт меню Файл|Принтер....

    Окно настройки принтера

    Рисунок 935. Окно настройки принтера

  2. В разделе Принтер выберите устройство для печати. При необходимости с помощью кнопки Свойства задайте дополнительные параметры печати, определяемые видом устройства.

  3. В разделе Бумага задайте размер и вариант подачи бумаги.

    [Предупреждение] Предупреждение

    Список размеров бумаги зависит от драйвера выбранного принтера. Большая вероятность, что у стандартного офисного принтера размеров A2, A1, A0 и т.д. представлено не будет, но такие размеры имеются у PDF принтеров.

  4. В разделе Ориентация укажите ориентацию страницы.

  5. Для закрытия окна настройки нажмите кнопку ОК. Кнопка Отмена закроет окно без сохранения изменений.


Печать с использованием панели печати

[Примечание] Примечание

В том случае, если вам не достаточно функций печати с использованием панели печати рекомендуем ознакомиться с макетами печати.

Данный вариант печати является упрощенным. Его, как правило, используют в том случае, когда надо напечатать карту без дополнительных компонентов, таких как рамка, подстановки, легенда и т.д. Такая печать состоит из нескольких этапов:

  1. Необходимо определиться с тем, какая область будет напечатана. Возможно напечатать:

    • текущий вид карты;

    • всю карту;

    • выделенную область;

    • по размерам указанного слоя;

    • по размерам внесенных координат.

    Если предполагается печать выделенной области, то её необходимо предварительно выделить. В остальных случаях перейдите к следующему пункту.

  2. Выберите формат, ориентацию бумаги и при необходимости настройте колонтитулы.

  3. Установите параметры печати карты, такие как масштаб, положение на странице, порядок печати страниц и т.д..

  4. Запустите печать карты.


Выделение и редактирование области печати

Область указывается в виде прямоугольника, для ее выделения:

  1. На панели инструментов нажмите кнопку Выделить область печати – [image] .

  2. Левой кнопкой мыши укажите на карте одну вершину области, удерживая кнопку мыши, переместите курсор и укажите противоположную вершину, для завершения отпустите левую кнопку мыши. При этом, если дополнительно нажать и удерживать клавиши Ctrl или Ctrl+Shift, то рамка будет цепляться за узлы объектов активного или любого другого слоя, соответственно.

Для редактирования области печати:

  1. На панели инструментов нажмите кнопку Редактировать область печати – [image] .

  2. Далее:

    • для перемещения области наведите курсор на нее, нажмите и, не отпуская левую кнопку мыши, переместите область в нужное место;

    • для изменения размеров области подведите курсор к ребру или углу области, нажмите и, не отпуская левую кнопку мыши, установите требуемый размер. Для завершения операции отпустите левую клавишу мыши.


Параметры страницы

Настройка параметров страницы происходит в соответствующем диалоге, который вызывается через меню Файл|Параметры страницы или кнопкой [image] панели инструментов. Диалог имеет две вкладки:

  • Страница – в ней задаются такие параметры, как размер, подача, ориентация бумаги, настройка полей и отступы колонтитулов;

  • Колонтитулы – в ней настраиваются колонтитулы и номера страниц.

    [Подсказка] Подсказка

    Для выбора и работы с нестандартными форматами листа не забудьте настроить принтер.


Вкладка Страница

Для задания соответствующих параметров страницы:

  1. В разделе Бумага задайте формат бумаги (из списка размер) и способ ее подачи (из списка подача) в устройство.

    [Примечание] Примечание

    Список доступных размеров страницы зависит от драйвера выбранного принтера.

  2. В разделе Ориентация выберите один из вариантов ориентации изображения на странице.

  3. В разделе Поля задайте поля с каждой стороны листа в сантиметрах. Печатаемая зона будет ограничена этими полями. Однако, если указанные поля окажутся меньше, чем физические поля печатающего устройства, то будут использованы поля устройства.

  4. В разделе Отступы колонтитулов задайте отступы от верхнего и нижнего колонтитула в сантиметрах.

Панель настройки параметров страницы. Вкладка Страница

Рисунок 936. Панель настройки параметров страницы. Вкладка Страница


Вкладка Колонтитулы

В данной вкладке имеется возможность настроить колонтитулы для печати карты. Отдельно настраиваются нижний и верхний колонтитул. По умолчанию есть уже готовые три варианта настройки:

  1. Нумерация по центру страницы (Страница 1).

  2. Нумерация по центру страницы и количество страниц (Страница 1 из ?).

  3. Нумерация по центру страницы и текущая дата в правом верхнем углу (Страница 1; 24.12.14).

Готовые варианты можно выбрать из открывающегося списка Верхний колонтитул или Нижний колонтитул, любой из них вы можете изменить с помощью кнопки Изменить.

Панель настройки параметров страницы. Вкладка Колонтитулы

Рисунок 937. Панель настройки параметров страницы. Вкладка Колонтитулы

Для настройки верхнего или нижнего колонтитула нажмите кнопку Изменить напротив соответствующего списка, после чего на экране появится диалог Колонтитул:

Рисунок 938. Диалог Колонтитул

Для создания колонтитула:

  1. Определитесь, в какой части листа необходимо создать колонтитул, затем установите курсор в соответствующий раздел диалога (Слева, В центре, Справа).

  2. Выберите нужное действие:

    • вставить любой текст с индивидуальной настройкой;

    • вставить номер страницы, число страниц, номер страницы по вертикали или по горизонтали;

    • вставить дату или время;

    • вставить название документа или путь к нему.

  3. Для подтверждения создания колонтитулов нажмите кнопку ОК.


Вставка текста в колонтитул

Для вставки текста в колонтитул:

  1. Нажмите в диалоге Колонтитул кнопку [image] .

  2. В открывшемся диалоге Шрифт задайте параметры вводимого текста, такие как шрифт, начертание, размер и другие. Затем подтвердите настройки нажатием кнопки ОК.

    Диалоговое окно Шрифт

    Рисунок 939. Диалоговое окно Шрифт

  3. Внесите текст с клавиатуры.

[Примечание] Примечание

Для изменения параметров уже внесенного текста его надо выделить, после чего нажать кнопку [image] и сделать необходимые изменения.


Вставка номера страницы

Для того чтобы вставить в колонтитул номер страницы:

  1. Нажмите на панели инструментов кнопку [image] . В выбранной области появится запись: ${page}.

Для того чтобы вставить в колонтитул число страниц:

  1. Нажмите на панели инструментов кнопку [image] . В выбранной области появится запись: ${pages}.

В один колонтитул можно внести как номер страницы, так и общее количество страниц. Для этого необходимо выполнить действия. описанные выше, а затем в диалоге Колонтитулы между записями внести с клавиатуры текст «из», как показано на рисунке ниже:

Диалоговое окно Колонтитул

Рисунок 940. Диалоговое окно Колонтитул

Для вставки в колонтитул номера страницы по вертикали или горизонтали:

  1. Нажмите на панели инструментов кнопку:

    • – чтобы внести номер страницы по вертикали, в выбранной области появится запись: ${page-row};

    • – чтобы внести номер страницы по горизонтали, в выбранной области появится запись: ${page-col}.


Вставка даты и времени

Для вставки в колонтитул даты:

  1. Нажмите на панели инструментов кнопку [image] . В выбранной области появится запись: ${date}.

Для вставки в колонтитул времени:

  1. Нажмите на панели инструментов кнопку [image] . В выбранной области появится запись: ${time}.


Вставка названия и пути до документа

Для вставки в колонтитул названия документа:

  1. Нажмите на панели инструментов кнопку [image] . В выбранной области появится запись: ${title}. После вставки названия в колонтитуле будет выведено пользовательское название карты.

Для вставки в колонтитул пути до документа:

  1. Нажмите на панели инструментов кнопку [image] . В выбранной области появится запись: ${path}${file}. После вставки пути в колонтитуле будет выведен путь и имя файла карты.


Настройка печати

Для настройки печати:

  1. Выберите в меню Карта|Настройка печати или нажмите на панели инструментов кнопку [image] . Также открыть настройки печати можно через панель Рабочее место. Для этого надо сделать щелчок правой кнопкой мыши на названии карты в панели, затем выбрать в контекстном меню пункт Настройка печати.

  2. В разделе Масштаб карты укажите, какой масштаб карты следует использовать:

    • установить – масштаб карты устанавливается точно, в окошке справа надо указать этот масштаб;

    • вписать в страницу – масштаб выбирается так, чтобы фрагмент попал целиком на страницу или на диапазон страниц, если он указан (см. расположить на ...);

    • в соответствии с масштабом на экране – масштаб выбирается так, чтобы геометрические размеры изображения на бумаге соответствовали размерам изображения на экране;

    • расположить на ... – этот флажок устанавливается в том случае, когда надо точно задать диапазон страниц для печати, количество страниц устанавливается в соответствующих окошках.

      Диалоговое окно настройки печати карты

      Рисунок 941. Диалоговое окно настройки печати карты

  3. В разделе Положение укажите, как следует выравнивать печатаемую зону на странице бумаги или заданном диапазоне страниц. Выбор нужного варианта из возможных девяти осуществляется нажатием на соответствующую кнопку.

  4. В разделе Печатаемый фрагмент местности задайте границы печатаемой карты:

    • текущий вид – печататься будет область карты, попадающая на всю страницу или заданный диапазон страниц, с указанным масштабом и центром изображения, совпадающим с координатами в центре активного окна карты;

    • вся карта – фрагмент местности будет вычисляться по границам всей карты;

    • фрагмент – будет напечатана отмеченная заранее область карты;

    • по размерам слоя – печатаемая область будет вычисляться по границам одного слоя. В списке необходимо выбрать этот слой;

    • указать – позволяет точно задать границы фрагмента местности. В окошках справа от этого переключателя задаются координаты левого нижнего и правого верхнего углов прямоугольной зоны, которую следует распечатать.

  5. В разделе Опции указываются дополнительные опции печати:

    • не отсекать печатаемую зону – если флажок установлен, то вместо пустых зон на листе бумаги будет выводиться изображение карты вне заданного фрагмента местности, результат этой опции проиллюстрирован на рисунке ниже (печатаемая зона обозначена светло-серым фоном, а границы заданного фрагмента – темно-серой рамкой);

      Результат опции Не отсекать печатаемую зону

      Рисунок 942. Результат опции Не отсекать печатаемую зону

    • печатать фон карты – по умолчанию фон окна карты не выводится при печати. Чтобы карта выводилась на цветном фоне, установите этот флажок;

    • листы в склейку – опция полезна при печати на нескольких листах для последующей склейки в один лист. При установленном флажке заданные для документа поля не будут использоваться на граничащих друг с другом листах;

    • печатать рамку – при установке данной опции печатаемый фрагмент будет обрамлен рамкой;

    • только выделенные объекты – если данная опция установлена, то на печать будут выведены только добавленные в группу объекты.

      [Подсказка] Подсказка

      Добавить в группу объекты сразу из нескольких слоев можно выделением произвольной областью и сочетанием клавиш CTRL+SHIFT.

    • порядок печати страниц – выберите один из двух вариантов следования страниц при многостраничной печати:

      1. сначала первый ряд слева направо, потом следующий ряд и т.д.;

      2. сначала первый ряд сверху в низ, потом следующий ряд и т.д.

  6. Для проверки настройки печати нажмите кнопку Просмотр. В окне предварительного просмотра:

    • c помощью окошка [image] меняется масштаб просмотра страницы;

    • с помощью инструментов [image] и [image] изменяется число отображаемых страниц;

    • с помощью инструментов [image] и [image] можно листать страницы вперед и назад.

      [Примечание] Примечание

      Для вывода данных на печать нажмите кнопку [image] . Также карта может быть сохранена в файл PDF. Чтобы сохранить файл, нажмите кнопку [image] , укажите место и имя файла. Для завершения нажмите кнопку Сохранить.

  7. Для выхода из режима просмотра нажмите кнопку Закрыть.


Печать карты

Для печати уже настроенной карты:

  1. Выберите пункт Файл|Печать или нажмите на панели инструментов кнопку [image] .

  2. В открывшейся стандартной панели печати при необходимости можно сменить указанное устройство, на которое будут выводится данные на печать.

  3. Кнопка Свойства откроет дополнительное окно настроек печати. Настройки будут соответствовать выбранному принтеру.

  4. В разделе Копии укажите количество копий.

  5. В разделе Диапазон печати укажите диапазон печатаемых страниц.

  6. Нажмите кнопку OK.

[Примечание] Примечание

Настроенная карта может быть экспортирована в PDF файл.

[Подсказка] Подсказка

Печать карты с заданными настройками соответствует методу PrintOut.


Примеры печати карты с использованием панели печати

Рассмотрим два примера:

  • «Пример печати карты по указанной области в файл PDF на листе формата A1»

  • «Пример печати карты по габаритам слоя на листах формата A4 в склейку»


Пример печати карты по указанной области в файл PDF на листе формата A1

В данном примере будет рассмотрен простой случай, когда требуется распечатать указанную область карты с определённым масштабом без дополнительных элементов. Печать будет осуществлена в файл формата PDF на бумаге A1. Получившийся результат в дальнейшем можно отнести в типографию для печати на большом размере бумаги. Стандартный офисный принтер не предназначен для работы с большими форматами, однако PDF-принтер такую возможность предоставляет. Если вы планируете повторить данный пример и у вас ещё не установлен PDF-принтер, рекомендуется установить его заранее.

Откройте карту для печати. В примере используется карта Пример тепловой сети, расположенная там же куда установлена программа, в папке \Examples\Termo\Kvartal.

  1. Произведите настройку принтера, для этого выберите пункт меню Файл|Принтер... В разделе Принтер выберите Adobe PDF.

  2. В разделе Бумага задайте размер А1.

  3. Нажмите кнопку ОК.

    Рисунок 943. Настройка принтера

  4. В колонтитул печатаемой страницы добавим название карты. Для этого выберите меню Файл|Параметры страницы или нажмите кнопку [image] . В открывшейся панели выберите вкладку Колонтитулы. Проверьте чтобы в верхнем колонтитуле было выбрано (нет) и нажмите кнопку Изменить.

  5. Установите курсор в центре. Нажмите кнопку Шрифт [image] и сделайте настройки шрифта для названия. В примере выбран максимальный размер из списка 72, при необходимости больший размер можно внести с клавиатуры в окошко Размер. Нажмите кнопку ОК.

    Рисунок 944. Настройка шрифта

  6. Для автоматической подстановки названия карты при печати на панели Колонтитул нажмите кнопку [image] . В выбранной области появится запись: ${title}. Для подтверждения и закрытия диалога нажмите кнопку ОК.

    Рисунок 945. Настройка подстановки

  7. Нажмите кнопку ОК в диалоге настройки страницы.

    Рисунок 946. Настройка страницы

  8. Для печати будет выведена только выделенная область карты. Чтобы её отметить, нажмите кнопку [image] Выделить область печати. Затем, удерживая левую кнопку мыши, укажите на карте одну вершину области. После этого переместите курсор к противоположной по диагонали вершине, не отпуская кнопку. Завершите выделение, отпустив левую кнопку. При этом, если дополнительно нажать и удерживать клавиши Ctrl или Ctrl+Shift, то рамка будет цепляться за узлы объектов активного или любого другого слоя, соответственно. При необходимости отредактируйте область печати.

  9. Для настройки печати выберите в меню Карта|Настройка печати или нажмите кнопку [image] . В разделе Масштаб выберите пункт установить и введите масштаб 500.

    Настройка параметров печати карты

    Рисунок 947. Настройка параметров печати карты

  10. Для просмотра результата нажмите кнопку Просмотр.

    Просмотр перед печатью

    Рисунок 948. Просмотр перед печатью

  11. Если на данном этапе вас не устроит увиденный результат, то можно нажать кнопку Закрыть и изменить нужные настройки. Чаще всего не устраивает толщина трубопроводов, выводимая на печать. Данный параметр можно изменить в структуре слоя, настроив в линейном режиме участков сети параметр толщина при печати.

    Если все устраивает, нажмите кнопку [image] Печать, после чего опять появится диалог Печать, в нем нажмите кнопку ОК. Далее в зависимости от принтера возможно еще понадобится нажать кнопку Сохранить в PDF, затем и указать название и местоположение файла. Для просмотра результата откройте сохраненный файл. Далее данный файл можно передать в печать на большом формате.


Пример печати карты по габаритам слоя на листах формата A4 в склейку

Рассмотрим печать карты по габаритам слоя Пример тепловой сети в масштабе 1:1000. Печатать будет осуществлена на бумаге A4. Листы в дальнейшем будут склеиваться.

Откройте карту для печати. В примере используется карта Пример тепловой сети, расположенная там же куда установлена программа, в папке \Examples\Termo\Kvartal.

  1. Произведите настройку принтера, для этого выберите пункт меню Файл|Принтер... В разделе Принтер укажите принтер для печати.

  2. В разделе Бумага проверьте чтобы стоял размер A4, ориентацию установите альбомную.

  3. Нажмите кнопку ОК.

    Рисунок 949. Настройка принтера

  4. Для настройки печати выберите в меню Карта|Настройка печати или нажмите кнопку [image] . В разделе Масштаб выберите пункт установить и введите масштаб 1000.

    В разделе Печатаемый фрагмент местности выберите опцию по размерам слоя и из списка слоев выберите Пример тепловой сети.

  5. Установите опцию листы в склейку.

    Настройка параметров печати карты

    Рисунок 950. Настройка параметров печати карты

  6. Для просмотра результата нажмите кнопку Просмотр. Если на экране отображены не все листы вы можете настроить масштаб отображения [image] , а так же и количество и расположение листов на экране ( [image] и [image] ).

    Просмотр перед печатью

    Рисунок 951. Просмотр перед печатью

  7. Если на данном этапе вас не устроит увиденный результат, то можно нажать кнопку Закрыть и изменить нужные настройки. Чаще всего не устраивает толщина трубопроводов, выводимая на печать. Данный параметр можно изменить в структуре слоя, настроив в линейном режиме участков сети параметр толщина при печати.

    Если все устраивает, нажмите кнопку [image] Печать.


Макет печати

  • «Управление макетами карты»

  • «Задание размеров страниц макета и принтера»

  • «Настройка печати карты»

  • «Редактирование элементов макета»

  • «Создание и правка элементов макета»

  • «Печать макета»

  • «Импорт и экспорт макета печати»

Макет печати служит для подготовки печатных документов, содержащих изображения карт, текст и графику. Макеты могут размещаться в составе карты ZuluGIS или храниться в виде отдельных файлов макетов.

[Примечание] Примечание

Подготовленный к печати макет можно экспортировать в PDF файл.


Управление макетами карты

Для управления макетами карты в системе предусмотрены два инструмента: диалог макетов и панель макетов. Оба инструмента предоставляют похожие возможности, реализуемые немного отличающимися способами. При рассмотрении действий с макетами будут рассматриваться оба способа.

Диалог управления макетами открывается выполнением команды меню Карта|Макеты.. или с помощью панели Рабочее место. Для этого надо сделать щелчок правой кнопкой мыши на названии карты в панели, затем выбрать в контекстном меню пункт Макеты....

Рисунок 952. Диалог Макеты

Чтобы открыть панель макетов, выполните команду меню Окно|Макеты.

Рисунок 953. Панель макетов

С макетами печати предусмотрены следующие основные действия:

  • Создание макета

  • Открытие макета для редактирования и печати

  • Переименование макетов, добавленных в карту

  • Удаление макетов из карты

  • Дублирование макетов

  • Сохранение макетов

  • Задание размеров страниц макетов и принтера

  • Редактирование элементов макетов

  • Печать открытых макетов

  • Импорт макетов в карту из других карт и файлов и экспорт макета из карты в отдельный файл


Создание нового макета

Макет печати при создании может размещаться в конкретной карте ZuluGIS или в отдельном файле.

Создание макета печати для карты:

Окно карты, для которой нужно создать макет, должно быть активно.

Для создания нового макета выберите один из вариантов:

  • Откройте диалог Макеты печати (меню Карта|Макеты...) и нажмите кнопку Создать.

  • Нажмите кнопку [image] на панели инструментов и в открывшемся меню выберите пункт Новый макет для карты <Карта>.

  • Нажмите кнопку [image] панели макетов.

В результате откроется окно редактирования макета. Созданный макет добавляется в карту.

Создание макета печати в отдельном файле:

Нажмите кнопку [image] на панели инструментов. Если при этом было активно окно карты, то в появившемся меню выберите пункт Новый пустой макет....

В результате откроется окно редактирования макета. Новый макет не будет привязан к конкретной карте и будет сохраняться как самостоятельный документ (в файле с расширением .zrp).


Открытие макета для редактирования и печати

Чтобы открыть макет печати карты:

  1. Выполните команду меню Карта|Макеты, откроется диалог управления макетами.

  2. Выберите в списке макет и нажмите кнопку Открыть

ИЛИ

  1. Выполните двойной щелчок левой кнопкой мыши по строке макета панели макетов или выберите макет в списке и нажмите кнопку [image] панели (нажмите клавишу Enter клавиатуры).

Чтобы открыть макет, сохраненный в файле:

  1. Выберите в меню Файл|Открыть или нажмите кнопку [image] .

  2. В окне выбора файла выберите тип файла Макеты отчета (*.zrp).

  3. Укажите файл макета и нажмите OK.


Переименование макета, добавленного в карту

Для переименования макета в карте доступны следующие способы:

  • В панели макетов:

    • Выберите макет в списке, после чего переместите указатель мыши на строку названия макета и однократно щелкните левой кнопкой мыши.

      ИЛИ

    • Переместите указатель мыши на строку названия макета, нажмите правую кнопку мыши и выполните в открывшемся контекстном меню команду Переименовать.

      Далее введите новое название макета и нажмите клавишу Enter клавиатуры.

  • В диалоге макетов:

    • Откройте диалог макетов (меню Карта|Макеты), выберите макет в списке, нажмите кнопку Переименовать, введите новое имя макета в открывшемся диалоге и нажмите кнопку ОК.


Удаление макета из карты

Для удаления макета из карты:

  • В панели макетов выберите требуемый макет в списке и нажмите клавишу Delete клавиатуры или нажмите кнопку [image] панели. Затем подтвердите удаление, нажав кнопку Да открывшегося диалога.

    ИЛИ

  • Откройте диалог макетов (меню Карта|Макеты), выберите макет в списке, нажмите кнопку Удалить и подтвердите удаление.


Дублирование макета

При дублировании макета в карте создается точная копия исходного макета с другим названием.

Для дублирования макета в карте:

  • В панели макеты переместите указатель мыши на строку названия макета, нажмите правую кнопку мыши, выполните в открывшемся контекстном меню команду Добавить копию… и введите название копии в открывшемся диалоге.

    ИЛИ

  • Откройте диалог макетов (меню Карта|Макеты), выберите макет в списке, нажмите кнопку Копировать и введите название копии в открывшемся диалоге.


Сохранение макета

Макет печати может быть сохранен в карту или как отдельный документ. Во втором случае для сохранения макета в отдельный документ надо произвести его экспорт.

Чтобы сохранить макет печати в карту:

  1. Выберите в меню команду Файл|Сохранить или нажмите кнопку [image] панели инструментов.

  2. В появившемся диалоговом окне введите имя макета, под которым он будет сохранен в карте, и нажмите OK. Макет будет сохранен.

[Примечание] Примечание

После сохранения макета обязательно необходимо сохранить карту, для которой он создавался!


Задание размеров страниц макета и принтера

По умолчанию макет создается в формате А4. В дальнейшем можно задать произвольные размеры макета. Если макет не помещается на одной странице размера, указанного в настройках, он разбивается на несколько страниц, как по горизонтали, так и по вертикали.

На макете рамка странниц принтера отображается пунктирной линией, а рамка макета – сплошной. В том случае, если они не совпадают, это наглядно видно. На рисунке ниже размер макета A2, а размер страниц принтера A3. Это означает, что при таких настройках макет будет напечатан на 2 страницах.

Страницы макета и принтера

Рисунок 954. Страницы макета и принтера

Настройка размеров страницы макета

Для настройки размеров страницы макета:

  1. Выберите пункт меню Файл|Параметры страницы, откроется диалог настройки страницы.

  2. Во вкладке Макет укажите размер макета, выбрав из списка известный формат и ориентацию или вписав в соответствующие поля его ширину и высоту.

  3. Нажмите кнопку OK.

Дополнительные настройки размеров страницы принтера

Настройки страниц принтера изначально производятся при настройках самого принтера, но возможно настроить дополнительные параметры, например, такие как поля.

Для настройки страниц принтера:

  1. Выберите пункт меню Файл|Параметры страницы.

  2. Выберите вкладку Страница. Изначально будут отображены те параметры страницы, которые ранее были указаны при настройке принтера. При необходимости измените их:

    • в разделе Бумага выберите размер и подачу бумаги. Список доступных размеров бумаги зависит от драйверов принтера. Большие форматы, такие как A0, A1 и другие, могут быть выбраны, например, при установке PDF принтера;

    • в разделе Ориентация выберите ориентацию страницы;

    • в разделе Поля и Отступы колонтитулов укажите необходимые параметры.

  3. Нажмите кнопку OK.


Настройка печати карты

Одну и ту же карту можно распечатать разными способами. Например, в разных масштабах: в масштабе, подобранном размером со страницу, в указанном вручную масштабе, на одной странице или на множестве страниц. При этом может печататься текущий масштаб и центр карты, карта по размерам слоя или указанные зоны карты в специальном слое. Также можно распечатать карту по габаритам планшетов, указанным в специальном слое.

Параметры печати задаются в свойствах карты. В зависимости от выбранного способа можно реализовать различные сценарии:

  • печатать текущий масштаб и центра карты;

  • печатать всю карту;

  • печатать по габаритам указанного слоя;

  • печатать фрагмент печати;

  • производить печать по габаритам заранее подготовленных планшетов.

Настроенный макет с картой города на листе A0, область печати задана по размерам слоя Тепловая сеть в масштабе 1:5000

Рисунок 955. Настроенный макет с картой города на листе A0, область печати задана по размерам слоя Тепловая сеть в масштабе 1:5000


Печать текущего масштаба и центра карты

При данном варианте печати будет напечатана карта по области, которая непосредственно отображается в макете. Масштаб печатаемой карты определяется в соответствии с отображаемой областью, при желании масштаб можно настроить.

Для печати карты по текущему масштабу и центру карты:

  1. Создайте макет.

  2. Настройте размеры страниц макета и принтера.

  3. Добавьте в макет карту, если нужно отредактируйте положение видимой области карты.

  4. При необходимости добавьте другие элементы макета.

  5. Сделайте щелчок левой кнопкой мыши по объекту Карта, щелкните правой кнопкой мыши и в контекстном меню выберите пункт Свойства.

  6. На вкладке Карта в разделе Область печати выберите Текущие масштаб и центр.

  7. Программа автоматически определяет масштаб печатаемой области. Если вам нужен другой масштаб, введите его в поле масштаб: и нажмите кнопку Применить. Масштаб карты сразу изменится. Кнопка ОК закроет окно настройки карты.

    Макет с картой города на листе A1, область печати задана Текущие масштаб и центр

    Рисунок 956. Макет с картой города на листе A1, область печати задана Текущие масштаб и центр

  8. Для предварительного просмотра результата выберите в меню Файл|Предварительный просмотр, либо нажмите кнопку [image] .

  9. Напечатайте макет или произведите его экспорт в PDF.


Печать всей карты

Карту можно напечатать в указанном масштабе или в масштабе, который будет подобран для того, чтобы вписать всю карту в страницу. Так же могут быть напечатаны только выделенные объекты в области карты.

Для настройки печати всей карты:

  1. Создайте макет.

  2. Настройте размеры страниц макета и принтера.

  3. Добавьте в макет карту.

  4. При необходимости добавьте другие элементы макета.

  5. Сделайте щелчок левой кнопкой мыши по объекту Карта, щелкните правой кнопкой мыши и в контекстном меню выберите пункт Свойства.

  6. На вкладке Карта в разделе Область печати выберите Вся карта.

  7. По умолчанию положение объекта печати в центре листа, если его надо изменить установите опцию положение и с помощью курсора выберите новое положение. Выбор положения недоступен при печати карты, вписанной в страницу.

  8. Для печати карты в определенном масштабе внесите нужный масштаб в окне масштаб:. В дальнейшем системой будет подобрано необходимое количество страниц для печати карты в указанном масштабе. Если надо всю карту разместить на одной странице установите опцию вписать в страницу, тогда масштаб подберется автоматически в соответствии с выбранной опцией.

    Макет с картой города на листе A1, область печати задана Вся карта с опцией вписать в страницу

    Рисунок 957. Макет с картой города на листе A1, область печати задана Вся карта с опцией вписать в страницу

  9. Чтобы закрыть окно диалога настройки печати карты нажмите кнопку ОК.

  10. Для предварительного просмотра результата выберите в меню Файл|Предварительный просмотр, либо нажмите кнопку [image] .

    Предварительный просмотр макета с картой города на листе A1, область печати задана Вся карта с опцией вписать в страницу

    Рисунок 958. Предварительный просмотр макета с картой города на листе A1, область печати задана Вся карта с опцией вписать в страницу

    Предварительный просмотр макета с картой города на листе A1, область печати задана Вся карта, масштаб 1:5000

    Рисунок 959. Предварительный просмотр макета с картой города на листе A1, область печати задана Вся карта, масштаб 1:5000

  11. Напечатайте макет или произведите его экспорт в PDF.


Печать по габаритам указанного слоя

Карта может быть напечатана по габаритам выбранного слоя, то есть все объекты, которые не попадают в габариты слоя напечатаны не будут. Печать производится как в указанном масштабе, так и в масштабе, который будет подобран для того чтобы вписать все объекты слоя в страницу. Так же могут быть напечатаны только выделенные объекты в области карты.

Для настройки печати по габаритам указанного слоя:

  1. Создайте макет.

  2. Настройте размеры страниц макета и принтера.

  3. Добавьте в макет карту.

  4. При необходимости добавьте другие элементы макета.

  5. Сделайте щелчок левой кнопкой мыши по объекту Карта, щелкните правой кнопкой мыши и в контекстном меню выберите пункт Свойства.

  6. На вкладке Карта в разделе Область печати, строка вид: выберите По габаритам слоя.

  7. В строке слой: укажите слой по габаритам которого будет производится печать.

  8. По умолчанию положение объекта печати в центре листа, если его надо изменить установите опцию положение и с помощью курсора выберите новое положение. Выбор положения недоступен при печати карты, вписанной в страницу.

  9. Для печати карты в по габаритам слоя в определенном масштабе впишите нужный масштаб в окне масштаб:. В дальнейшем системой будет подобрано необходимое количество страниц для печати в указанном масштабе. Если надо всю карту разместить на одной странице установите опцию вписать в страницу, тогда масштаб подберется автоматически в соответствии с выбранной опцией.

    Макет с картой города на листе A1, область печати задана По габаритам слоя Тепловая сеть с опцией вписать в страницу

    Рисунок 960. Макет с картой города на листе A1, область печати задана По габаритам слоя Тепловая сеть с опцией вписать в страницу

  10. Чтобы закрыть окно диалога настройки печати карты нажмите кнопку ОК.

  11. Для предварительного просмотра результата выберите в меню Файл|Предварительный просмотр, либо нажмите кнопку [image] .

    Предварительный просмотр макета с картой города на листе A1, область печати задана По габаритам слоя Тепловая сеть с опцией вписать в страницу

    Рисунок 961. Предварительный просмотр макета с картой города на листе A1, область печати задана По габаритам слоя Тепловая сеть с опцией вписать в страницу

    Предварительный просмотр макета с картой города на листе A1, область печати задана По габаритам слоя Тепловая сеть, масштаб 1:5000

    Рисунок 962. Предварительный просмотр макета с картой города на листе A1, область печати задана По габаритам слоя Тепловая сеть, масштаб 1:5000


Печать фрагмента

Возможно напечатать определенный фрагмент карты, для этого его надо будет выделить. Фрагмент может быть напечатан как в указанном масштабе, так и в масштабе, который будет подобран для того чтобы вписать его в страницу.

Для настройки печати фрагмента:

  1. В активной карте выделите фрагмент для печати.

  2. Создайте макет.

  3. Настройте размеры страниц макета и принтера.

  4. Добавьте в макет карту.

  5. При необходимости добавьте другие элементы макета.

  6. Сделайте щелчок левой кнопкой мыши по объекту Карта, щелкните правой кнопкой мыши и в контекстном меню выберите пункт Свойства.

  7. На вкладке Карта в разделе Область печати, строка вид: выберите Фрагмент печати.

    [Примечание] Примечание

    Если фрагмент не выделен на карте, то будет напечатан текущий масштаб и центр карты. Область можно выделить не только перед созданием макета но и в том случае когда он уже создан. Для ее выделения перейдите на вкладку активной карты.

    Рисунок 963.

  8. По умолчанию положение фрагмента печати в центре листа, если его надо изменить установите опцию положение и с помощью курсора выберите новое положение. Выбор положения недоступен при печати, вписанной в страницу.

  9. Для печати фрагмента в определенном масштабе впишите нужный масштаб в окне масштаб:. В дальнейшем системой будет подобрано необходимое количество страниц для печати в указанном масштабе. Если надо фрагмент разместить на одной странице, то установите опцию вписать в страницу, тогда масштаб подберется автоматически в соответствии с выбранной опцией.

    Макет с фрагментом карты города на листе A1, область печати задана Фрагмент печати с опцией вписать в страницу

    Рисунок 964. Макет с фрагментом карты города на листе A1, область печати задана Фрагмент печати с опцией вписать в страницу

  10. Чтобы закрыть окно диалога настройки печати карты нажмите кнопку ОК.

  11. Для предварительного просмотра результата выберите в меню Файл|Предварительный просмотр, либо нажмите кнопку [image] .

    Предварительный просмотр макета с картой города на листе A1, область печати задана Фрагмент печати с опцией вписать в страницу

    Рисунок 965. Предварительный просмотр макета с картой города на листе A1, область печати задана Фрагмент печати с опцией вписать в страницу


Многостраничная печать по планшетам

Суть данного метода печати заключается в формировании многостраничного документа, с одинаковым на всех листах оформлением, изменяться могут только надписи, оформленные в виде подстановок. При такой печати обязательно создается шаблон, в рамках одного макета может быть несколько шаблонов. Обычно таким образом формируют планшеты, что и дало название данному методу.

Использование печати по планшетам позволяет печатать карту по габаритам определенных областей (планшетов), которые вносятся в определенный слой (слой с объектами печати).

Количество листов для печати будет равно количеству объектов в слое для печати. Можно формировать документ по всем объектам или выбрать несколько при формировании окна предварительного просмотра, по аналогии с формированием запросов к базам данных. Выбор осуществляется по кодам, по умолчанию sys или по пользовательскому атрибуту, для этого в слое с планшетами необходимо сформировать базу данных. В дальнейшем информация хранимая в базах данных может быть использована в подстановках в макете.

Получившийся в окне предварительного просмотра документ можно распечатать на принтере или сохранить в файл PDF.

Настройка печати по планшетам производится в несколько этапов:

  1. Создается векторный слой. Если требуются подстановки, то к слою надо создать базу данных.

  2. В слой вносятся объекты (планшеты), по габаритам которых в дальнейшем будет производится печать.

  3. Если была создана база данных, то в нее для дальнейших подстановок вносятся данные.

  4. Создается макет печати с нужными элементами.

  5. Настраивается область печати карты и создается шаблон планшета.

  6. Производится печать макета.

1 Этап. Создание векторного слоя с объектами печати (планшетов)

  1. Слой с планшетами может быть создан двумя способами.

    • Первый вариант это создание слоя в виде сетки с указанным шагом. Сетка создается в виде полигонов по габаритам карты, слоя или по выделенным объектам. Одновременно со слоем рекомендуется создать базу данных, данные из которой в дальнейшем могут быть использованы для нумерации листов и автоматической подстановки.

    • Второй вариант создание простого векторного слоя. Слою возможно создать базу данных, данные из которой могут быть использованы для нумерации листов и автоматической подстановки в виде текстовой надписи при оформлении листа макета. Данные из таблицы будут размещены на каждом листе. Примером таких подстановок может быть название планшета, дата создания, автор и др.

      Пример диалога создания векторного слоя одновременно с базой данных

      Рисунок 966. Пример диалога создания векторного слоя одновременно с базой данных

В том случае, если база данных к слою не будет создана, то в дальнейшем при печати или просмотре планшетов вывод возможно будет осуществлять по ключу объектов (ID). ID объектам присваиваются автоматически при вводе их в слой, он уникален в рамках слоя. Если объект удален, его ID никому присваиваться не будет. Соответственно, в результате редактирования слоя может сложиться такая ситуация, что в слое какие либо ключи будут отсутствовать. При вводе отсутствующего ID на просмотр или печать будет выводится текущий вид макета, как если бы шаблон планшета не был бы к нему применён. Именно по этим причинам не рекомендуется использовать ID в качестве кода.

[Примечание] Примечание

Чтобы слой с планшетами не был виден при печати откройте панель настройки слоя и снимите опцию Отображать слой при печати.

2 Этап. Создание объектов (планшетов) в слое

Если слой был создан в виде сетки с указанным шагом, то данный этап следует пропустить, так как объекты создаются автоматически.

В том случае, если был создан простой векторный слой, то объекты, по габаритам которых будет производится печать необходимо внести в слой. Введите планшет в созданный на предыдущем этапе слой в виде полигонов (контуров). Полигоны могут быть как с заливкой так и без нее. Последовательность ввода простых полигонов (примитивов) можно узнать в разделе «Ввод простого площадного объекта (полигона) с экрана».

В качестве планшетов можно использовать не только примитивы но и типовые объекты. В таком случае необходимо будет создать площадные типы и к ним режимы. Так же при необходимости подстановок к ним можно создать семантическую базу данных. Последовательность ввода типовых полигонов можно узнать в разделе «Ввод типового площадного объекта (полигона) с экрана».

На рисунке ниже в слой введены три простых полигона с заливкой, для удобства для каждого полигона установлена прозрачность 60%. Каждый полигон покрывает собой зону действия определенной котельной. При печати их с применением шаблон печати они могут быть представлены на 3-х листах одного формата с одинаковым оформлением макета, но в разных масштабах. Полигоны печататься не будут, если указана соответствующая опция в настройках слоя.

Пример введенных планшетов по зонам действия котельных

Рисунок 967. Пример введенных планшетов по зонам действия котельных

Предварительный просмотр печати. Слой с планшетами скрыт при печати

Рисунок 968. Предварительный просмотр печати. Слой с планшетами скрыт при печати

3 Этап. Внесение данных для подстановок

Если для подстановок создавалась база данных, то в нее необходимо ввести нужную информацию. Как это сделать можно узнать в разделе «Заполнение табличных данных через вкладку Текущая запись» или запросами, если информация будет повторяться.

Пример окна семантической информации

Рисунок 969. Пример окна семантической информации

4 Этап. Создание макета печати и добавление элементов

На данном этапе:

  1. Создайте макет.

  2. Настройте размеры страниц макета и принтера.

  3. Добавьте в макет карту.

  4. Должным образом оформите макет, для этого добавьте элементы макета.

5 Этап. Настройка области печати карты и создание шаблона планшета

  1. Сделайте щелчок левой кнопкой мыши по объекту Карта в макете, щелкните правой кнопкой мыши и в контекстном меню выберите пункт Свойства.

  2. На вкладке Карта в разделе Область печати, строка вид: выберите Планшет.

    Рисунок 970. Настройка карты

  3. Если есть уже готовый шаблон планшета, то выберите его из списка шаблон:. Если шаблона нет, создайте его.

  4. По умолчанию положение планшетов в центре листа, если его надо изменить установите опцию положение и с помощью курсора выберите новое положение. Выбор положения недоступен при печати планшетов, вписанных в страницу.

  5. Для печати каждого планшета на одной странице, установите опцию вписать в страницу, тогда масштаб подберется автоматически. Для печати планшетов в определенном масштабе внесите нужный масштаб в окне масштаб:. В дальнейшем системой будет подобрано необходимое количество страниц для печати в указанном масштабе.

  6. Чтобы подтвердить настройки нажмите кнопку Применить, кнопка ОК произведет применение настроек и закроет диалоговое окно.

6 Этап. Производится печать макета или экспорт в формат PDF

Перед печатью или экспортом планшетов в формат PDF можно осуществить предварительный просмотр результата. Для него:

  1. Выберите в меню Файл|Предварительный просмотр, либо нажмите кнопку [image] .

  2. В появившемся окне укажите код планшета. Можно формировать документ по всем объектам или выбрать несколько. Для просмотра одновременно всех планшетов нажмите кнопку Все иди введите * и нажмите кнопку ОК. Для просмотра нескольких планшетов вводятся данные по аналогии с формированием запросов к базам данных. Например, если есть коды A-1, А-2, А-3, В-1, В-2, то для просмотра планшетов A-1, А-2, А-3 в строку кодов можно ввести A*.

    Откуда будет взята информация о коде указывается при создании шаблона планшета.

    Код планшета для печати

    Рисунок 971. Код планшета для печати

Если результат предварительного просмотра устраивает, то напечатайте - кнопка [image] или экспортируйте планшеты в формат PDF - кнопка [image] .

Предварительный просмотр печати по планшету 1 с параметром вписать в страницу

Рисунок 972. Предварительный просмотр печати по планшету 1 с параметром вписать в страницу


Редактирование элементов макета

В данном разделе описаны возможности для редактирования объектов макета печати:

  • «Выделение элементов макета»

  • «Удаление элементов макета»

  • «Изменение положения и габаритов объектов»

  • «Изменение порядка объектов»

  • «Группировка объектов»;

  • «Разгруппировка объектов»

  • «Фиксация объектов относительно группы»

  • «Изменение цвета и стиля объектов»

  • «Сохранение макета»


Выделение элементов макета

Для выделения объектов макета используются либо инструменты [image] и [image] в окне макета, либо список объектов панели Объекты.

Выделение элементов в окне макета с помощью инструмента [image] :

  • Щелчок левой кнопкой мыши по объекту макета выделяет одиночный объект или группу объектов, в которую он входит;

  • щелчок левой кнопкой мыши с нажатой клавишей Ctrl или Shift добавляет или убирает объект из выделенных, оставляя выделение прочих объектов без изменения. При этом можно выделять отдельные объекты внутри групп объектов;

  • нажатие левой кнопки мыши на свободном участке макета и выделение резиновой рамкой прямоугольной области позволяет выделить объекты или группы, частично или целиком попадающие в эту область.

Выделение элементов в окне макета с помощью инструмента [image] :

Выполняется аналогично выделению с помощью инструмента [image] за тем исключением, что нажатие левой кнопки мыши по вершине ломаной или многоугольника выделяет эту вершину.

Выделение с помощью панели Объекты:

  • Щелчок левой кнопкой мыши в правый край строки списка объектов выделяет указанный объект;

  • щелчок левой кнопкой мыши в правый край строки списка с нажатой клавишей Ctrl или Shift добавляет или убирает указанный объект из выделенных, оставляя выделение прочих объектов без изменения.


Удаление элементов макета

Для удаления одного или нескольких элементов макета:

  1. Выделите элементы макета, которые надо удалить.

  2. Нажмите клавишу Del или кнопку [image] инструментов – выделенные элементы будут удалены.


Изменение положения и габаритов объектов

Можно изменять положение и габариты одного или сразу нескольких объектов.

Изменение положения и габаритов объектов с помощью инструмента [image] :

  1. Выделите интересующие объекты макета.

  2. Выберите инструмент [image] (если он еще не выбран текущим).

  3. Положение объектов можно изменить простым перетаскиванием с помощью левой кнопки мыши.

  4. Для изменения размеров нажмите и перетащите один из восьми квадратных маркеров по периметру выделенных объектов.

Изменение положения и габаритов объектов с помощью панели Габариты:

С помощью панели Габариты можно точно задать расположение и размеры выделенных объектов.

  1. С помощью элемента [image] задается точка привязки, относительно которой будет меняться положение и размеры объекты.

  2. Поля X и Y задают положение объекта. В зависимости от того, какая выбрана точка привязки, эта точка объекта будет совмещается с указанными координатами.

  3. Поля W и H задают ширину и высоту объекта соответственно. При изменении этих значений габариты объекта будут меняться относительно выбранной точки привязки.

    Рисунок 973.


Изменение порядка объектов

Изменение порядка объектов на макете задает последовательность их отрисовки и, в случае, если один объект накрывает другой, какой из объектов отображается поверх другого.

Для изменения порядка объектов:

  1. Выделите интересующие объекты макета.

  2. Выберите в главном меню пункт Объект|Порядок, либо нажмите правой кнопкой мыши в окне макета и в контекстном меню выберите пункт Порядок.

  3. В подменю Порядок выберите подходящую команду:

    • команда На передний план поместит выделенные объекты поверх остальных;

    • команда На задний план поместит выделенные объекты позади остальных;

    • команда Переместить вперед переместит выделенные объекты на одну ступень поверх ближайших соседей;

    • команда Переместить назад переместит выделенные объекты на одну ступень позади ближайших соседей.

Если какой - либо выделенный объект входит в группу, то его порядок меняется только относительно соседей по группе.


Группировка объектов

Можно объединять несколько объектов в группу, это позволяет манипулировать несколькими объектами как единым целым. Группы также могут содержать вложенные подгруппы.

Для группировки объектов:

  1. Выделите не менее двух объектов макета.

  2. В главном меню выберите команду Объект|Группировать.

    - либо -

    Щелкните правой кнопкой мыши в окне макета и в контекстном меню выберите пункт Группировать.

[Примечание] Примечание

При группировке объектов может быть полезным фиксация границ объектов относительно группы, чтобы регулировать каким образом будут меняться положение и размеры объектов внутри группы при изменении габаритов самой группы.


Разгруппировка объектов

  1. Выделите нужную группу объектов.

  2. В главном меню выберите команду Объект|Разгруппировать.

    - либо -

    Щелкните правой кнопкой мыши в окне макета и в контекстном меню выберите пункт Разгруппировать.


Фиксация объектов относительно группы

При изменении габаритов группы, входящие в нее объекты по умолчанию пропорционально сжимаются или растягиваются, меняя при этом свое положение.

Существует возможность задать «якоря» для объекта так, чтобы при изменении габаритов группы, зафиксировать его размеры и/или положение относительно группы. Таким образом можно фиксировать как отдельные объекты внутри группы, так и подгруппы.

Якоря задаются для сторон прямоугольника, описывающего данный объект или подгруппу – слева, справа, сверху и снизу. Поведение объекта при изменении габаритов группы в зависимости от установленных якорей представлено в таблице ниже:

Таблица 15.

Слева | Справа | Поведение
 |  | Ширина и положение объекта по горизонтали меняется пропорционально габаритам группы.
X |  | Положение объекта по горизонтали фиксируется относительно левой границы группы, ширина не меняется
 | X | Положение объекта по горизонтали фиксируется относительно правой границы группы, ширина не меняется.
X | X | Левая и правая стороны объекта фиксируется относительно левой и правой границы группы, ширина меняется с учетом этих условий.
Сверху | Снизу | Поведение
 |  | Высота и положение объекта по вертикали меняется пропорционально габаритам группы.
X |  | Положение объекта по вертикали фиксируется относительно верхней границы группы, высота не меняется.
 | X | Положение объекта по вертикали фиксируется относительно нижней границы группы, высота не меняется.
X | X | Верхняя и нижняя стороны объекта фиксируется относительно верхней и нижней границы группы, высота меняется с учетом этих условий.

Для задания якорей для объектов:

  1. С помощью инструмента или окна Объекты выделите нужный объект или подгруппу.

  2. В окне Якорь установите флажки для нужных якорей.

    - либо -

    Щелкните правой кнопкой мыши в окне макета и выберите пункт меню Свойства, в закладке Общие установите флажки для якорей.


Изменение цвета и стиля объектов

У большинства объектов макета (кроме линий) можно задать цвет фона и рамку вокруг объекта.

Для задания цвета и стиля объекта:

  1. Выделите объект.

  2. Щелкните правой кнопкой мыши по объекту и в меню выберите пункт Свойства.

  3. В закладке Цвета и линии укажите цвет фона объекта, цвет и толщину рамки вокруг объекта и нажмите OK.

Кроме того, задать цвет и стиль объекта можно с помощью следующих инструментов:

- задает цвет фона объекта;

- задает цвет рамки объекта.


Создание и правка элементов макета

Макет печати может состоять из различных объектов, далее будут рассмотрены особенности работы с каждым из этих элементов:

  • «Рамка»

  • «Карта»

  • «Легенда»

  • «Указатель масштаба»

  • «Знак «Север»»

  • «Текст»

  • «Таблица»

  • «Изображения»

  • «Векторные графические элементы»


Рамка

  • «Добавление рамки»

  • «Редактирование рамки»

Добавление рамки

Для добавления рамки в макет:

  1. Выберите команду меню Вставка|Рамка.... После чего в макет будет добавлена рамка в соответствии с размерами и ориентацией страницы.

Для заполнения рамки текстом:

  1. Нажмите кнопку [image] на панели инструментов Макет.

  2. Переместите указатель мыши в ячейку рамки и сделайте щелчок левой кнопкой мыши. Работа с текстом в ячейках выполняется аналогично работе с текстом в других частях макета.


Редактирование рамки

По сути рамка это несколько сгруппированных вместе таблиц, поэтому если требуется изменить исходный текст в рамке или структуру таблиц то рамку обязательно необходимо разгруппировать. Выделение рамки для разгруппировки производится в режиме выделения [image] , щелчок левой кнопкой мыши надо делать на таблице рамки.

После разгруппировки таблиц рамки возможно:

  • удалить таблицы;

  • переместить таблицы;

  • заменить текст в таблицах;

  • дополнить рамку новыми таблицами;

  • сгруппировать объекты рамки.


Карта

  • «Добавление карты»

  • «Редактирование карты в макете»

  • «Создание шаблона планшета»

Добавление карты

Для добавления карты в макет:

  1. Нажмите кнопку [image] на панели инструментов Макет, либо выберите команду меню Вставка|Карта.

    • Если макет принадлежит какой-то карте, то в открывшемся диалоге требуется выбрать: следует ли вставлять фрагмент текущей карты, или выбрать другую карту (в последнем случае требуется также в стандартном диалоге выбора файлов указать файл карты);

    • Если макет является самостоятельным документом, то в панели выбора карты укажите карту, которую нужно вставить в макет.

  2. Выделите мышью прямоугольную область на макете, либо щелкните мышью в том месте, куда следует вставить фрагмент выбранной карты.

После добавления карты ее размер можно отредактировать точно по координатам и масштабу или с помощью мыши визуально .


Редактирование карты в макете

  • визуальная настройка карты в окне макета

  • точная настройка карты в окне макета

  • настройка области печати карты

  • замена карты

Разместив карту в макете можно точно настроить отображаемый фрагмент местности, включая масштаб, координаты центра карты и угол поворота, а также цвет фона карты и рамку.

Для того, чтобы настроить фрагмент карты визуально в окне макета:

  1. Сделайте двойной щелчок левой кнопкой мыши по объекту Карта. Объект примет вид как на рисунке снизу.

  2. Используйте инструменты навигации, чтобы выбрать отображаемый в объекте фрагмент местности:

    • С помощью инструмента [image] можно перемещать карту внутри объекта;

    • Если нажать на стрелку справа от [image] , то в зависимости от выбранного пункта возможно сдвинуть на размер видимой области влево/вправо/вверх/вниз. Сдвиг так же возможно произвести сделав щелчок правой кнопкой мыши и выбрав в контекстном меню пункт Сдвиг|Влево/Вправо/Вверх/Вниз.

    • С помощью инструментов [image] и [image] можно изменять масштаб карты;

    • С помощью кнопки [image] можно произвести масштабирование по размерам всей карты.

    • Если нажать на стрелку справа от кнопки масштабирования [image] , то можно произвести масштабирование по размерам слоя, по размеру выделенной группы или текущему виду карты. Для этого надо выбрать соответствующий пункт из меню:

      Меню масштабирования карты

      Рисунок 974. Меню масштабирования карты

    • Поворотом колесика мыши также можно плавно менять масштаб карты;

    • Поворотом колесика мыши с одновременным удержанием клавиши Ctrl можно плавно изменять угол поворота карты.

    Рисунок 975. Фрагмент карты

Для того, чтобы точно настроить параметры фрагмента карты:

  1. Щелкните правой кнопкой мыши по объекту Карта и в меню выберите пункт Свойства.

    Диалог свойства карты

    Рисунок 976. Диалог свойства карты

  2. Измените необходимые параметры:

    • координаты центра карты, масштаб и угол поворота - вкладка Карта;

    • размеры фрагмента и его якорь - вкладка Общие;

    • цвет фона карты и параметры рамки - вкладка Цвета и линии.

Для того, чтобы настроить область печати карты:

  1. Щелкните правой кнопкой мыши по объекту Карта и в меню выберите пункт Свойства.

    Диалог свойства карты

    Рисунок 977. Диалог свойства карты

  2. В разделе Область печати из списка вид выберите подходящее значение:

    • Текущие масштаб и центр - печататься будет видимая область карты, масштаб будет определен автоматически, подробней о такой печати можно узнать в разделе Печать текущего масштаба и центра карты;

    • Вся карта - на печать выводится вся карта, по умолчанию в текущем масштабе, подробней о такой печати можно узнать в разделе Печать всей карты;

    • По габаритам слоя - на печать будут выведены объекты, попавшие в габариты указанного слоя, по умолчанию в текущем масштабе, подробней о такой печати можно узнать в разделе Печать по габаритам указанного слоя;

    • Фрагмент печати - на печать будет выведен выделенный фрагмент, подробней о такой печати можно узнать в разделе Печать фрагмента;

    • Планшет - выбор данного пункта позволяет произвести многостраничную печать по планшетам, подробней можно узнать в разделе Многостраничная печать по планшетам.

Для того, чтобы заменить карту:

  1. Щелкните правой кнопкой мыши по объекту Карта и в меню выберите пункт Выбрать карту.

  2. Если макет встроен в существующую карту, то в появившейся панели Вставить текущую карту выберите вариант карты, который нужно поместить во фрагмент;

  3. Если макет - самостоятельный, либо выбран вариант вставки сохраненной карты из файла, то в панели выбора файла укажите путь к вставляемой карте.


Создание шаблона планшета

В том случае, если в области печати карты выбран вид Планшет, то необходимо так же указать из списка шаблон: шаблон для планшета. Когда шаблона нет его надо создать. Для создания шаблона печати по планшетам:

  1. Для открытия окна свойств карты макета сделайте щелчок левой кнопкой мыши по объекту Карта в макете, щелкните правой кнопкой мыши и в контекстном меню выберите пункт Свойства. Если окно уже открыто, пропустите данный пункт.

  2. Для редактирования ранее созданного шаблона в разделе Область печати из списка шаблон выберите шаблон и нажмите кнопку .... Для создания нового шаблона из списка шаблон выберите пункт Добавить/удалить шаблон.

  3. В появившемся диалоге Шаблон планшета в строке Шаблон введите название создаваемому шаблону.

  4. Из списка слой выберите слой с объектами печати. Список будет содержать слои активной карты, если слоя в карте нет нажмите кнопку Обзор... и укажите нужный слой. Важно учесть, что если слой будет удален, то шаблон перестанет работать.

  5. Если планшеты являются типовыми объектами, то из списка Объекты выберите тип и режим планшетов. При использовании примитивных объектов в качестве планшетов пропустите данный пункт.

  6. В том случае, когда в базе данных для подстановок создано несколько запросов при необходимости можно сменить запрос из которого будет загружаться информация. Запрос меняется в строке Запрос.

  7. Следующим этапом необходимо указать атрибуты. Данные выбранных полей будут размешаться в виде надписей на каждом листе макета, как подстановка. Для вывода планшетов при предварительном просмотре, печати или импорте в PDF обязательно используется код планшета. Код может быть цифровым или буквенным.

    При отсутствии семантической базы данных указывается только атрибут, который определяет код планшета при просмотре и печати. Так как база данных отсутствует, то за код будет принят ID объекта. Для его указания:

    1. Сделайте щелчок левой кнопкой мыши в столбце Поле справа от строки Код, нажмите кнопку ....

    2. В диалоговом окне Поле запроса выделите поле Sys и нажмите кнопку ОК.

    При наличии базы данных надо указать поле из которого будет браться код планшета при просмотре и печати, это может быть как строка базы данных так и ID объекта. Так же если будут использоваться подстановки, то указываются нужные поля. Для задания атрибутов:

    1. В строке Код задайте от куда берутся данные кодов. Для этого сделайте щелчок левой кнопкой мыши в столбце Поле справа от строки Код, нажмите кнопку .... В диалоговом окне Поле запроса выделите нужное поле и нажмите кнопку ОК.

    2. Укажите остальные поля, которые могут использоваться для подстановок в макете. Слева в столбце Имя указывается имя атрибута, справа поле из которого берется подстановка. Имя атрибута не должно содержать пробелы или специальные символы. Для указания данных нажмите кнопку [image] . Затем сделайте щелчок левой кнопкой мыши в столбце Поле в правой части добавленной строки, нажмите кнопку .... Появится диалоговое окно Поле запроса, в нем выделите нужное поле и нажмите кнопку ОК. Имя атрибута в этом случае будет внесено автоматически. При необходимости его можно изменить.

      Рисунок 978. Добавление атрибутов

    3. Аналогично предыдущему пункту добавьте остальные поля для подстановок. Если поле добавлено ошибочно, для его удаления выделите его и нажмите кнопку [image] . Поле Код удалить нельзя.

    Рисунок 979. Шаблон планшета

  8. Для подтверждения создания запроса нажмите кнопку Сохранить и кнопку Закрыть.


Легенда

  • «Структура легенды»

  • «Добавление легенды»

  • «Редактирование легенды»

Легенда содержит образцы условных обозначений карты и текстовые пояснения к ним.


Структура легенды

На рисунке показана структура легенды и составляющие легенду элементы:

фрейм легенды – 1

разделы – 2

колонки – 3

пункты с условными обозначениями и текстовыми пояснениями – 4

Все пункты с условными обозначениями и текстовыми пояснениями сгруппированы по колонкам. Колонки, в свою очередь, группируются в разделы, а фрейм легенды содержит произвольное количество разделов.

Для каждого элемента легенды могут быть заданы заголовок и стиль отображения его рамки и заполнения. Также для каждого элемента могут задаваться индивидуальные настройки размеров.

Используя перечисленные возможности, Вы можете построить легенду, в которой наглядно будут представлены условные обозначения карты и другая, полезная для наилучшего восприятия карты, информация.

Рисунок 980. Структура легенды


Добавление легенды

Для добавления легенды в макет:

  1. Выберите пункт меню Вставка|Легенда.

  2. Выделите мышью прямоугольную область на макете, либо щелкните мышью в том месте, куда следует вставить объект Легенда.

Если в макете есть один или несколько фрагментов карты, легенда будет автоматически присоединена к первому по порядку из них и скомпонована по его содержанию.

В дальнейшем легенду можно связывать к другим картам макета и менять содержание.


Редактирование легенды

Для правки созданной легенды используется редактор легенды. Для вызова редактора выполните двойной щелчок левой кнопкой мыши по легенде в макете.

Редактор легенды, знакомство с интерфейсом

Рисунок 981. Редактор легенды

Редактор содержит окно легенды, панель операций, вкладки Оформление и Размеры.

Окно легенды

В окне легенды можно просматривать редактируемую легенду, изменять режим отображения и выделять отдельные элементы легенды.

Щелкните правой кнопкой мыши в окне легенды для вызова контекстного меню со следующими командами:

  • Выделить – устанавливает режим выделения элементов легенды. Выделенные элементы подсвечиваются голубым цветом;

  • Увеличить – устанавливает режим увеличения;

  • Уменьшить – устанавливает режим уменьшения;

  • Показать 1:1 – устанавливает масштаб отображения, соответствующий масштабу при печати легенды;

  • Показать каркас – устанавливает режим отображения макета, когда границы элементов показаны; пунктирной серой линией;

  • Добавить… – вызывает диалог добавления новых элементов в легенду;

  • Удалить – удаляет выбранные элементы легенды.

[Примечание] Примечание

В любом режиме отображения можно осуществлять масштабирование с помощью поворота колесика мыши и сдвиг легенды с помощью перемещения мыши с нажатым колесиком.

Панель операций

С помощью кнопок вверх [image] , вверх до конца [image] , вниз [image] , вниз до конца [image] вы можете перемещать выбранные пункты легенды.

Добавить [image] - вызывает диалог добавления новых элементов в легенду.

Удалить [image] – удаляет выбранные элементы легенды.

Вкладка Оформление

Вы можете оформлять стиль рамки и стиль заполнения элементов легенды, задавать заголовок и его шрифт, выравнивание и перенос.

Вкладка Размеры

Вы можете задавать размеры и отступы элементов легенды.

Редактирование легенды

Добавление элементов в легенду

Диалог «Добавить в легенду»

Рисунок 982. Диалог «Добавить в легенду»

Нажмите кнопку [image] добавить на панели инструментов и выберите нужный вариант в открывшемся диалоге Добавить в легенду:

  • Добавить раздел - добавление нового раздела. Под пунктом требуется выбрать тип добавляемого раздела:

    • новый - добавление нового пустого раздела в последнюю позицию легенды;

    • по слою текущей карты - создастся раздел, заполненный по выбранному слою карты, на основе которой была построена легенда;

    • по слою на диске - создается раздел, заполненный по выбранному слою на диске;

    • по шаблону темы - создается раздел, заполненный по выбранному шаблону темы слоя. Тексты пояснительных подписей берутся из названий условий шаблона.

  • Добавить пункт легенды - добавление пунктов с условными обозначениями. Для добавления пункта предварительно должен быть выбран раздел или колонка в которую добавляется новый пункт.

    В поле со списком выбирается тип добавляемого пункта (Текстовый, символьный, линейный, или полигональный).

    С помощью переключателей выбирается способ добавления пункта:

    • новый - добавляется новый пункт;

    • взять из слоя текущей карты - откроется диалог импорта условных обозначений из слоя текущей карты;

    • взять из слоя на диске - откроется диалог импорта условных обозначений из слоя на диске.

Диалог импорта стилей

Рисунок 983. Диалог импорта стилей

Нажмите Выбор слоя и выберите слой, из которого вы хотите импортировать в легенду условные обозначения.

Верхний список заполнится примерами условных обозначений содержащихся в слое. Выделите те, которые хотите импортировать и нажмите кнопку Добавить. Для того, чтобы импортировать весь список нажмите Добавить все.

Нажмите Импортировать для завершения процедуры импорта.

Редактирование элементов легенды

Перемещение элементов легенды

С помощью кнопок на панели инструментов вы можете перемещать элементы легенды относительно друг друга.

  • Вверх [image] - перемещает выбранный элемент на одну позицию вверх. Если был выбран первый в колонке пункт легенды, то он перемещается в конец предыдущей колонки;

  • Вверх до конца [image] - перемещает выбранный элемент вверх до конца текущей колонки;

  • Вниз [image] - перемещает выбранный элемент на одну позицию вниз. Если был выбран последний в колонке пункт легенды, то он перемещается в начало следующей колонки;

  • Вниз до конца [image] - перемещает выбранный элемент вниз на последнюю позицию.

Удаление элементов легенды

Выделите элементы легенды, которые вы хотите удалить и нажмите кнопку [image] .

Оформление

Фрейм легенды

  • Рамка легенды – вы можете задать стиль оформления границы рамки и заливки фрэйма легенды.

  • Заголовок легенды – вы можете задать заголовок фрэйма легенды. С помощью кнопки Стиль… вы можете задать шрифт, цвет шрифта и выравнивание текста заголовка. Если вы не хотите, чтобы заголовок отображался при печати - выберите опцию Не отображать.

  • Автоперенос разделов – при включении этой опции разделы легенды автоматически позиционируются в соответствии с размером легенды в окне редактора макетов.

  • Автовыравнивание высоты разделов – при включении этой опции высота разделов находящихся в одном ряду будет одинаковой.

Разделы легенды

  • Рамка раздела – вы можете задать стиль оформления границы рамки и заливки раздела легенды.

  • Заголовок раздела – вы можете задать заголовок раздела легенды. С помощью кнопки Стиль… вы можете задать шрифт, цвет шрифта и выравнивание текста заголовка. Если вы не хотите, чтобы заголовок отображался при печати - выберите опцию Не отображать.

  • Перенести в новый ряд – при включении этой опции раздел будет перемещен в новый ряд.

  • Автовыравнивание высоты колонок – при включении этой опции высота колонок раздела будет одинаковой.

Колонки раздела

  • Рамка колонки – вы можете задать стиль оформления границы рамки и заливки колонки.

  • Заголовок колонки – вы можете задать заголовок колонки. С помощью кнопки Стиль… вы можете задать шрифт, цвет шрифта и выравнивание текста заголовка. Если вы не хотите, чтобы заголовок отображался при печати - выберите опцию Не отображать.

Пункты легенды

Рисунок 984. Диалог «Макет»

  • Рамка пункта легенды – вы можете задать стиль оформления границы рамки и заливки пункта легенды. С помощью кнопки Макет… вы можете задать взаимное расположение примера условного обозначения и пояснительной подписи.

  • Подпись пункта легенды – вы можете задать пояснительную подпись для примера условного обозначения пункта легенды. С помощью кнопки Стиль… вы можете задать шрифт, цвет шрифта и выравнивание текста пояснительной подписи.

  • Если вы не хотите, чтобы подпись отображалась при печати – установите флажок Не отображать.

    Диалог Настройка отображения примера

    Рисунок 985. Диалог Настройка отображения примера

  • Оформление примера – вы можете изменить стиль образца условного обозначения. Например, для полигональных объектов изменить прямоугольный образец на овальный и т.д.

Установка размеров

  1. Фрейм легенды.

    Вы можете задать размеры и отступы между разделами легенды введя значения в соответствующие поля вкладки Размеры.

  2. Разделы легенды.

    Вы можете задать размеры и отступы между колонками раздела введя значения в соответствующие поля вкладки Размеры.

  3. Колонки раздела.

    Вы можете задать размеры и отступы между пунктами колонки введя значения в соответствующие поля вкладки Размеры.

  4. Пункты легенды.

    Вы можете задать размеры и отступы для пункта легенды введя значения в соответствующие поля вкладки Размеры. Также вы можете изменить размер примера образца условного обозначения, горизонтальное и вертикальное выравнивание пояснительной подписи и примера.


Указатель масштаба

  • «Добавление масштаба»

  • «Редактирование масштаба»

Добавление масштаба

Можно добавлять в макет обозначение масштаба либо в текстовом виде, либо в виде масштабной линейки. Объект масштаб может быть связан с фрагментом карты, в этом случае он будет автоматически отображать масштаб карты в этом фрагменте.

Для добавления масштаба в макет:

  1. Нажмите кнопку [image] на панели инструментов Макет, либо выберите пункт меню Вставка|Масштаб.

  2. Выделите мышью прямоугольную область на макете, либо щелкните мышью в том месте, куда следует вставить обозначение масштаба.

    Диалог выбора варианта масштаба

    Рисунок 986. Диалог выбора варианта масштаба

  3. В открывшемся диалоге выберите вариант обозначения масштаба.

  4. Нажмите кнопку ОК или сделайте двойной щелчок левой кнопкой мыши по выбранному варианту масштаба.


Редактирование масштаба

В данном разделе описаны возможности редактирования отображения масштаба карты в макете.

  • Присоединение к карте

  • Выбор варианта обозначения

  • Настройка параметров

Присоединение к карте

Объект Масштаб можно присоединить к карте, для того, чтобы он автоматически отображал актуальный масштаб фрагмента карты.

Для того, чтобы присоединить масштаб к карте:

  1. Выделите объект Масштаб.

  2. Щелкните правой кнопкой мыши по объекту и выберите пункт меню Присоединить к карте.

  3. Щелкните левой кнопкой мыши по объекту Карта, курсор при этом будет иметь вид [image] . Масштаб будет присоединен к этому объекту.

Выбор варианта обозначения

Существует несколько вариантов обозначения масштаба карты в макете. Масштаб может быть указан либо в текстовом виде (напр. «М 1:2000» или «В 1 см 5 км»), либо в виде масштабной линейки. Масштабная линейка также может отображаться различными способами.

Для того чтобы выбрать вариант обозначения масштаба:

  1. Выделите объект Масштаб.

  2. Щелкните правой кнопкой мыши по объекту и выберите пункт меню Вариант.

  3. Выберите из списка вариант отображения масштаба и нажмите OK.

После того, как выбран вариант масштаба, можно точно настроить параметры его отображения.

Настройка параметров

Для настройки параметров отображения масштаба:

  1. Щелкните правой кнопкой мыши по объекту и выберите пункт меню Свойства.

  2. В панели свойств объекта выберите параметры объекта.

  3. Для текстового варианта.

    • В закладке Шрифт задайте шрифт и цвет текста.

    • В закладке Цвета и линии задайте фон объекта и рамку.

    Для масштабной линейки:

    • В закладке Вид выберите число основных делений и число подделений.

    • Можно точно указать цену деления. Для этого снимите флажок авто и в окошко цена деления впишите нужное значение.

    • Можно задать отображение отсчетов и подписей. В списке единицы выберите единицы измерения, в окошке подпись задайте подпись единиц измерения (напр. кратко «м» или полностью «метры»). В списке размещать выберите вариант размещения подписи, а в списке отсчеты задайте вариант отображения отсчетов.

    • В закладке Шрифт задайте шрифт и цвет текста подписей.

    • В закладке Цвета и линии задайте фон объекта и рамку.

Настройка отображения масштаба с помощью панелей инструментов:

  • - задает шрифт подписей.

  • - задает размер шрифта подписей.

  • - задает стиль шрифта(полужирный, курсив, подчеркнутый).

  • - задает выравнивание для текста или подписей.

  • - задает цвет шрифта.

  • - задает цвет фона объекта.

  • - задает цвет рамки объекта.

Если в макете есть один или несколько фрагментов карты, объект Масштаб будет связан к первому по порядку из них.


Знак «Север»

  • «Добавление знака «Север»»

  • «Редактирование знака «Север»»

Добавление знака «Север»

Для добавления обозначения направления на север в макет:

  1. Выберите пункт меню Вставка|Север.

  2. Выделите мышью прямоугольную область на макете, либо щелкните мышью в том месте, куда следует вставить обозначение направления на север.

  3. В появившейся панели выберите вариант обозначения.

  4. Нажмите кнопку ОК или сделайте двойной щелчок левой кнопкой мыши по выбранному варианту.

Если в макете есть один или несколько фрагментов карты, объект Север будет связан к первому по порядку из них.


Редактирование знака «Север»

  • Присоединение к карте

  • Выбор варианта обозначения

Присоединение к карте

Знак Север можно присоединить к карте, для того, чтобы он автоматически отображал направление на север с учетом актуального угла поворота фрагмента карты.

Для того, чтобы присоединить знак Север к карте:

  1. Выделите объект Север.

  2. Щелкните правой кнопкой мыши по объекту и выберите пункт меню Присоединить к карте.

  3. Щелкните левой кнопкой мыши по объекту Карта, курсор при этом будет иметь вид [image] . Объект Север будет присоединен к этой карте.

Выбор варианта обозначения

Для того, чтобы выбрать вариант обозначения знака Север:

  1. Выделите объект Север.

  2. Щелкните правой кнопкой мыши по объекту и выберите пункт меню Вариант.

  3. Выберите из списка вариант отображения масштаба и нажмите OK.


Таблица

  • «Добавление таблицы»

  • «Редактирование таблицы»

  • «Заполнение таблиц»

В макетах печати можно использовать таблицы с произвольным текстовым содержанием. Все действия с таблицами производятся в режиме редактирования макета.


Добавление таблицы

  • Добавление таблицы через меню

  • Рисование таблицы

В системе предусмотрено два способа добавления таблиц в макет: через меню, либо с помощью инструментов «рисования» таблицы.

Через меню сразу создается таблица с заданным количеством строк и столбцов.

Таблица созданная через меню

Рисунок 987. Таблица созданная через меню

При рисовании таблицы можно задать таблицу со сложной конфигурацией ячеек (объединенными столбцами и строками и т.д.).

Рисунок 988. Нарисованная таблица

Добавление таблицы через меню

Для добавления таблицы через меню:

  1. Выполните команду меню Вставка|Таблица, к указателю мыши добавится знак графического выделения – «+».

  2. Наведите указатель мыши в место левого верхнего угла добавляемой таблицы, нажмите левую кнопку мыши, и, не отпуская ее, переместите указатель мыши в место правого нижнего угла таблицы, после чего отпустите левую кнопку мыши. Откроется диалог вставки таблицы.

    Диалог вставки таблицы

    Рисунок 989. Диалог вставки таблицы

  3. Укажите число строк и столбцов таблицы в полях Число строк и Число столбцов диалога и нажмите кнопку ОК, чтобы завершить создание таблицы.

Рисование таблицы

При рисовании таблицы, вручную создается внешняя граница таблицы и все внутренние границы (разделяющие столбцы и строки таблицы).

Для того чтобы нарисовать таблицу:

  1. Включите режим рисования таблиц. Для этого нажмите кнопку [image] панели инструментов Макет.

  2. Нарисуйте внешний контур таблицы. Для этого наведите указатель мыши в место левого верхнего угла добавляемой таблицы, нажмите левую кнопку мыши, и, не отпуская ее, переместите указатель мыши в место правого нижнего угла таблицы, после чего отпустите левую кнопку мыши.

  3. Нарисуйте внутренние границы, разделяющие ячейки таблицы. Для этого:

    1. Переместите указатель мыши внутрь таблицы (должен быть включен режим рисования таблиц).

    2. Нажмите левую кнопку мыши и, не отпуская ее, начните перемещать мышь в горизонтальном (для добавления горизонтальной границы) либо в вертикальном (для вертикальной) направлении. В процессе перемещения указателя мыши, на экране отобразится пунктирная линия, показывающая расположение будущей границы.

    3. Как только пунктирная линия покажет требуемую границу, отпустите кнопку мыши. Граница добавится в таблицу.

  4. При необходимости можно удалить часть нарисованных границ. Удаление границ выполняется в режиме удаления границ. Режим включается кнопкой [image] панели инструментов Макет.

    Для удаления одной границы наведите указатель мыши на границу и щелкните левой кнопкой мыши. Для удаления сразу нескольких границ, обведите их мышью (выполняется аналогично выделению мышью нескольких объектов с помощью рамки). В процессе обведения удаляемые границы подсвечиваются.


Редактирование таблицы

  • Добавление строк и столбцов в таблицу

  • Удаление границ ячеек (объединение)

  • Точное изменение размеров ячеек

  • Задание границ и фона ячеек

Редактирование позволяет изменить число столбцов, строк, разбить или объединения ячейки. Так же возможно точно отредактировать геометрические размеры, задать стиль границ и фона ячеек.

Изменить структуру таблицы, число столбцов или строк, разбить или объединить ячейки можно в режиме рисования таблицы.

Добавление строк и столбцов в таблицу

Добавление строк и столбцов в таблице осуществляется разбитием уже существующих ячеек таблицы. После данной операции возможно ширину и высоту получившихся ячеек отредактировать.

Для разбития ячеек:

  1. Включите режим рисования таблиц. Для этого нажмите кнопку [image] панели инструментов Макет.

  2. Подведите курсор к нужной ячейке. Нажмите левую кнопку мыши и, не отпуская ее, начните перемещать мышь в горизонтальном (для добавления горизонтальной границы) либо в вертикальном (для вертикальной) направлении. В процессе перемещения указателя мыши, на экране отобразится пунктирная линия, показывающая расположение будущей границы. Как только пунктирная линия покажет требуемую границу, отпустите кнопку мыши.

    Разбитие ячеек таблицы

    Рисунок 990. Разбитие ячеек таблицы

Удаление границ ячеек (объединение)

При необходимости можно удалить часть нарисованных границ, для этого:

  1. Включите режим удаления границ, для этого нажмите кнопку [image] панели инструментов Макет.

  2. Для удаления одной границы наведите указатель мыши на границу и щелкните левой кнопкой мыши. Для удаления сразу нескольких границ, обведите их мышью (выполняется аналогично выделению мышью нескольких объектов с помощью рамки). В процессе обведения удаляемые границы подсвечиваются.

    Удаление границ ячеек

    Рисунок 991. Удаление границ ячеек

Точное изменение размеров ячеек

Для того, чтобы изменить геометрические размеры ячеек:

  1. Включите режим [image] и выделите левой кнопкой мыши нужную ячейку или группу ячеек. Для выбора группы ячеек используйте клавишу Shift. Можно также выделять ребра ячеек, а также вершины.

  2. В окне Габариты задайте точные габариты выбранных элементов таблицы.

    • С помощью элемента [image] задается точка привязки, относительно которой будет меняться положение и размеры объекты.

    • Поля X и Y задают положение объекта. В зависимости от того, какая выбрана точка привязки, эта точка объекта будет совмещается с указанными координатами.

    • Поля W и H задают ширину и высоту объекта соответственно. При изменении этих значений габариты объекта будут меняться относительно выбранной точки привязки.

      Рисунок 992.

Задание границ и фона ячеек

Для задания границ ячеек

  1. Включите режим [image] и выделите левой кнопкой мыши нужную ячейку или группу ячеек. Для задания границ можно выбирать отдельные грани ячеек.

  2. Щелкните правой кнопкой мыши и в меню выберите Границы.

  3. В панели Границы задайте стиль границ и фон, после чего нажмите OK.

  4. Настроить вид границ выделенных ячеек также можно с помощью инструмента [image] .


Заполнение таблиц

Для редактирования текста в ячейке таблицы переместите указатель мыши в ячейку и выполните двойной щелчок левой кнопкой мыши. Работа с текстом в ячейках выполняется аналогично работе с текстом в других частях макета.


Текст

  • «Добавление текста»

  • «Ввод и редактирование текста»

  • «Подстановка текстового значения»

Добавление текста

Для добавления текстового блока:

  1. Нажмите кнопку [image] на панели инструментов Макет, либо выберите пункт меню Вставка|Текст.

  2. Выделите мышью прямоугольную область на макете, либо щелкните мышью в том месте, куда следует вставить текстовый блок.

В появившемся прямоугольном элементе введите текст.


Ввод и редактирование текста

  • Ввод текста

  • Навигация по тексту

  • Выделение текста

  • Форматирование текста

  • Изменение направления текста

Включение режима редактирования текста:

Выберите один из перечисленных способов:

  • Выполните двойной щелчок левой кнопкой мыши по текстовому объекту.

  • Выделите текстовый объект и нажмите кнопку [image] инструментов.

  • Нажмите кнопку инструментов [image] и щелкните мышью по текстовому объекту.

[Примечание] Примечание

При добавлении нового текстового объекта режим редактирования текста включается автоматически.

Ввод текста:

  • Текст вводится внутри прямоугольника текстового объекта и автоматически переносится в зависимости от ширины текстового блока.

  • Новый абзац можно начать нажатием клавиши Enter.

  • Сочетание клавиш Ctrl + Enter добавляет перенос на новую строку без образования нового абзаца.

Навигация по тексту:

  • Щелчком левой кнопки мыши можно точно установить положение курсора внутри текста для ввода и правки.

  • Клавиши со стрелками влево и вправо перемещают курсор на один символ.

  • Клавиши со стрелками влево и вправо с нажатой клавишей Ctrl перемещают курсор на один слово.

  • Клавиши со стрелками вверх и вниз перемещают курсор на одну строку.

  • Клавиши со стрелками вверх и вниз с нажатой клавишей Ctrl перемещают курсор на один абзац.

  • Клавиши Home и End перемещают курсор в начало и в конец строки.

  • Клавиши Home и End с нажатой клавишей Ctrl перемещают курсор в начало и в конец всего текста.

Выделение текста:

  • Можно выделить фрагмент текст нажатием левой копки мыши в начале фрагмента и перетаскиванием мыши с нажатой левой кнопкой в конец фрагмента.

  • Можно выделять фрагмент текста пользуясь клавишами для навигации по тексту с одновременным удержанием клавиши Shift.

Форматирование текста:

Для форматирования имеющегося текста нужный фрагмент должен быть выделен. Для задания параметров нового вводимого текста нужно установить курсор в нужном месте, выполнить настройку и после этого ввести текст.

Настройка шрифта:

  • Щелкните правой кнопкой мыши и в меню выберите Шрифт.

  • В панели Шрифт задайте название шрифта, размер, стиль и цвет, после чего нажмите OK.

  • Шрифт также можно настроить с помощью инструментов:

    – задает шрифт подписей;

    – задает размер шрифта подписей;

    – задает стиль шрифта (полужирный, курсив, подчеркнутый);

    – задает цвет шрифта.

Настройка абзаца:

  • Щелкните правой кнопкой мыши и в меню выберите Абзац.

  • В панели Абзац задайте название выравнивание абзаца, отступы и межстрочные интервалы, после чего нажмите OK.

  • Кроме того, инструменты:

    – задают выравнивание абзаца.

Изменение направления текста

Для текстов в макете печати предусмотрен поворот текста на 90 градусов по, и против часовой стрелки.

Текст в макете печати отчетов

Рисунок 993. Текст в макете печати отчетов

Повернуть можно текст в предварительно созданном текстовом поле.

Для поворота текста:

  1. Переместите указатель мыши на поле с текстом, щелкните правой кнопкой мыши и выберите в открывшемся контекстном меню пункт Свойства. Откроется диалог свойств текста.

    Вкладка Направление текста диалога свойств текста

    Рисунок 994. Вкладка Направление текста диалога свойств текста

  2. Перейдите на вкладку Направление текста диалога.

  3. В группе настроек Ориентация выберите требуемую ориентацию текста. При этом в области Образец отображается примерный вид текста в выбранной ориентации.

  4. Нажмите кнопку ОК диалога чтобы сохранить изменения и закрыть диалог.


Подстановка текстового значения

  • Добавление подстановок

  • Настройка собственных подстановок

  • Редактирование подстановок

В режиме ввода или редактирования текста ( [image] ) вы можете использовать подстановки текстовых значений. Это специальные поля, которые заменяются при печати их значениями. Например, могут использоваться такие подстановки как текущая дата, время, автор, название планшета или файла.

Имеются как уже ряд готовых подстановок, так и настраиваемые. Индивидуально могут настраиваться подстановки для карты и для шаблона планшета.

Добавление подстановок

Для добавления подстановки:

  1. Если текстового объекта нет, то добавьте его. Если текстовый объект к которому надо добавить подстановку уже есть, то включите его режим редактирования.

  2. При необходимости введите текстовую константу - тест который не будет меняться при подстановке. Он может быть как в виде префикса, то есть значения, которое выводится до подстановки, так и в виде постфикса - значение, которое выводится после подстановки. Это может быть любой текст, например пояснение или единицы измерения: количество листов, название, дата, путь, штук и т.д.

  3. При необходимости введите дополнительные элементы подстановок, которые скрывают префикс и постфикс если подстановка пустая. То есть при использовании данных элементов будут выведены только префиксы и постфиксы если имеется атрибут подстановки, то есть она не пусто. Элементы вводятся перед префиксом и постфиксом без пробелов:

    • & для префикса

    • + для постфикса

    При применении данных элементов текстовые константы необходимо вводить в фигурных скобках, так же важное условие чтоб после префикса и перед постфиксом не было пробела:

    например:

    &{код планшета}${Карта1.planchette.code}+{й}, где

    • & - элемент, который скроет префикс если подстановка пустая;

    • {код планшета} - префикс, текстовая константа, введена в фигурных скобках так как используется &;

    • ${Карта1.planchette.code} - подстановка

    • + - элемент, который скроет постфикс если подстановка пустая;

    • {й} - постфикс, текстовая константа, введена в фигурных скобках так как используется +.

  4. Установите курсор в месте вставки подстановки и сделайте щелчок правой кнопкой мыши. В появившемся контекстном меню выберите пункт [image] Подстановка.

  5. В диалоге Подстановка подстановки разделены по категориям. Для просмотра доступных подстановок слева выделите нужную категорию. При необходимости настройте свои подстановки, например данные автора проекта. Настраиваемые подстановки могут быть добавлены как в проект, тогда соответственно доступны они будут только в текущем проекте, так и в карту. Тогда доступ к подстановкам будет у всех макетов карты. В зависимости от этого настроенные подстановки отобразятся в той или иной категории.

    По умолчанию доступны следующие подстановки:

    • Категория Общие – общие подстановки, такие как:

      • Время;

      • Дата;

      • Имя файла карты;

      • Код;

      • Название карты;

      • Путь до файла карты;

      • Количество страниц макета;

      • Номер страницы макета;

      • Номер страницы по вертикали;

      • Номер страницы по горизонтали.

    • Категория Название макета:

      • Имя файла макета;

      • Название макета;

      • Путь до файла (отображается только в том случае если файл открыт с диска).

    • Категория Название карты:

      • Имя файла карты;

      • Название карты;

      • Путь до файла карты.

    • Категория Планшет:

      • Код;

      • КоличествоП;

      • КоличествоУ;

      • Наименование;

      • Особые элементы.

    • Сверху, Справа, Сверху, Снизу - подстановки по планшетам, расположенным в соостветствии с названием категории.

  6. Справа в разделе Свойства выберите нужную подстановку. После выбора в строке Текст отобразится ее код, а в строке Значение ее значение, которое в итоге будет подставляться в макет.

    Диалог подстановки текстового значения

    Рисунок 995. Диалог подстановки текстового значения

  7. Завершить выбор подстановки можно нажав кнопку ОК. После чего в тексте будет виден код выбранной подстановки. Результат готовых подстановок будет виден после выхода из текстового режима. Для этого достаточно сделать щелчок левой кнопкой мыши в любом месте макета где нет текста или таблицы. Результат настроенных самостоятельно подстановок можно увидеть при предварительном просмотре макета.

    Результат подстановки даты

    Рисунок 996. Результат подстановки даты

Настройка собственных подстановок

Подстановки могут настраиваться:

  • для карты - они будут доступны для всех макетов карты;

  • для макета - они будут доступны только для макета в котором производилась настройка подстановки;

  • для шаблона планшетов - они будут доступны только при выборе шаблона планшетов.

Для создания новой или редактирования существующей подстановки для карты или макета:

  1. Если подстановка создается или редактируется для карты. Откройте диалог настройки карты, выберите вкладку Дополнительно.

    Если подстановка создается или редактируется для открытого макета. Выберите меню Файл|Свойства документа...

  2. Слева в столбце Свойство введите название для подстановки.

  3. Справа в столбце Значение введите значение соответствующее названию. Например:

    Диалог настройки индивидуальной подстановки

    Рисунок 997. Диалог настройки индивидуальной подстановки

  4. Для завершения настройки нажмите ОК.

После проделанных действий подстановка готова к применению. Добавленная подстановка появится в той категории куда добавлялась. Например, в диалоге выше подстановка настраивалась непосредственно в макете, и при ее добавлении будет отображена в этой категории:

Диалог подстановки текстового значения

Рисунок 998. Диалог подстановки текстового значения

Редактирование подстановок

Для редактирования подстановки:

  1. В режиме работы с макетом сделайте двойной щелчок левой кнопкой мыши по тексту с подстановкой.

    ИЛИ

    Включите режим Текст, для этого нажмите на панели Макет кнопку [image] и сделайте щелчок левой кнопкой мыши на тексте с подстановкой.

  2. Отредактируйте подстановку.


Изображения

  • «Добавление изображений»

  • «Редактирование изображений»

Добавление изображений

В макете можно размещать рисунки или фотографии, сохраненные в форматах *.bmp, *.gif, *.jpg, *.jpeg, *.png,*.tif, *.tiff, *.wmf, *.emf.

Для добавления рисунка:

  1. Нажмите кнопку [image] на панели инструментов Макет, либо выберите пункт меню Вставка|Рисунок.

  2. В появившейся панели выбора файла выберите файл картинку, которую нужно вставить.

  3. Далее:

    • сделайте одинарный клик – рисунок вставится с учётом геометрических размеров изображения в масштабе 1:1;

      или

    • выделите прямоугольную область – рисунок вставится пропорционально габаритам изображения.


Редактирование изображений

Можно переместить растровое изображение или изменить его геометрические размеры.

Для перемещения изображения:

  1. Выделите нужное изображение.

  2. Включите режим [image] .

  3. Подведите курсор к изображению, нажмите левую клавишу мыши и не отпуская переместите изображение в нужное место.

Для того, чтобы изменить размеры добавленного изображения:

  1. Выделите нужное изображение.

  2. Включите режим [image] .

  3. Подведите курсор к одному из белых квадратиков, расположенных на вершинах и ребрах объекта. Нажмите левую клавишу мыши и не отпуская переместите курсор в нужное положение.

    ИЛИ

    Для задания точных размеров сделайте двойной щелчок левой клавишей мыши на изображении или щелкните правой клавишей мыши и выберите меню Свойства. В появившемся окне в разделе Габариты укажите координаты вершин изображения на макете.

    Если требуется изменить размеры изображения в процентном соотношении от исходного размера установите нужные значения в соответствующих окнах. По умолчанию размер по горизонтали и вертикали меняется не зависимо от друг друга. Если надо чтобы размеры менялись с сохранением пропорций, то надо установить связь. Для ее установки сделайте щелчок левой клавишей мыши на значке [image] .

    После ввода новых данных и нажатия кнопки Применить, произойдет перестроение рамки с объектом в зависимости от новых параметров.

    Для закрытия окна и подтверждения изменений нажмите кнопку ОК.


Векторные графические элементы

  • «Добавление графических элементов »

  • «Редактирование графических элементов»

Добавление графических элементов

В макет можно добавлять геометрические фигуры – линии, прямоугольники, многоугольники, эллипсы.

Для ввода прямоугольника или эллипса:

  1. Нажмите кнопку [image] или [image] на панели инструментов.

  2. Выделите мышью прямоугольную область, либо щелкните мышью в том месте, куда следует поместить фигуру.

Для ввода ломаной или многоугольника:

  1. Нажмите кнопку [image] или [image] на панели инструментов.

  2. Щелчком левой кнопки мыши последовательно введите вершины фигуры.

  3. Двойным щелчком мыши завершите ввод фигуры.

Для отмены добавления фигуры в процессе ввода нажмите клавишу Esc.


Редактирование графических элементов

Можно редактировать геометрическую форму объектов типа ломаная или многоугольник путем перемещения дуг и вершин объектов.

Для того, чтобы изменить геометрическую форму объекта:

  1. Выделите нужный объект.

  2. Включите режим [image] .

  3. Нажмите левой кнопкой мыши на вершине или ребре объекта и перетащите в нужное положение.

  4. Чтобы точно задать положение вершины выделите ее щелкнув левой кнопкой мыши и в окне Габариты в полях X и Y укажите координаты этой вершины на макете.


Печать макета

Печать макета выполняется при открытом макете.

Для вывода макета на печать:

  1. Выберите в меню Файл|Печать или нажмите кнопку [image] .

  2. Укажите параметры принтера и диапазон печатаемых страниц и нажмите OK.

Предварительный просмотр

Чтобы включить режим предварительного просмотра:

Выберите в меню Файл|Предварительный просмотр или нажмите кнопку [image] .

В окне предварительного просмотра:

  • С помощью поля [image] можно менять масштаб просмотра страницы.

  • С помощью инструментов [image] и [image] можно изменить число отображаемых страниц.

  • С помощью инструментов [image] и [image] можно листать страницы вперед и назад.

Для того чтобы выйти из режима просмотра, нажмите кнопку Закрыть.


Импорт и экспорт макета печати

  • «Импорт макетов печати»

  • «Экспорт макетов печати»

В результате экспорта макета печати будет сформирован файл с расширением *.zrp, который в дальнейшем может быть импортирован в любую карту. Импортировать макеты можно как из карты, так и непосредственно из файлов.


Импорт макетов печати

Импорт макетов возможен как с использованием диалогового окна Макеты, так и через панель Макеты.

Для импорта макетов:

  1. Выполните команду меню Карта|Макеты и нажмите кнопку Импорт. Или же переместите указатель мыши на панель Макеты, нажмите правую кнопку мыши и выберите в контекстном меню команду Импорт.

  2. В стандартном диалоге выбора файлов укажите требуемый тип файлов в поле Тип файлов (файл макета или файл карты с требуемыми макетами).

  3. Выберите нужные файлы дли импорта.

  4. Если макет загружается из другой карты, укажите требуемые макеты в открывшемся диалоге и нажмите кнопку Импорт.


Экспорт макетов печати

Экспорт макетов возможен с использованием диалогового окна Макеты, через панель Макеты или в режиме редактирования макета. В первом случае возможен групповой экспорт макетов.

Для экспорта макетов с использованием диалогового окна Макеты:

  1. Выполните команду меню Карта|Макеты.

  2. Выделите в списке один или несколько макетов для экспорта.

  3. Нажмите кнопку Экспорт.

  4. В открывшемся окне укажите папку для сохранения файлов.

  5. Нажмите кнопку OK.

Для экспорта макета через панель Макеты:

  1. Откройте панель Макеты (Окно|Макеты).

  2. В панели макетов щелкните правой кнопкой мыши по строке макета и выберите в открывшемся меню команду Сохранить копию как.

  3. В открывшемся окне выбора файла укажите путь и имя файла, в котором нужно будет сохранить документ.

  4. Нажмите кнопку Сохранить.

Для экспорта из режима редактирования:

  1. В режиме редактирования макета выберите меню Файл|Сохранить копию как.

  2. В открывшемся окне выбора файла укажите путь и имя файла, в котором нужно будет сохранить документ.

  3. Нажмите кнопку Сохранить.


Примеры печати карты с использованием макета печати

Рассмотрим следующие примеры:

  • Печать карты с рамкой и дополнительными элементами в масштабе 1:5000 на листе формата A0

  • Печать карты по габаритам слоя на листе произвольного формата

  • Многостраничная печать карты по планшетам


Печать карты с рамкой и дополнительными элементами в масштабе 1:5000 на листе формата A0

Рассмотрим вариант печати карты с макетом. В макет по мимо карты добавим рамку, масштаб, знак север, картинку и легенду. Печать будет осуществлена в файл формата PDF на бумаге A0. Получившийся результат в дальнейшем можно отнести в типографию для печати на большом размере бумаги. Стандартный офисный принтер не предназначен для работы с большими форматами, однако PDF-принтер такую возможность предоставляет. Если вы планируете повторить данный пример и у вас ещё не установлен PDF-принтер, рекомендуется установить его заранее.

Откройте карту для печати.

  1. Создайте новый макет, для этого выберите меню Карта|Макеты... и нажмите кнопку Создать.

  2. Произведите настройку принтера, для этого выберите пункт меню Файл|Принтер... В разделе Принтер выберите Adobe PDF.

  3. В разделе Бумага задайте размер А0.

  4. В разделе Ориентация выберите Альбомная.

  5. Нажмите кнопку ОК.

    Рисунок 999. Настройка принтера

  6. Задайте параметры страниц макета. Выберите пункт меню Файл|Параметры страницы. Во вкладке Макет в разделе Размер листа укажите формат A0 и в разделе Ориентация - Альбомная. Нажмите кнопку OK.

    Рисунок 1000. Настройка страницы

    После произведенных настроек размер листа печати и макета должны совпадать. Пунктирная линия листа должна совпасть со сплошной линией макета.

  7. Добавьте в макет рамку. Выберите команду меню Вставка|Рамка.... После чего в макет будет добавлена рамка в соответствии с размерами и ориентацией страницы.

  8. Для заполнения рамки текстом нажмите кнопку [image] на панели инструментов Макет, переместите указатель мыши в ячейку рамки и сделайте щелчок левой кнопкой мыши. Щелкните правой кнопкой мыши, в открывшемся контекстном меню выберите Шрифт. Затем измените размер шрифта на 12 и нажмите ОК. Введите с клавиатуры текст. Аналогично можно ввести текст во все графы рамки.

    Рамка с текстом

    Рисунок 1001. Рамка с текстом

  9. Добавьте карту в макет. Нажмите кнопку [image] на панели инструментов Макет. Выберите Вставить текущую карту и нажмите ОК. Выделите мышью прямоугольную область на макете, в которую следует вставить фрагмент выбранной карты. При необходимости отредактируйте эту область.

  10. Сделайте щелчок правой кнопкой мыши на вставленной карте и в контекстном меню выберите пункт Свойства. В диалоге свойств карты:

    • в разделе Область печати: выберите вид: Текущие масштаб и центр;

    • в разделе Масштаб и центр: в окне масштаб: внесите масштаб 5000;

    • нажмите кнопку ОК.

    Рисунок 1002. Настройка карты

    Если после настройки карта неправильно расположена, отредактируйте ее расположение.

  11. Внесите в заголовок название карты. Нажмите кнопку [image] на панели инструментов Макет, переместите указатель мыши в место заголовка и сделайте щелчок левой кнопкой мыши, появится область текстового блока. Увеличите ее размер, для этого установите курсор на одном из квадратиков на углу или ребре области. Нажмите и не отпуская левую кнопку мыши переместите курсор в нужное место.

    Далее сделайте установите курсор в текстовый блок. На панели инструментов выберите шрифт и его размер, последний можно ввести с клавиатуры. Установите отображение текста посередине [image] .

    Введите название с клавиатуры или вставьте подстановку, как в примере ниже. Для подстановки сделайте щелчок правой кнопкой мыши в области текстового блока. В контекстом меню выберите [image] Подстановка. В открывшемся диалоге слева в категории выберите карту, справа свойство Название. Нажмите ОК. При вводе длинного названия с клавиатуры перенос стоки лучше осуществлять клавишей Enter, а не ограничением текстового блока.

    Настройка подстановки с названием карты в заголовок

    Рисунок 1003. Настройка подстановки с названием карты в заголовок

  12. Установите указатель масштаба. Нажмите кнопку [image] на панели инструментов Макет. Щелкните мышью в том месте, куда следует вставить обозначение масштаба. В открывшемся диалоге выберите вариант обозначения масштаба. Затем нажмите кнопку ОК.

    Рисунок 1004. Указатель масштаба

  13. Вставьте изображение. В данном примере будет использован герб города, но это может быть любое изображение. Например, график или какая-либо дополнительная информация по объектам печати. Нажмите кнопку [image] на панели инструментов Макет. В появившейся панели выбора файла выберите файл картинку, которую нужно вставить. Выделите прямоугольную область – рисунок вставится пропорционально габаритам изображения. При необходимости отредактируйте изображение.

  14. Установите знак север. Выберите пункт меню Вставка|Север, щелкните мышью в том месте, куда следует вставить обозначение направления на север. В появившейся панели выберите вариант обозначения. Затем нажмите кнопку ОК.

  15. Добавьте легенду. Выберите пункт меню Вставка|Легенда. Выделите мышью прямоугольную область на макете. При необходимости отредактируйте легенду.

    Рисунок 1005. Легенда

  16. Сохраните макет. Нажмите кнопку [image] панели инструментов. В появившемся диалоговом окне введите имя макета, и нажмите OK. Макет будет сохранен.

  17. Для просмотра результата нажмите кнопку [image] . Если есть подходящее устройство для печати, то готовый макет может быть сразу напечатан - кнопка [image] . Если его нет, то макет можно экспортировать в файл PDF и затем передать его на печать. Для экспорта выберите меню Файл|Экспорт|Печать в PDF. Или в режиме просмотра нажмите кнопку [image] . Затем выберите местоположение для сохранения файла, укажите имя создаваемого PDF файла и нажмите кнопку Сохранить.

    [Примечание] Примечание

    После сохранения макета обязательно необходимо сохранить карту, для которой он создавался!

Рисунок 1006. Готовый макет


Печать карты по габаритам слоя на листе произвольного формата

Рассмотрим вариант печати карты с макетом. Карта будет печататься в по габаритам слоя тепловой сети, масштаб будет выбран автоматически. Печать осуществим в файл формата PDF на бумаге размера 1000 мм на 1500мм. Получившийся результат в дальнейшем можно отнести в типографию для печати на большом размере бумаги. Стандартный офисный принтер не предназначен для работы с большими форматами, однако PDF-принтер такую возможность предоставляет. Если вы планируете повторить данный пример и у вас ещё не установлен PDF-принтер, рекомендуется установить его заранее.

Откройте карту для печати.

  1. Создайте новый макет, для этого выберите меню Карта|Макеты... и нажмите кнопку Создать.

  2. Произведите настройку принтера, для этого выберите пункт меню Файл|Принтер... В разделе Принтер выберите Adobe PDF.

  3. В разделе Бумага выберите размер Особый размер страницы.

  4. В разделе Ориентация выберите Книжная.

    Рисунок 1007. Настройка принтера

  5. Нажмите кнопку Свойства.... Во вкладке Макет нажмите кнопку Дополнительно.... В открывшемся диалоге Дополнительные возможности PDF нажмите кнопку Особый размер страницы, введите ширину и высоту листа и нажмите кнопку ОК.

    Рисунок 1008. Настройка принтера

  6. Нажмите кнопку ОК.

  7. Задайте параметры страниц макета. Выберите пункт меню Файл|Параметры страницы. Во вкладке Макет в разделе Размер листа укажите формат custom, введите ширину и высоту листа, в разделе Ориентация - Книжная. Нажмите кнопку OK.

    Рисунок 1009. Настройка страницы

    После произведенных настроек размер листа печати и макета должны совпадать, то есть пунктирная линия листа будет повторять сплошную линию макета.

    Совпадение листа принтера и листа макета

    Рисунок 1010. Совпадение листа принтера и листа макета

  8. Добавьте в макет рамку. Выберите команду меню Вставка|Рамка.... После чего в макет будет добавлена рамка в соответствии с размерами и ориентацией страницы.

  9. Для заполнения рамки текстом нажмите кнопку [image] на панели инструментов Макет, переместите указатель мыши в ячейку рамки и сделайте щелчок левой кнопкой мыши. Щелкните правой кнопкой мыши, в открывшемся контекстном меню выберите Шрифт. Затем измените размер шрифта на 12 и нажмите ОК. Введите с клавиатуры текст. Аналогично можно ввести текст во все графы рамки.

    Рамка с текстом

    Рисунок 1011. Рамка с текстом

  10. Добавьте карту в макет. Нажмите кнопку [image] на панели инструментов Макет. Выберите Вставить текущую карту и нажмите ОК. Выделите мышью прямоугольную область на макете, в которую следует вставить фрагмент выбранной карты. При необходимости отредактируйте эту область.

  11. Сделайте щелчок правой кнопкой мыши на вставленной карте и в контекстном меню выберите пункт Свойства. В диалоге свойств карты:

    • в разделе Область печати: выберите вид: По габаритам слоя;

    • в этом же разделе выберите слой, по габаритам которого будет производится печать;

    • установите опцию вписать в страницу, масштаб будет подобран автоматически;

    • нажмите кнопку ОК.

    Рисунок 1012. Настройка карты

    Обратите внимание что после сделанных настроек визуально карта не переместиться по габаритам слоя, результат будет виден только при предварительном просмотре макета.

  12. Внесите в заголовок название карты. Нажмите кнопку [image] на панели инструментов Макет, переместите указатель мыши в место заголовка и сделайте щелчок левой кнопкой мыши, появится область текстового блока. Увеличите ее размер, для этого установите курсор на одном из квадратиков на углу или ребре области. Нажмите и не отпуская левую кнопку мыши переместите курсор в нужное место.

    Далее сделайте установите курсор в текстовый блок. На панели инструментов выберите шрифт и его размер, последний можно ввести с клавиатуры. Установите отображение текста посередине [image] .

    Введите название с клавиатуры или вставьте подстановку, как в примере ниже. Для подстановки сделайте щелчок правой кнопкой мыши в области текстового блока. В контекстом меню выберите [image] Подстановка. В открывшемся диалоге слева в категории выберите карту, справа свойство Название. Нажмите ОК. При вводе длинного названия с клавиатуры перенос стоки лучше осуществлять клавишей Enter, а не ограничением текстового блока.

    Настройка подстановки с названием карты в заголовок

    Рисунок 1013. Настройка подстановки с названием карты в заголовок

  13. Установите указатель масштаба. Нажмите кнопку [image] на панели инструментов Макет. Щелкните мышью в том месте, куда следует вставить обозначение масштаба. В открывшемся диалоге выберите вариант обозначения масштаба. Затем нажмите кнопку ОК.

    Рисунок 1014. Указатель масштаба

  14. Вставьте изображение. В данном примере будет использован герб города, но это может быть любое изображение. Например, график или какая-либо дополнительная информация по объектам печати. Нажмите кнопку [image] на панели инструментов Макет. В появившейся панели выбора файла выберите файл картинку, которую нужно вставить. Выделите прямоугольную область – рисунок вставится пропорционально габаритам изображения. При необходимости отредактируйте изображение.

  15. Установите знак север. Выберите пункт меню Вставка|Север, щелкните мышью в том месте, куда следует вставить обозначение направления на север. В появившейся панели выберите вариант обозначения. Затем нажмите кнопку ОК.

  16. Добавьте легенду. Выберите пункт меню Вставка|Легенда. Выделите мышью прямоугольную область на макете. При необходимости отредактируйте легенду.

    Рисунок 1015. Легенда

  17. Сохраните макет. Нажмите кнопку [image] панели инструментов. В появившемся диалоговом окне введите имя макета, и нажмите OK. Макет будет сохранен.

  18. Для просмотра результата нажмите кнопку [image] . Если есть подходящее устройство для печати, то готовый макет может быть сразу напечатан - кнопка [image] . Если его нет, то макет можно экспортировать в файл PDF и затем передать его на печать. Для экспорта выберите меню Файл|Экспорт|Печать в PDF. Или в режиме просмотра нажмите кнопку [image] . Затем выберите местоположение для сохранения файла, укажите имя создаваемого PDF файла и нажмите кнопку Сохранить.

    [Примечание] Примечание

    После сохранения макета обязательно необходимо сохранить карту, для которой он создавался!

Рисунок 1016. Готовый макет


Многостраничная печать карты по планшетам

Предположим, необходимо распечатать карту по размерам сети на листах формата A4 в масштабе 1:500. На каждом листе карта должна располагаться строго в квадрате 20*20 см. При печати надо вывести номер соседних планшетов для дальнейшей склейки.

Для печати:

  1. Откройте карту для печати.

  2. Создайте слой с планшетами. В данном примере такой слой будет создан с помощью операции сетки по слою. Для создания выберите Карта|Операции|Сетка по слою, затем:

    1. из списка Исходный слой выберите слой, по которому будет создана сетка с полигонами, в данном варианте это слой инженерной сети;

    2. нажмите кнопку Обзор и укажите имя и место для сохранения слоя с сеткой;

    3. для одновременного создания со слоем базы данных установите опцию База по умолчанию и при необходимости измените Источник данных;

    4. в разделе Сетка установите шаг сетки, так как размер планшетов планируется 20 на 20 см, а масштаб 1:500, что означает 1 сантиметр на карте соответствует 500 сантиметрам на местности, в этом случае шаг сетки устанавливается 10000*10000 см;

    5. заполнение сетки выберите Выпуклая оболочка по слою;

    6. установите опцию Добавить в карту и нажмите кнопку ОК.

      Создание сетки по слою

      Рисунок 1017. Создание сетки по слою

    В результате будет создан и загружен в карту слой с сеткой указанного шага.

  3. Для дальнейшего удобства работы со слоем планшетов измените настройки стиля и параметр печати слоя. Выберите меню Карта|Слои, сделайте двойной щелчок по слою с планшетами. В открывшемся диалоге настроек слоя:

    1. во вкладке Общие снимите опцию Отображать слой при печати;

    2. во вкладке Контуры выберите узор без заливки и установите опцию Использовать указанный стиль для всех таких объектов;

      Рисунок 1018. Настройка слоя

    Нажмите кнопку ОК. В результате планшеты будут отображены на карте в виде рамок и не будут выведены при печати.

  4. Для возможности вывода на печать не всех планшетов, а определенных внесем в базу каждому планшету его название. Для этого:

    1. выделите планшеты;

    2. откройте окно информации по любому из планшетов, обновите число записей - кнопка [image] ;

    3. далее внесите название для каждого планшета, это можно сделать как вручную, так и с помощью запроса. Рассмотрим как это сделать запросом, для этого откройте вкладку Запрос, в строке Name введите ИЗМЕНИТЬ "p"+sys, где ИЗМЕНИТЬ - оператор обновления данных, "p" - название планшета латиницей, +sys - ID планшета. Далее выполните запрос - [image] :

      • Рисунок 1019. Вкладка Запрос

      В результате каждому планшету будет прописан номер в соответствии с его ID:

      Рисунок 1020. Вкладка База

  5. Создайте новый макет, для этого выберите меню Карта|Макеты... и нажмите кнопку Создать.

  6. Произведите настройку принтера. Выберите пункт меню Файл|Принтер.., далее:

    1. в разделе Принтер выберите принтер;

    2. в разделе Бумага задайте размер А4;

    3. в разделе Ориентация выберите Книжная;

    4. нажмите кнопку ОК:

      Рисунок 1021. Настройка принтера

  7. Задайте параметры страниц макета. Выберите пункт меню Файл|Параметры страницы. Во вкладке Макет в разделе Размер листа укажите формат A4 и в разделе Ориентация - Книжная. Нажмите кнопку OK. После произведенных настроек размер листа печати и макета должны совпадать, то есть пунктирная линия листа будет повторять сплошную линию макета.

    Рисунок 1022. Настройка страницы

  8. Добавьте карту в макет. Нажмите кнопку [image] на панели инструментов Макет. Выберите Вставить текущую карту и нажмите ОК. Выделите мышью прямоугольную область на макете, в которую следует вставить фрагмент выбранной карты.

  9. Настройте размер карты, область печати и шаблон планшета, для этого сделайте щелчок правой кнопкой мыши на вставленной карте и в контекстном меню выберите пункт Свойства.

    • Во вкладке Карта:

      1. В разделе Область печати: выберите вид: Планшет.

      2. В строке шаблон: нажмите кнопку ....

      3. Настройте шаблон. В открывшемся диалоге Шаблон планшета в строке Шаблон введите название создаваемому шаблону. Из списка слой выберите слой с объектами печати, в данном варианте это ранее созданный слой Сетка по сети. Следующим этапом необходимо указать атрибуты. Для этого установите курсор справа от сроки Код, нажмите кнопку ... и в окне Поле запроса двойным щелчком выберите поле Name. Нажмите кнопку Сохранить и Закрыть.

        Настройка шаблона планшета

        Рисунок 1023. Настройка шаблона планшета

      4. Установите опцию вписать в страницу.

        Рисунок 1024. Настройка карты

    • Во вкладе Общие:

      • В полях W и H введите 200 мм, это будет размер вставленной карты 20*20 см и нажмите кнопку ОК. После закрытия диалога область карты может сместиться с листа, при необходимости передвиньте ее. Для этого подведите к ней курсор, нажмите и не отпуская левую клавишу мыши переместите область в нужную часть листа.

        Рисунок 1025. Настройка карты

        Обратите внимание, что после сделанных настроек визуально карта не переместиться по габаритам области в масштабе, результат будет виден только при предварительном просмотре макета.

  10. Добавим подстановки для отображения названия соседних планшетов на листе. Для этого:

    1. Нажмите кнопку [image] на панели инструментов Макет.

    2. Установите на панели инструментов шрифт и размер:

    3. Установите курсор над картой в место вывода номера верхнего планшета. Сделайте щелчок правой кнопкой мыши и в контекстом меню выберите [image] Подстановка. В открывшемся диалоге слева в категории выберите в разделе Планшет пункт Сверху, справа свойство Код. Нажмите ОК.

      Рисунок 1026. Настройка подстановки

    4. Повторите данные действия для планшетов слева, справа и снизу. В результате в макете в местах дальнейших подстановок будут отображаться вопросительные знаки:

      Рисунок 1027. Настройка подстановки

  11. Для просмотра результата нажмите кнопку [image] . В появившемся окне укажите код планшета. Можно формировать документ по всем объектам или выбрать определенные. Для просмотра одновременно всех планшетов нажмите кнопку Все. Запрос на просмотр планшетов формируется по аналогии с запросами к базам данных. Для просмотра конкретных планшетов введите их название. Например, p2, p3, p4. По краям планшетов, там где были подстановки вместо ? будут указаны номера соседних планшетов [image] . Если результат устраивает, для печати нажмите кнопку [image] или экспортируйте планшеты в формат PDF - кнопка [image] .

    Просмотр перед печатью

    Рисунок 1028. Просмотр перед печатью


Экспорт в PDF

  • «Экспорт из окна карты»

  • «Экспорт из макета печати»

Подготовленную к печати карту или макет печати можно экспортировать в PDF файл. В документе PDF сохраняется разделение данных по слоям, что позволяет управлять настройками видимости при просмотре документов.


Экспорт из окна карты

После настроек печати карты карту можно экспортировать в PDF файл, для этого:

  1. Откройте подготовленную для печати карту/макет.

  2. Перед экспортом посмотрите, в каком виде будут экспортированы данные. Для просмотра выберите меню Файл|Предварительный просмотр или нажмите на панели инструментов кнопку [image] . При необходимости измените настройки печати карты. Запустить экспорт можно сразу из окна просмотра, нажав кнопку [image] , в этом случае пропустите пункт 3.

    [Примечание] Примечание

    Настройка параметров страниц печати можно изменить в настройках принтера.

  3. Выберите команду главного меню Файл|Экспорт|Печать в PDF.

  4. Выберите местоположение для сохранения файла и укажите имя создаваемого PDF файла.

  5. Нажмите кнопку Сохранить.

    Пример макета в pdf формате

    Рисунок 1029. Пример макета в pdf формате


Экспорт из макета печати

После настройки макета печати его можно экспортировать в PDF файл, для этого:

  1. Откройте подготовленный макет.

  2. Перед экспортом можно предварительно посмотреть, в каком виде будут экспортированы данные. Для просмотра выберите меню Файл|Предварительный просмотр или нажмите на панели инструментов кнопку [image] . При необходимости измените макет и его настройки. Запустить экспорт можно сразу из окна просмотра, нажав кнопку [image] , в этом случае пропустите пункт 3.

  3. Выберите команду главного меню Файл|Экспорт|Печать в PDF.

  4. Выберите местоположение для сохранения файла и укажите имя создаваемого PDF файла.

  5. Нажмите кнопку Сохранить.

  6. В открывшемся окне в строке Файл для записи проверьте путь до сохраняемого файла и его имя. Если требуется произвести изменения, нажмите кнопку Обзор... и исправьте необходимые параметры.

  7. В разделе Параметры страницы при необходимости измените размер страницы печати и ориентацию. По умолчанию параметры соответствуют настройкам макета.

  8. Для открытия результата сразу после экспорта установите опцию Открыть документ по завершению.

  9. Чтобы запустить экспорт, нажмите кнопку ОК.

Пример макета в pdf формате

Рисунок 1030. Пример макета в pdf формате


Копирование фрагмента карты в буфер обмена

Область карты может быть скопирована в буфер как в заданном масштабе, так и в масштабе отображения экрана. В дальнейшем скопированный фрагмент карты возможно использовать в сторонних программах, например, вставить в виде картинки в Microsoft Word или PowerPoint.

[Примечание] Примечание

Видео о копировании фрагмента карты в буфер обмен можно посмотреть, пройдя по ссылке https://youtu.be/a4iHGIcwapw.

Для копирования фрагмента надо:

  1. Выделить область для копирования ( [image] ).

  2. В окне карты сделать щелчок правой кнопкой мыши, появится контекстное меню. Если копирование требуется сделать в масштабе отображения экрана, то следует выбрать пункт Копировать область. В том случае, если копирование нужно в каком-то определенном масштабе, то следует выбрать пункт Копировать область M1:Z, где Z – настроенный заранее масштаб копирования.

Настройка масштаба копирования:

[Примечание] Примечание

Настройку масштаба копирования в буфер возможно сделать также через панель Параметры (Сервис|Параметры), вкладка Карта.

  1. После выделения области надо сделать щелчок правой кнопкой мыши и выбрать пункт Настройки копирования в буфер.

  2. В появившемся окне в строке Масштаб1: указать необходимый масштаб.

  3. Нажать кнопку ОК.

    Кнопка Отмена закроет диалог без сохранения изменений.

    Диалоговое окно Масштаб копирования фрагмента в буфер

    Рисунок 1031. Диалоговое окно Масштаб копирования фрагмента в буфер


Задачи топологического анализа

  • «Работа с флагами»

  • «Работа с результатом топологических задач»

  • «Поиск отключающих и изолирующих устройств»

  • «Сохранение и загрузка найденного пути и флагов»

  • «Экспорт сохраненных путей и флагов в XML файл»

  • «Импорт сохраненных путей и флагов из XML файла»

ZuluGIS поддерживает линейно-узловую топологию, которая позволяет моделировать инженерные и другие сети. Модель сети представляет собой граф, где узлы обозначаются символьными объектами (например, колодцами, источниками, задвижками, рубильниками, перекрёстками, потребителями и так далее), а рёбрами являются линейные объекты (трубопроводы, кабели, участки дорожной сети и другое).

Используя модель сети можно решать ряд топологических задач:

  • поиск связанных и несвязанных объектов;

  • поиск связанных объектов по и против направления;

  • поиск пути;

  • поиск группы путей;

  • поиск колец;

  • поиск участков без узлов.

Топологические задачи также позволяют:

  • после решения задачи выделить объекты сети;

  • в инженерных сетях построить путь для пьезометрического графика (графика падения давления, продольного профиля);

  • выделить маршрут для экспорта продольного профиля инженерной сети в AutoCAD DXF (ZuluHydro, ZuluDrain, ZuluGaz).

  • в ZuluHydro для расчёта гидравлического удара указать путь для наблюдения.

С помощью кнопки Поиск пути [image] отмечаются символьные (узловые) объекты на сети – расставляются флажки. Далее решается топологическая задача: поиск пути, связанности, колец и прочие. В результате решения топологической задачи, объекты на карте будут выделены цветом. Полученные результаты – объекты сети, можно выделить или добавить/исключить из уже существующей группы. Результат топологических задач может быть сохранен.

В том случае, если между объектами существует разрыв, то путь не будет найден и отобразится соответствующее сообщение.

Вы можете исключить определенные участки из пути. Для этого, удерживая клавишу Ctrl, щелкните левой кнопкой мыши по тем участкам, по которым не будет проходить маршрут, они отметятся красным крестиком.

[Подсказка] Подсказка

Цвет и стиль выделения результатов топологического анализа можно изменить в диалоге Параметры (Сервис|Параметры), вкладка Карта.

Возможно быстро получить список отключающих (изолирующих) устройств для выделенного объекта сети.

Для анализа изменений вследствие отключения задвижек или участков сети предназначен продукт Коммутационные задачи.


Поиск связанных и несвязанных элементов сети

Для сети, которая построена по типу графа (например, инженерная или дорожная сеть) возможно проверить связанность элементов указанных узлов. Узлы указываются путем расстановки флагов.

Что бы найти связанные или несвязанные элементы сети:

  1. Сделайте активным слой, для которого будут искаться связанные или несвязанные элементы сети.

  2. Нажмите кнопку Поиск пути [image] .

  3. Щелкните мышью по любому символу (в данной точке установится красный флажок).

    [Примечание] Примечание

    Подробней о работе с флагами можно узнать в разделе «Работа с флагами».

  4. Если требуется исключить из поиска определенные объекты сети, то удерживая клавишу Ctrl, щелкните по ним, после чего они будут отмечены красным крестом [image] .

  5. По умолчанию, отключенные объекты в поиске не участвуют, но вы можете их включить в поиск. Для этого надо удерживая клавишу Shift щелкнуть по ним, после чего они будут отмечены зеленым кружком [image] .

  6. Для запуска поиска связанных или несвязанных элементов в любом месте карты сделайте щелчок правой кнопкой мыши, в появившемся контекстном окне выберите пункт Найти связанные или Найти несвязанные соответственно.

В результате все участки сети, связанные или не связанные с узлами, отмеченными флагами, окрасятся цветом.

Нахождение связанных элементов сети

Рисунок 1032. Нахождение связанных элементов сети

[Примечание] Примечание

Полученные результаты - объекты сети, можно выделить или добавить/исключить из уже существующей группы.

Отмену флагов и результата поиска можно произвести нажав кнопку [image] . Как произвести отмену отдельно результата или флагов можно узнать в разделе «Работа с флагами».


Поиск связанных объектов по и против направления

Вы можете производить поиск связанных объектов по направлению (по стрелкам) участков или против. Следует учитывать, что направление участка определяется при его вводе, то есть его будет от начальной точки ввода к конечной точке. В дальнейшем направление можно участка можно изменить или вручную или после расчета, при соответствующих настройках в соответствии с направлением движения воды.

Для такого поиска:

  1. Повторите пункты 1-5 поиска связанных и несвязанных объектов.

  2. В контекстном меню выберите пункт Найти связанные по направлению или Найти связанные против направления. При выборе поиск будет осуществляться по направлению участков (по стрелкам) или соответственно против.

[Примечание] Примечание

Полученные результаты - объекты сети, можно выделить или добавить/исключить из уже существующей группы.

Отмену флагов и результата поиска можно произвести нажав кнопку [image] . Как произвести отмену отдельно результата или флагов можно узнать в разделе «Работа с флагами».


Поиск пути по графу

Построение пути может использоваться для решения следующих задач:

  1. Выделения объектов.

  2. Построения пути для пьезометрического графика (графика падения давления).

  3. Построение маршрута для экспорта продольного профиля инженерной сети в AutoCAD DXF (ZuluDrain,,ZuluGaz).

  4. В ZuluHydro для расчёта гидравлического удара указать путь для наблюдения.

  5. При наличии слоя рельефа для построения профиля.

При построении пути соединяются начальный и конечный узлы. Возможно указание промежуточных последовательных точек. Если путей от одного узла до другого может быть несколько, то по умолчанию путь выбирается самый короткий, в том случае если нужен другой путь, то надо указать промежуточные узлы.

[Примечание] Примечание

Найденный путь и флаги могут быть сохранены и в дальнейшем при необходимости загружены.

Для построения пути:

  1. Сделайте активным слой, в котором требуется найти путь.

  2. Нажмите кнопку Поиск пути [image] .

  3. Подведите курсор мыши к начальному символьному объекту и нажмите левую кнопку мыши, после чего на выбранном объекте будет установлен красный флажок.

  4. При существовании нескольких маршрутов до конечного узла (в кольцевых сетях) установите последовательно флажки на промежуточных узлах сети. Щелчком левой кнопкой мыши поставьте флажок на конечном объекте.

    [Примечание] Примечание

    Подробней о работе с флагами можно узнать в разделе «Работа с флагами».

  5. Если требуется исключить из маршрута определенные объекты сети, то надо удерживая клавишу Ctrl, щелкнуть по ним, после чего они будут отмечены красным крестом [image] .

    Установка флажков, исключение объектов из пути

    Рисунок 1033. Установка флажков, исключение объектов из пути

  6. По умолчанию, отключенные объекты в поиске пути не участвуют, но вы можете их включить в поиск. Для этого надо удерживая клавишу Shift щелкнуть по ним, после чего они будут отмечены зеленым кружком [image] .

  7. Для запуска поиска пути сделайте двойной щелчок левой кнопкой мыши или сделайте щелчок правой кнопкой мыши и выберите пункт Найти путь. Так же можно выбрать меню Карта|Топология|Найти путь.

    Найденный путь выделится цветом. В том случае, если путь найти невозможно, будет выдано соответствующее сообщение.

    Рисунок 1034. Нахождение пути

[Примечание] Примечание

Полученные результаты - объекты сети, можно выделить или добавить/исключить из уже существующей группы или сохранить.

Отмену флагов и результата поиска можно произвести нажав кнопку [image] . Как произвести отмену отдельно результата или флагов можно узнать в разделе «Работа с флагами».


Поиск группы путей

Вы можете построить группу путей - несколько путей между парами флагов. Это может использоваться для выделения объектов, лежащих на пути.

Флаги устанавливаются парами, при поиске флаги соединяются по самому короткому пути парами: первый флаг со вторым, 3 с 4 и так далее.

Для поиска группы путей:

  1. Сделайте активным слой, в котором будет производится поиск.

  2. Нажмите кнопку Поиск пути [image] .

  3. Щелкните левой кнопкой мыши по символьному объекту, на нём установится флажок.

    [Примечание] Примечание

    Подробней о работе с флагами можно узнать в разделе «Работа с флагами».

  4. Аналогичным образом установите флажок на следующих объектах.

    [Примечание] Примечание

    Флажки следует добавлять парами (начальный и конечный).

  5. В любом месте карты щелкните правой кнопкой мыши и в появившемся контекстном меню выберите пункт Найти группу путей.

Поиск группы путей

Рисунок 1035. Поиск группы путей

[Примечание] Примечание

Полученные результаты - объекты сети, можно выделить или добавить/исключить из уже существующей группы или сохранить.

Отмену флагов и результата поиска можно произвести нажав кнопку [image] . Как произвести отмену отдельно результата или флагов можно узнать в разделе «Работа с флагами».


Поиск колец в сети

Данная функция позволяет найти кольца в сети. Кольца будут найдены для областей сети, связанных с узлами, отмеченными флагами. Для поиска колец в сети:

  1. Сделайте активным слой, в котором будет производится поиск.

  2. Нажмите кнопку Поиск пути [image] .

  3. Левой кнопкой мыши щелкните по символьному объекту слоя, на нем установится флажок.

    [Примечание] Примечание

    Подробней о работе с флагами можно узнать в разделе «Работа с флагами».

    Пример нахождения колец в сети

    Рисунок 1036. Пример нахождения колец в сети

  4. В любом месте карты щелкните правой кнопкой мыши. В появившемся контекстном меню выберите пункт Найти кольца или выберите пункт главного меню Карта|Топология|Найти кольца.

    В результате все найденные кольца выделятся цветом.

[Подсказка] Подсказка

В нижней части окна отобразится количество найденных колец.

[Примечание] Примечание

Полученные результаты - объекты сети, можно выделить или добавить/исключить из уже существующей группы или сохранить.

Отмену флагов и результата поиска можно произвести нажав кнопку [image] . Как произвести отмену отдельно результата или флагов можно узнать в разделе «Работа с флагами».


Поиск участков без узлов

Используя данную функцию вы можете найти участки сети, которые как бы «повисли», то есть не имеют в начале или конце узлового объекта. Такие участки могут появиться либо после экспорта данных и дальнейшего преобразования их в сеть, либо при неправильном редактировании сети.

Для поиска участков без узлов:

  1. Сделайте активным слой, в котором будет производится поиск.

  2. Нажмите кнопку Поиск пути [image] .

  3. Левой кнопкой мыши щелкните по символьному объекту сети, на нем установится флажок.

    [Примечание] Примечание

    Подробней о работе с флагами можно узнать в разделе «Работа с флагами».

  4. В любом месте карты сделайте щелчок правой кнопкой мыши, в появившемся контекстном меню выберите пункт Найти участки без узлов.

    Нахождение участков без узлов

    Рисунок 1037. Нахождение участков без узлов

В результате все найденные участки без узлов выделятся цветом.

[Примечание] Примечание

Полученные результаты - объекты сети, можно выделить или добавить/исключить из уже существующей группы или сохранить.

Отмену флагов и результата поиска можно произвести нажав кнопку [image] . Как произвести отмену отдельно результата или флагов можно узнать в разделе «Работа с флагами».


Сохранение и загрузка найденного пути и флагов

После поиска пути по графу найденный путь и флаги могут быть сохранены и затем при необходимости загружены.

[Примечание] Примечание

Пути сохраняются только в локальных данных за рабочим компьютером, для обмена сохраненных путей и флагов используете импорт и экспорт данных.

Для сохранения пути и флагов:

  1. В ходе решения топологической задачи найдите путь.

  2. Выберите меню Карта|Топология|Сохранить путь и флаги или в режиме Поиск пути - [image] сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Сохранить путь и флаги.

  3. В открывшемся диалоговом окне в строке Название дайте название сохраняемому пути. Если требуется заменить уже существующий путь на новый выберите его из списка Название. При необходимости к названию можно добавить описание, оно заносится в одноименное окно.

    Диалоговое окно Сохранение пути

    Рисунок 1038. Диалоговое окно Сохранение пути

  4. Чтобы завершить сохранение нажмите кнопку ОК.

Для загрузки ранее сохраненного пути и флагов надо:

  1. Выберите меню Карта|Топология|Загрузить путь и флаги или в режиме Поиск пути - [image] сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Загрузить путь и флаги.

  2. В открывшемся диалоге сделайте двойной щелчок на названии загружаемого пути или выделите путь и нажмите кнопку Загрузить.

    Диалоговое окно Сохраненные пути

    Рисунок 1039. Диалоговое окно Сохраненные пути

[Примечание] Примечание

Для удаления ранее сохраненного пути выделите его в списке и нажмите кнопку Удалить.


Экспорт сохраненных путей и флагов в XML файл

Сохраненные пути вы можете как экспортировать в файл XML, так и импортировать из XML файла.

Пути и флаги сохраняются только локально за рабочим компьютером, импорт и экспорт используется для обмена данными.

Для экспорта сохраненных путей и флагов:

  1. Выберите меню Карта|Топология|Загрузить путь и флаги или в режиме Поиск пути - [image] сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Загрузить путь и флаги.

  2. Установите галочки напротив путей, которые надо экспортировать в XML. Для того чтобы отметить сразу все пути, включите опцию Все, после чего напротив всех названий путей будут установлены галочки.

  3. Нажмите кнопку Экспорт в файл.

  4. Укажите папку и введите название для создаваемого XML файла.

  5. Нажмите кнопку Сохранить.

Экспорт завершен.


Импорт сохраненных путей и флагов из XML файла

Сохраненные пути вы можете как импортировать из XML файла, так и экспортировать в XML файл.

Пути и флаги сохраняются только локально за рабочим компьютером, импорт и экспорт используется для обмена данными.

Для импорта сохраненных путей и флагов:

  1. Выберите меню Карта|Топология|Загрузить путь и флаги или в режиме Поиск пути - [image] сделайте щелчок правой кнопкой мыши и в контекстном меню выберите пункт Загрузить путь и флаги.

  2. Нажмите кнопку Открыть файл.

  3. Выберите на компьютере XML файл для импорта.

  4. Нажмите кнопку Открыть.

  5. В загруженном списке установите галочки напротив путей, которые надо импортировать. Для того чтобы отметить сразу все пути, включите опцию Все, после чего напротив всех названий путей будут установлены галочки.

  6. Нажмите кнопку Импорт. В результате успешного импорта будет выдано соответствующее сообщение.


Работа с флагами

  • «Установка флага»

  • «Установка флагов на группу объектов»

  • «Отмена последнего флага»

  • «Отмена всех флагов»

  • «Отмена результата»

  • «Отмена флагов и результата»

При решении различных задач топологического анализа используется расстановка флагов по сети. Флажки устанавливаются на символьные объекты активного слоя. Режим установки флажков включается нажатием кнопки Поиск пути [image] на панели навигации.

Установка флага

Флаг может быть установлен только на символьный объект сети, который имеет одну точку привязки. Для установки флага:

  1. Проверьте что слой на который требуется установить флаг активный.

  2. Нажмите кнопку Поиск пути [image] на панели навигации.

  3. Щелкните левой кнопкой мыши по символьному объекту. На нем будет установлен флажок.

Установка флагов на группу объектов

Одновременно возможна установка нескольких флагов на группу символьных объектов. Для такой остановки:

  1. Проверьте что слой на который требуется установить флаг активный.

  2. Выделите группу объектов на которые надо установить флаги.

  3. Выберите меню Карта|Топология|Добавить флаги для группы.

    или

    Нажмите кнопку Поиск пути [image] на панели навигации, сделайте щелчок правой кнопкой мышки в области карты, и в контекстном меню выберите пункт Добавить флаги для группы.

Отмена последнего флага

Чтобы удалить последний поставленный флаг:

  1. Выберите пункт меню Карта|Топология|Отменить последний флаг.

    или

    Проверьте чтобы на панели навигации была нажата кнопка Поиск пути [image] , нажмите правую кнопку мыши в области карты и в контекстном окне выберите пункт Отменить последний флаг.

Отмена всех флагов

Для удаления всех ранее установленных флагов без удаления результата топологических задач:

  1. Выберите пункт меню Карта|Топология|Отменить флаги.

    или

    Проверьте чтобы на панели навигации была нажата кнопка Поиск пути [image] , нажмите правую кнопку мыши в области карты и в контекстном окне выберите пункт Отменить флаги.

Отмена результата

Для отмены результата топологических задач без удаления флагов выберите меню Карта|Топология|Отменить результат.

Отмена флагов и результата

Для удаления флагов и результата (построенного пути) нажмите кнопку [image] на панели инструментов. Или выберите меню Карта|Топология|Отменить все.


Работа с результатом топологических задач

В результате решения различных топологических задачи происходит выделение объектов сети цветом. Полученные результаты - объекты сети, можно выделить (создать группу заново) или добавить/исключить из уже существующей группы.

[Примечание] Примечание

После того, как группа создана ее возможно сохранить и при необходимости загрузить.

Для создания группы или добавления/исключения объектов из существующей группы:

После решения коммутационной задачи нажмите правую кнопку мыши, и в контекстном меню выберите соответствующий пункт:

  • Создать группу - будет создана новая группа из выделенных объектов. При этом с ранее созданных групп выделение будет снято.

  • Добавить в группу - выделенные цветом объекты будут добавлены в уже существующую группу.

  • Исключить из группы - выделенные цветом объекты будут исключены из уже существующей группы.

Автоматическое создание или добавление объектов в группу:

Для того, чтобы результаты топологических задач автоматически добавлялись в группу следует в режиме Поиск пути [image] щелкнуть правой кнопкой мыши и отметить соответствующий пункт Создавать группу автоматически или Добавлять в группу автоматически.

Для удаления результата поиска:

Нажмите правую кнопку мыши и выберите пункт Отменить результат или выберите пункт главного меню Карта|Топология|Отменить результат.


Поиск отключающих и изолирующих устройств

Возможно быстро получить список отключающих (изолирующих) устройств, для выделенного объекта сети.

Отключающими устройствами считаются те объекты сети, для которых графический тип объекта инженерной сети установлен как «отсекающее устройство» (см. «Типы и режимы»). Система будет искать устройства, изолирующие объект от источника.

Для анализа изменений вследствие отключения задвижек или участков сети предназначены Коммутационные задачи.

Для поиска изолирующих устройств:

  1. Сделайте слой, содержащий инженерную сеть активным.

  2. Выделите [image] на карте объект, который необходимо отключить.

  3. Выберите пункт главного меню Задачи|Найти отключающие устройства

    или

    удерживая нажатой клавишу Ctrl нажмите кнопку [image] на панели инструментов.

    [Подсказка] Подсказка

    Для поиска отключающих устройств нажмите кнопку [image] , удерживая нажатой клавишу Ctrl.

В результате в окне Сообщения на вкладке Арматура появится список всех объектов, которые отключают выбранный объект. Если окно сообщений не появилось автоматически, тогда нажмите кнопку [image] , выберите вкладку Арматура или выберите пункт меню Окно|Сообщения, вкладка Арматура.

[Примечание] Примечание

Для того, чтобы убрать закладку Арматура, установите курсор на команду <Выход> и нажмите Enter или сделайте двойной щелчок мыши на этой команде. Для закрытия окна Сообщения нажмите кнопку [image] или выберите пункт меню Окно|Сообщения.


Расчеты инженерных сетей

В ZuluGIS расчеты инженерных сетей реализованы в виде встроенных модулей и компонентов для разработчиков.

Модули запускаются непосредственно из системы с использованием соответствующих кнопок на панели инструментов или из меню. Расчетные задачи собраны в разделе Задачи. Каждая инженерная сеть предусматривает определенный набор расчетов, которые можно приобрести отдельно. Это позволяет пользователям выбирать только те инструменты, которые необходимы для их работы.

Имеются расчеты для следующих инженерных сетей, чтобы открыть справку по определенной сети нажмите на его название:

ZuluThermo - расчеты тепловых сетей, состав задач:

  • Наладочный расчет

  • Поверочный расчет

  • Калибровка тепловой сети

  • Конструкторский расчет

  • Расчет требуемой температуры на источнике

  • Расчет надежности системы теплоснабжения

  • Расчет резерва пропускной способности сети

  • Расчет нормативных потерь тепла через изоляцию

  • Анализ термограмм

  • Поиск утечек и дефектов

  • Коммутационные задачи

  • Построение пьезометрического графика

  • Построение технологических схем

ZuluHydro - гидравлический расчет систем водоснабжения, состав задач:

  • Конструкторский расчет водопроводной сети

  • Поверочный расчет водопроводной сети

  • Калибровка водопроводной сети

  • Расчет резерва пропускной способности сети

  • Поиск утечек и дефектов

  • Оптимизация насосного оборудования

  • «Гидроудар» - расчет переходных процессов

  • Коммутационные задачи

  • Построение пьезометрического графика

  • Построение продольного профиля в (AutoCAD/DXF)

  • Построение технологических схем

ZuluDrain - гидравлический расчет самотечных и напорных систем канализации, состав задач:

  • Конструкторский расчет

  • Поверочный расчет

  • Продольный профиль

  • Построение продольного профиля в (AutoCAD/DXF)

  • Построение технологических схем

ZuluGaz - гидравлические расчеты систем газоснабжения, состав задач:

  • Конструкторский гидравлический расчет газовой сети

  • Поверочный гидравлический расчет газовой сети

  • Определение объема природного газа при аварийных выбросах

  • Определение времени работы газопровода на остаточном давлении при отключении источника

  • Расчет резерва пропускной способности сети

  • Построение графика падения давления в газовой сети

  • Коммутационные задачи

  • Построение продольного профиля газовой сети в (AutoCAD/DXF)

  • Построение технологических схем

ZuluSteam - теплогидравлические расчеты паровых сетей, состав задач:

  • Коммутационные задачи

  • Наладочный расчет

  • Поверочный расчет

  • Построение графиков изменения температуры, давления, энтальпии


ZuluOPC - поддержка OPC в продуктах ZuluGIS

ZuluOPC — программный комплекс со встроенной поддержкой технологии OPC для получения данных от измерительных приборов, SCADA и систем автоматизации, поддерживающих передачу данных по спецификациям OPC UA или OPC DA.

Технология OPC(Open Platform Communications, ранее OLE for Process Control) – программные технологии управления объектами автоматизации и технологическими процессами, созданные и поддерживаемые международной некоммерческой организаций OPC Foundation.

ZuluOPC дает возможность дополнять геоинформационные системы на основе ZuluGIS данными, передаваемыми в реальном времени различными измерительными приборами и устройствами - приборами учета, датчиками, контроллерами и т.д. Технология OPC позволяет объединять данные разнотипных систем и устройств в единое информационное пространство с иерархической организацией. Нет необходимости использовать напрямую драйвера и разные протоколы для подключения к оборудованию.

[Примечание] Примечание

Подробней о ZuluOPC можно узнать в справке.

Связь объектов ZuluGIS и информации с OPC-серверов

Рисунок 1040. Связь объектов ZuluGIS и информации с OPC-серверов


ZuluTracks - поддержка веб-сервисов трекинга в продуктах ZuluGIS

ZuluTracks — программа для получения и обработки информации от поставщиков данных о состоянии и местоположении объектов трекинга.

Объектами трекинга могут быть транспортные средства или мобильные устройства. Поставщиками данных являются веб-сервисы — системы мониторинга подвижных объектов и любые другие системы, работающие по протоколам, поддерживаемыми программой ZuluTracks. В текущей версии поддерживаются следующие веб-сервисы мониторинга:

  • Wialon

  • Omnicomm

  • Fort Monitor

ZuluTracks позволяет дополнить геоинформационные системы на основе ZuluGIS данными о местоположении и состоянии мобильных объектов. Объекты могут отображаться в специальном слое трекинга на ZuluServer (текущее местоположение и маршруты) или обычном векторном слое (текущее местоположение).

Возможности слоя трекинга

  • отображение местоположения и названий объектов на карте в режиме реального времени;

  • отображение маршрутов объектов в слое ZuluGIS;

  • фильтр по объектам и по дате;

  • задание индивидуальных иконок и стилей отображения треков пользователей: цвет, стиль и толщина линий;

  • централизованное хранение в базе данных информации о маршрутах объектов слоя трекинга.

[Примечание] Примечание

Подробней о ZuluTracks можно узнать в справке.

Рисунок 1041.


Импорт и экспорт данных

Текущая версия позволяет импортировать данные из следующих обменных форматов:

  • «Импорт из формата DXF»

  • «Импорт из формата MIF»

  • «Импорт из формата Shape SHP»

  • «Импорт из формата Metafile WMF»

  • «Импорт из формата GPX»

  • «Импорт треков из OziExplorer PLT»

  • «Импорт из формата KML, KMZ»

  • «Импорт из таблицы»

  • «Импорт из QGIS»

  • «Импорт из GeoJSON»

  • «Импорт растровых данных из MapInfo, OziExplorer и объектов формата ESRI World File»

  • «Импорт GeoTIFF в растровый слой ZuluGIS»

  • «Импорт XML-документов Росреестра»

  • «Импорт текста с разделителями»

  • «Импорт из формата LAS»

  • «Импорт модели рельефа из LandXML TIN»

  • «Импорт модели рельефа из Esri TIN»

  • «Импорт модели рельефа из Intermediate TIN Format (ITF)»

  • Импорт семантических данных из Microsoft Excel

  • «Импорт данных с веб-сервисов трекинга»

  • «Импорт групп из XML файла»

  • «Импорт сохраненных путей и флагов из XML файла»

и экспортировать данные в следующие форматы:

  • «Экспорт в формат DXF»

  • «Экспорт в формат MIF»

  • «Экспорт в формат Shape SHP»

  • «Экспорт в формат Google KML»

  • «Экспорт в SQLite»

  • «Экспорт в MBTiles»

  • «Экспорт в растр (печать в растр)»

  • «Экспорт описателей растровых объектов в форматы Mapinfo, OziExplorer, ESRI World File»

  • «Экспорт в GeoJSON»

  • «Экспорт рельефа в формат LandXML TIN»

  • «Экспорт рельефа в Intermediate TIN Format (ITF)»

  • «Экспорт данных в формат Microsoft Excel или электронную таблицу ODS»

  • «Экспорт проекции слоя»

  • «Экспорт групп в XML файл»

  • «Экспорт сохраненных путей и флагов в XML файл»


Импорт из формата DXF

При импорте чертежей AutoCAD есть возможность задавать правила, по которым будет осуществляться импорт графических элементов в формат ZuluGIS. Подробнее смотрите «Настройка подстановки при импорте графических данных из формата DXF».

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

Для импорта графической информации из формата DXF следует:

  1. Выбрать пункт главного меню Файл|Импорт|AutoCAD DXF. На экране появится стандартный диалог выбора файла, где необходимо выбрать файл формата DXF, который требуется импортировать.

  2. В строке Название слоя задать пользовательское название слоя.

  3. В строке Таблица необходимо выбрать источник данных, где будет создаваться новая таблица (или таблицы, в зависимости от операции). Это может быть как локальный источник («База данных Microsoft Access», «База данных SQLite»), так и настроенные источники данных ZuluGIS к различным СУБД с использованием ADO/OLEDB или ODBC.

  4. В появившемся диалоговом окне для импортируемого слоя в строке Имя слоя с помощью кнопки [image] необходимо задать имя файла и размещение его на диске.

  5. В строке Единицы измерения необходимо указать, какие единицы следует использовать при импорте.

  6. В строке Кодировка выбрать, какую кодировку использовать для чтения файла. В случае неверного выбора в результате импорта текст будет импортирован в нечитаемом виде:

    Неправильно подобранная кодировка

    Рисунок 1042. Неправильно подобранная кодировка

    Правильно подобранная кодировка

    Рисунок 1043. Правильно подобранная кодировка

  7. Для автоматической загрузки импортируемых данных в карту необходимо установить галочку добавить слой в карту. Если ее на данном этапе не установить, то для загрузки слоя в карту надо будет выбрать пункт главного меню Карта|Добавить слой.

  8. В том случае, если используется подстановка параметров, в поле Файл CFG надо указать путь к файлу параметров подстановки.

  9. Для подтверждения процедуры импорта нажать кнопку ОК.

    Диалоговое окно «Импорт из AutoCAD DXF»

    Рисунок 1044. Диалоговое окно «Импорт из AutoCAD DXF»

  10. После того как программа проанализирует содержимое DXF-файла, появится диалоговое окно Импорт из DXF, оно отображает список всех слоев, содержащихся в DXF данных. Напротив каждого слоя установлен флажок (галочка), он означает, что слой будет импортирован. Если какой-либо слой не надо импортировать, то флажок с помощью левой кнопки мыши надо снять. С помощью кнопок Выделить все и Отменить все можно отметить сразу все слои для импорта или снять отметки, соответственно.

    Диалоговое окно «Импорт из DXF»

    Рисунок 1045. Диалоговое окно «Импорт из DXF»

  11. При желании в диалоге Импорт из DXF можно установить дополнительные опции импорта:

    • разделять на слои – означает, что импорт произойдет послойно, при этом название каждого файла слоя будет составлено из имени слоя (файла), заданном в пункте 2 ранее, и изначального названия слоя, отображенного в диалоге Импорт из DXF, а пользовательское название слоя останется изначальным. Если флажок Разделять на слои не установлен, то все данные импортируются в один слой с одинаковым пользовательским названием слоя и именем файла, заданном на предыдущем этапе;

    • не импортировать геометрию блоков – при установке данной опции не будет импортироваться геометрия блоков;

    • импортировать точки вставки блоков – при установке данной опции будут импортироваться точки вставки блоков;

    • импортировать атрибуты блоков в отдельную таблицу – в результате установки данной опции атрибуты блоков будут импортированы в отдельную таблицу.

  12. Для запуска процедуры импорта надо нажать кнопку Импорт.


Настройка подстановки при импорте графических данных из формата DXF

При импорте чертежей AutoCAD есть возможность задавать правила, по которым будет осуществляться импорт графических элементов в формат ZuluGIS. В файле конфигурации импорта из DXF (указывается в диалоге импорта) настраиваются соответствия между графическими элементами чертежа и графическими объектами слоев ZuluGIS.

Файл конфигурации имеет следующий формат:

  • Файл разбит на секции. Секция начинается со строки <НАЗВАНИЕ>, где НАЗВАНИЕ – это название этой секции, а заканчивается она строкой </НАЗВАНИЕ>.

  • Секции могут содержать вложенные секции и параметры.

  • Параметры имеют формат НАЗВАНИЕ_ПАРАМЕТРА: ЗНАЧЕНИЕ_ПАРАМЕТРА.

  • Конфигурационный файл может также содержать строки комментариев, комментарий начинается со знака «#».

Параметры подстановки задаются в секции template-zulu. Секция содержит вложенную секцию dxflayers, в которой содержатся секции dxflayer, описывающие параметры подстановок для каждого слоя чертежа AutoCAD.


Секция dxflayer

Описывает правила подстановки графических элементов указанного слоя чертежа AutoCAD. Имя слоя чертежа задается параметром dxflayername. Секция dxflayer содержит секции dxfshape, каждая из которых описывает правила подстановки одного из графических элементов чертежа в соответствующий слой ZuluGIS.

Секция dxfshape может содержать следующие параметры:

  • type – тип графического элемента чертежа AutoCAD. Можно задавать следующие значения:

    • lines – линейные элементы;

    • polygons – площадные элементы;

    • texts – тексты;

    • inserts – блоки.

  • stylename – имя стиля линии или заливки чертежа;

  • blockname – имя блока чертежа;

  • color – номер цвета элемента чертежа;

  • zulufilename – имя слоя ZuluGIS, в который импортируется элемент чертежа;

  • zulutype – тип объекта, если элемент чертежа импортируется как типовой объект слоя ZuluGIS;

  • zulumode – режим типового объекта слоя ZuluGIS.

Если не задан параметр stylename или blockname, то в указанный слой ZuluGIS импортируются все элементы чертежа соответствующего типа.

Если не задан параметр color, то в указанный слой ZuluGIS импортируются элементы чертежа соответствующего типа, при этом цвет элемента чертежа не учитывается.

Если не заданы параметры zulutype и zulumode, то элементы чертежа импортируются в указанный слой ZuluGIS как примитивы.


Пример файла конфигурации

# Файл конфигурации импорта из dxf

<template-zulu>

<dxflayers>

<dxflayer>

dxflayername: Г1

<dxfshape>

type:Lines

stylename: Газ Г1_НАДЗЕМ

color:5

zulufilename:"C:\\ImportDxf\\Template\\gaz.b00"

zulutype: Участки НД

zulumode: НД ВКЛ

</dxfshape>

<dxfshape>

type:Lines

stylename: Газ Г1_ПОДЗЕМ

color:5

zulufilename:"C:\\ImportDxf\\Template\\gaz.b00"

zulutype: Участки НД

zulumode: НДН ВКЛ

</dxfshape>

<dxfshape>

type:Lines

stylename:Continuous

color:5

zulufilename:"C:\\ImportDxf\\Template\\gaz.b00"

</dxfshape>

<dxfshape>

type:Texts

color:5

zulufilename:"C:\\ImportDxf\\Template\\paramG1.b00"

</dxfshape>

<dxfshape>

type:Inserts

blockname: Кран шар НД (Закр) надзем

zulufilename:"C:\\ImportDxf\\Template\\gaz.b00"

zulutype: Кран шаровый надзем

zulumode: НД ЗАКР

</dxfshape>

<dxfshape>

type:Inserts

blockname: Заглушка НД

zulufilename:"C:\\ImportDxf\\Template\\gaz.b00"

zulutype: Устройства на сети

zulumode: Заглушка НД

</dxfshape>

</dxflayer>

<dxflayer>

dxflayername: Г3-Г4

<dxfshape>

type:Lines

stylename: Газ Г3_НАДЗЕМ

color:1

zulufilename:"C:\\ImportDxf\\Template\\gaz.b00"

zulutype: Участки ВД 2 кат

zulumode: ВД 2 кат ВКЛ

</dxfshape>

<dxfshape>

type:Lines

stylename:Continuous

color:1

zulufilename:"C:\\ImportDxf\\Template\\gaz.b00"

</dxfshape>

</dxflayer>

<dxflayer>

dxflayername: Водные объекты

<dxfshape>

type:Lines

stylename:Continuous

color:150

zulufilename:"C:\\ImportDxf\\Template\\water.b00"

zulutype: Реки

zulumode: Реки

</dxfshape>

<dxfshape>

type:Polygons

color:150

zulufilename:"C:\\ImportDxf\\Template\\water.b00"

zulutype: Водные объекты

zulumode: Крупные реки

</dxfshape>

</dxflayer>

</dxflayers>

</template-zulu>


Импорт из формата MIF

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

Система имеет возможность импортировать как один файл MIF, так и группу файлов одновременно.

Для импорта одного файла обменного формата MIF необходимо выполнить следующие действия:

  1. Выбрать пункт главного меню Файл|Импорт| MapInfo MIF. На экране появится стандартный диалог выбора файла, в нем необходимо выбрать файл формата MIF, который требуется импортировать.

  2. В окне импорта для импортируемого слоя в строке Имя слоя с помощью кнопки [image] задать имя файла и размещение его на диске.

  3. В строке Название слоя задать пользовательское название слоя.

  4. В строке Таблица необходимо выбрать источник данных, где будет создаваться новая таблица (или таблицы, в зависимости от операции). Это может быть как локальный источник (например «База данных SQLite»), так и настроенные источники данных ZuluGIS к различным СУБД с использованием ADO/OLEDB или ODBC.

  5. В том случае, если импортировать требуется только графическую часть, необходимо установить опцию Импортировать только геометрию.

  6. Если установлена галочка добавить слой в карту, то импортированный слой автоматически добавится в карту, если она не установлена, то для загрузки слоя в карту надо выбрать пункт главного меню Карта|Добавить слой.

  7. Нажать кнопку ОК для выполнения процедуры импорта.

    Диалоговое окно «Импорт из MIF/MID»

    Рисунок 1046. Диалоговое окно «Импорт из MIF/MID»

[Подсказка] Подсказка

Импорт слоя из формата MIF можно произвести с помощью метода ZuluTools.ImportFromMIF.

Для импорта группы файлов обменного формата MIF необходимо выполнить следующие действия:

  1. Выбрать пункт главного меню Файл|Импорт| MapInfo MIF. На экране появится стандартный диалог выбора файла, в нем необходимо выбрать группу файлов формата MIF, которые требуется импортировать.

  2. В строке Папка для записи с помощью кнопки [image] задать папку для записи результатов импорта.

  3. В строке Таблица необходимо выбрать источник данных, где будет создаваться новая таблица (или таблицы, в зависимости от операции). Это может быть как локальный источник («База данных SQLite»), так и настроенные источники данных ZuluGIS к различным СУБД с использованием ADO/OLEDB или ODBC.

  4. В том случае, если импортировать требуется только графическую часть, необходимо установить опцию Импортировать только геометрию.

  5. Если установлена галочка Добавить в карту, то импортированные слои автоматически добавятся в карту, если она не установлена, то для загрузки слоев в карту надо выбрать пункт главного меню Карта|Добавить слой.

  6. Нажать кнопку ОК для выполнения процедуры импорта.

    Диалоговое окно «Импорта группы файлов из MIF»

    Рисунок 1047. Диалоговое окно «Импорта группы файлов из MIF»


Импорт из формата Shape SHP

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

Вы можете импортировать как один файла Shape SHP, так и группу файлов одновременно. Группу файлов можно импортировать в один файл ZuluGIS с разделением на типы. Иными словами, в результате импорта появится слой, у которого в структуре уже будут типовые объекты с такими же названиями, как у исходных файлов.

Для импорта данных из формата Shape SHP:

  1. Выберите пункт главного меню Файл|Импорт|Shape SHP. В открывшемся диалоге укажите файлы для импорта. Можно указать как один, так и несколько файлов одновременно; в зависимости от количества выбранных файлов, диалог импорта будет немного отличаться.

  2. Если на предыдущем этапе был выбран один файл и для него имеется PRJ файл в формате WKT с параметрами проекции слоя, то слой можно импортировать с проекцией. Для этого с помощью кнопки [image] справа от поля Файл PRJ выберите требуемый PRJ файл и установите флажок Импортировать информацию о проекции.

    Если ранее была выбрана группа файлов с параметрами проекции слоя, то для импорта проекции установите флажок Импортировать информацию о проекции.

  3. При импорте группы файлов возможно импортировать все файлы в отдельные слои или в один слой, во втором варианте будет производиться разделение по типам.

    Для импорта в разные слои проверьте, чтобы была установлена опция Импортировать в разные слои, затем нажмите кнопку Обзор... и укажите папку для импорта.

    Для импорта в один слой с разделением по типам установите опцию Импортировать как типы в один слой. Далее нажмите кнопку Обзор... и укажите расположение и имя создаваемого файла. Потом в строке Название задайте пользовательское название слоя (оно может дублировать название файла).

    При импорте одного файла укажите расположение и имя создаваемого файла, для этого нажмите кнопку Обзор..., затем в строке Название задайте пользовательское название слоя (оно может дублировать название файла).

  4. В поле Кодировка выберите кодировку текстов импортируемого слоя, а в поле Единицы измерения – используемые в нем единицы.

  5. Из списка Таблица укажите источник данных, где будут создаваться табличные данные.

  6. Для импорта из слоя только геометрических построений установите флажок Импортировать только геометрию.

  7. Для автоматического добавления в карту импортированного слоя установите флажок Добавить в карту. Если флажок не установлен, то для последующей загрузки слоя в карту необходимо выбрать пункт главного меню Карта|Добавить слой.

    Диалоговое окно «Импорт из Shape» для импорта одного файла

    Рисунок 1048. Диалоговое окно «Импорт из Shape» для импорта одного файла

    Диалоговое окно «Импорт из Shape» для группы файлов

    Рисунок 1049. Диалоговое окно «Импорт из Shape» для группы файлов

  8. Для запуска процедуры импорта нажмите кнопку ОК.

[Подсказка] Подсказка

Импорт слоя из формата SHP можно произвести с помощью метода ZuluTools.ImportFromShape.


Импорт из формата Metafile WMF

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

Для импорта графической информации из формата Metafile WMF:

  1. Выберите пункт главного меню Файл|Импорт|Metafile WMF. На экране появится стандартный диалог выбора файла, в нем укажите файл формата WMF, который требуется импортировать.

  2. В окне импорта в строке Имя слоя с помощью кнопки [image] задайте имя файла и размещение его на диске.

  3. В строке Название слоя задайте пользовательское название слоя.

  4. В том случае, если импортированный слой надо сразу добавить в текущую карту, установите опцию добавить в карту.

  5. Нажмите ОК для выполнения процедуры импорта.


Импорт из формата GPX

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

В настоящей версии системы возможен импорт данных из файлов в формате GPX (GPS eXchange Format). Это текстовый формат хранения и обмена данными GPS , основанный на XML. Импортируется геометрия и атрибуты треков и путевых точек.

Для импорта из формата GPX надо:

  1. Выбрать пункт главного меню Файл|Импорт|GPS eXchange Format. На экране появится стандартный диалог, в нем необходимо указать файл для импорта.

  2. В окне импорта в строке Имя слоя с помощью кнопки [image] задать имя файла и указать его размещение на диске.

  3. В строке Название слоя задать пользовательское название слоя.

  4. Из списка Таблица указать источник данных, где будут создаваться табличные данные.

  5. В том случае, если импортированный слой требуется сразу добавить в текущую карту, то надо установить опцию добавить в карту.

  6. Нажать ОК для выполнения процедуры импорта.

В результате импорта будет создан векторный слой, в структуру которого будут добавлены типовые объекты, и создана база данных.

Также система имеет возможность открывать файл хранения и обмена данными GPS в формате GPX (GPS eXchange Format) как один из слоев ZuluGIS, как локально, так и опубликованный на ZuluServer. После открытия файла на карте будут отображены треки и путевые точки. По трекам, точкам трека и путевым точкам можно получить связанные с ними данные.

Для загрузки файла с данными GPS в формате GPX (GPS eXchange Format) следует:

  1. Открыть карту (если еще не открыта).

  2. Выбрать пункт главного меню Карта|Добавить слой или нажать на панели инструментов кнопку [image] .

  3. В появившемся диалоговом окне Выбор слоя в списке Тип файлов выбрать строку GPS eXchange Format (*.gpx).

  4. Левой кнопкой мыши указать файл, нажать кнопку Открыть.

После выбора произойдет загрузка слоя в текущую карту. Загруженный слой добавляется в конец списка слоев карты.


Импорт треков из OziExplorer PLT

Настоящая версия позволяет импортировать в слой ZuluGIS треки формата *.plt. Треки будут импортированы в виде типовых символьных объектов, расставленных по маршруту.

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

Для импорта треков надо:

  1. Выбрать пункт главного меню Файл|Импорт|из OziExplorer PLT. На экране появится стандартный диалог, в нем необходимо указать файл для импорта.

  2. В окне импорта в строке Имя слоя с помощью кнопки [image] надо задать имя файла и указать его размещение на диске.

  3. В строке Название слоя задать пользовательское название слоя.

  4. Из списка Таблица указать источник данных, где будут создаваться табличные данные.

  5. В том случае, если импортированный слой требуется сразу добавить в текущую карту, то надо установить опцию добавить в карту.

    Диалоговое окно «Импорт из PLT»

    Рисунок 1050. Диалоговое окно «Импорт из PLT»

  6. Нажать ОК для выполнения процедуры импорта.

Рисунок 1051. Результат импорта


Импорт из формата KML, KMZ

Система позволяет импортировать данные из файлов в формате Google Earth KML и KMZ (сжатый KML). В настоящее время импортируется геометрия объектов и их атрибуты.

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

Для импорта графической информации из формата KML, KMZ надо:

  1. Выбрать пункт главного меню Файл|Импорт|Google Earth KML. На экране появится стандартный диалог, в нем необходимо указать файл для импорта.

  2. В окне импорта в строке Имя слоя с помощью кнопки [image] надо задать имя файла и указать его размещение на диске.

  3. В строке Название слоя задать пользовательское название слоя.

  4. Из списка Таблица указать источник данных, где будут создаваться табличные данные.

  5. При необходимости импортировать только графическую часть данных установить опцию Импортировать только геометрию.

  6. Для добавления импортированного слоя в текущую карту надо установить опцию Добавить в карту.

  7. Нажать ОК для выполнения процедуры импорта.


Импорт из таблицы

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

С помощью данной операции можно преобразовать табличные данные (*.db), имеющие координатную привязку, в слой ZuluGIS с расставленными по координатам таблицы символьными объектами.

Для успешного импорта необходимо наличие в таблице как минимум двух полей, в одном из которых будут записаны значения широты, а в другом – долготы.

Для импорта надо:

  1. Выбрать меню Файл|Импорт|Из таблицы.

  2. В появившемся окне указать таблицу для импорта, формат ее должен быть *.db.

  3. Для выбора проекции табличных данных с правой стороны от сроки Проекция нажать кнопку Выбрать... и указать проекцию (по умолчанию Широта/Долгота WGS 84).

  4. Из открывающихся списков выбрать поля с Широтой и Долготой, соответственно.

  5. Справа от строки Слой для записи нажать кнопку Обзор... и задать каталог и название для создаваемого слоя (название желательно задавать латиницей). Строкой ниже можно задать пользовательское название слоя.

  6. При импорте имеется возможность изменить проекцию для импортируемого в ZuluGIS слоя, для задания новой проекции надо с правой стороны от сроки Проекция слоя нажать кнопку Выбрать... и указать новую (по умолчанию здесь будет указана точно такая же проекция, как у таблицы).

  7. В результате импорта имеется возможность к символьным объектам привязать базу данных с данными из таблицы. Для этого надо из открывающегося списка Источник данных указать источник для создаваемой базы, а в разделе Поля таблицы галочками отметить поля для импорта. По умолчанию указаны все поля таблицы.

  8. Если необходимо, чтобы после импорта слой был загружен в текущую карту, то надо отметить опцию Добавить в карту.

  9. Для запуска процедуры импорта нажать кнопку ОК.

Импорт из таблицы

Рисунок 1052. Импорт из таблицы

Рисунок 1053. Результат импорта


Импорт из QGIS

Импорт проектов, разработанных в свободно распространяемой ГИС QGIS (Quantum GIS).

При импорте поддерживаются символы, цвета, стили линий, заливки.

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

Для импорта надо:

  1. Выбрать меню Файл|Импорт|GGIS QGC.

  2. В появившемся диалоге выбора указать файл для импорта в формате *.qgc.

  3. Откроется окно импорта из QGIS. Из списка Таблица указать источник данных, где будут создаваться табличные данные.

    Окно Импорт из QGIS

    Рисунок 1054. Окно Импорт из QGIS

  4. Нажать кнопку Обзор... и задать каталог и название создаваемой карты Zulu. Карта будет содержать слои и настройки проекта QGIS.

  5. Чтобы сразу после процедуры импорта карта открылась, установить опцию Открыть карту.

  6. Нажать ОК для выполнения процедуры импорта.


Импорт из GeoJSON

GeoJSON – открытый формат, предназначенный для хранения географических структур данных.

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

Для импорта надо:

  1. Выбрать меню Файл|Импорт|GeoJSON.

  2. В появившемся диалоге выбора указать файл для импорта в формате *.geojson. Откроется окно импорта из GeoJSON.

  3. Нажать кнопку Обзор..., задать имя для импортированного файла и указать его размещение на диске.

  4. Из списка Таблица указать источник данных, где будут создаваться табличные данные.

    Окно Импорт из GeoJSON

    Рисунок 1055. Окно Импорт из GeoJSON

  5. Если требуется импортировать только геометрию, то установить соответствующую опцию.

  6. Для добавления импортированного слоя в открытую карту установить опцию Добавить в карту.

  7. Нажать кнопку ОК, чтобы подтвердить импорт.


Импорт растровых данных из MapInfo, OziExplorer и объектов формата ESRI World File

Имеется возможность импортировать описатели из файлов с привязкой *.tab (MapInfo), *.map (OziExplorer) и данные растровых объектов в формат ESRI World File. В том случае, если в файлах содержится информация о картографической проекции, то она также будет импортирована. Чтобы растры были успешно импортированы, их описатели должны храниться в одной папке. Для формата ESRI World File проекция должна содержаться в файле с тем же именем и расширением aux.xml.

[Примечание] Примечание

Видеоурок по импорту растровых данных можно посмотреть, пройдя по одной из ссылок: https://youtu.be/aLgk5dFVbhw или https://www.politerm.com/videos/raster/import-i-eksport-rastrovykh-dannykh/.

[Примечание] Примечание

Возможно добавить растровые данные сторонних программ для просмотра и без импорта, но если в дальнейшем планируется с ними работать, то рекомендуется их перевести в формат описателей ZuluGIS (*.zrs) с помощью операции преобразования или с помощью ниже описанного импорта.

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

Чтобы импортировать данные, надо:

  1. Выбрать меню Растр|Импорт/Экспорт|Импортировать описатели.

  2. В появившемся диалоге выбора сначала из списка Тип файлов выбрать тип импортируемых данных. Затем указать один или несколько файлов для импорта.

  3. Для монохромных данных возможно настроить цвета линий и заливки. Чтобы настроить цвет, надо установить опцию Использовать цвет 1 или Использовать цвет 2 и из палитры выбрать нужный цвет.

  4. Если в растре есть белый цвет, то возможно его сделать прозрачным, для этого надо установить опцию Прозрачный белый.

  5. Возможно настроить прозрачность растров, она устанавливается в процентном соотношении в соответствующем окне. Возможно использование прозрачного белого или общей прозрачности растра, использование одновременно обеих опций не предусмотрено.

    Импорт описателей растровых объектов

    Рисунок 1056. Импорт описателей растровых объектов

  6. Если исходные растры не *.bmp формата, то рекомендуется установить в опцию Преобразовать в BMP. При использовании данной опции в результате импорта будут сформированы растры формата *.bmp и постоянный кэш к ним (исходные растры останутся нетронутыми). Именно новые сформированные растры будут использованы в дальнейшей работе, для ZuluGIS такой формат является рабочим, что позволяет значительно ускорить работу с растровыми данными

  7. В том случае, если импортируется много растровых слоев, то рекомендуется объединить их в растровую группу. Для этого надо поставить опцию Создать группу и в окошке справа задать ей название.

  8. Для того чтобы указать папку, в которую будет сохранен результат импорта, надо нажать кнопку Обзор.... Папка может быть указана как на локальной машине, так и на сервере. Для указания папки на сервере надо в окне Выбор папки нажать кнопку [image] Серверы геоданных.

    При указании папки на локальной машине необходимо четко понимать, какая папка указывается, так как если не была установлена опция Преобразовать в BMP, то в результате импорта в указанной папке создадутся описатели растровых объектов с расширением *.zrs, которые будут ссылаться на растры из исходной папки. Такая ситуация в дальнейшем может привести к путанице при перемещении файлов. При указании папки на сервере в результате импорта на сервере будут созданы описатели растров формата *.zrs и скопированы исходные растры или растры формата *.bmp при установке соответствующей опции.

  9. Чтобы результат импорта был загружен в текущую карту, установите опцию Добавить в карту.

  10. Для завершения импорта нажмите кнопку ОК.

[Примечание] Примечание

Растровые описатели ZuluGIS (*.zrs) могут быть экспортированы в форматы описателей растровых объектов в форматы Mapinfo, OziExplorer, ESRI World File.


Импорт GeoTIFF в растровый слой ZuluGIS

Для успешного импорта в файлах GeoTIFF обязательно должна содержаться информация об их привязке. В результате импорта будут получены растровые слои, имеющие географическую привязку, и растровая группа из них. В исходной папке создается папка zrs, в которую сохраняется результат импорта.

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

Чтобы импортировать данные, надо:

  1. Выбрать меню Растр|Импорт/Экспорт|Импорт GeoTIFF в растровый слой Zulu.

  2. В появившемся диалоге справа от строки Папка с файлами изображений нажать кнопку Обзор... и указать папку в которой содержаться файлы GeoTIFF для импорта.

  3. После выполнения предыдущего этапа в окне Файлы будет отображен список файлов GeoTIFF, находящихся в указанной папке. Если выделить файл в списке, то справа будет отображена информация по нему, считанная системой. Для импорта файла необходимо установить слева от него галочку и при необходимости изменить параметры справа:

    • Папка для записи растров – по умолчанию в исходной папке создается папка zrs, в которую будет сохранен результат импорта, для сохранения данных в другое место справа надо нажать кнопку ... и указать новую папку;

    • Ширина части растра – указывается ширина плиток в пикселах, на которую будет производиться нарезка растров;

    • Высота части растра – указывается высота плиток в пикселах, на которую будет производиться нарезка растров;

    • Постоянный кэш – данную опцию следует установить, если необходимо создавать постоянные кэш-файлы для результата объектов; поставьте флажок (создание постоянного кэш-файла ускоряет загрузку объектов в карту).

    Окно импорта GeoTIFF в растровый слой ZuluGIS

    Рисунок 1057. Окно импорта GeoTIFF в растровый слой ZuluGIS

  4. Чтобы после импорта результат загрузился в активную карту, следует установить опцию Добавить в карту.

  5. Для запуска импорта нажмите кнопку ОК.


Импорт XML-документов Росреестра

Для успешного импорта документов Росреестра файлы XML должны соответствовать одной из следующих схем:

  • extract_cadastral_plan_territory;

  • extract_about_property_land;

  • kpt;

  • kvoks;

  • tp;

  • mp;

  • kvzu;

  • extract_about_property_construction;

  • Region_Cadastr;

  • TerritoryToGKN.

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

Импортировать можно как один файл, так и одновременно несколько файлов.

Для импорта:

  1. Выберите меню Файл|Импорт|XML Росреестр.

  2. В появившемся диалоге выбора укажите один или несколько файлов для импорта формата *.xml.

  3. В окне импорта из XML нажмите кнопку Обзор... и укажите папку, в которую будет сохранен результат импорта. При импорте одного файла возможно также задать имя для импортированного файла.

  4. Если импортируется один файл, то в окне Название слоя имеется возможность указать пользовательское название для созданного после импорта слоя.

  5. Из списка Таблица выберите источник данных, где будут создаваться табличные данные.

    Окно Импорт из XML при импорте одного файла

    Рисунок 1058. Окно Импорт из XML при импорте одного файла

    Окно Импорт из XML при импорте нескольких файлов одновременно

    Рисунок 1059. Окно Импорт из XML при импорте нескольких файлов одновременно

  6. Для импорта информации о проекции установите соответствующую опцию.

  7. Для перевода импортируемых данных в проекцию Широта/Долгота WGS-84 установите соответствующую опцию. Если опция не выбрана, то в результате будет план-схема с исходными координатами.

  8. Чтобы добавить результат импорта в открытую карту, установите опцию Добавить в карту.

  9. Для подтверждения импорта нажмите кнопку ОК.

На рисунке ниже представлен результат импорта: векторный слой с табличными данными.

Результат импорта из XML формата

Рисунок 1060. Результат импорта из XML формата


Импорт текста с разделителями

Операция позволяет импортировать данные из текстового формата *.csv или *.txt. В результате импорта система расставит объекты в слое по указанным в файле координатам.

В импортируемом файле для успешного результата могут содержаться следующие данные:

  • строка WKT (Well-known text) – WKT является текстовым форматом представления векторной геометрии и описания систем координат, результатом импорта будут расставленные в соответствии с координатами указанные в файле фигуры, такие как полигоны, полилинии и другие;

  • координаты X, Y – значения широты и долготы, результатом импорта будут расставленные в соответствии с координатами символы.

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

Для импорта надо:

  1. Выбрать меню Файл|Импорт|Текст с разделителями CSV, TXT.

  2. В появившемся окне указать файл для импорта формата *.csv или *.txt, нажать кнопку Открыть.

  3. Справа от строки Имя слоя нажать кнопку Обзор... и задать каталог и название для создаваемого слоя. Строкой ниже можно задать пользовательское название слоя, по умолчанию оно точно такое же, как имя файла слоя.

  4. В открывшемся окне в списке Разделитель полей необходимо выбрать разделитель, который используется в данных.

  5. Если строковые значения заключены в кавычки, то в списке Ограничитель текста надо выбрать тип кавычек (двойные или одинарные), при отсутствии ограничителя установить параметр {отсутствует}.

  6. Выбрать кодировку данных.

  7. Если первая строка текстового файла содержит названия полей, то надо установить флажок Первая строка содержит имена полей.

  8. Установить переключатель в зависимости от исходных данных:

    • WKT;

    • XY.

  9. В соответствии с установленным на предыдущем этапе переключателем выбрать из списка Поле или Поле X, Поле Y столбцы с координатами объекта, определяемые параметрами проекции.

  10. Для выбора параметров проекции карты нажать кнопку Система координат.

  11. Если требуется импортировать только геометрию, установить соответствующую опцию.

  12. В результате импорта имеется возможность привязать базу данных с данными из таблицы к создаваемым объектам. Для этого надо из открывающегося списка Таблица указать источник для создаваемой базы. Снизу будет отображена структура создаваемой таблицы.

  13. Для добавления импортированного слоя в текущую карту следует установить опцию Добавить в карту.

    Импорт текста с разделителями

    Рисунок 1061. Импорт текста с разделителями

  14. Нажатие кнопки ОК запустит процедуру импорта.

Результат импорта на карте с загруженным слоем OpenStreetMap

Рисунок 1062. Результат импорта на карте с загруженным слоем OpenStreetMap

Ниже рассмотрен импорт файла с данными формата WKT. В файле содержится векторная геометрия и описание систем координат в виде текста. В результате импорта требуется получить слой с полигонами кадастра и привязанной к ним заполненной базой данных.

Пример одной строчки из исходного файла:

"78:40:0019103:36","06", "7057537.52", "1502.0", "003002000000",
"для размещения индивидуального жилого дома (индивидуальных жилых домов)",
"MULTIPOLYGON (((29.9495877626394030 59.8748107688004510, 29.9503900503325370 59.8747298436313640,
29.9504911722216180 59.8750413428645560, 29.9498106887995340 59.8750904511623570, 29.9497595741696860
59.8751251680152170, 29.9495877626394030 59.8748107688004510)))"

Как видно, строка содержит разделитель полей , и ограничитель текста ", используется кодировка UTF-8.

Импорт текста с разделителями

Рисунок 1063. Импорт текста с разделителями

Рисунок 1064. Результат импорта


Импорт из формата LAS

Операция позволяет импортировать данные из формата *.las. Формат LAS (LASer) был разработан американской организацией ASPRS (American Society for Photogrammetry and Remote Sensing) и предназначен для обмена и архивирования данных облака лидарных (лазерных) точек. Лидар (Lidar – Light Identification, Detection and Ranging) – это метод, позволяющий измерять расстояние до цели путем освещения цели лазерным светом и измерением отраженного света датчиком. Различия во времени возврата и длине волны лазера могут затем использоваться для создания цифрового трехмерного представления цели. Результат лидарной съемки представляет собой наборов данных, содержащих облака точек.

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

В результате импорта данных будет получен слой в виде точек с указанным шагом и базой данных с высотными отметками каждой точки. Так как файл содержит на одну точку в плане сотни точек, то в качестве точки рельефа берется точка с меньшим значением высотной отметки. После импорта имеется возможность на основании данных построить слой рельефа для получения триангуляционной сетки, в которой в каждой точке будет задано значение высоты. Далее по модели рельефа возможно построение изолиний.

[Примечание] Примечание

Видеоурок по импорту данных из формата *.las можно посмотреть, перейдя по ссылке https://www.youtube.com/watch?v=qCDNk_s5jzE.

Для импорта надо:

  1. Выбрать меню Файл|Импорт|LAS lidar point data.

  2. В появившемся окне указать файл для импорта формата *.las, нажать кнопку Открыть.

  3. Справа от строки Имя слоя нажать кнопку Обзор... и задать каталог и название для создаваемого слоя. Строкой ниже можно задать пользовательское название слоя, по умолчанию оно точно такое же, как имя файла слоя.

  4. Из списка Таблица указать источник данных, где будут создаваться табличные данные.

  5. Если установлена опция Добавить в карту, то импортированный слой будет добавлен в текущую карту.

  6. Для запуска импорта нажать кнопку ОК.

Импорт из формата LAS

Рисунок 1065. Импорт из формата LAS


Импорт данных с веб-сервисов трекинга

Операция позволяет импортировать треки с веб-сервисов системы мониторинга. Поддерживаются следующие веб-сервисы мониторинга:

  • Wialon

  • Omnicomm

  • Fort Monitor

[Примечание] Примечание

После того как вы импортировали данные, для того чтобы совместить их с остальными слоями, возможно, потребуется назначить слою новую проекцию или изменить существующую. Как это сделать, вы можете узнать здесь.

Для импорта:

  1. Выберите меню Файл|Импорт|Web-сервисы трекинга.

  2. В открывшемся окне из списка Web-сервисы трекинга выберите веб-сервис, данные с которого будут импортированы.

  3. В разделе Авторизация введите Токен для веб-сервиса Wialon или Логин и Пароль для веб-сервисов Omnicomm или Fort Monitor.

  4. Нажмите кнопку Соединиться. В разделе Объекты отобразится список зарегистрированных объектов.

  5. С помощью галочек выберите объекты для импорта.

  6. Укажите интервал, за который будет производиться импорт.

  7. Нажмите кнопку Обзор... и выберите папку для записи результата импорта.

  8. Из списка Таблица выберите источник данных для таблиц.

  9. Если установить опцию Добавить в карту, то импортированные слои будут добавлены в текущую карту.

    Импорт треков из веб-сервисов трекинга

    Рисунок 1066. Импорт треков из веб-сервисов трекинга

  10. Для запуска импорта нажмите кнопку ОК.

Результат импорта на карте

Рисунок 1067. Результат импорта на карте


Экспорт в формат DXF

Векторные слои возможно экспортировать в формат DXF – открытый формат файлов для обмена графической информацией между приложениями САПР. Поддерживается практически всеми CAD-системами, например, такими как AutoCAD, Компас, nanoCAD и т.д.

[Подсказка] Подсказка

Используйте опции Экспортировать бирки и Брать стиль текущих тематических раскрасок для экспорта подключенных надписей и использования стиля тематических раскрасок.

При экспорте карты в формат DXF возможна подстановка блоков, стилей линий и текста, а также слоев AutoCAD взамен соответствующих элементов карты ZuluGIS. Подробнее об этом можно узнать в подразделе «Настройка подстановки при экспорте в формат DXF».

Для экспорта графической информации в формат DXF:

  1. Выберите пункт главного меню Файл|Экспорт|AutoCAD DXF. В открывшемся диалоге экспорта в поле Карта отображается название экспортируемой карты ZuluGIS.

    Диалог экспорта в DXF

    Рисунок 1068. Диалог экспорта в DXF

  2. В области Слои установите флажки у слоев, которые требуется экспортировать, или установите флажок Все, чтобы выбрать все слои. Для того, чтобы экспортировать только выделенные объекты карты, установите флажок Только выделенные объекты (объекты должны быть выделены заранее).

  3. Для экспорта подключенных надписей (бирок) установите опцию Экспортировать надписи. Надписи будут записаны в отдельный слой (внутри .dxf файла). Если требуется экспорт каждого вида надписи в отдельный слой, установите дополнительно опцию Разделять надписи в dxf по слоям.

  4. По умолчанию система экспортирует данные без стилей подключенных тематических раскрасок. Для экспорта с темами установите опцию Брать стиль текущих тематических раскрасок.

  5. В поле Файл DXF укажите путь и имя создаваемого файла DXF. Для этого нажмите кнопку [image] справа от поля и задайте требуемый путь и имя файла в стандартном файловом диалоге.

  6. При необходимости подстановки блоков и стилей линий укажите путь к файлу параметров подстановки в поле Файл CFG.

  7. Нажмите кнопку Система координат и в открывшемся диалоговом окне из открывающегося списка выберите систему координат для экспорта. По умолчанию система подставляет проекцию карты. Для корректного экспорта данных необходимо, чтобы была указана проекция, которая не имеет графических искажений экспортируемой области. Например, Гаусса-Крюгера в соответствии с центральным меридианом или соответствующая МСК. Подтвердите выбор системы кнопкой ОК.

  8. Нажмите кнопку ОК. Выбранные слои карты будут преобразованы и сохранены в указанном файле DXF.


Настройка подстановки при экспорте в формат DXF

Для выполнения подстановки элементов чертежа AutoCAD вместо элементов карты ZuluGIS при экспорте в DXF используется шаблон – чертеж формата DXF , в котором заданы элементы (блоки, стили линий и текста, слои), на которые заменяются соответствующие элементы карты ZuluGIS. В файле конфигурации экспорта в DXF (указывается в диалоге экспорта) настраиваются соответствия между элементами карты ZuluGIS и элементами подстановки в шаблоне.

Для создания и/или редактирования файла конфигурации экспорта можно воспользоваться мастером по редактированию файлов конфигурации экспорта в DXF.

Чтобы создать новый пустой файл конфигурации, в диалоге экспорта в DXF (рис. выше) нажмите кнопку Новый, если файл уже существует и задан в диалоге экспорта, его можно отредактировать, для этого нажмите кнопку Редактировать.


Мастер редактирования файлов конфигурации экспорта в DXF

Если мастер был вызван для создания новой конфигурации экспорта, то сначала необходимо задать путь к файлу шаблона в формате DXF, из которого будут браться данные для подстановок.

Красным цветом выделяются записи, отсутствующие в исходном файле конфигурации, если при вызове мастера был выбран режим редактирования существующей конфигурации.


Вкладка Слои

В данной вкладке задается соответствие экспортируемых слоев ZuluGIS слоям AutoCAD.

Диалог настройки конфигурации экспорта в DXF. Вкладка Слои

Рисунок 1069. Диалог настройки конфигурации экспорта в DXF. Вкладка Слои

В столбце Слой Zulu находится список экспортируемых слоев ZuluGIS. В столбце Слой DXF можно выбрать из выпадающего списка или заполнить вручную соответствующую подстановку слоя AutoCAD.


Вкладка Слои(Типы/режимы)

В ней задается соответствие экспортируемых типовых объектов слоя ZuluGIS слоям AutoCAD.

Диалог настройки конфигурации экспорта в DXF. Вкладка Слои (Типы/режимы)

Рисунок 1070. Диалог настройки конфигурации экспорта в DXF. Вкладка Слои (Типы/режимы)

Столбец Тип/Режим Zulu содержит список экспортируемых типовых объектов ZuluGIS. Жирным шрифтом выделяются названия типовых объектов, под ними выводятся их режимы. В столбце Слой DXF можно выбрать из выпадающего списка или ввести вручную соответствующий слой AutoCAD.

Имеется возможность задать экспорт в выбранный слой типового объекта независимо от режима или указать целевой слой AutoCAD для конкретного режима типового объекта. Если задано хотя бы одно соответствие режима типового объекта ZuluGIS слою AutoCAD, то подстановка будет осуществляться только для заданных режимов этого объекта, все режимы, для которых не задано соответствие, будут экспортироваться без подстановки.


Вкладка Стили линий

Вы можете задать соответствие экспортируемых стилей линий слоя ZuluGIS стилям линий AutoCAD.

Диалог настройки конфигурации экспорта в DXF. Вкладка Стили линий

Рисунок 1071. Диалог настройки конфигурации экспорта в DXF. Вкладка Стили линий

Столбец Стиль линии Zulu содержит список экспортируемых стилей линий ZuluGIS. В столбце Стиль линии DXF можно выбрать из выпадающего списка или ввести вручную соответствующий стиль линии AutoCAD.


Вкладка Шрифты

Во вкладке Шрифты имеется возможность задать соответствие шрифтов экспортируемых текстовых объектов слоя ZuluGIS стилям текста AutoCAD.

Диалог настройки конфигурации экспорта в DXF. Вкладка Шрифты

Рисунок 1072. Диалог настройки конфигурации экспорта в DXF. Вкладка Шрифты

Столбец Шрифт Zulu содержит список шрифтов экспортируемых текстовых объектов ZuluGIS. В столбце Стиль текста DXF можно выбрать из выпадающего списка или ввести вручную соответствующий стиль текста AutoCAD.


Вкладка Символы

С помощью данной вкладки можно задать соответствие экспортируемых символьных объектов слоя ZuluGIS блокам AutoCAD.

Диалог настройки конфигурации экспорта в DXF. Вкладка Символы

Рисунок 1073. Диалог настройки конфигурации экспорта в DXF. Вкладка Символы

Столбец Символьный объект Zulu содержит список экспортируемых символьных объектов ZuluGIS. В столбце Блок DXF можно выбрать из выпадающего списка или ввести вручную соответствующий блок AutoCAD.


Вкладка Типы

Позволяет задать соответствие режимов объектов слоя ZuluGIS и блоков AutoCAD. В нижней таблице имеется возможность задать соответствие семантической информации из базы данных для каждого режима типового объекта атрибутам блока AutoCAD.

Столбец Тип Zulu содержит список экспортируемых типовых символьных объектов ZuluGIS. В столбце Блок DXF можно выбрать из выпадающего списка или ввести вручную соответствующий блок AutoCAD.

Диалог настройки конфигурации экспорта в DXF. Вкладка Типы

Рисунок 1074. Диалог настройки конфигурации экспорта в DXF. Вкладка Типы


Вкладка Общие параметры

С помощью данной вкладки можно выбрать общие параметры экспорта.

Диалог настройки конфигурации экспорта в DXF. Вкладка Общие параметры

Рисунок 1075. Диалог настройки конфигурации экспорта в DXF. Вкладка Общие параметры

Экспорт заливок – если параметр задан, то вместо залитых полигонов в формат DXF экспортируются их границы, если параметр не задан, то экспорт залитых полигонов выполняется без их изменения.

Вставка блоков без масштабирования – если параметр задан, то вставка блоков в чертеж DXF проходит с масштабом 1:1, без учета размера исходного объекта слоя ZuluGIS.

Относительный путь для шаблона DXF – если параметр задан, в файле конфигурации сохраняется относительный путь к файлу шаблона DXF, если параметр не задан – сохраняется полный путь.


Формат файла конфигурации

Файл конфигурации имеет следующий формат:

  • Файл разбит на секции. Секция начинается со строки <НАЗВАНИЕ>, где НАЗВАНИЕ – это название этой секции, а заканчивается она строкой </НАЗВАНИЕ>.

  • Секции могут содержать вложенные секции и параметры.

  • Параметры имеют формат НАЗВАНИЕ_ПАРАМЕТРА: ЗНАЧЕНИЕ_ПАРАМЕТРА.

  • Конфигурационный файл может также содержать строки комментариев, комментарий начинается со знака «#».

Параметры подстановки задаются в секции template-dxf. Секция содержит параметр filename, в котором задается путь к файлу шаблона в формате DXF, и вложенные секции, в которых задаются параметры подстановки:

  • layers – параметры соответствия слоев AutoCAD в шаблоне слоям карты ZuluGIS или группировка типов объектов ZuluGIS по слоям AutoCAD;

  • line-styles – соответствие стилей линий;

  • font-styles – соответствие шрифтов в карте ZuluGIS стилям текста в шаблоне;

  • symbols – соответствие символов ZuluGIS блокам AutoCAD в шаблоне.


Секция options

В секции задаются общие параметры экспорта:

  • NoFilledPolygons – если для параметра задано значение «on», то вместо залитых полигонов в формат DXF экспортируются их границы, если для параметра задано другое значение (или параметр не задан), то экспорт залитых полигонов выполняется без их изменения.


Секция layers

Секция layers состоит из подсекций layer, каждая из которых описывает подстановку одного из слоев. Предусмотрено три вида подстановки – сохранение данных заданных слоев ZuluGIS в слой AutoCAD, группировка нескольких типов объектов из карты ZuluGIS в определенном слое AutoCAD и сохранение указанных режимов объектов в слое AutoCAD. В одной секции layer могут совмещаться подстановки всех перечисленных типов.

В секции layer задается параметр dxflayername, в котором указывается название слоя в DXF и параметры подстановки слоев и объектов.

Для задания сохранения слоев ZuluGIS в слое AutoCAD в секции layer задаются параметры:

  • countZululayers – количество слоев, сохраняемых в указанном слое;

  • Zululayer1…ZululayerN – имена слоев ZuluGIS, сохраняемых в слое AutoCAD.

Для задания группировки типов объектов в слой AutoCAD в секции layer задаются следующие параметры:

  • countZulutypes – количество типов объектов Zulu, добавляемых в указанный слой;

  • Zulutype1… ZulutypeN – названия типов объектов ZuluGIS, добавляемых в слой AutoCAD.

Для задания сохранения выбранных режимов объекта ZuluGIS в слое AutoCAD в секции layer создается подсекция objectmode со следующими параметрами:

  • Zulutype – тип объекта ZuluGIS, для которого выполняется подстановка;

  • countmodes – количество режимов, которые подставляются в данный слой;

  • mode1…modeN – названия режимов объекта, сохраняемых в слое AutoCAD.


Секция line-styles

Секция line-styles состоит из подсекций line-style, в каждой из которых задается соответствие одного из стилей линий карты ZuluGIS стилю линий AutoCAD, заданному в шаблоне.

В секции line-style задаются два параметра: Zuluname – название стиля линий в ZuluGIS и dxfname – название стиля линий в шаблоне.


Секция font-styles

Секция font-styles состоит из подсекций font-style, в каждой из которых задается соответствие одного из шрифтов, используемого в карте ZuluGIS, стилю текста AutoCAD, заданному в шаблоне.

В секции font-style задаются два параметра: Zuluname – название шрифта в карте ZuluGIS и dxfname – название стиля текста в шаблоне.


Секция symbols

Секция symbols состоит из подсекций symbol, в каждой из которых задается соответствие одного из символов в карте ZuluGIS блоку AutoCAD, заданному в шаблоне.

В секции symbol задаются два параметра: Zuluname – название символа в карте ZuluGIS и dxfname – название блока в шаблоне.


Секция types

Секция types состоит из подсекций typedsymbol, в каждой из которых задается соответствие типового символьного объекта слоя ZuluGIS блоку AutoCAD, заданному в шаблоне, и может содержать параметры соответствия семантической информации из базы данных типового объекта атрибутам блока AutoCAD.

В секции typedsymbol задаются два параметра: Zuluname – название типового символьного объекта слоя ZuluGIS и dxfname – название блока в шаблоне.

Соответствие семантической информации атрибутам блока задается в секциях attrib двумя параметрами: zuluname – имя поля семантической базы типового символьного объекта слоя ZuluGIS и dxfname – название атрибута блока в шаблоне.


Пример файла конфигурации

# Файл конфигурации экспорта в формат dxf

<template-dxf>

    filename:template_example.dxf

      <layers>

        <layer>

                dxflayername:газоснабжение

                countZulutypes:3

                Zulutype1:Кран шаровый надземный

                        Zulutype2:Газопровод низкого давления надземный

                        Zulutype3:Изменение диаметра

                </layer>

                <layer>

                        dxflayername:водопровод

                        countZulutypes:2

                        Zulutype1:Колодец водопроводный

                        Zulutype2:Водопровод

                </layer>

                <layer>

                        dxflayername:дороги

                        countZululayers:1

                        Zululayer1:Дороги

                </layer>

                <layer>

                        dxflayername:дома с заливкой

                        countZululayers:1

                        Zululayer1:Здания

                </layer>

        </layers>

        <line-styles>

                <line-style>

                        Zuluname:газопровод

                        dxfname:газопровод

                </line-style>

                <line-style>

                        Zuluname:газопровод на опорах надземный

                        dxfname: газопровод-надземный

                </line-style>

        </line-styles>

        <font-styles>

                <font-style>

                        Zuluname:Arial

                        dxfname:Standard

                </font-style>

                <font-style>

                        Zuluname:Courier

                        dxfname:Standard

                </font-style>

        </font-styles>

        <symbols>

                <symbol>

                        Zuluname:Кран шаровый в надземном исполнении

                        dxfname:60

                </symbol>

                <symbol>

                        Zuluname:Конец газопровода с заглушкой (пробка)

                        dxfname:25

                </symbol>

                <symbol>

                        Zuluname:Колодец водопроводный

                        dxfname:82

                </symbol>

                <symbol>

                        Zuluname:Колодец канализация

                        dxfname:83

                </symbol>

        </symbols>

<types>
 <typedsymbol>

    dxfname:grp1
    zuluname:Регулирующее устройство
    <mode>

        dxfname:grp2
        zuluname:ГРП
        <attrib>

            zuluname:Наименование
            dxfname:num

        </attrib>

    </mode>
    <mode>

        dxfname:grp3
        zuluname:ГРПБ
        <attrib>

            zuluname:Наименование
            dxfname:num

        </attrib>

    </mode>
    <mode>

        dxfname:grp4
        zuluname:ШРП
        <attrib>

            zuluname:Наименование
            dxfname:num

        </attrib>

    </mode>

</typedsymbol>

</types>

</template-dxf>


Экспорт в формат MIF

В настоящей версии системы имеется возможность экспортировать векторные слои в формат MIF. В данном формате могут содержаться как графические данные (объекты), так и описание таблиц данных. Файлы формата MIF могут использоваться, например, таким программным обеспечением, как MapInfo.

Для экспорта информации в формат MIF надо:

  1. Выбрать пункт главного меню Файл|Экспорт|MapInfo MIF. Откроется диалог экспорта, в поле Карта которого отображается название экспортируемой карты ZuluGIS.

    Диалог экспорта в MIF

    Рисунок 1076. Диалог экспорта в MIF

  2. В области Слои необходимо установить флажки у слоев, которые требуется экспортировать. Для того чтобы отметить все слои сразу, можно установить флажок Все.

    Если необходимо экспортировать только определенные объекты, то их предварительно надо выделить и затем в диалоге экспорта установить опцию Только выделенные объекты. В том случае, если объекты выделены в нескольких слоях, требуется таrже указать слой, из которого будет производиться экспорт.

  3. Если требуется экспортировать только графическую информацию, установите опцию Только геометрия.

  4. Для баз данных необходимо выбрать, каким образом будет происходить запись из справочников:

    • значения из справочников – если к полю подключен справочник, то в результате экспорта будут взяты значения из справочников;

    • реальные значения полей – если к полю подключен справочник, то в результате экспорта будут взяты реальные значения полей со справочниками.

  5. В поле Папка надо указать путь к каталогу, в котором будут сохраняться экспортируемые файлы. Для этого воспользуйтесь кнопкой Обзор... справа от поля и задайте требуемый путь в стандартном файловом диалоге.

  6. Нажать кнопку ОК, после чего выбранные слои карты будут преобразованы и сохранены в указанном каталоге.

[Подсказка] Подсказка

Экспорт слоя в формат MIF можно произвести с помощью метода ZuluTools.ExportToMIF.


Экспорт в формат Shape SHP

Векторные слои возможно экспортировать в формат SHP. Это популярный графический формат векторных данных. Он содержит графические данные (объекты), а также может содержать описание таблицы данных, содержащей атрибутивную информацию, связанную с объектами. Используется, например, таким программным обеспечением, как ArcGIS, а также другими ГИС.

Перед началом экспорта откройте карту, слои которой надо экспортировать, затем:

  1. Выберите пункт главного меню Файл|Экспорт|Shape SHP. Откроется диалог экспорта в формат Shape SHP.

    Диалоговое окно «Экспорт в формат SHAPE»

    Рисунок 1077. Диалоговое окно «Экспорт в формат SHAPE»

  2. В списке слои установите галочки напротив экспортируемых слоев. Для того чтобы отметить сразу все слои, установите опцию Все.

  3. Нажмите кнопку Обзор... справа от поля Shape файл. При экспорте одного слоя укажите путь и имя создаваемых SHP файлов. При одновременном экспорте группы слоев укажите только папку для экспорта. Если экспортируемый слой имеет информацию о проекции (не является план схемой), то вместе с SHP файлом будет создан PRJ файл формата WKT с информацией о проекции слоя. Имя PRJ файла аналогично имени SHP файла.

  4. Если установлен флажок Только выделенные объекты, будут экспортируются только выделенные объекты. Если флажок снят, экспортируются все объекты.

  5. Из списка Кодировка выберите кодировку экспортируемого файла.

  6. В группе переключателей Запись справочных значений выберите способ получения данных из базы для полей, в которых используются справочники: Значения из справочников или Реальные значения полей.

  7. Для запуска процедуры экспорта нажмите кнопку ОК.


Экспорт в формат Google KML

Векторные слои возможно экспортировать в формат KML. ZuluGIS позволяет экспортировать весь слой, выделенные объекты или отдельные типы объектов. Формат KML может использоваться таким программным обеспечением, как Google Планета Земля.

Для экспорта информации в KML предварительно загрузите слои для экспорта в карту, затем:

  1. Выберите пункт главного меню Файл|Экспорт|Google KML. Откроется диалог Экспорт в формат KML:

    Диалоговое окно “Экспорт в формат KML”

    Рисунок 1078. Диалоговое окно “Экспорт в формат KML”

  2. В поле Экспортируемый слой выберите слой для экспорта.

  3. В поле KML файл укажите путь и имя создаваемого KML файла. Для этого нажмите кнопку Обзор... справа от поля и задайте требуемый путь и имя файла в стандартном файловом диалоге.

  4. Затем в разделе ниже надо указать типы для экспорта и для каждого типа задать параметры метки и данных. Для экспорта сразу всех объектов слоя достаточно установить галочку напротив строки <Все объекты>.

    В столбце Метка можно выбрать метку, которая будет выводиться на объекте после экспорта (аналог бирок в ZuluGIS), меткой может быть ID объекта или любое поле из базы данных, подключенной к типу. Метка выбирается из открывающегося списка:

    Рисунок 1079. Выбор метки

    Выбор метки напротив строки <Все объекты> будет применен ко всем объектам одновременно.

    В столбце Данные можно указать, будут ли экспортироваться данные из базы, подключенной к объекту. При установленной галочке данные будут экспортироваться, в противном случает нет. Если необходимо экспортировать данные одновременно для всех объектов, то достаточно установить галочку в строке <Все объекты>.

  5. Если предварительно в слое была выделена группа объектов, то будет активна опция Только выделенные объекты. При ее установке будет экспортирована только эта группа.

  6. Для запуска процедуры экспорта нажмите кнопку ОК.

Для примера экспортируем слой, который содержит выделы леса, все объекты в данном слое являются примитивами, к ним подключена база данных. Необходимо, чтобы помимо графических данных экспортировалась семантическая база данных и при этом у каждого объекта отображалась метка с номером выдела.

Для этого в диалоге экспорта указываем слой, а также указываем и задаем местоположение и название для нового файла. Меткой выбираем строку из базы VYDEL и устанавливаем галочку в столбце Данные:

Диалоговое окно Экспорт в формат KML

Рисунок 1080. Диалоговое окно Экспорт в формат KML

Результат:

Экспорт в формат KML

Рисунок 1081. Экспорт в формат KML


Экспорт в SQLite

Экспорт в SQLite позволяет «нарезать» карту на тайловые плитки и сохранить в SQLite базе данных (файл с расширением .sqlite). Операция производится для текущей карты в окне ZuluGIS.

[Примечание] Примечание

Экспорт в SQLite также доступен через Слой|Тайл сервер|Создать, подробнее «Создание данных для Tile-сервера».

Для выполнения экспорта в SQLite:

  1. Выберите команду главного меню Файл|Экспорт|RMaps SQLite.

  2. Укажите место сохранения и название создаваемого файла. Откроется окно создания данных для Tile-сервера:

    Окно создания данных для Tile-сервера. Экспорт в SQLite

    Рисунок 1082. Окно создания данных для Tile-сервера. Экспорт в SQLite

  3. Укажите пользовательское название слоя в соответствующем поле.

  4. В полях Диапазон уровней укажите минимальный и максимальный уровни диапазона кэшируемых тайлов.

  5. В поле Область кэширования укажите, какую часть карты следует кэшировать:

    • текущий вид – отображаемую область в активном окне карты;

    • габариты карты;

    • габариты слоя;

    • объекты слоя.

  6. Если в качестве области кэширования были выбраны габариты слоя или его объектов, в поле Слой требуется выбрать необходимый слой. Также можно установить флажок Только выделенные объекты, чтобы в слое учитывались только выделенные его объекты.

  7. Нажмите кнопку Создать. Процесс может занять значительное время, особенно если выбран большой диапазон уровней.


Экспорт в MBTiles

Экспорт в MBTiles позволяет "нарезать" карту на тайловые плитки и сохранить формате MapBox MBTiles (файл с расширением .mbtiles). Операция производится для текущей карты в окне ZuluGIS.

[Примечание] Примечание

Экспорт в MBTiles также доступен через Слой|Тайл сервер|Создать, подробнее «Создание данных для Tile-сервера».

Для выполнения экспорта в MBTiles:

  1. Выберите команду главного меню Файл|Экспорт|MapBox MBTiles.

  2. Укажите место сохранения и название создаваемого файла. Откроется окно создания данных для Tile-сервера:

    Окно создания данных для Tile-сервера. Экспорт в MBTiles.

    Рисунок 1083. Окно создания данных для Tile-сервера. Экспорт в MBTiles.

  3. Укажите пользовательское название слоя в соответствующем поле.

  4. В полях Диапазон уровней укажите минимальный и максимальный уровни диапазона кэшируемых тайлов.

  5. В поле Область кэширования укажите, какую часть карты следует кэшировать:

    • текущий вид – отображаемую область в активном окне карты;

    • габариты карты;

    • габариты слоя;

    • объекты слоя.

  6. Если в качестве области кэширования были выбраны габариты слоя или его объектов, в поле Слой требуется выбрать необходимый слой. Также можно установить флажок Только выделенные объекты, чтобы в слое учитывались только выделенные его объекты.

  7. Нажмите кнопку Создать. Процесс может занять значительное время, особенно если выбран большой диапазон уровней.


Экспорт в растр (печать в растр)

Настоящая версия ZuluGIS имеет возможность экспортировать изображение карты в растр следующих типов:

  • монохромный рисунок BMP;

  • 256-цветный рисунок BMP;

  • 24-разрядный рисунок BMP;

  • GeoTIFF;

  • JPEG;

  • PNG.

При этом во время экспорта дополнительно могут быть созданы файл привязки с координатами:

  • Zulu (*.zrs);

  • MapInfo (*.tab);

  • OziExplorer (*.map);

  • ESRI World File.

Для экспорта в растр необходимо:

  1. Выбрать пункт главного меню Файл|Экспорт|Печать в растр.

  2. В строке Файл для записи нажать кнопку Обзор... и в открывшемся диалоговом окне указать путь для сохранения и ввести название для растрового файла.

  3. В строке Тип файла выбрать в списке тип создаваемого файла:

    • монохромный рисунок;

    • 256-цветный рисунок;

    • 24-разрядный рисунок;

    • GeoTIFF.

    • JPEG;

    • PNG.

  4. Если при экспорте дополнительно необходимо создать файлы привязки, то установить в разделе Создавать файл привязки нужную опцию:

    • .zrs (Zulu) – для создания файла привязки ZuluGIS;

    • .tab (MapInfo) – для создания файла привязки MapInfo;

    • .map (OziExplorer) – для создания файла привязки OziExplorer (создание файла привязки для OziExplorer возможно только для карты с проекциями Гаусса-Крюгера (Пулково 1942) и Universal Transverse Mercator (WGS 84));

    • ESRI World File – для создания файлов географических данных ESRI.

  5. В разделе Область карты задать границы экспортируемой карты и при необходимости дополнительные параметры:

    • текущий вид – экспортироваться будет область карты, попадающая на всю страницу или заданный диапазон страниц, с указанным масштабом и центром изображения, совпадающим с координатами в центре активного окна карты;

    • вся карта – фрагмент местности будет вычисляться по границам всей карты;

    • фрагмент – будет напечатан отмеченный заранее фрагмент карты, фрагмент можно выделить с помощью кнопки [image] ;

    • по размерам слоя – область печати будет вычисляться по границам слоя. Слой выбирается из открывающегося списка.

      Когда выбрана опция по размерам слоя, возможно дополнительно установить флажок По размерам группы. В этом случае граница печати будет определяется габаритами выделенных объектов указанного слоя.

    • указать – позволяет точно задать границы фрагмента местности. В окошках справа от этого переключателя задаются координаты левого нижнего и правого верхнего углов прямоугольной зоны, которую следует распечатать.

    Кроме вышеперечисленных опций возможно печатать в растр не только все объекты карты, но и определенные объекты, для этого их предварительно необходимо выделить любым известным способом и затем установить флажок Только выделенные объекты.

  6. В разделах Размер растра и Размер документа указать необходимые параметры. Размер растра можно задавать в пикселях, в миллиметрах при заданном разрешении (dpi) или в соответствии с масштабом (1:2000 и т.п.)(если установлена опция Пропорционально, то при изменении параметров пропорции растра будут сохранены).

  7. Нажать ОК для запуска процедуры экспорта.

    Диалоговое окно печати в растр

    Рисунок 1084. Диалоговое окно печати в растр


Экспорт описателей растровых объектов в форматы Mapinfo, OziExplorer, ESRI World File

Используя систему ZuluGIS, можно на основе растрового объекта создавать файлы привязки MAP OziExplorer, Mapinfo и ESRI World File.

[Примечание] Примечание

В OziExplorer возможен экспорт только растров с проекциями Гаусса-Крюгера (Пулково 1942) и Universal Transverse Mercator (WGS 84).

Существует два способа экспорта описателей: через главное меню и через панель привязки растрового объекта. Второй способ подходит для поштучного экспорта описателей растров.

[Примечание] Примечание

Видеоурок по экспорту растровых данных можно посмотреть, пройдя по ссылке: https://youtu.be/aLgk5dFVbhw.

Для экспорта через главное меню надо:

  1. Загрузить растры в карту.

  2. Можно заранее выделить растры для экспорта.

  3. Выбрать меню Растр|Импорт/Экспорт|Экспортировать описатели.

  4. В списке Растровые объекты с помощью галочек указать описатели для экспорта. Если на карте заранее были выделены растры, то список будет состоять только из них. Для отображения всех растров карты надо снять опцию Только выделенные.

  5. Указать формат создаваемого файла:

    • TAB MapInfo;

    • MAP OziExplorer;

    • ESRI World File.

    Диалоговое экспорта описателей

    Рисунок 1085. Диалоговое экспорта описателей

  6. Для запуска процедуры экспорта нажать кнопку ОК.

После завершения экспорта в той же папке, где расположены растры, для каждого описателя растрового объекта будет образован указанный файл привязки.

Для экспорта через панель привязки растрового объекта надо:

  1. Загрузить растр в карту.

  2. Выбрать меню Растр|Привязка.

  3. Из списка Слой выбрать растровый слой для экспорта.

  4. Из списка объект выбрать объект для экспорта.

  5. Нажать кнопку Экспорт.

  6. В появившемся диалоговом окне в строке Имя файла ввести имя для создаваемого файла.

  7. Из списка тип файлов выбрать тип:

    • MapInfo (*.tab) – для экспорта в Mapinfo;

    • OziExplorer (*.map) – для экспорта в OziExplorer;

    • World File Esri (*.bpw, *.bmpw, *.tfw, *.tifw, *.jgw, *.jpgw, *.gfw, gifw, *.pgw, *.pngw) – для экспорта в ESRI World File.

  8. Для запуска экспорта нажать кнопку Сохранить.


Экспорт в GeoJSON

Экспортировать в GeoJSON можно как один слой, так и несколько слоев одновременно. При этом, если заранее выделить объекты, то имеется возможность экспортировать только их. Также можно экспортировать только геометрии объектов без семантических данных.

Для экспорта в GeoJSON надо:

  1. Открыть карту со слоями для экспорта.

  2. Выбрать меню Файл|Экспорт|GeoJSON.

  3. Для экспорта всех слоев карты установить опцию Все. Если требуется экспортировать определенные слои, то установить галочки напротив их.

  4. Если нужен экспорт только выделенных объектов, то установить соответствующую опцию. Объекты должны быть выделены заранее.

  5. Для экспорта только геометрии объектов установить опцию Только геометрия.

  6. Выбрать проекцию для экспорта, проекция выбирается из открывающегося списка Проекция.

  7. В строке Папка нажать кнопку Обзор... и указать путь до создаваемого файла и его название.

    Диалоговое экспорта в GeoJSON

    Рисунок 1086. Диалоговое экспорта в GeoJSON

  8. Для запуска процедуры экспорта нажать кнопку ОК.

После завершения экспорта в указанной папке создаются файлы формата GeoJSON с графическими объектами, и если не установлена опция Только геометрия, будут присутствовать все поля активного запроса и поля по геометрии объектов.


Экспорт проекции слоя

Экспорт проекции слоя возможен в:

  • строку WKT;

  • proj4;

  • Mapinfo.

Экспорт проекции можно произвести или из окна информации по слою или из окна настройки слоя.

В первом случае надо открыть диалог информации, затем нажать кнопку Проекция.. и Экспорт.

Во втором варианте надо открыть окно настройки слоя, вкладка Общие. Далее нажать кнопку ..., расположенную справа от строки Проекция, и кнопку Экспорт.

В результате откроется окно Экспорт проекции, в котором будут указаны данные экспорта. Информацию возможно скопировать в буфер обмена.

Экспорт проекции слоя

Рисунок 1087. Экспорт проекции слоя


Настройка параметров и интерфейса системы

  • «Полноэкранный режим»

  • «Настройка интерфейса»

  • «Настройка параметров системы»

  • «Настройка языка интерфейса»

Система ZuluGIS имеет гибкую настройку параметров и интерфейса. Пользователь имеет возможность самостоятельно настроить, какие окна и панели будут отражаться на экране, какие кнопки будут видны, а также сделать привязку кнопок к макросам, добавить макрос в меню, указать папки для хранения файлов и кэша и т.д.

Также в системе можно настроить интерфейс на разные языки.


Полноэкранный режим

Включение полноэкранного режима позволяет полностью сосредоточиться на карте, чаще всего данный режим используется диспетчерами. В результате его включения на экране будет отображаться только карта, панели инструментов будут скрыты. Для включения полноэкранного режима надо:

  1. Выбрать меню Вид|Во весь экран или нажать кнопку F11.

Чтобы выйти из данного режима, нажмите кнопку F11.

Рисунок 1088. Полноэкранный режим


Настройка интерфейса

  • «Настройка панелей инструментов»

  • «Настройка кнопок панелей инструментов»

  • «Настройка интерфейса для макросов»

  • «Назначение «горячих» клавиш»

  • «Настройка тем и размеров кнопок для отображения панелей инструментов»

  • «Сброс пользовательских настроек интерфейса в исходное состояние»

Основная настройка интерфейса происходит через панель настройки интерфейса. Чтобы ее открыть, выполните команду главного меню Сервис|Настройка интерфейса или щелкните правой кнопкой мыши по любой из панелей инструментов и в контекстном меню выберите пункт Настройка....

Рисунок 1089. Меню «Настройка»

[Примечание] Примечание

При открытии диалога настройки ZuluGIS переходит в режим, когда все кнопки инструментов становятся доступными, то есть те кнопки, которые были заблокированы на момент перехода в этот режим, меняют свой внешний вид на обычный. В этом режиме возможно менять расположение кнопок панелей инструментов простым способом: взять и перетащить, то есть установить курсор на кнопку, которую надо переместить, нажать левую кнопку мыши и, не отпуская ее, переместить курсор в нужно место (надо учесть то, что когда происходит перемещение кнопки, курсор становится невидимым).

[Примечание] Примечание

Для возврата панелей инструментов, плавающих панелей и назначений клавиш в исходный вид и местоположение надо в окне Настройка интерфейса выбрать пункт Дополнительно…| Cброс настроек. Затем установить галочку напротив того объекта, который требуется вернуть в исходное местоположение, и нажать кнопку Сбросить.

Настройка интерфейса, вкладка «Панели инструментов»

Рисунок 1090. Настройка интерфейса, вкладка «Панели инструментов»

Диалог Настройка интерфейса содержит следующие вкладки:

  • Панели инструментов – позволяет создавать и настраивать панели инструментов, отображаемые в рабочем окне программы.

  • Команды – вкладка содержит кнопки для панелей инструментов.

  • Макросы – с помощью данной вкладки можно добавить иконки для кнопок макроса и добавить макрос в меню системы.

  • Клавиатура – позволяет назначить горячие клавиши для определенных команд.

  • Параметры – позволяет настроить внешний вид программы.


Настройка панелей инструментов

  • Перемещение панелей инструментов

  • Скрытие/отображение панели инструментов

  • Создание новой панели

  • Переименование созданной панели

  • Удаление созданной панели

  • Сброс стандартной панели в исходное состояние

Перемещение панели инструментов

Любую панель инструментов возможно переместить. Панель может располагаться как в зоне панелей, так и в любой части экрана. Для перемещения панели:

  1. Подведите курсор к началу панели, она обозначена [image] или [image] или [image] , в зависимости от выбранной темы. Курсор примет вид крестика:

    Перемещение панели инструментов

    Рисунок 1091. Перемещение панели инструментов

  2. Нажмите левую кнопку мыши и, не отпуская ее, переместите панель в нужное место. Отпустите левую клавишу мыши. Если панель после перемещения окажется вне зоны панелей, то у нее появится заголовок с названием и кнопка закрыть х. Для перемещения такой панели подведите курсор к ее заголовку, нажмите левую клавишу мыши и, не отпуская ее, начните перемещение. Для завершения перемещения отпустите левую клавишу мыши.

Скрытие/отображение панели инструментов

Для скрытия/отображения панели инструментов выберите один из вариантов.

1 вариант

  1. Сделайте щелчок правой кнопкой мыши в области панелей инструментов.

  2. В меню откроется список всех панелей инструментов. Напротив панелей, которые отображаются, будет установлен флажок. Если панель скрыта, то, соответственно, флажок будет отсутствовать. Для его установки/снятия сделайте щелчок левой кнопкой мыши по панели.

2 вариант

  1. Откройте диалог Настройка интерфейса. Выберите вкладку Панели инструментов.

  2. Снимите флажок, находящийся слева от названия панели в списке Панели инструментов, для того, чтобы скрыть панель, или установите его для того, чтобы отобразить панель. Для установки или сброса флажка сделайте по нему щелчок левой кнопкой мыши.

Создание новой панели

Для создания новой (изначально пустой) панели инструментов:

  1. Откройте диалог Настройка интерфейса. Выберите вкладку Панели инструментов.

  2. Нажмите кнопку Создать.

  3. В строке Название панели введите название создаваемой панели.

  4. Нажмите кнопку ОК. После произведенных действий в разделе Панели отобразится название новой созданной панели, а в левом верхнем углу рабочей области главного окна отобразиться она сама (пустая панель). С ней можно работать так же, как и со стандартной панелью.

  5. Добавить кнопки в новую панель можно, перейдя во вкладку Команды диалога Настройка интерфейса.

Переименование созданной панели

Каждая панель инструментов имеет свое название, оно отображается в маленьком заголовке панели, когда панель инструментов принимает плавающий вид. Название можно изменять только для созданных пользователем панелей, для остальных панелей это действие заблокировано.

Для переименования созданной панели:

  1. Откройте диалог Настройка интерфейса. Выберите вкладку Панели инструментов.

  2. В разделе Панели инструментов выделите панель левой кнопкой мыши.

  3. Нажмите кнопку Переименовать и в появившемся окне Панель инструментов ввести новое название.

  4. Для подтверждения переименования нажмите кнопку ОК.

Удаление созданной панели

Возможно удаление только созданной пользователем панели инструментов. Для удаления панели:

  1. Откройте диалог Настройка интерфейса. Выберите вкладку Панели инструментов.

  2. В разделе Панели инструментов выделите панель левой кнопкой мыши.

  3. Нажмите кнопку Удалить.

  4. Для подтверждения удаления панели нажмите кнопку Да.

Сброс стандартной панели в исходное состояние

Для возврата панели инструментов к стандартному состоянию, то есть отмены всех изменений, внесенных во внешний вид этой панели:

  1. Откройте диалог Настройка интерфейса. Выберите вкладку Панели инструментов.

  2. В разделе Панели инструментов выделите панель левой кнопкой мыши.

  3. Нажмите кнопку Сброс. Эта команда доступна только для стандартных панелей инструментов и строки меню.


Настройка кнопок панелей инструментов

  • Быстрая смена расположения кнопок инструментов

  • Создание копии кнопки

  • Добавление кнопки или команды на панель инструментов

  • Удаление кнопки инструментов с панели

  • Поиск кнопок или команд

  • Изменение значка и надписи на кнопке

Быстрая смена расположения кнопок инструментов

Для быстрой смены расположения кнопок:

  1. Нажмите клавишу Alt, после чего «захватите» с помощью левой кнопки мыши соответствующую кнопку инструментов.

  2. Далее перемещайте курсор мыши в то место панели инструментов, куда надо переместить кнопку, отпустите левую клавишу мыши, кнопка переместится в новое место.

[Примечание] Примечание

При перетаскивании выбранной кнопки на любое место экрана, не занятое какой-либо панелью инструментов, кнопка будет удалена со своего прежнего места.

Создание копии кнопки

Для копирования кнопки:

  1. Удерживайте вместе клавиши Alt и Ctrl.

  2. Далее, как и в случае перемещения кнопки, «захватите» кнопку и перетащите в новое место на любой панели инструментов. Теперь в указанном месте появится копия выбранной кнопки.

[Примечание] Примечание

При перетаскивании выбранной кнопки на любое место экрана, не занятое какой-либо панелью инструментов, кнопка будет удалена со своего прежнего места.

Добавление кнопки или команды на панель инструментов

Для добавление кнопки или команды на панель инструментов:

  1. Откройте диалог Настройка интерфейса. Выберите вкладку Команды.

    Настройка интерфейса, вкладка «Команды»

    Рисунок 1092. Настройка интерфейса, вкладка «Команды»

  2. В разделе Категории выберите нужную категорию. При выборе элемента в этом списке в окне Кнопки появится набор кнопок и команд из соответствующей категории.

  3. Выберите кнопку или команду в разделе Команды, нажмите левую кнопку мыши и, не отпуская ее, переместите курсор на ту панель инструментов, где требуется вставка элемента. При отпускании кнопки мыши панель инструментов будет увеличена и кнопка добавлена в панель.

Удаление кнопки инструментов с панели

Для удаления кнопки из панели инструментов выберите любой из ниже предложенных вариантов.

1 вариант:

  1. Нажмите клавишу Alt, после чего «захватите» с помощью левой кнопки мыши соответствующую кнопку инструментов.

  2. Далее перемещайте курсор мыши в область свободную от панели инструментов, отпустите левую клавишу мыши, кнопка переместится в новое место.

2 вариант:

  1. Откройте диалог Настройка интерфейса.

  2. Подведите курсор к удаляемой кнопке. Нажмите левую кнопку мыши и, не отпуская ее, перемещайте кнопку в область, свободную от панели инструментов, отпустите левую клавишу мыши, кнопка будет удалена с панели.

Поиск кнопок или команд

Для поиска кнопки или команды по названию надо ввести название в строку Поиск, результаты поиска будут отображены в разделе Команды.

Настройка интерфейса, вкладка «Команды»

Рисунок 1093. Настройка интерфейса, вкладка «Команды»

Изменение значка и надписи на кнопке

Любая кнопка панели инструментов может отображаться в виде значка (рисунка), только текста или совместно значка и текста. Настройка отображения производится выбором соответствующего пункта в контекстном меню. Для вызова контекстного меню надо в режиме настройки интерфейса сделать щелчок правой кнопки мыши на нужной кнопке:

Контекстное меню настройки кнопки

Рисунок 1094. Контекстное меню настройки кнопки

Для любой кнопки можно измененить значок и надпись на ней. Для этого:

  1. В режиме настройки интерфейса сделайте щелчок правой кнопки мыши на нужной кнопке.

  2. В появившемся контекстном меню для смены имени в строке Имя внесите новое имя кнопки.

  3. С помощью пункта Копировать значок на кнопке имеется возможность скопировать значок с другой кнопки, а с помощью пункта Вставить значок для кнопки, соответственно, вставить его. Для вызова редактора картинок выберите пункт Изменить значок на кнопке.

  4. В редакторе Картинка на кнопке в разделе Цвета выберите цвет рисунка, а в разделе Картинка нарисуйте картинку.

    При этом в разделе Просмотр будет отображаться созданная кнопка. С помощью стрелок из раздела Переместить можно сместить картинку в ту или иную сторону.

    Диалог «Картинка на кнопке»

    Рисунок 1095. Диалог «Картинка на кнопке»

  5. Для сохранения и закрытия окна Картинка на кнопке нажмите кнопку ОК.


Настройка интерфейса для макросов

  • Добавление иконки для кнопки макроса

  • Добавление кнопки макроса на панель инструментов

  • Привязка макроса к меню

  • Поиск макросов

Имеется возможность привязать макрос к кнопке панели инструментов, назначить кнопке иконку (картинку) и добавить макрос в пункт главного меню системы. Настройки интерфейса, относящиеся к макросам, производятся во вкладке Макросы диалога Настройка интерфейса.

[Примечание] Примечание

Для выполнения макроса также можно назначить сочетания клавиш.

Настройка интерфейса, вкладка «Команды»

Рисунок 1096. Настройка интерфейса, вкладка «Команды»

[Примечание] Примечание

После назначения макросу кнопки, иконки или привязки макроса к меню в папке, в которой располагается макрос, создается файл *.vbs.uidat, где хранится картинка кнопки и служебная информация. Это позволяет переносить созданные для макросов кнопки с ПК на ПК.

Добавление иконки для кнопки макроса

Иконка может быть добавлена из библиотеки иконок Zulu или создана пользователем самостоятельно. Во втором случае файл с иконкой может быть следующих форматов: *.bmp, *.gif, *.ico, *.jpg, *.jpeg, *.png, *.tif, *.tiff. Для корректного отображения иконки в системе изображение требуется нескольких расширений: 16x16-16 (для классической темы отображения иконок),16x16, 20x20, 24x24, 32x32, 40x40, 48x48, 64x64. Также возможно использование картинок, состоящих сразу из нескольких, длина которых кратна высоте, например, 32*64, 32*96 и т.д.

Такое количество расширений обусловлено индивидуальной настройкой размеров кнопок и панелей инструментов, то есть при определенных настройках будет использоваться иконка определенного расширения. В том случае, если иконки нужного расширения отсутствует, кнопка будет отображаться черным квадратом.

Для добавления иконки:

  1. Откройте вкладку Макросы диалога Настройка интерфейса (Сервис|Настройка интерфейса).

  2. В разделе Модули выберите модуль, содержащий нужный макрос.

  3. В разделе Команды отразятся названия всех имеющихся макросов, выделите макрос, к которому будет добавлена картинка.

  4. Нажмите кнопку Изменить....

  5. В появившемся диалоге в строке Текст можно изменить название, которое в дальнейшем после привязки макроса к кнопке или меню будет присвоено ему.

  6. Для выбора иконки из библиотеки в разделе Картинка нажмите кнопку [image] , после чего курсором укажите нужную иконку и нажмите кнопку ОК. По умолчанию отображаются все иконки библиотеки, для более быстрого поиска можно из списка выбрать конкретную категорию, тогда в разделе Команды отобразятся только иконки выбранной категории.

    Для загрузки файла картинки с компьютера нажмите кнопку [image] и укажите файл с изображением. Далее, в зависимости от используемого файла, появится тот или иной диалог.

    Если файл требуется покадрово нарезать, то сначала появится диалог Выбор картинки. В нем укажите картинку и нажмите кнопку ОК. Затем в появившемся диалоге Импорт картинки надо отметить галочками те расширения изображения, которые будут импортированы в Zulu. Чтобы подтвердить импорт, нажмите ОК.

    При использовании картинки, которую не требуется покадрово нарезать, диалог Импорт картинки появится сразу.

    Рисунок 1097. Импорт картинки

    В результате иконки, расширения которых были отмечены, будут загружены в систему.

    Если какая-либо картинка была загружена ошибочно, выделите ее и нажмите кнопку удалить [image] .

  7. Для закрытия диалога Команда нажмите кнопку ОК.

По итогу произведенных действий будут добавлены картинки, которые в дальнейшем используются при привязке макроса к кнопке панели или вывода в меню.

Добавление кнопки макроса на панель инструментов

  1. Для добавления кнопки, привязанной к макросу на панель инструментов, в разделе Модули выберите модуль, содержащий макрос.

  2. В разделе Команды укажите нужный макрос и перетащите его на панель инструментов. Для этого нажмите левую кнопку мыши на макросе и, не отпуская ее, переместите макрос на нужную панель инструментов. Отпустите левую кнопку мыши.

В результате проделанных действий на панели инструментов добавится кнопка, при нажатии на которую будет выполняться макрос. Если к макросу ранее не была добавлена иконка для кнопки, то кнопка отобразится в виде названия макроса, в противном случае она отобразится в виде иконки. Изменить настройку отображения кнопки можно с помощью контекстного меню, которое вызывается щелчком правой кнопки мыши на кнопке макроса. В меню указывается:

  • Основной стиль – кнопка отображается иконкой;

  • Только текст – кнопка отображается названием макроса;

  • Значок и текст – кнопка отображается в виде иконки и названия одновременно.

Привязка макроса к меню

Для того чтобы привязать макрос к меню, надо:

  1. Открыть вкладку Макросы диалога Настройка интерфейса (Сервис|Настройка интерфейса).

  2. В разделе Модули выбрать нужный модуль.

  3. Справа в разделе Команды выделить команду, нажать кнопку Изменить.

  4. В появившемся диалоге из списка Меню выбрать пункт меню, куда требуется вставить макрос. При необходимости в строке Пункт измените название для пункта меню, для добавления подменю воспользуйтесь разделителем / или |.

    Рисунок 1098. Диалог «Команда»

  5. Для подтверждения изменений нажмите кнопку ОК и закройте диалог Настройка интерфейса. Для проверки откройте меню, в которое был добавлен макрос.

    Рисунок 1099. Меню

Поиск макросов

Для поиска макроса по названию надо открыть вкладку Макросы диалога Настройка интерфейса и в строку Поиск... ввести название, результаты поиска будут отображены в разделе Команды.


Назначение «горячих» клавиш

  • «Назначение «горячих» клавиш для команд и макросов»

  • «Назначение «горячих» клавиш для быстрой активизации слоя»

  • «Список предустановленных «горячих» клавиш»

«Горячие» клавиши – это сочетания клавиш на клавиатуре, которые используются для выполнения определенных команд при работе с системой. Имеются уже предустановленные «горячие» клавиши, например, при нажатии сочетания клавиш Ctrl+S система выполнит команду Сохранить. Также возможно индивидуально назначить сочетания клавиш. Можно назначать горячие клавиши на команды и макросы, если командам назначена клавиша, то в пунктах меню у команды подписано сочетание:

Рисунок 1100. Меню Файл

Помимо макросов и команд, горячие клавиши можно назначить для быстрой активации слоя и для ввода сети.

Назначение «горячих» клавиш для команд и макросов

Для назначения нового сочетания:

  1. Откройте панель настройки интерфейса. Для вызова панели выполните команду главного меню Сервис|Настройка интерфейса, либо щелкните правой кнопкой мыши по любой из панелей инструментов, и выберите пункт Настройка... открывшегося контекстного меню.

  2. Выберите вкладку Клавиатура.

  3. В разделе Категория из списка выберите необходимый пункт меню или макросы.

  4. В разделе Команды выделите команду или макрос, которому требуется назначить сочетание клавиш. Если сочетание клавиш уже назначено, то оно отобразится в разделе Сочетание клавиш.

    В том случае, когда в выбранной категории много команд или макросов по ним можно осуществить поиск. Поиск производится введением нужной команды или названия макроса в строку [image] Поиск.... Результат поиска будет отображен в разделе Команды.

  5. Установите курсор в окошко Новое сочетание и нажмите на клавиатуре задаваемую комбинацию клавиш. В том случае, если указанное сочетание уже занято другой командой, то снизу отобразится ее название.

  6. Нажмите кнопку Добавить. Удалить случайно добавленное сочетание клавиш можно выделив его в разделе Сочетание клавиш и нажав кнопку Удалить. Кнопка Сброс удалит все назначенные пользователем сочетания клавиш.

  7. Закройте диалог Настройка интерфейса нажатием кнопки Закрыть.

Настройка интерфейса, вкладка «Клавиатура»

Рисунок 1101. Настройка интерфейса, вкладка «Клавиатура»

Назначение «горячих» клавиш для быстрой активизации слоя

Возможно назначить определенное сочетание клавиш, чтобы при их нажатии происходила активация слоя. Для назначения клавиш:

  1. Откройте карту, в которую добавлен слой для назначения сочетания клавиш.

  2. Откройте диалог Загруженные слои (меню Карта|Слои) или список слоев карты в ее настройках.

  3. Выделите в списке слой, для быстрой активации которого будет назначена комбинация клавиш.

  4. Нажмите кнопку Клавиша и из списка Сочетание клавиш выберите требуемое сочетание (вида Ctrl+Цифра).

  5. Закройте открытый диалог.

  6. Чтобы сохранить настройки, сохраните карту.

    Выбранные сочетания клавиш сохраняются в файл карты и будут работать только в той карте, в которой были назначены.

    После назначения «горячих» клавиш для быстрой активации слоя надо нажать назначенную комбинацию на клавиатуре.


Список предустановленных «горячих» клавиш

«Горячие» клавиши на определенные операции могут быть назначены самостоятельно пользователем, но помимо этого уже имеется предустановленная настройка ряда клавиш. Одни и те же клавиши в разных режимах выполняют разные функции.

Список горячих клавиш

Горячие клавиши | Режим | Пояснение
Ctrl+N | Все режимы | Создать карту.
Ctrl+O | Все режимы | Открыть (загрузить) карту.
Ctrl+S | Все режимы | Сохранить карту.
Ctrl+P | Все режимы | Напечатать карту.
Ctrl+E | Все режимы | Включить режим редактирования активного слоя.
Ctrl | Все режимы | При перемещении вспомогательных панелей не дает ей «прилипать» к краям экрана.
Ctrl+Shift+I | Все режимы | Инвертировать выделенную группу. В том случае если объекты выделены в нескольких слоях появится окно выбора слоя для инвертирования.
Ctrl+D | Все режимы | Отменить выделенную группу (снять выделение).
Ctrl+B | Все режимы | Отменить мигание объекта.
Ctrl | Все режимы | При вращении колеса мыши изменить угол отображения карты (повернуть). Вернуть угол поворота карты в ноль после нажатия на колесо мыши.
Alt | Все режимы | Быстрая смена расположения кнопок инструментов. Надо нажать клавишу Alt, после чего «захватить» с помощью левой кнопки мыши соответствующую кнопку инструментов. И переместить на новое место в панели инструментов, если кнопка будет перемещена не на панель инструментов, то она будет удалена.
Alt+Ctrl | Все режимы | Создать копию кнопки панели инструментов. Для создания копии требуется нажать комбинацию клавиш Alt+Ctrl «захватить» кнопку и перетащить в новое место на любой панели инструментов.
Shift | Режим выделить ( [image] ) | Выделить указанные объекты активного слоя. Объекты выделяются поштучно нажатием на них левой кнопкой мыши.
Ctrl | Режим выделить ( [image] ) | Снять выделение с указанных объектов активного слоя (исключить из выделенной группы).
Ctrl+Shift | Режим выделить ( [image] ) или режим информация ( [image] ) | Сделать активным слой, на объекте которого сделали щелчок. Если выбран режим информации ( [image] ), то дополнительно произойдет открытие окна семантической информации.
Alt+Ctrl +Shift | Режим выделить ( [image] ) или режим информация ( [image] ) | При щелчке по растровому объекту активизировать растровый слой.
Ctrl | Режим информация ( [image] ) | Выполнить запрос получения информации по всем слоям карты одновременно.
Alt | Режим информация ( [image] ) | При работе с инженерной сетью, даже при очень маленьком масштабе вызывать окно семантической информации по участкам.
Shift | Выделение объектов областью ( [image] , [image] , [image] ) | Добавить в существующую группу (то есть группу, которая создана ранее) все объекты активного слоя, полностью попавшие в указанную область.
Alt | Выделение объектов областью ( [image] , [image] ) | Добавить в новую группу все объекты активного слоя, частично попавшие в указанную область.
Ctrl | Выделение объектов областью ( [image] , [image] , [image] ) | Исключить из существующей группы все объекты активного слоя, полностью попавшие в указанную область.
Alt | Выделение объектов областью ( [image] ) | Создать группу (выделить) группу из объектов, попадающих в определенную область. При этом выделенные объекты и группа находятся в разных слоях. Например, можно выделить объекты тепловой сети, находящиеся в одном квартале (заметим, что объекты тепловой сети и объекты кварталы находятся в разных слоях). Слой в котором выделяется группа объектов должен быть активным. По объекту, в рамках которого требуется выделение надо сделать один щелчок левой кнопкой мыши. Если объекты, которые надо выделить окажутся в пределах нескольких объектов других слоев, то на необходимо будет указать слой пересечения.
Ctrl+Shift | Выделение объектов областью ( [image] ) | Создать группу из всех объектов всех слоев, попавших в указанную область.
Ctrl | Диалог Корректировка растров | Отключить опорные точки, для отключения точки надо подвести курсор мыши ней и нажать левую клавишу мыши, удерживая при этом клавишу Ctrl.
Ctrl+Z и Alt+Backspace | Редактирование слоя ( [image] ) | Отменить действие.
Ctrl+P и Shift+Alt+Backspace | Редактирование слоя ( [image] ) | Вернуть отмененное действие.
Ctrl+X и Shift+Delete | Редактирование слоя ( [image] ) | Вырезать выделенный объект.
Ctrl+C и Ctrl+Insert | Редактирование слоя ( [image] ) | Копировать в буфер выделенный объект.
Ctrl+V и Shift+Insert | Редактирование слоя ( [image] ) | Вставить скопированный ранее в буфер объект.
Ctrl+A | Все режимы/Редактирование слоя ( [image] ) | Выделить все объекты активного или редактируемого слоя.
Ctrl+T | Редактирование слоя ( [image] ) | Установить мишень.
Ctrl | Редактирование слоя ( [image] ). Режим объект ( [image] ) | Копировать объект при его перемещении.
Shift | Редактирование слоя ( [image] ). Режим объект ( [image] ) | При двойном щелчке открыть диалог изменения параметров группы объектов.
Shift | Редактирование слоя ( [image] ). Режим объект ( [image] ) или узлы ( [image] ) | При перемещении оторвать объект ( [image] ) или узел объекта ( [image] ) от связанных с ним объектов.
Ctrl+Alt | Редактирование слоя инженерной сети ( [image] ) | При вводе участков или символьных объектов разбить уже существующий участок на два указанным объектом (внедрить символ в участок).
Ctrl+Shift | Редактирование слоя ( [image] ). Режим узлы ( [image] ) | Выделить группу узлов на объекте, для этого достаточно указать начальный и конечный узлы.
Ctrl | Редактирование слоя. Режим узлы ( [image] ) | При щелчке мыши на ребре ломаной или многоугольника - добавить узел (точку перелома). При щелчке на узел - добавить его в группу выделенных узлов если он не выделен и снять выделение если выделен. При перемещении конечной точки участка к узлу символьного объекта «привязать» участок к нему. При перемещении узла объекта к какому-то узлу объекта активного слоя «привязать» к нему.
Alt | Редактирование слоя ( [image] ). Режим трансформация слоя с экрана ( [image] ) | При трансформации резиновый лист (локально-афинная трансформация). Указать зону трансформации для ограничения области локальных искажений. Зона указывается щелчком левой кнопкой мыши в углах.
Shift | Редактирование слоя ( [image] ). Режим ввода объектов ( [image] , [image] ) | Очередная точка ломаной (участка) или многоугольника, начиная со второй, будет вводится так, что заканчивающийся на ней последний отрезок ломаной будет образовывать с предыдущим отрезком углы 90, 180 или 270 градусов.
Ctrl | Редактирование слоя ( [image] ). Режим ввода объектов ( [image] , [image] ) или Все режимы. Измерение расстояний [image] . | При вводе объекта установить (прицепить) очередную точку объекта в одну из уже существующих вершин линии или полигона, одного из слоев карты, являющегося в данный момент активным. «Притягивание» произойдет в том случае, если курсор подвести на расстояние меньше пяти пикселов. При измерении расстояний «привязать» к узлам активного слоя.
Ctrl+Shift | Редактирование слоя ( [image] ). Режим ввода объектов ( [image] , [image] ) или Все режимы. Измерение расстояний [image] . | При вводе объекта «притянуться» к узлу объекта, находящегося в неактивном слое. При измерении расстояний «притянуться» к узлу объекта, находящегося в неактивном слое.
Shift | Редактирование слоя ( [image] ). Режим ввода объектов ( [image] , [image] ) | При вводе новой фигуры – получаемая фигура – овал.
Ctrl | Редактирование слоя ( [image] ). Режим ввода объектов ( [image] , [image] ) | Повернуть вводимый эллиптический контур.
Ctrl | Редактирование слоя ( [image] ). Режим ввода объектов ( [image] ) | Открыть диалог настройки параметров вводимого простого текстового объекта.
Ctrl | Редактирование слоя ( [image] ). Режим ввода объектов ( [image] ) | Разъединить ранее объединенные объекты, в этом случае если у площадных объектов ранее были вырезаны области, то они будут удалены. После разъединения у одного из объектов остается ключ комбинированного исходного объекта, а другие объекты получают новые ключи.
Shift | Редактирование слоя ( [image] ). Режим редактирования надписей ( [image] ). | Добавить в группу (выделение) надписи. Для выделения надо удерживая клавишу Shift подвести курсор к точке вывода надписи, нажать левую клавишу мыши, надпись будет добавлена в группу. Объект, к которому относится надпись так же будет выделен.
Ctrl | Редактирование слоя ( [image] ). Режим редактирования надписей ( [image] ). | Исключить надписи из выделенной группы. Для исключения надо удерживая клавишу Ctrl подвести курсор к точке вывода надписи, нажать левую клавишу мыши.
Ctrl | Для структуры слоя | Изменить порядок следования типов или режимов. Для изменения положения режима в списке режимов определенного типа надо в дереве типов и режимов «встать» на нужный режим, нажать и удерживать клавишу Ctrl и перемещать режим по списку клавишами вверх/вниз (стрелками).
Ctrl+Del | Для панели Свойства при редактировании слоя ( [image] ). Режим ввода объектов ( [image] , [image] ) или режим узлы ( [image] ). | Удалить точки объекта, для этого надо встать на строку с удаляемой точкой в панели Свойства нажать комбинацию клавиш Ctrl+Del.
Ctrl | Режим поиск пути ( [image] ) | При решении топологических задач исключить из маршрута поиска указанные объекты сети, они будут отмечены красным крестом.
Shift | Режим поиск пути ( [image] ) | При решении топологических задач включить в поиск отключенные объекты (по умолчанию они не участвуют в поиске). Для этого надо удерживая клавишу Shift щелкнуть по ним, после чего они будут отмечены зеленым кружком.
Ctrl+S | Окно семантической информации. Вкладки текущая запись, запрос, база, ответ. | Вкладка текущая запись - сохранить запись. Вкладка запрос - сохранить условия запроса. Вкладки база и ответ – сохранить результаты запроса или всю базу.
F5 | Окно семантической информации. Вкладки текущая запись, запрос, база. | Вкладки текущая запись, запрос, база – обновить записи.
Ctrl+P | Окно семантической информации. Вкладки текущая запись, база, ответ. | Вкладка текущая запись, база, ответ – вызвать диалог настройки шаблона для печати отчета.
Alt | Окно семантической информации. Вкладка база. | Вкладка база. При указании строки с помощью мыши произвести масштабирование карты по размерам объекта к которому относится строка.
F9 | Окно семантической информации. Вкладка запрос. | Выполнить запрос.
PgUp | Окно сообщения | На страницу вверх.
PgDn | Окно сообщения | На страницу вниз.
Home | Окно сообщения или Макет печати. Режим редактирования текста ( [image] ) | В начало строки.
End | Окно сообщения или Макет печати. Режим редактирования текста ( [image] ) | В конец строки.
Ctrl + Home | Окно сообщения или Макет печати. Режим редактирования текста ( [image] ) | В начало текста.
Ctrl + End | Окно сообщения или Макет печати. Режим редактирования текста ( [image] ) | В конец текста.
Ctrl | Диалог загруженные слои (настройка слоев карты) | При нажатии кнопок Назад и Вперед выделенный в списке слой будет перемещен в самый верх или низ списка соответственно.
Ctrl | Диалог загруженные слои (настройка слоев карты) или диалог Запрос | При щелчке на название слоя он выделится, таким образом возможно выделить сразу группу слоев в произвольном порядке. В диалоге Запрос при щелчке на строку с полем она будет выделена, таким образом можно выделить несколько полей для групповой настройки.
Shift | Диалог загруженные слои (настройка слоев карты) или диалог Запрос | Выделить одновременно несколько слоев идущих по порядку. Для выделения необходимо с помощью щелчка мыши указать первый и последний слой. В диалог Запрос при настройке полей запроса можно выделить одновременно несколько полей указав первое и последнее поле списка.
Ctrl + C | Окно сообщения | Поместить выделенный текст сообщений в буфер обмена (копировать).
Ctrl+S | Окно сообщения | Записать текст сообщений в текстовый файл или HTML.
Ctrl+F | Окно сообщения | Найти фрагмент текста в теле сообщений.
Ctrl + Enter | Макет печати. Режим редактирования текста ( [image] ) | Добавить перенос на новую строку без образования нового абзаца.
Ctrl | Макет печати. Режим редактирования текста ( [image] ) | Клавиши со стрелками влево и вправо с нажатой клавишей Ctrl перемещают курсор на один слово. Клавиши со стрелками вверх и вниз с нажатой клавишей Ctrl перемещают курсор на один абзац.
Shift | Макет печати. Режим редактирования текста ( [image] ) | Выделить фрагмент текста при использовании клавиш для навигации по тексту с одновременным удержанием клавиши Shift.
Ctrl | Макет печати. Режим редактирования карты в макете | При вращении колеса мыши плавно изменить угол поворота добавленной в макет карты.
Shift | Макет печати. Режим редактирования карты в макете | При редактировании добавленной в макет таблицы выбрать группу ячеек.


Настройка тем и размеров кнопок для отображения панелей инструментов

Пользователь может настроить тематический вид панелей инструментов системы и размер кнопок.

Для смены вида панелей инструментов в списке Тема можно выбрать следующие варианты:

  • Классическая – кнопки и панели будут отображены в классическом стиле, который был сформирован при создании системы ZuluGIS.

  • Модерн – современный стиль кнопок и панелей, используется по умолчанию.

  • Тёмная – вариант настройки, при которой кнопки отображаются на темной панели инструментов, цветоотображение кнопок так же корректируется. Данная темная тема может снизить нагрузку на глаза в ночное время, так как в слабо освещенном помещении контраст с темным фоном почти незаметен.

    [Примечание] Примечание

    Если после включения тёмной темы фон карты будет слишком светлым, то его можно изменить.

    Слева тема Модерн, справа Тёмная тема

    Рисунок 1102. Слева тема Модерн, справа Тёмная тема

Изменение размера кнопок панелей инструментов

Размер кнопок панелей инструментов меняется с помощью бегунка Размер. Для перемещения бегунка необходимо подвести к нему курсор, нажать левую кнопку мыши и не отпуская ее начать перемещение курсора в ту или иную сторону. При этом сразу после перемещения бегунка кнопки панелей инструментов примут выбранный размер.

Настройка интерфейса, вкладка «Параметры»

Рисунок 1103. Настройка интерфейса, вкладка «Параметры»


Сброс пользовательских настроек интерфейса в исходное состояние

В исходное состояние возможно сбросить настройки стандартных панелей инструментов, докируемых панелей и назначения клавиш.

Для сброса надо:

  1. Открыть диалог Настройка интерфейса (Сервис|Настройка интерфейса).

  2. Снизу окна выбрать пункт Дополнительно...|Сброс настроек....

    Диалоговое окно Параметры

    Рисунок 1104. Диалоговое окно Параметры

  3. В появившемся диалоговом окне установить галочки напротив настроек, которые требуется сбросить.

    Диалоговое окно Параметры

    Рисунок 1105. Диалоговое окно Параметры

  4. Нажать кнопку Сбросить. Кнопка Отмена закроет диалог без изменений.


Настройка параметров системы

Настройки параметров системы можно изменить в диалоговом окне Параметры, которое открывается через меню Сервис|Параметры:

Диалоговое окно Параметры

Рисунок 1106. Диалоговое окно Параметры

Окно разделено на несколько вкладок, в каждой из которых происходят соответствующие настройки:

  • Общие – во вкладке настраиваются общие параметры для системы, такие как папка для файлов, или количество запоминающихся файлов системой и другие.

  • Карта – вкладка позволяет настроить параметры для карты, например цвет и стиль выделяемых объектов, масштаб карты или каким образом будет происходить перемещение при работе с картой и другие.

  • Базы данных – в данной вкладке происходит настройка параметров, относящихся к базе данных, например язык ключевых слов или используемая по-умолчанию СУБД.

  • HASP – при использовании сетевого ключа во вкладке необходимо установить соответствующий параметр.

  • Сеть – во вкладке настраиваются параметры, относящиеся к сети.


Вкладка «Общие»

С помощью данной вкладки) имеется возможность настроить общие параметры системы, вкладка имеет следующие разделы:

Назначенные папки

В данном разделе указывается путь до папки Мои карты. Это папка для хранения данных, к которой при различных операциях, например добавлении слоя в карту, возможно произвести быстрый переход. Для перехода к данной папке в окне выбора файла будет достаточно нажать слева кнопку [image] .

Для изменения назначенной папки выделите строку с указанным путем и нажмите кнопку Изменить..., после чего в стандартном окне выбора укажите новую папку.

Списки последних файлов

В разделе Списки последних файлов можно установить количество запоминаемых последних открываемых файлов (карт, слоев, проектов). При необходимости можно очистить список последних открываемых документов. Для этого нажмите кнопку Очистить... и в открывшемся окне выберите, список из каких документов необходимо очистить.

Если установить опцию Запоминать пользовательские имена документов, то в списке последних используемых файлов будут отображаться пользовательские названия карт, в противном случае там будут отображены имена файлов.

Окна

В данном разделе возможно установить следующие параметры:

Использовать вкладки для документов – при установке данной опции документы (карты, макеты) будут открываться каждый в своей вкладке, между которыми при работе можно будет оперативно переключаться.

Использовать имеющееся пустое окно при открытии документа – если она установлена, то при открытии уже существующей на диске карты, карта откроется вместо пустого окна, в противном случае откроется еще одно окно карты.

Графика

Раздел Графика отвечает за отрисовку карты, доступны три варианта: Direct2d, GDI, Skia. По умолчанию стоит опция Direct2d, которая позволяет использовать интерфейс Direct2d, что способствует ускоренному и качественному отображению графики, при этом функция сглаживание включается по-умолчанию.

Если с интерфейсом Direct2d возникли какие либо проблемы, то целесообразно установить переключатель на GDI.

[Подсказка] Подсказка

Для ZuluServer опция графики указывается в конфигурационном файле ZuluServ.cfg, подробнее смотрите https://www.politerm.com/zuluserver/webhelp/index.html#zscommon.html#zscommon_render.


Вкладка «Карта»

В данной вкладке производятся настройки, которые непосредственно касаются работы с картой, вкладка поделена на несколько разделов:

Диалоговое окно Параметры. Вкладка Карта

Рисунок 1107. Диалоговое окно Параметры. Вкладка Карта

Выделение

В этом разделе можно настроить стиль выделения группы объектов на карте и мишени. Для этого нужно нажать на кнопку с выбранным стилем - линии или заливки и установить новые параметры. Также можно изменить стиль ответов на топологические запросы. Изменения вступят в силу после перезагрузки системы.

Опция Сглаживание линий – позволяет включить/отключить сглаживание линий (антиалиасинг) для слоя.

Опция Показ направлений – применяется к новым картам, при ее установке/снятии в добавляемых в карту слоях будут или не будут соответственно отображаться стрелки направлений на линейных типовых объектах. При этом если в слое были сохранены другие настройки, то будут применены они.

Перемещение изображения (режим рука)

В данном разделе настраивается каким образом будет перемещаться изображение карты в режиме произвольного перемещения центра изображения ( [image] ). Имеется два варианта перемещения: Фрагмент экрана или Полная отрисовка. При выборе первого варианта будет перемещаться только фрагмент карты, в противном случае перемещается вся карта, при больших картах первый вариант более предпочтителен.

Масштабирование колесом мыши

В данном разделе точно так же как и в предыдущем можно установить опцию Фрагмент экрана или Полная отрисовка, только для режима масштабирования с помощью колеса мыши.

Так же в этом разделе настраивается каким образом будет уменьшаться или увеличиваться масштаб карты с помощью колеса мыши. Для настройки надо из списка Приближать вращением выбрать тот вариант, который Вам удобен: либо «от себя» либо «на себя».

Кнопка «Информация»

В разделе Кнопка Информация можно установить две опции: По активному слою и По всем слоям карты. В случае установки первой опции при работе с картой в режиме получения информации по слою ( [image] ) запрос будет производиться только к активному слою, при установке опции По всем слоям карты запрос будет произведен сразу одновременно по всем слоям активной карты.

Масштаб карты

Из списка Масштаб карты выбирается масштаб: Геодезический или Сантиметры на пиксель.

Указанный масштаб будет отображаться в диалоге Масштаб и центр карты, так же он используется при написании макросов и доступе через COM.

Опция Использовать полосы прокрутки позволяет включить/отключить полосы прокрутки.

Выделение группы

Из списка выбираются критерии добавления объектов при выделении группы ( [image] , [image] , [image] ):

  • Полное попадание – при выборе данной опции в группу будут добавляться объекты только полностью попавшие в указанную область.

  • Полное или частичное попадание – при выборе данной опции в группу будут добавляться объекты полностью или частично попавшие в указанную область.

Копирование в буфер – указывается масштаб копирования выделенной области карты в буфер.

Сброс настроек – кнопка позволяет сбросить настройки параметров карты, устанавливаемые в данном диалоге до значений по умолчанию.

Ввод сети

Радиус захвата узла – указывается радиус захвата узла в пикселях при вводе объектов сети.

Восстанавливать последнее местоположение – опция устанавливается для того, чтобы при открытии карты производилось восстановление последнего местоположения карты, которое было до ее закрытия. При использовании серверной карты на машине клиента будут сохраняться локальные данные с последним местоположением.

Предупреждать при удалении группы более чем – вводится количество объектов, если оно будет превышено при удалении, то отобразится предупреждающее сообщение.


Вкладка «Базы данных»

Во вкладке задаются настройки, связанные с работой базы данных:

Диалоговое окно Параметры. Вкладка База данных

Рисунок 1108. Диалоговое окно Параметры. Вкладка База данных

Вкладка имеет следующие опции:

  • Использовать единственный браузер базы данных – если данная опция установлена, то при получении информации по различным типовым объектам слоя окно семантической информации будет единственным, в противном случае для каждой семантической базы данных открывается свое окно семантической информации.

  • Помещать сообщения об ошибках в окно Сообщения – если данная опция установлена, то при возникновении ошибки в системе сообщение о ней будет помещено в окно Сообщения.

  • При выборе опции Проверять настройки BDE при старте система будет автоматически проверять корректность настроек BDE перед началом работы с базами данных. Это позволит избежать возможных проблем и обеспечит стабильную работу с базами данных.

  • Ключевые слова в запросах по русски. Если данная опция включена, то в окне семантической информации при задании запроса ключевые слова будут написаны кириллицей на русском, в противном случае латиницей на английском.

В списке Использовать СУБД по-умолчанию можно выбрать базу данных, которая будет использоваться по умолчанию, если не указано иное. То есть в том случае, когда источник данных не выбирается через пользовательский интерфейс. При различных операциях, например, при создании слоя, копировании и др. , где есть список доступных источников данных, последний используемый источник данных будет запомнен для удобства работы. Изначально, же первый раз, там был выбран источник по-умолчанию.


Вкладка «HASP»

  • «Работа с сетевым ключом»

  • «Открытие теста ключа»

  • «Открытие центра администрирования ключей»

  • «Открытие информации о защите системы»

Во вкладке HASP указываются модули для работы с сетевым ключом. Так же возможно вызвать тест ключа, открыть страницу центра администрирования ключей и ознакомиться с организацией защиты ZuluGIS.

Диалоговое окно Параметры. Вкладка HASP

Рисунок 1109. Диалоговое окно Параметры. Вкладка HASP

Работа с сетевым ключом

В разделе Использовать сетевой ключ флажками должны быть отмечены модули, защита которых происходит с использованием сетевого ключа. Если модуль не отмечен, то система будет работать с локальным ключом.

[Предупреждение] Предупреждение

При использовании локального ключа, флажки обязательно должны быть сняты!

Открытие теста ключа

Тест ключа позволяет отобразить список локальных и сетевых ключей, доступных данному компьютеру и при выборе определенного ключа лицензии записанные на нем. Для вызова теста ключа нажмите кнопку Информация по ключам. Подробней о тесте ключа можно у знать в разделе «Просмотр доступных лицензий на ключе HASP».

Открытие центра администрирования ключей

Центр администрирования позволяет просматривать информацию локальным и сетевым ключам, составу и количеству лицензий на программные модули и продукты, количеству текущих пользователей лицензий и так далее. Для открытия страницы центра администрирования ключей нажмите кнопку HASP Admin Control Center.

Открытие информации о защите системы

Нажав кнопку Об организации защиты произойдет переход на страницу с описанием защиты системы ZuluGIS, так же о защите возможно ознакомиться в разделе Организация защиты продуктов линейки Zulu.


Вкладка «Сеть»

Во вкладке настраиваются параметры, относящиеся к настройке сети:

Диалоговое окно Параметры. Вкладка Сеть

Рисунок 1110. Диалоговое окно Параметры. Вкладка Сеть

Прокси сервер

В данном разделе задаются параметры прокси сервера:

  • Прямое подключение;

  • Использовать системные настройки;

  • Задать параметры, при выборе данной опции дополнительно задаются адрес, порт, логин и пароль.

HTTP клиент

  • MFS WinInet – стандартный HTTP клиент;

  • cURL – HTTP клиент для поддержки различных интернет сервисов, часто используется для работы с Росреестром.

Корневая папка для кэша

В разделе Корневая папка для кэша задается путь до корневой папки, отличной от папки по умолчанию для кэширования тайловых данных. Нажатие кнопки Папка по умолчанию, приведет к установке исходной папки для кэша.

Командный сервер

  • Включить – включает возможность работать с командным сервером ZuluGIS по протоколу HTTP. В окошке Порт необходимо указать номер порта.

  • SSL/TLS – включает возможность работать с командным сервером ZuluGIS по протоколу HTTPS. В окошке Порт необходимо указать номер порта, так же надо указать Сертификат и Ключ.

Опцию Разрешить выполнение макросов требуется включать в том случае, если планируется выполнять запросы к командному серверу ZuluGIS используя команду RunMacro для запуска макросов.

[Примечание] Примечание

Описание запросов к командному серверу ZuluGIS можно найти в руководстве программиста в разделе Командный сервер.


Настройка языка интерфейса

В ZuluGIS имеется два вида языка для интерфейса: русский и английский.

Для смены языка надо:

  1. Выбрать меню Сервис|Язык.

  2. Из открывающегося списка выбрать нужный язык.

  3. Нажать кнопку ОК.

Для того, чтобы изменения вступили в силу следует перезапустить ZuluGIS.

Настройка языка интерфейса

Рисунок 1111. Настройка языка интерфейса


Макросы

  • «Создание нового макроса»

  • «Изменение макроса»

  • «Выполнение макроса»

  • «Удаление макроса»

  • «Привязка макроса к кнопке панели инструментов»

Для расширения функциональности ZuluGIS предоставляет возможность создания макросов. Система позволяет создавать, редактировать и выполнять макросы на языках VBScript и JScript. Для доступа к данным и управления приложением ZuluGIS макросы используют объектную COM-модель.

Примеры макросов можно найти на нашем сайте: https://www.politerm.com/samples/zulugis/macros/.

Для быстрого вызова макроса можно назначить горячие клавиши, добавить в главное меню или создать кнопку на панели инструментов. Возможен перенос макросов между компьютерами с сохранением их настроек (местоположения в главном меню, иконки макроса).

[Примечание] Примечание

После назначения макросу кнопки, иконки или привязки макроса к меню в папке, в которой располагается макрос, создается файл *.vbs.uidat, где хранится картинка кнопки и служебная информация, что позволяет производить перенос между ПК созданных для макросов кнопок.

Для удобства написания кода используется IntelliSense – технология автодополнения, дописывающая название функции при вводе начальных букв. Кроме прямого назначения, IntelliSense используется для доступа к документации и для устранения неоднозначности в именах переменных, функций и методов. Имеется подсветка синтаксиса – выделение синтаксических конструкций текста с использованием различных цветов, шрифтов и начертаний. Обычно она применяется для облегчения чтения исходного текста компьютерных программ и улучшения визуального восприятия.

[Подсказка] Подсказка

При нажатии SHIFT + ПРОБЕЛ открывается список с константами.

IntelliSense при написании текста макроса

Рисунок 1112. IntelliSense при написании текста макроса


Создание нового макроса

  1. В меню Сервис выделите пункт Макросы....

  2. В строке Имя макроса введите название создаваемого макроса.

  3. Из списка Модуль выберите модуль для записи макроса. Если нужного модуля нет, то нажмите кнопку Новый, укажите имя модуля, затем с помощью опций выберите нужный язык программирования и нажмите ОК.

  4. Нажмите кнопку Правка.

  5. В появившемся окне напишите код для макроса.

  6. С помощью меню Файл|Сохранить или комбинацией клавиш Ctrl + S сохраните макрос и закройте окно редактора.

    Пользовательские макросы хранятся в папке Macros в Моих документах текущего пользователя: C:\Users\Admin\Documents\Zulu\Macros (C:\Пользователи\Имя пользователя\Мои документы).

[Примечание] Примечание

Видеоурок, в котором используется макрос, можно посмотреть, пройдя по ссылке: https://www.politerm.com/videos/examples/CalcGaussKruger/.


Изменение макроса

  1. В меню Сервис укажите пункт Макросы.....

  2. Выделите необходимый макрос. Если нужного макроса нет в списке, выберите другой модуль в списке Модуль.

  3. Нажмите кнопку Правка.

или

  1. В меню Сервис выделите пункт Модули….

  2. В списке выберите файл, содержащий нужный макрос.

  3. Нажмите кнопку Правка.


Выполнение макроса

  1. В меню Сервис укажите пункт Макросы….

  2. Выделите необходимый макрос. Если нужного макроса нет в списке, выберите другой модуль в списке Модуль.

  3. Нажмите кнопку Выполнить.

или

  1. В меню Сервис выделите пункт Выполнить.

  2. Откройте вкладку Макро.

  3. Выделите необходимый макрос. Если нужного макроса нет в списке, выберите другой модуль в списке Модуль.

  4. Нажмите кнопку Выполнить.


Удаление макроса

  1. Войдите в режим изменения макроса (см. выше).

  2. Удалите весь текст, относящийся к макросу.

  3. Сохраните файл макроса.

Для удаления модуля (файла), содержащего макросы:

  1. В меню Сервис укажите пункт Модули.

  2. В списке выделите необходимый модуль.

  3. Нажмите кнопку Удалить.


Привязка макроса к кнопке панели инструментов

[Примечание] Примечание

Начиная с ZuluGIS версии 8.0.0.7138, ниже описанный способ настройки внешнего вида кнопок не актуален. В настоящей версии настройка иконок производится через диалог Настройка интерфейса. Подробнее смотрите раздел «Настройка интерфейса для макросов». Также в данном разделе можно ознакомиться с тем, как привязать макрос к кнопке панели инструментов, назначить кнопке иконку (картинку) и добавить макрос в пункт главного меню системы. Как назначить макросу сочетание клавиш, можно узнать в разделе «Назначение «горячих» клавиш».

Для привязки макроса к кнопке:

  1. Сделайте щелчок правой кнопкой мыши в области панели инструментов. В появившемся контекстном меню выберите пункт Настройка.

  2. В разделе Категории выделите пункт Макросы, после чего в разделе Команды отразятся названия всех имеющихся макросов.

  3. Выберите макрос и перетащите его на панель инструментов.

  4. Для смены имени или настройки внешнего вида кнопки макроса сделайте щелчок правой кнопкой мыши на кнопке.

  5. Для смены имени в строке Имя внесите новое имя кнопки. С помощью пункта Копировать значок на кнопке имеется возможность скопировать значок с другой кнопки, а с помощью пункта Вставить значок для кнопки, соответственно, вставить его. Для вызова редактора картинок выберите пункт Изменить значок на кнопке.

  6. В редакторе Картинка на кнопке в разделе Цвета выберите цвет рисунка, а в разделе Картинка нарисуйте картинку.

    При этом в разделе Просмотр будет отображаться созданная кнопка. С помощью стрелок из раздела Переместить можно сместить картинку в ту или иную сторону.

    Диалог «Картинка на кнопке»

    Рисунок 1113. Диалог «Картинка на кнопке»

  7. Для сохранения и закрытия окна Картинка на кнопке нажмите кнопку ОК.

  8. С помощью кнопки Закрыть закройте окно Настройка интерфейса.


Формат файла описателя растра

Описание растрового изображения содержится в текстовом файле с расширением ZRS.

Файл состоит из следующих блоков:

  • «Заголовок»;

  • «Параметры»;

  • «Точки привязки»;

  • «Область отображения».

В последующих подразделах более подробно описаны блоки файла, а также приведен пример файла описателя.


Заголовок

Заголовок состоит из трех строк:

  • ZuluGIS Data – обязательно должна быть первой строкой файла.

  • Version: 8.0 – версия описателя.

  • Type: raster – указывает на то, что описываются растровые данные.


Параметры

В зависимости от системы координат точек привязки количество параметров может быть разным. Каждый параметр (см. таблицу ниже) задается в отдельной строке файла.

Формат параметров: <название><двоеточие><пробел><значение>

Параметры описателя:

Параметр | Единицы | Описание
File | Строка | Имя файла растрового изображения может содержать либо полный путь, либо путь относительно файла описателя.
Timestamp Xmin Ymin Xmax Ymax |  | Служебные параметры. Создаются системой.
Units | Строка | Единица измерения координат местности точек привязки. Может принимать значения: «degree» – градусы; «m» – метры; «cm» – сантиметры; «km» – километры.
Datum | Число | Код датума (см. раздел Проекции и датумы).
Projection | Число | Код проекции (см. раздел Проекции и датумы).
K0 | Число | Масштабный коэффициент.
Lon0 | Градусы | Центральный меридиан.
Lat0 | Градусы | Начальная широта.
Lon1 | Градусы | Стандартная широта 1.
Lon2 | Градусы | Стандартная широта 2.
FE | Метры | Восточное смещение.
FN | Метры | Северное смещение.
White | Строка | Отображение белого цвета. Может принимать значения «Yes», «No». По умолчанию – «Yes».
Transparency | Число | Прозрачность изображения. Может принимать значения от 0 до 100. 0 – полностью непрозрачное.
Cache | Строка | Наличие постоянного кэша. Может принимать значения «On», «Off». По умолчанию – «Off». Работает только для файлов в формате BMP.
ColorBkColor | Шестнадцатеричное число | Два цвета для палитры монохромных растров.


Точки привязки

Первая строка блока имеет вид: Points: <n>, где n – количество точек привязки.

Далее следуют строки по количеству точек привязки, содержащие координаты точек привязки в формате:

<X растра> <пробел> <Y растра> <пробел> <N местности> <пробел> <E местности>

X ,Y растра – целые числа, задающие координаты точки на растре в пикселях. Ось X направлена вправо, ось Y – вниз.

Точка (0, 0) – верхний левый угол растра.

N, E местности – десятичные числа, задающие координаты на местности, соответствующие указанным выше проекции и единицам измерения. Ось N направлена вверх, ось E – вправо.


Область отображения

Область отображения – это полигон, вершины которого задаются последовательностью точек на растре. В описателе растрового изображения этот раздел может отсутствовать.

Первая строка: CutPoints: <n> , где n – количество вершин полигона.

Далее следуют строки по количеству вершин полигона, содержащие координаты точек на растре:

<X растра><пробел>< Y растра>

X ,Y растра – целые числа, задающие точку на растре в пикселях. Ось X направлена вправо, ось Y – вниз.

Точка (0, 0) – верхний левый угол растра.


Пример файла описателя

Ниже представлен пример файла описателя растрового объекта:

Zulu GIS Data
Version: 8.0
Type: raster
File: 50GI.BMP
Timestamp: 29501466-1105944064
Cache: on
BkColor: FF0000
Color: FFFFFF
Units: m
Xmin: 7973.090000
Ymin: 7979.990000
Xmax: 8607.370000
Ymax: 8534.470000
Projection: 0

Points: 4

230 9498 8000.000000000000 8000.000000000000
8100 9567 8000.000000000000 8500.000000000000
8169 1688 8500.000000000000 8500.000000000000
301 1619 8500.000000000000 8000.000000000000

CutPoints: 4

301 1619
8169 1688
8100 9567
230 9498


Формат файла описателя Tile-сервера

В зависимости от модели тайловой системы количество параметров может быть разным. Каждый параметр задается в отдельной строке файла. Формат параметров: <название> <двоеточие> <пробел> <значение>

Пример файла описателя OpenStreetMap.zww:

Type: TILES
Title: OpenStreetMap
Address: http://tile.openstreetmap.org/
Method: OSM
CRS: EPSG:3857
Lat0: 90.000000
Lon0: -180.000000
MinLevel: 0
MaxLevel: 18
Northing: S
UseCache: On
Order: XY

Type: TILES

Обязательный параметр, указывающий, что описывается именно Tile-сервер.

Title: <User Name>

Пользовательское название слоя. В системе отображается в списке слоев. В объектной модели соответствует свойству Layer.UserName. Если параметр отсутствует, в качестве пользовательского названия будет использоваться имя файла.

Method: <Model Name>

Модель запроса к серверу. Допустимые значения:

Таблица 16.

XYZ | - XYZ
BING | - Bing Maps Tile SystemOSM
OSM | - OpenStreetMaps
YAHOO | - Yahoo
CACHE | - Кэш в формате SAS.Планета
ZS | - Тайловый слой ZuluServer
RK | - Роскосмос
NT | - Navitel
MFF | - Maps-For-Free
WIKI | - Wikimapia

Если параметр не указан, по умолчанию принимается значение XYZ.

Address: <Query Template>

Обязательный параметр. Содержит шаблон запроса к источнику тайловых данных. Значение параметра зависит от модели запроса.

[Примечание] Примечание

Для модели CACHE параметр должен содержать корневую папку кэша, например:

Address: d:\SASPlanet\cache\yhsat\
Address: с:\Documents and Settings\All Users\Application Data\Zulu\ztc_542831420\

Для модели ZS параметр должен содержать URL тайлового слоя на ZuluServer, например:

Address: Zulu://zs.Zulugis.ru:6473/osm/Relief_Maps-For_Free.zl

Для всех остальных моделей параметр должен содержать шаблон HTTP запроса, обязательно начинаясь с указания протокола “http://”, например:

Address: http://www.maps-for-free.com/layer/relief

CRS: <EPSG:Code>

Обязательный параметр. Содержит код картографической проекции, например:

CRS: EPSG:3857 # Сферический псевдо МеркаторCRS: EPSG:3395 # МеркаторCRS: EPSG:4326 # WGS 84

Lat0: <latitude>

Широта начала отсчета. Значение по умолчанию: 90°.

Lon0: <longitude>

Долгота начала отсчета. Значение по умолчанию: -180°.

MinLevel: <Zmin>

Минимальный уровень. Для уровня меньше данного запросы не производятся. Значение по умолчанию: 0.

MaxLevel: <Zmax>

Максимальный уровень. Для уровня больше данного запросы не производятся. Значение по умолчанию: 23.

Northing: <N/S>

Ориентация оси Y.

S – ось направлена на юг (значение по умолчанию), N – ось направлена на север.

UseCache: <On/Off>

Признак использования механизма кэширования. Значение по умолчанию: On.

Ext: <extension>

Расширение запрашиваемого файла изображения. Применяется для моделей OSM и MFF. Для остальных моделей расширение изображения либо жестко задано, либо определяется динамически.

Order: <XY/YX>

Определяет последовательность указания параметров X и Y в модели OSM. По умолчанию и для самого сервиса OpenStreetMaps применяется последовательность X\Y. Параметр введен для повышения гибкости модели.


Поддерживаемые типы проекций и датумы

Таблица 17. Типы проекций

Код проекции | Название проекции | Изображение
0 | План-схема |
1 | Широта/Долгота | Рисунок 1114. Широта/Долгота
2 | Широта/Долгота на глобусе | Широта/Долгота на глобусе Рисунок 1115. Широта/Долгота на глобусе
3 | Меркатора | Рисунок 1116. Меркатора
4 | Поперечная Меркатора (Гаусса-Крюгера) | Поперечная Меркатора (Гаусса - Крюгера) Рисунок 1117. Поперечная Меркатора (Гаусса - Крюгера)
5 | Равновеликая коническая Альберса | Равновеликая коническая Альберса Рисунок 1118. Равновеликая коническая Альберса
6 | Робинсона | Рисунок 1119. Робинсона
7 | Синусоидальная | Рисунок 1120. Синусоидальная
8 | Мольвейде | Рисунок 1121. Мольвейде
9 | Стереографическая | Рисунок 1122. Стереографическая
10 | Равноугольная коническая Ламберта | Равноугольная коническая Ламберта Рисунок 1123. Равноугольная коническая Ламберта
11 | Поликоническая | Рисунок 1124. Поликоническая
12 | Равновеликая азимутальная Ламберта | Равновеликая азимутальная Ламберта Рисунок 1125. Равновеликая азимутальная Ламберта
13 | Равнопромежуточная коническая | Рисунок 1126. Равнопромежуточная коническая
14 | Миллера цилиндрическая | Рисунок 1127. Миллера цилиндрическая
15 | Бонне | Рисунок 1128. Бонне
16 | Эккерта IV равновеликая | Эккерта IV равновеликая Рисунок 1129. Эккерта IV равновеликая
17 | Эккерта VI равновеликая | Эккерта VI равновеликая Рисунок 1130. Эккерта VI равновеликая
18 | Ван дер Гринтена I | Ван дер Гринтена I Рисунок 1131. Ван дер Гринтена I
19 | Каврайского VII | Рисунок 1132. Каврайского VII
20 | Вагнера VI | Рисунок 1133. Вагнера VI
21 | Коллиньона | Рисунок 1134. Коллиньона
22 | Голлa стереографическая | Рисунок 1135. Голлa стереографическая
23 | Цилиндрическая равновеликая | Рисунок 1136. Цилиндрическая равновеликая
24 | Равнопромежуточная азимутальная | Рисунок 1137. Равнопромежуточная азимутальная
25 | Винкеля тройная | Рисунок 1138. Винкеля тройная
26 | Эккерта I | Рисунок 1139. Эккерта I
27 | Эккерта II | Рисунок 1140. Эккерта II
28 | Эккерта III | Рисунок 1141. Эккерта III
29 | Эккерта V | Рисунок 1142. Эккерта V
30 | Аитова | Рисунок 1143. Аитова
31 | Ван дер Гринтена IV | Ван дер Гринтена IV Рисунок 1144. Ван дер Гринтена IV
32 | Фуко | Рисунок 1145. Фуко
33 | Локсимутальная | Рисунок 1146. Локсимутальная
34 | Кассини-Зольднера | Рисунок 1147. Кассини-Зольднера
35 | Ласковского | Рисунок 1148. Ласковского
36 | Региональная Меркатора | Рисунок 1149. Региональная Меркатора
37 | Лариве | Рисунок 1150. Лариве
38 | Августа, эпициклоидальная. | Рисунок 1151. Августа, эпициклоидальная
39 | Урмаева цилиндрическая III | Урмаева цилиндрическая III Рисунок 1152. Урмаева цилиндрическая III
40 | Павлова | Рисунок 1153. Павлова
41 | Харченко-Шабановой | Рисунок 1154. Харченко-Шабановой
42 | Урмаева цилиндрическая II | Урмаева цилиндрическая II Рисунок 1155. Урмаева цилиндрическая II
43 | Миллера перспективная | Рисунок 1156. Миллера перспективная
44 | Атлас Оксфорда | Рисунок 1157. Атлас Оксфорда
45 | Атлас Таймс | Рисунок 1158. Атлас Таймс
46 | Тоблера №1 | Рисунок 1159. Тоблера №1
47 | Тоблера №2 | Рисунок 1160. Тоблера №2
48 | Гинзбурга VIII (псевдоцилиндрическая ЦНИИГАиК) | Гинзбурга VIII (псевдоцилиндрическая ЦНИИГАиК) Рисунок 1161. Гинзбурга VIII (псевдоцилиндрическая ЦНИИГАиК)
49 | Гинзбурга IV (измененная поликоническая, ЦНИИГАиК 1939-1949) | Гинзбурга IV (измененная поликоническая, ЦНИИГАиК 1939-1949) Рисунок 1162. Гинзбурга IV (измененная поликоническая, ЦНИИГАиК 1939-1949)
50 | Гинзбурга V (измененная поликоническая, ЦНИИГАиК 1950) | Гинзбурга V (измененная поликоническая, ЦНИИГАиК 1950) Рисунок 1163. Гинзбурга V (измененная поликоническая, ЦНИИГАиК 1950)
51 | Гинзбурга VI (измененная поликоническая ЦНИИГАиК БСЭ) | Гинзбурга VI (измененная поликоническая ЦНИИГАиК БСЭ) Рисунок 1164. Гинзбурга VI (измененная поликоническая ЦНИИГАиК БСЭ)
52 | Гинзбурга IX (измененная поликоническая, ЦНИИГАиК 1966) | Гинзбурга IX (измененная поликоническая, ЦНИИГАиК 1966) Рисунок 1165. Гинзбурга IX (измененная поликоническая, ЦНИИГАиК 1966)
53 | Гномоническая | Рисунок 1166. Гномоническая
54 | Винкеля 1 | Рисунок 1167. Винкеля 1
55 | Quartic Authalic | Рисунок 1168. Quartic Authalic
56 | Каврайского V | Рисунок 1169. Каврайского V
57 | Боттомли | Рисунок 1170. Боттомли
58 | Вагнера IV | Рисунок 1171. Вагнера IV
59 | Вагнера V | Рисунок 1172. Вагнера V
60 | Параболическая Крастера (Путниньша P4) | Параболическая Крастера (Путниньша P4) Рисунок 1173. Параболическая Крастера (Путниньша P4)
61 | Проекция Хотина (равнонаправленная асимметричная ортоугольная проекция) Назначить проекцию можно путем импорта строки proj4: +proj=omerc +lat_0=52.5360318 +lonc=39.7080921 +alpha=0 +gamma=107.688028 +k=1 +x_0=0 +y_0=0 +ellps=WGS84 +units=m +no_defs | Проекция Хотина (проекция косого Меркатора) Рисунок 1174. Проекция Хотина (проекция косого Меркатора)

Таблица 18. Датумы

Код датума | Название проекции | Область применения | Эллипсоид
1 | WGS 84 | Весь мир | WGS 84
2 | Пулково 1942 Германия (MapInfo) | Германия | Krassovsky
3 | ПЗ-90 | Россия | PZ90
4 | NAD 27 Continental US | Континентальная часть США | Clarke 1866
5 | NAD 83 | Аляска, Канада, Центральная Америка, континентальная часть США, Мексика | GRS 80
6 | WGS 72 | Весь мир | WGS 72
7 | WGS 84 Spherical |  | Clarke 1880 (modified for IGN)
8 | GRS 80 | Весь мир | GRS 80
9 | NAD 27 Alaska | Аляска | Clarke 1866
10 | СК-95 | Россия | PZ90
11 | СК-42 | Россия | Krassovsky
12 | Tokyo 1 | Япония, Корея, Окинава | Bessel 1841
13 | Australian Geodetic Datum 84 | Австралия и о-в Тасмания | Australian
14 | Bellevue Ign | о-ва Ефат и Эрроманго | International 1924
15 | Bermuda 1957 | Бермудские о-ва | Clarke 1866
16 | Bogota | Колумбия | International 1924
17 | Campo Inchauspe | Аргентина | International 1924
18 | Canton Astro 1966 | о-ва Феникс | International 1924
19 | Cape | Южная Африка | Clarke 1880
20 | Cape Canaveral | Флорида и Багамские о-ва | Clarke 1866
21 | Carthage | Тунис | Clarke 1880
22 | Chatham 1971 | о-в Чатам (Новая Зеландия) | International 1924
23 | Chua | Парагвай | International 1924
24 | Corrego Alegre | Бразилия | International 1924
25 | Batavia | о-в Суматра (Индонезия) | Bessel 1841
26 | Dos 1968 | о-в Гизо (о-ва Новая Георгия) | International 1924
27 | Easter Island 1967 | о-в Пасхи | International 1924
28 | European Datum 1950 | Австрия, Бельгия, Дания, Финляндия, Франция, Германия, Гибралтар, Греция, Испания, Италия, Люксембург, Нидерланды, Норвегия, Португалия, Швеция, Швейцария | International 1924
29 | European Datum 1979 | Австрия, Финляндия, Испания, Нидерланды, Норвегия, Швеция, Швейцария | International 1924
30 | Gandajika 1970 | Мальдивская Республика | International 1924
31 | New Zealand GD49 |  |
31 | New Zealand Geodetic Datum 1949 | Новая Зеландия | International 1924
32 | GRS 67 | Весь мир | GRS 67
34 | Guam 1963 | о-в Гуам | Clarke 1866
35 | Gux 1 Astro | о-в Гуадалканал | International 1924
36 | Hito XVIII 1963 | Юг Чили (около 53 ю.ш.) | International 1924
37 | Hjorsey 1955 | Исландия | International 1924
38 | Hong Kong 1963 | Гонг-Конг | International 1924
39 | Hu Tzu Shan | Тайвань | International 1924
40 | Indian Thailand Vietnam | Таиланд и Вьетнам | Everest (India 1830)
41 | Indian Bangladesh | Бангладеш, Индия, Непал | Everest (India 1830)
42 | Ireland 1965 | Ирландия | Airy 1930 (modified for Ireland 1965
43 | ISTS 073 Astro 1969 | Диего Гарсия | International 1924
44 | Johnston Island 1961 | о-в Джонстон | International 1924
45 | Kandawala | Шри Ланка | Everest (India 1830)
46 | Kerguyelen Island | о-в Кергелен | International 1924
47 | Kertau | Западная Малайзия и Сингапур | Everest (W.Malaysia and Singapore 1948)
48 | L C 5 Astro | о-ва Кайман и Брак | Clarke 1866
49 | Liberia 1964 | Либерия | Clarke 1880
50 | Luzon Phillippines | Филиппины (кроме о-ва Минданао) | Clarke 1866
51 | Luzon Mindanao Island | о-в Минданао | Clarke 1866
52 | Mahe 1971 | о-в Маэ | Clarke 1880
53 | Marco Astro | о-ва Сальвагем | International 1924
54 | Massawa | Эритрея (Эфиопия) | Bessel 1841
55 | Merchich | Морокко | Clarke 1880 (modified for Merchich)
56 | Midway Astro 1961 | о-в Мидуэй | International 1924
57 | Minna | Нигерия | Clarke 1880
58 | Nahrwan Masirah Island | о-в Масирах (Оман) | Clarke 1880
59 | Nahrwan Un Arab Emirates | Объединенные Арабские Эмираты | Clarke 1880
60 | Nahrwan Saudi Arabia | Саудовская Аравия | Clarke 1880
61 | Naparima 1972 | Тринидад и Тобаго | International 1924
64 | NAD 27 Bahamas | Багамы (кроме о-ва Сан Сальвадор) | Clarke 1866
65 | NAD 27 San Salvador | о-в Сан Сальвадор | Clarke 1866
66 | NAD 27 Canada | Канада (включая о-в Ньюфаундленд) | Clarke 1866
67 | NAD 27 Canal Zone | зона Панамского канала | Clarke 1866
68 | NAD 27 Caribbean | Карибские о-ва (о-ва Тюрк и Кайкос) | Clarke 1866
69 | NAD 27 Central America | Центральная Америка (Белиз, Коста-Рика, Сальвадор, Гватемала, Гондурас, Никарагуа) | Clarke 1866
70 | NAD 27 Cuba | Куба | Clarke 1866
71 | NAD 27 Greenland | Гренландия (п-ов Хейса) | Clarke 1866
72 | NAD 27 Mexico | Мексика | Clarke 1866
73 | NAD 27 Michigan | Мичиган (используется исключительно в плановой системе координат штата 1927) | Clarke 1866 (modified for Michigan)
75 | Observatorio 1966 | о-ва Крово и Флорес (Азорские) | International 1924
76 | Old Egyptian | Египет | Helmert 1906
77 | Old Hawaiian | Гавайи | Clarke 1866
78 | Oman | Оман | Clarke 1880
79 | OSGB 1936 | Англия, о-в Мен, Шотландия, Шетландские о-ва, Уэльс | Airy 1930
80 | Pico De Las Nieves | Канарские о-ва | International 1924
81 | Pitcairn Astro 1967 | о-в Питкерн | International 1924
82 | Provisional South American | Боливия, Чили, Колумбия, Эквадор, Гайана, Перу и Венесуэла | International 1924
83 | Puerto Rico | о-ва Пуэрто-Рико и Виргинские | Clarke 1866
84 | Qatar National | Катар | International 1924
85 | Qornoq | Юг Гренландии | International 1924
86 | Reunion | о-в Маскарен | International 1924
87 | Monte Mario | о-в Сардиния | International 1924
88 | Santo Dos | о-в Эспириту-Санто | International 1924
89 | Sao Braz | о-ва Сан-Мигуэль, Санта-Мария (Азорские) | International 1924
90 | Sapper Hill 1943 | о-в Восточный Фолклендский | International 1924
91 | Schwarzeck | Намибия | Bessel 1841 (modified for Schwarzeck)
92 | South American Datum 1969 | Аргентина, Боливия, Бразилия, Чили, Колумбия, Эквадор, Гайана, Парагвай, Перу, Венесуэла, Тринидад и Тобаго | South American
93 | South Asia | Сингапур | Fischer 1960 (modified for South Asia)
94 | Southeast Base | о-ва Порто-Санто и Мадейра | International 1924
95 | Southwest Base | о-ва Файал, Грациоза, Пико, Сан- Хорхе и Терсейра (Азорские) | International 1924
96 | Timbalai 1948 | Бруней и восточная часть Малайзия (Аравак и Саба) | Everest (India 1830)
97 | Tokyo 2 | Япония | Bessel 1841
98 | Tristan Astro 1968 | Тристан-да-Кунья | International 1924
99 | Viti Levu 1916 | о-в Вити-Леву (о-ва Фиджи) | Clarke 1880
100 | Wake Entiwetok 1960 | Маршалловы о-ва | Hough
101 | WGS 60 | Весь мир | WGS 60
102 | WGS 66 | Весь мир | WGS 66
105 | Yacare | Уругвай | International 1924
106 | Zanderij | Суринам | International 1924
107 | NTF | Франция | Clarke 1880 (modified for IGN)
108 | European Datum 1987 | Европа | International 1924
109 | Netherlands Bessel | Нидерланды | Bessel 1841
110 | Belgium Hayford | Бельгия | International 1924
111 | NWGL 10 | Весь мир | WGS 72
112 | Rikets koordinatsystem 1990 | Швеция | Bessel 1841
113 | Lisboa DLX | Португалия | International 1924
114 | Melrica 1973 D73 | Португалия | International 1924
115 | Euref 98 | Европа | GRS 80
116 | GDA94 | Австралия | GRS 80
117 | New Zealand Geodetic Datum 2000 (NZGD2000) | Новая Зеландия | GRS 80
118 | America Samoa | о-ва Американского Самоа | Clarke 1866
119 | Antigua Astro 1965 | Антигуа, Подветренные о-ва | Clarke 1880
120 | Ayabelle Lighthouse | Джибути | Clarke 1880
121 | Bukit Rimpah | о-ва Бангка и Белитунг (Индонезия) | Bessel 1841
122 | Estonia 1937 | Эстония | Bessel 1841
123 | Dabola | Гвинея | Clarke 1880
124 | Deception Island | о-в Десепшен, Антарктика | Clarke 1880
125 | Fort Thomas 1955 | Подветренные о-ва, Невис, Сент- Киттс | Clarke 1880
126 | Graciosa base 1948 | о-ва Файал, Грациоза, Пико, Сан- Хорхе и Терсейра (Азорские о-ва) | International 1924
127 | Herat North | Афганистан | International 1924
128 | Hermanns Kogel | Югославия (до 1990), Словения, Хорватия, Босния и Герцеговина, Сербия | Bessel 1841
129 | Indian | Пакистан | Everest (Pakistan)
130 | Indian 1954 | Таиланд | Everest (India 1830)
131 | Indian 1960 | Вьетнам | Everest (India 1830)
132 | Indian 1975 | Таиланд | Everest (India 1830)
133 | Indonesian Datum 1974 | Индонезия | International 1924
134 | ISTS061 Astro 1968 | о-в Южная Джорджия | International 1924
135 | Kusaie Astro 1951 | Каролинские о-ва, федерация государств Микронезии | International 1924
136 | Leigon | Гана | Clarke 1880
137 | Montserrat Astro 1958 | Монсерат, Подветренные о-ва | Clarke 1880
138 | Mporaloko | Габон | Clarke 1880
139 | North Sahara 1959 | Алжир | Clarke 1880
140 | Observatorio Met 1939 | о-ва Крово и Флорес (Азорские) | International 1924
141 | Point 58 | Буркина-Фасо и Нигер | Clarke 1880
142 | Pointe Noire | Конго | Clarke 1880
143 | Porto Santo 1936 | о-ва Порто-Санто и Мадейра | International 1924
144 | Selvagem Grande 1938 | о-ва Сальвагем | International 1924
145 | Sierra Leone 1960 | Сьерра-Леоне | Clarke 1880
146 | S JTSK Ferro | Чешская республика | Bessel 1841
147 | Tananarive 1925 | Мадагаскар | International 1924
148 | Voirol 1874 | Тунис / Алжир | Clarke 1880
149 | Virol 1960 | Алжир | Clarke 1880
150 | Hartebeesthoek94 | Южная Африка | GRS 80
151 | ATS77 |  | ATS77 (Average Terrestrial System 1977)
152 | JGD2000 | Япония | GRS 80
158 | DHDN Potsdam Rauenberg | Германия | Bessel 1841
159 | NTF Paris Meridian | Франция | Clarke 1880 (modified for IGN)
160 | Switzerland CH 1903 | Швейцария | Bessel 1841
170 | Hungarian Datum 1972 | Венгрия | GRS 67
171 | Cape 7 Parameter | Южная Африка | WGS 84
172 | AGD84 7 Param Aust | Австралия | Australian
173 | AGD66 7 Param ACT | Австралия A.C.T. | Australian
174 | AGD66 7 Param TAS | Австралия, Тасмания | Australian
175 | AGD66 7 Param VIC NSW | Австралии, Виктория / Новый Южный Уэльс | Australian
176 | NZGD 7 Param 49 | Новая Зеландия | International 1924
177 | Rikets Tri 7 Param 1990 | Швеция | Bessel 1841
179 | Finnish KKJ | Финляндия | International 1924
180 | Без датума |  |
181 | Adindan | Эфиопия, Мали, Сенегал, Судан | Clarke 1880
182 | Afgooye | Сомали | Krassovsky
183 | Ain el Abd 1970 | о-в Бахрейн | International 1924
184 | Anna 1 Astro 1965 | о-ва Кокос | Australian
185 | Arc 1950 | Ботсвана, Лесото, Малави, Свазиленд, Заир, Замбия, Зимбабве | Clarke 1880 (modified for Arc 1950)
186 | Arc 1960 | Кения, Танзания | Clarke 1880
187 | Ascension Islands | о-в Ассенсьон | International 1924
188 | Astro Beacon E | о-в Иводзима | International 1924
189 | Astro B4 Sorol Atoll | о-в Терн | International 1924
190 | Astro Dos 71 4 | Сент- Св. Елены | International 1924
191 | Astronomic Station 1952 | о-в Маркус | International 1924
192 | Australian Geodetic Datum 66 | Австралия и о-в Тасмания | Australian
193 | Пулково 1942 Россия | Россия | Krassovsky
194 | Пулково 1942 Литва | Литва | Krassovsky
195 | Пулково 1942 Венгрия | Венгрия | Krassovsky
196 | Пулково 1942 Польша | Польша | Krassovsky
197 | Пулково 1942 Чехия | Чехия | Krassovsky
198 | Пулково 1942 Латвия | Латвия | Krassovsky
199 | Пулково 1942 Казахстан | Казахстан | Krassovsky
200 | Пулково 1942 Албания | Албания | Krassovsky
201 | Пулково 1942 Эстония | Эстония | Krassovsky
202 | Пулково 1942 Азербайджан | Азербайджан | Krassovsky
203 | Пулково 1942 Азербайджан и Грузия | Азербайджан и Грузия | Krassovsky
204 | ПЗ-90 (ГОСТ Р 51794-2001) | Россия | PZ90
205 | СК-95 (ГОСТ Р 51794-2001) | Россия | PZ90
206 | СК-42 (ГОСТ Р 51794-2001) | Россия | Krassovsky


Установка системы

  • «Установка с сайта»

  • «Выполнение мастера установки»

  • «Устанавливаемые примеры»

В комплект поставки системы входит инструкция по установке системы и ключ защиты Sentinel HASP HL c записанной на нем информацией о приобретенных лицензиях. Без установленного ключа HASP система будет работать в демонстрационном режиме.


Установка с сайта

Дистрибутив системы ZuluGIS доступен для загрузки с сайта компании «Политерм», версия ZuluGIS 2021 предоставлена в двух вариантах: 64-битная и 32-битная.

Скачать дистрибутив можно, пройдя по ссылке:

  • https://www.politerm.com/download/?dl=zulu2021exe_x64 – 64-битный;

  • https://www.politerm.com/download/?dl=zulu2021exe_x86 – 32-битный.

Для установки системы загрузите дистрибутив, запустите его и следуйте инструкциям мастера установки.

В состав стандартного пакета входит:

  • ZuluGIS 2021 – геоинформационная система;

  • ZuluThermo 2021 - расчёты систем теплоснабжения;

  • ZuluSteam 2021 – расчёты систем пароснабжения;

  • ZuluHydro 2021 – расчёты систем водоснабжения;

  • ZuluDrain 2021 – расчёты систем водоотведения;

  • ZuluGaz 2021 – расчёты систем газоснабжения;

  • Коммутационные задачи;

  • ПО для построения графиков.

Дополнительно в состав пакета входит:

  • Microsoft SQL Server 2012 Express LocalDB – облегчённая версия SQL Server 2012 Express для локального хранения данных.

После скачивания и установки дистрибутива на компьютер будет установлена система ZuluGIS 2021 с расчетными компонентами и драйвера ключей защиты Sentinel HASP HL.

[Важно] Важно

В том случае, если на компьютере устанавливалась система ZuluGIS версии 8.0 или более ранней, установка драйвера ключа защиты все равно необходима, поскольку драйвер, используемый со старыми версиями системы ZuluGIS, несовместим с форматом защиты, используемым в системе ZuluGIS 2021.

Для установки драйвера ключа защиты скачайте исполняемый файл по адресу http://www.politerm.com/download/zulu/hasp/srm/HASPUserSetup.exe, запустите его и следуйте инструкциям программы установки.

Для корректной работы систему необходимо устанавливать на компьютер, удовлетворяющий определенным минимальным требованиям.


Выполнение мастера установки

Перед запуском мастера установки рекомендуется закрыть все запущенные программы во избежание конфликтов.

На страницах мастера располагаются кнопки для управления процессом установки:

  • Кнопка Далее открывает следующую страницу мастера.

  • Кнопка Назад открывает предыдущую страницу.

  • Кнопка Отмена прерывает процесс установки программы.

  1. При запуске мастера открывается его первая страница. В зависимости от выбранного варианта дистрибутива заголовок диалога будет немного отличаться (64 бит или 32 бит).

    Рисунок 1175. Страница приветствия

  2. После нажатия кнопки Установить откроется страница лицензионного соглашения, прочитайте его и, если вы принимаете условия, установите галочку Я принимаю условия лицензионного соглашения, затем нажмите кнопку Далее.

    Страница лицензионного соглашения

    Рисунок 1176. Страница лицензионного соглашения

  3. По умолчанию для установки программы предлагается подпапка Zulu 2021 папки Program Files (x86) компьютера (или Program Files для 64х-битных ОС).

    Если требуется установить программу в другую папку, введите путь к ней в поле Установить ZuluGIS 2021 Инженерные расчеты в или нажмите кнопку Изменить... и выберите требуемую папку.

    Пользователь имеет возможность произвести настройку устанавливаемых компонентов. Для этого необходимо поставить галочку Настроить устанавливаемые компоненты. После этого на следующей странице мастера установки потребуется указать устанавливаемые компоненты программы. Данный вариант установки позволяет уменьшить объем дискового пространства, занимаемого программой, но он подходит только для опытных пользователей, четко понимающих, какие компоненты им в дальнейшем понадобятся для работы.

    В том случае, если галочка настройки не была установлена, на диск установятся все компоненты системы.

    После выбора папки и при необходимости выбора настройки компонентов нажмите кнопку Далее.

    Страница выбора установочной папки

    Рисунок 1177. Страница выбора установочной папки

  4. Если на предыдущем этапе была указана настройка устанавливаемых компонентов, то произойдет переход на страницу настройки. Если же была выбрана полная установка, то этот шаг будет пропущен, и откроется страница готовности к установке.

    На странице Выборочной установки в виде списка перечисляются все компоненты программы. По умолчанию все компоненты системы отмечены и готовы к установке. Для изменения списка устанавливаемых компонентов щелкните на значок, расположенный слева от компонента, и в открывшемся списке выберите, какая установка нужна для него:

    • компонент будет установлен на локальный жесткий диск;

    • компонент будет полностью установлен на локальный жесткий диск;

    • компонент будет установлен при необходимости;

    • компонент будет полностью недоступен.

    При выборе компонента в списке справа от списка отображается описание данного компонента. Ниже отображается информация о месте, требуемом для установки выделенного компонента. Для просмотра размеров дисков, доступного места и требуемого места дискового пространства для всей системы надо нажать кнопку Использование диска.

    Кнопка Сброс вернет состояние всех компонентов в исходное, то есть готовое к установке.

    После настройки для перехода к следующей странице нажмите кнопку Далее.

    Страница выбора устанавливаемых компонентов

    Рисунок 1178. Страница выбора устанавливаемых компонентов

  5. После проделанных действий система будет готова к установке, о чем будет указано на странице готовности. Проверьте, правильно ли заданы параметров установки. Если необходимо изменить какой-либо из параметров, вернитесь на соответствующую страницу мастера последовательными нажатиями кнопки Назад и измените требуемый параметр.

    После того как все параметры заданы правильно, нажмите кнопку Установить для начала процесса установки программы.

    Страница готовности установки

    Рисунок 1179. Страница готовности установки

  6. Нажмите кнопку Далее для перехода к странице выбора папки для ярлыков в меню Пуск.

    В ходе установки на странице отображаются выполняемые мастером действия и примерная готовность установки. Также на экране могут появляться различные вспомогательные окна (например, окно установщика драйвера ключа защиты HASP).

    [Важно] Важно

    В некоторых случаях может потребоваться вмешательство в процесс установки. Тогда на экране отобразиться диалоговое окно с текстом уведомления. Внимательно прочтите его, выполните предписания и нажмите соответствующую кнопку диалога.

  7. После завершения установки открывается страница окончания установки. Для того чтобы завершить работу мастера, нажмите кнопку Готово, затем рекомендуется выполнить перезагрузку компьютера.

    Страница окончания установки

    Рисунок 1180. Страница окончания установки

Вместе с системой ZuluGIS устанавливаются также и примеры, демонстрирующие работу ее компонентов.


Устанавливаемые примеры

При установке в каталоге программы на диске автоматически создается подкаталог Examples, в котором собраны примеры, иллюстрирующие возможности системы. Эти же примеры доступны в подпапках папки системы ZuluGIS в меню Пуск. В таблице перечислены примеры карт, поставляемые с системой:

Таблица 19. Поставляемые примеры

Подкаталог каталога программы | Подпапка папки Zulu 2021 в меню «Пуск» | Описание
Теплоснабжение
Termo\Kvartal | Теплоснабжение> Пример квартальной сети | Карта с нанесенной квартальной сетью теплоснабжения.
Termo\Magistral | Теплоснабжение> Пример магистральной сети | Карта с нанесенной магистральной сетью теплоснабжения.
Termo\CTP | Теплоснабжение> Пример четырехтрубной сети | Карта с нанесенной четырехтрубной сетью теплоснабжения.
Termo\Nasos | Теплоснабжение> Пример сети с насосными станциями | Карта с нанесенной системой теплоснабжения с насосными станциями.
Termo\Thermogram | Теплоснабжение> Термограмма | Карта с примером термограммы.
Водоснабжение
Gidro | Водоснабжение> Пример водопроводной сети | Карта жилого квартала с нанесенной водопроводной сетью.
Gidro\Sample1 | Водоснабжение> Пример расчета водопроводной сети | Пример расчета системы водоснабжения« с нанесенной водопроводной сетью из книги »Расчет водопроводных сетей", Москва, Стройиздат 1976г, издание 3.
WaterHammer\ Simple | Водоснабжение> Пример гидроудара 1 | Карта с примерами, иллюстрирующими типичные переходные процессы при различных возмущениях.
WaterHammer\ Append | Водоснабжение> Пример гидроудара 2 | Карта с примерами, иллюстрирующими более сложные переходные процессы.
WaterHammer\Basic | Водоснабжение> Пример гидроудара 3 | Карта с примером расчета переходных процессов в небольшой реальной сети.
Газоснабжение
Gaz\Gaz_v | Газоснабжение> Пример сети высокого и среднего давления | Карта с примером сети газоснабжения высокого и среднего давления.
Gaz\Gaz_n | Газоснабжение> Пример сети низкого давления | Карта с примером сети газоснабжения низкого давления.
Gaz\Gaz | Газоснабжение> Пример структуры газовой сети | Карта с примером настроенной структуры газовой сети.
Пароснабжение
Steam\SteamPipe | Пароснабжение> Пример1 - Фазовый переход | Карта с нанесенной простейшей паропроводной сетью.
Steam\SteamDevices | Пароснабжение> Пример2 - Объекты паропровода | Карта с примерами, иллюстрирующими работу всех устройств, которые можно использовать при создании модели паропроводной сети.
Steam\SteamNetwork | Пароснабжение> Пример3 - Система пароснабжения | Карта с примером реальной системы пароснабжения.
Водоотведение
Drain\Sample1 | Водоотведение> Пример самотечной канализации | Карта с примером самотечной канализации.
Drain\Sample2 | Водоотведение> Пример с подкачивающей станцией | Карта с подкачивающей станцией.
Drain\Sample3 | Водоотведение> Пример с напорным участком | Карта с напорным участком.
Примеры реальных объектов
Building\Axonmtry | Примеры данных> Схема-Здание, Аксонометрия | Схема теплоснабжения здания в аксонометрической проекции.
Building\Floor | Примеры данных> Схема-Здание, 1-й этаж | План этажа здания с нанесенной сетью теплоснабжения.
Building\TEPLO | Примеры данных> Схема-Тепловой узел | Схема теплового узла здания.
Defect | Примеры данных> Учет аварийных работ | Общая карта, включающая в себя слои водоснабжения, теплоснабжения (применяемые в примерах по теплу и воде), а также дополнительный слой с информацией о дефектах сетей.
OpenStreetMap | Примеры данных> Пример карты OSM | Карта, включающая в себя часть города с различными информационными слоями.

Кроме примеров карт, вместе с системой поставляются примеры приложений, разработанных с использованием компонентов ZuluGIS ActiveX на Delphi™ и VisualBasic 6.0.

В подкаталоге Delphi каталога системы собраны примеры по написанию собственных приложений с использованием компонентов Zulu ActiveX на Delphi™.

В подкаталоге VB собраны примеры по написанию собственных приложений с использованием компонентов ZuluGIS ActiveX на Visual Basic™ 6.0.

Некоторые примеры готовых приложений собраны в подпапке Примеры приложений папки программы ZuluGIS в меню Пуск компьютера.


Обновление ПО

  • «Обновление ПО в рамках версии 2021»

  • «Обновление продуктов ZuluGIS 5.2 - ZuluGIS 8.0 до версии ZuluGIS 2021»

Пользуясь программным обеспечением компании Политерм, важно следить за тем, чтобы работа производилась в последней, наиболее полной версии. Наши разработчики постоянно развивают ее возможности, исправляют ошибки и устраняют уязвимости.

Чтобы получать уведомления о новой версии при запуске программа, выберите Справка|Проверка обновлений в меню и отметьте соответствующую опцию. Если установленная версия отличается от свежей, то при запуске программы появится окно:

Рисунок 1181. Версия программы

Скачать свежую версию можно, пройдя по ссылке, указанной в диалоге. Обновление в рамках версии ZuluGIS 2021 и версий ZuluGIS 5.2 - ZuluGIS 8.0 различается. Перед обновлением обязательно ознакомьтесь с соответствующими инструкциями.

[Примечание] Примечание

После обновления версии рекомендуется ознакомиться с историей изменений. Просмотреть историю можно, перейдя на наш сайт или выбрав Справка|История изменений в меню.

Чтобы определить номер установленной версии ZuluGIS, выберите в меню пункт Справка|О программе...; в появившемся окне обратите внимание на цифры, выделенные на рисунке снизу. Данные цифры являются номером версии и датой сборки.

Рисунок 1182. Версия системы


Обновление ПО в рамках версии 2021

Обновление ПО

Для того чтобы обновить установленную на рабочем месте ZuluGIS с сохранением пользовательских настроек и справочников, необходимо устанавливать обновление поверх существующей версии в ту же самую папку (эта опция будет предложена программой-установщиком при установке).

Программа ZuluGIS может выступать как полноценное рабочее место и работать в данными с вашего компьютера в локальном режиме. В этом случае достаточно обновить только ее.

Но ZuluGIS так же может работать и в качестве клиента для ZuluServer. Тогда все данные хранятся на сервере, а пользователь работает с ними удаленно. При такой работе необходимо обновлять программу ZuluServer за компьютером-сервером и ZuluGIS на всех клиентских рабочих местах.

При любом из вышеперечисленных вариантов отдельно обновлять расчетные модули не требуется.

[Примечание] Примечание

Как посмотреть версию ZuluGIS можно узнать здесь, как посмотреть номер ZuluServer можно узнать здесь.

[Внимание] Внимание

Перед установкой обновления обязательно закройте ZuluGIS и ZuluServer.

Процесс установки:

  1. Скачайте дистрибутив обновления:

    • для 32-битной версии – https://www.politerm.com/download/?dl=zulu2021msi_x86

    • для 64-битной версии – https://www.politerm.com/download/?dl=zulu2021msi_x64

  2. Закройте все приложения на компьютере, на котором будет производиться установка ZuluGIS.

  3. Запустите загруженный исполняемый файл.

  4. Следуйте инструкциям мастера установки.

В состав пакетов обновления входит:

  • ZuluGIS 2021 – геоинформационная система

  • ZuluThermo 2021 – расчеты систем теплоснабжения

  • ZuluSteam 2021 – расчеты систем пароснабжения

  • ZuluHydro 2021 – расчеты систем водоснабжения

  • ZuluDrain 2021 – расчеты систем водоотведения

  • ZuluGaz 2021 – расчеты систем газоснабжения

  • Коммутационные задачи

  • ПО для построения графиков

Скачать обновление для ZuluGIS также можно в разделе https://www.politerm.com/download/?pr=zulugis.

После обновления полезно ознакомиться с историей внесенных изменений:

  • https://www.politerm.com/history/

Обновление справки

В текущей версии справка обновляется автоматически. Дату последней редакции справки можно посмотреть в разделе Добро пожаловать.


Обновление продуктов ZuluGIS 5.2 - ZuluGIS 8.0 до версии ZuluGIS 2021

При обновлении программного обеспечения линейки ZULU версий ZuluGIS 5.2, ZuluGIS 6.0, ZuluGIS 7.0, ZuluGIS8.0 до версии ZuluGIS 2021 требуется:

  1. Обновление лицензий, записанных на ключ защиты, до версии ZuluGIS 2021. Переход платный; за подробностями требуется обратиться в отдел продаж.

    Без обновления ключа новые версии программ будут работать в демонстрационном режиме. Само обновление заключается в изменении лицензий на аппаратном ключе защиты; его можно провести удаленно. Для этого пользователям необходимо запустить персонально подготовленный файл прошивки.

  2. Обновление установленного программного обеспечения.

    При использовании локальной версии программ достаточно обновить только ZuluGIS.

    Если используется серверная версия (сервер геонформационной системы), необходимо обновить ZuluServer за компьютером-сервером и ZuluGIS на всех клиентских рабочих местах.

Совместимость

Географическая информационная система ZuluGIS 2021 и ZuluServer 2021 совместимы с предыдущими версиями по программному интерфейсу и формату данных. Карты и графические слои, а также программы и модули расширения, разработанные с использованием предыдущих версий программы и ее объектной модели, также будут работать с ZuluGIS 2021 и ZuluServer 2021.

Таблицы Paradox

Для полноценной поддержки данных, разработанных в ZuluGIS 8.0 и более ранних версиях, может потребоваться установка или настройка BDE. Если используется локальная версия ZuluGIS, настройка выполняется за рабочими местами; при серверном варианте (ZuluServer) настройка выполняется за компьютером-сервером.

Таблицы Microsoft Acсess

В том случае, если для баз данных используется Microsoft Acсess, необходимо учесть, что в 64-битной версии ZuluGIS работа с предустановленным 32-битным ядром Acсess не поддерживается. В результате этого после установки 64-версии открыть базу данных будет НЕВОЗМОЖНО; появится сообщение следующего вида:

  • Ошибка ZB db(E:\газ\for_test\test_REGUL.zb):Не соединиться с СУБД.

  • Ошибка ZB db(E:\газ\for_test\test_REGUL.zb):Не удалось соединиться с источником данных.

Решить данную проблему можно двумя способами:

  1. Предварительная миграция данных в 32-битной версии ZuluGIS (https://www.politerm.com/zuludoc/index.html#zb_migratedata.html). Рекомендуемый, наиболее предпочтительный вариант.

  2. Установка 64-битной версии ядра Acсess (https://www.microsoft.com/ru-RU/download/details.aspx?id=54920). Необходимо учесть, что работа 32-битного и 64-битного ядра Microsoft Offiсe на одном компьютере не предусмотрена. Возможный, но не рекомендованный вариант, особенно при работе с серверными данными.

Обновление ключа до версии ZuluGIS 2021

  1. Подключите аппаратный ключ защиты HASP к компьютеру, за которым будет производиться обновление ключа.

  2. Скачайте программу диагностики ключа: Тест ключа для версий ZuluGIS 7.0, ZuluGIS 8.0 и ZuluGIS 2021

  3. Выполните диагностику ключа и убедитесь, что ключ доступен.

  4. Скачайте исполнительный файл прошивки ключа; он имеет вид HaspUpdate_хххх_номер_ключа.exe

  5. Запустите файл и в открывшемся окне нажмите кнопку Apply Update.

  6. После успешного обновления ключа появится сообщение – Operation successful.

  7. Выполните тест ключа и убедитесь, что лицензии на ключе обновлены.

После обновления лицензии на ключе до версии ZuluGIS 2021 остается возможность работать в ZuluGIS 7.0 и ZuluGIS 8.0. Однако одновременная установка и работа в разных версиях системы ZuluGIS на одном и том же рабочем месте не предусмотрена.

Возможные ошибки

update failed: another update must be installed first – вам отправляли обновление ключа, которое вы пропустили.

  1. Скачайте программу диагностики ключа: Тест ключа для версий ZuluGIS 7.0, ZuluGIS 8.0 и ZuluGIS 2021.

  2. Выполните диагностику ключа и убедитесь, что ключ доступен.

  3. Создайте конфигурационный файл C2V.

  4. Заархивируйте и отправьте его в службу технической поддержки.


Организация защиты продуктов линейки Zulu

  • «Драйвер ключа HASP»

  • « Центр администрирования ключей (Sentinel HASP Admin Control Center)»

  • «Просмотр доступных лицензий на ключе HASP»

  • «Локальная защита»

  • «Корпоративная защита»

  • «Использование расчетных лицензий, на рабочих местах пользователей»

  • «Просмотр доступных лицензий на ключе HASP»

  • «Период использования лицензий»

  • «Срок действия лицензии»

  • «Демонстрационный режим»

  • «Расшифровка лицензий на программные продукты линейки Zulu»

  • «Хранение и эксплуатация ключа»

  • «Возможные проблемы и решения защиты программных продуктов»

Во всех программных продуктах линейки ZuluGIS применяется программно-аппаратная защита с использованием электронного ключа защиты HASP (Sentinel HASP). Ключ представлен в форм факторе USB и может быть локальным (HASP Pro), фиолетового цвета или сетевым (HASP Net), красного цвета. HASP: https://www.euromobile.ru/produkciya/aparatnje_kluchi_sentinel_hl_hasp/.

Рисунок 1183. Ключи защиты

Все ключи защиты продуктов линейки ZuluGIS принадлежат к одной серии с маркировкой QZRKE на корпусе ключа, номер поставщика (vendor) 45939. Один ключ может одновременно защищать несколько программных продуктов или модулей продукта. Ключ подключается к USB порту компьютера. Ключ защиты обладает энергонезависимой памятью, в которой содержится информация о том, с какими программными модулями можно работать, используя данный аппаратный ключ.

Для каждого пользователя ключ конфигурируется индивидуально в соответствии с комплектом поставки программных продуктов.

[Важно] Важно

Ключи защиты более ранних версий (5.2, 6.0, 7.0, 8.0) с версией 2021 работать не будут. После проведения обновления программных модулей до версии 2021 по соответствующему договору ключи, подлежат либо замене, либо дополнительной программной прошивке.


Драйвер ключа HASP

Драйвер ключа HASP обязательно должен быть установлен на всех компьютерах, которые будут использовать ключ защиты. Драйвер поставляется в составе установочного пакета ZuluServer и ZuluGIS и устанавливается вместе с системой. Отдельно драйвер ключа можно скачать по ссылке: https://www.politerm.com/download/zulu/hasp/srm/HASPUserSetup.exe

Если драйвер требуется переустановить, то установочный файл драйвера ключа можно скачать с нашего сайта (Скачать) и, в зависимости от скачанного варианта, запустить из командной строки: Hinstall\haspdinst.exe /i или с помощью графического интерфейса.

После установки драйвера HASP становится доступен центр администрирования ключей Sentinel HASP Admin Control Center.


Центр администрирования ключей (Sentinel HASP Admin Control Center)

После установки драйвера HASP становится доступен центр администрирования ключей Sentinel HASP (Sentinel HASP Admin Control Center). Он запускается из WEB-браузера по адресу http://localhost:1947/ (операционная система должна разрешать работу по порту 1947).

[Примечание] Примечание

HASP Admin Control Center так же возможно запустить из ZuluGIS – меню Сервис|Параметры, вкладка Hasp, кнопка HASP Admin Control Center.

Центр администрирования ключей Sentinel HASP

Рисунок 1184. Центр администрирования ключей Sentinel HASP

Sentinel HASP Admin Control Center должен открываться на всех компьютерах (в том числе и удаленных рабочих местах пользователей), которые будут использовать ключ. На странице Sentinel Keys http://localhost:1947/_int_/devices.html должен быть доступен ключ защиты. Наш ключ защиты имеет уникальный для каждого ключа Key ID (HASP ID), и одинаковый для всех номер поставщика (vendor) 45939.

На компьютере, в который установлен ключ, проблем с отображением ключа в списке доступных быть не должно.

Список ключей в центре администрирования ключей

Рисунок 1185. Список ключей в центре администрирования ключей

При использовании сетевого ключа и сложной конфигурации сети или при работе через интернет, если на удаленных компьютерах информация о сетевом ключе не выводится необходимо произвести дополнительные настройки.

На компьютере, где установлен ключ:

  • Ключ должен быть сетевым, это всегда ключ красного цвета, ключ должен быть подключен к компьютеру и нем должна гореть красная лампочка (горит если установлен драйвер ключа.

  • Порт 1947, по которому работает Sentinel HASP Admin Control Center должен быть открыт.

  • Необходимо убедиться, что ключ доступен в центр администрирования ключей Sentinel HASP Admin Control Center http://localhost:1947/_int_/devices.html

  • В центре администрирования ключей Sentinel HASP на странице настроек http://localhost:1947/_int_/config_from.html должен быть разрешен доступ тех или иных клиентов к использованию сетевого ключа данного компьютера (по умолчанию указано allow=all – разрешено всем).

На удаленных компьютерах (рабочих местах пользователей):

  • Порт 1947, по которому работает Sentinel HASP Admin Control Center должен быть открыт.

  • Должен быть установлен драйвер ключа HASP

  • В центре администрирования ключей Sentinel HASP Admin Control Center на странице Configuration http://localhost:1947/ru.19.0.alp/config_to.html, необходимо:

    • Включить опцию Allow access to remote licenses.

    • Включить Aggressive Search for Remote Licenses.

    • Отключить Broadcast Search for Remote Licenses.

    • В параметре Specify Search Parameters указать публичный (белый) IP адрес компьютера, где установлен ключ защиты.

    • Нажать кнопку Submit.

Порт 1947 может блокироваться настройками локальной сети или брандмауэром. При подключении к сетевому ключу через интернет настраивается переадресация портов из сети интернет на адрес компьютера с ключом.

После настройки HASP Admin Control Center информацию о программных продуктах, доступных для работы с ключом, можно посмотреть при помощи утилиты ZuluGIS HASP Test.

Дополнительно центр администрирования позволяет просматривать информацию по составу и количеству лицензий на программные модули, количеству задействованных лицензий, а при открытии данного окна за компьютером, в который установлен ключ, можно увидеть какое рабочее место занимает лицензию и прервать использование лицензий.

Подробное описание Sentinel HASP Admin Control Center можно прочитать по адресу http://localhost:1947/_int_/ACC_help_index.html.


Локальная защита

В локальном режиме защиты программные продукты, записанные в конфигурацию ключа, могут работать только на том компьютере, к которому подключен данный ключ, при этом сам ключ может быть как локальным, так и сетевым.

Чаще всего таким образом лицензируется однопользовательская ZuluGIS и пакеты инженерных расчетов.

До 2021 года, чтобы привязать ключ HASP к определенному рабочему месту, на сетевой ключ записывалась локальная лицензия на ZuluServer. В таком случае для использования ZuluServer в виртуальной среде требовалось либо «пробросить» USB порт в виртуальную среду, либо заменить лицензию на ZuluServer на сетевую (корпоративная защита).

Для работы программного обеспечения потребуется:

  1. Установить ключ в рабочее место.

  2. Убедиться что драйвер ключа установлен и на ключе горит красная лампочка (подробнее).

  3. Выполнить тест ключа, после чего на экран будут выведены доступные лицензии. подробнее.

[Предупреждение] Предупреждение

Лицензии, записанные в локальном режиме защиты, не могут работать за терминальным сервером. Необходим сетевой ключ и корпоративная (сетевая) лицензия.


Корпоративная защита

При корпоративной защите используется сетевой ключ HASP HL Net (Sentinel HASP Net), и на ключ записываются сетевые лицензии. Один ключ может использоваться при работе нескольких пользователей, чьи компьютеры находятся в сети. На сетевом (корпоративном) ключе по каждому программному модулю записывается количество лицензий, лицензии имеют свойство [seats: n] , где n – количество лицензий на одновременное использование программного продукта c разных рабочих мест.

Корпоративная защита доступна для всех продуктов. Чаще всего используется при использовании ZuluServer, когда в одном сетевом ключе может быть задано количество рабочих мест, которые могут одновременно использовать каждый программный расчетный модуль, и количество одновременных подключений к ZuluServer.

[Примечание] Примечание

Подробней о защите ZuluServer. При работе ZuluServer на виртуальной машине есть свои особенности.

Для использования корпоративной защиты должен быть выполнен ряд требований.

На компьютере, где установлен ключ:

  1. Ключ должен быть сетевым, модели NetHasp. Это всегда ключ с пластмассой красного цвета, он должен быть подключен к компьютеру, и на нем должна гореть красная лампочка.

  2. Должен быть установлен драйвер ключа HASP (подробнее).

  3. Тест ключа выполняется и выводит доступные лицензии, подробнее.

  4. Системная служба hasplms.exe Sentinel LDK Licence Manager должна быть запущена.

  5. На странице http://localhost:1947/_int_/config_from.html необходимо разрешить доступ тех или иных клиентов к использованию сетевого ключа данного компьютера (по умолчанию указано allow=all – разрешено всем).

  6. Операционная система должна разрешать работу по порту 1947.

На компьютерах пользователей:

  1. Должен быть установлен драйвер ключа HASP, несмотря на то, что сам ключ в компьютере может отсутствовать. В случае если он не установлен, выдается сообщение об ошибке связи с менеджером лицензий.

  2. Системная служба hasplms.exe Sentinel LDK Licence Manager должна быть запущена.

  3. Ключ должен быть доступен в окне центра администрирования ключей Sentinel Hasр: http://localhost:1947/_int_/devices.html. Если информация о сетевом ключе не выводится, то на странице Configuration необходимо задать настройки по опросу сетевого ключа (в том числе конкретно указать IP-адреса или имена опрашиваемых компьютеров)

    • Включить опцию «Allow access to remote licenses»;

    • Отключить опцию «Broadcast Search for Remote Licenses»;

    • Задать адреса машин с ключом в параметре «Specify Search Parameters»(Remote License Search Parameters);

    • Включить опцию «Aggressive Search for Remote Licenses» (может отсутствовать, в зависимости от версии Sentinel Admin Control);

    • Нажать Submit.

      Если в сети установлено несколько сетевых ключей, то общее количество доступных лицензий на каждый программный модуль будет суммироваться.

  4. Тест ключа выполняется и выводит доступные лицензии, подробнее.

  5. Операционная система должна разрешать работу по порту 1947.

  6. Для каждого программного продукта, предполагаемого к использованию в режиме корпоративной защиты, должен быть прописан признак опроса сетевого ключа. В противном случае продукт будет работать в демонстрационном режиме.

    Для ZuluGIS признак опроса сетевого ключа можно задать и непосредственно из программы: команда меню Сервис|Параметры, вкладка HASP – устанавливаются флажки напротив нужного модуля.

    Подробней о признаке опроса сетевого ключа.


Использование расчетных лицензий, на рабочих местах пользователей

Один сетевой ключ красного цвета (HASP NET) может использоваться при работе нескольких пользователей, чьи компьютеры находятся в локальной сети или сети интернет. Сетевой ключ одновременно будет осуществлять лицензирование ZuluServer и расчётных задач.

На сетевом ключе NetHasp записано количество рабочих мест, которые могут одновременно использовать каждый расчетный модуль.

[Примечание] Примечание

Для просмотра доступных HASP ключей и лицензий, записанных на ключ, используйте утилиту Тест ключа (ZuluGIS HASP Test).

Для того, чтобы удаленное рабочее место пользователя могло использовать ключ защиты, размешенный в сети, необходимо открыть настройки программы ZuluGIS и убедиться, что:

  • На удаленном рабочем месте ключ доступен в центре администрирования ключей Sentinel HASP Admin Control Center.

  • При просмотре информации по ключу отображается ID ключа защиты и список доступных расчетных лицензий.

  • Напротив наименования задачи установлена опция Использовать сетевой ключ.

Диалоговое окно Параметры. Вкладка HASP

Рисунок 1186. Диалоговое окно Параметры. Вкладка HASP

Его также можно указать в реестре компьютера. Файл для регистрации этих переменных можно скачать по адресу NetHasp.reg.

Для ZuluServer, в случае если лицензия сетевая ( ZuluServer 2021 [id: 3, seats: 1, users: xxx]), признак опроса сетевого ключа указывается в конфигурационном файле (ZuluServ.cfg). Если лицензия локальная ( ZuluServer 2021 [id: 3, users: xxx]), требуется физическая установка ключа защиты в компьютер-сервер.


Просмотр доступных лицензий на ключе HASP

Информацию о программных продуктах, доступных для работы с ключом, можно посмотреть при помощи утилиты ZuluGIS HASP Test, доступной по ссылке https://www.politerm.com/download/?dl=zuluhaspupdate80.

Рисунок 1187. Утилита «Zulu80HaspUpdate»

После запуска программы нажмите кнопку Информация по ключам. В окне программы появится список локальных и сетевых ключей, доступных данному компьютеру. При выборе ключа в списке в информационной области отображается информация о ключе и полный список записанных на него лицензий и их количество:

  • Hasp Net10, id: 8459***** – уникальный номер ключа (Net10 – сетевой ключ, Pro – локальный);

  • Лицензия ZuluServer может записана на ключ в виде:

    • «локальной» без указания seats: 1 – в этом случае ключ HASP должен быть подключен к USB-порту компьютера, где установлен ZuluServer;

    • «сетевой» с указанием seats: 1 – в этом случае ключ HASP может быть подключен к USB-порту любого компьютера в сети;

  • users: 20 – количество одновременных подключений к ZuluServer;

  • ZuluThermo Naladka – лицензия на наладочный расчет тепловой сети;

  • id: 1 – порядковый номер лицензии на ключе, отображаемый в окне центра администрирования ключей http://localhost:1947/_int_/features.html;

  • seats: 10 – количество рабочих мест, имеющихся на сетевом ключе, которые могут одновременно использовать использовать данную лицензию;

  • queries: XX – количество доступных запросов веб-служб в сутки;

  • max tags: XX – количество доступных тегов для ZuluOPC;

  • Версия программного обеспечения указывается рядом с названием продукта: 2021, 8.0 или 7.0.

Расшифровка лицензий программных продуктов можно посмотреть в разделе Расшифровка лицензий на программные продукты линейки ZULU.

[Примечание] Примечание

Информацию о том, какие программные модули записаны на ключ защиты, какие модули в данный момент задействованы и какие свободны, также можно посмотреть на странице Sentinel HASP Admin Control Center http://localhost:1947/_int_/devices.html, нажав на кнопку Net Features.


Период использования лицензий

При использовании сетевого ключа (красный) и совмещении корпоративной защиты рабочих мест c защитой ZuluServer на одном ключе, важно понимать, какое время используются лицензии на программное обеспечение. В таком режиме высока вероятность одновременного обращения пользователей за лицензиями, а раз они конкурентные, можно встретить сообщения о работе программ в демонстрационном режиме.

Лицензирование ZuluServer

При использовании ZuluServer надо четко разделять использование лицензии при запуске ZuluServer от подключения удаленного пользователя к ZuluServer за данными.

  • Лицензия на ZuluServer задействуется в момент запуска сервера, она считается занятой все время работы службы ZuluServer.

  • После запуска ZuluServer предоставляет подключения к серверу геоданных, количество подключений регламентировано лицензий, к примеру, ZuluServer 2021 [id: 3, seats: 1, users: 15] – сервер на 15 подключений. Подключения являются конкурентными и доступны всем, кто имеет подключение в серверу, по очереди. Подключение задействуется в момент обращения к серверу геоданных, и не важно для каких целей: открытия каталога сервера геоданных для просмотра папок, открытия слоя на просмотр, редактирования данных слоев или структуры, обращения в серверу собственных приложений, написанных с применением библиотеки ActiveX компонентов. Количество активных соединений можно посмотреть в Мониторе ZuluServer и в Администраторе ZuluServer. Подключение закрывается в случае, если:

    • пользователь закрывает ZuluGIS;

    • пользователя принудительно отключают в Администраторе ZuluServer;

    • время бездействия пользователя превышает то время, которое регламентировано настройками ZuluServer.

Лицензии на расчеты

Независимо от расчетного модуля и вида расчета, каждая задача лицензируется отдельно. На ключ записывается максимальное количество одновременных расчетов, к примеру, ZuluThermo 2021 Naladka [id: 7, seats: 1], ZuluThermo 2021 Poverka [id: 8, seats: 2] – на ключ записана одна лицензия на наладочный расчет по теплоснабжению и две лицензии на поверочный расчет по теплоснабжению.

Лицензия на расчеты являются конкурентными и могут использоваться всеми пользователями ZuluServer по очереди. Лицензии задействуются в тот момент, когда пользователь нажимает кнопку Расчет. Лицензия считается занятой, пока у пользователя открыто окно расчетного модуля и в окне сообщений отображается протокол с результатами. Количество задействованных лицензий на расчеты можно посмотреть в окне центра администрирования ключей Sentinel Hasр: http://localhost:1947/_int_/features.html. В таблице указывается несколько колонок, значимыми будут являться:

  • Vendor – продукция компании Политерм всегда имеет Vendor 45939

  • Key ID – уникальный номер ключа пользователей

  • Feature – уникальный номе лицензии, расшифровка лицензий на программные продукты линейки Zulu доступна в разделе hasp_features

  • Location – адрес компьютера с ключом

  • Concurrency – количество конкурентных лицензий

  • Logins – количество задействованных лицензий

Лицензия освобождается в момент закрытия окна расчетов или принудительно в окне центра администрирования ключей Sentinel Hasр за компьютером с ключом.

При использовании локального ключа (фиолетовый) лицензии записываются в единичном экземпляре и доступны пользователю все время, пока ключ установлен в его рабочее место. После извлечения ключа все программное обеспечение начинает работать в демонстрационном режиме. Ключ не «привязывается» ни к программной, ни аппаратной инфраструктуре компьютера и может поочередно использоваться в разных рабочих местах.


Срок действия лицензии

Срок использования лицензии записанных на аппаратный ключ защиты ничем не ограничен. С выходом новой версии программы лицензии продолжают работать в рамках той версии, в которой записывались. Для перехода на новую версию программы необходимо обновлять лицензии на ключе, для этого всегда можно связаться с отделом продаж.


Демонстрационный режим

Без ключей защиты все программные продукты работают в демонстрационном режиме. Ограничения, накладываемые на работу в демонстрационном режиме, зависят от конкретного программного модуля.

Ограничения в демонстрационном режиме описаны на странице Демонстрационный режим.


Расшифровка лицензий на программные продукты линейки Zulu

ID | Name features | Наименование лицензии
Лицензирование ГИС компонентов
1 | Zulu 2021 | Однопользовательская ГИС или клиент для работы с ZuluServer. Если справа написано [id: 1], то версия локальная; если [id: 1, seats: n], то версия сетевая, где n – количество рабочих мест.
2 | ZuluXTools 2021 | Библиотека ActiveX компонентов для разработки приложений
3 | ZuluServer 2021 | Многопользовательская ГИС, в скобках будет указано количество одновременных соединений 2, 3, 5, 10, 15, 20, 50, 100, 150, 200, 250 и др. Если справа написано [id: 3, users: n] , то версия локальная; если [id: 3, seats: 1, users: n], то версия сетевая. В обоих вариантах n – количество одновременных соединений.
4 | ZuluWebServices 2021 | Веб-службы ZuluServer 2021 (WMS/WFS/ZWS) Справа указывается [queries: n, custom: yes], где n – максимальное количество запросов в сутки, custom: yes – кастомизация включена.
20 | CommutationTask 2021 | Коммутационные задачи (топологический анализ отключений, переключений)
21 | PiezoGraph 2021 | ПО для построения пьезометрических графиков
34 | ZuluOPC Service 2021 | Набор программ для получения и обработки информации с приборов учета, датчиков, контроллеров и SCADA-систем. С ограничением по количеству параметров: до 1000, 2000, 5000, 10000, 50000
ZuluThermo – теплогидравлические расчеты тепловых сетей
6 | ZuluThermo 2021 Reserve | Расчет резерва пропускной способности тепловой сети
7 | ZuluThermo 2021 Naladka | Наладочный теплогидравлический расчет тепловой сети (наладка)
8 | ZuluThermo 2021 Poverka | Поверочный теплогидравлический расчет тепловой сети (расчет режимов)
9 | ZuluThermo 2021 ThermoGraph | Расчет температур на источнике
10 | ZuluThermo 2021 Construct | Конструкторский расчет тепловой сети
11 | ZuluThermo 2021 ThermoLeaks | ПО для расчета нормативных тепловых потерь в тепловых сетях (325 Приказ МЭ РФ)
12 | ZuluThermo 2021 Reliability | Расчет надежности системы теплоснабжения
35 | ZuluThermo 2021 Thermogram | Анализ термограмм
22 | ZuluNetTools 2021 Thermo | ZuluNetTools 1.0 для ZuluThermo
41 | ZuluThermo 2021 Analysis | Поиск утечек и дефектов
39 | ZuluThermo 2021 Calibration | Калибровка тепловой сети
44 | Thermo Orthogonal Scheme 2021 | Построение технологических схем
ZuluHydro – гидравлические расчеты водопроводных сетей
5 | ZuluHydro02021 Reserve | Расчет резерва пропускной способности водопроводной сети
13 | ZuluHydro 2021 Poverka | Поверочный гидравлический расчет водопроводной сети
14 | ZuluHydro 2021 Construct | Конструкторский гидравлический расчет водопроводной сети
15 | ZuluHydro 2021 Gidroudar | Расчет переходных процессов (гидроудар)
23 | ZuluNetTools 2021 Hydro | ZuluNetTools 1.0 для ZuluHydro
37 | ZuluHydro 2021 Calibration | Калибровка водопроводной сети
38 | ZuluHydro 2021 Pump Optimize | Оптимизация насосного оборудования
36 | ZuluHydro 2021 Analysis | Поиск утечек и дефектов
32 | ZuluProfile 2021 | Экспорт продольного профиля в DXF
45 | ZuluHydro Orthogonal Scheme 2021 | Построение технологических схем
ZuluSteam – теплогидравлические расчеты паропровода
16 | ZuluSteam 2021 Naladka | Наладка паровой сети
17 | ZuluSteam 2021 Poverka | Поверочный расчет паровой сети
24 | ZuluNetTools 2021 Steam | ZuluNetTools 1.0 для ZuluSteam
ZuluGaz – Гидравлические расчеты газовых сетей
18 | ZuluGaz 2021 Poverka | Поверочный расчет газопроводов низкого, среднего и высокого давления
19 | ZuluGaz 2021 Construct | Конструкторский расчет газовой сети
29 | ZuluGaz 2021 Vibros | Определение объема природного газа при аварийных выбросах
30 | ZuluGaz 2021 Balloon | Определение времени работы системы газоснабжения с использованием баллонного запаса
31 | ZuluGaz 2021 Reserve | Расчет резерва пропускной способности газовой сети
32 | ZuluProfile 2021 | Экспорт продольного профиля в DXF
40 | ZuluGaz Orthogonal Scheme 2021 | Построение технологических схем
ZuluDrain – гидравлические расчеты канализационных сетей
27 | ZuluDrain 2021 Poverka | Поверочный расчет сетей водоотведения
28 | ZuluDrain 2021 Construct | Конструкторский расчет сетей водоотведения
33 | ZuluNetTools 2021 Drain | ZuluNetTools 1.0 для ZuluDrain
32 | ZuluProfile 2021 | Экспорт продольного профиля в DXF


Хранение и эксплуатация ключа

При эксплуатации ключа необходимо бережно с ним обращаться, оберегать его от падения, намокания, воздействий слишком высоких или низких температур и каких-либо механических воздействий, которые могут привести к его поломке.

При присоединении ключа к порту USB нельзя прилагать слишком много усилий; если ключ свободно не вставляется в порт, необходимо проверить, правильно ли вы его присоединяете.

Нельзя допускать засорение разъема ключа; когда ключ не присоединен к компьютеру, разъем лучше защитить специальной крышечкой, которая идет в комплекте с ключом. В том случае, если необходимо произвести чистку ключа, делать ее нужно сухой тканью; ни в коем случае нельзя пользоваться растворителями, кислотами или другими специфическими жидкостями.

Только при правильном хранении и эксплуатации ключа мы можем гарантировать его нормальную работу.

Не теряйте ключ, так как без него система будет работать только в демонстрационном режиме. При утере ключ восстановить невозможно.


Возможные проблемы и решения защиты программных продуктов

Иногда у пользователя при работе с программным обеспечением может возникнуть проблема по защите программных продуктов, когда даже при установленном ключе система работает в демонстрационном режиме.

Для начала необходимо определиться, что именно работает в демонстрационном режиме.

Демонстрационный режим может наблюдаться:

  • в работе модулей инженерных задач (ZuluThermo, ZuluHydro, ZuluDrain, ZuluGaz, ZuluSteam, Модуль построения графиков, Коммутационные задачи) в момент запуска расчета или построения графика;

  • в редакторе ZuluGIS при внесении изменения в графический слой (изменение, добавление, удаление объектов);

  • в работе ZuluServer на момент запуска.

Во всех программных продуктах линейки Zulu применяется программно-аппаратная защита с использованием локального или сетевого ключа электронного защиты HASP HL. Независимо от типа ключа, они имеют маркировку QZRKE на самом ключе и Vendor 45939 в центре администрирования ключей HASP.

Список ключей в центре администрирования ключей

Рисунок 1188. Список ключей в центре администрирования ключей

Защита производится двумя типами ключей:

  • Локальный ключ HASP HL Pro – фиолетового цвета, работает только на том компьютере, к которому подключен.

  • Сетевой ключ HASP HL Net – красного цвета. Пользователи на клиентских рабочих местах обычно его не видят, так как он установлен в компьютер сервер.

    Рисунок 1189. Ключи защиты

Модули инженерных задач работают в демонстрационном режиме

При такой проблеме сначала надо посмотреть конфигурацию ключа, убедиться в наличии лицензии на выполняемый расчет и соответствии версии установленного программного обеспечения и версии лицензии на ключе:

  • если лицензии нет, её можно приобрести и записать на ключ удаленно, для этого можно обратиться в отдел маркетинга;

  • если лицензия доступна и её версия не соответствует версии программного обеспечения, к примеру, на ключе версия 8.0, а установлено программное обеспечение версии 2021. В таком случае необходимо обновить лицензии на ключе, что можно сделать удаленно, для этого обратитесь в отдел маркетинга;

  • если тест ключа не выполняется, значит наблюдается проблемы с доступом к ключу. Об этом ниже, зависит от типа ключа.

Проблемы, которые могут наблюдаться при использовании локального ключа:

  1. Ключ защиты не подключен, необходимо подключить ключ HASP.

  2. Если ключ подключен, то могут наблюдаться проблемы с драйвером ключа. Драйвер ключа может быть не установлен, или после обновления Windows он мог «слететь». Требуется переустановить драйвер ключа HASP.

Проблемы, которые могут наблюдаться при использования сетевого ключа:

Вариант 1. Если тест ключа выполняется и необходимая лицензия присутствует на ключе, то скорее всего в настройках расчетных модулей не установлен признак опроса сетевого ключа. Опрос сетевого ключа необходимо задать для каждого расчетного модуля (самый распространенный вариант):

В версии ZuluGIS 2021 модули для работы с сетевым ключом указываются во вкладке HASP в диалоге настройки параметров и интерфейса системы.

В версии ZuluGIS 8.0 и ниже это можно сделать в настройках каждого модуля по отдельности:

  • ZuluThermo

  • ZuluHydro

  • ZuluDrain

  • ZuluGaz

  • ZuluSteam

  • Модуль построения графиков

  • Коммутационные задачи

Вариант 2. Если тест ключа выполняется, необходимая лицензия присутствует на ключе и признак опроса сетевого ключа установлен, то скорее всего данный расчет уже занят пользователями. На сетевой ключ записывается количество конкурентных лицензий на выполнение расчета, которые могут использоваться одновременно. Посмотреть количество задействованных лицензий можно в Sentinel Admin Control Center в разделе Features, где:

  • Feature – наименование лицензий, расшифровка кодов лицензий тут;

  • Concurrency – общее количество конкурентных лицензий;

  • Sessions – количество занятых лицензий.

В таком случае можно подождать, пока коллеги досчитают и освободят лицензию, закрыв окно расчетной задачи; в дальнейшем можно обратиться в отдел маркетинга и приобрести дополнительные лицензии.

Вариант 3. Тест ключа НE выполняется, Центр администрирования ключей HASP Sentinel Admin Control Center не открывается. Следовательно, есть проблемы с драйвером ключа HASP. Драйвер ключа не установлен или после обновления Windows он мог «слететь». Требуется переустановить драйвер ключа HASP.

Вариант 4. Тест ключа не выполняется, наш ключ (vendor 45939) недоступен в центре администрирования Sentinel Admin Control Center.

Причин, по которым информация о нем недоступна, много, рассмотрим их:

  • Ключ защиты не подключен в компьютер-сервер, необходимо подключить ключ HASP.

  • Порт 1947, по которому осуществляется работа сетевого ключа, заблокирован антивирусным программным обеспечением или брандмауэром Windows. Он может быть заблокирован как на клиентской стороне, так и на сервере, чаще на сервере. Требуется добавить порт 1947 в исключения программы, которая блокирует его.

  • Подключение к серверу лицензий осуществляется через интернет (при наличии внешнего IP за компьютером сервером лицензий) или ключ установлен в компьютер сети другого домена. Необходимо произвести настройку рабочего места и указать IP или доменное имя компьютера, в который установлен ключ. Для этого необходимо открыть Центр администрирования ключей HASP Sentinel Admin Control Center и произвести ряд настроек:

    • Включить опцию «Allow access to remote licenses»;

    • Отключить опцию «Broadcast Search for Remote Licenses»;

    • Задать адреса машин с ключом в параметре «Specify Search Parameters»;

    • Нажать Submit.

Редактор ZuluGIS работает в демонстрационном режиме

Если проблема возникла с геоинформационной системой Zulu, то следует уточнить, на какой программный продукт приобреталась лицензия, на ZuluGIS или ZuluServer. Это будет отображено в конфигурации ключа:

  • ZuluGIS – используется при однопользовательском режим работы (в тесте ключа Zulu 2021);

  • ZuluServer – используется при многопользовательском режиме работы (в тесте ключа ZuluServer 2021).

Приобретался ZuluServer – многопользовательский режим

В случае если подразумевалось использование ZuluServer, проблема чаще всего кроется в организации процесса работы. Скорее всего вы пытаетесь редактировать данные, открытые с использованием файлового доступа, – локальные слои, хотя в данном случае можете редактировать только слои, открытые с сервера геоданных, – серверные слои.

  • Как понять, как открыты данные?

  • Как создать подключение с сервером?

  • Как опубликовать данные?

Приобреталась ZuluGIS – однопользовательская ГИС

  1. Ключ защиты не подключен, необходимо подключить ключ HASP.

  2. Если ключ подключен, могут наблюдаться проблемы с драйвером ключа. Драйвер ключа может быть не установлен, или после обновления Windows он мог «слететь». Требуется переустановить драйвер ключа HASP.

Остались вопросы

Если остались вопросы, свяжитесь с технической поддержкой. Сообщите о том:

  • какой используется ключ (локальный или сетевой);

  • установлен ли признак опроса сетевого ключа в настройках модуля;

  • при каких действиях выявлен демонстрационный режим, приложите скриншот сообщением об ошибке;

  • выполните тест ключа и приложите скриншот с результатом.


Демонстрационный режим

Без ключей защиты все программные продукты работают в демонстрационном режиме, что позволяет ознакомиться с основными функциями и возможностями программного обеспечения. Ограничения, накладываемые на работу в демонстрационном режиме, зависят от конкретного программного модуля.

[Предупреждение] Предупреждение

Демонстрационная версия программного обеспечения не может использоваться для решения коммерческих задач. Использование программного обеспечения в коммерческих целях возможно только при получении лицензии.

Ограничения в демонстрационном режиме:

Продукт | Задача | Ограничение
ZuluGIS и ZuluXTools | Редактирование векторных слоев | В каждый слой можно ввести не более 150 объектов.
 | Трансформация растров | Трансформируются только растры, у которых количество точек по ширине и высоте меньше 1000.
 | Запись в растр | На растре будут отображаться надписи ZuluGIS 2021 Demo Version.
 | Слои в памяти | На карте будут отображаться надписи ZuluGIS 2021 Demo Version.
ZuluServer | Число соединений | Количество одновременных подключений не более двух.
 | Редактирование | Те же ограничения, что и для ZuluGIS.
 | Отображение | В окне карты на клиенте будут отображаться надписи ZuluGIS 2021 Demo Version.
 | Веб-службы ZuluServer (WMS/WFS/ZWS) | 250 запросов в сутки. На карте будут размещены водные знаки о работе в «Демонстрационном режиме».
ZuluThermo | Наладочный расчет Поверочный расчет Конструкторский расчет Расчет надежности | Суммарное количество потребителей и обобщенных потребителей в рассчитываемой подсети не должно превышать 15.
 | Расчет тепловых потерь | В отчет выводятся результаты только за январь месяц.
 | Анализ термограмм | Количество растров не должно превышать одного. Размер растра не должен превышать 500x500 пикселей.
 | Калибровка тепловой сети | Количество узлов для калибровки не должно превышать 5.
ZuluHydro | Поверочный расчет Конструкторский расчет | Суммарное количество узлов отбора воды не должно превышать 15.
 | Гидроудар | Разрешен расчет только поставляемых с программой примеров.
 | Калибровка водопроводной сети | Количество узлов калибровки не должно превышать 5.
ZuluSteam | Поверочный расчет Наладочный расчет | Количество потребителей не должно превышать 5.
ZuluGaz | Поверочный расчет конструкторский расчет | Количество потребителей не должно превышать 10.
ZuluDrain | Поверочный расчет конструкторский расчет | Количество потребителей не должно превышать 15.
ZuluOPC | Количество подключенных узлов OPC | Не более 10 одновременно подключенных узлов OPC.
Пьезографик График падения давления Продольный профиль | Построение пьезометрического графика | Пьезографик строится, если в пути не более 15 узлов.
Коммутационные задачи | Отчет | Полный результат анализа сети выводится при количестве элементов сети не большем 100.
Расчет пропускной способности | ZuluThermo ZuluGaz ZuluHydro | Количество участков не должно превышать 10.


Контакты

Если после знакомства с данным руководством пользователя у вас еще остались вопросы по работе с системой или в процессе работы возникли какие-либо проблемы, свяжитесь с нашей технической поддержкой. Мы также будем рады услышать от вас пожелания по расширению функциональности системы и предложения по доработке справки.

Прежде чем связываться с нашими специалистами, убедитесь, что у вас установлена самая последняя версия ZuluGIS. После звонка к нам именно это первым делом вас попросит сделать наша техническая поддержка. Связано это с тем, что обновления происходят регулярно и может возникнуть такая ситуация, когда ошибка уже исправлена.

Как установить новую версию, можно узнать в разделе Обновление ПО.

Техническая поддержка не является обучением. Она предполагает только консультацию по вопросам функционала программного обеспечения или помощь в решении проблем, возникших при работе с системой.

Техническая поддержка доступна с понедельника по пятницу, 9:00 - 17:30 по московскому времени.

Телефоны:

  • +7 (812) 767-0352

  • +7 (812) 767-0353

  • +7 (812) 766-6728

  • +7 (921) 864-8612 (WhatsApp, Viber)

Электронная почта:

  • politerm@politerm.com

Форум:

  • https://www.politerm.com/forums/

Данная версия справочной системы от 24 11 2025.


Примеры работы с ZuluGIS

[Примечание] Примечание

Кроме приведенных далее примеров, на нашем канале можно ознакомиться с видеоуроками, описывающими работу с системой ZuluGIS. Уроки доступны на каналах RUTube https://rutube.ru/channel/23486420/, VK Видео https://vkvideo.ru/@politerm, YouTube https://www.youtube.com/playlist?list=PL22D071EA66B64D44 или на нашем сайте https://www.politerm.com/videos/.

ZuluGIS

  • «Пример работы с растровыми объектами»

  • «Пример создания типовых объектов»

  • «Пример создания дополнительного режима для уже существующего типа объекта»

  • «Примеры подключения тайловых слоев»

  • Примеры работы с базой данных:

    • «Создание базы данных с одной таблицей»

    • «Создание базы данных с двумя таблицами, связанными между собой по ключу»

    • «Создание описателя из двух таблиц, одна из которых является справочником через запрос»

    • «Создание простого справочника»

    • «Создание описателя «Адресные точки»»

    • «Подключение файлов к базе данных»

    • «Изменение источника данных»

    • «Пример добавления полей в базу данных»

  • «Примеры работы с семантической информацией»

    • «Примеры запросов к семантическим базам данных»

    • «Примеры экспорта данных в Microsoft Excel»

  • «Примеры выполнения SQL запросов»

  • «Примеры работы с надписями»

  • «Примеры работы с тематической раскраской»

  • «Пример работы с проектом»

  • «Примеры печати карты с использованием панели печати»

  • «Примеры печати карты с использованием макета печати»


Закладки карты

Диалог используется для управления закладками карты

  • созданию

  • переходу

  • обновлению

  • переименованию

  • работой с группой

  • удалению закладок и разгруппировки групп

[Примечание] Примечание

Сохранение всех произведенных изменений произойдет при сохранении карты.

[Предупреждение] Предупреждение

Кнопка Вернуть все производит отмену ВСЕХ действий в диалоге по закладкам до сохранения карты! То есть все изменения, например созданные группы, закладки или перемещения будут ПОТЕРЯНЫ!

Создание закладок

Возможно создать два типа закладок - закладки, привязанные к конкретному виду отображения карты и второй тип - привязанные к конкретному объекту слоя. При перемещении объекта по карте автоматически будут изменяться координаты центра отображения карты. Таким образом, при создании закладки второго типа можно отслеживать перемещения объекта на карте.

Для создания закладки необходимо выполнить следующие действия:

  1. Нажать кнопку:

    • Связать с центром - если создается закладка, связанная с центром карты.

    • Связать с объектом - если создается закладка, связанная с объектом (объект должен быть предварительно активизирован - кнопка [image] ).

  2. В появившемся окне в строке Название закладки вместо текста <Новая> ввести название закладки, нажать кнопку ОК.

[Примечание] Примечание

Создание закладок так же возможно с использованием дополнительной панели Закладки.

Переход по закладкам

Для перехода по закладкам через диалог Закладки надо:

  1. Выделить в списке закладок нужную закладку и нажать кнопку Перейти. Или сделать двойной щелчок левой кнопкой мыши по закладке. При этом окно Закладки закрывается, а окно карты перестраивается с заданными в закладке параметрами (центр и масштаб) и выделяется объект на карте, если выбранная закладка второго типа.

Обновление закладки

Можно обновить закладку, для этого надо заранее перестроить масштаб или выделить объект. Далее в диалоге Закладки выделить нужную закладку и нажать кнопку Обновить.

Переименование закладки

Для изменения названия закладки:

  1. Выделить закладку, нажать кнопку Переименовать.

  2. Отредактировать название.

  3. Сделать щелчок левой кнопкой мыши в области закладок.

Работа с группами закладок

[Примечание] Примечание

Создать группу для закладок невозможно без самих закладок. То есть предварительно закладки должны быть созданы!

Для создания группы закладок надо:

  1. Установить курсор на закладку, которая должна входить в создаваемую группу.

  2. Нажать кнопку Группа/Создать.

  3. По умолчанию группы создаются с названиями Группа 1, Группа 2 и.т.д. Для переименования группы следует выделить группу, нажать кнопку Переименовать... и ввести новое название.

Перемещение групп и закладок

[Примечание] Примечание

В том случае, если при перемещении закладок произойдет такая ситуация, что в группе не останется ни одной закладки, то группа будет автоматически УДАЛЕНА. Так как существование группы без закладок невозможно.

Перемещение в диалоге Закладки возможно двумя вариантами:

Первый вариант:

  1. Подвести курсор к нужной закладке (группе) нажать левую клавишу мыши и не отпуская переместить закладку или группу в нужное место.

Второй вариант:

  1. Выделить в списке нужную закладку (группу).

  2. Нажать кнопку Группа|Переместить в....

  3. Указать группу для перемещения, нажать кнопку ОК.

Удаление закладок и разгруппировка групп

[Примечание] Примечание

При разгруппировке закладки, входившие в группу не удаляются.

Для удаления закладки надо:

  1. Выделить в списке нужную закладку.

  2. Нажать кнопку Удалить.

Для разгруппировки группы надо:

  1. Выделить в списке нужную группу.

  2. Нажать кнопку Группа|Разгруппировать.


Буферная зона

Буферная зона - полигональный слой, образованный путем расчета и построения эквидистант, равноудаленных относительно множества точечных, линейных или полигональных объектов.

Построение буферной зоны заключается в очерчивании вокруг группы объектов активного слоя контура (или нескольких контуров), все точки которого отстоят от объектов группы на заданную величину. Полученный в результате контур (группа контуров) записывается в редактируемый слой. Расстояние для построения буферной зоны либо задается постоянной для всех объектов группы, либо берется из указанного числового поля подключенной в данный момент к активному слою таблицы.

В результате построения буфера у созданных объектов могут быть унаследованы атрибуты слоя источника.

Построение буферной зоны может использоваться для многих задач, например для выделения охранной зоны трубопроводов, определения зеленых поясов между жилыми домами, нахождения водозащитных зоны вокруг рек, определение зон вокруг школ, зона ремонта вокруг трубопровода и др. Полученный буфер может быть объединен в общий буфер или построен отдельно для каждого объекта.

Зона записывается в виде контурного или комбинированного площадного объекта с текущими параметрами редактора.

[Примечание] Примечание

Буферная зона может быть преобразована в набор отрезков средствами системы (см. «Преобразование полигона в ломаную»):

В диалоге выводится имя активного слоя, по которому создается зона (Слой источник) и имя слоя для записи (Слой для записи).

Для построения буферной зоны:

1. Задайте параметры создаваемой буферной зоны:

  • Ширина буфера: в этом окошке задается значение ширины буферной зоны, которое используется при отсутствии данных о ширине из таблицы.

  • По умолчанию: если отмечена эта опция, то если значения ширины буфера берутся из таблицы, и эти значения для каких-либо объектов отсутствуют или неверны, то значение по умолчанию будет браться из окошка Ширина буфера. Если эта опция не отмечена, то любое неверное значение ширины из таблицы приведет к остановке процесса создания буферной зоны.

  • Поле базы: выпадающий список заполняется именами полей текущей семантической базы данных, подключенной к активному слою (слою источнику). Если в списке выбрано одно из полей, то значения ширины буфера будут браться из этого поля. Единицы измерения значений в выбранном поле указываются в соседнем открывающемся списке.

  • Объединять зоны в один объект: если буферная зона строится для нескольких объектов, тогда можно поставить галочку на против строки Объединять зоны в один объект. В этом случае построенная буферная зона для всех объектов будет единым целым, иначе для каждого объекта будет своя, отдельная буферная зона.

  • Вырезать из зоны сам объект: данную опцию следует отметить в том случае, если требуется из построенной буферной зоны вырезать объект, по которому она строилась.

  • Наследовать атрибуты - при установке данной опции атрибуты слоя (данные базы) источника будут скопированы в созданные объекты буфера слоя для записи. Подробней....

  • Концы линий - из открывающегося списка выбираются концы линий для буферной зоны:

    • Закругленный - концы линий будут закруглены, наружные углы на построенной буферной зоне так же будут закруглены, число точек на окружность необходимо указать в соответствующем окне;

    • Квадратный - концы линий на буферной зоне будут квадратными, углы так же будут квадратными;

    • Прямой - концы линий будут прямые, наружные углы на построенной буферной зоне будут закруглены, число точек на окружность необходимо указать в соответствующем окне.

  • Укажите точки перелома: закругленные или квадратные. Ели ранее были выбраны закругленные концы линий, то точки перелома могут быть тоже только закругленные.

  • Число точек на окружность: в данном окошке можно установить число точек, которое будет использоваться при создании окружностей буферной зоны. Чем больше количество точек, тем плавней будут окружности в зоне, точек можно задать от 12 до 360 шт.

  • Из списка выберите как будет производиться измерение ширины буфера, по аналогии с геометрическими построениями:

    • По проекции;

    • По сфероиду.

2. Нажмите кнопку ОК для запуска процедуры создания буферной зоны.


Смена режима

Диалог позволяет изменить состояние типовых объектов. Для типового объекта смена состояния объекта сводится к заданию нового режима и/или типа. Диалог выдаст для выбора список типов и режимов одного с объектом графического типа (для символьного только символьные, для линейного - линейные и т.д.). Для изменения параметров надо в разделе Тип левой кнопкой мыши выбрать тот тип, который нужен. В зависимости от выбранного типа в разделе Режим отобразятся все режимы, относящиеся к выбранному типу. Смена режима производится так же выделением нужного режима.

Описание кнопок диалога:

Сменить направление | Стрелка при изображении участка формально указывает направление от начала к концу участка, заданное при его вводе (при рисовании). При выборе опции Сменить направление и подтверждении с помощью кнопки ОК произойдет изменение направления ввода участка на противоположное.
ОК | Подтверждает произведенные изменения.
Отмена | Отменяет изменения, при этом окно Смена режима закрывается.


Масштаб и широта/долгота

С помощью данного диалога можно изменить масштаб отображения и широту/долготу карты.

Для задания нового масштаба, широты или долготы отображения сотрите имеющиеся и введите новые данные.

Ширина и долгота задаются в градусах. После ввода новых данных и нажатия кнопки OK, произойдет перестроение окна в соответствии с введенными параметрами.


Масштаб и координаты карты

С помощью данного диалога можно изменять центр изображения и масштаб карты.

Для задания нового масштаба или новых координат центра отображения сотрите имеющиеся и введите новые данные.

Координаты центра задаются в метрах. После ввода новых координат центра карты и нажатия кнопки OK, произойдет перестроение окна в соответствии с новыми масштабом и центром отображения.


Масштаб и центр карты

При местной прямоугольной системе координат можно задать новый масштаб (как отношение размера карты на экране к ее реальному размеру, либо как количество сантиметров на местности содержащихся в одном пикселе экрана, в зависимости от настроек системы), координаты центра окна в метрах и поворот карты.

При других проекциях (глобус, широта/долгота и др.) можно задать новый масштаб и широту/долготу в градусах (если единицы измерения установлены в метрах, то задаются X и Y) . После ввода новых координат центра карты и нажатия кнопки OK, произойдет перестроение окна в соответствии с новыми масштабом и центром отображения.

Угол поворота задается в градусах. Направление вращения - против часовой стрелки.


Выбор символов

Для выбора специальных символов надо:

  1. В общем списке символов левой кнопкой мыши выделить символ, который требуется вставить, при этом он отобразится в правом нижнем окошке.

  2. Нажать кнопку Выбрать. Если был случайно выбран символ, который не нужен, тогда щелкнуть левой кнопкой мыши в строке выбранных символов и кнопкой Delete удалить ненужный символ.

  3. После выбора символов нажать кнопку Копировать.

  4. Кнопкой Закрыть закрыть окно Выбор символов, диалог Стиль при этом не закроется.

  5. В диалоге Стиль в разделе Текст сделать щелчок правой кнопкой мыши, после чего в открывшемся контекстном меню, выбрать пункт Вставить.

[Примечание] Примечание

Символы, находящиеся в общем списке будут меняться от выбранного шрифта, он выбирается в диалоге Стиль, на вкладке Шрифт.


Выбор поля для надписи

Данное диалоговое окно может появиться в следствии удаления полей из базы данных, данные из которых были использованы в шаблоне надписи.

Для выбора нового поля взамен удаленного выберите поле в списке и нажмите кнопку ОК. Кнопка Отмена закроет диалог без сохранения изменений.


Пересечение с контуром слоя

В режиме выделения группы произвольным замкнутым многоугольником ( [image] ) имеется возможность создать (выделить) группу из объектов, попадающих в определенную область, например выделить объекты тепловой сети, находящиеся в одном квартале (заметим, что объекты тепловой сети и объекты кварталы находятся в разных слоях).

Для такого выделения надо:

  1. Сделать активным слой, в котором требуется создать группу.

  2. Нажать на панели инструментов кнопку [image] .

  3. Удерживая на клавиатуре кнопку Alt щелкнуть левой кнопкой мыши по объекту, в пределах которого надо выделить группу (например по району). Если объекты, которые надо выделить окажутся в пределах нескольких объектов других слоев, то на экране появиться диалоговое окно Пересечение с контуром из слоя. В этом окне надо левой кнопкой мыши выделить слой, в который входит объект, в пределах которого надо создать группу, и нажать кнопку ОК.


Добавление нового векторного элемента заливки

С помощью данного диалогового окна имеется возможность в заливку добавить новый векторный элемент (символ). Если в слое уже существует необходимый символ, то его можно выбрать из выпадающего списка, список откроется нажатием на кнопку [image] .

Если нужного символа в списке нет, то его можно создать самостоятельно в «Редактор символов», открыть его можно нажатием на кнопку Новый.

Подтвердить выбор символа и закрыть диалоговое окно можно кнопкой Выбрать.


Проекция слоя

Диалог параметров проекции слоя

Рисунок 1. Диалог параметров проекции слоя

Проекцию можно выбрать из списка готовых проекций (предложены наиболее часто используемые проекции), задать параметры проекции вручную, загрузить проекцию из файла слоя на диске или импортировать.

  • Выбрать готовую проекцию. Для выбора готовой проекции, надо указать из открывающегося списка типов проекций нужный тип, затем выбрать требуемую проекцию в списке проекций. В области параметров проекции отобразится список параметров выбранной проекции, но без возможности редактирования.

  • Задать проекцию вручную. Для задания параметров проекции вручную, в из верхнего открывающегося списка надо выбрать значение <Задать>. Затем указать настройки проекции в полях области параметров проекции.

  • Выбрать проекцию по слою карты. В данном варианте слой, проекция которого будет выбираться должен быть загружен в карту. Для назначения проекции надо из верхнего списка указать пункт Выбрать по слою карты. Затем из списка слоев карты указать слой, проекция которого будет использована.

  • Импортировать параметры системы координат (из слоя Zulu, с помощью строки MapInfo.prj, строки WKT или файла проекции PRJ.

После завершения настройки проекции карты нажмите кнопку ОК диалога, чтобы сохранить изменения и закрыть диалог.


Вкладка Команды

При открытии диалога Настройка интерфейса система переходит в режим, когда все кнопки инструментов становятся доступными, то есть те кнопки, которые были заблокированы на момент перехода в этот режим, меняют свой внешний вид на обычный. В этом режиме имеется возможность менять расположение кнопок панелей инструментов простым способом взять – и - перетащить. То есть установить курсор на кнопку, которую надо переместить, нажать левую кнопку мыши и не отпуская ее переместить курсор в то место, куда надо переместить кнопку (надо учесть то, что когда происходит перемещение кнопки, то курсор становится невидимым).

С помощью вкладки Команды можно менять расположение кнопок панелей инструментов, а также удалять кнопки и добавлять новые.

В разделе Категории отображается список категорий. При выборе элемента в этом списке в окне Кнопки появится набор кнопок из соответствующей категории.

Для того, чтобы поместить выбранную из какой либо категории кнопку на панель инструментов надо нажать левую кнопку мыши и не отпуская ее переместить курсор на ту панель инструментов, где она должна находиться. При отпускании кнопки мыши панель инструментов будет увеличена и кнопка добавлена в панель.

Для удаления кнопки из панели инструментов надо выделить кнопку на панели инструментов и удерживая нажатой левую кнопку мыши «утащить» удаляемую кнопку с панели. При отпускании левой кнопки мыши кнопка исчезнет с панели инструментов.

[Примечание] Примечание

Для возврата всех панелей инструментов, докируемых панелей и назначений клавиш в исходный вид и местоположение выберите пункт Дополнительно…|Сброс настроек. Затем установите галочку напротив того объекта, который надо вернуть в исходное местоположение и нажмите кнопку Сбросить.

Поиск кнопок или команд

Для поиска кнопки или команды по названию надо ввести название в строку Поиск, результаты поиска будут отображены в разделе Команды.


Диалог Команда

С помощью данного диалога возможно назначить кнопке иконку (картинку) и добавить макрос в пункт главного меню системы.

В строке Текст вносится название, которое в дальнейшем после привязки макроса к кнопке или меню будет присвоено ему.

Нажатие кнопки [image] вызовет диалог выбора картинки из уже имеющихся.

С помощью кнопки [image] производится импорт картинок с компьютера.

Кнопка [image] удаляет ошибочно добавленные картинки.

Раздел Пункт меню используется для привязки макроса к меню. Из списка Меню надо выбрать пункт меню, куда требуется вставить макрос. При необходимости в строке Пункт возможно изменить название для пункта меню, для добавления подменю воспользуйтесь разделителем / или |.

Кнопка ОК подтвердит произведенные изменения.

Кнопка Отмена закроет диалог без сохранения изменений.


Диалог выбора картинки

В данном выбирается картинка для кнопки из имеющихся в библиотеке системы.

Для выбора картинки выделите ее и нажмите кнопку ОК. По умолчанию в разделе Команды отображаются картинки всех категорий. Определенную категорию можно выбрать из списка Категория, после выбора в списке Команды будут загружены значки указанной категории.

При нажатии кнопки Отмена диалог закроется без изменений.


Диалог импорта картинки

Отметьте галочками те расширения изображения, которые будут импортированы в Zulu. Чтобы подтвердить импорт нажмите ОК.

Кнопка Отмена закроет диалог без сохранения изменений.


Диалог Выбор картинки

Диалог появляется в том случае, когда файл содержит набор изображений (если ширина картинки кратна высоте). При выборе картинки в списке и нажатии кнопки ОК произойдет вырезание картинки и открытие диалога Импорт картинки.

Кнопка ОК закроет диалог с подтверждением выбора.

Кнопка Отмена закроет диалог без сохранения изменений.


Вкладка Клавиатура

С помощью данной вкладки можно назначать сочетания клавиш для каких либо операций или макросов.

Для назначения нового сочетания надо:

  1. В разделе Категория выбрать необходимый пункт меню или макрос.

  2. В разделе Команды выделить команду или макрос. Если сочетание клавиш уже назначено, то оно отобразится в разделе Сочетание клавиш.

  3. Установить курсор в окошко Новое сочетание.

  4. Нажать на клавиатуре необходимое сочетание клавиш, оно будет отображено в окне Новое сочетание.

  5. Нажать кнопку Добавить.

С помощью кнопки Удалить возможно удалить не нужное сочетание клавиш.

Кнопка Сброс удалит все назначенные ранее сочетания клавиш.

[Примечание] Примечание

Для возврата всех панелей инструментов, докируемых панелей и назначений клавиш в исходный вид и местоположение выберите пункт Дополнительно…|Сброс настроек. Затем установите галочку напротив того объекта, который надо вернуть в исходное местоположение и нажмите кнопку Сбросить.

Поиск команд

Для поиска команды по названию надо открыть вкладку Клавиатура диалога Настройка интерфейса, из списка Категория выбрать категорию для поиска. Затем в строку Поиск... ввести название команды, результаты поиска будут отображены в разделе Команды.


Вкладка Макросы

В данной вкладке возможно привязать макрос к кнопке панели инструментов, назначить кнопке иконку (картинку) и добавить макрос в пункт главного меню системы.

[Примечание] Примечание

После добавления иконки для макроса или привязки макроса к меню в папке, в которой располагается макрос создается файл *.vbs.uidat, где хранится картинка кнопки и служебная информация, что позволяет производить перенос с ПК на ПК созданных для макросов кнопок.

Добавление иконки для кнопки макроса

Иконка может быть добавлена или из библиотеки иконок Zulu или самостоятельно созданная пользователем. Во втором случае, файл с иконкой может быть следующих форматов: *.bmp, *.gif, *.ico, *.jpg, *.jpeg, *.png, *.tif, *.tiff. Для корректного отображения иконки в системе изображение требуется нескольких расширений: 16x16-16 (для классической темы отображения иконок),16x16, 20x20, 24x24, 32x32, 40x40, 48x48, 64x64. Так же возможно использование картинок, состоящих сразу из нескольких, длинна которых кратна высоте, например 32*64, 32*96 и т.д.

Такое количество расширений обусловлено индивидуальной настройкой размеров кнопок и панелей инструментов, то есть при определенных настройках будет использоваться иконка определенного расширения. В том случае, если иконки нужного расширения отсутствует кнопка будет отображаться черным квадратом.

Для добавления иконки:

  1. В разделе Модули выберите модуль, содержащий нужный макрос.

  2. В разделе Команды отразятся названия всех имеющихся макросов, выделите макрос, к которому будет добавлена картинка.

  3. Нажмите кнопку Изменить...

  4. В появившемся диалоге в строке Текст можно изменить название, которое в дальнейшем после привязки макроса к кнопке или меню будет присвоено ему.

  5. Для выбора иконки из библиотеки в разделе Картинка нажмите кнопку [image] , после чего курсором укажите нужную иконку и нажмите кнопку ОК. По умолчанию отображаются все иконки библиотеки, для более быстрого поиска можно из списка выбрать конкретную категорию, тогда в разделе Команды отобразятся только иконки выбранной категории.

    Для загрузки файла картинки с компьютера нажмите кнопку [image] и укажите файл с изображением. Далее в зависимости от используемого файла появится тот или иной диалог.

    Если файл требуется покадрово нарезать то сначала появится диалог Выбор картинки, в котором укажите картинку и нажмите кнопку ОК. Затем в появившемся диалоге Импорт картинки надо отметить галочками те расширения изображения, которые будут импортированы в Zulu. Чтобы подтвердить импорт нажмите ОК.

    При использовании картинки, которую не требуется покадрово нарезать диалог Импорт картинки появится сразу.

    В результате иконки, расширения которых были отмечены будут загружены в систему.

    Если какая либо картинка была загружена ошибочно выделите ее и нажмите кнопку удалить [image] .

Привязка макроса к меню

Для того чтобы привязать макрос к меню надо:

  1. В разделе Модули выбрать нужный модуль.

  2. Справа в разделе Команды выделить команду, нажать кнопку Изменить.

  3. В появившемся диалоге из списка Меню выбрать пункт меню, куда требуется вставить макрос. При необходимости в строке Пункт измените название для пункта меню, для добавления подменю воспользуйтесь разделителем / или |.

  4. Для подтверждения изменений нажмите кнопку ОК и закройте диалог Настройка интерфейса. Для проверки откройте меню, в которое был добавлен макрос.

Поиск макросов

Для поиска макроса по названию надо открыть вкладку Макросы диалога Настройка интерфейса и в строку Поиск... ввести название, результаты поиска будут отображены в разделе Команды.


Вкладка Параметры

В данной вкладке имеется возможность настроить темы и размеры кнопок для отображения панелей инструментов.

Для смены вида панелей инструментов в списке Тема можно выбрать следующие варианты:

  • Классическая - кнопки и панели будут отображены в классическом стиле, который был сформирован при создании системы ZuluGIS.

  • Модерн - современный стиль кнопок и панелей, используется по умолчанию.

  • Тёмная - вариант настройки, при которой кнопки отображаются на темной панели инструментов, цветоотображение кнопок так же корректируется. Данная темная тема может снизить нагрузку на глаза в ночное время, так как в слабо освещенном помещении контраст с темным фоном почти незаметен.

Для настройки размера кнопок нужно подвести курсор к бегунку Размер, затем нажать левую кнопку мыши и не отпуская ее перемещать бегунок в нужную сторону. Чтобы зафиксировать размеры нужно отпустить левую кнопку мыши. При этом сразу после перемещения бегунка кнопки панелей инструментов примут выбранный размер.


Вкладка Панели инструментов

При открытии диалога Настройка интерфейса система переходит в режим, когда все кнопки инструментов становятся доступными, то есть те кнопки, которые были заблокированы на момент перехода в этот режим, меняют свой внешний вид на обычный. В этом режиме имеется возможность менять расположение кнопок панелей инструментов простым способом взять – и - перетащить. То есть установить курсор на кнопку, которую надо переместить, нажать левую кнопку мыши и не отпуская ее переместить курсор в то место, куда надо переместить кнопку (надо учесть то, что когда происходит перемещение кнопки, то курсор становится невидимым).

Во вкладке Панели инструментов отображается список имеющихся панелей инструментов. Возле каждого элемента списка слева находится флажок, который следует установить для тех панелей, которые должны отображаться, и соответственно сбросить (убрать), чтобы скрыть панель. Для установки или сброса флажка установите курсор на флажок, состояние которого требуется изменить, затем щелкните левой кнопкой мыши. Если флажок был установлен, то он сбросится, если же он был сброшен, то соответственно установится.

Создание новой панели

Для создания новой (изначально пустой) панели инструментов надо:

  1. Нажать кнопку Создать.

  2. В строке Название панели ввести название создаваемой панели.

  3. Нажать кнопку ОК.

Переименование созданной панели

После произведенных действий в разделе Панели отобразиться название новой созданной панели, а в левом верхнем углу рабочей области главного окна отобразиться она сама (пустая панель). С ней можно так же работать как и со стандартной панелью. Добавить кнопки в новую панель можно перейдя во вкладку Команды.

Каждая панель инструментов имеет свое название, оно отображается в маленьком заголовке панели, когда панель инструментов принимает плавающий вид. Название можно изменять только для созданных пользователем панелей, для остальных панелей это действие заблокировано. Название созданной панели можно изменить, для этого надо выделить панель левой кнопкой мыши в разделе Панели инструментов, после чего нажать кнопку Переименовать и в появившемся окне Панель инструментов ввести новое название.

Удаление созданной панели

Кнопка Удалить позволяет произвести удаление любой созданной пользователем панели. Для удаления панели надо ее выделить в списке, нажать кнопку Удалить, затем подтвердить удаление.

Кнопка Сброс сбрасывает панель инструментов к стандартному состоянию, отменяя все изменения, внесенные во внешний вид этой панели. Эта команда доступна только для стандартных панелей инструментов и строки меню.

[Примечание] Примечание

Для возврата всех панелей инструментов, докируемых панелей и назначений клавиш в исходный вид и местоположение выберите пункт Дополнительно…|Сброс настроек. Затем установите галочку напротив того объекта, который надо вернуть в исходное местоположение и нажмите кнопку Сбросить.


Задание окрестности

Диалоговое окно может использоваться для разных операций:

«Подтягивание концов линий к узлам»

«Объединение концов линий»

«Примыкание»

«Упрощение геометрии объекта» или «Упрощение геометрии группы объектов»

В строке Окрестность для захвата узла необходимо задать окрестность, в пределах которой будет произведена выбранная ранее операция, окрестность задается в сантиметрах.


Диалог выполнения команд

Диалог выполнения команд представляет возможность выполнения макросов и команд модулей расширения системы ZuluGIS.

Для открытия диалога необходимо выбрать команду Выполнить меню Сервис. Диалог состоит из двух вкладок:

  • Вкладка Команды - в ней выполняются команды модулей ZuluGIS:

    Для выполнения команды выберите категорию команд в поле со списком, затем выберите требуемую команду в списке и нажмите кнопку Выполнить (либо дважды щелкните по строке команды).

    При выборе в списке команды, в области Описание под списком отображается краткая информация о команде.

  • вкладка Макро - в ней выполняются макросы VBScript и JavaScript:

    Во вкладке предусмотрено выполнение макросов в форматах VBScript и JavaScript. Для выполнения макроса:

    1. Выделите необходимый макрос. Если нужного макроса нет в списке, выберите другой модуль в списке Файл.

    2. Нажмите кнопку Выполнить.


Поля таблицы

При «Размещение фотографий в слое с привязкой к географическим координатам» в данном диалоговом окне необходимо указать поля EXIF фотографий, данные из которых будут сохраняться в соответствующих поля таблицы фотографий базы данных. Для того чтобы изменить список сохраняемых полей нажмите кнопку справа от поля и выберите требуемые поля в открывшемся диалоге Поля таблицы. Установите флажки у полей, которые требуется сохранять в таблице, либо установите флажок Все чтобы добавить все поля списка. После задания требуемых полей нажмите кнопку ОК, чтобы сохранить изменения и закрыть диалог, либо кнопку Отмена чтобы закрыть диалог без сохранения изменений.


Экспорт в растр (печать в растр)

С помощью данного диалога имеется возможность экспортировать изображение карты в растр следующих типов:

  • монохромный рисунок BMP;

  • 256-цветный рисунок BMP;

  • 24-разрядный рисунок BMP;

  • GeoTIFF.

При этом во время экспорта дополнительно могут быть созданы файл привязки с координатами:

  • Zulu (*.zrs);

  • MapInfo (*.tab);

  • OziExplorer (*.map);

  • ESRI World File.

Для экспорта в формат BMP надо:

  1. В строке Файл для записи нажать кнопку [image] и в открывшемся диалоговом окне указать путь для сохранения и ввести название для растрового файла.

  2. В строке Тип файла выбрать в списке какого типа будет создаваемый файл:

    • монохромный рисунок;

    • 256-цветный рисунок;

    • 24-разрядный рисунок;

    • GeoTIFF.

  3. Если при экспорте дополнительно необходимо создать файлы привязки, то установить в разделе Создавать файл привязки нужную опцию:

    • .zrs (Zulu) - для создания файла привязки ZuluGIS;

    • .tab (MapInfo) - для создания файла привязки MapInfo;

    • .map (OziExplorer) - для создания файла привязки OziExplorer (создание файла привязки для OziExplorer возможно только для карты с проекциями Гаусса-Крюгера (Пулково 1942) и Universal Transverse Mercator (VGS 84));

    • ESRI World File - для создания файла географических данных ESRI, который в дальнейшем можно использовать с ArcGIS.

  4. В разделе Область карты задать границы экспортируемой карты и при необходимости дополнительные параметры:

    • текущий вид - экспортироваться будет область карты, попадающая на всю страницу или заданный диапазон страниц, с указанным масштабом и центром изображения, совпадающим с координатами в центре активного окна карты;

    • вся карта - фрагмент местности будет вычисляться по границам всей карты;

    • фрагмент - будет напечатан отмеченный заранее фрагмент карты, фрагмент можно выделить с помощью кнопки [image] ;

    • по размерам слоя - область печати будет вычисляться по границам одного слоя, слой выбирается из открывающегося списка;

      Когда выбрана опция по размерам слоя возможно дополнительно установить флажок По размерам группы - в этом случае граница печати будет определяется габаритами выделенных объектов указанного слоя.

    • указать - позволяет точно задать границы фрагмента местности. В окошках справа от этого переключателя задаются координаты левого нижнего и правого верхнего углов прямоугольной зоны, которую следует распечатать.

    Кроме вышеперечисленных опций возможно печатать в растр не только все объекты карты, но и определенные объекты, для этого их предварительно необходимо выделить любым известным способом и затем установить флажок Только выделенные объекты.

  5. В разделах Размер растра и Размер документа указать необходимые параметры. Размер растра можно задавать в пикселях, либо в миллиметрах при заданном разрешении (dpi), либо в соответствии с масштабом (1:2000 и т.п.) (если установлена опция Пропорционально, то при изменении параметров пропорции растра будут сохранены).

  6. Нажать ОК для запуска процедуры экспорта.


Экспорт в формат DXF

Представленный диалог предназначен для экспорта графической информации в формат DXF. Для экспорта:

  1. В области Слои установите флажки у слоев, которые требуется экспортировать, либо установите флажок Все, чтобы выбрать все слои. Для того чтобы экспортировать только выделенные объекты карты, установите флажок Только выделенные объекты (объекты слоя при этом должны быть предварительно выделены).

  2. Для экспорта подключенных надписей (бирок) установите опцию Экспортировать надписи. Надписи будут записаны в отдельный слой (внутри .dxf файла). Если требуется экспорт каждого вида надписи в отдельный слой, установите дополнительно опцию Разделять надписи в dxf по слоям.

  3. По умолчанию система экспортирует данные без стилей подключенных тематических раскрасок. Для экспорта с темами установите опцию Брать стиль текущих тематических раскрасок.

  4. В поле Файл DXF укажите путь и имя создаваемого файла DXF. Для этого нажмите кнопку [image] справа от поля и задайте требуемый путь и имя файла в стандартном файловом диалоге.

  5. При необходимости подстановки блоков и стилей линий укажите путь к файлу параметров подстановки в поле Файл CFG.

  6. Нажмите кнопку Система координат и в открывшемся диалоговом окне из открывающегося списка выберите систему координат для экспорта. По умолчанию система подставляет проекцию карты. Для корректного экспорта данных необходимо, чтобы была указана проекция, которая не имеет графических искажений экспортируемой области. Например, Гаусса-Крюгера в соответствии с центральным меридианом или соответствующая МСК. Подтвердите выбор системы кнопкой ОК.

  7. Нажмите кнопку ОК. Будет выполнена процедура преобразования выбранных слоев карты и их сохранение в указанном файле DXF.


Экспорт в GeoJSON

Экспорт в GeoJSON можно осуществлять как для одного слоя, так и для нескольких слоёв одновременно. Если заранее выделить объекты, то можно экспортировать только их. Также есть возможность экспортировать только геометрию объектов, без семантических данных.

Для экспорта в GeoJSON:

  1. Для экспорта всех слоев карты установите опцию Все. Если требуется экспортировать определенные слои, то отметьте галочки напротив их.

  2. Если нужен экспорт только выделенных объектов, то включите соответствующую опцию. Объекты должны быть выделены заранее.

  3. Для экспорта только геометрии объектов установите опцию Только геометрия.

  4. Выберите проекцию для экспорта, проекция выбирается из открывающегося списка Проекция.

  5. В строке Папка нажмите кнопку Обзор... и укажите путь до создаваемого файла и его название.

  6. Для запуска процедуры экспорта нажмите кнопку ОК.

После завершения экспорта в указанной папке создаются файлы формата GeoJSON с графическими объектами. Если не установлена опция Только геометрия, будут присутствовать все поля активного запроса и поля по геометрии объектов.


Экспорт модели рельефа в Intermediate TIN Format (ITF)

Диалог предназначен для экспорта слоя рельефа в формат в Intermediate TIN Format (ITF):

  1. Из списка Экспортируемый слой выберите слой для экспорта.

  2. В поле Файл укажите путь и имя создаваемого файла. Для этого нажмите кнопку Обзор... справа от поля и задайте требуемый путь и имя файла в стандартном файловом диалоге.

  3. Завершите экспорт рельефа нажатием кнопки ОК.


Экспорт в формат Google KML

Векторные слои возможно экспортировать в формат KML. ZuluGIS позволяет экспортировать весь слой, выделенные объекты или отдельные типы объектов. Формат KML может использоваться таким программным обеспечением как Google Планета Земля.

Для экспорта информации в формат KML:

  1. В поле Экспортируемый слой выберите слой для экспорта.

  2. В поле KML файл укажите путь и имя создаваемого KML файла. Для этого нажмите кнопку Обзор... справа от поля и задайте требуемый путь и имя файла в стандартном файловом диалоге.

  3. Затем в разделе ниже надо указать типы для экспорта и для каждого типа задать параметры метки и данных. Для экспорта сразу всех объектов слоя достаточно установить галочку напротив строки <Все объекты>.

    В столбце Метка можно выбрать метку, которая будет выводиться на объекте после экспорта (аналог бирок в ZuluGIS), меткой может быть или ID объекта или любое поле из подключенной к типу базы данных. Метка выбирается из открывающегося списка:

    Рисунок 1. Выбор метки

    Выбор метки напротив стоки <Все объекты> будет применен ко всем объектам одновременно.

    В столбце Данные можно указать будут ли экспортироваться данные из базы, подключенной к объекту. При установленной галочке данные будут экспортироваться, в противном случает нет. Если необходимо экспортировать данные одновременно для всех объектов, то достаточно установить галочку в строке <Все объекты>.

  4. Если предварительно в слое была выделена группа объектов, то будет активна опция Только выделенные объекты. При ее установке будет экспортирована только эта группа.

  5. Для запуска процедуры экспорта нажмите кнопку ОК.

    Диалоговое окно “Экспорт в формат KML”

    Рисунок 2. Диалоговое окно “Экспорт в формат KML”


Экспорт модели рельефа в LandXML TIN

Диалог предназначен для экспорта слоя рельефа в формат LandXML TIN:

  1. Из списка Экспортируемый слой выберите слой для экспорта.

  2. В поле Файл укажите путь и имя создаваемого XML файла. Для этого нажмите кнопку Обзор... справа от поля и задайте требуемый путь и имя файла в стандартном файловом диалоге.

  3. Завершите экспорт рельефа нажатием кнопки ОК.


Экспорт в формат MIF

Векторные слои возможно экспортировать в формат MIF. Он содержит графические данные (объекты), а также может содержаться описание таблицы данных, содержащей атрибутивную информацию, связанную с объектами. Используется например таким программным обеспечением как MapInfo.

Для экспорта информации в формат MIF надо:

  1. В области Слои установите флажки у слоев, которые требуется экспортировать, либо установите флажок Все, чтобы выбрать все слои. Для того чтобы экспортировать только выделенные объекты карты, установите флажок Только выделенные объекты.

  2. Если требуется экспортировать только графическую информацию установите опцию Только геометрия.

  3. Для баз данных необходимо выбрать каким образом будет происходить запись из справочников:

    • значения из справочников - если к полю подключен справочник, то в результате экспорта будут взяты значения из справочников;

    • реальные значения полей - если к полю подключен справочник, то в результате экспорта будут взяты реальные значения полей со справочниками.

  4. В поле Папка укажите путь к каталогу в котором будут сохраняться экспортируемые файлы. Для этого нажмите кнопку Обзор... справа от поля и задайте требуемый путь в стандартном файловом диалоге.

  5. Нажмите кнопку ОК. Будет выполнена процедура преобразования выбранных слоев карты и их сохранение в указанном каталоге.


Экспорт в формат Shape SHP

Векторные слои возможно экспортировать в формат SHP. Это популярный графический формат векторных данных. Он содержит графические данные (объекты), а также может содержаться описание таблицы данных, содержащей атрибутивную информацию, связанную с объектами. Используется например таким программным обеспечением как ArcGis, а также другими ГИС.

В диалоговом окне Экспорт в формат SHAPE:

  1. В списке слои установите галочки напротив экспортируемых слоев. Для того, чтобы отметить сразу все слои установите опцию Все.

  2. Нажмите кнопку Обзор... справа от поля Shape файл. При экспорте одного слоя укажите путь и имя создаваемых SHP файлов. При одновременном экспорте группы слоев укажите только папку для экспорта. Если экспортируемый слой имеет информацию о проекции (не является план схемой), то вместе с SHP файлом будет создан PRJ файл формата WKT с информацией о проекции слоя. Имя PRJ файла аналогично имени SHP файла.

  3. Если установлен флажок Только выделенные объекты, будут экспортируются только выделенные объекты. Если флажок снят, экспортируются все объекты.

  4. Из списка Кодировка выберите кодировку экспортируемого файла.

  5. В группе переключателей Запись справочных значений выберите способ получения данных из базы для полей, в которых используются справочники: Значения из справочников, либо Реальные значения полей.

  6. Для запуска процедуры экспорта нажмите кнопку ОК.


Экспорт в SQLite

Экспорт в SQLite позволяет «нарезать» карту на тайловые плитки и сохранить в SQLite базе данных (файл с расширением .sqlite). Операция производится для текущей карты в окне ZuluGIS.

Для экспорта в SQLite надо:

  1. Укажите место сохранения и название создаваемого файла. Откроется окно создания данных для Tile-сервера.

  2. В поле Область кэширования укажите, какую часть карты следует кэшировать:

    • текущий вид – отображаемую область в активном окне карты;

    • габариты карты;

    • габариты слоя;

    • объекты слоя.

  3. Если в качестве области кэширования были выбраны габариты слоя, или его объектов, в поле Слой требуется выбрать необходимый слой. Также можно установить флажок Только выделенные объекты, чтобы в слое учитывались только выделенные его объекты.

  4. Нажмите кнопку Создать. Процесс может занять значительное время, особенно если выбран большой диапазон уровней.


Справочник адресов ФИАС

С помощью данного диалога возможно внесение данных из классификатора ФИАС. Количество полей диалога зависит от настроек при подключении ФИАС к полю.

Для ввода данных установите курсор в нужное поле и с клавиатуры начните вводить адрес, после чего откроется список, в котором выберите нужную информацию.

Чтобы подтвердить ввод данных нажмите кнопку ОК. Адрес будет записан в поле в преднастроенном формате. Кнопка Отмена закроет окно без выбора данных.


Формат адреса поля ФИАС

В данном диалоге настраивается формат записи и отображения адреса объекта для поля, к которому подключена база ФИАС.

В строке Вариант следует выбрать, как будет отображаться адрес, после чего в строках Формат и Пример будет показан выбранный вариант.

Настройка формата так же возможна с непосредственным занесением кодов формата в поле Вариант, по мимо кодов в данную строку может быть занесена нужная информация, которая будет отображена в неизменном виде. Пример по введенным данным будет отображаться в строке Пример.

Таблица 1. Список кодов

Код | Обозначение
Z | индекс
R | регион
r | уникальный номер региона (код ФИАС)
D | район
d | уникальный номер района (код ФИАС)
C | город
c | уникальный номер города (код ФИАС)
S | улица
s | уникальный номер улицы (код ФИАС)
B | дом
b | уникальный номер дома (код ФИАС)


Настройка ФИАС

В данном диалоге при необходимости можно указать дополнительные настройки:

Использовать локально — для серверного слоя по-умолчанию запросы к веб-сервису ФИАС выполняются с ZuluServer. Если данная опция установлена то онлайн запросы к веб-сервису ФИАС будут выполнятся с клиента.

В разделе Область применения возможно указать регион, который будет указываться "по-умолчанию" (при вводе адреса будет уже введён).

При установке опции Ограничить выбор областью применения для выбора адреса будут доступные только записи из Области применения, поля области применения будут скрыты для ввода.


Поиск объекта по ключу

С помощью данного диалога зная ключ (ID) объекта активного слоя, объект можно найти на карте по этому значению. Для этого нужно выбрать в поле Ключ ввести номер, если набранный в диалоге ключ найден в активном слое, то на карте активизируется (замигает) объект, этому ключу соответствующий. Если объект не попадал в область отображения карты, то окно карты перестроится так, чтобы найденный объект оказался в центре окна.


Не обнаружен объект

Диалоговое окно Не обнаружен объект может появиться в нескольких случаях:

  • была удалена или перемещена карта, которая была добавлена в проект;

  • был удален и ли перемещен слой, который находился в карте;

  • была удалена или перемещена база данных, прикрепленная к слою.

В зависимости от того в каком случае возник этот диалог, меняется его название, например если не обнаружен слой, то название диалога будет Не найден слой.

Если объект был перемещен, то надо проделать следующие действия:

  1. В верхней строке указать новый путь до объекта, т.е. указать в какую папку он был перемещен (для открытия стандартного окна выбора файла воспользуйтесь кнопкой [image] ). После указания нового пути в диалоге отразиться реальное и пользовательское название объекта.

  2. Нажать кнопку Изменить путь, после чего до объекта будет установлен новый путь.

Если ZuluGIS не обнаружила несколько объектов, то после нажатия кнопки Изменить путь появится диалог, который предложит изменить путь для всех аналогичных случаев.

При нажатии на кнопку Да система автоматически пропишет новый, заданный Вами, путь для всех объектов, которые не были найдены. Нажимать эту кнопку надо в том случае, когда все объекты были перемещены в одно место.

В том случае, если объекты расположены в разных папках нажмите кнопку Нет, после чего произойдет возврат обратно в диалоговое окно Не обнаружен объект, в котором надо указать новый путь для следующего объекта.

При нажатии кнопки Игнорировать система пропускает указанный файл и не загружает его, но в следующий раз система будет вновь пытаться найти файл по указанному пути. Если вы хотите удалить сохранившуюся ссылку на отсутствующий объект, то нажмите кнопку Удалить.


Задать угол

Если ломаную линию необходимо нанести под определенным углом, то в данном диалоге надо задать угол, под которым линия будет нанесена. После введения значения угла и нажатия кнопки ОК

через предыдущую зафиксированную точку будет проведена линия под заданным углом. На линии будет «бегающая» точка, точку можно зафиксировать в нужном месте щелчком левой кнопки мыши.

Если до фиксации «бегающей» точки щелкнуть правой кнопкой мыши, то появится новое контекстное меню, позволяющее ввести дополнительные параметры (Рисунок 343, «Контекстное меню»).


Задать расстояние

При нанесении ломаной с помощью данного диалога можно задать расстояние на котором будет зафиксирована следующая точка ломаной. Расстояние задается в метрах, и отсчитывается оно от предыдущей зафиксированной точки ломаной.

После нажатия кнопки ОК вокруг последней зафиксированной точки появится круг, с «бегающей» на нем точкой, точку можно зафиксировать в нужном месте щелчком левой кнопки мыши.

Если до фиксации «бегающей» точки щелкнуть правой кнопкой мыши, то появится новое контекстное меню, позволяющее ввести дополнительные параметры (Рисунок 341, «Дополнительное контекстное меню»).


Изменение стиля отображения

Диалоговое окно Стиль заливки выводится в двух случаях:

  • При изменении стиля заливки выделенной группы площадных объектов.

  • При изменении стиля заливки площадных объектов при установке их мишенью.

Для того чтобы поменять стиль отображения выделенных или установленных мишенью площадных объектов надо:

  1. Щелкнуть левой кнопкой мыши в строке Цвет, в открывшихся палитрах выбрать щелчком мыши новый цвет.

  2. Щелкнуть левой кнопкой мыши в строке Узор, после чего откроется выпадающий список, содержащий различные узоры, выбрать новый узор.

  3. Нажать кнопку ОК.

Кнопка Отмена закроет диалоговое окно Стиль заливки без сохранения произведенных изменений.


Задать координаты

При нанесении ломаной с помощью данного диалога можно задать координаты для следующей точки. Окно появляется с координатами 0;0, сотрите их, и введите с клавиатуры новую широту и долготу.

После нажатия кнопки ОК произойдет перестроение экрана вместо с указанными координатами, и там будет закреплена новая точка ломаной. Кнопка Отмена закрывает окно введения координат, введение ломаной при этом не заканчивается.


Стиль линии

Диалоговое окно Стиль линии выводится в двух случаях:

  • При изменении стиля отображения выделенных линейных объектов при топологических запросах.

  • При изменении стиля отображения выделенной группы линейных объектов.

Для того чтобы поменять стиль отображения при выделении надо:

  1. Щелкнуть левой кнопкой мыши в строке Цвет, в открывшихся палитрах выбрать щелчком мыши новый цвет.

  2. Щелкнуть левой кнопкой мыши в строке Стиль, после чего откроется выпадающий список, содержащий различные стили линий, выбрать новый стиль.

  3. В строке Толщина с помощью клавиатуры или стрелок задать толщину линии. Все заданные изменения будут отображаться в окне Образец.

  4. Нажать кнопку ОК.

Кнопка Отмена закроет диалоговое окно Стиль линии без сохранения произведенных изменений.


Задать координаты

При нанесении ломаной с помощью данного диалога можно задать координаты для следующей точки. Окно появляется с координатами 0;0, сотрите их, и введите с клавиатуры новые координаты.

После нажатия кнопки ОК произойдет перестроение экрана вместо с указанными координатами, и там будет закреплена новая точка ломаной. Кнопка Отмена закрывает окно введения координат, введение ломаной при этом не заканчивается.


Сетка по слою или по карте

В результате данной операции будет создан слой с сеткой из заполненных полигонов. Сетка может быть построена в нескольких вариантах: по габаритам карты, слоя, по выделенным объектам слоя и по выпуклой оболочке слоя. При создании сетки вы можете так же одновременно со слоем создать базу данных. Сетка может быть построена не по всем объектам, а только по выделенным, тогда объекты необходимо выделить заранее.

Для создания сетки:

  1. В списке Исходный слой выберите слой, по которому создается сетка.

  2. В строке Слой для записи в первой строке задайте имя файла, в который будет записываться создаваемая сетка (используйте кнопку Обзор... для открытия стандартного окна выбора файла), во второй строке при необходимости можно заменить пользовательское название слоя.

  3. Одновременно со слоем вы можете создать базу данных. Базу создают в том случае, когда слой сетки будет использован для многостраничной печати по планшетам. В созданной базе будет одно поле Name, тип поля - строковый. Для создания базы установите флажок База по умолчанию и из списка Источники данных выберите источник.

  4. В разделе Сетка введите шаг создаваемой сетки в сантиметрах и точку начала координат – Опорная точка.

  5. Выберите опцию По слою или По карте.

  6. Если требуется чтобы сетка создавалась по выделенным заранее объектам установить флажок Группа.

  7. Из списка выберите вариант построения сетки, в зависимости от выбранного варианта будет применен определенный алгоритм построения сетки:

    • Габариты - по габаритам слоя;

    • Объекты - по объектам слоя;

    • Выпуклая оболочка - по выпуклой оболочке.

  8. Для того чтобы созданный слой-сетка сразу был загружен в текущую карту установить флажок Добавить в карту.

  9. Нажмите кнопку ОК.

В результате операции будет создан слой с сеткой. Если была отмечена опция Добавить в карту, то слой сетки автоматически загрузится в активную карту. При установке флажка База по слою создается база данных.

[Примечание] Примечание

При необходимости созданный слой может быть или исключен выделенным из карты или удален с диска.


Создание группы по графическим атрибутам объектов слоя

С помощью данного диалога имеется возможность создавать (выделить) группу из объектов, обладающих заданными графическими свойствами (цветом, стилем, шрифтом, типом и т.д.) Группа создается из объектов активного слоя текущей карты.

В зависимости от содержания графических данных конкретного слоя диалог по созданию группы может содержать несколько вкладок:

  • Типовые - содержит список всех типов и их режимов (только для смешанного слоя);

  • Контуры - содержит список всех встречающихся в слое заливок объектов (узор, цвет заливки, стиль, толщина, цвет границы);

  • Линии - содержит список всех встречающихся в слое способов отображения линий (цвет, толщина, стиль);

  • Текст - содержит список всех встречающихся в слое способов отображения текстовых объектов (имя шрифта, толщина, наклон, цвет). Высота и угол наклона надписи не рассматривается;

  • Простые символы - содержит список всех встречающихся в слое простых символьных объектов.

Если слой не содержит графических объектов, соответствующих той или иной закладке, то закладка диалоге отображаться не будет:

Для включения в выборку объектов с теми или иными атрибутами, нужно отметить соответствующие строки списка на соответствующих закладках (поставить «галочку» напротив объектов, подлежащих выделению). Если поставить «галочку» напротив поля Все, тогда будут отмечены все объекты данной закладки.

Если в момент нажатия кнопки удерживать нажатой клавишу Shift, то отмеченный объект дополнит существующую группу.

При нажатой клавише Ctrl отмеченный объект будет исключен из существующей группы. Если ни Shift, ни Ctrl не нажаты, то просто будет создана группа, состоящая из объектов с указанными параметрами отображения.


Создание группы объектов по пересечению со слоем

Вы можете выделить группу объектов по пересечению со слоем, загруженным в карту. Например, можно одновременно выделить все дома, попадающие полностью или частично в область кварталов. Для успешного результата оба слоя должны быть либо локальные, либо с одного сервера.

Для выделения группы по пересечению со слоем:

  1. В диалоговом окне Создать группу по пересечению со слоем, в списке Исходный слой выберите слой, в котором будет создаваться группа объектов.

  2. Укажите какие объекты слоя будут выделены. Если слой содержит только простые объекты (примитивы), то для указания достаточно в левом верхнем углу окна установить/снять галочки напротив названия объектов. По умолчанию установлена опция Все объекты, это означает что все объекты указанного ранее слоя, попадающие под пересечение будут выделены. В том случае, если слой содержит типовые объекты, то список типов и режимов отобразится под названием слоя. В этом списке по умолчанию напротив всех объектов установлены галочки. Если не требуется выделение какого либо типа, то галочку напротив его названия надо снять.

  3. Если предварительно уже была создана группа объектов, то при установке опции Выбирать только из выделенных объектов выделение будет осуществляться только из этой группы.

  4. Из списка Слой для пересечения выберите слой, с которым будет осуществляться пересечение.

  5. Далее укажите критерий пересечения, возможные критерии:

    • полное попадание;

    • частичное попадание;

    • полное или частичное попадание;

    • полное непопадание;

    • полное или частичное непопадание;

    • полное совпадение.

  6. После выбора критерия, в том случае, если необходимо произвести пересечение не со всеми объектами слоя, а с какой то определенной группой объектов установите опцию Пересекать только с выделенными объектами (группа должна быть предварительно создана).

  7. Из открывающегося списка выберите как будет создаваться группа.

    • создать группу заново - группа будет создана заново, со всех других ранее выделенных групп выделение будет снято;

    • добавить в группу - группа будет добавлена к другим уже существующим группам слоя;

    • исключить из группы группа будет исключена из ранее созданной группы слоя.

  8. Если в дальнейшем указанная конфигурация может еще понадобиться, то ее возможно сохранить. Для сохранения конфигурации нажмите кнопку Сохранить. Введите для не название и нажмите кнопку ОК. Конфигурация будет сохранена и затем доступна для дальнейшей загрузки только на том компьютере, на котором произошло ее сохранение.

    Для удаления ошибочно сохраненной конфигурации выберите ее из списка, нажмите кнопку Удалить. Затем нажмите кнопку Да для подтверждения удаления.

  9. Нажатие кнопки ОК завершит создание группы.


Формирование групп объектов по условию

С помощью данного диалогового окна возможно быстрое формирование групп объектов.

Для формирования группы:

  1. В поле со списком Слой выберите слой, из объектов которого создается группа.

  2. В группе полей Условия выборки задайте текст запроса (подробнее см. «Выборка данных по условию»).

  3. В поле со списком Группа выберите способ формирования группы.

    • Создать группу заново – формируется группа только из объектов выбранных в соответствии с запросом.

    • Добавить в группу – выбранные на основе запроса объекты добавляются к существующей группе (если она уже была выбрана).

    • Удалить из группы – выбранные на основе запроса объекты удаляются из уже существующей группы (если она уже была выбрана).

  4. Нажмите кнопку ОК чтобы сформировать группу и закрыть диалог.


Изменение параметров группы

С левой стороны диалогового окна выводится название графического типа и количество объектов конкретного типа, входящих в группу.

Описание кнопок диалога:

Изменить параметры - вызывает диалог Стиль или Смена режима в зависимости от типа объектов группы. При смене параметров новые атрибуты присваиваются всем объектам группы.

Сделать примитивом - позволяет превратить типовой объект в примитив, задав параметры создаваемого примитива (например, типовые объекты Участок превратить в полилинии). Для примитивов кнопка Сделать типовым - открывает диалог выбора типа и режима, изменяет примитивы на выбранный тип для всех объектов, вошедших в группу.

При выделении гриппы примитивов появляется кнопка Преобразовать в контуры (для замкнутых ломаных) или Преобразовать в линии (для контуров), при ее нажатии выполняется преобразование одного графического типа на другой. При этом происходит только преобразование типа объекта, ключ объекта остается тем же, в слой новых объектов не добавляется.

Выход - позволяет выйти из диалога.

Справка - открывает справочное окно по данной панели.


Запись группы в другой слой

Для того чтобы записать группу объектов группа должна быть предварительно выделена, затем:

  1. Выберите исходный слой из которого происходит запись группы (воспользуйтесь кнопкой Обзор...).

  2. Выберите слой, куда будет происходить запись(воспользуйтесь кнопкой Обзор...). Слой должен находится в той же карте, где находится исходный слой.

  3. Выберите как будет произведено копирование:

    • Наследовать ключи, в этом случае у объектов сохраняются те же ключи (ID), что и в исходном слое.

      [Предупреждение] Предупреждение

      При совпадении ключей объектов в слое для записи и в исходном слое, объекты с совпадающими ключами будут уничтожены, и вместо них скопированы объекты из исходного слоя, что может привести к потере данных!

    • Объединять базы атрибутов. Если в слое, куда будет копироваться группа уже имеется база данных, имеющая такие поля,которым в слое для записи будет найдено соответствие, то тогда группа запишется с сохранением данных (то есть со всей семантической информацией).

      При выборе опции Объединять базы атрибутов имеется возможность создать протокол изменение ключей (ID), для этого надо установить соответствующую галочку. Создание протокола возможно только при работе с локальными данными. Данный протокол отобразится в окне Сообщения, и будет содержать список как предыдущих ключей группы, так и новых. Ключи (ID) будут перечислены в столбик: старый ID, новый ID.

    • Перенос надписей - если в исходном слое имеются надписи (бирки), то при установке данной опции они так же будут записаны в слой для записи.

  4. Нажмите кнопку ОК.


Импорт из LAS

Операция позволяет импортировать данные из формата *.las. Формат LAS (LASer) был разработан американской организацией ASPRS (American Society for Photogrammetry and Remote Sensing), предназначен для обмена и архивирования данных облака лидарных (лазерных) точек.

Лидар (Lidar - Light Identification, Detection and Ranging) — это метод, который позволяет измерять расстояние до цели, освещая её лазерным светом и измеряя отражённый свет с помощью датчика. Различия во времени возврата лазера и длине его волны могут затем использоваться для создания цифрового трёхмерного представления цели. Результат лидарной съемки представляет собой наборов данных, содержащих облака точек.

В результате импорта данных будет получен слой в виде точек с указанным шагом и базой данных с высотными отметками каждой точки. Так как файл содержит на одну точку в плане сотни точек, в качестве точки рельефа берется точка с меньшим значением высотной отметки.

После импорта данных можно построить слой рельефа и создать триангуляционную сетку, где каждой точке будет соответствовать определённое значение высоты. Затем, используя эту модель рельефа, возможно построить изолиний.

Для импорта:

  1. Справа от строки Имя слоя нажмите кнопку Обзор... и задайте каталог и название для создаваемого слоя. Строкой ниже можно задать пользовательское название слоя, по умолчанию оно точно такое же как имя файла слоя.

  2. Из списка Таблица укажите источник данных, где будут создаваться табличные данные.

  3. Если установлена опция Добавить в карту, то импортированный слой будет добавлен в текущую карту.

  4. Для запуска импорта нажмите кнопку ОК.


Импорт из AutoCAD DXF

При импорте чертежей AutoCAD есть возможность задавать правила, по которым будет осуществляться импорт графических элементов в формат ZuluGIS. Подробнее см. «Настройка подстановки при импорте графических данных из формата DXF».

Для импорта графической информации из формата DXF следует:

  1. Выбрать пункт главного меню Файл|Импорт|AutoCAD DXF. На экране появится стандартный диалог выбора файла, где необходимо выбрать файл формата DXF, который требуется импортировать.

  2. В строке Название слоя задать пользовательское название слоя.

  3. В строке Таблица необходимо выбрать источник данных, где будет создаваться новая таблица (или таблицы в зависимости от операции). Это может быть как локальный источник («База данных Microsoft Access», «База данных SQLite», «Таблицы Paradox»), так и настроенные источники данных ZuluGIS к различным СУБД с использованием ADO/OLEDB или ODBC.

  4. В появившемся диалоговом окне для импортируемого слоя в строке Имя слоя с помощью кнопки [image] необходимо задать имя файла и размещение его на диске.

  5. В строке Единицы измерения необходимо указать, какие единицы следует использовать при импорте.

  6. В строке Кодировка выбрать, какие кодировку использовать для чтения файла.

  7. Для автоматической загрузки импортируемых данных в карту необходимо установить галочку добавить слой в карту. Если ее на данном этапе не установить, то для загрузки слоя в карту надо будет выбрать пункт главного меню Карта|Добавить слой.

  8. В том случае, если вы используете подстановку параметров в поле Файл CFG укажите путь к файлу параметров подстановки (см. «Настройка подстановки при импорте графических данных из формата DXF»).

  9. Для подтверждения процедуры импорта нажать кнопку ОК.

    Диалоговое окно «Импорт из AutoCAD DXF»

    Рисунок 1. Диалоговое окно «Импорт из AutoCAD DXF»

  10. После того, как программа проанализирует содержимое DXF-файла, появится диалоговое окно Импорт из DXF, оно отображает список всех слоев, содержащихся в DXF данных. Напротив каждого слоя установлен флажок (галочка), он означает, что слой будет импортирован. Если какой либо слой не надо импортировать, то флажок с помощью левой кнопки мыши надо снять. С помощью кнопок Выделить все и Отменить все можно отметить сразу все слои для импорта или снять отметки соответственно.

    Диалоговое окно «Импорт из DXF»

    Рисунок 2. Диалоговое окно «Импорт из DXF»

  11. При желании в диалоге Импорт из DXF можно установить дополнительные опции импорта:

    • разделять на слои – означает, что импорт произойдет послойно, при этом название каждого файла слоя будет составлено из имени слоя (файла), заданном в пункте 2 ранее, и изначальном названии слоя, отображенном в диалоге Импорт из DXF, а пользовательское название слоя останется изначальным. Если флажок Разделять на слои не установлен, то все данные импортируются в один слой, с одинаковым пользовательским названием слоя, и именем файла, заданном на предыдущем этапе;

    • не импортировать геометрию блоков - при установке данной опции не будет импортироваться геометрия блоков;

    • импортировать точки вставки блоков - при установке данной опции будут импортироваться точки вставки блоков.

  12. Для запуска процедуры импорта надо нажать кнопку Импорт.


Импорт модели рельефа из Esri TIN

В результате импорта модели рельефа из формата Esri TIN будет получен слой рельефа TIN модели в котором по каждой точке можно получить значение высоты. Для импорта обязательно нужен набор файлов с расширением *.adf, содержащих массив x, у точек, массив высот точек и описанием треугольников. Если отсутствует файл с описанием треугольников, то триангуляция будет выполнена системой. Импортируемые файлы должны располагаться в одном каталоге.

Чтобы импортировать модель рельефа:

  1. Выполните команду меню Карта\Рельеф\Импорт\Esri TIN.

  2. Укажите для импорта файл, содержащий массив x, y точек - tnxy.adf. Нажмите кнопку Открыть.

  3. В диалоге Импорт модели рельефа из Esri TIN справа от строки Имя слоя нажмите кнопку Обзор.... Далее укажите каталог и имя для создаваемого в результате импорта файла рельефа.

  4. В строке Название слоя имеется возможность задать пользовательское название слоя отличное от имени файла.

  5. Из списка Цвет можно выбрать цвет для сетки рельефа.

  6. При установке опции Добавить в карту слой рельефа будет создан и добавлен в текущую карту.

  7. Кнопка ОК завершит процедуру импорта.


Импорт из GeoJSON

GeoJSON - открытый формат, предназначенный для хранения географических структур данных.

Для импорта надо:

  1. Нажать кнопку Обзор..., задать имя для импортированного файла и указать его размещение на диске.

  2. Из списка Таблица указать источник данных, где будут создаваться табличные данные.

  3. Если требуется импортировать только геометрию, то установить соответствующую опцию.

  4. Для добавления импортированного слоя в открытую карту установить опцию Добавить в карту.

  5. Чтобы подтвердить импорт нажать кнопку ОК.


Импорт GeoTIFF в растровый слой ZuluGIS

Для успешного импорта в файлах GeoTIFF обязательно должна содержаться информация о их привязке. В результате импорта будут получены растровые слои имеющие географическую привязку и растровая группа из них. В исходной папке создается папка zrs, в которую сохраняется результат импорта. После импорта результат можно добавить в активную карту.

Чтобы импортировать данные надо:

  1. Справа от строки Папка с файлами изображений нажать кнопку Обзор... и указать папку в которой содержаться файлы GeoTIFF для импорта.

  2. После выполнения предыдущего этапа в окне Файлы будет отображен список файлов GeoTIFF находящихся в указанной папке. Если выделить файл в списке, то справа будет отображена по нему считанная системой информация. Для импорта файла необходимо установить слева от него галочку и при необходимости справа изменить параметры:

    • Папка для записи растров - по умолчанию в исходной папке создается папка zrs, в которую будет сохранен результат импорта, для сохранения данных в другое место справа надо нажать кнопку ... и указать новую папку;

    • Ширина части растра - указывается ширина плиток в пикселах на который будет производиться нарезка растров;

    • Высота части растра - указывается высота плиток пикселах на который будет производиться нарезка растров;

    • Постоянный кэш - данную опцию следует установить если необходимо создавать постоянные кэш-файлы для результата объектов поставьте флажок (создание постоянного кэш-файла ускоряет загрузку объектов в карту).

  3. Чтобы после импорта результат загрузился в активную карту следует установить опцию Добавить в карту.

  4. Для запуска импорта нажмите кнопку ОК.


Импорт из формата GPX

В настоящей версии системы возможен импорт данных из файлов в формате GPX (GPS eXchange Format). Это текстовый формат хранения и обмена данными GPS , основанный на XML. Импортируется геометрия и атрибуты треков и путевых точек.

Для импорта из формата GPX надо:

  1. В строке Имя слоя с помощью кнопки [image] задать имя файла и указать его размещение на диске.

  2. В строке Название слоя задать пользовательское название слоя.

  3. Из списка Таблица указать источник данных, где будут создаваться табличные данные.

  4. В том случае, если импортированный слой требуется сразу добавить в текущую карту, то надо установить опцию «добавить в карту».

  5. Нажать ОК для выполнения процедуры импорта.

Так же система имеет возможность файл хранения и обмена данными GPS в формате GPX (GPS eXchange Format) открывать как один из слоев ZuluGIS, как локально, так и опубликованный на ZuluServer. После открытия файла на карте будут отображены треки и путевые точки. По трекам, точкам трека и путевым точкам можно получить связанные с ними данные.


Импорт модели рельефа из Intermediate TIN Format (ITF)

В результате импорта модели рельефа из формата ITF будет получен слой рельефа TIN модели в котором по каждой точке можно получить значение высоты.

Чтобы импортировать модель рельефа:

  1. Справа от строки Имя слоя нажмите кнопку Обзор.... Далее укажите каталог и имя для создаваемого в результате импорта файла рельефа.

  2. В строке Название слоя имеется возможность задать пользовательское название слоя отличное от имени файла.

  3. Из списка Цвет можно выбрать цвет для сетки рельефа.

  4. При установке опции Добавить в карту слой рельефа будет создан и добавлен в текущую карту.

  5. Кнопка ОК завершит процедуру импорта.


Импорт из формата KML, KMZ

С помощью данного диалога возможен импорт данных из файлов в формате Google Earth KML и KMZ (сжатый KML). В настоящее время импортируется геометрия объектов и их атрибуты.

Для импорта графической информации из формата KML, KMZ надо:

  1. В окне импорта в строке Имя слоя с помощью кнопки [image] надо задать имя файла и указать его размещение на диске.

  2. В строке Название слоя задать пользовательское название слоя.

  3. Из списка Таблица указать источник данных, где будут создаваться табличные данные.

  4. При необходимости импортировать только графическую часть данных установить опцию Импортировать только геометрию.

  5. Для добавления импортированного слоя в текущую карту, надо установить опцию Добавить в карту.

  6. Нажать ОК для выполнения процедуры импорта.


Импорт модели рельефа из LandXML TIN

В результате импорта поверхностей нерегулярной триангулированной сети (TIN) из формата LandXML TIN будет получен слой рельефа TIN модели в котором по каждой точке можно получить значение высоты. Для успешного импорта в XML файле должен быть корневой индекс LandXML и TIN раздел со списком точек X, Y, Z. В том случае, если импортируемый XML файл не будет соответствовать LandXML формату, то будет выдано соответствующее сообщение.

Для импорта выбранного модели:

  1. Справа от строки Имя слоя нажмите кнопку Обзор.... Далее укажите каталог и имя для создаваемого в результате импорта файла рельефа.

  2. В строке Название слоя имеется возможность задать пользовательское название слоя отличное от имени файла.

  3. Из списка цвет можно выбрать цвет для сетки рельефа.

  4. При установке опции Добавить в карту слой рельефа будет создан и добавлен в текущую карту.

  5. Кнопка ОК завершит процедуру импорта.


Импорт из MIF/MID одного файла

Данное диалоговое окно появляется при импорте одного файла обменного формата MIF.

Для импорта надо выполнить следующие действия:

  1. В строке Имя слоя с помощью кнопки [image] задать имя файла и размещение его на диске.

  2. В строке Название слоя задать пользовательское название слоя.

  3. В строке Таблица необходимо выбрать источник данных, где будет создаваться новая таблица (или таблицы в зависимости от операции). Это может быть как локальный источник («База данных SQLite»), так и настроенные источники данных ZuluGIS к различным СУБД с использованием ADO/OLEDB или ODBC.

  4. Если установлена галочка добавить слой в карту, тогда импортированный слой автоматически добавится в карту, если она не установлена, то для загрузки слоя в карту надо выбрать пункт главного меню Карта|Добавить слой.

  5. Нажать кнопку ОК для выполнения процедуры импорта.


Импорт из MIF/MID группы файлов

Данное диалоговое окно появляется при импорте группы файлов обменного формата MIF.

Для импорта группы файлов обменного формата MIF необходимо выполнить следующие действия:

  1. В строке Папка для записи с помощью кнопки [image] задать папку для записи результатов импорта.

  2. В строке Таблица необходимо выбрать источник данных, где будет создаваться новая таблица (или таблицы в зависимости от операции). Это может быть как локальный источник («База данных SQLite»), так и настроенные источники данных ZuluGIS к различным СУБД с использованием ADO/OLEDB или ODBC.

  3. При необходимости импортировать только графическую часть данных установить опцию Импортировать только геометрию.

  4. Для добавления импортированных слоев в текущую карту, надо установить опцию Добавить в карту. Если опция не установлена, то для загрузки слоев в карту надо выбрать пункт главного меню Карта|Добавить слой.

  5. Нажать кнопку ОК для выполнения процедуры импорта.


Импорт треков из OziExplorer PLT

С помощью данного диалога возможно импортировать в слой ZuluGIS треки формата *.plt. Треки будут импортированы в виде типовых символьных объектов, расставленных по маршруту.

Для импорта треков надо:

  1. В строке Имя слоя с помощью кнопки [image] надо задать имя файла и указать его размещение на диске.

  2. В строке Название слоя задать пользовательское название слоя.

  3. Из списка Таблица указать источник данных, где будут создаваться табличные данные.

  4. В том случае, если импортированный слой требуется сразу добавить в текущую карту, то надо установить опцию добавить в карту.

  5. Нажать ОК для выполнения процедуры импорта.


Импорт из QGIS

Используя данный диалог возможен импорт проектов, разработанных в свободно распространяемой ГИС QGIS (Quantum GIS). При импорте поддерживаются символы, цвета, стили линий, заливки.

Для импорта надо:

  1. Для указанного файла из списка Таблица указать источник данных, где будут создаваться табличные данные.

  2. Нажать кнопку Обзор... и задать каталог и название создаваемой карты Zulu. Карта будет содержать слои и настройки проекта QGIS.

  3. Чтобы сразу после процедуры импорта карта открылась установить опцию Открыть карту.

  4. Нажать ОК для выполнения процедуры импорта.


Импорт из Shape SHP

Данный диалог используется при импорте одного файла Shape SHP.

Для импорта данных из одного файла необходимо выполнить следующие действия:

  1. В поле Файл SHP в области настроек Исходный слой укажите расположение импортируемого файла SHP (если он еще не выбран). Для этого нажмите кнопку [image] справа от поля и выберите файл в открывшемся диалоге выбора файла.

  2. В том случае, когда для импортируемого слоя задан PRJ файл в формате WKT с параметрами проекции слоя, то слой можно импортировать с проекцией. Для этого с помощью кнопки [image] справа от поля Файл PRJ выберите требуемый PRJ файл и установите флажок Импортировать информацию о проекции (если он еще не выбран).

  3. В поле Имя в области настроек Слой для записи укажите с помощью кнопки [image] расположение и имя создаваемого файла слоя ZuluGIS.

  4. В строке Название задайте пользовательское название слоя.

  5. В поле Кодировка выберите кодировку текстов импортируемого слоя, а в поле Единицы измерения - используемые в нем единицы.

  6. Из списка Таблица укажите источник данных, в соответствии с которым будут создаваться табличные данные.

  7. Для импорта из слоя только геометрических построений - установите флажок Импортировать только геометрию.

  8. Для автоматического добавления в карту импортированного слоя установите флажок Добавить в карту. Если флажок не установлен, то для последующей загрузки слоя в карту надо выбрать пункт главного меню Карта|Добавить слой.

  9. Для выполнения процедуры импорта нажмите кнопку ОК.


Импорт группы файлов из Shape SHP

Диалог используется при импорте группы файлов Shape SHP.

Для импорта:

  1. Чтобы была импортирована проекция установите флажок Импортировать информацию о проекции.

  2. При импорте группы файлов возможно все файлы импортировать в отдельные слои или в один слой, во втором варианте будет производиться разделение по типам.

    Для импорта в разные слои проверьте чтобы была установлена опция Импортировать в разные слои, затем нажмите кнопку Обзор... и укажите папку для импорта.

    Для импорта в один слой с разделением по типам установите опцию Импортировать как типы в один слой. Далее нажмите кнопку Обзор... и укажите расположение и имя создаваемого файла. Потом в строке Название задайте пользовательское название слоя (оно может дублировать название файла).

  3. В поле Кодировка выберите кодировку текстов импортируемого слоя, а в поле Единицы измерения - используемые в нем единицы.

  4. Из списка Таблица укажите источник данных, где будут создаваться табличные данные.

  5. Для импорта из слоя только геометрических построений - установите флажок Импортировать только геометрию.

  6. Для автоматического добавления в карту импортированного слоя установите флажок Добавить в карту. Если флажок не установлен, то для последующей загрузки слоя в карту надо выбрать пункт главного меню Карта|Добавить слой.

  7. Для выполнения процедуры импорта нажмите кнопку ОК.


Импорт из таблицы

С помощью данного диалога можно преобразовать табличные данные (*.db), имеющие координатную привязку в слой ZuluGIS, с расставленными по координатам таблицы символьными объектами.

Для удачного импорта необходимо наличие в таблице как минимум двух полей в одном из которых будут записаны значения широты, а в другом долготы.

Для импорта надо:

  1. Нажать кнопку Обзор для указания таблицы, которая будет импортирована (формат ее должен быть *.db).

  2. Для выбора проекции табличных данных с правой стороны от сроки Проекция нажать кнопку Выбрать... и указать проекцию (по умолчанию Широта/Долгота WGS 84).

  3. Из открывающихся списков выбрать поля с Широтой и Долготой соответственно.

  4. Справа от строки Слой для записи нажать кнопку Обзор... и задать каталог и название для создаваемого слоя (название желательно задавать латиницей). Строкой ниже можно задать пользовательское название слоя.

  5. При импорте имеется возможность изменить проекцию для импортируемого в ZuluGIS слоя, для задания новой проекции надо с правой стороны от сроки Проекция слоя нажать кнопку Выбрать... и указать новую (по умолчанию здесь будет указана точно такая же проекция как у таблицы).

  6. В результате импорта имеется возможность к символьным объектам привязать базу данных с данными из таблицы. Для этого надо из открывающегося списка Источник данных указать источник для создаваемой базы, а в разделе Поля таблицы галочками отметить поля для импорта. По умолчанию указаны все поля таблицы.

  7. Если необходимо чтобы после импорта слой был загружен в текущую карту, то надо отметить опцию Добавить в карту.

  8. Для запуска процедуры импорта нажать кнопку ОК.


Импорт текста с разделителями

Диалог используется для импорта данных из текстового формата *.csv или *.txt. В результате импорта система расставит в слое по указанным в файле координатам объекты.

В импортируемом файле для успешного результата могут содержаться следующие данные:

  • строка WKT (Well-known text) - WKT это текстовый формат представления векторной геометрии и описания систем координат, результатом импорта будут расставленные в соответствии с координатами указанные в файле фигуры, такие как полигоны, полилинии и др.

  • координаты X, Y - значения широты и долготы, результатом импорта будут расставленные в соответствии с координатами символы.

Для вызова диалога меню импорта выбрать меню Файл|Импорт|Текст с разделителями CSV, TXT, в появившемся окне указать файл для импорта формата *.csv или *.txt, нажать кнопку Открыть.

Затем:

  1. Справа от строки Имя слоя нажать кнопку Обзор... и задать каталог и название для создаваемого слоя. Строкой ниже можно задать пользовательское название слоя, по умолчанию оно точно такое же как имя файла слоя.

  2. В открывшемся окне в списке Разделитель полей необходимо выбрать разделитель, который используется в данных.

  3. Если строковые значения заключены в кавычки, то в списке Ограничитель текста надо выбрать тип кавычек (двойные или одинарные), при отсутствии ограничителя установить параметр {отсутствует}.

  4. Выбрать кодировку данных.

  5. Если первая строка текстового файла содержит названия полей, то надо установить флажок Первая строка содержит имена полей.

  6. Установить переключатель в зависимости от исходных данных:

    • WKT;

    • XY.

  7. В соответствии с установленным на предыдущем этапе переключателем выбрать из списка Поле или Поле X, Поле Y столбцы с координатами объекта, определяемые параметрами проекции.

  8. Для выбора параметров проекции карты нажать кнопку Система координат.

  9. Если требуется импортировать только геометрию, установить соответствующую опцию.

  10. В результате импорта имеется возможность к создаваемым объектам привязать базу данных с данными из таблицы. Для этого надо из открывающегося списка Таблица указать источник для создаваемой базы. Снизу будет отображена структура создаваемой таблицы.

  11. Для добавления импортированного слоя в текущую карту следует установить опцию Добавить в карту.


Импорт данных с веб-сервисов трекинга

Операция позволяет импортировать треки с веб-сервисов системы мониторинга. Поддерживаются следующие веб-сервисы мониторинга:

  • Wialon

  • Omnicomm

  • Fort Monitor

Для импорта:

  1. Из списка Веб-сервисы трекинга выберите веб-сервис данные с которого будут импортированы.

  2. В разделе Авторизация введите или Токен для веб-сервиса Wialon или Логин и Пароль для веб-сервисов Omnicomm или Fort Monitor.

  3. Нажмите кнопку Соединиться. В разделе Объекты отобразится список зарегистрированных объектов.

  4. С помощью галочек выберите объекты для импорта.

  5. Укажите интервал, за который будет производиться импорт.

  6. Нажмите кнопку Обзор... и выберите папку для записи результата импорта.

  7. Из списка Таблица выберите источник данных для таблиц.

  8. Если установить опцию Добавить в карту, то импортированные слои будут добавлены в текущую карту.

  9. Для запуска импорта нажмите кнопку ОК.


Импорт из Metafile WMF

Для импорта графической информации из формата Metafile WMF следует:

  1. Выбрать пункт главного меню Файл|Импорт|Metafile WMF. На экране появится стандартный диалог выбора файла, в нем необходимо выбрать файл формата WMF, который требуется импортировать.

  2. В окне импорта в строке Имя слоя с помощью кнопки [image] необходимо задать имя файла и размещение его на диске.

  3. В строке Название слоя задать пользовательское название слоя.

  4. Нажать ОК для выполнения процедуры импорта.


Импорт кадастровых планов Росреестра формата XML

Для успешного импорта документов Росреестра файлы XML должны соответствовать одной из следующих схем:

  • extract_cadastral_plan_territory;

  • extract_about_property_land;

  • kpt;

  • kvoks;

  • tp;

  • mp;

  • kvzu;

  • extract_about_property_construction;

  • Region_Cadastr;

  • TerritoryToGKN.

Чтобы импортировать данные надо:

  1. В окне импорта из XML нажать кнопку Обзор... и указать паку в которую будет сохранен результат импорта. При импорте одного файла воможно так же задать имя для импортированного файла.

  2. Если импортируется один файл, то в окне Название слоя имеется возможность указвать пользовательское название для созданного после импорта слоя.

  3. Из списка Таблица выбрать источник данных, где будут создаваться табличные данные.

    [Примечание] Примечание

    Текущая версия не поддерживает в качестве источника данных Microsoft Access.

  4. Для перевода импортируемых данных в проекцию Широта/Долгота WGS-84 установить соответствующую опцию. Если опция не выбрана, то в результате будет план-схема с исходными координатами.

  5. Чтобы добавить результат импорта в открытую карту установить опцию Добавить в карту.

  6. Для подтверждения импорта нажать кнопку ОК.


Подключение, отключение и обновление надписей

Диалог используется для работы с надписями, возможно:

  • отключить/подключить надписи

  • сделать дополнительные настройки для надписей

  • обновить надписи

  • открыть шаблон надписи

  • удалить надписи

  • копировать надписи

  • импортировать шаблон надписи

В окошке слева отображается название карты, перечислены слои и созданные надписи. Подключенные к слою надписи помечены иконкой - [image] , отключенные [image] . Подключить те или иные надписи к тому или иному слою на карте, означает указать системе для какого слоя, для какого типа какой вариант из ранее созданных надписей выводить на карту.

Для подключения/отключения надписи надо:

Подвести курсор к варианту надписи, который надо подключить и сделать на нем двойной щелчок левой кнопкой мыши. Подключенная надпись будет помечена иконкой - [image] .

Кнопка Включить все произведет подключение сразу всех надписей карты.

Отключение надписи производится так же двойным щелчком по ней, отключенные надписи помечены иконкой серого цвета ( [image] ).

Кнопка Отключить все произведет отключение сразу всех надписей карты.

Кнопка Вернуть произведет возврат диалога Бирки в начальное состояние.

Для подтверждения подключения/отключения надписи нажать кнопку Применить, для подтверждения подключения и одновременно закрытия диалогового окна бирки, надо нажать кнопку ОК.

Для каждой надписи возможно установить дополнительные опции:

  • Кэширование данных - с помощью данной опции можно увеличить скорость отображения бирок, при ее установке системой создается образ надписей, и при каждом следующем отображении он используется, то есть непосредственного обращения к базе данных не происходит. НО опцию целесообразно использовать только в том случае, если данные в базе не меняются, так как при каждом изменении данных образ будет создаваться заново.

  • Авто фильтр - при большом объеме данных и «подтормаживании» при отображении надписей данную опцию можно попробовать включить, она регулирует внутренние процессы системы по отображению бирок.

  • Не отображать при масштабе меньше, чем 1: - при установке данной опции надписи не будут отображаться, если масштаб станет меньше заданного.

  • Не отображать при масштабе больше, чем 1: - при установке данной опции надписи не будут отображаться, если масштаб станет больше заданного.

  • Порядок отображения: - определяет порядок вывода надписей на карте:

    • Отображать после всех слоев - при выборе данной опции надписи будут выведены поверх всех слоев карты.

    • Отображать после своего слоя - при выборе данной опции надписи будут отображены после своего слоя, то есть если над слоем с подключенными надписями в карте будут находится еще слои, то их объекты могут перекрыть надписи.

Обновление надписей

Если не включено автоматическое создание надписей для новых объектов, то для их создания следует нажать кнопку Обновить. Выполнение обновления зависит от выбранных элементов в списке объектов диалога:

  • если выбран конкретный вариант надписи, то обновляется именно он;

  • если выбран определенный тип объектов слоя, то обновляются все варианты надписей для этого типа;

  • если выбран слой – обновляются все варианты надписей для всех типов в этом слое.

Кнопка Изменить вызывает диалог Создание надписей, через который возможно изменить шаблон надписи.

Кнопка Удалить удаляет текущий в диалоге вариант надписей (шаблон при этом остается).

Используя кнопку Дубль возможно произвести копирование выделенной надписи. Для новой надписи потребуется

задать имя и подтвердить копирование.

Импорт шаблона надписей

Перед импортом в карту надо добавить слои источника шаблона надписей и слой, в который шаблоны планируется импортировать. Так же для успешного импорта необходимо также убедиться, что используемые в шаблоне надписи поля баз данных имеются о обоих слоях. В случае отсутствия полей в слое для записи, в окне сообщений будет выдано сообщение об ошибке импорта. Далее процесс импорта подробно описан в разделе «Импорт шаблонов надписей из одного слоя в другой».


Создание надписей

Для нового варианта надписей надо:

  1. Из открывающегося списка Слой выбрать слой, для которого будут создаваться надписи (автоматически при открытии диалога будет загружен активный слой).

  2. В строке Вариант надписей вместо слова <Новый> задать название для создаваемых надписей.

  3. Из открывающегося списка Тип объекта выбрать тип, для которого надо создать надписи. Если в слое нет типовых объектов, выбирать ничего не надо, по умолчанию надписи будут создаваться для Примитивов. После выбора типа в строку База данных загрузится название используемой выбранным типом базы данных, а в раздел Все поля загрузится список полей основного запроса базы.

  4. Если необходимо вывести надписи для определённых режимов выбранного выше типа, следует нажать кнопку Режимы и снять/установить флажки для необходимых режимов, затем подтвердить выбор нажатием кнопки ОК.

  5. Если в базе данных имеется несколько запросов, то тот, по которому нужно создать надписи можно выбрать из списка Запрос. После выбора запроса в раздел Все поля загрузится список полей выбранного запроса (если в базе данных имеется только один запрос, то выпадающий список Запрос не будет активным).

  6. Если в выбранном типе имеется несколько режимов и необходимо вывести надписи для определённых режимов, то следует нажать кнопку Режимы и снять/установить флажки для необходимых режимов, затем подтвердить выбор нажатием кнопки ОК.

  7. На следующем этапе надо указать поля, которые будут отображаться в надписи, они выбираются из списка Все поля. При большом количестве полей нужное поле возможно найти через поиск, для этого надо ввести хотя бы часть наименования поля в строку [image] , после чего список полей, удовлетворяющий введенным данным будет отображен в разделе Поля базы.

    Для выбора поля левой кнопкой мыши выделите его и нажмите кнопку [image] . После этого имя выбранного поля добавляется последним в список Поля для вывода. Если случайно было добавлено ненужное поле, то для того чтобы его переместить обратно в список Все поля, выделите его с помощью левой кнопки мыши и нажмите кнопку [image] . Для перемещения всех полей из списка Поля для вывода используйте кнопку [image] .

  8. Для каждого выводимого поля имеется возможность задать дополнительные параметры, такие как префикс, постфикс, шрифт, цвет шрифта, признак переноса для полей, следующих за этим полем и для цифровых полей точность, специальные символы, множитель и количество выводимых знаков после запятой. Для этого надо с помощью левой кнопки мыши установить курсор на одном из полей в списке Поля для вывода и задать для него соответствующие параметры. Подробнее.

  9. Затем в разделе Ориентация указывается способ расположения надписи относительно объекта. Подробнее.

  10. В разделе Стиль бирки определяется наличие и внешний вид выносной линии и внешний вид бирки, на фоне которой отображается надпись. При многострочном тексте бирок возможно задать выравнивание текста (лево, право, центр), задать цвет надписи и ее скрытие в зависимости от ее содержимого. Так же можно скрыть надписи у которых отсутствуют данные Подробнее.

  11. При работе с большим объемом данных возможны установки дополнительных параметров:

    • Кэширование - с помощью данной опции можно увеличить скорость отображения бирок, при ее установке системой создается образ надписей, и при каждом следующем отображении он используется, то есть непосредственного обращения к базе данных не происходит.

      [Примечание] Примечание

      Данную опцию целесообразно использовать только в том случае, если данные в базе не меняются, так как при каждом изменении данных образ будет создаваться заново.

    • Авто фильтр - при большом объеме данных и «подтормаживании» при отображении надписей данную опцию можно попробовать включить, она регулирует внутренние процессы системы по отображению бирок.

  12. Для сохранения созданной надписи надо нажать кнопку [image] Сохранить..., после чего станет активной опция, расположенная правее строки Вариант надписей. При установке данной опции произойдет подключение созданных надписей к слою.

[Примечание] Примечание

После подключения надписей их положение на карте и масштаб, с которого они уменьшаются можно отредактировать, как это сделать можно узнать в разделе Редактирование надписей.

Если надо создать еще один вариант надписей для того же типа объекта, то из выпадающего списка Вариант надо выбрать <Новый>, в место слова <Новый> ввести новое название и задать таким же образом, как и для предыдущего варианта все остальные параметры.

[Примечание] Примечание

Для созданных надписей в настройках слоя имеется возможность задать дополнительные опции:

  • Создавать бирки для объекта при добавлении записи в базу - если установлена данная опция, то при добавлении новых объектов на карту не придется в ручную обновлять бирки, они будут обновлены автоматически.

  • Перемещать бирки при перемещении объекта - если она установлена, то при перемещении объектов бирки так же будут перемещены.

Опции возможно установить в структуре слоя (Слой|Структура слоя) в разделе Правила/Редактор.


Запись надписей в слой

С помощью данного диалога имеется возможность записать надписи в уже существующий или автоматически создаваемый слой. Надписи могут быть скопированы как в виде простого текста, ломаных или площадных объектов, так и в виде типового текстового объекта. Все атрибуты стилей объектов при копировании будут сохранены.

Для копирования:

  1. В строке Имя слоя указать слой для записи, воспользуйтесь кнопкой Обзор. Слой может быть как уже существующий, так и новый. При записи в уже существующий слой надо его указать и нажать кнопку Сохранить. Если вы хотите создать новый слой, то в строке Имя файла укажите имя для нового слоя, а в строке Название слоя - его пользовательское название.

  2. При использовании уже существующего слоя, выберите опцию Добавить в слой (надписи будут добавлены к уже существующим объектам слоя) или Создать слой заново (все ранее существующие объекты будут удалены!, а надписи добавлены).

  3. В том случае, если требуется произвести запись только определенных бирок, то их следует заранее выделить и установить опцию Записывать только бирки выделенных объектов.

  4. По умолчанию при копировании надписей в слой они копируются в виде набора простых объектов,для того, чтобы текст был скопирован как типовой объект надо установить дополнительные параметры:

    • Если в слое, куда будет скопирован текст уже существуют соответствующие типы и режимы, к которым должны относится надписи, то надо установить опцию Искать соответствие среди существующих типов. В результате копирования если система найдет в слое, куда будут копироваться надписи соответствующие типы и режимы, то надписи будут преобразованы в них, в противном случае надписи будут скопированы как простые объекты.

    • Если при копировании нужные типы отсутствуют, то надо установить опцию Создавать новые типы для вариантов надписей. В этом случае в структуре слоя, куда будут скопированы надписи будут созданы новые типы и режимы с параметрами копируемых бирок. Названия создаваемых типов будет соответствовать названию слоя, из которого копируются надписи, а названия создаваемых режимов будут соответствовать названию полей базы данных из которых брались данные для бирок. Стиль режимов будет соответствовать стилю исходных надписей.

  5. При установке опции По возможности объединять поля в один объект надписи, расположенные в одной строке, и имеющие одинаковые шрифт, размер и начертание будут объединены в один объект.

  6. С помощью галочек укажите какие надписи будут скопированы, по умолчанию галочки стоят у подключенных к текущей карте надписей.

  7. Для того, чтобы слой с записанными в него надписями был добавлен в текущую карту, установите опцию Добавить слой в карту.

  8. В окне Масштаб 1:1 укажите масштаб для отображения надписей, масштаб по умолчанию считывается с карты.

  9. Нажмите кнопку ОК.


Упаковка слоя

Диалог позволяет упаковать слой, при упаковке создается его архив в виде единого файла с расширением ZPKG. Архив включает всю информацию слоя: структуру слоя, графическую и семантическую информацию, варианты надписей, шаблоны и варианты тематических раскрасок, ассоциированные со слоем пользовательские данные и т.д.

Такая архивация данных удобна при передаче информации сторонним лицам, в результате создается архив с СУБД независимыми данными. В дальнейшем при извлечении слоя для хранения таблиц возможно будет выбрать нужный источник.

[Примечание] Примечание

Видеоурок по упаковке слоя можно посмотреть пройдя по ссылке: https://youtu.be/nwKNZIxOzWo.

[Примечание] Примечание

Если требуется уменьшить размер архива, то возможна упаковка слоя без данных полей типа BLOB (загруженные в базу фото, документы и т.д.).

[Примечание] Примечание

Для упаковки только выделенных объектов необходимо их заранее выделить.

Для упаковки слоя:

  1. Выберите слой для упаковки из открывающегося списка Исходный слой, или нажмите кнопку Обзор... и укажите его на диске. Нажмите кнопку Открыть.

  2. В строке файл архива укажите имя для архива и путь до него, воспользуйтесь кнопкой Обзор.

  3. Дополнительно можно настроить параметры упаковки:

    • Только структуру – будет упакована только структура слоя;

    • Только графику – будет упакована только графическая информация без баз данных;

    • Без BLOB – слой будет упакован без данных полей типа BLOB, что может существенно уменьшить объем архива.

    • Только выделенные объекты - будут упакованы только заранее выделенные объекты. Если в слое нет выделенных объектов, то данный пункт будет не активен.

  4. Нажмите кнопку ОК.


Настройка базы данных для слоя

В разных картах один и тот же слой может отображаться по-разному: разными стилями, через разные тематические файлы, он может быть связан с разными семантическими базами данных и выводить надписи из базы данных по разным шаблонам.

[Важно] Важно

Все настройки, описанные далее относятся только к текущей карте, и будут сохранены ТОЛЬКО при сохранении карты. Соответственно при добавлении настроенного слоя в другую карту настройки будут потеряны.

Во вкладке База данных имеется возможность указать базу данных, которая будет использоваться примитивами слоя. Вкладка отображается только у локальных слоев.


Привязка фотографий

Для фотографических изображений формата JPEG, в полях параметров EXIF которых указаны географические координаты места выполнения съемки, в системе предусмотрена операция по их размещению в слое карты с одновременным их автоматическим позиционированием на карте в соответствии с заданными координатами.

[Примечание] Примечание

Видеоурок по привязке фотографий к слою можно посмотреть пройдя по ссылке: https://www.politerm.com/videos/map/photo_geocoding/.

Диалог привязки фотографий

Рисунок 1. Диалог привязки фотографий

Для выполнения привязки:

  1. Нажмите кнопку [image] справа от поля Папка с фотографиями и выберите в стандартном диалоге выбора файлов каталог, в котором располагаются требуемые фотографии.

  2. Нажмите кнопку [image] справа от поля Слой для записи и выберите в открывшемся диалоге выбора слоя слой, в котором будут сохранены данные привязки фотографий. При выборе уже существующего слоя он будет замещен новым слоем с данными привязки, о чем будет выведено предупреждение.

    [Подсказка] Подсказка

    При создании серверного слоя, все размещаемые фотографии будут скопированы на сервер и к слою будут привязываться уже копии фотографий на сервере.

  3. Для выбора географической проекции слоя нажмите кнопку [image] справа от поля Проекция и «укажите требуемую географическую проекцию» в открывшемся диалоге.

  4. Если требуется добавлять создаваемый слой в текущую карту, установите флажок Добавить в карту.

  5. В поле Символ выберите символ, который будет отображаться в слое для фотографий, если символ не выбрать, для фотографий будет отображаться кружки. Символы, используемые для фотографий, являются стандартными символьными объектами ZuluGIS и могут быть заменены на любые другие символьные объекты, после создания слоя.

  6. В поле со списком Поля таблицы указаны поля EXIF фотографий, данные из которых будут сохраняться в соответствующих поля таблицы фотографий базы данных. Для того чтобы изменить список сохраняемых полей нажмите кнопку справа от поля и выберите требуемые поля в открывшемся диалоге Поля таблицы. Установите флажки у полей, которые требуется сохранять в таблице, либо установите флажок Все чтобы добавить все поля списка. После задания требуемых полей нажмите кнопку ОК, чтобы сохранить изменения и закрыть диалог, либо кнопку Отмена чтобы закрыть диалог без сохранения изменений.

  7. После задания всех параметров привязки фотографий, нажмите кнопку ОК чтобы выполнить процесс привязки, либо кнопку Отмена чтобы закрыть диалог без выполнения привязки фотографий.


Общие настройки слоя

На разных картах один и тот же слой может отображаться по-разному, например, его видимость может меняться в зависимости от масштаба карты, он может быть напечатан или нет, а также отображаться с указанием направлений участков или без них.

[Важно] Важно

Настройки отображения слоёв сохраняются при сохранении файла карты. Также можно сохранить настройки отдельного слоя: «Сохранение настроек слоя».

Во вкладке Общие задаются следующие параметры:

Название слоя – отображается пользовательское наименование, которое указывается при его создании.

Путь – полный путь до места хранения слоя.

Источник – отображается версия ZuluServer или Локальный, если работа с данными осуществляется локально.

Проекция – в данной строке отображается назначенная слою проекция. Для отображения всех характеристик проекции или экспорта проекции слоя нажмите кнопку ....

Отображение:

  • отображать слой на карте – слой будет виден, если стоит галочка, в противном случае нет;

  • отображать слой при печати – слой будет напечатан, если стоит галочка, в противном случае нет;

  • отображать в псевдо 3D – включает режим псевдо 3D, данная опция будет активна только в том случае, если к слою подключена база данных с информацией о высоте объектов;

  • показ направлений на карте – показывать/не показывать стрелками направления для линейных объектов (участков сети - направленных графов). Если при включении данной опции направления на линейных объектах все равно не отображаются, то следует проверить режим линейных типовых объектов в структуре слоя. Если опция отключена в структуре, то даже при включении отображения в настройке слоя направление отображаться не будет;

  • показ направлений при печати – отображать/не отображать стрелками направления для участков сети при печати слоя;

  • отображать узлы – отображать/не отображать узлы объектов;

  • сглаживание линий – включить/отключить сглаживание линий (антиалиасинг) для слоя. Сглаживание линий для всех слоев одновременно задается в настройках карты (Карта|Настройка, вкладка Карта);

[Примечание] Примечание

Масштаб на карте может быть представлен в двух вариантах: геодезическом и в сантиметрах на пиксель. Выбор нужного масштаба осуществляется в параметрах системы.

Масштаб отображения:

  • не отображать при масштабе меньше, чем – слой не будет отображаться, если масштаб станет меньше заданного;

  • не отображать при масштабе больше, чем – слой не будет отображаться, если масштаб станет больше заданного.


Список загруженных слоев

Диалоговое окно Загруженные слои отображает список всех слоев, загруженных в активную карту а также позволяет производить некоторые действия над слоями.

[Важно] Важно

Настройки отображения слоёв сохраняются при сохранении файла карты. Также можно сохранить настройки отдельного слоя: «Сохранение настроек слоя».

Диалог «Загруженные слои»

Рисунок 1. Диалог «Загруженные слои»

Диалог Загруженные слои позволяет:

  • Изменить порядок следования слоев карты

  • Добавить слой в карту

  • Группировать слои карты

  • Исключить слой из карты

  • Изменить параметры настройки слоя

  • Сохранить текущие настройки слоя

  • Назначить проекцию слою

  • изменить структуру слоя

  • Назначить сочетание клавиш для быстрой активизации слоя на карте

    1. Укажите из списка слой.

    2. Нажмите кнопку Клавиша и из списка Сочетание клавиш выберите требуемое сочетание (вида Ctrl+Цифра).

  • Изменить атрибуты слоя

    В списке слоев щелчком левой кнопки мыши можно установить атрибуты для каждого слоя:

    Таблица 1.

    символ отображается в том случае, если у слоя назначена проекция, отличная от план/схемы;

            отменить выделенную группу объектов (если имеются);

    слой является активным (может быть только один слой из списка);

    устанавливает/отменяет редактирование слоя;

    устанавливает/отменяет признак отображения слоя на экране (если кнопка серого цвета, то слой не отображается). Активный слой не может быть скрытым, так как он обязательно должен выводиться на экран. Так же слой можно сделать невидимым на карте сделав щелчок левой кнопкой мыши по иконке рядом с названием слоя в панели Рабочее место.

  • Показывать имена файлов

    Для вывода полных имен файлов загруженных в карту слоев можно установить флажок Показывать имена файлов.

Для подтверждения всех произведенных действий нажмите кнопку ОК, а для отмены новых установок – Отмена.


Преобразование в сеть

С помощью данного диалога возможно автоматическое преобразование объектов в сеть.

Для выполнения преобразования требуется:

  1. Сделать слой сети с преобразуемыми ломаными активным.

  2. Сделать слой сети редактируемым ( [image] ).

  3. Установить режим редактирования объектов (кнопка [image] ).

  4. Выделить группу объектов для преобразования.

  5. Выполнить команду меню Карта|Операции|Преобразование в сеть.

  6. Задать требуемые параметры преобразования в открывшемся диалоге и нажать кнопку ОК. Будет выполнено преобразование выделенных ломаных в сеть.

В диалоге преобразования ломаных в сеть задаются следующие параметры преобразования:

  • список Слой – слой, в котором сохраняется полученная сеть;

  • опция Декомбинировать мультилинии. При установленной опции мультилинии будут разбиты на составляющие отрезки;

  • опция Узловать в точках пересечения линий. При установленной опции, в точках пересечения линий создаются узлы;

  • опция Подтягивать концы линий к узлам. При установленной опции «свободные» концы линий после преобразования будут подтянуты к ближайшим узлам, в поле справа от флажка задается максимальное расстояние на которое могут подтягиваться концы;

  • опция Объединять концы линий. При установленной опции «свободные» разомкнутые концы линий подтягиваются друг к другу, в поле справа от флажка задается максимальное расстояние на которое могут подтягиваться концы;

  • опция Узловать в точках примыкания линий. При установленной опции на концах линий «примыкающих» к другим линиям создаются узлы, в поле справа от флажка задается максимальное расстояние на которое могут подтягиваться концы линий для выполнения примыкания;

  • опция Разделять участки узлами используется в том случае, если на ломаных, которые надо преобразовать в сеть имеются символьные объекты. Тогда символы будут преобразованы в типовые объекты и внедрены в участки. В поле справа от флажка задается максимальное расстояние для «захвата» узлов.

  • опция Разделять участки узлами в точках перелома аналогична предыдущей опции, только символьные объекты будут установлены в каждой вершине ломаных (точках перелома);

  • опция Удалять дублированные объекты. Если опция установлена, дублирующиеся объекты при преобразовании удаляются;

  • в группе полей Участки задается тип (в поле Тип) и режим (в поле Режим) участков создаваемых из ломаных. Для выполнения преобразования ломаных в участки должна быть установлена опция Преобразовывать примитивы в участки;

  • опция Копировать атрибуты при разбиении участка. Если опция установлена, то при разбиении участка его атрибуты будут скопированы во все итоговые участки. В том случае, когда надо чтобы данные поля длины участка не просто были скопированы, а разбиты пропорционально в соответствии с новыми получившимися участками надо дополнительно установить опцию Поле длины и из списка выбрать соответствующее поле (по умолчанию это поле L);

  • в группе полей Узлы задаются типы (в поле Тип) и режимы (в поле Режим) узлов инженерной сети создаваемых на разветвлениях (группа На разветвлениях) и в тупиках (группа На тупиках) сети. Создание узлов сети производится только при установленном флажке Преобразовывать примитивы в узлы.

После задания параметров преобразования нажмите кнопку ОК, чтобы выполнить преобразование, либо кнопку Отмена, чтобы отменить его.


Копирование слоя

Копирование слоя заключается в создании его копии, с новым именем и (по желанию) с новым пользовательским названием. Копируются векторные слои, растровые слои и растровые группы, как локально так и на ZuluServer. Возможно копирование выделенных объектов слоя, только графику или структуру.

[Примечание] Примечание

Видеоурок по копированию слоя можно посмотреть пройдя по ссылке: https://www.politerm.com/videos/layerstruct/layer_copy/.

Серверный слой может копироваться на том же сервере, на локальную машину или на другой сервер. При копировании слоя можно указать новую систему координат (копирование с перепроецированием) и новый источник данных для хранения табличной информации (например, из локальной базы данных в базу Microsoft SQL Server).

Для копирования слоя:

  1. В поле со списком Исходный слой выберите слой для копирования. В том случае, если слой находится в текущей карте выберите его из открывающегося списка, если же слой находится на диске, воспользуйтесь кнопкой Обзор.

  2. Чтобы скопировать группу выделенных объектов слоя, следует установить флажок Только выделенные.

    Для наследования ключей, при копировании группы (ID объектов не изменятся), следует установить опцию Наследовать ключи.

  3. В том случае если требуется уменьшить время копирования или трафика можно скопировать базу данных слоя без данных в полях BLOB, для этого следует установить опцию Без BLOB.

  4. В строке имя задайте полный путь к новому файлу слоя, для этого воспользуйтесь кнопкой Обзор….

  5. В поле название укажите пользовательское название для нового слоя, если было внесено ошибочное пользовательское название, то нажатие кнопки Исходное заменит его на пользовательское название исходного слоя.

  6. Для того чтобы перепроецировать пространственные данные слоя в другую картографическую проекцию в копии слоя, нажмите кнопку Система координат и задайте требуемую проекцию в открывшемся диалоге. Если систему координат не надо менять, пропустите данный пункт.

  7. Выберите требуемый вариант копирования:

    • Графику и таблицы – при выборе данного варианта будет скопирована вся информация слоя, включая графику и базу данных со всей внесенной ранее информацией;

    • Только графику – копируется только графическая информация без баз данных;

    • Только структуру – копируется только структура слоя.

  8. Если необходимо поменять источник данных для хранения табличной информации (например, из Access в SQLite), выберите новый из списка Источник для таблиц.

  9. Для автоматического добавления в текущую карту нового слоя установите флажок Добавить в карту.

  10. Нажмите кнопку ОК чтобы начать процесс копирования.

[Подсказка] Подсказка

Копирование слоя соответствует методу Layer.CopyLayer.


Создать новый слой

Данная панель служит для задания параметров создаваемого векторного слоя.

  1. В строке Имя файла укажите полный путь к создаваемому файлу слоя на диске. Для этого нажмите кнопку Обзор..., и выберите в стандартном окне открытия файла диск и каталог, в котором будут храниться графические файлы, введите имя файла слоя в поле Имя файла и нажмите кнопку Сохранить. Если выбрано имя файла уже существующего слоя, то в результате создания нового слоя существующий слой будет УНИЧТОЖЕН, а новый будет создан на его месте. При задании имени для избежания дальнейших проблем в работе нежелательно использовать специальные символы, например \ / | : * ? " < >. При работе в однопользовательской версии (ZuluGIS) каталог должен располагаться на локальной машине. При работе в многопользовательской версии (ZuluServer) каталог должен располагаться на Сервере геоданных, для доступа к нему надо нажать кнопку Серверы геоданных, расположенную в левой части окна.

  2. В строке Название слоя автоматически повторяется ранее введенное имя, при желании можно ввести отличное название. Желательно, чтобы пользовательское название слоя отображало тематику содержимого создаваемого слоя. Данное наименование будет отображаться в ZuluGIS. При просмотре созданных файлов стандартными средствами операционной системы будет отображаться Имя файла.

  3. Для задания системы координат слоя нажмите кнопку Система координат (списки поддерживаемых типов проекций и датумов см. Поддерживаемые типы проекций и датумы ). Если система координат для слоя указана не будет, то слой будет создан в системе координат план-схема.

  4. При создании слоя без базы, данный пункт пропустите. В том случае, если требуется не только создание слоя, но и одновременно создание базы данных установите опцию Создать таблицу, затем:

    • для создаваемой базы из списка Источник выберите источник данных для таблиц, если нужного источника в списке нет, то добавьте новый;

    • в создаваемой таблице необходимо указать имя и тип полей, подробней о создании таблиц можно узнать в разделе «Создание таблицы».

  5. Для автоматического добавления слоя в текущую карту установите флажок добавить в карту.

  6. После того, как все параметры диалога создания слоя заданы, нажмите кнопку OK, что и завершит создание слоя.

После выполнения действий создается векторный слой (без объектов). Если была указана опция Создать таблицу, то в данном слое уже будет создана база данных с указанными полями. При необходимости созданную базу данных в дальнейшем имеется возможность изменить, например добавить/удалить поля, сделать их группировку, настроить цвет полей, подключить справочники, настроить всплывающие подсказки и др., как это сделать можно узнать в разделе «Редактирование и настройка базы данных».

Так же в таком слое будут уже настроены правила редактора на добавление (при добавлении любого объекта в слой к нему будет автоматически создана запись в таблице) и удаление (при удалении любого объекта из слоя удаляется соответствующая ему запись в базе данных ) объектов.

В том случае, если был установлен флажок добавить в карту, созданный слой загружается в текущую карту.


Создать новый слой по образцу

Данная панель служит для создания нового слоя по уже существующему. В результате такого создания будет получен пустой слой, структура которого будет являться полной копией слоя - образца слоя.

Для создания слоя по образцу в первую очередь после выбора меню Создать по образцу… необходимо указать слой по образцу которого будет создан новый, затем:

  1. Справа от строки Имя в разделе Новый слой нажмите кнопку Обзор... и укажите каталог для нового файла слоя. При работе в однопользовательской версии (ZuluGIS) каталог должен располагаться на локальной машине. При работе в многопользовательской версии (ZuluServer) каталог должен располагаться на Сервере геоданных, для доступа к нему надо нажать кнопку Серверы геоданных, расположенную в левой части окна.

    После указания каталога в строке Имя файла введите имя файла слоя и нажмите кнопку Сохранить. Если выбрано имя файла уже существующего слоя, то в результате создания нового слоя существующий слой будет УНИЧТОЖЕН, а новый будет создан на его месте. Имя слоя не должно содержать специальные символы, например \ / | : * ? " < >.

  2. В поле Название слоя возможно задать пользовательское название отличное от имени файла.

  3. В разделе Система координат выберите проекцию для создаваемого слоя:

    • Взять с карты - система координат будет взята с текущей карты;

    • Взять у исходного слоя - система координат будет взята у «эталонного» слоя;

    • Задать заново - после выбора данной опции надо нажать кнопку Система координат и выбрать или импортировать нужную.

  4. Если необходимо поменять источник данных для хранения табличной информации (например, из Access в SQLite), выберите новый из списка Источник для таблиц. Если менять источник не требуется, пропустите данный пункт.

  5. Для автоматического добавления в текущую карту нового слоя установите флажок Добавить в карту.

  6. Нажмите кнопку ОК чтобы начать процесс создания нового слоя по образцу.


Вырезание слоев по области

Используя данный диалог можно произвести вырезание слоев по области, в результате данной операции будет создана новая карта с копией слоев текущей карты и объектами, которые попадают в указанную область. При этом слои могут быть скопированы с сохранением настроек текущей карты, структурой, базой данных, бирками и.т.д.

Для вырезания области предварительно необходимо сделатьактивным слой, в котором находится область для вырезания. Выделить объект или группу объектов по границам которых будет происходить вырезание. Затем вызвать диалог меню Карта/Операции/Вырезать слои по области.

В диалоговом окне надо:

  1. Нажать кнопку Обзор..., указать название и расположение файла карты, в которую будут добавлены скопированные данные. Нажать кнопку Сохранить.

  2. В строке Название карты при необходимости изменить пользовательское название карты, оно по умолчанию берется из исходной карты.

  3. Из списка Источник для таблиц выбрать источник для хранения таблиц базы.

  4. Для наследования ключей (ID объектов не изменятся), следует установить опцию Наследовать ключи.

  5. Если требуется скопировать только геометрические объекты без баз данных, то следует установить опцию Только геометрия.

  6. Выбрать из списка способ пересечения с областью:

    • полное попадание - при выборе данного пересечения результатом вырезания будут только те объекты, которые полностью попадут в указанную раньше область;

    • любое пересечение - результатом вырезания будут объекты как полностью, так и частично попавшие в указанную область, объекты при этом обрезаны не будут;

    • обрезка по границе - в результате операции объекты, попавшие на границу области будут обрезаны по ней.

  7. Для запуска процесса вырезания слоев по области нажать кнопку ОК.


Уничтожение слоя

С помощью данной операции можно уничтожить либо все файлы, относящиеся к слою либо только графическую информацию.

Для уничтожения слоя:

  1. Выберите нужную опцию :

    • удалять все – будет уничтожена вся информация, относящаяся к слою;

    • не удалять таблицы – не будут удаляться таблицы;

    • не удалять локальные таблицы - не будут удаляться локальные таблицы;

    • не удалять SQL таблицы – не будут удаляться SQL таблицы.

  2. Нажмите кнопку ОК.

В результате произойдет физическое уничтожение слоя с диска компьютера и, если слой был загружен в одно или несколько окон-карт, произойдет его автоматическое удаление из этих окон.


Обезличивание слоя сети

Операция обезличивания слоя сети позволяет создать новый слой, у которого до неузнаваемости изменен графический вид слоя. В результате все объекты будут располагаться на новых местах. При этом все элементы сети остаются связанные между собой как и раньше и такая сеть, хотя и внешне становится полностью неузнаваемая может быть посчитана. Все семантические данные будут сохранены.

Для обезличивания сети надо:

  1. Выбрать меню Слой|Операции|Обезличить слой сети...

  2. Если слой сети для обезличивания загружен ранее в карту, то выбрать его из открывающегося списка Исходный слой. В противном случае нажать кнопку Обзор... и выбрать слой.

  3. В разделе Слой для записи справа от строки имя нажать кнопку Обзор... и указать имя слоя и папку в которую будет записан новый обезличенный слой сети.

  4. В строке название можно поменять пользовательское название для обезличенного слоя.

  5. Если необходимо новому слою поменять источник данных для хранения табличной информации (например, из Access в SQLite) то выбрать новый из списка Источник для таблиц.

  6. Для завершения операции нажать кнопку ОК.


Отображение типов

На этой вкладке можно настроить фильтр для отображения типов и режимов в зависимости от масштаба карты. Это ускоряет отрисовку слоёв с множеством объектов. Опция аналогична настройке видимости слоёв и меток.

М.мин – минимальный масштаб. Если масштаб карты станет меньше заданного Тип (Режим) не будет отображаться.

М.макс – максимальный масштаб. Тип (Режим) не будет отображаться если масштаб отображения станет больше заданного.

Например М.макс: 5000 означает, что объект будет невидимый при масштабах отображения карты более 1:5000.

Фильтры на отображение типов применяются только при выбранной опции Все фильтры включены. Если выбрать опцию Все фильтры отключены, то типовые объекты будут не будут скрываться.


Редактор

  • Геометрические построения

  • Ввод линейных и площадных объектов

  • Обновление данных на рабочих местах пользователей

Во вкладке Редактор выбирается, каким образом будут строится геометрические построения и вводиться линейные и площадные объекты. Так же настраивается интервал обновления данных на рабочих местах пользователей при работе с ZuluServer.


Извлечение слоя

Диалог используется для извлечения ранее созданного упаковкой архива. В результате извлечения создается слой, со всей информацией, содержащейся в архиве. При распаковке можно указать источник данных для хранения табличной информации, отличный от исходного.

Чтобы распаковать архив слоя:

  1. Выберите папку куда будет извлечен слой и задайте имя файла, для этого нажмите кнопку Обзор. Выбранная папка и имя указывается в строке Слой для записи.

  2. Если для распаковываемого слоя нужен новый, отличный от исходного источник данных для хранения табличной информации, то выберите его из списка Источник для таблиц.

  3. При необходимости установите опцию Добавить в карту, распакованный слой тогда будет добавлен в текущую карту.

  4. Нажмите кнопку ОК.


Настройка контуров слоя

Данная закладка помогает настроить стиль для объектов слоя типа Контур. Следует иметь в виду, что при таком задании стиля отображения контурных объектов Вы задаете стиль ТОЛЬКО для отображения в данной карте. Если слой будет загружен на другую карту, настройки отображения сбросятся.

  • цвет фона – задается цвет фона;

  • цвет узора – задается цвет узора;

  • узор – задается узор для площадного объекта, если в списке стилей нет нужного, то его можно создать самостоятельно;

  • прозрачность – задается только для сплошного узора, значение прозрачности указывается в процентах от 0 до 100;

  • цвет – задается цвет для контура площадного объекта;

  • стиль – задается стиль контура площадного объекта, если в списке нет нужного, то его можно создать самостоятельно.

  • толщина на экране – задается толщина контура на экране пикселях;

  • толщина при печати – задается толщина контура при печати.

Настройки для контуров объектов вступят в силу только после установки опции Использовать указанный стиль для всех таких объектов.


Индексация слоя

Для выполнения индексации слоя надо:

  1. В строке Имя выбрать слой, подлежащий индексации (воспользуйтесь кнопкой Обзор... для открытия окна выбора файла).

  2. В строке Шаг индексации ввести значение шага индексации (в сантиметрах). Если слой уже был проиндексирован, то в строке высветится текущий шаг индексации.

  3. Задав желаемое значение шага индексации следует подтвердить ввод клавишей OK, после чего будет запущен процесс индексации.


Информация

[Примечание] Примечание

Информация по слою доступна для векторных слоев.

Диалог Информация позволяет получить краткую информацию о слое. В нем выводится информация об общем количестве объектов и о количестве объектов каждого типа.

В строке Имя отображается полный путь, то есть путь до того места, где храниться файл слоя, по которому отображается информация, а так же название файла слоя.

В строке Название отображается пользовательское название слоя.

В строке Тип отображается тип слоя.

Строка Фрагментация показывает процент логически удаленных объектов от общего количества объектов графической базы данных. Если этот процент велик, имеет смысл произвести «Сжатие слоя» или «Оптимизация слоя».

Отображенная информация может быть скопирована в буфер, для этого нажмите кнопку Копировать.

Кнопка Проекция... откроет информацию о проекции слоя, так же из данного диалога возможно произвести экспорт проекции слоя.

[Примечание] Примечание

Видеоурок по просмотру информации слоя можно посмотреть пройдя по одной из ссылок: https://youtu.be/J_dyxpE0O3g или https://www.politerm.com/videos/layerstruct/informatsiya-po-sloyu/.


Настройка линий слоя

Данная вкладка позволяет установить одинаковый стиль для всех объектов слоя, тип которых Линия. Следует иметь в виду, что при таком задании стиля отображения линейных объектов Вы задаете стиль ТОЛЬКО для отображения в данной карте. Если слой будет загружен в другую карту, то данные настройки отображения будут утеряны.

  • цвет – задается цвет для линии;

  • стиль – задается стиль для лини, если в списке стилей нет нужного, то его можно создать самостоятельно.

  • толщина на экране – задается толщина линейных объектов на экране пикселях;

  • толщина при печати – задается толщина линейных объектов при печати.

    Настройки для линейных объектов вступят в силу только после установки опции Использовать указанный стиль для всех таких объектов.


Режим псевдо-3D

С помощью данного диалога имеется возможность отображать объекты слоя в изометрической проекции, с высотой боковых граней объектов пропорциональной высоте объекта указанной в базе данных. Для слоев, объектам которых в базе данных задана информация о высоте, возможно отображение в режиме псевдо-3D. Режим позволяет визуально оценить высоту объектов от земли и относительно друг друга.

Для построения псевдо-3D отображения объектов:

  1. В полях Тип, База данных и Запрос выберите тип объектов, базу данных слоя и запрос по которым требуется выполнить построение.

  2. В поле Поле выберите поле, в котором указана высота объектов (в метрах, либо в этажах).

  3. В поле Единицы выберите единицы, в которых задается высота объектов (Этажи, либо Метры).

  4. В поле Высота по умолчанию, м, задайте высоту, которую должны иметь объекты, для которых не указана высота.

  5. Если в качестве единицы высоты выбраны этажи, в поле Высота этажа, м укажите высоту одного этажа, в метрах.

  6. Флажок Подключить псевдо 3D дублирует функциональность аналогичного флажка в настройках слоя. Установите его, чтобы включить режим псевдо-3D, либо снимите, – чтобы выключить.

  7. Нажмите кнопку ОК, чтобы закрыть диалог и выполнить построение объектов в режиме псевдо-3D.

Подробней о режиме псевдо-3D можно узнать в разделе «Режим псевдо-3D».


Публикация данных для веб-служб ZuluServer

Диалог используется для публикации данных для веб-служб ZuluServer по протоколу ZWS.

Чтобы опубликовать серверный слой для веб-служб ZuluServer надо:

  1. Из списка Слой следует выбрать слой с сервера для публикации. Если слой не загружен в текущую карту, то его возможно выбрать нажав кнопку Обзор.

    [Предупреждение] Предупреждение

    Слой для публикации должен быть опубликован на сервере и находиться в корневом каталоге данных сервера (по-умолчанию папка Data). При выборе для публикации локального слоя появится сообщение: Локальный слой не может быть опубликован для веб-служб. Выберите слой на сервере. После чего надо нажать кнопку ОК и указать слой на сервере геоданных.

  2. Создать пространство имён. Для этого следует нажать кнопку Добавить и в появившемся окне внести название для пространства. Допустимыми в названии являются латинские буквы, арабские цифры и символ "_". Если нужное пространство уже имеется то его надо выбрать из соответствующего списка.

  3. В строке Имя ZWS ввести служебное имя слоя и установить опцию Доступ.

  4. Выбрать параметры отображения слоя:

    • по умолчанию - слой будет отображаться без собственных настроек отображения;

    • из настроек слоя - при отображении слоя будут использоваться настройки (масштаб отображения слоя, типов и режимов, направлений), сохранённые в слое.

  5. При необходимости, указать в секундах Интервал обновления слоя.

    [Примечание] Примечание

    Интервал обновления - указывается в секундах частота обращения клиента к серверу, для проверки актуальности текущих данных.

    Необходимо указывать в случаях, когда данные слоя меняются «внешними средствами», например: запись в базу данных слоя SCADA системой, или изменение данных с помощью запросов внутри СУБД.

  6. При установке опции Редактирование геометрии через веб отключено запрещается редактирование графической информации через веб-службы. В этом случае при попытке редактирования геометрии через ZuluGIS Online или ZuluGISMobile будет появляться ошибка.

  7. При установке опции Редактировать в ZuluGISMobile только по GPS в ZuluGISMobile координаты при вводе объекта возможно получать только по GPS данным.

  8. Нажать кнопку Опубликовать.

    В случае удачной публикации в разделе Публикации появится название пространства имен и через двоеточие название опубликованного слоя.


Настройка параметров растрового слоя

[Важно] Важно

Все настройки, произведенные указанным ниже способом относятся только к текущей карте, и будут сохранены ТОЛЬКО при сохранении карты. Соответственно при добавлении настроенного слоя в другую карту настройки будут потеряны.

Во вкладке Параметры задаются цвета отображения растрового объекта:

  • флажки использовать цвет линий и использовать цвет фона - позволяют установить цвета, выводимые для монохромного растра вместо его исходных цветов. Для задания требуемого цвета установите флажок и выберите цвет в поле справа от флажка;

  • флажок прозрачный белый. Установка этого флажка делает все белые области растра прозрачными;

  • Поле Прозрачность – устанавливает степень прозрачности растров. Прозрачность задается в процентах, от 0 до 100.

Для вступления в силу всех произведенных изменений установите флажок Использовать указанный стиль для всех таких объектов и нажмите кнопку ОК.


Переименование слоя

Операция переименования может применяться к следующим слоям:

  • векторного (*.b00);

  • растрового (*.zrs);

  • рельефа (*.ztr);

  • WMS, WMTS, слои Tile-сервера, SRTM (*.zww)

  • трекинга.

[Примечание] Примечание

Видеоурок по переименованию слоя можно посмотреть пройдя по ссылке: https://youtu.be/eL4ZXTYPjFY.

Для локальных векторных слоев возможно переименование как пользовательского названия, так и имен всего семейства файлов слоя. Для остальных слоев производится переименование только пользовательского названия.

[Предупреждение] Предупреждение

Переименовать слои в файловой системе (Проводнике) не рекомендуется. Это может привести к потере данных!

Для переименования слоя:

  1. Если необходимо задать новое пользовательское имя для слоя, то в появившемся диалоговом окне, в строке Пользовательское название слоя укажите новое название.

  2. Если необходимо сменить имя для семейства файлов локального векторного слоя, то в строке Новое имя файла укажите новое имя.

  3. Для запуска процесса переименования нажмите кнопку ОК.

При изменении имени файла слоя слой будет извлечен из карты, для добавления в карту надо выбрать меню Карта/Добавить слой.


Параметры видимости слоев

Данный диалог позволяет настроить параметры отображения сразу для нескольких выделенных слоёв карты.

Диалог Параметры видимости слоев

Рисунок 1. Диалог Параметры видимости слоев

  • отображать слой на кате- слой будет виден, если стоит галочка, в противном случае нет;

    [Подсказка] Подсказка

    Параметр соответствует свойству Layer.Visible.

  • отображать слой при печати- слой будет напечатан, если стоит галочка, в противном случае нет;

    [Подсказка] Подсказка

    Параметр соответствует свойству Layer.Printable.

  • показ направлений- показывать/не показывать стрелками направления для участков сети т.е. для линейных объектов (направленных графов);

  • отображать узлы- отображать/не отображать узлы объектов;

  • не отображать при масштабе меньше, чем- слой не будет отображаться, если масштаб станет меньше заданного;

    [Подсказка] Подсказка

    Параметр соответствует свойству Layer.MinScale.

  • не отображать при масштабе больше, чем- слой не будет отображаться, если масштаб станет больше заданного.

    [Подсказка] Подсказка

    Параметр соответствует свойству Layer.MaxScale.


Параметры символьного объекта

С помощью данного диалога имеется возможность изменить параметры для простого символьного объекта:

  • список Символ - содержит список всех символов слоя, из него можно выбрать новый символ для отображения объекта.

  • кнопка Изменить... - открывает Редактор символов для редактирования символа, выбранного в списке Символ;

  • кнопка Новый - открывает Редактор символов для создания нового символа;

  • в строке размер меняется масштаб карты для отображения символа - поскольку размеры символов из библиотеки символов задаются в относительных единицах (пикселах), то заранее неизвестно, какого размера они будут на той или иной карте, так как слой может создаваться для масштабов области, города, квартала, помещения. Поэтому для регулирования размеров символов на карте вводится масштабирующий отображение символов коэффициент. В строке размер указывается тот масштаб карты, при котором символ будет отображаться в размере 1:1 как он был создан в редакторе символов.

  • Из списка цвет выбирается цвет узора только для тех символов, у которых цвет узора задан как авто, если цвет узора уже был указан при создании символа, то цвет из данного списка игнорируется;

  • флажок Масштабировать - регулирует изменение размеров символа при изменении масштаба карты;

  • если установлен флажок Не увеличивать больше указанного размера, то при уменьшении масштаба карты меньше указанного в строке размер, символ больше увеличиваться не будет.


Стиль текстового объекта

В данной вкладке задается стиль для простого текстового объекта:

  • раздел Шрифт - задается наименование шрифта;

  • раздел Начертание - задается начертание шрифта, доступно начертание: курсив, обычный, полужирный, полужирный курсив;

  • из списка Набор имеется возможность выбрать подходящий набор для текстовых объектов (Юникод, Арабский, Балтийский, Вьетнамский, Греческий, Западный, Иврит, Кириллический, Турецкий, Центральноевропейский);

  • в разделе Текст задается стиль шрифта (подчеркнутый, зачеркнутый);

  • цвет шрифта задается с помощью открывающегося окна Цвет;

  • параметры фона шрифта задаются в разделе Фон с помощью списков Тип и Цвет.

Все производимые изменения стиля будут отражены в окошке Образец.


Трансформирование слоя

Данный диалог позволяет произвести трансформирование слоя с помощью параметров сдвига, поворота, масштаба или с помощью коэффициентов трансформации.

Для трансформирования слоя надо:

  1. Указать слой, подлежащий трансформации (для открытия стандартного окна выбора файла используйте кнопку Обзор...).

  2. Из списка Параметры преобразования выбрать по каким параметрам будет производиться трансформация: Сдвиг, поворот, масштаб или Коэффициенты.

  3. При выборе трансформирования с помощью Сдвига, поворота, масштаба:

    • в разделе Смещение следует задать значения смещений слоя по X и Y в сантиметрах;

    • в разделе Масштаб следует задать значения коэффициентов искажения масштаба слоя по X и Y. Если установлен флажок Пропорционально, то коэффициенты масштабирования по осям X и Y будут одинаковыми;

    • В разделе Центр (см) следует задать координаты точки поворота слоя в сантиметрах и угол поворота в градусах.

  4. При выборе трансформации с помощью коэффициентов:

    • в разделе Коэффициенты надо задать коэффициенты для трансформации, смещения задаются в сантиметрах, ось X направлена вверх, Y вправо;

    • при нажатии кнопки Инвертировать коэффициенты будут обратно преобразованы.

  5. После ввода требуемых параметров преобразования следует нажать кнопку OK, после чего запустится процесс трансформации слоя.

[Примечание] Примечание

Трансформацию слоя также можно произвести с экрана.


Построение зон близости

Данный диалог используется для построения зон близости:

  1. Выберите слой, по которому будут строиться зоны.

  2. Справа от сроки Слой для записи нажмите кнопку [image] , в открывшемся диалоге укажите путь до создаваемого слоя с зонами и его имя.

  3. Укажите пользовательское название создаваемого слоя с зонами.

  4. При необходимости установите опцию Добавить в карту, созданный слой тогда будет добавлен в текущую карту.

  5. Нажмите кнопку ОК.

    В результате будет создан слой с зонами близости.


Работа со слоями по спецификации WMS

Система поддерживает возможность работы с удаленными картами и данными через Интернет в соответствии со спецификацией Web Map Service (WMS). Данная спецификация разрабатывается консорциумом открытых ГИС (Open GIS Consortium – OGC).

Для использования данных с удаленного сервера в диалоге Параметры WMS:

  1. В поле Сервер WMS введите адрес веб–сервера (если он уже ранее вносился, то выберите его из списка).

  2. Если адрес вводился заново, нажмите кнопку Запросить, при выборе адреса из списка, запрос к серверу происходит автоматически. После запроса к серверу в окне Слои WMS будут отображены доступные слои сервера, в списке Проекция указана проекция, и в том случае, если слой имеет стили, то при его выделении они будут указаны в списке Стиль. У слоя, не содержащего атрибутивные данные иконка будет серого цвета, в противном случае синего.

  3. Для просмотра слоя можно выбрать его в списке и нажать кнопку Показать слой.

  4. Следующий этап - это выбор тех слоев, которые в дальнейшем будут сохранены, для выбора слоя укажите его в списке Слои WMS и нажмите кнопку [image] , если слой выбран ошибочно, то удалить его из списка можно с помощью кнопки [image] .

    Напротив выбранных слоев будут отображены иконки: и [image] , щелкая по ним имеется возможность отключить видимость слоя и получаемую информацию соответственно. Если данные отключены иконки будут отображены серым цветом.

    Выбранные слои в дальнейшем будут отображены в обратном порядке их выбора, т.е., самый верхний слой - последний в выбранном списке. Если нужно поменять порядок отрисовки слоёв, воспользуйтесь кнопками [image] и [image] . Полученный результат можно увидеть нажав кнопку Показать результат. Но необходимо учитывать, что встречается такой размер слоев, что в результате масштабирования он может быть не виден в диалоге.

  5. Далее установите параметры для WMS слоя:

    • проекцию - список доступных проекций определяется настройками сервера, при неправильно выбранной проекции данные могут быть искажены;

    • формат растра (png, gif, jpeg) - формат jpeg используется в том случае, если не принципиально качество изображения, так как алгоритм сжатия предполагает небольшую его потерю. Использование png формата подразумевает более качественное воспроизведение слоев, при этом соответственно объем информации будет увеличен;

    • прозрачность или цвет фона - прозрачность доступна только для форматов png, gif, формат jpeg ее не поддерживает;

    • подбор полупрозрачности - при установке данной опции запускается алгоритм оптимизации изображения, на рисунке ниже слева выведено изображение без подбора полупрозначности, справа с подбором:

    • Слева слой WMS без подбора полупрозрачности, справа с подбором полупрозрачности

      Рисунок 1. Слева слой WMS без подбора полупрозрачности, справа с подбором полупрозрачности

    • формат получаемой информации (text/plain, text/html, aplication/vnd.ogc) - данная опция определяет в каком формате будет получен ответ на запрос информации от сервера

      • text/plain - простой текст, при каждом запросе будет скачиваться текстовый файл;

      • text/html - текст в формате html, при запросе откроется браузер с данными объекта;

      • application/vnd.ogc.gml - ответ в формате GML.

    • максимальную ширину и высоту - от сервера данные получаются в виде множества квадратов, необходимо задать их максимальный размер, надо учитывать что чем меньше указанные значения, тем меньше качество изображения в результате малого разрешения.

  6. В поле Название введите пользовательское название слоя.

  7. Нажмите кнопку Сохранить, укажите папку и введите имя файла, снова нажмите кнопку Сохранить, после чего созданный слой будет загружен в текущую карту.

  8. Для закрытия диалогового окна Параметры WMS нажмите кнопку ОК.

Окно «Параметры WMS»

Рисунок 2. Окно «Параметры WMS»

[Примечание] Примечание

Параметры прокси-сервера для выполнения HTTP запросов к WMS и тайл-серверам задаются в диалоге Сервис|Параметры|Сеть.


Работа со слоями по спецификации WMTS

WMTS (Web Map Tile Service) - стандарт, разработанный консорциумом открытых ГИС (Open GIS Consortium – OGC), является открытой спецификацией для публикации в сети цифровых карт с использованием кэшированных листов изображений.

Zulu реализует работу с сервисами WMTS по спецификации организации OGC WMTS 1.0.0, которые используют в запросах либо кодировку REST, либо «ключ/значение» (KVP).

Для обращения к сервису WMTS необходимо знать URL, который имеет следующий формат:

http://<имя сервера или ip адрес>:<порт>/<URI сервиса>

Для использования данных с удаленного сервера необходимо эти данные загрузить и сохранить как WMTS слой, для этого:

  1. В поле Источник введите URL сервиса WMTS.

  2. Нажмите кнопку Обзор, выпадающий список Имя слоя заполнится списком слоев, прочитанных с сервера, а таблица содержания соответственно заполнится списками стилей, схем листов и проекций для каждого слоя.

  3. Выберите нужный слой и соответствующие параметры в таблице содержания:

    • cтиль;

    • схема листов;

    • проекция.

  4. В поле Название слоя введите пользовательское название слоя.

  5. Нажмите кнопку Сохранить, введите имя файла, снова нажмите кнопку Сохранить.

  6. Для закрытия диалогового окна WMTS задать параметры слоя нажмите кнопку ОК.

Окно «WMTS задать параметры слоя»

Рисунок 1. Окно «WMTS задать параметры слоя»

Для загрузки слоя в карту:

  1. Выберите меню Карта|Добавить слой или нажмите кнопку [image] .

  2. Укажите на диске созданный ранее слой.

  3. Нажмите кнопку Открыть.

[Примечание] Примечание

Параметры прокси-сервера для выполнения HTTP запросов к WMS, WMTS и тайл-серверам задаются в диалоге Сервис|Параметры|Сеть.


Добавление карты в макет

С помощью данного диалога имеется возможность добавить карту в макет, для этого:

  1. Выберите какую карту необходимо вставить:

    • Вставить текущую карту - при выборе данной опции вставлен будет фрагмент текущей карты;

    • Выбрать на диске - опцию необходимо установить в том случае, если карта не загружена и ее надо выбрать на диске.

  2. Нажмите кнопку ОК. Если на предыдущем этапе была выбрана опция Выбрать на диске, то после нажатия кнопки откроется стандартный диалог выбора файлов, в нем укажите файл карты.

  3. Выделите мышью прямоугольную область на макете, либо щелкните мышью в том месте, куда следует вставить фрагмент выбранной карты.


Вкладка цвета и линии

Данная вкладка позволяет:

  • в разделе Заливка - из открывающегося списка выбрать цвет фона для вставленного объекта;

  • в разделе Линии - задать цвет и толщину для рамки объекта.

После ввода новых данных и нажатия кнопки Применить, произойдет обновление в соответствии с новыми параметрами.


Вкладка Общие

С помощью данной вкладки имеется возможность настроить:

  • в разделе Габариты - местоположение и размер вставленного в макет объекта (в мм);

  • в разделе Якорь - якорь для объекта.

После ввода новых данных и нажатия кнопки Применить, произойдет перестроение рамки с объектом в зависимости от новых параметров.


Добавить в легенду

С помощью данного диалога возможно добавить в легенду новый раздел или новый пункт:

  • Добавить раздел - добавление нового раздела. Под пунктом требуется выбрать тип добавляемого раздела:

    • новый - добавление нового пустого раздела в последнюю позицию легенды;

    • по слою текущей карты - создастся раздел, заполненный по выбранному слою карты, на основе которой была построена легенда;

    • по слою на диске - создается раздел, заполненный по выбранному слою на диске;

    • по шаблону темы - создается раздел, заполненный по выбранному шаблону темы слоя. Тексты пояснительных подписей берутся из названий условий шаблона.

  • Добавить пункт легенды - добавление пунктов с условными обозначениями. Для добавления пункта предварительно должен быть выбран раздел или колонка в которую добавляется новый пункт.

    В поле со списком выбирается тип добавляемого пункта (Текстовый, символьный, линейный, или полигональный).

    С помощью переключателей выбирается способ добавления пункта:

    • новый - добавляется новый пункт;

    • взять из слоя текущей карты - откроется диалог импорта условных обозначений из слоя текущей карты;

    • взять из слоя на диске - откроется диалог импорта условных обозначений из слоя на диске.


Настройка легенды

С помощью данного редактора имеется возможность настроить легенду макета.

Редактор содержит окно легенды, панель операций, вкладки Оформление и Размеры.

Окно легенды

В окне легенды можно просматривать редактируемую легенду, изменять режим отображения и выделять отдельные элементы легенды.

С помощью щелчка правой кнопкой мыши в окне легенды вызывается контекстное меню со следующими командами:

  • Выделить – устанавливает режим выделения элементов легенды. Выделенные элементы подсвечиваются голубым цветом;

  • Увеличить – устанавливает режим увеличения;

  • Уменьшить – устанавливает режим уменьшения;

  • Показать 1:1 – устанавливает масштаб отображения, соответствующий масштабу при печати легенды;

  • Показать каркас – устанавливает режим отображения макета, когда границы элементов показаны; пунктирной серой линией;

  • Добавить… – вызывает диалог добавления новых элементов в легенду;

  • Удалить – удаляет выбранные элементы легенды.

[Примечание] Примечание

В любом режиме отображения можно осуществлять масштабирование с помощью поворота колесика мыши и сдвиг легенды с помощью перемещения мыши с нажатым колесиком.

Панель операций

С помощью кнопок вверх [image] , вверх до конца [image] , вниз [image] , вниз до конца [image] вы можете перемещать выбранные пункты легенды.

Добавить [image] - вызывает диалог добавления новых элементов в легенду.

Удалить [image] – удаляет выбранные элементы легенды.

Вкладка Оформление

С помощью данной вкладки имеется возможность оформлять стиль рамки и стиль заполнения элементов легенды, задавать заголовок и его шрифт, выравнивание и перенос.

Фрейм легенды

  • Рамка легенды – вы можете задать стиль оформления границы рамки и заливки фрэйма легенды.

  • Заголовок легенды – вы можете задать заголовок фрэйма легенды. С помощью кнопки Стиль… вы можете задать шрифт, цвет шрифта и выравнивание текста заголовка. Если вы не хотите, чтобы заголовок отображался при печати - выберите опцию Не отображать.

  • Автоперенос разделов – при включении этой опции разделы легенды автоматически позиционируются в соответствии с размером легенды в окне редактора макетов.

  • Автовыравнивание высоты разделов – при включении этой опции высота разделов находящихся в одном ряду будет одинаковой.

Разделы легенды

  • Рамка раздела – вы можете задать стиль оформления границы рамки и заливки раздела легенды.

  • Заголовок раздела – вы можете задать заголовок раздела легенды. С помощью кнопки Стиль… вы можете задать шрифт, цвет шрифта и выравнивание текста заголовка. Если вы не хотите, чтобы заголовок отображался при печати - выберите опцию Не отображать.

  • Перенести в новый ряд – при включении этой опции раздел будет перемещен в новый ряд.

  • Автовыравнивание высоты колонок – при включении этой опции высота колонок раздела будет одинаковой.

Колонки раздела

  • Рамка колонки – вы можете задать стиль оформления границы рамки и заливки колонки.

  • Заголовок колонки – вы можете задать заголовок колонки. С помощью кнопки Стиль… вы можете задать шрифт, цвет шрифта и выравнивание текста заголовка. Если вы не хотите, чтобы заголовок отображался при печати - выберите опцию Не отображать.

Пункты легенды

Рисунок 1. Диалог «Макет»

  • Рамка пункта легенды – вы можете задать стиль оформления границы рамки и заливки пункта легенды. С помощью кнопки Макет… вы можете задать взаимное расположение примера условного обозначения и пояснительной подписи.

  • Подпись пункта легенды – вы можете задать пояснительную подпись для примера условного обозначения пункта легенды. С помощью кнопки Стиль… вы можете задать шрифт, цвет шрифта и выравнивание текста пояснительной подписи.

  • Если вы не хотите, чтобы подпись отображалась при печати – установите флажок Не отображать.

    Диалог «Настройка отображения примера»

    Рисунок 2. Диалог «Настройка отображения примера»

  • Оформление примера – вы можете изменить стиль образца условного обозначения. Например, для полигональных объектов изменить прямоугольный образец на овальный и т.д.

Вкладка Размеры

В данной вкладке можно задавать размеры и отступы элементов легенды.

Установка размеров

  1. Фрейм легенды.

    Вы можете задать размеры и отступы между разделами легенды введя значения в соответствующие поля вкладки Размеры.

  2. Разделы легенды.

    Вы можете задать размеры и отступы между колонками раздела введя значения в соответствующие поля вкладки Размеры.

  3. Колонки раздела.

    Вы можете задать размеры и отступы между пунктами колонки введя значения в соответствующие поля вкладки Размеры.

  4. Пункты легенды.

    Вы можете задать размеры и отступы для пункта легенды введя значения в соответствующие поля вкладки Размеры. Также вы можете изменить размер примера образца условного обозначения, горизонтальное и вертикальное выравнивание пояснительной подписи и примера.


Настройка вставленной карты

В разделе Карта отображено пользовательское название вставленной карты и путь до нее.

В разделе Масштаб и центр:

  • масштаб - устанавливается масштаб печатаемой карты;

  • центр карты - указывается центр карты;

  • поворот карты указывается поворот карты, направление вращения - против часовой стрелки.

В разделе Область печати настраивается область печати карты:

  • Текущие масштаб и центр - печататься будет видимая область карты, масштаб будет определен автоматически, подробней о такой печати можно узнать в разделе Печать текущего масштаба и центра карты;

  • Вся карта - на печать выводится вся карта, по умолчанию в текущем масштабе, подробней о такой печати можно узнать в разделе Печать всей карты;

  • По габаритам слоя - на печать будут выведены объекты, попавшие в габариты указанного слоя, по умолчанию в текущем масштабе, подробней о такой печати можно узнать в разделе Печать по габаритам указанного слоя;

  • Фрагмент печати - на печать будет выведен выделенный фрагмент, подробней о такой печати можно узнать в разделе Печать фрагмента;

  • Планшет - выбор данного пункта позволяет произвести многостраничную печать по планшетам, подробней можно узнать в разделе Многостраничная печать по планшетам.

После ввода новых данных и нажатия кнопки Применить, произойдет перестроение вставленного фрагмента в соответствии с новыми параметрами.


Диалог Вариант

В данном диалоге выбирается вариант обозначения для вставленного в макет знака Север.

Чтобы выбрать вариант необходимо выделить его в списке и нажать кнопку ОК. После чего произойдет изменение внешнего вида знака в соответствии с выбранным вариантом.


Настройка масштаба в макете

Данная вкладка позволяет:

  • в разделе Заливка - из открывающегося списка выбрать цвет фона для вставленного масштаба;

  • в разделе Линии - задать цвет и толщину для рамки масштаба.

После ввода новых данных и нажатия кнопки Применить, произойдет обновление в соответствии с новыми параметрами.


Настройка масштаба в макете

Данная вкладка позволяет настроить вид масштаба в макете:

  • В разделе Шкала можно изменить число делений и число подделений. Так же имеется возможность точно указать цену деления. Для этого надо снять флажок авто и в окошко цена деления вписать нужное значение.

  • В разделе Единицы измерения можно задать отображение отсчетов и подписей. В списке единицы выберите единицы измерения, в окошке подпись задайте подпись единиц измерения (напр. кратко «м» или полностью «метры»). В списке размещать выберите вариант размещения подписи, а в списке отсчеты задайте вариант отображения отсчетов.

После ввода новых данных и нажатия кнопки Применить, произойдет перестроение масштаба в соответствии с указанными данными.


Вариант обозначения масштаба

В данном диалоге выбирается вариант обозначения для вставленного в макет масштаба.

Чтобы выбрать вариант необходимо выделить его в списке и нажать кнопку ОК. После чего произойдет изменение внешнего вида масштаба в соответствии с выбранным вариантом.


Настройка текста в макете

Данная вкладка позволяет настроить направление текста. В группе настроек Ориентация выберите требуемую ориентацию текста. При этом в области Образец будет отображен вид текста в выбранной ориентации.

После ввода новых данных и нажатия кнопки Применить, произойдет перестроение текста в соответствии с указанной ориентацией.


Логин и пароль для сервера

Данное диалоговое окно предназначено для того, чтобы установить соединение с сервером ZuluServer.

Для соединения необходимо ввести в поле пользователь имя пользователя, а в поле пароль пароль, нажать кнопку ОК.

Кнопка Отмена закроет диалог.


Ошибка авторизации

Данное диалоговое окно появляется при ошибки авторизации, т.е. если не правильно были введены имя или пароль пользователя. Для повторной авторизации нажмите кнопку Закрыть и введите идентификационные данные заново.


Макросы

Диалоговое окно предназначено для создания макросов на языках VB Script или Java Script. При выборе в меню Сервис пункт Макросы... автоматически в папке Macros создается файл MyMacros, который может быть использован для написания макросов на языке VB Script. Данная папка находится в той же директории где установлена ZuluGIS, в том случае, если папки не существует, она также будет создана автоматически.

Корневым объектом для макросов ZuluGIS является объект Application.

Для создания нового макроса:

  1. В строке Имя макроса введите название создаваемого макроса.

  2. Из списка Файл выберите файл для записи макроса. Если нужного файла нет, то нажмите кнопку Новый, укажите имя файла, затем с помощью опций выберите нужный язык программирования и нажмите ОК.

  3. Нажмите кнопку Правка.

  4. В появившемся окне напишите код для макроса.

  5. С помощи меню Файл|Сохранить или комбинацией клавиш Ctrl + S сохраните макрос и закройте окно редактора.


Упаковка карты

При упаковке карты создается архив в виде единого файла с расширением ZPKG. Архив будет включать в себя карту и слои в нее входящие. При этом сохраняются все данные и настройки, такие как структура слоев, графическая и семантическая информация, варианты надписей, шаблоны и варианты тематических раскрасок, ассоциированные со слоем пользовательские данные и т.д.

Такая архивация данных удобна при передаче информации сторонним лицам, в результате так же как и при архивации отдельного слоя создается архив с СУБД независимыми данными. В дальнейшем при извлечении слоя для хранения таблиц возможно будет выбрать нужный источник.

Для упаковки карты:

  1. Проверьте чтобы в списке Исходная карта было указано название нужной карты, так же можно нажать кнопку Обзор и указать карту на диске.

  2. В строке файл архива укажите имя для архива и путь до него, воспользуйтесь кнопкой Обзор.

  3. Нажмите кнопку ОК.


Общие настройки карты

С помощью данной вкладки карты задаются общие параметры карты:

  • Название карты – пользовательское наименование карты.

  • Путь – путь до файла карты.

  • Раздел Стиль:

    • Цвет фона карты. Поле для выбора цвета подложки карты. По умолчанию задается белый цвет.

    • Флажок Единый стиль для всех растров управляет стилем отображения монохромных растров на карте. Если флажок снят, то цвета выводимых монохромных растров определяются настройками слоев растров, либо настройками самих растров (см. «Настройка отображения растра в параметрах слоя»).

      Если же флажок установлен, то цвета всех монохромных растров в карте определяются цветами выбранными в полях цвет линий и цвет фона.

    • Установка флажка Сглаживание линий (антиалиасинг) включает режим сглаживания линий на картах. Параметры сглаживания для карт по умолчанию задаются в диалоге общей настройки (меню Сервис|Параметры, вкладка Карта).

  • Раздел Опции:

    • В поле Автообновление задается период времени (в секундах) между обновлением данных в карте. Если для поля установлено значение «0», обновление не производится. Если же значение указано, то через заданный промежуток времени перечитываются данные входящие в карту (файлы слоев, растровых изображений, баз данных). Это может быть полезно для отображения на карте динамически изменяющихся данных.

  • Раздел Отображение данных с сервера:

    • В поле со списком Отображение данных с сервера, выбирается способ загрузки картографических изображений с сервера (при работе с картами через ZuluServer) – в векторном формате, или в виде растровых изображений. Выбор правильного формата позволяет значительно ускорить отображение карт с сервера. Векторный формат оптимален при небольшом количестве картографических объектов, отображаемых на экране, при увеличении их количества, более быстрым является использование растрового формата. Оптимальный формат для карты подбирается экспериментально. При этом следует учитывать, что выгода использования векторного/растрового формата меняется в зависимости от масштаба карты и выводимого ее участка. Например, в векторном виде быстрее загружаются участки с лесами и водоемами, а в растровом – карты густонаселенной местности с большим количеством домов.

      При выборе растрового формата передачи данных можно дополнительно указать масштаб, начиная с которого он будет использоваться (см. ниже). При масштабе меньше указанного, используется векторный формат передачи данных.

      В поле доступны следующие варианты выбора:

      • векторный – загрузка данных в векторном формате;

      • растр в формате PNG – загружать в растровом формате PNG, наилучшее качество (по сравнению с GIF), но меньшая скорость загрузки;

      • растр в формате GIF – загружать в растровом формате GIF, качество хуже чем PNG (могут теряться цвета), но большая скорость загрузки.

    • Флажок Растр при масштабе большем чем 1:. Доступен только при выборе растрового формата данных для передачи с сервера. При установке флажка, данные с сервера передаются в растровом формате только при масштабе карты большем, чем указано в поле справа от флажка, при меньшем масштабе данные передаются в векторном формате.


Копирование карты

В результате данной операции произойдет копирование самой карты и загруженных в нее векторных слоев. При этом будут сохранены все настройки исходных данных.

[Примечание] Примечание

Карта для копирования должна быть загружена в Zulu.

Для копирования карты надо:

  1. В открывшемся диалоге нажать кнопку Обзор... и указать диск и каталог для копируемых данных. При работе с серверной версией слева надо выбрать Серверы геоданных, указать нужное соединение и затем каталог в области данных сервера. В строке Имя файла ввести имя для копии файла карты и нажать кнопку Сохранить. Если выбрано имя файла уже существующей карты, то в результате копирования карты существующая будет УНИЧТОЖЕНА, а новая будет создана на его месте.

  2. В строке Название карты автоматически подставляется пользовательское название исходной карты, по желанию его можно изменить.

  3. При установки опции Только геометрия – копируется только графическая информация без баз данных.

  4. При установки опции Наследовать ключи – при копировании будут сохранены все ID объектов.

  5. При копировании с базой данных из списка Источник для таблиц выбрать источник данных для таблиц, если нужного источника в списке нет, то добавить новый.

  6. Для подтверждения копирования нажать кнопку ОК. Кнопка Отмена закроет диалог Копирование карты без сохранения изменений.


Извлечение упакованной карты

В результате операции в указанный каталог будет извлечена ранее упакованная карта со всей информацией, содержащейся в архиве. При извлечении можно указать источник данных для хранения табличной информации, отличный от исходного.

Для распаковки карты:

  1. В карта для записи указывается папка для распаковки и имя файла. Для их выбора нажмите кнопку Обзор. Распаковать архив можно как на локальную машину так и на сервер геоданных. Во втором случает требуется слева нажать кнопку [image] Сервер геоданных, выбрать сервер и указать на нем папку. Затем нажмите кнопку Сохранить.

  2. Если для слоев распаковываемой карты нужен новый, отличный от исходного источник данных для хранения табличной информации, то выберите его из списка Источник для таблиц.

  3. При необходимости установите опцию Открыть по завершении, тогда после распаковки карта со всеми данными будет загружена в ZuluGIS.

  4. Нажмите кнопку ОК.


Геокодирование (поиск объектов на карте)

Геокодирование – процесс преобразования адресов в географические координаты, которые используются для позиционирования карты. С помощью данного инструмента имеется возможность легко найти объект на карте с помощью его адреса.

Для наглядного поиска объектов удобней всего использовать слои openstreetmap, которые можно загрузить через меню Слой|OpenStreetMap|OpenStreetMap.

[Примечание] Примечание

Использование слоев OpenStreetMap возможно при условии соблюдения соответствующих авторские прав (http://www.openstreetmap.org/copyright).

Для поиска надо:

  1. Указать сервер к которому система будет обращаться при запросе. Для этого нажать кнопку [image] и выбрать сервер из списка.

  2. В окно запросов ввести данные для поиска.

  3. Нажать кнопку [image] . Если объект будет найден, то произойдет автоматическое перемещение этого объекта в центр карты без изменения масштаба. В том случае, если будет найдено несколько объектов, то они будут списком выведены под строкой задания параметров. Для перехода к объекту достаточно установить курсор на его названии в списке.

[Примечание] Примечание

В зависимости от выбранного сервера для поиска результаты одного и того же запроса могут отличаться.


Настройка сетки

С помощью данной вкладки можно настроить сетку карты и сетку редактора:

  • Сетка карты – сетка, разбивающая карту на планшеты заданного размера. Не рекомендуется включать при использовании картографических проекций по широте/долготе.

  • Сетка редактора – набор точек заданного цвета, нанесенных на карту с определенным шагом по осям координат, облегчающий ввод и редактирование графических объектов слоя. Один из узлов сетки должен совпадать с задаваемой опорной точкой. Разметка окна сеткой позволяет лучше ориентироваться при редактировании объектов, а также привязывать вводимые координаты объектов к узлам сетки.

Настройки сетки карты задаются в полях группы настроек Сетка карты:

  • В полях шаг сетки по X, м и по Y, м задается расстояние между линиями сетки на карте (в метрах).

  • В поле Планшет можно также выбрать одну из популярных планшетных сеток.

  • В полях Опорная точка X, м и Y,м задаются координаты опорной точки сетки (в метрах).

  • В полях Стиль и цвет задаются стиль и цвет линий сетки.

  • Для отображения сетки редактора на карте, должен быть установлен флажок Отображать сетку карты.

Настройки сетки редактора задаются полями группы настроек Сетка редактора:

  • В полях шаг сетки по X, м и по Y, м задается расстояние между метками сетки на карте (в метрах).

  • В поле цвет задается цвет меток сетки.

  • Для отображения сетки редактора на карте, должен быть установлен флажок Отображать сетку редактора. Отображение сетки также может переключаться кнопкой [image] на панели инструментов.

  • При установленном флажке Привязка к сетке, графические элементы карты «прилипают» к метками сетки. Привязка к сетке также включается/выключается кнопкой [image] на панели инструментов. Эта кнопка доступна только, когда включено отображение сетки.


Извлечение слоя или карты

В указанном архиве содержится карта с упакованными слоями.

Чтобы извлечь данные:

  1. Для извлечения одного конкретного слоя выберите его в списке. Для извлечения всей карты со слоями выберите опцию Извлечь карту целиком.

  2. Нажмите кнопку Далее.

  3. В диалоговом окне Сохранить файл задайте папку для распаковки и имя файла, после чего нажмите кнопку Сохранить.


Слои карты

В данной вкладке настраиваются слои загруженные в карту:

  • Кнопки Назад и Вперед изменяют порядок следования выделенных в списке слоев:

    • Назад перемещает выбранный слой на одну позицию к началу списка;

    • Вперед перемещает выбранный слой на одну позицию к концу списка.

  • Кнопки Добавить и Исключить позволяют добавить/исключить слои карты:

    • Добавить вызывает диалог выбора слоя для добавления в карту;

    • Исключить исключает выбранные слои из списка слоев карты.

  • Кнопка Настройка вызывает диалог настройки выбранного слоя.

  • Кнопка Структура открывает структуру выбранного слоя.

При установке флажка Показывать имена файлов, рядом с названиями слоев в списке выводятся названия их файлов на диске.


Импорт макетов

Для того чтобы импортировать макеты в карту надо:

  1. Выбрать в списке Макеты нужные файлы.

  2. Нажать кнопку Импорт.

Кнопка Отмена закроет диалоговое окно Импорт без сохранения изменений.


Имя макета

Диалоговое окно предназначено для задания имени создаваемого макета. Для того чтобы задать новое имя макету в строке Имя макета сотрите имя по умолчанию (Макет 1, 2...) и введите новое. После завершения нажмите кнопку ОК, кнопка Отмена закроет окно без сохранения изменений.


Управление макетами карты

Диалог Макеты предназначен для управления макетами карты.

Описание кнопок диалога:

  • Открыть - позволяет открыть макет, выделенный в списке для редактирования и печати (подробней см. «Открытие макета для редактирования и печати» или «Печать макета»).

  • Создать - позволяет создать новый макет (подробней см. «Создание нового макета»).

  • Переименовать - позволяет переименовать выделенный в списке макет.

  • Импорт/Экспорт - позволяет импортировать макеты в карту из других карт и файлов и экспортировать макеты из карты в отдельный файл (подробней см. «Импорт и экспорт макета печати»).

  • Копировать - позволяет дублировать макет, при этом, в карте создается точная копия исходного макета с другим названием.

  • Удалить - удаляет макет из карты.

  • Закрыть - закрывает диалоговое окно Макеты.


Панель настройки печати

Масштаб карты. В этом разделе укажите какой масштаб карты следует использовать:

  • установить - масштаб карты устанавливается точно. В окошке справа надо указать этот масштаб;

  • вписать в страницу - масштаб выбирается так, чтобы фрагмент попал целиком на страницу или на диапазон страниц, если он указан (см. расположить на ...);

  • в соответствии с масштабом на экране - масштаб выбирается так, чтобы геометрические размеры изображения на бумаге соответствовали размерам изображения на экране;

  • флажок расположить на ... устанавливается в том случае, когда надо задать точно диапазон страниц для печати, количество страниц устанавливается в соответствующих окошках.

  • в разделе Положение надо указать, как следует выравнивать печатаемую зону на странице бумаги или заданном диапазоне страниц. Выбор нужного варианта из возможных девяти осуществляется нажатием на соответствующую квадратную кнопку.

В разделе Печатаемый фрагмент местности задаются границы печатаемой карты.

  • текущий вид - печататься будет область карты, попадающая на всю страницу или заданный диапазон страниц, с указанным масштабом и центром изображения, совпадающим с координатами в центре активного окна карты;

  • вся карта - фрагмент местности будет вычисляться по границам всей карты;

  • фрагмент - будет напечатан отмеченный заранее фрагмент карты;

  • по размерам слоя - фрагмент местности будет вычисляться по границам одного слоя. В открывающемся списке необходимо выбрать этот слой;

  • указать - позволяет точно задать границы фрагмента местности. В окошках справа от этого переключателя задаются координаты левого нижнего и правого верхнего углов прямоугольной зоны, которую следует распечатать.

В разделе Опции указываются дополнительные опции печати:

  • не отсекать печатаемую зону - если флажок установлен, то вместо пустых зон на листе бумаги будет выводиться изображение карты вне заданного фрагмента местности, результат этой опции проиллюстрирован на рисунке ниже (печатаемая зона обозначена светло-серым фоном, а границы заданного фрагмента - темно-серой рамкой).

    Результат опции Не отсекать печатаемую зону

    Рисунок 1. Результат опции Не отсекать печатаемую зону

  • печатать фон карты - по умолчанию фон окна карты не выводится при печати. Чтобы карта выводилась на цветном фоне, установите этот флажок;

  • листы в склейку - эта опция полезна при печати на нескольких листах для последующей склейки в один лист. При установленном флажке заданные для документа поля не будут использоваться на граничащих друг с другом листах;

  • печатать рамку - при установке данной опции печатаемый фрагмент будет обрамлен рамкой;

  • только выделенные объекты - если данная опция установлена, то на печать будут выведены только выделенные на карте объекты;

  • порядок печати страниц - выберите один из двух вариантов следования страниц при многостраничной печати.

    1. сначала первый ряд слева направо, потом следующий ряд и т.д.;

    2. сначала первый ряд сверху в низ, потом следующий ряд и т.д.

Для проверки настройки печати надо нажать кнопку Просмотр. В окне предварительного просмотра.

  • c помощью окошка [image] меняется масштаб просмотра страницы;

  • с помощью инструментов [image] и [image] изменяется число отображаемых страниц;

  • с помощью инструментов [image] и [image] можно листать страницы вперед и назад.

Для выхода из режима просмотра надо нажать кнопку Закрыть.


Проекция карты

С помощью данной вкладки задается проекция карты. Проекцию можно выбрать из списка готовых проекций (предложены наиболее часто используемые проекции), задать параметры проекции вручную, либо загрузить проекцию из слоя карты или из файла слоя на диске:

  • Выбор готовой проекции.

    Для выбора готовой проекции, выберите тип проекции в поле типов проекций, после чего выберите требуемую проекцию в списке проекций. В области параметров проекции отобразится список параметров выбранной проекции, но без возможности их редактирования.

  • Задание проекции вручную.

    Для задания параметров проекции вручную, выберите в поле выбора типа проекции значение «<Задать>». Задайте настройки проекции в полях области параметров проекции.

  • Импорт параметров проекции из другого слоя данной карты.

    Для импорта проекции из другого слоя карты выберите в поле типов проекции значение «<Выбрать по слою карты>» и выберите в области списка проекций слой, проекцию которого требуется использовать для карты.

  • Импорт параметров проекции из файла слоя.

    Для импорта параметров проекции из файла слоя, сохраненного на диске, нажмите кнопку Импорт, справа от поля выбора типа проекции и выберите файл слоя с требуемой проекцией в стандартном диалоге выбора файлов.

В области параметров отображения задаются настройки управляющие выводом данных проекции на экран. Настройки разделены на несколько групп:

  • Градусная сетка. Управляет отображением градусной сетки на экране:

    • Градусная сетка выводится только в том случае, если установлен флажок Отображать;

    • Цвет линий сетки задается в поле Цвет;

    • Шаг линий сетки по широте и долготе (в градусах) задается в полях Шаг по широте, град. и Шаг по долготе, град.

  • Заливка. Управляет отображением фоновой заливки:

    • Заливка отображается при установленном флажке Отображать;

    • Цвет заливки задается в поле Цвет.

  • Переключатель Система измерений задает используемую систему координат: декартову, или сферическую.

  • В группе полей Единицы измерения задаются используемые единицы измерения для координат, расстояний и площадей.

После завершения настройки проекции карты нажмите кнопку ОК диалога, чтобы сохранить изменения и закрыть диалог.

[Примечание] Примечание

Карты, выполненные в локальной системе координат можно привязать к географической системе координат только в том случае, если для данной карты известны параметры перехода из локальной системы координат в географическую.

Если параметры известны, задайте параметры проекции и системы координат карты, в соответствии с имеющимися параметрами перехода.


Настройка карты

Диалог позволяет выполнить следующие действия:

  • установить пользовательское название карты, просмотреть/скопировать расположение файла карты, изменить цвет фона карты, для лучшего отображения данных установить опцию сглаживания линий, задать одинаковый стиль для всех растров, установить интервал обновления карты и задать способ загрузки данных с сервера (вкладка Карта);

  • настроить слои, загруженные в карту (переместить, добавить, исключить, настроить, просмотреть и изменить структуру), на вкладке Слои;

  • установить планшетную сетку, снять или установить отображение сетки редактора, задать параметры сеток, и привязку к сетке редактора (вкладка Сетка);

  • настроить картографическую проекцию карты (вкладка Проекция);

  • настроить параметры отображения объектов в режиме псевдо-3D (вкладка Псевдо 3D).

[Примечание] Примечание

Для сохранения всех изменений, произведенных в диалоговом окне настройки карты необходимо нажать кнопку [image] на панели инструментов или в главном меню Файл выбрать команду Сохранить.

Вкладка Карта

Вкладка «Карта» диалога настройки карты

Рисунок 1. Вкладка «Карта» диалога настройки карты

Общие параметры карты задаются следующими полями и группами полей вкладки Карта диалога:

  • Название карты – пользовательское наименование карты.

  • Цвет фона карты. Поле для выбора цвета подложки карты. По умолчанию задается белый цвет.

  • Флажок Единый стиль для всех растров управляет стилем отображения монохромных растров на карте. Если флажок снят, то цвета выводимых монохромных растров определяются настройками слоев растров, либо настройками самих растров (см. «Настройка отображения растра в параметрах слоя»).

    Если же флажок установлен, то цвета всех монохромных растров в карте определяются цветами выбранными в полях цвет линий и цвет фона.

  • Установка флажка Сглаживание линий (антиалиасинг) включает режим сглаживания линий на картах.

  • В поле Автообновление задается период времени (в секундах) между обновлением данных в карте. Если для поля установлено значение «0», обновление не производится. Если же значение указано, то через заданный промежуток времени перечитываются данные входящие в карту (файлы слоев, растровых изображений, баз данных). Это может быть полезно для отображения на карте динамически изменяющихся данных.

  • В поле со списком Отображение данных с сервера, выбирается способ загрузки картографических изображений с сервера (при работе с картами через ZuluServer) – в векторном формате, или в виде растровых изображений. Выбор правильного формата позволяет значительно ускорить отображение карт с сервера. Векторный формат оптимален при небольшом количестве картографических объектов, отображаемых на экране, при увеличении их количества, более быстрым является использование растрового формата. Оптимальный формат для карты подбирается экспериментально. При этом следует учитывать, что выгода использования векторного/растрового формата меняется в зависимости от масштаба карты и выводимого ее участка. Например, в векторном виде быстрее загружаются участки с лесами и водоемами, а в растровом – карты густонаселенной местности с большим количеством домов.

    При выборе растрового формата передачи данных можно дополнительно указать масштаб, начиная с которого он будет использоваться (см. ниже). При масштабе меньше указанного, используется векторный формат передачи данных.

    В поле доступны следующие варианты выбора.

    • векторный – загрузка данных в векторном формате;

    • растр в формате PNG – загружать в растровом формате PNG, наилучшее качество (по сравнению с GIF), но меньшая скорость загрузки;

    • растр в формате GIF – загружать в растровом формате GIF, качество хуже чем PNG (могут теряться цвета), но большая скорость загрузки.

  • Флажок Растр при масштабе большем чем 1:. Доступен только при выборе растрового формата данных для передачи с сервера. При установке флажка, данные с сервера передаются в растровом формате только при масштабе карты большем, чем указано в поле справа от флажка, при меньшем масштабе данные передаются в векторном формате.

Вкладка Слои

Во вкладке Слои настраиваются слои загруженные в карту, в ней частично повторяются операции из диалога Список слоев. Более подробно см. «Диалог Загруженные слои».

Вкладка «Слои» диалога настройки карты

Рисунок 2. Вкладка «Слои» диалога настройки карты

Описание кнопок вкладки Слои:

  • Кнопки Назад и Вперед изменяют порядок следования слоев:

    • Назад перемещает выбранный слой на одну позицию к началу списка;

    • Вперед перемещает выбранный слой на одну позицию к концу списка.

  • Кнопки Добавить и Исключить позволяют добавить/исключить слои карты:

    • Добавить вызывает диалог выбора слоя для добавления в карту;

    • Исключить исключает выбранные слои из списка слоев карты.

  • Кнопка Настройка вызывает диалог настройки выбранного слоя.

  • Кнопка Структура открывает структуру выбранного слоя.

При установке флажка Показывать имена файлов, рядом с названиями слоев в списке выводятся названия их файлов на диске.

Вкладка Сетка

Вкладка «Сетка редактора» диалога настройки карты

Рисунок 3. Вкладка «Сетка редактора» диалога настройки карты

На карте могут отображаться две координатные сетки:

  • Сетка карты – сетка, разбивающая карту на планшеты заданного размера . Не рекомендуется включать при использовании картографических проекций по широте/долготе.

  • Сетка редактора – набор точек заданного цвета, нанесенных на карту с определенным шагом по осям координат, облегчающий ввод и редактирование графических объектов слоя. Один из узлов сетки должен совпадать с задаваемой опорной точкой. Разметка окна сеткой позволяет лучше ориентироваться при редактировании объектов, а также привязывать вводимые координаты объектов к узлам сетки.

Настройки сетки карты задаются в полях группы настроек Сетка карты:

  • В полях шаг сетки по X, м и по Y, м задается расстояние между линиями сетки на карте (в метрах).

  • В поле Планшет можно также выбрать одну из популярных планшетных сеток.

  • В полях Опорная точка X, м и Y,м задаются координаты опорной точки сетки (в метрах).

  • В полях Стиль и цвет задаются стиль и цвет линий сетки.

  • Для отображения сетки редактора на карте, должен быть установлен флажок Отображать сетку карты.

Настройки сетки редактора задаются полями группы настроек Сетка редактора:

  • В полях шаг сетки по X, м и по Y, м задается расстояние между метками сетки на карте (в метрах).

  • В поле цвет задается цвет меток сетки.

  • Для отображения сетки редактора на карте, должен быть установлен флажок Отображать сетку редактора. Отображение сетки также может переключаться кнопкой [image] на панели инструментов.

  • При установленном флажке Привязка к сетке, графические элементы карты «прилипают» к метками сетки. Привязка к сетке также включается/выключается кнопкой [image] на панели инструментов. Эта кнопка доступна только, когда включено отображение сетки.

Вкладка Проекция карты

Вкладка «Проекция карты» диалога параметров карты

Рисунок 4. Вкладка «Проекция карты» диалога параметров карты

Проекцию можно выбрать из списка готовых проекций (предложены наиболее часто используемые проекции), задать параметры проекции вручную, либо загрузить проекцию из слоя карты или из файла слоя на диске:

  • Выбор готовой проекции.

    Для выбора готовой проекции, выберите тип проекции в поле типов проекций, после чего выберите требуемую проекцию в списке проекций. В области параметров проекции отобразится список параметров выбранной проекции, но без возможности их редактирования.

  • Задание проекции вручную.

    Для задания параметров проекции вручную, выберите в поле выбора типа проекции значение «<Задать>». Задайте настройки проекции в полях области параметров проекции.

  • Импорт параметров проекции из другого слоя данной карты.

    Для импорта проекции из другого слоя карты выберите в поле типов проекции значение «<Выбрать по слою карты>» и выберите в области списка проекций слой, проекцию которого требуется использовать для карты.

  • Импорт параметров проекции из файла слоя.

    Для импорта параметров проекции из файла слоя, сохраненного на диске, нажмите кнопку Импорт, справа от поля выбора типа проекции и выберите файл слоя с требуемой проекцией в стандартном диалоге выбора файлов.

В области параметров отображения задаются настройки управляющие выводом данных проекции на экран. Настройки разделены на несколько групп:

  • Градусная сетка. Управляет отображением градусной сетки на экране:

    • Градусная сетка выводится только в том случае, если установлен флажок Отображать;

    • Цвет линий сетки задается в поле Цвет;

    • Шаг линий сетки по широте и долготе (в градусах) задается в полях Шаг по широте, град. и Шаг по долготе, град.

  • Заливка. Управляет отображением фоновой заливки:

    • Заливка отображается при установленном флажке Отображать;

    • Цвет заливки задается в поле Цвет.

  • Переключатель Система измерений задает используемую систему координат: декартову, или сферическую.

  • В группе полей Единицы измерения задаются используемые единицы измерения для координат, расстояний и площадей.

После завершения настройки проекции карты нажмите кнопку ОК диалога, чтобы сохранить изменения и закрыть диалог.

[Примечание] Примечание

Карты, выполненные в локальной системе координат можно привязать к географической системе координат только в том случае, если для данной карты известны параметры перехода из локальной системы координат в географическую.

Если параметры известны, задайте параметры проекции и системы координат карты, в соответствии с имеющимися параметрами перехода.

Вкладка Псевдо 3D

Вкладка «Псевдо 3D» диалога параметров карты

Рисунок 5. Вкладка «Псевдо 3D» диалога параметров карты

В полях данной вкладки задаются параметры отображения объектов при использовании режима псевдо-3D ( подробнее см. «Режим псевдо-3D»):

  • В полях Отклонение от нормали к экрану по вертикали/по горизонтали, град. группы настроек Наклон задается степень отклонения угла зрения на строимые изображения объектов, в градусах, по вертикали и горизонтали, соответственно (от 0 до 45 градусов). При значениях равных нулю отображается вид «строго сверху» совпадающий с изображением при отключенном режиме «псевдо-3D».

  • В полях группы настроек Раскраска боковых граней задается цвет раскраски боковых граней псевдо-3D объектов. Цвет раскраски боковых граней формируется на базе цвета заливки исходного объекта (являющегося «крышей» получающегося изображения). В полях Контраст в процентах от контраста крыши и Яркость в процентах от яркости крыши задается понижение контраста (в процентах) и понижение яркости (в процентах) исходного цвета для получения цвета боковых граней.

  • В полях группы настроек Раскраска ребер – Контраст в процентах от контраста крыши и Яркость в процентах от яркости крыши задается цвет раскраски боковых ребер псевдо-3D объектов. Цвет раскраски боковых ребер формируется из цвета заливки исходного объекта, по принципу описанному в предыдущем пункте.


Настройка режима псевдо-3D

В данной вкладке задаются параметры отображения объектов при использовании режима псевдо-3D ( подробнее см. «Режим псевдо-3D»):

  • В полях Отклонение от нормали к экрану по вертикали/по горизонтали, град. группы настроек Наклон задается степень отклонения угла зрения на строимые изображения объектов, в градусах, по вертикали и горизонтали, соответственно (от 0 до 45 градусов). При значениях равных нулю отображается вид «строго сверху» совпадающий с изображением при отключенном режиме «псевдо-3D».

  • В полях группы настроек Раскраска боковых граней задается цвет раскраски боковых граней псевдо-3D объектов. Цвет раскраски боковых граней формируется на базе цвета заливки исходного объекта (являющегося «крышей» получающегося изображения). В полях Контраст в процентах от контраста крыши и Яркость в процентах от яркости крыши задается понижение контраста (в процентах) и понижение яркости (в процентах) исходного цвета для получения цвета боковых граней.

  • В полях группы настроек Раскраска ребер – Контраст в процентах от контраста крыши и Яркость в процентах от яркости крыши задается цвет раскраски боковых ребер псевдо-3D объектов. Цвет раскраски боковых ребер формируется из цвета заливки исходного объекта, по принципу описанному в предыдущем пункте.


Перепроецирование слоев

При процедуре перепроецирования слоя происходит физический пересчет хранимых в слое координат объектов из текущей проекции слоя в новую проекцию с назначением новой проекции в качестве текущей. Эта процедура отличается от простого назначения слою новой проекции, когда пересчета координат не происходит.

Для перепроецирования слоя надо:

  1. В диалоге Перепроецирование слоев карты нажать кнопку Система координат, в открывшемся окне указать новую систему координат и нажать кнопку ОК.

  2. Указать с помощью галочек слои для перепроецирования, выделить сразу все слои можно поставив галочку на против опции Все.

  3. Нажать кнопку ОК.


Трансформирование слоев карты

Данный диалог позволяет произвести трансформирование одновременно сразу нескольких слоев карты с помощью параметров сдвига, поворота, масштаба или с помощью коэффициентов трансформации.

Для трансформирования слоя надо:

  1. В разделе Слои отметить слои для трансформации. Опция Все позволяет выделить все слои одновременно.

  2. Из списка Параметры преобразования выбрать по каким параметрам будет производиться трансформация: Сдвиг, поворот, масштаб или Коэффициенты.

  3. При выборе трансформирования с помощью Сдвига, поворота, масштаба:

    • в разделе Смещение следует задать значения смещений слоя по X и Y в сантиметрах;

    • в разделе Масштаб следует задать значения коэффициентов искажения масштаба слоя по X и Y. Если установлен флажок Пропорционально, то коэффициенты масштабирования по осям X и Y будут одинаковыми;

    • В разделе Центр (см) следует задать координаты точки поворота слоя в сантиметрах и угол поворота в градусах.

  4. При выборе трансформации с помощью коэффициентов:

    • в разделе Коэффициенты надо задать коэффициенты для трансформации, смещения задаются в сантиметрах, ось X направлена вверх, Y вправо;

    • при нажатии кнопки Инвертировать коэффициенты будут обратно преобразованы.

  5. Если предварительно в трансформируемых слоях были выделены объекты, то при установке опции Трансформировать только выделенные объекты преобразование будет применяться только для них.

  6. После ввода требуемых параметров преобразования следует нажать кнопку OK, после чего запустится процесс трансформации слоя.

[Примечание] Примечание

Трансформацию слоев также можно произвести с экрана (см. «Трансформирование слоя с экрана»).


Вкладка Базы данных

Вкладка содержит библиотеку баз данных слоя.

В правой верхней части вкладки располагается панель инструментов с кнопками для выполнения основных действий над базами данных.

С базами данных доступны следующие основные действия:

  • Создание новой базы данных. Для создания новой базы данных нажмите кнопку [image] Создать... в панели инструментов и задайте название для создаваемой базы. Подробнее о создании базы данных см. в разделе «Создание описателя базы данных».

  • Добавление уже готовой базы данных. Для добавления уже готовой базы данных ZuluGIS нажмите кнопку [image] Добавить..., затем укажите путь и файл добавляемой базы данных.

  • Редактирование базы данных. Для вызова конструктора баз данных сначала выделите базу данных в списке, а затем нажмите кнопку [image] Конструктор... панели инструментов. Подробней о работе с базой данных см. в разделе «Создание описателя базы данных».

  • Удаление базы данных. Для удаления выделенной в списке базы данных нажмите кнопку [image] Удалить, затем в появившемся окне подтвердите удаление базы нажатием кнопки Да.


Вкладка Слой

Данная вкладка отображает параметры слоя:

  • В поле Название приводится пользовательское название слоя. Для его изменения удалите текущее название и введите новое, затем нажмите кнопку Сохранить.

  • В поле Семейство файлов отображается название семейства файлов слоя – названия файлов, в которых хранится структура слоя начинаются с указанной в данном поле последовательности символов.

  • В поле Размещение указывается путь к каталогу, в котором располагаются файлы слоя.

  • Кнопка Изменить в строке Система координат открывает диалог параметров картографической проекции хранения данных слоя (подробней см. «Задание проекции слоя»).


Редактор структуры слоя

В структуре могут быть настроены различные стили для линейных, площадных объектов, созданы графические символы, которые возможно использовать для ввода на карту нетипизированных символьных объектов (примитивов) и типовых объектов. Также символы могут использоваться в стилях линейных объектов и стилях заливки площадных объектов. В том случае, если к объектам слоя подключаются базы данных, то именно в структуре будет указано какие объекты будут использовать какую базу.

В структуре так же указываются типовые графические объекты. Каждый типовой объект может иметь несколько режимов (обычно связываемых с режимами работы объекта в инженерной сети). С каждым режимом типового объекта связан отдельный символ библиотеки символов, эти символы используются для отображения режима типового объекта на карте. Типовые объекты слоя образуют структуру сети. Под структурой сети подразумеваются объекты (узлы) и связи (участки) сети, их условные обозначения, режимы функционирования каждого объекта и структура таблиц (семантических данных), связанных с этими объектами. В основе математической модели сети лежит граф, состоящий из узлов, соединенных дугами. В любой сети можно выделить свой набор узловых элементов и дуг. Так в теплоснабжении узлы – это источники, тепловые камеры, потребители, насосные станции, запорная арматура и прочие, а дуги – трубопроводы. Типовые графические объекты связываются только с семантической базой своего типа.

Диалоговое окно разделено на две части, в зависимости от того, какой пункт выделен с левой стороны, справа будут происходить соответствующие изменения, то есть будет отображаться информация, относящаяся к выбранному пункту.

В дереве структуры содержатся все элементы структуры слоя. Далее представлено краткое описание элементов дерева структуры слоя:

  • Слой. Параметры слоя. Предусмотрено изменение пользовательского названия слоя и просмотр название файлов слоя и путь к ним, изменение системы координат слоя.

  • Символы. Библиотека графических символов слоя. Предусмотрено:

    • создание новых символов;

    • редактирование существующих символов;

    • копирование символов;

    • удаление символов из библиотеки;

    • смена ID символов;

    • «Редактор символов»;

    • «Изменение размеров символов».

  • Линии. Библиотека стилей линейных объектов слоя. Предусмотрено:

    • создание нового стиля линии;

    • изменение стиля линии;

    • копирование стиля линии;

    • удаление стиля линии;

    • редактор стиля линий;

    • импорт стилей из других слоев.

  • Заливки. Библиотека стилей заливок площадных объектов слоя. Предусмотрено:

    • создание нового стиля заливок;

    • изменение стиля заливок;

    • копирование стиля заливок;

    • удаление стиля заливок;

    • редактирование стиля заливок;

    • импорт стиля из других слоев.

  • Базы данных. Список баз данных слоя. Предусмотрено:

    • создание и импорт баз данных, их правка и удаление.

  • Правила - содержит список правил слоя:

    • правила Редактора;

    • правила быстрого поиска;

    • правила для веб-служб ZuluServer;

    • баннеры.

    Примитивы. Выбор базы данных подключенной к нетипизированным объектам слоя (примитивам).

  • Типы и режимы. Типовые объекты слоя и их режимы. Предусмотрено:

    • работа с типами: создание, удаление, редактирование;

    • работа с режимами: создание, удаление, редактирование;

    • настройка порядка отображения объектов в слое;

    • импорт типов и режимов из других слоев;

    • печать типов и режимов.

Для сохранения изменений внесенный в структуру слоя требуется нажать кнопку [image] Сохранить. Если при закрытии диалога в структуре слоя будут не сохраненные изменения, то будет предложено сохранить их.


Редактор стиля заливки

Диалог «Стиль заливки»

Рисунок 1. Диалог «Стиль заливки»

Диалог редактора состоит из следующих основных частей:

  • Область общих настроек стиля. В этой области собраны следующие параметры стиля:

    • В поле Название, при необходимости, задается название стиля. Название для стиля необязательно. Если названия нет, для именования стиля используется его номер;

    • В поле Единицы задаются единицы измерения для геометрических параметров стиля заливки (пикселы или миллиметры). Все линейные размеры, шаги, сдвиги, толщины могут принимать не только целые, но и дробные значения. На экране дробные размеры округляются до экранных пикселей, но при печати все размеры воспроизводятся точно;

    • В поле Масштаб задается масштабный коэффициент, на который умножаются все линейные размеры заливки при отображении. Это позволяет одновременно масштабировать все элементы заливки.

  • Список элементов стиля. В списке отображаются все элементы, используемые в данном стиле линии (см. ниже Список элементов стиля);

  • Область настроек выбранного элемента стиля. Набор полей настроек в списке зависит от типа выбранного элемента в списке – растровой или векторной заливки, штриховки;

  • Область просмотра стиля. Предварительный просмотр заливки с редактируемым стилем.

Список элементов стиля

Элементы выводятся в списке в том же порядке, в каком они отображаются: сначала рисуется верхний элемент, затем, поверх него второй сверху, и т.д.

Слева от каждого элемента списка располагается флажок, элемент отображается в стиле, только когда этот флажок установлен.

Для выбора элемента списка достаточно щелкнуть по нему левой кнопкой мыши.

Под списком располагаются кнопки управления:

  • – сдвиг выбранного элемента вверх по списку;

  • – сдвиг выбранного элемента вниз;

  • – добавление нового растрового элемента заливки (см ниже, Задание растровой заливки);

  • – добавление новой штриховки (см. ниже, Задание векторной штриховки);

  • – Добавление нового векторного элемента заливки (см. ниже, Задание векторной заливки);

  • – Удаление выбранного элемента из списка.

Задание растровой заливки

Для создания нового растрового элемента заливки нажмите кнопку [image] .

На экране появится окно редактора растровых изображений. Для открытия редактора для уже существующего растрового элемента достаточно дважды щелкнуть по нему в списке элементов.

Диалог редактирования изображения

Рисунок 2. Диалог редактирования изображения

Создание, загрузка и редактирование растровых изображений подробно описаны в разделе см. .

По завершении создания растрового изображения в список элементов стиля добавляется растровый элемент. В правой части диалога Стиль заливки отображаются поля для задания параметров отображения данного растрового элемента. Для настройки параметров уже созданного растрового элемента достаточно его выбрать в списке.

Поля редактирования параметров растрового элемента заливки в диалоге стиля заливки.

Рисунок 3. Поля редактирования параметров растрового элемента заливки в диалоге стиля заливки.

Параметры растрового элемента задаются следующими полями:

  • Растр. Информационное поле в котором приводятся ширина и высота растра в выбранных единицах размера;

  • Масштаб. Коэффициент на который умножаются линейные размеры выбранного элемента при отображении;

  • Шаг по горизонтали/Шаг по вертикали. Шаг, с которым выводится в заливке растровый рисунок, по вертикали и горизонтали. Если шаг совпадает с размером рисунка по соответствующей оси, то соседние рисунки будет отображаться без зазоров между ними. Если шаг меньше размера рисунка, то соседние рисунки будут накладываться друг на друга;

  • Сдвиг по горизонтали/Сдвиг по вертикали. Смещение начальных координат рисунков по соответствующей оси. Может быть полезен при использовании комбинированной заливки – смещение позволяет задать относительное стартовое положение для элементов заливки;

  • Цвета пользователя. Флажок доступен только для монохромных растров состоящих из черного и белого цветов. Если флажок установлен, то при заливке полигона в качестве двух цветов используются цвет фона и цвет узора полигонального объекта.

Задание векторной заливки

Для создания нового элемента векторной заливки нажмите кнопку [image] .

На экране появится диалог выбора векторных изображений из библиотеки символов слоя.

Для выбора существующего изображения выберите в выпадающем списке нужный символ и нажмите кнопку Выбрать.

Для создания нового векторного изображения нажмите кнопку Новый. На экране появится редактор векторных изображений. Подробно создание векторного рисунка описано в разделе см. .

Для редактирования векторного элемента уже добавленного стиль заливки достаточно дважды щелкнуть левой кнопкой мыши по его строке в списке.

По завершении создания/выбора векторного изображения в список элементов стиля добавляется векторный элемент. В правой части диалога Стиль заливки отображаются поля для задания параметров отображения данного векторного элемента. Для настройки параметров уже существующего символьного элемента достаточно его выбрать в списке.

Поля редактирования параметров векторного элемента заливки в диалоге стиля заливки.

Рисунок 4. Поля редактирования параметров векторного элемента заливки в диалоге стиля заливки.

Параметры векторного элемента задаются в следующих полях:

  • Символ. Информационное поле в котором приводятся ширина и высота векторного символа в выбранных единицах размера;

  • Масштаб элемента. Коэффициент на который умножаются линейные размеры выбранного элемента при отображении;

  • Шаг по горизонтали/Шаг по вертикали. Шаг, с которым выводится в заливке векторный символ, по вертикали и горизонтали. Если шаг меньше размера символа, то соседние символы будут накладываться друг на друга;

  • Сдвиг по горизонтали/Сдвиг по вертикали. Смещение начальных координат символов по соответствующей оси. Может быть полезен при использовании комбинированной заливки – смещение позволяет задать относительное стартовое положение для элементов заливки;

  • Угол. Угол поворота символа против часовой стрелки.

Задание векторной штриховки

Для задания нового элемента векторной штриховки нажмите кнопку [image] . В список элементов добавится элемент векторной штриховки, а в правой части диалога отобразятся поля для задания параметров отображения данной векторной штриховки. Для настройки параметров уже существующей векторной штриховки достаточно ее выбрать в списке.

Параметры векторной штриховки в диалоге стиля заливки

Рисунок 5. Параметры векторной штриховки в диалоге стиля заливки

Параметры штриховки задаются в следующих полях:

  • Расстояние между линиями. В этой группе настроек задается расстояние между линиями штриховки.

    В поле Перпендикулярно линиям задается расстояние между линиями перпендикулярно направлению линий.

    В поле По вертикали – задается расстояние по вертикали между соответствующими точками соседних линий. При угле поворота линии между 46 и 135 градусами (либо между 226 и 315 градусами) данное поле заменяется на поле По горизонтали, в котором задается расстояние по горизонтали между соответствующими точками соседних линий. Поля Перпендикулярно линиям и По вертикали (По горизонтали) связаны между собой, при изменении значения в одном поле, значение другого поля пересчитывается автоматически;

  • Сдвиг линий. Группа настроек в которой задается смещение линий относительно других элементов заливки при создании комбинированных заливок.

    В поле Перпендикулярно линиям задается смещение перпендикулярно направлению линии.

    В поле По вертикали – задается смещение линий по вертикали. При угле поворота линии между 46 и 135 градусами (либо между 226 и 315 градусами) данное поле заменяется на поле По горизонтали, в котором задается смещение по горизонтали.

    Поля Перпендикулярно линиям и По вертикали (По горизонтали) связаны между собой, при изменении значения в одном поле, значение другого поля пересчитывается автоматически;

  • В поле Угол, град задается поворот линий штриховки, в градусах, против часовой стрелки;

  • Поле Толщина линии задает толщину линии в заданных единицах;

  • Флажок Цвет линии указывает какой цвет используется для вывода линий штриховки. Если флажок сброшен, то используются цветы заданные для линии в стиле линии, если установлен – цвет, выбранный в поле справа от флажка;

  • Стиль линии. Стиль линии используемый для вывода линий штриховки. Стиль выбирается из стилей линий слоя.


Вкладка Заливки

Вкладка отображает библиотеку стилей заливок слоя. При создании нового слоя он уже содержит библиотеку стандартных стилей заливок. Причем во всех библиотеках стилей заливок обязательно содержатся стили №1 - пустая заливка (полигон не заливается) и заливка №2 - сплошная заливка (полигон полностью заливается цветом узора). Прочие стили могут редактироваться, удаляться и создаваться пользователями.

Со стилями заливок в библиотеке стилей заливок доступны следующие действия:

  • Создание нового стиля. Для создания нового стиля заливки нажмите кнопку [image] Новый.... Откроется редактор стиля заливки.

  • Изменения стиля. Для изменения существующего стиля заливки выберите его в списке и нажмите кнопку [image] Изменить.... Откроется редактор стиля заливки в который загрузится информация о выбранном стиле.

  • Удаление стиля. Для удаления существующего стиля заливки выберите его в списке и нажмите кнопку [image] Удалить.

  • Копирование стиля в буфер обмена. Для копирования стиля заливки в буфер обмена, выберите его в списке, нажмите правую клавишу мышки и в контекстном меню выберите команду Копировать.

  • Добавление стиля из буфера обмена. Если ранее в буфер обмена был скопирован стиль заливки, то этот стиль можно добавить в библиотеку заливок данного слоя. Для этого в области списка нажмите правую клавишу мышки и в контекстном меню выберите команду Вставить.

  • Импорт стиля из другого слоя. Подробней о импорте можно узнать в разделе «Импорт элементов из других слоев».


Импорт элементов из библиотек других слоев

Для импорта элементов библиотек (символы, стили линий и заливок) из одного слоя в другой:

  1. Выберите слой-источник, то есть слой из которого требуется импортировать элементы библиотеки и нажмите кнопку Открыть. Откроется диалог импорта элементов требуемого вида. Основную часть диалога импорта занимают две области. В верхней области диалога представлены все элементы выбранного вида слоя-источника, а в нижней – элементы, импортируемые в текущий слой. Если вы случайно выбрали не тот слой-источник, то выбрать новый можно нажав кнопку Выбор слоя.

  2. Для добавления части символов из слоя источника в текущий слой выберите требуемые элементы в верхней области (например щелкая левой кнопкой мыши по требуемым элементам с нажатой клавишей Ctrl) и нажмите кнопку Добавить.

    Для добавления всех элементов из верхнего списка в нижний нажмите кнопку Добавить все.

  3. Для исключения символов из списка элементов, предназначенных для импорта, выберите исключаемые символы в нижней области и нажмите кнопку Исключить (кнопка Исключить все исключает все элементы из нижней области).

  4. Нажмите кнопку Импортировать, выбранные элементы будут импортированы в библиотеку текущего слоя и диалог закроется. Для того чтобы закрыть диалог не проводя импорта, нажмите кнопку Закрыть.


Импорт символов из библиотек других слоев

С помощью этого диалога можно импортировать символы из одного слоя в другой. Это означает, что в библиотеку нового слоя можно добавить элементы, которые уже были созданы для других слоёв.

Для импорта элемента библиотеки в слой:

  1. Нажмите кнопку Выбор слоя, укажите слой-источник, то есть слой из которого требуется импортировать элементы библиотеки, нажмите кнопку Открыть. После чего в верхней области диалога будут представлены все элементы выбранного вида слоя-источника, а в нижней – элементы, импортируемые в текущий слой. Если вы случайно выбрали не тот слой-источник, то выберите новый нажав кнопку Выбор слоя.

  2. Для добавления части символов из слоя источника в текущий слой укажите элементы в верхней области (например щелкая левой кнопкой мыши по требуемым элементам с нажатой клавишей Ctrl) и нажмите кнопку Добавить.

    Для добавления всех элементов из верхнего списка в нижний нажмите кнопку Добавить все.

  3. Для исключения символов из списка элементов, предназначенных для импорта, выберите исключаемые символы в нижней области и нажмите кнопку Исключить (кнопка Исключить все исключает все элементы из нижней области).

  4. Нажмите кнопку Импортировать, выбранные элементы будут импортированы в библиотеку текущего слоя и диалог закроется. Для того чтобы закрыть диалог не проводя импорта, нажмите кнопку Закрыть.


Импорт типов и режимов

С помощью данного диалога возможно из структуры одного слоя в структуру другого импортировать типы объектов, включая относящиеся к этим типам режимы, символы и структуры баз данных.

Для импорта типов:

  1. Выберите слой, из которого будут импортированы типы. Для этого нажмите кнопку Обзор ... и выберите требуемый слой в открывшемся стандартном диалоге выбора файлов.

  2. В списке типов выбранного слоя отметьте флажками типы для импорта. Для выбора всех типов отметьте опцию Все.

  3. По умолчанию импорт типов производится одновременно с структурой базы данных, в том случае если база данных не нужна снимите опцию Импортировать структуру базы данных.

  4. Завершите импорт нажатием кнопки Импорт.


Редактор стиля линий

Диалог «Стиль заливки»

Рисунок 1. Диалог «Стиль заливки»

Диалог редактора состоит из следующих основных частей:

  • Область общих настроек стиля. В этой области собраны следующие параметры стиля:

    • В поле Название, при необходимости, задается название стиля линии. Название для стиля необязательно. Если названия нет, для именования стиля используется его номер;

    • В поле Единицы задаются единицы измерения для геометрических параметров стиля линии (пикселы или миллиметры). Все линейные размеры, шаги, сдвиги, толщины могут принимать не только целые, но и дробные значения. На экране дробные размеры округляются до экранных пикселей, но при печати все размеры воспроизводятся точно.

  • Список элементов стиля. В списке отображаются все элементы, используемые в данном стиле линии (см. Список элементов стиля);

  • Область настроек текущего элемента. Набор полей настроек в списке зависит от типа выбранного элемента в списке – линейного, или символьного;

  • Область просмотра стиля. Предварительный просмотр линии с редактируемым стилем.

Список элементов стиля

Элементы выводятся в списке в том же порядке, в каком они отображаются: сначала рисуется верхний элемент, затем, поверх него второй сверху, и т.д.

Слева от каждого элемента списка располагается флажок, элемент отображается в стиле, только когда этот флажок установлен.

Для выбора элемента списка достаточно щелкнуть по нему левой кнопкой мыши.

Под списком располагаются кнопки управления:

  • – сдвиг выбранного элемента вверх по списку;

  • – сдвиг выбранного элемента вниз;

  • – Добавление нового линейного элемента стиля в нижнюю строку списка (см. Задание линейных элементов);

  • – Добавление нового символьного элемента стиля в нижнюю строку списка ( см. Задание символьных элементов);

  • – Удаление выбранного элемента из списка.

Задание линейных элементов

Для задания нового линейного элемента стиля, нажмите кнопку [image] под списком элементов, для редактирования существующего линейного элемента выберите его в списке.

Параметры выбранного линейного элемента задаются в полях правой части диалога стиля:

  • Сплошная линия. Флажок задает тип линии элемента. Когда он установлен линия рисуется сплошной, когда снят – прерывистой. Для прерывистых линий задаются дополнительные параметры: шаг, длина штриха, сдвиг штрихов вдоль линии (см. ниже);

  • Цвет. Цвет линии. В поле либо задается конкретный цвет, в этом случае линия всегда отображается выбранным цветом, либо выбирается значение «авто», – в этом случае линия отображается цветом выбранным в диалоге «Стиль» при нанесении линий;

  • Толщина. Толщина линии. В поле со списком выбирается способ задания толщины, а в поле ввода – толщина линии. Доступны следующие способы задания толщины линии:

    • «постоянная». Толщина линии остается всегда постоянной и равна значению, указанному в поле ввода;

    • «равна общей толщине плюс». Толщина отображаемой линии складывается из значения указанного в поле ввода + значение толщины линии указанное в диалоге Стиль при нанесении линий;

    • «пропорциональная». Толщина линии равна произведению значения указанного в поле ввода и толщины, указанной в диалоге Стиль при нанесении линий. Если необходимо чтобы линия масштабировалась при изменении масштаба карты, то устанавливается именно этот параметр, в противном случае масштабирования линии не будет.

  • Линейные размеры. В данной группе настроек задаются параметры штрихов для прерывистой линии, и сдвиг поперек направления линии для непрерывной линии;

    • В поле со списком задается способ расчета линейных размеров: «постоянные» – размеры равны указанным в соответствующих полях, и «пропорциональные» – размеры определяются как заданный размер * значение толщины линии указанное в диалоге Стиль при нанесении линий. Если в дальнейшем необходимо будет масштабирование линии в зависимости от масштаба карты, то в данном поле необходимо выбрать значение «пропорциональные» ;

    • Шаг (только для прерывистых линий). Задает шаг штрихов линии. Например, если для шага указано значение 10 пикселей, то каждые 10 пикселей линии будет начинаться новый штрих;

    • Длина штриха (только для прерывистых линий). Задает длину штрихов линии. Если штрих выступает за начало следующего штриха (длина штриха + смещение штриха по X превышает шаг штриха), то выступающая часть штриха отбрасывается;

    • Сдвиг по X (только для прерывистых линий). Смещение штриха вдоль направления линии. Смещение может иметь как положительное, так и отрицательное значение;

    • Сдвиг по Y. Смещение штриха поперек направления линии. Смещение может иметь как положительное, так и отрицательное значение.

  • Конец линии. Вид отображения концов линии – закругленный, квадратный, либо прямой.

Задание символьных элементов

Для задания нового символьного элемента стиля, нажмите кнопку [image] , для изменения вида существующего символьного элемента дважды щелкните левой кнопкой мыши по элементу в списке.

На экране появится редактор Рисунок 140, «Окно редактора символов».

Подробно создание векторного рисунка описано в разделе см «Редактор символов».

По завершении создания векторного изображения в список элементов стиля добавляется символьный элемент. В правой части диалога Стиль заливки отображаются поля для задания параметров отображения данного символьного элемента. Для настройки параметров уже существующего символьного элемента достаточно его выбрать в списке.

Параметры символьного элемента

Рисунок 2. Параметры символьного элемента

Параметры символьного элемента задаются следующими полями:

  • Символ. Информационное поле, в котором приводится ширина и высота символа в выбранных единицах;

  • Масштаб элемента. Коэффициент масштабирования символа, – на эту величину умножаются линейные размеры данного элемента;

  • Шаг по горизонтали. Шаг, с которым выводится символ в линии;

  • Сдвиг по горизонтали. Расстояние вдоль линии, на которое сдвигается изображение символа;

  • Линейные размеры. Способ расчета размеров элемента при отображении линии: «постоянные» – размеры равны исходным размерам объекта, и «пропорциональные» – размеры определяются как исходный размер * значение толщины линии указанное в диалоге Стиль при нанесении линий. Если в дальнейшем необходимо будет масштабирование символа в зависимости от масштаба карты, то в данном поле необходимо выбрать значение «пропорциональные»;

  • Сдвиг по вертикали. Расстояние, на которое сдвигается изображение символа по вертикали;

  • Толщины. Способ расчета толщин линий символьного элемента при отображении линии: «постоянные» – толщины равны исходным толщинам, и «пропорциональные» – толщины определяются как исходная толщина * значение толщины линии указанное в диалоге Стиль при нанесении линий. Если в дальнейшем необходимо будет масштабирование линии в зависимости от масштаба карты, то в данном поле необходимо выбрать значение «пропорциональные»;

  • Угол. Угол поворота символа против часовой стрелки;

  • Установка. Способ установки объекта:

    • «с заданным шагом». Символ выводится с шагом указанным в поле Шаг по горизонтали;

    • «в начале отрезка». Символ выводится только в начале отрезка, отрезком считается кусок линии от одной точки перелома до другой;

    • «в начале полилинии». Символ выводится только в начале полилинии, независимо от точек перелома;

    • «в конце отрезка». Символ выводится только в конце отрезка, отрезком считается кусок линии от одной точки перелома до другой;

    • «в конце полилинии». Символ выводится только в конце полилинии, независимо от точек перелома).


Вкладка Линии

Вкладка отображает библиотеку стилей линий. При создании нового слоя библиотека уже содержит список стандартных стилей линий. Причем во всех библиотеках стилей линий обязательно содержатся стили линий №5 (пустая линия), и №6 (сплошная линия), зарезервированные системой. Прочие стили могут редактироваться, удаляться и создаваться пользователями.

Со стилями линий в библиотеке доступны следующие действия:

  • Создание нового стиля. Для создания нового стиля линии нажмите кнопку [image] Новый.... Откроется «редактор стиля линий».

  • Изменение стиля. Для изменения существующего стиля линии выберите в списке требуемый стиль и нажмите кнопку [image] Изменить.... Откроется «редактор стиля линий», в который загрузится информация о выбранном стиле.

  • Удаление стиля. Для удаления существующего стиля линии выберите этот стиль в списке и нажмите кнопку [image] Удалить.

  • Копирование стиля в буфер обмена. Для копирования стиля линии в буфер обмена выберите его в списке, нажмите правую клавишу мышки и в открывшемся контекстном меню выберите команду Копировать.

  • Добавление стиля из буфера обмена. Если ранее в буфер обмена был скопирован стиль линии, то этот стиль можно добавить в библиотеку стилей линий данного слоя. Для этого в области списка нажмите правую клавишу мышки и в открывшемся контекстном меню выберите команду Вставить. Через буфер обмена стили линий можно в том числе и копировать между слоями.


Вкладка Примитивы

В данной вкладке указывается какая база данных используется простыми объектами слоя (примитивами).

Для того, чтобы указать какая база данных будет привязана к примитивам надо с правой стороны из списка База данных выбрать заранее созданную базу.

Если для примитивов база данных не используется, в поле содержится значение «(нет базы данных)».


Печать списка типов и режимов

Для печати отчета по структуре:

  1. Во вкладке Заголовок введите текст заголовка отчета. Нажмите кнопку Выбрать и задайте Параметры шрифта заголовка. Затем укажите тип выравнивания (по левому краю, по центру, либо по правому краю).

  2. Во вкладке Стили укажите информацию включаемую в отчет (типы, режимы базы данных) и задайте стиль вывода информации. Для каждого из перечисленных типов данных (сверху вниз) задаются следующие параметры:

    • для выводимых типов данных должен быть установлен флажок Включить в отчет;

    • кнопка Типы/Режимы/Базы открывает диалог для выбора шрифта печати Типа/Режима/Баз данных;

    • кнопки справа от поля с названием шрифта задают тип выравнивания (по левому краю, по центру, либо по правому краю);

    • в поле Отступ на странице (0,1 мм) задается отступ при печати соответствующих данных.

  3. Во вкладке Размеры задайте размеры печатаемых пиктограмм для графических объектов (ш - ширина, в - высота).

  4. Во вкладке Страница задаются параметры страниц для печати.

  5. Для предварительного просмотра отчета нажмите кнопку Просмотр....

  6. Нажмите кнопку Печать, выберите принтер, диапазон печати и число копий. Для запуска печати нажмите кнопку ОК.

Кнопка Отмена закроет диалог печати.


Вкладка Режим

С помощью данной вкладки задаются настройки для выбранного слева в дереве режима.

[Примечание] Примечание

Подробней о типах и режимах можно узнать в разделе «Типы и режимы».

Для режима задаются следующие параметры:

  • В поле Название указывается название режима. При создании режима для него задается название «Название режима # НОМЕР», где НОМЕР – порядковый номер режима в типе.

  • В поле цвет задается цвет линии режима.

  • В поле стиль из линейных стилей слоя выбирается стиль режима (если нужного стиля нет в списке, его можно самостоятельно создать, подробней см. «Редактор стиля линий»).

  • В полях толщина на экране и толщина при печати задается толщина линий режима при выводе на экран и при выводе на печать.

  • В поле Масштаб 1:1 задается масштаб карты с которого линия будет масштабироваться, масштабирование линии будет производиться только при установленной опции Масштабировать.

    [Примечание] Примечание

    Масштабирование элементов сложного стиля линий, создаваемого пользователем будет возможно только при условии задания в редакторе стиля линий пропорциональных линейных размеров (см. «Редактор стиля линий»).

  • Для типов объектов инженерных сетей вида «отсекающий участок» в поле Состояние задается свойство проводимости для режима. Свойство проводимости используется при решении топологических задач:

    • «Включен» – проводит в обоих направлениях;

    • «Отключен» – не проводит;

    • «Прямая проводимость» – проводит по направлению ввода (по стрелке);

    • «Обратная проводимость» – проводит против направления ввода (против стрелки).

      По мимо проводимости при добавлении дополнительных режимов для инженерных сетей необходимо соблюдать следующие правила:

      Для тепловой сети участки задаются четверками режимов, которые воспринимаются программой следующим образом:

      • «Номера режимов 1, 5, 9 и т. д.» – включен;

      • «Номера режимов 2, 6, 10 и т. д.» – отключен;

      • «Номера режимов 3, 7, 11 и т. д.» – отключен обратный трубопровод;

      • «Номера режимов 4, 8, 12 и т. д.» – отключен обратный трубопровод.

      Для водопроводной сети участки задаются парами режимов, которые воспринимаются программой следующим образом:

      • «Номера режимов 1, 3, 5 и т. д.» – включен;

      • «Номера режимов 2, 4, 6 и т. д.» – отключен.

    [Примечание] Примечание

    Важно понимать, что не стоит без необходимости добавлять в инженерную сеть новые режимы. Их имеет смысл добавлять только в том случае, если надо визуально выделить объекты одного типа друг от друга. Т.е., например если на карте необходимо чтобы участки сети отличались по цвету (например, при изображении четырёхтрубной сети в теплоснабжении.


Вкладка Режим

С помощью данной вкладки задаются настройки для выбранного слева в дереве режима.

[Примечание] Примечание

Подробней о типах и режимах можно узнать в разделе «Типы и режимы».

Для режима задаются следующие параметры:

  • В поле Название указывается название режима. При создании режима для него задается название «Название режима # НОМЕР», где НОМЕР – порядковый номер режима в типе.

  • В группе полей Граница настраиваются параметры границы площадного объекта:

    • в поле цвет задается цвет границы;

    • в поле стиль из линейных стилей слоя выбирается стиль границы;

    • в полях толщина на экране и толщина при печати задается толщина границ при выводе на экран и при выводе на печать;

  • В группе полей Заливка настраиваются параметры заливки площадного объекта:

    • в полях цвет фона и цвет узора задаются цвета узора и фона заливки;

    • в поле узор из площадных стилей слоя выбирается стиль заливки;

    • в поле прозрачность задается степень прозрачности заливки (от 0 до 100), поле активно только для сплошной заливки;

    • В поле Масштаб 1:1 указывается масштаб, при котором размеры элементов заливки отображаются один к одному (параметр аналогичен размеру символа в настройке символьного объекта). Масштабирование будет производиться только при установленной опции Масштабировать.

[Примечание] Примечание

Для того чтобы могли масштабироваться элементы сложного стиля заливки, создаваемого пользователем, линейные размеры и толщины этих элементов, должны задаваться в редакторе стиля заливки как пропорциональные.


Вкладка Режим

С помощью данной вкладки задаются настройки для выбранного слева в дереве режима.

[Примечание] Примечание

Подробней о типах и режимах можно узнать в разделе «Типы и режимы».

Для режима задаются следующие параметры:

  • В поле Название указывается название режима. При создании режима для него задается название «Название режима # НОМЕР», где НОМЕР – порядковый номер режима в типе.

  • В списке символ из символов слоя выбирается символ, требуемый для отображения режима. В том случае если подходящего символа нет, можно создать новый нажав кнопку Новый, либо отредактировать выбранный символ нажав кнопку Изменить.

  • В поле размер выбирается размер символа.

  • Поле цвет для символьного графического типа не используется.

  • Для символьного типа, объекта инженерных сетей вида «источник», либо «отсекающее устройство», в поле состояние свойств режима необходимо указать его проводимость. Свойство проводимости объекта (участка, задвижки) используется при решении топологических задач.

    • «Включен» – рабочее состояние, проводимость во всех направлениях;

    • «Отключен» – нет проводимости;

    • «Прямая проводимость» – существует проводимость от входящих участков к выходящим (для устройств входящей сети является потребителем, для устройств выходящей – источником);

    • «Обратная проводимость» – проводит от выходящих участков ко входящим (для устройств входящей сети является потребителем, для устройств выходящей – источником).

    • Для типов вида «Отсекающее устройство» существует еще такой вид проводимости как «Размыкатель», в этом случает он разъединяет все входящие и выходящие в узел участки, т.е. проводимость через узел в любых направлениях полностью отсутствует.

    [Примечание] Примечание

    При создании новых режимов следует учесть:

    Для типовых объектов в окне Состояние выбирается проводимость для решения топологических задач. Однако для инженерных расчетов следует добавлять объекты в определенной последовательности и по определенным правилам.

    По мимо проводимости при добавлении режима для символьного типа, объекта инженерных сетей вида «задвижка» необходимо придерживаться так же следующих правил.

    • Задвижки задаются парами режимов, которые воспринимаются программой следующим образом: нечетный номер режима соответствует открытому состоянию, четный номер режима – закрытому.

      • «Номера режимов 1, 3, 5 и т. д.» – включена;

      • «Номера режимов 2, 4, 6 и т. д.» – отключена.

    Для символьного типа, объекта инженерных сетей вида «потребитель» поле состояние отсутствует, но для идентификации режима потребителя существуют такие же правила как и у задвижки:

    • Потребители задаются парами режимов, которые воспринимаются программой следующим образом: нечетный номер режима соответствует включенному состоянию, четный номер режима – отключенному. В случае отключения участка сети, все потребители, попавшие под отключение изменят режим работы на отключенный (перейдут в режим с номером на единицу больше), при обновлении состоянии сети.

      • «Номера режимов 1, 3, 5 и т. д.» – включен;

      • «Номера режимов 2, 4, 6 и т. д.» – отключен.

  • При установленном флажке Масштабировать для символа включается режим масштабирование, то есть размер символа изменяется при изменении масштаба карты.

  • При установленном флажке Не увеличивать больше указанного размера, символ не увеличивается при масштабе карты большем, чем указанный в поле размер.

  • При установленном флажке Ориентировать при вводе участков, объекты, при вводе на карте будут повернуты по направлению ввода участков. Установка флажка не влияет на положение уже введенных на карту объектов.

  • При установленном флажке Поворачивать на 90 град., символ, при вводе на карте, поворачивается на угол 90 градусов по часовой стрелке, относительно изображения в редакторе символов. Параметр действует только при установленном флажке Ориентировать при вводе участков.

  • При установленном флажке Ориентация в верхней полуокружности объекты при нанесении будут принимать ориентацию в верхней полуокружности вводимого участка. Параметр действует только при установленном флажке Ориентировать при вводе участков.


Вкладка Режим

С помощью данной вкладки задаются настройки для выбранного слева в дереве режима.

[Примечание] Примечание

Подробней о типах и режимах можно узнать в разделе «Типы и режимы».

Для режима задаются следующие параметры:

  • В поле Название указывается название режима. При создании режима для него задается название «Название режима # НОМЕР», где НОМЕР – порядковый номер режима в типе.

  • В разделе Шрифт - выбирается шрифт для текстового объекта.

  • В разделе Начертание - задается начертание для текстового объекта.

  • Из списка Набор надо выбрать набор для кодирования символов (по умолчанию используется Юникод).

  • В разделе Текст задаются дополнительные параметры для текста:

    • подчеркнутый, зачеркнутый - при выборе данных опций текст будет соответственно подчеркнут или зачеркнут;

    • из списка Цвет - выбрать цвет для шрифта;

    • в окошке Высота задать высоту текста, высота задается относительных единицах. Для регулирования размеров текстовых объектов на карте вводится коэффициент масштабирующий отображение текста. Коэффициент задает масштаб карты, при котором текст будет отображаться в таком же размере, в каком он был создан в структуре. Чем больше значение коэффициента, тем крупнее выглядят текст на карте (при одном и том же масштабе карты).

  • В разделе Фон можно задать:

    • из списка выбрать Тип текста - будет он с ореолом или выделен боксом вокруг текста, по умолчанию никаких эффектов у текста не будет;

    • при выборе типа Ореол или Бокс для них из списка Цвет выбирается цвет.

  • В разделе Выравнивание задается выравнивание для текста:

    • по горизонтали: лево, центр, право;

    • по вертикали: верх, базовая линия, низ;

    • при многострочном тексте: лево, центр, право.

[Примечание] Примечание

Все задаваемые параметры текстового объекта будут отображаться в окошке Образец.


Вкладка Символы

Вкладка отображает библиотеку символов слоя, содержащую все символы, которые могут использоваться в данном слое.

В правой части окна находится область управления библиотекой. В верхней части области библиотеки располагается панель инструментов с кнопками для выполнения основных действий над символами.

При создании пустого слоя, библиотека символов также создается пустой. При создании слоя инженерной сети (тепловой, водопроводной, газовой, паровой) библиотека символов создается с символами для типов и режимов сети.

С символами в библиотеке доступны следующие основные действия:

  • Создание нового символа библиотеки символов. Для создания символа нажмите кнопку [image] Новый... в панели инструментов библиотеки и задайте параметры добавляемого символа в открывшемся редакторе символов.

  • Редактирование символа библиотеки символов. Для редактирования символа выберите его в библиотеке щелчком левой кнопки мыши, нажмите кнопку [image] Изменить... панели инструментов библиотеки и измените настройки символа в открывшемся редакторе символов.

  • Удаление символа из библиотеки. Для удаления символа выберите его в библиотеке щелчком левой кнопки мыши и нажмите кнопку [image] Удалить панели инструментов библиотеки. Так же имеется возможность удалить все символы, которые не используются на карте, то есть не нанесены на карту. Для такого удаления выберите пункт меню Операции|Удалить свободные. При этом символы, нанесенные на карту или используемые в режимах объектов удалены быть не могут.

  • Смена ID символа. Для смены ID символа сделайте щелчок правой кнопкой мыши на символе и в появившемся контекстном меню выберите Изменить ID.

  • Импорт символов из другого слоя. Импорт символов описан в разделе «Импорт элементов из других слоев».


Редактор символов

Редактор символов – это простейший графический редактор, предназначенный для создания и редактирования графических символов. Изображение может состоять из комбинации векторных элементов и растровых изображений (Bitmap).

Окно редактора символов

Рисунок 1. Окно редактора символов

Создание изображения в редакторе символов состоит из следующей последовательности действий:

  1. В рабочем поле редактора создайте изображение символа. Поле изображения ограничено размером 256х256 точек.

  2. В поле Название задайте пользовательское название символа, в дальнейшем оно будет использоваться для идентификации символа в списке символов библиотеки данного слоя и на карте.

  3. При необходимости, укажите точку привязки символа к карте (по умолчанию точка привязки 0:0). Точка привязки, это точка на изображении символа, которая соответствует физическим координатам символа на карте.

  4. Сохраните символ, нажав кнопку [image] .

  5. Закройте окно редактора символов.

Панель Стандартная

Сохранение символа в библиотеке символов;

Вырезание (удаление в буфер обмена) выделенного элемент или группы элементов;

Копирование выделенного объекта в буфер обмена;

Вставка объекта из буфера;

Удаление выделенного объекта;

Отмена последнего действия;

Повтор последнего выполненного действия.

Панель Навигация

Выделение группы элементов;

Увеличение рисунка;

Уменьшение рисунка;

Включение режима произвольного перемещения центра изображения в пределах экрана.

Панель Форматирования

Установка типа и размера букв для надписи;

Установка стиля букв надписи (полужирный, курсив, подчеркнутый);

Установка цвета и стиля шрифта;

Установка цвета, стиля и толщины линии;

Установка стиля заливки контуров.

Панель Редактирование

Установка режима выделения объекта для редактирования;

Установка режима выделения вершин для редактирования;

Установка режима ввода линий;

Режим ввода прямоугольников;

Режим ввода заполненных прямоугольников;

Режим ввода окружностей;

Режим ввода заполненных окружностей;

Режим ввода произвольных многоугольников;

Режим ввода дуг;

Режим ввода сегментов;

Режим ввода текста;

Помещение выделенного объекта впереди всех объектов;

Помещение выделенного объекта позади всех объектов.


Вкладка Тип

С помощью данной вкладки имеется возможность задать настройки для выбранного слева в дереве типов и режимов типа.

[Примечание] Примечание

Подробней о типах и режимах можно узнать в разделе «Типы и режимы».

Параметры выбранного типа объектов задаются следующими полями в правой части диалога структуры:

  • В поле Название задается название типа. При создании для типа автоматически назначается название вида «Новый тип # НОМЕР», где НОМЕР – id номер, назначенный типу.

  • В поле id выбирается уникальный идентификатор типа объектов. При создании, типу назначается первый свободный номер id. Для того чтобы поменять номер id, нажмите кнопку [image] справа от поля, введите в открывшемся диалоге требуемый номер id и нажмите кнопку OK. Смена номера произойдет только в том случае, если новый id не занят другими типами, в противном случае отобразится соответствующее предупреждение.

  • В группе переключателей Графический тип выбирается тип графического объекта используемый для отображения типа: символьный, линейный, площадной либо текстовый. Для символьных и линейных графических объектов задаются дополнительные особые параметры:

    • Символьный. Символьные типовые объекты могут отвечать за объекты инженерных сетей. Для таких объектов требуется установить флажок Объект инженерной сети и выбрать тип объекта инженерной сети переключателем: источник, потребитель, отсекающее устройство, узел.

    • Линейный. Для линейного типового объекта являющегося участком инженерной сети требуется установить флажок участок. При вводе такой участок требует наличия на своих концах объектов символьного типа. Для участка сети может дополнительно устанавливаться флажок отсекающий. Если флажок сброшен, то при переключениях участки ведут себя пассивно, если же флажок установлен, то участок рассматривается при решении задач топологического анализа как отсекающее устройство, т. е. отключение на схеме можно производить участком.

  • В поле со списком База данных выбирается база данных слоя подключаемая к данному типу объектов. База данных должна быть предварительно создана (подробней о базе данных можно узнать в разделе «Общие сведения»). Если подключение типа к базе данных не требуется, оставьте в поле значение «(нет базы данных)». В слоях инженерных (тепловых, водопроводных, газовых, паровых) сетей базы данных создаются автоматически при создании слоя.


Смена ID типа

С помощью данного диалога имеется возможность задать новый ID (уникальный номер) для выделенного в дереве типов типа. Для задания нового номера в строке Введите новый ID типа с помощью клавиатуры введите новое значение, при этом внизу диалога появится сообщение о том занят ID или свободен. Использовать можно только свободные номера. Нажатие кнопки ОК подтверждает смену ID, кнопка Отмена закроет диалог без изменения данных.


Вкладка Типы и режимы

Данный раздел содержит список типовых объектов слоя и их режимы.

Предусмотрены следующие операции:

  • Настройка порядка отображения объектов в слое.

  • Импорт типов и режимов из других слоев.

  • Создание и редактирование типов и режимов.


Вкладка Макро

С помощью данной вкладке возможно производить управление созданными модулями.

Описание кнопок вкладки:

  • Включить - подключает модуль;

  • Отключить - отключает модуль;

  • Создать - открывает окно создания нового модуля;

  • Правка - открывает окно для правки выделенного в списке модуля;

  • Удалить - удаляет выделенный в списке модуль.


Создать новую сеть

Данный диалог предназначен для создания новой инженерной сети.

При создании слоя инженерной сети (тепловой, водопроводной, паровой, газовой, канализационной) через меню структура слоя создается автоматически. Под структурой сети понимается количество объектов (узлов) и связей (участков), их условные обозначения, количество режимов функционирования каждого объекта и структура таблиц (семантических данных), связанных с этими объектами.

Для создания сети:

  1. Указать полный путь к создаваемому файлу слоя на диске, для этого надо справа от строки Имя файла нажать кнопку [image] . В стандартном окне открытия файла выбрать диск и каталог, в котором будут храниться графические файлы. Ввести латинскими буквами имя файла слоя. Слой сети необходимо создавать в отдельной папке!

  2. В строке Название слоя ввести пользовательское название слоя – любую последовательность любых символов, которая будет использоваться в дальнейшем системой для идентификации данного слоя.

  3. При необходимости сразу добавить слой в текущую карту установите опцию добавить в карту.

  4. Нажать кнопку ОК.

    После проведения всех операций автоматически создается слой, который уже содержит файлы графической базы данных с типовой структурой, таблицы и описатели семантической информации для каждого типового объекта.


Разделение участка символьными объектами с заданным шагом (разделение полилинии символами)

Диалог используется для разделение участков сети одинаковыми символьными объектами с заданным шагом. В результате выделенные участки будут разбиты на несколько частей одинакового размера, между которыми размещаются символы. Участки для разделения должны быть заранее выделены.

Для разделения:

  1. В разделе Шаг разбиения внесите шаг в метрах с которым будут разбиты участки символами.

  2. Выберите положение переключателя По сфероиду или По проекции. По умолчанию установлена опция По сфероиду. Именно такой вариант позволяет производить построения в натуральную величину без искажений размеров вводимых объектов.

  3. Нажмите кнопку Символ и выберите символ для разделения.

  4. Из списка Способ разбиения укажите как будет производится работа с остатком линии:

    • Остаток разбиения в конце линии;

    • Остаток разбиения в начале линии;

    • Округлять шаг до разбиения на равные части.

  5. При необходимости отметьте дополнительные опции:

    • Разбивать до остатка - опция будет доступна только если разделение производится с остатком. При ее выборе участок будет разбит до конца, остаток будет меньше указанного шага.

    • Ориентировать символы по направлению линии - при установке данной опции внедренные символы будут ориентированы по направлению участков.

  6. Для запуска процедуры разделения нажмите кнопку ОК. Кнопка Отмена закроет диалог Разбиение линии без сохранения.

    Рисунок 1. Результат разделения


Новая база данных

Диалог предназначен для задания имя базы данных при ее создании. Имя задается в строке Название базы данных, нажатие кнопки ОК подтвердит создание базы данных с заданным именем. Кнопка Отмена закроет диалог без сохранения изменений.


Настройка простого площадного объекта

В диалоговом окне Стиль задаются параметры для простых площадных объектов.

В разделе Заливка можно изменить:

  • цвет фона;

  • цвет узора;

  • выбрать из списка новый узор, если в списке узоров нет нужного, то его возможно создать самостоятельно.

  • при сплошной заливке так же можно установить степень прозрачности (значение прозрачности задается в процентах от 0 до 100).

В разделе Линии можно изменить:

  • поменять для границы площадного объекта цвет;

  • поменять для границы площадного объекта стиль, если в списке стилей нет нужного, то его можно создать самостоятельно;

  • толщину на экране;

  • толщину при печати.


Настройка простого линейного объекта

В диалоговом окне Стиль задаются параметры для простых линейных объектов:

  • цвет – задается цвет для линии;

  • стиль – задается стиль для лини, если в списке стилей нет нужного, то его можно создать самостоятельно;

  • толщина на экране – задается толщина линейных объектов на экране пикселях;

  • толщина при печати – задается толщина линейных объектов при печати.

  • Масштабировать - устанавливается в том случае, если необходимо чтобы линия изменяла свою толщину, пропорционально масштабу отображения карты, при этом и в окне Масштаб 1:1 надо ввести требуемый масштаб.


Базы данных

Диалоговое окно Базы данных отображает список всех слоев и баз данных, содержащиеся в активной карте.

Значком [image] обозначена активная карта, значком [image] - загруженные в нее слои, значком [image] - подключенные к слоям базы данных.

Описание кнопок диалога:

  • Открыть - открывает выделенную в списке базу данных.

  • Сжать - производит сжатие базы данных. Данная операция может понадобиться в том случае, если Вы производили удаление графических объектов, которым ранее соответствовали записи в базе данных. После сжатия соответствующие записи удаляются.

  • Заполнить - создает пустые записи в базе данных для каждого графического объекта. Данную операцию необходимо проделать перед тем, как работать с запросами.

  • Изменить - вызывает диалоговое окно База данных.

  • Закрыть - закрывает окно Базы данных.


Параметры

  • Вкладка Общие

  • Вкладка Карта

  • Вкладка База данных

  • Вкладка HASP

  • Вкладка сеть

Вкладка Общие

Назначенные папки

В данном разделе указывается путь до папки Мои карты. Это папка для хранения данных, к которой при различных операциях, например добавлении слоя в карту, возможно произвести быстрый переход. Для перехода к данной папке в окне выбора файла будет достаточно нажать слева кнопку [image] .

Для изменения назначенной папки выделите строку с указанным путем и нажмите кнопку Изменить..., после чего в стандартном окне выбора укажите новую папку.

Списки последних файлов

В данном разделе можно установить количество запоминаемых последних открываемых файлов (карт, слоев, проектов). При необходимости можно очистить список последних открываемых документов. При необходимости можно очистить список последних открываемых документов. Для этого нажмите кнопку Очистить... и в открывшемся окне выберите, список из каких документов необходимо очистить.

Если установить опцию Запоминать пользовательские имена документов, то в списке последних используемых файлов будут отображаться пользовательские названия карт, в противном случае там будут отображены имена файлов.

Окна

При установке опции Использовать вкладки для документов документы (карты, макеты) будут открываться каждый в своей вкладке, между которыми при работе можно будет оперативно переключаться.

Если установлена опция Использовать имеющееся пустое окно при открытии документа, то при открытии уже существующей на диске карты, карта откроется вместо пустого окна, в противном случае откроется еще одно окно карты.

Графика

Раздел Графика отвечает за отрисовку карты, доступны три варианта: Direct2d, GDI, Skia. По умолчанию стоит опция Direct2d, которая позволяет использовать интерфейс Direct2d, что способствует ускоренному и качественному отображению графики, при этом функция сглаживание включается по-умолчанию.

Если с интерфейсом Direct2d возникли какие либо проблемы, то целесообразно установить переключатель на GDI.

Вкладка Карта

Выделение

В этом разделе можно настроить стиль выделения группы объектов на карте и мишени. Для этого нужно нажать на кнопку с выбранным стилем - линии или заливки и установить новые параметры. Также можно изменить стиль ответов на топологические запросы. Изменения вступят в силу после перезагрузки системы.

Опция Сглаживание линий - позволяет включить/отключить сглаживание линий (антиалиасинг) для слоя.

Опция Показ направлений - применяется к новым картам, при ее установке/снятии в добавляемых в карту слоях будут или не будут соответственно отображаться стрелки направлений на линейных типовых объектах. При этом если в слое были сохранены другие настройки, то будут применены они.

Перемещение изображения (режим рука)

В данном разделе настраивается каким образом будет перемещаться изображение карты в режиме произвольного перемещения центра изображения ( [image] ). Имеется два варианта перемещения: Фрагмент экрана или Полная отрисовка. При выборе первого варианта будет перемещаться только фрагмент карты, в противном случае перемещается вся карта, при больших картах первый вариант более предпочтителен.

Масштабирование колесом мыши

В разделе Масштабирование колесом мыши точно так же как и в предыдущем разделе можно установить опцию Фрагмент экрана или Полная отрисовка, только для режима масштабирования с помощью колеса мыши.

Так же в этом разделе можно настроить каким образом будет уменьшаться или увеличиваться масштаб карты с помощью колеса мыши. Для настройки надо из списка Приближать вращением выбрать нужный вариант либо «от себя» либо «на себя».

Масштаб карты

Из списка Масштаб карты выбирается масштаб: Геодезический или Сантиметры на пиксель.

Указанный масштаб будет отображаться в диалоге Масштаб и центр карты, так же он используется при написании макросов и доступе через COM.

Кнопка Информация

В разделе Кнопка Информация можно установить две опции: По активному слою и По всем слоям карты. В случае установки первой опции при работе с картой в режиме получения информации по слою ( [image] ) запрос будет производиться только к активному слою, при установке опции По всем слоям карты запрос будет произведен сразу одновременно по всем слоям активной карты.

Выделение группы

Из списка выбираются критерии добавления объектов при выделении группы ( [image] , [image] , [image] ):

  • Полное попадание - при выборе данной опции в группу будут добавляться объекты только полностью попавшие в указанную область.

  • Полное или частичное попадание - при выборе данной опции в группу будут добавляться объекты полностью или частично попавшие в указанную область.

Копирование в буфер – указывается масштаб копирования выделенной области карты в буфер.

Сброс настроек - кнопка позволяет сбросить настройки параметров до значений по умолчанию.

Ввод сети

Радиус захвата узла – указывается радиус захвата узла в пикселях при вводе объектов сети.

Восстанавливать последнее местоположение - опция устанавливается для того, чтобы при открытии карты производилось восстановление последнего местоположения карты, которое было до ее закрытия. При использовании серверной карты на машине клиента будут сохраняться локальные данные с последним местоположением.

Предупреждать при удалении группы более чем – вводится количество объектов, если оно будет превышено при удалении, то отобразится предупреждающее сообщение.

Вкладка Базы данных

Использовать единственный браузер базы данных - если данная опция установлена, то при получении информации по различным типовым объектам слоя окно семантической информации будет единственным, в противном случае для каждой семантической базы данных открывается свое окно семантической информации.

Помещать сообщения об ошибках в окно Сообщения - если данная опция установлена, то при возникновении ошибки в системе сообщение о ней будет помещено в окно Сообщения.

При выборе опции Проверять настройки BDE при старте система будет автоматически проверять корректность настроек BDE перед началом работы с базами данных. Это позволит избежать возможных проблем и обеспечит стабильную работу с базами данных.

Ключевые слова в запросах по русски. Ключевые слова в запросах по русски. Если данная опция включена, то в окне семантической информации при задании запроса ключевые слова будут написаны кириллицей на русском, в противном случае латиницей на английском.

В списке Использовать СУБД по-умолчанию можно выбрать базу данных, которая будет использоваться по умолчанию, если не указано иное. То есть в том случае, когда источник данных не выбирается через пользовательский интерфейс. При различных операциях, например, при создании слоя, копировании и др. , где есть список доступных источников данных, последний используемый источник данных будет запомнен для удобства работы. Изначально, же первый раз, там был выбран источник по-умолчанию.

Вкладка HASP

В разделе Использовать сетевой ключ флажками должны быть отмечены модули, защита которых происходит с использованием сетевого ключа. Если модуль не отмечен, то система будет работать с локальным ключом.

[Предупреждение] Предупреждение

При использовании локального ключа, флажки обязательно должны быть сняты!

Открытие теста ключа

Тест ключа позволяет отобразить список локальных и сетевых ключей, доступных данному компьютеру и при выборе определенного ключа лицензии записанные на нем. Для вызова теста ключа нажмите кнопку Информация по ключам. Подробней о тесте ключа можно у знать в разделе «Просмотр доступных лицензий на ключе HASP».

Открытие центра администрирования ключей

Центр администрирования позволяет просматривать информацию локальным и сетевым ключам, составу и количеству лицензий на программные модули и продукты, количеству текущих пользователей лицензий и т.д. Для открытия страницы центра администрирования ключей нажмите кнопку HASP Admin Control Center.

Открытие информации о защите системы

Нажав кнопку Об организации защиты произойдет переход на страницу с описанием защиты системы ZuluGIS, так же о защите возможно ознакомиться в разделе Организация защиты продуктов линейки Zulu.

Вкладка Сеть

Прокси сервер

В данном разделе задаются параметры прокси сервера:

  • Прямое подключение;

  • Использовать системные настройки;

  • Задать параметры, при выборе данной опции дополнительно задаются адрес, порт, логин и пароль.

HTTP клиент

  • MFS WinInet – стандартный HTTP клиент;

  • cURL – HTTP клиент для поддержки различных интернет сервисов, часто используется для работы с Росреестром.

Корневая папка для кэша

В разделе Корневая папка для кэша задается путь до корневой папки, отличной от папки по умолчанию для кэширования тайловых данных. Нажатие кнопки Папка по умолчанию, приведет к установке исходной папки для кэша.

Командный сервер

  • Включить – включает возможность работать с командным сервером ZuluGIS по протоколу HTTP. В окошке Порт необходимо указать номер порта.

  • SSL/TLS – включает возможность работать с командным сервером ZuluGIS по протоколу HTTPS. В окошке Порт необходимо указать номер порта, так же надо указать Сертификат и Ключ.

Опцию Разрешить выполнение макросов требуется включать в том случае, если планируется выполнять запросы к командному серверу ZuluGIS используя команду RunMacro для запуска макросов.

[Примечание] Примечание

Описание запросов к командному серверу ZuluGIS можно найти в руководстве программиста в разделе Командный сервер.


Колонтитулы

Данный диалог позволяет настроить колонтитулы.

Для создания колонтитула надо:

  1. Определиться в какой части листа необходимо создать колонтитул, затем установить курсор в соответствующий раздел диалога (Слева, В центре, Справа).

  2. Выбрать нужное действие:

    • вставить любой текст с индивидуальной настройкой;

    • вставить номер страницы, число страниц, номер страницы по вертикали или по горизонтали;

    • вставить дату или время;

    • вставить название документа или путь к нему.

  3. Для подтверждения создания колонтитулов нажать кнопку ОК.


Вставка даты и времени

Для того чтобы вставить в колонтитул дату надо:

  1. Нажать на панели инструментов кнопку [image] . В выбранной области появится запись: ${date}.

Для того чтобы вставить в колонтитул время надо:

  1. Нажать на панели инструментов кнопку [image] . В выбранной области появится запись: ${time}.


Вставка названия и пути до документа

Для того чтобы вставить в колонтитул название документа надо:

  1. Нажать на панели инструментов кнопку [image] . В выбранной области появится запись: ${title}. После вставки названия в колонтитуле будет выведено пользовательское название карты.

Для того чтобы вставить в колонтитул путь до документа надо:

  1. Нажать на панели инструментов кнопку [image] . В выбранной области появится запись: ${path}${file}. После вставки пути в колонтитуле будет выведен путь и имя файла карты.


Вставка номера страницы

Для того чтобы вставить в колонтитул номер страницы надо:

  1. Нажать на панели инструментов кнопку [image] . В выбранной области появится запись: ${page}.

Для того чтобы вставить в колонтитул число страниц надо:

  1. Нажать на панели инструментов кнопку [image] . В выбранной области появится запись: ${page-col}.

В один колонтитул возможно внесение и номера страницы и общее количество страниц. Для этого необходимо произвести действия описанные выше, и затем в диалоге Колонтитулы между записями внести с клавиатуры текст "из", как показано на рисунке ниже:

Диалоговое окно Колонтитул

Рисунок 1. Диалоговое окно Колонтитул

Для того чтобы вставить в колонтитул номер страницы по вертикали или горизонтали надо:

  1. Нажать на панели инструментов кнопку:

    • - чтобы внести номер страницы по вертикали, в выбранной области появится запись: ${page-row};

    • - чтобы внести номер страницы по горизонтали, в выбранной области появится запись: ${page-col}.


Вставка текста в колонтитул

Для того чтобы вставить текст в колонтитул надо:

  1. Нажать на панели инструментов кнопку [image] .

  2. В открывшемся диалоге Шрифт задать параметры вводимого текста, такие как шрифт, начертание, размер и др. Затем подтвердить настройки нажатием кнопки ОК.

  3. Внести текст с клавиатуры.

[Примечание] Примечание

Для изменения параметров уже внесенного текста его надо выделить, после чего нажать кнопку [image] и сделать необходимые изменения.


Параметры страницы

Диалог предназначен для задания параметров страницы, он имеет две вкладки:

  • Страница - в ней задаются такие параметры как размер, подача, ориентация бумаги, настройка полей и отступы колонтитулов (см. «Вкладка Страница»);

  • Колонтитулы - в ней настраиваются колонтитулы и номера страниц (см. «Вкладка Колонтитулы»).


Графический редактор изображений

Описание работы в растровом графическом редакторе:

Растровый графический редактор

Рисунок 1. Растровый графический редактор

Основные элементы окна растрового графического редактора:

  • Рабочая область редактора. Область редактирования изображения;

  • Область просмотра. В ней отображается редактируемое растровое изображение в масштабе 1:1;

  • Панель инструментов с кнопками устанавливающими режим рисования в редакторе;

  • Область настроек текущего инструмента. В этой области задаются дополнительные настройки некоторых инструментов;

  • Индикатор текущих цветов. Отображает текущие цвета;

  • Палитра цветов. Палитра предназначена для выбора цветов для рисования. Нижний квадрат палитры - [image] , отвечает за прозрачный цвет.

Работа с цветом

В растровом редакторе используется два цвета – основной цвет и цвет фона.

Основной цвет используется для границ создаваемых площадных объектов и текста. Цвет фона используется для заполнения замкнутых фигур. Для создаваемых линий и заливок может использоваться как основной цвет, так и цвет фона.

Текущие основной цвет и цвет фона отображаются на индикаторе текущих цветов над палитрой палитры. В верхнем квадрате отображается основной цвет. В нижнем квадрате – цвет фона.

Задание основного цвета и цвета фона

Для выбора цветов используется палитра цветов редактора. Для задания основного цвета щелкните левой кнопкой мыши по требуемому цвету в палитре, для задания фонового цвета – щелкните правой кнопкой мыши по цвету.

Создание прозрачных областей

Для создания прозрачных областей в изображении требуется выбрать в палитре цветов прозрачный цвет (представленный квадратом [image] ) и далее использовать его для рисования обычными инструментами редактора. Области закрашиваемые прозрачным цветом становятся также прозрачными.

[Примечание] Примечание

Прозрачность изображения может использоваться только в символах слоев ZuluGIS. При сохранении рисунка в файл BMP информация о прозрачности теряется, и прозрачные места закрашиваются черным цветом.

Установка произвольного цвета

В редакторе предусмотрен выбор цветов не входящих в палитру редактора. Для выбора цвета:

  1. Для изменения основного цвета дважды щелкните левой кнопкой мыши по палитре, либо по индикатору цвета (для изменения цвета фона дважды щелкните правой кнопкой мыши).

  2. В диалоге выбора цвета выберите нужный цвет и закройте диалог нажав кнопку ОК.

Копирование цвета области

Используемые цвета можно выбрать с текущего изображения. Для этого:

  1. В панели инструментов нажмите кнопку Выбор цвета - [image] .

  2. Щелкните кнопкой мыши по области редактируемого изображения, цвет которой требуется выбрать. Для выбора основного цвета щелкните левой кнопкой, для выбора фонового – правой.

Работа с рисунком

Отмена изменений:

Чтобы отменить последнее изменение в рисунке, выберите в меню Правка команду Отменить, либо нажмите сочетание клавиш Ctrl-Z. Для отмены нескольких последних изменений выполните команду последовательно требуемое количество раз. Отменены могут быть все изменения внесенные с момента открытия растрового графического редактора.

Изменение масштаба отображения:

  1. В панели инструментов нажмите кнопку [image] .

  2. Прокручивая колесо мыши, измените масштаб рисунка.

[Примечание] Примечание

При максимальном увеличении на рисунке появится сетка с размером ячейки, равным одному пикселю изображения. При этом прозрачные пиксели рисунка будут перечеркнуты.

Изменение размеров рисунка:

  1. Выберите в меню Рисунок команду Атрибуты.

  2. В открывшемся диалоге Атрибуты введите новую ширину и высоту рисунка в поля Ширина и Высота и закройте диалог, нажав кнопку ОК.

Растяжение и сжатие рисунка:

  1. Выберите в меню Рисунок команду Атрибуты.

  2. В диалоге Атрибуты введите новую ширину и высоту рисунка в полях Ширина и Высота.

  3. Установите флажок Сжать/Растянуть.

  4. Закройте диалог, нажав кнопку ОК.

Создание нового рисунка:

  1. Выберите в меню Файл команду Создать (кнопка [image] ) для создания нового рисунка.

Сохранение рисунка в файл:

  1. Выберите в меню Файл команду Сохранить как (кнопка [image] ) для того, чтобы сохранить отредактированный рисунок в файл BMP на диске.

Открытие существующего рисунка из файла:

  1. Выберите в меню Файл команду Открыть (кнопка [image] ) для того, чтобы открыть рисунок, сохраненный в формате BMP.

Работа с выделенными фрагментами изображения

Выделение фрагмента

  1. В панели инструментов нажмите кнопку Выделить - [image] .

  2. Подведите указатель мыши к одному из углов выделяемого фрагмента.

  3. Нажмите левую кнопку мыши и, не отпуская ее, переместите указатель в противоположный угол фрагмента.

  4. Отпустите левую кнопку мыши.

Копирование и вырезание фрагмента:

  1. Выделите фрагмент, если он еще не выделен.

  2. Выберите в меню Правка команду Копировать или Вырезать (соответственно кнопки [image] или [image] ) для копирования в буфер обмена или вырезания выделенного фрагмента рисунка.

Вставка рисунка:

  1. Выберите в меню Правка команду Вставить (кнопка [image] ) для замены рисунка на рисунок содержащийся в буфере обмена.

Рисование

Рисование линии:

  1. Нажмите в панели инструментов кнопку Линия – [image] .

  2. Выберите толщину линии в области настроек под панелью инструментов.

  3. Для рисования линии основным цветом нажмите левую кнопку мыши в точке начала линии и, не отпуская ее, переместите в точку окончания линии.

  4. Отпустите кнопку мыши, линия будет зафиксирована.

Рисование фоновым цветом выполняется аналогичным образом, но вместо левой кнопки мыши следует нажимать правую кнопку.

Рисование произвольной кривой:

  1. В панели инструментов нажмите кнопку Карандаш – [image] .

  2. Для нанесения кривой основным цветом нажмите левую кнопку мыши и перемещайте указатель по траектории наносимой кривой.

  3. По окончании нанесения кривой отпустите кнопку мыши.

Рисование фоновым цветом выполняется аналогичным образом, но вместо левой кнопки мыши следует нажимать правую кнопку.

Кривые рисуются с толщиной в 1 пиксель.

Рисование эллипса (круга):

  1. В панели инструментов нажмите кнопку Эллипс – [image] .

  2. Выберите стиль заливки в области настроек под панелью инструментов. Доступны три стиля (сверху-вниз): незаполненный эллипс, заполненный эллипс, эллипс заполненный цветом его границы.

  3. Нажмите левую кнопку мыши в позиции, совпадающей с одним из углов прямоугольника, в который вписан рисуемый эллипс (круг).

  4. Переместите указатель мыши так, чтобы отобразился требуемый эллипс (круг) и отпустите кнопку мыши.

При использовании для рисования эллипса (круга) левой кнопки мыши, граница эллипса изображается основным цветом, а заливка фоновым цветом. Если использовать правую кнопку мыши, то граница отображается цветом фона, а заливка – основным цветом.

Толщина границы эллипса (круга) соответствует толщине линии выбранной для инструмента Линия – [image] .

Рисование прямоугольника (квадрата):

  1. В панели инструментов нажмите кнопку Прямоугольник - [image] .

  2. Выберите стиль заливки в области настроек под панелью инструментов. Доступны три стиля (сверху-вниз): незаполненный прямоугольник, заполненный прямоугольник, прямоугольник заполненный цветом его границы.

  3. Нажмите левую кнопку мыши в позиции, совпадающей с одним из углов рисуемого прямоугольника (квадрата).

  4. Переместите указатель мыши так, чтобы отобразился требуемый прямоугольник (квадрат) и отпустите кнопку мыши.

При использовании для рисования прямоугольника (квадрата) левой кнопки мыши, граница прямоугольника (квадрата) изображается основным цветом, а заливка фоновым цветом. Если использовать правую кнопку мыши, то граница отображается цветом фона, а заливка – основным цветом.

Толщина границы прямоугольника (квадрата) соответствует толщине линии выбранной для инструмента Линия – [image] .

Рисование многоугольника:

  1. В панели инструментов нажмите кнопку Многоугольник - [image] .

  2. Выберите стиль заливки в области настроек под панелью инструментов. Доступны три стиля (сверху-вниз): незаполненный многоугольник, заполненный многоугольник, многоугольник заполненный цветом его границы.

  3. Нажмите левую кнопку мыши в точке одной из вершин рисуемого многоугольника.

  4. Последовательно перемещайте указатель мыши и нажимайте левую кнопку в точках остальных вершин многоугольника, кроме последней.

  5. Переместите указатель мыши в точку последней вершины многоугольника и дважды щелкните левой кнопкой мыши. Многоугольник будет зафиксирован.

При использовании для рисования многоугольника левой кнопки мыши, его граница изображается основным цветом, а заливка фоновым цветом. Если использовать правую кнопку мыши, то граница отображается цветом фона, а заливка – основным цветом.

Толщина границы многоугольника соответствует толщине линии выбранной для инструмента Линия – [image] .

Заливка области:

  1. В панели инструментов нажмите кнопку Заливка - [image] .

  2. Для заливки основным цветом, щелкните левой кнопкой мыши в области изображения, которую требуется залить текущим основным цветом.

Заливка фоновым цветом выполняется аналогичным образом, но вместо левой кнопки мыши следует нажимать правую кнопку.

Ввод и форматирование текста:

  1. В панели инструментов нажмите кнопку Текст - [image] .

  2. Щелкните левой кнопкой мыши в позиции начала текста.

  3. Введите текст.

Шрифт и атрибуты текста настраиваются стандартном диалоге настройки шрифтов вызываемом командой Шрифт меню Текст.

Для рисования текста используется текущий основной цвет.

Очистка области:

  1. В панели инструментов нажмите кнопку Резинка – [image] .

  2. Выберите толщину резинки в области настроек под панелью инструментов.

  3. Для стирания основным цветом нажмите левую кнопку мыши и перемещайте указатель по очищаемой области рисунка.

  4. По окончании очистки отпустите кнопку мыши.

Очистка фоновым цветом выполняется аналогичным образом, но вместо левой кнопки мыши следует нажимать правую кнопку.


Новый проект

Для создания нового проекта задайте следующие параметры:

  1. В строке Имя файла наберите полный путь и имя файла,в котором будет сохранен проект ZuluGIS. Используйте кнопку [image] , чтобы задать этот файл с помощью диалоговой панели выбора файла.

  2. В строке Название введите смысловое название проекта длиной до 48 символов.

  3. Нажмите кнопку OK.

Новый проект будет создан.


Проекты

В диалоге Проекты пользователю предоставляется возможность по работе как с зарегистрированными в системе проектами (выводятся в списке проектов), так и по созданию новых проектов.

Для вызова диалога следует выбрать пункт главного меню Файл|Проекты...

Список Зарегистрированные проекты содержит список имен всех проектов, ранее зарегистрированных и физически существующих по указанным путям.

Описание кнопок диалога:

  • Открыть - открывает выделенный в списке проект.

  • Обзор... - вызывает диалог выбора имени файла проекта с диска. После выбора открывает проект и, если он еще не был зарегистрирован, добавляет его в список проектов системы. Поведение аналогично разделу Открытие проекта.

  • Создать - вызывает диалог создания проекта.

  • Переименовать - переход в режим редактирования пользовательского названия выделенного в списке проекта.

  • Исключить - исключает выделенные проекты из списка проектов, зарегистрированных в системе. При этом сам файл проекта с диска не удаляется.

  • Закрыть - закрывает диалог Проекты.


Связь объекта с другой картой

Диалоговое окно Связь объекта с другой картой предназначено для связи карт проекта между собой. Например, на карте Пример Тепловой Сети необходимо более подробно рассмотреть план отопления одного из зданий, а у этого здания подробнее рассмотреть схему теплового узла. Т. е. три карты: «Пример тепловой сети», «Здание-1 этаж» и «Тепловой узел» необходимо объединить, связав карту более низкого уровня (Здание - 1 этаж) с одним из объектов на карте более высокого уровня (Пример тепловой сети).

Здание на карте «Пример тепловой сети» - карта «Здание-1 этаж» - Тепловой узел на карте «Здание-1 этаж» - карта «Тепловой узел».

Для установки связи объекта с картой надо:

В разделе Карты проекта выделить карту, с которой необходимо связать объект (объект должен быть предварительно выделен кнопкой [image] ) и нажать кнопку Связать.

Если карты нет в списке карт, то нажмите кнопку Найти и связать, после чего откроется диалог Выбор карты, в котором надо выбрать карту, с которой надо произвести связь, непосредственно с диска компьютера.

Чтобы удалить связь надо:

В нижнем списке раздела Карты проекта выделить карту, связь с которой необходимо удалить и нажать кнопку Удалить связь.

Для вызова диалога следует выбрать пункт главного меню Файл|Проекты...

Кнопка Закрыть закрывает окно настройки связи.


Карты проекта

Данный диалог позволяет открыть карту, исключить карту из проекта, добавить новую карту в проект. Здесь же выводится список всех карт, входящих в открытый проект.

В диалоге Проект возможно выполнить следующие действия:

1. Добавить карты в проект

Карта в проект может быть добавлена двумя способами:

  • Нажать кнопку Найти и добавить.... При этом открывается стандартный диалог выбора файла на диске. Выберите диск, каталог и имя файла карты, которую необходимо открыть.

  • Через меню Файл открыть карту стандартным способом. После этого вызвать диалог Проекты и нажать кнопку Добавить активную.

2. Исключить карты из проекта

Для этого надо выделить карту в списке карт и нажать кнопку Исключить из проекта.

Назначение командных кнопок диалога:

  • Открыть - открывает выделенную в списке карту.

  • Открыть все - открывает все карты проекта.

  • Найти и добавить... - вызывает диалог открытия файла. На диске выбирается карта, которую необходимо добавить в проект.

  • Добавить активную - если была загружена карта не входящая в проект, то можно добавить ее в список карт проекта. Для этого необходимо сделать карту активной и в диалоге Проект нажать кнопку Добавить активную.

  • Исключить из проекта - исключает из проекта выделенную карту. При этом если карта была открыта, то система ее НЕ закрывает.

  • Закрыть - закрывает диалог Проект.


Вкладка Шрифт

Данная вкладка позволяет настроить следующие параметры текста:

  • Шрифт, его начертание, размер и цвет.

  • Подчеркивание текста.

  • Видоизменение: зачёркнутый, надстрочный, подстрочный, все прописные.

После внесения изменений и нажатия кнопки ОК, произойдет сохранение параметров.


Сохранение импортированных растровых файлов

С помощью данного диалога имеется возможность преобразовать используемые в картах описатели растров формата MapInfo (файлы tab), или OziExplorer (файлы map) в формат описателя растра ZuluGIS (файлы zrs), а также конвертировать растры в формат BMP. Данные действия позволяют увеличить скорость и удобство работы с указанными объектами.

Для выполнения преобразования выполните следующие действия:

  1. В диалоге будет приведен список растровых объектов карты доступных для преобразования. Установите флажки слева от объектов которые требуется преобразовать (либо установите флажок Все под списком, чтобы отметить сразу все объекты в списке).

  2. Если требуется перевести файлы растровых изображений в формат BMP, установите соответствующий флажок.

  3. Поставьте флажок Создать постоянный кэш если необходимо создавать постоянные кэш-файлы для преобразуемых объектов (создание постоянного кэш-файла ускоряет загрузку объектов в карту, но потребляет некоторое пространство на диске).

  4. В строке Папка для записи нажмите кнопку [image] и укажите путь к папке для файлов преобразованных растровых объектов. Если путь к папке не указывать, то преобразованные объекты сохраняются в одной папке с исходными объектами.

  5. Нажмите кнопку ОК для выполнения преобразования и закрытия диалога. Кнопка Выход закрывает диалог без выполнения преобразования.

По завершении преобразования растровых объектов они замещают собой исходные объекты в карте. При этом файлы исходных объектов остаются нетронутыми.


Корректировка растра

Панель корректировки растров предназначена для выравнивания и обрезки отсканированных растровых изображений. Она позволяет исправлять геометрические искажения, возникающие при сканировании растровых изображений. Подробнее об операции см. «Корректировка растра».

В диалоговом окне Корректировка растра используются следующие кнопки:

  • - загрузка растрового файла для корректировки;

  • - сохранение скорректированного растрового файла в файл с заданным именем (при необходимости расширение файла можно поменять в поле Тип файла;

  • - запуск процесса корректировки растрового файла;

  • - прерывание процесса корректировки растрового файла;

  • - задание количества ячеек корректирующей сетки по вертикали и горизонтали;

  • - отмена последнего действия по перемещению узла;

  • - увеличение изображения в два раза;

  • - уменьшение изображения в два раза;

  • - вписать изображение в размеры окна;

  • - перемещение изображения влево, при котором ближайшая слева опорная точка окажется в центре окна;

  • - перемещение изображения вниз, при котором ближайшая снизу опорная точка окажется в центре окна;

  • - перемещение изображения, при котором в центре окна окажется ближайшая с любой стороны опорная точка;

  • - перемещение изображения вверх, при котором ближайшая сверху опорная точка окажется в центре окна;

  • - перемещение изображения вправо, при котором ближайшая справа опорная точка окажется в центре окна.

  • - выход из диалога.


Задание растра

Для задания растра выполните следующую последовательность действий:

  1. Откройте растр. Для этого нажмите кнопку Растровый файл диалога и выберите требуемый графический файл в стандартном диалоге выбора файлов. Изображение загрузится в область просмотра диалога. Масштаб изображения в области просмотра регулируется кнопками [image] и [image] , расположенными над областью.

  2. Выберите систему координат. Для этого, нажмите кнопку Система координат диалога и выберите систему координат в открывшемся диалоге (см. «Диалог задания проекции слоя»).

  3. Задайте точки привязки растра к координатам.

    Данные о точках привязки отображаются в таблице Точки привязки растра:. В поле N приводится номер точки, в полях x, y – координаты точки растра (в пикселях), X и Y – координаты этой же точки на карте, в выбранной системе координат. Флажок Перевод строки под таблицей управляет добавлением в таблицу точек привязки. Если флажок установлен, то информация о добавляемой точке размещается в новой строке внизу таблицы, если флажок сброшен – замещается информация в текущей строке таблицы. Для добавления координат точки привязки на растре доступно несколько способов:

    • Щелкните левой кнопкой мыши в требуемой точке привязки на изображении;

    • Для добавления точки одного из углов растра, нажмите кнопку [image] , [image] , [image] или [image] в таблицу добавятся координаты соответствующего угла;

    • Либо введите координаты точки на растре вручную, в поля x и y пустой строки внизу таблицы. Если пустой строки в таблице нет, нажмите кнопку [image] под таблицей, для добавления такой строки.

  4. Настройте дополнительные параметры задания растра. Эти параметры задаются в группе полей Параметры диалога.

    • Для задания цвета линий растра (только для монохромных растров) установите флажок использовать цвет линийи выберите требуемый цвет в поле справа от флажка;

    • Для задания цвета фона (только для монохромных растров) установите флажок использовать цвет фона и выберите требуемый цвет фона справа от флажка;

    • Для того чтобы белый цвет был прозрачным (только для монохромных растров), установите флажок Прозрачный белый. Флажок доступен только в том случае, если в поле Прозрачность установлено значение «0»;

    • В поле Прозрачностьзадается степень прозрачности растра;

    • Установка флажка Использовать постоянный кэш включает для растра использование постоянного временного кэш-файла, что ускоряет загрузку растра, но увеличивает занятое дисковое пространство.

  5. После задания растра, сохраните его файл-описатель, для этого нажмите кнопку Сохранитьи в стандартном диалоге сохранения файла задайте название сохраняемого файла-описателя.

  6. Для задания следующего растра, нажмите кнопку Новый.

  7. По завершению задания растров нажмите кнопку Закрыть диалога.

Для того чтобы изменить параметры уже созданного файла-описателя, в диалоге задания растров нажмите кнопку Открыть и выберите требуемый файл описатель (формата .zrs) в стандартном диалоге выбора файлов.


Экспорт описателей растровых объектов в форматы Mapinfo, OziExplorer, ESRI World File

С помощью данного диалога имеется возможность на основе растрового объекта создавать файлы привязки MAP OziExplorer, Mapinfo и ESRI World File.

[Примечание] Примечание

В OziExplorer возможен экспорт только растров с проекциями Гаусса-Крюгера (Пулково 1942) и Universal Transverse Mercator (VGS 84).

Для экспорта надо:

  1. Загрузить растры в карту.

  2. Можно заранее выделить растры для экспорта.

  3. Выбрать меню Растр|Экспортировать описатели.

  4. В списке Растровые объекты с помощью галочек указать описатели для экспорта. Если на карте заранее были выделены растры, то список будет состоять только из них. Для отображения всех растров карты надо снять опцию Только выделенные.

  5. Указать формат создаваемого файла:

    • TAB Mapinfo;

    • MAP OziExplorer;

    • ESRI World File.

  6. Для запуска процедуры экспорта нажать кнопку ОК.

После завершения экспорта в той же папке где расположены растры для каждого описателя растрового объекта будет образован указанный файл привязки.


Привязка растра на карте

С помощью данного диалога возможно выполнить привязку растра на карте. Это удобно в тех случаях, когда известны только приблизительные координаты растра и требуется их уточнить на местности, например, проводя склейку с соседними сегментами карты. Кроме того, привязка на карте позволяет провести обрезку краев растра, если требуется.

[Примечание] Примечание

В настоящей версии через диалог привязки растров так же имеется возможность экспортировать растр в формат Mapinfo (*.tab) OziExplorer (*.map), подробно об экспорте можно узнать в разделе «Экспорт описателей растровых объектов в форматы Mapinfo, OziExplorer, ESRI World File».

Диалог привязки растров

Рисунок 1. Диалог привязки растров

Для привязки или обрезки:

  1. В поле Слой диалога выберите растровый слой, в котором находится объект для привязки.

  2. В поле Объект выберите нужный объект (необходимо, если в слое несколько объектов). Требуемый объект можно также выбрать нажав клавишу Ctrl и, не отпуская ее, щелкнув левой кнопкой мыши по требуемому растру в карте.

    Требуемый растр может быть выбран и до открытия диалога. Для этого, предварительно сделайте слой растра редактируемым [image] , войдите в режим редактирования объектов (кнопка [image] ) и выберите требуемый растр на карте.

  3. В группе настроек Параметры задайте параметры отображения растра:

    • для задания цвета линий растра (только для монохромных растров) установите флажок использовать цвет линий и выберите требуемый цвет в поле справа от флажка;

    • для задания цвета фона (только для монохромных растров) установите флажок использовать цвет фона и выберите требуемый цвет фона справа от флажка;

    • для того чтобы белый цвет был прозрачным (только для монохромных растров), установите флажок Прозрачный белый (флажок доступен только в том случае, если в поле Прозрачность установлено значение 0).

    • в поле Прозрачность задается степень прозрачности растра;

    • установка флажка Постоянный кэш включает для растра использование постоянного временного кэш-файла, что ускоряет загрузку растра, но увеличивает занятое дисковое пространство;

    • для применения измененных параметров нажмите кнопку Применить.

  4. Диалог параметров привязки используется для решения двух основных задач: задания точек привязки растра и обрезки незначащих границ растра (рамок, полей и т.д.). В зависимости от того, какая вам нужна операция выберите нужную кнопку в левом верхнем углу диалога: – задание координат, [image] – обрезка растра.

  5. Укажите точки привязки или границы растра, в соответствии с ранее выбранной кнопкой.

  6. После задания требуемых параметров, нажмите кнопку Сохранить для сохранения изменений в файле-описателе. Если при переходе к другому растровому слою через поле Слой, либо при закрытии диалога, обнаруживаются не сохраненные изменения, то появляется соответствующее уведомление.

  7. После завершения работы с диалогом, нажмите кнопку Выход чтобы закрыть диалог.


Группировка растровых объектов

Диалог создания растровой группы содержит раздел Состав группы, куда в виде древовидной структуры добавляются растровые файлы, которые необходимо включить в группу. Группа может состоять как из отдельных растров, так и из растровых групп, которые отображаются со значком «+» слева от названия группы. Нажав на «+» можно раскрыть группу и посмотреть список входящих в группу растров.

Для создания растровых групп:

  1. Выберите пункт меню Растр|Сгруппировать.

  2. В появившемся диалоге Растровая группа добавьте в список Состав группы все объекты, которые должны входить в состав группы, для этого воспользуйтесь кнопками.

    • Добавить – вызывает диалог выбора файлов для добавления растровых объектов и групп в данную группу, в этом диалоге укажите добавляемые файлы и нажмите кнопку Открыть;

    • Удалить– удаляет выбранный элемент из списка группы.

    Список добавленных объектов отображается в окне состава группы в древовидной форме – для объектов списка, являющимися другими растровыми группами показывается их состав.

    [Примечание] Примечание

    Для вложенных групп редактирование их состава не предусмотрено, поэтому при выделении элементов этих групп кнопка Удалить становится недоступной.

  3. После того как растровая группа набрана и отредактирована, нажмите кнопку Сохранить и в появившемся диалоге выбора файла укажите файл для сохранения группы.

    [Примечание] Примечание

    Очистка полей диалога редактирования растровой группы выполняется кнопкой Новая. После нажатия этой кнопки система предложит сохранить текущие изменения, очистит все строки диалога и будет готова к заданию новой растровой группы.

Описание кнопок диалога:

  • Добавить - вызывает диалог выбора файлов для добавления растровых объектов и групп в данную группу.

  • Удалить - удаляет выбранный элемент из списка группы.

  • Новая - очищает диалоговую панель для задания новой растровой группы. Если текущие данные были изменены, предлагает сохранить изменения.

  • Открыть - открывает уже готовую растровую группу для редактирования.

  • Сохранить - сохраняет внесенные изменения. При этом вызывается диалоговая панель выбора файла, в которой следует указать путь к файлу ZRG, в который следует записать растровую группу.

  • Закрыть - закрывает диалог Растровая группа.


Перепроецирование растровых слоев

Перепроецирование дает возможность из исходного растрового объекта, заданного в одной географической проекции получать новый растр с привязкой в другой проекции.

Для перепроецирования растрового слоя:

  1. В диалоге Перепроецирование слоев карты нажмите кнопку Система координат, в открывшемся окне укажите новую систему координат и нажмите кнопку ОК.

  2. В том случае, если в карте загружены объекты с разных источников (локальные и серверные) из списка Выбирать из: укажите какой источник данных использовать.

  3. Если необходимо перепроецировать только определенную группу растров, то установите опцию Только выделенные (группа объектов должна быть заранее выделена).

  4. В разделе Растровые объекты укажите с помощью галочек объекты для перепроецирования.

  5. Укажите папку для записи перепроецированных растров, воспользуйтесь кнопкой [image] .

  6. Из открывающихся списков выберите Выходной формат и Единицы измерения для перепроецированных растров.

  7. Поставьте флажок Создать постоянный кэш если необходимо создавать постоянные кэш-файлы для преобразуемых объектов (создание постоянного кэш-файла ускоряет загрузку объектов в карту, но потребляет некоторое пространство на диске).

  8. Нажмите кнопку ОК.


Разбиение растрового объекта

С помощью данного диалога имеется возможность разрезать исходный растровый объект на составные растровые объекты. Данная операция полезна в том случае, если исходный растр большого объема и работа с ним снижает производительность системы.

Для разделения растра:

  1. Если в карте загружены объекты с разных источников (локальные и серверные) из списка Выбирать из: укажите какой источник данных использовать.

  2. В том случае когда необходимо разбить только определенную группу растров, установите опцию Только выделенные (группа объектов должна быть заранее выделена).

  3. В разделе Растровые объекты: выберите с помощью галочек объекты для разбивки.

  4. Укажите папку для записи разделенных растров, воспользуйтесь кнопкой [image] .

  5. Из открывающегося списка выберите Выходной формат для разделенных растров.

  6. В разделе Разбить на части: укажите количество частей для разбивки каждого растрового объекта.

  7. При установке опции Создать группу раст будет разделен на части, а затем эти части сгруппированы в растровую группу, групп будет столько, сколько разбивается растров.

  8. Если необходимо создавать постоянные кэш-файлы для разделяемых объектов поставьте флажок Создать постоянный кэш (создание постоянного кэш-файла ускоряет загрузку объектов в карту, но потребляет некоторое пространство на диске).

  9. При установке опции Добавить в карту после процедуры разъединения объекты сразу будут добавлены в текущую карту.

  10. Нажмите кнопку ОК.

В результате выполненных действий на диске в указанной папке появятся следующие файлы:

  • *.ZRG - группы разделенных растровых объектов (файлы появятся в том случае, когда установлена опция Создать группу);

  • *_1.BMP, *_2.BMP... - разделенные растры их количество будет зависеть от количества исходных файлов и количества частей разбивки каждого растрового объекта;

  • *_1.ZRS, *_2.ZRS... - файлы - описатели разделенных растровых объектов.


Зональная статистика по растровым слоям

Использование зональной статистики позволяет вычислить статистику растрового изображения в области площадных объектов векторного слоя. Производится пересечение векторными объектами растра и подсчет статистики в рамках объектов. Статистика производится или по модели RGB или по значению пикселя. По значению пикселя анализ может производиться когда в файле хранится информация о температуре, то есть каждый пиксель это число с плавающей точкой, в котором записана какая то температура.

После подсчета статистики, если в семантической базе данных векторного слоя рамках объектов которого производится анализ отсутствуют поля для записи данных то они будут добавлены. Если же поля есть, то информация будет записана в них. В результате анализа могут быть добавлены следующие поля с готовой статистикой:

  • Count - количество;

  • Sum - сумма;

  • Mean - среднее;

  • Minimum - минимальное значение;

  • Maximum - максимальное значение.

Перед работой с зональной статистикой в карту должны быть загружены слой растра для анализа и векторный слой в области объектов которого будет производиться анализ. К объектам векторного слоя обязательно должна быть подключена семантическая база данных. Если анализ требуется не по всем объектам векторного слоя, то надо заранее выделить объекты в рамках которых по растру будет собрана зональная статистика.

Для запуска зональной статистики надо:

  1. Из списка Растровый слой выбрать слой для анализа.

  2. Из списка Векторный слой выбрать слой с набором полигонов. Если в слое были выделены объекты, то установить опцию Только выделенные.

  3. Выбрать параметры для статистики, для этого надо установить нужную опцию:

    • Растровый канал, при указании данной опции так же необходимо выбрать из списка канал для статистики.

    • Значение пикселя.

  4. В таблице проверить чтобы были установлены галочки напротив полей, статистика по которым должна быть записана в базу данных. Справа при необходимости отредактировать поле для записи.

  5. Нажать кнопку ОК.

[Примечание] Примечание

Далее для анализа статистики возможно создать тематическую раскраску.

.


Создание рельефа (TIN)

[Примечание] Примечание

Если из-за большого объёма данных создание рельефа в формате TIN невозможно, то в этом случае на основании этих же данных можно построить рельеф SRTM.

Для создания слоя рельефа необходим один или несколько векторных слоев с изображениями горизонталей или точек высот рельефа, с подключенной базой данных, в одном из полей которой заданы высоты объектов в метрах. Перед созданием рельефа слой должен быть предварительно загружен в карту.

[Примечание] Примечание

Видеоурок по созданию слоя рельефа можно посмотреть, пройдя по ссылке: https://www.politerm.com/videos/relief/relief_create/.

Для создания рельефа:

  1. Укажите слои, по которым будет создаваться рельеф. Рельеф может строиться по данным из нескольких слоев, например, слоя с горизонталями и слоя с точками высот. Информация об используемых слоях приводится в списке в верхней части диалога.

    Для добавления слоя данных:

    • Нажмите кнопку Данные. Откроется диалог выбора данных.

    • Выберите слой карты с данными для построения рельефа в поле Слой.

    • В списке Тип отметьте флажком тип объектов слоя к которым подключена база данных с высотами. Если база данных подключена к примитивам, то установите флажок напротив строки <Примитивы>.

    • В поле со списком Поле выберите поле базы данных слоя в котором записаны высоты.

    • Нажмите кнопку Выбрать чтобы закрыть диалог выбора и добавить выбранные данные в список (кнопка Отмена закроет диалог без сохранения изменений).

    • Если требуется добавить еще слой, повторите для него действия, описанные выше.

  2. В разделе Триангуляция выберите требуемый тип триангуляции

    • Делоне;

    • с ограничениями;

    • с улучшением рельефа.

    Чаще всего используется триангуляция с улучшением рельефа.

  3. Рельеф может быть создан с учётом вогнутой оболочки, нужно ли использовать данную опцию зависит от исходных данных и желаемого результата. Чтобы включить эту опцию, установите флажок Вогнутая оболочка. Затем из списка выберите и введите Минимальную длину ребра в метрах или Отношение длины ребра. Во втором случае длина определяется коэффициентом, самой большой длиной и самой малой длиной:

    Length = Ratio * (maxLen – minLen) + minLen,

    где Ratio — коэффициент, maxLen — самая большая длина, minLen — самая малая длина.

  4. По умолчанию, для создаваемого слоя рельефа используется система координат слоя из которого берутся данные для построения рельефа.

    При необходимости, можно изменить систему координат создаваемого слоя рельефа, для этого нажмите кнопку Изменить группы настроек Система координат и укажите требуемую систему координат и проекцию.

  5. В группе настроек Слой для записи задайте параметры создаваемого слоя рельефа.

    • В строке Имя файла нажмите кнопку Обзор... и в появившемся стандартном диалоге выбора файлов укажите путь и имя для файла слоя создаваемого рельефа.

    • В поле Название введите пользовательское название (по умолчанию оно совпадает с именем файла).

    • Из списка Цвет выберите цвет для создаваемого рельефа.

    • Для того чтобы слой после создания сразу загрузился в активную карту, установить флажок добавить в карту.

  6. Для запуска создания рельефа с указанными параметрами нажмите кнопку ОК.


Редактирование рельефа

Данное диалоговое окно отображает список ранее созданных на данном клиенте слоев рельефа. Чтобы загрузить параметры слоя для дальнейшего его редактирования, слой надо выделить в списке и нажать кнопку ОК.

Кнопка Отмена закроет диалог без изменений.


Построение зон затопления

Зона затопления строится по слою рельефа и затем сохраняется в отдельный векторный слой.

Для построения зон затопления:

  1. Сделайте активным слой рельефа.

  2. Установите режим выделения – [image] , и с помощью левой кнопки мыши укажите точку, с которой будут построены зоны.

  3. Выполните команду меню Карта|Рельеф|Зоны затопления. Отобразится диалог построения зон затопления с координатами указанной ранее точки в полях X м, Y м и Z м. Откроется диалог построения зон затопления.

  4. В полях Превышение уровня воды и Шаг по высоте задайте уровень превышения и шаг по высоте соответственно. Значения вводятся с клавиатуры. Если зоны затопления нужно строить только на одном уровне, установите флажок На одном уровне, в этом случае Шаг по высоте не задается.

  5. В строке Слой для записи нажмите кнопку [image] , укажите путь и имя файла создаваемого слоя изолиний в стандартном диалоге выбора файлов и нажмите кнопку Сохранить.

  6. В поле Название слоя введите пользовательское название для слоя затоплений.

  7. Зоны затопления могут быть построены в виде полилиний и/или полигонов, установите требуемый флажок и задайте цвет изолиний в полях Цвет от и до.

  8. При необходимости создать таблицу высот установите флажок Создавать таблицу высот.

  9. Если созданный слой зон затопления должен быть сразу добавлен в карту, то установите флажок Добавить слой в карту.

  10. Для завершения создания слоя затоплений нажмите кнопку ОК. Кнопка Отмена закроет диалоговое окно Построение зон затоплений без сохранения изменений.


Построение изолиний

Изолинии – это линии одного уровня. Построение изолиний – эффективный способ идентификации мест с одинаковым значением высоты. Изолинии полезны также при представлении поверхности, поскольку они позволяют визуализировать плоские и крутые участки поверхности по расстоянию между изолиниями.

В ZuluGIS изолинии строятся по слою рельефа и затем сохраняются в отдельный векторный слой.

К построенным изолиниям может быть применена операция сглаживания, после применения которой будут сглажены прямые ребра и ломаные углы изолиний, угловатая форма будет заменена плавными линиями.

[Примечание] Примечание

С построением изолиний по TIN рельефу можно познакомится в видеоуроке по ссылке: https://www.politerm.com/videos/relief/relief_create/.

Построение изолиний по SRTM рельефу рассмотрено в следующем видео: https://youtu.be/6i0QBX3zTes.

Изолинии строятся либо по всему слою, либо по выделенной заранее области. Если требуется построить изолинии по области, то для ее выделения надо заранее на панели Рельеф нажать кнопку Задать регион - [image] . После чего указать область построения. Область задается аналогично многоугольнику. Точки области фиксируются нажатием левой кнопки мыши, для окончания ввода региона выполните двойной щелчок левой кнопкой мыши, при этом первая и последняя точка будут соединены по прямой линии. Для отмены последней введенной точки щелкните правой кнопкой мыши и выберите в появившемся контекстном меню пункт Отменить последнюю точку.

Для построения изолиний:

  1. В списке Слой рельефа выберите слой для построения изолиний.

  2. Установите начальную высоту, конечную высоту, шаг рельефа в соответствующих полях. В том случае, если необходимо построение изолиний только на одном уровне, установите флажок На одном уровне и задайте начальную высоту.

  3. В строке Слой для записи нажмите кнопку Обзор..., укажите путь и имя файла создаваемого слоя изолиний в стандартном диалоге выбора файлов и нажмите кнопку Сохранить.

  4. В поле Название слоя введите пользовательское название для слоя изолиний.

  5. Изолинии могут быть построены в виде полилиний и/или полигонов, установите требуемый флажок и задайте цвет изолиний в полях Цвет от и до.

  6. Если построенные изолинии требуется сгладить, то надо поставить опцию Сглаживание и для задания параметров сглаживания нажать соответствующую кнопку. Параметры сглаживания настраиваются аналогично параметрам сглаживания объектов, подробно о настройках можно узнать в разделе «Сглаживание геометрии объекта».

  7. При необходимости создать таблицу высот установите флажок Создавать таблицу высот.

  8. Если созданный слой изолиний должен быть сразу добавлен в карту, то установите флажок Добавить слой в карту.

  9. Для завершения создания слоя изолиний нажмите кнопку ОК. Кнопка Отмена закроет диалоговое окно Построение изолиний без сохранения изменений.


Вычисление площади и объема

Вычисление площадей и объемов замкнутых областей на карте с учетом рельефа возможно только в случае использования TIN-рельефа. Вы можете указать область самостоятельно или воспользоваться отдельным слоем с уже заданными областями.

Для вычисления площади и объема:

  1. Нажмите на панели инструментов кнопку Задать регион - [image] .

  2. Укажите область для вычисления:

    • Новая область задается аналогично многоугольнику. Точки области фиксируются нажатием левой кнопки мыши, для окончания ввода выполните двойной щелчок левой кнопкой мыши, при этом первая и последняя точка будут соединены по прямой линии. Для отмены последней введенной точки щелкните правой кнопкой мыши и выберите в появившемся контекстном меню пункт Отменить последнюю точку.

    • Так же для указания области может использоваться отдельный слой с уже ранее нанесенными областями. Области в слое должны быть площадными объектами (полигонами). Для использования готовой области из другого слоя нажмите клавишу Alt и не отпуская ее сделайте щелчок левой кнопкой мыши по области слоя, область выделится.

  3. Выполните команду меню Карта|Рельеф|Площадь, Объем. Откроется диалог вычисления площадей и объемов.

  4. В окне Уровень разреза укажите уровень разреза в метрах.

  5. Нажмите кнопку Расчет, после чего в полях диалога отобразятся результаты вычислений.

  6. Если результаты необходимо отобразить на карте и записать в отдельный слой, то для этого необходимо задать цвета областей в соответствующих разделах. Далее, в строке Слой для записи нажмите кнопку [image] , укажите путь, имя файла создаваемого слоя. В поле Название слоя введите его пользовательское название.

  7. Если созданный слой должен быть сразу загружен в активную карту, то установите флажок Добавить слой в карту, после чего нажмите кнопку Записать ответ в слой.

  8. Для закрытия окна Вычисление площади и объема нажмите кнопку Выход.


Построение растра по триангуляции

С помощью данного диалога имеется возможность построить растровое изображение по слою рельефа. Для построения растра рельефа:

  1. В поле со списком Слой выберите слой рельефа, по которому требуется создать растр.

  2. В поле Число точек выберите число точек формируемого растра (по большей стороне создаваемого растра). При выбранном пункте «Авто» количество точек подбирается автоматически.

  3. Если требуется раскраска растра по высоте, установите флажок в группе настроек Раскраска по высоте и задайте цвета для раскраски в полях Цвет от и до.

  4. Для добавления отмывки рельефа (освещения ) в растр установите флажок группы настроек Отмывка рельефа и укажите масштаб высоты, направление источника света (в градусах) и его угол над горизонтом (в градусах) в соответствующих полях. В поле Уровень задается коэффициент смешения раскраски по высоте (если она используется) и отмывки. Значение может изменяться в пределах от «0» до «100», при значении «0» – применяется только раскраска, при «100» – только отмывка.

  5. В строке Растровый объект нажмите кнопку [image] и укажите путь и имя файла для создаваемого файла растрового изображения.

  6. Если требуется добавить в карту созданный растровый объект, установите флажок Добавить слой в карту.

  7. Для завершения создания растра нажмите кнопку ОК. Кнопка Отмена закроет диалоговое окно Создание растра по триангуляции без сохранения изменений.


Сохранение фрагмента TIN рельефа

Используя данную операцию возможно скопировать указанный фрагмент рельефа в новый слой. Слой из которого требуется сохранить фрагмент рельефа должен быть загружен в активную карту. И на нем должна быть указана область фрагмента (кнопка [image] ), далее:

  1. В диалоге Сохранение фрагмента рельефа по области в строке Слой для записи укажите название и местоположение слоя для записи фрагмента. Для этого нажмите кнопку Обзор..., выберите каталог и в строке Имя файла введите название. Нажмите кнопку Сохранить. Если исходный слой был локальной версии, то его сохранение возможно как на сервер (кнопка Серверы геоданных) так и на локальную машину. Фрагмент серверного слоя можно сохранить только на сервер. При желании можно так же заменить пользовательское название создаваемого слоя (строка Название слоя).

  2. Из списка Цвет выберите цвет для фрагмента.

  3. Установите флажок Добавить в карту для автоматического добавления слоя в текущую карту.

  4. Для запуска копирования фрагмента нажмите кнопку ОК.

В результате проделанных действий будет создан новый слой рельефа с выбранным фрагментом.


Создание слоя высотных отметок в формате SRTM

Для снятия геодезических отметок система ZuluGIS имеет возможность использовать файлы высотных отметок SRTM3. SRTM (Shuttle radar topographic mission) - это радарная интерферометрическая съемка поверхности земного шара.

Для создания слоя высотных отметок необходимы файлы съемки формата *.hgt.

Чтобы создать слой высотных отметок:

  1. В строке Название слоя укажите пользовательское название для слоя высотных отметок.

  2. С правой стороны от строки Папка с файлами HGT нажмите кнопку Обзор и укажите каталог, в котором расположены файлы съемки (*.hgt).

  3. Нажмите кнопку Сохранить, задайте имя файла для слоя высотных отметок.

  4. Если созданный слой необходимо сразу добавить в карту то установите опцию добавить в карту.

  5. Нажатие кнопки ОК запустит создание слоя высотных отметок на основании указанных данных.

В результате проделанных действий будет создан файл с расширением *.zww.


Вкладка Настройка шаблона

Предусмотрено создание шаблонов для экспорта данных в Excel как с использованием встроенного механизма системы ZuluGIS, так и с помощью файлов шаблонов программы MS Excel, формата .xlt. Для создания шаблона на базе механизма отчетов ZuluGIS с ручным выбором полей, установите переключатель Использовать собственные настройки. Создание подобных отчетов освещено в разделе «Просмотр и печать отчетов».

Для вывода отчетов в виде таблиц с произвольным оформлением с использованием основных средств оформления программы Excel установите переключатель Использовать настройки шаблона Excel (подробно см. «Файл шаблона в формате .xlt»).

Для создания шаблона на базе файла шаблона MS Excel:

  1. В поле Файл шаблона укажите путь к файлу шаблона. Для этого, нажмите кнопку [image] справа от поля и укажите в открывшемся диалоге выбора файлов путь к файлу шаблона в формате .xlt.

  2. С помощью переключателя Тип отчета укажите тип отчета формируемого шаблоном, Табличный, либо Свободной формы (подробно см. «Файл шаблона в формате .xlt»), при выборе значения Свободной формы в поле Диапазон области данных также выбирается диапазон шаблона из которого формируется запись отчета.

  3. В таблице Соответствие полей и диапазонов шаблона указывается в каких именованных диапазонах шаблона отображаются поля базы данных. В столбце Поля перечислены поля базы данных, а в столбце Диапазон указываются соответствующие им диапазоны шаблона. По умолчанию, для полей подставляются диапазоны с соответствующими названиями (знаки подчеркивания в названии диапазона рассматриваются как пробелы).

По завершению настройки шаблона нажмите кнопку ОК, чтобы сохранить изменения и закрыть диалог.


Вкладка Настройка полей

Данная вкладка служит для ручной настройки полей, выводимых в отчёт. В Редакторе шаблона должна быть выбрана опция Использовать собственные настройки.

В списке полей галочкой отмечаются поля для вывода в отчет. Если нужно вывести все поля, то надо установить флажок Выбрать все поля, при этом автоматически будут отмечены все поля из располагающегося под этим флажком списка. Если же вместо пользовательских названий полей необходимо, чтобы отображались реальные названия полей, взятые из таблиц, то надо установить флажок Физическое имя поля.

Параметры шрифтов для заголовков и для данных задаются нажатием на кнопку Шрифт… в соответствующем разделе. Цвета устанавливаются выбором из открывающегося списка.

В окне внутренняя и внешняя рамка имеется возможность выбрать из списка толщину внешней и внутренней рамки.

Если установлена опция Использовать перенос слов, тогда слова будут в ячейке


Вкладка Заголовок

В данной вкладке настраивается заголовок "шапка" отчётного документа:

  • текст заголовка отчёта;

  • ориентация заголовка;

  • параметры шрифта (шрифт, цвет, начертание и прочие).


Выборка данных по условию

Выборка производится по выбранным полям одного из слоев карты. Для выборки надо:

  1. В поле со списком Слой выбрать слой, в котором будет производиться выборка.

  2. В списке Поля для выборки флажками отметить поля слоя для выборки.

    В каждом слое доступна группа полей «Геометрия» с полями геометрических свойств слоя, в слоях с базами данных доступны для выбора и поля баз данных слоя.

    [Примечание] Примечание

    Для быстрого поиска нужных полей в списке введите начало названия требуемого поля в поисковой строке над списком, в списке будут отображаться только поля, начинающиеся с введенных символов.

  3. Составить текст запроса в группе полей Условия выборки. Текст запроса вводится вручную, в поле ввода, либо конструируется визуально, кнопками панели инструментов, над полем ввода. Запрос состоит из набора условных выражений, соединяемых булевыми операторами (И/ИЛИ/НЕ), условные выражения можно группировать с помощью скобок.

  4. При необходимости выборки с учетом регистра установить флажок Учитывать регистр.

  5. При необходимости выборки объектов только из выделенной группы установить флажок Выбирать из выделенных объектов.

Подробней о синтаксисе условий можно узнать «Выборка данных по условию».


Окно редактора SQL запросов

Диалоговое окно редактора SQL запрос используется для написания и выполнения SQL запросов. SQL позволяет делать запросы сразу ко всем слоям и подключенным к ним базам данных и анализировать пространственное отношение между объектами на карте.

В программе используется диалект языка SQL основанный на диалекте Transact-SQL, разработанном компаниями Microsoft и Sybase (см. http://msdn.microsoft.com/en-us/library/bb510741(SQL.100).aspx и http://infocenter.sybase.com/help/index.jsp?topic=/com.sybase.help.ase_15.0.sqlug/html/sqlug/title.htm). Используемый диалект дополнен в соответствии с OGC расширением языка SQL, информация о котором приводится по адресам http://www.opengeospatial.org/standards/sfa (общая архитектура) и http://www.opengeospatial.org/standards/sfs (SQL расширение).

Для удобства написания кода используется IntelliSense — технология автодополнения, дописывает название функции при вводе начальных букв. Кроме прямого назначения IntelliSense используется для доступа к документации и для устранения неоднозначности в именах переменных, функций и методов. Подсветка синтаксиса — выделение синтаксических конструкций текста с использованием различных цветов, шрифтов и начертаний. Обычно применяется для облегчения чтения исходного текста компьютерных программ, улучшения визуального восприятия.

Окно редактора SQL запросов

Рисунок 1. Окно редактора SQL запросов

Диалог состоит из нескольких областей:

  1. Панель управления — содержит команды и кнопки, для сохранения, загрузки и выполнения SQL запроса.

  2. Область текста запроса — здесь вводится и редактируется текст SQL запроса. области ввода задать текст SQL запроса.

  3. Навигатор по полям карты Источник — позволяет быстро добавить поле в текст запроса. Для добавления запроса данных поля, выберите в списке требуемый слой, БД и выполните двойной щелчок по названию поля — запрос будет добавлен в область ввода.

    [Примечание] Примечание

    Для быстрого поиска нужных полей, надо ввести начало названия требуемого поля в поисковой строке сверху, в списке будут отображаться только поля, начинающиеся с введенных символов.

  4. Область Ответ — отображает результаты запроса в виде браузера базы данных и ошибки выполнения запроса. Содержит кнопки для работы с результатами, экспорт, печать...

Чтобы выполнить SQL запрос надо:

  1. Ввести текст SQL запроса или загрузить запрос из файла с диска (Файл|Открыть).

  2. Нажать кнопку Выполнить на панели инструментов.

    В результате в области Ответ в нижней части диалога отобразится панель данных с результатами запроса.

В диалоге SQL запросов предусмотрено сохранение текущего запроса в файл, открытие запроса из файла и создание нового запроса:

  • Для открытия запроса из файла (в формате .sql) выполните команду меню Файл|Открыть, или нажмите кнопку панели инструментов – [image] и выберите требуемый файл в стандартном диалоге выбора файлов;

  • Для сохранения текущего запроса в файле (формата .sql) выполните команду меню Файл|Сохранить, или нажмите кнопку панели инструментов – [image] и задайте требуемое название файла в стандартном диалоге сохранения файлов.

  • Для создания нового запроса выполните команду меню Файл|Новый запрос, либо нажмите кнопку панели инструментов [image] .


Сохранение TIN в формат SRTM

Возможно сохранить рельеф TIN формата в одно секундный формат - SRTM1 или трех секундный - SRTM3. В первом варианте точность данных будет выше, но и соответственно будет больший объем данных.

Для сохранения TIN рельефа в формат SRTM:

  1. Из списка Экспортируемый слой выберите слой, на основе которого будет создан SRTM слой.

  2. Справа от строки Имя файла описателя нажмите кнопку Обзор... и в открывшемся окне укажите путь и имя для файла описателя создаваемого рельефа.

  3. В соответствующую строку введите название слою.

  4. Из списка Формат выберите SRTM1 или SRTM3.

  5. Справа от строки Папка с файлами HGT нажмите кнопку Обзор... и укажите папку куда будут сохранены создаваемые файлы HGT.

  6. Если установить опцию Добавить в карту, то слой будет создан и добавлен в текущую карту.

  7. Для запуска процедуры сохранение нажмите кнопку ОК.

В результате в указанных папках будет создан описатель и файлы формата *.hgt.


Просмотр таблицы

Панель предназначена для просмотра таблицы базы данных, в ней возможны следующие операции:

  • Добавить запись - для добавления новой записи надо нажать кнопку [image] , после чего курсор переместится в конец таблицы на добавленную пустую запись (строку).

  • Удалить запись - для удаления записи ее необходимо выделить и затем нажать кнопку [image] .

  • Найти информацию - для поиска нужной информации надо нажать кнопку [image] и в появившемся окне ввести данные для поиска. Поиск будет производиться по тому столбцу, на котором в данный момент находится курсор мыши.

  • Открыть следующую таблицу - открытие следующей таблицы осуществляется нажатием кнопки [image] .

  • Закрыть панель просмотра - для того чтобы закрыть панель просмотра таблицы надо нажать кнопку Закрыть.

[Примечание] Примечание

Вводить и редактировать записи таблицы удобней через окно семантической информации (см. «Общие сведения об окне семантической информации»).


Копирование таблицы

С помощью данного диалога возможно произвести копирование таблицы.

Для копирования таблицы:

  1. В строке Таблица указана таблица, которая будет скопирована. В строке Новая таблица необходимо задать имя файла новой таблицы (воспользуйтесь кнопкой Обзор... для открытия стандартного окна выбора файла).

  2. Для завершения операции нажмите кнопку OK.


Создание таблицы

Данная панель предназначена для создания новой таблицы. В панели создания таблицы необходимо задать информацию о полях новой таблицы, которая заносится в список Поля таблицы, организованный в табличной форме.

Всегда при создании таблицы в список полей автоматически добавляется поле «Sys». Это поле нужно для таблиц, которые должны быть связаны непосредственно с объектами слоя. Данное поле индексированное, его так же называют ключевым или уникальным полем, в нем не допускается ввод повторяющихся значений. Уникальность поля указывается стоящим напротив поля ключиком [image] . В системе по умолчанию оно используется для связи графической и семантической информации. Если у таблиц, связанных с объектами данное поле удалить, то при попытке изменить таблицу будет выдана ошибка: «не удаётся обновить данные, т.к. базовая таблица * не проиндексирована».

Для таблиц, не связанных напрямую с объектами карты это поле можно удалить.

Далее для набора полей таблицы надо:

  1. Нажать кнопку Добавить поле, после чего в таблице появится новая строка. В данной строке в столбце Имя поля ввести название поля.

  2. Список возможных типов полей зависит от используемой базы данных, а также от выбранного "режима": обычного или экспертного.

    Наиболее часто используемые типы данных:

    • Строковое - символьный тип данных, имеет диапазон от 0 до 255 символов (используется как правило для наименований).

    • Короткое целое - целочисленный цифровой тип данных, позволяет хранить целые числа диапазоном от -32768 до 32767.

    • Длинное целое - цифровой тип данных, позволяет хранить целые числа диапазоном от -2147483648 до 2147483647.

    • Вещественное - цифровой тип данных, имеет диапазон приблизительно [-1.7x10^-308, -1.7x10^+308] и [+1.7x10^-308, +1.7x10^+308] (используется для тех данных, у которых по мимо целой части может быть еще и дробная).

    • Длинный текст - строковый тип данных. Часто используемый вариант при хранении больших текстовых данных.

    • Логическое - может сохранять следующие значения: true/да или false/нет.

    • BLOB - специальный тип данных, предназначенный для хранения изображений, текстов, аудио и видео;

    • Дата и время - данный тип данных предназначен для хранения даты и времени. Если требуется только дата, то испольщуйте тип Date, он доступен в экспертном режиме.

  3. В столбце Длина для строкового типа при необходимости исправить максимальное количество символов, по умолчанию оно устанавливается 50.

  4. С помощью кнопки Добавить поле, которая добавляет новую строку в конец списка и кнопки Вставить поле, которая вставляет строку в список полей перед выделенной, набрать остальные необходимые строки таблицы. Если была добавлена лишняя строка, то ее можно удалить с помощью кнопки Удалить поле.

  5. Для сохранения таблицы нажать кнопку Сохранить.


Настройка параметров импорта

С помощью данного диалога настраиваются параметры интерпретации текстового файла при импорте.

Для настройки необходимо указать:

  1. В списке Разделитель полей выбрать символ, который используется в качестве разделителя полей записи.

  2. Если строковые значения заключены в кавычки, то в списке Ограничитель текста выбрать тип кавычек (двойные или одинарные) или установить параметр {отсутствует}.

  3. Если первая строка текстового файла содержит названия полей, то установить флажок Первая строка содержит имена полей. При этом все заданные настройки будут отображаться в разделе Предварительный просмотр.

  4. После задания всех установок нажать кнопку Далее.


Настройка параметров импорта

В данном диалоговом окне необходимо задать имена полей, типы полей, а также для строковых полей задать длину поля:

  1. Для задания имени и длинны поля необходимо щелкнуть мышью в нужной ячейке. Система перейдет в режим редактирования текста ячейки (имена полей желательно задавать латинскими буквами).

  2. Для изменения типа поля (по умолчанию тип задан Строковым) необходимо сделать щелчок мыши на нужной ячейке и из открывающегося списка выбрать нужный тип.

  3. Для запуска процедуры импорта нажмите кнопку Готово. Если система не сможет импортировать все данные из текстового файла в таблицу, будет выдано соответствующее сообщение.


Диалог выбора таблиц

Выбор таблиц для импорта

Рисунок 1. Выбор таблиц для импорта

Окно Выбора таблиц открывается при импорте таблицы, если в импортируемой базе данных хранится нескольких таблиц:

Следует отметить необходимые таблицы для импорта или использовать опцию Отметить всё.

В последнем столбце указывается новое имя таблицы в конечной базе данных.


Настройка параметров импорта

В данном диалоговом окне в строке Таблица необходимо указать полный путь к файлу таблицы Paradox, задать его имя (используйте кнопку Обзор... для открытия стандартного окна выбора файла) и выбрать дополнительную опцию:

  • создать таблицу с новой структурой;

  • заменить данные в имеющейся таблице;

  • добавить данные в имеющуюся таблицу.

Для перехода к следующему этапу импорта нажмите кнопку Далее.


Переименование таблицы

Данная функция позволяет переименовать файл таблицы.

Для переименования существующей таблицы надо:

  1. В строке Новое имя таблицы задать новое имя для таблицы.

  2. Нажать кнопку OK.


Параметры текстового объекта

В данной вкладке задаются параметры для простого текстового объекта:

  • Высота - задается высота на местности, то есть размер текста на карте (см);

  • Угол - задается угол наклона текста (град.);

  • Текст - задается/изменяется содержание текста;

    [Примечание] Примечание

    В том случае, если необходимо чтобы текст в одном текстовом объекте был разных цветов, то нужно указать с помощью специального тэга цвет в шестнадцатеричной системе в палитре GBR.

    Условие для цвета задается следующим образом:

    {\C цвет} текст {\C цвет} текст...

    Основные цвета в шестнадцатеричной системе в палитре GBR:

    • 000000 - черный;

    • 0000FF- красный;

    • 008000 - зеленый;

    • FF0000 - синий;

    • 00FFFF - желтый;

    • 808080 - серый;

    • FFFFFF - белый.

    Рассмотрим задание цвета на конкретном примере, предположим необходимо, чтобы название улицы отображалось следующим образом: , то есть слово улица черным цветом, часть названия красным, а затем опять черным цветом. Для вывода данных таким образом в окне Текст необходимо ввести:

    улица {\C0000FF}Большая{\C} Конюшенная

    Если в приведенном выше примере название улицы нужно было бы все отображать красным цветом, то конечный тэг {\C} для закрытия цвета можно было бы не вводить:

    улица {\C0000FF}Большая Конюшенная

  • Положение относительно точки привязки - в данном разделе выбирается выравнивание текстового объекта относительно точки привязки: по горизонтали (лево, центр, право) и по вертикали (лево, центр, право);

  • Выравнивание многострочного текста - при многострочном тексте можно задать его выравнивание (лево, центр, право);

  • кнопка Символы вызывает диалоговое окно Выбор символов, которое позволяет вставить специальные символы, находящиеся в выбранном шрифте (см. «Ввод текста»).


Подключение и отключение тематической раскраски

[Примечание] Примечание

Порядок отображения тем на карте определяется порядком их включения. Последняя включенная тематическая окраска будет отображаться самой последней, и соответственно возможно перекрывать предыдущие темы.

Для подключения тематического файла к слою:

  1. Подведите курсор к тематической раскраске, которую надо подключить и сделайте двойной щелчок левой кнопкой мыши. Подключенная раскраска будет помечена иконкой - [image] .

  2. Для подтверждения подключения темы нажмите кнопку Применить или кнопку ОК (кнопка ОК подтвердит произведенные изменения и закроет диалоговое окно Тематические раскраски).

    [Примечание] Примечание

    Подключить тему можно нажав правой кнопкой мыши по названию темы в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Подключить или сделав один щелчок левой кнопкой мыши по его иконке [image] .

Для отключения тематической раскраски:

  1. Подведите курсор к тематической раскраске, которую надо отключить и сделайте двойной щелчок левой кнопкой мыши. Отключенная тема будет помечена иконкой серого цвета - [image] .

  2. Для подтверждения отключения темы нажмите кнопку Применить или кнопку ОК (кнопка ОК подтвердит произведенные изменения и закроет диалоговое окно Тематические раскраски).

С помощью кнопки Вернуть можно произвести возврат диалога Тематические раскраски в исходное состояние.

Кнопка Удалить удаляет выделенную в диалоге тематическую раскраску (шаблон при этом остается). Подробней об удалении тематических раскрасок «Удаление темы».

Кнопка Дубль... копирует тематическую раскраску.

Если в данных, по которым была создана тематическая раскраска произошли изменения, то для обновления раскраски надо нажать кнопку Обновить. Подробней об обновлении тематических раскрасок «Обновление темы».

Кнопка Изменить открывает тематический фильтр выделенной раскраски.

Кнопка Переименовать позволяет переименовать выделенную раскраску.

Кнопка Импорт откроет диалог импорта тематических раскрасок.


Создание тематического файла

Прежде чем создавать тематический файл предварительно необходимо загрузить в карту слой, для которого будет создаваться тематическая раскраска. Так же к слою должна быть подключена база данных, так как именно на основе данных из базы будет создаваться тема.

Для создания нового тематического файла:

  1. Из списка Слой выберите слой, для которого создается тема.

  2. С правой стороны от списка Фильтр нажмите кнопку Редактор и в открывшемся диалоговом окне настройте и сохраните новый тематический фильтр (начиная с пункта 3). Если фильтр был ранее уже создан, то для подключения к теме его надо выбрать из списка.

  3. После того как тематический фильтр уже создан, в строке Тема вместо надписи <Новая> введите название темы. Желательно, чтобы название коротко раскрывало смысл данной «раскраски» слоя. Именно это название в дальнейшем будет отображаться в списке тематических раскрасок. Если надо переписать уже существующею тему, которая ранее подключалась к выбранному слою, то ее название выбирается из открывающегося списка.

  4. Чтобы при изменении значений в семантической базе данных тематическая раскраска будет обновляться автоматически установите опцию Обновлять автоматически.

  5. Для подключения темы сразу после создания отметьте опцию Подключить к карте.

  6. Создание темы завершается нажатием кнопки OK.

Если все настройки были произведены верно, то тема будет подключена к слою.

Кнопка Отмена закроет диалог без создания темы.


Тематический фильтр

В тематическом фильтре задаются параметры, по которым будет производиться изменение внешнего вида объектов. При этом в одном фильтре условия могут быть заданы по разным семантическим базам.

Создание тематического фильтра

Для создания тематического фильтра :

  1. Нажмите кнопку [image] Слой..., в появившемся стандартном окне выбора файла выберите имя слоя, для которого будет создаваться тематическая раскраска.

    Данный диалог также можно вызвать, нажав правой кнопкой мыши по разделу Темы в панели Рабочее место и выбрав в открывшемся контекстном меню пункт Редактор фильтров.

  2. В строке Шаблон вместо слова <Новый> задайте пользовательское название шаблона тематического фильтра. Желательно, чтобы данное название отражало смысл раскраски.

  3. В фильтре может быть задано как одно условие, так и несколько, для каждого условия есть возможность задать имя (данное поле не обязательно). Имя условия вводится в строку Имя.

  4. Из списка База выберите базу данных, на основе которой будут настраиваться условия для тематического отображения. Список будет отображать те базы данных, которые используются примитивами или типовыми объектами ранее выбранного слоя. Если в базе создано несколько запросов, в поле Запрос также требуется выбрать нужный запрос.

    После выбора базы и запроса левая колонка таблицы диалога заполнится пользовательскими названиями полей выбранной базы данных.

  5. В правой колонке таблицы напротив желаемых полей задайте первое условие для тематического фильтра. При задании условий можно использовать идентификаторы полей (F1, F2, ...), константы, функции и операторы, их список вызывается нажатием на кнопку [image] . Синтаксис условий аналогичен синтаксису в окне запросов по семантической базе данных. Условия могут быть заданы как по одному полю, так и по нескольким одновременно.

  6. Если у объектов, для которых создается тематический фильтр, имеется несколько режимов, то можно настроить раскраску только для определенных режимов. При этом раскраска может применяться как к указанным режимам, так и к конкретным условиям фильтра режимов. В первом случае, например, можно изменить внешний вид только для работающих потребителей, а для отключенных потребителей раскраску не применять. Во втором случае раскраска может применяться, например, к включенным потребителям, удовлетворяющим определенным, прописанным в фильтре условиям.

    Для того чтобы весь тематический фильтр применялся к определенным режимам, надо нажать кнопку Режимы общие, затем установить флажок напротив нужных режимов.

    Если же фильтр должен применяться к режимам, удовлетворяющим определенным условиям, то надо нажать кнопку Режимы условия и затем установить флажок напротив нужных режимов. В этом случае раскраска будет применена к выбранным режимам и условиям, которые были заданы на предыдущем этапе (пункт 5).

  7. В зависимости от графического вида объектов, для которых создается раскраска, выберите соответствующую вкладку и задайте желаемые параметры отображения (цвет, стиль, толщину и т.д.), соответствующие первому запросу. При задании параметров указывайте только те из них, которые интересуют (например, только цвет узора). Остальные при отображении слоя будут браться такими же, как если бы тема к слою не была подключена. Если в окошке отображается -1 или [image] , это означает, что значение параметра не будет меняться и останется исходным.

    • Во вкладке Площадные параметры задаются для площадных объектов – полигонов (домов, кварталов, водоемов и т.д.). Для каждого условия можно задать как цвет, стиль заливки, стиль и цвет границы площадного объекта и прозрачность, так и символ заданного размера с заданными условиями масштабирования. Точки вывода символов внутри площадных объектов при создании раскраски из диалога Создание тематической раскраски определяются автоматически. Символ должен быть заранее создан в структуре слоя.

    • Во вкладке Линейные задаются параметры для линейных объектов (участков, ж.д. дорог и т.д.). Можно задать цвет, выбрать стиль ( [image] ), толщину на экране и при печати.

      Помимо этого, возможно установить масштабирование линии в зависимости от масштаба карты. Масштабирование будет производится после ведения коэффициента масштабирования в строку Масштаб1:. Если для тематической окраски введено значение толщины линии на экране, то коэффициент будет применяться к данному значению. Если он не введен, стоит -1, то коэффициент будет применен к исходным параметрам линейных объектов. Масштаб указывается аналогично масштабу, который задается для типовых объектов при создании режима, а для простых объектов он указывается перед их нанесением.

      [Примечание] Примечание

      При подключении тематической раскраски с указанным коэффициентом масштаба линия будет масштабироваться независимо от того, установлена ли опция масштабирования в ее исходный параметрах.

    • Во вкладке Символьные задаются параметры для символьных объектов (потребителей, узлов, источников и других). Задать можно цвет, размер и признак масштабируемости. Параметр цвет для символа будет применен только в том случае, если изначальный цвет символа был задан как авто.

      Для символов, у которых был задан определенный цвет, требуется создать новый символ, которым будут отображены объекты, удовлетворяющие заданным условиям. Для создания нового символа надо нажать кнопку Новый символ и нарисовать его в редакторе символов. Кнопка Изменить символ также откроет окно редактора символов, но с загруженным в него текущим символом для его изменения.

  8. Также помимо ранее указанных характеристик могут быть скрыты объекты или надписи, подключенные к ним. Для включения этих параметров установите галочку напротив нужной опции:

    • Невидимый объект – объекты, соответствующие заданному условию станут невидимыми;

    • Невидимая надпись – надписи, подключенные к объектам, соответствующим заданному условию, станут невидимыми.

  9. Для ввода следующего условия запроса нажмите кнопку [image] . Таблица очистится, далее повторите пункты с 4 по 8. Пункт 4 повторяется в том случае, если надо задать условия запроса по другой базе данных, используемой выбранным слоем. Пункт 7 повторяется, если раскраска задается определенному режиму по условиям.

    Количество запросов не ограничено. Запросы при подключении тематической раскраски будут выполняться последовательно, начиная с первого. Соответственно, объекты, удовлетворившие условиям запроса, получат параметры отображения в той же последовательности. По этой причине рекомендуется более общие запросы ставить вначале.

    Например, если мы хотим покрасить все жилые дома красным, а жилые пятиэтажные дома зеленым, то в поле базы данных по адресам «Тип» первым должен стоять запрос *КЖ*, а вторым 5КЖ. В противном случае более общее условие перекроет более конкретное.

    При необходимости запросы можно поменять местами, для этого используются кнопки:

    • Вверх, [image] Вниз – изменить местоположение текущего условия на одно положение вверх или вниз соответственно;

    • Вставить – вставить новое условие перед текущим условием;

    • Удалить – удалить текущее условие запроса из списка запросов;

    • Очистить – очистить все строки текущего условия.

    Перемещаться между запросами можно, используя следующие кнопки:

    • , [image] – переместиться к предыдущему/следующему запросу, соответственно;

    • , [image] – переместиться к первому/последнему запросу, соответственно.

  10. Для завершения создания шаблона тематического фильтра нажать кнопку [image] Сохранить....

  11. Закрыть окно создания тематического фильтра с помощью кнопки Закрыть.

Если диалог Тематический фильтр был вызван из диалога Создание тематической раскраски, то после нажатия кнопки Закрыть будет произведен возврат к нему.

Копирование тематического фильтра

Для копирования фильтра надо:

  1. Проверить чтобы в диалоге был загружен фильтр для копирования. Сменить фильтр в рамках указанного слоя можно выбрав его из списка Шаблон.

  2. Нажать кнопку Дублировать....

  3. Ввести имя для копии тематического фильтра. Чтобы подтвердить копирование нажать кнопку ОК. Кнопка Отмена закроет окно задания имени без изменений.

В результате проделанных действий будет создана копия шаблона тематического фильтра, которую заем можно использовать в новой теме. Для этого при ее создании надо не задавать параметры фильтра заново а выбрать из списка Шаблон нужный фильтр. При необходимости скопированный фильтр имеется возможность изменить.


Управление кэшированием данных Tile-сервера

Система ZuluGIS позволяет проводить дополнительное управление процессом кэшированием данных с Tile-сервера – выполнять принудительное кэширование всех, или части графических данных, удалять отдельные слои данных, либо весь кэш (подробней о кэшировании можно узнать в разделе «Кэширование данных Tile-сервера»). Управление кэшированием на удаленном сервере ZuluServer возможно только при наличии соответствующих прав.

Для выполнения принудительного кэширования данных Tile-сервера выполните следующие действия:

  1. Нажмите кнопку [image] справа от поля Имя файла и выберите файл-описателя для доступа к требуемому Tile-серверу. В поле Название отобразится название сервера, а в поле Папка кэша путь к папке кэша.

  2. В полях Диапазон уровней укажите минимальный и максимальный уровни диапазона кэшируемых тайлов.

  3. В поле Область кэширования укажите, какую часть карты следует кэшировать – отображаемую в данный момент область карты, габариты карты полностью, в пределах габаритов какого-либо слоя карты, либо его объектов.

  4. Если в качестве области кэширования были выбраны габариты слоя, или его объектов, в поле Слой требуется выбрать необходимый слой. Также можно установить флажок Только выделенные объекты, чтобы в слое учитывались только выделенные его объекты.

  5. Нажмите кнопку Кэшировать чтобы выполнить кэширования. Процесс может занять значительное время, особенно если выбран большой диапазон уровней.

Для того чтобы удалить из кэша сервера часть уровней тайлов:

  1. Нажмите кнопку [image] справа от поля Имя файла и выберите файл-описателя для доступа к требуемому Tile-серверу. В поле Название отобразится название сервера, а в поле Папка кэша путь к папке кэша.

  2. В полях Диапазон уровней укажите минимальный и максимальный уровни диапазона удаляемых из кэша тайлов.

  3. Нажмите кнопку Удалить уровни и подтвердите удаление указанного диапазона тайлов.

Чтобы полностью удалить кэш Tile-сервера:

  1. Нажмите кнопку [image] справа от поля Имя файла и выберите файл-описателя для доступа к требуемому Tile-серверу. В поле Название отобразится название сервера, а в поле Папка кэша путь к папке кэша.

  2. Нажмите кнопку Удалить весь кэш и подтвердите удаление.

По завершении работы с кэшем, нажмите кнопку Выход, для того чтобы закрыть диалог.


Создание данных для Tile-сервера

Можно разделить растровые данные карты на плитки, которые сохраняются в формате кэша программы SAS.Планета. Для этого используется диалоговое окно Создание данных для Tile-сервера. Нарезка выполняется для текущей карты, отображаемой в ZuluGIS.

Диалог создания данных для Tile-сервера

Рисунок 1. Диалог создания данных для Tile-сервера

Параметры нарезки карты хранятся в файле описателя zww. Допускается создание новых нарезок и правка уже существующих.

Для создания новой нарезки карты на плитки:

  1. Чтобы создать новый файл описателя, нажмите кнопку Новый. В диалоговом окне создания файла укажите путь и название для нового файла. Путь можно указать как на локальном компьютере, так и на сервере геоданных Zulu Server. Название файла описателя отобразится в поле Имя файла описателя.

  2. В поле Название слоя задайте имя слоя, в котором будут отображаться нарезанные данные при их открытии в карте с помощью данного файла описателя.

  3. Выберите каталог, в котором сохраняются нарезанные плитки. Если файл описателя создан на локальном компьютере, нажмите кнопку [image] справа от поля Папка для данных и выберите требуемый каталог. Если каталог уже занят кэшем SAS-планета действие запрещается. Если файл описателя был создан на сервер геоданных, кнопка справа от поля Папка для данных будет неактивна, – введите в поле название подпапки, которая будет создана на сервере для хранения плиток.

  4. В поле со списком Проекция выберите проекцию, в которой сохраняются нарезаемые данные.

  5. В поле со списком Формат растра выберите тип графических файлов в которых сохраняются плитки.

  6. При установке флажка Прозрачность при нарезке плиток будет сохраняться параметр прозрачности нарезаемых графических данных.

  7. В полях Диапазон уровней укажите минимальный и максимальный уровни диапазона сохраняемых плиток.

  8. В поле Область интересов укажите, какую часть карты следует нарезать – отображаемую в данный момент область карты, габариты карты полностью, в пределах габаритов какого-либо слоя карты, либо его объектов.

  9. Если в качестве области интересов были выбраны габариты слоя, или его объектов, в поле Слой требуется выбрать необходимый слой. Также можно установить флажок Только выделенные объекты, чтобы в слое учитывались только выделенные его объекты.

  10. Для выполнения процесса нарезки нажмите кнопку Сохранить.

Чтобы отредактировать параметры нарезки, которую вы уже создали, откройте существующий файл описателя. Для этого нажмите кнопку Открыть и выберите нужный файл в диалоговом окне выбора файлов. Вы можете выбрать как локальный файл, так и файл на сервере геоданных ZuluServer. Название файла описателя отобразится в поле Имя файла описателя.

Если для данного описателя уже выполнялось создание плиток, то изменение параметров нарезки и создания плиток будет недоступно. В этом случае вы сможете только выполнить следующие действия:

  • Создание плиток для заданного диапазона уровней. Если требуется перезаписывать уже созданные для указанных уровней плитки, установите флажок Заменять существующие плитки. Для создания плиток укажите сохраняемую область карты в поле Область интересов (и, если требуется в полях Слой и Только выделенные объекты слоя), укажите диапазон уровней в полях Диапазон уровней и нажмите кнопку Создать;

  • Удаление заданного диапазона плиток. Для удаления уровней укажите диапазон уровней в полях Диапазон уровней и нажмите кнопку Удалить уровни;

  • Удаление всех сохраненных данных кэша SAS. Планета. Для этого нажмите кнопку Удалить все данные. После удаления данных становится возможным изменить часть параметров нарезки карты в части: проекцию, формат сохраняемых растров.

Для закрытия диалога нажмите кнопку Выход.


Параметры Tile-сервера

Настройка описателя Tile-сервера и его подключения в качестве слоя карты выполняется с помощью диалога Параметры Tile-сервера программы ZuluGIS.

В группе настроек Слой задается описатель Tile-сервера, используемый в качестве слоя:

  • В поле Имя файла описателя отображается название выбранного файла-описателя слоя, при работе с ZuluServer слой следует сохранять на сервере;

  • В поле Название слоя задается название слоя карты, в котором отображаются графические данные с Tile-сервера. В объектной модели соответствует свойству Layer.UserName;

  • Для того чтобы выбрать уже существующий файл-описатель, нажмите кнопку Открыть и выберите файл-описатель на диске;

  • Для того чтобы очистить параметры описателя и задать их с нуля, нажмите кнопку Новый;

  • По завершении редактирования параметров описателя нажмите кнопку Сохранить, чтобы сохранить изменения в текущем файле-описателе, или кнопку Сохранить как, чтобы сохранить новый файл-описатель.

В группах полей Запрос и Уровни задаются параметры обращения к Tile-серверу). Часть полей данного раздела могут становиться неактивными в том случае, если они не используются в выбранной модели обращения к серверу:

  • В поле запрос задается строка шаблона запроса, зависящая от используемой сервером модели запроса. При использовании модели кэша SAS.Планета, нажав кнопку … справа от поля, можно указать путь к папке кэша.

    Для модели Zulu Server параметр должен содержать URL тайлового слоя на ZuluServer, например:

    Address: zulu://zs.zulugis.ru:6473/osm/Relief_Maps-For_Free.zl

    Для всех остальных моделей параметр должен содержать шаблон HTTP запроса, обязательно начинаясь с указания протокола «http://», например:

    Address: http://www.maps-for-free.com/layer/relief

  • В поле со списком Модель выбирается используемая модель обращения к серверу;

  • В поле со списком Проекция выбирается код используемой картографической проекции;

  • В поле со списком Порядок координат задается последовательность указания параметров X и Y в модели «OpenStreetMap»;

  • В поле Расширение задается расширение запрашиваемого файла изображения. Применяется для моделей «OpenStreetMap» и «Map-For-Free». Для остальных моделей расширение изображения либо жестко задано, либо определяется динамически;

  • В полях Широта и Долгота группы настроек Начало отсчета указываются, соответственно, широта и долгота точки начала отсчета;

  • В полях По широте и По долготе группы настроек Ориентация осей задается ориентация осей Y и X;

  • В полях со списком Минимальный и Максимальный группы настроек Уровни задаются минимальный и максимальный уровень запрашиваемых с сервера плиток;

  • При установке флажка Использовать кэш запрашиваемые данные кэшируются, путь к папке кэша указывается в поле Папка кэша (см. «Принудительное кэширование данных Tile-сервера»).

После завершения настройки параметров доступа к Tile Server нажмите кнопку Закрыть и подтвердите добавление слоя в карту.

[Примечание] Примечание

Для того, чтобы масштабирование карты с тайловыми слоями было плавным, в диалоге настройки карты (Карта|Настройка) необходимо отключить опцию Дискретный масштаб с тайловыми слоями.

Возможно задание прозрачности слоя: «Настройка прозрачности тайлового слоя»


Фильтр отображения слоя трекинга

Настройка слоя трекинга позволяет задать отображение определённых пользователей по любым данным таблицы mobile_cur или установить фильтр по дате, чтобы ограничить видимость данных только за определённый период.

Кроме того, есть возможность включить отображение маршрутов вместо текущего местоположения объектов в этом слое. Также вы можете настроить масштаб для наименования из поля DisplayName или UserName и масштаб символов из поля Img.

[Примечание] Примечание

Произведенные настройки отображения слоя трекинга будут сохранены только при сохранении карты.

Настраиваются следующие параметры:

  1. Фильтр по объектам. В данном разделе может быть настроен фильтр по любым полям таблицы mobile_cur. Используя фильтр, вы можете настроить отображение определенных объектов на экране.

    Для фильтрации отображаемых данных информацию, по которой требуется фильтровать, вводят в таблицу справа от названия поля. Синтаксис в фильтре по данным аналогичен правилам написания запросов в окне семантической информации.

  2. Фильтр по дате. Для фильтрации отображения треков за определенный период времени следует выбрать:

    • Без фильтра – слой будет отображен без фильтра по дате;

    • Сегодня – отображает данные только за текущий день;

    • Последние N дней – для фильтрации по данному параметру справа следует ввести количество дней;

    • Интервал – устанавливается интервал времени, в течение которого требуется отобразить треки.

  3. Также возможно установить следующие опции отображения:

    • Отображать треки – данная опция включает отображение треков (маршрутов) объектов на экране;

    • Отображать имена объектов – данная опция включает отображение названий объектов из поля DisplayName или из поля UserName, если данные в первом поле отсутствуют;

    • Отображать последнее местоположение – при включении данной опции текущее местоположение объектов будет отображаться красным кружком;

    • Отображать точки трека - при включении данной опции на экране будут отражаться точки трека.

  4. Изменить масштаб отображения наименования трека и символа, которым отображается на карте устройство можно изменив масштабирующий коэффициент в окошке Масштаб надписей и Масштаб символов соответственно. По умолчанию установлен минимальный масштаб 1.

  5. Интервал между треками при необходимости задается в минутах в соответствующем окне. Если время между соседними точками трека больше интервала, то они не соединяются линией, то есть будут отдельные полилинии.

  6. Кнопка База откроет редактор баз данных для редактирования баз.

  7. Нажмите ОК для сохранения настроек.


Диалог Окна

Диалог Окна позволяет управлять открытыми окнами документов в ZuluGIS.

  • Кнопка Активировать делает выбранное в списке окно активным. Если окно было скрыто другими окнами документов, оно станет видимым.

  • Кнопка Сохранить сохраняет документы, окна которых выбраны в списке.

  • Кнопка Закрыть окно(а) закрывает выбранные в списке окна.

  • Кнопка OK закрывает данный диалог.


Панель поиск

С помощью данной диалоговой панели можно производить поиск проектов, карт и слоев в окне Панель проектов.

Для поиска требуемого объекта:

  1. В строке Образец наберите искомый текстовый фрагмент названия. Если нужно найти объект с полностью совпадающим названием, то наберите это название целиком и установите флажок только слова целиком. Для того, чтобы поиск производился строго с учетом регистра символов (больших и маленьких букв) установите флажок с учетом регистра.

  2. В группе флажков Искать укажите область поиска указанного названия, установив соответствующий флажок - проекты, карты и слои (при этом обязательно должен быть установлен хотя бы один флажок).

  3. Нажмите кнопку Найти далее или клавишу Enter.

  4. Повторным нажатием кнопки Далее производится поиск следующего по списку объека по указанным критериям.


Загрузка и импорт условий запроса

Диалог используется для загрузки ранее сохраненных условий запроса. Запросы могут быть загружены как из самого слоя, так и с диска. Во втором варианте по мимо загрузки условия запроса можно импортировать в слой.

Для загрузки или импорта условий запроса:

Если нужный запрос есть в списке сохраненных запросов, то для его загрузки выделите его и нажмите кнопку Открыть. Или сделайте на нем двойной щелчок левой кнопкой мыши.

Если запроса для загрузки в списке нет, то его можно загрузить с диска или импортировать. В первом варианте для повторной загрузки запроса его снова придется загружать с диска. Во втором варианте после импорта запрос будет добавлен в список запросов слоя и в дальнейшем для загрузки его надо будет просто выбирать из списка. При импорте условий запроса в слой дополнительно необходимо будет задать им название.


Сохранение условий запроса

Диалог используется для сохранения в слой или на диск условий запроса. В первом случае сохраненные условия могут загружаться только в этот слой, во втором случае в дальнейшем условия могут быть загружены и импортированы в другие слои.

Для сохранения запроса в слой:

  1. Укажите название сохраняемого запроса в верхней строке диалогового окна Сохранить запрос.

  2. Нажмите кнопку Сохранить.

Для сохранения запроса на диск:

  1. В окне Сохранить запрос нажмите кнопку Сохранить на диске….

  2. Укажите путь и дайте название файлу в котором будет сохранен запрос. В результате операции в указанной папке будет сохранен файл с введенным названием и расширением *.zq.

[Примечание] Примечание

Сохраненный запрос можно будет загрузить или импортировать.


Добавить таблицу

Диалог Добавить таблицы открывается в редакторе запросов базы данных.

Добавить в запрос можно как таблицы, справочники, так и уже существующие запросы.

Окно Добавить таблицы

Рисунок 1. Окно Добавить таблицы

В данном окне следует выделить таблицу, которая будет участвовать в создании Запроса и затем нажать кнопку Добавить.

Пример окна запроса

Рисунок 2. Пример окна запроса


Свойства поля

Диалог Свойства используется для задания атрибутов полей запроса.

Окно свойств поля запроса

Рисунок 1. Окно свойств поля запроса

В открывшемся диалоговом окне Свойства:

  • в строке пользовательское имя – в данную строку при необходимости возможно ввести новое значение для поля. Например в том случае, если имя поля ранее было задано латинскими буквами, и именно оно будет отображаться в окне семантической информации;

  • если поле должно быть запрещено к редактированию, то установить опцию нередактируемое;

  • если поле должно быть обязательно для заполнения, то установить опцию обязательное, в окне семантической информации такое поле будет помечено красной точкой и без внесения данных в это поле при сохранении информации будет выдано сообщение о необходимости указания значений поля;

  • если поле должно выбираться из справочника, то надо установить опцию значение поля выбирать из справочника и в открывающемся списке выбрать справочник, справочник при этом должен быть заранее создан;

  • в разделе Стиль при необходимости установить стиль отображения полей заголовков (названия) и полей значений (значения) в окне семантической информации;

    [Примечание] Примечание

    Стиль поля можно копировать/вставлять. Для этого надо вернуться в редактор запросов (закрыть окно Свойства), выделить поле в списке, нажатием правой мыши, открыть контекстное меню и выбрать пункт Копировать стиль. Затем, для вставки стиля в новое поле выделить его, опять сделать щелчок правой кнопкой мыши и в контекстном меню выбрать пункт Вставить стиль.

    Стиль полей семантической информации

    Рисунок 2. Стиль полей семантической информации

  • в строке группа можно задать группы полей, это делается для того, чтобы в браузере баз данных поля были сгруппированы в древовидный список. Для того чтобы заданное поле принадлежало какой-то группе нужно указать имя этой группы в настройках этого поля в редакторе запроса. Для задания подгруппы следует использовать знак «\» (обратная косая черта) или «/» (косая черта).

    Пример группировки полей

    Рисунок 3. Пример группировки полей

  • в разделе Дополнительно находятся опции, предназначенные для программного расширения функциональных возможностей ZuluGIS:

    имя модели данных - в данной строке можно задать имя поля для модели данных,

    псевдоним колонки ответа - можно ввести название поля, которое будет отображаться в названии столбца закладок База и Ответ окна семантической информации, псевдоним задается только латинскими буквами или цифрами без пробелов и знаков препинания, и начинаться он должен обязательно с буквы;

  • в разделе тэги при необходимости имеется возможность установить тэги:

    [Примечание] Примечание

    Использование тэгов позволяет расширить возможности системы, например можно подключать к полям и загружать в поля различные файлы, подключить базу ФИАС, хранить в поле цвет, записывать в поле данные gps.

    Видео с примером применения тэгов можно посмотреть пройдя по ссылке: https://youtu.be/I4aIjiGwlPc или https://www.politerm.com/videos/database/ispolzovanie-tegov/.

    document - может быть применен к полю типа Строковое. Позволяет открывать файл, путь к которому будет прописан в поле окна семантической информации. Это может быть фотография, картинка, текстовый файл или например таблица Excel.

    Если подключены документы типа Microsoft Excel, Microsoft Word или например pdf формата, то в случае нажатия на ярлык ( [image] ) с одновременно нажатой клавишей Ctrl, файл будет открыт в программе соответствующей расширению файла и скачан в папку Загрузки. Правый клик по кнопке ( [image] ) ярлыка вызывает контекстное меню, в котором можно выбрать Показать или Скачать подключенный файл.

    Если выделена строка с подключенным файлом, то для скачивания файла в папку Загрузки так же можно сделать щелчок правой кнопкой мыши и выбрать пункт [image] Скачать, данный пункт доступен только для соответствующего поля.

    Путь до подключенного файла может быть как абсолютным, так и относительным. Если задан относительный путь, то он рассчитывается относительно папки указанной в поле Папка для изображений и документов настроек БД (см. «Дополнительные настройки») если это поле задано, либо относительно папки карты в противном случае.

    [Примечание] Примечание

    При работе с подключёнными данными важно правильно организовать работу. Желательно документы располагать не в разных местах на компьютере, а скопировать их в один каталог, который при необходимости может включать в себя подкаталоги. Директория расположения файлов указывается в редакторе баз данных, вкладка Сервис - Папка для изображений и документов.

  • тэг picture может применяться к полям типа BLOB или Строковое, во втором случае данный тэг применяется совместно с тэгом document. Данный тэг указывает программе что файл, путь к которому задается в этом поле, является изображением. Для таких объектов в диалоге редактирования записи отображается уменьшенное его изображение, а двойной щелчок по фото или нажатие кнопки ... справа от фото откроет изображение в специальном окне просмотра. В данном окне возможно загружать файлы, копировать, печатать или открывать окно редактора изображений.

    Применение тэга picture

    Рисунок 4. Применение тэга picture

  • [Примечание] Примечание

    Пример применения тэгов для подключения документов можно посмотреть в разделе «Подключение файлов к базе данных».

  • url - может быть применен к полю типа Строковое. В дальнейшем в поле возможно вписать адрес типа ​http://politerm.com/. При нажатии на кнопку справа от введенного адреса [image] в браузере по умолчанию откроется указанный сайт:

    Применение тэга url

    Рисунок 5. Применение тэга url

  • text - может быть применен к полю типа BLOB. Позволяет вносить в поле текст или загружать текстовые файлы (*.txt). Нажатие на кнопку ... справа от поля откроет окно в котором текст возможно отредактировать, сохранить в новый текстовый файл или загрузить файл;

    Использование тэга text

    Рисунок 6. Использование тэга text

  • color - применяя данный тэг имеется возможность в поле хранить цвет, используется для полей типа длинное целое:

    Использование тэга color, вкладка Текущая запись

    Рисунок 7. Использование тэга color, вкладка Текущая запись

    Использование тэга color, вкладка База

    Рисунок 8. Использование тэга color, вкладка База

  • fias - подключает классификатор ФИАС к полю, подробней можно узнать в разделе Подключение ФИАС к полю базы;

  • gallery - позволяет подключать несколько файлов к одному полю, применяется для поля типа BLOB. Справа от тега возможно указать дополнительные опции, если опции не использовать, то файлы будут загружены в базу данных.

    Дополнительные опции к тэгу gallery:

    • files - в поле будут храниться данные, при применении только одной этой опции данные загружаются в базу так же если бы опция не применялась. Целесообразно использовать ее в комбинации с опцией links;

      Пример применения тэга gallery с опцией files или без нее

      Рисунок 9. Пример применения тэга gallery с опцией files или без нее

    • links - в поле будут храниться ссылки на данные. При использовании данной опции важно правильно организовать работу. Желательно документы располагать не в разных местах на компьютере, а в одном каталоге, который при необходимости может включать в себя подкаталоги. Директория расположения файлов указывается в редакторе баз данных, вкладка Сервис - Папка для изображений и документов.

      Установка опции links

      Рисунок 10. Установка опции links

      Для загрузки файла по ссылке надо сделать по нему двойной щелчок левой кнопкой мыши или сделать щелчок правой кнопкой мыши и выбрать пункт Открыть.

      Установка опции links

      Рисунок 11. Установка опции links

    • комбинация files и links - указываются через пробел или запятую, позволяют использовать сочетание ссылок на файлы и непосредственное добавление файлов в базу.

      Установка комбинации опций files и links

      Рисунок 12. Установка комбинации опций files и links

      В том случае, если опции применяются совместно, то при указании файла надо будет выбрать способ загрузки:

      Выбор способа загрузки данных при применении опций lfiles и links

      Рисунок 13. Выбор способа загрузки данных при применении опций lfiles и links

      Пример применения тэга gallery с опциями lfiles и links

      Рисунок 14. Пример применения тэга gallery с опциями lfiles и links

  • custombrowseobject и custombrowsemethod - адают соответственно, com-объект, зарегистрированный в реестре и метод у этого объекта, который будет вызываться (используются программистами). Подробнее смотрите раздел Объекты-обработчики.

  • gps - используется для записи данных gps в поле базы данных. При добавлении объекта в ZuluGIS Mobile, у него будут автоматически заполнятся настроенные поля. Дополнительно справа от тега следует указать необходимый параметр gps для записи:

    • lat.decimal - широта.

    • lon.decimal - долгота.

    • Altitude - высота над уровнем моря.

    • accuracy - точность gps.

    • vertical_accuracy - вертикальная точность gps.

    • time - время.

    Пример применения тэга gallery с опциями lfiles и links

    Рисунок 15. Пример применения тэга gallery с опциями lfiles и links

  • mobileeditonly - тег, который позволяет изменять данные по объектам только из ZuluGIS Mobile, в ZuluGIS это поле редактироваться не будет по аналогии с опцией нередактируемое.

  • cameraonly - применяется для полей, предназначенных для подключения документов. С данным тэгом возможность подключать документы с компьютера или памяти телефона блокируется, остается возможность загружать только фотографии в ZuluGIS Mobile, сделанные камерой мобильного устройства. На стороне сервера поведение тега совпадает с тегом mobileeditjnly, отличия появляются только при обработке в Android приложении.

  • audio - при применении тэга в поле встраивается плеер-рекордер для проигрывания аудио файлов. В текущей версии используется только для ZuluGIS Mobile. Используется только с типом поля BLOB.

    [Примечание] Примечание

    Подробней о работе с аудиополями

    Для перехода к следующему/предыдущему полю запроса нажмите кнопку След. или Пред. окна свойств. Нажатие кнопки ОК подтвердит произведенные изменения и закроет окно Свойства.

  • в разделе Описание (всплывающая подсказка) можно задать комментарий, который в дальнейшем будет появляться при подведении курсора к названию поля в окне семантической информации:

    Рисунок 16. Описание поля

    [Примечание] Примечание

    По умолчанию перенос строк всплывающей раскраски происходит автоматически. Для принудительного переноса строк надо установить курсор в конце строки, после которой должен осуществляться перенос, затем нажать на клавиатуре клавишу Ctrl и не отпуская ее нажать Enter.


Свойства группы полей

Используя диалог можно настроить Стиль, Группу и дополнительные свойства полей для выделенной группы полей в редакторе запроса.

Редактор запроса. Свойства группы полей

Рисунок 1. Редактор запроса. Свойства группы полей

  • в разделе Стиль при необходимости установить стиль отображения полей заголовков (названия) и полей значений (значения) в окне семантической информации;

    [Примечание] Примечание

    Стиль поля можно копировать/вставлять. Для этого надо вернуться в редактор запросов (закрыть окно Свойства), выделить поле в списке, нажатием правой мыши, открыть контекстное меню и выбрать пункт Копировать стиль. Затем, для вставки стиля в новое поле выделить его, опять сделать щелчок правой кнопкой мыши и в контекстном меню выбрать пункт Вставить стиль.

    Стиль полей семантической информации

    Рисунок 2. Стиль полей семантической информации

  • в строке группа можно задать группы полей, это делается для того, чтобы в браузере баз данных поля были сгруппированы в древовидный список. Для того чтобы заданное поле принадлежало какой-то группе нужно указать имя этой группы в настройках этого поля в редакторе запроса. Для задания подгруппы следует использовать знак «\» (обратная косая черта) или «/» (косая черта).

    Пример группировки полей

    Рисунок 3. Пример группировки полей

  • в разделе тэги при необходимости имеется возможность установить тэги, подробней о тэгах можно узнать в разделе Свойства полей запроса.

    [Примечание] Примечание

    Использование тэгов позволяет расширить возможности системы, например можно подключать к полям и загружать в поля различные файлы, подключить базу ФИАС, хранить в поле цвет, записывать в поле данные gps.

    Видео с примером применения тэгов можно посмотреть пройдя по ссылке: https://youtu.be/I4aIjiGwlPc или https://www.politerm.com/videos/database/ispolzovanie-tegov/.


Форма

С помощью данного диалога возможно настроить список полей для отображения в окне семантической информации.

Для создания формы необходимо:

  1. В строке Название формы задать то название, которое будет отражать назначение создаваемой формы.

  2. В списке Все поля выделить поле, которое необходимо отобразить в окне семантической информации и нажать кнопку [image] , в результате чего выделенное поле появится в списке Поля формы.

Повторить действия, описанные в пункте 2 для тех полей, которые необходимо отобразить в окне семантической информации.

Функции кнопок диалога «Форма»:

Кнопки добавления (удаления) полей в список:

Добавляет выбранное поле в список полей формы.
Добавляет все поля из выбранной таблицы в форму.
Удаляет выбранное поле из списка.
Удаляет все поля из списка.

Кнопки изменения порядка следования полей:

Поля в окне семантической информации будут выводиться в том порядке, в котором они указаны в данном списке. Воспользуйтесь указанными кнопки, чтобы изменить порядок вывода полей:

Перемещает поле в самое начало списка.
Сдвиг на одно поле вверх.
Перемещает поле в самый конец списка.
Сдвиг на одно поле вниз.


Параметры связи

Тип установленной связи можно изменить, если щелкнуть дважды по линии связи. При этом открывается окно задания параметров связи. Для проведения новой связи полей подведите курсор к полю в одной таблице, нажмите левую клавишу мыши и не отпуская проведите связь до поля в другой таблице.

Связь между таблицами может иметь один из трех типов:

  1. Один к одному - объединяет только те записи, в которых связанные поля совпадают.

  2. Много к одному - объединяет все записи из левой таблицы и только те записи из правой таблицы, в которой связанные поля совпадают.

  3. Один ко многим - объединяет все записи из правой таблицы и только те записи из левой таблицы, в которой связанные поля совпадают.

Выбор необходимого типа связи производится переключателем.

Для удаления связи между таблицами щелкните мышкой по связи и нажмите клавишу Del на клавиатуре.


Редактор баз данных

Для хранения семантической информации ZuluGIS может использовать различные источники табличных данных. Это могут быть как коммерческие, так и бесплатные клиент-серверные СУБД: Microsoft SQL Server, Oracle, Sybase, PostgreSQL, MySQL, Линтер, и т.д.; файл-серверные СУБД: SQLite, MS Access, Paradox, dBase; другие источники, поддерживающие ODBC или ADO соединения. В поставку ZuluGIS входит бесплатная СУБД Microsoft SQL Server Express LocalDB.

Для удобства и единообразия доступа к семантическим данным ZuluGIS описывает подключения к различным СУБД в виде своих «источников данных». Подобно источникам данных ODBC DSN или связям с данными OLEDB UDL эти источники данных можно использовать при добавлении таблиц в базу данных или выборе таблиц для других операций. Источники данных могут использоваться как локально в однопользовательской версии ZuluGIS, так и на ZuluServer. Подробнее об источниках данных «Источники данных ZuluGIS».

Физически файлы таблиц могут располагаться в удобном для пользователя месте (на сервере, на локальной машине в отдельном каталоге, в том же каталоге, что и файлы графической базы данных). Желательно чтобы файл описателя базы данных хранился в том же каталоге, что и файл графической базы данных. Описатель базы данных ZuluGIS хранит следующую информацию:

  • список таблиц, участвующих в запросе;

  • если необходимо - набор справочников;

  • набор запросов, задающих правила выбора значений из таблиц и содержащих ссылки на таблицы, из которых выполняется выборка, связи между таблицами, набор полей для вывода с пользовательскими названиями;

  • если необходимо - набор форм для разного отображения информации.

Создание базы данных состоит из нескольких этапов:

  1. Создание описателя баз данных.

  2. Создание структуры таблиц.

  3. При необходимости создание и включение таблиц – справочников.

  4. Создание запроса в котором определяются все поля, входящие в семантическую БД.

  5. При необходимости установка связей между таблицами.

  6. При необходимости создание форм вывода.

  7. Подключение семантической БД к объектам слоя.


Запрос

Запросы используются для просмотра, изменения и анализа данных различными способами. Запросы также можно использовать в качестве источников записей для форм. Данный тип объектов - это визуальный запрос ZuluGIS или описатель запроса, который будет выполняться при вызове окна семантической информации. Описатель запроса задает правила выбора значений из таблиц и содержащих ссылки на таблицы, из которых выполняется выборка, связи между таблицами, набор полей для вывода с пользовательскими названиями.

Для создания нового запроса надо:

  1. Нажать кнопку [image] Создать....

  2. В появившемся диалоговом окне Добавить таблицы выделить таблицу, которая будет участвовать в запросе, нажать кнопку Добавить.

    Окно Добавить таблицу

    Рисунок 1. Окно Добавить таблицу

  3. Если для запроса необходимо несколько таблиц, то необходимо повторить пункт 3.

    Добавленные в запрос таблицы отображаются в виде прямоугольников со списком полей таблицы.

  4. Для закрытия окна добавления таблиц нажать кнопку Закрыть.

    [Примечание] Примечание

    • В запросе можно использовать как таблицы, справочники, так и уже существующие запросы;

    • Для повторного вызова диалогового окна Добавить таблицы надо нажать на панели инструментов кнопку [image] ;

    • Если таблица в запрос была добавлена ошибочно, то исключить из за проса ее можно с помощью кнопки [image] .

  5. В том случае, если в запросе будут участвовать несколько таблиц провести связи между полями таблиц. Если в запросе участвует только одна таблица, то данный пункт следует ПРОПУСТИТЬ.

    Для установки связей:

    • выделите поле одной таблицы;

    • не отпуская левой кнопки мыши протяните курсор к полю другой таблицы;

    • отпустите кнопку мыши - связь проведена (подробней о связях таблиц можно узнать в разделе «Связь нескольких таблиц в запросе»).

    [Примечание] Примечание

    Начиная с версии ZuluGIS 8.0.0.7298u имеется возможность для подчиненной таблицы назначить роль, от которой будет зависеть как поля из таких таблиц будут обрабатываться в браузере.

  6. Выбрать поля, которые будут появляться в окне семантической информации при выполнении данного запроса.

    Это можно сделать несколькими способами:

    • щелкнуть два раза на поле таблицы, добавленной в запрос - данное поле появится в списке полей запроса.

      или

    • выделить поле таблицы, добавленной в запрос и, не отпуская левой кнопки мыши, протянуть курсор вниз, в список полей запроса, отпустить кнопку мыши.

      или

    • щелкнуть правой кнопкой мыши в области полей добавленной таблицы, в появившемся контекстном меню выбрать пункт Добавить поле или Добавить все поля. При выборе пункта Добавить поле в список полей запроса будет добавлено поле, выделенное в окне таблицы. При выборе пункта Добавить все поля в список полей запроса будут добавлены все поля, а так же автоматически выберется Поле связи с картой (Sys).

      Диалоговое окно Запрос

      Рисунок 2. Диалоговое окно Запрос

      При необходимости порядок полей запроса можно изменять как с помощью контекстного меню, вызываемого щелчком правой кнопкой мыши в списке полей запроса:

      Рисунок 3. Контекстное меню

      так и при помощи мыши или с помощью следующих кнопок, расположенных на панели инструментов:

      - перемещает поле в самое начало списка;

      - выполняет сдвиг на одно поле вверх;

      - выполняет сдвиг на одно поле вниз;

      - перемещает поле в самый конец списка.

      Так же перемещение полей возможно с помощью мыши, для этого надо:

      1. Выделить левой кнопкой мыши поле, которое надо переместить.

      2. Перевести курсор в столбец с номером поля (№) на перемещаемое поле, нажать левую кнопку мыши.

      3. Не отпуская кнопку начать перемещение поля.

      4. Для прерывания процесса перемещения отпустите левую кнопку мыши.

      Выделив поле в списке и нажав кнопку [image] можно удалить ошибочно добавленное поле.

  7. Вызвать диалоговое окно Свойства для задания пользовательских названий и дополнительных атрибутов полей запроса.

    Окно свойств поля запроса

    Рисунок 4. Окно свойств поля запроса

    Вызвать его можно несколькими способами:

    • щелкнув два раза на любом поле в списке полей запроса

      или

    • нажав кнопку [image] (кнопка будет активной только в том случае, если в списке полей запроса выделено хотя бы одно поле)

      или

    • щелкнув правой кнопкой мыши в списке полей запроса, и в появившемся контекстном меню выбрав пункт Свойства.

  8. В открывшемся диалоговом окне Свойства:

    • в строке пользовательское имя – в том случае, если имя поля ранее было задано латинскими буквами в данной строке их можно заменить на пользовательское название;

    • если поле должно быть запрещено к редактированию, то установить опцию нередактируемое;

    • если поле должно выбираться из справочника, то надо установить опцию значение поля выбирать из справочника и в открывающемся списке выбрать справочник, справочник при этом должен быть заранее создан;

    • в разделе Стиль при необходимости установить стиль отображения полей заголовков (названия) и полей значений (значения) в окне семантической информации (Рисунок 688, «Результат»);

      [Примечание] Примечание

      Стиль поля можно копировать/вставлять (рис. Рисунок 683, «Контекстное меню »). Для групповой настройки полей следует выделить группу полей и открыть Свойства. Чтобы выделить поле нажмите и не отпускайте клавишу Ctrl и с помощью мыши укажите нужные поля в списке. Если необходимо выделить сразу несколько последовательно идущих поля, то на клавиатуре можно удерживать клавишу Shift, а мышью при этом указать первое и последнее поле.

      Стиль полей семантической информации

      Рисунок 5. Стиль полей семантической информации

    • при необходимости в строке группа можно задать группы полей, это делается для того, чтобы в браузере баз данных поля были сгруппированы в древовидный список (Рисунок 691, «Результат в окне семантической информации»). Для того чтобы заданное поле принадлежало какой-то группе нужно указать имя этой группы в настройках этого поля в редакторе запроса. Для задания подгруппы следует использовать знак «\» (обратная косая черта) или «/» (косая черта);

      Пример группировки полей

      Рисунок 6. Пример группировки полей

    • в разделе Дополнительно находятся опции, предназначенные для программного расширения функциональных возможностей ZuluGIS:

      имя модели данных - в данной строке можно задать имя поля для модели данных,

      псевдоним колонки ответа - можно ввести название поля, которое будет отображаться в названии столбца закладок База и Ответ окна семантической информации, псевдоним задается только латинскими буквами или цифрами без пробелов и знаков препинания, и начинаться он должен обязательно с буквы;

    • в разделе тэги при необходимости имеется возможность установить тэги:

      document - позволяет вызвать файл, путь к которому будет прописан в поле окна семантической информации, в названии файла обязательно необходимо указать его расширение (например D:/spravka.doc - откроет Microsoft Word с загруженным документом spravka). Путь может быть как абсолютным, так и относительным. Если задан относительный путь, то он рассчитывается относительно папки указанной в поле Папка для изображений и документов настроек БД (см. «Дополнительные настройки») если это поле задано, либо относительно папки карты в противном случае. Совместно с тэгом document может дополнительно указываться тэг picture указывающий программе, что файл, путь к которому задается в этом поле, является изображением. Для таких документов вызывается не программа по умолчанию, а встроенный просмотрщик изображений, а в диалоге редактирования записи отображается уменьшенное изображение из файла;

      url - аналогичен тэгу document, различие состоит только в том, что файл будет открываться в окне интернет браузера;

      text - позволяет загружать текстовые файлы (*.txt);

      color - используя данный тэг имеется возможность в поле хранить цвет, используется для полей типа длинное целое:

      Использование тэга color, вкладка Текущая запись

      Рисунок 7. Использование тэга color, вкладка Текущая запись

      Использование тэга color, вкладка База

      Рисунок 8. Использование тэга color, вкладка База

      fias - подключает классификатор ФИАС к полю, подробней можно узнать в разделе Подключение ФИАС к полю базы;

      gallery - позволяет подключать несколько файлов к одному полю, применяется для поля типа BLOB:

      Подключенные к полю файлы

      Рисунок 9. Подключенные к полю файлы

      custombrowseobject и custombrowsemethod - задают соответственно, com-объект, зарегистрированный в реестре и метод у этого объекта, который будет вызываться (используются программистами).

      Для перехода к следующему/предыдущему полю запроса нажмите кнопку След. или Пред. окна свойств. Нажатие кнопки ОК подтвердит произведенные изменения и закроет окно Свойства.

    • в разделе Описание можно задать комментарий, который в дальнейшем будет появляться при подведении курсора к названию поля в окне семантической информации:

      Рисунок 10. Описание поля

  9. Установите поле связи с картой (если оно еще не установлено), для этого в строке поле связи нажмите кнопку Выбор и в открывшемся списке укажите поле связи с картой (по умолчанию полем связи с картой является Sys). Нажатие кнопки ОК подтвердит Ваш выбор и закроет диалог Выбор поля.

    [Примечание] Примечание

    Поле связи не обязательно должно присутствовать в списке полей описателя БД.

  10. После создания запроса его необходимо сохранить, для этого надо нажать кнопку [image] Сохранить... и затем закрыть окно запроса с помощью кнопки Закрыть.

Если появляется необходимость связать между собой таблицы, включенные в запрос, то для этого надо:

  1. Щелчком левой кнопки мыши выделить поле одной таблицы.

  2. Удерживая нажатой левую кнопку мыши, протянуть курсор от поля одной таблицы к полю второй таблицы.

  3. Отпустить левую кнопку мыши, после чего между таблицами появится линия связи.

Рисунок 11. Связанные таблицы

Тип установленной связи можно изменить, если щелкнуть дважды по линии связи. При этом открывается окно задания параметров связи. Связь между таблицами может иметь один из трех типов:

  1. Один к одному - объединяет только те записи, в которых связанные поля совпадают.

  2. Много к одному - объединяет все записи из левой таблицы и только те записи из правой таблицы, в которой связанные поля совпадают.

  3. Один ко многим - объединяет все записи из правой таблицы и только те записи из левой таблицы, в которой связанные поля совпадают.

Окно Параметры связи

Рисунок 12. Окно Параметры связи

Выбор необходимого типа связи производится переключателем.

Для удаления связи между таблицами щелкните мышкой по связи и нажмите клавишу Del на клавиатуре.

Дополнительные кнопки панели инструментов окна создания запроса:

Браузер - включает режим просмотра запроса в браузере (окне семантической информации);

Тест - включает режим тестирования созданного запроса.

Режим тестирования позволяет протестировать созданный запрос и посмотреть полученные результаты. Для входа в режим тестирования нажать кнопку [image] Тест и в окне тестирования установить параметры выполняемого запроса.

Рисунок 13. Окно Запрос

В разделе Запрос формируется строка запроса в режиме SQL. Данная строка может быть отредактирована.

Для выборки всех значений из базы нажмите кнопку [image] . В результате в поле Запрос появится строка для выборки всех записей из базы в соответствии с созданным запросом. Для выполнения запроса нажмите кнопку [image] . Чтобы получить одну запись по ключу, в поле ввода необходимо указать ключ объекта, после чего нажать кнопку [image] - поле Запрос будет сформирована строка запроса по заданному условию. Для выполнения запроса нажать кнопку [image] .

Кнопка [image] Браузер открывает окно семантической информации, что позволяет непосредственно в этом окне протестировать созданный запрос.


Простой справочник

Диалог предназначен для создания простого справочника. Простой справочник - это справочник, который будет содержать список предопределенных именованных значений.

Такой справочник является наиболее легким по способу создания справочником, для его создания надо:

  1. В окне создания справочника, надо внести исходные данные справочника. Данные вводятся в два столбца: код – в который вводятся коды значений, и столбец значение, в который соответственно вводится значение.

  2. При заполнении справочника можно пользоваться кнопками:

    - добавить запись;

    - удалить запись.

  3. Если необходимо чтобы записи справочника выводились в алфавитном порядке, то установите опцию Автоматическая сортировка. Если же значения должны будут выводиться в том порядке, в котором были внесены, то проверьте, чтобы данная опция была снята.

  4. При желании можно задать свойства справочника, их можно открыть с помощью кнопки [image] Параметры.... В строке Название задайте название справочника, в стоке Описание опишите содержимое справочника, нажмите кнопку ОК.

  5. Для завершения процедуры создания справочника нажмите кнопку ОК. Если ранее в свойствах не было задано название справочника, то система потребует его ввести.


Общие настройки базы данных

В данном диалоговом окне можно сделать общие настройки для базы данных слоя.

В строке Сетевая папка для временных файлов можно указать сетевую папку, которая будет использоваться для временных файлов при работе ZuluGIS.

При установке опции Помещать сообщения об ошибках в окно Сообщения в случае возникновения ошибки в базе данных она будет продублирована в окне Сообщения.

При установке опции Ключевые слова в запросах по-русски слова в запросах будут отображаться на русском языке.


Настройка источников данных

С помощью данного диалога возможно добавить, изменить или удалить источник данных ZuluGIS.

Для добавления источника данных:

  1. Нажмите кнопку Добавить, откроется панель Источник данных.

  2. В панели Источник в строке Название источника впишите название нового источника. Используйте те же правила для названия, что и для имен файлов и папок, т.е. можно использовать символы латиницы и кириллицы, цифры, пробелы, знаки подчеркивания, но нельзя использовать знаки косой черты, двоеточия, знака вопроса и т.п.

  3. Выберите нужный Тип подключения из списка.

    В зависимости от типа подключения:

    Для соединения ADO(OLEDB):

    • либо выберите опцию Использовать строку соединения и задайте строку соединения. Воспользуйтесь кнопкой Построить, чтобы вызвать стандартное окно задания связи с данными;

    • либо выберите опцию Использовать файл связи с данными (UDL) и укажите путь к файлу UDL. Воспользуйтесь кнопкой Обзор, чтобы найти и выбрать этот файл на компьютере.

    Для источника BDE/ODBC:

    • в окошке Псевдоним выберите из списка или впишите псевдоним BDE или имя источника данных ODBC DSN.

    Для локальной папки:

    • в разделе Папка укажите папку, которая будет источником для таблиц Paradox или dBase. Воспользуйтесь кнопкой Обзор, чтобы найти и выбрать эту папку на компьютере.

  4. Если нужно, чтобы соединение с источником данных осуществлялось с предопределенными логином и паролем, впишите их в окошках Логин и Пароль (пароль сохраняется в файле DataSrc.cfg в зашифрованном виде).

  5. Нажмите OK.

Для изменения настроек источника данных:

  1. Выберите источник из списка и нажмите кнопку Изменить.

  2. В панели Источник задайте параметры источника.

  3. Нажмите OK.

Для удаления источника данных:

  1. Выберите источник из списка и нажмите Удалить.

  2. В появившемся окне предупреждения подтвердите выбор кнопкой Да.


Совмещение корпоративной защиты рабочих мест c защитой ZuluServer в одном ключе

В одном сетевым ключе NetHasp может быть задано и количество рабочих мест, которые могут одновременно использовать каждый программный расчетный модуль, и количество одновременных подключений к ZuluServer.

В этом случае ключ должен быть установлен на том же компьютере, где установлен ZuluServer. Тогда сетевой ключ одновременно будет осуществлять локальную защиту ZuluServer и корпоративную защиту остальных продуктов.

В итоге:

  • ZuluServer предоставляет доступ к данным, для их редактирования;

  • Сетевой ключ Hasp Net10 предоставляет доступ к лицензиям на расчетные модули.


Вкладка Страница

Для задания соответствующих параметров страницы надо:

  1. В разделе Бумага задать формат бумаги (из списка размер) и способ ее подачи (из списка подача) в устройство.

  2. В разделе Ориентация выбрать один из вариантов ориентации изображения на странице.

  3. В разделе Поля задать поля с каждой стороны листа в сантиметрах. Печатаемая зона будет ограничена этими полями. Однако, если указанные поля окажутся меньше, чем физические поля печатающего устройства, то будут использованы поля устройства.

  4. В разделе Отступы от колонтитулов задать отступы от верхнего и нижнего колонтитула в сантиметрах.


Вкладка Колонтитулы

В данной вкладке имеется возможность настроить колонтитулы для печати карты. Отдельно настраиваются нижний и верхний колонтитул. По умолчанию есть уже готовые три варианта настройки:

  1. Нумерация по центру страницы (Страница 1).

  2. Нумерация по центру страницы и количество страниц (Страница 1 из ?).

  3. Нумерация по центру страницы и текущая дата в правом верхнем углу (Страница 1; 24.12.14).

Изменения уже готового колонтитула или создание нового происходит с помощью кнопки Изменить.

Для настройки верхнего или нижнего колонтитула надо нажать кнопку Изменить напротив соответствующего списка, после чего на экране появится диалог Колонтитул.

Для создания колонтитула надо:

  1. Установить курсор в тот раздел диалога, в котором необходимо создать колонтитул (Слева, В центре, Справа).

  2. Нажать соответствующую кнопку:

    • - позволяет вставить любой текст с индивидуальной настройкой, после ее нажатия откроется диалог, в котором необходимо сделать настройки текста, затем можно ввести нужный текст с клавиатуры;

    • - с помощью данной кнопки можно вставить в колонтитул номер страницы;

    • - с помощью данной кнопки можно вставить в колонтитул число страниц;

    • - с помощью данной кнопки можно вставить номер страницы по вертикали;

    • - с помощью данной кнопки можно вставить номер страницы по вертикали;

    • - с помощью данной кнопки можно вставить в колонтитул дату;

    • - с помощью данной кнопки можно вставить в колонтитул время;

    • - с помощью данной кнопки можно вставить в колонтитул название документа (пользовательское название карты);

    • - с помощью данной кнопки можно вставить в колонтитул путь до документа.

  3. Для подтверждения создания колонтитулов нажать кнопку ОК.


Импорт модели рельефа из Esri TIN

В результате импорта модели рельефа из формата Esri TIN будет получен слой рельефа TIN модели в котором по каждой точке можно получить значение высоты. Для импорта обязательно нужен набор файлов с расширением *.adf, содержащих массив x, у точек (tnxy.adf), массив высот точек (tnz.adf) и описанием треугольников (tnod.adf). Если отсутствует файл с описанием треугольников, то триангуляция будет выполнена системой. Импортируемые файлы должны располагаться в одном каталоге.

Чтобы импортировать модель рельефа:

  1. Выполните команду меню Карта\Рельеф\Импорт\Esri TIN.

  2. Укажите для импорта файл, содержащий массив x, y точек - tnxy.adf. Нажмите кнопку Открыть.

  3. В диалоге Импорт модели рельефа из Esri TIN справа от строки Имя слоя нажмите кнопку Обзор.... Далее укажите каталог и имя для создаваемого в результате импорта файла рельефа.

  4. В строке Название слоя имеется возможность задать пользовательское название слоя отличное от имени файла.

  5. Из списка Цвет можно выбрать цвет для сетки рельефа.

  6. При установке опции Добавить в карту слой рельефа будет создан и добавлен в текущую карту.

  7. Кнопка ОК завершит процедуру импорта.

    Импорт рельефа из Esri TIN

    Рисунок 370. Импорт рельефа из Esri TIN


Импорт модели рельефа из Intermediate TIN Format (ITF)

В результате импорта модели рельефа из формата ITF будет получен слой рельефа TIN модели в котором по каждой точке можно получить значение высоты.

Чтобы импортировать модель рельефа:

  1. Выполните команду меню Карта\Рельеф\Импорт\Intermediate TIN Format (ITF).

  2. Укажите для импорта файл *.itf. Нажмите кнопку Открыть.

  3. В диалоге Импорт модели рельефа из Intermediate TIN Format (ITF) справа от строки Имя слоя нажмите кнопку Обзор.... Далее укажите каталог и имя для создаваемого в результате импорта файла рельефа.

  4. В строке Название слоя имеется возможность задать пользовательское название слоя отличное от имени файла.

  5. Из списка Цвет можно выбрать цвет для сетки рельефа.

  6. При установке опции Добавить в карту слой рельефа будет создан и добавлен в текущую карту.

  7. Кнопка ОК завершит процедуру импорта.

    Импорт рельефа из Intermediate TIN Format (ITF)

    Рисунок 371. Импорт рельефа из Intermediate TIN Format (ITF)


Импорт модели рельефа из LandXML TIN

В результате импорта поверхностей нерегулярной триангулированной сети (TIN) из формата LandXML TIN будет получен слой рельефа TIN модели в котором по каждой точке можно получить значение высоты. Для успешного импорта в XML файле должен быть корневой индекс LandXML и TIN раздел со списком точек X, Y, Z. В том случае, если импортируемый XML файл не будет соответствовать LandXML формату, то будет выдано соответствующее сообщение.

Чтобы импортировать модель рельефа:

  1. Выполните команду меню Карта\Рельеф\Импорт\LandXML.

  2. Выберите XML файл для импорта, нажмите кнопку Открыть.

  3. В диалоге Импорт модели рельефа из LandXML справа от строки Имя слоя нажмите кнопку Обзор.... Далее укажите каталог и имя для создаваемого в результате импорта файла рельефа.

  4. В строке Название слоя имеется возможность задать пользовательское название слоя отличное от имени файла.

  5. Из списка Цвет можно выбрать цвет для сетки рельефа.

  6. При установке опции Добавить в карту слой рельефа будет создан и добавлен в текущую карту.

  7. Кнопка ОК завершит процедуру импорта.

    Импорт рельефа из LandXML

    Рисунок 369. Импорт рельефа из LandXML


Слои Росреестра

Настоящая версия ZuluGIS позволяет добавить на карту следующие данные Росреестра:

  • Cлой кадастрового деления Росреестра. Слой кадастрового деления Росреестра поддерживает прямые (информация по указанной точке на карте) и поисковые запросы (поиск по кадастровым номерам).

  • Pоны (ЗОУИТ) – зоны с особыми условиями использования территории.

Слой Росреестра и кадастровая информация

Рисунок 372. Слой Росреестра и кадастровая информация


Добавление слоя кадастрового деления

Для добавления слоя кадастрового деления Росреестра в карту следует:

  1. Выбрать команду главного меню Слой|Росреестр|Кадастровое деление.

  2. В карту добавится слой кадастрового деления.

    Слой Росреестра и кадастровая информация

    Рисунок 373. Слой Росреестра и кадастровая информация


Добавление слоя зон (ЗОУИТ) Росреестра

Для добавления слоя ЗОУИТ Росреестра (зоны с особыми условиями использования территории) в карту следует:

  1. Выбрать команду главного меню Слой|Росреестр|Зоны (ЗОУИТ).

  2. В карту добавится слой зон с особыми условиями использования территории. При запросе информации по объектам слоя, доступна семантическая информация.

    [Подсказка] Подсказка

    Подробная легенда, с условными обозначениями http://pkk5.rosreestr.ru/arcgis/rest/services/Cadastre/ZONES/MapServer/legend

    Слой зон (ЗОУИТ)

    Рисунок 374. Слой зон (ЗОУИТ)


Просмотр информации по кадастру

  1. Открыть окно информации для слоя Росреестра.

  2. Войти в режим информации, для этого нажать на панели инструментов кнопку [image] . Сделать активным слой, по которому надо получить информацию или нажать и удерживать клавиши Ctrl+Shift.

  3. Сделать щелчок левой кнопкой мыши на объекте активного слоя, после чего откроется окно информации.


Поиск по кадастровому номеру Росреестра

Система позволяет осуществлять поиск по кадастровому номеру Росреестра, например 78:13:0007306:8

Для выполнения поиска:

  1. Открыть окно информации для слою Росреестра,

  2. Войти в режим информации, для этого нажать на панели инструментов кнопку [image] . Сделать активным слой, по которому надо получить информацию или нажать и удерживать клавиши Ctrl+Shift.

  3. Введите в строке поиска кадастровый номер, например 78.

    Поиск по кадастровому номеру Росреестра

    Рисунок 375. Поиск по кадастровому номеру Росреестра